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Introduction
The award-winning Invitrogen™   Attune™   CytPix™   Flow 

Cytometer combines acoustic focusing with a high-speed 

brightfield camera for simultaneous high-throughput flow 

cytometry and high-resolution brightfield imaging. Images of 

individual events and derived morphometric data can benefit an 

extensive, almost limitless range of flow cytometry applications. 

Invitrogen™   Attune™   Cytometric Software has automated 

image analysis capability to derive morphometric parameters 

(extended image-based parameters) using models pretrained 

on leukocytes and beads. These parameters may provide 

researchers a wealth of additional information for their assays 

beyond non–image-based cytometric methods. 

This instruction guide is an introduction to the use of an additional 

software package, FCS Express™ software (De Novo Software, 

Pasadena, CA). The guide is intended to help users export data 

files from Attune Cytometric Software. Users can then open and 

adjust settings in FCS Express software to properly display and 

facilitate the analysis workflow when using Attune CytPix Flow 

Cytometer data files in either standard FCS file format or the 

ACS data file format that supports images and raw data. These 

instructions are being provided in part because we understand 

that users may want to take advantage of the workflow or 

analysis features provided by FCS Express software. We also 

highlight further analysis capabilities and features of FCS Express 

software to benefit Attune CytPix Flow Cytometer users. The 

pipeline feature allows users to access algorithms for high-

dimensional data sets and provides innovative visualizations to 

help with data interpretation. This guide is not meant, however, 

to be a comprehensive resource for all features and functions 

available in FCS Express software. We suggest that you refer 

to the FCS Express software user guide or visit the De Novo 

Software website for help with the features not addressed here. 

These instructions will cover the needed steps for version 7 of 

FCS Express software; other versions may require modifications 

to these instructions, as menus and placement of settings may 

have changed.

User instructions
FCS Express software version 7.16.0047 or higher is required to 

open Attune CytPix Flow Cytometer ACS data files. 

Note: Online tutorials and other helpful information can be 

accessed on the De Novo Software website, 

denovosoftware.com/full-access/, with a free De Novo 

Software account.

Exporting Attune CytPix Flow Cytometer data files 
from Attune Cytometric Software
Data files may be exported as standard FCS files (no images) or 

in the ACS file format (“FCS and Image Data” with images). Both 

are supported by FCS Express software. 

To export your data from Attune Cytometric Software to allow 

working with raw data and images in the ACS format:

1.	Right-click on either the experiment (to export ACS files for all 
samples) or a single sample.

2.	Choose the option Export FCS and Image Data. 

Note: There are circles 

with a check mark next to 

the samples in the image. 

This icon indicates that 

the images have been 

processed in the software, 

which has generated 

image-based “extended 

parameters”. Users may 

choose to export data with 

or without the extended 

parameters in the next steps. 

3.	Check the Extend FCS File check box next to Save Options, 
and select Save at the bottom of the dialog.  

4.	Name the file, and then choose Save.



Opening Attune CytPix Flow Cytometer data files in 
FCS Express software
Attune CytPix Flow Cytometer ACS files are loaded into FCS 

Express software like any standard FCS files. Data files may be 

dragged and dropped onto the layout, dragged and dropped into 

the data list, or loaded via standard operating system dialogs. In 

the example below, we will add data files using the data list. 

1.	Select the desired Attune CytPix Flow Cytometer data files.

2.	Drag the data files from the folder into the data list.

Note: Data files can also be added by clicking on the blue “+” 

icon in the Data List, navigating to the desired folder, choosing 

the file type from the drop-down menu, and selecting the desired 

files before clicking on Open file.

3.	From the Data List, drag a data file onto the white space on 
the page.

4.	Select one or more plot types. 

5.	Select OK. 

Tip: You can select one or more plot types to generate in the 

workspace. You can also add plots by using the buttons for 1D 

and 2D Plots on the Insert tab.

If, in the previous step, you selected plots to be generated, you 

will see a workspace that looks similar to the one shown below. 

Please see the section on Working with images via data grids 

in FCS Express software for Attune CytPix Flow Cytometer 

data files for information on utilizing data grids and accessing 

the image component of the ACS files.

Working with 2D plots and parameters in FCS 
Express software
In most cases, no additional adjustments to plots or scaling are 

needed to visualize Attune CytPix Flow Cytometer data in FCS 

Express software. To adjust and change the parameters on 

a plot: 

1.	Choose each axis title and select the parameter you would like 
to display. In this example, FSC-A is displayed on the x-axis 
and SSC-A on the y-axis.

2.	Add any additional plot to the layout via the Insert tab using 
your preferred plot type ( e.g., density, color dot).
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Note: If you would like to change the axis scaling, there are 

several options to choose from. To change the axis scaling, follow 

the optional steps below:

3.	Select the plot, right-click, and select Format to bring up the 
formatting window.

4.	Choose the drop-down menu at the top of the formatting 
window and select Axes.

5.	Adjust scalings as desired.

Adjusting the scaling may be useful when working with the 

Extended Parameters. Additionally, there are user options 

specific to the Attune CytPix Flow Cytometer accessible via 

the File tab  Options  Data Loading  Thermo Cytpix ACS 

Options. These options will allow you to set preferences for how 

you would like to visualize and scale data sets.

Tip: Setting the Scatter and Fluorescence Parameters Range 

Options to use Based on data with both Minimum and 

Maximum checked, and linear scaling, may be useful for display 

of extended parameters on plots. The scale formula for manually 

scaled plot parameters will be retained and applied automatically 

to all plots in the layout when selected.

In addition to adjusting scaling, a user can modify the range 

of data displayed on a plot by using Resolution Options from 

the Format  Specific Options section. This will optimize the 

display of data within a desired range.

Tip: To determine the best range to set for Resolution Minimum 

and Resolution Maximum, the user may observe the range 

collected by the Attune CytPix Flow Cytometer by selecting a 

plot, clicking on the Data tab, and selecting View Header under 

Parameter Information. # Channels will indicate the maximum 

of the range.
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Working with images via data grids in FCS Express 
software for Attune CytPix Flow Cytometer data files 
Data grids allow users to visualize the images obtained during 

acquisition. Data grids can have gates applied and create new 

gates. Multiple data grids can be used to visualize differences in 

images between gated populations or data files. 

1.	Select Insert tab  Data Grid.

2.	Click on an area in the layout to insert the Data Grid. The data 
grid will show all parameters by default, with the Brightfield 
image parameter shown in the last column. In this example, the 
image has been modified to display desired parameters.

To format the data grid to show specific parameters or 

only images:

3.	Select Data Grid  right-click  Format.

4.	Select Parameters to Display from the drop-down menu. 
Using Only the items checked below, select the parameters 
to display in your data grid. Images are contained in the 
Brightfield parameter, usually last in the list. 

Gating data grids and visualizing images
Gates may be applied to a data grid by dragging a gate onto 

the Data Grid or by selecting the Data Grid and modifying the 

Current Gate using the drop-down menu on the Gating tab. 

Data sets from the Attune CytPix Flow Cytometer may not include 

images of every event acquired. In those cases, users may create 

a gate on the “IsProcessed” parameter in order to visualize only 

events with associated images. An “IsProcessed” parameter 

value of “1” indicates an event for which an image exists. Once 

gates are created they may be dragged and dropped onto a 

Data Grid as shown below, to visualize the events and  images 

associated with the event. Additionally, users may use the 

Format  Gates To Display feature to show a colored icon 

associated with the gate within which an event falls. 

Note: The Data Grid at bottom right of the graph was selected 

(see blue arrow), Processed gate was chosen to display from the 

Gates To Display dialog, and the Processed gate was applied to 

limit visualization to only events with images.

Images may also be inserted into the layout by dragging and 

dropping from the Data Grid onto a blank space in the layout. 

This is an effective tool to display representative images of a 

given population in your reports.

Working with statistics
Statistics can easily be accessed from any plot via a right click on 

the plot and selecting Statistics  Gate Statistics.
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Additionally, statistics can be introduced into text boxes, tables, 

and spreadsheets by dragging a plot onto the object or by 

right-clicking in an object and using the Insert a Token dialog 

as shown. A token is live updating text that displays information 

such as statistics, FCS file keywords, layout properties, system 

information, and more. 

Working with high-dimensional analysis tools in 
FCS Express software
FCS Express software offers high-dimensional analysis tools via 

Pipelines. Pipelines enable researchers to use the flexible and 

intuitive interface of FCS Express software to perform advanced 

data analysis and processing steps, without the need for external 

applications such as R or Python. Within FCS Express software 

you have access to many of the most common flow cytometry 

algorithms and processing steps that are also applicable to your 

Attune CytPix Flow Cytometer data sets. Pipelines increase the 

computational flexibility and granularity of running algorithms 

and data transformations while giving users the unique ability 

to customize the data processing workflow. The steps below 

will assist you in accessing and implementing pipelines, but 

we suggest viewing the extensive resources on the De Novo 

Software website to understand the tools offered and how they 

should be implemented practically.

Please see:

1.	Pipelines overview

2.	Learn more about available Pipeline Steps and 
their operation

To access high-dimensional analysis tools using a pipeline:

1.	Select the Tools tab  Transformations. 
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Gates created on the pipeline-transformed plot may be dragged 

onto a Data Grid to visualize events and images associated with 

the population or cluster of interest. Additionally, representative 

images may be dragged onto the layout for further reporting. 

Note: When high-dimensional analysis is performed, it is often 

necessary to merge multiple files into one file before running a 

pipeline, and files are then deconvolved via gates to compare file-

to-file variability and clustering. To learn more about the process 

of merging ACS files for use in high-dimensional data reduction 

pipeline steps, please see How can image ACS files from the 

Attune CytPix be merged for high dimensional analysis?

2.	Select the blue “+” icon at the far left and select Pipeline. 

3.	Select the pipeline created.

4.	Select the blue “+” icon at the right to select a pipeline step to 
insert. Add additional steps as desired.

Users may select as many pipeline steps as needed to 

achieve the desired results. Actions within the pipeline can be 

checked or unchecked.

To run a pipeline on a data set, choose the method below that 

best suits your needs. Once a pipeline is applied, the series 

of steps will begin running. If running a step results in new 

parameters being created (i.e., UMAP, tSNE), the new parameters 

will be accessible on any plot the pipeline is applied to after the 

run is complete.  

•	 Select specific plots for the pipeline: choose Apply to selected 
plots or select Apply to all plots.

•	 Drag and drop the pipeline root step onto a plot.


