
ChromQuest™ 4.2 
Chromatography Data 
System

Installation Guide

CHROM-97200 Revision A April 2005



© 2006 Thermo Electron Corporation. All rights reserved.

Surveyor® is a registered trademark and ChromQuest is a trademark of Thermo Electron Corporation. 
Microsoft® and Windows® are registered trademarks of Microsoft Corporation. All other trademarks are the 
property of Thermo Electron Corporation and its subsidiaries.
This document is provided to customers who have purchased Thermo Electron Corporation equipment to use 
in the operation of such Thermo Electron Corporation equipment. This document is copyright protected and 
any reproduction of this document or any part of this document is strictly prohibited, except as Thermo 
Electron Corporation may authorize in writing.

Technical information contained in this publication is for reference purposes only and is subject to change 
without notice.  Every effort has been made to supply complete and accurate information; however, Thermo 
Electron Corporation assumes no responsibility and will not be liable for any errors, omissions, damage, or loss 
that might result from any use of this manual or the information contained therein (even if this information is 
properly followed and problems still arise).

This publication is not part of the Agreement of Sale between Thermo Electron Corporation and the purchaser 
of an LC/MS system.  In the event of any conflict between the provisions of this document and those 
contained in Thermo Electron Corporation’s Terms and Conditions, the provisions of the Terms and 
Conditions shall govern.

System Configurations and Specifications supersede all previous information and are subject to change without 
notice.
Software Version: ChromQuest 4.2



Contents
Preface................................................................................................ v
About This Guide................................................................................ v
Related Documentation....................................................................... v
Safety and Special Notices.................................................................... v
Contacting Us..................................................................................... vi

Assistance ........................................................................................ vi
Changes to the Manual and Online Help ........................................ vi

Chapter 1 Software Installation ....................................................................................1
Definitions........................................................................................... 2
Installation Configurations .................................................................. 4

Workstation Control with Local Data System Users......................... 4
Workstation Control with Domain Controller Users........................ 4
Client/Server Control with Local Data System Users........................ 4
Client Server Control with Domain Controller Users....................... 5

Stand-Alone Installations ..................................................................... 6
Step 1: Set up the Enterprise Path .................................................... 6
Step 2: Set up the Workstations........................................................ 6
Step 3: Install the Software Licenses.................................................. 7
Step 4: Activate Advanced File Security ............................................ 7
Step 5: Configure the Enterprise....................................................... 8

Client/Server Installations .................................................................. 10
Step 1: Set Up the Enterprise Path.................................................. 10
Step 2: Set up the Enterprise Machine ............................................ 11
Step 3: Set Up the Data Acquisition PCs........................................ 12
Step 4: Set Up the Client PCs ........................................................ 13
Step 5: Install the Software Licenses................................................ 13
Step 6: Activate Advanced File Security .......................................... 14
Step 7: Configure the Enterprise..................................................... 15

Hardware Requirements .................................................................... 17
Installing ChromQuest ...................................................................... 19

Installation Requirements for Windows 2000/XP........................... 19
The Installation Screens.................................................................. 19

Installation Qualification ................................................................... 26
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide iii



Contents
Software License Installation ..............................................................27
License Installation Wizard .............................................................28
Upgrading Existing License.............................................................33
Uninstall License Wizard ................................................................36
Installation of Evaluation License....................................................38
Reinstalling a License Key...............................................................39

Network Printers................................................................................47
TCPIP Printer Installation..............................................................47
Driver Installation...........................................................................47

Chapter 2 Hardware Installation ................................................................................ 49
SS420 A/D Installation ......................................................................50

SS420 Board Installation ................................................................50
Detector Connections.....................................................................55
Trigger Signal Connections.............................................................55
Ready Signal Connections ..............................................................55
External Device Connections ..........................................................56

HP LAS Installation...........................................................................57
HP LAS A/D Supported Configurations.........................................57
Loop Controller Board Installation and Address Setting .................57
HP LAS Loop Cabling....................................................................59
Error Codes for HP LAS ................................................................60

Index .............................................................................................................. 63
iv ChromQuest Chromatography Data System Installation Guide Thermo Electron Corporation



Preface

About This Guide Welcome to ChromQuest™4.2. The ChromQuest chromatography data system is 
a member of the Thermo Electron family of LC data systems. 

For information on connecting the Surveyor Plus LC system, refer to the 
Surveyor Plus Getting Connected manual.

Related
Documentation

In addition to this guide, Thermo Electron provides the following documents for 
the ChromQuest chromatography data system:

• Administrator’s Guide

• User’s Guide

• Reference Guide

• QuickStart

Safety and Special
Notices

Make sure you follow the precautionary statements presented in this guide. The 
safety and other special notices appear in boxes.

Safety and special notices include the following:

IMPORTANT  Highlights information necessary to avoid damage to software, loss 
of data, invalid test results, or information critical for optimal performance of the 
system.

Note  Highlights information of general interest.

Tip  Helpful information that can make a task easier.
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide v
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Contacting Us
Contacting Us There are several ways to contact Thermo Electron Corporation. 

Assistance For new product updates, technical support, and ordering information, contact us 
in one of the following ways:

Visit Us on the Web

www.thermo.com/finnigan

Contact Technical Support

Phone: 1-800-685-9535
Fax: 1-561-688-8736
E-mail: techsupport.finnigan@thermo.com

Find software updates and utilities to download at http://mssupport.thermo.com

Contact Customer Service

In the US and Canada for ordering information:
Phone: 1-800-532-4752
Fax: 1-561-688-8731
Web site: www.thermo.com/finnigan

Changes to the Manual
and Online Help

To suggest changes to this guide or to the online Help, use either of the following 
methods:

• Fill out a reader survey online at www.thermo.com/lcms-techpubs 

• Send an e-mail message to the Technical Publications Editor at 
techpubs.finnigan-lcms@thermo.com 
vi ChromQuest Chromatography Data System Installation Guide Thermo Electron Corporation

www.thermo.com/finnigan
mailto:techsupport.finnigan@thermo.com
http://mssupport.thermo.com
www.thermo.com/finnigan
www.thermo.com/finnigan
www.thermo.com/lcms-techpubs
mailto:techpubs.finnigan-lcms@thermo.com


Chapter 1 Software Installation

This chapter shows you how to install the ChromQuest data system and contains 
the following sections:

• Definitions

• Installation Configurations

• Stand-Alone Installations

• Client/Server Installations

• Hardware Requirements

• Installing ChromQuest

• Installation Qualification

• Software License Installation

• Network Printers
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide 1



1 Software Installation
Definitions
Definitions The following terms are used to describe the standalone and client/server 
ChromQuest installation configurations:

• Enterprise Path

The Enterprise Path is a shared folder that is used to store all of the files 
(methods, data, sequences, configurations, settings, and so on) used by the 
software. The Enterprise path must always be accessible to all PCs running the 
data system.

In the client/server environment, the Enterprise Path must be a shared folder 
on a Microsoft Windows Network. Typically, it is located on a Windows File 
Server.

For standalone installations, the Enterprise Path can be a shared network 
folder or a folder on the local PC.

• Enterprise File Server

The Enterprise File Server is a PC on the network that is used to store all of the 
files (methods, data, sequences, configurations, settings, and so on) used by 
the software. These files are stored in a shared folder (see Enterprise Path) on 
this PC.

• Enterprise Machine

The Enterprise Machine is a PC on the network that is used to perform overall 
data system management tasks such as log ins to the data system and file access. 
The Enterprise Machine must always be accessible to all PCs running the 
ChromQuest data system.

In a client/server environment, the Enterprise Machine is the Enterprise File 
Server. For standalone installations, the Enterprise Machine is the PC on 
which the software is installed.

• ChromQuest Workstation

A ChromQuest Workstation can be a standalone or networked PC that has 
control and access only to the instrument attached to it.

• ChromQuest Chromatography Interface

A ChromQuest Chromatography Interface is a PC that is attached to directly 
to an instrument. It can be controlled locally or by a networked Client PC.
2 ChromQuest Chromatography Data System Installation Guide Thermo Electron Corporation



 1 Software Installation
Definitions
• Domain Controller 

A Domain Controller is a PC that is used to provide control and data 
acquisition to one or more LC or GC systems. In general, users do not interact 
directly with the software on Domain Controllers. Rather, Client PCs are used 
to connect to Domain Controllers and provide user control.

• Client PCs 

Client PCs provide the user interface and interactive environment for users of 
the data system. Client PCs are used to set up runs, monitor instrument 
activity, review data and perform other interactive tasks.

• Enterprise Service Account

This special domain user account is used internally by the data system to access 
the Enterprise. This account should not be the account of a normal domain 
user. Because of the nature of its usage, if possible, this account should be given 
a secure password with no expiration date.

• Enterprise Service Group

When Advanced File Security is activated, members of this group have 
complete access to the Enterprise Path. This group should contain the 
Enterprise Service Account, as well as any other accounts that will be permitted 
full access to the files in the Enterprise Path. This may include accounts such as 
domain administrators, accounts used by network back systems, and so on. It 
should not contain the accounts of normal data system users.

• Advanced File Security

Advanced File Security (AFS) is a feature wherein the data system software 
modifies the Windows 2000/XP permissions on the Enterprise so that only 
members of a special domain users group can access the files. While Advanced 
File Security greatly increases the level of security for your data, it also imposes 
restrictions on access to the files within as well as outside of the data system. 
Once AFS has been implemented for an Enterprise, it cannot be turned off.

Note  Although it is easier to install Advanced File Security when you install the 
ChromQuest software, you can secure the Enterprise at any time by running 
the Enterprise Setup Utility.
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide 3



1 Software Installation
Installation Configurations
Installation
Configurations

There are several ways to install ChromQuest 4.2 ranging from stand-alone data 
systems to fully networked client/sever systems with maximum security afforded 
through an NT domain controller. These installation configurations are 
summarized in the following topics:

• Workstation Control with Local Data System Users

• Workstation Control with Domain Controller Users

• Client/Server Control with Local Data System Users

• Client Server Control with Domain Controller Users

Workstation Control with
Local Data System Users

This configuration contains one or more stand-alone ChromQuest workstations. 
The workstations may or may not be connected to a network. Each workstation 
has control and access to only the instruments attached to it, and users are 
administered by each workstation independently of the others.

Workstation Control with
Domain Controller Users

This configuration contains one or more ChromQuest workstations on a 
Windows 2000/XP Network. In this environment, each ChromQuest workstation 
has instruments attached that can only be controlled or accessed by the local 
workstation. User privileges are administered by the Windows 2000/XP Domain 
Controller. Use of the Windows 2000/XP Domain Controller affords enhanced 
security.

Client/Server Control with
Local Data System Users

This configuration consists of one or more ChromQuest Chromatography 
Interfaces with instruments attached, along with one or more ChromQuest clients 
on an NT Network where users are administered by the data system. Because users 
are administered locally, file security is not as high as when using a domain 
controller to administer users.
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 1 Software Installation
Installation Configurations
Client Server Control with
Domain Controller Users

This configuration consists of one or more ChromQuest Chromatography 
Interfaces with instruments attached, along with one or more ChromQuest clients 
on an NT Network, where users are administered by the domain controller 
(NTFS). This configuration affords the highest possible security.

Figure 1. Client Server Control with Domain Controller Users
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1 Software Installation
Stand-Alone Installations
Stand-Alone
Installations

To install a Standalone system, perform the following steps:

Step 1: Set up the Enterprise Path

Step 2: Set up the Workstations

Step 3: Install the Software Licenses

Step 4: Activate Advanced File Security

Step 5: Configure the Enterprise

Step 1: Set up the
Enterprise Path

To set up the Enterprise Path

1. Create a folder on the File Server PC that will be designated as the Enterprise 
Path.

2. Set the file permissions on this folder to “Full control” for the Data System 
Users Group.

3. Share this folder, giving “Full Control” to Everyone for the Share Permissions.

4. Confirm that the Enterprise Service Group and the Data System Users Group 
have been granted the Windows 2000/XP permission called “Access this 
Computer from the Network”.

Step 2: Set up the
Workstations

To setup each workstation

1. Confirm that the workstation is a member of your Windows 2000 / XP 
domain and has TCP/IP installed.

2. Confirm that the Enterprise Service Group and the Data System Users Group 
have been granted the following Windows 2000 / XP permissions:

• Log on Locally

• Act as part of the operating system

The Enterprise Serve Account/Group needs the “Access this computer from 
the network” privilege on the domain controller machine.

Note  Document the share name for the Enterprise Path. The Enterprise 
Path must be in UNC format (i.e.\\ComputerName\ShareName)

Note  When Advanced File Security is activated, the permissions on the 
Enterprise folder will be modified to restrict access to its contents.
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 1 Software Installation
Stand-Alone Installations
3. Log into the workstation.

4. Install the ChromQuest 4.2 software and accept the default settings for each 
installation option section. During installation, leave the field labeled 
Enterprise Machine blank, and specify the share name as the Enterprise Path. 

5. Reboot the computer after you install ChromQuest and login using the name 
and password of the Enterprise Service Account.

6. Launch ChromQuest by choosing Start > Programs > Chromatography > 
ChromQuest. This will create the necessary folder structure in the Enterprise 
path, as required by ChromQuest.

7. When the Main Menu window appears, choose File > Exit.

8. Reboot the computer.

Step 3: Install the
Software Licenses

For a set of networked ChromQuest Workstations, the license key is typically a 
pool of software licenses that must be installed in the Enterprise Path. As 
chromatography interface PCs connect to the Enterprise, the software maintains 
the count of the remaining available licenses. Refer to “Software License 
Installation” on page 27. 

Step 4: Activate Advanced
File Security

Advanced File Security (AFS) protects files from unauthorized access. When AFS is 
activated, the Windows 2000/XP permissions on the entire Enterprise Path are 
modified so that only members of a special domain users group have access to the 
files.

Activation of Advanced File Security may be performed from any PC with the data 
system software installed.

To activate the Advanced File Security feature

1. Reboot the PC and log in using the name and password of the local 
administrator.

2. Copy the program EnterpriseSetup.exe from the Software Installation CD into 
the main data system installation folder.

Note  Once you have enabled the advanced file security feature by setting an 
Enterprise Service Account, the change will be permanent. All dialog boxes for 
file opening, saving, and so on will reflect this change and will limit access to 
Enterprise locations only. In addition, file permissions for the Enterprise will be 
modified so that no users other than members for the Enterprise Service Group 
will have access to the contents of the Enterprise outside of the data system 
software.
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide 7
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3. Double-click on the EnterpriseSetup.exe application icon to run it.

4. When the program starts, log in using the name and password of a person who 
has the authority to make changes on the Enterprise File Server.

5. In the Enterprise Service Account dialog box, make the following entries: 

• Enter the name and password of the Enterprise Service Account.

• Enter the domain to which the Enterprise Service Account belongs. 

• Enter the name of the Enterprise Service Group.

6. After the entries have been made, click on OK.

7. Delete the EnterpriseSetup.exe file from the data system installation directory.

After running EnterpriseSetup.exe, the directory structure for the enterprise will be 
established. The NTFS rights will be set so that users other than the Enterprise 
Administrator cannot view the project directories from Windows 2000/ XP 
Explorer. These users will be able to access the projects and files from the data 
system software if they are given those rights inside the data system software. 

Step 5: Configure the
Enterprise

Configuration of the Enterprise can be performed from any PC with the 
ChromQuest 4.2 data system installed.

To configure the Enterprise

1. Launch ChromQuest by choosing Start > All Programs > Chromatography 
> ChromQuest.

2. From the Main Menu screen, choose the Tools > Options. 

3. Click on the Enterprise tab.

4. Select the Stand-alone option button in the Instrument Control Mode 
group box.

5. If you want the users to log into ChromQuest, select the Enable Instrument 
Login And Project Management check box. 

6. If you are enabling log ins, select the source of the user lists. To use 
Windows 2000/XP domain bases user lists, select the Domain Controller 
option button and specify the name(s) of your domain(s).

7. Click on OK. Then, exit ChromQuest.
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 1 Software Installation
Stand-Alone Installations
Figure 2. Options - Enterprise dialog box
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Client/Server Installations
Client/Server
Installations

To install the ChromQuest Chromatography Data System in the Client/Server 
mode

Step 1: Set Up the Enterprise Path

Step 2: Set up the Enterprise Machine

Step 3: Set Up the Data Acquisition PCs

Step 4: Set Up the Client PCs

Step 5: Install the Software Licenses

Step 6: Activate Advanced File Security

Step 7: Configure the Enterprise

Step 1: Set Up the
Enterprise Path

To set up the Enterprise Path

1. Create a folder on the Enterprise File Server machine that will be designated as 
the Enterprise Path.

2. Set the file permissions on this folder to “Full control” for the Data System 
Users Group.

3. Share this folder, giving “Full Control” to Everyone for the Share Permissions.

4. Confirm that the Enterprise Service Group and the Data System Users Group 
have been granted the Windows 2000/XP permission called “Access this 
Computer from the Network”.

Note  Document the share name for the Enterprise Path. The Enterprise 
Path must be in UNC format (for example, 
\\ComputerName\ShareName)

Note  When Advanced File Security is activated, the permissions on the 
Enterprise folder will be modified to restrict access to its contents.
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Client/Server Installations
Step 2: Set up the
Enterprise Machine

To set up the Enterprise Machine

1. Confirm that the Enterprise Service Group and the Data System Users Group 
have been granted the following Windows 2000/XP permissions:

• Log on Locally

• Act as part of the operating system

The Enterprise Serve Account/Group needs the “Access this computer from 
the network” privilege on the domain controller machine.

2. Log into the Enterprise Machine using the name and password of a user with 
local administrator permissions.

3. Install the ChromQuest 4.2 software and accept the default settings for each 
installation option section. 

During installation, leave the field labeled Enterprise Machine blank, and 
specify the share name as the Enterprise Path. 

4. Reboot the computer after you install ChromQuest and login using the name 
and password of a user with local administrator permissions.

5. Launch ChromQuest by choosing Start > All Programs > Chromatography 
> ChromQuest. 

This will create the necessary folder structure in the Enterprise path, as 
required by ChromQuest.

6. When the Main Menu screen appears, choose File > Exit.

7. Reboot the computer.

8. Run the program DCOMServerSettings.exe, which is found in the main data 
system installation folder. 

9. In the DCOM Server Settings dialog box, do the following:

a. From the Run As list box, select Auto Logon.

b. In the User Name text box and the Password text box, enter the name and 
password of an account that has local Administrative privileges

c. Click on Set.

d. Close the DCOM Server Settings dialog box.
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide 11
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Client/Server Installations
Figure 3. DCOM Server Settings v1.0 dialog box

10. Reboot the computer.

Step 3: Set Up the Data
Acquisition PCs

In the ChromQuest client/server environment, the data acquisition PC is the 
ChromQuest Interface PC.

To set up the ChromQuest Interface PCs

1. For each ChromQuest Interface PC confirm the following:

• Confirm that each ChromQuest Interface PC is a member of the 
Windows 2000/XP domain and has TCP/IP installed.

• Confirm that the Enterprise Service Group has been granted the 
Windows 2000/XP permissions called Logon Locally and Act as Part of 
the Operating System.

2. Log onto the Interface PC using the name and password of a user with local 
administrator rights.

3. Install the ChromQuest software. During installation, enter the name of the 
Enterprise Machine and the share name of the Enterprise Path.

4. Reboot the computer and login using the name and password of a user with 
local administrator rights.
12 ChromQuest Chromatography Data System Installation Guide Thermo Electron Corporation
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5. Run the program DCOMServerSettings.exe, which is found in the main data 
system installation folder. 

6. In the DCOM Server Settings dialog box, do the following:

a. Make a selection from the Run As list box:

• If the Interface PC will be dedicated to data acquisition, select 
Auto Logon from the Run As list box.

• If the Interface PC will function as both a data acquisition station and 
a Client PC, select Interactive User from the Run As list box.

b. In the User Name text box and the Password text box, enter the name and 
password of an account that has local Administrative privileges

c. Click on Set.

d. Close the DCOM Server Settings dialog box.

7. Reboot the computer.

Step 4: Set Up the Client
PCs

To set up the Client PCs

1. For each Client PC in the Enterprise confirm the following:

• Confirm that the Enterprise Service Group has been granted the 
Windows 2000/XP permission called Logon Locally 

• Confirm that the Data System Users Group has been granted the 
Windows 2000/XP permission called Act as {art of the Operating System.

2. Log onto the Client PC using the name and password of a user with local 
administrator rights.

3. Install the ChromQuest software.

4. Reboot the computer and login using the name and password of a user with 
local administrator rights.

Step 5: Install the
Software Licenses

To install software licenses

To control instruments and perform data acquisition, you must install a software 
license key in the Enterprise Path.

In Client/Server installations, the license key is a pool of software licenses that must 
be installed in the Enterprise Path. As clients connect to the Enterprise, the count 
of the remaining available licenses is maintained by the ChromQuest 
chromatography data system.
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide 13
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Step 6: Activate Advanced
File Security

Advanced File Security (AFS) protects files from unauthorized access. When AFS is 
activated, the Windows 2000/XP permissions on the entire Enterprise Path are 
modified so that only members of a special domain users group have access to the 
files.

Activation of Advanced File Security can be performed from the Enterprise 
Machine or any other PC in the client/server network with the data system 
software installed.

To activate the Advanced File Security feature 

1. Reboot the PC and log in using the name and password of the local 
administrator.

2. Copy the program EnterpriseSetup.exe from the Software Installation CD into 
the main data system installation folder.

3. Double-click on the EnterpriseSetup.exe application icon to run it.

4. When the program starts, log in using the name and password of an account 
that has the authority to change the folder/file rights on the Enterprise File 
Server.

5. In the Enterprise Service Account dialog box, make the following entries: 

• Enter the name and password of the Enterprise Service Account.

• Enter the domain to which the Enterprise Service Account belongs. 

• Enter the name of the Enterprise Service Group.

6. After the entries have been made, click on OK.

7. Delete the EnterpriseSetup.exe file from the data system installation directory.

After running EnterpriseSetup.exe, the directory structure for the enterprise will be 
established. The NTFS rights will be set so that users other than the Enterprise 
Administrator cannot view the project directories from Windows 2000/XP 
Explorer. These users will be able to access the projects and files from the data 
system software if they are given those rights inside the data system software. 

Note  Once you have enabled the advanced file security feature by setting an 
Enterprise Service Account, the change will be permanent. All dialog boxes for 
file opening, saving, and so on will reflect this change and will limit access to 
Enterprise locations only. In addition, file permissions for the Enterprise will be 
modified so that no users other than members for the Enterprise Service Group 
will have access to the contents of the Enterprise outside of the data system 
software.
14 ChromQuest Chromatography Data System Installation Guide Thermo Electron Corporation
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Step 7: Configure the
Enterprise

Configuration of the Enterprise can be performed from any PC with the 
ChromQuest 4.2 data system installed.

To configure the Enterprise 

1. Launch ChromQuest by choosing Start > All Programs > Chromatography 
> ChromQuest.

2. From the Main Menu screen, choose the Tools > Options. 

3. Click on the Enterprise tab.

4. Select the Client/Server option button in the Instrument Control Mode 
group box.

5. If you want the users to log into ChromQuest, select the Enable Instrument 
Login And Project Management check box.

6. If you are enabling log ins, select the source of the user lists. To use 
Windows 2000/XP domain bases user lists, select the Domain Controller 
option button and specify the name(s) of your domain(s).

7. Click on OK. Then, exit ChromQuest.
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide 15
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Figure 4. Options - Enterprises dialog box
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Hardware
Requirements

The recommended minimum hardware requirements for running ChromQuest are 
as follows. 

Enterprise Path PC The Enterprise Path PC should be a PC running one of the following:

• Windows 2000 Server with Service Pack 4

• Windows XP Professional with Service Pack 2

Network: Network with TCP/IP 

Standalone Systems CPU: Pentium II 500 MHz minimum
Memory: 256 MB to control 1 instrument 

Add 32 MB per additional instrument
Add an additional 64MB per PDA

Disk: At least 80 MB free disk space
Network: Network with TCP/IP

The chromatography interface PCs should be running one of the following:

• Windows 2000 Professional with Service Pack 4

• Windows XP Professional with Service Pack 2

Client/Server Systems CPU: Pentium II 500 MHz minimum
Memory: 256 MB to control 1 instrument 

Add 32 MB per additional instrument 
Add an additional 64MB per PDA

Disk: At least 80 MB free disk space
Network: Network with TCP/IP

The chromatography interface PCs should be running one of the following:

• Windows 2000 Professional with Service Pack 4

• Windows XP Professional with Service Pack 2

Note  A faster processor and additional RAM memory are required when using 
other programs in addition to ChromQuest. 

Note  In most cases, the server versions are preferred because of the limitations 
of the number of simultaneous network connections in the workstation 
versions.
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide 17
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Advanced File Security In addition to the hardware and operating system requirements specified above, the 
use of Advanced File Security requires that all computers and users in the 
Enterprise must be members of a Microsoft Windows 2000/XP Domain.

Note  

1. Make sure the Enterprise Path PC is rebooted either before or immediately 
after EnterpriseSetup.exe is run to enable the Advanced File Security. 
Otherwise, the postings to the Instrument Activity log will be interrupted.

2. Service packs are available on the ChromQuest CD-ROM.
18 ChromQuest Chromatography Data System Installation Guide Thermo Electron Corporation
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Installing ChromQuest This section describes how to install the ChromQuest chromatography data system 
and contains the following topics:

• Installation Requirements for Windows 2000/XP

• The Installation Screens

Installation Requirements
for Windows 2000/XP

Before installing ChromQuest software on a Windows 2000/XP workstation, the 
following requirements must be met:

1. Verify that Windows 2000 Service Pack 4 or greater is installed. This is 
displayed when Windows is starting.

2. Log in to the Windows 2000/XP system as a local administrator for the 
machine. The user(s) that will be running ChromQuest do not have to be 
administrators, but installation requires administrator rights.

3. Configure the TCP/IP protocol. Use DHCP or assign a static IP address.

4. If running in a Windows 2000 domain, make sure that the user(s) log into the 
domain and not just the local computer.

The Installation Screens The following screens appear after you insert the ChromQuest CD into your 
CD-ROM drive:

• Welcome 

• Choose Destination Location

• Enterprise Settings

• Select Program Folder

• Information

• Reboot to Complete Setup
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide 19
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Welcome The first installation screen advises you to close down any current Windows 
applications before you start the installation, and informs you of the copyright laws 
governing the ChromQuest application.

Figure 5. Welcome window

Click on Next to continue the installation.
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Choose Destination Location This screen allows you to select the folder where you want the ChromQuest 
program files to be installed. You may accept the default location, enter a new one 
by typing it in, or you may select a folder from those already on your disk by 
clicking on the Browse button. 

Figure 6. Choose Destination Location window

When you have the correct folder designated, click Next to continue.
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Enterprise Settings This screen is used to designate enterprise information.

Figure 7. Enterprise Settings dialog box

• Enterprise Machine

This field is not used for workstation or networked workstation environments.

• Enterprise Path

The enterprise path is where configuration files for instruments, project 
management, and network security are stored. You can set the enterprise path 
to your own computer, or to another location on the network.

Note  Enterprise paths must be designated using the Universal Naming 
Convention ( \\ntserver).
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Select Program Folder From this screen, you designate where you want the ChromQuest program icon to 
be located.

Figure 8. Select Program Folder dialog box
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Information This screen summarizes the installation information you have designated. 

Figure 9. Information dialog box

Review the settings, and if you want to change them before installation proceeds, 
click on Back. If you are satisfied with the information, click on Next to finish 
installing the software. When the software is installed, a “default” project will be 
created automatically on the enterprise machine. All users on the system have 
access to the default project. After installation, the system administrator may want 
to delete this project.
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Reboot to Complete Setup When the software installation is complete, you should re-start your computer 
before running it.

Figure 10. Reboot to Complete Setup dialog box

If you select the Yes, I want to restart my computer now option button, the setup 
program will automatically reboot your computer when you click on Finish. If you 
select the No, I will restart my computer later option button, the computer will 
not be rebooted. However, you MUST reboot before running the ChromQuest 
software.
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Installation
Qualification

To verify that all ChromQuest files were successfully installed, run the Installation 
Qualification program. From the Windows taskbar, choose Start > All Programs 
> Chromatography > Installation Qualification (IQ).

The IQ program will generate an Installation Qualification Report that should 
have the result "PASSED". If it does not pass, you need to check that all the 
computer requirements and preparations were done properly and then re-install 
ChromQuest. Do not proceed with using the system if the installation 
qualification does not pass.

Figure 11. Report.TXT - Wordpad window
26 ChromQuest Chromatography Data System Installation Guide Thermo Electron Corporation



 1 Software Installation
Software License Installation
Software License
Installation

To run ChromQuest, you must install a "software key" or “license key” that 
enables operation of the software on your computer. The key is your software 
license. It contains your data system serial number and determines the number of 
instruments and other options that may be used with your system. 

A license key disk containing a file with all the purchased options (for example, 
number of instruments, LC, GC, spectral, and other options) was provided with 
your shipment. This disk should be saved for uninstalling and reinstalling the 
software.

To install the license, or upgrade an existing license, you must run the key 
installation wizard from the Key.exe program. This program will be located in the 
ChromQuest program folder following software installation. The wizard will 
request user information and serial number and then will provide a Request Code. 
You must contact Thermo Electron with this number to obtain a valid Enable 
Code for your system. Once this code is entered in the Key Installation Wizard, the 
key installation will be completed and your software will become fully functional.

If you require more instruments or other options than your license allows, contact 
your sales representative for upgrade information. 

This section contains the following topics:

• License Installation Wizard

• Upgrading Existing License

• Uninstall License Wizard

• Installation of Evaluation License

• Reinstalling a License Key

• Key Program
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License Installation
Wizard

The License Installation Wizard is started when you execute the Tools > Install 
License Options from the Key.exe program. This command is used to install the 
initial license key as well as to update an existing key with additional options you 
have purchased.

To access the Key window from the desktop, choose Start > Programs > 
Chromatography > Key.

Figure 12. Key window
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Initial License Activation The first screen in a new license installation is shown below. This screen is for 
information, and gives you an overview of what you need to continue the 
installation of the software license.

Figure 13. Initial License Activation window
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Select Template File This step in the Wizard prompts you to locate and select your. LKT file that 
describes the software and options you have purchased for this system. When you 
select the .LKT file, the license options to be installed will be displayed in the 
window at the bottom of the dialog. If these options do not match the options you 
purchased, contact Thermo Electron immediately.

Figure 14. Select Template File window
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Request Code In order to continue installation of the software licenses, you must supply a name 
to be used for system registration (Customer Name), and the serial number of your 
software. The serial number is located on the Create Key diskette.

Figure 15. Request Code window
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Enable Code Once you have supplied your Customer Name and serial number, you will be 
given a Request Code. You will need this code to request an Enable Code for the 
installation of the software license of your system.

Figure 16. Enable Code dialog box

You must contact Thermo Electron via web, phone, or email and provide your 
Request Code to receive a valid Enable Code for your system. Click on Contact 
Information to view current web sites and phone numbers.

If you have an Internet connection open on your computer, click on Online 
Activation. This will automatically send your serial number and request code to 
the web site and return the enable code. 

When you have received your Enable Code, enter it exactly as provided in the 
Enable Code field. Click on Finish to complete the license installation.

Note  Online Activation does not work for reinstallation.
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You will be asked if you want to create a License Repair Disk. A license repair disk 
is necessary to restore your license in case it is corrupted. A blank license repair 
disk has been provided for you with your software media. Be sure to enter the 
correct computer name and enterprise path so that you can identify the correct 
license repair disk for this computer in the future. 

Figure 17. Installation Complete window

Upgrading Existing
License

If you want to install new software options after you have installed your software 
license key, you must run the License wizard again. This will upgrade your license 
for the options you have purchased. 

To upgrade an existing license, do the following:

1. Choose Start > Programs > Chromatography > Key to open the Key 
dialog box. 

2. In the Key dialog box, choose Tools > Install License Options.
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Figure 18. Key window

The license wizard will recognize your existing software key and start the 
upgrade wizard. 

3. Follow the instructions to upgrade your license. 

This is similar to the initial installation of your license. You will need to obtain 
an Enable Code from Scientific Software to complete the upgrade of your 
license.
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Figure 19. Upgrade License Activation window
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Uninstall License Wizard To uninstall a software license, run the Key.exe program by choosing 
Start > Programs > Chromatography > Key from the desktop. Then, choose 
Tools > Uninstall Licenses. This will start the Uninstall License Wizard.

Figure 20. Uninstall License window

When you complete this wizard, all licenses will be removed from your system, a 
new .LKT file will be created for use in reinstalling the licenses, and you will be 
provided with an “Uninstall Code” which must be used to obtain a new Enable 
Code for reinstalling the licenses.

Output File

In this screen, you should select the location where you want to have the new .LKT 
file created. In most cases, this would be a floppy, but can choose another location. 
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Figure 21. Output File dialog box

Make sure the location for creation of the new .LKT file is accessible from the 
computer where you intend to reinstall the licenses.

When you click the Finish button, the licenses will be removed from your 
computer, a new .LKT file will be created in the designated location, and you will 
receive an Uninstall Code.

Figure 22. Uninstall Code window
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide 37



1 Software Installation
Software License Installation
Save the information provided. It will be required to obtain an Enable Code for 
reinstallation of the software licenses on another computer. If you click the Copy 
Information to Clipboard button, the serial number and uninstall code will be 
copied to the clipboard. You can then paste this information into a document that 
can be saved for later reference, or printed.

Installation of Evaluation
License

Evaluation licenses are available that enable full use of the software and options for 
a limited time. These licenses are designed to aid customers in evaluation of the 
software or for demonstration of the software. 

The process of installing an evaluation license is the same as that for installing a 
regular license. The evaluation license .LKT file is provided on a floppy disk. If the 
Evaluation Enable Code is entered during license installation, the software and 
options will be operational for a designated period.

 

Figure 23. Evaluation Installation Complete window
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Reinstalling a License Key After you have uninstalled a license key, you should have a disk with the .LKT file 
created during the uninstall, and the uninstall code provided during the uninstall 
process. This uninstall code is required for you to obtain a new enable code when 
you re-install the license.

To reinstall the license key after an uninstall, use the Tools > Install 
License Options command from the Key.exe program and follow the installation 
wizard as if you were installing the license for the first time. However, the enable 
code for a reinstallation must come from the reinstallation web page.

Select Reinstall when you go to the web page at 
ChromatographyKey.com/ThermoElectron.

Figure 24. ChromatographyKey.com/ThermoElectron web page
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Figure 25. ChromatographyKey.com/ThermoElectron/reinstallation web page

Enter the Serial Number, the Uninstall Code provided when you uninstalled your 
license, and the Request Code provided by your installation wizard, then click on 
Submit.

Copy the Enable Code into the license installation wizard and step through the 
final wizard screens to complete the key re-installation.
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Figure 26. Reinstall Code Results web page

Creating a License Repair Disk Once you have installed your software license key, you should create a License 
Repair Disk. This is highly recommended. This will create a License Repair disk 
on a formatted floppy disk and contains your software license information. If you 
need to restore your software license because of an unexpected error in your system, 
this disk will recover it for you. 

The License Repair Disk is created by running the Key.exe program, located in 
your data system program directory (Start > Programs > Chromatography > 
Key). Insert the license repair disk floppy provided with your software media, and 
then choose the Tools > Create License Repair Disk command. Enter the drive 
letter for the floppy drive, and click on OK to continue.

Note  You can only use the License Repair Disk to re-install your software 
license to its original location. It cannot be used to install your license to 
another machine or location.
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Figure 27. Create License Repair Disk dialog box

Your software license information will be transferred to the License Repair Disk. 

Figure 28. Key window

Save this disk in a secure location should you need it to repair your software license. 
Be sure to fill in the correct computer name and enterprise path so you can identify 
the correct license repair disk if needed.

Repairing a Software License Key

Should you for some reason lose access to your software license key, you can restore 
it to its original location using your License Repair Disk. (See Creating a License 
Repair Disk.) To repair your software license, insert the License Repair Disk in 
your floppy drive, and then run the Key.exe program in your ChromQuest 
program directory. 
42 ChromQuest Chromatography Data System Installation Guide Thermo Electron Corporation



 1 Software Installation
Software License Installation
Figure 29. Key - Serial Number window

Choose the Tools > Repair Licenses command. The program will restore your 
license to its original location. Note that the repair licenses command will not 
overwrite an existing license key.
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Key Program The Key.exe program is used to display the status of the licenses available on a 
software license key. Once you have your software license key installed, you can 
view its options by running the Key.exe program located in the ChromQuest 
program directory (Start > Programs > Chromatography > Key).

This program allows you to view your key status, and also provides a means for 
creating a License Repair Disk, Uninstalling an existing license, or updating a 
current license.

Figure 30. Key - Serial Number window

• File

− Exit

Exit the key program.
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• View

− Auto Refresh

This automatically updates the status of the network key, and sets the 
number of seconds between refresh.

− Refresh   

Use this to update the status of the network key.

− Toolbar 

This toggles the display of toolbar icons.

− Status Bar 

This will toggle the display of the Status line.

− Key Status

This displays information about the key, including current enterprise path 
and program directory.

Figure 31. Key Status window

• Tools

− Install License Options

Use this to install license or update current license with new options.

− Uninstall Licenses

Use this to uninstall current licenses from the current machine.
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− Contact Information

Displays contact information for your software.

− Create License Repair Disk

This command creates a license repair floppy to be used to recover an 
existing license that has been damaged.

− Repair Licenses

This command uses the License Repair Disk for the current computer to 
restore the existing license to its original state.
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Network Printers In Windows 2000/XP, when the user logged into the computer is not a local 
administrator and the printer is shared with only Print permission, ChromQuest 
will require the user to select the printer every time they open an instrument. This 
is due to the logged user having insufficient rights to query for information about 
the printer.

To solve the problem, simply set the permissions for Everyone to Full Control 
rather than Print. This is done on the sharing computer as follows: log onto each 
computer as a local administrator, select the properties for the printer, on the 
Security tab click Permissions, and in the Permissions dialog change Everyone from 
Print rights to Full Control rights.

TCPIP Printer Installation Certain network printers that use TCPIP communications, and are connected 
directly to the network must be installed properly for ChromQuest to 
communicate with them. The HP5Si model printers are examples of such 
printers. The following information will aid you in installing the HP5Si printers 
for use with ChromQuest software. Other printers may require similar procedures.

Driver Installation HP5Si model printers come with driver installation software. Use this software to 
install the printer. DO NOT use the “ADD PRINTER” function from the 
Windows 2000/XP operating system.

To install the printer driver, run the Setup.exe program (Windows 2000/XP 
version) from the CD provided with the printer. Follow the installation wizard 
provided to install the driver for your chosen model. When you install the driver, 
the software will ask you to select a local port for the printer. 

Figure 32. Select Port dialog box
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This port acts as a “temporary” designation, as the printer is directly connected to 
the network and will later be designated.

Continue to follow the wizard to install your printer as directed. When the 
installation program is completed, it will prompt you to reboot, or restart 
Windows for the changes to take effect.

The printer driver must be installed on every ChromQuest Workstation where you 
want to use the printer.

It is important to set up the printer for each instrument so that the reports for that 
instrument are printed on the correct printer. Make sure to follow the guidelines 
for printer setup in stand-alone or networked mode, as appropriate for your 
laboratory. See the Configuration section for details on configuring printers for use 
with ChromQuest.
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Chapter 2 Hardware Installation

This chapter describes how to install the various A/D options supported by the 
ChromQuest data system. For the following analog to digital modules, refer to the 
instruction manual included with the respective hardware: SS420X A/D interface, 
GPIB board, Digiboard, CIO/DIO. 

For the Surveyor Plus LC system, refer to the Surveyor Plus Getting Connected 
manual.

This chapter contains the following sections:

• SS420 A/D Installation

• HP LAS Installation
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SS420 A/D Installation This section describes how to install the SS420 Analog to Digital Converter (ADC) 
Board and make analog detector connections on the terminal panel. It also 
describes how to connect trigger and external event lines. 

This section contains the following topics:

• SS420 Board Installation

• Detector Connections

• Trigger Signal Connections

• Ready Signal Connections

• External Device Connections

SS420 Board Installation The ADC board must be installed in one of the I/O slots of your computer. This 
board requires one I/O slot in your computer.

Preparation Before you install the SS420 board

1. Turn the computer OFF. Care must be taken whenever your computer cover 
is removed to avoid electric shock or damage to your computer components.

2. Remove the cover from the computer. Remove the small cover from the 
narrow computer slot where you intend to install the ADC board.

3. Carefully remove the ADC board from its protective shipping bag. To avoid 
damaging the board, use a grounding strap, or discharge any static electricity 
you may have accumulated by touching the chassis of your computer before 
handling the ADC board.

Hints for Finding the IRQ and
Base Address

You can examine the current IRQ and Address settings for your computer system 
by doing the following:

For Windows 2000/XP:

1. Click on Start.

2. Choose Run to display the Run dialog box.

3. In the Open text box, type Winmsd. Then, click on OK to open the System 
Information folder.

Note  Because configuration sometimes requires board number and connection 
information, it is a good idea to document all connections, board addresses, 
and external event connections and keep in a handy place for future reference.
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4. Click on the Hardware Resources folder. Then, click on the IRQs folder. 

SS420 Board Address and IRQ The SS420 board is factory-set to an interrupt IRQ11, and base address of 
360 (hex). If these settings conflict with a board already installed in your computer, 
you must change the interrupt and/or address on the board before installing it. 

Changing Interrupt Level (IRQ)
Jumper

If you install more than one SS420 board, then each board must have a different 
interrupt level setting.

Suggested interrupt levels are:

Board # Interrupt (IRQ)
1 10
2 11
3 5
4 12

You can also use IRQ3 by deleting COM2 if you are not using it.

To change the interrupt level, locate the IRQ jumpers on the SS420 board labeled 
P1. The SS420 board is shipped from the factory with the jumper set at IRQ11. 
Gently pull the jumper off IRQ11 and push it onto the IRQ setting you wish to 
use. Note the IRQ level used, as you will need to enter this number during the 
configuration portion of your software installation.

Note  If you later install a “Plug and Play” device in your computer, you may 
need to change the IRQ and base address to avoid conflicts with the new 
device. You can also go to your computer’s BIOS setup and reserve the IRQ as 
a “legacy” to avoid this problem.

Note  Conflicts in interrupt level typically result in a lack of data (no 
chromatogram, no time clock.) If you use a network card or tape backup drive, 
it is especially important to check for conflicts in interrupts.

Note  If you later install a “Plug and Play” device in your computer, you may 
need to change the base address to avoid conflicts with the new device. 
Thermo Electron Corporation ChromQuest Chromatography Data System Installation Guide 51



2 Hardware Installation
SS420 A/D Installation
Figure 33. SS420 Analog to Digital Board

Changing Board Address The SS420 board is shipped from the factory with a base address of 300 or 
360 (hex). The address of 360 should be used if other hardware, such as a network 
card, tape backup, CD ROM, sound card, etc., is installed. (If more than one 
SS420 board is ordered, each board will be set with a unique address.) Each board 
uses four address spaces. Therefore, if you have four SS420 boards installed, set 
their base addresses to:

• 1st Board = 360

• 2nd Board = 364

• 3rd Board = 368

• 4th Board = 36C

To change the board address, change the switches labeled SW1 on your board to 
reflect the correct address. Each switch is labeled with a number, and SW1 
contains a label showing which position is ON. To set a switch ON, slide the 
switch in the ON direction. 

The board address is set to 3XY (hex), where X and Y are variables set by using the 
switches labeled 1 through 5. Switch 6 is not used.

J1

J2

P1

SW1
1

ON
2 3 4 5 6

Note  Conflicts in base address often cause random failures. If you use a 
network card or tape backup drive, it is especially important to check for 
possible conflicts. 
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The following diagram illustrates the switch positions used for setting the board 
address. Switches 1-3 are used for setting X, and switches 4-5 are used for setting Y.

For example, the correct switch settings for a board address of 364 are: 

Installing the ADC Board To install the ADC board

1. Hold the ADC board by its edges and position it so that the 25-pin and 15-pin 
connectors face the rear of the computer.

2. Plug the ADC board into the slot of your computer by firmly pushing the edge 
of the card with the gold "fingers" into the long connector of the slot until the 
card is seated.

3. Use the screw from the slot cover plate to secure the board in place. Screw it 
into the chassis through the hole at the end of the board.

4. Replace the computer cover and follow the directions below to install the 
software and instrument connections. Do not turn on your computer until 
after you have completed the instrument connections.

5. Plug the 25-pin connector on the terminal panel cable into the 25-pin 
connector (J2) on the rear of the SS420 board. Connect the other end of the 
cable to the 25-pin connection of the terminal panel.

Switch Number

1 2 3 4 5

X = 0 ON ON ON

1 ON ON Off

2 ON Off ON

3 ON Off Off

4 Off ON ON

5 Off ON Off

6 Off Off ON

7 Off Off Off

Y = 0 ON ON

4 ON Off

8 Off ON

C Off Off

Switch Number

1 2 3 4 5

Off Off ON ON Off
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6. Plug the 15-pin connector on the terminal panel cable into the 15-pin 
connector (J1) on the rear of the SS420 board. Connect the other end of the 
cable to the 15-pin connector of the terminal panel.

Installing the Terminal Panel The TP420 terminal panel supplied with your system is used to make instrument 
connections (analog input, triggers, and external events) to the ADC board. The 
terminal panel is located inside the black cover of the box. To access the terminal 
panel, remove the four screws holding the cover.

Figure 34. TP420 Terminal Panel

The TP420 terminal panel contains the following connections:

• 4 Analog Connections labeled CHAN A - D +/-/com 

• 4 Digital Input Connections labeled IN1 - 4 +/-

• 8 Digital Output Connections labeled OUT1 - 8 +/-

• 1 Digital ground connection labeled GND

• 1 Power connection labeled +5 v (two connectors)

Locate these connections on the card before you proceed.

+5V

GND

TB1

TB2

SCIENTIFIC SOFTWARE, INC.

TP420

MADE IN U.S.A.

COPYRIGHT 1992

+ - Com + - Com + - Com + - Com

CHAN
A

CHAN
B

CHAN
C

CHAN
D

J1

J2

1

+
5
V

TB3 USER

1 2 3 4 5 6

2

+
5
V

Out1

3

G
N
D

4

+

5

-
Out2

6

+

7

-
Out3

8

+

9

-
Out4

10

+

11

-
Out5

12

+

13

-
Out6

14

+

15

-
Out7

16

+

17

-
Out8

18

+

19

-
In1

20

+

21

-
In2

22

+

23

-
In3

24

+

25

-
In4

26

+

27

-

Note  The box surrounding the terminal panel provides electrical shielding 
from noise sources and provides protection for the connectors. After making all 
of your connections to the terminal panel, replace the terminal panel cover.
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Detector Connections You need to connect the analog output lines from each detector from which you 
intend to acquire data. Each detector is connected to one of the four analog 
connections labeled ChanA through ChanD.

Always use a shielded twisted pair cable to connect each detector to the terminal 
panel. This minimizes electrical noise. Up to four detectors can be connected to the 
terminal panel. The detector cables are connected to one of the four analog 
connections labeled ChanA through ChanD.

The two wires in each cable are used for the signal HIGH (+) and signal LOW (-) 
connections (e.g., CHAN A + and CHAN A -). Connect the cable shield at only 
one end, preferably to a COM connector on the SS420.

After making all of your detector connections, replace the terminal panel cover.

Trigger Signal
Connections

If you want your instrument to trigger the start of data acquisition on your 
ChromQuest system, you must connect a trigger signal cable to the terminal panel. 
The trigger signal is connected to one of the four digital input connectors on the 
terminal panel of the SS420. 

Connect the high side of the trigger to one of the connectors labeled IN1-4 +, and 
the low side of the trigger lead to the associated connector labeled IN1-4 -. 

Ready Signal Connections To connect a READY cable or relay so that ChromQuest can delay an injection 
until it is ready to acquire data, you must connect a ready signal cable from the 
READY input of your instrument to one of the digital output channels of the 
terminal panel of the SS420.

Connect one of the wires of the READY cable to the OUT1-8 + of the terminal 
panel. Connect the other wire to the associated connector labeled OUT1-8 -. 
Connect the other ends of the wires to the READY input of your instrument.

Note  After power up, allow 15 minutes for the electronics to stabilize before 
running samples that may require sensitive measurements.
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External Device
Connections

SS420 outputs are Open Collector TTL devices. If you are using an external device 
that requires a contact closure or TTL signal (e.g., gas sampling or column 
switching valves), you must connect these properly so that ChromQuest can 
control them during the run. External devices are connected using the digital out 
connectors on the terminal panel.

The SS420 inputs can detect switch closures or can be driven by TTL compatible 
logic. The output switches are open collector switches. For relay connections, it is 
not necessary to install a pull-up resistor between the output connector and +5 v. 
The relay coil takes the place of a resistor.

To connect an output switch to an external device, connect one lead from the cable 
between the device and the SS420 to one of the output low connectors OUT1-8 -. 
Connect the corresponding lead on the other end of the cable to a ground terminal 
on the device. Connect the other leads on the cable to the corresponding SS420 
output connector OUT1-8 + and the input terminal on the device.

Note  The output switches do not supply power to the circuit.
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HP LAS Installation ChromQuest supports acquisition from the HP LAS A/D Models 35900A, 
35900B, and 35900E Multichannel Interfaces. The 35900E must include the 
MIO Loop board. The HP LAS interfaces are connected via a loop cable to a 
loop controller board installed in the Workstation (cable and board supplied by 
Scientific Software). 

Currently, external events, RS232 control, and BCD are not supported.

This section contains the following topics:

• HP LAS A/D Supported Configurations

• Loop Controller Board Installation and Address Setting

• HP LAS Loop Cabling

• Error Codes for HP LAS 

HP LAS A/D Supported
Configurations

The following configuration for acquisition from HP LAS A/D is supported: 
Workstation Mode

The HP LAS A/D is supported in standalone mode. One loop is permitted per 
system. Each instrument, when opened, consumes 10 MB of RAM.

It is possible to have a loop controller board installed with an IEEE board in one 
PC. For example, the IEEE board could act as a control/acquisition device for 
HP 5890 gas chromatographs.

Loop Controller Board
Installation and Address

Setting

The Loop Controller board is an 8-bit ISA board with several local processors. It 
interfaces to several LAS A/D converters on an HP LAS loop through a 9-pin 
connector. When a workstation is equipped with a loop controller board it can take 
the place of a HP1000 loop controller in an HP LAS system. The board supports 
up to 15 HP A/D converters (channels) on a loop.
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Loop Controller Board Address
Settings

The default setting for the Loop Controller Board is 318h. The following diagram 
should be used to aid in setting other addresses. The selection of the I/O address 
depends on the hardware configuration of your computer.

Figure 35. Loop controller board address settings

One board may be installed in a workstation.
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 2 Hardware Installation
HP LAS Installation
HP 35900 Model E Interface
Switch Settings 

When a 35900 Model E is configured for dual channel operation and each channel 
will be acquiring using different sampling rates, the channel configuration 
(Function) DIP switches on the 35900 rear panel must be reversed. For example: 

Normally board switches for Channel A @ 16 Hz and Channel B @ 8 Hz would be 
set as shown in the following diagram:

Instead, reverse the Channel settings so that the settings for channel A are set on 
the Function “B” side and the settings for Channel B are set on the Function “A” 
side:

HP LAS Loop Cabling Connection of the HP LAS A/D interfaces is done using cables supplied with the 
option.

The table below describes the minimum requirements of cables to connect the loop 
controller to the loop, and for information purposes, the cables required to make a 
loop system functional.

For information on configuring the HP LAS A/D hardware, see “HP LAS 
Installation” on page 57.

Function

A B

Switch 1 2 3 4 5 6 7 8

Setting 0 1 0 1 0 1 0 0

Function

A B

Switch 1 2 3 4 5 6 7 8

Setting 0 1 0 0 0 1 0 1

Table 1. Cable Connections

Part Number Description

SSI Part Number 001814-010 Cable to connect loop control board to the 
loop. Consists of two three wire shielded 
twisted pair cables. Includes a 9-pin male 
connector at the PC side and two “French 
phone jack” male connectors on the loop side.

Preferred Cable Configuration
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2 Hardware Installation
HP LAS Installation
Error Codes for HP LAS Error 1 Communication with PCLoop failed. Please check if the driver is 
running.

Error 2 The device is off line.

Error 3 The operation was aborted.

Error 4 The operation was stopped by the user.

Error 5 The operation failed because the device is busy.

Error 6 The base address does not match.

Error 7 The device is not responding.

Error 8 The sample frequency of the PCLoop does not match the frequency 
set in the configuration.

Error 9 An unknown error occurred on the PCLoop box.

Error 10 The PCLoop is not available. Please check device power-on status 
and cables.

Error 11 The driver timed out.

Error 12 The driver's response timed out.

Error 13 A buffer overrun occurred.

Error 14 A response of zero was returned.

Error 15 The response returned was too short.

Error 16 The length of the response was wrong.

Error 17 The header of the response was wrong.

Error 18 An unknown error occurred.

Error 19 An unknown error occurred.

Error 20 The PCLoop is not available. Please check device power-on status 
and cables.

Error 21 The PCLoop is not ready.

Error 22 The PCLoop is ready.
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 2 Hardware Installation
HP LAS Installation
Error 23 The PCLoop is currently running. Please check if the box is used by 
another instrument. Please reset the PCLoop box and start again.

Error 24 The PCLoop is down.

Error 25 The PCLoop is locked.

Error 26 The PCLoop was stopped manually. Data acquisition will stop now.

Error 27 The PCLoop has stopped.

Error 28 The PCLoop has ended.

Error 29 An unknown status was found at the PCLoop box.

Error 30 The trigger timer timed out. The PCLoop was not responding.

Error 31 The data acquisition timer timed out. The PCLoop was not 
responding.

Error 32 An unknown error occurred. 
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