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Preface

About This Guide Welcome to ChromQuest™4.2. The ChromQuest chromatography data system is 
a member of the Thermo Electron family of LC data systems.  

Whether you are a new ChromQuest user or are upgrading from a previous version 
of ChromQuest, we think you will find the features of ChromQuest 4.2 both 
powerful and well organized.

This ChromQuest Chromatography Data System Administrator's Guide describes the 
administrative tasks that you need to perform after you install the ChromQuest 
data system.

For information on configuring a SpectraSYSTEM LC or a Surveyor Plus LC, 
refer to the sections at the back of the ChromQuest Chromatography Data System 
User's Guide.

Related
Documentation

In addition to this guide, Thermo Electron provides the following documents for 
the ChromQuest chromatography data system:

• Installation Guide

• User’s Guide

• Reference Guide

• QuickStart

Safety and Special
Notices

Make sure you follow the precautionary statements presented in this guide. The 
safety and other special notices appear in boxes.

Safety and special notices include the following:

IMPORTANT  Highlights information necessary to avoid damage to software, loss 
of data, invalid test results, or information critical for optimal performance of the 
system.

Note  Highlights information of general interest.

Tip  Helpful information that can make a task easier.
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide v



Preface
Contacting Us
Contacting Us There are several ways to contact Thermo Electron Corporation. 

Assistance For new product updates, technical support, and ordering information, contact us 
in one of the following ways:

Visit Us on the Web

www.thermo.com/finnigan

Contact Technical Support

Phone: 1-800-685-9535
Fax: 1-561-688-8736
E-mail: techsupport.finnigan@thermo.com

Find software updates and utilities to download at http://mssupport.thermo.com

Contact Customer Service

In the US and Canada for ordering information:
Phone: 1-800-532-4752
Fax: 1-561-688-8731
Web site: www.thermo.com/finnigan

Changes to the Manual
and Online Help

To suggest changes to this guide or to the online Help, use either of the following 
methods:

• Fill out a reader survey online at www.thermo.com/lcms-techpubs 

• Send an e-mail message to the Technical Publications Editor at 
techpubs.finnigan-lcms@thermo.com 
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Chapter 1 Managing ChromQuest

ChromQuest systems can be installed in a variety of configurations to satisfy the 
needs of the individual company: single stand-alone data system with instruments 
attached, multiple stand-alone data systems on a network without a domain 
controller (non-Windows 2000/XP network), workstations on a 
Windows 2000/XP network using a domain controller, or in the client/server 
mode with multiple networked ChromQuest Interfaces and ChromQuest Clients. 
System Administration functions are available for all configurations to maximize 
the security and efficiency of the data systems.

This chapter contains the following sections:

• Windows 2000/XP Environments 

• System Administration Functions

• Enabling the System Administration Functions
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 1



1 Managing ChromQuest
Windows 2000/XP Environments
Windows 2000/XP
Environments

When ChromQuest systems are networked using a Windows 2000/XP computer 
as a domain controller, security privileges are granted to users and groups for 
resources (ChromQuest or otherwise) that are shared on the network through the 
domain controller. The ChromQuest System Administrator then configures the 
ChromQuest enterprise, configures instruments, defines projects, and assigns users 
or groups access privileges to projects and instruments within the enterprise. 
Project definition and editing, and assignment of user and group access and 
privileges are accomplished using the ChromQuest System Administration 
Wizards.

Figure 1. ChromQuest 4.2 Windows 2000/XP environments

Windows XP System
Administrator

Define users
Define groups

ChromQuest System
Administrator

Define Enterprise
Configure instruments
Define/edit projects

Assign Access to 
  Instruments/Locations 
  per User/Group

Assign User/Group Access 
  per Instrument/Location

Assign User/Group Access 
  to Projects
Set Privilege levels

User Wizard Instrument Wizard Project Wizard
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 1 Managing ChromQuest
System Administration Functions
System
Administration

Functions

The System Administration function includes setting up or modifying the system 
enterprise (locations and laboratories), and adding and configuring instruments. It 
also involves the following administration functions, which are performed using 
Wizards.

This section contains the following topics:

• Enterprise Configuration

• Enterprise Options

• System Administration Wizards

Enterprise Configuration The Enterprise consists of all the ChromQuest Workstation, ChromQuest 
Interfaces, and ChromQuest Clients in your network. After you install the 
ChromQuest chromatography data system, you must add the PCs within your 
network to it. This function is performed from the Main Menu window and is 
described in detail in Chapter 5: Configuring Instruments.

 

Figure 2. ChromQuest 4.2 - The Enterprise menu

Enterprise Options Once you have successfully logged onto the Enterprise, you have access to setting 
the Workstation, Enterprise, General, and E-Mail options. 
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1 Managing ChromQuest
System Administration Functions
System Administration
Wizards

There are three System Administration Wizards:

• The User Wizard

• The Instrument Wizard

• The Project Wizard

Administrating the Enterprise with these Wizards is described in detail in 
Chapter 4: Using the System Administration Wizards.

The User Wizard The User Wizard allows you to do the following:

• Assign Administration functions to a user or group, including 
System Administration and Instrument Administration.

• Select instruments or locations available to a user or group.

• Add or delete users (only for non-domain workstations).

The Instrument Wizard The Instrument Wizard allows you to do the following:

• Assign users or groups to an instrument on the domain.

• Assign users or groups to a location on the domain, granting access to all 
instruments in that location.

The Project Wizard The Project Wizard allows you to do the following:

• Define new projects or editing existing projects. A project is comprised of a 
name, location, description, and defined locations for data, method, template, 
and sequence files.

• Select users and groups for a project.

• Set project privileges for each user (access to command functions such as 
method development or instrument control).

• Remove projects from active use.

System Administration capabilities can be assigned to as many users as required. 
The System Administration function is set as part of the User Wizard.
4 ChromQuest Chromatography Data System Administrator’s Guide Thermo Electron Corporation



 1 Managing ChromQuest
Enabling the System Administration Functions
Enabling the System
Administration

Functions

To access the System Administration functions from the ChromQuest 
Main Menu, you must login to the Enterprise. 

To login to the Enterprise

1. Choose Tools > Enterprise Login. Alternatively, click on the Enterprise Login 
or Logout button on the command ribbon.

Figure 3. ChromQuest 4.2 - Enterprise Login menu

The Login dialog box appears.

Figure 4. Login dialog box

2.  To login, type your assigned user name, followed by your password, and select 
the Windows 2000/XP domain you are using. 

If your system does not use a domain controller, your login screen will not 
display a “domain” choice. 
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1 Managing ChromQuest
Enabling the System Administration Functions
Once you have logged-in, the System administration functions and buttons on 
the menu bar will become active.

The first time you run the software after installation, you will be presented 
with a dialog where you must designate your System Administrator. 

Figure 5. Select System Administrator dialog box

3. To select a single administrator, do the following:

a. Select the correct domain, and then select the Users option button to view 
the users of the domain. 

b. Select a user from the list, and then click on OK to establish this user as 
the ChromQuest System Administrator.

Note  You can give system administration capabilities to additional users 
through the System Administration User Wizard.
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Chapter 2 Selecting the Enterprise 
Options

Once you have enabled System Administration mode, and have successfully logged 
onto the system, you have access to setting the Workstation, Enterprise, General, 
and E-Mail options. 

To access the Options dialog box, choose Tools > Options from the 
Main Menu bar. 

This chapter contains the following sections:

• Workstation Options

• Enterprise Options

• E-Mail Options

• General Options

• Enabling the System Activity Log
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 7



2 Selecting the Enterprise Options
Figure 6. Options - Workstation dialog box
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 2 Selecting the Enterprise Options
Workstation Options
Workstation Options The Workstation page of the Options dialog box shown on page 8 allows you to 
set options that apply to your workstation. These include the following:

• Enterprise Machine

• Status Update Interval

• Display the Following Warnings and Confirmations?

Enterprise Machine If you are using the network domain to supply user lists, you must specify a 
Windows 2000/XP machine on the network that is also running this application. 
This machine will supply network information. The enterprise machine selected 
during installation is displayed by default. You may change the machine by typing 
its enterprise name in the field, or by selecting it from a list of enterprise machines 
by clicking on the file open button. The enterprise machine must be the same for 
all clients and servers in the enterprise. 

This option is not available if you have chosen the Obtain user list from Data 
System selection in the Enterprise Options.

Status Update Interval When instruments are displayed in the Main Menu with the View > Details 
option, the status of each instrument is shown (for example, Idle, Available, In 
Use). You can select how often the instrument status display is updated using this 
text box. Select the number of seconds you wish to have between status updates.

Display the Following
Warnings and

Confirmations?

If you want to view warnings and confirmations when you close the applications, 
select this check box.
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 9



2 Selecting the Enterprise Options
Enterprise Options
Enterprise Options Select the Enterprise tab to view or change the current settings for your Enterprise. 
The Enterprise page includes the following options:

• Instrument Control Mode

• Enable Instrument Login and Project Management

Figure 7. Options - Enterprise dialog box

Instrument Control Mode Select the Stand Alone option button to do data acquisition and control for 
instruments connected directly to the ChromQuest data system workstation.

Select the Centralized Administration option button if you want Enhanced File 
Access Security. Access to the contents of the Enterprise path will be restricted so 
that unauthorized users cannot use Windows Explorer or other programs to access 
files in the Enterprise Path.
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 2 Selecting the Enterprise Options
Enterprise Options
Enable Instrument Login
and Project Management

Select this check box to turn on the security functions for login and project 
management. If this check box is not selected, you will not be required to log in 
when accessing instrument or administration functions. Normally, this check box 
is selected, except in single-user labs or where instrument or project access security 
is not an issue.

After you select this check box, the following options become available:

• Obtain User List From: Data System

• Obtain User List From: Domain Controller

• Allow passwords to be saved

Obtain User List From:
Data System

Select the Data System option button if you are running a stand-alone data system 
(not networked) or you are not using a domain controller for your network.

If you are not using a domain controller to obtain user lists, a list of currently 
defined users for your workstation will be displayed. To add a user, click on 
Add User, and complete the User Information dialog box. To delete a user, select 
the user name from the list, and click on Delete User.

The User Information dialog box allows you to define a new user name and 
password for access to your data system that is not using a domain controller.

Figure 8. User Information dialog box

• User Name

Type the name of the new user, as it will be entered (including capitals and 
punctuation).

• Password

Enter the password for this user. The password will be required whenever the 
user logs into the system.
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2 Selecting the Enterprise Options
Enterprise Options
• Confirm password

Confirm the password by typing it again. Click on Save to save the name in the 
list of enterprise users.

Obtain User List From: Domain
Controller

Select the Domain Controller option button if you are connected to a 
Windows 2000/XP network with a domain controller.

Select domains to be scanned

Select on the check box(es) next to the domain(s) you wish to scan for 
users/groups. Click on Add Domain to delete a domain from the list after 
highlighting it with the mouse. Click on Refresh to updates the list of current 
domains. 

If you are not using a domain controller to obtain user lists, a list of currently 
defined users for your workstation will be displayed. 

Lockout setup

Click on this button to open the Login Lockout dialog box and view the options 
for setting up login lockout.

The Login Lockout dialog box is where a system administrator can set up the 
parameters for locking out specific users or locking users out after a given number 
of login attempts. The parameters in this dialog box affects only ChromQuest user 
accounts, and does not affect Windows 2000/XP access.
12 ChromQuest Chromatography Data System Administrator’s Guide Thermo Electron Corporation



 2 Selecting the Enterprise Options
Enterprise Options
Figure 9. Login Lockout dialog box

• Lockout After Bad Logon Attempts

Enter a number in the field. After this number of failed attempts to logon (bad 
password, etc.) the user attempting to logon will be locked out of the system. 
When this occurs, the user cannot access the system until the system 
administrator has unlocked his/her user account. Processes already started by 
the user (such as sequence acquisition) will not be affected. Entries will be 
made in system logs when a user is locked out.

• Locked Out Users

Locked out users are listed in this area. To unlock a user, select the user or 
users, and then click on Unlock User.

• Enable email notification

When this is selected, an email message will be sent to the designated addresses 
whenever a user is locked out. In order for the email notification to work, a 
MAPI-compatible email must be installed on the server.   
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2 Selecting the Enterprise Options
Enterprise Options
− Recipients

Enter the email address(s) for email notification. You can enter multiple 
email addresses by separating them with a semicolon. 

− Message text

The default message for email notification is "User <USER> locked out of 
Data System on machine <MACHINE> due to failed login." This string is 
also used for the subject line of the email generated. The subject line 
cannot be modified.

− Profile name

A MAPI-compatible email must be installed on the server to support email 
notification. A profile will need to be set up on that machine. This profile 
needs to be set up to “not prompt for a password”. The profile name can 
then be entered into the Login Lockout dialog.

• Enable user program

Select this check box if you want to launch a user program whenever a login 
lockout occurs. When "enable user programs" is checked in the Login-Lockout 
dialog box, the path must be a network path. This dialog box is accessed by 
choosing Tools > Options > Enterprise, and then clicking on the Lockout 
Setup button in the Domain Controller mode. The application launched must 
be in a shared folder. The application will run on the enterprise machine.

− User program

Enter the name (including path) for the user program to be launched. 

− Additional parameters

Enter any additional parameters required by the program here.

Allow passwords to be saved When this check box is selected, the user’s password will be saved when the user 
logs into the system. Subsequent logins will not require the user to enter their 
password. This option is designed for systems where only one user will be using a 
client workstation. Because the passwords are saved, system security is decreased.

Enable Single User Login Mode Select this check box to allow users to login to all the instruments in the Enterprise 
simultaneously. To open a different instrument in the Enterprise, users need only 
select a project from the Select Project dialog box.   
14 ChromQuest Chromatography Data System Administrator’s Guide Thermo Electron Corporation



 2 Selecting the Enterprise Options
E-Mail Options
E-Mail Options The E-mail options page allows you to set up your e-mail protocol. To enable the 
selections on this page, select the Enable check box. When the Enable check box is 
not selected, controls are disabled and previously- configured notifications are not 
sent by instruments.

The E-Mail Page

Figure 10. Options - Email dialog box
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 15



2 Selecting the Enterprise Options
E-Mail Options
SMTP (Simple Mail Transfer
Protocol)

SMTP is an acronym for Simple Mail Transfer Protocol. An SMTP server is a 
server that sits on a network port and receives connections. An SMTP session 
involves the identification of the client (usually a machine running an email 
program), and the transmission of email headers and content. When a session ends, 
the SMTP server starts the process of sending the mail over the network.

Select the SMTP option button if SMTP is to be used for e-mail.

• Use this address in the ‘From’ field

Enter an e-mail address of a valid user.

• Mail server address

This text box is used to specify the SMTP compliant E-mail address of the 
local mail server to whom the e-mail notification should be sent. This field can 
be a valid TCP/IP address or a URL name understood by the network.

• SMTP Port

This field is used to specify the TCP/IP port number used for SMTP mail.

• Login Authentication

Select this check box to enable login authentication. Enter your user name and 
password for login authentication.

MAPI (Messaging Application
Programming Interface)

MAPI is an acronym for Messaging Application Programming Interface. It is a 
system built into Microsoft Windows that enables different e-mail applications to 
work together to distribute mail. As long as both applications are MAPI-enabled, 
they can share mail messages with each other.

Select the MAPI option button if MAPI is to be used for e-mail.

The profile text box is used to specify the MAPI Profile to be used for sending 
e-mail.

Test Clicking this button will cause the system to attempt to connect to the e-mail 
server and test the port (for SMTP) or will check if the profile exists on the server 
(for MAPI). This function will display a message box indicating the success or 
failure of the connection attempt.
16 ChromQuest Chromatography Data System Administrator’s Guide Thermo Electron Corporation
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 2 Selecting the Enterprise Options
E-Mail Options
Setting up Email
Notification in

ChromQuest

Email notifications from ChromQuest (version 4.0 or higher) are done through a 
Messaging Application Programming Interface (MAPI) on the Enterprise 
Machine. To set this up, you will first need information on how to install email 
software and connect to the appropriate network server for the organization. The 
specific settings are different for all organizations so it is generally necessary to 
consult with a network administrator.

1. Verify or install email software that supports the Messaging Application 
Programming Interface (MAPI). Windows Messaging Mail and Microsoft 
Outlook support MAPI but Microsoft Outlook Express does not. If you use 
Microsoft Outlook, it must be configured for "Corporate or Workgroup". The 
"Internet only" configuration does not support MAPI.

For Windows 2000, a separate MAPI-compatible email program must be 
installed, as one is not included with the operating system.

2. Send email directly from the email program on the Enterprise Machine and 
verify it is received as expected. If this is not working, ChromQuest will not be 
able to send email.

3. From the Windows Control Panel, double-click Mail and identify the profile 
name. This name will be entered in the administration for ChromQuest.

Figure 11. Mail window
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 17



2 Selecting the Enterprise Options
E-Mail Options
4. On the Login Lockout window (Tools > Options > Enterprise page with the 
Domain Controller option selected) in ChromQuest, enter the profile name as 
shown below:

Figure 12. Login Lockout dialog box

Note  Be sure the email software is set up so there is no password or other 
response required to send email.
18 ChromQuest Chromatography Data System Administrator’s Guide Thermo Electron Corporation



 2 Selecting the Enterprise Options
General Options
General Options Use this tab to turn on general enterprise options.

Figure 13. Options - General dialog box

Save all analysis results When this check box is selected, every time an analysis is made on a data file, the 
results will be saved in the data file. If this box is not selected, only the original and 
most recent results will be saved in the file. If this box is selected, the results will be 
tagged with the user name and date of analysis. This makes it possible to open a 
specific result from the Open Data dialog, using the Open with Results option.
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 19



2 Selecting the Enterprise Options
General Options
Logging Options These options control how audit trail and activity logs are handled.

• Automatically enable method audit trail

When this check box is selected, the method audit trail will be enabled 
whenever a method is saved.

• Automatically enable sequence audit trail

When this check box is selected, the sequence audit trail will be enabled 
whenever a sequence is saved.

• Activity log purge authorized only after archive

When this check box is selected, the instrument activity log must be archived 
before it can be purged.

• Enable system activity log

When this check box is selected, the system activity log will be enabled. Once 
this is enabled, it cannot be turned off.

Security options • Extended Security

When this check box is selected, a checksum is calculated whenever a data file 
is closed. When the file is subsequently opened, its checksum is verified first. If 
the check fails (the calculated checksum for the file does not match the one 
previously calculated for the file) the file cannot be opened, and an error is 
posted in the instrument activity log. Checksum verification is enterprise-wide.

In addition, the Extended Security function provides additional security to the 
enterprise in the following ways:

− All system administrators have full access to everything.

− All non-system administrators will have read/execute rights to project 
directories for which they have rights.

− All non-system administrators will have read/write/execute rights to 
project subfolders for which they have rights. This means that users in the 
project without system administrator rights will not be able to create 
subdirectories or files under the project directory, and they will not be able 
to rename or delete files under the project subfolders. Directories can still 
be created in project subfolders, but only through ChromQuest.

Note  Extended security does not affect Windows 2000/XP security 
settings in non-networked environments (Stand-alone).
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 2 Selecting the Enterprise Options
General Options
• Log out of System Administration Mode when idle for:

When this checkbox is selected, enter a number of minutes. If no mouse or 
keyboard activity is detected during the specified number of minutes in system 
administration mode, the system will:

− Cancel any open dialog boxes

− Cancel any Wizard in progress

− Log out of Administrative Mode

• Cancel an in-progress electronic signature when idle for:

If an electronic signature is in progress, it will be cancelled if there is no input 
for the specified number of minutes.
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 21



2 Selecting the Enterprise Options
Enabling the System Activity Log
Enabling the System
Activity Log

To enable the system activity log, go to the Main menu and choose 
Tools > Options > General tab. Then, select the Enable System Activity Log 
check box. Once the system activity log is enabled, it cannot be disabled.

Once the system activity log is enabled, the system activity log menu will be 
enabled in the Main menu. To access the menu, choose File > System Activity 
Log from the Main menu.

To archive the system activity log, choose File > System Activity Log > Archive 
from the Main menu. A dialog will appear where you can select the location for the 
archive file. A default name is assigned, with the .logarc extension. This file can be 
viewed using the Archived Log Viewer that can be run from the Chromatography 
program group in Windows. 
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Chapter 3 Setting Up E-Mail

The ChromQuest data system includes the ability to automatically send e-mail 
notifications when system events occur. E-Mail notifications can be global or 
instrument specific.

This chapter contains the following topics:

• Setting Up the E-Mail Option

• Setting Up Automatic Notifications

• Setting Up Specific Notifications

Note  If you are unfamiliar with the e-mail configuration of your network, 
consult your network administrator to complete this setup.
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3 Setting Up E-Mail
Setting Up the E-Mail Option
Setting Up the E-Mail
Option

To set up the e-mail notification feature

1. Launch ChromQuest and log on as a user with system administration 
privileges.

2. From the Main Menu, choose Tools > Options to open the Options 
dialog box.

3. Click on the E-Mail tab to open the E-Mail page.

4. In the E-Mail page, select the e-mail interface that is supported by your 
network: SMTP or MAPI. Then, enter the appropriate parameters. For more 
information, refer to the ChromQuest online Help.

5. Click on the Test button. 

This will cause the system to attempt to connect to the e-mail server and test 
the port (for SMTP) or will check if the profile exists on the server (for MAPI). 
This function will display a message box indicating the success or failure of the 
connection attempt.

Figure 14. Options - Email dialog box
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 3 Setting Up E-Mail
Setting Up Automatic Notifications
Setting Up Automatic
Notifications

Automatic Notifications are e-mail messages that are sent every time a specific 
event occurs. Automatic notifications are setup by a data system user with system 
administration privileges. They can be setup for an individual instrument, for 
location/groups, or for the entire Enterprise.

To set up automatic notifications

1. Decide if the event is global to The Enterprise or specific to an instrument in 
The Enterprise:

• If the event is global, from the Main Menu window, select File > 
Configure > E-mail to open the Send E-Mail For the Following Events 
From The Enterprise.

• If the event is specific to an instrument in The Enterprise, right-click on 
an instrument icon in the Main Menu window to open a shortcut menu. 
From the shortcut menu, choose Configure > E-Mail to open the Send 
E-Mail For the Following Events From The Enterprise\Instrument dialog 
box.

Figure 15. Send E-Mail For the Following Events From The Enterprise dialog box

2. Fill in a row of the spreadsheet for each notification you want to occur.

• Select the event from the Event list box. If this event occurs during a run, 
the custom e-mail message will be sent to the recipient(s) designated.

• Specify a recipient in the E-Mail Recipient(s) text box.

The recipients will be listed in the “To” field of the message. This must be 
an SMTP compliant e-mail address of a valid user. You can add multiple 
addresses separated by a semi-colon.

Note  Automatic notifications for an instrument are inherited from the group 
and Enterprise of which it is a member. For example, if you create an automatic 
notification for hardware error for the Enterprise, that event will automatically 
appear in the spreadsheet for every instrument in the Enterprise.
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• Click on the down arrow to enter an optional custom text message for this 
event. Enter a custom text message to be sent with an event e-mail.

Figure 16. Custom Message window

• In the Assigned text box, enter the origin of the event. Depending on the 
enterprise configuration, the origin of the event can be the Enterprise or 
the name of a location/group. If you are using ChromQuest in the 
stand-alone mode, leave this text box blank.

3. Click on OK to accept the settings and close the dialog box.
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Setting Up Specific Notifications
Setting Up Specific
Notifications

Specific Notifications are one-time events that can be setup by any user of the 
ChromQuest data system. An example of this type of event is a notification that an 
individual sequence has completed.

A user activates a specific notification within the Instrument window by filling in 
the information for that event in the dialog box initiating that action. 

In the Run Sequence dialog box shown below, the entries specify that B.A.Cook 
will be notified by e-mail when the sequence pauses due to an error or stops.

Figure 17. Run Sequence dialog box
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Chapter 4 Using the System 
Administration Wizards

To start the System Administration Wizard, do one of the following:

• Click the System Administration Wizard button on the toolbar of the 
Main Menu

• Choose Tools > System Administration Wizard.

The following dialog box appears. 

Figure 18. System Administration Wizard dialog box

Select the Restart Selected Wizard When Finished check box if you want to 
continue using the selected wizard after completing the current definition. For 
example, selecting this box allows set up of multiple new projects without 
re-starting the Project Wizard. 
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4 Using the System Administration Wizards
This chapter contains the following sections:

• User Wizard

• Instrument Wizard

• Project Wizard
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User Wizard
User Wizard The User Wizard is used to modify system access for users and groups. 

Select the Restart Selected Wizard When Finished check box if you want to add or 
edit more than one user or group. When this check box is selected, the User 
Wizard will re-start whenever you click on Finish, allowing you to add or edit 
additional users or groups.

Select the User Wizard option button. Then, click on Next to continue the User 
Wizard.

Select User The options in the Select User dialog box depend on whether you enable logins 
from a domain controller or the data system. Logins are enabled by selecting the 
Enable Instrument Logins and Project Management check box on the Tools > 
Options > Enterprise page. 

If you enabled logins from a domain controller, the following dialog box appears:

Figure 19. Select User dialog box

Select a Domain from the drop-down list of domains available. (A domain is a 
functional portion of the network that has been set up by the Windows 2000/XP 
Domain Controller.) Once you have selected a domain, a list of defined groups 

Note  Users are defined through the Microsoft Windows 2000/XP domain 
controller administration. See your network administrator or Microsoft 
Windows 2000/XP documentation for details. 
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User Wizard
within that domain appears. Select a group by highlighting the name with the 
mouse. To select a user, select the Users option button to view a list of defined users 
within the domain. 

If you enabled logins from the data system, the following dialog box appears.

Figure 20. Select User dialog box

Select a Use or a group. Then, click on Next to continue with setting ChromQuest 
administrative privileges for this user or group.

Note  If you plan to assign the same administration privileges, instrument 
privileges, and project privileges to all users in a group, it is faster to perform 
this function based on a Group selection, rather than assigning each user 
individually.
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User Wizard
Administrative Privileges The Administrative Privileges dialog box allows you to assign System 
Administration, Instrument Administration, or both privileges to users.

Figure 21. Administrative Privileges dialog box

Select the System Administration check box to allow this user to have access to 
System Administration functions. These include access to user wizard, instrument 
wizard, and project wizard.

Select the Instrument Administration check box to allow this user to have access to 
Instrument Administration functions. When this box is selected, the user will have 
access to adding, deleting, and configuring instruments.

If neither check box is selected, the user will have no access to system 
administration functions or instrument administration functions.

Click on Next to continue with Instrument Selection. 
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 33



4 Using the System Administration Wizards
User Wizard
Select Instruments The Select Instruments dialog box allows you to select the Instruments that users 
or groups can access.

Figure 22. Select Instruments dialog box

From the list displayed in the Available Instruments box, select the instruments for 
this user (or group) by double-clicking on the instrument or by clicking once to 
highlight the instrument followed by clicking the green arrow. The list of 
instruments to be accessed by this user (or group) will be displayed in the Selected 
Instruments window. If no instruments appear in the Available Instruments 
window, expand the enterprise by double-clicking locations until the desired 
instruments appear.

You can also assign all instruments within a laboratory or location to a user/group 
by selecting the entire location from the Available Instruments window. When a 
location (for example, QC Lab) appears in the Selected Instruments window, this 
means that all instruments in that location are selected.

When finished selecting instruments, click on Next to select projects. 
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User Wizard
Select Projects The Select Projects dialog box allows you to select the projects to which the current 
user/group will have access. From the Available Projects window, select a project by 
double-clicking it with the mouse, or by clicking once, to highlight, followed by 
clicking the green arrow. The list of Selected Projects will be the projects the 
current user/group will be able to access. 

Figure 23. Select Projects dialog box 

When you have completed assigning projects, click on Next.
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Set User Privileges For each selected project, assign privileges by highlighting the privileges in the 
“Unassigned privileges” box, then click the green arrow to move them to the 
“Assigned privileges” box. You can also double-click on the privileges to quickly 
assign them.

Figure 24. Set User Privileges dialog box

When you have completed assigning privileges for desired projects, click on Next.

Note  The “Calibrate” privilege enables the user to run a calibration sample to 
update the method calibration. In order to create or modify the calibration 
parameters in a method, the user must have the “Save Method” privilege 
assigned.
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User Wizard
Set User Electronic
Signature Role

Select the electronic signature roles for the each project that the user has 
privileges to. 

Figure 25. Set User Electronic Signature Role dialog box

When you are finished, click on Finish.
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Instrument Wizard The Instrument Wizard allows you to assign Users/Groups to an instrument or to 
all instruments in a given Enterprise location.

Select Instrument From the Select Instrument dialog box, you can select an individual instrument or 
a location containing multiple instruments. To view individual instruments within 
a location, double-click on the location until the instrument names appear.

Figure 26. Select Instrument dialog box
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Instrument Wizard
Figure 27. Select Instrument dialog box

Select the instrument or location to which you want to assign a user or group, and 
then click on Next.

Select Users

Figure 28. Select Users dialog box
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For the instrument or location selected, choose the Groups/Users who will have 
access. First, select the Windows 2000/XP domain from the drop-down list. Then 
select either the groups or users (radio button controlled) from the list displayed. 
Double-click a user or group to add it to the list. Alternatively, select multiple users 
or groups, and then click on the green arrow. (Highlight one entry, followed by 
Shift-click to highlight all selections between, or use Ctrl-click to highlight 
multiple non-contiguous entries.) Use the red arrow to remove entries from the 
selected list.

When you have completed the list of Users for this instrument/location, click on 
Finish.
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Project Wizard
Project Wizard The Project Wizard allows you to define, edit, or delete system projects, and assign 
users and groups to projects. A project is comprised of a set of directories for 
storage of Methods, Data, Sequences, and Templates, along with a project 
description. Using Projects facilitates data management by ensuring related data are 
stored in designated directories that are consistent for all users. 

Figure 29. Select Project Action dialog box

The Select Project Action page shown below allows you to select the project-related 
action for which you want to use the wizard:

• To define a new project on your system, select the Create A New Project 
option button.

• To assign users or groups to existing projects in the system, select the Assign 
Users to a Project option button.

• To edit or modify an existing project in the system, select the Change a 
Project’s Settings option button.

• To remove a project from the system, select the Remove Projects option 
button. When a project is removed using the wizard, access to the specified 
directories is removed. The actual data directories defined for the project are 
not deleted. Removal of data directories must be done by the Windows 
2000/XP Administrator (if desired) after proper backup has been performed.
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Create a New Project Select the Create a new project option button. Then, click on Next to open the 
next page of the wizard and complete the project definition.

General Project Settings This dialog box is used to define the project settings. 

Figure 30. General Project Settings dialog box

Make the following entries in the General Project Settings dialog box:

• Enter a name for the project in name text box.

• Enter the location for the project definition. This should be selected from 
available directories by clicking the file open button. The location entered in 
this field sets up default directories for the project Method, Data, Sequences, 
and Templates directories. 

• Enter a text description of the project. 

• File locations for your project are automatically created for you based on your 
entry for the Location field. If you wish to change any of these, you may type 
in the new location, or select it from available directories by clicking the file 
open button.

When you have completed the project settings, click on Next to continue.
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Project Wizard
General Project Settings -
Audit Trail

This dialog box allows you to select the auditing options for the project.

Figure 31. General Project Settings dialog box

In this General Project Settings dialog box, make the following selections:

• Select the Automatically Enable Method Audit Trail check box to enable the 
auditing of methods. Then, select one of the method auditing options.

You can view the Method Audit Trail from the Instrument window. To view 
the Method Audit Trail, choose File > Method > Audit Trail.

• Select the Automatically Enable Sequence Audit Trail check box to enable the 
auditing of sequences. Then, select one of the sequence auditing options.

You can view the Sequence Audit Trail from the Instrument window. To view 
the Sequence Audit Trail, choose File > Sequence > Audit Trail.

Click on Next to continue selecting the Project options.
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Project Wizard
Define Electronic Signature
Roles

Define the electronic signature roles for this project. You add up to five signature 
roles to each project. You can change the names of the roles and you can change the 
reasons for the signatures. 

Figure 32. Define Electronic Signature Roles dialog box

To change the signature reasons, click on Modify to open the Modify Electronic 
Signature Reasons dialog box.

You can add to or modify the List of Reasons box.
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Project Wizard
Figure 33. Modify Electronic Signature Reasons dialog box

Select Project Users Use this dialog box to select the users/groups that will have access to the new 
project. 

To allow users access to this project

1. Select the Windows 2000/XP domain from the drop-down list. Then, select 
either the groups or users (radio button controlled) from the list displayed. 

2. Double-click a user or group to add it to the list. Alternatively, select multiple 
users or groups, and then click on the green arrow. (Highlight one entry, 
followed by Shift-click to highlight all selections between, or use Ctrl-click to 
highlight multiple non-contiguous entries.) Use the red arrow to remove 
entries from the selected list.
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Project Wizard
Figure 34. Select Users dialog box

Click on Next to continue.

Set Project User Privileges This dialog box allows you to assign software command access for the selected 
users/groups with access to this project. Once you have set the user privileges for a 
given project, the user/group will have access only to the functional commands 
assigned for the defined project. You may grant full functional privileges (including 
method development and data acquisition control), or you may grant a sub-set of 
the ChromQuest software commands to a given user/group.
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Project Wizard
Figure 35. Set User Privileges dialog box

To assign a privilege

• Highlight a privilege with the mouse, and then click on the green arrow. 

• To assign a complete group of related privileges (such as Data commands), 
double-click on the main privilege type (Methods, Data, Sequences). This 
automatically selects all available commands for that functional area.

Note  The “Calibrate” privilege enables the user to run a calibration sample to 
update the method calibration. In order to create or modify the calibration 
parameters in a method, the user must have the “Save Method” privilege 
assigned.
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Project Wizard
Set Electronic Signature Role Assign the electronic signature roles for the user.

Figure 36. Set User Electronic Signature Role dialog box

When you have completed selection of project privileges, click on Finish to 
complete the project definition.
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Project Wizard
Assign Users/Groups to a
Project

Once you have one or more projects defined for your system, you can add or 
change the assigned users/groups using this option.

Figure 37. Select Project Action dialog box

Select the Assign Users to a Project option button, then click on Next to continue.
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Project Wizard
Select Project Select the project to work with, and then click on Next.

Figure 38. Select Project dialog box

Define Electronic Signature
Roles

Define the electronic signature roles for this project. Click on Next.

Figure 39. Define Electronic Signature Roles dialog box
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Select Users For the selected project, choose a Windows 2000/XP domain from the drop-down 
list, and then select the users/groups you want to have access to this project from 
the available users/groups displayed. When a user/group is selected, it will appear 
in the Selected Users list on the right. Select a user/group by double-clicking it with 
the mouse, or perform a multiple selection using Shift-click (to select contiguous 
users/groups) or Ctrl-click (to select multiple, non-contiguous users/groups) to 
highlight, and then click on the Green Arrow. When you have completed your 
selection, click on Next to continue or Finish if you are done.

Figure 40. Select Users dialog box

Set User Privileges This dialog box allows you to assign software command access for the selected 
users/groups with access to this project. Once you have set the user privileges for a 
given project, the user/group will have access only to the functional commands 
assigned for the defined project. You may grant full functional privileges (including 
method development and data acquisition control), or you may grant a sub-set of 
the ChromQuest software commands to a given user/group.
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Project Wizard
Figure 41. Set User Privileges dialog box

To assign a privilege, highlight it with the mouse, and then click the green arrow. 
To assign a complete group of related privileges (such as Data commands), 
double-click on the main privilege type (Methods, Data, Sequences). This 
automatically selects all available commands for that functional area.

Note  The “Calibrate” privilege enables the user to run a calibration sample to 
update the method calibration. In order to create or modify the calibration 
parameters in a method, the user must have the “Save Method” privilege 
assigned.
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Project Wizard
Set User Electronic Signature
Role

Assign the electronic signature roles for the user or group.

Figure 42. Set User Electronic Signature Role dialog box

When you have finished, click on Finish.
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 53



4 Using the System Administration Wizards
Project Wizard
Change a Project's
Settings

Use this option to change the definition of an existing project in your enterprise. 
You can change the project description, user/groups assignment, and privilege 
assignments. You cannot change a project’s location after it has been created, 
however.

Figure 43. Select Project Action dialog box

Once you have selected this option, you will be allowed to change all the project 
parameters defined when you create a new project except for the project locations. 
Click on Next to continue.
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Project Wizard
Select Project Select the project to work with, and then click on Next.

Figure 44. Select project dialog box

General Project Settings
Changes

This dialog box is used to review the current project settings and change the project 
description, if desired. 

Figure 45. General Project Settings dialog box
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Project Wizard
• Description

Enter a text description of the project. This can be as detailed as you wish.

When you have completed the project setting changes, click on Next to continue, 
or Finish if done.

Define the Electronic Signature
Roles

Define the electronic signature roles for this project. Click on Next or Finish if 
done.

Figure 46. Define the Electronic Signature Roles dialog box
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Select Users Use this dialog box to change the users/groups that will have access to the project. 
First, select the Windows 2000/XP domain from the drop-down list. Then select 
either the groups or users (radio button controlled) from the list displayed. 
Double-click a user or group to add it to the list. Alternatively, select multiple users 
or groups, and then click on the green arrow. (Highlight one entry, followed by 
Shift-click to highlight all selections between, or use Ctrl-click to highlight 
multiple non-contiguous entries.) Use the red arrow to remove entries from the 
selected list.

Figure 47. Select Users dialog box

Click on Next to continue, or Finish if done.

Set User Privileges This dialog box allows you to change the assigned software command access for the 
selected users/groups with access to this project. Once you have set the user 
privileges for a given project, the user/group will have access only to the functional 
commands assigned for the defined project. You may grant full functional 
privileges (including method development and data acquisition control), or you 
may grant a sub-set of the ChromQuest software commands to a given user/group.
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Figure 48. Select Users dialog box

Set User Electronic Signature
Role

Assign the electronic signature roles for the user or group.

Figure 49. Set User Electronic Signature Role dialog box

When you have completed selection of project privileges, click on Finish to 
complete the project definition changes.
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Project Wizard
Remove a Project Use this option to remove a project from active use. The directories will remain on 
the Windows 2000/XP system; however, access to the project from within 
ChromQuest will no longer be possible.

Figure 50. Select Project Action dialog box

Click on Next to continue with selection of project(s) to be removed.

Note  The “Calibrate” privilege enables the user to run a calibration sample to 
update the method calibration. In order to create or modify the calibration 
parameters in a method, the user must have the “Save Method” privilege 
assigned.
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 59



4 Using the System Administration Wizards
Project Wizard
Figure 51. Select Project dialog box

Select the project(s) you wish to remove as active projects. Then click on Finish. 
The following message will remind you that you must manually remove the 
projects from your database if desired.

Figure 52. ChromQuest message window
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Chapter 5 Configuring Instruments

This chapter gives you information about configuring instruments in the 
Enterprise, and contains the following sections:

• Configuring the Enterprise, Instruments, and Detectors

• Interface Configuration

• HP LAS Loop Controller Configuration

• Configuring Instruments and Detectors

• Printer Configuration

• Verification of Analog Connections

For specific information about configuring the SpectraSYSTEM LC and 
Surveyor Plus LC modules, refer to the sections at the back of the ChromQuest 
Chromatography Data System User’s Guide.
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Configuring the Enterprise, Instruments, and Detectors
Configuring the
Enterprise,

Instruments, and
Detectors

Configuration of ChromQuest is the process of defining the system and its 
hardware. There are three main areas for configuration:

• Enterprise Configuration. This involves defining the ChromQuest enterprise 
locations and instruments.

• Interface Configuration. This is where you set up your system hardware, such 
as A/D boards, pump control boards, and BCD boards. Interface 
configuration is accessed through the Tools command on the ChromQuest 
Main Menu.

• Instrument Configuration. Each instrument to be used on the system must 
be configured. This is done from the ChromQuest Main Menu, and involves 
defining the modules used in the instrument and their configuration 
parameters

Main Menu The ChromQuest Main Menu is the first window that appears when you start the 
datasystem. From this window, you can view the entire ChromQuest “Enterprise” 
including any locations and instruments that have been configured on the system. 

Figure 53. ChromQuest main window

By default, the left side of the Main Menu displays the defined system enterprise 
locations. The enterprise is displayed as a hierarchy, where each location is 
displayed as a “folder” containing locations or instruments configured within it. 
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Click on a location on the left side of the window to display its contents on the 
right. Click on the plus signs (+) to display more locations. To change the size of 
either side of the window, drag the bar that separates the two sides. To quickly 
open a location and display its contents, double-click on the location on the left 
side of the window.

Instrument Access To access an instrument for method development, sequence generation and data 
acquisition; double-click on the icon of the instrument you wish to access.

Changing the View By default, instruments configured on the system are displayed as icons. You can 
change how the Main Menu appears using the commands located in the View 
menu. These commands allow you to turn on and off the toolbar and status bar, 
change the size of the icons, or arrange the icons. Options for changing the icon 
sizes or viewing details are also available as buttons on the command ribbon.

Figure 54. Chromquest - Tools menu

You can view status details of instruments configured on the system from the Main 
Menu. To view status, choose the View > Details command from the menu bar, or 
click on the Details button. Instruments for the current location will be displayed 
with status information.
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Figure 55. ChromQuest window

When you view a location in “details” mode, the right side of the dialog box will 
display the instrument name, current instrument status (available, idle, running), 
and the current user of that instrument. The status is updated periodically, as 
defined by the Status Update Interval set in the Tools > Options > Workstation 
tab. 
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Figure 56. ChromQuest window

You can also view the Main Menu without the entire enterprise displayed. To 
remove the enterprise, or hierarchy, pane, choose View > Hierarchy Pane. If this 
selection is not checked, the enterprise will not be displayed.
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Item Properties You can view details of an instrument by clicking on the right-hand mouse button 
on the instrument icon, and then choosing the Properties command. An 
information box will appear with current instrument information.

Figure 57. Instrument Properties window
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Enterprise Configuration When ChromQuest is first started, the Main Menu has no “enterprise” defined. 
The ChromQuest system administrator must define the enterprise before 
instruments can be configured and used.

Figure 58. ChromQuest window

You can re-name the enterprise by clicking on the right-hand mouse button on the 
enterprise name, then choose Rename, and type the new enterprise name.
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Adding an Enterprise Location To add a location to your enterprise, click on the right hand mouse button in the 
enterprise window, and choose New > Location Group.

Figure 59. ChromQuest - The Enterprise menu

A new entry will appear below the enterprise. You can give the new location or 
group a name. Continue adding locations or groups to the enterprise until the 
enterprise configuration matches that of your company or group.

Adding an Instrument to the
Enterprise

Before you can configure an instrument, you must add it to the enterprise 
definition. To add an instrument, select the location where the instrument is 
found. Then click on the right-hand mouse button, followed by New > 
Instrument. An icon for the new instrument will appear in the right window, and 
you can give it a name.
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Figure 60. ChromQuest window

Continue to add locations and instruments until the system enterprise matches 
your company/laboratory configuration. Then go on to configure each of the 
instruments as described in “Configuring Instruments and Detectors” on 
page 77. You must also configure any A/D interfaces you will be using on your 
system, as described in “Interface Configuration” on page 71. Your completed 
enterprise can be as simple as one lab with multiple instruments, or a complex list 
of buildings, laboratories, and instruments.
Thermo Electron Corporation ChromQuest Chromatography Data System Administrator’s Guide 69



5 Configuring Instruments
Configuring the Enterprise, Instruments, and Detectors
Figure 61. ChromQuest window
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Interface Configuration
Interface
Configuration

Interface Configuration involves configuring the hardware boards used in 
ChromQuest for data acquisition. You must configure your data acquisition 
interface before you can acquire data using the data system. 

Choose the Tools > Interface Configuration command from the ChromQuest 
Main Menu. A box will appear with possible interface boards displayed. To 
configure a board, click on the icon to select it, and then click on Properties.

Figure 62. Interface Configuration window

SS420 A/D Board
Configuration

If you are using an SS420 A/D Board to acquire data from your detectors, click on 
the SS420 A/D icon then click on Properties. A dialog box will appear where you 
configure the board. 

Board Select the board number you wish to configure. If you only have one board, leave 
the selection at 1. 

• Board Setting

This area is where you set the parameters for the SS420 Board selected.

Note  It is only necessary to perform Interface Configuration on workstations 
where the interface board is actually installed.

Note  It is only necessary to perform Interface Configuration on workstations 
where the interface board is actually installed. 
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− Base Address (Hex)

Default value is 360. The address entered here must match the address set 
on your board. You may change this if it conflicts with another board you 
have installed. Each board takes 4 addresses. Therefore, if you have more 
than one SS420 board, the next board address must be set at least to the 
first address plus 4. (For example, board 1 = 360, board 2 = 364.) Make 
sure the base address is set to zero for boards not installed. (Check this by 
clicking on each unused board number displayed at the top of the dialog 
box.) 

− Interrupt Level 

Default is IRQ11. The interrupt level entered here must match the 
interrupt level set on the board. Each SS420 board must have a unique 
interrupt level Default is IRQ11. The interrupt level entered here must 
match the interrupt level set on the board. Each SS420 board must have a 
unique interrupt level assignment. If you change the interrupt level, you 
must set the interrupt jumper on the SS420 board to reflect the correct 
interrupt level.

− Base Frequency

The default setting for the SS420 is 10 Hz, which gives optimal signal to 
noise, and can be used in countries using either 50Hz or 60Hz.   If you 
choose a higher base frequency, you must select a base frequency which 
can be evenly divided into your line frequency (i.e. 30 for 60Hz countries 
and 25 for 50Hz countries). If selected incorrectly, you may see line 
frequency noise on your chromatogram.   For best performance, select a 
base frequency close to the maximum sampling frequency you will be 
using to acquire data. 

Sampling frequencies available in the Acquisition Setup portion of the 
method will reflect the Base Frequency selected. 

− Range

For each channel used, select the button next to the signal range for the 
detector connected to that channel.

• Board Information

This area is for information only. It contains manufacturing information about 
the board that may be required in service situations. If this information is 
blank, your board is not being recognized. This may be due to a conflict of 
Address. If multiple SS420 boards are installed, when one board is not 
recognized, none of the other boards will be recognized until the conflict is 
corrected.
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Interface Configuration
CIO/DIO Boards If you are using one or more of the ComputerBoard, Inc. CIO/DIO Boards to 
control external events, click on the CIO/DIO icon, then click on Properties. A 
dialog box will appear where you configure the board.

Figure 63. CIO/DIO Configuration dialog box

You can configure up to four CIO/DIO boards. For each board installed, click on 
the corresponding tab, then configure the board as follows.

• Installed

Check this box if the board is installed and you want to configure it.

• Model

Select the correct model for the board you have installed from the 
drop-down list.

Note  You must close and restart Windows 2000/XP before the SS420(s) will 
be recognized. 
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• Base Address

Enter the base address for the board by entering the number in the numeric 
field, or by moving the switch settings to match your board.

• Connector
Select the appropriate connector for the board from the drop-down list. The 
diagram of the connector for your selected model will be displayed.

When you have completed the configuration, click on OK. You should reboot 
your computer whenever you change board configuration.
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HP LAS Loop Controller Configuration
HP LAS Loop
Controller

Configuration

After the Loop Controller board has been installed, it must be configured to 
communicate with the software. From the Main Menu, choose Tools > Interface 
Configuration. 

Figure 64. Interface Configuration window

Select the HPLAS icon, and click on Properties to access the HP LAS board 
configuration dialog.

HP LAS Board
Configuration

Select the Installed box to enable the fields for configuration of the board.

Figure 65. HP LAS Board Configuration dialog box

Enter the base address of the board, or change the switches on the diagram to 
match the address setting on the board. The base address is determined by the 
DIP switches located on the loop controller board. Click on OK when finished.
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HP LAS Loop Controller Configuration
HP LAS Detector
Configuration

In order to use the HP LAS interface for acquisition, it must be configured for the 
instrument. From Detector Configuration, select HP LAS A/D for Acquisition 
Source.

Figure 66. Detector Configuration dialog box

Click on the configuration button adjacent to the Acquisition Source field and 
complete the dialog for configuration of the detector.

HP LAS Configuration Complete the dialog for configuration of HP LAS.

Figure 67. HP LAS Configuration dialog box

• Channel number

Select the channel number of the HP multichannel interface to be used for 
acquisition. This must match the channel number (DIP switch setting) on the 
back of the multichannel interface.

• Base Frequency

Select the Base frequency. This must match the base frequency set on the back 
of the multichannel interface (DIP switch setting).
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Configuring
Instruments and

Detectors

Configuration of instruments and detectors is done from the Main Menu of 
ChromQuest. To access instrument configuration, either select an instrument by 
clicking on it to highlight it, and then select the File > Configure > Instrument 
command. Alternatively, click on the instrument with the right-hand mouse 
button and choose Configure from the popup menu.

Instrument Configuration Enter an identification name for the instrument in the Instrument Name field. 
This name will appear adjacent to the instrument icon in the Main Menu, and at 
the top of this instrument’s application window, as well as in other areas of the 
software that refer to this specific instrument (such as System Administration 
Wizards).

Figure 68. Instrument Configuration dialog box

Select the Instrument Type from the drop-down list 

• Server name. 

This text box is available only in the client/server mode.

Click on Configure to complete the instrument configuration by defining 
detectors and external events for the instrument. 

Note  You must have instrument administration privileges in order to configure 
instruments.

Note  If you are using an HP5890 with or without an HP7673 autosampler, 
and want to use instrument and/or autosampler control features of 
ChromQuest, you must select the HP5890 + HP7673 type for the instrument. 
Details on how to configure HP instruments and how to control them are 
located in a separate control manual that comes with the instrument control 
option software.
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Extract Configuration From
Data File

The Extract From Data File command allows you to extract an instrument 
configuration from a stored data file. Right-click on your instrument to open the 
shortcut menu. Then choose Configure > Extract From Data File.

Figure 69. ChromQuest window

ChromQuest displays the following warning.

Figure 70. ChromQuest - Warning window

Click on Yes to display the Select Data File dialog box.
78 ChromQuest Chromatography Data System Administrator’s Guide Thermo Electron Corporation



 5 Configuring Instruments
Configuring Instruments and Detectors
Figure 71. Select Data File window

Generic System
Configuration

This dialog box is used to add and define detectors and external events for your 
instrument.

Figure 72. Generic System Configuration window

There will be one or more icons displayed in the Available Modules box on the 
left. To add a detector for configuration, click on the icon in the left box. Then, 
click on the Green button to move it to the Configured Modules box on the right, 
or double-click on the icon. You must then configure each module (detector or 
event configuration) separately. The Options button is used to initiate any 
optional analysis software for this instrument.
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General Configuration
Options

A list of available analysis options will be presented. 

Figure 73. Configuration Options dialog box

Select the checkbox(es) for the optional software you want to enable for this 
instrument. PDA will automatically be selected if a detector capable of spectral 
analysis is configured.

Detector Configuration For EACH detector in the Configured Modules window, double click on the icon 
and complete the configuration dialog for every detector channel. You must also 
complete the Acquisition Source configuration by clicking on the adjacent button 
before leaving the Detector Configuration dialog.

Figure 74. Detector Configuration dialog box
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• Detector Name

Enter a descriptive name for the detector. For example, FID or TCD.

• Detector Model

Select the type of detector from the drop-down list. 

• Acquisition Source

Select the type of A/D board or device you are using from the drop-down list. 
Then click on the adjacent button to configure it. 

• Y-Axis Units

Type in the units to be displayed on the Y-Axis of your chromatogram. For 
example, microvolts or AU, depending on the detector units of measurement. 
ChromQuest acquires your analog signal and stores it in microvolts. If you 
want to display the signal in different units, you must use the correct 
multiplier. Consult the table below for commonly used Y-axis labels and 
corresponding multipliers.

• Y-Axis Multiplier

ChromQuest normally displays the chromatogram in volts. If you wish to 
display another unit, enter the conversion factor to be applied. The following 
table shows commonly used Y-axis labels and corresponding multipliers.

Y-Axis Label Y-Axis Multiplier
Volts 0.000001
Millivolts 0.001
Microvolts 1
Other Enter a number such that when multiplied by microvolts, 

gives you the desired units. 

For example, if you want the label to be Units, and each Unit corresponds to 5 
microvolts of signal, enter 1/5 = 0.2.

Before you exit the dialog, you MUST configure the Acquisition Source by 
clicking on the button adjacent to the acquisition source. 

When you have completed configuration for all detectors of this instrument, your 
System Configuration dialog will display each detector’s name and type. Click on 
OK to exit the configuration. It is necessary to re-start the instrument application 
for the configuration to take effect. 
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Configuring SS420 Acquisition If you select this acquisition source, a dialog box will appear.

Figure 75. SS420 dialog box

If you have more than one SS420 board installed, select the Board Number for 
this instrument from the drop-down list.

For Analog Input, select the channel to which the detector channel is connected 
from the drop-down list. Make sure each detector is configured for the correct 
channel to which it is connected on the A/D board. Click on OK to exit and return 
to the detector configuration dialog.

Configuring PE Nelson 760
Acquisition Source

If you are using a PE Nelson 760 series interface to acquire your data, the following 
dialog box will appear.

Figure 76. PE Nelson 760 Configuration dialog box

Select the GPIB board number from the drop-down list. For most systems, select 
GPIB0.

Select the GPIB Device Address for the PE Nelson interface connected to this 
instrument. This address should match the address set on the PE Nelson interface.

Note  GPIB address changes do not take effect unless the instrument is power 
cycled.
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Select an Input range for the detector from the drop-down list. 

Select the Channel for this detector. The detector should be connected to this 
channel on the PE Nelson interface.

When you are done, click on OK to return to the detector configuration dialog.

Configuring PE Nelson 941
Acquisition Source

If you are using a PE Nelson 941 interface to acquire your data, the following 
dialog box will appear.

Figure 77. PE Nelson 941 Configuration dialog box

Select the Com Port from the drop-down list. 

Select the Baud Rate the PE Nelson interface uses to communicate. This should 
match the baud rate set on the PE Nelson interface.

Select the Parity used from the drop-down list. 

Select the Input Range for this detector. 

Click on the radio button adjacent to the Channel that matches the channel where 
the detector is connected. 

When you are done, click on OK to return to the detector configuration dialog.
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Configuring PE Nelson 960
Acquisition Source

If you are using a PE Nelson 960 interface to acquire your data, the following 
dialog box will appear. 

If the interface is set to communicate via GPIB, the following box will appear.

Figure 78. PE Nelson 960 Configuration dialog box

Select the GPIB board number from the drop-down list. For most systems, select 
GPIB0.

Select the GPIB Device Address for the PE Nelson interface connected to this 
instrument. This address should match the address set on the PE Nelson interface.

Select an Input range for the detector from the drop-down list. 

Select the Channel for this detector. The detector should be connected to this 
channel on the PE Nelson interface.

When you are done, click on OK to return to the detector configuration dialog.

If the interface communicates via RS232, select RS232 Communication from the 
drop-down list, and complete the following dialog.

Note  GPIB address changes do not take effect unless the instrument is power 
cycled.
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Configuring Instruments and Detectors
Figure 79. PE Nelson 941 Configuration dialog box

Select the Com Port from the drop-down list. 

Select the Baud Rate the PE Nelson interface uses to communicate. This should 
match the baud rate set on the PE Nelson interface.

Select the Parity used from the drop-down list. 

Select the Input Range for this detector. 

Click on the radio button adjacent to the Channel that matches the channel where 
the detector is connected.

When you are done, click on OK to return to the detector configuration dialog.

Configuring Valves and
External Events

In order to configure a valve, trigger, or other external event, you must first make 
sure the event is properly connected to the ChromQuest system. Configuring an 
external event involves specifying which input lines are being used, so you must 
have this information available before you start the configuration.

Valve and external event configuration is done from the instrument configuration 
dialog. To access this, highlight the instrument to configure, then choose File > 
Configure from the Instrument menu bar, or do a right mouse click on the 
instrument icon, and choose the Configure command.
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Configuring Instruments and Detectors
Figure 80. Instrument Configuration dialog box

Click on the Configure button. From the System Configuration window, 
double-click on the Events Configuration icon. This will move the icon into the 
“Configured Modules” area of the window.

Figure 81. Generic System Configuration dialog box

Double-click on the Event Configuration icon in the right-hand box. A 
spreadsheet will appear where you can select the external events to configure.
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Event Configuration When you double-click on the Event Configuration icon, the following 
spreadsheet will appear where you configure the events.

Figure 82. Event Configuration dialog box

• Name

If you are configuring a Trigger or Ready line, click on the button in the Name 
text box and select either Trigger or Ready from the list. If you are configuring 
a valve or other external event, simply click on the Name text box and then 
type in the name of your event.

• Source

In the Source field, click on the button and select the source of the event (the 
hardware from which the event comes). 

• Setup

Click on the button in the Setup field. A dialog will appear where you set up 
the appropriate information for the operation of this event.

Continue the external event configuration until all events for this instrument are 
configured. Programming of the external events into your method is done in the 
Instrument Setup section of the method, and is described in the Method 
Development section.
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Configuring Instruments and Detectors
SS420 Input Setup When you are configuring a Trigger, the SS420 Input Setup dialog will appear 
when you click on Setup. Select the appropriate input line for your Trigger.

Figure 83. SS420 Input Setup dialog box

• Board Number

Select the number of the board from which the event comes.

• Input

Select the input to which the event is connected on the board.

• Triggered State

Select the state of the connection when it is triggered. (e.g. For 
normally-closed select Open, for normally-open select Closed.) 

Note  

1. The external events tab in Instrument Setup will not be available unless 
you have configured your instrument with one or more external events.

2. It is possible to assign the same event to more than one instrument. Be 
careful to assign events such that conflicts between instruments will not 
happen.
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SS420 Output Setup When you configure a valve or other external device, the Setup field opens the 
SS420 Output Setup dialog. Select the Output line on your board to which the 
event is tied.

Figure 84. SS420 Output Setup dialog box

When completed, click on OK to exit the dialog. Continue the external event 
configuration until all events for this instrument are configured. Programming of 
the external events into your method is done in the Instrument Setup section of 
the method, and is described in the Method Development section.

PE Nelson 760 Output Setup When you configure a valve or other external device, the Setup field opens the 
Output Setup dialog. Select the GPIB Board Number, GPIB Interface Address, 
and Output line to which the event is tied.

Figure 85. PE Nelson 760 Output Configuration dialog box

When completed, click on OK to exit the dialog. 

Note  The external events tab in Instrument Setup will not be available unless 
you have configured your instrument with one or more external events. 
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PE Nelson 941 Output
Configuration

When you configure a valve or other external device, the Setup field opens the 
Output Configuration dialog. 

Figure 86. PE Nelson 941 Output Configuration dialog box

Select the COM Port where the interface is configured from the drop-down list.

Select the Output from the drop down list.

When completed, click on OK to exit the dialog. Once the events are configured, 
you can program them from the Instrument Setup section of the methods.

PE Nelson 960 Output
Configuration

When you configure a valve or other external device, the Setup field opens the 
Output Configuration dialog. 

If the interface uses GPIB to communicate, select this option from the drop-down 
menu.

Figure 87. PE Nelson 960 Output Configuration dialog box

Select the GPIB Board to which the interface is connected from the 
drop-down list.

Select the GPIB Address that matches the address set on the interface.
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Select the Output to configure from the drop-down list.

Click on OK to exit the dialog.

If the 960 Interface communicates via RS232, select this option from the 
drop-down list, and the following dialog will appear.

Figure 88. PE Nelson 960 Output Configuration dialog box

Select the COM Port where the interface is configured from the drop-down list.

Select the Output from the drop down list.

Click on OK to exit the dialog box. Once the events are configured, you can 
program them from the Instrument Setup section of the methods.

CIO/DIO Setup - Event
Configuration

If you are using one of the CIO/DIO boards, the following dialog will appear 
when you click on the Setup field in the event configuration spreadsheet.

Figure 89. Event Configuration dialog box

Note  GPIB address changes do not take effect unless the instrument is power 
cycled.
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• Board

Select the board for which you want to configure events.

• Connector

Select the connector to be used.

• Signal

Select the signal source for the event.

• Idle State

Select the idle state for the event: default, open, or closed.

When you have completed the dialog, click on OK. Once the events are 
configured, you can program them from the Instrument Setup section of the 
methods for instruments using this board.
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Printer Configuration
Printer Configuration ChromQuest allows each instrument to print to a different printer. Use the 
following guidelines to specify the printer. 

Print Setup for
Workstations

Each instrument connected to ChromQuest can have its own unique printer. To 
designate a printer other than the Windows default printer, choose the File > Print 
Setup command from the Instrument window menu bar. Select and setup the 
printer to be used for this instrument from the standard printer dialog shown.

Printing in an Offline
Environment

When working with an instrument Offline, the printer designated in the File > 
Print Setup dialog becomes the configured printer for that user, and has no effect 
on the configured printer for the online instrument. This enables a laboratory 
manager to work offline and request reports to a local or office printer without 
changing the printer configured for the instrument to use in the lab. A user can 
designate a different offline printer for each instrument. 
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Verification of Analog
Connections

Before attempting to inject samples on your chromatograph, you should verify the 
analog connections and triggers you have made are correct by looking at the actual 
detector signals. 

Using Preview to Verify
Analog Connections

To do a quick preview of the signal without performing a run using the Preview 
function. 

1. From the ChromQuest Main Menu, click on the icon that represents the 
instrument you wish to check, and login to start the instrument application. 

2. Locate the Preview button on the command ribbon and click on it. 
Alternatively, choose the Control > Preview Run command from the menu. 
At this point, you will see the real time detector output from your instrument. 
If you inject a simple sample (i.e. solvent) you should see a peak elute, oriented 
in the correct direction. If you see no peaks, check to see if your connections 
and assignment of analog line numbers, and configuration are correct. If the 
peaks are in the wrong direction, reverse your detector signal lines and repeat.

3. When you are finished, click on the STOP button. Note that in the Preview 
mode, the data is not integrated or analyzed. 

Once you have verified your analog signals and remote input lines are properly 
connected, you can start acquiring actual data. If you are using ChromQuest 
for the first time, take a few minutes to perform the Tutorial. This Tutorial 
takes you step-by-step through the basics of using the system, and will make 
learning ChromQuest much faster. 

Starting an Instrument To access the Instrument window where you can develop methods and sequences, 
create custom reports, and acquire data, double-click on the instrument icon you 
wish to start in the Main Menu. You may be required to login before you can 
access the instrument window functions.
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Instrument Login Whenever the instrument login and project management is enabled, you will be 
required to login whenever you attempt to start an instrument application.

Figure 90. Login - User name dialog box

Enter the information as prompted, and then click on Login.

• User name

Enter the user name that has been assigned to you on the network.

• Password

Enter your assigned network password.

• Save Password

If the “save password” option is enabled by your system administrator, a Save 
password checkbox will appear. 

Figure 91. Login - Password dialog box

If you select this box, the password you type at login will be saved when you click 
on the Login button. Once the password has been saved, whenever you login to 
the instrument, the saved password will be used. 
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• Domain 

Select the domain you have privileges on from the drop-down list, or type in 
the correct domain. (Not shown unless you are using a domain controller.) 

• Project 

Select a project to log into. This project will become the default project path 
for methods, data, and sequences in the instrument. You can, however, create 
and save files in other locations, or change the selected project later, even 
though you have logged into a designated project.

Once you have logged into an instrument and selected a project, that project’s 
paths for methods, data, sequences, and templates will be used unless you designate 
a new project. To change the selected project, use the File > Select Project 
command from the Instrument window menu bar. 

Note  The password will be saved when the Login button is clicked, whether or 
not the login is successful. 
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