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Preface

This tutorial describes how to generate custom reports for Thermo TraceFinder GC/MS and
LC/MS analytical software.

Contents

¢ Related Documentation
* Special Notices
* System Requirements

* Contacting Us

Related Documentation

In addition to this tutorial, Thermo Fisher Scientific provides the following TraceFinder
documents as PDF files:

* TraceFinder User Guide

o TraceFinder Administrator Quick Reference Guide

o TraceFinder Acquisition Quick Reference Guide

* TraceFinder Analysis Quick Reference Guide

o TraceFinder Shortcut Menus Quick Reference Guide

The software also provides Help.

Special Notices

Make sure that you follow the precautionary statements presented in this tutorial. The safety
and other special notices appear in boxes.

Special notices include the following:

Note Highlights information of general interest.

Tip Highlights helpful information that can make a task easier.

Thermo Scientific TraceFinder Custom Reports Tutorial vii



Preface

System Requirements

Your system must meet these minimum requirements.

System Requirements
Computer * 2.33 GHz processor dual core with 4 GB RAM
¢ CD/R-ROM drive

Video card and monitor capable of 1280 x 1024 resolution (XGA)
75 GB available on the C: drive

e NTES format
Instruments Autosamplers:
(supported or e TriPlus™
required) * AS3000

e Accela™ AS

GC Devices:
* FOCUS™ GC
e Trace GC Ultra™
* Trace 1300 Series

LC Devices:
* Accela 1250 Pump
* Accela Pump
* Dionex™
e TLX-1
e 1LX2
* Agilent™ 1100
* Agilent 1200

GC/MS and LC/MS mass spectrometers

Software * Microsoft™ Windows XP Professional SP3
or Windows 7 Professional
e Microsoft Office 2007 SP2 or Microsoft Excel™ 2007 SP2
¢ Microsoft .NET Framework 4.0 Extended
¢ Thermo Foundation™ 2.0 SP1
e Thermo Xcalibur™ 2.2 SP1
e Adobe™ Reader™ 10.0
e NIST™ 2008
* (optional) Thermo LC Devices 2.5 SP2
* (optional) Thermo GC Devices 2.2

viii TraceFinder Custom Reports Tutorial Thermo Scientific
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Contacting Us

There are several ways to contact Thermo Fisher Scientific for the information you need.

< To contact Technical Support

Phone 800-532-4752
Fax 561-688-8736
E-mail us.techsupport.analyze@thermofisher.com

Knowledge base ~ www.thermokb.com

Find software updates and utilities to download at mssupport.thermo.com.

< To contact Customer Service for ordering information

Phone 800-532-4752

Fax 561-688-8731

E-mail us.customer-support.analyze@thermofisher.com
Web site www.thermo.com/ms

% To copy manuals from the Internet

Go to mssupport.thermo.com, agree to the Terms and Conditions, and then click
Customer Manuals in the left margin of the window.

< To suggest changes to documentation or to Help
* Fill out a reader survey online at http://www.surveymonkey.com/s/PQMG6PG2.

* Send an e-mail message to the Technical Publications Editor at
techpubs-lems@thermofisher.com.

Thermo Scientific TraceFinder Custom Reports Tutorial ix
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Introduction

Thermo Scientific

Custom reports for the TraceFinder application are based on the Microsoft Excel application
using add-ins and templates. This tutorial guides you through the process of creating a few
typical reports and explains the principles and techniques used to create those reports. After
completing this tutorial, you should be able to start creating your own reports for your
business needs.

Prior knowledge of the Excel application and Microsoft Visual Basic™ for Applications (VBA)
code is advantageous though not required before beginning the exercises in this tutorial.

This tutorial guides you step by step in creating four different reports. These reports show the
scope of TraceFinder functionality:

* Batch Report

This is the simplest report tutorial and highlights essential techniques used for creating
the custom reports. The Excel table is used to show a list of samples and their batch
properties.

* High Density Report

This report tutorial demonstrates how to include graphics in a report and how to create a
repeating area for each compound in the template.

* Calibration Report

This report tutorial explains how to create a cross-tab table (called a pivot table in the
Excel application) in a report.

* DCC Report

This report tutorial uses static method data with the help of an internal mapping table to
create a DCC report, commonly used in doping control centers.

TraceFinder Custom Reports Tutorial 1






Overview

This chapter explains the templates, workflow, customization levels, and Excel application
features used in generating custom reports in the TraceFinder application.

Contents

* Template Architecture
* Custom Report Generation
* Customization Levels

e Excel Features and Limitations

Thermo Scientific TraceFinder Custom Reports Tutorial 3
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2 Overview
Template Architecture

Template Architecture

The custom report templates use a two-tiered design. They use the a Microsoft Excel add-in
component to provide more generic services, such as the framework and the library, for all
templates. At each template level, you can write VBA code to control the report layout and
format the output data.

The add-in component provides the following major functions:

* Handles the startup parameters for the template that are passed in from the TraceFinder
application. The application uses these parameters to fully automate the generation of
custom reports.

* Provides a framework for creating the headers and footers for all reports. A default set of
headers and footers is included in the delivered add-in, but you can override these in each
template to further customize the reports.

* Provides utility functions specific to the TraceFinder application reports to hide internal
complexity and to facilitate customization at the template level. For example, you can use
a one-line add-in function to add graphics to the report or to create a cross-tab- report.

By design, you will rarely need to customize the add-in module. It is password-protected. If
you must modify the add-in code, contact your Thermo Fisher Scientific representative for
the password.

The VBA code used in each template is kept to a minimum. In general, most of the templates
use fewer than 100 lines of VBA code.

TraceFinder Custom Reports Tutorial Thermo Scientific



2 Overview
Custom Report Generation

Custom Report Generation

The TraceFinder application generates custom reports sequentially. The following flow chart

shows the TraceFinder process for generating custom reports.

Figure 1. Generating custom reports

TraceFinder oplication

Generate Reports =

MNeed Any
Custom
Report? Excel Templata
( EMD )
/ F 3
For each Sample
Create Report
{*.xlsm)
w
£
Generate
* SampleCentricData.xml
ProcessData()
r
-
4 For each Report
in Sample
- Import XML data
Excel.exa /n [Templata] /...
r
Windows 05 Validate()
I
Opens
¥
Excel Template N Add-In
(*.xltm) (Pracess command args)

The workflow to create custom reports with the finished templates is as follows:

1. Configure the TraceFinder application to enable the generation of custom reports. Refer
to the TraceFinder User Guide for more details. You can include all report templates in the

C:\Thermo\Shared\Templates\Reports folder in the application.
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2 Overview
Custom Report Generation

2. When you submit a custom report for batch processing, the TraceFinder application
automatically generates a sample-specific data file for each sample in .xml format. These
files are located in the Data folder. They have names similar to
RawFileName_SampleCentricData.xml, where RawFileName is the name of the raw data
file for the sample.

* This XML file includes all the data needed for creating sample-specific reports. In
most cases, you need only refer to this one file for a report.

* In some reports, you might need to refer to more than one sample-specific raw data

file.

* The RawFileName_SampleCentricData.xml file also contains calibration data, which
is batch-level data. Because this file is created as each sample is processed, the
batch-level data might contain partial results until the last sample is finished.

3. To generate a custom report, the application creates a Windows command line for the
Excel application and passes it to the operating system. The operating system opens the
Excel application with the specified template. The template processes the remaining
parameters through the add-in component, which loads and processes the data to
generate the report.

If you are a regular user of the TraceFinder applications, the details of this process are
hidden. However, if you are a template developer, understanding this process is helpful.

The Excel command line looks like this:
excel.exe /n TEMPLATENAME /X/CUSTOMPARAMETERS

where:

* /n tells the Windows operating system that you are using this template to create an
Excel spreadsheet, not editing the template itself. Without this switch, the Excel
application would open the specified template for editing.

* /x indicates that all subsequent parameters be passed to the add-in component for
processing.

Chapter 3, “Getting Started,” describes the command line in more detail.

The Windows operating system opens the Excel application with the specified template.
It passes all the parameters after /x to the template for further processing. The template
processes the parameters through the add-in component, which loads and processes the
data to generate the report. After the custom parameters are processed, the first function
that the add-in component calls is the Validate() function on the IUtil interface, which is
implemented by all templates. This function protects the template design from accidental
changes. When Validate() succeeds, it starts importing XML data. After it imports all the
data, the add-in calls the ProcessData() function on the IUtil interface to perform all the
post-processing. The function then notifies the TraceFinder application that the report is
completed and that it is ready for the next report, if any.

6 TraceFinder Custom Reports Tutorial Thermo Scientific



2 Overview
Customization Levels

Customization Levels

The Excel application provides flexibility in customizing your reports to your needs and
technical expertise.

* You can customize the appearance of your reports by making changes to the template.
You do not need to know VBA programming. For example, if you have some basic
familiarity with the Excel application, you can change the font, resize a column, or format
a number. With a little training, you can add or remove columns in a list.

* When you know VBA programming, you can customize the template logic by modifying
the code that the template uses. At this level, you do not need to change the add-in code
because you can customize the template code.

* You can perform advanced customization if you need to change the add-in framework. By
referring to the existing add-in component, you can create completely different kinds of
templates for your needs. The DCC report is an example of this kind of customization.

Thermo Scientific TraceFinder Custom Reports Tutorial 1



2 Overview

Excel Features and Limitations

Excel Features and Limitations

Features

Limitations

Here are additional features and limitations in the Excel application that affect custom report
creation:

Named ranges: Used extensively in the report-generation process.
XML support: Used to create custom reports based on a single XML file as a data source.

Flexible formatting: Used to create professional-looking reports.

The Excel application does not use relational data. Instead, all its data follows a
hierarchical structure. As a result, some of the data in source XML files might be
duplicated.

You can reference each mapped XML data source only once in the workbook. When you
want to use the same field more than once, you must add the same source as an XML
map for each usage.

All images are embedded in the XML file as byte arrays. However, the cells in an Excel
spreadsheet have a data size limit that precludes the application from loading the byte
arrays directly into the cells. Therefore, it loads all images programmatically into the
spreadsheet at run time. Placing graphics onto a spreadsheet just creates a placeholder for
graphics.

The Excel application does not offer an Undo function for any macros or VBA code. It
clears its undo stack completely when it executes any macro or VBA code.

The Excel copy/paste function is powerful, but it uses the Windows Clipboard to pass
around the data. When you use the Windows Clipboard to move data on the spreadsheet
while running the reporting process in the background, you might inadvertently cause an
incorrect report to be generated. The add-in component provides a special copy/paste
function to circumvent this problem.

Tip In general, the copy/paste function becomes slower as the amount of data on a sheet
increases. The Excel application can more easily handle many tabs with a small set of data
on each tab, so many reports feature several tabs, with each tab representing one printed

page.
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Getting Started

In this chapter, you will create a ThermoCustomReportBaseTemplate file to be used in
subsequent chapters as a base for creating specific report templates.

Contents

* Prerequisites

* Creating the Base Template
* Working with Columns

* Security Settings

* Testing the Template

Prerequisites

To create custom reports using the Excel application, you must conﬁgure your system with
the following required components.

Note If you have the TraceFinder application installed and have generated any custom
reports, you have already met these requirements.

¢ Microsoft Excel 2007 SP2 (12.0.6524 or above)

To verify your version of the Excel application, do the following:
a.  Open the Excel application.
b. Click the Office button, b@ , and click Excel Options,

2] Excel Optjons |.

c. Click Resources.

Thermo Scientific TraceFinder Custom Reports Tutorial
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3 Getting Started
Prerequisites

d.  Verify your version in the About Microsoft Office Excel 2007 area.

Figure 2.  Excel Options Resources dialog box

Excel Options

Popular Diagnose and repair problems with your Microsoft Office programs,
Formulas contact us Contact Us
Proofing Let us know if you need help, or how we can make Microsoft Office better,
" activate Microsoft Office
Advanced Activation is required to continue wsing all the festures in this product,
Clustomizs go to Microsoft Office Online
Add-Ing Get free product updates, heip, and online senaces at Microsoft Office Online,
| Trust Cenber t Microso ce 12007 [ apout |
E “Retources | Microsoft® Office Excel® 2007 (12/0.6524.5003) 5F2 MSO [12.0,6529,5000) j
1 i}
[ ok || canca |

* Thermo Report Add-In (Thermo Report Add-In.xla)

Load any custom template (*.xltm). When the add-in is successfully loaded, you see the
Add-Ins menus as shown in the following example.

Figure 3. Add-Ins menus

(1 - e T EatchReportxitm [Read-Only] - Microsoft Excel T
R eee——— .
Home Insert Page Layout Formulas Data Review View Developer | Add-Ins ! @ - X
| Team ~ Lo New List v-| Get Work [tems “’| Publish | Refresh f‘]‘ Configure List _'“’| Choose Calumns
e =
Team Project Process Guidance 4 Add Column x Remove Column ﬁc Add Graphic Show Mamed Ranges « Validate B ] .
Team System Help
|' Menu Commands Custom Toaolbars i
| 2 T v
| B [C] D | E F L6 | H L | W
| Batch Report
2] | :
3 Lab name: Method: =
4 |instrument:
5 |usern: Cali File:
6 |Batch:
kil
& |File Hame E]E] Date/Time |3 Sample ID B Sample Name E Level B Sample Type 'E] Pos El Inj 'E
9 his
Ready | X | .

The Thermo Report Add-In.xla file is located in the following folder:
C:\Thermo\Shared\Templates\Reports
The Excel application template files (*.xltm) are installed in the following folder:

C:\Thermo\Shared\Templates\Reports

10 TraceFinder Custom Reports Tutorial Thermo Scientific



3 Getting Started
Creating the Base Template

Creating the Base Template

To create specific report templates, begin with the basic template file
(ThermoCustomReportBaseTemplate).

< To enable the Developer tab in the Excel application

1. Click the Office button, '@ , and click Excel Options,

[z3 Excel Options |

2. Select the Show Developer Tab in the Ribbon check box and click OK.

Excel Options @

B
= ular :| . A .
e _3 Change the most popular options in Excel.
Formulas
Proofing Top options for working with Excel
Save Show Mini Toolbar on selection (i
i@ 5 Enable Live Preview (i)
vance
l Show Developer tab in the Ribbon ]
Customize Always use ClearType
Add-Ins Color scheme: Blue [
Trust Center screenTip style: | Show feature descriptions in ScreenTips w
BesouUrces Create lists for use in sorts and fill sequences: [ Edit Custom Lists... ]
[ Ok _] [ Cancel ]

The Excel application displays the Developer tab.
% To load the ThermoReportAddin function
1. Click the Developer tab.

The ribbon expands to display the Developer functions.
2. Click Visual Basic,

Visual
Basic

The Microsoft Visual Basic window opens.

Thermo Scientific TraceFinder Custom Reports Tutorial
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3 Getting Started
Creating the Base Template

3. Choose View > Properties Window.

The Properties pane opens.

Figure 4. Microsoft Visual Basic window with Properties pane

_—

<8 Microsoft Visual Basic - Book1

! File Edit View [Insert Format Debug Run Tools AddlIns Window Help

ME-H s BB 9C rn K HFE RO

Project - ¥EAProject B

' YBAProject (Book1) 4|
=3 Microsoft Excel Objec—

Sheetl ‘Worksheet
Alphabetic Categurizedl

DisplayPagebre: False

DisplayRightTol False ‘
EnableAutoFilel False
Enableutlining False

4. Choose Tools > References.

The References - VBAProject dialog box opens. The check marks indicate active
references, which appear at the top of the list.

References - VBAProject

Available References:

[v] Wisual Basic For applications | Cancel |

[ Microsoft Excel 12,0 Object Library

¥l OLE Automation i
A icrosoft OFfice 12.0 Object Library fl Browse. . |

i;l Microsaft Forms 2.0 Object Library
[T Microsoft Windows Commmon Controls 6.0 (SPS) S
[ IMicrosaft ¥ML, w&.0 Priarity

[ ThermoRepartaddin
[] 185 Helper COM Component 1,0 Type Library il Help |
[ 11-) WideoSoft weCcxd Contrals

[l ahanFditarSerintinn 1.0 Tvne | iheaes |

& i | ¥

~Microsoft Office 12,0 Object Library

Location:  Ci\Program Files\Common FilestMickosaft sharedOFFICEL 210
Language: Standard
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3 Getting Started

Creating the Base Template

5. To load the ThermoReportAddIn reference, do one of the following:

When ThermoReportAddIn is selected in the Available References list, it is correctly
set up. Click OK.

When ThermoReportAddln is in the Available References list but not selected,
select the check box, and click OK.

Tip Scroll down to find it; unselected references are listed alphabetically.

When ThermoReportAddln is not in the Available References list, manually add it

as follows:

i.

if.

iil.

iv.

V.

vi.

Click Browse.
Navigate to the C:\Program Files\Microsoft Office\Office12\Library folder.
Change Files of Type to All files(*.*).
Select the Thermo Report Add-In.xla add-in file.

Click Open.
The application adds ThermoReportAddIn to the Available References list in
the References dialog box.

References - VBAProject

fevailable References:

v| Yizual Basic For Applications
v Microsaft Excel 12,0 Object Library
[w| OLE &utomation
v Microsoft Cffice 12.0 Object Librar
=
[ I Microsoft Forms 2.0 Object Library
| Microsoft Windows Common Contrals 6.0 (SP&)
I Microsoft ML, wE.0
165 Helper COM Component 1.0 Type Library
[] 185 RADIUS Protocal 1.0 Type Library
[]:-) Componentone Awkione Contral
-1 WideoSoft waFlexarid 7.0 (Light)
|-} ¥ideoSoft wsOcxé Controls
ahanFdibneserintinn 1.0 Tene | ikrars

£ [

—ThermoR eportaddIn

Location:  Ci\Program FilesiMicrosoft OFficel Officel 2iLibraryt Thermo Re

Language: EnglishfUnited States

|

[£

+|

Pricrity

+

Figure 5. References - VBAProject dialog box with ThermoReportAddin

04

Zancel

Browse, ..

Help

e Bl

Select the ThermoReportAddIn check box and click OK.
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3 Getting Started
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The Microsoft Visual Basic application loads the ThermoReportAddIn project into the
Visual Basic dialog box.

Figure 6. Microsoft Visual Basic dialog box with ThermoReportAddIn

= Microsoft Visual Basic - Thermo Report Add-In.xla
: File Edit Miew Insert Format Debug RBun Tools Add-Ins Window Help

‘R - %2 @BRTC o uom "’&’x @ -

Project - ThermoReportAddIn E

=l= .
ERA ThermoReportaddIn {Thermo Report Add-In.xla) Jji
= ﬁ ¥BAProject (Book1) [

E]- 5 Microsoft Excel Objects
¢ B sheetl (Sheet1) o

x| |

Alphabetic ICategDrized I

Note The ThermoReportAddIn project is password protected. When you try to
expand the project by clicking the plus (+) sign, it prompts you for the password. The
add-in was designed so that most users do not need to change it to create their custom
reports. If you must change the add-in behavior, contact your Thermo Fisher
Scientific representative for the password.

The ThermoReportAddIn project is now referenced in your project, but until you use the
add-in project, it is not part of your template. When you exit the Excel application without
first using the add-in project and then reopen it, you will not see this reference again.

You are now ready to use the add-in to ensure that the add-in project is associated with your
template.

< To connect the basic elements to the add-in component
1. Double-click ThisWorkbook in the VBAProject.
The code editor pane opens.

2. Enter the following code in the code editor:

Private Sub workbook_open()
Set mIUtil = New MyUtil
End Sub
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Figure 7. Workbook code editor

<& Microsoft Visual Basic - ThermoCustomReportBaseTemplate.xlim - [ ThisWorkbook (Code)] |
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When you open the workbook, the application calls the MyUtil function.

The code connects the MyUstil function to the process and implements the IUtil interface.
The function connects your template to the add‘-in component.

You are now ready to add the ProcessData and Validate subroutines to the template. For more
explanation on these two functions, see Chapter 2, “Overview.”

% To add a module to the project
1. Right-click the VBA project and choose Insert > Module from the shortcut menu.

The application adds a folder named Modules to the project, adds a module named
Modulel to the folder, and opens a code editor.

Figure 8. Module1 code editor

‘d Microzoft Vizual Basic - ThermoCustomReporiBaseTemplate, xltm - [Module (Code)] |! | rbr__}g
4 File Edt View [Inset Format Debug Run  Took AddIns  Window Help - & X
HE-E f a9 e o noE e NFY O ® o
oty =] l{mocursony =]
g 5 4 ] pprion Explicic =
+ B ThermoReportaddIn {Ther
= B veaproject (ThermoCustor " Called after xml data gects imported
= 55 Mcresoft Excel Objacts Public Sub ProcesaDatai)
Shest] (Shastl)
Shest? (Shest2) | End Sub
Shest3 (Sheet3)
This'sorlkbook ' Yalidate the template design =.g. named rang
= 25 Modules Public Function Validate (Optional showWarning
5% Mosdule Validate = True * Return® True =0 that dat
# (23 Class Modules End Function
+ [T References
¢ y =@ | i
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2. Enter the following code in the Modulel code editor:

Option Explicit
Public Sub Processbata()
End Sub

Public Function validate(Optional showwarning As Boolean = True) As
Boolean
validate = True

End Function

The ProcessData and Validate subroutines are the most fundamental functions in your
template.

* Validate() is called before the XML data source is loaded into the spreadsheet to
verify that everything on the design interface is correct (for example, if name ranges
are intact). This function must return True to be able to import data. If it returns
False, you see an error message explaining the problem.

* ProcessData() is called after the XML data source is imported and ready for further
processing (for example, to extract data).

You are now ready to add functions that give you control of headers and footers in your
reports. The ThermoReportAddIn function has a default implementation of this interface
using mIUtil.

To add a MyUtil class to the project

1. Right-click the VBA project and choose Insert > Class Module from the shortcut menu.

The application adds a Class Modules folder and Class1 module to the project and opens

a code editor.

2. To change the Class1 name to MyUztil, do the following:

a. Select Classl.
b. Choose View > Properties Window.

The Properties pane for Class1 opens.
—|-E5 Class Maodules

[# Classt W
1 MLkl 7
Properties - Class1 K
[Class1 ClassModule -

Alphabetic lCategnrized ]

Class1
Instancing 1 - Private

c. Change Class1 to MyUtil and press ENTER.

d. Close the Properties pane.
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3. Double-click MyUtil to open the code editor.
4. Enter the following code in the MyUtil code editor:

Ooption Explicit
Implements IUtil
Private Sub IUtil_Processbata()

ProcessData
End Sub
Private Sub IUtil_SetupPageFooter()
mutil.SetupPageFooter "", 0.5
End Sub

Private Sub IUtil_SetupPageHeader()
muUtil.SetupPageHeader
End Sub
Private Function IUtil_validate(Optional showwarning As Boolean =
True) As Boolean
IUtil_validate = validate(showwarning)
End Function

Figure 9. MyUtil code editor

B

<& Microsoft Visual Basic - ThermoCustomReportBaseTemplate.xltm - [MyUtil (Code])]

‘@ File Edit View Insert Format Debug Run Tools AddIns  Window Help =
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[= @?BnPrnject (ThermoCustor Private Sub IUtil ProcessDatal)
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Sheet? (Sheet2) Priwvate Sub IUtil SetupPageFooter ()
B Sheet3 (Sheet3) wlitil.3etupPageFooter ™", 0.5
3% Thisworkbook End Sub
=125 Maodules Private Sub IUtil SetupPageHeader ()
i g Modulel mwlitil.SetupPageHeader
=5 Class Madules End Sub
N Priwvate Function IUtil Validate (Optional sw
[+ 77 References ITcil Validate = Validate (showlWarning)
End Function
-

. | 3 |=E | o

The ProcessData, SetupPageFooter, SetupPageHeader, and Validate functions in the IUtil
interface give you more control on the template level.

You are now ready to map the XML data file to the template. To do this you must have a
RawFileName_SampleCentricData.xml file.
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When you created a custom report in the TraceFinder application, the application created a
RawFileName_SampleCentricData.xml file that acts as a data source file for the custom
reports. The sample-centric data is usually located in the Data folder of the batch. For
example, C:\Thermo\TraceFinder\Projects\Subprojects\Batches\Batches\
ML_BATCH_01\Data.

If you do not have the TraceFinder application installed, you can use any
RawFileName_SampleCentricData.xml file to create the report templates in this tutorial.

< To associate the template with the schema of the data source
1. Close the Microsoft Visual Basic project.

2. In the Excel spreadsheet, click the Developer tab to display all the Developer functions.

3. Click Source, E .

Source

The spreadsheet displays the XML Source pane. You can drag mapped nodes from the
XML Source pane to the spreadsheet.

By default, the Excel application automatically creates three sheets. Only two are visible in
the following example.

Figure 10. Excel spreadsheet with XML Source pane

(a (R I e SR ThermoCustomReportBaseTemplate.xltm - Microsoft Excel = ml
e tigs = —
Home Inset  Page layout  Formulas Data Review View | Developer | Adddns @ - =@ X
— 3 Record Macro |_'?'~'_-l % Properties E i}l".lap Properties [T Import
; l—Ej ﬁ Use Relative References 3 s i Q’,?]Vim Code k : i..‘g Expansion Packs v_«;,' Export
WVisual Macros Insert Design Source, .
Basic ‘ﬁMacru Security - Mode # Run Dialog || | “® Refresh Data
Code Controls XML
H3 - (> £ | ¥
| A B | & D XML Source .
1 #ML maps in this workbook:
2| v
3|
4 -
5 4
b [ This workbook dogs naot contain any ¥ML maps. Click XML Maps ko
7 add an ML map to this workbook,
g ' [Optinns v] [XML Maps... ]
F;I. . verify Map for Export
M4 4 » v | Sheetl - Sheet2 [l
Ready| B |
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. Click XML Maps.

The XML Maps dialog box opens.

XML Maps X]

%ML maps in this workbook:

MName Foak MNamespace

. Click Add and navigate to the following file:

RawFileName_SampleCentricData.xml

You might get the following warning message:

Microsoft Office Excel

. The specified ¥ML source does not refer ko a schema. Excel will create a
\_:!-‘) schema based on the XML source data,

[11n the Future, do not show this message.

. Select the In the Future... check box and click OK.

The application adds the imported schema to your XML maps list.
Figure 11. XML Maps dialog box with the XML map

XML Maps ?X

¥ML maps in this workbook:

MName F.oak Mamespace
SampleCentricExportBatch_Map  SampleCenkricExportBatch <o Mamespace =

£ - | 3

(8] 4 ]’ Cancel ]

Eename. .. ]

o

. Click OK.

The Excel application adds the XML map to the XML Source pane.
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Figure 12. XML Source pane with XML map
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8. Scroll through the XML Source list to see the available data fields.

The template is now ready to use for creating reports. You are now ready to save the template
to use for all the custom reports in this tutorial.

% To save the Excel workbook as a macro-enabled template
1. Click the Office button, @, and choose Save As.

By default, the Excel application tries to save this workbook as an Excel Workbook
(*.xIsx), which is a spreadsheet without macro support.

2. Change the Save as Type to Excel Macro-Enabled Template (*.xltm).

3. Change the File Name to ThermoCustomReportBaseTemplate.
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Figure 13. Save As dialog box with the template file type specified
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Note By default, the TraceFinder application uses only the Excel application
templates in the folder C:\Thermo\Shared\Templates\Reports.

This template serves as the base for custom report templates in this tutorial. Throughout this
tutorial, add the prefix “My” to your custom report templates to avoid a naming conflict with
the delivered reports.

Figure 14. Completed base template
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Working with Columns

This section describes the procedures you can use to add, insert, move, or delete a column.

< To move a column in a data table
1. Click the column header to select the column.
2. Hold the cursor on the border area of the selected column.

Flag

3. When the cursor changes to the four-way arrow, drag the column to the new location.

* When you drag the column to an empty column, the contents of the dragged column
replace the empty column.

* When you drag the column to an occupied column, a warning dialog box asks if you
want to replace the contents of the destination column.

< To insert an empty column in a data table

1. Right-click an adjacent column header and select any of the commands from the Insert
menu.

The Excel application inserts an empty, unmapped column to the left or right of the
selected column. By default, the new column is named Columnz.

2. Drag a tree node to the empty column.

Note The Excel application prevents you from inserting a new column by directly
dragging a tree node into the middle of the data table; instead, you must drag a node to an
empty column and overwrite the empty column or drag the node to the beginning or end
of the data table and move it later.

When you attempt to overwrite a mapped column, you get the following error message:

Microsoft Office Excel

! E The operation cannot be completed because the cell or table column is already mapped,

22 TraceFinder Custom Reports Tutorial Thermo Scientific



3 Getting Started
Working with Columns

Note If you get the following error message, click Match Element Data Type to dismiss
it.

Microsoft Office Excel

The data that wou are attempting to map contains Formatking
' "_». that iz incompatible with the Format specified in the worksheet,

[ IUse existing Formatting ] [Match element data tvpe ] L Zancel |

If you are concerned that your node is not correctly mapped, there are several ways to verify a

mapped node.

% To verify a mapped field in the template
Do one of the following:
¢ Select the column.

When the column is mapped to a tree node, the Excel application selects the mapped
node in the XML Source tree and displays it in bold.

* Select the mapped node in the XML Source tree.

All mapped nodes are displayed in bold font. When the node is mapped to a column,
the Excel application automatically selects the column in the data table.

When you insert an empty column and then drag an XML Source node to the empty column,
the default column header does not change.

Note A “node” in the XML Source tree creates a “field” in the spreadsheet.

% To restore a mapped name to a column header
Select and delete the default cell name, for example Columnl.

Because a column header in a data table cannot be empty, the Excel application
automatically uses the mapped node name.

< To delete an entire column from a data table
Right-click the column header cell and choose Delete from the shortcut menu.
< To delete a portion of a column in a data table
1. Click the column header to select the column.

2. Right-click the column and choose Delete > Table Columns from the shortcut menu.

Note Do not press the Delete key to delete the column.
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< To remove the mapping from the XML Source tree
1. Select the node in the XML Source pane.

2. Right-click the selected (bold) node, and choose Remove Element from the shortcut
menu.

The Excel application removes the link between the node and the data table column. It
does not delete the data table column. The data table column is unmapped and the
previous mapped name remains.
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3 Getting Started
Security Settings

For the macro-enabled templates to run in the Excel application, you must add the directory
of the add-in and the template files to the list of trusted locations.

. Click the Office button, "/@ , and click Excel Options,

When you installed the TraceFinder application, the default template folder,
C:\Thermo\Shared\Templates\Reports, was added to the Excel application’s list of trusted
locations. The default security setting works as long as you run your templates from this

folder.

When you want to save your templates to a different folder, you can add that folder to the
trusted locations.

To add a folder to the Trusted Locations list

[] Excel Options

The Excel Options dialog box opens.
Click Trust Center, and then click Trust Center Settings.

The Trust Center dialog box opens.

Figure 15. Trust Center dialog box
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3. Click Trusted Locations.

4. Click Add New Location and navigate to the location of your folder.

5. Click OK in the Microsoft Office Trusted Location dialog box.

Thermo Scientific
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6. Click OK in the Trust Center dialog box.

7. Click OK in the Excel Options dialog box.

Your macro-enabled templates can now run in the Excel application.
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Testing the Template

Thermo Scientific

You are now ready to run a test from the Windows Start > Run box. In this test, the code you

enter does the following:

* Opens the Excel application.

* Creates a new workbook using the ThermoCustomReportBaseTemplate.xltm template.
* Dasses the parameters to the template.

* Generates a report based on the 1ngrep5_SampleCentricData.xml source file.

* Saves the report to the ThermoCustomReportBaseTemplate.xlsm file.

Note Because you did not map any nodes from the XML Source tree to your spreadsheet,
the Excel application displays an error that “no elements have been mapped.” You can click
OK to dismiss this error and continue to generate an empty report, or you can temporarily
map a node before you begin this test. For instructions on adding a mapped node, see

“Adding a Temporary Node to the Template (Optional)” on page 29.

2
0.0

1.

2.

To run the test

Choose Start > Run.

The Run dialog box opens.

= Type the name of a program, Folder, document, or
5 Internet resource, and Windows will open it Far you,

Open: | vl

Zancel ][ Browse. .. ]

Enter this code in the Open box:

Excel.exe /n "C:\Thermo\Custom Report
Tutorials\ThermoCustomReportBaseTemplate.xTtm"
/x/C:\Thermo\Custom|Report|Tutorials\Data\lngrep5_SampleCentricbata.Xx
ml/C:\Thermo\Custom|Report|Tutorials\Reports\MyThermoCustomReportBase
Template.xIsm/s/h

Where:

* The /n switch tells the Windows operating system that you are using this template to
create an Excel spreadsheet, not editing the template itself. Without this switch, the
Excel application would open the specified template for editing.

* You must enclose the template file path in quotes when there are spaces in it, for
example:

"C:\Thermo\Custom Report Tutorials\MyReportName.xTtm"

Otherwise, the Excel application considers each item separated by a space as a
separate Excel workbook and tries to load it (causing an error).
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The space before /x tells Windows to pass everything after this space to the Excel
template. Do not add quotes after this space; otherwise, Windows considers this as a
second spreadsheet to open (causing an error).

The /x switch is an internal switch specific to custom reports. The Thermo Custom
Report Add-In utility processes all the parameters after /x.

Parameters after /x cannot contain spaces. When you need a space, use a vertical bar

«|>

’ instead. The vertical bar is replaced with spaces in the add-in. The following
example shows use of the vertical bar in the Custom Report Tutorials folder:

.../x/C:\Thermo\Custom|Report|Tutorials\...

Custom parameters after /x use a slash “/” as a separator. The first two parameters
after /x are required; all others are optional.

—  The first parameter after /x tells the add-in the path of the XML Source data.
The template location does not matter, as long as you correctly specify the path.
However, for the TraceFinder application to use the template, the template must

be located in the dedicated folder.

—  The second parameter after /x tells the add-in the path of the generated Excel
spreadsheet.

The /s parameter tells the add-in to save the file (the second parameter) before closing
the spreadsheet. Without this switch, the spreadsheet is generated but not saved.

The /h parameter tells the Excel application to hide the screen update. This makes
the report generation faster and reduces screen flashes. However, if you want to debug
the template, you must remove this switch.

The Thermo Custom Report Add-In supports additional controls and parameters
that affect how reports are generated. For a complete list of parameters, see “How Do
I Use the Command Line to Generate the Excel Report?” on page 175.

Tip By default, the TraceFinder application file structure results in a long file path.
The Windows Run dialog box limits you to 256 characters. To work around this
limitation, either copy files to a folder close to the root directory or put the command
line into a batch file.

You are now ready to use this base template to create any of the custom report templates in
this tutorial:

* Chapter 4, “Creating a Batch Report.”
* Chapter 5, “Creating a High Density Sample Report.”
* Chapter 6, “Creating a Calibration Report.”

* Chapter 7, “Creating a DCC Report.”
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Adding a Temporary Node to the Template (Optional)

When you tested the template, you likely saw this error message: “No data was imported
because no elements have been mapped.”

This error occurred because you did not use any nodes from the XML map in your template.
In this optional exercise, you will add a node from the map and generate a report to show that
you have mapped elements in your template.

< To add a mapped field to the template

1. Click the Developer tab to display all the Developer features.

2. Click Source, E .

Source

The spreadsheet displays the XML Source pane. You can drag mapped nodes from the
XML Source pane to the spreadsheet.

3. From the XML Source tree, drag at least one node to any cell on your spreadsheet.
You can drag as many nodes as you like.

4. Save the template.

IMPORTANT You must remove these mapped fields from the base template before

you use it to create any of the custom reports in this tutorial.

5. Repeat all the instructions in “Testing the Template” on page 27.

The resulting report displays the nodes that you added to the spreadsheet. In this example, the
node InstrumentName was mapped to cell Al.

Figure 16. Example report

G::x = & | ¥ ThermoCustomReportBaseReport_20100811145840.xsm [Group] - Microsoft Excel e — i
= -
Home Insert Page Layout Formulas Data Review View Developer Add-Ins W - X
% | Calibri 11 - || ol S (Te “Iil A = o | 1 R }}
'y il 5l
= a2 |B I OD-A A | EEE - $o= Yaed : ol [ bt :
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Note Unlike Crystal Reports in the TraceFinder application, custom reports can have a
time stamp in their names. Custom reports do not overwrite existing reports. When you
generate a report the first time, no time stamp is added to the file name. If you generate
the same report again, the application adds a time stamp to the name of the new report.

You are now ready to integrate the template into the TraceFinder application to see what a
custom report looks like when generated from the application.
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Adding a Temporary Node to the Template (Optional)

2
0.0

To use the template in the TraceFinder application

1. Copy your new template into the dedicated folder of the application:

C:\Thermo\Shared\Templates\Reports

2. Use this template the same way as you would for the other delivered reports in the

TraceFinder application. For detailed information about how to use custom reports, refer
to the TraceFinder User Guide.

To make ThermoCustomReportBaseTemplate.xltm the base template in this tutorial, you
must remove the temporary mapped fields.

*»*

1.

To remove the temporary mapped fields

Right-click the upper left corner cell.

—&?j Home In
T29
Right-click here, ——— A

Choose Delete from the shortcut menu.

The Excel application removes all data on the spreadsheet. Choosing Delete removes the
text in the cell but does not remove the mapping.

Save the template.
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Creating a Batch Report

In this chapter, you will create an Excel template for a batch report similar to the standard
Batch Report delivered with the TraceFinder application.

Contents

* Opening the Report Template

Adding Labels, Mapped Fields, and Mapped Tables

Adding Empty Columns

Completing the Layout

Adding VBA Code

Testing the Template

A Batch Report in the TraceFinder application is a batch-level, summary report that lists all
samples and certain properties in a batch.

Figure 17. Sample batch report template
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Opening the Report Template

A batch report highlights many concepts and principles used for creating custom reports. In
this tutorial, you will learn the following:

* How to add static labels

* How to add data fields from the XML Source map

* How to add a list (or table) field from the XML Source map
* How to add and use an empty column in the data table

* How to add and use a hidden column in the data table

* How to add and use named ranges to reference data

* How to use the interface exposed by add-in components and write basic VBA code to
connect the template to the add-in

* How to use the Start > Run command to generate the report.

Opening the Report Template

For the following procedures, use the ThermoCustomReportBaseTemplate.xltm file that you
created in Chapter 3, “Getting Started,” as the basic template.

< To begin your batch report template

In Windows Explorer, make a copy of the ThermoCustomReportBaseTemplate.xltm file
and name the new copy MyBatchReport.xltm.

< To load the template file from the Excel application
1. Open the Excel application.
2. Click the Office button, DE’ and choose Open from the menu.

3. In the Open dialog box, select MyBatchReport.xltm and click Open.

< To load the template file from Windows Explorer

In Windows Explorer, right-click the MyBatchReport.xltm file and choose Open.

IMPORTANT Do not double-click this template file in Windows Explorer because,
instead of opening the template for editing, you create a new spreadsheet based on this
template.
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Adding Labels, Mapped Fields, and Mapped Tables

In the following procedures, you will create and name the static column headers in your
template, add mapped fields, and add a mapped table.

% To enter static labels for the report heading
1. Type Batch Report in cell B1.
. Type Lab name: in cell B3.

. Type Instrument: in cell B4.

N N

. Type User: in cell B5.
. Type Batch: in cell B6.
. Type Method: in cell H3.

NN W

. Type Cali File: in cell H5.

8. Press CTRL and select each of the labeled cells.

9. Right-click and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.

10. Click the Font tab to open the Font page.
Figure 18. Font page in the Format Cells dialog box

Format Cells

| Murnber || Alignment I Fonk | Border || Fill || Prokection |
Font: Font skyle: Size:
Calibri Regular 11
ambria (Headings - g -
| Tkalic q =
El ddobe Gararmond Pro Eild 10 —
B adobe Garamond Pro Bold Eold Ikalic
nderline: Colar:
|N|:|ne V| |_ Y| [+] Mormal Fant
Effects Prewview
[ strikethrough
[ superscript - AaBbCcYyZz ]
[] subseript

[ 04 ] [ Cancel

11. In the Font Style box, select Bold.
12. Click OK.
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Ensure that your template looks like the following example.

Figure 19. Template with static labels

-G MyBatchReport.xltm - Microsoft Excel i
: Home | Insert Page Layout Formulas Data Review View Developer Add-Ins @ - =
=1 X | calibr bt P |= = = General - || B conditional Formatting = | 5*=Insert - x - ? Eﬁ
_j Er |B L S 4 'HA‘ A'| |§' | § =B e | ﬁFormatasTﬁbte' 4 Delete = @'
Paste i i e T == S = 5 . Sort& Find &
w F |||Em) S| |3E £E|| 3~ | %0 20 5 cell Styles - [ZlFormat ~ | 27 Fittar~ Select~
|| Clipboard ™ Font {F] Alignment (Fi Number T styles Cells Editing
| us < (i fx | caliFile: &
| 4/ B c D E ol o6 R 1 K L 3
il Batch Report
2
I3 | Lab Mame: Method:
4 Instrument: =
5| User: I{:ali File: !
B Batch:
? 4
W 4 b | Sheetl <Sheet? ~ Sheet3 , Fd T B — _]l
Ready | 9 | HE"@ 100% ; a1

Note You start from column B instead of column A because later you will use column A

as a hidden column.

Note You can fix any column size issues and fine-tune the format at the end, after all the

elements are in place.

You are now ready to use the XML Source pane to add mapped fields to your template.

Tip Before proceeding, make sure the Excel window shows the Developer tab, which is
hidden by default. If your Excel window does not show the Developer tab, see Chapter 3,

“Getting Started.”
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% To add mapped fields to the template
1. Click the Developer tab.
The ribbon expands to display the Developer features.
2. Click the Source button, IE .

Source

The spreadsheet displays the XML Source pane. You can drag mapped nodes from the
XML Source pane to the spreadsheet.

Ensure that your template looks like the following example.

Figure 20. Template with XML Source pane

|’/3 HY-o G+ MyBatchReport.xitm - Microsoft Excel - m X
> Home Insert Page Layout Farmulas Data Review View Developer Add-Ins '@ - =
o ] Recard Macro |'E‘l b [ Properties % Map Properties [ Import
: B E.E Use Relative References e Q;'J\-fiew Code | fﬁ Expansion Packs ﬁﬂd Export
Visual Macros : Insert Design ; s
R i Macro Security +  Mode B RunDialog 9} Refresh Data
Cade Contraols XML
H5 - | caliFile: &
| A B c D £ Eii H & ML Source ¥ x
B Batch Report “ML maps in this warkbook:
2 |SampIeCentricExportBatch_Map »
3 ] Lab Name: Method: = lj SampleCentricExportBatch R
4 | Instrument: = =[5 BakchHeaderData =
= User: ICaIi File: .I (=] BatchFolderPath
& Batch: i ._] Batchiamne
i =] BatchState
7| ] CalibrationFile
8 | (2] Instrumentarne e
9 £ | ¥
10 To map elements, drag the elements from the
5 1 tree onka your worksheet,
| Oplions - “ML Maps. ..
= [options ~ | | v maps.. |
i =l]——==— === I} Werify Map For Export. ..
M 4 » ¥ | Sheetl -~ Sheet2  'Sheet3 . ¥1 ¢ [/ m [ A |
Ready | 3 |55 O 2003, (~)

Thermo Scientific

Before you begin creating a template for any report, identify the data points on the report
and understand how they map to the nodes in the XML Source tree.

Note A “node” in the XML Source tree creates a “field” in the spreadsheet.

You are ready to create mapped fields from the nodes in the SampleCentricExportBatch
folder by dragging the nodes from the XML Source tree to the appropriate table cell.

3. Open the MethodHeaderData folder and do the following:
a. Drag the LabName node to cell C3.
b. Drag the InstrumentMethodName node to cell C4.
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Ensure that your template looks like the following example.

4. Open the BatchHeaderData folder and do the following:

a. Drag the UserName node to cell C5.

b. Drag the BatchName node to cell C6.

5. Open the MethodHeaderData folder and do the following:
a. Drag the MethodName node to cell I3.

b. Drag the MasterMethodName node to cell 14.

6. Open the BatchHeaderData folder and drag the CalibrationFile node to cell I5.

Figure 21. Template with mapped fields

I.-’i;-uD s Bl e T MyBatchReport.xltm - Microsoft Excel I
k2 -
> Home Insert Page Layout Farmulas Data Review View Developer Add-Ins '@ - B X
ey 3 Record Macro |-* 3 %f Properties v@ 5 Map Praperties [Tl Import
- =7 ﬁ Use Relative References PN it Gl view Code i | & Expansion Packs &f'] Export
Visual Macros ; Insert Design : Source_,_.a
Basic i\. Macro Security - Made # Run Dialog -ERefresh Data
Code Contrals XML
15 - £ | -
. B c D : F G H | .| ¥ML Source v x
155 Batch Report #ML maps in this workbook:
2 | |SampIeCentricExportBatch_Map w
3 |Lab Name Method: ~ ] BatchName =
4 |Instrument: = (5] Batchstate =
5 |User: cali File: =
I 5 -Batch: : _I Instrumenthame
i & LocalMethodMame
7| =] ProjectMame
g | =] SubprojectMame bl
5 £ | >
10 To map non-repeating elements, drag the
i elements from the tree onta the worksheet
11 | where you want the data to appear.
12
. — = ————=——a To import data, use the Import XML Data bukkan
M 4 » vi| Sheetl Sheet? “Sheet3 ¥l [ m s 4 |
Ready | 73 == O/ to0ssy :
Tip The mapped field on the spreadsheet is shown in a blue box as long as the XML
Source pane is visible. The mapped node in the XML Source tree is highlighted in bold.
Note You can use each node in the XML Source tree only once. In future tutorials where
the same field is used more than once, you will work around this limitation by importing
the same mapping schema as many times as needed.
You are now ready to create the sample list for the batch. The sample list is presented in a
mapped data table. In the Excel application, you can drag the mapped table fields from the
XML source pane.
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You are ready to create mapped fields from the nodes in the
SampleCentricExportBatch/Samples/SampleCentricExportSample folder by dragging the
nodes from the XML Source tree to the appropriate table cell.

< To add a mapped table to the template

1. Drag the RawFileName node to cell BS.

2. Drag the AcquisitionDate node to cell C8.

Ensure that your template looks like the following example.

Figure 22. Template with mapped tables

M 4 » ¥ | Sheetl - Sheet? ~Sheet3 .~ 7.

Ready S

II-/B = R [ = MyBatchReportxltm - Microsoft Excel Table Tools = = oA
e | =
> Home Insert Page Layout Farmulas Data Review View Developer Add-Ins Design '@ - 3 X
Table Name: i3] Summarize with PivatTable % ﬂj B | ¥ Header Row First Column = |
| mt
Tabled I,}*' Remove Duplicates | " Total Row Last Column
; o Export Refresh ; Quick
«[ Resize Table || 5] Convert to Range - - e || ¥ Banded Rows Banded Columns Styles ~
Properties Tools External Table Data Table Style Gptions Table Styles
cs - £ | ¥
| B C D E F H _iXML Source bl 3
B Batch Report “ML maps in this warkbook:
2 |SampIeCentricExportBatch_Map Vl
3 Lab Name: Method: OB Samples %
4 Instrument: = =l SampleCentricExportSampls —
5 User: Cali File: =N AcquisitionDate
& |Batch: : Acquisitioris 1D
1 -| applicationamplaType
7 =] BaseSamplebare
.g Acqmmtlun[)ate H [E] CorversionFackar By
9 | < | b3
10 | To map repeating elements, drag the elements
1 fram the tree onko the warksheet where vou
11| want the data headings to appear.
12

Toimpork =ML data, right click an XML mapped
w

Note The spreadsheet displays mapped fields differently from mapped tables (a list).
You can see this difference in the XML Source tree: A regular node has a regular folder
icon, [5. A repeating or collection container node has a folder icon with an extra

small arrow pointing down, |57 . For example, in a batch, there is only one set of
BatchHeaderData (regular node), but you can have many samples and each
SampleCentricExportSample (repeating node) represents one of them.

You can now create additional mapped fields from the nodes in the
SampleCentricExportBatch/Samples/SampleCentricExportSample folder by dragging the

nodes from the XML Source tree to the appropriate table cell.

3. Drag the Sampleld node to cell D8.

4. Drag the SampleName node to cell E8.

Thermo Scientific
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Drag the ApplicationSampleType node to cell F8.
Drag the VialPosition node to cell G8.

Nooow

Drag the InjectionVolume node to cell H8.
8. Drag the ConversionFactor node to cell 18.
9. Drag the SampleComments node to cell J8.

Ensure that your template looks like the following example.

Figure 23. Template with mapped fields and tables

) iﬂf}" t ul = MyBatchReport.xltm - Microsoft Excel Tahte ook - =

Home Insert Page Layout Formulas Data Review View Develaper Add-Ins Design '@ - =

Table Mame: i3] Summarize with PivotTable g gj @ || W] HeaderRow [ First Column ﬁ
L

Tabled Eﬂ Remaove Duplicates Total Row | Last Column

=

= Export Refresh . i _ Chuick
+C* Resize Table u‘tl Convert to Range - - £2 || ¥ Banded Rows || Banded Columns Styles =
Praperties Tools External Table Data Table Style Options Table Styles
F8 - '.i"- I | ApplicationSampleType ¥
- il E \;/ G H | JiXML Source W
] Batch Report #ML maps in this workbook:
2| |SampleCentricExpnrtBatch_Map v |
3 | Method: BI@ SampleCentricExportSanmple A
22 | = ‘5 AcquisitionDate —
5 Cali File: =| AcquisitionEUID
5 [ ApplicationSampleTyp
- 5 i 5| BaseSarnpleMarne
Uit =| ConversionFactor
a In'ectiun\n}llﬂ' =] FilelD b
g £ [ | >
10 To map repeating elements, drag the elements
S fram the tree onto the worksheet where you
11 wank the data headings to appear.,
12

M 4 » b | Sheetl < Sheet? . Sheet3 , ¥J
CReady | &3 |

Toimport XML daka, right click an %ML mapped

| = |

This template, compared to the final one, has two columns that are missing. The final
template shows an empty column at C and a Level column at G. Those two columns are
important concepts in creating the custom reports. The next two procedures explain these
columns.
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4 Creating a Batch Report

Adding Empty Colum

ns

When you use the Excel application as a reporting tool, you might need to adjust the size of

columns. In a spreadsheet, a column must run from top to bottom with the same width,
because the Excel application does not support the concept of sections. Sometimes, however,

you need more space only for some rows but not others.

When a data table is not involved, you can make columns smaller and leave space between
them as needed. However, when a data table is on the same sheet, you cannot use this method.
For more details, see “Why Do So Many Data Tables Appear on My Spreadsheet?” on

page 192.

As a workaround, you can add empty columns to the data table. An empty column can

provide the extra space needed for the previous column, where the text can run over into it.
Usually, you would add hidden columns instead of empty columns because you cannot use
the XML source data field directly in a linked table.

In this sample list, the RawFileName column needs more space. However, you do not want to

make column B too wide because you do not want to leave too much space between the label
and the mapped field from B3 to C6. Adding an empty column next to the RawFileName
column resolves this problem.

< To add an empty column to the template

Right-click cell C8 and choose Insert > Table Columns to the Left from the shortcut

menu.

The application inserts an empty column at column C and names the column Columnl.

Ensure that your template looks like the following example.

Figure 24. Template with empty column
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il - (&) S MyBatchReportadtm - Microsoft Excel Table Tools - B
—‘) Home Insert Page Layout Formulas Data Review View Developer Add-Ins Design '.QJ - B X
Team ~ \‘A Mew List _. Get Waork Items ™ Publish 2| Refresh :.‘ onfigure List "’_ Chooze Calumns U Links and Attach
Team Praject Process Guidance 4 Add Column >< Remove Column ﬁ&cﬁdd Graphic Show Named Ranges « Validate ﬁ it
Menu Commands Custom Toalbars
D8 . f | AcquisitionDate ¥
| A B C D E F EXML Source v ®
1 | #ML maps in this workbook:
2 | iSampIeCentricExportBatch_Map vi
3| Lab Name: =l FampleCentricExportSample A
4 | Instrument: = =l AcquisitionDate --
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7| ! . = ConversionFactor
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Adding Derived Columns

You are ready to hide the mapped field in the first column and then use the Excel formula to
fill in the Level column. Now you want to make Column1 invisible. You cannot simply delete
it, because Excel requires that the column header be unique and not empty. A space character
is allowed as a valid header, so you can change “Column1" to a space character to hide it.

< To add a derived column to the template

1. Open the SampleCentricExportBatch/Samples/SampleCentricExportSample folder and
drag the SampleLevel node from the XML Source tree to cell A8.

The SampleLevel field has a value for the calibration standard sample type and is empty
for the non-calibration standard sample type. However, displaying SampleLevel in a
report requires the level column to show N/A instead of an empty field if the sample type
is not a calibration standard. Therefore, the SampleLevel field cannot be used directly.

The workaround for this problem is to make SampleLevel a hidden column and add a
derived column for display that uses an Excel formula to evaluate SampleLevel.

2. Right-click the ApplicationSampleType cell and choose Insert > Table Columns to the
Left from the shortcut menu.

|#] = Refresh
Insert k "l"_]] Table Columns to the Left !
Delete il I
Select , s
Clear Contents

The application inserts an empty column G before the ApplicationSampleType column
and inserts the header name Column2 into cell G8.

3. In cell GY, type the following formula:

=IF(A9="", IIN/AII’ A9)

This tells the table to show “N/A” when the SampleLevel at A9 is empty, and otherwise,
to show the SampleLevel value. You enter this formula at G9 only, but it automatically
expands to all the cells in this column when you import the data into this table.
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Ensure that your template looks like the following example.
Figure 25. Template with formula referencing a hidden column
ﬁ‘j [j MyBatchReportxltm - Microsoft Excel Table Toals - B X

DL
=

Team ~

Pagr@ymﬂ: Formulas Reuiey --. prer I A-ns | Design @ - 7 x
.J, MNew List =5 Get Waork Items J Publish ,_| ru=fre-'n ﬁ Jnﬂgule List _| Chogse Columns Llﬂ_| Links and Attach
4 Add Column }( Remove Column f-'lbcﬁdd Graphic EE Show Mamed Ranges « Validate ﬂ

Team Project Process Guidance
Team System Help

l Menu Commands | Custom Toolbars

| G9 - L. £ | =|F{A9="", “NfA", AB} ¥
' i E F I G | H | __|ixML Source ¥ X
15 Batch Report #ML maps in this workbook:
| 2 | |SampIeCentricExportBatch _Map vl
23| Method: =5 I.Q' SampleCentricExportSample A
35 | = -._—I AcquisitionDate -
5 Cali File: ] AcquisitionGUID
& [ =N ApplicationSampleTyp
: - I —| BaseSampleMame
ConversionFactor
S\_M sampleNameBd| Column2 VialPositi¢ FileID v
A =IF(A9="", "N/A", A9) & | -
10 To map repeating elements, drag the elements
ey from the tree onko the worksheet where wou
i 11 ] want the data headings bo appear.
12 |
__________ — To import %ML data, right click an %ML mapped
4 4 » M| Sheetl Sheet? - Sheet3 -~ ¥J : = i

Ready | 73 |

4. Change the cell format to the General type to use this column as a formula.

When you add an empty column, the cell type defaults to the text type. The text type
column does not expand when you import data. For more information, see “Why Does
My Formula in a Data Table Not Expand?” on page 201.

5. Right-click the column A header and choose Hide from the shortcut menu.

Tip You can hide any column in the Excel application. However, if you need hidden
columns for the TraceFinder custom reports, always use the first columns. A hidden
column in the middle of the table can cause trouble when copying blocks of data for
the repeating area.
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Completing the Layout

42

The following procedures show you how to rename the default table header names, name the

mapped table, and finish the layout.

By default, when you drop a node on the spreadsheet, the node name becomes the default
header name. You are now ready to rename the default header names. In the following
procedures, you will rename the default table header name.

*»*

1.

SRS

Nooow

10.
11.

To rename mapped table header names in the template

Change B8 from RawFileName to File Name.

. Change C8 from Column1 to “” (one space).

Change D8 from AcquisitionDate to Date/Time.
Change E8 from Sampleld to Sample ID.
Change F8 from SampleName to Sample Name.
Change G8 from Column2 to Level.

Change H8 from ApplicationSampleType to Sample Type.

Change 18 from VialPosition to Pos.
Change J8 from InjectionVolume to Inj Vol.
Change K8 from ConversionFactor to Conv Factor.

Change L8 from SampleComments to Comment.
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Ensure that your template looks like the following example.

Figure 26. Template with custom header text

l/cn H-™-F ) MyBatchReport.xltm - Microsoft Excel Table Tools - =
- Home Insert Fage Layout Formulas Data Reviewr View Developer Add-Ins Acrobat Design @ - =
3 Record Macro |_a'\ 3 [%F Properties .'E’ Map Properties Eﬁlmport
per} E Use Relative References ” @View Code fﬂ Expansion Packs g,q Export
Visual Macros Insert Design @
B 3\ Macro Security ~  Mode T RunDialog } Refresh Data
Code Controls XML
L9 - £ |
| B C D | E | F | G | H ¥ML Source v
1 Batch Report 2L maps in this workbook:
2 | SampleCentricEx portBatch_Map
3 |Lab Name: Method: [ -2 ReinjectionIndex ‘
4 Instrument: [ B -roplccomment B
5 |User: Cali File: [ =] sampleld
6 |Batch: ] Samplekey
~(=] SampleLevel
7 ] SampleName
8 ﬂ Date/Time ﬂ Sample ID ﬂ Sample Nam-uﬂ Level ﬂ Sample T\‘rpuﬂ 3 = cw-luncwn -
9 | N/A : =
. . To map repeating elements, drag the
10 elements from the tree anko the
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12| )
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You are now ready to use the Excel named range feature to name the table in the template.
You can name a range of cells and then use the name to refer to this area.

When there is no data to display in custom reports, “No data in this report” appears on the
report. In this case, you also want to hide the data table completely. Two add-in components
can implement this functionality.

VBA code provides two ways that you can refer to cells: as direct cell ranges (for example,
Sheet1!A5:B6) or as named ranges. Named ranges has the advantage of providing more
flexibility in design.

In the following procedures, you will define two named ranges. First, define a named range
called “NoData” for cells where “No data in this report” is to be displayed. You will use an
add-in function to display this message.

Second, Excel automatically gives each data table a name, for example, Tablel. To reference
the table in the VBA code, change it to a specific name.
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< To name the data table in the template

1. Click the Formulas tab and then click Name Manager.
Note The Excel application automatically creates a name for all tables, such as Tablel

or Table2. Each time that you create a new table, it increments the table name, even if
you deleted a previous one.

2. In the Name Manager dialog box, double-click Tablel.

The default table name might vary. Use the sheet, row, and column numbers in the Refers
To column to verify the table.

The Edit Name dialog box opens.
3. Change the default name to DataTable.
4. Click OK.

You now have two names defined, as shown in this figure:

Figure 27. Name Manager dialog box with two named tables

MName Manager @@
Mew, .. Edit. ielete

Marme Walue Refers To SCope

T DataTable oy _Sheat] 144604049 Warkbook
E] MoData =sheet11$B47 Wiarkbook,
¥liv| |

You will later use VBA code to show “No data in the report” at cell B7 when the table is
empty. See “Adding VBA Code” on page 48.

5. Click Close in the Name Manager dialog box.

You are now ready to polish the layout of the template.

% To resize the columns in the template
1. Click the Page Layout tab to display the layout editing features.
1sert Page Layout Formulas Data Review Wiew
e = = mEr =l
= Bk = Ll F
=] =
Margins Crientation Size Print EBEreaks Background Print

2 s -  AmeaT T Titles Click to open the Page
Setup dialog box

Fage Setup ]
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2. Click the arrow in the lower-right corner to open the Page Setup dialog box.

Figure 28. Page Setup dialog box

Page Setup

| Margins " Header/Footer " Sheet |

Crientation
O Portrait & Landscaps
Scaling

&) adjust to: % normal size
) Fit ko pageis) wide by kall
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Print quality:; | A00 dpi w |

First page number:

Prink. .. ] ’F‘rint F‘revieg] [ Qpkions. .. ]

I Ok l[ Cancel ]

3. In the Page Setup dialog box, make the following changes:

a.

C.

d.

Click the Page tab and change the orientation from Portrait to Landscape.
For a Batch Report, the table is too wide to fit into portrait format.

Click the Margins tab and change the page margins to the following (all units are in
inches):

Top: 0.65, Left: 0.25, Right: 0.25, Bottom: 0, Header: 0.3, Footer: 0.3
Click the Header/Footer tab and select the Align with Page Margins check box.
Click OK to close the Page Setup dialog box.

4. Drag the dividers in the column headings to make all the columns fit within the page

range.

When you are in page preview mode, the right margin of the page is indicated by a
dashed line.
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< To change the background in the template
1. Click the header of the data table to display the Design tab.
2. Click the Design tab.

The Design tab displays the Table Styles functions.

Table Styles

3. Expand the Table Styles gallery and click Clear, [F3 Ciear | in the lower left corner of

the gallery.

The background changes to a plain background.

Ensure that your template looks like the following example.

Figure 29. Column width example with plain background
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4. To prevent the text in the last column of the page from running over its boundary and

creating a new page, do the following:
a.  Select the last column.
b. Right-click and choose Format Cells from the shortcut menu.

The Format Cells dialog box opens.
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Click the Alignment tab to open the Alignment page.
Figure 30. Alignment page in the Format Cells dialog box
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In the Text Control area, select the Wrap Text check box.

Click OK.

TraceFinder Custom Reports Tutorial

The template design is complete. You are now ready to add VBA code to connect the template
to the data.
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Adding VBA Code

For this Batch Report, you will add two functions using VBA code. These functions do the
following:

* Verify that the table named DataTable exists.

* When there is no data in the table, display “No data in this report” in the name range
defined as NoData.

% To connect the VBA data to the template
Add the following code to Modulel:
Option Explicit

Public Sub ProcessbData()

If Sheetl.ListObjects("DataTable").Range.Rows.Count = 0 Then
mutil.SetNobata "NoData"
muUtil.HideRows "DataTable" 'Hide all data area
End If
End Sub
PubTic Function validate(optional showwarning As Boolean = True) As

Boolean
Dim err_msg As String, info_msg As String, msg As String

Check required names
mUtil.CheckRequiredName err_msg, "DataTable", "'DataTable' must
be defined."

Display messages if any
mUtil.ShowErrMsg err_msg, info_msg, showwarning

validate = err_msg =
End Function

Where:
* JUtl_Validate() in MyUsil class calls the Sub Validate().

Before the source XML data is imported, IUtil_Validate() verifies that named ranges
are correctly defined. For example, if you add a column to a table or remove a column
from a table, you must update the associated named range so that the other functions
depending on this name range still work.

* Workbook_Open() in ThisWorkbook calls Sub ProcessDatal().

Workbook_Open() is called after the source XML file is imported. In the
Workbook_Open() code, the application checks if the table DataTable has any rows.
If not, it sets “No data in this report” to the name range NoData using the
SetNoData function defined in the add-in. In this case, it hides the DataTable rows
using the HideRows add-in function.
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5. To use the Visual Basic compile function to check for errors, choose Debug > Compile

VBAProject.

Ensure that your Visual Basic code looks like the following example.

Figure 31. VBA data
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You are now ready to use your template to generate a report.
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Testing the Template

Testing the Template

You are now ready to run a test from the Windows Start > Run box. In this test, the code that
you enter does the following:

* Opens the Excel application.

* Creates a new workbook using the MyBatchReport.xltm template.

* Dasses the parameters to the template.

* Generates a report based on the 1ngrep5_SampleCentricData.xml source file.

* Saves the report to the MyBatchReport.xlsm file.

< To run the test

1. Choose Start > Run.

The Run dialog box opens.

= Type the name of a program, Folder, document, ar
E Internet resource, and Windows will open it For wou,

Open: | vl

[ Cancel ][ Browse. ., ]

IMPORTANT By default, the TraceFinder application file structure results in a long
file path. The Windows Run dialog box limits you to 256 characters. If you exceed
the 256 character limit, the application truncates the text without warning, possibly
resulting in a failed operation.

To work around this limitation, either copy files to a folder close to the root directory
or put the command line into a batch file.

2. Enter this code in the Open box:

Excel.exe /n "C:\Thermo\Custom Report Tutorials\MyBatchReport.xltm"
/x/C:\Thermo\Custom|Report|Tutorials\Data\lngrep5_SampleCentricbata.x
ml/C:\Thermo\Custom|Report|Tutorials\Reports\BatchReport.xIsm/s/h

For detailed descriptions of the parameters used in this code, see “Testing the Template”
on page 27.

The generated report should appear on your screen as in the following figure (the actual data
might vary, depending on the batch that you used).
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Figure 32. Generated report
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You are now ready to integrate the template into the TraceFinder application.

% To use the template in the TraceFinder application
1. Copy your new template into the dedicated folder of the application:
C:\Thermo\Shared\Templates\Reports

2. Use this template the same as the delivered reports in the TraceFinder application.

For detailed information about how to use custom reports, refer to the TraceFinder User
Guide or Chapter 3, “Getting Started.”
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Creating a High Density Sample Report

In this chapter, you will create an Excel template for a high density sample report similar to

the High Density Sample Report 1 Long delivered with the TraceFinder application.
Contents
* Opening the Report Template
* Adding Labels and Mapped Nodes
* Creating a Repeating Area

* Adding Images to a Report

Creating a Temporary Data Sheet

Using Data in a Repeating Area

Adding VBA Code to the Template

Testing the Template

A high density sample report in the TraceFinder application is a sample-level report that

presents chromatograms of quantitative peaks and related results for each compound in a
highly condensed format.

Figure 33. Sample high-density report template
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5 Creating a High Density Sample Report

As you create a high-density sample report template, you will learn the following:
* How to use a data table on a temporary sheet
* How to add images to a report
* How to use a repeating area as a design interface that is duplicated at run-time
* How to use formulas with the data table to combine or reformat values

* How to duplicate sheets to create multi-sheet reports

* How to use the Start > Run command to generate the report
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Opening the Report Template

Opening the Report Template

Thermo Scientific

For the following procedures, use the ThermoCustomReportBaseTemplate.xltm file that you
created in the Getting Started section as the basic template.

R

< To begin your high density report template

In Windows Explorer, make a copy of the ThermoCustomReportBase Template.xltm file
and name the new copy MyHighDensitySampleReportl Long.xltm.

% To load the template file
1. Open the Excel application.
2. Click the Office button, ':13/ , and choose Open.

3. In the Open dialog box, double-click MyHighDensitySampleReport1Long.xltm.

Tip Do not open this template file from Windows Explorer because, instead of opening
the template for editing, you create a new spreadsheet based on this template.
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Adding Labels and Mapped Nodes

You are now ready to create and name the static column headers in your template.

56

Follow these procedures:

N N

N oW

To enter static labels for the report heading
To display the XML Source pane
To enter static labels for the column headers

To add mapped fields to the template

To enter static labels for the report heading

. Type the report header High Density Sample Report 1 Long in cell BI1.
. Type Lab name: in cell B3.

. Type Instrument: in cell B4.

. Type User: in cell B5.

. Type Batch: in cell B6.

Type Method: in cell K3.
Type Cali File: in cell K5.
Select cells B1 through K5.

Right-click and choose Format Cells from the shortcut menu.

The Format Cells dialog box opens.

TraceFinder Custom Reports Tutorial
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Adding Labels and Mapped Nodes

10. Click the Font tab to open the Font page.
Figure 34. Font page in the Format Cells dialog box

Format Cells |1||£|
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Fank: Font skyle: Size:
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ﬁ Carmbria EHeadinis:Il -~ a -
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Bl adobe Garamond Pro Eiold 10 =
B adobe Garamond Pro Bold Eold Italic
nderline: Calar:
|I"-.I|:une V| |_ v| [+] Mormal Font
Effects Prewview
[] strikethrough
[ superscript - AaBbCcYyZz
[ subscript
L ok J [ Cancel ]

11. In the Font Style box, select Bold.
12. Click OK.
Ensure that your template looks like the following example.

Figure 35. Template with static labels

v_t'_ | = MyHighDensitySampleReportllong.xltm - Microsoft Excel i
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Code JL _ Controls 1l XML .~
K5 - (‘ I | Cali File: &
| T TSNS ST W - VNR0] NN - AU NUY: -SNPON] N - PUP) N | -SR] NV W] N, | K L | M | =
i High Density Sample Report 1 Long
3 |Lab Name: Method: =
4 | Instrument:
E‘User: I{Sali File: !
6 Batch:
W 4 b M| Sheetl -~ Sheet? ~ Sheet3 - iJ |
Ready | X3 |

You are now ready to display the XML Source pane.

Tip Before proceeding, make sure the Excel window shows the Developer tab, which is
hidden by default. If your Excel window does not show the Developer tab, see Chapter 3,
“Getting Started.”
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Adding Labels and Mapped Nodes

< To display the XML Source pane
1. Click the Developer tab to display all the Developer features.
2. Click the Source button, E .

Source

The spreadsheet displays the XML Source pane. You can drag mapped nodes from the
XML Source pane to the spreadsheet.

Before you begin creating a template for any report, identify the data points on the report and
understand how they map to the nodes in the XML Source.

Ensure that your template looks like the following example.

Figure 36. Template with the XML Source pane
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2 | iSampIeCentricExportBatch_Map v |
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5 | User: cali File: = @
6 Batch: P T
= 7 | | P Py " To map non-repeating elements, drag the
M 4 » ¢ | Sheetl - Sheetz . Sheet3 - ¥ [ m -
Ready | 3
The file list at the sample level contains one line only, but the table format provides better
readability. Most of the TraceFinder sample-level reports use this kind of file list as part of the
report header.
You are now ready to add a file list that the application uses as part of the report header. To
create this file list, you will add static labels and then drag nodes from the XML Source pane.
< To enter static labels for the column headers
1. Type Pos in cell BS.
2. Type SamplelD in cell C8.
3. Type File Name in cell F8.
4. Type Level in cell H8.
5. Type Sample Name in cell 8.
6. Type File Date in cell MS8.
7. Type Comment in cell P8.
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10.

11.
12.
13.

5 Creating a High Density Sample Report
Adding Labels and Mapped Nodes

Select cells B8 through P8.

Right-click and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.

Click the Font tab to open the Font page.

See “Font page in the Format Cells dialog box” on page 57.

In the Font Style box, select Bold.

In the Underline list, select Single.

Click OK.

You are now ready to use the XML Source pane to add mapped fields to your template.

Note A “node” in the XML Source tree creates a “field” in the spreadsheet.

2
0.0

1.

To add mapped fields to the template

To add mapped nodes from the SampleCentricExportBatch/Samples/
SampleCentricExportSample folder, drag the nodes from the XML Source tree to the
appropriate table cell.

a. Drag the VialPosition node to cell B9.

b. Drag the Sampleld node to cell C9.

c. Drag the RawFileName node to cell F9.

d. Drag the SampleLevel node to cell A9.

e. Drag the SampleName node to cell ]9.

f.  Drag the AcquisitionDate node to cell M9.
g. Drag the SampleComments node to cell P9.
In cell HY, type the following formula:
=IF(A9="", "N/A", A9)

This tells the table to show “N/A” when the SampleLevel at A9 is empty (column A is a
hidden column), and otherwise, to show the SampleLevel value.

Note You normally add hidden columns, such as the Level column on the final
report, because you cannot use the XML Source data field directly in the mapped
table. This hidden column is special because you want to display N/A instead of a
blank when the field is empty, so you cannot just drag the field from the XML Source.
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Ensure that your template looks like the following example.

Figure 37. Template with file list
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Note This tutorial creates a layout as close as possible to the delivered report. You can
format the cells in many ways to obtain the same final result; however, adjusting the
columns and cells to create professional-looking reports that meet your business
requirements is a time-consuming process.
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Creating a Repeating Area
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The high density sample report repeats the same information for each compound in the

sample.

The following figure shows the required information for each sample.

Figure 38. Required sample information
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Where:

The Chromatogram for the compound is exported in the XML file as a byte array. This
image refers to the quantitation peak image in the SampleCentricExportBatch/Samples/
SampleCentricExportSample/ Compounds/SampleCentricCompoundExportData/
QuanResult/QuanPeakResults/ CompoundQuanPeakResultExportData/PeakImage
folder.

The Compound Name is the complete name identified in the library.
The Quan Mass is the mass-to-charge ratio for the quantitation peak.

The Total Response is either Total Area or Total Height, depending on the
ResponseValue setting.

The Peak Response is either Peak Area or Peak Height depending on the ResponseValue.
For a single quantitation peak, the total response and peak response represent the same
value.

When the peak is manually integrated, a label “M” is appended to the entry.

The Calculated Amount is either a calibration level amount (for Cal Std sample) or a QC
level amount (for Chk Std sample) depending on the sample type.

The Calculated Amount is a calibration level amount for a Cal Std sample.
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* The Calculated Amount is either a calibration level amount (for Cal Std sample) or a QC
level amount (for Chk Std sample) depending on the sample type.

* The Theoretical Amount is the Reported In Sample Concentration value of the
quantitation result for target compounds. For internal standard compounds, this is the
amount set in the method.

* The Quan Flag is the flag for the quantitation peak.
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Adding Images to a Report

The TraceFinder application embeds images as byte arrays in an exported XML file. The Excel
spreadsheet cannot directly handle embedded images because the images are normally too

large. You can create a named range that acts as a placeholder for an image when you drag an
image node from the XML Source tree. At run time, the application loads images from the

XML file directly to the placeholders through the VBA code.

Tip All images file names in the exported XML file have an “Image” suffix, for example,
SampleTotallonCurrentImage for the TIC image of the sample. This naming convention
identifies the node as an image file so that the application processes the node correctly

when you drag it to your spreadsheet.

% To add an image file to the template

1. Open the SampleCentricExportBatch/Samples/SampleCentricExportSample folder and
drag the SampleTotallonCurrentImage image node from the XML Source tree to cell

W14.

The Edit Graphic dialog box opens.
Figure 39. Edit Graphic dialog box

Edit Graphic
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The tree view in the dialog box lists only image nodes. The application highlights the

currently selected tree node.

2. In the Name for This Graphic box, leave the default name.
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3. In the Range for This Graphic box, change the default to $B$10:$F$18.

Tip You can type the range or you can click the adjacent button in the Range for This
Graphic box and select cells on the spreadsheet.

It is not necessary to create a named range placeholder for images because the VBA
code can directly reference the cells. However, creating named ranges for images
makes their maintenance easier.

4. Click OK.

The application loads the images on the spreadsheet at run time using the following VBA
code and the Createlmage add-in function:

mUtil.CreateImage NAMEDRANGEOFIMAGE, IMAGENODEPATH

Where:
* NAMEDRANGEOFIMAGE is the named range for the image you created at design

time.
* IMAGENODEPATH is the XPath to the image node in the XML Source tree.

The following code inserts a peak image into this report:

mUtil.CreateImage mutil.shiftRange("Quanchart" & cc, 0, offset, O,
offset),
"SampleCentricExportBatch/Samples/SampleCentricExportSample/Compounds
/SampleCentricCompoundExportbData[CompoundKey="" & compKey &
"']/QuanResult/QuanPeakResults/CompoundQuanPeakResultExportData/PeakI
mage"

In this example, NAMEDRANGEOFIMAGE is dynamically calculated for each
compound through the ShiftRange add-in function. IMAGENODEPATH uses an XPath

expression to select the image node based on the compound key.

Note The XPath (the XML Path Language), defined by the World Web Consortium
(W3C), is a query language for selecting nodes from an XML document. For additional
XPath information, refer to the appropriate external documentation.
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Ensure that your template looks like the following example.

Figure 40. Template with an image field
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Creating a Temporary Data Sheet

For this report, you cannot directly use the data as you did for the Batch Report because the
data must be preprocessed. You will put the data on a separate sheet and use formulas to
combine and reformat them before the VBA code uses them to generate the report.

Follow these procedures:

3.
4.

To create a temporary sheet
To add mapped nodes to the template

To name the data table in the template

To create a temporary sheet

. Right-click Sheet2 and choose Rename from the shortcut menu.

The Excel application highlights the sheet name for editing.
Type tempSheet and press ENTER.
Right-click Sheet3 and choose Delete from the shortcut menu.

Click Delete in the confirmation dialog box.

You will use tempSheet as a data sheet to hold the temporary data used during the creation of
the report, and the application removes it after generating the report.

You are now ready to add mapped nodes from the SampleCentricExportBatch folder to create
a data table by dragging the nodes from the XML Source tree to the appropriate table cell.

R
*»*

1.
2.

To add mapped nodes to the template

Open the Samples/SampleCentricExportSample/ Compounds folder.

Open the SampleCentricCompoundExportData folder and do the following:
a. Drag the CompoundName node to cell Al.

b. Drag the CompoundKey node to cell B1.

c. Drag the ResponseValue node to cell C1.

Open the QuanResult folder and drag the TotalResponse node to cell D1.

Open the QuanResult/QuanPeakResults/ CompoundQuanPeakResultExportData/
ResultPeak folder and do the following:

a. Drag the Area node to cell E1.
b. Drag the ApexHeightAboveBaseLine node to cell F1.

Open the QuanResult/QuanPeakResults/ CompoundQuanPeakResultExportData folder
and drag the ManualFlagSet node to cell G1.
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Open the QuanResult/QuanPeakResults/ CompoundQuanPeakResultExportData/
ResultPeak folder and drag the ApexRetentionTime node to cell H1.

Open the SampleCentricCompoundExportData/QuanPeakldentifiers/
QuanPeakIdentifierExportData folder and drag the DisplayRetentionTime node to cell
I1.

Open the SampleCentricCompoundExportData folder and drag the LevelAmount node
to cell J1.

Open the QuanResult folder and drag the CalculatedAmount node to cell K1.
Open the SampleCentricCompoundExportData folder and do the following:
a. Drag the Units node to cell L1.

b. Drag the CompoundType node to cell M1.

c. Drag the Amount node to cell N1.

Open the QuanResult folder and drag the ReportedInSampleConcentration node to
cell O1.

Open the SampleCentricCompoundExportData folder and drag the
TotalExpectedRetentionTimes node to cell P1.

Open the SampleCentricCompoundExportData/QuanPeakldentifiers/
QuanPeakIdentifierExportData folder and drag the DisplayMassRange node to cell Q1.

Open the QuanResult folder and do the following:
a. Drag the QuanFlags node to cell R1.

b. Drag the Active node to cell SI.

c.  Drag the IsValidCompound node to cell T1.

You are now ready to name the data table you created.

R
0’0

1.

2.

3.

Thermo Scientific

To name the data table in the template

Click the Formulas tab and then click Name Manager.

Note The Excel application automatically creates a name for all tables, such as Tablel
or Table2. Each time you create a new table, it increments the table name, even if you
deleted a previous one.

In the Name Manager dialog box, double-click Tablel.

The table name might vary. Use the sheet, row, and column numbers in the Refers To
column to verify the table.

The Edit Name dialog box opens.

Change the default name to DataTable.
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4. Click OK.
You now have two names defined, as shown in the following example.

Figure 41. Name Manager dialog box

Mame Manager |E E|

MeEw, ., BlE Delete
Marne Yalue Refers To SCope
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Xl |

Ensure that your template looks like the following example.

Figure 42. Template with mapped nodes

(Ba HY-o- (8 )+ MyHighDensitySampleReportilongxitm - Microsoft Excel Table Tools e
i B iy, i — ==
: Home Insert Page Layout Formulas Data Review View | Developer | Add-Ins Design @ - =
i 3 record Macro |'E:, 7 [%F Properties 5y Map Properties 2@ Import
E.E Use Relative References QF:JView Code qg Expansion Packs ga, Export
Visual Macros 5 Insert Design - @
Basic A Macro Security - Mode # Run Dialog || -i Refresh Data
Code : Contrals XML |
| Al - (" i | CompoundName ¥
.___I A B C D E F B ZML Source - x
28 CompoundName £4 compoundiype m AML mnaps in this workbook:
2 |SampleCentricExpDrtBatch_Map v|
3| ; ; ; Compoundkey :1
2l EompounName Remove Duplicate [cons
5 Type
6 | CurveType
e HeightThreshald
Z| H H InternalStandardCompound b
Ll < | >
9 | Taomap repeating elements, drag the elements from the tree onto
10 the worksheet where you want the data headings to appear.
L - | Toimport ML data, right dick an #ML mapped cell, point ko %ML, and
4 4 » W[ Sheetl | tempSheet - ¥J - i | T I i ===
ready | 23 | | == e (e | T
Some values are exported more than once, mostly in different formats and at different tree
nodes or levels, to facilitate custom report creation. Sometimes a display value can depend on
several other fields, and putting all the logic on the spreadsheet can be overwhelming.
For help in finding the right data point from the XML Source, see Appendix B, “Custom
Report Add-in APL.”
68 TraceFinder Custom Reports Tutorial Thermo Scientific



5 Creating a High Density Sample Report
Using Data in a Repeating Area

Using Data in a Repeating Area

In a repeating area, some of the fields are populated by using VBA code and others by using
formulas within the Excel application.

For this report, you will use formulas at two levels to simplify the logic at each level.

* The first-level formulas are at the data table level. In the Excel application, you can add
formula columns to a data table. The formula is evaluated when you import the data into
the data table and expanded to each imported data row. With this level of formula, you
can combine values or reformat values to make them ready for display.

* The second-level formulas are embedded in the repeating area. This uses the Excel
VLookup function to get the data element for a specific compound.

You can add the formula columns anywhere in the data table, but in this exercise, you will add
them to the beginning of the data table to make the Excel VLookup function (which is based
on column index) easier to use. For the Excel VLookup function to work, the first column of
the data table must be the “key” column. In TraceFinder reports, the key is the compound
name, so you must keep CompoundName as the first column.

You are now ready to add columns to your data table.
Follow these procedures:

e To create the columns in the data table

* To change the cell format in the template

* To rename the column headers and enter the formulas

* To specify the formulas in the template

< To create the columns in the data table

1. Right-click the CompoundType cell and choose Insert > Table Columns to the Left

from the shortcut menu.

2. Repeat Step 1 seven times, using the default column names Column1 through Column?7.
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Ensure that your template looks like the following example.

Figure 43. Template with inserted columns
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When you add a new column to the data table, the cell format defaults to Text. In this formart,
the formula you enter into the cell appears as text (notice the equal sign in the cell, instead of
an evaluated result). As text, the formula does not expand when data is imported into data
table. For example:

B2 - (> fe | ="Quan m/z: " & TEXT(S2, "0.00")

f A | B T—
8 Comp pundMame ﬂ QuanhMass ﬂ|
="Quan m/z: " & TEXT(S2, "0.00")

You are now ready to manually change the cell formats from Text to General.
% To change the cell format in the template
1. Select the Column1 cell.

2. Right-click and choose Format Cells from the shortcut menu.

The Format Cells dialog box opens.
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3. Click the Number tab to open the Number page.
Figure 44. Number page in the Format Cells dialog box
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4. Select General in the Category list and click OK.
5. While the Column1 cell is still selected, press ENTER.

The Excel application does not automatically update the new cell format. Pressing
ENTER manually updates it.

6. Repeat steps 1-4 for each of the seven columns that you added.

The formula in cells with the General format (no equal sign at the beginning of the cell
content) expands when data is imported into the data table, as shown in the following
example.

Quan mjz: 0.00

You are now ready to give the column headers meaningful names.

< To rename the column headers and enter the formulas
1. In cell B1, change Columnl to QuanMass.

2. In cell B2, enter the following formula:

="Quan m/z: " & TEXT(S2, "0.00")

3. In cell C1, change Column2 to OverallResponse.
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4. In cell C2, enter the following formula:

="Total " & J2 & ": " & ROUND(K2, 0)
5. In cell D1, change Column3 to PeakResponse.

6. In cell D2, enter the following formula:
="Peak" & J2 & ": " & ROUND(IF(J2="Area", L2, M2), 0) & IF(N2, "M", "")
7. In cell E1, change Column4 to RT.
8. In cell E2, enter the following formula:
="RT: " & TEXT(02, "0.00") & " min (" & TEXT(P2, "0.00") & ")"
9. In cell F1, change Column5 to CalculatedAmount.
10. In cell F2, enter the following formula:
=IF(Q2="", "", "TAmount: " & TEXT(Q2, "0.000") & " " & U2)
11. In cell G1, change Column6 to TheoreticalAmount.

12. In cell G2, enter the following formula:

="Amount: " & IF(I2="Internal Standard", TEXT(N2, "0.000"), TEXT(V2,
"0.000") & " " & U2

13. In cell H1, change Column7 to QuanFlag.

14. In cell H2, enter the following formula:
=IFCAC$1, Y2, ")

15. Double-check the formulas to confirm that the referenced columns are correct.

Ensure that your template looks like the following example.

Figure 45. Template with formulas

.*/i-:!n = R ._1 ¥ MyHighDensitySampleReportilong.xltm - Microsoft Excel Table Tools e i 2
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You are now ready to specify formulas in the repeating area on Sheetl.
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To specify the formulas in the template

. Click the Sheetl tab.
. Select cells B19 through F26.
. Click the Home tab to display the Home functions.

. Click the down arrow next to Merge & Center in the Alignment area.

Figure 46. Merging cells
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. Choose Merge Cells from the menu.

Merging these cells creates more space for each data element.

The application uses cells B19 through F19 for the Compound Name. You use VBA code
to set up the compound name. The other fields in the repeating area use
CompoundName as a reference to retrieve data from the DataTable on the tempSheet.

. Select cells B20 through F20, and enter the following formula for Quan Mass:

=IF(ISNA(VLOOKUP(B19, DataTable, 2, FALSE)), "",VLOOKUP(B19,
DataTable, 2, FALSE))

. Select cells B21 through F21, and enter the following formula for Total Response:

=IF(ISNA(VLOOKUP(B19, DataTable, 3, FALSE)), "", VLOOKUP(B19,
DataTable, 3, FALSE))

. Select cells B22 through F22, and enter the following formula for Peak Response:

=IF(ISNA(VLOOKUP(B19, DataTable, 4, FALSE)), "",
VLOOKUP(B19,DataTable, 4, FALSE))

Select cells B23 through F23, and enter the following formula for RT:

=IF(ISNA(VLOOKUP(B19, DataTable, 5, FALSE)), "",
VLOOKUP(B19,DataTable, 5, FALSE))

Select cells B24 through F24, and enter the following formula for Calculated Amount:

=IF(ISNA(VLOOKUP(B19, DataTable, 6, FALSE)), "", VLOOKUP(B19,
DataTable, 6, FALSE))

Select cells B25 through F25, and enter the following formula for Theoretical Amount:

=IF(ISNA(VLOOKUP(B19, DataTable, 7, FALSE)), "", VLOOKUP(B19,
DataTable, 7, FALSE))
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12. Select cells B26 through F26, and enter the following formula for Quan Flag:

=IF(ISNA(VLOOKUP(B19, DataTable, 8, FALSE)), "", IF(VLOOKUP(B19,
DataTable, 8, FALSE)=0, "", VLOOKUP(B19, DataTable, 8, FALSE)))

The formulas are designed so that nothing is visible when the CompoundName cell is empty.

Ensure that your template looks like the following example.

Figure 47. Template with formulas in a repeating area
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The template for the repeating area is complete. You are now ready to duplicate the repeating
area for each compound with four compounds in a row and three rows on a page (a total of 12
on each page).
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Completing the Layout
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In the following procedures, you will modify the layout and create named ranges.

You are now ready to hide column A.

Follow these procedures:

To hide the SampleLevel column

To modify row 19 in the template

To add a border around the merged cells

To copy the repeating area

To name the QuanChart repeated areas

To create the CompoundName named ranges

To create a named range that includes all QuanChart ranges

To adjust the QuanChart columns

To hide the SampleLevel column

Right-click the column A header and choose Hide from the shortcut menu.

Tip You can hide any column in the Excel application. However, if you need hidden
columns for the TraceFinder custom reports, always use the first columns. A hidden
column in the middle of the table can cause trouble when copying blocks of data for
the repeating area.

You are now ready to modify the font in the merged cells.

To modify row 19 in the template

. Click the number for row 19.

Drag the horizontal separator between row 19 and row 20 until row 19 is twice its

original height.

Tip The right separator controls the column width; the bottom separator controls the
row height.

Because of this extra height, row 19 can now accommodate long compound names.

. To prevent the text in merged cells from running over its boundary, do the following:

a. Select the merged cells.
b. Right-click and choose Format Cells from the shortcut menu.

The Format Cells dialog box opens.
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c. Click the Alignment tab to open the Alignment page.

Figure 48. Alignment page in the Format Cells dialog box
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d. In the Text Control area, select the Wrap Text check box.

e. In the Vertical list, select Top.

f.  Click the Font tab.
g. In the Font Style box, select Bold.
h. Click OK.

You are now ready to add a border to the merged cells.
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< To add a border around the merged cells
1. Select the cells B10 through F26.
2. Click the Home tab to display the Home functions.
3. Click the down arrow next to the Borders icon in the Font area.
Calibri 11 | A AT

(B I U ~||[# v||{hv&v|

Fd Borders

Bottom Border
Top Border
Left Border
Right Border

Mo Border
FH ' anBorders
Outside Borders

4. Choose Outside Borders from the menu.

This border groups the compound information.

< To copy the repeating area

1. Select the cells B10 through F26.

To select the cells, do not click the bordered area; you must drag your cursor across all the
cells.

2. Right-click and choose Copy from the shortcut menu.
3. Right-click in cell G10, and choose Paste from the shortcut menu.

4. Repeat Step 3 for cells L10 and Q10.

You are now ready to name the QuanChart ranges.

% To name the QuanChart repeated areas
1. Select cells B10 through F18.
2. Click the Formulas tab, and then click Define Name.

~=) Define Name -

£ Use in Formula -
Mame
Manager E& Create from Selection

Defined Mames
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The selected cell range automatically appears in the Refers To box of the New Name

dialog box.

Mame: || |

Srope: |'-.-'u'|:|rkl:u:u:|k v |

Comment:

Refersto: | _rempsheet!§B$10:4F$15 &
[ kK l [ Zancel ]

3. In the Name box, type QuanChartl.

4. Click OK.

5. Repeat steps 1 through 4 using the following values:
* Cells G10 through K18, type QuanChart2
* Cells L10 through P18, type QuanChart3
* Cells Q10 through U18, type QuanChart4

< To create the CompoundName named ranges
1. Select cell B19.
2. Click the Formulas tab, and then click Define Name.
The selected cell automatically appears in the Refers To box of the New Name dialog box.

3. In the Name box, type CompoundNamel.
4. Click OK.
5. Repeat steps 1 through 4 for the following values:

* Cell G19, type CompoundName2

e Cell L19, type CompoundName3

* Cell Q19, type CompoundName4
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To create a named range that includes all QuanChart ranges

. Select cells B10 through U26.

The selected cells include all four QuanChart ranges.

. Click the Formulas tab, and then click Define Name.

The selected cell automatically appears in the Refers To box of the New Name dialog
box.

. In the Name box, type RepeatArea.
. Click OK.

You will treat this range as a single unit of the repeating area.

To adjust the QuanChart columns

Drag the dividers in the column headings to make all the columns fit within the page
range.

When you are in page preview mode, a dashed line indicates the right margin of the page.
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Ensure that your template looks like the following example.

Figure 49. Completed template design
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Adding VBA Code to the Template

The template interface design is complete. You are ready to add VBA code to connect the data
to the interface.

Using the VBA code, you will do the following:

* DPopulate the RepeatArea for each compound by making each sheet a single page and
creating as many sheets as needed.

Note There are two ways to populate the RepeatArea for each compound:

* Make multiple copies of the RepeatArea on the same sheet to create one sheet
containing the entire report.

Creating a single sheet for the entire report can have a negative performance
impact. The Excel application can become very slow as the sheet becomes large.
For best performance, limit a sheet to no more than 10 printed pages.

* (Preferred) Make each sheet a single page and create as many sheets as needed.

The Excel application can better handle many sheets with a small set of data on
each sheet.

* Put 12 compounds on each sheet (which makes up a single printed page) and create as
many sheets as needed.

* Name each sheet after the compound name of the first compound on the sheet—with
some special characters removed to make it eligible as an Excel application tab name.

* Group the sheets and use an add-in component to make the page numbering continuous
across the sheets.

* Use the Excel Sheet.Copy function to copy a sheet.

Using the CopyPaste Add-in Function

The native CopyPaste function in the Excel application uses the Clipboard to transfer data,
which is a shared resource for all applications. For the purposes of this tutorial, you do not
want to share the data with other applications.

As a workaround, use a special CopyPaste function in the add-in component that avoids using
the Clipboard. When you want to copy and paste cell data, use the CopyPaste add-in function
instead of the Excel application’s CopyPaste function.
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VBA Code in Module1

In the Getting Started chapter, you created two empty functions in Modulel: ProcessDatal()
and Validate().

* The Validate() function is called before the XML data is imported and it checks if the
named ranges are intact. Validate checks for the following types of named ranges:

—  Required: Without the required name ranges, the template cannot work properly.

— Optional: The template uses a default value if an optional range is missing. For
example, PageBreakEvery is an optional named range that specifies how many rows of
the RepeatArea to include on a single page. By default, you have three rows on a page.
If you add more data to the RepeatArea and need more space for each row, you can
define a named range with the cell value set to 2, so that each page consists of two
rOWS.

* The ProcessData() function is called after the XML data is imported into the spreadsheet.

As a convention, the logic code for each sheet is in a separate function, for example,
ProcessSheet1Datal().

You are now ready to create a special footer for the flag legend.
Follow these procedures:

* To create a special footer

* To duplicate the repeating area for each compound
% To create a special footer

1. Click the Developer tab to display the Developer features.
2. Click Visual Basic, icl .

Visual
Basic

The Microsoft Visual Basic window opens.

3. In the Project - VBAProject pane, double-click MyUstil to open the
MyHighDensitySampleReport1Long.xltm - MyUtil (Code) window.

4. Change the IUtil_SetupPageFooter() interface function in the MyUstil class module

From:

Private Sub IUtil_SetupPageFooter()
muUtil.SetupPageFooter “”, 0.5
End Sub

To:

Private Sub IUtil_SetupPageFooter()
mUtil.SetupPageFooter GetPageFooterText, 0.5
End Sub
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The IUtil_SetupPageFooter() function calls the GetPageFooterText function defined in
Modulel.

You are now ready to add VBA code to create multiple repeating areas.

% To duplicate the repeating area for each compound

1. In the Project - VBAProject pane, double-click Modulel to open the
MyHighDensitySampleReport1Long.xltm - Modulel (Code) window.
2. Replace the code in the Modulel code editor with the following code:
Option Explicit
' called after xml data gets imported
Public Sub Processbata()
On Error GoTo ErrorHandler
mutil.LogMsg "Processing - Start"
ProcessSheetlbata
mUtil.LogMsg "Processing - End"
Exit Sub
ErrorHandler:

MsgBox Err.Number & " - " & Err.Source & ": " & Err.Description,
vbCritical, "Process Data Error"

End Sub

Private Sub ProcessSheetlbata()
mutil.LogMsg "Processing - Sheetl - Start"
Activeworkbook.sSheets("sheetl").Activate

Dim i As Long, j As Long, 1stObj As ListObject, compName As String,
offset As Long, k As Long

Dim n As Long, h As Long, rr As Long, cc As Long, pageBreakEvery As
Long, compKey As String, nn As Long

Setup page header/footer here once and it will be copied to all
sheets by Sheet.Copy.

Otherwise, it's slow to set it up sheet by sheet.

v

NOTE: To make this work, the page header/footer must meet certain
requirements.

mutil.skipSetupPageHeaderFooter = True
mIUti1.SetupPageHeader
mIUti1.SetupPageFooter
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If
mutil.GetXmlElement("SampleCentricExportBatch/Samples/SampleCentricEx
portsample/ApplicationsampleType") <> "Breakdown" Then

pageBreakEvery = mUtil.Getvalue("PageBreakevery", 3)

h = Range("RepeatArea'").Rows.Count row height

' First duplicate the RepeatArea to fill up the whole page
For i = 2 To pageBreakEvery

mUtil.CopyPaste "RepeatArea", Range("RepeatArea").offset((i
- 1) * h)

Next
Set 1stobj = wWorksheets("tempSheet").ListObjects("DataTable")

mUtil.LogMsg "Processing - Start - " & 1stObj.Range.Rows.Count
- 2 & " Compounds"

For i = 2 To TstObj.Range.Rows.Count

If 1stobj.ListColumns("Active").Range(i) And
Tstobj.ListColumns("IsvalidCompound").Range(i) And
T1stobj.ListColumns("CompoundType") .Range(i) <> "Native" And
T1stobj.ListColumns("CompoundType").Range(i) <> "Breakdown" Then

n=n+1
compName = 1stObj.Range.Cells(i, 1)
If (n - 1) Mod 12 = 0 Then
If n > 1 Then
' Refresh the formula
Application.Calculate

Turn formula into text because we will delete
the source data at the end

ActiveSheet.UsedRange.value =
ActiveSheet.UsedRange.value
End If

Make a new sheet by copying it from Sheetl

worksheets ("Sheetl") .Copy
Before:=worksheets("tempSheet™)

' Set the sheet name to compound name for easier review

ActiveSheet.Name =
mUtil.GetvalidSheetName (compName)

nn =0
End If
nn = nn + 1 ' tracks how many compounds in a sheet
rr = Int((nn - 1) / 4) + 1 ' row number
cc=(-1)Mod 4 +1 ' column number
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offset = (rr - 1) * h
Range ("CompoundName" & cc).offset(offset) = compName

compKey = muUtil.vLookup(compName, Range("DataTable"),
11, False)

muUtil.CreateImage mutil.shiftRange("'Quanchart" & cc, 0,
offset, 0, offset),
"SampleCentricExportBatch/Samples/SampleCentricExportSample/Compounds
/SampleCentricCompoundExportData[CompoundKey="" & compKey &
"']/QuanResult/QuanPeakResults/CompoundQuanPeakResultExportData/PeakI
mage"

If n Mod 10 = 0 Then mutil.LogMsg "Processing - " & n
& "th compound"
End If
Next
If nn > 0 Then ' Last sheet not finalized yet

Application.Calculate
' Turn formula into text
ActiveSheet.UsedRange.value = ActiveSheet.UsedRange.value
End If
muUtil.LogMsg "Processing - End"
End If
If n = 0 Then
mUtil.SetNoData "NobData"
Else
Sheets("Sheetl") .Delete
End If
Sheets("tempSheet") .Delete
muUtil.LogMsg "Processing - Sheetl - End"

End Sub

PubTlic Function GetPageFooterText() As String

If
mutil.GetxmlElement("SampleCentricExportBatch/MethodHeaderbata/ShowF1
agsAndLegend") Then

GetPageFooterText = "Flag legend: LOD<J<JOQ; I=Ion ratio
failure; C=Carryover; ?=Linearity Timit; D=Detection 1limit; Q=Quan
Timit; POS=Rpt limit; b=Blank; s=Solvent blank."

End If

End Function

' validate the template design e.g. named ranges
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PubTic Function validate(oOptional showwarning As Boolean = True) As
Boolean
Dim err_msg As String, info_msg As String, msg As String

Check required names

muUtil.CheckRequiredName err_msg, "RepeatArea", "The 'RepeatArea' is
the named range for repeating area."

muUtil.CheckRequiredName err_msg, "DataTable", "The 'DataTable' 1is the
named table including all compound data in TempSheet."

mutil.CheckRequiredName err_msg, "QuancChartl", "The 'QuancChartl'’
is the named cell for the first chart.”

muUtil.CheckRequiredName err_msg, "QuancChart2", "The 'QuancChart2'
is the named cell for the second chart."

muUtil.CheckRequiredName err_msg, "QuanChart3", "The 'QuancChart3'
is the named cell for the third chart.”

muUtil.CheckRequiredName err_msg, "QuancChart4", "The 'QuancChart4'
is the named cell for the fourth chart."

muUtil.CheckRequiredName err_msg, "CompoundNamel", "The
'CompoundNamel' is the named cell for the compound name of the first

chart."

mUtil.cCheckRequiredName err_msg, "CompoundName2™, "The
'CompoundName2' is the named cell for the compound name of the second
chart."

muUtil.CheckRequiredName err_msg, "CompoundName3", "The
'CompoundName3' 1is the named cell for the compound name of the third
chart."

muUtil.CheckrRequiredName err_msg, "CompoundName4™, "The 'CompoundName4'
is the named cell for the compound name of the fourth chart."

Check optional names

mUtil.CheckoptionalNameoutsideof err_msg, info_msg,
"PageBreakEvery'", "RepeatArea", '"Page break is set at every 3 rows as
default."

Display message if any

mutil.ShowErrMsg err_msg, info_msg, showwarning

validate = err_msg = ""
End Function
Where:
* ProcessData() calls ProcessSheet1 Data and is used for error handling.

* ProcessSheet1Data contains the main body of this report:

— LogMsg is an add-in function used for logging messages, primarily for debugging.
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SetupPageHeader and SetupPageFooter are add-in functions that are usually called
once for each page break. Because this tutorial uses the Excel Sheet.Copy function to
duplicate the pages (including the headers and footers), you do not need these
functions.

The first IF statement checks if the sample type is a Breakdown type. The high

density sample report is valid only for non-breakdown sample types.

When PageBreakEvery is undefined, it defaults to 3, which means that each page
can have a maximum of three RepeatArea rows.

The RepeatArea is duplicated as follows:

i. Duplicates the RepeatArea to fill the entire page using the CopyPaste add-in
function (it does not use the Clipboard).

ii. Fetches the data from DataTable and grabs each valid compound. To be valid,
the compound must be active, isValidCompound must be true, and the
compound type must not be Native or Breakdown.

iii. Fetches the data from DataTable and grabs each valid compound. To be valid,
the compound must be active and isValidCompound must be true.

iv. Sets the compound name to the sheet (for example, B19). This automatically
updates the formulas on the sheet. Calls Application.Calculate to refresh the
formulas before copying the sheet.

v. Sheet.Copy copies all formulas into the new sheet.
ActiveSheet.UsedRange.Value is assigned to itself to turn the formulas into text
on the new sheet and disconnect them from the original sheet.

vi. Sheet.Copy creates a new sheet.

vii. GetValidSheetName is an add-in function that assigns a sheet name based on
the first compound name on the sheet and verifies that the name is a valid tab
name (because compound names can contain invalid characters).

viii. CreateImage is an add-in function that loads an image into the spreadsheet.
CreateImage grabs the image byte array from the XML file, converts the byte
array into a bitmap image, puts the image on the designated named range, and
resizes or crops the image to make it fit.

ix. Each sheet is copied when it is filled with 12 compounds. The last page needs
special handling if it is not completely filled.

x. The code makes sure that “No data in the report” is shown if there is no data to
show.

xi. The application deletes Sheet] that acted as a template during this process and
deletes tempSheet because it is not needed after processing,.
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* GetPageFooterText returns the flag legend to be used as a page footer.

—  SkipSetupPageHeaderFooter is used because the footer text is the same on every
page.

—  The legend visibility depends on the setting of ShowFlagsAndLegend, which is
retrieved directly from the XML source file using the GetXmlElement add-in

function.
* Validate checks these named ranges:

— CheckRequiredName is an add-in function that checks if the required named range
exists in the workbook. You can specify the error message if the named range is
missing.

—  CheckOptionalNameOutsideOf is an add-in function that checks if a named range
is defined outside another named range. If not, a warning message specifies the
default value.

— The error messages are accumulated for all errors and warnings and are displayed in a

single dialog box, for example:

Microsoft Excel E|

@ Following errors have been found in the template:
+ The named range '"QuanChartz' is required and is currently missing, The '"QuaniChart? is the named cell For the second chart,
+ The named range 'QuanChart3' is required and is currently missing, The 'QuaniChart3 is the named cell For the third chart.
+ The named range '"QuanChart4’ is required and is currently missing, The '"QuancChart4 is the named cell For the Forth chart,

Following messages don't present an error and are For wour information only:

+ The optional named range 'PageBreakEvery’ is undefined or invalid, Page break is sek at every 3 rows as default,

3. To use the Visual Basic compile function to check for errors, choose Debug > Compile
VBAProject.
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Testing the Template

You are now ready to run a test from the Windows Start > Run box. In this test, the code that

you enter does the following:

Opens the Excel application.

Creates a new workbook using the MyHighDensitySampleReport1Long.xltm template.
Passes the parameters to the template.

Generates a report based on the 4bw01_SampleCentricData.xml source file.

Saves the report to the MyHighDensitySampleReport1Long.xlsm file.

Follow these procedures:

To run the test

To use the template in the TraceFinder application

To run the test

. Choose Start > Run.

The Run dialog box opens.

= Type the name of a program, folder, document, ar
= Inkernet resource, and Windows will open it for wou,

Open: | vl

[ Cancel ][ Browse. ., ]

. Enter this code in the Open box:

Excel.exe /n "C:\Thermo\Custom Report
Tutorials\MyHighDensitySampleReportlLong.xTtm"
/Xx/C:\Thermo\Custom|Report|Tutorials\Data\4bwOl_SampleCentricbData.xml
/C:\Thermo\Custom|Report|Tutorials\Reports\MyHighDens1itySampleReportl
Long.x1sm/s/h

For detailed descriptions of the parameters used in this code, see “Testing the Template”
on page 27.

The generated report that appears on your screen is similar to the following figure (actual data
may vary depending on the batch you used).

Thermo Scientific
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Figure 50. Generated report
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You are now ready to integrate the template into the TraceFinder application.
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< To use the template in the TraceFinder application
1. Copy your new template into the dedicated folder of the application:
C:\Thermo\Shared\Templates\Reports

2. Use this template the same way as the other delivered reports in the TraceFinder
application.

For detailed information about how to use custom reports, refer to the TraceFinder User

Guide.
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Creating a Calibration Report

In this chapter, you will create an Excel template for a calibration report similar to the
Calibration Report delivered with the TraceFinder application.

Contents

* Opening the Report Template
* Creating a Calibration Summary — Sheetl
— About Multipurpose Columns
— Adding Helper Columns as Derived Columns
* Creating a Calibration Data Point — Sheet2
—  Creating a Pivot Table
—  Creating the Sheet2 Template
* Creating a Calibration File List — Sheet3
— Adding VBA Code to the Template

* Testing the Template

A calibration report in the TraceFinder application is a batch-level report that presents the
calibration results of the batch. The calibration report includes the following three sections:

* Calibration summary data
* Calibration data points for each compound

¢ A list of calibration files

Each section of the report is presented in a separate sheet in an Excel spreadsheet.
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Figure 51. Template for Sheet1 - Calibration summary data
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Figure 52. Template for Sheet? - Calibration data points
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Figure 53. Template for Sheet3 - Calibration files
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As you create a calibration report template, you will learn the following:
* How to work with a data table to add, insert, remove, or move a column

* How to use the same field multiple times to work around the limitation that a data field
can be referenced only once

* How to create a cross-tab (pivot table) report
* How to filter data for display

e How to use derived columns and rows

Before you begin creating a template for any report, identify the data points on the report and
understand how they map to the nodes in the XML Source.
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Opening the Report Template

For these step-by-step procedures, use the ThermoCustomReportBaseTemplate.xltm file that
you created in the Getting Started section as the basic template.

R

< To begin your high density report template

In Windows Explorer, make a copy of the ThermoCustomReportBase Template.xltm file
and name the new copy MyCalibrationReport.xltm.

% To load the template file
1. Open the Excel application.
2. Click the Office button, () , and choose Open.
~

3. In the Open dialog box, double-click MyCalibrationReport.xltm.

Tip Do not open this template file from Windows Explorer because doing so creates a new
spreadsheet based on this template instead of opening the template for editing,
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The calibration summary page in a calibration report contains a list of summary data, as

shown in the following report.

Figure 54. Calibration summary report
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* Compound is the compound name.

* Manually Integrated is flagged as M when the curve is manually integrated or blank

otherwise.

* *Curve Type indicates one of the available curve types:

— L (Linear)

—  Q (Quadratic)
— A (Average RF)

— I (Internal Standard, which has no curve)

* AO/y-Intercept/Mean RF is a multi-purpose column. Its value depends on the curve

type.

* Al/Slope is a multi-purpose column. Its values depends on the curve type.

* A2 is used for quadratic curve types only.

* RA2/RA2/%RSD is a multi-purpose column.

* Flag is a calibration flag.

Thermo Scientific

TraceFinder Custom Reports Tutorial 97



6 Creating a Calibration Report
Creating a Calibration Summary — Sheet1

About Multipurpose Columns

The content of a multipurpose column depends on the curve type settings.

* Fora Linear curve type, the curve equation is y = AO + Al * x, where the A0 column is the
y-intercept and the A1 column is the slope. The A2 column is empty.

* For a Quadratic curve type, the curve equation isy = A0 + Al *x + A2 * x/2. All three
columns are used.

* For an Average RF type curve, the curve for each compound has a single value. Only the
first column is used. The average RF value depends on the Standard Type settings.

—  For external Average RF:
Amount = (Response)/(Mean Response Factor)

—  For internal Average RF:
Amount = (Response * ISTD Amount)/(ISTD Response * Mean Response Factor)

* For a linear or quadratic curve, the fourth column shows the RA2 value. For an Average
RF curve, the fourth column shows a %RSD value.

Putting the logic code into the spreadsheet (and the VBA code) can be difficult to maintain.
For this reason, you exported extra massaged data points ready for the custom report to use.

The CurveSummaryValuel, CurveSummaryValue2, CurveSummaryValue3, and
CurveSummaryValue4 columns in the SampleCentricExportBatch/CalibrationData/
CompoundCurveExportData folder represent this type of shared column.

Creating the Report Headers

In this section, you will create static labels for the report header and then drag the data nodes
from the XML Source tree.

Follow these procedures:
* To enter static labels for the report heading
* To enter static labels for the column headers
* To add mapped fields to the template

* To add a mapped table to the template
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< To enter static labels for the report heading
1. Type Calibration Report in cell B1.
2. Select the cells B1 through L1.
3. Right-click and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.

4. Click the Alignment tab to open the Alignment page.
Figure 55. Alignment page in the Format Cells dialog box

Format Cells

Mumber | Alignrnent | Fonk " Border " Fill || Prakection

Text alignrment Orientation
Horizonkal: * .
|Center b | Indent: *
Yertical: |E| s T
e
|T|:|p gt | w Texk —
Justify distributed . .
*
P

|:| Wrap bexk
[ ] shrink o it
Merge cells

Dedgrees

Right-to-left

Text direction:

L ok ][ Cancel ]

5. In the Horizontal list, select Center.
6. In the Text Control area, select the Merge cells check box.
7. Click OK.

8. In the spreadsheet, do the following:
a. Type Lab name: in cell A3.
b. Type Instrument: in cell A4.
c. Type User: in cell AS.
d. Type Batch: in cell A6.
e. Type Method: in cell G3.
. Type Cali File: in cell G5.
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9. Hold down the CTRL key and select the label cells you just created.
10. Right-click and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.

11. Click the Font tab to open the Font page.
Figure 56. Font page in the Format Cells dialog box

Format Cells
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L (0] 4 ] [ Zancel
12. In the Font Style box, select Bold.
13. Click OK.
Your template header looks like this:
Calibration Report
Lab name: Method:
Instrument:
User: Cali File:
Batch:

< To enter static labels for the column headers
1. Type Calibration Summary in cell C8.
2. Type Compound in cell C11.
3. Type Manually Integrated in cell D10.
4. Type Curve Type in cell E10.

100  TraceFinder Custom Reports Tutorial Thermo Scientific



Thermo Scientific

NN W

10.

11.

12.
13.

6 Creating a Calibration Report
Creating a Calibration Summary — Sheet1

. Type AO y-Intercept Mean RF in cell F9.
. Type A1 Slope in cell G9.

. Type A2 in cell H9.

. Type RA2 RA2 %RSD in cell 19.

. Select cells C8 through I10.

Right-click and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.

Click the Font tab if it is not already selected.

See “Font page in the Format Cells dialog box” on page 100.
In the Font Style box, select Bold.

Click OK.

Tip Before proceeding, make sure the Excel window shows the Developer tab, which is
hidden by default. If your Excel window does not show the Developer tab, see Chapter 3,
“Getting Started.”

Before you begin creating a template for any report, identify the data points on the report and
understand how they map to the nodes in the XML Source tree.

Note A “node” in the XML Source tree creates a “field” in the spreadsheet.

To add mapped fields to the template

. Click the Developer tab to display the Developer features.
. Click the Source button, E .

Source

The spreadsheet displays the XML Source pane. You can drag mapped nodes from the
XML Source pane to the spreadsheet. You are ready to create mapped fields from the
nodes in the SampleCentricExportBatch folder by dragging the nodes from the XML
Source tree to the appropriate table cell.

. Open the MethodHeaderData folder and do the following:

a. Drag the LabName node to cell B3.
b. Drag the InstrumentMethodName node to cell B4.

. Open the BatchHeaderData folder and do the following:

a. Drag the UserName node to cell B5.
b. Drag the BatchName node to cell B6.
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5. Open the MethodHeaderData folder and do the following:

Drag the MethodName node to cell G3.
b. Drag the MasterMethodName node to cell G4.

a.

6. Open the BatchHeaderData folder and drag the CalibrationFile node to cell G5.

You are now ready to add a mapped table to your template.

Using the Excel application, you

can drag the mapped table nodes from the XML Source pane.

R
**

To add a mapped table to the template

To create mapped fields from the nodes in the SampleCentricExportBatch/
CalibrationData/ CompoundCurveExportData folder, drag the nodes from the XML

Source tree to the appropriate table cell.

a. Drag the CompoundName node to cell A12.

b. Drag the CurveSummaryValuel node to cell D12.
c. Drag the CurveSummaryValue2 node to cell E12.
d. Drag the CurveSummaryValue3 node to cell F12.
e. Drag the CurveSummaryValue4 node to cell G12.

Ensure that your template looks like the following example.

Figure 57. Template with mapped fields

I’D3 [ N R P MyCalibrationRepart.xitm - Microsoft Excel TalfeTonl: - =
3 Home Insert Page Layout Formulas Data Review View Developer Add-Ins Cresign w - =
Ef.-ﬂ = Recard Macra (sl E 29 ﬁ-‘ Properties E -_} Map Properties ;_?glmport
! =z E.E Use Relative References Y B ol view Code ||| | & Expansion Packs frj Export
Visual Macros Insert Design Suurcnfe_‘0
s I\ Macro Security +~  Mode H RunDialog ||| |*9} Refresh Data
Code Controls XML
c12 - I | CurveType ¥
| A B c D E F G H | %ML source v x
) Calibration Report #ML maps in this workbook:
2 | |SampIeCentricExportBatch_Map b
2 Lab name: Method: - CompoundType -~
4 | Instrument: 5] CurveEquation
5 |User: cali File: & Curvelmage
& Batch: =| | & curveSummary¥aluel
1 ‘=] CurveSummary¥Yalue2
7 | 5] CurveSummary¥alue3
8 Calibration Summary -] CurveSummary¥alued
9 A0 Al A2 RA2 =
l = e v
10| Manually Curve  y-Intercept slope RA2 = Datemd'ﬁecll ST
11 Compound Ilntegrated Type Mean RF %RSD Flag B e e e
7 compoundidl Manualrid curvetypf curvesurfa curvesumBa curvesumiBd curvesumm B calibratiofafll RS ERTEEEIS
13 it worksheet where vou wank the data
¥ | headings bo appear.
14
1 Tao impark ¥ML daka, right click an XML
15 | mapped cell, point ko ¥ML, and thien click
I ¢ » ¥| Sheetl ~Sheet2 ~ Sheetd 3 i L m o b '
Ready | ﬂ |
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Adding Helper Columns as Derived Columns

In this section, you will add two helper columns, CompoundType and HasActiveReplicates,
as derived columns. Some columns in the data table depend on the CompoundType and

HasActiveReplicates columns, which are not visible in the generated report.

Follow these procedures:

To add two new columns to the template

To map the derived columns in the template

To hide the helper columns in the template

To add three new columns to the template

To change the cell format in the template

To rename the column headers in the template (optional)
To enter the formulas in the template

To hide the helper columns and rows

To import the XML file into the template

To change the background in the template

To enlarge the Compound Name column

To align the header text in the template

To change the data type of the Mean RF and %RSD cells

To save your layout design

To add two new columns to the template

. Right-click the column A header cell and choose Insert from the shortcut menu.

Repeat Step 1 to add another new column.
Starting from column C, the Excel application shifts all cells to the right.

Open the SampleCentricExportBatch/CalibrationData/ CompoundCurveExportData
folder and do the following:

a. Drag the CompoundType node from the XML Source tree to cell B12.
b. Drag the HasActiveReplicates node from the XML Source tree to cell A12.

Later, you will hide these columns and use formulas to create massaged values for display.

You are now ready to add mapped fields to the template.

Thermo Scientific
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< To map the derived columns in the template

To add mapped fields from the SampleCentricExportBatch/CalibrationData/
CompoundCurveExportData folder, drag the nodes from the XML Source tree to the

appropriate table cell.

a. Drag the ManualFlagSet node to cell C12.
b. Drag the CurveType node to cell D12.

c. Drag the CalibrationFlags node to cell E12.

Ensure that your template looks like the following example.

Figure 58. Template with mapped table

‘.-’- ™ L B R W MyCalibrationReport.xitm - Microsoft Excel abte tomts - =
el -
- Home Insert Page Layout Formulas Data Review View Developer Add-Ins Design '@ - X
= ¥ Record Macro |\¢j_l E ? [ Properties @@Map Properties [7f Import
L =73 ﬁ Use Relative References 25 T q-—'JView Code ||| | f‘ﬁ Expansion Packs ﬁ:l, Export
Visual Macros 2 Insert Design . |Source| o
Hakie 8\ Macro Security +  Mode T RunDialog '} Refresh Data
Code Controls XML
E12 - (> I | CalibrationFlags ¥
P | codeon. G G H | 1 L4 | B %vuSource v x
S| Calibration Report HML maps in this workbook:
2 | |SampleCentricExportBatch_Map v|
3] Lab name: Method: CalibrationFlags ~
5o Instrument: Calibrationtethod
5 | User: Cali File: CompoundId
6 Batch: = CompoundName
| CompoundType
7 | CurveEquation
8 | Calibration Summary Curvelmage =
9 A0 Al A2 RA2 CurveSummaryYaluel
! " v
10| Manually Curve y-Intercept slope RA2 & = l:urveSulmmarv\l'aIue>2 =
11 Compound Integrated Type Mean RF %RSD Flag e e e
6% HasActd compold ManualF1aBal curveTypda calibraticEd compounf curvesumB curvesumiBdl curvesummd curvesunfa il LRI R ErE
12| worksheet where you want the data
il headings to appear.
14
| Toimport ¥ML data, right click an 5ML
15 mapped cell, point to ¥ML, and then
4 4 b | Sheatl ~Sheet2 ~Sheetd %) . [T m s —— |
Ready | S |

Note Do not worry that the static headers and mapped fields are not correctly aligned. In
the next section, you will move the static headers to the correct columns.

< To hide the helper columns in the template
1. Select the cells A1 through A11.
Select only these cells; do not select the entire column.
2. Right-click and choose Insert from the shortcut menu.
The Insert dialog box opens.
3. Select the Shift Cells Right option and click OK.

4. Repeat steps 1 through 3 two more times.
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You now have a total of five empty columns: the three you added plus the two that were
already there. The columns are empty only in cells 1 through 11.

Ensure that your template looks like the following example.

Figure 59. Template with five empty columns

r'/.:a (=L B T S MyCalibrationReport.xftm - Microsoft Excel b Tonk - m
Liad <
3 Home Insert Page Layout Formulas Data Review View Developer Add-Ins Design 9 -
== P Recard Macro i','\?-:'.l E f i??Properties E%Map Properties iﬁlmport
= & ﬁUse Relative References S T &l View Code i | & Expansion Packs &:J Expart
Visual Macros : Insert Design ; |Source| o
Basic & Macro Security - Mode % Run Dialog | fRefresh Data
Code Controls XML
G12 v 5 | CurveSummaryValuel ¥
| _a B ol Lok S H _ 1 1 & xMLsource v x
1| Calibration Report “ML maps in this workbook:
2 | |SampleCentricExportBatch_Map v
3 | Lab name: Me (=] CalibrationFlags »
4| Instrument: CalibrationMethod
5 User: cal CompoundTd
6 | Batch: = CompoundName
| CompoundType
7 CurveEquation
8 | Calibration Summary Curvelmage =
=] AD Al CurveSummaryYaluel
i v
10| Manually Curve y-Intercept Slope Fh ':"r"es"!“"marwa'“e)z i
11 Compound Integrated Type Mean RF e L mew T
FE) Hasact Bl compod vanualFiafd curve Typ®d calibratickd compounf slements from the tree orka the
13 | B worksheet where wou want the data
e headings to appear,
14
| Toimport £ML data, right click an <ML
15 | mapped cell, point ko XML, and then
4 4 » M| Sheetl Sheet2  “Sheetd #J . [T m st > ]
Ready | S |
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% To add three new columns to the template

1. Right-click the G12 cell and choose Insert > Table Columns to the Left from the
shortcut menu.

The Excel application adds a new column with the default name Column1 to the left of
the G column.

2. Right-click the G12 cell and choose Insert > Table Columns to the Left from the
shortcut menu.

The Excel application adds a new column with the default name Column2 to the left of
the G column.

3. Right-click the L12 cell and choose Insert > Table Column to the Right from the
shortcut menu.

The Excel application adds a new column with the default name CurveSummaryValue5
(based on the previous column name) to the right of the L column.

You now have three empty columns to use for Manually Integrated, Curve Type, and Flag.
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When you add a new column to the data table, the cell format defaults to Text. In this format,
the formula you enter into the cell appears as text. As text, the formula does not expand when
data is imported into the data table.

You are now ready to manually change the cell formats from Text to General.

% To change the cell format in the template
1. Right-click the Column1 cell and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.
2. Click the Number tab to open the Number page.
Figure 60. Number page in the Format Cells dialog box

Format Cells

Murnber | Alignment Fank Border Fill Prokeckion
Category:

eneral Sample
Murmber
Currency
Accounking Text format cells are breated as bext even when a number is
Date in the cell, The cell is displayed exactly as entered,

Time
Percentage
Frackion
Scientific

Developrment (373

Spu:ial
Zuskom

(0] 4 l [ Zancel

3. Select General in the Category list and click OK.
4. While the Columnl cell is still selected, press ENTER.

The Excel application does not automatically update the new cell format. Pressing
ENTER manually updates it.

5. Repeat steps 1-5 for each of the three columns that you added.

In the next procedure, you will give the column headers meaningful names. Because later you
will hide the headers, this procedure is optional.

< To rename the column headers in the template (optional)
1. In cell G10, change Column1 to Manually Integrated.
2. In cell H10, change Column2 to Curve Type.
3. In cell M11, change CurveSummaryValue5 to Flag.

You are now ready to enter the formulas for the columns.
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< To enter the formulas in the template

1. In cell G13, enter the following formula:
=IF(C13, "M", "")
2. In cell H13, enter the following formula:

=IF(B13="Internal Standard", "I", LEFT(D13, 1))

3. In cell M13, enter the following formula:

=IF(Al3, IF(E13=0, "", E13), "")

The field below the RA2 column is for the Average %RSD value, which is the average of all
RSD values. The result is also exported into the XML file under the
SampleCentricExportBatch/CalibrationSummaryData/AverageRSD node. The Excel data
table automatically pushes the Average %RSD row down when it expands the data table.

You are now ready to hide the helper columns and rows.

< To hide the helper columns and rows
1. Select columns A through E.
2. Right-click and choose Hide from the shortcut menu.

3. Right-click the number 12 in the first column of row 12 and choose Hide from the
shortcut menu.

The Excel application hides row 12. At any time, you can restore the contents of a hidden
row.

To restore row 12, do the following:
a. Select rows 11 through 13.

b. Right-click and choose Unhide from the shortcut menu.
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Ensure that your template looks like the following example.

Figure 61. Completed Sheet1

Alr (W A 7 MyCalibrationReport.xltm - Microsoft Excel e
l-f-" . _ﬁ‘j_ _ ¥ p i - Table Tools
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=i E Use Relative References QJVrew Code | & Expansion Packs (@5 Export
Visual Macros Insert Design @
I 3\ Macra Security ~  Mode B RunDialog '} Refresh Data
Code : Controls XML
| F13 ~ (2 5 | =
Pl s H YR WU - b M N XML Source v x
e G Calibration Report #ML maps in this workbook:
| 2_ | |SampleCentricExportBatch_Map v|
3 |Lab name: Method: "] CalibrationFlags ~
4 |Instrument: = CalibrationMethod
5 User: Cali File: Compoundld
. e
s 5 CompoundType
: i 1 CuryveEquation
8 |Calibration Summary =| Curvelmage L
g AD Al A2 RA2 —| CurveSummary¥aluel
i : w
10| Manually Curve y-Intercept slope RA2 = = E”"f__egummarwaluef o
11 Compound Integrated Type Mean RF %RSD Flag e e
13 elements from the tree onta the
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B Taimpart %ML data, right click an XL
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W4 b n| Sheetl /Sheet? ,~Sheetd . ¥d ek tmnad___+ )
Ready | B |
Sheet1 of the template is ready to run.
You are now ready to directly import an XML file to test the data table. You will not save this
data; this is a test to see how the imported data looks in your report.
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% To import the XML file into the template

1. Save your template.

Tip There is no undo for the Import function, so to save your template in case you
make a mistake, for example, importing the wrong .xml file.

2. Click the Developer tab and then click the Import button.

| Developer l Acrobat

ap Properties E’]mpurt

The Import XML dialog box opens.

Import XML |E”z|
Look ins |E;| Data V| @ -3 X oiE-
Eil My Recent raw file1_SampkeCentricData.xmi
Documents

@ Desktop

File name: | . |

Files of LYpe: | smL Files (* xmi) v

.
|

3. Select your sample-centric data file, and click Import.

The Excel application imports the .xml file into your spreadsheet.
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Ensure that your template looks like the following example.

Figure 62. Template with imported data

( DE [ ._,1 s MyCalibrationReport.xdtm - Microsoft Excel o E
- Home Insert Page Layout Formulas Data Review View Developer |  Add-Ins @' - o X
= E3 Record Macra I'--E;'.]_ M @Pmperﬂes @ i;rf-.lap Properties Dglmpmt
=258 E Use Relative References % ) Q'?]Vim Code . % Expansion Packs ﬁ*ﬂ Export
Visual Macros Insert Design Source
Basic ‘ﬁ Macro Security - Mode # Run Dialog *"":- Refresh Data
Code Controls XML
| G2 - (> £ | ¥
Pl r e H T _—— K L M N =
(3 Calibration Report
2] —1
3 |labpame: Thermo Fisherlab Method: 2974 cal test 2974
4 |Instrument: Thermo Scientific Instrument cal_test 2974
5 |User: AMER\ming.liu Cali File: 2974.calx
6 Batch: 2974
8 |Calibration Summary
9 | AD Al A2 RA2
10 | Manually Curve y-Intercept Slope RA2
11 |Compound Integrated Type Mean RF %RSD Flag
.15: :Peni.‘achloron A 2.176294689 133.7505 D
14 _1,3—Dich|DrDI A 6.844520546 133.7286 D
15 |1,4-Dichlorol | 13993412.02 5.2465
16 _1,¢Dich|0r0l A 6.500837462 1327205 D
17 _1,2—Dichlor_{:rl A B.562984443 133.2664 D =
18 |Hexachloroe A 2.208186943 134.2629 D
13 _Nitrobenzen A 1.066056954 131.5094 D
20 |1,2,4-Trichlo A 1.417166695 132.4452 D
21 MNaphthalene | 53969025.29 4.888959
M 4 M| Sheetl  ~Sheet? “Sheet3 ~¥J_ -
Ready | &3 |
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4. Discard this version of the template and open the one you saved before the Import
function.

Leaving imported data in the template does not cause any harm to generated reports
because the data is overwritten at run time.

For additional instructions, see “How Do I Remove Data from the Template After
Importing It?” on page 196.
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To change the background in the template

. Click the header of the data table to display the Design tab.
. Click the Design tab.

The Design tab displays the Table Styles functions.

Table Styles

Expand the Table Styles gallery and click Clear, i Clear | in the lower left corner of
the gallery.

The background changes to a plain background.

The Compound Name column is so narrow that the compound names are not entirely visible.
Cell text can run into the next cell as long as the next cell is empty. You are now ready to
introduce an empty column after the Compound Name column.

Note Making the entire column wider is not a solution because it affects the alignment of
the cells above the data table.

To enlarge the Compound Name column

. Insert an empty column by right-clicking the Compound Name column header and

choosing Insert > Table Columns to the Left from the shortcut menu.

The Excel application inserts an empty, unmapped column in the table. By default, the
new column is named Columnl.

. Select the cells G1 through G11.

Select only these cells; do not select the entire column.

. Right-click and choose Insert from the shortcut menu.

The Insert dialog box opens.

. Select the Shift Cells Right option and click OK.

Select cells G3 through G6.
Right-click and choose Cut from the shortcut menu.
Right-click in cell F3 and choose Paste from the shortcut menu.

Moving the text in these header columns to the left prevents them from overrunning the
page.
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< To align the header text in the template
1. Select the Manually Integrated and Curve Type header cells.
2. Right-click and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.
3. Click the Alignment tab to open the Alignment page.
See “Alignment page in the Format Cells dialog box” on page 99.
4. In the Horizontal list, select Center.

5. Click OK.

The Mean RF and %RSD cells required a number format of three decimal places. You are
now ready to change the data type of these cells.

% To change the data type of the Mean RF and %RSD cells

1. Select the cells from J13 through M13.
Select only these cells; do not select the entire column.

2. Right-click and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.

3. Click the Number tab to open the Number page.
See “Number page in the Format Cells dialog box” on page 106.

4. In the Category list, select Number.

Mumber | Aligrirment Fank Border Fill

Cakegory:
izeneral Sample

rurnber
Currency
Accounting Decimal ol e -
Date Decimal places: S

5. In the Decimal Places box, change the value to 3.
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< To save your layout design
1. Click the Developer tab, and then click Map Properties.

The XML Map Properties dialog box opens with the first map automatically selected.

XML Map Properties

Mame: | SampleCentricExportBatch_Map |

#ML schema validation

[ ¥alidate data against schema For impart and expart
[aka source

Save data source definition in workbook,
Drata Formatting and layout

[ adiust calumn width:

Preserve column Filker

Preserve number Formatking

When refreshing or impaorking daka:
() Overwrite existing data with new data

) append new data ko existing XML tables

K l [ Zancel

2. Clear the Adjust Column Width check box.

When this option is selected, the field expands to fit imported data, which changes your
layout.
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You can optionally resize the columns to optimize how they look on the page. When you
reimport the data, ensure that your template looks like the following example.

Figure 63. Template with finalized layout
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10 Manually  Curve y-Intercept Slope RA2
11 |Compound Integrated = Type Mean RF %RSD Flag =
13 |Pentachioroethane A 2176 133751 D
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17 |1,2-Dichlorobenzene A 6.563 133.266/D
18 |Hexachloroethane A 2.208 134,263 D
19 |Nitrobenzene-d5 A 1.066 131.508|D
20 |1,2,4-Trichlorobenzene A 1417 132.445/D
21 |Naphthalene-d& | 53969025.290 4 BRG
22 _Hexachlorcuprc-pene A D.813 135883 D
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_25__Hexachlorclwc!c-pentadiene A 1287 138.506 D
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31 |Phenanthrene-d10 1 55035373.458 4084
32 |p-Terphenyl-d14 A 3.840 133.580/D
33 Chrysene-di2 I 31021690.953 12774
34 Perylene-di2 I 26960159.352 14,634 A
35 Awverage %RSD: 133.742
'ﬁ'ﬁl » W | Sheetl < Sheet2 ~Sheetd %1
Ready | P |

The template design is complete. No VBA code is required for this sheet.
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Creating a Calibration Data Point — Sheet2

Sheet2 of the calibration report contains a cross-tab (pivot table) list of data that displays the
calculated amount for each compound against each calibrator.

To create this sheet in your custom report, use an add-in function for creating cross-tab type
reports to expose the parameters you need.

For additional information about creating a pivot table, refer to your Excel documentation.

Creating a Pivot Table

Thermo Scientific

The calculated amount (the pivot data point) for each compound and calibrator depends on
these factors:

* Compound type

* Curve type

* Manual flag (manual integration affects how the amount is calculated)
* Sample level (as column header)

* Acquisition date (for sorting purposes)

* Expected retention time (for sorting purposes)

* Exclusion reason (to flag the values)

Calibration reports require a pivot table for indicating flags such as the following:
* “Manually Integrated” for a curve that was manually integrated
* “X” for an excluded point

e “X(ISNF)” for exclusion because the internal standard was not found

The Excel pivot table works only with numbers as pivot data points. In this tutorial, you will
reformat the pivot data for those data points to a special value so that the template can treat
them differently after the pivot table is created.

* For the Manually Integrated flag, change the data point value to “negative” for manually
integrated points. Because your data points are normally positive, you can easily identify
those values after the pivoting.

* For the X flag, change the data point value to a large number (for example,
88987654 321). This number must be a valid value, but unlikely to be a real data point.

* For X(ISNF) flag, change the data point value to a different large number
(for example, 9987 654 321). This number must be a valid value, but unlikely to be a real
data point.

Tip These large numbers are based solely on observations. If these suggested numbers
happen to be the actual result data of your report, use different numbers.
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Using the CreatePivotTable Function

116

Use the following CreatePivotTable add-in function to create the pivot table for your report.

CreatePivotTable(dataTableName, targetRange, rowFields, columnFields,
valueFields, [pivotTableName])

Where:
* dataTableName is the named range for the data table on which the pivot table is based.
* targetRange is the named range for where the pivot table is located on the sheet.

* rowFields is a semicolon-delimited string from the Compound Name and Curve Type
columns that become rows in the resulting pivot table.

* columnFields is a semicolon-delimited string from the Acquisition Date and Sample
Level columns that become columns in the resulting pivot table.

* valueFields is a semicolon-delimited string from the Point Value column that become
pivot data values.

* pivotTableName is an optional argument that specifies the name for the resulting pivot
table.

This CreatePivotTable add-in function performs the following two tasks:

* Creates the pivot table using the ActiveWorkbook.PivotCaches.Create and
ActiveSheet.PivotTables.AddDataField Excel functions.

* Clears the default styles and borders of the pivot table.

You cannot directly use the resulting pivot table in your report because of the format
requirements. After running this function, the Excel application creates the pivot table on a
temporary sheet. You will use the CopyPaste add-in function to copy the data to the reporting
sheet.

In an Excel spreadsheet, you can use each tree node in the XML Source only once. When you
try to drag a tree node that is already mapped onto your spreadsheet, you get an error message
that the “element has already been mapped and cannot be mapped more than once.”

To avoid this problem, you can add as many XML maps to the same XML Source file as you
need. This generates sequentially numbered XML maps, for example,
SampleCentricExportBatch_Mapl.

TraceFinder Custom Reports Tutorial Thermo Scientific



6 Creating a Calibration Report
Creating a Calibration Data Point — Sheet2

Creating the Sheet2 Template

Create another map in the XML Source pane and use that map to create the report heading.

Follow these procedures:
* To add an XML mapping file
* To enter static labels for the report heading
* To create the cross-tab table in the template
* To add two helper columns to the template
* To create the ProcessSheet2Data add-in function
* To copy the pivot table to Sheet2

* To complete the layout

< To add an XML mapping file
1. In the XML Source pane in your spreadsheet, click XML Maps, [ L paps... .
The XML Maps dialog box opens.

XML Maps ?)X]

%ML maps in this workbook:
MName F.oot Mamespace
SampleentricExpartBatch_Map SampleCentricExparkBatch  <Mo Mamespace
SampleentricExportBatch_Mapil sampleCentricExporkBatch  <Mo Mamespace
< I | >
Rename. .. i Add.. [ Delete ] [ ok ] [ Cancel ]

2. Click Add.
3. Navigate to your XML mapping file (the same one you used before) and click Open.

The Excel application adds the mapping file to the XML Maps in This Workbook list.
Because this is a duplicate of your original mapping file, the number 1 is appended to the
file name.

4. Click OK.

Because you have only a single .xml file to import, the add-in component populates all maps
when you import the .xml file.

IMPORTANT Do not change the name of the XML map file.
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< To enter static labels for the report heading
1. Type the report header Calibration Report in cell B1.
2. Type Lab name: in cell A3.
3. Type Instrument: in cell A4.
4. Type User: in cell A5.
5. Type Batch: in cell A6.
6. Type Method: in cell F3.
7. Type Cali File: in cell F5.
8. Hold down the CTRL key and select the label cells you just created.
9. Right-click and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.
10. Click the Font tab to open the Font page.
See “Font page in the Format Cells dialog box” on page 100.
11. In the Font Style box, select Bold.
12. Click OK.
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Ensure that your template looks like the following example.

Figure 64. Template with static labels

I.-’E.; -+ MyCalibrationReportxitm - Microsoft Excel i
LS =
- Home Insert Page Layout Formulas Data Review View Developer Add-Ins @ - =
== P Record Macrao r'l W (% Properties ‘E 5k Map Properties [T Import
== | i | 4 i
=2 E.E Use Relative References 2S Hen O view Code : £ Expansion Packs ﬁ:', Export
Visual Macros g Insert Design : ,Scurce_‘a
Bede _\ Macra Security +  Mode H RunDialog } Refresh Data
Code Controls XML
G5 - £ | ¥
| a B c D E F ol H I s K & %ML source v x
1] Calibration Report #ML maps in this workbook:
2 | %SampleCentricExportBatch_Map1 v
2 i Tt = ,_j SampleCentricExportBatch ~
4 _Instrument: =-[.5 BatchHeaderData =
5 |user: Cali File: (=] BatchFolderPath
6 -Batch' 3 =] BatchName
g =] Batchstate
7| =N CalibrationFile
8 Calibration Data Points =] InstrumentName
9 Curve =] LocalMethodMarne
10 -Compoun Type & Projectilame i
| < | ¥
11
I To map non-repeating elements, drag the
12 elements From the tree onto the workshest
13 where wou want the data to appear.
14 Ta import daka, use the Impork XML Data
15 button on the List toolbar,
6] | (cptions ~ | [0 eps.. |
M 4 » M| Sheetl | Sheet? - Sheet3 ~ TempSheet % T m E >
Ready Calculate | P3|

% Toc

reate the cross-tab table in the template

1. Open the SampleCentricExportBatch/CalibrationData/ CompoundCurveExportData
folder, and drag the nodes from the XML Source tree to the appropriate table cell.

a.
b.

C.

d.
2. Ope

Sam
tree

a.
b.
c.

d.

Drag the CompoundName node to cell D1.
Drag the CurveType node to cell E1.

Drag the ManualFlagSet node to cell F1.
Drag the SampleLevel node to cell G1.

n the SampleCentricExportBatch/CalibrationData/CalibrationReplicates/
pleCompoundReplicateExportData folder, and drag the nodes from the XML Source
to the appropriate table cell.

Drag the AcquisitionDate node to cell H1.
Drag the ExpectedRetentionTime node to cell I1.
Drag the ExclusionReason node to cell J1.

Drag the CurveDataPointValue node to cell K1.

You are ready to add two helper columns: Curve Type and Point Value.

e The

Curve Type column needs reformatting so that only the first character of the type is

shown in the report:

Thermo Scientific
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— L (Linear)

—  Q (Quadratic)
— A (Average RF)

— I (Internal Standard, which has no curve)

* The Point Value column contains the massaged data ready to be used in the pivot table.

< To add two helper columns to the template
1. Right-click the column A header cell and choose Insert from the shortcut menu.

2. Repeat Step 1 to add another new column.

Starting from column C, the Excel application shifts all cells to the right.
3. Change the default header in column B to Curve Type.
4. Change the default header in column C to Point Value.

5. In cell B2, enter the following formula:

=IF(A2="Internal Standard", "I", LEFT(E2, 1))

6. In cell C2, enter the following formula:
=IF(OR(J2="eISTDNotFound",J2= "eISTDManuallyExcluded"), 99987654321,
IF(J2="eManual", 88987654321, IF(F2, -K2, K2)))

You are now ready to add a function to process the pivot table.

< To create the ProcessSheet2Data add-in function

1. Click the Developer tab to display the Developer features.
2. Click Visual Basic, icl .

Visual
Basic

The Microsoft Visual Basic window opens.

3. Enter the following code into the Modulel code editor:
Public Sub Processbata()
ProcessSheet2Data
End Sub
Private Sub ProcessSheet2Data()
Dim rng As Range

Set rng = mUtil.CreatePivotTable("DataTable", "TempSheet!0l",
"CompoundName;Curve Type", "AcquisitionDate;SampleLevel", "Point
value™)

End Sub

Where:
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CreatePivotTable creates the pivot table based on the DataTable (a named range of your data
on TempSheet) and puts the resulting pivot table in the cell starting from TempSheet!O1.

The pivot table uses the CompoundName and Curve Type column names as row headers,
AcquisitionDate and SampleLevel as column headers, and the value from the Point Value
column.

When you create your custom report, the original data table in the Excel spreadsheet is
translated into a pivot table, as shown in the following examples.

Figure 65. Original data table

Ho- [+ MyCalibrationReport_20100712155944.x1sm - Microsoft Excel Table Tools T
Home Insert Page Layout Formulas Data Review View Developer Add-Ins Design '@ - =
Table Name: [i3] summarize with PivotTable % ; 5 Praperties V| Header Row [ First Column EEEEE| CEEEE e e -
DataTable 11 Remove Duplicates =) & ope Total Row Last Column SSo-- —oDo- oS- -
= ExportRefresh = o e e e e e =
I Resize Table ] Convert to Range - ink | Banded Rows Banded Columns L
Properties Tools Escternal Table Data Table Style Options Table Styles
‘ A8 - 5 | Internal Standard
' A B E E g H 1 J K Li
1 mﬂmmz sampleif3 Acquisitionnatfd ExpectedretE|Exclusionr & curvepatapoinkd
2 Target Compound A 0.481089042 Pentachloroethane  Average RF FALSE o5 4/27/2009 18:47  4.094016667 eNone 0.431089042
3 |Target Compound A 5.537360764 Pentachloroethane Average RF FALSE clo 4/27/2009 18:56 4.034016667 eNone 5.537360764
4 Target Compound A 0.510434262 Pentachloroethane  Average RF FALSE  c20 4/27/2009 18:52  4.094016667 eNone 0.510434262
5 |Target Compound A 1.529130324 1,3-Dichlorobenzene Average RF FALSE c5 4/27/2009 18:47 4.38 eNone 1.529130324
6 Target Compound A 17.41353177 1,3-Dichlorobenzene Average RF FALSE  c10 4/27/2009 18:56 4.38 eNone 17.41353177 1
7 |Target Compound A 1.590899543 1,3-Dichlorobenzene Average RF FALSE c20 4/27/2009 18:52 4.38 eNone 1.590839543 i
g ]Intemal Standard _II 13341547.74 1,4-Dichlorobenzene- Average RF FALSE c5 4{27/2009 18:47 4.45 eNone 12341547.74
9 |Internal Standard | 13849980.82 1,4-Dichlorobenzene- Average RF FALSE clo 4/27/2009 18:56 4.45 eNone 13849980.82
10 Internal Standard | 14788707.5 1,4-Dichlorobenzene- Average RF FALSE c20 4{27/2009 18:52 4.45 eNone 14788707.5
11 Target Compound A 1.624499844 1,4-Dichlorobenzene Average RF FALSE c5 4/27/2009 18:47 4.47 eNone 1.624499844
12 Target Compound A 17.47653045 1,4-Dichlorobenzene Average RF FALSE  cl10 4/27/2009 18:56 4.47 eNone 17.47653045
13 Target Compound A 1.601482093 1,4-Dichlorobenzene Average RF FALSE c20 4/27/2009 18:52 4.47 eNone 1.601482093
14 Target Compound A 1.521440148 1,2-Dichlorobenzene Average RF FALSE o5 4/27/2009 18:47 4.65 eNone 1.521440148
15 Target Compound A 16.66228222 1,2-Dichlorobenzene Average RF FALSE clo 4/27/2009 18:56 4.65 eNone 16.66228222
16 Target Compound A 1.505230963 1,2-Dichlorobenzene Average RF FALSE  c20 4/27/2009 18:52 4.65 eNone 1.505230963
17 Target Compound A 0.490653011 Hexachloroethane  Average RF FALSE c5 4/27/2009 18:47 5.05 eNone 0.430653011
18 Target Compound A 5.631607783 Hexachloroethane  Average RF FALSE  c10 4/27/2009 18:56 5.05 eNone 5.631607783
13 |Target Compound A 0.502300034 Hexachloroethane  Average RF FALSE c20 4/27/2009 18:52 5.05 eNone 0.502300034
20 Target Compound A 0.252503084 Nitrobenzene-d5 Average RF FALSE c3 4/27/2009 18:47 5.14 eNone 0.252503084
21 Target Compound A 2.684900027 Nitrobenzene-d5 Average RF FALSE clo 4/27/2009 18:56 5.14 eNone 2.684300027
22 Target Compound A 0.260767749 Nitrobenzene-d5 Average RF FALSE c20 4/27/2009 18:52 5.14 eNone 0.260767749
23 Target Compound A 0.339290796 1,2, 4-Trichlorobenzen Average RF FALSE c5 4/27/2009 18:47 5.9 eNone 0.339290796
24 Target Compound A 3.584494263 1,2,4-Trichlorobenzen Average RF FALSE cl0 4{27/2009 18:56 5.9 eNone 3.584494263
25 |Target Compound A 0.327715026 1,2, 4-Trichlorobenzen Average RF FALSE c20 4/27/2009 18:52 5.9 eNone 0.327715026
26 Internal Standard | 51733410.16 Naphthalene-d8 Linear FALSE c5 4{27/2009 18:47 5.96 eNone 51732410.16
27 Internal Standard | 53294257.69 Naphthalene-d8 Linear FALSE clo 4/27/2009 18:56 5.96 eNone 53294257.69
28 Internal Standard | 56879408.02 Naphthalene-d8 Linear FALSE c20 4{27/2009 18:52 5.96 eNone 56879408.02
29 |Target CQmDDund A 0.1705685244 Hexachloronmqene Average RF FALSE c5 4/27/2009 18:47 6.1 eMNone 0.170565244
W 4 » M| Sheetl Sheet? ~Sheet3 | TempSheet . [ |
Ready | 3
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Figure 66. Data table translated into a pivot table

I/ - 1?' MycalibrationReport_20100712155944.xlsm - Microsoft Excel Table Tools - B x
= ame Inse Pag aut Formulas Diata Reuis View Developer Add-Ins Design x
H T fif
Table Name: [i3] summarize with PivotTable g ﬁ 5 Properties V| Header Row *| First Column
DataTable E*‘ Remove Duplicates [ & Opel Browser || || Total Row 7| Last Column
Export Refresh E
I Resize Table .;iCcmverttu Range - - &3 Unlir | Banded Rows Banded Columns
Properties Tools External Table Data Table Style Options Table Styles
A8 - 5 | Internal Standard
L M N a P a R s u v wi
1] Sum of Point Value
2 4/27/2009 18:47 4/27/2009 18:52 4/27/2009 18:56
3 | cs c20 c1o
4 1,2,4,5-Tetrachlorobenzene A 0.550797882  (0.543839328  6.222150521
5| 1,2,4-Trichlorobenzene A 0.339290796  0.327715026  3.584494263
6 1,2-Dichlorobenzene A 1.521440148  1.505230963  16.66228222 1
iz 1,3-Dichlorobenzene A 1529130324 1.590899543  17.41353177
8 1,4-Dichlorobenzene A 1.624499844  1.601482093  17.47653045
g | 1,4-Dichlorobenzene-d4 1 13341547.74 14788707.5  13849930.82
10 2-Chloronaphthalene A 1701026778  1.713898841  19.15362012
11| 2-Fluorobiphenyl A 1.257286148 1.26408062  13.54352752
12 Acenaphthene-d10 1 28865089.45  31003986.36  28415450.61
13| Chrysene-di2 1 32624263.83  33932123.85  26508685.18
14 Hexachlorobenzene A 0.177589086 0.190720506 1.979364837
15| Hexachlorobutadiene A 0146209643  0.145009759  1.601492377
16 Hexachlorocyclopentadiene A 0.23306153 0.270634325 3.355858348
17| Hexachloroethane A 0490653011  0.502300034  5.631607783
13 Hexachloropropene A 0.170565244 0.181322347 2104589734
19| Naphthalene-d8 1 51733410.16  56879408.02  53294257.69
20 Nitrobenzene-ds A 0.252503084  0.260767749  2.684900027
21| Pentachlorobenzene A 0.42749716 0.408210239 4.555467734
2 Pentachloroethane A 0481089042  0.510434262  5.537360764
3| Perylene-di2 1 29532450.09  28930291.93  22417736.04
24 Phenanthrene-d10 1 55987819.07  56649860.44  52458440.87
25| p-Terphenyl-d14 A 0.880168641  0.922856228  10.01831931
26
27|
28
29 o
W 4 » M| Sheetl , Sheet?  Sheetd | TempSheet %] .
Ready | 73
Note The AcquisitionDate in row 2 is for sorting purposes. It is not required on the
report.
The pivot table on TempSheet contains the data you want to include on the second page of
your Calibration report.
% To copy the pivot table to Sheet2
Use the CopyPaste add-in function.
Private Sub ProcessSheet2Data()
Dim rng As Range
Set rng = mutil.CreatepPivotTable('"'DataTable", "TempSheet!0ol",
"CompoundName;Curve Type", "AcquisitionDate;SampleLevel", "Point
value')
mUtil.CopyPaste mutil.shiftRange(rng, 0, 2), "Sheet2!All", False, True
End Sub
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When you generate your report, Sheet2 looks like the following example:

Figure 67. Sheet? in a generated report

Ho-- ()5 MyCalibrationReport_20100712162722 xlsm - Microsoft Excel e B
Home Insert Page Layout Formulas Data Review View Developer Add-Ins @ - T X
b Calibri =15 1 |§ General = ,&Condi‘tlonalFurmatting' g'ﬂlnsert'  Fon ? Lﬁ
123 |B I Q '||A‘g_:| @‘ |$ Y °.|-"= ¥ | %Formataﬂabie' ;"F“Delete* E' :
= 5 A | a8 || e iFomt | &- S DA
Clipboard T Font || plignment || Number Styles Cells Editing
| G6 ~ (2 e |
o L loc o [ [ B v [ o [ [ [ o
1 | Calibration Report
2 4
2 lLahr:arne: Therma Fisher Lab Method: 2974 cal_test_2974
4. llrmrumem: Therma Scientific Instrument cal_test_2974
_i User: AMERYming.liu Cali File: 28974 calx
6 Batch: 2074 |
? 4
8 Calibration Data Points
2 Curve
10 |Compoun  Type
11| c5 c20 clo
1211,2,4,5-Te A 0.550798 0.5438339 6.222151
13 _1,2,4—Tricl‘A 0.3392951  0.327715 3.58445%4
14 _1,2-Dich|0A 1.52144 1.505231  16.66228
15 _1,3—DiChIOA 1.52913 1.5909 17.41353
16 _1,4-Dich|0A 1.6245 1.601482 17.47653 =
1?_1,4—Dichlol 13341548 14788707 13849981
18 _2—Ch|0r0n A 1.701027  1.713859 19.15362
13 .2-F|u0r0b A 1.257286 1.264081 13.54353
_EQ.Acenaphtll 28865089 31003586 28415451
21_Chrysene-l 32624264 33932124 26508685
22 _HexachlorA 0.177589 | 0.190721 1.979865
23 _HexaChIOFA 0.14621 0.14501 1.601492
24 _HexachlcrA 0.233062 0.270634 3.355858
25 _HexachlorA 0.490653 0.5023 5.631608
20 _HexachlorA 0.170565 | 0.181323 2.10459
27 .Naphthalﬁl 51733410 56879408 53294258
28 .NitrobenzA 0.252503  0.260768 2.6849
29 _PentachloA 0.427457  0.40821 4.555468
30 _PentachloA 0.481089 0.510434 5.537361
31 _Perylene—l 29532450 28930292 22417736
a2 _Phenanth 1 55987819 56649860 52463441
23 _p—TerpherA 0.880169 0.922856 10.01832
34
W 4 » W] Sheeti | Sheet2 ~Sheetd TempSheet ~¥d T s
Ready | I |
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To complete the layout

(Optional) Resize the columns to optimize their appearance on the page.
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Creating a Calibration File List — Sheet3

The last sheet of the Calibration Report contains a list of all calibration sample types. The
information you need for this list is embedded in each compound node; therefore, you must
filter out the unwanted data. You will use the Excel filtering function to create this filtered list
by adding a CompoundID column as a derived helper column. This sample list must also
include a derived acquisition date column to order the samples by their acquisition date.

Follow these procedures:

10.

11.
12.

To enter static labels for the report heading
To add an XML mapping file to the template

To add mapped fields to the template

To enter static labels for the report heading

. Type the report header Calibration Report in cell B1.
. Type Lab name: in cell B3.

. Type Instrument: in cell B4.

. Type User: in cell B5.

. Type Batch: in cell B6.

. Type Method: in cell F3.

. Type Cali File: in cell F5.

Hold down the CTRL key and select the label cells you just created.
Right-click and choose Format Cells from the shortcut menu.

The Format Cells dialog box opens.

Click the Font tab to open the Font page.

See “Font page in the Format Cells dialog box” on page 100.

In the Font Style box, select Bold.

Click OK.

You are now ready to add another XML map to use for Sheet3.

124  TraceFinder Custom Reports Tutorial Thermo Scientific



Thermo Scientific

2
0‘0

1.

2.

3. Navigate to your XML mapping file (the same one you used before) and click Open.

4.

6 Creating a Calibration Report
Creating a Calibration File List — Sheet3

To add an XML mapping file to the template
In the XML Source pane in your spreadsheet, click XML Maps, [ %L taps... |.
The XML Maps dialog box opens.

XML Maps

#ML maps in this workbook:

Mame F.ook Mamespace
SampleCentricExportBatch_Map SampleCentricExportBatch  <Mo Mamespace =
SampleCentricExportBatch_Mapl SamplecCentricExportBatch  <Mo Mamespace =

SampleCentricExportBatch_MapZ SampleCentricExportBatch  <Mo Mamespace =

[Eename... ] [ add. .. ] [ Delete ] [ I ] [ Zancel J

Click Add.

The Excel application adds the mapping file to the XML Maps in This Workbook list.

Because this is the second duplicate of your original mapping file, the number 2 is
appended to the file name.

Click OK.

Because you have only a single .xml file to import, the add-in component populates all maps

when you import the .xml file.

You are now ready to add mapped nodes from the SampleCentricExportBatch_Map?2 file.

0’0

1.

NN N R W

To add mapped fields to the template

Open the SampleCentricExportBatch/CalibrationReplicates/SampleCompound
ReplicateExportData folder, and drag the nodes from the XML Source tree to the
appropriate table cell.

. Drag the AcquisitionDate node to cell A8.
. Drag the VialPosition node to cell B8.

. Drag the Sampleld node to cell C8.

. Drag the RawFileName node to cell D8.

. Drag the SampleLevel node to cell ES.

. Drag the SampleName node to cell F8.

. Drag the FileDate node to cell G8.

. Drag the Comments node to cell H8.
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Ensure that your template looks like the following example.

Figure 68. Template with headers and mapped fields

H- (- MyCalibrationReport.xitm - Microsoft Excel rabkTonk - =
Home Insert Page Layout Formulas Data Review View Developer | Add-Ins Design @ =
f F3 Record Macro |E:, = M @ Properties ETL Map Properties Eﬁlmpor’c
=272 E Use Relative References Q‘,;'JVim Code : | fﬂ'é Expansion Packs ﬁ; Export
Visual Macros Insert Design Source @
Basic £ Macro Security - Mode # Run Dialog | i Refresh Data
Code Contrals XML ]
| A3 ~Q £ | ¥
Pleadu B c D E F G H _ixML Source - x
1) Calibration Report #ML maps in this workbook:
£ | |SampIeCentricExportBatch_MapZ v|
3 | S e L—_, CalibrationReplicates ~
43 | Instrument: 4 = Lﬂ? SampleCompoundReplicateExp
5 | User: Cali File: 1 : ._—I AcqguisitionDate
& Batch: ] AmountDifference
? | | Area
—| BatchDate =]
vialposit' 'sampieB RawFil &3 samp B8 sampicBd| FileDatBa| commda) 5 Batchame =
Z Ee | (I [ . —
e . % | >
1‘_0 | To map repeating elements, drag the
11 elements from the tree onto the worksheet
| whete you want the data headings to
12 | Sppear.
| Toi t ¥ML data, right click an XML
=L o impar 5ka, right click an
M 4 » ¥ [ Sheetl .~ Sheet? | Sheet3 . TermpSheet ¥ [[HIL s = = ' i
Ready Calculate | 2 | R [T T e

Completing the Layout

126

In the following procedures, you will rename the default table header names, name the

mapped table, and finish the layout.

Follow these procedures:
* To rename mapped table header names
* To name the table in the template

* To change the background in the template

% To rename mapped table header names
1. Change B8 from VialPosition to Pos.
. Change C8 from Sampleld to Sample ID.

2
3. Change D8 from RawFileName to File Name.
4

. Change E8 from SampleLevel to Level.

5. Change F8 from SampleName to Sample Name.

6. Change G8 from FileDate to File Date.

TraceFinder Custom Reports Tutorial
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10.

11.
12.
13.
14.

6 Creating a Calibration Report
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Change H8 from Comments to Comment.

Select cells B8 through HS.

Right-click the Vial Pos cell and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.

Click the Font tab to open the Font page.

See “Font page in the Format Cells dialog box” on page 100.

In the Font Style box, select Bold.

In the Underline list, select Single.

Click OK.

Resize the columns to have the appropriate width and still fit into a single printed page.

Ensure that your template looks like the following example.

Figure 69. Template with custom header text

)\ e D (Y ) 5 MyCalibrationRepart.xltm - Microsoft Excel - =X
b
W L ﬁ —
e Haome Insert Page Layout Farmulas Data Review View | Developer | Add-Ins @' - O X
Record Macro |'§1' [ Properties @ ‘Sn Map Properties L"ﬁ Import |
E Use Relative References @ View Code - i.g Expansion Packs m‘ﬂ Export
Wisual Macros : Insert Design : source .
Basic .Il: Macro Security - Mads T Run Dialog 9§ Refresh Data
Code : Controls ' XML |
A~ Cussl :
- D E | | G - H - I f
1 Calibration Report
&4
3 |Lab name: Method:
4 linstrument: 31
5 |user Cali File: i
o |Batch:
7

8 [Pos  [v/sampleID

E]File Mame |El|.E‘ul'E‘| |E]Samnle NEEFiIE Date Eﬂ}mment [3

4 4 b M| Shestl  Sheet2 | Sheet3 .~ TempSheet . ¥

Ready | ¥ |

Thermo Scientific

Count: 2
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You are now ready to use the Excel named range feature to name the table in the template.
You can give a name to a range of cells and then use the name to refer to this area.

< To name the table in the template

1. Click the Formulas tab and then click Name Manager.

Note The Excel application automatically creates a name for all tables, such as Tablel
or Table2. Each time you create a new table, it increments the table name, even if you
deleted a previous one.

2. In the Name Manager dialog box, double-click Tablel.

The table name might vary. Use the sheet, row, and column numbers in the Refers To
column to verify the table.

The Edit Name dialog box opens.
3. Change the default name to DataTableFileList.
4. Click OK.
5. Click Close in the Name Manager dialog box.

You are now ready to polish the layout of the template.

< To change the background in the template
1. Click the header of the data table to display the Design tab.
2. Click the Design tab.

The Design tab displays the Table Styles functions.

Table Styles

3. Expand the Table Styles gallery and click Clear, @ Clear | in the lower left corner of
the gallery.

The background changes to a plain background.

4. Right-click the column A header (AcquisitionDate) and choose Hide from the shortcut
menu.

Note You can hide any column in an Excel spreadsheet. However, if you need derived
columns for the TraceFinder custom reports, always use the first columns. A derived

column in the middle of the table can cause trouble when copying blocks of data for
the repeating area.
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Adding VBA Code to the Template

You are now ready to use VBA code to add a filtering function to the template.

< To add the Acquisition Date filtering function to the template
1. Click the Developer tab to display the Developer features.
2. Click Visual Basic,

Visual
Basic

The Microsoft Visual Basic window opens.
3. Right-click the VBA project and choose Insert > Module from the shortcut menu.

The application adds a module to the Modules folder in the project and opens a code
editor.
4. Enter following code into the module code editor:

Public Sub Processbata()
ProcessSheet2Data
ProcessSheet3Data

End Sub

Private Sub ProcessSheet3pata()
Activeworkbook.sheets("sSheet3").Activate

Range('"'DataTableFileList").AutoFilter Field:=1,
Criterial:=Cells(9, 1)

mutil.SortList "DataTableFileList", "AcquisitionDate"
End Sub

Ensure that your Visual Basic code looks like this:

Figure 70. VBA data

- ThermoCustomReportBaseTemplate1.xlsm - Module3 (Code)

BIX
|(General] j |Prncessnata ﬂ
Pulbhlic 2ub Processhatal) =l
Process3heetilata
Process3heetilata
End Suhk
Priwvate 3ub ProcessSheetiDatal)
betiveWorkbhook. 2heets ("2heet3™) L Aetivate
RBange ("DataTableFilelList™) .AutoFilter Field:=1, Criterial:=Cellsi(9, 1)

wltil.3ortlist "DataTableFilelist®™, "AcguisitionDate®
End Suhk

With this code and a RawFileName_SampleCentricData.xml file, the template is ready to run.
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Testing the Template

You are now ready to run a test from the Windows Start > Run box. In this test, the code you
enter does the following:

* Opens the Excel application.

* Creates a new workbook using the MyCalibrationReport.xltm template.

* Dasses the parameters to the template.

* Generates a report based on the level5_SampleCentricData.xml source file.

* Saves the report to the MyCalibrationReport.xlsm file.
Follow these procedures:

* To run the test

* To use the template in the TraceFinder application

< To run the test

1. Choose Start > Run.

The Run dialog box opens.

= Type the name of a program, folder, document, ar
= Inkernet resource, and Windows will open it for wou,

Open: | vl

[ Cancel ][ Browse. ., ]

Tip By default, the TraceFinder application file structure results in a long file path.
The Windows Run dialog box limits you to 256 characters. To work around this
limitation, either copy files to a folder close to the root directory or put the command
line into a batch file.

2. Enter this code in the Open box:

Excel.exe /n "C:\Thermo\Custom Report
Tutorials\MyCalibrationReport.x1tm" /x/C:\Thermo\
Custom|Report|Tutorials\Data\level5_SampleCentricbata.xml/C:\Thermo\
Custom|Report|Tutorials\Reports\MyCalibrationReport.xlsm/s/h

For detailed descriptions of the parameters used in this code, see “Testing the Template”
on page 27.

The generated report on your screen will be similar to the following example (actual data
varies depending on the batch you used):
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Testing the Template
Figure 71. Generated report
!’,/Eg: ) [ s I &9 * MiyCalibrationReport 20100714115648 xlsm - Microsoft Excel il
. - Home Insert Page Layout Formulas Data Review View Developer Add-Ins '@ - 3 X
“""' & Arial il lg = —| @ General i Eﬁ Conditional Formatting ~ j‘ﬂlnsert Ci P B ? Lﬁ
& CEMIIE Iu '||A‘A'| |E |- |8 - % ||| 5% Format as Table ~ 3% Delete - || [@]~ ;
Paste I T — | - T 2 P Sort & Find &
- F | e |3 | %8 58 5} Cell styles - [E)Format = | (2~ Filter~ Select~
Cliphoard & Font w|| " Alignment % | Number Styles Cells Editing
| G6 - @ & | ¥
< D E E__ e & | H I T R R—" i
L Calibration Report
2 1]
i _Lab name: Therme Fisher Lab Method: 2874 cal_test 2574
4 _fnstrumemr Therme Scientific Instrument cal test 2974
| 5___User: AMER\ming. liu Cali File: 2974 calx
6 |Batch: 'ZE!T-# 1
vl =
8 Pos [+|sample D [+|File Name [+ |level [v|Sample Nai~|File Date  [+|Comment [r]
91 cal std =5 ngful cal_std_5 c5 4137/2009 18:47 this is a Calibration Standard at 5ng
103 cal std=20ngfulcal std 20 c20 4/27/2009 18:52 this is a Calibration Standard at 20ng
115 cal std =100 ng/ucal_std 100 cl0 4/27/2003 18:56 this is a Calibration Standard at 100ng
75
76
77
M 4 v M[ Sheetl Sheet? | Sheet3  TempSheet ¥ . N Il
Ready 7 | || O |00

You are now ready to integrate the template into the TraceFinder application.

< To use the template in the TraceFinder application

Thermo Scientific

1. Copy your new template into the dedicated folder of the application:
C:\Thermo\Shared\Templates\Reports

2. Use this template the same way as the other delivered reports in the TraceFinder
application.

For detailed information about how to use custom reports, refer to the TraceFinder User

Guide.
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Creating a DCC Report
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In

this chapter, you will create an Excel template for a doping control center report similar to

the Steroid Analysis Report delivered with the TraceFinder application.

Contents

* Opening the Report Template

* Creating the Report Header

* Creating an Image Area

* Creating a Data Area

* Adding Derived Data

* Creating the Page Footer

* Creating a Compound Mapping Table
* Creating a Data Table

* Adding VBA Code

* Testing the Template

Commonly used in doping control centers, a DCC report is a special custom report that ties
to a specific method.

A DCC report, unlike other reports, does not use standard headers and footers. To create this
report template, you will use the provided add-in framework and the Excel formula capability
to adapt the formulas for your business needs.

Features of a DCC report include the following:

A highly condensed, single page, sample-level summary report
A specific method with about 26 compounds (up to 28 in the following example case)

The chromatograms displayed on the top of the report; the compounds and related data,
at the bottom

The compounds listed in a specific order (In the method, compound names are prefixed
with Z or ZZ to adapt to the special sorting needs. You will use an extra mapping table to
remove these prefixes on the actual report.)

Compound-related data and calculations based on this data displayed at the bottom of
the report
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Figure 72. DCC Report example
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As you create a DCC Report template, you will learn the following:

* How to create headers, footers, and other static objects

* How to create specific headers and footers not using the add-in framework

* How to create a compound mapping table that maps the compound names to displayed

text
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* How to use reference symbols in formulas
* How to use a TempSheet to hold a data table for compound-related information
* How to sort the data table by compound name after you import the data

* How to create a template that loops through each compound, finds its display name
through the compound mapping table, copies it to a display page, and creates the image
area for the compound

Before you begin creating a template for any report, identify the data points on the report and
understand how they map to the nodes in the XML Source.
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Opening the Report Template

For these step-by-step procedures, use the ThermoCustomReportBaseTemplate.xltm file that
you created in the Getting Started section as the basic template.

R

% To begin your DCC report template

In Windows Explorer, make a copy of the ThermoCustomReportBase Template.xltm file
and name the new copy MyDCCReport.xltm.

% To load the template file
1. Open the Excel application.
2. Click the Office button, () , and choose Open.
~

3. In the Open dialog box, do;.-lble—click MyDCCReport.xltm.

Tip Do not open this template file from Windows Explorer because, instead of opening
the template for editing, you create a new spreadsheet based on this template.
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7 Creating a DCC Report
Creating the Report Header

This report has many sections with different layouts on the same page, so having many

smaller columns makes the adjustment easier. You can use the Excel application to run text

from one cell over to the next cell as long as the cell is empty.

In this section, you will create static labels for the report header and then drag the data nodes
from the XML Source tree.

N W N

NN W

10.
11.
12.

To enter static labels for the report heading

. Type Data File: in cell A3.

. Type Sple Name: in cell A4.
. Type Inj Vol: in cell A5.

. Type Inst Meth: in cell AG.
. Type Dil Factor: in cell G5.
. Type Proc Mtd.: in cell G6.
. Type Cali File: in cell M3.

. Type Instr.: in cell M4.

. Type Vial: in cell M5.

Type Acqu. Date: in cell M6.

Hold down the CTRL key and select the label cells you just created.

Right-click and choose Format Cells from the shortcut menu.

The Format Cells dialog box opens.
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13. Click the Font tab to open the Font page.
Figure 73. Font page in the Format Cells dialog box

Format Cells

| Mumber || Alignment I Fank | Border || Fill || Protection |
Font: Font style; Sizes
Zalibri Fegular 11
Zambria {Headings ” a ”~
| Tkalic Q =
B adobe Gararmond Pro Bold 10 —
El adobe Gararmond Pro Bold Bold Italic
nderline: Colar:
|Nn:|ne v| |_ V| [+] Mormal Fant
Effects Prewview
[] strikethrough
[ superscript - AaBbCcYyZz
[] subscript

L 04 ] [ Cancel

14. In the Font Style box, select Bold.
15. Click OK.

You are now ready to add mapped nodes from the SampleCentricExportBatch folder.

Note A “node” in the XML Source tree creates a “field” in the spreadsheet.

K2

< To add mapped fields to the template

1. Click the Developer tab to display the Developer features.

Tip For instructions about how to enable the Developer tab, which is hidden by
default, see Chapter 3, “Getting Started.”

2. Click Source, I_@ .

Source

The spreadsheet displays the XML Source pane. You can drag mapped nodes from the
XML Source pane to the spreadsheet.

3. Open the SampleCentricExportBatch folder, and drag the nodes from the XML Source
tree to the appropriate table cell.

a.  Open the MethodHeaderData folder and drag the LabName node to cell R1.
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b. Open the Samples/SampleCentricExportSample folder and drag the RawFileName
node to cell C3.

c.  Open the Samples/SampleCentricExportSample folder and drag the SampleName
node to cell C4.

d. Open the Samples/SampleCentricExportSample folder and drag the
InjectionVolume node to cell C5.

e. Open the MethodHeaderData folder and drag the InstrumentMethodName node
to cell C6.

. Open the Samples/SampleCentricExportSample folder and drag the
ConversionFactor node to cell I5.

g.  Open the MethodHeaderData folder and drag the MethodName node to cell 16.

h. Open the MethodHeaderData folder and drag the CalibrationFile node to cell O3.

i. Open the MethodHeaderData folder and drag the InstrumentName node to cell
O4.

j. Open the Samples/SampleCentricExportSample folder and drag the VialPosition
node to cell O5.

Open the Samples/SampleCentricExportSample folder and drag the
AcquisitionDate node to cell O6.

Ensure that your template looks like the following example.

Figure 74. Template with header cells

!'.t!g Ho-oo s MyDCCReport.xltm - Microsoft Excel -
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. B =2 - 3 3 Delete - || (@]~
Paste | BosE B | &= A= = S g | % - % » [|%0 s%|| Conditional Format  Cell || .. . Sort& Find &
- - LU | - l ;3 I = |70 3-o] Formatting = as Table ~ Styles = L;jFormat * || &7 Filter~ Select~
Clipboard ™ Font & Alignment F} Number (F] Styles Cells Editing
| R1 oy | e
| A B 5 D E F G H 1 il K " M| N |O)|P Q Rl S 3 - & XML Source s
4k _Workup: Screening 4 - Anabolic Steroids (A4 DCL/S04): Page 1 - Endogenous hormone profile | ! #ML maps in this workbook:
2 ! SampleCentricExportBatch_Map b i
3  Data File: I_I CaliFile: | | = InstrumentMethodh A
4 |sple Name:lzl Instr. =] IonRangeCalclevel
5 Inj Vol I:l Dil Factor: I:l Viak (= IonRangeCalchethad
6 Inst Meth: l:l Proc Mtd.: Acqu. Date; ‘-J
=] LimitofDetectionFlag
7 | 1 imnitCFR enarkinaFlan
8 < |
9 To map non-repeating elements, drag the
i elements From the kree onto the workshest
10 ¢ where you want the data to appear,
W 4 » »| Sheetl /Sheet? , Sheetd , ¥J [ Al
Ready | 3
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Creating an Image Area

For each compound, you must show a quantitation peak chromatogram, the compound name
below the chromatogram, and the legend on the right, as shown in the following example.

Figure 75. Compound data as shown in a DCC report

miz-5ZZ
RT-11.2
| B= BE-ATTERE
| B AH-Z140057
| Amk-0.0
=

1ib-Hydrozyandrosterone

To create this image area, you will define three named ranges:
* QuanChart at cells A7 through D11 for holding the image
* CompoundName at cell A12 for holding the compound name

* ChartLegend at cells E7 through E12 for holding the legend

To create this DCC report template, you will duplicate this area 28 times. Use the ShiftRange
function to dynamically calculate the ranges for each compound at run time and use VBA
code to merge the ChartLegend cells after their value is populated.

Follow these procedures:
* To create the QuanChart named range in the template
* To merge the cells in the template
* To create the CompoundName named range in the template
* To create the ChartLegend named range in the template
* To add a border to the cell range
* To horizontally copy the QuanChart cell range
* To vertically copy the QuanChart cell range
* To adjust the ChartLegend columns
* To adjust the QuanChart columns

* To adjust the row height
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% To create the QuanChart named range in the template
1. Select cells A7 through D11.

2. Click the Formulas tab, and then click Define Name.

§ == Define Mame -

£ Use in Formula -
Mame
Manager B Create from Selection

Defined Mames

The application displays the selected cell range in the Refers To box of the New Name
dialog box.

Mew Mame E|

Mame: | |

SCope: | Warkbook, w |

Comrmenk:

Refers bo: |=Sheet1!$.ﬁ.$?:$D$11 Fs
[ o J [ Cancel

3. In the Name box, type QuanChart.
4. Click OK.

You are now ready to merge the cells.

< To merge the cells in the template
1. Select cells A7 through D11.
2. Click the Home tab to display the Home functions.

3. Click the Merge & Center down arrow in the Alignment area.

| §| @Wrap Text

| |2 £=|| = Merge&Centerq
Alignm @ Merge & Center
Merge Across
E[ﬂ Merge Cells
E Unmerge Cells

4. Choose Merge Cells from the menu.

You are now ready to create a named range for the compound.
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< To create the CompoundName named range in the template

1. Select cell A12.
2. Click the Formulas tab to display the Formulas functions.
3. Click Define Name in the Defined Names area.

== Define Mame ~

F£2 Use in Formula -
Mame
Manager B Create from Selection

Defined Mames
The selected cell automatically appears in the Refers To box of the New Name dialog box.
I Refers to: | _checriigagiz I

4. In the Name box, type CompoundName.
5. Click OK.

You are now ready to create a named range for the legend and align the text from the bottom
to the top of the range.
< To create the ChartLegend named range in the template

1. Select cells E7 through E12.

2. Click the Formulas tab, and then click Define Name.

== Define Mame ~

F2 Use in Formula =
Mame
Manager B Create from Selection

Defined Mames

The selected cell range automatically appears in the Refers To box of the New Name

dialog box.

| Befers to: | _tampshestigEg7:gE412 |
3. In the Name box, type ChartLegend.
4. Click OK.

N

. Select the cells in the ChartLegend cell range: cells A7 through D11.
6. Right-click and choose Format Cells from the shortcut menu.

The Format Cells dialog box opens.
7. Click the Alignment tab to open the Alignment page.
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Figure 76. Alignment page in the Format Cells dialog box
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8. In the Vertical list, select Top.

9. Click OK.
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< To add a border to the cell range
1. Select cells A7 through E12.

The selected cells look like this:

6
7
8
3
10
11
12 1

These selected cells include the area for the image, the column on the right for the legend,
and the row at the bottom for the compound name.

2. Click the Home tab to display the Home functions.

3. Click the down arrow next to the Borders icon in the Font area.

Calibri ~l11 || A AT

‘B I U -||EH~&5- A

Fq Borders

Bottom Border
Top Border
Left Border
Right Border

Mo Border
EH ' anBorders
Outside Borders

4. Choose Outside Borders from the menu.

The bordered cells look like this:

6
7
8
3
10
11
12
12

In the next procedures, you will make 28 copies of the bordered area.
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7 Creating a DCC Report
Creating an Image Area

To horizontally copy the QuanChart cell range

. Select the cells A7 through E12.

To select the cells, do not click the bordered area; you must drag your cursor across all the
cells.

Right-click and choose Copy from the shortcut menu.
Right-click cell F7 and choose Paste from the shortcut menu.

Repeat Step 3 for cells K7 and P7.

The copy/paste function copies the cells and the border, but it does not copy the named
ranges.

*»*

1.

L

To vertically copy the QuanChart cell range

Select rows 7 through 12.

Right-click and choose Copy from the shortcut menu.
Right-click cell A13 and choose Paste from the shortcut menu.

Repeat Step 3 for cells A19, A25, A31, A37, and A43.

You now have 28 image areas for holding up to 28 compounds. Each of the areas displays data
that look like this:

. 1ib-Hydrozyandrosterone

miz-5EE
RT-11.z
AR-ATTERTE
AH-Z1d005T
Ame-0.0

In the next procedures, you will adjust the columns in your spreadsheet.

0‘0

1.
2.

To adjust the ChartLegend columns
Click the header for column E (the first legend column).
Drag the separator between column E and column F until column E is 6.00 points wide.

The Excel application displays the column width as you drag the separator.

Ism

Width: 6,00 [47 pixels) |
E 1-|: F G
E 1

Repeat Step 1 for each of the other legend columns (J, O, and T).
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< To adjust the QuanChart columns
1. Click the header for column A (the first chart column).
2. Drag the separator between column A and column B until column A is 4.00 points wide.
The Excel application displays the column width as you drag the separator.

3. Repeat Steps 1 and 2 for each of the other chart columns (B, C, and D), (E G, H, and I),
(K, L, M, and N), and (B, Q, R, and S).

< To adjust the row height
1. Click the number for row 7.

2. Drag the separator between row 7 and row 8 until row 7 is 4.00 points in height.

Tip The right separator controls the column width; the bottom separator controls the
row height.

3. Repeat Steps 1 and 2 for each of the other rows (through row 48).

Ensure that your template looks like the following example.

Figure 77. Template with 28 image areas
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Ready | &
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Creating a Data Area
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At the bottom of Sheetl, you will reserve up to 28 rows for displaying data for up to 28
compounds. See the “DCC Report example” on page 134.

For following procedure, create the column headers and populate the data at run time using

VBA code.

SRV RN

7.

To enter static labels for the column headers in the template

. Type Name in cell A50.
. Type Symbol in cell E50.

This column will later act as a key for the VBA Vlookup function.

. Type RT in cell F50.
. Type Cal. Amt in cell H50.

Type Resp in cell ]50.
Type Type in cell K50.
Type Diagnostic Behaviors in cell M50.

You are now ready to group the data and create a named range.

To create a named range for the data in the template

. Select cells E51 through K78.

. Click the Formulas tab, and then click Define Name.

~=) Define Mame =

£ Use in Formula -
Mame
Manager B Create from Selection

Defined Mames

The selected cell range automatically appears in the Refers To box of the New Name
dialog box.

I Refers to: | —cheeti 14447140611 I
In the Name box, type DataArea.

Click OK.

To make everything fit onto a page, make the data rows smaller. Change the row height to
9 points for rows 50 through 78.
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Adding Derived Data

In this section, you will add derived data to Sheetl. The finished sheet will look like this:
Figure 78. Completed template with derived data
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Follow these procedures:
* To enter static labels for the derived data in the template
* To format the heading font in the template
* To add the check boxes to the template

* To enter the formulas in the template

148 TraceFinder Custom Reports Tutorial Thermo Scientific



7 Creating a DCC Report
Adding Derived Data

< To enter static labels for the derived data in the template
1. Type Diagnostic Behaviors in cell M50.
. Type T/E (conc) in cell M53.
. Type Expected and Reference limits (ng/ml) in cell M57.
. Type Alter in cell M62.

2

3

4

5. Type Hydrolyze in cell M65.

6. Type Derivatization in cell M68.
7

. Type IS-Areas in cell M71.

You are now ready to format these headings with bold font.

% To format the heading font in the template
1. Hold down the CTRL key and select the label cells you just created.
2. Right-click and choose Format Cells from the shortcut menu.
The Format Cells dialog box opens.
3. Click the Font tab to open the Font page.
See “Font page in the Format Cells dialog box” on page 138.
4. In the Font Style box, select Bold.

You are now ready to add check boxes to specific cells.

< To add the check hoxes to the template

1. Type q in cell R53.

2. Right-click cell R53 to display the following pop-up box.

Calibri ~11 - A" A" $ - % » <f
B I =-b-A-51058

L1

3. Click the down arrow next to Calibri (Calibri is the spreadsheet default font).

4. From the list of fonts, choose Wingdings.
The q in Wingdings font looks like this:

o
5. Repeat steps 1 through 4 for cells T58, S66, S69, and S72.

You are now ready to enter the formulas for the derived data.
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150

10.

11.

12.

13.

To enter the formulas in the template

. In cell P52, enter the following formula:

=IF(VLOOKUP("E", DataArea, 6, FALSE) = 0, 0, VLOOKUP("T", DataArea, 6,
FALSE) / VLOOKUP("E", DataArea, 6, FALSE))

In cell P53, enter the following formula:

=IF(VLOOKUP("E", DataArea, 4, FALSE) = 0, 0, VLOOKUP("T", DataArea, 4,
FALSE) / VLOOKUP("E", DataArea, 4, FALSE))

In cell P54, enter the following formula:

=IF(VLOOKUP("Etio", DataArea, 4, FALSE) = 0, 0, VLOOKUP("Andro",
DataArea, 4, FALSE) / VLOOKUP("Etio", DataArea, 4, FALSE))

. In cell P55, enter the following formula:

=IF(VLOOKUP("T", DataArea, 4, FALSE) = 0, 0, VLOOKUP("Andro",
DataArea, 4, FALSE) / VLOOKUP("T", DataArea, 4, FALSE))

In cell T54, enter the following formula:

=IF(VLOOKUP("T", DataArea, 4, FALSE) = "0", "Im 0", "Not 0")

In cell P58, enter the following formula:

=VLOOKUP("Andro", DataArea, 4, FALSE)

In cell P59, enter the following formula:

=VLOOKUP("Etio", DataArea, 4, FALSE)

In cell P60, enter the following formula:

=VLOOKUP("DHEA", DataArea, 4, FALSE)

In cell S58, enter the following formula:

=VLOOKUP("E", DataArea, 4, FALSE)

In cell §59, enter the following formula:

=VLOOKUP("T", DataArea, 4, FALSE)

In cell S60, enter the following formula:

=IF(VLOOKUP("c-DHEA", DataArea, 6, FALSE)=0, "N/A", VLOOKUP("DHEA",
DataArea, 6, FALSE) / VLOOKUP("c-DHEA", DataArea, 6, FALSE))

In cell Q63, enter the following formula:

=IF(VLOOKUP("Etio", DataArea, 6, FALSE) = 0, 0, IF(VLOOKUP("S_Etio",
DataArea, 6, FALSE) = 0, 0, VLOOKUP("Etio", DataArea, 6, FALSE) /
(VLOOKUP("Etio", DataArea, 6, FALSE) + VLOOKUP("S_Etio", DataArea, 6,
FALSE))))

In cell Q66, enter the following formula:

= IF(VLOOKUP("MT", DataArea, 6, FALSE) = 0, 0, 066 *
VLOOKUP("D5-Andro", DataArea, 6, FALSE)/VLOOKUP("MT", DataArea, 6,
FALSE))

TraceFinder Custom Reports Tutorial Thermo Scientific



7 Creating a DCC Report
Adding Derived Data

14. In cell Q69, enter the following formula:

=IF(VLOOKUP("Andro" ,DataArea,6,FALSE)=0,0,IF(VLOOKUP("Andro-mono",Dat

aArea, 6,FALSE)

=0,0,VLOOKUP("Andro" ,DataArea, 6,FALSE)/(VLOOKUP("Andro" ,DataArea, 6, FA
LSE)+VLOOKUP("Andro-mono" ,DataArea,6,FALSE))))

15. In cell Q72, enter the following formula:

=TEXT(VLOOKUP("MT", DataArea, 6, FALSE), "0,000")

All the formulas are included in the Excel look-up function based on the symbols defined in
the named range DataArea. These formulas are evaluated and filled after data is imported and

copied to the DataArea range.

The derived data area in your template looks like this:

Figure 79. Template with derived data

Thermo Scientific
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Creating the Page Footer

In this section, you will create a footer for the data table.

< To enter static labels for the report footer
1. Type Verified: in cell A79.
2. Type Bacteria: in cell A79.
3. Type Positive: in cell A79.
4

. Type Substances: in cell A79.

% To add the check boxes
1. Type q in cell I79.
2. Right-click cell 179 to display the following pop-up box.

Calibri ~11 - A" A" $ - % » <f
B I=H-b-A-<10E

L1

3. Click the down arrow next to Calibri (Calibri is the spreadsheet default font).

4. From the list of fonts, choose Wingdings.
The q in Wingdings font looks like this:

a

5. Repeat steps 1 through 4 for cell M79.

The footer of your template looks like this:

Figure 80. Template with footer
FE

i

Fi=

Fis}

7

78

79 Verified: Bacteria: O Positive: O Substances:

80
M 4 » M| Sheetl Sheet2 -~ Sheet3 ~ ¥J T
rReady | 5 Uﬁ@ | 100%
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Creating a Compound Mapping Table

Thermo Scientific

The DCC report requires listing the compounds in a specific order. You will create a mapping
table that serves two purposes:

* Sorting: This report need a special sorting order using prefixes in the compound names in
the method. Later, you will remove the prefixes from the report.

* Reference: Many formulas in the area M51 through T72 use the Excel application
Vlookup function. Instead of using actual compound names, you will use a symbol for
some of the compounds.

The first column of the mapping table contains the compound names that must match the
names defined in the method.

The second column of the mapping table contains any names you want to display on the
report.

The third column of the mapping table contains symbols for the compounds that you will
reference in the formulas. Using symbols instead of compound names makes the formula
easier to read and maintain (for example, you can change the display name without changing
the formula).

You will use the values in the following table to create a mapping table in your template.

Table 1. Mapping table column values (Sheet 1 of 2)

Name in method Name to be displayed Symbol
11b-Hydroxyandrosterone 11b-Hydroxyandrosterone
11b-Hydroxyetiocholanolone 11b-Hydroxyetiocholanolone
16-Androstenol 16-Androstenol

Allotetrahydrocortisol Allotetrahydrocortisol

Androstandiolel Androstandiolel

Androstandiole2 Androstandiole2

Androstendione Androstendione

Androsterone Androsterone Andro
Cortisol Cortisol

Cortisone Cortisone

Dehydroepiandrosterone Dehydroepiandrosterone DHEA
Dihydrotestosterone Dihydrotestosterone

Epitestosterone Epitestosterone E
Etiocholanolone Etiocholanolone Etio
Etiocholanolone_S_Artefact Etiocholanolone_S_Artefact S_FEtio
Methyltestosterone Methyltestosterone MT
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Table 1. Mapping table column values (Sheet 2 of 2)
Name in method Name to be displayed Symbol
Norandrosterone Norandrosterone
Pregnandiole Pregnandiole
Testosterone Testosterone T
Tetrahydrocortisol Tetrahydrocortisol

Z-Androsterone_mono

Androsterone_mono

Andro-mono

7d5_Stanozolol M1

d5_Stanozolol M1

Zd5-Androsterone_bis d5-Androsterone_bis D5-Andro
Zd5-Norandrosterone d5-Norandrosterone

ZTestosterone-d3 Testosterone-d3

Z77_Cyclo_DHEA Cyclo_DHEA c-DHEA

K2
0‘0

Follow these procedures:

* To enter static labels for columns in the template

* To add the compounds in the template

* To create a named range for the data in the template

* To hide the mapping table columns in the template

To enter static labels for columns in the template

1. Type Name in Method in cell V50.

2. Type Name to be displayed in cell W50.

3. Type Symbol in cell X50.

To add the compounds in the template

1. In cells V51 through V76, type the compound names.

2. In cells W51 through W76, type the display names.

You are now ready to add the compounds, display names, and symbols to the mapping table.

In most cases, these names are the same as the compound names, but for the last few

compounds, just remove the Z or ZZ from the name. The Excel application uses leading
Zs to sort those compounds to the bottom of the list.

3. In the Y column, type the symbols for the specified compounds.

You will use the symbols indicated here in the formulas for this report.
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You are now ready to create a named range for this mapping table. You will reference this
named range in the VBA code.
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< To create a named range for the data in the template
1. Select cells V51 through X78.
2. Click the Formulas tab, and then click Define Name.

A=) Define Mame ~
£ Use in Formula -
Mame
Manager B Create from Selection

Defined Mames

The selected cell range automatically appears in the Refers To box of the New Name

dialog box.

I Refers to: | —sheet1 14451 14475
3. In the Name box, type CompoundMapTable.

4. Click OK.

Ensure that your template looks like the following example.

Figure 81. Template with compound mapping table
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You are now ready to hide the mapping table. The mapping table will not be visible in the
generated report.
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< To hide the mapping table columns in the template
1. Select columns V, W, and X.
2. Right-click and choose Hide from the shortcut menu.

The Excel application hides columns V, W, and X. At any time, you can restore the
contents of the hidden columns.

To restore columns V, W, and X, do the following:
a.  Select columns U and Z.

b. Right-click and choose Unhide from the shortcut menu.
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Creating a Data Table
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The source data reported in cells A5 through T78 come from the *_SampleCentricData.xml
file, but because of the special sorting needs, you cannot use the data directly. In this section,
you will put that imported data in a temporary sheet that you will use to fill in the report at

run time.

Follow these procedures:
* To remove Sheet3 in the template
* To rename Sheet2 in the template
* To add mapped nodes to the template
* To add seven new helper columns to the template
* To change the cell format in the template
* To rename the column headers in the template
* To enter the formulas in the template

* To name the table in the template

% To remove Sheet3 in the template

Right-click the Sheet3 tab and choose Delete from the shortcut menu.

< Torename Sheet2 in the template
1. Right-click the Sheet2 tab and choose Rename from the shortcut menu.

2. Type TempSheet and press ENTER.

You are now ready to add mapped nodes from the SampleCentricExportBatch folder by
dragging the nodes from the XML Source tree to the appropriate table cell.

< To add mapped nodes to the template

1. Open the Samples/SampleCentricExportSample/ Compounds/
SampleCentricCompoundExportData folder and drag the CompoundName node to cell
Al.

2. Open the Samples/SampleCentricExportSample/ Compounds/
SampleCentricCompoundExportData/QuanResult folder and drag the
ActualRTDisplayValue node to cell B1.

3. Open the CalibrationData/ CompoundCurveExportData/CalibrationReplicates/
SampleCompoundReplicateExportData folder and drag the CalculatedAmount node to
cell C1.
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4. Open the Samples/SampleCentricExportSample/ Compounds/
SampleCentricCompoundExportData/QuanResult folder and drag the TotalResponse
node to cell D1.

5. Open the Samples/SampleCentricExportSample/ Compounds/
SampleCentricCompoundExportData folder and do the following:

a. Drag the ResponseValue node to cell E1.

b. Drag the CompoundType node to cell F1.
c. Drag the CompoundKey node to cell G1.
d. Drag the QuanMassRange node to cell H1.

6. Open the SampleCentricExportBatch/Samples/SampleCentricExportSample/
Compounds/SampleCentricCompoundExportData/QuanPeakldentifiers/
QuanPeakIdentifierExportData/PeakDetectionParameters folder and drag the
FilterString node to cell I1.

7. Open the Samples/SampleCentricExportSample/ Compounds/
SampleCentricCompoundExportData/QuanResult folder and do the following:

a. Drag the TotallonArea node to cell J1.
b. Drag the TotallonHeight node to cell K1.
c. Drag the ManuallntegrationFlagSet node to cell L1.

8. Open the CalibrationData/ CompoundCurveExportData/CalibrationReplicates/
SampleCompoundReplicateExportData folder and drag the Units node to cell M1.

You are now ready to create helper columns to massage the data for display.

% To add seven new helper columns to the template

1. Right-click the Units header cell and choose Insert > Table Column to the Right from
the shortcut menu.

The Excel application adds a new column with the default name Columnl1 to the right of
the M column.

2. Right-click the Column1 header cell and choose Insert > Table Column to the Right
from the shortcut menu.

3. Continue to right-click the last column and add a column to the right until you have
seven new columns named Column1-Column?7.

Ensure that your new column headers look like this:
5 ™ N 0 P Q R 5 T

You are now ready to change the cell formats from Text to General.
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To change the cell format in the template
Right-click the Column1 cell and choose Format Cells from the shortcut menu.

The Format Cells dialog box opens.

2. Click the Number tab to open the Number page.

3.
4.

5.

Figure 82. Number page in the Format Cells dialog box

Format Cells
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Special
Zuskom

(0] 4 l [ Zancel

Select General in the Category list and click OK.
While the Column1 cell is still selected, press ENTER.

The Excel application does not automatically update the new cell format. Pressing
ENTER manually updates it.

Repeat steps 1 through 5 for each of the seven columns that you added.

You are now ready to give the column headers meaningful names.

To rename the column headers in the template
In cell N1, change Columnl to Response.

In cell O1, change Column2 to MassCharge.

In cell P1, change Column3 to RT.

In cell Q1, change Column4 to Arealntensity.
In cell R1, change Column5 to HeightIntensity.
In cell S1, change Column6 to Amt.

In cell T1, change Column? to ChartLegend.

You are now ready to enter formulas for these seven columns.

Thermo Scientific
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< To enter the formulas in the template

For each listed cell, enter the following formula:

a. Cell N2
=TEXT(D2, "0")
b. Cell 02
="m/z=" & H2
c. Cell P2
="RT=" & B22
d. CellQ2
=IF(L2, "™M", "A") & "A=" & TEXT(32, "0")
e. CellR2
=IF(L2,"M","A")&"H="&TEXT(K2,"0")
f. Cell S2
="Amt=" & TEXT(C2, "0.0™)
g. Cell T2

= 02 & CHAR(10) & P2 & CHAR(10) & Q2 & CHAR(10) & R2 & CHAR(10) & S2

This formula concatenates all legend fields and makes them ready to use on the report.

You are now ready to name the table you just created.
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% To name the table in the template

1. Click the Formulas tab and then click Name Manager.

Mame Manager

Mame Value Refers To SCope Comment
= CompoundMapT.., "ML =Sheet 1 1EvES1$YETS workbook,
=l data o o v —ohest11§YES1i5047E Workbook
] DataTable i ey =Tempsheet!$adz: 3042 Workbook
7 Tables - Terncheck £ 162 4742 wiorkbook
1 Tables =TempSheet!$H$2:$HEZ  Workbook
] Tables o =TempSheet!$E42: 4342 Workbook
< | >
X[~ | s

2. In the Name Manager dialog box, double-click the name of the table you created.
The name will vary depending on how many tables you created.
The Edit Name dialog box opens.
3. Change the name to DataTable and click OK.
4. Click Close in the Name Manager dialog box.
Ensure that your template looks like the following example.

Figure 83. Completed data table layout
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3
pa .l =HE
W < b W[ Sheeti | TempSheet <%0 T I
Reagy | 23

The template interface design is completed. In the next section, you will add VBA code to
populate the data from the DataTable on TempSheet to the columns on Sheet1.
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Adding VBA Code
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You are now ready to use VBA code to populate the columns on Sheetl of the template.

Follow these procedures:
* To connect the VBA data to the template
* To remove code from the MyUltil class module
* To edit the Modulel module
* To run the test

* To use the template in the TraceFinder application

< To connect the VBA data to the template

1. Click the Developer tab to display the Developer features.
2. Click Visual Basic, icl .

Visual
Basic

The Microsoft Visual Basic window opens.

Because this report does not use the standard header and footer, in the next procedure, you
will remove the header and footer code.

< To remove code from the MyUtil class module

1. To remove the code that specifies the footer, type a single quote (tick mark) to comment
out the footer code:

Private Sub IUtil_SetupPageFooter()

mutil.SetupPageFooter "", 0.5

End Sub

2. To remove the code that specifies the header, type a single quote (tick mark) to comment
out the header code:
Private Sub IUtil_SetupPageHeader()

mUtil.SetupPageHeader
End Sub
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Your MyUtil code looks like this:

Option Explicit

Implements IUtil

Private Sub IUtil_Processbata()
ProcessData

End Sub

Private Sub IUtil_SetupPageFooter()

' mUtil.SetupPageFooter "", 0.5

End Sub

Private Sub IUtil_SetupPageHeader()

! mUtil.SetupPageHeader

End Sub

Private Function IUtil_validate(Optional showwarning As Boolean =
True) As Boolean

IUtil_validate = validate(showwarning)

End Function

To edit the Module1 module

. Click Modulel.

The Modulel window contains the code you inherited from the
ThermoCustomReportBaseTemplate.xml template.

. Replace the base template code with the following code:

Option Explicit

' called after xml data gets imported

Public Sub Processbata()
ProcessSheetlData

End Sub

Private Sub ProcessSheetlData()

Dim i As Long, r As Long, Cc As Long, compName As String, compId As
String, arrCompounds() As String

Dim rr As Long, cc As Long
Activeworkbook.sSheets("sheetl").Activate
' Sort the data table by compound name

mUtil.SortList "DataTable", "CompoundName", Sheets("TempSheet")
' Get a unique list of compound names

arrCompounds = muUtil.GetUniqueList("DataTable", 1)

For i = 1 To UBound(arrcCompounds)

r Int((i -1 /4) +1 ' row number
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c=( -1) Mod 4 + 1 ' col number
rr = (r-1) *6 ' row offset
cc=(Cc-1) *5 ' col offset

v

Get the compound display name from the CompoundMapTable

compName = muUtil.vLookup(arrCompounds(i),
Range ("CompoundMapTable™), 2, False)

If compName <> "" Then
' Copy compound display name to column A starting from row
51
Range("A" & 50 + i) = compName
' Copy compound display name to the image area under the
image

Range ("'CompoundName") .0ffset(rr, cc) = compName

Copy symbol to column E starting from row 51

Range("E" & 50 + i) = mutil.vLookup(arrcompounds(i),
Range (" CompoundMapTable"), 3, False)

Copy RT to column F starting from row 51

Range("F" & 50 + i) = mutil.vLookup(arrcompounds(i),
Range("DataTable"), 2, False)

Copy Calc Amt to column H starting from row 51

Range("H" & 50 + i) = mutil.vLookup(arrcompounds(i),
Range('"DataTable"), 3, False)

Copy Units to column I starting from row 51

Range("I" & 50 + i) = mutil.vLookup(arrcompounds(i),
Range("DataTable"), 13, False)

Copy Response to column J starting from row 51

Range("J" & 50 + i) = mutil.vLookup(arrcompounds(i),
Range("DataTable"), 14, False)

Copy Respvalue to column K starting from row 51

Range("K" & 50 + i) = mutil.vLookup(arrcompounds(i),
Range("DataTable"), 5, False)

Set the legend next to the image

mutil.shiftRange("ChartLegend", cc, rr, cc, rr) =
mUtil.vLookup(arrCompounds(i), Range("DataTable"), 20, False)

' Merge the legend cells and make the text wrap
with mutil.shiftRange("ChartLegend", cc, rr, cc, rr)
.MergeCells = True

.WrapText = True

End With

v

Application.Calculate Refresh formula

Load images in place

Thermo Scientific



Thermo Scientific

7 Creating a DCC Report
Adding VBA Code

compId = mutil.vLookup(arrCompounds(i), Range("DataTable"),
7, False)

muUtil.CreateImage mutil.ShiftRange("Quanchart", cc, rr, cc,
rr),
"sampleCentricExportBatch/Samples/SampleCentricExportSample/Compounds
/SampleCentricCompoundExportDatal[Compoundkey="'" & compId &
"']/QuanResult/QuanPeakResults/CompoundQuanPeakResultExportData/PeakI
mage", 20, 5, 12, 2

End If
Next
mUtil.HideColumns "v:AA"
Activeworkbook.Sheets("TempSheet™) .Delete

' mUtil.AddTextAswatermark "Thermo Custom Report",
Range("Sheetl!Al:T78")

End Sub

validate the template design e.g. named ranges

PubTic Function validate(Optional showwarning As Boolean = True) As
Boolean

validate = True

End Function
Where:
* SortList sorts the data table by the compound name.

* GetUniqueList retrieves a unique list of compound names that will be used for
looping into each compound.

* CopyPaste copies the following columns from the data table on TempSheet to the
data area at the bottom of Sheet1:

— DisplayRetentionTime
— CalculatedAmount

—  Units

— Response

—  ResponseValue

* To loop through for each compound, the VBA functions do the following:

—  Calculate the row and column offset that will be used to place the compound
name, image and legend for each compound.

—  VLookup gets the compound display from the CompoundMapTable.

— Range("A" & 50 + i)... copies the compound display name to the data area
starting at Al below each quantitation chart.
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— Range("CompoundName").Offset(rr, cc)... copies the compound display

name to the data area below each quantitation chart.
— Range("E" & 50 + i)... copies the symbol to column E starting from E51.

—  ShiftRange shifts the legend for the image by the specified offset and copies it to
the ChartLegend named range.

—  Merge the legend cells and set the WrapText property to true so that no text runs
over the next cell.

—  Load the image from the XML file based on the CompoundKey.
* ActiveWorkbook.Sheets("TempSheet").Delete deletes the TempSheet.

3. To use the Visual Basic compile function to check for errors, choose Debug > Compile

VBAProject.

To use this template to create an Excel report, you must have specific compounds defined in
your method or you must modify the CompoundMapTable to fit your method.
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Testing the Template

You are now ready to run a test from the Windows Start > Run box. In this test, the code you

enter does the following:

Opens the Excel application.

Creates a new workbook using the MyDCCReport.xltm template.

Passes the parameters to the template.

Generates a report based on the 4bw01_SampleCentricData.xml source file.

Saves the report to the MyDCCReport.xlsm file.

Follow these procedures:

R
0’0

1.

3.

Thermo Scientific

To run the test

To use the template in the TraceFinder application

To run the test

Choose Start > Run.

The Run dialog box opens.

= Type the name of a program, folder, document, ar
= Inkernet resource, and Windows will open it for wou,

Open: | vl

[ Cancel ][ Browse. ., ]

Tip By default, the TraceFinder application file structure results in a long file path.
The Windows Run dialog box limits you to 256 characters. To work around this
limitation, either copy files to a folder close to the root directory or put the command
line into a batch file.

. Enter this code in the Open box:

Excel.exe /n "C:\Thermo\Custom Report Tutorials\MyDCCReport.xTtm"
/x/C:\Thermo\Custom|Report|Tutorials\Data\4bw0O1l_SampleCentricbata.xml
/C:\Thermo\Custom|Report|Tutorials\Reports\MyDCCReport.xlsm/s/h

For detailed descriptions of the parameters used in this code, see “Testing the Template”
on page 27.

Click OK.
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Ensure that the generated report on your screen is similar to the following figure (actual data

will vary depending on the batch you used):

Figure 84. DCC Report example
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You are now ready to integrate the template into the TraceFinder application.
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< To use the template in the TraceFinder application
1. Copy your new template into the dedicated folder of the application:

C:\Thermo\Shared\Templates\Reports

2. Use this template just as you would any of the custom reports in the TraceFinder
application.

For detailed information about how to use custom reports, refer to the TraceFinder User
Guide or Chapter 3, “Getting Started.”
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Frequently Asked Questions

This appendix answers frequently asked questions about TraceFinder custom reports. The
tutorial chapters provide additional instructions.

Contents

* General Questions
* Data Table Questions
* Image Handling Questions

* Debugging Questions
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General Questions

This section covers general questions about TraceFinder custom reports.
* How Do I Find the Excel Version Number?
* How Do I Enable the Developer Tab?
* What Is a Named Range in Excel?
* How Do I Use the Command Line to Generate the Excel Report?
* Why Does My Excel Report Show a Security Warning When I Open I¢?
* Why Are Page Numbers Not Sequential Across All Pages?
* How Do I Change the Default Logo Image for All Reports?

* Why Do I Need to Use the Add-in Copy/Paste Function Instead of the Excel Copy
Function?

* How Do I Add a Watermark to a Report?
* Why Do I Get a “File in Use” Error Message?

How Do | Find the Excel Version Number?

< To find the Excel version number

1. Open the Excel application.

2. Click the Office button, @ , and click Excel Options,

[#] Excel Options |.

3. In the left pane of the Excel Options dialog box, click Resources.

The Resources page of the Excel Options dialog box shows the version number.

Excel Options ‘?”i]
Popular | ! Diagnose and repair problems with your Microsoft Office programs, &)
Formulas contact us
Proofing Let us know if you need help, or how we can make Microsoft Office better,

S activate Microsoft Office

Adwanced Activation is required to continue using all the features in this product.

Customize go to Microsoft Office Online
Adddns Get free product updates, heip, and online services at Microsoft Office Online.

| TrustCenter || abgut Microsoft Office Excel 2007 About
© Resources | N Microsoft® Office Excel® 2007 (12,0.65.24.5003) 5F2 MO [12.0,6529,.5000) j |
| | A

| o || conce |

J
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How Do | Enable the Developer Tah?

Thermo Scientific

To start Visual Basic development in the Excel application, you must enable the Developer

tab, which is hidden by default.

% To enable the Developer tab

1. Click the Office button, '@ , and click Excel Options,

[z] Excel Options |.

2. Click Popular.

3. Select the Show Developer Tab in the Ribbon check box.
Figure 85. Excel Options Popular dialog box

Excel Options @E

[ F o ] I s
& Change the most popular options in Excel. =
Formulas
Froofing Top options for working with Excel
Save Show Mini Toolbar on selection(i®
Advanced Enable Live Preview (1)
vance |
l Show Developer tab in the Ribbon ] T
Customize Always use ClearType
AddIns Color scheme: | Blue ™
Trust Center ScreenTip style: | Show feature descriptions in ScreenTips b
Resources Create lists for use in sorts and fill sequences: [ Edit Custom Lists.., ]
o
L QK _] [ Cancel ]
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What Is a Named Range in Excel?

You can define a name for a range of cells, and you can use this name in formulas or the VBA
code to refer to that cell range.

K2

< To specify a name for a range of cells
1. Select the cells.

2. Click the Formulas tab.

3. Click Define Name.

The application displays the selected cell range in the Refers To box of the New Name

dialog box.
New Name @
Marne: | |
Scope: | Workbaok, - |
Commenk:
Refers to: | _cheati1$§36:$v440 i
[ (0’4 ][ Cancel ]

The Excel application automatically assigns a default name to some objects, for example, data

tables and shapes.

< To add, remove, or modify a name
1. Click the Formulas tab.

2. Click Name Manager.
The Name Manager dialog box opens.

Mame Manager |E@
Mew, ., Edit.

ame Value Refers To Scope
T DataTable Juo v w07 —Sheetl1$AF9:4L$9 Workbook
=l MoData =5Sheet1 14647 Warkbook
I e
Xl | .5

3. In the Name Manager dialog box, do one of the following:
Click New and create a new name.
—Or—
Select the name to edit and click Edit or Delete.
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How Do | Use the Command Line to Generate the Excel Report?

When you develop a new report template or modify an existing one, you might want to test it
before using it in the application. You can use the Windows Run box in the Start menu for
this purpose. Use this command:

Excel.exe /n [/embedded] TEMPLATEFILE
/X/ SAMPLECENTRICDATAFILE/OUTPUTFILE[/s]1[/h]1[/p PRINTERNAME]
L/vIL/c1l/h]L/F10/110/b]10/gl/€]11/d]]

Example:

Excel.exe /n "C:\Thermo\Custom Report Tutorials\MyBatchReport.xltm"
/x/C:\Thermo\Custom|Report|Tutorials\Data\lngrep5_SampleCentricbata.x
ml/C:\Thermo\Custom|Report|Tutorials\Reports\BatchReport.xIsm/s/h

Where:

* The /n switch tells Windows that you are using this template to create an Excel
spreadsheet, not to edit the template itself. Without this switch, the Excel application
opens the specified template for editing.

e The /embedded switch tells Windows to run Excel embedded—that is, in silent mode. In
this case, you do not see the Excel spreadsheet on the screen, but it is still visible in the
Task Manager. When this switch is on, make sure you also include the /c custom switch
to automatically close the Excel application after it generates the report. Otherwise, the
Excel application runs until you shut down Windows or you end it in the Task Manager.

* The template file path must be enclosed in quotation marks if it contains any spaces.
Otherwise, the Excel application considers each item separated by a space as a separate
Excel workbook and tries to load it. As a result, you receive an error message.

IMPORTANT There must be a space before /x to tell Windows to pass everything
after this space to the Excel template. Do not add a quotation mark after this space. If
you do, Windows considers it an instruction to open a second spreadsheet, and you
receive an error message.

* The /x switch is an internal switch special to custom reports. The custom report add-in
processes all parameters after /x.

IMPORTANT Both the Excel application and the operating system require that
parameters after /X contain no spaces. This requirement is imposed by the Excel
application and the operating system. When you need a space, use a vertical bar (|)
instead. The add-in replaces all bars with spaces. To illustrate, the example given
earlier in this section uses vertical bars in the name of the Custom Report Tutorials

folder.

* The custom parameters after /X use a slash, /, as a separator. The first two parameters
after /x are required. All others are optional.
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* The first parameter after /x tells the add-in where the XML Source data is located. The

template location does not matter, as long as you correctly specify the path name.
p gasy y sp p

However, for the TraceFinder application to use the template, the template must be
located in a dedicated folder.

* The second parameter after /x specifies the name of the path where the add-in saves the
generated Excel spreadsheet.

* The custom switches are the following:

/s tells the add-in to save the file in the location specified by the second custom
parameter before closing the workbook. Without this switch, the spreadsheet is
generated, but not saved.

/h tells the Excel application to hide the screen update. This switch makes the report
generation faster, especially when the report is large. It also reduces screen flashes.

/p prints the report. You can optionally specify the printer after this switch. When
you do not specify a printer, the switch uses the default printer.

/v previews what will be printed. You must manually close the preview window
before the printing can continue.

/c closes the Excel workbook after it generates the report.
/T saves the Excel spreadsheet as a PDF file.

/1 locks the sheet with an optional password. When protected, a sheet is read-only.
To modify it, unlock the sheet by using the Review tab in the Excel window.

/b copies data using the native copy function in Excel, which uses the Clipboard for
transferring data. Thermo Fisher Scientific recommends that you avoid using this
function, because generating reports is a long process running in the background, and
using the Clipboard could cause some unwanted side effects.

/g creates a log file to log all messages generated by the LogMsg function. The log
file, named ThermoCustomReport.log, resides in the current user’s temporary folder.
When this switch is on, the /d and /t switches add a time stamp to the log file name.

/d adds a date to the log file name in the format
ThermoCustomReport_yyyyMMedd.log, where yyyy is the year (for example, 2011),
MM is the month of the year (for example, 12 for December), and 4 is the two-digit
day of the month (for example, 06 for the sixth day).

/t adds a time stamp to the log file name in the format
ThermoCustomReport_yyyyMMdd_HHmmss.log, where yyyy is the year, MM is the
month of the year, dd is the day of the month, AH is the hour in 24-hour format,
mm is the minute, and ss is the second. An example is

ThermoCustomReport_20110902_150208.log.

Tip By default, the TraceFinder application file structure results in a long file path.
The Windows Run dialog box limits you to 256 characters. To work around this
limitation, either copy files to a folder close to the root directory or put the command
line into a batch file.
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Why Does My Excel Report Show a Security Warning When | Open It?

The Excel application has a strict security requirement to prevent unintended execution of the
macros, and it applies this requirement to the templates and reports. The Excel application
displays the following security warning message when you open a spreadsheet with macros or
VBA code from an untrustworthy location.

Figure 86. Security warning message

!f/t!? [ Rl e T BatchReportxlsm [Group] - Microsoft Excel i i
- - Home Insert Page Layout Farmulas Data Review WView Developer Add-Ins 'QJ - X
- Calibri i B 2 General = E‘ Salnsert = X~ r{ > [ﬁ
1 B ||[Ber u A K| E == |8 % e Fpete - [ S C
I |[E A W |- | EFomat || O Fiter- selec

Clipboard ™= Font fll| [ Alignment ] Mumber = _ Cells Editing

EQ Security Warning Macros have been disabled. Options... ] 7
B2 - (> J 22

_ B . C D E | F _ G

a Batch Report

L 2 .:.

3 |lab Name: Default Laboratory =3

4 _Instrument: 1

5 |User: DGTAKSDIVLF3.1

6 |Batch: mdl

? 4

8 |File Name || [»]Date/Time [=]Sample D (+]sample Name [= | Level _

9 |cal_std 5 5/21/2008 20:36 cal std =5 ngfuL =IF{A9="", "N/A", |

10 |cal_std_100 5/21/2008 20:45 cal std = 100 ng/uL

11 1naran | 3/2/0R12:34 mdl =1 noful

4 4 b #| Sheetl  Sheet? . Sheet3 < ¥J 4 '

Ready |

Without the enabled macros, the add-in component cannot run and generate a report.

For the macro-enabled templates to run in the Excel application, you must add the directory
of the add-in and the template files to the list of trusted locations.

* When you installed the TraceFinder application, the installer should have added the
C:\Thermo\Shared\Templates\Reports default template folder to the Excel application
list of trusted locations. The security setting is adequate, as long as you run your
templates from this folder.

* You can add a folder to the list of trusted locations (for example, if you decide to save the
template in a different folder) by following the next procedure.
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2
0.0

1. Click the Office button, '@ , and click Excel Options,

2. Click Trust Center.

3. Click Trust Center Settings.

To add a folder to the list of trusted locations

[] Excel Options

4. Click Trusted Locations to open the Microsoft Office Trusted Location dialog box.

Figure 87. Trust Center dialog box

Trusted Publishers
E’ ;lzd.[umi_‘inn;q :

Add-ins

ActiveX Settings

Macro Settings

Message Bar

External Content

Privacy Options

Trusted Locations

Warning: All these locations are treated as trusted sources for opening files. If you change or add a location, make

sure that the new location is secure,

Path
ChThermoh,
ChMApplication Data\Microsoft\Templates),
Ch.iles'\Microsoft Office’, Officel W XLSTART,
Ch\Thermoh\TraceFinder',

.. plication Data\Microsoft\Excel'\XLSTART,
C.gram Files\Microsoft Office\Templates,

s

Description

Excel 2007 default location: User Templates
Excel 2007 default location: Excel StartUp
Thermao Data

Excel 2007 default location: User StartUp
Excel 2007 default location: Application Te..

Date Modified  #%|

2/3/2010 7:54 AM

£

Path: ChThermo?,
Description:

Date Modified: 2/3/2010 7:54 AM
Sub Folders: Allowed

[gdd newlocation...] [ Remove J [ Modify... J

|:| Allow Trusted Locations on my nebtwork (not recommended)

|:| Disable all Trusted Locations, Only files signed by Trusted Publishers will be trusted,

OK _] [ Cancel

5. Click Add New Location.

6. In the Microsoft Office Trusted Location dialog box, add the new location and click OK.
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Why Are Page Numbers Not Sequential Across All Pages?

Thermo Scientific

In Excel, the page numbers normally start from 1 for each sheet. However, you can assign
sequential page numbers to multiple sheets by grouping the sheets together.

When you generate a report through a custom report add-in, all sheets in the workbook are
automatically grouped to make sure that they have sequential page numbers. Grouping is
especially important for some reports, for example, the Confirmation Report, when each page
is placed in a separate sheet for better performance. Under certain circumstances, grouped
sheets might not be obvious.

You can break this grouping by clicking any of the inactive sheets. You can also break the
grouping by right-clicking any tab and selecting Ungroup Sheets from the menu.

When pages are not numbered sequentially across all pages, it is probably because you have
manually edited the sheets (see “Why is My Data Table Not Editable?” on page 203) and
forgotten to group them afterward, or the sheet grouping was unintentionally broken, for
example, by clicking inactive sheets.

To group sheets, right-click the tab and select Select All Sheets from the menu. You can also
group or select sheets individually by using the CTRL and SHIFT keys while clicking the
sheet tab.
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How Do | Change the Default Logo Image for All Reports?

By default, custom reports use the logo image saved as
C:\Thermo\Shared\Templates\Reports\mylogo.jpg. You can replace this file with your own
logo image.

% To change the logo for a specific report
1. Use the IUtil_SetupPageHeader() function of the MyUstil class.

This function normally calls the mUtil.SetupPageFooter add-in function to create the
default header.

2. Replace the default header with your code.

180 TraceFinder Custom Reports Tutorial Thermo Scientific



A Frequently Asked Questions
General Questions

Why Do | Need to Use the Add-in Copy/Paste Function Instead of the Excel Copy

Function?

Thermo Scientific

The Excel copy function is powerful in duplicating formatted cells, but it uses the Clipboard
to transfer data. The Clipboard is a system-wide resource shared by all running applications,
and report generation is a long process that normally runs in background. Therefore, using
the Clipboard to transfer data might cause some unwanted side effects. For example, if you
interactively use the Clipboard in the foreground to write e-mail while the reporting process
runs in the background, the Excel application might inadvertently generate an incorrect
report.

The Excel application lacks a copy function that does not use the Clipboard; however, you can
use a special copy/paste function created by the add-in component. It is similar to the Excel
native copy function except for its Clipboard usage. When you want to copy and paste cell
data in the VBA code, use the add-in’s copy/paste function rather than the Excel copy

function. For instructions on using this function, see Appendix B, “Custom Report Add-in
APL”
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How Do | Add a Watermark to a Report?

There are two add-in functions for adding watermarks to reports: one adds text as a

watermark, and the other adds an image as a watermark. The following function call adds a

text watermark to all the pages of the report:

mUtil.AddTextAswatermark "Thermo Custom Report",

Range("Sheetl!A1l:T78™)

Figure 88. Custom report with a watermark
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Why Do | Get a “File in Use” Error Message?

If you have an Excel window open at the same time you generate a report that was created

with a custom report template, you might get this message:

-

File in Use [~ B[]

PERSOMAL.XLSE is lodked for editing

by 'user'. Notify

Open 'Read-0nly' or dick 'Motify' to open read-only and receive notification

when the document is no longer in use.

Cancel

When TraceFinder generates a custom report, it opens the Personal Macro Workbook in a

hidden Excel window. Because you already have an open Excel window and Excel will not

allow two open windows at once, you get this error message.

Use any of the following methods to solve this problem:

Thermo Scientific

Close any Excel windows that you currently have open.

Do not save your macros in the Personal Macro Workbook.

If you no longer need the Personal Macro Workbook, delete it from the
Microsoft\Exce\XLSTART folder.

Temporarily move the PERSONAL.XLSB file out of the Microsoft\Exce\XLSTART
folder.

Share the PERSONAL.XLSB file.

To share the file, do the following:

a.

In an Excel window, click the View tab, and then in the Window options, click

Unbhide.
The Unhide dialog box opens.
Select PERSONAL.XLSB, and click OK.

In the Excel window, click the Review tab, and then in the Changes options, click

Share Workbook.
The Share Workbook dialog box opens.
Select the Allow changes by more than one user... option and click OK.

When asked if you want to save the workbook, click OK.
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Data Table Questions

This section answers questions about data tables in TraceFinder custom reports.
* How Do I Create a Data Table in Excel?
e How Do I Add or Insert a Column in a Data Table?
* How Do I Remove a Column from a Data Table?
* How Do I Move a Column in a Data Table?
* How Do I Determine If a Column in a Data Table Is Linked to an XML Source?
* Why Do So Many Data Tables Appear on My Spreadsheet?
* How Do I Remove Data from the Template After Importing It?
* Why Does the Design Interface Layout Change After I Import Data?
* How Do I Use the Same Field More Than Once in a Report?
* How Do I Add an XML Map to the Workbook?
* How Do I Force the Formulas to Reevaluate?
e Why Does My Formula in a Data Table Not Expand?
* Where Can I Find a RawFileName_SampleCentricData.xml File?
e Why is My Data Table Not Editable?
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How Do | Create a Data Table in Excel?

A data table (also called a list in earlier Excel versions) is a table of related data. There are
several ways to create a data table in the Excel application. For custom reports, you create a
data table only by dragging a tree node from the XML source to the Excel spreadsheet. Each
node becomes a column in the data table. The data table has two rows: the column header
and an empty row beneath it that acts as a data holder. The second row expands when you
import data.

Note The XML source tree contains two kinds of nodes: a single-value node and a
collection node. When you place a single-value node in the spreadsheet, it is linked to a
single cell, and only the single cell is highlighted. When you place a collection node in the
spreadsheet, the Excel application automatically creates a data table with two rows.

A field mapped to a single-value node on the spreadsheet is not visible before data is
imported unless the XML source pane is visible. The data table is always visible.

Data tables can have columns that are not linked to the XML source tree. You can use these
columns for two purposes in custom reports:

* To reserve space for text if the space in the previous column is insufficient. For example,
you can use an unlinked column to accommodate long compound names.

* To create derived columns using Excel formulas for preformatting values based on other
columns, enter formulas in the second row. The Excel application automatically expands
and evaluates them in all rows after you import data.

Figure 89. Data table before data is imported
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% To import data
1. Click the Developer tab to display the Developer functions.
2. Click Import.

The Import XML dialog box opens.

IMPORTANT Because Excel cannot undo the importation of data, always save the
template before you import data. To avoid corrupting the template, do not save the
template with imported data.

3. Navigate to your .xml file and click Import.

The Excel application populates the spreadsheet with data for you to preview.

Figure 90. Preview of imported data
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How Do | Add or Insert a Column in a Data Table?

You can place an XML source node in the spreadsheet only at the beginning or end of an
existing Excel data table. You cannot place a source node in the middle of a data table if the
column is already mapped to the XML source. If you do, the following error message appears;
however, you can place a source node in any unmapped column.

Microsoft Office Excel

< To place a node in the middle of a data table

1. Do one of the following:
a. Place the tree node at the beginning or the end of the data table.
b. Move the column to any place within the data table.

For more information on moving columns within a data table, see “Creating the
Report Headers” on page 98.

—Or—

a. Insert an empty (unmapped) column by right-clicking the column and choosing
Insert > Table Columns to the Left.

The new column (usually called Column1) is unmapped.

b. Dragand drop a tree node to it.

2. Ifyou receive the following formatting error message, click Match Element Data Type to
dismiss it.

Microsoft Office Excel

The data thak wou are attempting to map contains Formatking
'2 that is incampatible with the Farmat specified in the worksheet,

[ Use exjsting formatting ] [Mat-:h element data bvpe ] L Cancel |
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< To verify a mapped node
Do one of the following:
¢ Select the column.

When the column is mapped to a tree node, the Excel application selects the mapped
node in the XML source tree and displays it in bold font.

* Select the mapped node in the XML source tree.

All mapped nodes are displayed in bold font. When the node is mapped to a column, the

Excel application automatically selects the column in the data table.

When you insert an empty column and then drag an XML source node to the empty column,
the default column header does not change.

For additional instructions, see “Creating the Report Headers” on page 98.

188 TraceFinder Custom Reports Tutorial Thermo Scientific



A Frequently Asked Questions
Data Table Questions

How Do | Remove a Column from a Data Tahle?

You might need to remove a column in a data table.

* To delete an entire column of the spreadsheet that includes a column in the data table,
right-click the column header cell and choose Delete from the shortcut menu.

Note Pressing the Delete key does not delete the column.

* To delete a column in a data table without deleting the columns outside the data table,
right-click the column, and choose Delete > Table Columns.

* To remove the mapping from the XML source tree, right-click the node shown in bold
font and choose Remove Element.

This step removes the link between this node and the data table column, but it does not
delete the data table column. The data table column becomes unmapped, but the
previous name remains.

For additional instructions, see “Creating the Report Headers” on page 98.
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How Do | Move a Column in a Data Table?

Follow this procedure to move a column in a data table.

< To move table columns
1. Select the column and hold the mouse cursor on the border of the selected cells.

2. When the pointer changes to Resize All, drag the column to its new location.

Figure 91. Moving table columns

For additional instructions, see “Creating the Report Headers” on page 98.
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How Do | Determine If a Column in a Data Table Is Linked to an XML Source?

Thermo Scientific

A column in a data table might or might not be mapped to an XML source. To determine if it
is mapped, open the XML source pane by choosing Developer > Source and then click the
column to be checked in the spreadsheet. For a mapped column, the Excel application
automatically selects the mapped node in the XML source tree. This node automatically
appears in the visible area.

All nodes in the XML source window shown in bold font are mapped nodes. The Excel
application makes the mapped field or column visible when you click a node appearing in
bold font in the XML source tree.

For additional instructions, see “Creating the Report Headers” on page 98.
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Why Do So Many Data Tables Appear on My Spreadsheet?

When you drag a node from the XML source tree and place it next to another node, Excel
automatically merges them into one data table.

% To control the automatic merging of two adjacent nodes
1. Choose Developer > Source.

2. Click Options and choose Automatically Merge Elements When Mapping.

Figure 92. Automatically merging nodes into one data table

XML Source

[ - |
= g

=
=] AcquisitionEUID
= Application3ampleType
= BaseSampletams
=] ConversionFackaor w
< >
To map repeating elements, drag the elements

from the tree onto the worksheet where wou
want the data headings to appear.

Toimpark $ML daka, right click an $ML mapped
cell, point ko ®ML, and then click Impaort.

[ Opkions = ] [ ML Maps...

] awr Nata in Task Pane

g Hide Help Text in the Task Pane

+ | Automatically Merge Elements When Mapping

+ My Data Has Headings

The Automatically Merge Elements When Mapping check box is selected by default. When
you do not select this check box, Excel creates a new data table each time that you drop a node
from the XML source, so several data tables might appear on your spreadsheet.

Excel also creates a new data table if you place a node in a cell that is not adjacent to an
existing data table. The Automatically Merge Elements When Mapping option has no effect
on this activity.

If you create data tables separately, you cannot merge them later.

Each data table on the spreadsheet is marked by a small triangle at the bottom right corner, as
shown in the following example. The A and B columns belong to one data table. The C and
D columns are separate data tables.
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Figure 93. Triangular data table marker

A B C D

sl CompoundName BJ|LevelName B3 Compourkd LevelamEd

2
3

Data table marker

Excel automatically assigns a default name like Tablel or Table2 to each data table. When you
select Formulas > Name Manager, you can view these names displayed in the Name Manager
dialog box, as shown in the following figure:

Figure 94. Data table default names in the Name Manager dialog box

MName Manager

Mame Yalue Refers To Scope Carmrmenkt
 Table1z 0 =3hect11$4%2: 3642 Wiarkbook,
T Tablez1 =Sheet11$C$2: 4042 Workbook
T Tablezz =Shect11$042:4042  Workbook
x|~ | s

Thermo Fisher Scientific recommends that you rename the automatically assigned data table
names with distinctive names that you can refer to in formulas or in the VBA code.

You might want to leave some space between two columns. For example, you might want to
leave enough space to accommodate long compound names. Do not create separate tables to
do this, although it might work in some cases. Instead, create an empty column. For
instructions, see “Adding Empty Columns” on page 39.

The effect of separate data tables versus one data table might not become obvious until you
place nodes from different levels in the XML source tree or import source data into the data
tables. In the following figure, the A and B columns belong to one data table. The C and D
columns are separate data tables.
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Figure 95. One data table (columns A and B) with two separate data tables (columns C and D)
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“LevelName” is a sub-collection of a compound. In columns B and D, one compound has
three calibration levels, except for fluorene and benzo[a]pyrene, which are internal standard
compounds and are not associated with any calibration level.

The third and fourth columns are directly mapped to the XML source. However, in the first
data table, each “CompoundName” is repeated for every “LevelName,” and each
“LevelName” is repeated for every “CompoundName.”

A target compound—for example, benzene—can have multiple calibration levels, but internal
standard compounds—for example, fluorene—do not have any. When you map the
“LevelName” in a separate data table like column D, internal standard compounds like
fluorene do not have any entries. However, if you map “CompoundName” and “LevelName”
together in one data table like columns A and B, fluorene must be listed, although its
corresponding “LevelName” is empty.

Recognizing this difference between one data table and separate data tables is very important
when you create a new report because it helps you decide when to use a separate data table and
when to avoid using one. You can find an example showing how to use these two table types

together in the delivered High Density Sample Report Long 2 template.
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How Do | Remove Data from the Template After Importing It?

Importing data is one of the actions in Excel that you cannot undo. Thermo Fisher Scientific
recommends that you save the template before importing data. Do not save the template after
importing data.

Note Leaving imported data in the template might confuse other template developers,
but it does not cause any harm to generated reports because the data is overwritten at run
time.

If you saved the template with the imported data, you can remove the data from the template
by following these procedures:

* For single-value cells, select the cell and press the Delete key to remove the text. The
mapping of the cell is not removed.

* For data tables, select the entire table except the header row, right-click and select
Delete > Table Rows. You must exclude the header rows from selection to avoid deleting
the entire data table. Pressing the Delete key only removes the text from the template; it
does not reduce the data table to two rows.
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Why Does the Design Interface Layout Change After | Import Data?

If you find that the design interface layout changes after you import data, the likely cause is
the Adjust Column Width property defaulting to True.

% To turn off the Adjust Column Width property
1. Click the Developer tab in the Excel spreadsheet.
2. Select the related map.
3. Click Map Properties.

The XML Map Properties dialog box opens.

XML Map Properties

Mame: ESampIeCentricExpnrtEatch_Map |
WML schema validation
[ ] ¥alidate data against schema For import and export

Daka source
Save daka source definition in waorkbook,

Drata Formatking and layouk

(D Adjust column width ]

[+] Preserve column Filker

Preserve number Farmatking

When refreshing or imparking daka:
(%) Overwrite existing data with new data

) Append new data to existing XML tables

! (T

4. Clear the Adjust Column Width check box.

When you select this check box, the cell expands to fit the data when you import data,
and the interface layout changes as a result. This check box is selected by default.
However, Thermo Fisher Scientific recommends that you clear this check box for all
XML maps to preserve layout design.
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How Do | Use the Same Field More Than Once in a Report?

You can reference a tree node in the XML source only once. When you try to drag an already
mapped tree node to the spreadsheet, the following error message appears.

Microsoft Office Excel

! E This element has already been mapped. &n element cannok be mapped more than once,

For custom reports, always use a separate XML map when you need a field more than once.
You can add XML maps to the same file as many times as necessary.

Figure 96. Multiple mappings added to the same file

XML Maps ?X]

*ML maps in this workbook:

MNarne F.oaot Mamespace
SampleentricExportBatch_Map SampleCentricExporkBatch  <Mo Mamespace
SampleentricExportBatch_Mapil SampleCentricExporkBatch <Moo Mamespace
< | [ b3

| opeete || ok || cancal |

Rename. .. ]

s

Because you have only a single .xml file to import, the add-in component populates all maps
when you import the .xml file. You must keep the default names
SampleCentricExportBatch_Map, SampleCentricExportBatch_Map1, and so on.
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How Do | Add an XML Map to the Workbook?

You can add an XML map to the workbook.

< To add an XML map to the workbook

1. In the Excel spreadsheet, click the Developer tab to display the Developer features.
2. Click Source, \E

source

3. Click XML Maps.

The XML Maps dialog box opens. It lists all the existing maps.

XML Maps ?X]

#ML maps in this workbook:

Marmne Rook Mamespace

SampleCentricExportBatch_Map  SampleCentricExportBatch  <Mo Mamespace =

£

Eename. .. | oade

| »
Delete J[ I ][ Zancel J

F

You can use the XML Maps dialog box to add a new map, rename a map, or delete a map.
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How Do | Force the Formulas to Reevaluate?

When you want the Excel application to reevaluate formulas on the sheet, for example, before
copying, call the Application.Calculate function in the VBA code.
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Why Does My Formula in a Data Table Not Expand?

Thermo Scientific

When you add a new column to a data table, the cell format defaults to text. In text format,
the formula that you entered into the cell appears as text and does not expand when you
import data into the data table. An equal sign (=) in a cell distinguishes text format in the cell
from evaluated results, as shown in the B2 cell in the following example.

Figure 97. Cell in text format marked by an equal sign

I

B2 _e fe | ="Quan m/z: " & TEXT(S2, "0.00")

A | B I c

% To expand a formula in a data table

1. Manually change the cell format to another format, such as the general format shown in
the following example.

Figure 98. Cell in general format marked by the absence of an equal sign

B2 - fe | ="Quan m/z: " & TEXT(S2, "0.00")
A : B : C

Quan mjz: 0.00

2. To update the cell format throughout the data table, click each cell and press ENTER.
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Where Can | Find a RawFileName_SampleCentricData.xml File?

202

The TraceFinder application generates the RawFileName_SampleCentricData.xml file when it
checks any custom report as part of submitting the batch or sample for reporting. This file
contains all sample-specific data and is the only file used by custom reports. The file is
normally located in the Data folder of the batch:

C:\Thermo\TraceFinder\1.1\Projects\PROJECTNAME\ SUBPROJIECTNAME\
BATCHNAME\Data

Example file location:

C:\Thermo\TraceFinder\1l.1\Projects\ProjectA\SubprojectA\
ML_BATCH_O1\Data

When you use the Run box on the Start menu to test your template, you can place this file
anywhere on your local drive as long as you pass the correct path to the template in the Run
box.
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Why is My Data Table Not Editable?

Thermo Scientific

When you try to edit data tables in the generated report, you might receive the following error
message from Excel.

Microsoft Office Excel

! E Zannot make changes to a kable or %ML mapping when multiple sheets are selected,

This error message results from grouping the sheets. Grouped sheets are selected sheets in the
Excel spreadsheet. When a generated report contains multiple sheets (tabs), the add-in
component automatically groups them all together to make sure that the pages in all sheets are
sequentially numbered. Without this grouping, pages in each sheet start from 1, which is
normally undesirable.

You can break this grouping by clicking any of the inactive sheets. You can also break the
grouping by right-clicking any tab and selecting Ungroup Sheets from the menu. To group
them again, right click the tab and select Select All Sheets from the menu.

Figure 99. Ungrouping multiple sheets

18
19
20

Select All Sheets
Ungroup Sheets
4 4 » »| Sheetl ~Sheef? ~Sheef3 ¥l
Ready ;ﬂ

When you manually break the grouping, be sure to restore it after editing and before printing
to ensure that the page numbering is correct.
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Image Handling Questions

The questions in this section pertain to the handling of images in TraceFinder custom reports.
* How Do I Add an Image to a Report?

* How Do I Remove an Image from a Report?

How Do | Add an Image to a Report?

The TraceFinder application exports images as byte arrays embedded in the
RawFileName_SampleCentricData.xml file. However, the Excel spreadsheet cannot directly
convert byte arrays into an image. Byte arrays for an image are normally too large to be placed
directly into a cell.

As a workaround to this limitation, when you drag and drop an image node onto the
spreadsheet, the add-in component captures this event and instructs you to create a named
range that acts as a placeholder for the image that you drag.

The image is loaded to this placeholder at run time through a special add-in function called
CreateImage in the VBA code. For information on this function, see “Public Function
Createlmage” on page 214.

Note All image nodes in the exported XML file have the “Image” suffix appended to their
names, for example, SampleTotallonCurrentImage for the TIC image of the sample. This
naming convention enables the add-in component to capture drag-and-drop events as
images so that the application can handle them correctly.
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< To add an image to a report
1. Drag an image node from the XML source tree to your spreadsheet.

The Edit Graphic dialog box opens.

Edit Graphic

#ML maps in this workbook:
SampleCentricExportBatch_Map| LJ

SampleCentricExportBatch
—- Samples
= SampleZentricExportSample
SampleTotallonCurrentImage
= Compounds
=) Sampleentric”ompoundExportData
= QuanResult
M5DataSpectrumImage
M3MethodSpectrumImage

[

= ZalibrationData

= CamooundCurveExportData i

Marne For this graphic: Range Faor this graphic:
| SampleTotallonZurrentImage Funfld ;J

Hint: & named range "SampleTokallonCurrentImage’ will be created For

Delete K, Cancel |

The tree shown in this dialog box only displays the image nodes with the Image suffix

appended to their names. The currently selected tree node is automatically highlighted.

2. Specify the name and cell range for the graphic in the Edit Graphic dialog box.

Tip You can enter the range directly in the Range for This Graphic box in the Edit
Graphic dialog box, or select the cells from the list on the right.

Tip You do not have to create named range placeholders for images, because the VBA
code can reference the cells directly. However, creating named ranges for images
makes later maintenance easier.

For the syntax of the CreateImage function, see “Public Function Createlmage” on page 214.
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How Do | Remove an Image from a Report?

Because images are loaded through the VBA code, you must remove the corresponding VBA
code that the template is based on if you want to remove an image. When removing an image,
you might also remove the cells reserved for the image on the spreadsheet by deleting or
hiding them. You can find examples of this usage in the delivered Quantitation report, where
the visibility of the TIC image is controlled by the value of the
SampleCentricExportBatch/MethodHeaderData/ShowChromatogramOnQuanReport node.
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Debugging Questions
This section provides information on debugging VBA code.
* How Do I Debug the VBA Code That the Template Is Based On?
* How Do I Debug the Add-in Code?

How Do | Debug the VBA Code That the Template Is Based On?

You can use several methods to debug the VBA code that the template is based on, but you
must first stop running the template. The template runs by default but stops if any variable is
undefined, assuming that the code module includes the Option Explicit statement at the
beginning.

In VBA, the code is compiled as needed. The process stops running if it cannot compile a
function. If the code module includes the Option Explicit statement at the beginning, VBA
requires all variables must be explicit defined before it can use them. If you add a new,
undefined variable in a function, the template stops at the beginning of the function.

< To debug the VBA code
1. Estimate where the problem might be in the code.
2. Change any variable in that place to an undefined variable.

You will receive a compiler error when you try to compile the code, but you can ignore
this error for debugging purposes.

3. Run the template.

The compiler stops at the beginning of the function where the undefined variable is
located.

4. Change the variable back, set a break point in the code, and press the F5 key to run the
program.

The program stops at the first break point that you set in this function. After it stops, you
can step through the code as usual. You can also switch to the spreadsheet any time to
determine how the code has worked so far.
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How Do | Debug the Add-in Code?

The add-in code is a regular VBA project. You can use the same procedure described in “How
Do I Debug the VBA Code That the Template Is Based On?” on page 207 to debug the
add-in code. The only difference is that the add-in project is protected by a password. Any
error in a password-protected module generates a generic Microsoft Visual Basic error
message.

Microsoft Visual Basic

To debug the error, unlock the add-in project with a valid password. After the project is
unlocked, you can debug it as you would any other VBA code.



Custom Report Add-in API

Thermo Scientific

The custom report add-in application programming interface (API), an Excel add-in
component, provides a framework for customizing reports by using the Excel template for
applications.

The add-in file is called Thermo Report Add-In.xla, which is usually installed in the
C:\Thermo\Shared\Templates\Reports folder. This add-in component is normally associated
with a template, and it is loaded only when you open or use the associated template.

The add-in component performs two main tasks:
* Automates the custom report generation.

* Provides some helper functions (APIs) for template developers to use.

Chapter 2, “Overview,” discusses the automatic generation of custom reports. This appendix
describes all public APIs that you can use in the template VBA code. You can generate most
custom reports without changing the add-in code.

Contents

* DPublic Sub SetupPageHeader

Public Sub SetupPageFooter

* DPublic Function Createlmage

* DPublic Sub CopyPaste

* Public Function IsXPath

* Public Function HiddenRowCount
* Public Function VisibleRowCount
* Public Function Contains

* Public Sub ShowErrMsg

* DPublic Sub CheckRequiredName
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Contents, Cont'd

Public Sub CheckRequiredNamelnsideOf
Public Sub CheckRequiredNameOutsideOf

Public Sub CheckOptionalName
Public Sub AddTextAsWatermark

Public Sub AddNamedShapeAsWatermark

Public Function GetXmlElement
Public Function GetXmINodesText
Public Function NameExists
Public Function GetNamedRange
Public Sub HideColumns

Public Sub SetPageBreakAt

Public Sub SetFrame

Public Function GetRowlndex
Public Function GetColCount
Public Function GetRowCount
Public Function ColumnNumber
Public Function DeleteName
Public Function GetUniqueList
Public Function GetListColumn
Public Function Value

Public Function GetValue

Public Function HideListColumn
Public Sub SortList

Public Sub EnumerateColumn
Public Function CreatePivotTable
Public Sub SetManuallyIntegrated
Public Sub ReformatManuallylntegrated
Public Sub SetNoData
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Contents, Cont'd
* DPublic Sub HideRepeatArea

* Public Sub FormatValue

* DPublic Sub ReplaceValue

* Public Function ShiftRange

* DPublic Function GetText

* DPublic Sub MergeRowCells

* Public Function ArraySize

* DPublic Sub LogMsg

* Public Function GetValidSheetName

e Public Function FileExists

All API functions documented in this appendix reside in the Util class. A public instance
(mUtil) is created in Modulel of the add-in so that all templates referring to the add-in
component can use it directly, for example, mUtil.ShiftRange(...).

Note If you have access to the add-in source code, you might see more APIs than those
described in this appendix. Some of them were created for an earlier version of the Excel
application and are no longer needed but are retained for backward compatibility.

Tip The add-in VBA project (ThermoReportAddIn) is password-protected. However, if
you must access the add-in source code, consult your Thermo Fisher Scientific
representative for the password.
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Public Sub SetupPageHeader

Public Sub SetupPageHeader

PubTlic Sub SetupPageHeader(Optional Byval withPrintTimestamp As Boolean =
True)

Purpose
This function provides the default page header commonly used in reports.

It is normally called when the IUtil interface is implemented. When you do not need the
default header, remove this call from IUtl_SetupPageHeader() in the MyUitil class.
Parameters

The following table describes the parameters that you must provide values for in the Public
Sub SetupPageHeader syntax.

Table 2. Public Sub SetupPageHeader parameters

Parameter Description

withPrintTimestamp Specifies whether the page header includes a time stamp as the
second line in the middle when you print reports.

* True: Includes the time stamp in the header.
* False: Does not include the time stamp in the header.

The default is True.

This parameter is optional.
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Public Sub SetupPageFooter

Public Sub SetupPageFooter

Thermo Scientific

PubTic Sub SetupPageFooter(text As String, Optional bottomMarginInInch As
Double = 0.75, Optional picFileName As String)

Purpose
This function provides the default page footer commonly used in reports.

This function is normally called when the IUtil interface is implemented. When you do not
need the default footer, remove this call from IUtil_SetupPageFooter() in the MyUtil class.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub SetupPageFooter syntax.

Table 3. Public Sub SetupPageFooter parameters

Parameter Description

text Specifies the footer text.

bottomMarginInInch Specifies the page margin at the bottom of the page, in inches.
The default is 0.75.

This parameter is optional.

p1cFTleName Specifies the image file (full path) to be shown.
This parameter has no default.
This parameter is optional.
Only one image can appear in the footer.

The text must contain “&G” to indicate in the Excel application
where to show the image. Without “&G” in the text, no image is
shown.

If you do not provide an image file, the square.jpg image appears
in the C:\Thermo\Shared\Templates\Reports report folder. It is

used to indicate manual integration in the legend.
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Public Function Createlmage

Public Function Createlmage

Public Function CreateImage(Byval target, Byval imagePath As String,
Ooptional Byval cropTop As Long = 1, Optional Byval cropLeft As Long = 1,
optional Byval cropRight As Long = 1, Optional Byval cropBottom As Long =
1) As String

Purpose

This function creates an image based on the byte array at 7magepath from the XML file and
specifies its target location.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function CreateImage syntax.

Table 4. Public Function Createlmage parameters (Sheet 1 of 2)

Parameter Description

target Specifies a range of cells either by a named range (for example,
QuanChart) or by a cell range (for example, Sheet1!A1:E5) to
indicate where to set the image.

TmagePath Specifies a full XPath to the image node in the XML source tree.
Here is an example:

SampleCentricExportBatch/Samples/
SampleCentricExportSample/Compounds/
SampTleCentricCompoundExportbData
[CompoundKey="" & compIid & "']/
QuanResult/QuanPeakResults/
CompoundQuanPeakResultExportData/
PeakImage.

cropTop Specifies how much to crop at the top of the image.
The default is 1.

This parameter is optional.

cropLeft Specifies how much to crop to the left of the image.
The default is 1.

This parameter is optional.
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Public Function Createlmage

Table 4. Public Function Createlmage parameters (Sheet 2 of 2)

Parameter Description

CropRight Specifies how much to crop to the right of the image.
The default is 1.

This parameter is optional.

cropBottom Specifies how much to crop at the bottom of the image.
The default is 1.

This parameter is optional.

Example

Here is an example taken from a DCC report:

mUtil.CreateImage mutil.ShiftRange("Quanchart", cc, rr, cc, rr),
"sampleCentricExportBatch/Samples/SampleCentricExportSample/Compounds
/SampleCentricCompoundExportData[CompoundKey="" & compid & "']
/QuanResult/QuanPeakResults/CompoundQuanPeakResultExportbata/
pPeakImage", 20, 5, 12, 2

In this example:
* The target parameter is a shifted named range.

* The 7magepPath is an XPath with an expression that specifies the compound
identification.

* All margins surrounding the image are cropped: 20 on the top, 5 on the left, 12 on the
right, and 2 on the bottom.

Thermo Scientific TraceFinder Custom Reports Tutorial 215



B Custom Report Add-in API
Public Sub CopyPaste

Public Sub CopyPaste

PubTlic Sub CopyPaste(Byval source, Byval target, Optional Byval
inclRowHeight As Boolean = True, Optional Byval valueonly = False,
optional Byval copyFormula = True)

Purpose

This function replaces the Excel application’s Selection.Copy function, primarily to avoid
using the Clipboard. The reporting process normally runs in the background and might take
some time. When you use the Clipboard to move data on the spreadsheet, you might
inadvertently cause an incorrect report to be generated.

This function is a little slower than the Excel application’s Selection.Copy function, especially
when you copy a large amount of data. If you prefer to use the Clipboard and you are certain
that no one is working on the computer while the application is generating reports in the
background, you can switch to the Excel application’s Selection.Copy function by setting the
UseClipboard global parameter to True in the Util class. You can also switch by using the /b
command-line option.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub CopyPaste syntax.

Table 5. Public Sub CopyPaste parameters (Sheet 1 of 2)

Parameter Description

source Specifies a range of cells by a named range (for example, DataTable) or
by a cell range (for example, TempSheet!A1:E5) to indicate the location
of the source to copy.

target Specifies a range of cells to indicate the location to copy to. You can
specify this range by a named range (for example, ChartLegend) or by a
cell range (for example, TempSheet!A1:E5). The target cell range does
not have to match the source cell range. When it is smaller than the
source cell range, it expands to all the source cells copied. It could be
just the first cell of the paste target.

inclRowHeTght  Specifies whether the row height should be copied to the target.
* True: Copies the row height to the target.

* False: Does not copy the row height to the target.
The default is True.

This parameter is optional.
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Public Sub CopyPaste

Table 5. Public Sub CopyPaste parameters (Sheet 2 of 2)

Parameter

valueonly

Description

Determines whether the formatting and formulas in the cells are copied
along with the values.

* True: Copies only the values of the cells.

¢ False: Copies the formatting and formulas in addition to the values

of the cells.
The default is False.

This parameter is optional.

copyFormula

* Specifies whether formulas are copied.
* True: Copies formulas.

* False: Does not copy formulas.
The default is True.

This parameter is optional. It takes effect only if you set the va7ueonTy
parameter to False.

Example

The following example copies the M2 through M29 cells on the tempSheet sheet to Sheetl,
starting from the H51 cell. It does not include row height adjustment and copies only text
values (no formatting or formulas).

mUtil.CopyPaste "tempSheet!M2:M29", "Sheetl!H51", False, True
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Public Function IsXPath

Public Function IsXPath

Public Function IsxPath(Byval rng As Range) As Boolean

Purpose

This function determines whether the specific cell or cell range contains a valid XPath. The
only reason to include this function is to prevent the Excel application from throwing an
exception when the value is accessed if it is not a valid XPath.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function IsXPath syntax.

Table 6. Public Function IsXPath parameters

Parameter Description

rng Specifies a range of cells by a named range (for example,
DataTable), by a cell range (for example, TempSheet!A1:E5), or by
a cell.

* True: The cell or cell range contains a valid XPath.

* False: The cell or cell range does not contain a valid XPath.
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Public Function HiddenRowCount

Public Function HiddenRowCount

PubTic Function HiddenRowCount(Byval Rangel) As Long

Purpose

This function returns the count of hidden rows in the specified cell range. It is primarily used
to calculate copy locations. For example, it is used in quantitation reports.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function HiddenRowCount syntax.

Table 7. Public Function HiddenRowCount parameters

Parameter Description

Rangel Specifies a range of cells by a named range (for example,
DataTable), by a cell range (for example, TempSheet!A1:E5), or by
a cell.

Thermo Scientific TraceFinder Custom Reports Tutorial 219



B Custom Report Add-in API
Public Function VisibleRowCount

Public Function VisibleRowCount
Public Function visibleRowCount(Byval Rangel) As Long
Purpose

This function returns the count of visible rows in the specified cell range. It is primarily used
to calculate copy locations. For example, it is used in quantitation reports.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function VisibleRowCount syntax.

Table 8. Public Function VisibleRowCount parameters

Parameter Description

Rangel Specifies a range of cells by a named range (for example,
DataTable), by a cell range (for example, TempSheet!A1:E5), or by
a cell.
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Public Function Contains

Public Function Contains
Public Function Contains(Byval Rangel, Byval Range?) As Boolean
Purpose

This function determines whether a range contains another range. This function is primarily
used in the Validate() function to check the named ranges.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function Contains syntax.

Table 9. Public Function Contains parameters

Parameter Description

Rangel Specifies a range of cells by a named range (for example,
DataTable), by a cell range (for example, TempSheet!A1:E5), or by
a cell.

¢ True: The range contains another range.

* False: The range does not contain another range.

Rangez Specifies a range of cells either by a named range (for example,
DataTable), by a cell range (for example, TempSheet!A1:E5), or by

a cell.
¢ True: The range contains another range.

* False: The range does not contain another range.
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Public Sub ShowErrMsg

Public Sub ShowErrMsg

Public Sub ShowerrMsg(Byval err_msg As String, Byval warn_msg As String,
optional Byval showwarning As Boolean = True)

Purpose

This function displays a dialog box with a specified message. It is primarily used in the
Validate() function to check the named ranges.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub ShowErrMsg syntax.

Table 10. Public Sub ShowErrMsg parameters

Parameter Description

err_msg Specifies the error message text to display.

warn_msg Specifies the warning message text to display.

showwarning Specifies whether the warning message is shown when err_msg is
not defined. When err_msg is defined, the message box always
appears.

* True: Displays the warning message if err_msg is not defined.

* False: Does not display the warning message if err_msgis not

defined.
The default is True.

This parameter is optional.
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Public Sub CheckRequiredName

Public Sub CheckRequiredName

Thermo Scientific

Public Sub CheckRequiredName(err_msg As String, Byval regName As String,
optional Byval msg As String)

Purpose

This function determines whether the specified required name (regnvame) is defined as a
named range. When it is not, the function appends the message specified by msg to the error
message (err_msg) to act as the error message. When regnvame is defined, this function does
not alter the original error message. This function is primarily used in the Validate() function
to check the named ranges.

Parameters

The following table describes the parameter that you must provide values for in the Public
Sub CheckRequiredName syntax.

Table 11. Public Sub CheckRequired Name parameters

Parameter Description

err_msg Specifies the error message text to display.

reqName Specifies the name of the required named range.

msg Specifies the message text to use in a default message if regnvame is

not defined as a named range.

This parameter is optional.
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Public Sub CheckRequiredNamelnsideOf

Public Sub CheckRequiredNamelnsideOf

PubTic Sub checkRequiredNameInsideof(err_msg As String, Byval regName As
String, Byval containerName As String, Optional Byval msg As String)

Purpose

This function checks whether the required name specified by regnvame is defined as a named
range and is within the named range specified by containernvame. When it is not, the
function appends the message specified by msg to the error message specified by err_msg to
act as the error message. When the required name is defined, this function does not alter the
original error message. This function is primarily used in the Validate() function to check the
named ranges.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub CheckRequiredNamelnsideOf syntax.

Table 12. Public Sub CheckRequiredNamelnsideOf parameters

Parameter Description

err_msg Specifies the error message text to display.

reqName Specifies the name of the required named range.

containerName Specifies the named range of the container cells.

msg Specifies the message text to use if the required name specified by

regname is not defined as a named range or is defined outside the
range specified by containername. If msg is missing and
regName is undefined, the function generates a default message.

This parameter is optional.
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Public Sub CheckRequiredNameQutsideOf

Thermo Scientific

Public Sub checkrRequiredNameoutsideof(err_msg As String, Byval regName As
String, Byval containerName As String, Optional Byval msg As String)

Purpose

This function determines whether the required name specified by reqname is defined as a
named range and is outside the named range specified by containernvame. When it is not,
the function appends the message specified by msg to the error message specified by err_msg
to act as the error message. When the required name is defined, this function does not alter
the original error message. This function is primarily used in the Validate() function to check
the named ranges.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub CheckRequiredNameOutsideOf syntax.

Table 13. Public Sub CheckRequiredNameQutsideOf parameters

Parameters Description

err_msg Specifies the error message text to display.

reqName Specifies the name of the required named range.

containerName Specifies the named range of the container cells.

msg Specifies the message text to use if the required name specified by

regname is not defined as a named range or is defined but is
outside the range specified by containername. If msg is missing
and regname is undefined, the function generates a default
message.

This parameter is optional.
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Public Sub CheckOptionalName

Public Sub CheckOptionalName

Public Sub CheckoptionalName(7info_msg As String, Byval optName As String,
optional Byval msg As String)

Purpose

This function determines whether the specified optional name specified by optnvame is
defined as a named range. When it is not, it appends a message specified by msg to the
informational message specified by 7nfo_msg to act as the informational message. When
optName is defined, this function does not alter the original informational message. This
function is primarily used in the Validate() function to check the named ranges.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub CheckOptionalName syntax.

Table 14. Public Sub CheckOptionalName parameters

Parameter Description

info_msg Specifies the informational message text to display.

optName Specifies the name of the optional named range.

msg Specifies the message text to use if the optional name (optname) is

not defined as a named range. If msg is missing and optnvame is
undefined, the function generates a default message.

This parameter is optional.
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Public Sub AddTextAsWatermark

Public Sub AddTextAsWatermark

Public Sub AddTextAswatermark(text As String, rng As Range, Optional s7ze
As Double = 40#)

Purpose

This function adds a textual watermark to each printed page of the report.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub AddTextAsWatermark syntax.

Table 15. Public Sub AddTextAsWatermark parameters

Parameter Description
text Specifies the text to display as the watermark.
rng Specifies the range of cells used to display the watermark.
size Specifies the font size of the watermark text.
The default is 40.

This parameter is optional.

Example

Adding the following line to the MyDCCReport template at the end of the

ProcessSheet1Data() function generates the watermark shown in Figure 100.

mUtil.AddTextAswatermark "Thermo Custom Report", Range("Sheetl!Al:T78")
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Figure 100. \Watermark on printed page
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Public Sub AddNamedShapeAsWatermark

Public Sub AddNamedShapeAsWatermark

PubTic Sub AddNamedsShapeAswatermark(name As String, rng As Range)

Purpose

This function adds the named shape (normally an image) to use as a watermark to each
printed page of the report.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub AddNamedShapeAsWatermark syntax.

Table 16. Public Sub AddNamedShapeAsWatermark parameters

Parameter Description

name Specifies the name of the shape (normally an image) to use as a
watermark. The Excel application automatically assigns names to
all shapes.

rng Specifies the range of cells used to display the watermark.
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Public Function GetXmlElement

Public Function GetXmlElement

PubTic Function GetxXxmlElement(XxPath As String) As String

Purpose

This function returns the element content for the specified XPath of the current XML source
file.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function GetXmlElement syntax.

Table 17. Public Function GetXmlElement parameters

Parameter Description

XPath Specifies the XPath to a node in an XML document. XPath might
contain expressions.
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Public Function GetXmINodesText

Public Function GetXmINodesText

Public Function GetxXmINodesText(XPath As String) As String(Q)

Purpose

This function returns a string array containing the nodes for the specified XPath of the
current XML source file.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function GetXmINodesText syntax.

Table 18. Public Function GetXmINodesText parameters

Parameter Description

XPath Specifies the XPath to a node in an XML document. XPath might
contain expressions.
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Public Function NameExists

PubTic Function NameExists(name As String) As Boolean

Purpose

This function determines whether the specified named range is defined.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function NameExists syntax.

Table 19. Public Function NameExists parameters

Parameter Description

name Specifies the name of the named range to check.
* True: The specified named range exists.

* False: The specified named range does not exist.

232 TraceFinder Custom Reports Tutorial Thermo Scientific



B Custom Report Add-in API
Public Function GetNamedRange

Public Function GetNamedRange

PubTic Function GetNamedRange(Byval name As String, cI As String, rI As
Long, Optional c¢2 As String, Optional r2 As Long) As Boolean

Purpose

This function determines whether the specified named range is found.

Parameters

The following table describes the parameters that you must provide values for in the Public

Function GetNNamedRange syntax.

Table 20. Public Function GetNamedRange parameters

Parameter

name

Description

Specifies the name of the named range to retrieve.

cl

Returns the start column letter if the named range is found.

* True: The specified named range exists. The remaining cI,
r1, c2, r2 options return the cell range.

* False: The specified named range does not exist.

ri

Returns the start row number if the named range is found.

* True: The specified named range exists. The remaining cI,
r1, c2, r2 options return the cell range.

* False: The specified named range does not exist.

c2

Returns the end column letter if the named range is found.

* True: The specified named range exists. The remaining c1,
r1, c2, r2 options return the cell range.

* False: The specified named range does not exist.

This parameter is optional.

r2

Returns the end row number if the named range is found.

* True: The specified named range exists. The remaining cI,
r1, c2, r2 options return the cell range.

* False: The specified named range does not exist.

This parameter is optional.
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Public Sub HideColumns

Public Sub HideColumns

Public Sub HideColumns(Byval target, Optional Byval hide As Boolean =
True)

Purpose

This function makes the target range invisible or visible.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub HideColumns syntax.

Table 21. Public Sub HideColumns parameters

Parameter Description

target Specifies the target range to hide. The target range could be a
named range (for example, QuanChart), a cell range (for example,
A1:E5), a row range (for example, 10:30), or a column range (for

example, A:C).

hide Determines whether the target range is invisible or visible.
* True: Makes the target range invisible.
* False: Makes the target range visible.

The default is True.

This parameter is optional.
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Public Sub SetPageBreakAt

Public Sub SetPageBreakAt

PubTlic Sub SetPageBreakAt(Byval target)

Purpose

This function sets a page break at the specified cell location or at the beginning of a cell range.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub SetPageBreakAt syntax.

Table 22. Public Sub SetPageBreakAt parameters

Parameter Description

target Specifies the target range for setting the page break.
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Public Sub SetFrame

Public Sub SetFrame

PubTlic Sub SetFrame(Byval target, Optional Byval vL7ines As Boolean =
False, Optional Byval AL7ines As Boolean = False)

Purpose

This function sets a border frame around the specified cell range. You can use the optional
parameters to create a frame of horizontal lines only or vertical lines only.

The following table describes the parameters that you must provide values for in the Public
Sub SetFrame syntax.

Table 23. Public Sub SetFrame parameters

Parameter Description
target Specifies the target range of the border frame.
vLines Specifies whether vertical lines appear in the border frame.

* True: Vertical lines appear.

* False: Vertical lines do not appear.
The default is False.

This parameter is optional.

hLines Specifies whether horizontal lines appear in the border frame.
* True: Horizontal lines appear.

* False: Horizontal lines do not appear.
The default is False.

This parameter is optional.
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Public Function GetRowlIndex

PubTic Function GetRowIndex(str As String, col As String, startRow As
Long) As Long

Purpose

This function returns the row index of the specified string at a specific column or —1 if does
not find the specified string. It stops searching if it encounters an empty cell.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function GetRowlIndex syntax.

Table 24. Public Function GetRowIndex parameters

Parameter Description

str Specifies the string to search for.

col Specifies the column letter of the specified string.
startRow Specifies the row where the search starts.
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Public Function GetColCount

Public Function GetColCount

PubTic Function GetColCount(row As Long, startCol As String, Optional
tocol As Long = 0) As Long

Purpose

This function returns the count of the non-empty cells in a specified row between two
columns.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function GetColCount syntax.

Table 25. Public Function GetColCount parameters

Parameter Description

row Specifies the row number.

startcol Specifies the letter of the first column to count.

tocol Specifies the letter of the last column to count. When it is 0, the

function counts all columns.
The default is 0.

This parameter is optional.
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Public Function GetRowCount

PubTlic Function GetRowCount(co/, Optional startRow As Long = 1, Optional
toRow As Long = 0) As Long

Purpose

This function returns the count of the non-empty cells in a specified column between
designated rows.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function GetRowCount syntax.

Table 26. Public Function GetRowCount parameters

Parameter Description
col Specifies the column number or letter.
startRow Specifies the number of the first row to count.

The default is 1.

This parameter is optional.

toRow Specifies the number of the last row to count. When it is 0, this
function counts all rows.

The default is 0.

This parameter is optional.
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Public Function ColumnNumber

Public Function ColumnNumber(Byval ColumnLetter As String) As Long

Purpose

This function converts the specified column letter to a number, for example, 1 for column A
or 2 for column B.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function ColumnNumber syntax.

Table 27. Public Function ColumnNumber parameters

Parameter Description

ColumnLetter Specifies the column letter.
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Public Function DeleteName

PubTic Function DeleteName(name As String) As Boolean

Purpose

This function determines whether to delete or retain the named range.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function DeleteName syntax.

Table 28. Public Function DeleteName parameters

Parameter Description

name Specifies the name of the named range to be deleted or retained.
* True: Deletes the named range.

* False: Retains the named range.
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Public Function GetUniqueList

PubTic Function GetuUniqueList(Byval target, Optional Byval co7 As Long =
1, optional startIndex As Long = 1, Optional Byval 7nc/HiddenrRows As
Boolean = False) As String()

Purpose

This function returns an array of unique strings containing the text for the specified column
from the startindex. It can optionally include hidden columns in the returned array.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function GetUniqueList syntax.

Table 29. Public Function GetUniqueList parameters

Parameter Description
target Specifies a range of cells by a named range, a cell range, or a cell.
col Specifies the column to retrieve the list from.

The default is 1.

This parameter is optional.

startIndex Specifies the start index of the rows.
The default is 1.

This parameter is optional.

inc IHiddenRows Specifies whether the returned list should include hidden rows.
¢ True: Includes hidden rows.

¢ False: Does not include hidden rows.
The default is False.

This parameter is optional.
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Public Function GetListColumn

Public Function GetListColumn(Byval tablenName As String, Byval columnName
As String) As String(Q)

Purpose

This function returns an array of strings containing the text for the specified column.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function GetListColumn syntax.

Table 30. Public Function GetListColumn parameters

Parameter Description

tableName Specifies the name of the data table.

columnName Specifies the name of the column, which is the column header
text.
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Public Function Value

PubTlic Function value(Byval target, Optional Byval rowoffset As Long = 0,
optional Byval coloffset As Long = 0)

Purpose

This function returns the value of the target cell with optional offsets.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function Value syntax.

Table 31. Public Function Value parameters

Parameter Description
target Specifies a range of cells by a named range, a cell range, or a cell.
rowoffset Specifies the offset of the row.

The default is 0.

This parameter is optional.

coloffset Specifies the offset of the column.
The default is 0.

This parameter is optional.
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Public Function GetValue

Public Function Getvalue(Byval target, Byval defaultvalue)

Purpose

This function returns the value of the target cell or the specified default value if the target is
not found.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function GetValue syntax.

Table 32. Public Function GetValue parameters

Parameter Description
target Specifies a range of cells by a named range, a cell range, or a cell.
defaultvalue Specifies the default value if the target cannot be found.

The default is nothing.

This parameter is optional.
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Public Function HideListColumn
Public Function HideListColumn(77stName As String, colName As String)
Purpose

This function hides the specified column in the specified data table.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function HideListColumn syntax.

Table 33. Public Function HideListColumn parameters

Parameter Description

7istName Specifies the name of the list or data table.

colnName Specifies the name of the column, which is the column header
text.
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Public Sub SortList

PubTlic Sub SsortList(77stName As String, sortColNames As String, Optional
sheet As worksheet)

Purpose

This function sorts the list or data table by the specified column.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub SortList syntax.

Table 34. Public Sub SortList parameters

Parameter Description

17stName Specifies the name of the list or data table.

sortcColName Specifies the name of the column, which is the column header
text.

sheet Specifies the sheet (also called the tab). When this parameter is

missing, the function uses the active sheet by default.

This parameter is optional.
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Public Sub EnumerateColumn

PubTic Sub EnumerateColumn(Byval target, Byval colIndex As Long)

Purpose

This function enumerates the specified column to create a sequential number (1, 2, 3, and so
forth).

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub EnumerateColumn syntax.

Table 35. Public Sub EnumerateColumn parameters

Parameter Description
target Specifies a range of cells by a named range, a cell range, or a cell.
colIndex Specifies the index of the column.
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Public Function CreatePivotTable

Public Function CreatePivotTable(Byval dataTablenvame As String, Byval
target, Byval rowrFields As String, Byval columnFields As String, Byval
valueFields As String, Optional Byval pivotTableName = "PivotTablel") As
Range

Purpose

The Excel application is a powerful tool for creating pivot tables. However, creating these
tables is normally a manual process that involves several steps, which many Excel users might
not understand well. The CreatePivotTable function tries to simplify the process by hiding
many internal details and exposing only a few relevant parameters to the template developer.
The goal is to create a pivot table that is ready to be used (copied) in custom reports; for
example, custom reports never use background colors and borders. You can find an example
of this function in Chapter 6, “Creating a Calibration Report.”

Parameters

The following table describes the parameters that you must provide values for in the Public
Function CreatePivotTable syntax.

Table 36. Public Function CreatePivotTable parameters

Parameter Description

dataTableName Specifies the name of the data table that the pivot table is based
on.

target Specifies a range of cells by a named range, a cell range, or a cell.

rowrields Specifies the column names of the original data table to translate

into pivot table rows. You can concatenate multiple columns by
using semicolons.

columnFrields Specifies the column names of the original data table to translate
into pivot table columns. You can concatenate multiple columns
by using semicolons.

valuerields Specifies the column names of the original data table to translate
into pivot table values. You can concatenate multiple column
names by using semicolons.

pivotTableName Specifies the name of the resulting pivot table. The Excel
application normally assigns a default name to a pivot table
automatically. When you need to programmatically refer to the
pivot table, you must give it a name so you can refer to it.

The default name is PivotTablel.

This parameter is optional.
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Public Sub SetManuallyintegrated

PubTic Sub SetManuallyIntegrated(Byval dataTableName As String, Byval
refColName As String, Byval valueColName As String, Optional Byval
negatevalue As Boolean = False, Optional Byval extraCols As Long = 0)

Purpose

In Thermo Fisher Scientific reports, the manually integrated values are normally displayed
with a rectangular box around them. The Public Sub SetManuallyIntegrated function is
specifically created for two primary purposes:

* You can use it to format the data table for final display. In this case, refcolnvame is
normally a hidden column containing the manual integration flag. va7uecolname is the
column enclosed in a box. When more than one column is to be enclosed in a box, you
can use the extraco] parameter. For example, a long compound name might use three
columns, although its value is defined in one (the first) column. In this case, extracols
must be 2.

* You can use it to reformat the data for further processing. For example, in creating the
calibration report, you can use this function to format the data table before it is translated
into a pivot table. This step is necessary because the Excel pivot table can only work with
numbers.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub SetManuallyIntegrated syntax.

Table 37. Public Sub SetManuallylntegrated parameters (Sheet 1 of 2)

Parameter Description
dataTableName Specifies the name of the data table.
refcolnName Specifies the name of the column, which is the column header

text, that acts as a reference value.

valueCoIName Specifies the name of the column containing the value to be
manipulated.
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Table 37. Public Sub SetManuallylntegrated parameters (Sheet 2 of 2)

Parameter Description

negatevalue Specifies whether the value should be negated.
* True: Negates the value.

¢ False: Does not negate the value.
The default is False.

This parameter is optional.

extracols Specifies the number of extra columns to be included in the
manual integration frame.

The default is 0.

This parameter is optional.
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Public Sub ReformatManuallyIntegrated

Public sub ReformatManuallyIntegrated(Byval target As Range)

Purpose

This function is a special-purpose function that adds a box around the cell in a specified
column whose value is negative. It also turns a negative value to positive. This function is used
in the calibration report for post-processing the manual integration flags after the pivot table
is created.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub ReformatManuallylntegrated syntax.

Table 38. Public Sub ReformatManuallylntegrated parameters

Parameter Description

target Specifies a range of cells by a named range, a cell range, or a cell.
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Public Sub SetNoData

PubTlic Sub SetNoData(Byval target, Optional Byval text As String = "No
data for this report™)

Purpose

This function sets specified text in the target cells. You can use it to create more consistent
reports.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub SetNoData syntax.

Table 39. Public Sub SetNoData parameters

Parameter Description
target Specifies a range of cells by a named range, a cell range, or a cell.
text Specifies the text to display.

This parameter defaults to “No data for this report.”

This parameter is optional.
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Public Sub HideRepeatArea

PubTlic Sub HideRepeatArea(Optional name As String = "RepeatArea",
optional AideHelpercolumns As Boolean = True)

Purpose

This function hides the rows in the named range of the repeat area (RepeatArea). It is
normally called after the sheet is processed. Some templates have helper columns (for
example, data tables) next to the repeat area that must be hidden as well. The optional
hideHe Ipercolumns parameter hides the helper columns in one function call.

Parameters

The following table describes the parameters that you must provide values for in the Public

Sub HideRepeatArea syntax.
Table 40. Public Sub HideRepeatArea parameters

Parameter Description

name Specifies the name of the repeat area. The named range of the
repeat area is normally defined as RepeatArea.

The default is RepeatArea. This parameter is optional.

hiderHelpercolumns  Specifies whether to hide the helper columns (normally to the
right of the repeat area).

¢ True: Hides the helper columns.
* False: Does not hide the helper columns.

The default is True.

This parameter is optional.
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Public Sub FormatValue

Public Sub Formatvalue(Byval target, Byval Timitvalue, Byval biggerrormat
As String, Byval smallerfFormat As String, Optional Byval zeroFormat =
Nothing)

Purpose

This function formats the cell value on the basis of the limit value and given formats.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub FormatValue syntax.

Table 41. Public Sub FormatValue parameters

Parameter Description

target Specifies a range of cells by a named range, a cell range, or a cell.
Timitvalue Specifies the limit value.

biggerrormat Specifies the format to use for the value bigger than 77mitvaiue.
smallerFormat Specifies the format to use for the value smaller than 77m7tvaiue.
zeroformat Specifies the format to use for zero-value cells.

This parameter defaults to nothing. When it is set to nothing,
zero-value cells are turned into empty cells.

This parameter is optional.
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Public Sub ReplaceValue

Public Sub Replacevalue(Byval target, Byval fromvalue, Byval toValue)

Purpose

This function replaces one cell value with another.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub ReplaceValue syntax.

Table 42. Public Sub ReplaceValue parameters

Parameter Description

target Specifies a range of cells by a named range, a cell range, or a cell.
fromvalue Specifies the value to replace.

tovalue Specifies the value that replaces Fromvalue.
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Public Function ShiftRange

Public Function ShiftRange

Thermo Scientific

Public Function ShiftRange(Byval target, Byval Jeft As Long, Byval top As
Long, Optional Byval right As Long = 0, Optional Byval bottom As Long = 0)
As Range

Purpose

This function shifts the target range by the specified margins. When the right and bottom
parameters are non-zero, it also shrinks or expands the original range. This function is often
used in a loop to calculate the range for images.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function ShiftRange syntax.

Table 43. Public Function ShiftRange parameters

Parameter Description

target Specifies a range of cells by a named range, a cell range, or a cell.
left Specifies the shift value to apply to the left of the range.

top Specifies the shift value to apply to the top of the range.

right Specifies the shift value to apply to the right of the range.

The default is 0. When it is 0, no shift is applied.

This parameter is optional.

bottom Specifies the shift value to apply to the bottom of the range.
The default is 0. When it is 0, no shift is applied.

This parameter is optional.
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Public Function GetText

Public Function GetText(Byval target, Optional Byval rowbelim As String =
vbLf, Optional Byval colpelim As String = vbTab) As String

Purpose

This function returns a string containing the text of the specified target range with the given
delimiters.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function GetText syntax.

Table 44. Public Function GetText parameters

Parameter Description
target Specifies a range of cells by a named range, a cell range, or a cell.
rowbelim Specifies the delimiter to use to concatenate the rows.

The default is vbLf.

This parameter is optional.

colpelim Specifies the delimiter to be used to concatenate the columns.
The default is vbTab.

This parameter is optional.
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Public Sub MergeRowCells

Public Sub MergeRowCells

Thermo Scientific

Public Sub MergeRowCells(Byval target, Optional Byval rowAutoFit As
Boolean = True)

Purpose

This function merges cells in rows in the specified target range. It is normally used to
accommodate long values that expand to multiple cells. Text type values can run into the next
cell as long as the next cell is empty. However, other type values (for example, dates or
numbers) cannot run into the next cell. Instead, “#” appears in the cell if the values cannot fit.
In this case, you must merge the cells to get the values to display correctly in final reports.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub MergeRowCells syntax.

Table 45. Public Sub MergeRowCells parameters

Parameter Description
target Specifies a range of cells by a named range, a cell range, or a cell.
rowAutoFit Specifies whether the row height should automatically fit the text

after the merge.
* True: The row height automatically expands to fit the text.

* False: The row height does not automatically expand to fit the
text.

The default is True.

This parameter is optional.
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Public Function ArraySize

PubTic Function ArraySize(arr() As String) As Long

Purpose

This function returns the size of an array. It returns 0 if the array is not initialized.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function ArraySize syntax.

Table 46. Public Function ArraySize parameters

Parameter Description

arr Specifies the array to check.
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Public Sub LogMsg

Thermo Scientific

Public Sub LogMsg(Byval msg As String, Optional Byval f7/eName As String =
llll)

Purpose

This function adds a message to the log file. It automatically prepends each message in the log
file with a time stamp. If 77 7envame is “”, the log message is not logged unless the command
line contains the /g option. The command line in the application does not include this
option, so no log file is generated with the report. This function is primarily designed for
developing templates.

Parameters

The following table describes the parameters that you must provide values for in the Public
Sub LogMsg syntax.

Table 47. Public Sub LogMsg parameters

Parameter Description
msg Specifies the message text to add to the log file.
11eName Specifies the name of the log file. If you do not specify 77 7ename,

the function uses the default log file name specified by the /g, /d,
or /t command-line option.

The default is “”.

This parameter is optional.
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Public Function GetValidSheetName

Public Function GetvalidSheetName(name As String) As String

Purpose

This function returns a string as a valid sheet name that is based on the specified name. The
sheet name in the Excel application is like a file name in Windows, which does not allow
certain specific characters. This function replaces those special characters with a space. In
addition, the sheet name cannot exceed 30 characters, so this function trims long names up to
25 characters and appends ellipses (...). Furthermore, sheet names in an Excel workbook
cannot have duplicates. If the same name sheet already exists, this function adds a number to
the name. This function is primarily used to make a compound name a qualified sheet name,
which is used in many reports.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function GetValidSheetName syntax.

Table 48. Public Function GetValidSheetName parameters

Parameter Description

name Specifies the name to be used as the basis of the sheet name.
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Public Function FileExists

PubTic Function FileExists(Byval f7lename As String) As Boolean

Purpose

This function determines whether the specified file already exists. This function is a Windows
API wrapper.

Parameters

The following table describes the parameters that you must provide values for in the Public
Function FileExists syntax.

Table 49. Public Function FileExists parameters

Parameter Description

f1TeName Specifies the name of the file to check for.
* True: The specified file already exists.
* False: The specified file does not already exist.
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