
To familiarize yourself with using the Thermo Scientific™ Compound Discoverer™ 3.3 SP1 application to detect 
compounds labeled with a stable isotope such as carbon-13, follow the topics in this tutorial. These topics show you 
how to set up a study and an analysis, process a set of example Xcalibur™ RAW files, review the result file produced 
by the analysis, and export the results to a Microsoft™ Excel™ spreadsheet.
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Overview Before begin this tutorial, locate the example files for a stable isotope labeling study and review the tutorial 
workflow:

• Locate the example files for this tutorial

• Tutorial workflow

• Use the Help system, the user guides, and the tutorials as needed

Locate the
example files for

this tutorial

In the Compound Discoverer application, data processing takes place within the study environment. To create a 
practice study, use the example Xcalibur RAW files that are provided in the following folder on the key-shaped USB 
drive in the software media kit: 

Example Studies\LC\Stable Isotope Labeling 

To save space on your data processing computer, you can leave the raw data files on the USB drive provided in the 
software media. 

If you do not have the key-shaped USB drive that comes with the media kit, download the example files from the 
LSMS Software Download and Licensing Portal.

 To download the example files
1. Go to the following URL: thermo.flexnetoperations.com

The LSMS Software Download and Licensing Portal website opens.
2. Log in.
3. Under Software & Services at the left, click the Product List link.
4. On the Product List page, click the Application - Compound Discoverer link.
5. On the Product Information page, click the Compound Discoverer 3.3 SP1 link.

The Product Information page for the Compound Discoverer 3.3 SP1 application contains compressed folders
for all the tutorials provided with the application.

Compound Discoverer 3.3 SP1 Stable Isotope Labeling Tutorial

Note  For isotopic labeling experiments, you must use a high resolution accurate mass (HRAM) Thermo 
Scientific mass spectrometer coupled with a liquid chromatography (LC) inlet to acquire the raw data.
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6. On the Product Download Compound Discoverer 3.3 SP1 page, click the file names of the compressed folders 
(.zip) that contain the example files of interest.

7. Copy the files to a folder on your data processing computer.

Tutorial
workflow

The typical workflow for a stable isotope labeling analysis includes the following steps. 

File name File type File name File type

Blank_01.raw RAW file Ecoli_12C_AcquireX_ID_01.raw RAW file

Ecoli_12C_01.raw RAW file Ecoli_12C_AcquireX_ID_02.raw RAW file

Ecoli_12C_02.raw RAW file Ecoli_12C_AcquireX_ID_03.raw RAW file

Ecoli_12C_03.raw RAW file Ecoli_12C_AcquireX_ID_04.raw RAW file

Ecoli_13C_01.raw RAW file Stable Isotope Labeling.cdResult Result file (analysis result)

Ecoli_13C_02.raw RAW file Stable Isotope Labeling.cdStudy Study file

Ecoli_13C_03.raw RAW file

IMPORTANT  For optimal performance, all Compound Discoverer study files (.cdStudy) and result files 
(.cdResult) should be located on a local hard drive, ideally a solid state drive (SSD). Latency, read- and write 
speeds of external USB-connected hard drives and network drives are typically much slower than internal 
hard drives. 

Because the result files are continuously accessed throughout the entire data processing workflow, processing 
times can be significantly longer when using external drives. The RAW files however, are read only once, at 
the very beginning of the processing workflow and can be located on an internal or external drive.

Step Task

Start the Compound Discoverer application.

Check the computer’s access to the mzCloud™ and ChemSpider™ databases.

Use the New Study and Analysis Wizard to do the following:

a. Select the study type, create a new study, and select a processing workflow.

b. Add the files that you want to process to the study.

c. Define the sample types for the sample set.

d. Set up the sample groups for the analysis.

Confirm the analysis and start the run.

Open the result file and review, filter, and sort the data.

Sort and filter the data. Then, export the data to a spreadsheet. 
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Use the Help
system, the user
guides, and the

tutorials as
needed

The application provides Help for the views, pages, and dialog boxes. It also provides two user guides—one for LC 
studies and one for GC studies, six tutorials for various fields of study, and a quick start guide for creating reports 
with the application’s reporting tool.

Table 1. Instructions for accessing the Help, the tutorials, and the user guides

Task Procedure

Open the Help topic for a 
specific view, page, or dialog 
box

1. Open the view, page, or dialog box.
2. On the computer keyboard, press the F1 key or the function key on 

your keyboard that you have assigned as the Help key.

The Help system opens to the topic for the current view, page, or 
dialog box.

Find a topic in the Help 
system for a specific topic or 
phrase

1. On the Search page in the left pane of the Help system, enter the topic 
name or the phrase in quotes in the search box. 

2. Click List Topics.
3. In the Select Topic to Display list, select the topic of interest and click 

Display.

Access the manuals as PDF files From the menu bar, choose Help > Manuals.

The following list appears:
• Compound Discoverer Metabolism Tutorial
• Compound Discoverer Metabolomics Tutorial
• Compound Discoverer E & L Tutorial
• Compound Discoverer Stable Isotope Labeling Tutorial
• Compound Discoverer GC EI Tutorial
• Compound Discoverer GC PCI Tutorial
• Compound Discoverer User Guide for LC Studies
• Compound Discoverer User Guide for GC Studies
• Compound Discoverer Reporting Quick Start
3



Start the
application

 To start the application

• From the taskbar, choose Start > All Programs (or Programs) > Thermo Compound Discoverer 3.3.

–or–

• From the computer desktop, double-click the Compound Discoverer 3.3 icon, .

The application opens to the Start Page.

Check
whether the

data
processing

computer can
access the

external
databases

To use any of the processing workflows that use the online databases, such as mzCloud™ and ChemSpider™, your 
data processing computer must have unblocked access to these databases on the Internet. 

 To verify that your computer has access to the external mass spectral databases
1. From the menu bar, choose Help > Communication Tests.
2. Click the mzCloud tab and click Run Tests. When the tests are complete, go to the next step.
3. Click the ChemSpider tab and click Run Tests. 
4. If your computer has an Internet connection, but these tests fail, leave the Communication Test dialog box open 

and press the F1 key to open the Help. Then, follow the instructions to troubleshoot the communication failure. 

Go to the next topic to “Set up a new study and a new analysis.” 

Set up a new
study and a

new analysis

Make sure to copy the example files to an appropriate folder on your data processing computer. See “Locate the 
example files for this tutorial” on page 1.

Follow these steps to create a new study and a new analysis in the order listed:
1. Open the New Study and Analysis Wizard
2. Select the study type, specify the directory folder, and name the new study
3. Select the processing workflow
4. Add the input files to the study
5. Specify the sample types
6. Set up the sample groups
7. Customize the processing workflow

Menu bar Study, data review, and reporting 
toolbar icons
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Open the New
Study and

Analysis Wizard

In the Compound Discoverer application, you use the New Study and Analysis Wizard to create new studies and set 
up new analyses.

 To open the New Study and Analysis Wizard

Do one of the following:

• From the menu bar, choose File > New Study and Analysis.

• From the application toolbar, click the Create a New Study and Analysis from Scratch icon, .

• On the Start Page, click the New Study and Analysis link in the What Would You Like to Do? area.

The New Study and Analysis Wizard opens to the Study Name and Processing Workflow page. The first time 
you create a new study, the (top-level) studies folder is undefined. See Figure 1.
Figure 1. Study Name and Processing Workflow page of the wizard

Leave this page of the wizard open and go to the next topic to “Select the study type, specify the directory folder, and 
name the new study.” 

Select the study
type, specify the
directory folder,

and name the
new study

 To select the study type, specify the directory folder, and name the new study
1. In the Study Type area on the Study Name and Processing Workflow page of the wizard (Figure 1), select the LC 

option if it is not already selected.

The application stores this selection until you change it.
.

2. In the Study Name and Directory Structure area, select the studies directory folder as follows:
a. Click the browse icon, , next to the Studies Folder box.

The Select Folder dialog box opens.

Note  After you create a new study and assign sample types to the input files, you can set up different analyses 
from within the study.

Undefined 
studies folder

Note  There are two types of studies: GC for gas chromatography-mass spectrometry data and LC for liquid 
chromatography-mass spectrometry data.
5



b. Browse to the directory where you want to store your studies.

c. Click New Folder.
d. Name the new folder Studies, select it, and then click Select Folder (Figure 2). 

Figure 2. Select Folder dialog box

3. In the Study Name and Directory Structure area, name the new study in the Study Name box.

For example, type Stable Isotope Labeling in the Study Name box.

Leave this page of the wizard open and go the next topic to “Select the processing workflow.” 

Select the
processing

workflow

In the Compound Discoverer application, the processing method that interprets the raw data is called a processing 
workflow (.cdProcessingWF). The application provides defined processing workflows for several applications 
including stable isotope labeling experiments. 

This tutorial uses a defined processing workflow that searches the mzCloud and ChemSpider databases to identify 
the unlabeled compounds detected in the sample files. It uses the Analyze Labeled Compounds node to detect the 
isotopologues of these compounds. This workflow also maps compounds to their biological pathways by using the 
local Metabolika pathway files.

IMPORTANT  To avoid excessive processing times, select a directory on your data processing computer. 
Do not store your studies on an external hard drive. 

You can archive your studies on an external hard drive. But, if you need to fully reprocess any of the 
result files in these studies, move the studies back to a computer that has an installation of the 
Compound Discoverer application.

During data processing, the application makes a copy of the spectral data in the raw data files and copies 
this data to the result file, which is located in the folder that has the same name as the study. This 
processing step is relatively fast, so storing the raw data files on an external hard drive instead of the 
processing computer does not add a significant amount of time to data processing.

Note  The first time you create a new study, you must specify the directory (Studies Folder) where you want 
to store your studies. Thereafter, you can use the same studies folder or create additional studies folders.

Note  When you create a new study, the application creates a new study folder with the same name and 
stores the study file (.cdStudy) in the new folder and the new study folder in the specified top-level folder for 
your studies.

 > This PC > OSDisk (C:) > Studies > Stable Isotope Labeling > Stable Isotope Labeling.cdStudy

Select Folder button

Note  If your processing computer does not have Internet access, select the following processing workflow: 
Stable Isotope Labeling w Metabolika Pathways and ID using Offline Databases. 
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 To select the processing workflow
1. In the Processing area on the Study Name and Processing Workflow page of the wizard, select the following 

processing workflow from the Workflow list:

Workflow Templates \LC\ Stable Isotope Labeling\Stable Isotope Labeling w Metabolika Pathways and 
ID using Online Databases

Figure 3. Selecting the processing workflow template from the Workflows list

A description of the processing workflow appears in the Workflow Description box. 

2. Read the description.
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Go to the next topic to “Add the input files to the study.” 

Add the input
files to the study

 To add input files to the study
1. At the bottom of the Study Name and Processing Workflow page of the wizard, click Next.

The Input File Selection page opens.
2. On the Input File Selection page, click Add Files.
3. In the Add Files dialog box, browse to the folder where you copied the example RAW files.

4. Select all 11 Xcalibur RAW files in this folder and click Open.
Figure 4. Imported example files

Note  When you complete the wizard, the application creates the Stable Isotope Labeling Examplel.cdStudy 
file, stores the study file in the Stable Isotope Labeling Example folder, and stores the Stable Isotope Labeling 
Example folder in the Studies folder. 

When you run the analysis in this tutorial, the application stores the result file (.cdResult) in the Stable 
Isotope Labeling Tutorial folder.

Tip  The application assigns a file number to each input file in the order you import them (see Figure 5). The 
file numbers are useful for tracking the input files in the result file tables. 
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5. Click Next to open the Input File Characterization page of the wizard. 

Figure 5 shows the newly added samples in the Samples area on the Input File Characterization page of the 
wizard. By default, the application assigns Sample as the Sample Type to new samples. 
Figure 5. Imported files with assigned file numbers

Leave this page of the wizard open and go to the next topic to “Specify the sample types.” 

Specify the
sample types

To specify the sample types for the example files in this tutorial, do the following in any order on the Input File 
Characterization page of the wizard:

• Automatically assign the blank sample type

• Specify the identification samples

• Specify the labeled samples

Table 2 describes the sample types for a stable isotope labeling analysis.

Default 
sample 
type

File numbers based on the import order

Table 2. Sample types

Sample type The application processes these sample types as follows

Sample Detects the unlabeled compounds in the sample.

Blank Marks the background compounds in the entire data set.

Identification Only Does not report the chromatographic peak areas for the compounds in these samples. 
Uses the sample’s fragmentation scans for component (compound) identification.

Labeled Determines the isotopic label incorporation. 
9



Automatically assign
the blank sample type

 To assign the Blank sample type

In the command bar, click Assign.

The application assigns the Blank sample type to the Blank.raw file.

Go to the next topic to identify the samples to be used to identify the compounds in the unknown samples.

Specify the
identification

samples

Identification samples must have fragmentation scans. In the example data set, the Acquire_X_ID.raw files contain 
data-dependent fragmentation scans (acquired within the same acquisition sequence and the same chromatographic 
conditions as the other data files).

 To specify the samples to use for compound identification

Use the SHIFT key to select the four Acquire_X_ID files. Then, right-click the selected rows and choose Set 
Sample Type To > Identification Only (Figure 6).

Figure 6. Defining the samples to be used for Identification Only

Go to the next topic to identify the labeled samples.

Specify the labeled
samples

The tutorial data set includes three samples labeled with carbon-13.

 To specify the labeled samples for the detection of labeled compounds

Use the CTRL key to select the files with 13C in their file name. Then, right-click the selected rows and choose 
Set Sample Type To > Labeled (see Figure 7 on page 11).

Note  When you select the appropriate delimiters, the application assigns the Blank sample type to files 
named Blank or files with Blank in the file name.

Tip  To select a row, you can click any column but the Sample Type column.
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Figure 7. Defining the labeled samples

Set up the
sample groups

 To set up the sample groups for the analysis
1. At the bottom of the Input File Characterization page, click Next. 

The Sample Groups and Ratios page of the wizard opens. Use this page of the wizard to set up the sample groups 
and ratios for a differential analysis. 

Figure 8 shows the 11 individual example files with their defined sample types in the Generated Sample Groups 
pane. Because you have not yet selected the study variables, the samples are not grouped.
Figure 8. Generated sample groups without any study variables

Tip  Unlike a typical metabolic flux experiment, this tutorial does not include time as a study variable. For 
information on how to set up the study factors for a metabolic flux experiment, follow the embedded wizard 
Help or press the F1 key to access the Help system.

The time points in a flux experiment are the items for a categorical study factor.
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2. In the Study Variables area of the Sample Groups and Ratios page of the wizard, select the Sample Type check 
box.

The sample groups—Blank, Sample, Identification Only, and Labeled—appear in the Generated Sample Groups 
area (see Figure 9 on page 12).

Figure 9. Samples grouped by sample type

3. At the bottom of the Sample Groups and Ratios page, click Finish to save the study and close the wizard.

The study page with its four subpages and the analysis that you set up with the wizard open. See Figure 11.

The Analysis view lists the 11 input files in the example data set. The analysis is set up to combine the processed 
results from these files into one result file—that is, the By File check box is clear and the file name for the result 
file is available for editing.

Note  For the example data set, grouping the samples by sample type makes reviewing the data in the result 
tables easier. 

Tip  If you are setting up a metabolic flux study for your own data set, use the Sample Groups and Ratio page 
to set up the ratios for a differential analysis.
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Figure 10 shows the Input Files page of the study and the Analysis view with a list of files for analysis. 
Figure 10. Study with an analysis that is ready for processing

Customize the
processing

workflow

Before submitting the analysis to the job queue, review the processing workflow and make changes as needed.

 To review and customize the processing workflow for this tutorial
1. Click the Workflows tab to open the Workflows page of the analysis.

The Workflows page displays the processing workflow that you selected with the wizard. 

Figure 11 on page 14 shows the processing workflow in the Workflow Tree pane. 

Tabs for four 
the subpages 
of the study 

Analysis 
pages

Analysis viewStudy page tab

Files for analysis

Opens the 
Workflows page

Tip  You can open the Workflows page in two ways:

• Click the Workflows tab to the left of the Analysis view.

• Click Edit in the Analysis view to the right of Processing Step. 
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Figure 11. Processing workflow template for a stable isotope labeling experiment

IMPORTANT  The minimum peak intensity setting in the Detect Compounds (Legacy) node specifies the 
minimum height (for the base spectral peak of a chromatographic peak) for detecting and reporting 
chromatographic peaks. 

For this tutorial, change the setting to 100000 (1e5), as the raw data files were acquired with an Orbitrap 
ID-X™ mass spectrometer (see Table 3). 
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2. To customize the minimum peak intensity for the Detect Compounds (Legacy) node, do the following, 
a. In the Workflow Tree area on the Workflows page, click the Detect Compounds (Legacy) node to select it.

A dashed green border appears around the Detect Compounds (Legacy) node. 

In addition, the parameters page for the node opens to the left of the Workflow Tree pane. Most of the 
parameters for the node are set to their default values, but Thermo Fisher Scientific customized a few of the 
parameters settings for the processing workflow template. 
Figure 12. Parameter settings for the Detect Compounds (Legacy) node

Figure 13. Ions list in the Detect Compounds (Legacy) node

Detect Compounds
(Legacy)C OH

O

Thermo Fisher Scientific set this parameter to 
1E6 in the processing workflow templates for 
stable isotope labeling.

Thermo Fisher Scientific set this parameter to 
False in the processing workflow templates 
for stable isotope labeling.

For the Ions parameter, Thermo Fisher 
Scientific selected 32 out of 33 ions 
in the processing workflow templates 
for stable isotope labeling. Notice 
that the triply charged ion is not 
selected.
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b. In the parameters page for the Detect Compounds (Legacy) node, type 1e5 in the Min. Peak Intensity box.

Table 3 lists the recommended range for the Min. Peak Intensity parameter, which depends on the sensitivity 
of the mass spectrometer. 

3. (Optional) To learn more about the parameter settings for the workflow nodes in the processing workflow 
template for stable isotope labeling studies, review the settings in Table 4.

Note   The Analyze Labeled Compounds node requires input from the Detect Compounds (Legacy) 
node. 

The Use Most Intense Isotope Only parameter is set to False in the processing workflow templates for 
stable isotope labeling and 32 out of 33 ion definitions are selected for the Ions parameter.

Table 3. Recommended minimum peak intensity range

Mass spectrometer Minimum peak intensity
(chromatographic peak height)

Q Exactive™, Q Exactive Plus™, Q Exactive HF 500 000 to 1 000 000

Exactive™, Exactive Plus™, Orbitrap Elite™, Orbitrap Velos Pro™ 100 000 to 500 000

Orbitrap Fusion™, Orbitrap Lumos, Orbitrap ID-X 50 000 to 100 000

LTQ Orbitrap XL™, LTQ Orbitrap Velos™ 25 000 to 100 000

Table 4. Processing workflow node settings for the stable isotope processing workflow template (Sheet 1 of 2)

Group Compounds node

In the processing workflow template for stable isotope labeling, the RT Tolerance is set to 0.2 min. 

The Group Compounds node creates the MSn tree that the analysis sends to the search nodes and saves to the 
result file. The Predict Compositions node uses the MSn tree to match fragments.

The peak rating filter 
is not enabled.
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Assign Compound Annotations node

For the example data set, do not change the settings.

Tip  If you are working with your own data set and the analysis does not identify the correct isotopologues, 
consider changing Data Source #1 to a custom mass list for your analytes and reprocessing the analysis.

Analyze Labeled Compounds node

For the example data set, keep the default settings. For a different data set, enter the appropriate isotope for the 
Label Element parameter. 

Table 4. Processing workflow node settings for the stable isotope processing workflow template (Sheet 2 of 2)

Hides the compounds without formulas 
in the Compounds table.

Customize this setting for your own data set, as appropriate.
Specifies the maximum number of exchangeable atoms.

The default setting is 25.

If you set this value to 0, the analysis determines the 
maximum number of exchangeable atoms for each 
compound from the compound’s elemental composition.
17



Submit the
analysis to

the job queue

For the example data set and analysis, you can now submit the analysis to the job queue for processing.

 To submit the analysis to the job queue
1. To create one result file for the input file set, leave the By File check box clear in the Analysis view.

In this analysis (and for most analyses), you compile the processing results from multiple input files into one 
result file.

By default, the application uses the name of the first input file for the file name of the result file.
2. In the Result File box, rename the result file Stable Isotope Labeling.

3. Click Run.

The Analysis Validation Issues prompt opens with an alert about the lack of a peak rating filter in the Group 
Compounds node. 

4. Click Ignore.

The Job Queue page opens. 
5. To view the processing messages, click the expand icon, , to the left of the job row. 

 

6. Leave the Job Queue page open and go to “Review the analysis results.” 

Tip  If you modified the analysis and the Run button is unavailable, do the following:

• Remedy the issues listed in the Current Workflow Issues pane on the Workflows page. 

• If there is a Caution symbol to the right of Edit in the Analysis view, point to it and remedy other 
analysis errors, for example, no input files in the Files for Analysis area of the Analysis view or missing 
node connections.

If a prompt appears when you submit the run, open the Grouping & Analysis page of the analysis and select 
the Sample Type check box to group the input files by sample type.

Note  During the run, the Search ChemSpider node generates warning messages, which you can ignore. 
Warning messages have a yellow background.

Result file name

Available Run 
command

Expand 
icon
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Review the
analysis

results

To review the analysis results, follow these topics in the order listed: 
1. Open the result file
2. Review the default layout for the result page and common layout modifications
3. Apply the Stable Isotope Labeling layout
4. Review the exchange rates
5. Review the labeling status
6. View a trend chart for a single compound or a set of trend lines for multiple compounds
7. View the distribution of the isotopologues for each compound
8. View the Metabolika pathways for a compound

For more information about a specific result table or view, select the table or view to make it active, and then press 
the F1 key. The Compound Discoverer application provides F1 Help for all the views that you access from the View 
menu and all the result tables.

Open the result
file

You can open a result file from multiple locations: the Job Queue page, the Analysis Results page of a study, the 
Compound Discoverer Start Page, or the menu bar.

 To open the result file generated by the analysis

When the application completes the run, double-click the run on the Job Queue page. 

Review the
default layout for

the result page
and common

layout
modifications

These topics describe the default layout for the result file that the stable isotope labeling analysis generates and some 
of the common layout modifications that you can make:

• Default layout for the stable isotope labeling analysis

• Common layout modifications

Note  For this tutorial, you can create a result file by setting up and running an analysis with the example data 
set. Or, you can open the result file—Stable Isotope Labeling—in the same folder where you found the example 
data set.
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Default layout for the
stable isotope

labeling analysis

The result file opens as a tabbed document with the following layout (numbered in Figure 14 on page 20):
1. The Chromatograms view appears on the upper left of the page.

The Chromatograms view displays the overlaid and shaded chromatographic peaks for the compound in the first 
row of the Compounds table. 

2. The Mass Spectrum view appears on the upper right of the page.

The Mass Spectrum view displays the MS1 scan in the spectrum tree that is closest to the apex of the 
compound’s chromatographic peak. 

The spectrum tree to the left of the spectrum plot includes the MS1 scans and the fragmentation scans for the 
preferred ions that the MS acquired within the following retention time window:

• The chromatographic peak apex for the selected compound ± peak width at half maximum (FWHM)

–or–

• The Start and end points of the chromatographic peak, as determined by the peak detection algorithm 

3. A set of tabbed result tables opens in the bottom half of the page. The Compounds table is the active table. 

Because the selected processing workflow includes the Mark Background Compounds node and the Analyze 
Labeled Compounds node, the Compounds tab has a filter icon with a check mark ( ). The compounds that 
the analysis identified as background compounds are marked as background compounds in both the blank and 
non-blank samples and are hidden from the table. In addition, the compounds without a formula are hidden 
from the table.

4. A collapsed area for the related data tables below the main tables.

In the Compounds table, the detected compounds are listed in descending order of the maximum chromatographic 
peak area [Area (Max.)] across the set of input files. The Chromatograms and Mass Spectrum views are populated 
with data for the first compound in the table. 

Figure 14 shows the factory default layout for the Stable Isotope Labeling.cdResult file.
Figure 14. Default result file layout 

Note  If the data set does not include data-dependent MS2 scans within the retention time window but does 
include data-independent scans within this window, the spectrum tree includes the data-independent scans. 

1 2

3

4
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Common layout
modifications

You can change which columns, tables, and views are visible or hidden. To display the subcolumn headings for 
columns that contain multiple subcolumns, you must expand the column headers. 

Table 5. Common layout modifications

Task Procedure

Show or hide a table column Open the Field Chooser for a table by clicking the icon, , in the upper 
left corner of the table. To display a column, select its check box. To hide 
a column, clear its check box. 

Show or hide a table Open the Select Table Visibility dialog box by clicking the icon, , at 
the left of the table tabs.

Close a view Click the close icon, , in the upper right corner of the view.

Open a view In the application menu bar, choose View > Specific View. Or, in the 
toolbar, click the icon for the view.

Expand the header for a column with 
multiple subcolumns

Click the expand icon, , to the right of the heading.

Freeze a column to the left side of the 
table

Right-click the table and choose Enable Column Fixing. Then, click the 
pin icon to the right of the column heading.

Pin a row to the top of the result table. Click the pin icon to the right of the row number (unpinned, , or 
pinned, ) 

Sort a result table by a column with 
numeric or text information.

Click a column header once or twice to sort the rows in ascending order 
( ) or descending order ( ), based on the contents of the column. 

Sort a result table by multiple columns. Click the column header of the primary sort column once or twice to 
sort the rows in ascending order ( ) or descending order ( ), based 
on the contents of the column.

Hold down the CTRL key and click the column header of the secondary 
sort column once or twice to set the sort order.

Reset the result page layout. From the application menu bar, choose Window > Reset Layout.
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Apply the Stable
Isotope Labeling

layout

The application comes with the factory default layout and two named layouts: 
Statistics and Stable Isotope Labeling. When reviewing the results of a stable 
isotope labeling analysis, apply the Stable Isotope Labeling layout. 

 To apply the Stable Isotope Labeling layout to the current result file

From the application menu bar, choose Window > Apply Layout > Stable 
Isotope Labeling.

Applying the Stable Isotope Labeling layout does the following to the example 
result file as shown in Figure 15 on page 23:

• Hides the following main tables: 

• Hides the following columns in the Compounds table: 

• Opens the Related Tables pane to the Labeled Compounds per File table 
for the first compound in the Compounds table.

• Opens the Isotopologues Distribution Chart, Trend Chart, and 
Metabolika Pathways views as tabbed views on the bottom right of the 
page.

• Selects the Rel. Exchange data property for the Trend Chart view.

 Compounds per File  Labeled Compounds per File

 Features per File  Labeled Features

 ChemSpider Results  mzCloud Results

 #Adducts  Gap Status

 #Metabolika Pathways  Metabolika Pathways

 Annot. Mass [Da]  MS Depth

 Annotation MW  mzCloud Library Matches

 Avg. Exchange  RT Tolerance [min]

 Background  Structure

 FISh Coverage
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Figure 15. Default layout after applying the Stable Isotope Labeling layout

Review the
exchange rates

The following topics show you how to modify the layout of the result page for easier visualization of the exchange 
rate columns in the Compounds table:

• View the relative exchange rates for a compound across the input file set

• View the exchange rate for each of the compound’s isotopologues

• View the exchange rates for the adducts of a compound

View the relative
exchange rates for a

compound across the
input file set

Precondition: You applied the Stable Isotope Labeling layout to the result file as described in “Apply the Stable 
Isotope Labeling layout” on page 22.

In this topic, you review the exchange rates for L-glutamic acid. The chromatographic peak for this compound has 
the second largest maximum area among all the detected compounds, so it sorts to row 2 when the Compounds 
table is sorted in descending order by the Area (Max). column.

 To view the relative exchange rates for a compound across the input file set
1. In the Compounds table, click the pin icon to the left of L-Glutamic acid in row 2.

Clicking the pin icon to the right of a row number freezes the row to the top of the table. 
Figure 16. L-glutamic acid frozen at the top of the Compounds table

2. In the Compounds table, freeze the Name column at the left of the table as follows:
a. Right-click the Compounds table and choose Enable Column Fixing. See Figure 17.

Note  The Annotation Source column is hidden in the following figures.
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Figure 17. Shortcut menu for the Compounds table

Pin icons appear to the right of the column headings.

b. Click the pin icon to the right of the Name column heading (pinned, , and unpinned, ). 
3. Scroll right to the Rel. Exchange [%] column.
4. To view the input file names in the Rel. Exchange [%] column, click the expand icon ( ) next to the column 

header. Or, right-click the Compounds table and choose Expand All Column Headers to expand all the table 
column headers.

Figure 18 shows the relative exchange rate for L-glutamic acid in each input file. The relative exchange rate is 
98% for the labeled samples and 0% for the unlabeled samples.
Figure 18. Relative exchange rate for L-glutamic acid 

Name column frozen at the left of the 
Compounds table

98% relative exchange rate for L-glutamic acid in 
the three labeled samples (F9, F10, and F11)
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View the exchange
rate for each of the

compound’s
isotopologues

 To view the exchange rate for each isotopologue of a compound
1. In the main Compounds table, select L-glutamic acid (row 2).

• If you applied the Stable Isotope Labeling layout, the related tables pane is visible and the Labeled 
Compounds per File table is the active table. See “Apply the Stable Isotope Labeling layout” on page 22.

• If you fixed the Name column to the left of the table, you can scroll to the right without losing track of which 
compound you are viewing. See step 2 in “View the relative exchange rates for a compound across the input 
file set” on page 23.

2. Click Show Related Tables below the main tables.

With the Stable Isotope Labeling layout applied, the related tables pane opens to the Labeled Compounds per 
File table for L-glutamic acid.

3. In the related Labeled Compounds per File table, scroll to the Exchange Rate [%] column.
4. To view the isotopologues, click the expand icon ( ) next to the Exchange Rate [%] column heading.

Figure 19 shows the exchange rates in the labeled (F9, F10, and F11) and unlabeled (F2, F3, and F4) samples. 
The exchange rates for the labeled samples are 92% for the 13C5H9NO4 isotopologue and 7% for the 
13C4CH9NO4 isotopologue of L-glutamic acid. 

The Exchange Rate [%] column contains 25 subcolumns because the analysis specified a maximum exchange 
of 25 atoms for any of the detected compounds. See “Analyze Labeled Compounds node” on page 17.

Color-coding: 

• Irrelevant subcolumns for unprocessed elemental compositions have a gray background.

• Subcolumns for isotopologues have a pink to red background that turns darker as the exchange rate increases. 
Figure 19. Exchange Rate and Study File columns in the Labeled Compounds per File table for L-glutamic acid 

(numbered in clockwise order, starting with 1 at the top right)

View the exchange
rates for the adducts

of a compound

Precondition: Glutamic acid (row 2) is selected in the main Compounds table.

 To view the exchange rates for the adducts of a compound in a specific input file
1. In the related Labeled Compounds per File table for glutamic acid, select F11, a labeled sample.
2. Click Show Related Tables below the Labeled Compounds per File table.
3. In the related tables pane for input file F11, click the Labeled Features tab to make it the active table.

No. Description No. Description

1 Unlabeled samples, F2, F3, and F4 4 Exchange rate [%] for all five carbon atoms in 
L-glutamic acid

2 Labeled samples, F11, F10, and F9 5 Exchange rate [%] for four out of five carbon atoms in 
L-glutamic acid

3 Blank sample, F1 6 Exchange rate [%] for all no carbon atoms in 
L-glutamic acid

1

2

4

3

6 5
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This figure shows the relative amounts (by chromatographic peak area) of the labeled adduct ions that the 
analysis detected for L-glutamic acid in study file F11 (a labeled sample).
Figure 20. Labeled features for L-glutamic acid in study file F11

Review the
labeling status

The Labeling Status column in the Compounds table and the Status column in the Labeled Compounds per File 
table provide information about the quality of the analysis.

( ) Red—Indicates a contaminating mass in an unlabeled sample.

( ) Blue—Indicates an irregular exchange rate for a labeled sample.

( ) Orange—Indicates a low fit between the measured and fitted isotope patterns. 

( ) Gray—Indicates the absence of isotopologues for the detected compound. 

A contaminating mass in an unlabeled sample is more problematic than an irregular exchange rate for a labeled 
sample.

 To investigate a contaminating mass in an unlabeled sample
1. In the Compounds table for the example result file, sort the compounds in descending order by Area (Max.).

If you fixed L-glutamic acid to the top of the table, sorting the compounds releases it.
2. In row 8, click the pin icon to the left of NP-008095 to fix this compound to the top of the table.
3. Click the expand icon, , for the Labeling Status column. 

Because you grouped the samples by sample type (Figure 9), the samples are also grouped by sample type in the 
Labeling Status column.

The red status for NP-008095 in the unlabeled samples indicates the presence of a contaminating mass in these 
samples (F2, F3, and F4). 
Figure 21. Cuauhtemone (row 7) in the Compounds table (with the Name and Labeling Status columns frozen at the left)

4. In the related Labeled Compounds per File table for cuauhtemone, do the following:

• Right-click the table and choose Enable Column Fixing. Then, click the pin icon for the Exchange Rate [%] 
column.

• Click the expand icon, , for the Exchange Rate [%] column.

Unlabeled 
samples

Labeled 
samples
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This figure shows the exchange rate for NP-008095 in its related Labeled Compounds per File table. The 
Exchange Rate [%] column shows that the contaminating mass is possibly a compound with a mass of M+4.
Figure 22. Labeled Compounds per File table for cuauhtemone

View a trend
chart for a single

compound or a
set of trend lines

for multiple
compounds

When you apply the Stable Isotope Labeling layout, the Trend Chart view opens as a hidden view below the 
Isotopologues Distribution Chart view.

Use the Trend Chart view to compare the relative exchange rate [%] for each compound by input file, sample group, 
or study variable (for example, the time points in a metabolic flux study). When you select a single compound in the 
Compounds table, you can view its distribution as a box-and-whiskers plot or as a trend line plot. When you select 
multiple compounds in the Compounds table, the application automatically displays the distribution for each 
compound as a trend line plot.

 To view a box-and-whiskers plot for L-glutamic acid
1. To sort the main Compounds table in descending order by area, click the Area (Max.) column heading. 

For the example data set, L-glutamic acid sorts to the top of the table.
2. In the Compounds table, select L-Glutamic Acid (row 2).
3. In the set of tabbed views to the right of the result table, click the Trend Chart tab.

By default, the Trend Chart view displays a box-and-whiskers plot for the relative 
exchange rate per group (labeled and sample).

4. Right-click the chart and choose Show Legend.

The legend appears below the chart.
5. To display a tooltip with descriptive statistics, point to a box or a whisker. 

The false exchange rate of four carbon-13 atoms for an unlabeled 
compound was probably caused by a contaminating mass of M + 4.

Note  The example data set does not include metabolic flux samples.

Tip  Apply the Stable Isotope Labeling layout if you have not already applied it or if you closed some of the 
views. To apply the Stable Isotope Labeling layout, choose Window > Apply Layout > Stable Isotope Labeling 
from the menu bar.
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This figure shows the box-and-whiskers plot for L-glutamic acid with the samples grouped by sample type.

View the
distribution of

the
isotopologues

for each
compound

Use the Isotopologues Distribution Chart view to visualize the distribution of the isotopologues for a compound.

 To view the distribution of the isotopologues for a compound
1. Apply the Stable Isotope Labeling layout to the result file (see “Apply the Stable Isotope Labeling layout” on 

page 22).

The Isotopologues Distribution Chart view opens to the right of the result tables.
2. In the Compounds table, select a compound of interest.

Figure 23 shows the distribution for L-glutamic acid with no sample grouping.

Legend Tooltip
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Figure 23. Isotopologues Distribution Chart view showing L-glutamic acid with no sample grouping

3. To group the samples by Sample Type, under Group By, select the Sample Type check box.

Figure 24 shows the isotopologue distribution for L-glutamic acid with the samples grouped by sample type.
Figure 24. Isotopologues Distribution Chart view showing L-glutamic acid with samples grouped by sample type
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View the
Metabolika

pathways for a
compound

The Map to Metabolika Pathways node (in the selected processing workflow) returns a set of mapped pathways for 
each detected compound.

 To view the Metabolika pathways that include a selected compound
1. Apply the Stable Isotope Labeling layout to the result file (see “Apply the Stable Isotope Labeling layout” on 

page 22).

The Isotopologues Distribution Chart, Trend Chart, and Metabolika Pathways views open as tabbed views on 
the bottom right of the page. The related tables pane opens below the main tables pane.

2. Close some of the views as follows:

• In the lower right quadrant, close the Isotopologues Distribution Chart view and the Trend Chart view by 
clicking their Close icons, . Leave the Metabolika Pathways view open.

• In the upper portion of the window, close the Chromatograms and Mass Spectrum views by clicking their 
Close icons, .

3. Right-click the Compounds table and choose Collapse All Column Headers.
4. Sort the Compounds table by the Area (Max.) column in descending order.
5. In the Compounds table, select row 2 (L-glutamic acid) in the example result file.
6. To view a Metabolika pathway that includes L-glutamic acid, do the following:

a. In the related tables pane for L-glutamic acid, click the Metabolika Pathways tab to make it the active table.
b. For this tutorial, scroll down to row 93—the L-glutamate degradation IX (via 4-aminobutanoate) 

pathway and select it.

This figure shows the selection of row 93 in the Metabolika Pathways table for L-glutamic acid. The mapped 
pathway appears in the Metabolika Pathways view at the right of the result tables. The Stable Isotope 
Labeling layout automatically selects the Rel. Exchange [%] column as the overlay data source with an 
overlay cell size of 10 pixels.

The mapped pathway appears in the Metabolika Pathways view at the right of the result tables. The Stable 
Isotope Labeling layout automatically selects the Rel. Exchange [%] column as the overlay data source with 
an overlay cell size of 10 pixels.

Overlay Data 
Source

Overlay Cell 
Size

Selected Metabolika 
pathway
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c. To view the Metabolika Pathways view below the result tables instead of to their right, drag the view by its 
title bar until it aligns with the alignment tool’s down arrow at the bottom of the page.
Figure 25. Dragging the Metabolika Pathways view below the result tables

d. Release the mouse button.

The structure for the compound that you selected in the Compounds table is blue, the structures for other 
detected compounds are red, and the structures for undetected compounds in the pathway are black.

7. To enlarge the overlaid data, increase the value in the Overlay Cell Size box (Range: 6 to 30 pixels in width).
8. To view the file name for a specific value, point to the value.

This figure shows the selected Metabolika pathway with an overlay of the relative exchange [%] data for the 
selected compound—L-glutamate. The overlay cell size is 20 pixels. A Caution symbol next to a compound 
indicates that the analysis found multiple matches.

File name Caution symbol
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9. To view information about the matching compounds for a structure with multiple matches, point to the 
Caution symbol.

10. To keep only the appropriate explanation for the structure, mark the incorrect explanation as a background 
compound as follows:
a. In the second pane of related tables, open the related Compounds table for the selected Metabolika pathway.
b. Fix the Name column to the leftmost column of the table. See “Common layout modifications” on page 21.
c. Open the Field Chooser dialog box for the related Compounds table and select the check box for the 

Background column.

The Background column appears in the related Compounds table.
d. To mark gamma-aminobutyric acid as a background compound, select its check box in the Background 

column.

In the Metabolika pathways view, the Caution symbol below the structure disappears, but the structure 
remains red.

Information about the 
matching compounds

Name column frozen at the left of 
the related Compounds table

Check box to select in the 
Background column
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Export the
analysis

results

To create a report for your records, filter the Compounds table to display only the compounds of interest, and then 
export the results using the appropriate format.

Follow these procedures to filter the Compounds table and export the results:
1. Use the Result Filters view to select compounds of interest
2. Select columns that you want to export
3. Export the results to a spreadsheet

Use the Result
Filters view to

select
compounds of

interest

The analysis detected a few thousand compounds, including over one thousand compounds that it marked as 
background compounds or compounds without a formula. To reduce the number of compounds to export, filter the 
table or select the check boxes for the compounds of interest.

Do the following in the order listed:
1. Filter the Compounds table by the selected items
2. Filter the Compounds table by the relative exchange rate
3. Filter the Compounds table by the best mzCloud match

Filter the Compounds
table by the selected

items

 To filter the Compounds table by the selected items
1. If the Compounds table is not the active table, click its tab to make it active.
2. Manually select the check boxes for the compounds of interest.
3. From the menu bar, choose View > Result Filters.

Because the processing workflow included the Mark Background Compounds node and the Analyze Labeled 
Compounds node, the Compounds table is currently filtered by two properties—Background and Formula. 

4. Click Add Property and select Checked.

This figure shows the filter set.

5. Click Apply Filters.

The Compounds table displays only the selected compounds.
6. To undo the Checked filter, click Remove to its right. Then, click Apply Filters again. 

Now that you have removed the Checked filter, the Compounds table contains the original set of compounds. 

Go to the next topic to “Filter the Compounds table by the relative exchange rate.” 

Note  Pointing to the Compounds tab or the scroll bar for the Compounds table displays a tooltip with the 
number of visible compounds and the total number of compounds that the analysis detected. 
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Filter the Compounds
table by the relative

exchange rate

 To filter the Compounds table by the relative exchange rate of each compound
1. Click the Compounds tab for the main Compounds table to make it the active table.
2. From the application menu bar, choose View > Result Filters.

The Result Filters view opens as a floating window. Because the processing workflow included the Mark 
Background Compounds node and the Analyze Labeled Compounds node, the filter for the Compounds table 
already includes a filter for background compounds and a filter for compounds without a formula. 

This figure shows the default filters for the example result file.

3. On the right side of the Result Filters view, set up filters for the relative exchange rate as follows:
a. Click Add Property, and then select Rel. Exchange [%] from the list.
b. In the pink relation list, select Is Greater Than or Equal To. 
c. In the value box next to the relation list, type 98.
d. In the pink condition list, select In File.
e. In the Green sample list, select one of the labeled input files.
f. Repeat steps step 3a through step 3e to add a filter for all three labeled input files.

This figure shows the filter set.

4. Click Apply Filters.

The applied filter set reduces the number of visible rows in the Compounds table to 236.
34



Leave Result Filters view open and go to the next topic to filter the remaining visible compounds by their best 
mzCloud match scores.

Filter the Compounds
table by the best

mzCloud match

Precondition: The Compounds table in the example result file is filtered by the exchange rate as described in “Filter 
the Compounds table by the relative exchange rate” on page 34.

 To filter the Compounds table by the best mzCloud match
1. Open the Result Filters view if it is not open. 
2. Click Add Property below the last Rel Exchange [%] filter.
3. In the dropdown property list, select mzCloud Best Match.
4. In the pink dropdown conditions list to the right, select Is Greater Than or Equal To.
5. In the value box, type 99.

6. Click Apply Filters.

The Compounds table is now reduced to three compounds. 

7. Close the Result Filters view by clicking the Close icon, , in the upper-right corner.

Go to the next topic to “Export the results to a spreadsheet.” 

Select columns
that you want to

export

For the stable isotope labeling analysis, the Compounds table contains up to 37 visible table columns. With the 
Stable Isotope Labeling layout applied, the Compounds table contains 19 visible table columns. See the Field 
Chooser dialog box in the following topic: “Apply the Stable Isotope Labeling layout” on page 22.

 To select the table columns that you want to export to a spreadsheet file
1. Click the Field Chooser icon, , for the Compounds table.
2. In the Field Chooser dialog box, clear the check boxes for the columns that you do not want to export to a 

spreadsheet file. For this tutorial, clear all the check boxes except the following five columns:

Name, Area (Max), Calc. MW, Formula, and RT 
3. Close the Field Chooser dialog box.
35



Export the
results to a

spreadsheet

Preconditions: The Compounds table is filtered by a relative exchange rate of greater than or equal to 98% and an 
mzCloud Best Match of greater than or equal to 99% and contains only two compounds and only six columns. 

 To create a report by exporting the results to a spreadsheet
1. Sort the Compounds table in descending order by the Area (Max) column.
2. To export the filtered and sorted results, do the following: 

a. Right-click the Compounds table and choose Export > As Excel. 

The Export to Excel dialog box opens.

Note  If you have not already filtered the Compounds table and reduced the number of visible table columns, 
see these topics:

• Filter the Compounds table by the relative exchange rate 

• Filter the Compounds table by the best mzCloud match

• Select columns that you want to export
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b. In the Path box, change the file name and the location of the spreadsheet file as appropriate by clicking the 
browse icon, selecting the storage folder, naming the file, and clicking Save. 

The dialog box remembers the last folder location you selected. The default file name is the table name. 
c. In the Items and Related Tables to be Exported area, do the following:

• Do not change the Level 1 selection of the Compounds table. 

• In the Level 2 list, select Labeled Compounds per File.
d. In Options area, select the All Items option and the Open File After Export check box.

e. Click Export.
f. At the status prompt, click OK.

The Excel spreadsheet opens (Figure 26).

This spreadsheet shows the exported Compounds table. 
Figure 26. Excel spreadsheet with three compounds and the labeled compounds per file for each of the three 

compounds

Expand 
icon
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3. To view the Compounds per File table for a compound, click the expand icon, , to the left of the compound. 

The Labeled Compounds per File table for the compound expands below the compound.

Trademarks Compound Discoverer, LTQ Orbitrap XL, LTQ Orbitrap Velos, Q Exactive Plus, mzCloud, Orbitrap ID-X, 
Orbitrap Elite, Orbitrap Velos Pro, and Q Exactive are trademarks; and Exactive, Orbitrap, Orbitrap Fusion, and 
Xcalibur are registered trademarks of Thermo Fisher Scientific Inc. in the United States. 

ChemSpider is a trademark of ChemZoo, Inc.

Microsoft and Excel are registered trademarks of Microsoft Corporation in the United States and other countries.

All other trademarks are the property of Thermo Fisher Scientific Inc. and its subsidiaries. 
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