
To familiarize yourself with the Thermo Compound Discoverer™ 3.0 application, follow the topics in this tutorial to 
set up a study and an analysis, process a set of example Xcalibur™ RAW files, review the result file produced by the 
analysis, and export the results to a Microsoft™ Excel™ spreadsheet. 

Overview These files are provided on the key-shaped USB key in the software media kit. You can find these files in the 
following folder: 

Example Studies\Metabolomics\ZDF\

Copy the ZDF folder to your data processing computer. This figure shows the tutorial’s workflow.
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Open the result file and review, filter, and sort the data.

Export the results to an Excel spreadsheet.

Confirm the analysis and start the run.

Use the New Study and Analysis Wizard to do the following:
1. Create a new study and select a processing workflow.
2. Add the files that you want to process to the study.
3. Define and assign the study factors for the sample set.
4. Set up the sample groups and ratios for the analysis.

Start the Compound Discoverer application.

Check the computer’s access to the mzCloud™, and ChemSpider™ databases.
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Starting the
Application

 To start the application

• From the taskbar, choose Start > All Programs (or Programs) > Thermo Compound Discoverer 3.0.

–or–

• From the computer desktop, double-click the Compound Discoverer icon, .

The application opens to the Start page.

Accessing
Help

The application provides Help for the views, tabbed pages, and dialog boxes. 

 To open the Help topic for a specific view, tabbed page, or dialog box

1. Open the view, tabbed page, or dialog box.
2. On the computer keyboard, press the F1 key.

The Help opens to the selected topic.

Checking the
Computer’s

Access to the
External

Databases

This tutorial uses a processing workflow that uses online mass spectral databases to identify the unknown 
compounds. To use any of the processing workflows that use online databases, such as mzCloud and ChemSpider, 
your processing computer must have unblocked access to these databases on the Internet.

 To verify that your computer has access to the external mass spectral databases
1. From the menu bar, choose Help > Communication Tests.
2. Click the mzCloud tab and click Run Tests. When the tests are complete, go to the next step.
3. Click the ChemSpider tab and click Run Tests. 

If your computer has an Internet connection, but these tests fail, leave the Communication Test window open and 
press the F1 key to open the Help. Then, follow the instructions to troubleshoot the communication failure. 

Go to the next topic “Setting Up a New Study and a New Analysis.” 

Setting Up a
New Study
and a New

Analysis

Make sure to copy the example data files to an appropriate folder on your processing computer (see “Overview” on 
page 1).

Follow these topics to create a new study and a new analysis:
1. Setting Up the Study Folders
2. Selecting the Processing Workflow
3. Adding the Input Files to the Study
4. Defining the Study Factors
5. Setting Up the Sample Groups and Ratios
6. Modifying the Processing Workflow

Menu bar Toolbar
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Setting Up the
Study Folders

Each time you create a new study, the application creates a new study folder with the same name and stores the study 
file (.cdStudy) in the new folder. When you first install the Compound Discoverer application, you must set up a 
top-level folder for the study folders. 

 To name the new study and set up the top-level folder

1. From the menu bar, choose File > New Study and Analysis.

The New Study and Analysis Wizard opens.
2. Click Next to open the Study Name and Processing Workflow page.

The first time you open the wizard, the top-level folder for storing the study folders is undefined.

3. In the Study Name box, name the study. 

• For a metabolomics study with the ZDF (rat) example files, type ZDF Study.

• For a study that includes your own Xcalibur RAW files, type an appropriate name.
4. Select the folder where you want to store your Compound Discoverer study folders as follows:

a. Click the browse icon, , next to the Studies Folder box. Browse to your local disk drive or a location on 
your local network. 

b. Click New Folder to create a new folder and name the folder Studies.

After you select or create a top-level folder, stay on this wizard page and go to the next topic “Selecting the Processing 
Workflow.” 

When you complete the wizard, the application creates the ZDF Study.cdStudy file, stores the study file in the ZDF 
Study folder, and stores the ZDF Study folder in the Studies folder. 

Drive:\Studies\ZDF Study folder

When you run the analysis in this tutorial, the application stores the result file (.cdResult) in the ZDF Study folder.

Select the 
top-level folder 
for storing the 
study folders.

Name the study . 
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Selecting the
Processing

Workflow

In the Compound Discoverer application, the processing method that interprets the raw data is called a processing 
workflow (.cdProcessingWF). The application provides defined processing workflows for several fields of study 
including the metabolomics field. This tutorial uses a defined processing workflow that searches the mzCloud and 
ChemSpider databases to identify the compounds detected in the input files (Xcalibur RAW files). This workflow 
also maps compounds to their biological pathways by using the local Metabolika pathway files.

 To select the processing workflow
1. Under Processing, select the following processing workflow from the Workflow list:

Workflow Templates\Metabolomics\Untargeted Metabolomics with Statistics Detect Unknowns with 
ID Using Online Databases and mzLogic

A description of the processing workflow appears in the Workflow Description box. 

2. Read the description.

3. Click Next to open the Input File Selection page of the wizard.

Adding the Input
Files to the Study

 To add input files to the study
1. On the Input File Selection page of the wizard, click Add Files in the command bar.

The Add Files dialog box opens.
2. Browse to the folder where you copied the Xcalibur RAW files.
3. Select all the Xcalibur RAW files in this folder and click Open.

The names of the selected files appear in the Files box on the Input File Selection page.

4. Click Next to open the Input File Characterization page of the wizard.
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Defining the
Study Factors

This figure shows the newly added samples in the Samples pane of the Input File Characterization page. By default, 
the application assigns Sample as the Sample Type to new samples. To group the samples according to your 
experimental design, you must define their study factors. In this tutorial, you are comparing the compounds in the 
plasma from two phenotypes of ZDF rats—Fatty and Lean.

To define the study factors, follow these procedures:
1. To select the delimiters that separate the factors in the file names
2. To set up Phenotype as a categorical study factor
3. To assign the phenotypes and the sample types

 To select the delimiters that separate the factors in the file names 
1. Select the Underscore check box.

In the example files, the underscore character is the delimiter that separates the study factors from the other parts 
of the file name.

The study factor is Phenotype (Lean or Fatty).

ZDF_Fatty_1 ZDF_Fatty_2 ZDF_Fatty_3 Blank

ZDF_Lean_1 ZDF_Lean_2 ZDF_Lean_3 Pooled_ddMS2

Default Sample Type

Select this check box.
5



 To set up Phenotype as a categorical study factor
1. In the Study Factors area of the Input File Characterization page, choose Add > Categorical Factor.

The categorical study factor editor opens in the Study Factors area with the [new factor] box selected.

2. Type the factor name: Phenotype. 

If the editor closes before you type Phenotype, click Edit to reopen it. Select [new factor] and type Phenotype.

3. To add the Fatty and Lean phenotypes to the Items list, do the following:
a. In the box next to the Add button, type F.

The application parses the file names in the Sample Identifier column and Fatty appears in the box.
b. Click Add.

Fatty appears in the list.
c. Type L in the box.

Lean appears in the box.
d. Click Add.

Lean appears in the list.
4. Click Apply.

The editor closes and the Edit button replaces the Apply and Cancel buttons.
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 To assign the phenotypes and the sample types
1. In the command bar, click Assign.

The application does the following:

• Assigns the study factor items for the Phenotype study factor, Fatty or Lean, to the samples.

• Assigns the Blank sample type to the Blank.raw file.

This figure shows the study variable assignments. Study variables include the study factor and sample type 
assignments for the samples.

Because the file names for the Pooled_ddMS2_Top3 sample and the Blank sample do not match the defined 
pattern, ZDF_categorical factor_, the application assigns these samples a value of n/a for the Phenotype study 
factor. 

2. For the Pooled_ddMS2_Top3 sample, select Identification Only in the Sample Type list.

Click Next to open the Sample Groups and Ratios page of the wizard.

IMPORTANT  The assignment of n/a for a study factor is appropriate for the Blank and Identification Only 
sample types, as the application does not use these sample types in statistical analyses.

Note  The Pooled_ddMS2_Top3 sample is a blend of the six non-blank samples. The 
Pooled_ddMS2_Top3.raw file acquired from this sample contains the data-dependent MS2 scans for the 
input file set, and the full scan data for this sample was acquired at a lower resolution than that for the other 
samples. The Blank sample is a matrix blank and only contains the background compounds. 
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Setting Up the
Sample Groups

and Ratios

Use the Sample Groups and Ratios page of the wizard to set up a differential analysis for the two phenotypes: Lean 
and Fatty.

 To set up the sample groups and ratios
1. In the Study Variables area, select the Phenotype check box.

The sample groups—n/a, Fatty, and Lean—appear in the Generated Sample Groups area.

The n/a group includes 
only these sample types:
• Blank 
• Identification Only
8



2. If an error message ( ) appears in the Generated Sample Groups area, do the following:
a. Return to the Input File Characterization page and verify the following sample type assignments: 

• Blank is assigned to the Blank sample.

• Identification Only is assigned to the Pooled_ddMS2 sample.
b. Return to the Sample Groups and Ratios page and verify that you have corrected the sample type assignment 

error.
3. In the Bulk Ratio Generation area, select the Phenotype: Lean check box to make the Lean group the control 

group.

The Add Ratios button becomes available.
4. Click Add Ratios. 

The ratio, Fatty/Lean, appears in the Generated Ratios area. 

The analysis is set up to compare the two sample groups: Fatty versus Lean. 

5. Click Finish to save the study and close the wizard.

The ZDF Study tab, the two analysis page tabs (Grouping & Ratios and Workflows), and the Analysis pane 
appear. 

The Analysis pane lists the eight input files. The analysis is set up to combine the mass spectral data in these files 
into one result file—that is, the As Batch check box is clear and the Result File name is available for editing.
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Modifying the
Processing

Workflow

Before submitting the analysis to the job queue, review the processing workflow and make changes as needed.

 To review the processing workflow
1. Click the Workflows tab to open the Workflows page.

Figure 1. Processing workflow for a metabolomics study

2. Open the parameter settings for the Detect Compounds node and check the Min. Peak Intensity setting against 
the suggested setting for your data set (Table 1). 

The minimum peak intensity setting defines the base peak intensity for the unknown compound detection. For 
the example ZDF data files, keep the setting of 1 000 000. 

Tip  To open the parameter settings for a workflow node, click the node in the Workflow Tree pane. The 
Parameters page for the node opens to the left.

Minimum Peak Intensity
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Table 1 lists the recommended range for the minimum peak intensity parameter. The optimal setting depends 
on the sensitivity of the mass spectrometer. 

3. Open the parameter settings for the Group Compounds node.

The node is set to the default settings. For this tutorial, do not change the selection. For other analyses, select the 
appropriate ions from the Preferred Ions list, making sure that the selected ions include the ion selected for the 
Base Ions parameter in the Detect Compounds node. The node sends the data-dependent MS2 scans for the 
preferred precursor adduct ion to the search nodes and the Predict Compositions node.

4. Open the parameter settings for the Search ChemSpider node.

Three out of 349 databases are selected. For this tutorial, do not change the selection. 

5. Open the parameter settings for the Search mzCloud node.

The node is set to search the entire mzCloud database and run an Identity search and a Similarity search. For this 
tutorial, do not change the settings. 

Table 1. Recommended minimum peak intensity range

Mass spectrometer Minimum peak intensity
(chromatographic peak height)

Q Exactive™, Q Exactive Plus™, Q Exactive HF 500 000 to 1 000 000

Orbitrap Fusion™, Orbitrap Lumos, Orbitrap ID-X 50 000 to 100 000

Exactive™, Exactive Plus™, Orbitrap Elite™, Orbitrap Velos Pro™ 100 000 to 500 000

LTQ Orbitrap XL™, LTQ Orbitrap Velos™ 25 000 to 100 000

Note  When setting up the node parameters, make sure that the list of preferred ions specified in the Group 
Compounds node includes the list of base ions specified in the Detect Compounds node.
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6. Open the parameter settings for the Map to Metabolika Pathways node.

The node is set to search all the Metabolika pathways. For this tutorial, do not change the settings. 

Submitting
the Analysis

to the Job
Queue

If the Run command in the Analysis pane is available, you are ready to start the processing run.

 To submit the analysis to the job queue
1. To create one result file for the input file set, leave the As Batch check box clear.

By default, the application uses the name of the first input file as the result file name.
2. In the Result File box, rename the result file Fatty vs Lean.

3. To submit the analysis to the job queue, click Run.

4. If a warning message appears, for this tutorial, do the following:
a. Click Abort.
b. Open the Grouping & Ratios page.
c. In the Study Variables area, select the Phenotype check box if it is not already selected.
d. In the Bulk Ratio Generation area, select the Lean check box if it is not already selected and click Add 

Ratios.
e. To restart the analysis, click Run in the Analysis pane.

The Job Queue page opens. 
5. To view the processing messages, click the expand icon, , to the left of the job row.

 

Tip  The processing workflow for this tutorial includes the Differential Analysis node. If no groups or ratios 
are set up on the Grouping & Ratios page of the analysis, a warning message appears. If you are not 
interested in grouping or comparing the samples, you can ignore this warning.

Result file name

Run command

Expand icon
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Reviewing
the Analysis

Results

Follow these topics to review the analysis results.

• Opening the Result File

• Default Result Page Layout

• Modifying the Layout of the Result Tables

• Reviewing the Chromatograms for Each Compound

• Reviewing the Full Scan MS1 Spectra

• Reviewing the Fragmentation Spectra

• Applying the Statistics Layout

• Working with the Trend Chart View

• Working with the Volcano Plot in the Differential Analysis View

• Viewing the Principal Component Analysis

• Working with the Partial Least Squares Discriminant Analysis View

• Running a Hierarchical Clustering Analysis

• Viewing the Metabolika Pathways for a Compound

• Reviewing the Results of the mzLogic Analysis 

Opening the
Result File

You can open a result file from multiple locations: the Job Queue page, the Analysis Results page of a study, the 
Compound Discoverer Start Page, or the menu bar.

 To open the result file generated by the analysis

When the run is completed, double-click the run on the Job Queue page.

Note  During the run, the Search ChemSpider, and Map to Metabolika nodes generate warning messages 
that you can ignore.

Warning messages have a yellow background.

Tip  If you did not reprocess the example data set, do the following:
1. Open the result file provided on the Compound Discoverer 3.0 USB key:

Example Studies\ZDF Study\ZDF result.cdResult

2. From the menu bar, choose Window > Reset Layout.

Tip  If the Job Queue page is closed, from the menu bar, choose View > Job Queue to open it.
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Default Result
Page Layout

The factory default layout for a result file includes the following items:

• A page tab with the result file name.

• A Chromatograms view on the top left that is populated with XIC traces for the compound in the first row of 
the active table. The view automatically zooms in to the start and end points of the chromatographic peak for the 
compound.

• A Mass Spectrum view on the top right that is populated with the MS1 scan (for a preferred ion) that is closest to 
the chromatographic peak apex for the selected compound across the input files. The spectrum tree to the left 
includes the MS1 scans and the fragmentation scans for the preferred ions that were acquired within the 
following time range:

chromatographic peak apex for the selected compound ± full peak width at half maximum (FWHM)

• A set of tabbed main tables below the two graphical views. For a metabolomics analysis, the Compounds table is 
the active table.

• A collapsed area for the related tables below the main tables.

Figure 2 shows the factory default layout for the Fatty vs Lean.cdResult file (or the ZDF result.cdResult file).
Figure 2. Default result file layout

Note  If the data set does not include data-dependent MS2 scans within the retention time window but does 
include AIF scans within this window, the spectrum tree includes the AIF scans.

Select Table Visibility icon

Field Chooser icon

Opens the tabbed related tables.
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Table 2 describes the main result tables that the selected processing workflow produces. The Compounds table is the 
active table and is sorted by the Area (Max.) column. The first row displays the compound with the largest 
chromatographic peak area (found in one of the input files). Because the selected processing workflow includes the 
Mark Background Compounds node, the Compounds tab has a filter icon with a check mark ( ). The compounds 
that the analysis identified as background compounds are marked as background compounds in both the blank and 
non-blank samples and are hidden from the table.

Table 2. Main tables and some of the related tables for the selected processing workflow

Result table Description

Visible main (top-level) tables

Compounds Lists all the compounds that the analysis detected grouped by their molecular weight 
and retention time (MW×RT) dimensions across all the input files.

Compounds per File Lists all the compounds that the analysis detected across all the input files on a per 
file basis. Does not list compounds that the Fill Gaps node detected by filling a full 
gap.

Features Lists all the features (ions with the same mass-to-charge values and retention time) 
that the analysis detected across all the input files on a per file basis. 

Metabolika Results Lists the mapped compounds across all the input files.

mzCloud Results Lists the mzCloud search results across all the input files.

ChemSpider Results Lists the ChemSpider search results across all the input files.

Input Files Describes the input files that the application processed to create the result file.

Metabolika Pathways Lists the Metabolika Pathways that contain at least one of the detected compounds 
across the input files.

Visible tables related to the Compounds table

Structure Proposals Displays your structure proposals for the selected compound. Initially, this table is 
empty. 

Compound per File Displays information about the selected compound on a per file basis.

Predicted Compositions Displays the predicted compositions for the selected compound. The predicted 
compositions are based on the molecular weight of the neutral compound.

Metabolika Result Displays information about the matched and partially matched structures for the 
selected compound.

mzCloud Results Displays the mzCloud results for the selected compound.

ChemSpider Results Displays the ChemSpider results for the selected compound.

Metabolika Pathways Lists the pathways that include the selected compound.
Visible table related to the Features table

Chromatogram Peaks Describes the chromatographic peak for the selected feature.
Visible table related to the Input Files table

File Alignments Describes the alignment for the input file selected in the Input File table.
Hidden tables

Adducts (main table) Lists the adducts in the Adducts library.

Filled Gaps (related table) Provides information about the imputed chromatographic peak areas.
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Modifying the
Layout of the

Result Tables

The following topics describe how to modify the layout of the result tables:

• Selecting the Visibility of the Result Tables

• Showing the Related Tables

• Showing or Hiding Table Columns

• Displaying the Input File Names for the Subcolumns

• Sorting Table Rows

Selecting the
Visibility of the Result

Tables

The default layout does not include all the results tables that the selected processing workflow produces. By default, 
the Filled Gaps related table produced by the Fill Gaps node is a hidden table in the first set of related tables.

 To show or hide result tables
1. Click the Select Table Visibility icon, , to the left of the result table tabs.

The Select Visible Tables dialog box opens.

2. To display a table, select its check box. To hide a table, clear its check box. 

By default, the Adducts and Filled Gaps tables are hidden.

For this tutorial, do not change the selections.
3. Click OK.

Showing the Related
Tables

The main tables provide information about each compound across the input file set. The tables related to a main 
table provide details about the item selected in the main table. For example, the Compounds per File table for a 
compound in the main Compounds table provides information about the compound in each input file where it is 
detected.

 To view the tables related to the Compounds table 

Click Show Related Tables at the bottom of the page to display the tables related to the Compounds table.

 To view the information for a specific compound in the main Compounds table
1. Select the compound in the main table.
2. Click Show Related Tables.
3. In the related tables pane, click the tab of interest.
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Showing or Hiding
Table Columns

 To display or hide a table column
1. Click the Field Chooser icon, , to open the Field Chooser box.

In the Compounds table, the following columns are hidden: 

2. Do one of the following:

• To display a column, select its check box. 

• To hide a column, clear its check box.

 To show the Area column in the Compounds table 
1. Click the Field Chooser icon, .
2. Select the Area check box.

The Area column appears in the Compounds table to the left of the Group Areas 
column.

3. To close the Field Chooser box, click its close icon, . 

Displaying the Input
File Names for the

Subcolumns

In the Compounds table, the following columns contain a subcolumn for each input file in the processed data set: 
Metabolika Pathways, Areas (hidden by default), Group Area, Group CV [%], Ratio, Log2 Fold Change, P-Value, 
and Adj. P-Value.

 To view the input file names for the area subcolumns 
1. Click the expand icon, , to the right of the column name.

The names of the input files appear vertically above the individual area columns. The name of the first input file, 
blank.raw (F1), appears in bold font and has an asterisk indicating that it is the selected area column. 

2. Click the collapse icon, , to hide the sample names.

To hide the Area column for the remaining portion of this tutorial, open the Field Chooser box and clear the Area 
check box.

• #Adducts
• #Similarity Results
• Area (per input file)
• Background
• Gap Status
• Normalized Area
• RT Tolerance [min]
• Structure

Expand icon

Collapse icon

Selected column
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Sorting Table Rows  To sort the table rows by the content of the table columns
1. Click a column header to sort the rows between ascending order (A, B, C …) and descending order (Z, Y, X …), 

based on the contents of the column.

2. To sort the data by a second column, hold down the CTRL key and click the second column heading.

 To sort the table rows by a column that contains a distribution map
1. Click the expand icon to display the vertical headings of the subordinate columns.
2. Select the heading of the subordinate column that you want to sort by.

The selected subordinate column heading appears in bold text.
3. Click the column heading to sort the table rows.

Reviewing the
Chromatograms

for Each
Compound

Follow these procedures to review the chromatographic data.

 To view the overlaid XIC traces for a compound
1. In the Compounds table, click the Area (Max.) column heading to sort the table by Area (Max.) in descending 

order. 
2. Select row 8 to display the overlaid XIC traces for Creatine.

This figure displays the overlaid traces for the input files that contain the selected compound and the shortcut 
menu for the Chromatograms view. The Mass Spectrum view is closed. By default, the display options for the 
Chromatograms view are set to Show ToolTips, Show Detected Peaks, and Show Legend.

Note  The application treats formulas the same as text strings and sorts them by the order of the characters in 
the formula string, not by the actual number of elements in the formula.

Shortcut menu
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 To review the information in the left pane
1. Under Filter By, expand Phenotype, Sample Type, and File by clicking their expand icons, . 

2. Review the information in the collapsible left pane:

• Under Group By, the count for Phenotype is 3 out of 3 (3/3). Under Filter By, Phenotype lists three groups 
and all three groups are selected. 

• Under Group By, the count for Sample Type is (2/2). This means that the analysis found the compound in 
both the Sample and Blank sample types. Because the Fill Gap node imputed a very small peak at the level of 
spectrum noise for the compound (MW×RT dimensions) in the Blank sample, creatine (row 8 by maximum 
peak area) is not marked as a background compound.

• Under Filter By > File, the count for F2: Pooled_ddMS2 is 0/0. The application uses the fragmentation scans 
in the Identification Only samples for the mzCloud and mzVault searches. It does not report compounds for 
this sample type.

Modifying the Display
Options

 To view the chromatographic traces without the shading that can mask underlying peaks

Right-click the Chromatograms view and choose Display Options > Show Detected Peaks. 

This figure shows the overlaid traces for the six samples that you are comparing. The application displays the two 
sample groups in different colors. The legend shows the display colors for the groups—blue for Fatty and orange 
for Lean. 

Expand icon
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Reviewing the
Full Scan MS1

Spectra

 To view a mass spectrum with color-coded isotopes for a compound with a predicted formula
1. With the Compounds table sorted in descending order by the Area (Max.) column, select row 8 (Creatine, 

C4 H9 N3 O2). 
2. Expand the Mass Spectrum view to the full screen width by closing the Chromatograms view or by dragging the 

Mass Spectrum view by its title bar to a second monitor. 

To close the Chromatograms view, click its Close icon.

This figure shows the Mass Spectrum view as a floating window. The spectrum tree on the left lists all the MS1 
and fragmentation scans for the preferred ions within the following time range:

chromatographic peak apex for the selected compound ± full peak width at half maximum (FWHM)

The mass spectral peaks in the full MS scan are color-coded as follows:

3. To zoom in on the isotopes detected for the [M+H]+1 adduct ion, drag the mouse pointer across the x axis from 
m/z 132 to m/z 135. 

• Lavender bars indicate centroids for A0 (monoisotopic) ions. The x-axis position and the width of the 
bar reflect the expected m/z value of the centroid and the user-specified mass tolerance, respectively. 

• Green rectangles indicate matching centroids for isotopic ions. When you zoom in on the matching 
centroid, the x-axis position and width of the rectangle reflect the expected m/z value of the centroid 
and the user-specified mass tolerance, respectively. The y-axis position and height of the rectangle 
reflect the expected relative intensity of the centroid and the user-specified intensity tolerance, 
respectively.

• Red rectangles indicate centroids that are missing from the expected isotopic pattern. 

• Blue rectangles indicate centroids that are missing from the expected isotopic pattern but that are also 
expected to have an intensity below the measured baseline noise (determined by the Fourier transform 
mass spectrometry (FTMS) mass analyzer).
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This figure shows three matching isotopes and two missing isotopes for the [M+H]+1 adduct ion.

4. For more information about the matching and missing isotopes, click Show Related Tables below the 
Compounds table. Then, click the Predicted Compositions tab.

This figure shows that the Predict Compositions node matched 3 out of 5 isotopes to the theoretical isotope 
pattern for the calculated formula.

Reviewing the
Fragmentation

Spectra

 To view the results of an mzCloud search for a compound and display a mirror plot
1. With the Compounds table sorted in descending order by the Area (Max.) column, select row 8 (Creatine, 

C4 H9 N3 O2). 
2. Click Show Related Tables to display the related tables below the main tables.
3. Click the mzCloud Results tab to display the mzCloud Results table.
4. Select the row 1 in the mzCloud Results related table.
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A mirror plot appears in the Mass Spectrum view with the mass spectrum from the Pooled_ddMS2 sample on 
the top and the mzCloud reference spectrum on the bottom.

Applying the
Statistics Layout

The application comes with the factory default layout and four named layouts: Identification, Quantification, Stable 
Isotope Labeling, and Statistics. When running statistical analyses, for ease of use, apply the Statistics layout.

 To apply the Statistics layout
1. If the result file is not the active page in the application window, click the result file tab.
2. From the menu bar, choose Window > Reset Layout. Then, choose Window > Apply Layout > Statistics.

For the example result file, the Statistics layout does the following (Figure 3):

• Closes the Chromatogram view and the Mass Spectrum view. Moves the result tables to the top of the page 
and hides most of the main tables, except for the Compounds table and Input Files table. 

• Opens the Differential Analysis and Trend Chart views as tabbed views on the bottom left of the page with 
the Differential Analysis view selected as the active tab. For the differential analysis, sets the P-value 
parameter to 0.001 and the Log2 Fold Change parameter to 3. 

• Opens the Principal Component Analysis, Partial Least Squares Discriminant Analysis, and Hierarchical 
Cluster Analysis views as tabbed views on the bottom right of the page.

Note  The Compounds table, the Partial Least Squares Discriminant Analysis view, the Differential Analysis 
view, the Hierarchical Cluster Analysis view, and the Loadings Plot page of the Principal Component 
Analysis view are interactive—that is, checking the points in any of these views checks the points in all of 
these views. 

In the Hierarchical Cluster Analysis view, a segmented bar—red for checked and gray for unchecked—to the 
right of the heat map indicates whether a compound is checked. In the other views, checked data points turn 
blue.
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Figure 3. Statistics layout for the example result file

Go to the next topic “Working with the Trend Chart View.” 

Working with
the Trend Chart

View

Use the Trend Chart view to compare the distribution of the chromatographic peak areas for each compound by 
sample group. When you select a single compound in the Compounds table, you can view the distribution as a 
box-and-whiskers plot or as a trend line plot. When you select multiple compounds in the Compounds table, the 
application automatically displays the distribution for each compound as a trend line plot.

 To view a box-and-whiskers plot for a single compound
1. Apply the Statistics layout (see “Applying the Statistics Layout” on page 22). 
2. Click the Trend Chart tab in the left pane.
3. Sort the Compounds table in descending order by Area (Max.).
4. Select row 8 (Creatine, C4 H9 N3 O2).
5. Right-click the chart and choose Show Legend.
6. Place the cross-hair cursor anywhere on a box or whisker to display a ToolTip with descriptive statistics. 

Left pane Right pane
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This figure shows the box-and-whiskers plot for creatine and the Tooltip for the Fatty sample group.

 To view trend line plots for multiple compounds

Hold down the CTRL key and select the following rows in the Compounds table: row 8 (creatine), row 7 
(DL-tryptophan), and row 13 (acetyl-L-carnitine).

This figure shows the trendline plots for the selected compounds in the Trend Chart view.

7. To display the error bars for the trend line plots, do the following:
a. In the Scaling list, select Unscaled.
b. Right-click the plot and choose Show Standard Errors.
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This figure shows trend line plots with error bars for the standard error. 

Working with
the Volcano Plot

in the
Differential

Analysis View

Use the volcano plot in the Differential Analysis view to select the significant compounds for the comparison groups, 
which in this case are the Fatty and Lean ZDF rats. The volcano plot is a plot of the p-value, the result of a 
significance test, on the y axis versus the log2 fold change between two sample groups on the x axis. The y-axis scale 
is the –Log10 of the p-value. As the p-value increases from 0 to 1, the –Log10 of the p-value decreases from infinity 
to 0 (–Log10 0.05 equals 1.3). The compounds in the shaded regions are statistically significant for the specified 
p-value and outside the specified upper and lower fold change thresholds. 

Apply the Statistics Layout if you have not already done so (see “Applying the Statistics Layout” on page 22). Then, 
drag the left pane away from the window.

To familiarize yourself with the Differential Analysis view, follow these procedures:

• To display the Differential Analysis view

• To display the legend for the volcano plot

• To change the p-value

• To change the log2 fold change value

• To select the up-regulated compounds or the down-regulated compounds

• To view information about a compound in the Compounds table and the graphical views

• To copy a compounds list with structures to the clipboard

 To display the Differential Analysis view

Click the Differential Analysis tab.

 To display the legend for the volcano plot

Right-click the view and choose Show Legend.

The legend appears at the bottom of the page. Each data point represents a compound. Placing the crosshair 
cursor over a data point displays a ToolTip with the XY coordinates, MW, RT, maximum area, and number of 
adducts. 
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This figure shows the default Statistics layout, the added legend, and the ToolTip for the data points. 

 To change the p-value

Move the P-value slider to the left or right. Or, type a value in the box next to the slider.

 To change the log2 fold change value

Move the Log2 Fold Change slider to the left or right. Or, type a value in the box next to the slider.

ToolTip

Legend

p-value 
of 0.001
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 To select the up-regulated compounds or the down-regulated compounds

• Right-click the plot and choose Check All Up-regulated Points.

–or–

• Right-click the plot and choose Check All Down-regulated Points.

The checked data points turn blue.

 To view information about a compound in the Compounds table and the graphical views

In the Differential Analysis view, double-click the compound or right-click the compound and choose Check 
Point. 

The Compounds table automatically scrolls to the selected compound. If the Chromatograms view is open, it 
displays the overlaid XIC traces for the compound. If the Mass Spectrum view is open, it displays the MS1 scan 
for the compound.

 To copy a compounds list with structures to the clipboard

Right-click the Differential Analysis view and choose Copy > Point Details.

Viewing the
Principal

Component
Analysis

Use the Principal Component Analysis view to display the results of the principal component analysis. The principal 
component analysis reduces the dimensionality of the data set to a set of principal components, PC1, PC2, and so 
on, where PC1 is the principal component with the most variance.

 To view the Principal Component Analysis 
1. Apply the Statistics layout (see “Applying the Statistics Layout” on page 22). 
2. Click the Principal Component Analysis tab in the right pane.

Use the Scores Plot page to interpret the relationship among the sample groups. Sample groups that are near each 
other are similar.
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This figure shows the Scores Plot page for the Fatty and Lean sample groups.

Working with
the Partial Least

Squares
Discriminant

Analysis View

Use the Partial Least Squares Discriminant Analysis view to find a set of compounds that you can use to discriminate 
between sample groups.

Follow these procedures:

• To make the Partial Least Squares Discriminant Analysis view active

• To change the number of discriminating compounds

• To automatically select the check boxes for the discriminating compounds in the Compounds table

 To make the Partial Least Squares Discriminant Analysis view active
1. Apply the Statistics layout (see “Applying the Statistics Layout” on page 22). 
2. Click the Partial Least Squares Discriminant Analysis tab in the right pane.
3. If the graph includes checked data points, right-click the view and choose Uncheck All Visible Points.
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This figure shows the Partial Least Squares Discriminant Analysis view with the default settings for the Statistics 
layout. The orange circles represent the five discriminating compounds. 

 To change the number of discriminating compounds
1. Type the number of discriminating compounds in the #sPLS-DA Compounds box.
2. To start the analysis, click the view.

Orange circles represent the discriminating compounds. Place the crosshair cursor over a circle to display a 
ToolTip.

 To automatically select the check boxes for the discriminating compounds in the Compounds table

Right-click the view and choose Check All sPLS-DA Points.

The color of the circles changes to blue and the check boxes for the associated compounds in the Compounds 
table are selected.

To display only the checked compounds in the Compounds table, see “To filter the Compounds table by the 
checked compounds” on page 35.

Note  If the discriminating compounds are checked, right-click the view and choose Uncheck All sPLS-DA 
Points before changing the number of discriminating compounds.
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Running a
Hierarchical

Clustering
Analysis

Use the Hierarchical Cluster Analysis view to visualize the correlation between detected compounds and selected 
samples in a two-dimensional array of color-coded rectangles (heat map) where each rectangle represents the relative 
amount (by area) of a specific compound in a specific sample.

 To view a hierarchical cluster analysis for the compounds in the Compounds table
1. Apply the Statistics layout (see “Applying the Statistics Layout” on page 22).
2. Click the Hierarchical Cluster Analysis tab in the right pane.

3. In the Hierarchical Cluster Analysis view, click Refresh.

A heat map and two dendograms for the cluster analysis appear.
4. In the left pane, under Color By, select the Phenotype check box.

A color bar appears above the heat map to visually differentiate the samples by the two phenotypes—Fatty and 
Lean.

This figure shows a hierarchical cluster analysis for the compounds in the Compounds table. Pointing to a 
cluster’s node displays a ToolTip.

Color barToolTip for the 
cluster node
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5. To zoom in on a specific area of the heat map, drag the pointer across the rectangular area of interest.
6. To view information for a cell in the heat map, point to it.

The ToolTip displays the row and column coordinates. The row coordinates are the compound’s name, MW, 
and RT. The column coordinates are the file ID and study factor values.

This figure shows a magnified view of four cells in the upper left corner of the heat map and their corresponding 
dendograms.

Viewing the
Metabolika

Pathways for a
Compound

The Map to Metabolika Pathways node searches for compounds that match the detected compounds in the selected 
Metabolika Pathway files.

 To view a Metabolika pathway for a detected compound
1. From the menu bar, choose Window > Reset Layout.

2. Sort the Compounds table by the Area (Max.) column in descending order.
3. Select row 11 (L-Tyrosine).
4. Below the Compounds table, click Show Related Tables.
5. Click the Metabolika Pathways tab.
6. In the Metabolika Pathways table, select row 6 (L-tyrosine degradation IV (to 4-methylphenol).

ToolTip for the 
heat map cell

ToolTip for the 
cluster node
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7. From the application menu bar, choose View > Metabolika Pathways.

The view opens to the right of the result tables and displays the selected pathway. The structure for the selected 
compound is blue, the structures for other compounds in the Compounds table are red, and the structures for 
other compounds in the pathway that are not in the Compounds table are black.

8. In the Overlay Data Source list, select Log2 Fold Change.
9. In the Overlay Cell Size list, increase the value to 20.

This figure shows the selected pathway, data source, and overlay cell size. 

Reviewing the
Results of the

mzLogic
Analysis

An mzLogic analysis requires candidate structures from the ChemSpider database, a Metabolika pathway, or a mass 
list with structures. It also requires matching structures from an mzCloud similarity search. The processing workflow 
for this metabolomics tutorial (Figure 1 on page 10) includes the two nodes that provide structures—the Search 
ChemSpider node and the Map to Metabolika Pathways node.

 To review the results of an mzLogic analysis for structure candidates
1. In the Compounds table (sorted in descending order by the Area (Max.) column, select row 8 (Creatine).
2. Open the Compound table’s Field Chooser dialog box (“To display or hide a table column” on page 17) and 

select the #Similarity Results check box.
3. In the Compounds table, review the number of ChemSpider results and the number of similarity results for the 

selected compound.

For Creatine, the ChemSpider search found 2 matches and the mzCloud similarity search found 1 match.

Compound selected in the Compounds table

Number of ChemSpider results

Number of mzCloud similarity results
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4. From the application menu bar, choose View > mzLogic Analysis.

The mzLogic Analysis view opens to the right of the result tables.

5. Below the Candidates pane, click Similar Structures from mzCloud.
6. In the Candidates pane, select the structure for the lower ranking hit—UL1984YRKA—in the ChemSpider 

Results table.

This figure shows the matching substructure in blue for the lower ranking compound in the ChemSpider Results 
table.

Reprocessing
an Analysis

You can modify the parameter settings for any of the scoring, mapping, or search nodes without reprocessing the 
entire workflow; that is, without reprocessing the core nodes. 

Matching substructure

Note  In the processing workflow for this tutorial, the Input Files, Select Spectra, Align Retention Times, Detect 
Compounds, Group Compounds, and Fill Gaps nodes are core nodes.
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 To reprocess the same set of input files with a modified processing workflow
1. Open the Analysis Results page of the study.
2. Select the analysis that you want to reprocess.
3. Click Reprocess.

The Grouping & Ratios and Workflows tabs appear, and a Caution symbol appears in the Analysis pane. 
Pointing to the Caution symbol displays the following message:

Unchanged workflow. No node chosen for processing.
4. Click the Workflows tab.

All the nodes have lost their distinguishing colors, and the right sides of all the nodes are gray.
5. Right-click the Input Files node and choose Reprocess.
6. To reprocess the data, click Run.

Exporting the
Analysis

Results

To create a report for your records or a file for external use by the TraceFinder™ application or the Xcalibur data 
system, filter the compounds table to display only the compounds of interest, and then export the results using the 
appropriate format.

Follow these procedures to filter the compounds table and export the results:
1. Using the Result Filters to Select the Compounds of Interest
2. Exporting the Results to a Spreadsheet, Text, or CSV File

Using the Result
Filters to Select
the Compounds

of Interest

The analysis found a total of 4127 compounds, including 1450 background compounds. By default, background 
compounds are hidden, so the Compounds table lists 2677 compounds. To reduce the number of compounds to 
review—for example, to display only compounds that are statistically significant, filter the table by p-value. To 
reduce the number of compounds to the discriminating compounds for the comparison groups or to the compounds 
of interest for other reasons, check the discriminating compounds or the compounds of interest to you and filter the 
table by the checked property.

 To reduce the number of Compounds to review by using the p-value as a filter
1. In the main tables, click the Compounds tab.
2. From the menu bar, choose View > Result Filters.

The Result Filters view opens as a floating window. Because the processing workflow included the Mark 
Background Compounds node, the filter for the Compounds table already includes a Background filter and the 
table does not display the background compounds. 

Note  Pointing to the vertical scroll bar displays a ToolTip with the number of compounds in the table.
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3. In the right pane of the Result Filters view, set up a filter for the p-value as follows:
a. Click Add Property and select P-Value from the list.

b. In the pink relation list, select Is Less Than or Equal To. 
c. In the value box next to the relation list, type 0.001.
d. In the pink condition list, select In Ratio.
e. In the Green sample list, select Fatty/Lean.

4. Click Apply Filters.

The filter reduces the number of displayed rows in the Compounds table to 134.

 To filter the Compounds table by the checked compounds
5. If the Compounds table is not the active table, click its tab to make it active.
1. Do one of the following:

• In the Partial Least Squares Discriminant Analysis view, select the compounds of interest as described in “To 
automatically select the check boxes for the discriminating compounds in the Compounds table” on page 29.

• In the Differential Analysis view, select the compounds of interest as described in “To select the up-regulated 
compounds or the down-regulated compounds” on page 27.

• Manually select the check boxes for the compounds of interest.
2. From the menu bar, choose View > Result Filters.

Because the processing workflow included the Mark Background Compounds node, the Compounds table is 
currently filtered by one property—Background. 

3. If there are more filter properties, remove them by clicking Remove to the right of each filter.
4. Click Add Property and select Checked.
5. Click Apply Filters.

The Compounds table displays only the selected compounds.

This figure shows the filter tree for the Compounds table.

6. To undo the Checked filter, click Remove to its right. Then, click Apply Filters. The Compounds table contains 
the original set of compounds.
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Exporting the
Results to a

Spreadsheet,
Text, or CSV File

Before exporting the results to a spreadsheet, an Xcalibur™ inclusion/exclusion list, a TraceFinder™-compatible CSV 
file, or a new mzVault library, filter the results table as described in “Using the Result Filters to Select the 
Compounds of Interest” on page 34. 

Follow these topics as needed:

• Creating a Report

• Creating an Xcalibur Inclusion/Exclusion List

• Creating a File to Import into the TraceFinder Compounds Database

• Exporting a Compound to an Existing mzVault Library

• Exporting Compounds to a New Library

Creating a Report To create a report, follow these procedures as needed:

• To check the number of table rows

• To sort the rows

• To display the table columns that you want to export

• To export the filtered and sorted results to an Excel spreadsheet

 To check the number of table rows

Point to the vertical scroll bar to the right of the Compounds table. A ToolTip appears with the row count.

 To sort the rows

Click the column heading that you want to sort by.

 To display the table columns that you want to export

Open the Field Chooser box and select the check boxes for the columns of interest and clear the other check 
boxes (see “To display or hide a table column” on page 17). To view the areas for each input file, select the Areas 
check box.

 To export the filtered and sorted results to an Excel spreadsheet
1. Right-click the Compounds table and choose Export > As Excel. 

The Export to Excel dialog box opens.
2. Check the file name and location in the Path box. Change the file name and location as appropriate.
3. In the Options area, select the appropriate options.

4. Click Export.
5. At the prompt, click OK.
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Creating an Xcalibur
Inclusion/Exclusion

List

 To export the results to an Xcalibur Inclusion/Exclusion list
1. Right-click the Compounds table and choose Export > As Xcalibur Inclusion/Exclusion List.

2. In the Instrument area, select the instrument format for the exported masses.
3. (Optional) To export only the selected compounds, select the Checked Items Only check box.
4. (Optional) To automatically open the file in a spreadsheet application, select the Open File(s) after Export 

check box. 
5. Click Export.
6. At the prompt, click OK.

Creating a File to
Import into the

TraceFinder
Compounds Database

 To export the results to a file that is compatible with the TraceFinder Compounds Database
1. Right-click the Compounds table and choose Export > As TraceFinder List.
2. Select one or more of the options.

3. Click Export.
4. At the prompt, click OK.
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Exporting a
Compound to an
Existing mzVault

Library

 To export a compound to an existing mzVault Library
1. Right-click the compound in the Compounds table and choose Export > Single Compound to an Existing 

mzVault Library.

The Export to mzVault Library dialog box opens. Its Spectra view displays the available fragmentation spectra for 
the selected compound.

2. Do the following:

• In the spectrum tree, select the check boxes for the spectra that you want to add to the compound entry.

• In the mzVault Library area, select the existing mzVault library from the Selected Library list.
3. Do one of the following:

• To add the spectra to an existing compound entry in the library, select the entry in the Similar Compounds 
Found in Library list. Then, click Add to Selected.

• To add the compound and the selected spectra as a new compound entry, click Add as New.
4. Click Close.

Exporting Compounds
to a New Library

 To export the checked compounds to a new mzVault Library
1. Right-click the Compounds table and choose Export > Compounds to a New mzVault Library.

The Export to New mzVault Library dialog box opens. By default, the Exclude Items Without Name check box 
is selected.

2. Select the Checked Items Only check box.

3. Click Export.
4. At the prompt, click OK.
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Trademarks The following are trademarks in the United States: Compound Discoverer, Exactive Plus, FreeStyle, Q Exactive, and 
TraceFinder are trademarks; and Exactive, Orbitrap, Orbitrap Fusion, and Xcalibur are registered trademarks of 
Thermo Fisher Scientific Inc. 

ChemSpider is a registered trademark of ChemZoo Inc. 

mzCloud is a registered trademark of HighChem, Ltd. in the Slovak Republic.

Microsoft and Excel are registered trademarks of Microsoft Corporation in the United States and other countries.

All other trademarks are the property of Thermo Fisher Scientific Inc. and its subsidiaries.
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