
If you are unfamiliar with the Thermo Compound Discoverer™ 3.1 application, follow the topics in this tutorial to 
set up a new study and a new analysis, process a set of example Xcalibur™ RAW files, review the targeted (expected) 
and untargeted (detected) compounds that the analysis found, and print a report. 

Overview In the Compound Discoverer application, data processing—the analysis of a set of raw data files to extract 
information about the sample set—takes place within the study environment. To create a practice study, use the 
example Xcalibur RAW files. These files are provided in the following folder on the key-shaped USB drive in the 
software media kit: Example Studies\Omeprazole Metabolism Study. Copy the Omeprazole Metabolism Study 
folder to your data processing computer. 

This figure shows the typical workflow for a targeted analysis. 
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Start the Compound Discoverer application.

Use the New Study and Analysis Wizard to do the following: 
1. Create a new study and select a processing workflow.
2. Add the files that you want to process to the study.
3. Define the study factors and assign their values to all the input files in the sample 

set, excluding the Blank, Quality Control, and Identification Only samples.
4. Set up the sample groups and ratios for the analysis.

Open the result file and review the data.

Sort the data, select a defined report template, and print a report. 

Confirm the analysis and start the run.

Add the compounds of interest to the Expected Compounds list.
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Starting the
Application

 To start the application

• From the taskbar, choose Start > All Programs (or Programs) > Thermo Compound Discoverer 3.1.

–or–

• From the computer desktop, double-click the Compound Discoverer icon, .

The application opens to the Start Page. By default, the toolbar icons are relatively small.

Enlarging the
Toolbar Icons

 To enlarge the toolbar icons

Right-click the toolbar and choose Show Large Icons.

Accessing
Help

The application provides Help for the views, tabbed pages, and dialog boxes. 

 To open the Help topic for a specific view, tabbed page, or dialog box

1. Open the view, tabbed page, or dialog box.
2. Place the mouse cursor anywhere in the opened view, tabbed page, or dialog box.
3. On the computer keyboard, press the F1 key. 

Adding
Compounds

to the
Expected

Compounds
List

For targeted analyses of known compounds and their transformation products, you must add the compounds to the 
Expected Compounds list.

 To add a compound to the Expected Compounds list
1. (Optional) Download a 2D structure file for the compound from the Internet. For example, download the 

structure for caffeine from the ChemSpider™ database.
2. From the menu bar, choose List & Libraries > Expected Compounds. 

The Expected Compounds view opens.
3. Click New.

The Compound Editor dialog box opens.
4. To add the compound’s structure, do one of the following:

a. If you do not have a structure file for the compound, click ChemSpider.

The ChemSpider Search dialog box opens.
b. In the Input box, type the name, formula, molecular weight, or ChemSpider ID (CSID) for the compound.

Menu bar Toolbar

Tip  If you are not using the omeprazole example data set for this tutorial, follow the instructions in this topic to 
add the compounds you are studying to the Expected Compounds list. This list already includes omeprazole.
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c. Click Search.
d. Select one of the hits and click Select.

–or–
a. If you have a structure file for the compound, in the Compound Editor toolbar, click the Load Structure 

from Disk icon, . 

The Open Structure dialog box opens.
b. In the Known Structure Formats list, select the format of the structure file.

The Compound Editor dialog box supports the following file formats:

• MOL Format (.mol)

• Compressed Structure (.mcs)

• Template (.tml)
c. Select the structure file of interest and click Open.

The chemical structure appears in the drawing pane of the Compound Editor dialog box, and the application 
automatically populates the Elemental Composition and Molecular Weight boxes. The application also 
populates the Name box with the CSID or the file name of the structure file. 

5. If necessary, type a different name for the compound. 
6. Click Save to add the compound to the Expected Compounds list.

The new compound appears in the list.

7. To close the Lists & Libraries page, click the close icon, , on its tab.

Note  To delete a compound, right-click the table to open the shortcut menu and turn off the Cell Selection 
Mode if it is on ( ). Then select the compound of interest and click Delete. 

Replace the ChemSpider ID number 
with the compound name.

Shortcut menu
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Setting Up a
New Study
and a New

Analysis

To create a new study, you must use the New Study and Analysis wizard. As its name implies, you can also use the 
wizard to set up a new analysis. Or, you can start a new analysis from within an existing study.

Follow these topics to set up a new study and a new analysis:
1. Naming the Study and Selecting Its Storage Location
2. Selecting a Processing Workflow for the Analysis
3. Adding Input Files to the Study
4. Setting Up the Experimental Variables
5. Grouping the Samples By Study Variable
6. Troubleshooting the Analysis

Naming the
Study and

Selecting Its
Storage Location

Use the Study Name and Processing Workflow page of the wizard to name the study and select the top-level folder 
for storing studies of this type. 

 To name the new study and select the top-level folder for studies of this type
1. From the menu bar, choose File > New Study and New Analysis.

The New Study and Analysis Wizard opens.
2. Click Next to open the Study Name and Processing Workflow page.

The first time you open the wizard, the top-level folder for storing studies is undefined.
3. In the Study Name box, type a name for the new study (the study folder for this study shares the same name). 

• For a metabolism study with the omeprazole example files, type Omeprazole Study.

• For a study that includes your own Xcalibur RAW files, type an appropriate name.
4. Select the folder where you want to store your Compound Discoverer studies as follows:

a. Click the browse icon, , next to the Studies Folder box.
b. Browse to a location on your local disk drive or network. 
c. Click New Folder and name the new folder Studies.

Selecting a
Processing

Workflow for the
Analysis

Continue on the Study Name and Processing Workflow page of the wizard to select a processing workflow for the 
analysis.

 To select the processing workflow
1. In the Workflow list in the Processing area, select the following processing workflow:

Workflow Templates\MetID\MetID w Stats Expected and Unknown w Background Removal

2. Read the description of the processing workflow, and then click Next to open the Input File Selection page of the 
wizard.

Top-level 
folder
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Go to the next topic, “Adding Input Files to the Study.” 

Adding Input
Files to the Study

 To add input files to the study
1. On the Input File Selection page of the wizard, click Add Files. 
2. Browse to the folder where you copied the example data. 

drive:\Example Studies\Omeprazole Metabolism Study 
3. Select all the raw data files in this folder and click Open.

The file names of the selected files appear in the Files box, the number of files that you selected appears below 
this box, and the Next button becomes available.

4. Click Next to open the Input File Characterization page of the wizard.

To define the study factors, go to the next topic, “Setting Up the Experimental Variables.” 

Setting Up the
Experimental

Variables

The sample type and study factor values for each sample are experimental variables. A study factor is an experimental 
variable that might have a statistically significant effect on the sample population being studied.

In this tutorial, you are comparing the compounds in urine samples collected at different time points from a subject 
dosed with the drug omeprazole. The time points are 3, 5, 7and 9 hrs after dosage. 

 To set up the experimental variables for the example data set

1. For the example data set, select the Underscore check box for the file name delimiter. 

The time points study variable is included in the file names of the example data set, and underscore symbols 
separate the time point text (for example, 0-3) from the other text in the file name (Urine_0-3_GSH_PhII_01).

Number of selected files

Note  Omeprazole is a proton pump inhibitor that blocks the production of acid by the stomach. It is 
metabolized in the liver and excreted as metabolites in the urine within 3 to 6 hours after oral ingestion. Its 
primary metabolites are omeprazole sulfone and 5-hydroxyomeprazole.

Note  The study variables include the sample types and study factor values.
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This figure shows the newly added samples in the Samples area. Sample is the default sample type. The 
Underscore check box is selected as the file name delimiter.

2. In the Study Factors area, choose Add > Categorical Factor.

The categorical factor editor appears in the Study Factors area with the [new factor] text selected.

3. To replace the [New Factor] text, type the factor name, Time Points.
4. For each item that you want to add to the Items list (0-3, 3-5, 5-7, and 7-9), do the following:

a. In the Items box (next to the Add button), begin typing a factor item, for example, 0-3.

If the file name contains a character delimiter and you selected the delimiter’s check box, the editor displays a 
selection list as you type. Otherwise, you must type all the characters for the item.

Finish typing the appropriate alphanumeric text or select an item from the list.

Tip   If you are not working with the omeprazole data set, select the study factor type as follows:
• To define study factors that include alphanumeric items, use the categorical study factor editor. 
• To define study factors that include only numbers, use the numerical study factor editor. 
• To set up a nested experiment, use the biological replicate factor for one of the study factors.

To open the Help topic about setting up the study factors and sample types, press the F1 key.

Underscore selected as the file name delimiter

Default 
sample type
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The Add button becomes available. 
b. Click Add.

The current item appears in the Items list. 

Add the remaining time points, 3-5, 5-7, and 7-9.
5. To save the study factor, click Apply.

The factor editor collapses to show only the study factor name and items list. The items appear in ascending 
order.

6. Click Assign.

7. For the example data set, keep the default assignments of Sample. 

For other data sets, select the sample types as needed from the list. 

Or, use the shortcut menu as follows (see Figure 1 on page 8):

• To select the same sample type for a consecutive sample range, hold down the SHIFT key 
and select the rows of interest. Then, right-click and choose Set Sample Type To > Sample 
Type.

• To select the same sample type for non-consecutive samples, hold down the CTRL key and select the rows of 
interest. Then, right-click and choose Set Sample Type To > Sample Type.

Note  The application assigns the Blank sample type to any sample that begins with Blank (or that contains 
Blank as delimited text, for example, Solvent_Blank with Blank preceded by the selected delimiter). The 
sample set for this tutorial does not include blanks.

Tip  To select a row in the Samples table, click the Error, File, or Sample Identifier 
columns. Do not click the Sample Type or Study Factor columns.

Assign 
command
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Figure 1. Samples pane shortcut menu

The sample type affects the processing actions.

8. Click Next to open the Sample Groups and Ratios page.

The Study Variables area contains check boxes for the study variables—File, Sample Type, and the user-defined 
study factors. 

Go to the next topic, “Grouping the Samples By Study Variable.” 

Table 1. Sample types

Sample type Processing actions

Sample, Control, 
and Standard

Detects the components in the sample. When the analysis and the processing workflow 
include grouping, the application reports the group areas for these sample types by study 
factor. 

Does not differentiate between the Sample, Control, and Standard sample types, which 
means that you can use these sample types interchangeably. Thermo Fisher Scientific 
recommends that you use the Control and Standard sample types for labeling or grouping 
purposes as needed.

IMPORTANT  When you want to group the samples by one or more study factors, you 
must define the study factor items (or values) for the Sample, Control, and Standard 
sample types. Failing to define the study factors for these sample types generates error 
messages on the Sample Groups and Ratios page.

Blank Detects the components in the sample. When the processing workflow includes one or 
both Mark Background Compound nodes, the application marks these components as 
background compounds. 

Quality Control Detects the components in the sample. When the processing workflow includes the 
Normalize Areas node, the application does the following:
• Fits the areas of the compounds in the QC samples to linear or cubic spline curves.
• Runs a batch normalization of the non-QC samples against these curves.

Identification 
Only

Does not report the chromatographic peak areas for the sample components 
(chromatographic peaks with the same MW×RT dimensions). The application uses the 
sample’s data-dependent fragmentation (DDA) scans for component identification when 
the processing workflow includes the Group Unknown Compounds node.

Labeled Not used for targeted analyses.

Shortcut menu
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Grouping the
Samples By

Study Variable

 To set up the sample groups for the data set
1. On the Sample Groups and Ratios page, select the Time Points check box in the Study Variables area. 

The generated sample groups appear in the Generated Sample Groups pane. The application generates a “not 
assigned” (n/a) group for samples without an assigned value for the Time Points study factor. For the example 
data, there is no n/a group.

2. Do one of the following:

• If you are working with the omeprazole example files, go step 4.

• If you are not working with the omeprazole data set, and error messages appear when you select the study 
variables for the analysis, go to step 3. If no errors appear, go to step 4.

3. If you are not working with the example data set, and an error message appears in the Generated Sample Groups 
pane, do the following: 
a. Check whether any of these sample types are part of an n/a sample group in the Generated Sample Groups 

pane on the Samples Groups and Ratios page:

• Sample 

• Standard

• Control

b. To assign values to the Sample, Standard, or Control samples, click Back to return to the Input File 
Characterization page. Then, select study factor values for all the samples except for the Blank and 
Identification Only samples.

c. Return to the Sample Groups and Ratios page.
d. In the Study Variables area, select the study variables of interest.
e. In the Generated Samples Groups pane, make sure that the n/a group only includes the Blank samples.

4. Click Finish.

The study—Omeprazole Study—opens as a tabbed document at the left of the application window, 
and the Analysis pane opens to the right of the study. 

IMPORTANT  When you select a study factor in the Study Variables area, the Sample, Quality Control, 
and Control sample types must have assigned study factor values. Only Blanks and Identification Only 
samples can have an n/a study factor value. 

If you are working with a different data set and you do not assign study factor values to one or more of 
the Sample, Control, or Standard samples, an error message ( ) appears and the n/a group is 
highlighted in red.
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The study consists of four tabbed pages: Study Definition, Input Files, Samples, and Analysis Results. 
The two tabs—Grouping & Ratios and Workflows—to the right of the study pages are part of the 
analysis. If you close the Analysis pane, these two tabs also close.

The Analysis pane lists the selected processing workflow, the name of the result file (which is based on 
the first input file), and the selected raw data files. If the analysis is valid, the Run button is green.

Go to the next topic, “Troubleshooting the Analysis.” 

Troubleshooting
the Analysis

A Caution symbol to the right of Processing Step in the Analysis pane warns you that the analysis contains errors. 
You cannot submit the run until you fix the errors.

 To troubleshoot the analysis and fix the errors
1. In the Analysis pane, point to the Caution symbol. Or, click the Workflows tab and review the messages in the 

Current Workflow Issues pane at the bottom of the Workflows page.

The application displays explanations for the analysis errors.

2. To fix the analysis errors, go to “Customizing the Processing Workflow.” 

Note  Because the example data set contains only one sample per group and the statistical analysis tools 
require at least two samples per group, this tutorial does not describe how to set up ratios. For information 
about setting up ratios and using the application’s statistical views, refer to the Help, the metabolomics 
tutorial, or the extractables and leachables tutorial.

Study pages Analysis pages Analysis pane

Default file name for the 
result file (.cdResult)

Unavailable 
Run button

Caution symbol
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Customizing
the

Processing
Workflow

For an analysis of one or more known compounds and their transformation products, you must specify the target 
compounds in the processing workflow template. For the MetID w Stats Expected and Unknown w Background 
Removal processing workflow, you must also select the parent compound for the Create FISh Trace node, the 
spectrum database file for the Search mzVault node, and the compound class file for the Compound Class Scoring 
node.

To customize the processing workflow for the example data set, see these topics:

• Specifying the Target Compounds and Adduct Ions 

• Specifying the Parent Compound for the Create FISh Trace Node

• Specifying the mzVault Database Files for the Search mzVault Node

• Specifying the Compound Class Library for the Compound Class Scoring Node

• (Optional) Modifying the Specified Isotope Patterns

Specifying the
Target

Compounds and
Adduct Ions

The default Expected Compounds list includes omeprazole—the target compound for the example data set. 

Tip  When customizing a processing workflow template, consider doing the following:

• Basing the Ions list in the Generate Expected Compounds node and the Preferred Ions list in the Group 
Expected Compounds node on the sample matrix or other experimental factors 

• Basing the Base Ions for the Detect Compounds node and the Preferred Ions for the Group Compounds 
node on the experimental factors

• Changing the Min. Peak Intensity setting in the Find Expected Compounds node and the Detect 
Compounds node to a threshold that is consistent with the mass spectrometer where you acquired the data

• Changing the Sample/Blank ratio threshold in the Mark Background Compounds node

IMPORTANT  If you are following this tutorial with a different data set and you have not added the target 
compounds to the Expected Compounds list, add the compounds to the list as described in “Adding 
Compounds to the Expected Compounds List” on page 2. 

In the Compound Discoverer 3.1 or later application, you can leave the analysis open as you update any of the 
lists under Lists & Libraries.
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 To specify the target compound for the example data set
1. Click the Workflows tab to open the Workflows page.

This figure show the Workflows page with the selected processing workflow. The exclamation marks in the upper 
right corner of the Generate Expected Compound node, Search mzVault node, Create FISh Trace node, and 
Compound Class Scoring node indicate that these nodes are missing parameter values.

2. In the Workflow Tree pane, select the Generate Expected Compounds node.

The Parameters page for the Generate Expected Compounds node opens to the left. In the selected processing 
workflow template, Apply Dearylation has been set to True, and all the Phase 1 and Phase II reactions have been 
selected.

Workflows tab Indicates a missing 
parameter value. 

Parameters 
page

All the Phase I 
and Phase II 
transformations 
are selected.

Apply 
Dearylation is 
set to True.
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3. Do one of the following:

• For the example data, in the Compound box, type O for omeprazole.

If Omeprazole is the only compound in the list that begins with an O, it appears in the box. Otherwise, 
continue typing the next letter in the name until the compound’s name appears.

• For a different data set, add the target compounds to the Expected Compounds list, and then select these 
compounds in the Generate Expected Compounds node. To target multiple compounds with a different set 
of transformation rules for each compound, add an additional Generate Expected Compounds node for each 
set of transformation rules, and then connect these nodes to the Find Expected Compounds node.

To continue fixing the validation issues for the MetID w Stats Expected and Unknown w Background Removal 
processing workflow, go to the next topic, “Specifying the Parent Compound for the Create FISh Trace Node.” 

Specifying the
Parent

Compound for
the Create FISh

Trace Node

The Create FISh Trace node uses the observed and theoretical fragments for a compound along with a list of 
fragmentation rules and fragmentation libraries to search the spectral data in the input files for fragments related to 
the compound of interest. It uses the matched fragments to create a fragment based total ion current chromatogram 
that you can use to visualize regions with fragment ions related to the parent compound. 

 To specify the compound for the Create FISh Trace node
1. On the Workflows page, select the Create FISh Trace node.
2. On the Parameters of Create FISh Trace page, select the parent compound for the trace.

• For the example data, select omeprazole and keep the default settings for the Scan Polarity and Fragment 
Mode parameters.

• If you are not working with the example data set, match the following parameter settings in the Create FISh 
Trace node to your data set: Scan Polarity (positive or negative) and Fragmentation Mode (Data-Dependent or 
Data Independent).

To continue fixing the validation issues for the MetID w Stats Expected and Unknown w Background Removal 
processing workflow, go to the next topic, “Specifying the Parent Compound for the Create FISh Trace Node.” 
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Specifying the
mzVault

Database Files
for the Search
mzVault Node

The Search mzVault node searches the selected mzVault databases for scans that match the scans associated with each 
expected or detected compound. 

 To specify the mzVault database for the Search mzVault node
1. On the Workflows page, select the Search mzVault node.
2. On the Parameters of Search mzVault page, click the mzVault Library box, and then click the browse icon to the 

right of this box.

The Select Input Files dialog box opens.

3. In the Select Input Files dialog box, select the check box for the mzVault Reference May 2019 spectral database.

4. Click OK.

To continue fixing the validation issues for the MetID w Stats Expected and Unknown w Background Removal 
processing workflow template, go to the next topic, “Specifying the Compound Class Library for the Compound 
Class Scoring Node.” 

Specifying the
Compound Class

Library for the
Compound Class

Scoring Node

The Compound Class Scoring node scores the detected compounds against a set of fragment ions commonly 
present in the fragmentation scans for a compound class. The node compares the ions (m/z values) 
detected in the fragmentation scans to the fragments in the selected compound class libraries. 

Tip  If you working with your own data set, consider creating your own mzVault libraries with the 
mzVault 2.2 application. For information about importing mzVault libraries into the Compound Discoverer 
application, choose Lists & Libraries > Spectral Libraries from the menu bar, and then press the F1 key on 
your computer keyboard to open the Help topic.
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 To specify the compound class library for the example data files
1. On the Workflows page, select the Compound Class Scoring node.
2. On the Parameters of Compound Class Scoring page, click the Compound Classes box, and then click the 

browse icon to the right of this box.

The Select Input Files dialog box opens.
3. Select the check box to the left of the Omeprazole Compound Class file.

4. Click OK.

Modifying the
Specified

Isotope Patterns

The MetID w Stats Expected and Unknown w Background Removal processing workflow template includes the 
Pattern Scoring node and the Create Pattern Trace node. The Create Pattern Trace node can create a trace based on 
only one isotope pattern; whereas, the Pattern Scoring node can search for multiple isotope patterns. 

The processing workflow templates that come with the application (and that include one or both of these nodes) 
specify an isotope pattern at a resolution of 60 000 for the following elemental composition: C15S. 
Figure 2. Parameter settings for the Pattern Scoring node in the MetID workflow templates

Note  The Compound Discoverer 3.1 application comes with a compound class library for omeprazole, which is 
the compound of interest in this tutorial. 

Tip  If you are not working with the example data set, delete the Compound Class Scoring node from the 
processing workflow. Or, create compound class libraries for your targeted compounds. 

For information about adding compound class libraries to the Compound Class list, choose Lists & Libraries > 
Compound Classes from the application menu. Then, press the F1 key.
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To optimize the node’s settings for your experimental data, enter the appropriate elemental compositions for your 
targeted compounds. For example, the targeted compound in the example data is omeprazole (C17 H19 N3 O3 S). 
Appropriate elemental compositions for omeprazole’s metabolites might include C15S, C16S, and C17S, and so on.

In addition to entering the appropriate compositions, match the Resolution setting to the instrument method used 
to acquire the sample data.

 To specify the parameter settings for the Pattern Scoring node for the example data
1. On the Workflows page, select the Compound Class Scoring node.
1. On the Parameters page, click the Isotope Patterns box, and then click the browse icon, .

The Pattern List Editor opens.
2. To modify the isotope pattern for C15S, do the following:

a. Select row 1 and click Edit Pattern.

The Isotope Ratio Editor opens.
b. Type 70 000 in the Resolution box, and then click OK.

3. To add the isotope pattern for C17S, do the following:
a. In the Pattern List Editor, click Add Patterns.

The Isotope Ratio Editor opens.
b. In the Elemental Composition box, type C17S.
c. In the Resolution box, type 70 000.
d. Set up the required isotope pattern as follows:

• Clear the check box for the A1 peak (mass shift of 1.00335).

• Select the check box for the A2 peak (mass shift of 1.99580).

• Select the check box for the A2 peak (mass shift of 2.00670).

4. Click OK.
5. In the Pattern List Editor, do the following:

a. Verify that the editor lists the C15S and C17S elemental compositions and that the number of required 
peaks for both of these compositions is 3.

b. Click OK.

A0 peak for the monoisotopic ion with 
only the C12 isotope of carbon and the 
S32 isotope of sulfur

A2 peak for ion with one sulfur-34 atom

A2 peak for ion with two carbon-13 atoms
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6. Verify that the Isotope Patterns parameter for the Pattern Scoring node lists the following: C15S; C17S. 

The experimental m/z values of the A2 peaks must be within 5 ppm and their relative intensity must be within 30% 
of the theoretical isotope pattern. 

 To check the resolution of the full scan data in the RAW data files
1. Open the RAW data file in the FreeStyle™ application.
2. In the Workspace Options toolbar, click Instrument Method.
3. In the Instrument Method view, select the Mass Spectrometer page.

Go to “Submitting the Analysis to the Job Queue.”  

Submitting
the Analysis

to the Job
Queue

For the omeprazole study, set up the analysis as described on the previous pages of this tutorial.

 To submit the analysis to the job queue
1. To create one result file for the input files set, leave the As Batch check box clear.

By default, the application uses the name of the first input file as the result file name.

Table 2. Theoretical isotope patterns at a resolution of 70 000

Elemental composition Peak Mass Shift Relative Intensity Relative Intensity Range 

C15 S A0 monoisotopic 0.00000 100.00 N/A

A2 (one 34S atoms) 1.99580 4.52 3.16 to 5.88

A2 (two 13C atoms ) 2.00670 1.27 0.89 to 1.65

C17 S A0 monoisotopic 0.00000 100.00 N/A

A2 (one 34S atoms) 1.99580 4.52 3.84 to 5.20

A2 (two 13C atoms ) 2.00670 1.64 1.15 to 2.13

Note  If you select the As Batch check box, the application creates a separate result file for each input file, 
which means that it cannot compare the results across the data set.
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2. In the Result File box, rename the result file Omeprazole Example.

3. Click Run to submit the analysis to the job queue.

Because the processing workflow includes the Differential Analysis node and you have not defined any ratios for 
the analysis, the Analysis Validation Issues dialog box opens.

4. Click Ignore. 

The Job Queue page opens to the right of the study tab.

5. To view the processing messages, click the expand icon, , to the left of the processing job.

You can ignore the warning messages that are highlighted in yellow.

Leave the Job Queue page open and go to the next topic “Opening the Result File and Reviewing the Default 
Layout.”  

Note  Because a differential analysis requires a minimum of two data points per group and the data set 
includes only one sample per group, the Differential Analysis node cannot calculate the p-values for the 
sample group regardless of whether you define ratios for the analysis.

Note  During the run, the nodes generates the following warning messages, which you can ignore:

• The input files do not contain any UV data, so the Create Analog Trace node generates a warning 
message for each input file. 

• The data set does not include any blank samples, so the Mark Background Compounds node generates a 
warning message that no blank files were specified for the analysis.

• You did not define any ratios for the analysis, so the Differential Analysis node generates a warning 
message about the missing ratios.

Renamed result file

Expand icon
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Opening the
Result File

and
Reviewing
the Default

Layout

You can open a result file from multiple locations: the Job Queue page, the Analysis Results page of a study, the Start 
Page, or the menu bar. The result file opens as a tabbed document in the application window (see Figure 3). For 
information about all the ways you can open a result file, refer to the Help.

To open the result file and review the default layout, see these topics:

• Opening the Result File

• Default Layout for a Result Page

Opening the
Result File

 To open the result file generated by the analysis

Do one of the following:

• If the Job Queue page is open, double-click the completed run.

• If the study is open, click the Analysis Results tab, and then double-click the link to the completed run.

–or–

• If you closed the study after the run completed, under Recent Results on the Start Page, click the result file 
name under Recent Results.

Default Layout
for a Result Page

The factory default layout for a result file includes the following items (Figure 3 on page 20):

• A page tab with the result file name.

• A Chromatograms view on the top left that is populated with XIC traces for the compound in the first row of 
the Expected Compounds table. The view automatically zooms in to the start and end points of the 
chromatographic peak for the compound, and the area under the peak is shaded.

• A Mass Spectrum view on the top right that is populated with the MS1 scan (for a preferred ion) that is closest to 
the chromatographic peak apex for the selected compound across the input files. The spectrum tree to the left 
includes the MS1 scans and the fragmentation scans for the preferred ions that were acquired within the 
following retention time window:
 The chromatographic peak apex for the selected compound ± peak width at half maximum (FWHM)

–or–
 The Start and end points of the chromatographic peak, as determined by the peak detection algorithm

• A set of tabbed main tables below the two graphical views. 

• A collapsed area for the related tables below the main tables.

Tip  If you did not reprocess the example data set, do the following:
1. Open the result file provided on the Compound Discoverer 3.1 USB key:

Example Studies\Omeprazole Metabolism Study\Omeprazole MetID QE Example.cdResult

2. From the menu bar, choose Window > Reset Layout.

Opens the Omeprazole Example 
result file.

Opens a dialog box to locate and 
open a result file.
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Figure 3. Default layout for the result file generated by the processing workflow 

The selected processing workflow creates the following main tables from left to right.

Table 3. Result tables for the selected processing workflow template

• Compounds Lists all the compounds that the Detect Compounds node detected across the input 
file set beginning with the compound with the largest chromatographic peak area in 
any of the input files.

• Compounds per File Lists the compounds that the Detect Compounds node detected in each input file.

• Expected 
Compounds

Lists all the expected compounds that the Expected Compounds node found in one or 
more of the input files, and groups the compounds by molecular weight and retention 
time. 

• Expected 
Compounds per File

Lists all the expected compounds that the Expected Compounds node found in each 
input file (Xcalibur RAW file). The Group Expected Compounds node groups the 
compounds by molecular weight and retention time. 

• Expected Formulas Lists the expected formulas that the Find Expected Compounds node searched 
against. The expected formulas list is the output from the Generate Expected 
Compounds node.

• Features Lists the adduct ions that the Detect Compounds node detected across all the input 
files.

• Merged Features Lists the chromatographic peaks with the same m/z × RT dimensions that the analysis 
found in one or more of the input files. When the processing workflow includes both 
of these nodes—Find Expected Compounds and Detect Unknown Compounds—the 
Merge Feature node merges the features in this table and adds the Ion Status column.

• Expected Features Lists the features that the Find Expected Compounds node found across all the input 
files.

• mzVault Results Lists all the compounds that the mzVault search identified across the input files. The 
compounds are listed in order of the best match score between the query spectra and 
the matching spectra in the selected mzVault database.

• FISh Trace Fragments Lists the structures of the expected fragments and the summed intensities of the 
matching adduct ions. The Create FISh Trace node generates a list of expected 
fragments (adduct ions) for the user-specified compound. 

• Input Files Lists the input files for the analysis.

• Specialized Traces For the selected MetID processing workflow, this table lists the traces generated by the 
Create FISh Trace node and the Create Pattern Trace node.

Shows the related tables

Closest MS1 scan to the 
chromatographic peak apex 
for the selected compound

Shaded chromatographic peaks 
for the selected compound 
across the input files
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Working with
the Result

Tables

The following topics describe how to sort and filter the result tables:

• Viewing the Number of Items in a Table

• Sorting the Result Tables

• Filtering the Tables

• Displaying or Hiding Result Table Columns

• Viewing Related Information about an Item in a Main Result Table

Viewing the
Number of Items in

a Table

 To view the total number of items in a result table

Point to its tab.

For this analysis, the Compounds table contains 4181 compounds.

The Expected Compounds table contains 483 compounds.

Sorting the Result
Tables

 To sort a result table by a single table column

Click the column header. Click the column header a second time to reverse the sort order. 

• Descending order ()

• Ascending order ()

 To sort a table by multiple columns

Hold down the CTRL key and click the column header of the first column and the column headers of any 
additional columns that you want to sort by.

 To sort a table by a column with multiple sub-columns
1. Click the expand icon, , to the right of the column heading to display the vertical headings for the 

sub-columns.
2. Select the sub-column that you want to sort by.

An asterisk appears at the top of the vertical heading.
3. Click the column heading.

Filtering the Tables Use the Result Filters view to create filters for data reduction.

 To filter the Compounds table by the maximum chromatographic peak area of each compound
1. From the application menu bar, choose View > Result Filters.

The Result Filters view opens as a floating window.
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2. In the list of tables on the right, select the Compounds table if it is not already selected.

3. In the right pane, add a filter that hides compounds with maximum peak areas below 500 000 000 counts as 
follows:
a. Click Add Property and select Area (Max.) from the list. (The maximum area for each compound is the 

largest chromatographic peak for this compound across the input file set.)

b. Click the (pink) relation list and select Is Greater Than or Equal To. 
c. Type 5e8 (or 500 000 000) in the box next to the relation box.

d. Click Apply Filters.

The Compounds tab has a filter icon and the table now displays only 33 entries.
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Displaying or Hiding
Result Table

Columns

By default, some of the result table columns are hidden. You can choose to hide or display any of the columns in a 
result table.

 To display or hide a column
1. Click the icon, , in the upper left corner of the result table.

The Field Choose dialog box for the result table opens.
2. Select the check boxes for columns that you want to display and clear the check boxes for columns that you want 

to hide.

Viewing Related
Information about
an Item in a Main

Result Table

The related tables below the opened main table contain related information about the selected item in the main 
table.

 To open a related table for a selected item
1. Select the item in the main table. For example, in the example result file, select row 4 (Caffeine) in the main 

Compounds table.
2. Click Show Related Tables at the bottom of the application window.
3. Click the tab for the related table of interest. For example, click the mzVault Results tab to open the mzVault 

Results table and view the compound matches for caffeine.

Reviewing
the

Untargeted
Compounds

To review the results for the untargeted compounds detected by the Detect Compounds node, see these topics:

• Filtering the Compounds Table by the Peak Areas

• Reviewing the Results from the Compound Class Scoring Node

• Reviewing the Results from the Pattern Scoring Node

• Comparing the Chromatograms for Two Compounds

• Comparing the Trendline Plots for Two Compounds

• Viewing a Mass Defect Plot

Filtering the
Compounds
Table by the
Peak Areas

 To filter the Compounds table by the chromatographic peak areas
1. Click the Compounds tab if the Compounds table is not open.
2. Filter the Compounds table by the chromatographic peak area [Area (Max.)]. Limit the table entries to 

compounds with chromatographic peak areas greater than or equal to 5e8. See “Filtering the Tables” on page 21.

Only 36 compounds are now visible in the Compounds table for the example result file.

Reviewing the
Results from the
Compound Class

Scoring Node

The processing workflow for this tutorial included the Compound Class Scoring node with the selection of a 
compound class (fragmentation) library for omeprazole.

 To review the class coverage for detected compounds reported in the Compounds table
1. If you have not already filtered the Compounds table by the maximum chromatographic peak area, filter it now.
2. Sort the Compounds table in descending order by the Area (Max.) column.
3. In the Compounds table, select row 7 (5-hydroxyomeprazole).
4. Click Show Related Tables at the bottom of the application window.
5. In the set of related tables, click the Compounds Class Matches tab.
6. Select the entry in the Compound Class Matches table (see Figure 4 on page 24).

Note  To display the Compounds table in the alloted space below, several of the columns are hidden.
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Figure 4. Compound Class Matches table for 5-hydroxyomeprazole

In the Mass Spectrum view, each matching fragment for the selected compound is highlighted in green and 
annotated with its structure.
Figure 5. Data-dependent fragmentation scan for 5-hydroxyomeprazole with structure annotations for matching fragments

Reviewing the
Results from the
Pattern Scoring

Node

 To review the results of the Pattern Scoring node
1. If you have not already filtered the Compounds table by the chromatographic peak area [Area (Max.)], filter it 

now. Limit the table entries to compounds with chromatographic peak areas greater than or equal to 5e8 (see 
“Filtering the Tables” on page 21).

2. Sort the Compounds table by the C17S subcolumn of the Pattern Matches column in descending order (see “To 
sort a table by a column with multiple sub-columns” on page 21).

3. Select row 1 (Esomeprazole).

4. In the related tables, click the Matched Patterns tab. Then, select the entry in the Matched Patterns table (see 
Figure 6 on page 25).

Note  Esomeprazole is an isomer of omeprazole.
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Figure 6. Compounds table sorted by pattern matches for C17S 

The Mass Spectrum view displays the matching isotopes. The monoisotopic adduct ion is highlighted in 
lavender, and the other matching isotopes are highlighted in green.

Go to the next topic, “Comparing the Chromatograms for Two Compounds.” 

Comparing the
Chromatograms

for Two
Compounds

The untargeted portion of the analysis detected the parent compound, esomeprazole, and one of its oxidation 
products, 5-hydroxyomeprazole.

 To compare the chromatograms for esomeprazole and 5-hydroxyomeprazole
1. If you have not already sorted the Compounds table by the C17S subcolumn of the Pattern Matches column in 

descending order, sort it now.
2. In the Compounds table, select row 1 (Esomeprazole).

3. To view the chromatograms for the four time points more clearly, right-click the Chromatograms view and 
choose Display Options > Show Detected Peaks (Figure 7 on page 26).

Note  To display the Compounds table in the alloted space below, several of the columns are hidden.

Note  Esomeprazole is an isomer of omeprazole.
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Figure 7. Shaded peaks for esomeprazole

4. To add a plot below the current plot, right-click the Chromatograms view and choose Plots > Add Plot.
Figure 8. Unshaded peaks for esomeprazole

An empty plot appears below the current plot. The blue bar at the left of the plot indicates that the plot is active.
Figure 9. Two plots
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5. In the Compounds table, select row 5 (5-Hydroxyomeprazole).

The chromatograms for 5-Hydroxyomeprazole appear below those for Esomeprazole.

Go to the next topic, “Comparing the Trendline Plots for Two Compounds.” 

Comparing the
Trendline Plots

for Two
Compounds

 To compare the trendline plots for 5-hydroxyomeprazole and esomeprazole
1. If you have not already sorted the Compounds table by the C17S subcolumn of the Pattern Matches column in 

descending order, sort it now.
2. From the application menu bar, choose View > Trend Chart.

The Trend Chart view opens to the right of the result tables.
3. Hold down the CNTRL key and select row 1 and row 5 in the Compounds table.
4. Right-click the Trend Chart view and choose Show Legend.

Go to the next topic, “Viewing a Mass Defect Plot.” 

Note   The sampling points for this study represent the last dosage of omeprazole taken by the test subject 
after several previous dosages. The samples taken at 3, 5, and 7 hrs show a delay in the oxidation of 
omeprazole due to enzyme inhibition by its metabolites. After 7 hrs, the subject begins to metabolize the 
current dosage of omeprazole. 
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Viewing a Mass
Defect Plot

You can view a mass defect plot for the compounds in the Compounds table or the Expected Compounds table. In 
this tutorial, you inspect a plot of the Kendrick mass defect for the following Kendrick formula: C2H4O.

Follow this procedure to set up a mass defect plot that highlights polyethylene glycols. 

 To set up a mass defect plot for a Kendrick formula
1. From the application menu bar, choose View > Mass Defect Plot.

The Mass Defect Plot opens to the right of the result tables.
2. In the Kendrick Formula box, type C2H4O.
3. Select the Highlight Named Compounds check box.

4. Zoom in on the four named compounds that form a horizontal line.
5. Right-click the plot and choose Check All Visible Points.

6. Sort the Compounds table by the Name column in descending order.

Note  Polyethylene glycols are commonly detected in urine samples. 
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7. Notice that the four PEG compounds are checked. Clear these check boxes.

Go to the next topic,“Reviewing the Targeted Compounds.” 

Reviewing
the Targeted
Compounds

The Expected Compounds table lists the compounds found by the Find Expected Compounds node, which searches 
the data for the adduct ions specified by the Generate Expected Compounds node. The Group Expected 
Compounds node groups the compounds found across the input files by their molecular weight, formula, 
transformations, and retention time. 

To review the targeted (expected) compounds, follow these topics in order:
1. Filtering the Expected Compounds Table by Peak Area
2. Sorting the Expected Compounds by Their Transformations
3. Reviewing the Mass Spectra for the Expected Compounds
4. Determining the Most Probable Explanation for Each Expected Compound
5. Naming and Proposing Structures for the Expected Compounds

Filtering the
Expected

Compounds
Table by Peak

Area

 To filter the Expected Compounds table by the chromatographic peak areas
1. Click the Expected Compounds tab 
2. Filter the Expected Compounds table by the chromatographic peak area [Area (Max.)]. Limit the table entries to 

compounds with chromatographic peak areas greater than or equal to 5e8. See “Filtering the Tables” on page 21.

Only 13 compounds are now visible in the Expected Compounds table for the example result file.

Sorting the
Expected

Compounds by
Their

Transformations

 To bring the parent compound to the top of the Expected Compounds table
1. In the Expected Compounds table, do the following:

a. Hold down the CNTRL key, and do the following:

• Click the Dealkylated column heading until the table is sorted in ascending order—that is, until all the 
compounds that are not the product of a dealkylation reaction move to the top.

• Click Transformations column heading until the table is sorted in ascending order by the 
Transformations (alphabetical and number).

This figure shows the Expected Compounds table sorted by the Dealkylated and Transformations columns. The 
parent compound, with no dealkylation reactions and no transformations, is at the top of the table.

Go to the next topic, “Reviewing the Mass Spectra for the Expected Compounds.” 
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Reviewing the
Mass Spectra

for the Expected
Compounds

Use the Mass Spectrum view to view the isotopic pattern in the full MS scans for a selected compound and the FISh 
annotations in the compound’s fragmentation scans.

To review the mass spectra, see these topics:

• Inspecting the Isotope Pattern in the Full MS Scan

• Viewing the Fragmentation Scans

• FISh Coverage Score

Inspecting the
Isotope Pattern in
the Full MS Scan

 To inspect the isotope pattern for a selected compound
1. Select the first row in the sorted Expected Compounds table (with omeprazole sorted to the first row).
2. In the Mass Spectrum view, inspect the compound’s isotope pattern in the full MS scan.

This figure shows the isotope pattern for the protonated ion of omeprazole. 

Note  This tutorial uses the following terminology for isotope patterns:

• A0—The spectrum peak for the monoisotopic ion or the leftmost isotopic ion.

• A1—The M + 1 ion approximately one mass unit greater than the peak for the monoisotopic ion, for 
example, an ion where one 13C atom replaces one 12C atom.

• A2—The M + 2 ion, approximately two mass units greater than the peak for the monoisotopic ion, for 
example, an ion where one 34S atom replaces one 32S atom and two 13C atoms replace two 12C atoms.

• A3—The M + 3 ion, approximately three mass units greater than the peak for the monoisotopic ion, for 
example, an ion where one 34S atom replaces one 32S atom and one 13C atom replaces one 12C atom.

A0 peak for the monoisotopic protonated ion

A1 peak for isotope with one carbon-13 atom

Two A2 peaks

One A3 peak
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This figure shows the resolution of the A2 isotopes at m/z 348.1.

The full MS scan shows the isotope pattern for the detected compound. Colored rectangles highlight the mass 
spectrum peaks (centroids) that match the theoretical isotope pattern.

Viewing the
Fragmentation

Scans

The FISh Scoring node annotates centroids that match the m/z value of a theoretical fragment ion with its 
theoretical structure and color-codes the centroids in a fragmentation scan as follows: 

• Direct match—( ) Green

• Shifted match—( ) Blue

 To compare the fragmentation spectra of a metabolite and the parent compound
1. Select the first row in the sorted Expected Compounds table (with omeprazole sorted to the first row). 
2. In the spectral tree pane of the Mass Spectrum view, select an MS2, DDA scan, for example, scan #1650.

Table 4. Color-coding for isotope patterns

Color Meaning 

( ) Lavender The labeled centroid is the monoisotopic mass of the expected adduct ion. The x-axis 
position and the width of the bar reflect the expected m/z value of the centroid and the 
user-specified mass tolerance, respectively. The Find Expected Compounds node searches 
for the monoisotopic peaks associated with the selected ion species, for example, [M+H]+1, 
[M+Na]+1, and so on. In this tutorial, the selected processing workflow only generates a list 
of expected compounds for the protonated adduct ion, [M+H]+1.

( ) Green The labeled centroid matches the delta mass and relative intensity of the theoretical isotope 
pattern. When you zoom in on the matching centroid, the x-axis position and width of the 
rectangle reflect the expected m/z value of the centroid and the user-specified mass 
tolerance, respectively. The y-axis position and height of the rectangle reflect the expected 
relative intensity of the centroid and the user-specified intensity tolerance, respectively.

( ) Red The expected centroid for this m/z value is missing or its intensity does not fall within the 
tolerance range for the theoretical isotope pattern.

( ) Light blue The centroid for this m/z value might be missing because its theoretical intensity is at the 
level of the measured baseline noise (determined by the Fourier transform mass 
spectrometry (FTMS) mass analyzer).

A2 peak for the (M + 2) ion with one sulfur-34 atom

A2 peak for the (M + 2) ion with two carbon-13 atoms 
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The annotated fragmentation scan appears in the right pane. 
Figure 10. Annotations for scan #1650 generated by the FISh Scoring node during data processing

3. Right-click the Mass Spectrum view and choose Show Library Spectra As Reference to turn this feature off.
4. Right-click the Mass Spectrum view and choose Use As Reference.
5. In the Expected Compounds table, select row 5 (oxidation product).

A mirror plot appears in the Mass Spectrum view. The MS2 spectrum for omeprazole is on the bottom and the 
MS2 spectrum for the metabolite is on the top.

This figure shows a mirror plot with the data-dependent fragmentation scan for omeprazole set as the reference.

Note  The FISh Scoring node cannot calculate a FISh Coverage score for compounds that lack DDA scans.
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FISh Coverage
Score

In a targeted workflow where you connect the Group Expected Compounds node to the FISh Scoring node, the 
FISh Scoring node creates a list of expected fragments for each found expected compound. It then attempts to match 
the fragment structures to the centroids in the fragmentation scans of the precursor ions.

When only one fragmentation scan follows a precursor ion scan, the node calculates the FISh coverage score as 
follows:

where:

# matched centroids represents the number of matched centroids.

# used (matched + unmatched) centroids represents the number of centroids in the fragmentation scan that are 
above the user-specified signal-to-noise threshold (not skipped).

When a precursor scan is followed by more than one fragmentation scan, the node calculates a composite score as 
follows:

The FISh Scoring node annotates the centroids in the fragmentation scans with the matching fragment structures. It 
also provides a FISh Coverage score for compounds with DDA scans in the Expected Compounds table.

Determining the
Most Probable
Explanation for
Each Expected

Compound

 To display only the most probable explanation for each compound
1. If you have not already filtered the Expected Compounds table by the chromatographic peak area [Area (Max.)], 

do so now. Limit the table entries to compounds with chromatographic peak areas greater than or equal to 5e8. 
See “Filtering the Tables” on page 21.

2. Sort the Expected Compounds table by the Area (Max.) column in descending order.
3. For each replicated compound (same MW×RT dimensions), select the check box for the most probable 

explanation. In addition, select the check box for each unique compound.

When the application returns multiple explanations for the same compound (same MW×RT dimensions), 
consider the following criteria to determine the correct explanation:

• Compare the FISh Coverage score for each explanation. The probability that an explanation is correct 
increases as the FISh Coverage score increases.

• Compare the reaction pathway for each explanation. The correct explanation is often the one with the fewest 
steps. 

This figure shows the selection of the explanations with the higher FISh coverage score.

Tip  Use the color coded FISh fragments to elucidate the structure for the putative metabolites. Typically the 
smallest shifted and largest unshifted fragments help to localize the site of transformation.

FISh coverage score # matched centroids
# used centroids

------------------------------------------------------ 100=

FISh coverage score
per all scans# matched centroids 

per all scans# used centroids 
---------------------------------------------------------------------------------------------- 100=
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4. In the Result Filters view, click Add Property and select Checked from the list. 

5. Click Apply Filters.

The Expected Compounds table now displays only nine compounds.

Go to the next topic, “Viewing the Dealkylation Product for a Compound.” 

Viewing the
Dealkylation
Product for a

Compound

 To view the dealkylation product for a compound with additional transformations
1. In the Expected Compounds table, select a compound that is the product of a dealkylation reaction and one or 

more transformations.
2. For example, select row 7 (C16 H17 N3 O2 S).

Figure 11. Related structures table for dealkylation product

Go to the next topic, “Naming and Proposing Structures for the Expected Compounds.” 
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Naming and
Proposing

Structures for
the Expected

Compounds

You can add names and structures for expected compounds to the result file. 

 To populate the Name and Structure columns in the Expected Compounds table
1. In the Expected Compounds table, right-click the row for omeprazole—row 5 when sorted in descending order 

by Area (Max.).
2. Click Show Related Tables, and then click the Structure Proposals tab.
3. Right-click the empty Structure Proposals table and choose Add Structure Proposal.

A new row with the formula and MW of the expected compound appears in the Structure Proposals table.

4. Double-click the row in the Structure Proposals table.

The Compound Annotation Editor opens to the Description page.
5. To assign a structure to this custom annotation, do one of the following:

• Click the Load Structure from Disk icon, , and open the Omeprazole.mol file that you copied to your 
processing computer. 

• Use the drawing tools to draw a structure. To open the Help for the Compound Annotation Editor, press the 
F1 key.

• If your computer has Internet access, click ChemSpider. When the search finishes, select a structure from the 
list.

The application checks whether the calculated exact mass of the structure matches the molecular weight and the 
elemental composition (if available) of the selected peak within the mass tolerance (for XIC trace creation) that 
you specified in the Find Expected Compounds node. 
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6. In the Name box, type Omeprazole.

7. Run the FISh scoring algorithm as follows:
a. Select the Apply FISh Scoring check box.
b. Click Save.

The structure appears in the Structure column of the Structure Proposals table, and the FISh Scoring Queue 
opens. The application recalculates the FISh Coverage score and modifies the fragmentation spectra 
annotations by using the proposed structure.

8. In the Structure Proposals table, right-click the row for your new structure proposal and choose Structure 
Proposals > Use As Compound Annotation.

Omeprazole appears in the Name column of row 5 (MW 345.11471).
9. To view the structure in the Expected Compounds table, display the Structure column as follows:

a. Click the Field Chooser icon, .
b. Select the Structure check box.

10. If necessary, to restore the original processing results, right-click the newly annotated row and choose Reset 
Compound Annotation.

The application removes the structure and name annotations and restores the original FISh Coverage score.
11. Repeat steps 2 through 8 for row 1 (MW 361.10963). To annotate the compound, use the 

5-hydroxyomeprazole.mol file that you copied to your processing computer, and then name the compound 
5-hydroxyomeprazole.

Finding
Unexpected
Metabolites

If an unidentified compound in the Compounds table matches the expected isotope pattern, use its related Merged 
Features and Expected Compounds tables to determine its possible transformation path. 

 To find unexpected metabolites
1. Click the Compounds tab.
2. If you have not already filtered the Compounds table by the following filter do so now—Area (Max.) is greater 

than or equal to 5e8.

The Compound table is now reduced to 36 visible compounds.
3. Click the expand icon, , to the right of the Pattern Matches column heading, select C17S, and then sort the 

Compounds table in descending order by the Pattern Matches column.
4. Select row 2 (C17 H19 N3 O5 S).
5. In the primary set of related tables, click the Merge Features tab.
6. Compare the Find Expected Compounds column to the Detect Compounds column.
7. Select an entry in the Merged Features table where both nodes found the compound. In addition, select the 

check box for this entry.
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8. In the secondary set of related tables, click the Expected Compounds tab.
9. Review the transformations.
10. Select the check box for most probable explanation.

This figure shows the selection of the Oxidation, Oxidation transformation as the most probable explanation for 
C17H19N3O5S in the Compounds table.

Saving or
Resetting the

Result File’s
Layout

The layout of the result file includes the location of the graphical views, the columns and rows that you want to 
display in the result tables, the filter set, and the Group By and Filter By settings. 

 To save the current layout of the result file

With the result file selected as the active page, do one of the following:

• In the toolbar, click the Save the Currently Active Item icon, .

–or–

• From the menu bar, choose File > Save (save the currently active item).

 To save the current layout of the result file to a layout file
1. With the result file selected as the active page, in the menu bar choose Window > Save Layout.

2. Name the layout and click OK.

 To restore the default layout to a result file
1. With the result file selected as the active page, in the menu bar choose Window > Reset Layout.
2. Click Yes to confirm the action.
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Printing
Reports

Compound Discoverer reports are based on the result tables and their associated chromatograms and mass spectra.

Before you print a report, review the result table that you want to include in the report. Filter the table as described 
in “Determining the Most Probable Explanation for Each Expected Compound.”  Sort the table by the column of 
interest, for example, by retention time (see “Sorting the Result Tables” on page 21).

Follow these procedures to print reports:

• To create a report by using the defined report template for the Expected Compounds table

• To print the report

• To export the contents of a report to a file

 To create a report by using the defined report template for the Expected Compounds table
1. On the result file page, click the Expected Compounds tab.
2. From the menu bar, choose Reporting > Create Report.

The Open Design Template dialog box opens.
3. Select the Expected Compounds No Graphs A4.cdReportTemplate file and click Open.

The application resolves the report and displays thumbnails in the Page Thumbnails pane to the left.

 To print the report 
1. In the Current Page/Total Number of Pages box, check how many pages are in the report.
2. In the reporting toolbar, click the Print icon, , make the appropriate selections in the Print dialog box, 

including the print range and any advanced settings, and click OK. 

 To export the contents of a report to a file
1. In the reporting toolbar, choose Export > File Type.
2. Select the directory where you want to store the file, name the file, and click Save.

Creating an
Inclusion List

for Met ID
Experiments

To create an inclusion list of m/z values for specific adduct ions, follow these topics in order: 
1. Generating a Formulas List
2. Exporting the Contents of a Result Table to a Spreadsheet
3. Converting a Molecular Weight List to a Mass-to-Charge List

Generating a
Formulas List

 To generate a list of formulas for the targeted compounds and their transformation products
1. Add the compounds of interest to your Expected Compounds list (“Adding Compounds to the Expected 

Compounds List” on page 2).
2. Start a new analysis from the existing study as follows:

a. Click the Omeprazole Study tab.
b. In the study command bar, click New Analysis.

3. Click the Workflows tab.

Note  For information about creating and editing your own custom report templates, refer to the Compound 
Discoverer 3.1 Reporting Quick Start, the reporting chapter in the Compound Discoverer 3.1 User Guide, or the 
Help.

With the current reporting tool, you can add graphs for chromatogram traces and the MS1 and MS2 spectra to 
the report template. You cannot add graphs for the statistical plots.
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4. Select the processing workflow as follows:
a. Click Open Common in the command bar.
b. Open the Workflow Templates folder.
c. Open the MetID folder. 
d. Select the following processing workflow:

MetID Generate Inclusion List for Acquisition Pos Mode.cdProcessingWF

e. Click Open.
5. Customize the processing workflow as follows:

a. In the Workflow Tree area, select the Generate Expected Compounds node.
b. In the Compound list, select the compounds of interest.

6. Drag any input file from the Input Files page to the Files for Analysis area of the Analysis pane.

All analyses require input files; however, this analysis does not use the raw data to generate chromatograms or 
spectral trees. It only generates a list of expected formulas for the selected compounds and their transformation 
products.

7. Rename the result file.

8. Click Run.

The Job Queue page opens.

Go to the next topic

Exporting the
Contents of a

Result Table to a
Spreadsheet

Follow this procedure to export the contents of the Expected Formulas table to a spreadsheet.

 To export the formulas to a spreadsheet
1. When the run is complete, on the Job Queue page, double-click the result file.

The result file opens as a tabbed page.
2. On the result file page, click the Expected Formulas tab.

Rename the result file.
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3. Open the Field Chooser dialog box for the Expected Formulas table (click its Field Chooser icon, ) and clear 
all the check boxes, except those for Formula and Molecular weight.

4. Right-click the table and choose Export > As Excel.

5. In the Export To Excel dialog box, select a folder, name the file, and click Export.

6. At the prompt, click OK.

Converting a
Molecular

Weight List to a
Mass-to-Charge

List

Follow this procedure to convert a list of molecular weights to a list of mass-to-charge values. Use the following 
procedure to convert the molecular weights for neutral compounds to the mass-to-charge values for the protonated 
adduct ions.

 To convert the spreadsheet to an inclusion list for data acquisition
1. Open the exported spreadsheet in a spreadsheet application.

The Molecular Weight column displays the molecular weight of the neutral compound.
2. Name the third column m/z.
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3. To display the molecular weight of the protonated ion of each compound, copy the following formula down the 
third column: +B2+1.00728. 

4. Check the cell format and verify that the number of decimal places is appropriate for your MS.
5. Save the modified spreadsheet.

Trademarks Compound Discoverer, FreeStyle, mzVault, and Q Exactive are trademarks, and Thermo Scientific, and Xcalibur are 
registered trademarks of Thermo Fisher Scientific Inc. in the United States. 

All other trademarks are the property of Thermo Fisher Scientific Inc. and its subsidiaries.
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