
To familiarize yourself with the Thermo Compound Discoverer™ 3.2 application, follow the topics in this 
tutorial to set up a new study and a new analysis, process a set of example Xcalibur™ RAW files, review the 
targeted (expected) and untargeted (detected) compounds that the analysis found, and print a report. 
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Overview Before you open the application and begin this tutorial, review the following topics:

• Location of the example files

• Tutorial summary

• The Help system

Location of the
example files

In the Compound Discoverer application, data processing—the analysis of a set of raw data files to extract 
information about the sample set—takes place within the study environment. 

To create a practice study, use the example Xcalibur RAW files. These files are provided in the following 
folder on the key-shaped USB drive in the software media kit: 

Example Studies\LC\Met ID\Omeprazole Study

Compound Discoverer 3.2 Metabolism Tutorial 

Tip  You can also download these example files from the Compound Discoverer 3.2 Product 
Download page of the LSMS Software Download and Licensing Portal website. 
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Copy the Met ID folder to your data processing computer.

This folder contains the following files.

Tutorial
summary

This flowchart summarizes the overall workflow for a targeted analysis of expected compounds. 

The Help system The application provides Help for the views, tabbed pages, and dialog boxes. 

 To open the Help topic for a specific view, tabbed page, or dialog box

1. Open the view, tabbed page, or dialog box.

2. Place the mouse cursor anywhere in the opened view, tabbed page, or dialog box.

3. On the computer keyboard, press the F1 key. 

File name Description

Omeprazole Study.cdStudy Compound Discoverer study file with the study information for 
the Xcalibur RAW files

Omeprazole Example.cdResult Compound Discoverer result file from an analysis with a Met ID 
processing workflow without a node for naming the detected 
compounds

Omeprazole Example with 
ID.cdResult

Compound Discoverer result file from reprocessing the 
Omeprazole Example.cdResult file after adding a node for 
naming the detected compounds

Omeprazole.mol Structure file 
Urine_0-3_GSH_PhII_01.raw Xcalibur raw data file from a Q Exactive mass spectrometer (MS)
Urine_3-5_GSH_PhII_01.raw Xcalibur raw data file from a Q Exactive MS
Urine_5-7_GSH_PhII_01.raw Xcalibur raw data file from a Q Exactive MS
Urine_7-9_GSH_PhII_01.raw Xcalibur raw data file from a Q Exactive MS

Start the Compound Discoverer application.

Use the New Study and Analysis Wizard to do the following: 
1. Select the study type, create a new study, and select a processing 

workflow.
2. Add the files that you want to process to the study.
3. Define the study factors and assign their values to all the input files in the 

sample set, excluding the Blank, Quality Control, and Identification Only 
samples.

4. Set up the sample groups and ratios for the analysis.

Open the result file and review the data.

Sort the data, select a defined report template, and print a report. 

Confirm the analysis and start the run.

Add the compounds of interest to the Expected Compounds list.
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Start the
application

 To start the Compound Discoverer application

• From the taskbar, choose Start > All Programs (or Programs) > Thermo Compound 
Discoverer 3.2.

–or–

• From the computer desktop, double-click the Compound Discoverer icon, .

The application opens to the Start Page (Figure 1). 

Figure 1. Start Page

Add your
target

compounds to
the Expected

Compounds
list

For targeted analyses of known compounds and their transformation products, you must add the target 
compounds to the Expected Compounds library.

 To add a compound to the Expected Compounds library

1. (Optional) Download a 2D structure file for the compound from the Internet. For example, 
download the structure for caffeine from the ChemSpider database.

2. From the menu bar, choose List & Libraries > Expected Compounds. 

The Expected Compounds view opens.

3. Click New.

The Compound Editor dialog box opens.

4. To add the structure for a compound, use one of the following methods: 

a. If you do not have a structure file for the compound, click ChemSpider at the bottom right of 
the dialog box.

The ChemSpider Search dialog box opens.

Menu bar Toolbar

Tip  If you are using the omeprazole example data set, you do not need to add the target compound, as 
this library already includes omeprazole. To use a different data set for this tutorial, follow the 
instructions in this topic to add the compounds you are studying to the Expected Compounds library. 
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b. In the Input box, type the name, formula, molecular weight, or ChemSpider ID (CSID) for the 
compound.

c. Click Search.

d. Select one of the hits and click Select.

–or–

a. If you have a structure file for the compound, click the Load Structure from Disk icon, , in the 
Compound Editor toolbar, 

The Open Structure dialog box opens.

b. In the Known Structure Formats list, select the format of the structure file.

The Compound Editor dialog box supports the following file formats:

• MOL Format (.mol)

• Compressed Structure (.mcs)

• Template (.tml)

c. Select the structure file of interest and click Open.

The chemical structure appears in the drawing pane of the Compound Editor dialog box, and the 
application automatically populates the Elemental Composition and Molecular Weight boxes. For a 
ChemSpider search, the application also populates the Description box with the CSID number of the 
compound and the Name box with its name (Figure 2). 

Figure 2. Compound Editor dialog box with the structure of caffeine returned by a ChemSpider search

5. When applicable, type a different name for the compound. 

6. Click Save to add the compound to the Expected Compounds library.

The new compound appears in the library (Figure 3).

Opens the 
ChemSpider Search 
dialog box

Opens the 
Open Structure
dialog box 
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Figure 3. Lists & Libraries page with the Expected Compounds library displayed

7. To close the Lists & Libraries page, click the close icon, , on the page tab.

Set up a new
study and a

new analysis

To create a new study, you must use the New Study and Analysis wizard. 

To set up a new study and a new analysis, follow these steps:

1. Open the New Study and Analysis Wizard 

2. Select the study type, specify the directory folder, and name the new study

3. Select a processing workflow for the analysis

4. Add the input files to the study

5. Specify the experimental variables

6. Group the samples in this tutorial by their collection time

7. Troubleshoot the analysis

Open the New
Study and

Analysis Wizard

 To open the New Study and Analysis Wizard

Do one of the following:

• From the menu bar, choose File > New Study and Analysis.

• From the application toolbar, click the Create a New Study icon, .

• On the Start Page, click the New Study and Analysis link in the What Would You Like to Do? 
area.

The New Study and Analysis Wizard opens to the Study Name and Processing Workflow page 
(Figure 4).

The first time you open the wizard, the Studies Folder is undefined. After you select the directory 
folder for your Compound Discoverer studies, the application remembers the location. You can store 
all your studies in one directory or create new directory folders as needed.

Clicking the light bulb icon (  or ), at the bottom left of the wizard opens or closes the wizard’s 
embedded instructions.

Note  To delete a compound, select the compound in the library and click Delete. 
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Figure 4. Study Name and Processing Workflow page of the New Study and Analysis Wizard

Go to the next task to “Select the study type, specify the directory folder, and name the new study.” 

Select the study
type, specify the
directory folder,

and name the
new study

 To select the study type, specify the study folder, and name the new study

1. In the Study Type area on the Study Name and Processing Workflow page of the wizard (Figure 4), 
select the LC option if it is not already selected.

The application stores this selection until you change it.

2. In the Study Name and Directory Structure area, select the studies folder as follows:

a. Click the browse icon, , next to the Studies Folder box.

The Select Folder dialog box opens (Figure 5).

Initially, the 
studies 
directory is 
undefined. 

Opens instructions for the current 
page to the left of the page.

Note  There are two types of studies: GC for gas chromatography-mass spectrometry data and LC 
for liquid chromatography-mass spectrometry data.
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Figure 5. Select Folder dialog box

b. Browse to the directory where you want to store your studies.

c. Click New Folder.

d. Name the new folder Studies, select it, and then click Select Folder.

3. In the Study Name and Directory Structure area, type Omeprazole Study in the Study Name box. 

Stay on this page of the wizard and go the next topic to “Select a processing workflow for the analysis.” 

Select a
processing

workflow for the
analysis

 To select the processing workflow

1. In the Workflow list in the Processing area, select the following processing workflow:

Workflow Templates\LC\MetID\MetID w Stats Expected and Unknown w Background 
Removal

A description of the processing workflow appears in the Workflow Description box.

Note  When you create a new study, the application creates a new study folder with the same name 
and stores the study file (.cdStudy) in the new folder and the new study folder in the specified 
studies folder.

New Folder button

Select Folder 
button
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2. Read the description of the processing workflow, and then click Next to open the Input File Selection 
page of the wizard.

Go to the next topic to “Add the input files to the study.” 

Add the input
files to the study

 To add input files to the study

1. On the Input File Selection page of the wizard, click Add Files. 

2. Browse to the folder where you copied the example data. 

drive:\Example Studies\ LC\Met ID\Omeprazole Study 

3. Select all the raw data files in this folder and click Open.

The file names of the selected files appear in the Files box, the number of files that you selected 
appears below this box, and the Next button becomes available.

4. Click Next to open the Input File Characterization page of the wizard.

Go to the next topic to “Specify the experimental variables.” 

Specify the
experimental

variables

The sample type and study factor values for each sample are experimental variables. A study factor is an 
experimental variable that might have a statistically significant effect on the sample population being 
studied.

In this tutorial, you are comparing the compounds in urine samples collected at different time points from 
a subject dosed with the drug omeprazole. The time points are 3, 5, 7and 9 hours after dosage. 

 To specify the study variables for the example data set

The study variables include the sample types and study factor values.

1. For the example data set, select the Underscore check box for the file name delimiter. 

The time points study variable is included in the file names of the example data set, and underscore 
symbols separate the time point text (for example, 0-3) from the other text in the file name 
(Urine_0-3_GSH_PhII_01).

Number of selected files

Note  Omeprazole is a proton pump inhibitor that blocks the production of acid by the stomach. It is 
metabolized in the liver and excreted as metabolites in the urine within 3 to 6 hours after oral 
ingestion. Its primary metabolites are omeprazole sulfone and 5-hydroxyomeprazole.
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Figure 6 shows the newly added samples in the Samples area. Sample is the default sample type. The 
Underscore check box is selected as the file name delimiter.

Figure 6. Underscore check box selected

2. In the Study Factors area, choose Add > Categorical Factor.

The categorical factor editor appears in the Study Factors area with the [new factor] text selected.

3. To replace the [New Factor] text, type the factor name, Time Points.

4. For each item that you want to add to the Items list (0-3, 3-5, 5-7, and 7-9), do the following:

a. In the Items box (next to the Add button), begin typing a factor item, for example, 0-3 
(Figure 7).

If the file name contains a character delimiter and you selected the check box for the delimiter, 
the editor displays a selection list as you type. Otherwise, you must type all the characters for the 
item.

Finish typing the appropriate alphanumeric text or select an item from the list.

Tip   If you are not working with the omeprazole data set, select the study factor type as follows:
• To define study factors that include alphanumeric items for a non-quantifiable feature, use the 

categorical study factor editor. 
• To define study factors for quantifiable features that are provided as numeric values, use the 

numerical study factor editor. 
• To set up a nested experiment, use the biological replicate factor for one of the study factors.

To open the Help topic about setting up the study factors and sample types, press the F1 key.

Underscore selected as the file name delimiter

Default 
sample type
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Figure 7. Typing the categorical item

The Add button becomes available. 

b. Click Add.

The current item appears in the Items list. 

Add the remaining time points, 3-5, 5-7, and 7-9.

5. To save the study factor, click Apply.

The factor editor collapses to show only the study factor name and items list. The items appear in 
ascending order.

6. Click Assign.

The wizard automatically assigns the study factors to the samples.

Figure 8. Samples with assigned study factor values 

Note  The application assigns the Blank sample type to any sample that begins with Blank (or that 
contains Blank as delimited text, for example, Solvent_Blank with Blank preceded by the selected 
delimiter). The sample set for this tutorial does not include blanks.

Assign command
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7. For the example data set, keep the default assignments of Sample. 

For other data sets, select the sample types as follows. 

• To change the sample type for a single sample, click the down arrow and select the 
sample type from the dropdown list.

• To select the same sample type for a consecutive sample range, hold down the 
SHIFT key and select the rows of interest. Then, right-click and choose Set 
Sample Type To > Sample Type.

• To select the same sample type for non-consecutive samples, hold down the CTRL key and select 
the rows of interest. Then, right-click and choose Set Sample Type To > Sample Type.

Figure 9. Samples pane shortcut menu

The sample type affects the processing actions (Table 1).
Table 1. Sample types (Sheet 1 of 2)

Sample type Processing actions

Sample, 
Control, and 
Standard

Detects the components in the sample. When the analysis includes study groups, 
the application reports the group areas for these sample types by study factor. 

The application does not differentiate between the Sample, Control, and 
Standard sample types, which means that you can use these sample types 
interchangeably. Thermo Fisher Scientific recommends that you use the Control 
and Standard sample types for labeling or grouping purposes as needed.

IMPORTANT   To group samples by one or more study factors, you must define 
the study factor items (or values) for the Sample, Control, and Standard sample 
types. Failing to define the study factors for these sample types generates error 
messages on the Sample Groups and Ratios page.

Blank Detects the components in the sample. When the processing workflow includes 
Mark Background Compound nodes, the application marks these components as 
background compounds. 

Quality Control Detects the components in the sample. When the processing workflow includes a 
QC correction node and the analysis includes QC samples, the application does 
the following:
• Fits the areas of the compounds in the QC samples to linear or cubic spline 

curves. Or, runs a Random Forest analysis (new Apply SERRF QC 
Correction (beta) node on the compound areas.

• Runs a batch normalization of the non-QC samples against these curves.

Shortcut menu
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8. Click Next to open the Sample Groups and Ratios page.

The Study Variables area contains check boxes for the study variables—File, Sample Type, and the 
user-defined study factors. 

Go to the next topic to “Group the samples in this tutorial by their collection time.” 

Group the
samples in this
tutorial by their
collection time

 To set up the sample groups for the data set

1. On the Sample Groups and Ratios page, select the Time Points check box in the Study Variables area. 

The generated sample groups appear in the Generated Sample Groups pane. The application 
generates a “not assigned” (n/a) group for samples without an assigned value for the Time Points 
study factor. For the example data, there is no n/a group.

2. If you are not working with the example data set, and an error message appears in the Generated 
Sample Groups pane, do the following: 

a. Check whether any of these sample types are part of an n/a sample group in the Generated 
Sample Groups pane on the Samples Groups and Ratios page:

• Sample 

• Standard

• Control

Identification 
Only

Does not report the chromatographic peak areas for the sample components 
(chromatographic peaks with the same MW×RT dimensions). The application 
uses the sample’s data-dependent fragmentation (DDA) scans for component 
identification when the processing workflow includes the Group Unknown 
Compounds node.

Labeled Not used for targeted analyses.

Table 1. Sample types (Sheet 2 of 2)

Sample type Processing actions
12



b. To assign values to the Sample, Standard, or Control samples, click Back to return to the Input 
File Characterization page. Then, select study factor values for all the samples except for the 
Blank and Identification Only samples.

c. Return to the Sample Groups and Ratios page.

d. In the Study Variables area, select the study variables of interest.

e. In the Generated Samples Groups pane, make sure that the n/a group only includes the Blank 
samples.

3. Click Finish.

The study—Omeprazole Study—opens as a tabbed document at the left of the application window, 
and the Analysis pane opens to the right of the study (see Figure 10). 

The study consists of four tabbed pages: Study Definition, Input Files, Samples, and Analysis Results. 
The two tabs—Grouping & Ratios and Workflows—to the right of the study pages are part of the 
analysis. If you close the Analysis pane, these two tabs also close.

The Analysis pane lists the selected processing workflow, the name of the result file (which is based on 
the first input file), and the selected raw data files. If the analysis is valid, the Run button is green.

Figure 10. New study page and new analysis

Go to the next topic to “Troubleshoot the analysis.” 

IMPORTANT  When you select a study factor in the Study Variables area, the Sample, Quality 
Control, and Control sample types must have assigned study factor values. Only Blanks and 
Identification Only samples can have an n/a study factor value. 

If you are working with a different data set and you do not assign study factor values to one or 
more of the Sample, Control, or Standard samples, an error message ( ) appears and the n/a 
group is highlighted in red.

Note  Because the example data set contains only one sample per group and the statistical analysis 
tools require at least two samples per group, this tutorial does not describe how to set up ratios. 
For information about setting up ratios and using the statistical views, refer to the Help, the 
metabolomics tutorial, or the extractables and leachables tutorial.

Study pages Analysis pages Analysis pane

Default file name for 
the result file 

Unavailable 
Run button
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Troubleshoot the
analysis

A Caution symbol to the right of Processing Step in the Analysis pane warns you that the analysis contains 
errors. You cannot submit the run until you fix the errors.

 To troubleshoot the analysis and fix the errors

In the Analysis pane, point to the Caution symbol (Figure 11). Or, click the Workflows tab and 
review the messages in the Current Workflow Issues pane at the bottom of the Workflows page 
(Figure 12).

The application displays explanations for the analysis errors.

Figure 11. Analysis pane with Caution symbol to the right of the Edit button

Figure 12. Current Workflow Issues pane at the bottom of the Workflows page

All of the errors are due to missing values in the workflow nodes. To fix the analysis errors, go to the next 
topic to “Customize the processing workflow.” 

Customize the
processing

workflow

For an analysis of one or more target compounds and their transformation products, you must specify the 
target compounds in the processing workflow template. For the MetID w Stats Expected and Unknown w 
Background Removal processing workflow, you must also select the parent compound for the Create FISh 
Trace node and the compound class file for the Compound Class Scoring node.

Caution symbol

Tip  When customizing a processing workflow template, do the following:

• Base the Ions list in the Generate Expected Compounds node and the Preferred Ions list in the 
Group Expected Compounds node on the sample matrix or other experimental factors. 

• Base the Base Ions for the Detect Compounds node and the Preferred Ions for the Group 
Compounds node on the experimental factors.

• Change the Min. Peak Intensity setting in the Find Expected Compounds node and the Detect 
Compounds node to a threshold that is consistent with the mass spectrometer where you acquired 
the data.
14



To customize the processing workflow for the example data set, do the following:

• Specify the target compounds and adduct ions 

• Specify the parent compound for the Create FISh Trace node

• Specify the compound class library for the Compound Class Scoring node

Specify the
target

compounds and
adduct ions

The default Expected Compounds list includes omeprazole—the target compound for the example data 
set. 

 To specify the target compound for the example data set

1. Click the Workflows tab to open the Workflows page.

Figure 13 shows the Workflows page with the selected processing workflow. 

The exclamation marks ( ) in the upper right corner of the following nodes indicate that these 
nodes are missing parameter values: 

• Generate Expected Compound node 

• Create FISh Trace node

• Compound Class Scoring node 

IMPORTANT  If you are following this tutorial with a different data set and you have not added the 
target compounds to the Expected Compounds list, add the compounds to the list as described in 
“Add your target compounds to the Expected Compounds list” on page 3. 
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Figure 13. Processing workflow nodes for the selected processing workflow template

2. In the Workflow Tree pane of the Workflows page, select the Generate Expected Compounds node.

The Parameters pane for the Generate Expected Compounds node opens to the left. In the selected 
processing workflow template, Apply Dearylation is set to True, and all the Phase 1 and Phase II 
reactions are selected.

Workflows tab Indicates a missing 
parameter value. 
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Figure 14. Generate Expected Compounds node

3. Do one of the following:

• For the example data, in the Compound box, type O for omeprazole.

If Omeprazole is the only compound in the list that begins with an O, it appears in the box. 
Otherwise, continue typing the next letter in the name until the compound’s name appears.

• For a different data set, add the target compounds to the Expected Compounds list, and then 
select these compounds in the Generate Expected Compounds node. To target multiple 
compounds with a different set of transformation rules for each compound, add an additional 
Generate Expected Compounds node for each set of transformation rules, and then connect these 
nodes to the Find Expected Compounds node.

To continue fixing the validation issues for the MetID w Stats Expected and Unknown w Background 
Removal processing workflow, go to the next topic to “Specify the parent compound for the Create FISh 
Trace node.” 

Specify the
parent

compound for
the Create FISh

Trace node

The Create FISh Trace node uses the observed and theoretical fragments for a compound along with a list 
of fragmentation rules and fragmentation libraries to search the spectral data in the input files for 
fragments related to the compound of interest. It uses the matched fragments to create a fragment based 
total ion current chromatogram that you can use to visualize regions with fragment ions related to the 
parent compound. 

 To specify the compound for the Create FISh Trace node

1. On the Workflows page, select the Create FISh Trace node.

Parameters 
pane

All the Phase I 
and Phase II 
transformatio
ns selected

Apply 
Dearylation 
set to True
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2. On the Parameters of Create FISh Trace page, select the parent compound for the trace.

• For the example data, select omeprazole and keep the default settings for the Scan Polarity and 
Fragment Mode parameters.

Figure 15. Create FISh Trace node

• If you are not working with the example data set, match the following parameter settings in the Create 
FISh Trace node to your data set: Scan Polarity (positive or negative) and Fragmentation Mode 
(Data-Dependent or Data Independent).

To continue fixing the validation issues for the MetID w Stats Expected and Unknown w Background 
Removal processing workflow template, go to the next topic to “Specify the compound class library for 
the Compound Class Scoring node.” 

Specify the
compound class

library for the
Compound Class

Scoring node

The Compound Class Scoring node scores the detected compounds against a set of fragment ions commonly 
present in the fragmentation scans for a compound class. The node compares the ions (m/z values) 
detected in the fragmentation scans to the fragments in the selected compound class libraries. 

 To specify the compound class library for the example data files

1. On the Workflows page, select the Compound Class Scoring node.

2. On the Parameters of Compound Class Scoring page, click the Compound Classes box, and then 
click the browse icon to the right of this box (Figure 16).

Note  The Compound Discoverer 3.2 application comes with a compound class library for 
omeprazole, which is the compound of interest in this tutorial. 

Tip  If you are not working with the example data set, delete the Compound Class Scoring node from 
the processing workflow. Or, create compound class libraries for your targeted compounds. 

For information about adding compound class libraries to the Compound Class list, choose Lists & 
Libraries > Compound Classes from the application menu. Then, press the F1 key.
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Figure 16. Compound Class Scoring node 

The Select Input Files dialog box opens.

3. Select the check box for the Omeprazole Compound Class file.

4. Click OK.

Go to the next topic to “Submit the analysis to the job queue.”  

Submit the
analysis to

the job queue

For the omeprazole study, set up the analysis as described on the previous pages of this tutorial.

 To submit the analysis to the job queue

1. To create one result file for the input files set, leave the By File check box clear.

By default, the application uses the name of the first input file as the result file name.

2. In the Result File box, rename the result file Omeprazole Example.

Note  If you select the By File check box, the application creates a separate result file for each input 
file, which means that it cannot compare the results across the data set.

Renamed result file
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3. Click Run to submit the analysis to the job queue.

Because the processing workflow includes the Differential Analysis node and you have not defined 
any ratios for the analysis, the Analysis Validation Issues dialog box opens.

4. Click Ignore. 

The Job Queue page opens to the right of the study tab.

5. To view the processing messages, click the expand icon, , to the left of the processing job.

You can ignore the warning messages that are highlighted in yellow.

Leave the Job Queue page open and go to the next topic “Open the result file and review its layout and 
other layout options.”  

Open the
result file and

review its
layout and

other layout
options

You can open a result file from multiple locations: the Job Queue page, the Analysis Results page of a 
study, the Start Page, or the menu bar. The result file opens as a tabbed document in the application 
window (see Figure 17). For information about all the ways you can open a result file, refer to the Help.

Note  Because a differential analysis requires a minimum of two data points per group and the data 
set includes only one sample per group, the Differential Analysis node cannot calculate the 
p-values for the sample group regardless of whether you define ratios for the analysis.

Note  During the run, the nodes generate the following warning messages, which you can ignore:

• The input files do not contain any UV data, so the Create Analog Trace node generates a 
warning message for each input file. 

• The data set does not include any blank samples, so the Mark Background Compounds node 
generates a warning message that no blank files were specified for the analysis.

• You did not define any ratios for the analysis, so the Differential Analysis node generates a 
warning message about the missing ratios.

Expand icon

Tip  If you did not reprocess the example data set, do the following:

1. Open the result file provided on the Compound Discoverer 3.2 USB key:

Example Studies\LC\Met ID\Omeprazole Example.cdResult

2. From the menu bar, choose Window > Reset Layout.
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To open the result file and review the default layout, do the following:

1. Open the result file

2. Review the default layout for the result page

For general information about modifying the layout of a result page, see “Common layout modifications 
for the result tables and views” on page 23.

Open the result
file

 To open the result file generated by the analysis

Do one of the following:

• If the Job Queue page is open, double-click the completed run.

• If the Omeprazole Study page is open, click the Analysis Results tab. Then, double-click the link 
to the completed analysis.

–or–

• If you closed the study after the run completed, click the result file name under Recent Results on 
the Start Page. If the Start Page is closed, open it by choosing View > Start Page from the menu 
bar.

To identify the unknown compounds by name go to the following topic to “Modify the processing 
workflow and partially reprocess the analysis” on page 24.

Review the
default layout for

the result page

The factory default layout for a result file includes the following items (Figure 17):

• A page tab with the result file name.

• A Chromatograms view on the top left that is populated with XIC traces for the compound in the first 
row of the Expected Compounds table. The view automatically zooms in to the start and end points of 
the chromatographic peak for the compound, and the area under the peak is shaded.

Opens the Omeprazole 
Example result file.

Opens a dialog box where you can 
locate, select, and open a result file.
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• A Mass Spectrum view on the top right that is populated with the MS1 scan (for a preferred ion) that 
is closest to the chromatographic peak apex for the selected compound across the input files. The 
spectrum tree to the left includes the MS1 scans and the fragmentation scans for the preferred ions 
that were acquired within the following retention time window:

 The chromatographic peak apex for the selected compound ± peak width at half maximum 
(FWHM)

–or–

 The Start and end points of the chromatographic peak

• A set of tabbed main tables below the two graphical views. 

• A collapsed area for the related tables below the main tables.

Figure 17. Default layout for the result file generated by the processing workflow 

The selected processing workflow creates the following main result tables from left to right.
Table 2. Result tables for the selected processing workflow template (Sheet 1 of 2)

• Compounds Lists all the compounds that the Detect Compounds node detected across the 
input file set beginning with the compound with the largest chromatographic 
peak area in any of the input files.

• Compounds per 
File

Lists the compounds that the Detect Compounds node detected in each input 
file.

• Expected 
Compounds

Lists all the expected compounds that the Expected Compounds node found 
in one or more of the input files, and groups the compounds by molecular 
weight and retention time. 

• Expected 
Compounds per 
File

Lists all the expected compounds that the Expected Compounds node found 
in each input file (Xcalibur RAW file). The Group Expected Compounds 
node groups the compounds by molecular weight and retention time. 

• Expected Formulas Lists the expected formulas that the Find Expected Compounds node searched 
against. The expected formulas list is the output from the Generate Expected 
Compounds node.

Shows the related tables

Closest MS1 scan to the 
chromatographic peak apex 
for the selected compound

Shaded chromatographic peaks 
for the selected compound 
across the input files
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Common layout
modifications for
the result tables

and views

Table 3 describes common layout modifications for the result tables and views in a result file. 

• Merged Features Lists the chromatographic peaks with the same m/z × RT dimensions that the 
analysis found in one or more of the input files. When the processing 
workflow includes both of these nodes—Find Expected Compounds and 
Detect Unknown Compounds—the Merge Feature node merges the features 
in this table and adds the Ion Status column.

• Features Lists the adduct ions detected by the Detect Compounds node across all the 
input files.

• Expected Features Lists the features found by the Find Expected Compounds node across all the 
input files.

• FISh Trace 
Fragments

Lists the structures of the expected fragments and the summed intensities of 
the matching adduct ions. The Create FISh Trace node generates a list of 
expected fragments (adduct ions) for the user-specified compound. 

• Input Files Lists the input files for the analysis.
• Specialized Traces For the selected MetID processing workflow, this table lists the traces 

generated by the Create FISh Trace node and the Create Pattern Trace node.
• Study Information Displays information about the samples, study groups, and ratios for the set of 

processed input files. The sample information includes the sample type and 
file name of each input file.

Table 2. Result tables for the selected processing workflow template (Sheet 2 of 2)

Table 3. Common layout modifications (Sheet 1 of 2)

To do this Do the following

Show or hide a table column Open the Field Chooser for a table by clicking the icon, , in the 
upper left corner of the table. To display a column, select its check 
box. To hide a column, clear its check box. 

Show or hide a table Open the Select Table Visibility dialog box by clicking the icon, 
, at the left of the table tabs.

Close a view Click the close icon, , in the upper right corner of the view.
Open a view In the application menu bar, choose View > Specific View. Or, in 

the toolbar, click the icon for the view.
Expand the header for a column 
with multiple subcolumns

Click the expand icon, , to the right of the heading.

Freeze a column to the left side of 
the table

Right-click the table and choose Enable Column Fixing. Then, 
click the pin icon to the right of the column heading.

Pin a row to the top of the result 
table.

Click the pin icon to the right of the row number (unpinned, , 
or pinned, ) 

Sort a result table by a single table 
column.

Click the column header. Click the column header a second time 
to reverse the sort order. 

• Descending order ()

• Ascending order ()
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You can also change the relative location of the table columns and views. Or, float the views and drag 
them to another monitor. For more details, refer to the following Help topics: 

“Modifying the result page layout” and “Common operations for manipulating data tables”

To identify the unknown compounds by name go to the following topic to “Modify the processing 
workflow and partially reprocess the analysis” on page 24.

Modify the
processing

workflow and
partially

reprocess the
analysis

You can modify the parameter settings for any of the scoring nodes, mapping nodes, or search nodes 
without reprocessing the entire workflow—that is, without reprocessing the core peak detection and 
grouping nodes.

To identify compounds by using MS/MS database matching, add the Search mzVault node to the 
processing workflow. Then, partially reprocess the analysis.

 To add the Search mzVault node to the processing workflow and reprocess the data

1. Close the Omeprazole Example result file by clicking the Close icon, , on the result page tab.

2. Open the Omeprazole Study page by doing one of the following:

• If the Omeprazole Study file is open, click the Omeprazole Study tab. 

• If the Omeprazole Study file is closed, click the Omeprazole Study link under Recent Studies on 
the Start Page. Or, choose File > Open Study from the menu bar and locate the study.

3. On the Omeprazole Study page, click the Analysis Results tab.

4. On the Analysis Results page, right-click the analysis and choose Reprocess.

Sort a table by two columns. Click the column header of the first column once or twice until 
the column is sorted in the order you want. Then, hold down the 
CTRL key and click the column header of the second column 
until the column is sorted in the order you want.

Sort a table by a column with 
multiple sub-columns.

1. Click the expand icon, , to the right of the column heading 
to display the vertical headings for the sub-columns.

2. Select the sub-column that you want to sort by.

3. An asterisk appears at the top of the vertical heading.

4. Click the column heading.
Reset the result page layout. From the application menu bar, choose Window > Reset Layout.

Tip  To find a topic in the Help system if you know its name, do the following:

1. In the Contents pane of the Help system, enter the topic’s name in quotes in the search box. 

2. Click List Topics.

3. In the Select Topic to Display list, select the topic of interest and click Display.

Table 3. Common layout modifications (Sheet 2 of 2)

To do this Do the following

Note  The Search mzVault node searches for matching entries in the local mzCloud Offline databases. 
Your computer does not need access to the Internet to search these databases.
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Figure 18. Analysis Result page with the result file selected

The Grouping & Ratios and Workflows tabs appear to the right of the study tabs, and the Analysis 
pane opens to the right of the tabbed pages. 

Figure 19. Omeprazole Study page with a reopened analysis

5. In the Analysis pane, click Edit.

The Workflows page opens (Figure 20). 

Edit button 
that opens the 
Workflows pageAnalysis pane

Workflows tab
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Figure 20. Workflow Tree (Reprocess) pane with unmodified workflow nodes from the selected analysis

6. If the Workflow Nodes pane is closed, click the Workflow Nodes tab at the bottom left of the 
application window.

7. Add the Search mzVault node to the processing workflow by dragging it from the Workflow nodes 
pane to the Workflow Tree (Reprocess) pane.

Figure 21. Dragging the Search mzVault node from the Workflow nodes pane to the Workflow Tree (Reprocess) pane

The Group Compounds and Group Expected Compounds nodes automatically connect to the 
Search mzVault node. The Current Workflow Issues area displays an issue for the Search mzVault 
node. You must select a library to search.

Workflow Nodes tab
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8. Select the mzVault library for this tutorial as follows:

a. In the Workflow Tree (Reprocess) pane, select the Search mzVault node.

The Parameters of Search mzVault pane appears at the left (Figure 22).

Figure 22. Modified processing workflow with recently added Search mzVault node

b. Click the box to the right of mzVault Library. Then, click the browse icon, .

The Select Input Files dialog box opens.

c. Select the check box for the mzCloud_Offline for mzVault_Reference_2020B file (Figure 23). 

Figure 23. Select Input Files dialog box
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d. Click OK.

The name of the selected library appears in the mzVault Library box, and the Current Workflow 
Issues pane closes.

9. In the Analysis pane, rename the result file by appending with ID to the original file name in the 
Result File box.

Figure 24. Renamed result file

10. Click Run. 

11. At the warning prompt, do the following:

a. If you did not close the result file before you clicked Run, click Abort, close the result file, and 
click Run again.

b. At the Grouping and Ratios warning prompt, click Ignore. 

Reprocessing starts. 

When the run is completed, go to the next topic to “Review the results from the untargeted analysis.” 

Review the
results from

the
untargeted

analysis

The processing workflow that you selected in the wizard performed a targeted analysis for omeprazole and 
its transformation products and an untargeted analysis for the detection of unknown compounds.

To review the results from the untargeted analysis, see these topics:

• Open the new result file from reprocessing

• View the number of number of compounds in the Compounds table

• Filter the Compounds table to reduce the number of compounds to review

• Review the results from the Compound Class Scoring node

• Compare the chromatograms for two compounds

• Compare the trend line plots for two compounds

• View a mass defect plot
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Open the new
result file from

reprocessing

 To open the new result file from reprocessing

1. Do one of the following:

• Double-click the Omeprazole Example with ID run on the Job Queue page.

• Open the Omeprazole Example with ID.cdResult file in the Example Study folder that you 
copied from the media or downloaded from the LSMS Software Download and Licensing Portal 
website. Then, choose Window > Reset Layout from the application menu bar.

View the number
of number of

compounds in
the Compounds

table

 To view the total number of compounds in the Compounds table

Point to its tab.

For this analysis, the Compounds table contains 4181 compounds.

Filter the
Compounds

table to reduce
the number of
compounds to

review

To reduce the number of compounds to review, filter out the low-level compounds.

 To filter the Compounds table by the chromatographic peak areas

1. Open the Omeprazole Example with ID.cdResult file, if it is not currently open. 

2. If the Compounds table is not open, click the Compounds tab.

3. From the application menu bar, choose View > Result Filters.

The Result Filters view opens as a floating window.

4. In the list of tables on the right, select the Compounds table if it is not already selected.
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5. In the right pane, add a filter that hides compounds with maximum peak areas below 500 000 000 
counts as follows:

a. Click Add Property and select Area (Max.) from the list. (The maximum area for each 
compound is the largest chromatographic peak for this compound across the input file set.)

b. Click the (pink) operation list and select Is Greater Than or Equal To. 

c. Type 5e8 (or 500 000 000) in the box next to the operation.

d. Click Apply Filters.

The Compounds tab has a filter icon and the table now displays only 36 entries. 4145 
compounds are currently hidden.
30



Review the
results from the

Compound Class
Scoring node

The processing workflow for this tutorial included the Compound Class Scoring node with the selection 
of a compound class (fragmentation) library for omeprazole.

 To review the class coverage for detected compounds reported in the Compounds table

1. If you have not already filtered the Compounds table by the Area (Max.) column, filter it now (see 
“Filter the Compounds table to reduce the number of compounds to review” on page 29).

2. Sort the Compounds table in descending order by the Area (Max.) column.

3. In the Compounds table, select row 7 (5-hydroxyomeprazole).

4. Click Show Related Tables at the bottom left of the result page.

5. In the set of related tables, click the Compounds Class Matches tab.

6. Select the entry in the Compound Class Matches table.

Figure 25. Compound Class Matches table for 5-hydroxyomeprazole

In the Mass Spectrum view, each matching fragment for the selected compound is highlighted in 
green and annotated with its structure.

Note  To fit the columns in the alloted space in Figure 25, column fixing was enabled.
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Figure 26. Data-dependent fragmentation scan for 5-hydroxyomeprazole with structure annotations for matching 
fragments

Go to the next topic to “Compare the chromatograms for two compounds.” 

Compare the
chromatograms

for two
compounds

The untargeted portion of the analysis detected the parent compound, esomeprazole, and one of its 
oxidation products, 5-hydroxyomeprazole.

 To compare the chromatograms for esomeprazole and 5-hydroxyomeprazole

1. Sort the Compounds table by the Name column in descending order (see “Common layout 
modifications for the result tables and views” on page 23).

2. In the Compounds table, select row 6 (Esomeprazole).

Figure 27. Filtered Compounds table sorted by the Name column in descending order

3. To view the chromatograms for the four time points more clearly, right-click the Chromatograms 
view and choose Display Options > Show Detected Peaks (Figure 28).

Note  Esomeprazole is an isomer of omeprazole.
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Figure 28. Shaded peaks for esomeprazole

4. To add a plot below the current plot, right-click the Chromatograms view and choose Plots > Add 
Plot.

Figure 29. Unshaded peaks for esomeprazole

An empty plot appears below the current plot. The blue bar at the left of the plot indicates that the 
plot is active.

Figure 30. Two plots

Shortcut menu for the display options 

Shortcut menu for the plots 
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5. In the Compounds table, select row 8 (5-Hydroxyomeprazole). See Figure 27 on page 32.

The chromatograms for 5-Hydroxyomeprazole appear below those for Esomeprazole.

Go to the next topic to “Compare the trend line plots for two compounds.” 

Compare the
trend line plots

for two
compounds

 To compare the trend line plots for 5-hydroxyomeprazole and esomeprazole

1. If you have not already filtered the compounds table by the Area (Max) column and sorted the 
Compounds table by the Name column in descending order, filter it and sort it now. 

For details about filtering and sorting, see “Filter the Compounds table to reduce the number of 
compounds to review” on page 29 and “Common layout modifications for the result tables and 
views” on page 23.

2. From the application menu bar, choose View > Trend Chart.

The Trend Chart view opens to the right of the result tables.

3. Select row 6 (esomeprazole) in the Compounds table. Then, hold down the CNTRL key and select 
row 8 (5-hydroxyomeprazole) in the Compounds table.

The Plot Type automatically changes to Trendline Chart, and the plot shows the trend lines for the 
two compounds (Figure 31).

4. Right-click the plot and choose Show Legend.

Note   The sampling points for this study represent the last dosage of omeprazole taken by the test 
subject after several previous dosages. The samples taken at 3, 5, and 7 hours show a delay in the 
oxidation of omeprazole due to enzyme inhibition by its metabolites. After 7 hours, the subject 
begins to metabolize the current dosage of omeprazole. 
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Figure 31. Trend Chart view with trend line plots for two compounds

Go to the next topic to “View a mass defect plot.” 

View a mass
defect plot

You can view a mass defect plot for the compounds in the Compounds table or the Expected Compounds 
table. 

In this tutorial, inspect a plot of the Kendrick mass defect for the following Kendrick formula—C2H4O.

Follow this procedure to set up a mass defect plot that highlights polyethylene glycols. 

 To set up a mass defect plot for a Kendrick formula

1. From the application menu bar, choose View > Mass Defect Plot.

The Mass Defect Plot opens to the right of the result tables.

2. In the Kendrick Formula box, type C2H4O.

3. Select the Highlight Named Compounds check box.

Legend

Note  Polyethylene glycols are commonly detected in urine samples. 
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Figure 32. Mass Defect Plot view with a plot of the Kendrick mass defect versus the molecular weight of the 
compounds

4. Zoom in on the four named compounds that form a horizontal line.

5. Right-click the plot and choose Check All Visible Points.

Figure 33. Mass Defect Plot view with shortcut menu

6. If the Compounds table is not currently sorted by the Name column in descending order, sort it now.

Shortcut menu for the
Mass Defect Plot view
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7. Notice that the four PEG compounds are checked. Clear these check boxes.

Go to the next topic to “Review the targeted compounds.” 

Review the
targeted

compounds

The Expected Compounds table lists the compounds found by the Find Expected Compounds node, 
which searches the data for the adduct ions specified by the Generate Expected Compounds node. The 
Group Expected Compounds node groups the compounds found across the input files by their molecular 
weight, formula, transformations, and retention time. 

To review the targeted (expected) compounds, do the following:

1. Filter the Expected Compounds table by peak area

2. Sort the Expected Compounds table by the transformations

3. Review the mass spectra for the expected compounds

4. Determine the most probable explanation for each expected compound

5. View the dealkylation product for an expected compound

6. Name and propose structures for the expected compounds

Filter the
Expected

Compounds
table by peak

area

 To filter the Expected Compounds table by the chromatographic peak areas

1. Click the Expected Compounds tab 

2. Check the number of compounds in the Expected Compounds table by pointing to the Expected 
Compounds tab.

3. Reduce the number of compounds to review by filtering the Expected Compounds table as follows:

a. From the application menu bar, choose View > Result Filters.

The Result Filters view opens.

b. In the left pane, select the Expected Compounds table.

c. In the right pane set up the following filters (Figure 34):

 Area (Max.) is Greater Than or Equal to 5e8 

 FISh Coverage is Greater Than or Equal to 10
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Figure 34. Filters for the Expected Compounds table

d. Click Apply Filters.

Only 13 compounds are now visible in the Expected Compounds table for the example result file 
(Figure 35).

Sort the
Expected

Compounds
table by the

transformations

 To bring the parent compound to the top of the Expected Compounds table

1. Click the Dealkylated column heading until the table is sorted in ascending order—that is, until all 
the compounds that are not the product of a dealkylation reaction move to the top.

2. Hold down the CTRL key and click the Transformations column heading until the table is sorted in 
ascending order by the Transformations (alphabetical and number).

This figure shows the Expected Compounds table sorted by the Dealkylated and Transformations 
columns. The parent compound, with no dealkylation reactions and no transformations, is at the top 
of the table.

Figure 35. Filtered Expected Compounds table sorted by the Dealkylated and Transformations columns

Go to the next topic to “Review the mass spectra for the expected compounds.” 
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Review the mass
spectra for the

expected
compounds

Use the Mass Spectrum view to view the isotopic pattern in the full MS scans for a selected compound 
and the FISh annotations in the compound’s fragmentation scans.

To review the mass spectra, see these topics:

• Inspect the isotope pattern in the full MS scan

• View the fragmentation scans

• FISh coverage score

Inspect the
isotope pattern in

the full MS scan

 To inspect the isotope pattern for a selected compound

1. Select the first row in the sorted Expected Compounds table (with omeprazole sorted to the first row 
as shown in Figure 35).

2. In the Mass Spectrum view, inspect the compound’s isotope pattern in the full MS scan.

This figure shows the isotope pattern for the protonated ion of omeprazole. 

Note  This tutorial uses the following terminology for isotope patterns:

• A0—The monoisotopic ion (typically the leftmost spectrum peak)

• A1—The M + 1 ion approximately one mass unit greater than the peak for the monoisotopic 
ion, for example, an ion where one 13C atom replaces one 12C atom

• A2—The M + 2 ion, approximately two mass units greater than the peak for the 
monoisotopic ion, for example, an ion where one 34S atom replaces one 32S atom and two 13C 
atoms replace two 12C atoms

• A3—The M + 3 ion, approximately three mass units greater than the peak for the 
monoisotopic ion, for example, an ion where one 34S atom replaces one 32S atom and one 13C 
atom replaces one 12C atom

A0 peak for the monoisotopic protonated ion

A1 peak for isotope with one carbon-13 atom
Two A2 peaks

One A3 peak
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This figure shows the resolution of the A2 isotopes at m/z 348.1.

The full MS scan shows the isotope pattern for the detected compound. Colored rectangles highlight 
the mass spectrum peaks (centroids) that match the theoretical isotope pattern.
Table 4. Color-coding for isotope patterns

Color Meaning 

( ) Lavender The labeled centroid is the monoisotopic mass of the expected adduct ion. The 
x-axis position and the width of the bar reflect the expected m/z value of the 
centroid and the user-specified mass tolerance, respectively. The Find Expected 
Compounds node searches for the monoisotopic peaks associated with the selected 
ion species, for example, [M+H]+1, [M+Na]+1, and so on. In this tutorial, the 
selected processing workflow only generates a list of expected compounds for the 
protonated adduct ion, [M+H]+1.

( ) Green The labeled centroid matches the delta mass and relative intensity of the 
theoretical isotope pattern. When you zoom in on the matching centroid, the 
x-axis position and width of the rectangle reflect the expected m/z value of the 
centroid and the user-specified mass tolerance, respectively. The y-axis position 
and height of the rectangle reflect the expected relative intensity of the centroid 
and the user-specified intensity tolerance, respectively.

( ) Red The expected centroid for this m/z value is missing or its intensity does not fall 
within the tolerance range for the theoretical isotope pattern.

( ) Light blue The centroid for this m/z value might be missing because its theoretical intensity is 
at the level of the measured baseline noise (determined by the Fourier transform 
mass spectrometry (FTMS) mass analyzer).

A2 peak for the (M + 2) ion with one sulfur-34 atom

A2 peak for the (M + 2) ion with two carbon-13 atoms 
40



View the
fragmentation

scans

The FISh Scoring node annotates centroids that match the m/z value of a theoretical fragment ion with its 
theoretical structure and color-codes the centroids in a fragmentation scan as follows: 

• Direct match—( ) Green

• Shifted match—( ) Blue

 To compare the fragmentation spectra of a metabolite and the parent compound

1. Select the first row in the sorted Expected Compounds table (with omeprazole sorted to the first row). 

2. In the spectral tree pane of the Mass Spectrum view, select an MS2, DDA scan, for example, 
scan #1650.

The annotated fragmentation scan appears in the right pane. 

Figure 36. Annotations for scan #1650 generated by the FISh Scoring node during data processing

3. Right-click the Mass Spectrum view and choose Show Library Spectra As Reference to turn this 
feature off.

4. Right-click the Mass Spectrum view and choose Use As Reference.

5. In the sorted Expected Compounds table (Figure 35), select row 6 (oxidation product). 

A mirror plot appears in the Mass Spectrum view. The MS2 spectrum for omeprazole is on the 
bottom and the MS2 spectrum for the metabolite is on the top.

Figure 37 shows a mirror plot with the data-dependent fragmentation scan for omeprazole set as the 
reference.

Note  The FISh Scoring node cannot calculate a FISh Coverage score for compounds that lack 
DDA scans.
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Figure 37. Mirror plot with omeprazole on the bottom and one of its metabolites on the top

FISh coverage
score

In a targeted workflow where you connect the Group Expected Compounds node to the FISh Scoring 
node, the FISh Scoring node creates a list of expected fragments for each found expected compound. It 
then attempts to match the fragment structures to the centroids in the fragmentation scans of the 
precursor ions. 

When only one fragmentation scan follows a precursor ion scan, the node calculates the FISh coverage 
score as follows:

where:

# matched centroids represents the number of matched centroids.

# used (matched + unmatched) centroids represents the number of centroids in the fragmentation 
scan that are above the user-specified signal-to-noise threshold (not skipped).

When a precursor scan is followed by more than one fragmentation scan, the node calculates a composite 
score as follows:

The FISh Scoring node annotates the centroids in the fragmentation scans with the matching fragment 
structures. It also provides a FISh Coverage score for compounds with DDA scans in the Expected 
Compounds table.

Tip  Use the color coded FISh fragments to elucidate the structure for the putative metabolites. 
Typically the smallest shifted and largest unshifted fragments help to localize the site of 
transformation.

FISh coverage score # matched centroids
# used centroids

------------------------------------------------------ 100=

FISh coverage score
per all scans# matched centroids 

per all scans# used centroids 
---------------------------------------------------------------------------------------------- 100=
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Determine the
most probable

explanation for
each expected

compound

 To display only the most probable explanation for each compound

1. If you have not already filtered the Expected Compounds table by the chromatographic peak area 
[Area (Max.)] and the FISh Coverage, do so now. See step 3 on page 29.

2. Sort the Expected Compounds table by the Calc. MW column in ascending order. 

3. For each replicated compound (same MW×RT dimensions), select the check box for the most 
probable explanation. In addition, select the check box for each unique compound.

When the application returns multiple explanations for the same compound (same MW×RT 
dimensions), consider the following criteria to determine the correct explanation:

• Compare the FISh Coverage score for each explanation. The probability that an explanation is 
correct increases as the FISh Coverage score increases.

• Compare the reaction pathway for each explanation. The correct explanation is often the one 
with the fewest steps. 

This figure shows the selection of the explanations with the higher FISh coverage score.

4. In the Result Filters view, click Add Property and select Checked from the list. 

5. Click Apply Filters.

The Expected Compounds table now displays only nine compounds.

Go to the next topic to “View the dealkylation product for an expected compound.” 
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View the
dealkylation

product for an
expected

compound

 To view the dealkylation product for a compound with additional transformations

1. In the filtered Expected Compounds table (sorted in ascending order by Calc. MW), select a 
compound that is the product of a dealkylation reaction and one or more transformations.

For example, select row 2 (C16 H17 N3 O2 S).

2. Click Show Related Tables at the bottom left of the result page.

3. Click the Expected Compounds per File tab. Then, select row 1 in the Expected Compounds per 
File table.

4. Click Show Related Tables at the bottom left of the result page.

5. Click the Related Structures tab.

The Related Structures table shows the dealkylation products for compounds with additional 
transformations.

Figure 38. Related structures table for dealkylation product

Go to the next topic, “Name and propose structures for the expected compounds.” 

Name and
propose

structures for
the expected

compounds

You can add names and structures for expected compounds to the result file. 

 To populate the Name and Structure columns in the Expected Compounds table

1. Sort the filtered Expected Compounds table in descending order by Area (Max.).

2. Select row 5 (Calc. MW 345.11423).

3. Click Show Related Tables. Then, click the Structure Proposals tab.

4. Right-click the empty Structure Proposals table and choose Structure Proposals > Add Structure 
Proposal.

Demethylation composition change
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Figure 39. Shortcut menu for the Structure Proposal result table

A new row with the formula and MW of the expected compound appears in the Structure Proposals 
table.

5. Double-click the row in the Structure Proposals table.

The Compound Annotation Editor opens to the Description page.

6. To assign a structure to this custom annotation, do one of the following:

• Click the Load Structure from Disk icon, , and open the Omeprazole.mol file that you 
copied to your processing computer. 

• Use the drawing tools to draw a structure. To open the Help for the Compound Annotation 
Editor, press the F1 key.

• If your computer has Internet access, click ChemSpider. When the search finishes, select a 
structure from the list.

The application checks whether the calculated exact mass of the structure matches the molecular 
weight and the elemental composition (if available) of the selected peak within the mass tolerance (for 
XIC trace creation) that you specified in the Find Expected Compounds node. 
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7. In the Name box, type Omeprazole. 

8. Run the FISh scoring algorithm as follows:

a. Select the Apply FISh Scoring check box.

b. Click Save.

The structure appears in the Structure column of the Structure Proposals table, and the FISh 
Scoring Queue opens. The application recalculates the FISh Coverage score and modifies the 
fragmentation spectra annotations by using the proposed structure.

9. In the Structure Proposals table, right-click the row for your new structure proposal and choose 
Structure Proposals > Use As Compound Annotation.

Omeprazole appears in the Name column of row 5 (MW 345.11471).

10. To view the structure in the Expected Compounds table, display the Structure column as follows:

a. Click the Field Chooser icon, .

b. Select the Structure check box.

11. If necessary, to restore the original processing results, right-click the newly annotated row and choose 
Reset Compound Annotation.

The application removes the structure and name annotations and restores the original FISh Coverage 
score.

Save or reset
the layout of

the result file

The layout of the result file includes the location of the graphical views, the columns and rows that you 
want to display in the result tables, the filter set, and the Group By and Filter By settings. 

 To save the current layout of the result file

With the result file selected as the active page, do one of the following:

• In the toolbar, click the Save the Currently Active Item icon, .

–or–

• From the menu bar, choose File > Save (save the currently active item).
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 To save the current layout of the result file to a layout file

1. With the result file selected as the active page, in the menu bar choose Window > Save Layout.

2. Name the layout and click OK.

 To restore the default layout to a result file

1. With the result file selected as the active page, in the menu bar choose Window > Reset Layout.

2. Click Yes to confirm the action.

Print reports Compound Discoverer reports are based on the result tables and their associated chromatograms and mass 
spectra.

Before you print a report, review the result table that you want to include in the report. Filter the table as 
described in “Determine the most probable explanation for each expected compound.”  Sort the table by 
the column of interest, for example, by retention time (see “Common layout modifications for the result 
tables and views” on page 23).

Follow these procedures to print reports: 

• To create a report by using the defined report template for the Expected Compounds table

• To print the report

• To export the contents of a report to a file

 To create a report by using the defined report template for the Expected Compounds table

1. On the result file page, click the Expected Compounds tab.

2. From the menu bar, choose Reporting > Create Report.

The Open Design Template dialog box opens.

3. Select the Expected Compounds No Graphs A4.cdReportTemplate file and click Open.

The application resolves the report and displays thumbnails in the Page Thumbnails pane to the left.

Note  For information about creating and editing your own custom report templates, refer to the 
Compound Discoverer 3.2 Reporting Quick Start, the reporting chapter in the Compound Discoverer 3.2 
User Guide, or the Help.

With the current reporting tool, you can add graphs for chromatogram traces and the MS1 and MS2 
spectra to the report template. You cannot add graphs for the statistical plots.
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 To print the report 

1. In the Current Page/Total Number of Pages box, check how many pages are in the report.

2. In the reporting toolbar, click the Print icon, , make the appropriate selections in the Print dialog 
box, including the print range and any advanced settings, and click OK. 

 To export the contents of a report to a file

1. In the reporting toolbar, choose Export > File Type.

2. Select the directory where you want to store the file, name the file, and click Save.

Trademarks Compound Discoverer and Q Exactive are trademarks, and Thermo Scientific, and Xcalibur are registered 
trademarks of Thermo Fisher Scientific Inc. in the United States. 

All other trademarks are the property of Thermo Fisher Scientific Inc. and its subsidiaries.
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