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Preface

How to Use This Guide

Purpose of
This Guide

Audience

Assumptions

Text Conventions

GeneMapper® Software 5 Installation and Administration Guide

This guide describes the procedures for installing, securing, and
maintaining the GeneMapper® Software 5.

Note: For instructions on analyzing sample data using the
GeneMapper® Software, see the appropriate applications getting
started guide for your fragment analysis chemistry as explained on
page 9.

This guide is written for laboratory personnel responsible for installing
and maintaining the GeneMapper® Software.

This guide assumes that you have a working knowledge of the
Microsoft® Windows® operating system.

This guide uses the following conventions:
* Bold indicates user action. For example:
Type 0, then press Enter for each of the remaining fields.

* [talic text indicates new or important words and is also used for
emphasis. For example:

Before analyzing, always prepare fresh matrix.

* A right arrow bracket ( » ) separates successive commands you
select from a drop-down or shortcut menu. For example:

Select File » Open » Spot Set.

Right-click the sample row, then select View Filter »
View All Runs.



User Attention
Words

Two user attention words appear in Life Technologies user
documentation. Each word implies a particular level of observation
or action as described below:

Note: Provides information that may be of interest or help but is not
critical to the use of the product.

IMPORTANT! Provides information that is necessary for proper
instrument operation, accurate chemistry kit use, or safe use of a
chemical.

Examples of the user attention words appear below:

Note: The size of the column affects the run time.

Note: The Calibrate function is also available in the Control
Console.

IMPORTANT! To verify your client connection to the database, you
need a valid Oracle® user ID and password.

IMPORTANT! You must create a separate Sample Entry Spreadsheet
for each 96-well plate.

GeneMapper® Software 5 Installation and Administration Guide



How to Obtain More Information

Related Portable document format (PDF) versions of this guide and the
Documentation documents listed below are available on the GeneMapper® Software
Documentation CD.

» GeneMapper® Software Getting Started Guides for
microsatellite analysis (PN 4403672), loss of hetereozygosity
(LOH) analysis (PN 4403621), AFLP® system analysis
(PN 4403620), SNaPshot® kit analysis (PN 4403618), and
SNPIlex® system analysis (PN 4403617) — Five guides that
explain how to analyze the application-specific example data
provided with the GeneMapper Software. The guides provide
brief, step-by-step procedures for the analysis of microsatellite,
LOH, AFLP® system, SNaPshot® kit, and SNPlex® system data
generated by compatible Life Technologies electrophoresis
instruments and Data Collection Software. The guides are
designed to help you quickly learn to use basic functions of the
GeneMapper Software.

+ GeneMapper® Software Quick Reference Guide (PN 4403615)
— Provides workflows for specific analysis types and lists
instruments, software, and analysis applications compatible with
the GeneMapper Software.

s GeneMapper® Software Reference and Troubleshooting
Guide (PN 4403673) — Provides reference information such as
theory of operation and includes troubleshooting information.

Note: For additional documentation, see “How to Obtain Support”
on page 10.

GeneMapper® Software 5 Installation and Administration Guide 9



Obtaining The GeneMapper® Software online help system describes the
Information from  GeneMapper Software and provides procedures for common tasks.
the Online Help  Access online help by clicking @ in the toolbar of the GeneMapper
window, selecting Help » Contents and Index, or pressing F1.

How to Obtain Support

For the latest services and support information for all locations, go to
www.lifetechnologies.com/support.
At the Support page, you can:

* Access to worldwide telephone and fax numbers to contact
Life Technologies Technical Support and Sales facilities

* Search through frequently asked questions (FAQs)
* Submit a question directly to Technical Support

* Order Life Technologies user documents, SDSs, certificates of
analysis, and other related documents

* Download PDF documents
* Obtain information about customer training
» Download software updates and patches

10 GeneMapper® Software 5 Installation and Administration Guide
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Safety Information

This section covers:

B Safety Conventions Used in This Document
B General Instrument Safety ................ ... ... ...

B Workstation Safety. ......... .. ... .. .. ..

GeneMapper® Software 5 Installation and Administration Guide
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Safety Conventions Used in This Document

12

Safety Alert
Words

Four safety alert words appear in Life Technologies user
documentation at points in the document where you need to be aware
of relevant hazards. Each alert word—-IMPORTANT, CAUTION,
WARNING, DANGER-implies a particular level of observation or
action, as defined below:

Definitions

A (O.\I[e]M] - Indicates a potentially hazardous situation that,
if not avoided, may result in minor or moderate injury. It may also be
used to alert against unsafe practices.

A WWZ.GUII[ed — Indicates a potentially hazardous situation that,
if not avoided, could result in death or serious injury.

A PLW[e]1F38 — Indicates an imminently hazardous situation
that, if not avoided, will result in death or serious injury. This signal
word is to be limited to the most extreme situations.

Examples

The following examples show the use of safety alert words:

ACAUTION MUSCULOSKELETAL AND REPETITIVE
MOTION HAZARD. These hazards are caused by potential risk
factors that include but are not limited to repetitive motion, awkward
posture, forceful exertion, holding static unhealthy positions, contact
pressure, and other workstation environmental factors.

AWARNING Do not attempt to lift or move the computer or
the monitor without the assistance of others. Depending on the
weight of the computer and/or the monitor, moving them may require
two or more people.

GeneMapper® Software 5 Installation and Administration Guide



General Instrument Safety

AWARNING PHYSICAL INJURY HAZARD. Use this

product only as specified in this document. Using this instrument in a
manner not specified by Life Technologies may result in personal
injury or damage to the instrument.

Moving and AWARNING Do not attempt to lift or move the computer or

Lifting the monitor without the assistance of others. Depending on the
Stand-Alone weight of the computer and/or the monitor, moving them may require

Computers and two or more people.

Monitors
Things to consider before lifting the computer and/or the monitor:

* Make sure that you have a secure, comfortable grip on the
computer or the monitor when lifting.

* Make sure that the path from where the object is to where it is
being moved is clear of obstructions.

* Do not lift an object and twist your torso at the same time.

» Keep your spine in a good neutral position while lifting with
your legs.

+ Participants should coordinate lift and move intentions with
each other before lifting and carrying.

* Instead of lifting the object from the packing box, carefully tilt
the box on its side and hold it stationary while someone slides
the contents out of the box.

GeneMapper® Software 5 Installation and Administration Guide 13



Workstation Safety

Correct ergonomic configuration of your workstation can reduce or
prevent effects such as fatigue, pain, and strain. Minimize or
eliminate these effects by configuring your workstation to promote
neutral or relaxed working positions.

ACAUTION MUSCULOSKELETAL AND REPETITIVE

MOTION HAZARD. These hazards are caused by potential risk
factors that include but are not limited to repetitive motion, awkward
posture, forceful exertion, holding static unhealthy positions, contact
pressure, and other workstation environmental factors.

To minimize musculoskeletal and repetitive motion risks:

* Use equipment that comfortably supports you in neutral
working positions and allows adequate accessibility to the
keyboard, monitor, and mouse.

 Position the keyboard, mouse, and monitor to promote relaxed
body and head postures.

14 GeneMapper® Software 5 Installation and Administration Guide



Chapter 1

Getting Started

This chapter covers:
B Start Here: Getting the Most Out of This Guide ......... 16
B For Applied Biosystems 3500 Series Genetic Analyzers... 17
B Oracle® Database License Agreement. ................ 18
B GeneMapper® Software Workflow ................... 19
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Chapter 1

Start Here: Getting the Most Out of This Guide

The GeneMapper® Software 5 Installation and Administration Guide
describes how to install the GeneMapper® Software 5 and manage
the software, database, and auditing functions.

Note: GeneMapper® Software 5 does not support autoanalysis on
any instrument platform.

Installation  To get the most out of this guide:

1.

Read through this chapter to familiarize yourself with the
Oracle® database licensing agreement.
Review the general installation requirements in Chapter 2:
* Installation overview workflow
+ Computer requirements and compatible operating systems
* Supported instruments and software applications
+ User account requirements

3. Install the GeneMapper® Software as described in Chapter 3.

4. Loginto and configure the GeneMapper® Software as described

in Chapter 3.

Administration Review the procedures for setting up and maintaining the:

GeneMapper® Software security settings
Password policies

Profiles and user accounts

Data tracking system

Audit map and audit history

Electronic Signature settings

Maintenance Review the procedures for using the Database Dashboard to:

16

Review database statistics
Export and import projects and supporting data

Maintain the GeneMapper® Software by backing up data and
allocating disk space

GeneMapper® Software 5 Installation and Administration Guide



Chapter 1

Troubleshooting  If you have trouble with the installation, see Appendix A. Be sure to
perform the troubleshooting procedures in the order given:

1. Read through the troubleshooting procedures starting on
page 162.

2. If you continue to have problems, complete the Troubleshooting
Checklist on page 170, then contact Technical Support

(page 10).

For Applied Biosystems 3500 Series Genetic
Analyzers

If you are installing the GeneMapper® Software on an Applied
Biosystems 3500 series genetic analyzer, refer to the user guide for
instructions for:

+ Starting the Data Collection services on the local computer

+ Installing the GeneMapper® Software on the same computer as
the Data Collection Software

Document Part number

Applied Biosystems 3500/3500xL Genetic Analyzer User 4401661
Guide

Applied Biosystems 3500 Dx/3500xL Dx Genetic 4401688
Analyzer User Guide

GeneMapper® Software 5 Installation and Administration Guide 17



Chapter 1

Oracle® Database License Agreement

About the The GeneMapper® Software uses an Oracle® database to store all

Database project-related data. In addition to serving as a common data
repository, the database provides user authentication, robust and
scalable data management, and flexible archive capabilities through
the utilities provided with the GeneMapper® Software.

Database Access Life Technologies does not support access to the Oracle® database
through any means other than the GeneMapper® Software.

User Access The version of the Oracle® database included with the GeneMapper®
Software is an embedded-license database. This license allows access
to the database for up to five named users at any one time. If you
want to accommodate more than five named users, you can purchase
either additional GeneMapper® Software licenses or additional
Oracle®-named user privileges and thereby honor Life Technologies
agreement with the Oracle® Corporation.

18 GeneMapper® Software 5 Installation and Administration Guide
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Chapter 2

ey Installation Requirements
and Software Compatibility

This chapter covers:

B OOVEIVIEW . .ottt et et e e 22
B Computer Requirements. . ........... ... .. .......... 23
B Instrument, Software, and Data Compatibility. . ......... 26
B User Account Requirements. .. ...................... 27
B GeneMapper® Software Installation DVDs. ............ 28
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Chapter 2

Overview
This chapter specifies the requirements for installing the
GeneMapper® Software 5.
Step See page
Verify that the computer meets requirements 23
Verify that you have Administrator privileges on the computer 27
Is a current version Export data from the current 30
of GeneMapper® —) database
Software installed? Yes
I o |
Perform a full installation 35
or or
Perform a client installation 48
Import data into the new database 30
54 and 55
Register and log in to the GeneMapper® Software

22 GeneMapper® Software 5 Installation and Administration Guide



Chapter 2

Computer Requirements

Computer Table 2-1 shows the computer specifications that Life Technologies
Configuration recommends for use with the GeneMapper® Software 5.

Even though you can install the GeneMapper® Software on a
computer containing the minimum supported RAM,

Life Technologies highly recommends using 4 GB of RAM (or
higher) for better performance.

Note: The following specifications are for the 3130 and 3730 series
instrument computer. The 310 instrument computer has less RAM
and HD capacity than the 3130 and 3730 series computer, so
performance may vary.

Table 2-1 GeneMapper® Software computer requirements

c Recommended Minimum Configuration#
omponent N .
Configuration Full Installation Client Installation
Computer | * Dell® OptiPlex® CE, Intel® | o Intel® Core™?2 Duo ¢ Intel® Pentium® 4
Core™?2 Duo Processor, Processor, Processor, 2 GHz
E8400/3.0 GHz E8400/3.0 GHz e 2 GB of RAM
¢ 4 MB of RAM, Non-ECC, e 4 GB of RAM e 10/100 NIC network
667 MHzDDR22 x1GB | o 10/100 NIC network card with RWU
e 320 GB SATA hard drive, card with RWU (internal)
3.0 Gb/s and 8 MB Data (internal) e Free disk space: 1 GB
Burst Cache ¢ Free disk space:
e 16X DVD +/- RW IDE 500MB on the boot
Combo Drive drive, 7 GB on the
* Free disk space: 500MB drive on whicg the
on the boot drive, 7 GB on GeneMapper
the drive on which the Software is installed
GeneMapper® Software is
installed
Monitor e 1280 x 1024 or higher pixel resolution
e 17-inch color monitor
Operating | ® Microsoft® Windows® 7 Professional operating system, Service Pack 1
System

¥ The memory and hard disk space requirements need to be considerably higher than the minimum configuration if
the product is deployed in a multi-user environment.

GeneMapper® Software 5 Installation and Administration Guide 23
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Chapter 2

Verifying that
Your Computer
Meets the
Minimum
Requirements

1. In the desktop, right-click Computer, then select Properties.

2.

Verify that your computer meets the minimum requirements for
the operating system, processor, and memory as shown in
“Computer Requirements” on page 23.

GeneMapper® Software 5 Installation and Administration Guide
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. . ;'Bj, + Control Panel » All Control Panel ltems » System - Search Ct

File Edit View Tools Help

@l
&
&
]

Control Panel Home

Device Manager
Remote settings
System protection

Advanced system settings

See also
Action Center
Windows Update

Performance Information and
Tools

View basic information about your computer

Windows edition

Windows 7 Professional

Copyright © 2009 Microsoft Corporation. All rights reserved.

Operating System
(09)

Service Packl

Get more features with a new edition of Windows 7

Systemn
Manufacturer:
Model:
Rating:
Processor:
Installed memory (RAM):
Systemn type:

Pen and Touch:

Dell support
Website:

L Latest Service Pack
installed

Dell j Computer model

Optiplex XE

a Your Windows Experience Index needs to be refreshed
' — Microprocessor
Intel(R) Core(TM)2 Duc CPU E2400 @ 3.00GHz 2.99 GHztype and speed

4,00 GB (3.25 GB usable)
32-bit Operating System Installed memory
Mo Pen or Touch Input is available for this Display

Online support

Computer name, domain, and workgroup settings

Computer name:
Full computer name:
Computer description:

Workgroup:

Windows activation

Windows is activated

OPTIPLEX-XE
OPTIPLEX-XE
Optiplex XE Series Instrument & Application Computer
WORKGROUP

Product ID: 00371-0EM-8992671-00524
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Chapter 2

Instrument, Software, and Data Compatibility

Compatibility  Table 2-2 shows the version(s) of the Data Collection Software,
Matrix Windows operating system, and sample data files that are supported
by the GeneMapper® Software for specified instruments.

Note: The columns in Table 2-2 are described on page 27.

Table 2-2 Compatibility matrix

Genetic Analysis Compatible Data Collection Software Sample Data
Instrument and Operating System Compatibility
_ Applied Biosystems e Data Collection v2.0 o Sample files
3500/3500xL. * Windows 7 Professional, 32-bit, SP1 ¢ Co-installation
Genetic Analyzer
e Data Collection v4.0 e Sample files
Applied Biosystems e Windows 7 Professional, 32-bit, SP1 e Co-installation
| 3730/3730x/
= DNA Analyzer

h Applied Biosystems
L &= 3130/31300

Genetic Analyzer

H;&J Applied Biosystems

3100 Genetic
Analyzer

Applied Biosystems
310 Genetic

EH_I: Analyzer

26 GeneMapper® Software 5 Installation and Administration Guide



Chapter 2

Compatible Data Collection Software and Operating System Column

This column displays the version(s) of the Data Collection Software,
Windows operating system, and any associated service pack(s)
supported by the GeneMapper® Software for the specified
instrument.

Sample Data Compatibility Column

This column indicates the methods by which the GeneMapper®
Software can process sample data produced by the associated
combination of instrument, Data Collection Software, and Windows
operating system.

* Sample Files — The software can import sample files created by
the specified combination of the Data Collection Software and
Windows operating system.

* Co-installation — The software can be installed on the same
computer that contains the specified combination of the Data
Collection Software and Windows operating system.

PDF File Reader To open the user documentation included on the GeneMapper®
Software Documentation CD, use the Adobe® Acrobat® Reader®
software available from www.adobe.com.

User Account Requirements

Log On  To install the GeneMapper® Software, you must:

Requirements  Have administrator privileges (complete and unrestricted
access) on the local computer.

Note: This level of access is required only to install the
GeneMapper® Software. After it is installed, you can run
the GeneMapper® Software without administrator privileges.

Verifying that 1. In the desktop, select Start » Control Panel.
Your User
Account Meets
the Requirements

2. In the Control Panel window, double-click User Accounts.

GeneMapper® Software 5 Installation and Administration Guide 27
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3. In the Users tab of the User Accounts dialog box, verify that the
user account you are using belongs to the Administrators group.
If you are performing a full installation, verify that the domain is
the same name as the computer name.

Example:

Users | Advanced

Use the list below to grant or deny users access to your computer,
and to change passwords and other settings.

Users for this computer:

User Name Domain Group

Y Administrator

&3 INSTR-ADMIN OFTIi EA-AEG Tzers

3 INSTR-USER OPTIFLEX-XE6 Users Belongs to the
Administrators
Domain is the same
as the computer

Add... ] [ Remove ] [ Properties name

Password for Administrator

To change your password, press Ctrl-Alt-Del and select Change
Password.

Reset Password...

4. Click OK.

GeneMapper® Software Installation DVDs

Before installing/upgrading the GeneMapper® Software, verify that
you have the appropriate installation DVD(s).

Table 2-3 GeneMapper® Software installation DVDs

If you are
performing a ... Use the DVD ...

A full installation GeneMapper® Software Full Installation

A client installation GeneMapper® Software Installer for Client

28 GeneMapper® Software 5 Installation and Administration Guide



Performing a New Installation
of the GeneMapper® Software

This chapter covers:
B OOVEIVIEW . oottt e e et e 30

B Exporting GeneMapper® Software from a Windows XP
Computer ...t e 30

B Importing GeneMapper® Software to a

Windows 7 Computer ................ciiniinain.... 30
B Determining Your Installation Options . ............... 32
Section 3.1: Full Installation Procedures................ 35
B Instrument Configuration Procedures ................. 36
B Stand-alone Configuration Procedures. . ............... 43
Section 3.2: Client Installation Procedures .............. 48
B Client Configuration Procedures ..................... 48
Section 3.3: Software Login Procedures................. 53
B Registering the Software After a New Installation . ...... 54
B Logging In to the Software for the First Time After a New

Installation ......... ... .. .. . .. . ... 55
B Logging In to the Database Dashboard for the First Time.. 57
B What Next?. . ... e 58
B Logging In to and Out of the Software ................ 59
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Chapter 3

Overview

This chapter describes how to perform a new installation of the
GeneMapper® Software on a Windows 7 computer. To perform a
new installation, you cannot have a previous version of the
GeneMapper® Software on your computer.

Exporting GeneMapper® Software from a
Windows XP Computer

To export GeneMapper® Software data from a Windows XP

computer:

If the GeneMapper® Software
Configuration is

e Stand-alone (not co-installed
with Data Collection software)

e (Co-installed on a 3500 Series
computer

e Co-installed on a 3730 Series,
3130 Series, 3100, or 310

computer

Follow the procedure in

Appendix C, Migrating Data Using |
the GeneMapper® Database
Utility Wizard

Appendix D, Migrating Data
Manually

Importing GeneMapper® Software to a Windows 7

Computer

30

To import GeneMapper® Software data to a Windows 7 computer:

If the GeneMapper® Software
Configuration is

Follow the procedure in

e Stand-alone (not co-installed
with Data Collection software)

e Co-installed on a 3500 Series
computer

Appendix C, Migrating Data Using
the GeneMapper® Database
Utility Wizard
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If the GeneMapper® Software
Configuration is

e
Chapter 3

Follow the procedure in

Co-installed on a 3730 Series,
3130 Series, 3100, or 310
computer

Appendix D, Migrating Data
Manually

GeneMapper® Software 5 Installation and Administration Guide
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Chapter 3

Determining Your Installation Options

Your installation options depend on the type of computer on which
you are installing the software:

* Instrument computer (connected to the instrument)

+ Stand-alone computer (not connected to the instrument)

Table 3-1 GeneMapper® Software installation options

Computer Description See page

Instrument: 36
Local computer

FullInstallation
only (software GeneMapper® software

and database +
se) GeneMapper® database Instrument
Data
collection
software

The Data Collection Software and the GeneMapper® Software are
installed on the same computer.

In this configuration, you can use the GeneMapper® Software to:

e Add sample files and studies to a project from a local Data
Collection Software database.

* Perform manual analysis of the project or study.

32 GeneMapper® Software 5 Installation and Administration Guide



Chapter 3

Table 3-1 GeneMapper® Software installation options

Computer Description See page
Stand-alone: 43
Client Local computer
Installation | GeneMapper® software |
(software only)

Data
transfer
Remote computer Data | Remote
GeneMapper® software | |transfer| CCMPUter
+ — Instrument
GeneMapper® database co:?:;gon
HOST software
The Data Collection Software and the GeneMapper® Software are
installed on separate computers.
In a stand-alone configuration, you can use the GeneMapper®
Software to:
e Add sample files and studies to a project from a remote Data
Collection Software database.
e Perform manual analysis of the project or study.
Stand-alone: 48
Local computer Data Remote
FullInstallation GeneMapper® software | |transfer | Computer I—
(software and + p— [ Data Instrument
database) GeneMapper® database collection
HOST software

The Client GeneMapper® Software can be installed on multiple client
computers. The Full GeneMapper® Software is installed on one
computer separate from the client computers. The Data Collection
Software is installed on a computer separate from the client
computers.

In a client configuration, you can set up the Client GeneMapper®
Software to:

e Obtain sample files from the remote Data Collection Software
database.

e Store sample files, panel and bin definitions, analysis methods, size
standards, table and plot settings, and projects on the
GeneMapper® Software instrument computer.
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Full Installation Procedures

This section covers:
B Instrument Configuration Procedures ................. 36

B Stand-alone Configuration Procedures. . ............... 43

Note: To perform a client installation, go to Section 3.2, “Client
Installation Procedures,” on page 48.

IMPORTANT! Be sure you use the GeneMapper® Software Full
Installation DVD when performing the installation procedures
described in this section.
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Instrument Configuration Procedures

Installation Tasks
for an Instrument
Configuration

36

Install the instrument configuration if the Data Collection Software is
installed on the local computer.

Local computer

GeneMapper® software
+
GeneMapper® database Instrument

Data
collection
software

Figure 3-1 Example of an instrument configuration

If you do not have the Data Collection Software on the computer, do
one of the following:

* Install the Data Collection Software before proceeding
* Install the stand-alone configuration (see page 43)

Installing the GeneMapper® Software in an instrument configuration
requires that you:

Task See page

1. Export from the database on the Windows XP computer:

— 3500 Series computer . 189
— 3730 Series, 3130 Series, 3100, or 310 computer 193
2. Start the Data Collection services on the computer. 37
3. Install the GeneMapper® Software on the computer. 39
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Before you install the GeneMapper® Software, start the
Data Collection services on the local computer.

Note: For information on starting the Data Collection services for

the 3500 series genetic analyzers, refer to the instrument user guide.

1. Select Start » All Programs » Applied Biosystems »
Data Collection » Run <Data Collection version>, where
<Data Collection version> is one of the following:

* 3730/3730x! Data Collection v3.1
* 3130/3130x/ Data Collection v3.1

After the Service Console opens, wait until all four symbols
change to green squares.

Service Console

==

Messaging Service

Data Service

Instrument Service

Viewer

©
®
®
@

Service Console (ol ® =
Messaging Service
Data Service
Instrument Service
Viewer

Note: If the services do not start automatically, click Start All.

2. If the Data Collection Software requires a password, a login
dialog box opens. Type the Login Name and Password, then

click OK.

Note: If you do not know the Login Name or Password, contact
the administrator.

37
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3. Verify that Data Service started without errors:

a. In the Service Console, right-click the square next to Data
Service and select Show Console to display the Data
Service output window.

Service Console [oll® =

Messaging Service

— Right-click here

Start

Data Service

Stop

Instrument Service

Show Console

Viewer

Restart All Stop All

b. Verify that no errors are displayed in the lower pane of the
window, then close the Data Service output window.

|| Data Service output B
getCurrentStatusTypes. ..

08:49:13.411 For testing only: ICFGetManua
Dakar, instrumentTypeNams= ga3100-Avant
getCurrentStatusTypes. ..

08:49:13.973  Spatial Run Data Managsr bean
08:49:13.989 WARNING: No valid spatial cal
Spectral Pun Data Manager bzan has bsen cre
D8:49:18.887
08:49:33.910
08:49:48.933

No errors
displayed
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To install the GeneMapper® Software on the same computer as
the Data Collection Software:

. Insert the GeneMapper® Software Full Installation DVD into

the DVD drive to start the installer.
If the installer does not start automatically:
a. Right-click Computer and select Explore.

b. Expand the DVD drive, then select the GeneMapper 5
folder to display the contents.

c. Double-click &= GeneMappers5 to start the installer.

. Be sure that the Data Collection services are running

(see page 37). Close all other applications and windows, then
click OK to close the following message:

GeneMapper- Installshield Wizard ==

i i 1 Leave Data Collection Application Running on the Data Cellection
QW' system before proceeding with the installation.

3. In the Welcome window, click Next.

4. Review the installation requirements status, then click Next.

5. Read the release notes, then click Next.

GeneMapper® Software 5 Installation and Administration Guide
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6. If you want to install the GeneMapper® Software to a drive
different from the default drive, select the destination folder:

Note: We recommend installing the GeneMapper® Software on
the E drive when co-installing the GeneMapper® Software on
the same computer as the Data Collection Software.

a. Confirm that the boot drive has at least 200 MB of
available free space.

b. Select a destination folder with at least 7 GB of free space,
then click Next.

GeneMapper Software v5.0 ﬂ

Choose Destination Location
Select a destination folder where Setup will install the software
application.

GeneMapper® Software 5

- Setup will inztall GeneM apper software in the following folder. To
} inztall in this folder, click Nest. Othenwize, select a different folder
{1\

( A

Gy
i,
17

Destination Folder:

£
L%

o
.\.,
‘? ﬁ'\zlE:\AppliedBiosystems [ Available free space 126 GE) j
ﬁiﬁf 4
<

AR OB

EEERIE

< Back Cancel

Note: On 3500 Series computers, the installation prompts you
to import the database that you exported from the Windows XP
computer. On 3730 Series, 3130 Series, 3100, or 310 computers,
the installation does not prompt you to import; you must
manually import the database contents from the Windows XP
computer (see 193).

7. On 3500 Series computers only: To import data you exported
from the GeneMapper Windows XP computer:

a. Click Yes in the Import Data dialog box.
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F ™
Import Data - = D R — |
— I ——

:] Do you want to import data from a previous GeneMapper installation?

b. Select the version you are importing in the Setup Type
window, then click Next.

GeneMapper Software v5.0 3]

Setup Type
GeneMapper® Software 5 Choose the setup type that best suits your needs.

Please spacily the version of the GeneMapper data to import:

[ <Back [ New> | [ Cancel |

8. View the amount of disk space that is preallocated for the
GeneMapper® Software database, then click Next.

Note: The amount of disk space that is preallocated varies
according to your computer configuration.

9. Review the settings, then click Next to start the installation.

IMPORTANT! During installation, DOS commands are executed
and the DOS window may open. Do not delete, close, or click
the DOS window. If you do click it, press the Esc key.
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10. After the installer completes the installation, it displays an
InstallShield Wizard Complete window. Be sure to stop the Data
Collection services before restarting your computer:

a. In the Service Console, click Stop AlL

Service Consele [ @ =3
Messaging Service
Data Service
Instrument Service
Viewer
‘ Start Al Restart All Stop All

b. Remove the installation DVD from the drive.

c. In the InstallShield Wizard Complete window, select Yes, I
want to restart my computer now, then click Finish.

11. Go to Section 3.3, “Software Login Procedures,” on page 53.

GeneMapper® Software 5 Installation and Administration Guide



Chapter 3

Stand-alone Configuration Procedures

Installation Tasks
for a Stand-alone
Configuration

Installing the
Stand-alone
Configuration
of the
GeneMapper®
Software

Install the stand-alone configuration on a computer that does not
contain the Data Collection Software.

Local computer Data Remote
GeneMapper® software | |transfer| COmputer
+ —
Dat Instrument
GeneMapper® database colleacta;on
HOST software

Figure 3-2 Example of a stand-alone configuration

Installing the GeneMapper® Software as a stand-alone configuration
requires that you:

Task See page
Export the database using the GeneMapper® Database 189
Utility Wizard
Install the GeneMapper® Software on the local computer. 43

To install the GeneMapper® Software on a computer separate
from the Data Collection computer:

1. Insert the GeneMapper® Software Full Installation DVD into
the DVD drive to start the installer.
If the installer does not start automatically:
a. Right-click Computer and select Explore.

b. Expand the DVD drive, then select the GeneMapper5
folder to display the contents.

c. Double-click €£) GeneMappers5 to start the installer.

Wy
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2. Close all other applications and windows, then click OK to
close the following message.

[~ I
GeneMapper Software v3.0 “ L e— M

p

[ "-.I Before proceeding with the installation, please close all running
" applications and its windows
But if Data Collection application is installed in this system, please

ensure that it is running.

3. Review the installation requirements status, then click Next.

4. Select Stand-alone for type of installation, then click Next.

GeneMapper Software v5.0 @

Setup Type
GeneMapper® Software 5 Chooze the setup type that best suits your needs.

Femote auto-analysiz option will inztall the auto-analysiz manager

utility to automatically analyze data collected from D ata Collection

zyztem. |f you don't have a Data Collection spstem available, you
; should ch

tand-alone option.
o
/ Ki )

~ ~) Remote Autoanalysis
* Qg i
R

L

[ < Back [ Mext » ][ Cancel

F=

5. Read the release notes, then click Next.

6. If you want to install the GeneMapper® Software to a drive
different from the default drive, select the destination folder:

a. Confirm that the boot drive has at least 200 MB of
available free space.
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b. Select a destination folder with at least 7 GB of free space,

then click Next.

-
GeneMapper Software v5.0

S

Choose Destination Location

Select the folder to store the installed application.

Setup will inztall Genet apper Software +5.0 in the following folder.

Genetd apper Software.

Destination Folder

C:\AppliedBiosystemsh,

N InstallS hield

To install Genebd apper software in this folder, click Mext. Tao install Genebapper 5 oftware
I in a different folder, click Browse and navigate to the folder that you want to install the I

Browse...

[ < Back [

J |

Mext > Cancel ]

computer:

To import data you exported from the GeneMapper Windows 7

a. Click Yes in the Import Data dialog box.

-

-
Import Data
e — —

o |

:I Do you want to import data from a previous GeneMapper installation?

b. Select the version you are importing in the Setup Type

window, then click Next.

GeneMapper® Software 5 Installation and Administration Guide

45



Chapter 3

GeneMapper Software v5.0 3]

Setup Type
GeneMapper® Software 5 Choose the setup type that best suits your needs.

Please spacily the version of the GeneMapper data to impart:

(£ D) o o

L /i

AR s

[ < Back [ MNext > ][ Cancel

8. (Optional) Allocate space for the GeneMapper® Software
database, then click Next.

IMPORTANT! The minimum allocation for the install drive is
3 GB. If you want to increase the drive space allocation,
increase it in increments of 5 GB.

r

GeneMapper Saoftware v5.0 &J

DriveSpace Configuration

GeneMapper® Software 5

Allocate databaze storage space for each drive. This step is
optional. Y'ou can also use Database Dazhboard to do the
allocation after installation.

~

|

AR 2R

Select a diive to allocate space and then use the "+ and "'
buttons to allocate space in 5 GB unitz. The install drive haz a
minimum allocation of 3 GB. “When all of the drives are configured,
select Next to continue.

Dirive: Allocated Space: Free Space:
o 33 GB Available

Total Allocated: 3GB  Total Free: 83 GB

<Back [ MNest> |[ Cancel

Note: You can allocate more drive space later using the
Database Dashboard. See “Allocating Additional Disk Space”
on page 155.
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9. Read the current settings, then click Next to start the
installation.

IMPORTANT! During installation, DOS commands are executed
and the DOS window may open. Do not delete, close, or click
the DOS window. If you do click it, press the Esc key.

10. In the InstallShield Wizard Complete window, select Yes, I
want to restart my computer now, remove the installation
DVD from the drive, then click Finish.

11. Go to Section 3.3, “Software Login Procedures,” on page 53

GeneMapper® Software 5 Installation and Administration Guide 47



Chapter 3

Client Installation Procedures

Client Configuration Procedures

Stand-alone
Client
Configuration

Installation Tasks
for a Stand-alone
Client
Configuration

48

Install the client configuration on computers that share one central
GeneMapper® Software database. You can install the GeneMapper®
Software clients as a stand-alone configuration.

In stand-alone configuration, the GeneMapper® Software client
does not interact with the Data Collection Software.

You can use the stand-alone client to:

* Add sample files from a remote Data Collection Software
database to a project, then perform manual analysis of the
project.

+ Add sample files from the GeneMapper® Software to a project,
then perform manual analysis of the project.

Local computer

| GeneMapper® software |

Data
transfer
Remote computer Data Remote
GeneMapper® software | |tyansfer| COMPUter
+
Dat Instrument
GeneMapper® database colleacgon
HOST software

Figure 3-3 Example of stand-alone client configuration

To install the GeneMapper® Software as a stand-alone client
configuration, perform the following tasks:

See
Task page
1. Obtain the name of the GeneMapper® Software instrument 49
computer.
2. Install the GeneMapper® Software client on the local computer. 50
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When installing the GeneMapper® Software clients, you need the
name of the GeneMapper® Software instrument computer.

1.
2.

3.

Right-click Computer in the desktop and select Properties.

Locate the full computer name. You will need to enter the name
when you install the GeneMapper® Software.

Note: The full computer name is the host name.

Computer name, domain, and workgroup settings

Computer name; OPTIPLEX-XE
Gull computer name: OPTIPLEX-@
Computer description: Optiplex XE Series Instrument & Application Computer
Workgroup: WORKGROUP
Close the dialog box.
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Installing

the Client
Configuration
of the
GeneMapper®
Software

Insert the GeneMapper® Software 5 Installer for Client DVD
into the DVD drive to start the installer.

If the installer does not start automatically, then:

Q

. Right-click Computer and select Explore.

b. Expand the DVD drive.

c. Select the GeneMapper S folder to display the contents.
d

. Double-click &3 GeneMappers5 to start the installer.

In the Welcome window, click Next.

3. Review the installation requirements status, then click Next.

Type the instrument computer name (host name or full computer
name) for the GeneMapper® Software database computer (see
page 49), then click Next.

GeneMapper Saoftware v5.0 &J

Enter Text
. i

“Y'ou should provide a valid Genebapper D atabase Server Mame below. [F you don't have the
Genetdapper Database Server installed yet, You can still proceed your client installation and

Please enter information in the figld below.

install the server later. Genekd apper Client requires a valid Geneb apper D atabase Server in
order to function properly.

| < Back " Mest » || Cancel |

. After the installer establishes a connection with the

GeneMapper® Software instrument computer, click OK to
continue.

Select Stand-alone for the type of installation:

. Read the release notes, then click Next.
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8. If you want to install the GeneMapper® Software to a drive
different from the default drive, select the destination folder:

a. Confirm that the boot drive has at least 200 MB of
available free space.

b. Select a destination folder with at least 7 GB of free space,

then click Next.
GeneMapper Saoftware v5.0 &J
Choose Destination Location ‘
Select the folder to store the installed application. "’M

Setup will inztall Genet apper Software +5.0 in the following folder.
To install Genebd apper software in this folder, click Mext. Tao install Genebapper 5 oftware

[l in a different folder, click Browse and navigate to the folder that you want to install the I
Genetd apper Software.

Destination Folder

C:\AppliedBiosystemsh,

[ < Back [ Mext » ][ Cancel ]

9. Read the current settings, then click Next to start the
installation.

IMPORTANT! During installation, DOS commands are executed
and the DOS window may open. Do not delete, close, or click
the DOS window. If you do click it, press the Esc key.

10. In the InstallShield Wizard Complete window, click Finish.

11. Go to Section 3.3, “Software Login Procedures,” on page 53.

Note: To import data from a previous version of the software after
you log in, see Appendix D, Migrating Data Manually,
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Software Login Procedures

This section covers:

Registering the Software After a New Installation ... .... 54
Logging In to the Software for the First Time After a New

Installation ......... ... .. .. i 55
Logging In to the Database Dashboard for the First Time.. 57
What Next?. .. ... 58
Logging In to and Out of the Software ................ 59
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Registering the Software After a New Installation

Register the software the first time that you start the software.

Note: If you cannot to register the software as described, see
Appendix A on page 161.

1. In the desktop, double-click @ GeneMapper5 or
select Start » All Programs » Life Technologies »
GeneMapper » GeneMapperS5.

2. Complete the Registration dialog box:

T GeneMapper Soﬂwam M

Product Registration

‘Your Name: |

QOrganization:

Registration Code:

Note: The registration code is on the registration card packaged
with the software. Keep your registration code where you can
retrieve it easily. If you need to reinstall the software, you will
be prompted for the registration code.

3. Click OK.
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Logging In to the Software for the First Time
After a New Installation

1. Complete the Login to GeneMapper dialog box:
a. Use the default user name gm.
b. Type the password password.
c. Click OK.

-
™ Login to GeneMapper Software 5 I u

‘GeneMapper® Software 5

User Mame: |gm -

Password: | esssssss

I Database Host: | BRO143 -
AR AR e © 2012 Applied Biosystems. All Rights Reserved.
‘ [ Mew Host... H Delete Host H Default Host ]
=

2. Click OK when the software prompts you to change the
password.
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. Change the password:

a. Type a new password.
b. Retype the new password to confirm.
c. Click OK.

Note: Type a password that is 6 to 10 alphanumeric characters.

IMPORTANT! Keep the new password for the default user gm
where you can retrieve it easily. If you forget or lose your
password for the default user gm, it is not possible for

Life Technologies to retrieve it.

. Read the license agreement, then click Yes if you agree with the

terms.

. Review the license agreement and product warranty. You can:

* Click Decline to quit the application.

* Click Service to bypass the agreement and proceed to the
Project window.

IMPORTANT! You can click Service (and bypass the
agreement) up to three times before you are locked out of
the software. After you make this selection one or two
times, the license agreement and product warranty are
displayed the next time that you log in to the software.

* Click Print to print the agreement.

* Click Accept to accept the terms of the agreement and open
a new, untitled Project window.

6. Ifnecessary, see the “Creating a User Account” on page 89 for

instructions on adding users.
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Logging In to the Database Dashboard for the
First Time

Use the following procedure to log in to the Database Dashboard for
the first time after performing a new full installation of the
GeneMapper® Software.

To log in to the Database Dashboard for the first time:

1. Select Start » All Programs » Life Technologies » Database
Dashboard » Dashboard.
2. Complete the Login to Dashboard dialog box:
a. Type the password password.
b. Click OK.

3. Click OK when the software prompts you to change the
password.
4. Change the password:
a. Type a new password.
b. Retype the new password to confirm.
c. Click OK.

Note: Type a password that is 6 to 10 alphanumeric characters.

IMPORTANT! Keep the new password for the Database
Dashboard where you can retrieve it easily. If you forget or lose
your password for the Database Dashboard, it is not possible for
Life Technologies to retrieve it.

5. See “About the Dashboard Software” on page 149 and the
GeneMapper® Software Online Help for more information
about using the Database Dashboard to maintain the
GeneMapper® Software database.
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What Next?

For user instructions, refer to the:
+ GeneMapper® Software Getting Started Guides
 GeneMapper® Software Online Help

To access the online help from the GeneMapper® Software, do
one of the following:

— Click & in the toolbar
— Select Help » Contents and Index
— Press F1
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Logging In to and Out of the Software

Logging In 1. In the desktop, double-click @ GeneMapper5 or select
Start » All Programs » Life Technologies »
GeneMapper » GeneMappers5.

2. Select your user name from the User Name drop-down list. If
your name is not listed, type it in.

™ Login to GeneMapper Software 5 I M
User Mame: |gm -

I ,"21‘; /> Password: (esssssss

& AT
I /;/aq' ¢ ! Database Host: |BRO143 =

iﬁ;ﬂ-\:{ I-'{.F {/ | J

-«
I -
fu Yo © 2012 Applied Biosystems. All Rights Reserved.

‘ [ Mew Host... ] [ Delete Host ] [ Default Host ]

If you do not have a user name, request a user name and/or
password from the administrator. If you are the administrator,
use:

e User Name: Administrator
e Password: Administrator

If your password is pre-expired, the software prompts you to
create a password after you click OK.

3. Type your password.

IMPORTANT! Life Technologies recommends changing the
password for the Administrator user account after installing the
software.
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Connecting to a
New Host

60

4. Click OK.

Note: If you unsuccessfully attempt to log in to the software
more times than allowed by your password policy, your account
becomes suspended. To activate a suspended user account,
either wait the time specified by the policy associated with the
account, or ask your administrator to reactivate the account (see
“Activating, Deactivating, and Suspending User Accounts” on
page 93 for more information).

1. Click New Host on the Login to GeneMapper dialog box.

™ Login to GeneMapper Software 5 I @
User Mame: |gm -

£y

I ,J‘ﬁ.f; /> Password: essssses
y (o
I ’{f/gﬂ ! [l‘ Database Host: |[BRO143 ]
-

I o ae

fu Yo © 2012 Applied Biosystems. All Rights Reserved.
‘ ([ Mew Host... D[ Delete Host ] [ Default Host ]

2. Complete the fields in the New Host dialog box to connect to a
GeneMapper® Software database on another computer:

E Mew Host B @

Enter new GeneMapper host information:

Host Mame: |

Machine Type: Stand-alone -
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a. Inthe Host Name field, type the instrument computer name
or IP address of the database host.

The window displays the new database host and its user
names list. If the GeneMapper® Software cannot connect to
the database host you entered, the error message “You have
entered an invalid host” is displayed. Click OK to exit, then
retype the database host information.

b. Select the appropriate machine type.
c. Click OK.

IMPORTANT! If] at any time, the network connection is
interrupted or lost, the GeneMapper® Software becomes
unusable. To restore the connection, exit the software, then
restart it using a user account that belongs to the Administrator
user group.

Logging Out  You can close the GeneMapper® Software in one of three ways:
* Select File » Logout
+ Select File » Exit
* Click (3 (the Close button).
When you log out of the GeneMapper® Software with a GeneMapper
project that has unsaved changes, the software prompts you to save or

discard the changes you made since the last time you updated the
project.

Save Project g|

& [ro you want to save changes?

If you close the GeneMapper® Software using the File » Logout
command, the login window reopens after you select either “Yes” or
“No.” GeneMapper® Software closes completely if you use either the
File » Exit command or the Close button.
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Managing Database Security
and User Access

This chapter covers:

B About GeneMapper® Software Security ............... 64
B Configuring the Password Policies ................... 66
B Managing User and Security Groups. . ................ 70
B Managing Applications ............. ... .. .. .. ... .. 78
B Managing Profiles .......... .. .. .. .. . ... 78
B Managing User Accounts. .. .........c.oovuvenennen .. 88
B Viewing the Security Report ........................ 94
B Exporting and Importing the Security Settings .......... 96
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About GeneMapper® Software Security

Security System  The GeneMapper® Software uses two applications to secure and
Components monitor the data it stores:

+ Security Manager
* Audit Map Configuration Software

This chapter describes how to use the Security Manager utility to
control user access to the GeneMapper® Software. For more
information on monitoring use and modification of data stored by the
GeneMapper® Software, see Chapter 5, “Managing the Auditing and
Electronic Signature Systems.”

About the The Access Control Administration Software restricts user access to
Access Control the functions of the GeneMapper® Software and to the data it stores.
Administration Using the Security Manager, you can create or remove user accounts,
Software control user access to functions of the GeneMapper® Software, and
define general policies for password use.

IMPORTANT! Use of the Access Control Administration Software is
not optional.

Note: The Access Control Administration Software is an integral part
of the GeneMapper® Software that cannot be deactivated or
uninstalled.

Starting the  IMPORTANT! Only users that belong to the Administrator user group
Access Control (see page 83) can use the Access Control Administration Software.

Administration

Software

IMPORTANT! After the installation of the software, the first person
to log in must do so using the default user account (user name: gm;
password: password), then configure user names for his or her
department.

1. Start and log in to the GeneMapper® Software (see “Logging In
to and Out of the Software” on page 59).

2. In the GeneMapper window, select Tools » Security Manager.
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3. In the AdminToolAcc dialog box, type a user name and

password for a user account with administrative privileges, then

click OK.

The following tasks must be performed to set up the Security System

Software for the GeneMapper® Software.

Start the Access Control Administration Software (see page 64).

i

Configure the password policies (see page 66).

_

Can you use the default profiles provided with the
installation? (see page 84).

—

4

Create custom security profiles for your users (see page 81).

¥

Create user accounts for all users of the GeneMapper® Software

-~

(see page 89).

¥

If you just installed the GeneMapper® Software, change the
passwords for the default Administrator and gm user accounts
(see page 92).

i

Exit the Access Control Administration Software (see page 64).

Perform the tasks in the following table to maintain the security
system for the GeneMapper® Software.

Frequency Tasks

As needed e Create, modify, or retire user accounts as needed

(see page 89).

(see page 81).

e Create, modify, or retire security profiles as needed
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Configuring the Password Policies

About Password
Policies

Setting the
Password
Policies

66

The password policies system of the Access Control Administration
Software is a set of rules that control various aspects of password use
and how the software responds to failed login attempts. The Access
Control Administration Software applies the password policies
settings uniformly to all user accounts, including those with
administrative privileges. Configuring the password policies system
is not optional. We recommend that you configure the password
policies immediately after you install the GeneMapper® Software,
and review the policies every six months as part of routine
maintenance.

1.

Start the Access Control Administration Software (see page 64).

Select Settings » Password Policies.

3. In the Password Policies dialog box, configure the Attempts
settings to determine how the software handles failed login
attempts (when a user attempts to log in using the wrong
password):

T

Max Login Attempts | S court

Upon Failure

|
|—_V-| Send log message

Set User State

O Retnain active

@Suspendfor hour(s)

- Max Login

Attempts field

Send log
message check
box

Remain Active
radio button

Suspended for
_ hour(s) radio
button/field

* Max Login Attempts — Type the number of failed login
attempts that the software should allow before suspending
the user account.
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* Send log message — Select this if you want the software to
record the failed login attempts to the security log.

Note: The security log for the GeneMapper® Software is
an ASCII text file located in <drive>:\
AppliedBiosystems\ GeneMapper\
GeneMapper_Log. txt. For more information on
interpreting the notations in the security log, see “Viewing
the Security Report” on page 94.

» Set User State — Select an option to determine the way that
the software responds to users who exceed the number of
failed login attempts (defined by the Max Login Attempts
field):

— Remain Active — If selected, the user account remains
active when a user exceeds the maximum login attempts.

— Suspended for hour(s) — If selected, the software
suspends the user account for the specified number of
hours when a user exceeds the maximum login attempts.

Note: If a user exceeds the maximum number of login
attempts, you can reactivate the user account before the
specified time period elapses as explained in “Activating,
Deactivating, and Suspending User Accounts” on page 93.
Otherwise, the user must wait for the specified number of
hours to elapse before he or she can attempt another login.
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4. Configure the Password settings to determine the length of time

that passwords are valid on the system:

—— Password
'E Password “ Lifetime check
] |:| Password Lifetime days box/field
[=leaf
] Password Grace Logine | 6 ‘ count
= — Password

Grace Logins
field

* Password Lifetime — Select this if you want the software
to retire the password of each user account after the
specified number of days elapses.

Note: When the software retires a password, it
automatically prompts the user to create a new password
the next time he or she uses the GeneMapper® Software.

* Password Grace Logins — Type the number of times that a
user can delay changing his or her password after the
software prompts the user to change it. Once the user
exceeds the number of specified logins, the software
requires the user to change his or her password.

5. Configure the Password Reusability settings to determine how
long users can use the same password:

Password

| rPazsword Reusability

Pazsword Reuse Period

Passwords kept per user

30

10
|

days

count

| Reuse Period
check box/field

— Password kept

per usage field

* Password Reuse Period — Select this if you want the
software to allow a user to reuse a former password after
the specified number of days has elapsed since its last use.

* Password kept per usage — Type the number of former
passwords per user that the Access Control Administration

Software should store.
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6. In the Minimum Password Width field of the Password Format
settings, type the number of characters that the software should
enforce as the lower limit for all user passwords.

Pazswword Fortnat
| ’V Minimum Password Width | 6 characters
|

— Minimum

B _l Password

Width field

For example, if you type “6” in the Minimum Password Width
field (as shown in the figure above), all users must choose
passwords at least 6 characters in length.

Note: By default, all passwords must be at least 6 characters.

7. Click Save Changes.
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Managing User and Security Groups
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Overview

About User
Groups

The GeneMapper® Software employs a system of user and security
groups to manage data access privileges in a multi-user environment.
By combining the groups you can create multiple public and private
data pools for the users of the GeneMapper® Software. In addition to
the control provided by the user and security groups, the
GeneMapper application provides a locking mechanism to prevent
users from unknowingly overwriting each other’s changes.

IMPORTANT! Use of the user and security groups is applicable only
to multi-user environments (such as the client installation and situations
in which multiple users operate the GeneMapper® Software on a single
computer). Individual users who do not plan to share the application, do
not need to alter the user and security group settings.

As the name implies, user groups associate user accounts for the sole
purpose of bestowing them with data access privileges. Each user
group can be individually configured to provide users with Read or
Update access to the data object controlled by the associated security
groups. When rights conflict, the most permissive right prevails. A
user account can belong to multiple user groups, and a user group can
be associated with multiple security groups.

Note: If a user belongs to multiple user groups, the user's access
privileges are a combination of all the rights granted by the
associated groups.

The GeneMapper® Software installs two default user groups:

* Administrators — The default user group created for users
responsible for maintaining and administrating the software.
The Administrator user group has Read/Update privileges
(uneditable) to all data objects.

* All Users — All users are automatically members of the All
Users group. By default, the All Users user group has
Read/Update privileges to all data objects belonging to the
default GeneMapper security group.
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About Security  Top-level GeneMapper® Software data (such as individual analysis
Groups methods, projects, and panels) are assigned to a single security group.

When a security group is associated with a user group, the
GeneMapper® Software defines the access rights of that user group to
the data of the security group. Security groups provide the basis for
ownership of the objects used by the GeneMapper® Software. For
example, if a user creates a new project and associates it with a
particular security group, only users who belong to a user group that
has Read or Update permissions for the same security group can view
the project. Security groups restrict access to: projects, table settings,
plot settings, cluster plot settings, report settings, reference data,
chemistry kits, and panels.

IMPORTANT! Security groups do not restrict access to sample data.
After samples are added to a project, the GeneMapper® Software
stores the pertinent data from the sample files to the database, where
any user can access it for use in additional projects.

The GeneMapper® Software installs two default security groups:
* Admin Security Group — Contains all data objects for the:

— Access Control Administration Software (user accounts, user
profiles, user and security groups, and applications)

— Electronic Signature Software (electronic signature settings
and records)

— Audit Manager Software (audit map settings and records)

* GeneMapper — By default, the GeneMapper security group
contains all data objects used by the GeneMapper® Software
(until the addition of other security groups).

User and Security  After you configure the GeneMapper® Software with user and
Groups From the security groups and associate user accounts to the user and security
User's groups, the software modifies the content of specific dialog boxes
Perspective and windows accordingly. When a user creates, opens, or attempts to
modify a controlled data object, the software includes in the
appropriate element of the user interface, a drop-down list that
prompts the user to assign a Security Group to the data object.
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Examples

This section illustrates the function of user and security groups
through a series of example scenarios. Figure 4-1 on page 74 displays
a diagram of the user and security group configuration for each
example.

Example 1: Simple Public and Private Data Configuration

This configuration supports two users who do not co-author projects,
but share data resources, such as analysis methods, size standard
definitions, panels and bin sets, or SNP sets.

In Example 1:

* Both users can read and update data belonging to the Public
security group (shared data such as analysis methods, size
standard definitions, panels and bin sets).

» Each user can read and update data belonging to his or her
personal security group (projects)

* The users cannot read each other’s private data.

Example 2: Public and Private Data Configuration with Viewer

This configuration provides the same support explained in
Example 1, except that it features the Private Viewer user group that
allows Users 1 and 2 to view each other’s private data.

In Example 2:

* Both users can read and update public data belonging to the
Public security group (multi-author projects and other shared
data such as analysis methods, size standard definitions, panels
and bin sets).

» Each user can read and update private data belonging to his or
her personal security group (single-author projects).

* Because both users belong to the Private Viewer user group,
they can read each other’s private data.

Note: The Private Viewer user group prevents the users from
updating each other’s projects, but it allows them to use and
create copies of the viewable projects.
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Example 3: Workgroup Configuration

This configuration contains two duplicate workgroups in the
configuration shown in Example 2. Also included in Example 3 are
user and security groups for a principal investigator (PI) who is
responsible for managing and reviewing the data generated by the
work groups.

In Example 3:

* The users of the workgroups can read and update public data
belonging to the Workgroup security group for their workgroup.

For example, Users 1 and 2 can read and update data objects
belonging to the Workgroup 1 security group (multi-author
projects and other shared data, such as analysis methods, size
standard definitions, panels and bin sets).

* All users can read and update the private data belonging to their
personal security group (single-author projects).

* Because the members of each workgroup belong to a
Workgroup user group, they can view each other’s private data.

Note: The Workgroup user group prevents the users from
altering each other’s private data, but the users can use and
create copies of the viewable data objects.

» The user assigned to the principal investigator user group can
read and update the private data of all other users.

Note: One possible application of the Example 3 configuration is
version control of reference data (such as analysis methods, panels,
and bin sets). The principal investigator could assume the
responsibility of maintaining the reference data used by the members
of the workgroups. By storing all reference data in the security group
for the principal investigator, the other members could use the
reference data to analyze their respective projects, but control of the
data objects would belong only to the principal investigator.

GeneMapper® Software 5 Installation and Administration Guide 73



Chapter 4

—— Create/View
- - - -View Only
€: User Account
% User Group
& Security Group
_ 4 Data

Key

74

Example 1: Public and Private Data Setup

A

Private: User 1

User 1
=iy
ﬁ Public
User 2

A

User 1 Private: User 2

Example 2: Public and Private Data Configuration with Viewer

A

Private: User 1

A

Public

A

Private: User 2

&

User 1 Private: User 1

|
ﬁ Public: Wrkgrp
User 2
|

Private: User 2

Private: PI

User 3 (PI)
=N
ﬁ Private: User 4
User 4
=iy
ﬁ Public: Wrkgrp
User 5
=iy
User 5 User 4 Private: User 5

Figure 4-1 Examples of user and security group configurations
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Setting Up User and Security Groups

Overview  Setting up user and security groups for the GeneMapper® Software
requires that you:

» Carefully read “Managing User and Security Groups” on page 70
and determine the appropriate user and security group structure
for your users.

» Create security groups as explained below.

* Create user groups as explained in “Creating a User Group” on
page 77 (associate the security groups and user accounts during
or after the creation of each).

» If necessary, create security profiles as explained in “Creating a
Profile” on page 81.

* Create user accounts for your users as explained in “Creating a
User Account” on page 89.

+ Test the access control system you created by creating,
modifying, deleting, and viewing data objects using the
appropriate user accounts.

* Modify the system as necessary.
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Creating Security

76

Groups

N =

. Start the Access Control Administration Software (see page 64).

In the Access Control Administration window, click & (File »
New Security Group).

3. In the Create Security Group dialog box, click Next.

4. In the Create Security Group screen, type a name and

description for the new group, then click Next.

Note: The name cannot begin with a number (1, 2, 3, ...) or
contain symbols (&, $, #, ...).

IMPORTANT! Do not modify the Control Security Group
setting. The Control Security Group drop-down list assigns the
security group data object you are editing to an existing security
group. If you assign it to an unassociated security group, the
group you are editing becomes unavailable.

5. In the Associate User Groups settings:

a. Select Associate for each user group that you want to
associate with the new security group.

b. For each associated user group, select Read or Update to
determine the data access privileges to provide users of the
group.

c. When finished, click Next.

6. Click Finish to complete the setup.
7. Click & (File » Save).

To edit an existing Security Group:

1.

Expand 3 Security Groups in the Navigation Pane of the
Access Control Administration window, then select a security

group.

Modify the settings for the selected security group displayed in
the Security Group Properties pane.

When you finish, click 5 (File » Save).
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Creatinga 1. Inthe Access Control Administration window, click gg (File »
User Group New User Group).

2. In the Create User Group dialog box, click Next.

3. In the Configure the New User Group screen, type a name and
description for the new group. The name cannot begin with a
number (1, 2, 3, ...) or contain symbols (&, $, #, ...).

4. Select the default rights for the software to apply when
associated with a security group:

* Read — Select to allow the user to read the data objects of
the security groups that you will associate with the user
group.

» Update — Select to allow the user to modify the data
objects of the security groups that you will associate with
the user group.

IMPORTANT! Do not modify the Control Security Group
setting. The Control Security Group drop-down list assigns the
security group data object you are editing to an existing security
group. If you assign it to an unassociated security group, the
group you are editing becomes unavailable.

5. Click Next.

6. Select Associate for each user account that you want to associate
with the new user group, then click Next.

7. In the Associate Security Groups settings:

a. Select Associate for each security group that you want to
associate with the new user group.

b. For each associated security group, select Read or Update
to determine the data access rights to provide users of the
new users group for the associated security group data
objects.

c. When finished, click Next.
8. Click Finish to complete the profile setup.
9. Click £ (File » Save).
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Editing an 1. In the Navigation Pane of the Access Control Administration
Existing User window, expand User Groups, then select a user group.

Group 2. Modify the settings for the selected user group displayed in the

User Group Properties pane.

3. When you finish, click &5 (File » Save).

Managing Applications

About The applications settings are for use by Life Technologies support
Applications personnel and should not be modified.

Managing Profiles

About Profiles A profile is a set of rules that limit user access to:
+ Aspects of the GeneMapper® Software
+ Data contained by the GeneMapper® Software

* Security and audit management software of the GeneMapper®
Software

You can limit the access of individual users by assigning each user
account a profile that provides the user with access to appropriate
functions. By default, the Access Control Administration Software
installs three generic security profiles (Technician, Scientist, and
Administrator) that correspond to the typical professional roles in a
laboratory environment. We recommend that you use the default
profiles until you are familiar with the software, then you can either
create custom profiles for your workplace or modify the settings of
the default profiles as necessary.
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Each profile consists of a set of switches called Installed Elements
that grant a user permission to perform an action on a specific aspect
of the GeneMapper® Software or one of the software utilities that
install with the software. Each Installed Element has two settings that
exist in the on (), off (™), or inherited (/") states:

« Execute — If selected, the software allows users of the
associated profile to perform the action defined by the Installed
Element.

* OIR (Override Inherited Rights) — If selected, the Installed
Element overrides the setting it inherits from its aggregate
element.

The Installed Elements exist in a relational hierarchy where the
settings of the aggregate elements (denoted by the & and 7 icons)
determine the default settings of the elements in the group they
define. In this way, the subordinate Installed Elements are said to
inherit the setting of the element to which they belong. Note that you
can override the inherited setting of any Installed Element by
selecting OIR (), then selecting or deselecting the Execute check
box. Figure 4-2 on page 80 illustrates the concept of the inheritance
hierarchy using the Installed Elements of the GeneMapper
applications group.
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Example of Installed Element Inheritance

Figure 4-2 illustrates an example of inherited rights in the installed
elements for the GeneMapper® Software.

[ Installed Elements [ or [Execute]
F' Default Rights [ [C % Default Rights element
* AdminTool&co | =
* At | ||
+ FoundationDataCollection | ||
= Geneapper [vl [ GeneMapper application
# [ Database Manager | [ element
4 ﬁ Panel Manager |_ |7
= O size Standard O B 5 Analysis Method action
(5 READ_SIZE_STAMDARD | ¥ group
5 UPDATE_SIZE_STANDARD | ¥
= [ snalysis Methad [vl O
B UPDATE_aMaLysis_WETHOD | [ B jﬁ’ READ_ANALYSIS_METHOD
(5 READ_ANALYSIS_METHOD v v installed element

Figure 4-2 Hierarchy of Installed Elements

80

Default Rights element — Because Execute is not selected (),
the software assigns the value as the default () for all Installed
Elements of the profile.

GeneMapper application element — Because OIR is selected
(#), the Execute value () overrides the inherited value ().
Also, the software assigns the override Execute value (=) to all
Installed Elements that belong to the GeneMapper application
element.

Analysis Method action group — Because OIR is selected (¥),
the Execute value () overrides the inherited value (). Also,
because Execute is not selected (), the software assigns the
override Execute value () to all Installed Elements of the
action group.

READ_ANALYSIS_METHOD installed element — Because
OIR is selected (F ), the software overrides the inherited Execute
value (1) and applies the selected Execute value (#) for the
individual Installed Element.
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Creating a Profile Start the Access Control Administration Software (see page 64).
Click % (File » New Profile).

In the Create Profile dialog box, click Next.

A\

In the Configure the New Profile screen, enter:
* A name for the new profile (<30 characters).
* A brief description of the new profile (<1024 characters).

5. Select Control Security Group » <security group>.

IMPORTANT! Do not modify the Control Security Group
setting. The Control Security Group drop-down list assigns the
security group data object you are editing to an existing security
group. If you assign it to an unassociated security group, the
group you are editing becomes unavailable.

6. Configure the Installed Elements as desired to provide users of
the profile with the appropriate level of access to the
GeneMapper® Software and other applications.

Note: See Table 4-1 on page 84 for a description of the
functions displayed in the Installed Elements table.

a. Select () or deselect (™) /Default Rights to determine
the default value for all Installed Elements in the profile.

b. For each Installed Element, select (#) or deselect (")
OIR and/or Execute.

c. When you finish assigning rights to the profile, click Next.
7. Click Finish to complete the profile setup.
8. Click £ (File » Save).
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Editing a Profile

Select the -

desired profile

82

Admin(istrator) Profile.

IMPORTANT! We strongly recommend against modifying the

1. Start the Access Control Administration Software (see page 64).

2. In the Navigation Pane of the Access Control Administration
window, expand Profiles, then select the desired profile.

% Access Control Administration

File Edit Wew Settings Help
A== X & SEe®mY H=
=] J Users Profile Properties
€ Acriristrstor P—
G
B 'p"CEaitll\T:vSigator Mame | Admin Profile |
dminToolAcc
uditHistoryiewer Description | Admin Profile for Access Cortr |
udithapBuilcer
udithapConfiguration Cortral Properties
milvieswer
sigadministration Cortrol Security Group
LB
aundationviewersgp | ||| Installed! Eletmerts [ or_J[Execute]
enehapper % Default Rights [7] [7] ’:
cEAdmin = AdminTooldcc | 7|
avigator = [P ceneral ol ol
T Admin IQ}" Mary run application C 7 —
=] J User Groups B’ Add User to User Group C 7
% Administrators B’ Azzociste Uzer Groups with Sec [7]
All Users B’ Azzociste Uzer Groups with Use [7]
=] J Security Groups B’ Change Pazsword Policies [7]
Admin Security Group IQ}" Import Security Data ol 7
@ GeneMapper IQ}" Export Security Data C 7
= 4 Profiles = [ user Groups ol 7
A clmiit = Creste | ol
(5 Moty [ ol
Technician B’ Change Control Security Group [/ b

Hierarchical list of access control ohjects

4. When you finish, click &5 (File » Save).

In the Profile Properties pane, modify the Installed Elements
settings for the selected profile.

— Edit the

properties of
the Installed
Elements

GeneMapper® Software 5 Installation and Administration Guide



Chapter 4

About Default By default, the Access Control Administration Software installs the
Profiles and following security profiles:

Privileges  Administrator — Designed for laboratory personnel responsible
for installing and maintaining the GeneMapper® Software, and
for managing user profiles and user accounts.

* Scientist — Designed for laboratory personnel responsible for
analyzing sample data using the GeneMapper® Software.

* Technician — Designed for laboratory personnel responsible for
operating the genetic analysis instrument, and for uploading
sample data to the GeneMapper® Software database.

Note: If the GeneMapper® Software is installed on a computer that
contains other Life Technologies products, the Installed Elements
table may contain elements other than those listed in Table 4-1. Most
Life Technologies products employ the Access Control
Administration Software and install their elements to the same
location.
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Table 4-1 User groups and privileges

L
§ o
Installed Elements =S | 3o _—
(G3 Application/(FAction Group/EAction) E £ £ .g Grants the user permission(s) to...
5§ 3% %
= » | < ®
7 . All or none of the installed elements (determines the
¥ Default Rights LN L default value for all installed elements)
5 Admin Tool Acc(ess) v | v/ | All aspects of the Access Control Administration Software
(I General v | v/ | Use the general functions of the Access Control
£ May Run Application N Administration Software, which include:
e Starting the Access Control Administration Software
& Add User to User Group I/ (see page 64)
& Associate User Groups with Security v | v/ | e Editing user accounts (see page 91)
Groups e Editing user groups
(= Associate User Groups with Users v | /| » Changing the password policies (see page 66)
f=Change Password Policies v | v | * Exporting/importing security settings (see page 94)
B Import Security Data e
= Export Security Data I/
FUser Groups v | / | Create, delete, or modify user groups (gg)-
=Create i/
EModify I/
(= Change Control Security Group I/
= Delete e
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Table 4-1 User groups and privileges (Continued)

= Change Control Security Group

y 4e1deyo

o
g/, 8
Installed Elements = | h o -
o .2
(FF Application/FAction Group/ 5 Action) E £ £ _8 Grants the user permission(s) to...
o E |2
O | =
3 |
FProfiles v | v | Create, delete, or modify user profiles ().
E:?=>Create |/ = 4 Profiles ||
g Ahin Profile I User profile
E:;}Mod”y ‘/ ‘/ il Scientist
. Note: See page 78 for more information on user profiles.
(&= Change Control Security Group I/
(= Delete I/
FApplications v | v/ | Create, delete, or modify applications ([
E::’Create v |V = 4 Applications ||
i AB Mavigator “ Application
E:‘;;:,Modlfy v/ v B8l AdminTooldce
Note: See page 70 for more information on applications.
= Delete e
(FUsers v | v/ | Create, delete, or modify user accounts (€).
E::’Create I/ = 4 Users ||
€ Ldministrator — User account
EModify I/ e
) Note: See page 88 for more information on user
(& Change Control Security Group v | V| accounts.
(= Delete v/
I Security Groups — | — | /| v/ | Create, delete, or modify security groups ({f).
(% Create - =\ V|V
& Modify - =V
I/
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Table 4-1 User groups and privileges (Continued)
2
Installed EIl t g E
nstalled Elements S B la -
(G} Application/FAction Group/(Action) ::E, £ g .8 Grants the user permission(s) to...
o E |2
[3) —
SR
. All aspects of the Audit Map Configuration Software and
Audit GUI A the Audit History Viewer Software.
I Audit History Viewer v | v/ | Use the Audit History Viewer Software.
(Z=May Run Application Note: See page 114 for more information on the Audit
x4 History Viewer Software and the audit history.
FMap Configuration Tool v | v/ | Use the Audit Map Configuration Software including
& Enable and Disable Maps N enabling, disabling, and modifying audit maps.
. Note: See page 107 for more information on the Audit
(May Run Application v | Y| Map Configuration Software and the auditing system for
®
B> Change Auditing State v v | theGeneMapper™ Software.
i Foundation Data Collection v | v/ | / | All aspects of the Data Collection Software
JGeneMapper / |~ | All aspects of the GeneMapper® Software
(FDatabase Manager v | v/ | Use the functions of the Database Manager including:
READ_DATABASE_INFO(rmation) ¢ Viewing (reading) database statistics (see page 151)
Y and project information (see page 156)
(=~ UPDATE_DATABASE_CONGIF(uration) ¢ Modifying (updating) the disk space allocated for the
- - I/ GeneMapper® Software database (see page 154)
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2
§ . 8
Installed Elements S | B o _—
(FF Application/FAction Group/ 5 Action) ::E, £ _8 Grants the user permission(s) to...
o E |2
[3) —
SR
(@Panel Manager v | v/ | Use the functions of the Panel Manager including:
= READ_PANEL A e Viewing (reading) panels, bin sets, and bin definitions
¢ Creating/modifying (updating) panels, bin sets, and
(> UPDATE_PANEL ey bins
Note: For more information on panels, bin sets, bins, or
the GeneMapper Manager, see the Online Help.*
(JSize Standard v | v/ | Use the GeneMapper Manager to view (read) and create
or modify (update) the size standard definitions stored by
(> READ_SIZE_STANDARD v/ | v | the GeneMapper® Software.
Note: For more information on size standard definitions
(>UPDATE_SIZE_STANDARD v/ |~ | orthe GeneMapper Manager, see the online help.*
(FAnalysis Method v | V/ | Use the GeneMapper Manager to view (read) and create
or modify (update) the analysis methods stored by the
EREAD_ANALYSIS_METHOD /| v | GeneMapper® Software.
Note: For more information on analysis methods or the
[ UPDATE_ANALYSIS_METHOD v |~ | GeneMapper Manager, see the online help.*
(3 Study v | v/ | Use the GeneMapper Manager to view (read) and create
or modify (update) the studies stored by the
P~READ_STUDY v/ | v | GeneMapper® Software.
Note: For more information on analysis methods or the
(> UPDATE_STUDY v |~ | GeneMapper Manager, see the online help.*

T You can access the Online Help at any time by clicking g in the toolbar of the GeneMapper window, selecting Help » Contents and Index, or
pressing F1. See “Related Documentation” on page 9 for more information.
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Managing User Accounts

About User
Accounts

Default User
Names and
Passwords

The GeneMapper® Software user account system is similar to that
used by the Windows operating system, in which each user is assigned
a user account with a personalized password. The account provides
the user with specific privileges to operate the GeneMapper®
Software and its utilities based on the profile assigned to it. See
“Managing Profiles” on page 78 for more information on user
profiles.

User accounts not only provide direct control of user access to the
GeneMapper® Software, they also serve as the basis for auditing user
activity. When a user performs an audited activity, the auditing software
creates an audit record that includes the name of the user account
used to perform the action. In this way, the auditing software uses
user accounts to identify the users responsible for performing audited
activities. For more information about auditing or audit records, see
Chapter 5, “Managing the Auditing and Electronic Signature Systems.”

Table 4-2 lists the default user accounts that install automatically
with the GeneMapper® Software. Both default accounts belong to the
Administrator profile and should be used to install and configure the
GeneMapper® Software, not to analyze sample data.

IMPORTANT! To ensure the security of your data, we strongly
recommend that you reassign the passwords for both default user
accounts after installing the GeneMapper® Software.

IMPORTANT! Do not misplace the password for the Administrator
account. If the administrator password is lost, the access control
system must be reset, resulting in the loss of all users and profiles

Table 4-2 Default user accounts and passwords

User Name Password Description

Administrator | Administrator | A user account for the person responsible for configuring and managing

the security and auditing systems of the GeneMapper® Software$

gm password*® | A user account for logging into the GeneMapper® Software for the first

time after installation.

1 The password for the “gm” user account is changed during the installation of the GeneMapper® Software.
§ The “Administrator” user account cannot be deleted.
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User Account
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Chapter 4

Start the Access Control Administration Software (see page 64).
Click & (File » New User).
In the Create User dialog box, click Next.

In the Configure the New User screen, type a name and

description for the new user.

IMPORTANT! The user name cannot begin with a number
(1,2, 3, ...) or contain symbols (&, $, #, ...).

IMPORTANT! You cannot create a user account with the same
name as a user account that has been deleted.

5. Configure the user details for the new user:

* Full Name — Type the first and last name of the new user
separated by a space character.

* Show EULA — (Optional) If selected, the software displays
the End User License Agreement (EULA) when the user

logs in.

» Status — Select the appropriate status for the user account.

Status
[ Active

Definition

The user can log in to and use the software.

& Inactive

The user cannot log in to the software.

™ Suspended

The user cannot log in to the software.

Note: Depending on the Password Policy
settings (see page 78), the software assigns
the Suspended status to user accounts that
have been subject to multiple unsuccessful
login attempts.
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6.

7.

Select the control properties for the new user:

» Profile — Select the appropriate profile from the drop-down
list.

* Default Security Group — Select the appropriate security
group from the drop-down list.

* Control Security Group — Select the appropriate security
group from the drop-down list.

A (.\UI{el'] Do not modify the Control Security

Group setting. The Control Security Group drop-down list
assigns the security group data object you are editing to an
existing security group. If you assign it to an unassociated
security group, the group you are editing will be
unavailable.

Set the password for the new user:
a. Click Set Password.

b. In the Change Password dialog box, type a temporary
password in the Type and Retype fields.

c. Click OK.

Note: Because the password is configured to Pre-Expire by
default, the password set in this step is temporary. When the user
logs in for the first time, the software prompts for a new
password.

When finished assigning rights to the user, click Next.

9. Select the appropriate check boxes in the Associate column to

10.
11.
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associate the user account with the appropriate user groups, then
click Next.

Click Finish to complete the user setup.

Select File » 5 Save (or click &5 in the toolbar).
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Editinga 1. Start the Access Control Administration Software (see page 64).

User Account
2. In the Navigation Pane of the Access Control Administration

window, expand Users, then select a user account.

3. Modify the settings for the selected user account displayed in
the User Properties pane.

4. When you finish, click =5 (File » Save).

Deleting a User The Access Control Administration Software allows you to delete
Account any user account except for the default Administrator account
(see page 88). After you delete a user account, you cannot retrieve or
restore it, nor can you create another user account of the same name.
We recommend using the delete function sparingly, and only when
you are certain to have no further need of a user account.

Note: Instead of deleting a user account, consider deactivating or
suspending the user account as explained in “Activating,
Deactivating, and Suspending User Accounts” on page 93.

To delete a user account:
1. Start the Access Control Administration Software (see page 64).

2. In the Navigation Pane of the Access Control Administration
window, expand Users, then select the user account to delete.

3. Click X (Edit » Delete).

4. In the Delete Identifiers dialog box, click Yes to confirm the
action.

Delete Identifiers

Deelete ‘example?

5. Click 5 (File » Save).

IMPORTANT! After the user account has been deleted, you
cannot create another user account of the same name.
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Changing the
Password of an
Existing User

In the event that a user forgets his or her password or you identify a
security risk, you can log in to the Access Control Administration
Software using an administrative user account to change the

Account password for a user account.
IMPORTANT! To ensure the security of your data, We strongly
recommend that you reassign the passwords for both default user
accounts (gm and Administrator) after installing the GeneMapper®
Software.
To change the password of an existing user account:
1. Start the Access Control Administration Software (see page 64).
2. In the Navigation Pane of the Access Control Administration
window, expand Users, then select the user account () of
interest.
3. In the User Properties pane, set the new password for the user:
a. Click Set Password.
b. In the Change Password dialog box, type a password in the
Type and Retype fields.
c. Click OK.
4. Select () or deselect (I") Pre-Expire.
# — When the user logs in for the first time, the software
prompts the user to enter a password of their choice.
I~ — The user must use the password assigned in step 3.
L--wzwjhmx 4 DET =
'_‘““.u-- ~Pazsword———————
- '—'i:;:‘;m Set Password Click
. Adminiztrator
Select the desired em [ Pre-Expire Select or deselect
user account Expiration Date Mo expiration
Grace Loginz Used 0
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5. When finished, select File » =5Save (or click &5 in the toolbar).
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Activating, The Access Control Administration Software allows you to change
Deactivating, and the status (Active, Suspended, or Inactive) of individual user
Suspending accounts. This function is useful when:
User Accounts * You want to deactivate a user account without deleting it
* A user exceeds the maximum number of failed login attempts
and you want to activate the user account manually

Note: The software can suspend a user account if the user repeatedly
enters an incorrect password (see page 66).

To reactivate, deactivate, or suspend the user account:
1. Start the Access Control Administration Software (see page 64).

2. In the Navigation Pane of the Access Control Administration
window, expand Users, then select the user account ().

3. In the Status menu of the User Properties pane, select the
appropriate account status for the user account.

Status Definition
[ Active The user can log in to and use the software.
@ Inactive The user cannot log in to the software.

/™ Suspended | The user cannot log in to the software.

Note: Depending on the Password Policy
settings (see page 78), the software assigns the
Suspended status to user accounts that have
been subject to multiple unsuccessful login
attempts.

D Gl wem e

&3 0 Rx & LET =

"""!a.- o | rUser Detail
=a - Full Matme | GeneMapper DefaultUser
E’“::,_ [ER e [re——— - i
= 4 Users e [ Shows ELLA
Administrator [ .
Select the desired ———— € s Status [ active - Select the desired
user account g User Crested Aug 13, 2003 2:15:45 PM status

Horvgaes
Akt

Last Login Mov 9, 2004 1:05:03 PM

oo ot o s corrt st |

4. When finished, select File » =5Save (or click 5 in the toolbar).
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Viewing the Security Report

About the
Security Report

Example record for
a user account

Example record for
an Application

Example record for —¢-

a profile

Printing the
Security Log
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The Access Control Administration Software can print a summary of
one or more components of the security system (user accounts,
applications, and profiles).

Note: The security report does not summarize login attempts or other
user activity. To monitor and record user activity, you must configure
the software for auditing (see Chapter 5, “Managing the Auditing and
Electronic Signature Systems,” for more information).

é Preview fccess Control Administration

First Previous et Last Print Cloze

User

Detai . .
Full Hame: Administrator uzer Description: User Administrator
Dizabled: no EULA: true
Profile: Admin Profile
Applications

— AR . B

‘ Description: AB Mawvigatar Challenge? : yes
Profiles
Detai Frafile: in Frofi
Description: Admin Profile for Access Control A iated Uszer List: Administrator, gm

Figure 4-3 Security report example records

Note: The security log is regenerated daily.

Start the Access Control Administration Software (see page 64).

2. If you want to print a report for a specific user account or
profile, select a user account or profile in the Navigation Pane of
the Access Control Administration window.

3. Click E (File » Report).
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4. In the Print Access Control Identifiers dialog box, select an
option to determine the content of the report:

Print Access Control Identifiers g]

Prirt Range

O Ertire Access Control

|:| Users

|:| Applications

|:| User Groups
|:| Security Groups
|:| Profiles

[ Print H Previeww H Cancel

* Entire Access Control — Select to print a summary of all
user accounts, applications, and profiles.

+ Selection only — Select to print a report of the selected user
account, application, or profile selected in the left pane of
the Access Control Administration Software window.

* Print checked objects below — Select to print a report of
all elements of a specific type (user accounts, applications,
or profiles), then select one or more of the following:

— Users — Select to print a report of all user accounts.

— Applications — Select to print a report of all
applications.

— Profiles — Select to print a report of all profiles.
Click Preview to view a preview of the report.

6. Review the report preview. If the preview contains all of the
information of interest, click Print. Otherwise, click Close and
go to step 4 to modify the report settings as desired.

Click Close to close the report preview.

Click Cancel to close the Print Access Control Identifiers dialog
box.
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Exporting and Importing the Security Settings

Transferring

Security Settings
Between
Computers
Exporting the
Security Settings
Importing the
Security Settings
96

The Access Control Administration Software allows you to export a
summary of all security settings for backup or transfer to another
computer. The exported Access Control file is small (£100KB) and
contains the password policies for the software and all user accounts,
applications, and profiles.

Note: The security settings for the Access Control Administration
Software are not stored as part of the GeneMapper® Software project
data and must be backed up separately as an exported file.

1. Start the Access Control Administration Software (see page 64).

4,

In the Access Control Administration window, select
File » Export Database.

In the Save dialog box, type a file name for the exported file,
select Access Control files (.acc), then click Save to export the
security settings as an .acc file.

In the Export Users dialog box, click OK.

IMPORTANT! Importing security settings from an .acc file
automatically replaces all existing settings.

1. Start the Access Control Administration Software (see page 64).

In the Access Control Administration window, select
File » Import Database.

In the Save dialog box, navigate to the appropriate location,
select the desired .acc file, then click Open.

In the Import Users dialog box, click OK.
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B About the Data Tracking Systems . ................... 98
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About the Data Tracking Systems

About the Data
Tracking Systems

The GeneMapper® Software installs two software utilities that you
can use to monitor user activity and modify data stored by the
software:

* Audit Mapping Software

» Electronic Signature Software
Use of the data tracking system does not interfere with the operation
of the software and is optional. By default, both utilities install
automatically with the client installation of the GeneMapper®

Software and must be activated as described in this chapter before
they monitor data activity.

Table 5-1 summarizes the functions of the utilities.

Table 5-1 Elements of the data tracking systems

Utility

Description/Function See Page

Audit Mapping
Software

Creates an audit trail for data objects (such as projects and 99
analysis methods) used by the GeneMapper® Software that

have been configured for auditing. Each audit trail lists the

changes (creation, modification, and deletion) made to the

associated data object. Depending on the configuration of the

utility, the software can track changes with or without (silent

auditing) the users knowledge.

Electronic Signature
Software

98

Restricts the creation, deletion, and modification of data stored 121
by the GeneMapper® Software. Similar to the auditing system,

the Electronic Signature (e-Signature) System creates a history

of user activity based on actions performed on the data objects

stored by the GeneMapper® Software. However, unlike the

auditing system, the e-Signature system requires the user to
authenticate or “sign” for actions by entering a user name

(optional) and password.
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Setting Up the Auditing System

This section covers:

B About the Auditing System .. ......................
B Audit Maps, Objects, and Attributes . ................
B Configuringthe AuditMap ........................
B Managing Audit Records .. .........................
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About the Auditing System

Components of The GeneMapper® Software uses two applications, the Security
the Auditing Manager Software and the Audit Map Configuration Software, to
System  secure and monitor the data it contains. This chapter describes how to

use the Audit Map Configuration Software to control and monitor
use and modification of the data stored by the GeneMapper®
Software. For information about securing the GeneMapper®
Software, see Chapter 4, “Managing Database Security and User
Access.”

About the The Audit Map Configuration Software monitors and records the
Audit Map modification of data stored by the GeneMapper® Software. Using the
Configuration Audit Map Configuration Software, you can determine what data
Software elements the software monitors and how it monitors them. Use of the
Audit Map Configuration Software is optional and is inactive by
default.

Setting Up the The following tasks must be performed to set up the auditing system
Auditing System  for the GeneMapper® Software.

Start the software (see page 101).

_

Can you use the default settings for the software?
—— (see page 102) —
No
‘ Yes

Configure the audit map settings as needed (see page 107).

!

Close the software.
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Maintaining the  Perform the tasks in the following table to maintain the auditing
Auditing System  system for the GeneMapper® Software.

Frequency Tasks

As needed e Review the audit report for the GeneMapper®
Software (see page 114).

e Backup/restore audit records (page 118).

Semi-annually | Review the audit map for the GeneMapper® Software
and modify it as necessary to meet the regulation
requirements of your laboratory (see page 107).

Starting the 1. Start and log in to the GeneMapper® Software (see “Logging In

Audit Map to and Out of the Software” on page 59).
Conflc’golj]c:leacig 2. In the GeneMapper window, select Tools » Audit Manager »

Setting.

3. In the AuditMapConfiguration dialog box, type a user name and
password for a user account with administrative privileges, then
click OK.

IMPORTANT! Only users that belong to the Administrator user
group (see page 83) can use the Audit Map Configuration
Software.
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Audit Maps, Objects, and Attributes

102

About the
GeneMapper®
Software
Audit Maps

The Audit Map Configuration Software monitors GeneMapper®
Software activity based on the configuration of the “audit map” for
the application. An audit map is a collection of rules that define
which data elements of an application the Audit Map Configuration
Software monitors, and how it monitors them. The audit map consists
of two elements: audit map objects and object attributes. In terms of
the GeneMapper® Software, audit map objects represent the types of
data used by the software (such as bins, projects, and samples), and
object attributes describe the ways that users can modify them. For
example, the audit map object “Analysis Method” shown in

Figure 5-1 has the attributes “created, deleted, and modified” because
users can create, delete, or modify analysis methods using the
GeneMapper® Software.

GeneMapper® Software 5 Installation and Administration Guide



About Audit State
Inheritance

Chapter 5

] Audit Map Configuration

File Auditing Settings  Help
a2k
Audit Map Ohjects Attributes for Audit Map named 'AnalysisMethod'
|[ Marme ][ Type ][ Enabled ] [ Marme ][ Type ]L State ]
P Alele AlleleT created ritmitive & o
hied deleted primitive [ I

Ein BinT [#] rodified pritmitive [ 5
T BinSet BinSetT [v]
B it KitT [¥]
2 Marker MarkerT [w]
T Wtatrix MatrixT [v]
(3 Panel PanelT [#]
i Praject ProjectT [¥]
& Run RunT V]
B Samnple SampleT [w]
3 SizeStandard SizeStandardT [w]
B study StudyT [7]
ame of Audit Map

Audit Map Objects Attributes for the
(AnalysisMethod selected) “AnalysisMethod” audit map object

Figure 5-1 Audit map objects and attributes

Note: Because most Life Technologies products use the Audit Map
Configuration Software to monitor data activity, the auditing
software may display additional audit map objects if the
GeneMapper® Software is installed on a computer that contains other
software.

The audit map, each audit map object, and each object attribute have
an audit state that determines which elements of the GeneMapper®
Software the Audit Map Configuration Software monitors, and how
it monitors them. By configuring the audit states of the components
of the audit map, you can customize the system to meet the
regulatory requirements of your laboratory workplace. Figure 5-2
displays the locations of the audit state controls in the software.
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m Audit Map Configuration

File BEOLTNEN Settings  Help
Audit map setting—— s o[Hon
i & Silent
AL TS CHECTE Attributes for Audit Map named 'Allele!
Marme Type Enabled [ Marme ][ Type ]L State ]
Selected audit — Allele v created [pritmitive @ o
map object ||| «t KitT [v] deleted on
(enab|ed) E_E_ Sample SampleT z modified primmitive
E_E_ Marker MarkerT ¥
E Run RunT ¥ 1~ Current attribute
E_E_ Panel PanelT ¥ state
B AnalysisMethod |AnalysisMethodT 4
(4 Binset BinSetT [v]
(24 Ein EinT [+] Possible states
B Project ProjectT = for the selected
attribute
Figure 5-2 States of the audit map, audit objects, and attributes
The audit states of the audit map, the audit map objects, and the
object attributes are linked in a hierarchical relationship, where the
states of the audit map and objects override those of the object
attributes. Understanding this relationship is crucial to successfully
configuring the audit map. Table 5-2 shows the result of all possible
combinations of the audit states for the audit map objects and object
attributes.
Table 5-2 Audit state inheritance matrix
State of the Audit State of the Attribute
Audit Object .
(Enabled) [ ON /[ Silent @ OFF
(Yes) ON Silent OFF
] (No) OFF OFF OFF
Auditing from  When a user changes an audited object attribute, the software
the Users displays the Reason(s) For Change dialog box (see Figure 5-3). To

Perspective

104

proceed with the action, the user must type a description of the reason
for the change and click OK. If the user clicks OK, the software
changes to the attribute and saves the information as an audit record.
The user cannot cancel the audited action.

Note: If the audit map is configured for silent auditing (/7 Silent),
the software does not display the Reasons for Change dialog box and
just records the action to the audit history.
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= Reason(s) for Change

rReaszon(s) for Change

I Name of the affected
audit object attribute

Aftribute | modified

Old “alue | [Crange Min Peak] 50

— Former (Old) and current
New Valus | [Orange Min Pesk] 30 HIl (New) values of the audit
object (if applicable)

Erter the Reason(z) for Change:

This iz an example of a Reason(s) for Change 7—7User-provided
dialog box.| justification for the
change

Figure 5-3 Reason(s) For Change dialog box

Note: Figure 5-3 shows the Reason(s) for Change dialog box that the
software displayed when a user changed the Orange Peak Amplitude
Threshold setting of the “Temp” analysis method from 50 to 30 RFU.

Example Figure 5-4 displays the settings for the Allele audit object of the
GeneMapper® Software. In the example configuration, the Audit
Map Configuration Software:
* Displays the Reason(s) for Change dialog box when a user
deletes an allele call

 Passively creates a record when a user changes an allele call
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] Audit Map Configuration
File Auditing Settings  Help

CH [&
Audit Map Ohjects Attributes for Audit Map named 'Allele!
Marme Type Enabled [ Marme ][ Type ]LState ]
! V] deleted pritnitive On
E.E. AnalysisMethod | AnalysisMethodT z rnodified pritnitive Silert
= Bin BinT [v] crested primitive | @ ot
5 Binget BinSetT =
(4 DC Plste Record |DC Plate Record [
E.E. D Results Group |DC Results Group ]
50 OC Run Module|DC Run Module O
G Kit KitT []
B4 Marker MarkerT [V]
3 Matric MatrixT =
(4 Panel PanelT [V]
(4 Project PrajectT [¥]
T4 Run RunT [#]
(4 Sample SatnplaT [#]
EEf SizeStandard  |SizeStandardT =
T Study StudyT [#]

uditable?

Figure 5-4 Auditing Settings for the Allele audit object

Note: If you have installed the GeneMapper® Software on a
computer that contains other Applied Biosystems software, the audit
map may display additional auditable objects and attributes. Because
most Applied Biosystems products use the Audit Map Configuration
Software for auditing purposes, the audit map may display more
objects and attributes than displayed in Figure 5-4.

IMPORTANT! When a user makes a change to an audited object, the
auditing software writes the name of the user account that was used
to make the change to the audit record. The software does not require
the user to authenticate himself or herself to make the change.

IMPORTANT! The audit information is saved when the user saves
modified documents back to the database (for example, File » Save).
If the user closes a document or object without saving it, the software
discards the audit information.
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Configuring the Audit Map

Guidelines for  Observe the following guidelines when modifying the audit map:

Configuripg the « All changes made to the audit map are applied immediately. The
Audit Map software does not have a “save” function.

*  When the audit map is changed, the software must be closed
before the changes take effect.

Configuring the 1. Start the Audit Map Configuration Software (see page 101).

Audit Ma
P 2. In the Audit Map Configuration window, select Auditing »

<audit state>.

The Auditing setting of the Audit Map Configuration Software
determines how the software audits changes to the audit map.
The Auditing setting exists in two states:

* [ On — Configures the software to display the Reason(s)
for Change dialog box whenever a user modifies the audit
map.

+ /M Silent — Configures the software to audit all changes the
audit map passively (the software records each change but
does not prompt the user to enter a reason for the change).

3. For each audit map object displayed in the Audit Map Objects
(left) pane:

a. Decide whether to track modifications to the audit map
object (see Table 5-3 on page 110 for descriptions of all
objects).

b. Select () or deselect () the Enabled check box.

The state of an audit map object determines whether the
software creates audit records for the data type that the
object represents. Audit map objects can exist in two states:
. (enabled) — Configures the software to audit all
object attributes according to their individual audit
states.
* [ (disabled) — Configures the software to ignore
changes made to the audit map object.

c. Repeat steps 3a and 3b for the remaining audit map objects.
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4. For each audit map object that you enabled, perform the
following actions for each attribute in the right pane:

a. Select the audit map object.

b. Decide how you want the software to audit the associated
data type.

c. Click the cell in the State column for each attribute, then
select a state for the attribute.

The state of an audit map object determines whether the
software creates audit records for the data type that the
object represents. Audit map object attributes can exist in
three states:

+ [ On - The software actively creates an audit trail
for the attribute. When an attribute is set to “On” and a
user performs the action associated with the attribute,
the software displays the Reasons For Change dialog
box (see page 105). When the user clicks OK, the
software creates an audit record for the change that
includes the description of the reason for the change
entered by the user.

+ /\ Silent — The software passively creates an audit
trail for the attribute. When an attribute is set to
“Silent” and a user performs the action associated with
the attribute, the software automatically creates an
audit record, but does not prompt the user to enter an
explanation for the change.

+ @ Off — The software ignores changes made to the
attribute. When an attribute is set to “Off”” and a user
performs the action associated with the attribute, the
software does not create an audit record.

d. Repeat steps a and b for each audit map object you enabled
in step 3 on page 115.

5. When you finish configuring the audit map, select File » Exit to
close the software.
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About the Audit
Map, Audited
Objects, and
Attributes

Table 5-3 shows the components of the audit map for the GeneMapper® Software that installs
with the Audit Map Configuration Software.

Note: If the GeneMapper® Software is installed to a computer that contains other

Applied Biosystems products, the Audit Map Objects table may contain elements other than
those listed in Table 5-3. Most Applied Biosystems products employ the Audit Map
Configuration Software and install their audit map objects to the same location.
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Table 5-3 Elements of the audit map for the GeneMapper® Software

Object Attribute(s) D;tf:tlgt Definition

14 Allele created @ Off Represents allele calls made by the software.
deleted @ Off | When configured for auditing, the software creates a record of the
— - associated modification(s) made from the Cluster Plot Manager, the
modified ® Off  samples Plot, or the Genotypes Plot.

@ Analysis Method created @ Off Represents the analysis methods used to analyze project data.
deleted @ Off When configured for auditing, the software creates a record of the
dified ® off associated modification(s) made from the Analysis Method Editor.
modifie

% Bin created @ Off Represents the individual bins of the bin sets used to analyze project
— ta.
deleted @ Off data

. When configured for auditing, the software creates a record of the
— 9 9
modified @ Off associated modification(s) made from the Panel Manager or the
Samples or Genotypes Plots.

% BinSet created @ Off Represents the bin sets used to analyze project data.
deleted @ Off | When configured for auditing, the software creates a record of the

creation and/or deletion of bin sets using the Panel Manager.

% Kit BINSET [ On Represents the kits used to analyze project data.
created @ Off When configured for auditing, the software creates a record of the
deleted ® off associated modification(s) made from the Panel Manager.
elete
— - Note: When the BINSET or PANEL attributes are activated, the
modified @ Off | software creates audit records for edits made to bin sets or panels
PANEL [ on that are associated with kits.
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Table 5-3 Elements of the audit map for the GeneMapper® Software (Continued)

Object Attribute(s) Dg:tlgt Definition
% Marker BIN [ On Represents the markers of the bin sets used to analyze project data.
created @ Off | When configured for auditing, the software creates a record of the
— associated modification(s) made from the Panel Manager or the
iated modification(s) made fi he Panel M h
deleted @ Off Samples or Genotypes Plots.
modified @ Off Note: When the BIN attribute is activated, the software creates
audit records for edits made to bins that are associated with markers.
@ Matrix created @ Off Represents the matrices used to analyze project data.
deleted @ Off When configured for auditing, the software creates a record of the
dified ® off associated modification(s) made using the GeneMapper Manager.
modifie
% Panel created @ Off Represents the panels used to analyze project data.
deleted @ Off | When configured for auditing, the software creates a record of the
p— associated modification(s) made from the Panel Manager or the
MARKER [ On Samples or Genotypes Plots.
modified @ Off Note: When the MARKER attribute is activated, the software
creates audit records for edits made to markers that are associated
with panels.
% Project analyzed @ Off Represents the project data object that associates analysis
created ® off parameters, settings, and sample data for projects.
— When configured for auditing, the software creates a record of the
deleted @ Off associated modification(s) made from the GeneMapper window.
modified ® Off | Note: When the RUN attribute is activated, the software creates
= audit records for edits made to the run folders within projects.
RUN [ On
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Table 5-3 Elements of the audit map for the GeneMapper® Software (Continued)

Default

Object Attribute(s) State Definition
% Run created @ Off Represents the run folders of the project data object that contain
deleted ® Off samples for an analysis.
el
When configured for auditing, the software creates a record of the
— 9 9
SAMPLE [ On associated modification(s) made from the GeneMapper window.
Note: When the SAMPLE attribute is activated, the software creates
audit records for edits made to the samples within run folders.
@ Sample ALLELE [ On Represents the sample data added to projects.
created @ Off When configured for auditing, the software creates a record of the
— associated modification(s) made from the Samples or Genotypes
deleted @ Off  1aps of the GeneMapper window.
modified @ Off Note: When the ALLELE attribute is activated, the software creates
OverrideGQ @ Off audit records for edits made to the alleles of individual samples.
o ) Note: When the OverrideGQ attribute is activated, the software
OverrideSQ @ Off creates an audit record when users override the GQ PQV made by
the software.
Note: When the OverrideSQ attribute is activated, the software
creates an audit record when users override the SQ PQV made by
the software.
% Size Standard created @ Off Represents the size standard definitions used to analyze project
deleted @or
p— - When configured for auditing, the software creates a record of the
[Z modified @ Off 9 I
modifie

associated modification(s) that are made using the GeneMapper
Manager.
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Table 5-3 Elements of the audit map for the GeneMapper® Software (Continued)

Default

Object Attribute(s) State Definition
% Study analyzed @ Off Represents the study data object that associates projects for the
created ® Off analysis of SNPlex® System data.
el
— When configured for auditing, the software creates a record of the
deleted @ Off associated modification(s) made from the Study Manager.
OverrideStatus @ Off Note: When the PROJECT attribute is activated, the software
PROJECT [ On creates audit records for edits made to the projects that are attached
to studies.
ProjectAdded @ Off
ProjectRemoved | @@ Off
RunAnalyzed @ Off
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Managing Audit Records

Overview  You can view, back up, remove, and restore the audit history records
generated by the GeneMapper® Software.

B Viewing the Audit History. ................... (see below)
B Backing Up, Removing, and Restoring Audit Data. . ... ... 118

Viewing the Audit History

About the The Audit Map Viewer Software is the GeneMapper® Software
Audit Map Viewer utility that allows users belonging to the Administrator user group to
Software view historic audit data. The software provides read-only access to
audit records and data filters so that audit records can be viewed in
different formats.

Note: Only users of the Administrator user group (see page 83) can
use the Audit Map Viewer software.

Audit Details (ShOW) ﬂ ﬁ Audit History Yiewer
ile  Wiew Settings Help

Filter tool (show) 15+ 115 | |5 (&
Audit Objects rFitter Audit Recard:
= analysishethadT By Text By Date
D e T — e
Audit object & = FF audittapain DL A [ get
Eefore Query
r =7 P T O user [ Match Whale iard O
- After
Attribute (selected) & analy od [ atch Case
Fil | Audit Records
ilter tool
| Audit Record Diate: User Old Yalue || Mew Walue
E created E:09:46 PM GeneMapper DefaultlUser Silent A
. O crested Mar 3, 2005 6:09:56 PM | GeneMapper DefaultUser | Silent on
Audit record; for_the O created har 3, 2005 6:10:02 PM | Genedapper DefautUser |(On off
selected audit OPJeCt O modified  |Mar 3, 2005 E1005 PM | Genehapper DefaultUser |Off on v
attribute T
U -Audit Record Details
Old “alue Off Mew Walue Silent
Details of the selected Reason for Change

audit record

Figure 5-5 Components of the Audit History Viewer window
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Starting the  IMPORTANT! Only users that belong to the Administrator user group
Audit History (see page 83) can use the Audit History Viewer Software.
Viewer

1. Start and log in to the GeneMapper® Software (see “Logging In
to and Out of the Software” on page 59).

2. In the GeneMapper window, select Tools » Audit Manager »
Report.

3. In the AuditHistoryViewer dialog box, type a user name and
password for a user account with administrative privileges, then
click OK.

—h

Viewing Audit

Start the Audit History Viewer Software (see above).
History Records

A

In the Audit Objects pane, select the audit object of interest, or
click [#] to the left of an object to display its attributes.

3. Select the audit object attribute for which you want to display
audit records.

ﬁ Audit History Yiewer

File ‘“iew Settings Help

B(E|S (&
Audit object category —

. Audit Objects Audit Recards
(Analysis Methods) e
. . T = AnalysizMethodT Audit Record Date Uszer Qe Walue
Audited object &
(analysis method named “Temp”) gi1= &3 Audittapain modified  |Mar 3, 2005 |GeneMapper Defauttser| [SHPlsx Allele Calli
Audited obi J  slele
) u Ite“ o |e(,:,t  Analysismethod
(analysis method named “Temp”)

The following options are available:
» View the audit record details
* Filter or Sort the audit records
* Print the audit records (by selecting File » Print Preview).
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Viewing Audit
Record Details

Sorting the
Record Data by
Column

If you configured an audit object attribute for active auditing
(see step 4c on page 108), then you can view the details of the
associated audit records.

To view the details of the audit history records:

1. Click | (View » Details Panel) to show the Audit Record
Details panel.

2. Select individual records from the Audit Records list.

You can sort the audit history records in the Audit Records list by
clicking one of the column headers. When the software sorts data by
a column, a triangle (A) appears inside the header to indicate the
direction of the sort.

Selected audit history record Sort triangle A

£

Details Panel i
(show)

File ‘“iew Settings Help

B S

B [&

Audit object category
(AuditMapAUD)

Audit records for the

Audit Records ‘

Audit Objects

= analysishethadT

= 5 auditMapalo
£ siele

(F analysisMethad

Temp audit object

Audit Record Details

Mewy Yalue [Crange Min Peak] 30

Old Yalue [Crange Min Peak] 50

Reason for Change

Details of the selected
audit history record

This is an example of a Beason(s) for Change dialog box.

records

Filtering the
Record Data

116

Figure 5-6 Details of the Audit Record created for the change
shown in Figure 5-3 on page 105

The Audit History Viewer software includes a Filter tool to help you
organize the large sets of audit history records generated through
routine use of the GeneMapper® Software. The tool allows the
software to display a subset of the total number of records based on a
set of predefined criteria.
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To filter the audit history records:

1. Make sure that the Audit Records list contains the record data
that you want to filter.

2. Click # (View » Filter Records) to display the Filter Audit
Records pane.

3. Type search criteria in the applicable fields:
To display records containing a specific word or phrase:
a. In the Find What field, type the word or phrase.

b. Select the Name or User option button to specify the
column in which you expect the word or phrase to occur.
c. Select the appropriate options for the text search:

* Match Whole Word — The software retrieves only
records that contain words that match the specified
text exactly.

* Match Case — The software retrieves only records
that match the case (upper or lower) of the specified
text.

To display records created within a specific period of time:

a. To display records that were created before a specific date,
select Before, then click the adjacent field and select a date.

b. To display records that were created after a specific date,
select After, then click the adjacent field and select a date.

4. Click Query.

E’ Filter records

(show)

rFitter Audit Record

By Text By Date:
Y E— ‘ Sort critria
- i Before March 4, 2005
O User [ Match hole WWiord O - Guery
After
[ Msteh Case -

Audit Records

CF8 crested  |Mar 3, 2005 5:09.55 PM GeneMapper Defauliiser snent on = Sorted audit
O crested  |Mar 3, 2005 61002 PM | GeneMapper Defauttlser |On oot history records
O modified  [Mar 3, 2005 6:10:05 PM | GeneMapper Defaultlser |Off on b

GeneMapper® Software 5 Installation and Administration Guide 117



Chapter 5

Backing Up, Removing, and Restoring Audit Data

Overview

Backing Up and

118

Removing
Audit Records

The GeneMapper® Software allows you to backup, remove, and
restore audit records from the GeneMapper database application.
Depending on the configuration of the electronic signature system
and the frequency of software use, the system can generate a
significant number of audit records in a very short period. Over time,
the amount audit data may begin to hinder the database and will need
to be removed to optimize performance.

Scheduling Backups and Data Removal

Depending on your circumstances you may need to devise a schedule
for backing up and removing audit data. As part of regular
maintenance of the GeneMapper® Software, routinely review the
amount of space occupied by audit records using the Database
Dashboard utility (see “Reviewing the Database Statistics” on

page 151). As the Audit Data tablespace approaches the maximum
limit defined in the software, you must either:

* Increase the size of the Audit Data tablespace as explained in
“Allocating Disk Space” on page 154, or

* Back up and remove the audit records as explained below.

IMPORTANT! The GeneMapper® Software automatically backs up
the audit data with the main database application (see “Backing Up
the Database” on page 158). Therefore, the primary use of the
Backup Audit Records function described here is for transferring
audit data to a flat file for archival.

1. Start and log in to the GeneMapper® Software (see “Logging In
to and Out of the Software” on page 59).

2. In the GeneMapper window, select Tools » Audit Manager »
Backup Audit Records.

3. In the Backup Audit Records dialog box:
a. Navigate to the desired location.
b. Type a name for the exported file.
c. Click Backup.
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4. In the GeneMapper window, select Tools » Audit Manager »
Delete All Audit Records.

5. In the Delete All Audit Records dialog box, click Yes.

Delete All Audit Records

@ This will delete all audit recards, Do you wank ko continue?

The exported GeneMapper audit file (*.aud) can now be
compressed and transferred to a storage medium for archival. If
you ever need to view the archived records, restore the records
as explained below and view them using the Audit History
Viewer Software (see “Viewing the Audit History” on page 114).

Restoring Audit 1. Start and log in to the GeneMapper® Software (see “Logging In
Records to and Out of the Software” on page 59 for more information).

2. In the GeneMapper window, select Tools » Audit Manager »
Backup Audit Records.

3. In the Backup Audit Records dialog box, navigate to and select
the desired GeneMapper audit file (*.aud).

4. Click Restore.
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Setting Up the Electronic
Signature System

This section covers:

B About the Electronic Signature System . .............. 122
B About Electronic Signatures. . ...................... 124
B Configuring the Electronic Signature Settings. ......... 125
B Configuring the GeneMapper® Software Action Map. ... 126
B Viewing the Electronic Signature History . ............ 128
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About the Electronic Signature System

About the The Electronic Signature (eSig) Software is the GeneMapper®
Electronic  Software utility that allows users belonging to the Administrator
Signature  group to setup, monitor, and maintain the electronic signature system.
Software
Guidelines for Using the Electronic Signature Software

* Only users of the Administrator user group (see page 83) can
use the software.

» Unlike the audit trail utilities, you must save changes made to
the electronic signature system before the database can
implement them.

Setting Up the  The following tasks must be performed to set up the electronic
Electronic signature system for the GeneMapper® Software.
Signature System

Start the software (see page 123).

N

Can you use the default settings for the software?
—— (see page 126) —
No
d Yes

Configure the eSig settings as needed (see page 126).

|

Close the software.
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Maintaining the Perform the tasks in the following table to maintain the electronic
Electronic signature system for the GeneMapper® Software.

Signature System

Frequency

Tasks

As needed

Review the electronic signature history for the
GeneMapper® Software (see page 128).

Semi-annually

Review the electronic signature system settings and
modify them as necessary to meet the regulation
requirements of your laboratory (see page 125).

Starting the 1. Start and log in to the GeneMapper® Software (see “Logging In

Electronic to and Out of the Software” on page 59).
Signature :
Administration 2. ElszheAC(;c;rllielll\i/Isifgz rwmdow, select Tools »
Software g '

3. In the ESigAdministration dialog box, type a user name and
password for a user account with administrative privileges, then

click OK.

IMPORTANT! Only users that belong to the Administrator
user group (see page 83) can use the Electronic Signature
Administration Software.
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About Electronic Signatures

Electronic

Signatures from

124

the User’s
Perspective

The GeneMapper® Software has an Electronic Signature (eSig)
system that can be used to regulate the creation, deletion, and
modification of data stored by the database. When a user performs an
action (such as the detection of data) that has been configured for an
electronic signature, the GeneMapper® Software displays the
Electronic Signature Verification dialog box (see Figure 5-7). The
user must then authenticate or “sign” for the action by typing the user
name (optional) and password of his or her account.

& Electronic Signature Verification

A default warning to the
user that explains the

Delete Analysis Method b fvalidation request

By entering your UserID and Password, you are b -
I p—— 1 An additional custom
> message to the user
User ID User types his or her
user name
Pazsword —L
| User types his or her
password

Figure 5-7 Electronic Signature Verification dialog box

If a user enters the correct password, the GeneMapper® Software
performs the requested action and records the electronic signature
transaction. If the password fails, the software either locks out the
user or returns the user to the screen from which the user attempted
the action, depending on the password policies.

Note: The Electronic Signature Software tracks the number of failed
login attempts.
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Configuring the Electronic Signature Settings

About the The Electronic Signature Software allows you to activate (and
Configuration Tab  deactivate) the electronic signature system using the Configuration
Settings tab of the software. The setting is system-wide and can be customized.

Enabling 1. Start the Electronic Signature Software (see page 123).
Electronic

Signatures 2. In the Electronic Signature window, select the Configuration

tab.

3. In the Configuration tab, select Yes to activate the Electronic
Signature System.

Select Method » UsernamePassword.

5. (Optional) If you want the software to require the user to enter
his or her user name as part of the electronic signature
verification, select Require UserID?

IMPORTANT! Users belonging to the Administrator user group
can reconfigure the requirement for entering a user name in the
Electronic Signature Verification dialog box.

6. (Optional) In the Description field, type a brief description of
the electronic signature settings.

Note: The software does not use the Checksum settings.

= ESig Administration

File Settings Help

) ==
Require UserlD check box
| Configuration | action Administration | Histary Viewer

. . . . rElectronic Signature Method
Electronic signature activation —
(system-wide) LB |z Electronic Signature Reguired? @ Yes O Mo
dethod |UsernamePassword * | Require UserlD?
Description of the electronic Description
signature settings (Max. 1024 characters)
etting
Core Checksum |:| Full Checksum |:|

7. Click & (File » Save) to save the settings.
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Configuring the GeneMapper® Software

Action Map

About the Action
Administration
Tab Settings

About the
GeneMapper®
Software
Action Maps

Configuring the
Action Maps

126

The Action Administration tab of the Electronic Signature Software
allows you to configure the electronic signature requirements for the
controlled actions (creating, deleting, and editing) of the
GeneMapper® Software applications.

Electronic signatures for the GeneMapper® Software are configured
through a set of GM__ action maps that represent the data objects of
the GeneMapper® Software. For each action map, you can enable or
disable the electronic signature requirement for the corresponding
data object and customize the challenge text that appears in the
Electronic Signature Verification dialog box (see Figure 5-7 on
page 124).

IMPORTANT! You must enable the electronic signature system as
explained on page 125 and save it before changes to the ESig Action
map can take effect.

1. If necessary, start the Electronic Signature Software (see
page 125).

2. In the ESig Administration window, select the Action
Administration tab.
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Enable Esig check box (enabled)

Selected action group

Challenge text displayed in the
Electronic Signature Verification dialog
box

Actions for the selected actions group

Definition text displayed in the
Electronic Signature Verification dialog

Chapter 5

53| 9

= ESig Administration IZHEWE
File Settings Help

Configuration | Action Administration | History Viewer

;l ESig Action Maps rA&ction Group - Approve
# DEFALLT ACTION GROUP [l Eeie
# GM_STUDY
# GM PROJECT Electronic Signature Challenge Texd (Max. 1024 characters)
*» GM_CHEMISTRY WIT By entering your UserID and Password, you are
L WG _METHOD signing the action
# GM_SIZE_STAMNDARD
* GM_MATRIX
Action deaning

1 |CREATE_AMNALYSIS_METHOD |Creste hew Analysis Method
2 MODIFY_AMALYSIS_METHOD |Modify Analysiz Method
3 |DELETE_AMALYSIS_METHOD |Delete Analysis Method

3. For each GM_ action group in the left pane of the Action
Administration tab:

a.
b.

Select a GM__ action group.

Carefully review the information displayed in the Action
Groups - Approve group box for the associated action map.

If you want to require electronic signatures for the actions
displayed in the Actions List, select the Enable ESig check
box.

. In the Electronic Signature Challenge Text field, type a

short message to your users. The software displays the text
you enter here when the software prompts the user for an
electronic signature

Repeat steps 3a through 3d for each action map in the ESig
Action Maps pane.

4. Click &5 (File » Save) to save the electronic signature settings.
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Viewing the Electronic Signature History

About the History The History Viewer tab of the Electronic Signature Software allows
Viewer Tab  you to query, retrieve, and view the event history for the controlled
Settings  actions (creating, deleting, and editing) of the GeneMapper®
Software.

Note: The Electronic Signature Software does not record printing or
exporting in the event history.

Viewing Histories 1. If necessary, start the Electronic Signature Software
(see page 125).

2. In the Electronic Signature window, select the History Viewer
tab.

= ESig Administration

File Settings Help

ey

=5 B

GM_ANALYSIS_METHOD
Action Group

Configuration | Action Administration | Hiztary ‘iewer |
r@uery Electronic Sighature Even:

ObiectMame | | actionGroup  [GM_ANALYSIS_METHOD v [ Fna |
ObiectType [ | Action [DELETE_ANALYSIS_METHOD v |
= = Clear

Event Date
Fahame [ | From DELETE_ANALYSIS_METHOD
To Action
rEvent
User I Full Marme Action Group | Action “ersion | Server Time Cliert Time

|| G apper DefaultUs DELETE_&H... 1 2005-04-01 00... mrecgnme + Deleted analysis method
electronic signature event

~Event Detail
Ohject Name Ohject Type Ohject Yersion i .
Temp ANALYSIS METHOD [razes 11 Details of the electronic

signature event

“erify Checksum
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3. In the Query Electronic Signature Events group box, enter

parameters to refine the query of electronic signature records:

Note: Enter parameters only in those fields that are relevant to

your search. The software can perform a query regardless of
whether the remaining fields and menus contain values.

Object Name — Enter the name of an object. For example,
entering “Study 123” in the Object Name field retrieves all
events for study “Study 123.”

Object Type — Enter the type of object (study, project, or
analysis method). For example, entering “study” in the
Object Type field retrieves events for all studies.

User ID — Enter the name of a user account to query the
electronic signature events created by a specific user.

Full Name — Enter the full name of a user to query the
electronic signature events created by a specific user.

Action Group — Select an action group to view all events
for the group. For example, selecting Action Group »
GM_ANALYSIS METHOD retrieves all events created
when a user created, deleted, or modified an analysis
method.

Action — After selecting an action group, select an action to
further refine the search by isolating it to a specific action
of the group. For example, after selecting Action Group »
GM_ANALYSIS METHOD, selecting Action »
DELETE ANALYSIS METHOD retrieves all events
created when a user deletes an analysis method.

Event Date/Time — Enter a date or dates to display records
created in a specific time period.

From — Restricts the search to events created after the date.
To — Restricts the search to events created before the date.

4. Click Find.

5. (Optional) In the Events list, select an event to view the details

for the electronic signature.

6. If you want to run another query, click Clear, then repeat

steps 3 through 5.
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Maintaining the Software
and Database Application

This chapter covers:
B Maintenance OVerview . ...............covuuren.... 132

Section 6.1: Managing Study, Project, and Sample Data.. 133

B Exporting Data Objects .. ............c.oiiuiin.... 135
B Exporting GeneMapper Data Objects . ............... 137
B Exporting and Importing Reference Data . ............ 142
Section 6.2: Managing the Database................... 145
M Using the Oracle® Database. .. ..................... 146
B About the Dashboard Software . .................... 149
B Reviewing the Database Statistics ... ................ 151
B Allocating Disk Space . .......... ... ... ... .. ... 154
B Viewing Project Information . ...................... 156
B Backing Up the Database. . ........................ 158
B Generating a Database Report .. .................... 160
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Maintenance Overview

Overview The GeneMapper® Software requires regular maintenance to ensure:

* Optimal performance of the software and database application

* Protection against data loss (due to hardware or software failure)

+ Security of the stored data (projects, analysis methods, etc.)

+ Compliance with changes in regulatory requirements
This chapter explains how to maintain the GeneMapper® Software
and the associated database application. The procedures for
maintaining the security, auditing, and electronic signature systems

are referred to in Table 6-1, but are explained in Chapters 4 and 5
respectively.

Recommended IMPORTANT! The maintenance schedule shown in Table 6-1
Maintenance contains general recommendations and may require adjustment based

Schedule on system throughput.

Table 6-1 Database maintenance activities

Frequency

Tasks

Weekly .

Exit the GeneMapper® Software and cycle the computer power (see page 61).
(Optional) Back up the GeneMapper database application (see page 158).
Review the statistics for the database (see page 151), and if necessary:

— Export unused projects and data (see page 138).

— Allocate additional disk space (see page 154).

Monthly .

Semi-annually e
(6 months)

Defragment the computer hard drive.

If using the auditing system, review the audit report (see page 114).

If using the electronic signature system, review the history (see page 128).

If using the auditing system, review the audit map and modify the settings as
necessary (see page 107).

If using the electronic signature system, review the electronic signature settings
and modify them as necessary (see page 125).

As Needed Export projects (see page 138), studies (see page 140), and audit records (see
page 118).

132
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Managing Study, Project, and
Sample Data

This section covers:

B Exporting DataObjects . .......................... 135
B Exporting GeneMapper Data Objects ................ 137
B Exporting and Importing Reference Data . ............ 142
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Exports Not  This section does not explain how to export elements of the
Covered in this  GeneMapper® Software user interface. The software can export most
Section of the tables and plots displayed during an analysis of a project or

study for:
» Transfer to a third-party application for secondary analysis
(such as a spreadsheet or a database), or

* Inclusion in a report, paper, or slide show presentation

Table 6-2 lists the elements of the user interface that can be exported
by the GeneMapper® Software. See the GeneMapper® Software Online
Help or the individual GeneMapper® Software Getting Started Guides
for information on exporting the individual tables and plots.

Table 6-2 Exportable elements of the GeneMapper® Software user interface

Interface Element

Can be exported as...

Cluster Plot
Genotypes Plot

Genotypes table of
the Cluster Plot

A *.jpg graphic generated from the plot(s) of the Cluster Plot Manager

A screen capture of the Genotypes Plot dialog box

A tab/comma-delimited text file (*.txt) containing all columns of the

Genotypes table in the Cluster Plot Manager.

Genotypes table of
the Samples Plot

A tab/comma-delimited text file (*.txt) containing all columns of the
Genotypes table in the Samples Plot

Project

Samples Plot

A tab/comma-delimited text file (*.txt) containing columns of the
Samples/Genotypes tables for an individual project

A screen capture of the Samples Plot dialog box

Sizing table of the A tab/comma-delimited text file (*.txt) containing all columns of the Sizing
Samples Plot table in the Samples Plot

SNP table of the A tab/comma-delimited text file (*.txt) containing all columns of the
Cluster Plot Genotypes table in the Cluster Plot Manager.

Study (table and A tab/comma-delimited text file (*.txt) containing specific columns of the

genotypes data)

Samples/Genotypes tables of the projects that belong to the study

134
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Exporting Data Objects

Overview The GeneMapper® Software can export most of the data objects
stored by the GeneMapper database application. Exported data
objects can be used to:

* Transfer the data object(s) to other computers running additional
copies of the GeneMapper® Software

+ Store or archive the associated data object(s)

Table 6-2 lists the exportable data objects of the GeneMapper®
Software.

Table 6-3 Exportable data objects of the GeneMapper® Software

Data Object(s) Export Format/Description See Page
¢ Analysis Method An *.xml file containing the metadata equivalents of the 144
e Cluster Plot Setting settings displayed in the associated editor dialog box

« Plot Setting when accessed from the GeneMapper Manager. For

example, an exported analysis method file contains the
* Size Standard Definition | metadata equivalent of all settings found in the Analysis
e SNP Set Method Editor dialog box.

e Report Setting
e Table Setting

Audit Records An *.aud file containing the metadata equivalents of the 118
audit records generated by the GeneMapper® Software

Bin Set An *.xml file containing the metadata equivalents of the 143
base pair ranges of all bins in the bin set

Panel An *.xml file containing the metadata equivalents of the kit, 143
panel, and marker definitions

Projects A *.ser file containing all of the analyzed data for a 137
project*

Security Settings An *.acc file containing the metadata equivalents of the 96

security settings of the Access Control Administration
Software (user accounts, profiles, user and security
groups).

Study A *.ser file containing all of the analyzed data for a study 140
and associated projects*

I Exported projects and studies contain the associated supporting data used to perform the analysis (such as the
analysis method, size standard definition, and SNP set). Therefore, you do not need to export the supporting files
separately and imported again to reanalyze the project or study.
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Export Formats The GeneMapper® Software supports the following export formats:

» Access Control File (*.acc) — An encoded flat file that contains
the security settings of the Access Control Administration
Software.

* Audit File (*.aud) — An encoded flat file that contains exported
audit records created by the GeneMapper® Software Audit
Management System.

+ Extensible Markup Language File (*.xml) — An ASCII text
file that contains the essence of a data object used by the
GeneMapper® Software (such as analysis methods, panels and
bin sets, or size standard definition). The data stored by the file is
encoded in an extensible markup language (XML) standard used
by the GeneMapper® Software.

» Java Serialized File (*.ser) — An encoded flat file that contains
the essence of a data object used by the GeneMapper® Software.
Only projects and studies can be saved as Java serialized files
usually for the purpose of storage, backup, or transfer of the
associated data.

+ Joint Photographic Experts Group File (*.jpg or *.jpeg) — A
compressed color image format recognized as an internet and
multimedia standard. Jpeg graphics can be imported by most
major word processing applications or referenced by an HTML
document for web publishing.

* Tab/Comma-Delimited Text Files (*.txt) — An ASCII text file
that contains tabular data in which each row is exported as a
single line of text and the cells are separated by the tab
(ASCII#009) or the comma (ASCII#044) characters.
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Exporting GeneMapper Data Objects

Overview The GeneMapper® Software can export most types of data objects
(such as projects, studies, and analysis methods) stored by the
GeneMapper database application.

The exported files can be used to:

* Back up the related data objects by transferring the files to an
offline storage device (such as an external hard drive,
DVD ROM, or other storage media)

* Transfer studies or projects to other computers running
additional copies of the GeneMapper® Software

» Update the reference data (such as analysis methods, bin sets,
and panels) on other computers running additional copies of the
GeneMapper® Software

Exporting and Importing Projects

Overview The GeneMapper® Software allows you to export projects from the
GeneMapper database application as *.ser files. The exported files
contain the analyzed sample data and analysis parameters of each
project. Depending on the configuration of the export settings, the
files can also contain the reference data (analysis methods, size
standard definitions, etc.) used to perform the analysis.

Note: Exported projects do not contain the raw data of the sample
files associated with the project. If the sample files for a project are
lost, the project cannot be used to regenerate them.
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Exporting 1. Inthe GeneMapper window, click & (Tools »
Projects GeneMapper Manager).

2. In the GeneMapper Manager, select the Projects tab.

3. Using the Shift and Ctrl keys, select the project(s) that you want
to export, then click Export.

4. In the Export Project dialog box:

a. Navigate to the location where you want to save the
exported project(s).
b. Configure the options for the export:
* Autoname — Configures the software to name the

exported file(s) automatically using the project(s)
name.

* Overwrite existing files — Configures the software to
overwrite existing files of the same name.

+ Export reference data — Configures the software to
include the supporting data objects (such as panels,
bin sets, size standards, and SNP sets) in the exported
file.

c. If you did not select Autoname, type a name for the
exported project file in the File name field.

5. Click Save.

Note: If you did not select Autoname, the software prompts you to
name each project as it is exported. Note that at any time, you can
select Autoname to have the software automatically name the files.
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Importing  Before importing projects, make sure that the projects were exported
Projects  with the associated reference data. If not, before importing the
projects, import the associated reference data including:

* Panels and bin sets (see page 143)

* Supporting data such as analysis methods, table settings, plot
settings, cluster plot settings, matrices, size standard definitions,
SNP sets, or report settings (see page 144)

To import one or more projects:

1. In the GeneMapper window, click [E (Tools »
GeneMapper Manager).

2. In the GeneMapper Manager, select the Projects tab.

3. In the Import Project dialog box:
a. Navigate to the location containing the exported project(s).

b. While pressing Ctrl, select the project(s) that you want to
import.

c. Configure the Reference Data options to determine what
the software does when it attempts to import reference data
(analysis methods, size standard definitions, etc.) with the
same name as an existing data object:

» Skip — Configures the software to proceed without
importing the reference data.

* Overwrite — Configures the software to overwrite
existing reference data.

4. Click Import.
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Exporting and Importing Studies

Overview The GeneMapper® Software allows you to export studies from the
GeneMapper database application for transfer to offline storage, such
as a hard drive, a CD ROM, or other storage media.

Note: Sample files used by the projects are not exported with the
study.

Exporting a Study 1. In the GeneMapper window, select Tools » Study Manager.

2. In the Study Manager, open the study you want to export:
a. Click % (File » Open).

b. In the Open Study dialog box, select a study, then
click OK.

3. In the Study Manager, select File » Export.

4. In the Export Study dialog box, navigate to the location where
you want to save the exported study.

5. If necessary, select Export reference data to include the
supporting data objects (such as panels, bin sets, size standards,
and SNP sets) for the associated projects in the exported file.

6. Type a name for the exported study file.
7. Click Export.

140 GeneMapper® Software 5 Installation and Administration Guide



Importing a Study

Chapter 6

Before importing a study, make sure that the study was exported with
the reference data for the associated projects. If not, before importing
the study, import the associated reference data including:

Panels and bin sets (see page 143)

Supporting data such as analysis methods, table settings, plot
settings, cluster plot settings, matrices, size standard definitions,
SNP sets, or report settings (see page 144)

To import one or more studies:

1.
2.
3.

In the GeneMapper window, select Tools » Study Manager.
In the Study Manager, select File » Import.

In the Import Study dialog box, navigate to the location
containing the exported study.

Configure the Reference Data options to determine what the
software should do when it attempts to import reference data
(analysis methods, size standard definitions, etc.) with the same
name as an existing data object:

» Skip — Configures the software to proceed without
importing the reference data.

* Overwrite — Configures the software to overwrite existing
reference data.

Click Import.
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Exporting and Importing Reference Data

Overview The GeneMapper® Software allows you to export and import
reference data independently of studies and projects. Reference data
refers to the data objects that are used to analyze projects, but are not
altered by the process (such as analysis methods, size standard
definitions, and panels).

Table 6-4 Exportable reference data

Reference Data fE:,f,ot::d lizee
. Kits Panel 143
. Panels Manager

e Bin sets

¢ Analysis methods Report settings GeneMapper 144

e Cluster plot ¢ Size standard Manager
settings definitions

e Matrices e SNP sets

* Plot settings e Table settings
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Exporting Kits, Panels, and Bin Sets

Export All Kits  From the Panel Manager, you can export the panels and bin sets for
all of the kits in your current GeneMapper® Software database.

Note: This procedure allows you to export all panels and bin sets at
once. If you want to export only specific panels and bin sets, see
“Exporting Panels” on page 143 and “Exporting Bin Sets” on

page 144.

To export all kits (all panels and bin sets at once):
1. In the GeneMapper window, select Tools » Panel Manager.

2. In the Panel Manager, select File » Export All Kits to open the
Export All Kits dialog box.

3. Select a folder where you want to save the exported kits (panels
and bin sets), then click Export All Kits.

The software exports the panel and bin set *.txt files for all of
the kits to the selected folder.

Note: The names of the exported panels and bin sets correspond to
the names used in the GeneMapper® Software.

Exporting Panels  From the Panel Manager, you can export specific panels from the
GeneMapper® Software database as tab-delimited *.txt files.

Note: This procedure allows you to export specific panels. If you
want to export all panels at once, see “Export All Kits” on page 143.

To export specific panels:
1. In the GeneMapper window, select Tools » Panel Manager.
2. In the navigation pane of the Panel Manager, select a kit folder.

3. Select File » Export Panels to open the Export Panels dialog
box.

4. Select the folder where you want to save the exported panel(s),
type a file name, then click Export.
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Exporting Bin
Sets

From the Panel Manager, you can export specific bin sets from the
GeneMapper® Software database as tab-delimited *.txt files.

Note: This procedure allows you to export specific bin sets. If you
want to export all bin sets at once, see “Export All Kits” on page 143.

To export specific bin sets:

1.
2.
3.

In the GeneMapper window, select Tools » Panel Manager.
In the navigation pane of the Panel Manager, select a kit folder.

Select File » Export Bin Sets to open the Export Bin Set dialog
box.

Select the folder where you want to save the exported bin set(s),
type a file name, and click Export.

Exporting All Other Reference Data

144

Exporting
Reference Data
Using the
GeneMapper
Manager

1.

In the GeneMapper window, select Tools »
GeneMapper Manager.

In the GeneMapper Manager, select the appropriate tab
(Analysis Methods, Table Settings, Plot Settings, Cluster Plot
Settings, Matrices, Size Standards, SNP Sets, or Report
Settings).

Using the Shift or Ctrl keys, select one or more analysis
methods to export, then click Export.

In the Export Analysis Method dialog box, navigate to the
location where you want to save the exported data object

Type a file name for the exported file.

6. Click Export.

Note: The only file type available for exported analysis
methods files is *.xml.
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This section covers:

M Using the Oracle® Database. . ...................... 146
B About the Dashboard Software ..................... 149
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B Viewing Project Information .. ..................... 156
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B Generating a Database Report . ..................... 160
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Using the Oracle® Database

About the The GeneMapper® Software employs a relational Oracle® 11g
Oracle® 11g  Database for all of its data management needs. The database serves
Database as acommon repository for the analyzed fragment analysis data
(projects and studies), and the supporting data objects (such as

analysis methods, size standard definitions, and SNP sets).

IMPORTANT! Do not install third-party database applications to the
computer running the GeneMapper® Software. If co-installed with
the GeneMapper® Software, third-party database applications can
produce unexpected results including loss of data and corruption of
the GeneMapper database application. Consult a certified Oracle®
database administrator before making any changes to the configuration
of the Oracle® 11g database or before using any of the Oracle®
utilities.

Database Life Technologies does not support access to the Oracle® database
Access through any means other than the GeneMapper® Software and
associated tools (such as the Database Dashboard, the Security
Manager Software, and Audit Map Configuration Software).

SQL Support

Life Technologies does not support the use of SQL (using SQLMGR
or SQL*Plus) to query or modify the tables of the GeneMapper
database application.
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Oracle® 11g
Database Tools

Chapter 6

API Support

The GeneMapper® Software does not feature an application
programming interface (API) for linking the GeneMapper database
application with a LIMS. However, the software can export data from
the database application in a variety of formats, many of which can be
imported by major third-party data storage and analysis applications.

Note: The GeneMapper® Software features a command line
interface that can be useful when integrating the software into an
existing LIMS. The interface allows you to automate most of the
software operations via a scripting language or batch file so that most
maintenance and data-entry tasks can be minimized or eliminated
altogether. See Appendix B, “Operating the Software

from a Command Line,” for more information.

Use of the Oracle® 11g Database bundled with the GeneMapper®
Software is limited by the terms of an embedded license agreement
that prohibits the installation and use of additional third-party
database applications. The license included with the purchase of the
GeneMapper® Software allows access to the database for up to five
named users at any given time. If you want to accommodate more
than five named users, you can purchase either additional
GeneMapper® Software licenses, or additional Oracle®-named user
privileges and thereby, honor Life Technologies’ agreement with the
Oracle® Corporation.

IMPORTANT! Life Technologies strongly advises against using the
database for any purpose other than as a data repository for the
GeneMapper® Software.

IMPORTANT! The operation and maintenance of the GeneMapper®
Software does not require the use of the Oracle® tools.

The Oracle® Corporation provides utilities for accessing and
maintaining their database products. Life Technologies does not
support the use of the Oracle® utilities and recommends against their
use by anyone other than a certified Oracle® database administrator.
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Oracle® Additional documentation for the Oracle® 11 g Database is available
Documentation from the Oracle® web site:

www.oracle.com
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About the Dashboard Software

Overview The Database Dashboard utility that installs with the full version of
the GeneMapper® Software provides tools for maintaining the
Oracle® 11g Database and for evaluating the performance of the
GeneMapper database application. This section explains how to use
the Database Dashboard to maintain the GeneMapper database
application that resides in the Oracle® 11g Database.

About the Utility The Database Dashboard provides multiple views for evaluating the
characteristics and performance of the Oracle® 11g Database, and
several features for maintaining and optimizing the system.

The interface includes the following tabs:

* Dashboard Tab — Provides real-time information about
database performance, space utilization, and operating systems
space usage. The traffic light displays the current state of the
database.

* Report Tab — Provides a comprehensive view for
troubleshooting the Oracle® 11g Database or the GeneMapper
database application. The top of the report provides a list of
potential problems that the software has identified.

e Administration Tab—Provides a limited set of database
administration functions.

* GeneMapper Tab —Provides statistical summaries and tools for
the GeneMapper database application.

Note: If the GeneMapper® Software is installed to a computer
containing additional Life Technologies software products, the
Database Dashboard utility may contain additional tabs for the
administration of the related applications.
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Features Not

Covered in This

150

Manual

About the
Administrator
Role

Starting the
Software

The Database Dashboard provides several advanced features not
discussed in this manual that can be used by a certified Oracle®
Database Administrator to optimize the performance of the Oracle®
11g Database. Life Technologies strongly recommends against using
the features of the Dashboard, Report, and Administration tabs unless
you have been trained to administer Oracle® databases. Many of the
features require advanced knowledge of Oracle® systems to ensure
the integrity of the database.

iy Oracle Dashboard
File Database Helo ; Advanced features

@ Repart AdministratioQGeneMapper

When operating the GeneMapper® Software in a multi-user
environment, Life Technologies recommends designating a single
user as an administrator for the workgroup. The administrator need
not have prior knowledge of the Oracle® 11g and should be
responsible for performing the basic database administration tasks
described in this section. By designating an administrator in a multi-
user environment, you can avoid most problems caused by usage
conflicts.

Note: Ideally, Life Technologies recommends that the maintenance
of the Oracle® 11g Database be performed by a certified Oracle®
Database Administrator, preferably one with prior knowledge of the
application.

IMPORTANT! Only users that belong to the Administrator user group
(see page 83) can use the software.

1. In the desktop, select Start » All Programs »
Life Technologies » Database Dashboard » Dashboard.

2. In the Enter Database Details dialog box:
a. In the DB Name field, type IFA.

b. In the Machine Name field, type the name of the computer
that contains the instance of the Oracle® database.

c. In the Port Number field, type 1521.
d. In the SYSTEM Password field, type manager.
e. Click OK.
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Reviewing the Database Statistics

Overview  As part of regular maintenance, you should compute the statistics of
the GeneMapper database application regularly to ensure optimal
performance of the GeneMapper® Software. The statistics can warn
you of potential problems and help you troubleshoot existing ones.

About the The Database Dashboard displays the statistics for the GeneMapper
Database database application in the Database Statistics table of the
Statistics GeneMapper Statistics tab. The values displayed in the table are

calculated from the space that is allocated for the Oracle® database
itself and the and that which is used by the GeneMapper database,
including tables, indexes, and other information.

[ : AES
Fie Dal Help

Dashicerd | Report | Aminisraion| GeneMapper Siafistics

Distat
'Category Allocated ME Used(ME) Free(ME) Used(%] Auto Extend 1]
Audlt Data 100.00 :

Praoject Data 20,336.00 16253.7562
Reference Data |2,048 .00 [19.45 2025 523 | 1.0[Mo

Statistic

| | Database Statistics I Project Statistics

Figure 6-1 Database Statistics table of the Dashboard Software

GeneMapper® Software 5 Installation and Administration Guide 151



Chapter 6

Columns of the Database Statistics Tab

Note: Values displayed by the Database Statistics tab are

approximate.

» Category — Lists the names of the tables used by the
GeneMapper database application to store data.

Table

Stores

Audit Data

If auditing is turned on, audit records generated
from changes made to the software

Project Data

Reference
Data

Studies and projects, including samples and
result data

Supporting data such as analysis methods,
bin sets, kits, markers, matrices, panels, size
standard definitions, SNP sets, and all other
settings

* Allocated MB — Displays the amount of disk space allocated for

the table space.
Used (MB) — Displays the amount of disk spaced used by the

table space.

Free (MB) — Displays the amount of disk space available to be

allocated to the total table space.

Size value.

Used (%) — Displays the used value divided by the Allocated

+ Auto Extend — Indicates whether the Oracle® database can
automatically increase the Allocated Size of the associated table.

Auto Extend
Value

Effect

YES

NO

The Oracle® database can automatically increase
the allocated size of the associated table when the
Used (MB) approaches Allocated Size limit.

the allocated size is not increased automatically.
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Determining  When reviewing the database statistics, use the following procedure
Whether to determine if maintenance is required to optimize performance of
Database the GeneMapper® Software.

Maintenance is
Necessary To determine whether the database requires maintenance:

1. Start the Database Dashboard (see page 150).

2. In the Database Dashboard window, select the GeneMapper
tab.

3. In the GeneMapper Statistics tab, select the Database Statistics
tab.

4. Review the content of the statistics table and determine whether
database maintenance is required using the following table.

Auto
Extend Required Action
Value

Used (%)
Value

> 80% YES Allocate more space for data as
explained in “Allocating Disk Space”
on page 154, if:

e The Used (MB) is approaching
Maximum Allocated (MB), or

e The available Disk Space on
allocated drives is low

NO Allocate more space for data as
explained in “Allocating Disk Space”
on page 154.

If Available Space on the computer is
insufficient for disk allocation, export
data and delete it from the
GeneMapper database application.

< 80% n/a No maintenance required
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Allocating Disk Space

Overview

154

The GeneMapper® Software allows you to allocate additional space
on the computer hard drive for use by the GeneMapper database
application. When the Used (%) value of any database table
approaches 80%, you must allocate additional disk space for the
GeneMapper database application.

Alternative to Allocating Additional Disk Space

Instead of increasing the disk space occupied by the Oracle®
database, you can export and remove existing data objects to provide
more room for new analyses. The type of data objects that you export
and remove depends on which table space is approaching its limit.
Table 6-5 lists the data objects that you can export and remove to
reduce the size of the corresponding tables of the GeneMapper
database application.

Note: See “Reviewing the Database Statistics” on page 151 to view
the table size statistics.

Table 6-5 Table spaces and related exportable data objects

Table
Approaching Export and Remove See Page
Limit
Audit Data  Audit records 118
Project Data Projects and studies 137 /140
Reference e Analysis methods e Panels 143 /144
Data ¢ Bin sets * Plot settings
e (Cluster plot e Size standard
settings definitions
e Kits e SNP sets
* Markers ¢ Report settings
e Matrices ¢ Table settings
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Allocating Note: The Project Data tablespace consists of three subdivisions that
Additional Disk can be allocated separately to maximize application performance. For
Space more information on refining the Project Data tablespace allocation,

see the Database Dashboard Online Help.

1. Start the Database Dashboard (see “Starting the Software” on
page 150 for more information).

2. In the Database Dashboard window, select the GeneMapper tab.

3. In the GeneMapper Statistics tab, select the Database Statistics
tab.

4. In the bottom portion of the Database Dashboard, select the
Default Allocation tab.

5. In the Default Allocation tab, select Available Drives »
<select a drive>.

r@'vn_:!-, Dashboard - -‘I! IE—I EE
Fle Datsbase Help
Dashtxserd | Report| GeneMapper Sitistics ‘

el
SHPe Sampie TS
) — — ——
TotaProects = | Default Alocation | Custom Allocation |
Datshase Shatistics Propect Statabes
Available Drives:
| Tahle Space:
. Aucit Data b

4 Add Disk Space(ME): 10248

' HBEEEEEEE
=]

Allocate

6. Select Table Space » <select a database table>.

Note: See “Columns of the Database Statistics Tab” on
page 152 for more information on the tables used by the
GeneMapper database application.

7. In the Add disk space (MB) field, increase the additional disk
space in MB to allocate for the selected table.
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8.
9.

10.

Click Allocate.
In the Alert dialog box, click Yes.

IMPORTANT! Allocating disk space cannot be undone.

Wait until the progress bar indicates that the allocation is
complete, then select Database » Refresh (or press Alt-R) to
refresh the screen and verify that the software has increased the
Allocated Size and Maximum Allocation values in the data
table.

Viewing Project Information

Viewing the
Statistics

156

The GeneMapper® Software can summarize the statistics for the
projects that are stored by the GeneMapper database application. The
Database Dashboard that performs the computations automatically.

To view project information:

1.
2.

Start the Database Dashboard (see page 150).

In the Database Dashboard window, select the GeneMapper
tab.

In the GeneMapper Statistics tab, select the Project Statistics
tab to display table space values and table values for each data

type.
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o OracleDazhuoard §

He Datsbase Hep

| Dashicerd | Rport | Adwiriswation| GeneMappes Siatistcs |

Project Statistic:

AFLP

Microsatelite Samples 55
SHPlex" Samples 32575
SMaPshot® Samples 1368
Total Projects 206

*| TDatabase Statistics | project Statistics
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Backing Up the Database

Note: This section presents general recommendations only. The
backup and restore strategy appropriate for your site depends on your
circumstances and your organization’s data-protection policies. An
experienced Oracle® database administrator knows the appropriate
commands to enter to back up or restore the Oracle® database.

When to Back Up  We recommend that you back up the Oracle® 11g Database bundled
the Oracle® 1 1g with the GeneMapper® Software onto an external storage medium
Database (such as 4-mm tape) at least once weekly, or more frequently
depending on software use.

Note: The security settings for the Security Manager Software are
not stored as part of the GeneMapper® Software project data and
must be backed up separately as an exported file. See “Exporting and
Importing the Security Settings” on page 96 for more information.

Performing a IMPORTANT! The GeneMapper database application can become
Logical Backup very large, and the amount of disk space required for export can also
be sizeable. Plan on maintaining 60 to 70% of the size of the database
for the export file.

To back up the database:
1. Start the Database Dashboard (see page 150).

2. In the Database Dashboard window, select the Administration
tab.

3. In the navigation column of the Administration tab, select
Administration » Export Database.

4. In the Full Database Backup settings, click Browse, navigate to
the desired location, type a name for the exported file, then click
Open.

5. Click Export and wait for the software to complete the operation.
The software displays the progress of the export operation in the Log
Viewer field.
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Restoring the  After exporting the database tables, you can import the resulting
Database *.dmp file using the Import utility of the Database Dashboard.

To restore the database from an exported file:
1. Start the Database Dashboard (see page 150).

2. In the Database Dashboard window, select the Administration
tab.

3. In the navigation column of the Administration tab, select
Administration » Import Database.

4. In the Full Database Restore settings, click Browse, navigate to
the desired location, select the file, then click Open.

5. Click Import.

Wait for the Database Dashboard to complete the operation. The
software displays the progress of the export operation in the Log
Viewer field.
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Generating a Database Report

About the The Report tab displays a comprehensive report that characterizes
Report Tab  nearly all aspects of the Oracle® database and the resident
applications. Advanced users with prior knowledge of Oracle®
databases can use the information displayed by the report to assess
and optimize database and application performance. In the event of a
malfunction, the report can provide database error information which
can be used to troubleshoot the problem.

Distributing the 1. In the Database Dashboard window, select the Report tab.

Report
P 2. In the Report tab, to:

Print the report, click Print.
Save the report as an HTML or tab-delimited text file:
a. Click Save.

b. In the Save dialog box, navigate to the desired destination
directory.

c. Type a name for the exported file,

d. Select the desired file format (HTML or tab-delimited
text),

e. Click Save.
Email the report:
a. Click E-mail.
b. Type the address of a valid email account, then click OK.
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Troubleshooting the Installation

This appendix covers:

B Troubleshooting Tasks .. .......................... 162
B Uninstalling the Software. . ........................ 164
B Troubleshooting Checklist. ........................ 170
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Troubleshooting Tasks

IMPORTANT! If you have trouble installing the GeneMapper®
Software on your computer, perform the following tasks in the order
given below.

Task See page
1. Collect the installation log file. 162
2. Check the Oracle® database installation. 162
3. If necessary, uninstall the software. . 164

Collect the 1. Go to x:\AppliedBiosystems\GeneMapper, where x is the
Installation drive on which the GeneMapper® Software is installed.
Log Fil
og riie 2. Copy and save the GMInstalllog file.
You may need to send the GMInstall.log file to
Life Technologies Technical Support if the troubleshooting
procedures in this appendix do not solve the installation
problem.

Check the Check to see if the Oracle® database instance was installed correctly.
Oracle® Database

Installation 1. Select Start » All Programs » Accessories »

Command Prompt.
2. Type sqlplus, then press Enter.
3. Type the user name system, then press Enter.

4. Type the password manager, then press Enter.

+ Ifa“Connected to:” message is displayed, the Oracle®
database was installed correctly. Proceed to “Uninstalling
the Software” on page 164.

+ If the Oracle® database was not installed correctly,
complete Table A-1, “Troubleshooting checklist,” on
page 170, then contact Technical Support.

162 GeneMapper® Software 5 Installation and Administration Guide



Appendix A

Check the After installation, if you have trouble connecting to the default
Oracle® Services database, perform the following tasks:

* Check the Oracle® Services
+ Check to see if the Oracle® services are running.

IMPORTANT! Make sure that the GeneMapper® Software is closed.

1. Right-click Computer and select Manage.

2. Expand Services and Applications and select Services.

LI Computer Management [’._|[’E|r‘5__<|
g File  Action Wiew ‘Window Help el x|
& || 2
Computer Management {Local) Gt
= m Syskem Tools
+E
+ a E;:::::;T;;rs Select an item ko view its description. Mame Description | Status Startup Type
o % Local Users and Groups %Network DDEDSDM  Manages D... Disabled
+- 8] Performance Lags and ¢ %Network Location A...  Collects an...  Started Manual
__E__l_:‘ Device Manager %Network Provisionin... Manages X... Manual
= @ Storage %NT LM Security Sup...  Provides s... Manual
+ Removable Storage %NVIDIA Display Driv... Provides s...  Started Automatic
g Disk Defragmenter %Office Source Engine  Saves inst... Manual
Disk Management 8 OracleIFATHSListener Started Automatic
=1 Services and Applications 8 OraclelobScheduler. . Disabled =
Services %OracleServiceIFA Started Aukomatic
WML Control Performance Logs a... Collects pe... Manual
* g Indexing Service %Plug and Play Enables ac... Started Automatic
%Portable Media Seri... Retrievest... Disabled
Print Spooler Loads files ... Started Automatic
%Protected Storage Provides pr... Started Automatic Z
e renn Peeddeo o wa_ ! Y
& ! ?
< | * \ Extended A Standard

3. Scroll to OracleServicesIFA and OracleIFAListener and
check if they have started.

4. If they are not listed as “Started” under the Status column,
right-click the service name and select Start.

5. After the services have started, restart the GeneMapper®
Software.
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Uninstalling the Software

Uninstall  To uninstall the GeneMapper® Software, perform the following
Tasks tasks:

Task See page
1. Verify that you are logged in as a user with administrator 165
privileges.
2. If you are uninstalling an co-installation configuration of 166
the GeneMapper® Software, start the Data Collection
Software.
3. Uninstall the software. 168
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Verifying Note: Administrator privileges means you have complete and
that You Are unrestricted access to the local computer.
a User with
Administrator 4
Privileges )

In the desktop, select Start » Control Panel.
2. In the Control Panel window, double-click User Accounts.

3. In the Users tab of the User Accounts dialog box, verify that the
user account you are using belongs to the Administrators group
and to the domain with the same name as the computer name.

Example:

User, swccounts

Users | Advanced

Use the list below to grant or deny users access to your
computer, and ko change passwords and other settings,

Users For this computer:

User Mame Domain Group L

I i Administratar Adrministrators
lgGuest D4BPF351 Guests | B Belongs to the

Administrators

Domain is the same

v as the computer
name
Add... ] [ Remove ] [ Properties ]
Password for Administrator
Ta change the password For Administrator, click Reset
Password,

Ok H Cancel ]

4. Click OK.
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Starting the  Before you uninstall co-installation configuration of the
Data Collection GeneMapper® Software, start the Data Collection services.

Services
To start the Data Collection services:

1. Select Start » All Programs » Applied Biosystems »
Data Collection » Run <Data Collection version>, where
<Data Collection version> is one of the following:

* 3730/3730x! Data Collection v3.1
* 3130/3130x/ Data Collection v3.1

After the Service Console opens, wait until all four symbols
change to green squares.

[ Service Console glilg‘ [ Service Console glilg‘

=

Messaging Service & Messaging Service

Data Service O Data Service
Instrumert Service O Instrumert Service

Note: If the services do not start automatically, click Start All.

2. If the Data Collection Software requires a password, a login
dialog box displays. Type the Login Name and Password, then
click OK.

Note: If you do not know the Login Name or Password, contact
the administrator.

3. Confirm that Data Service started without errors:

a. In the Service Console, right-click the square next to Data
Service and select Show Console to display the Data
Service output window.
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[@ Service Console

Messaging Service

_J

— Right-click here
Data Service Shark

Stop

Instrument Service

Wigwer

Start All Restart Al Stop Al

b. Confirm that no errors are displayed in the lower pane of
the window, then close the Data Service output window.

£ pata Service output

[INFO,Defsult] 10:59:33.643 Found disk space for drive G: = -1
[INFO,Default] getCurrentStatusTypes. ..

[INFO,Defaule] 10:59:35.718 For testing only: ICFGetManualCont
[INFO,Default] 3130, instrumentTypeName= ga3l00-Avant
[INFO,Default] getCurrentStacusTypes. ..

[INFO,Default] 10:59:36.562 WARNING: No valid spatial calibrat .,

< | >

No errors
displayed
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Uninstall the  This procedure removes the GeneMapper® Software and the Oracle®
Software Database Standard Edition.

To uninstall the GeneMapper® Software:
1. Ensure that the Data Collection software is open (see page 166).

2. Close all other applications (including the GeneMapper®
Software) and windows before proceeding with the uninstall.

Note: If you do not close the GeneMapper® Software before
proceeding with the uninstall, the uninstall will fail. The next
time you attempt to uninstall the GeneMapper® Software, the
operating system performs a disk check. If inconsistencies are
found during the disk check, you may be required to correct
issues involving some GeneMapper® Software files.

3. Select Start » Control Panel.

4. Double-click Add or Remove Programs.

Note: If you receive the message stating that you need
administrator rights or privileges, log off of the computer, then
log on again as a user with administrator privileges.

Select the GeneMapper® Software.
Click Change/Remove. The InstallShield Wizard starts up.

In the Welcome window, select Remove, then click Next.

© N o O

At the prompt, click OK to confirm the uninstall.
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9. Ifyou are uninstalling an instrument configuration, the message
below appears. Be sure Data Collection services is open, then
click OK to start the uninstall.

"j Please make sure Data Collection services are on during the Uninstall,

Click. O to continue the Uninstal,

10. When the Maintenance Complete window appears, finish the
uninstallation process:

IMPORTANT! Ifyou are upgrading an instrument configuration,
stop the Data Collection services before restarting your
computer by clicking Stop All in the Service Console for the
Data Collection Software:

m Service Console ‘ZHE'E‘

Messaging Service

Data Service

Instrument Service

Wigwer

| Gwa ——— Stop Al

a. Select Yes, I want to restart my computer now.
b. Click Finish.
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Troubleshooting Checklist

IMPORTANT! Complete the Troubleshooting Checklist before
contacting Life Technologies Technical Support for assistance.

Table A-1

Troubleshooting checklist

Check

Information for Technical Support

Summarize the problem:

Have you been able to repeat the problem?

If yes, list the steps that you perform:

N o o Mo

Life Technologies personnel that you have contacted:
(J Field Applications Specialist

(1 Field Service Engineer

(d Technical Support

1 Sales Representative

 Order Administration

a Other

Computer specifications:
e QOperating system:

* \ersion:

* Processor

e Memory

e Hard disk space:

¢ Hard disk configuration:

170

GeneMapper® Software 5 Installation and Administration Guide



Table A-1

Appendix A

Troubleshooting checklist (Continued)

Check

Information for Technical Support

Software installed:

(1 Data Collection Software version:
[ Status of Data Collection services:
1 GeneMapper® Software version:
d Other Life Technologies software:

Computer login information:

e User privileges:
e | ocal or networked domain:

Software configuration installed:

3 Instrument
1 Stand-alone
[ Client

Instrument and instrument computer information:

e Model:

e Data Collection Software version:
e Status of Data Collection services:
e Other Life Technologies software:
e Capillary length:

e Capillary lot number:

¢ Run module:

e Dye set:

Chemistry kit or reagent, with version number:

Be prepared to send to Technical Support:

e |[nstallation log file (page 162)

¢ Exported panels

e Exported bins

e Exported size standard definition
¢ Exported analysis method

e Sample (.fsa) files

e GeneMapper_log.txt

¢ PanellmportLog.txt

® Printed results
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This appendix covers:
B Operating the Software from a Command Line
B Example Commands ....................

B Command Line Arguments ...............
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from a Command Line
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Operating the Software from a Command Line

Overview

About the
Interface

Command Syntax

174

This appendix explains how to analyze, import, and export data from
the command line interface of the GeneMapper® Software.

IMPORTANT! Life Technologies supports the use of the command
line interface only as it is explained in this manual.

Note: If you are unfamiliar with Microsoft DOS, Life Technologies
recommends running the application from the user interface.

The primary advantage of the GeneMapper® Software command line
interface is that it can automate most software operations without
using the graphic user interface. If incorporated as part of a batch file
or a scripted sequence, the commands can eliminate most of the
repetitive, data-entry tasks associated with project analysis. Use of
the command line interface is intended for advanced users (such as
systems administrators, bioinformaticians, and network
administrators) who choose to operate the application using a
scripting language.

Commands are issued to the GeneMapper® Software command line
interface via the MS DOS shell of the Windows operating system.
The basic formula for all commands is as follows:

<GeneMapper.exe> -commandline <arguments>

where:

* <GeneMapper.exe> isthe path and filename of the executable
file for the GeneMapper® Software.

* -commandline is the argument that placed the software into
command line mode.

* <arguments> is the series of arguments that specify the
operation(s) to be performed.
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Creating a Batch  This section explains how to use the command line interface of the
File to Run the GeneMapper® Software by creating a common batch file for the
GeneMapper® Windows® operating system. The use of batch files is a convenient

Software method to author and submit command line commands to the
GeneMapper® Software; however, use of the command line interface
is not limited to the method demonstrated here.

To create the batch file:

1. In the desktop, open the Windows Notepad accessory
(Start » All Programs » Accessories » Notepad).

2. In the Notepad window, type @ECHO OFF to instruct the
operating system to hide the batch file commands as they are
executed.

Note: If you want the operating system to display each
command in the MD DOS prompt as it is executed, replace
@ECHO OFF with @ECHO ON. The @ECHO ON command
can be useful when troubleshooting batch file errors. If the
software encounters an error when executing the commands in
the batch file, you can review the contents of the batch file to
identify the offending command.

3. Press Enter to create a new line.

4. In the Notepad window, type the following:

@echo off

“GeneMapper” -commandline -option h -username “user” -password
“password” -project “project”

where:

* GeneMapper is the directory path for the GeneMapper®
Software executable (enclosed in double quotes).

* user is the name of a user account with privileges
sufficient to perform the desired functions (enclosed in
double quotes).

* password is the password of the user account (enclosed in
double quotes).

* project is the name of the project to create or analyze
(enclosed in double quotes).
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For example:

@echo off

“D:\AppliedBiosystems\GeneMapper \app\GeneMapper .exe” -commandline -
option h -username “gm” -password “password” -project “snpProject”

5. Following the -project argument, type any additional
arguments to instruct the GeneMapper® Software to perform the
desired functions. See “Command Line Arguments” on
page 183 for a complete list of all arguments.

IMPORTANT! Follow the guidelines below when entering
commands:

* Add arguments to the command in any order.

» Type all arguments on the same line of text (the command
cannot contain hard or soft returns)

* Enclose the user-defined component of arguments in
double quotes (for example: -project “my project”)

+ Separate all arguments using a space (ASCII character 32).

6. (Optional) After typing the last argument in the command,
repeat steps 3 through 5 to enter additional commands.

Note: The operating system executes the commands in the
order that they appear in the batch file (from top to bottom).

7. (Optional) After typing the last command:
a. Press Enter to create a new line.
b. Type ECHO Batch file operation complete.

c. Press Enter to create a new line.
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Example batch file:

@ECHO off

“D:\AppliedBiosystems\GeneMapper \app\GeneMapper .exe” -commandline -
option h -username “gm” -password “password” -project “snpProject” -
analysismethod “snpAM” -sizestandard “snpSS” -panel “snpPanel”
—snpset “snpSetl” -folder “D:\populationStudy\asian D:\
populationStudy\caucasian” -ladder “D:\populationStudy\asian
ladderl.fsa ladder2.fsa” -ladder “D:\populationStudy\caucasian
ladder.fsa” -exportall “D:\populationStudy\genemapper_export.txt”

ECHO Batch file operation complete.

Note: See “Example #2: SNPlex® System Analysis” on
page 180 for an explanation of the example batch file.

8. When finished, carefully review the text of the batch file for any
€rrors or typos.

9. When satisfied with the content of the file, save the text as a
batch file:

a. Select File » Save.

b. In the File name field, type a name for the batch file that
terminates in the .bat file extension.

For example: mybatchfile.bat or GManalysis.bat
c. Click Save.

10. Select File » Exit to close the batch file.

GeneMapper® Software 5 Installation and Administration Guide 177



178

Appendix B

To run the batch file, double-click the file icon and wait for the
computer to run the scripted command. While the GeneMapper®
Software executes the command(s) in the batch file, the operating
system displays a command prompt window. When the operating
system has finished processing the batch file, the command prompt
window displays Press any key to continue.

A (O.\[eIN] Do not close the command prompt window before

it displays “Press any key to continue.” Doing so prematurely
terminates the command(s) executed by the batch file and could
result in loss of data.

Note: Depending on the speed of your computer and the number of
commands included in your batch file, the operating system may take
several minutes to a number of hours to process the batch file.
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Example Commands

Example B Example #1: Basic Sample File Analysis ........ (see below)
Commands in ® -
. . B Example #2: SNPlex® System Analysis ............... 180
This Section ramp Y Y
B Example #3: Sample File Analysis with Named Ladders .. 181
B Example #4: Export of Project Data .................. 182

Example #1: Basic Sample File Analysis

Purpose This command was written to analyze sample files that have been
configured with the appropriate analysis method, size standard,
panel, SNP set, and ladder using the Data Collection Software (the
default options can also be used to perform the analysis).

Description  The command logs into the GeneMapper® Software using the default
user account and password (gm and password) and analyzes the
sample files located in the d:\mouseStudy\mouseTrait directory. After
the analysis, the command instructs the software to save the project
as Mouse Project.

Example File

@echo off

“D:\AppliedBiosystems\GeneMapper\app\GeneMapper .exe” -commandline -
option h -username “gm” -password “password” —-project
“Mouse Project” -folder “d:\mouseStudy\mouseTrait”

ECHO Batch file operation complete.
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Example #2: SNPlex® System Analysis

Purpose This command was written to perform a SNPlex® System analysis.

Description  This command logs into the GeneMapper® Software using the default
user account and password (gm and password) and analyzes the
sample files located in the d:\populationStudy\asian and d:\
populationStudy\caucasian directories using the snpAM analysis
method, the snpSS size standard, the snpPanel panel, and the snpSet ]
SNP set. The command also instructs the software to use the
ladder1 fsa and ladder2.fsa sample files located in the d:|
populationStudy\asian directory, and the ladder.fsa sample file
located in the d:\populationStudy\caucasian directory as allelic
ladders for the analysis. Following the analysis, the command
instructs the software to save the project as SNP Project, and then to
export the Samples and Genotypes tables to the d:\populationStudy\
folder as the genemapper_export.ixt file.

Example File

@echo off

“D:\AppliedBiosystems\GeneMapper\app\GeneMapper .exe” -commandline -
option h -username “gm” -password “password” -project “SNP Project”
-analysismethod “snpAM” -sizestandard “snpSS” -panel “snpPanel”
—-snpset “snpSetl” -folder “d:\populationStudy\asian d:\
populationStudy\caucasian” -ladder “d:\populationStudy\

asian ladderl.fsa ladder2.fsa” -ladder “d:\populationStudy\
caucasian ladder.fsa” -exportall “d:\populationStudy\
genemapper_export.txt”

ECHO Batch file operation complete.
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Example #3: Sample File Analysis with Named Ladders

Purpose

Description

Example File

@echo off

This command was written to analyze sample files that have been
configured with the appropriate analysis method, size standard, panel,
SNP set, and ladder using the Data Collection Software (the default
options can also be used to perform the analysis).

The command logs into the GeneMapper® Software using the default
user account and password (gm and password) and analyzes the sample
files located in the e:\dog project\dog trait. The command also
instructs the software to use the dog ladder1.fsa and dog ladder?2 fsa
sample files located in the e:\dog project\dog trait directory as the
allelic ladders for the analysis. After the analysis, the command
instructs the software to save the project as Dog Project before closing
the application.

“D:\AppliedBiosystems\GeneMapper\app\GeneMapper .exe” —-commandline -
option h -username “gm” -password “password” -project “Dog Project”
—folder “e:\dog project\dog trait” -ladder “e:\dog project\dog
trait” “dog ladderl.fsa” “dog ladder2.fsa”

ECHO Batch file operation complete.
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Example #4: Export of Project Data

Purpose This command was written to export the sizing data and analyzed
electropherogram data for the sample files of an existing project.

Description  The command logs into the GeneMapper® Software using the default
user account and password (gm and password) and exports the sizing
data and analyzed electropherogram data of the California Orange
project as the g:\lorange project\size map.txt and g:\orange project\
analyzed eps.txt files.

Example File

@echo off

“D:\AppliedBiosystems\GeneMapper\app\GeneMapper .exe” -commandline -
option h -username “gm” -password “password” -project

“California Orange” -exportsizemap “g:\orange project\size map.txt”
-exportanalyzedeps “g:\orange projectlanalyzed eps.txt”

ECHO Batch file operation complete.
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Command Line Arguments

Conventions This section uses the following text conventions:

* “italic text” — Italic text appearing between double
quotation marks (‘“”’) must be substituted with custom values
when entered as part of a command.

IMPORTANT! Always enclose italic text in double quotes (“This
is an example”). The quotations allow the software to
accommodate spaces in the user-defined text.

* bold text — Bold text must be typed exactly as it appears.

. — Grey table cells indicate the required elements

of all commands issued via the command line interface.

Commands Table B-1 contains a summary of all parameters for the command
line interface.
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Table B-1 Summary of arguments for the GeneMapper® Software command line interface
Argument Action/Definition Usage
-analysismethod Specifies the name of the analysis -analysismethod “method”
method to use in the analysis of the where method is the name of the analysis
specified project. method.
-commandline Configures the GeneMapper® Software | -commandline
to operate in command line mode.

-deleteproject Deletes the specified project(s). -deleteproject “projectl” “project2” ..
where projectl and project2 arethe names
of the projects to be deleted.

-deletesnpset Deletes the specified SNP sets. -deletesnpset “snpsetl” “snpset2” ..
where snpsetl and snpset2 are the names of
the SNP sets to be deleted.

-exportall Exports the combined contents of the -exportall “filename”

Samples and Genotypes tables of the ' \yhere £i1ename is the long path (file name
specified project as a tab-delimited text ' appended to the export directory path) of the
file of the specified name. exported file.

-exportanalyzedeps Exports the analyzed electropherogram | -exportanalyzedeps “filename”

data for the samples of the specified where filename is the long path (file name
prOJep_t as a tab-delimited text file of the appended to the export directory path) of the
specified name. exported file.

-exportbinoffsettable Exports the bin offsets for the specified | -exportbinoffsettable “filename”

project as a tab-delimited text file of the
specified name.

where filename is the long path (file name
appended to the export directory path) of the
exported file.

-exportclustergenotypetable

Exports the Genotypes table of the
Cluster Plot Manager for the specified
project as a tab-delimited text file of the
specified name.

-exportclustergenotypetable “filename”
where filename is the long path (file name

appended to the export directory path) of the
exported file.
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Table B-1 Summary of arguments for the GeneMapper® Software command line interface (Continued)

Argument

-exportgenotypetable

Action/Definition

Exports the Genotypes table for the
specified project as a tab-delimited text
file of the specified name.

Usage

-exportgenotypetable “filename”

where filename is the long path (file name
appended to the export directory path) of the
exported file.

-exportplotsampletable

Exports the Samples table of the
Samples plot for the specified project
as a tab-delimited text file of the
specified name.

-exportplotsampletable “filename”
where filename is the long path (file name

appended to the export directory path) of the
exported file.

-exportsampletable Exports the Samples table for the -exportsampletable “filename”
specified project as atab-delimited text | \here £i1ename is the long path (file name
file of the specified name. appended to the export directory path) of the

exported file.

-exportsizemap Exports the sizing data for the specified -exportsizemap “filename”
project as a tab-delimited text file of the | \yhere £i1ename is the long path (file name
specified name. appended to the export directory path) of the

exported file.

-exportsnptable Exports the specified SNP table for the | -exportsnptable “filename”
specified project as a tab-delimited text | \yhere £i1ename is the long path (file name
file of the specified name. appended to the export directory path) of the

exported file.

-folder Specifies the names of the affected run | -folder “folderl” “folder2” ..

folders in the project:

e If analyzing by run, the argument
specifies the run folder of interest

¢ If analyzing by project, the argument
specifies the run folders of interest in
the specified project.

where folderl is always required. The

following folders are needed only if analyzing by

project (not used when analyzing by run).
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Table B-1 Summary of arguments for the GeneMapper® Software command line interface (Continued)

Argument

-help

Action/Definition

Prints a summary of the commands for
the command-line interface.

Usage

-help

-importanalysismethod

Imports the specified file as an analysis
method.

-importanalysismethod “filename”
where filename is the long path (file name
appended to the import directory path) of the
imported file.

IMPORTANT! The specified file must be formatted as an XML file that uses GeneMapper-
specific syntax and contains the necessary analysis method data in the format identical to

that of an exported analysis method.

-importproject

-importsizestandard

-importsnpset

Imports the project or projects stored
by the specified file.

IMPORTANT! The specified file must be
function of the GeneMapper Manager.

Imports the specified file as a size
standard.

IMPORTANT! The specified file must be

-importproject “filename”

where filename is the long path (file name
appended to the import directory path) of the
imported file.

an exported project file (*.) created by the export

-importsizestandard “filename”

where filename is the long path (file name
appended to the import directory path) of the
imported file.

formatted as an XML file that uses GeneMapper-

specific syntax and contains the necessary size standard data in the format identical to that

of an exported size standard.

Imports the specified file as a SNP set.

IMPORTANT! The specified file must be

-importsnpset “filename”

where filename is the long path (file name
appended to the import directory path) of the
imported file.

formatted as an XML file that uses GeneMapper-

specific syntax and contains the necessary SNP set data in the format identical to that of an

exported SNP set.
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Table B-1 Summary of arguments for the GeneMapper® Software command line interface (Continued)

Argument

-ladder

Action/Definition

Instructs the software to use the
specified samples as allelic ladders in
the analysis of the specified project.

Usage

-ladder “folder” “ladderl” “ladder2” ..

where:

e folder isthe name of the project folder that
contains the negative control samples.

® Jadderl and ladder?2 ... are the names of
the allelic ladder sample files separated by a
space.

-negcontrol

Instructs the software to use the
specified samples as negative controls
in the analysis of the specified project.

-negcontrol “folder” “ctrll” “ctrl2"” ..

where:

e folder isthe name of the project folder that
contains the negative control samples.

e ctrll and ctri2 ...arethe names of the
negative control sample files separated by a
space.

-option

Specifies the options for the exported
data.

-option “option”;“option”;..;“option”

where option is any of the following option

letters:

® b - Attaches bin names to the exported
Genotype table

e h - Hides the user interface

e p “port” - Specifies the monitoring TCP/IP
port number (default is 8393)

-panel

Specifies the name of the panel to use
in the analysis of the specified project.

-panel “panel”
where panel is the name of the panel.

-password

Specifies the password for the user
account defined by the ~username
argument.

-password “password"”

where password is the password for the user
account.
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Table B-1 Summary of arguments for the GeneMapper® Software command line interface (Continued)
Argument Action/Definition Usage
-poscontrol Instructs the software to use the -poscontrol “folder” “ctrll” “ctrl2” ..
specified samples as positive controls where:
in the analysis of the specified project. ) )
e folder isthe name of the project folder that
contains the positive control samples.
e ctrllandctrl2 ...arethe names of the
positive control sample files separated by a
space.
-project Specifies the name of the project to -project “project”
create or analyze. where project is the name of project.
-sizestandard Specifies the name of the size standard | -sizestandard “standard”
to use in the analysis of the specified where standard is the name of the size
project. standard.
-snpset Specifies the name of the SNP set to -snpset “snpset”
use in the analysis of the specified where snpset is the name of the SNP set.
project.
-username Specifies the user account with which -username “user”

to perform the actions of command.

where user is the name of a user account.

IMPORTANT! The user account that you use must have privileges sufficient to perform the

desired function(s).

g xipuaddy



E— Migrating Data Using the
GeneMapper® Database
Utility Wizard

When to use  Use the utility wizard to export the database from the GeneMapper®
Software installed on a Windows XP computer.

Use this procedure to export the database from a Windows XP
computer with the following GeneMapper® Software configuration:
 Stand-alone (not co-installed with Data Collection software)

* Co-installed on a 3500 Series computer (the 3500 Series Data
Collection software does not store data in a database)

IMPORTANT! This procedure exports the entire database. For
computers with a GeneMapper® Software co-installation that share
the database with the Data Collection software (3730 Series, 3130
Series, 3100, or 310 computers), follow the procedure in
Appendix D, Migrating Data Manually.

The GeneMapper® Database Utility Wizard is included on the
GeneMapper® Software v5 Full Installation DVD.

Procedure 1. Insert the Full Installation DVD.

2. In the launcher window, click Software Extras, then click
GeneMapper Database Utility Wizard.

3. In the GeneMapper Database Utility Wizard window, select
MIGRATE.

Note: The MIGRATE option only exports the database to a
.dmp file; it does not actually migrate the GeneMapper®
Software. When you perform a full installation of the software
(described on page 35), the software prompts you to import the
.dmp file.
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| £ GeneMapper Database Utility Wizard EI@
Steps Select Task
1. Select Task Welcome to the GeneMapper Utility Wizard!
2. This wizard will guide you in upgradi igrating your
Please select your desired task:
Basic User
) MIGRATE:

Acvanced User
) EXPORT:
| want to export GeneMapper data.

' IMPORT:
| want to import GeneMapper data.

| have an existing GeneMapper application. | want to move the GeneMapper application to another system while retaining the data.

Please select a task.

Other functions

190

Cancel

4. Click Next and follow the instructions in the wizard.

Note: Exporting or importing the database may take a while to
complete. You can check the progress by opening the minimized
command prompt window.

Click Finish.

6. Perform a full installation (page 35). The full installation

prompts you to import the .dmp file.

The wizard also includes the following functions. These
functions are for use to export and import on the same computer.

Note: Do not use the IMPORT function to import the .dmp file
into the GeneMapper® Software on the Windows 7 computer.
When you perform a full installation of the software (described
on page 35), the software prompts you to import the .dmp file.

+ EXPORT makes a copy of the database and saves it to the
folder that you specify.

Note: Exporting a database may require more disk space
than is available. You may need to export the database
temporarily to a different hard drive.
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* IMPORT restores the exported database to the upgraded
software. This is done automatically by the upgrade
installer during installation. However, you can use this
option to manually import the GeneMapper database.

Log File  The wizard log file is written to: <C>: \AppliedBiosystems\
logs\GeneMapper4l DB_Utility\wizard.log
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Migrating Data Manually

When to use  Use this procedure to:

+ Export GeneMapper® Software components from the database
on a Windows XP computer co-installed with 3730 Series, 3130
Series, 3100, or 310 Data Collection Software. In these
co-installation configurations, the GeneMapper® Software and
the Data Collection Software share the database.

+ Import GeneMapper® Software components into the database on
a Windows 7 computer co-installed with 3730 Series, 3130
Series, 3100, or 310 Data Collection Software.

Note: For computers with a GeneMapper® Software co-installation
on a stand-alone or a 3500 Series computer, follow the procedure in
Appendix C, Migrating Data Using the GeneMapper® Database
Utility Wizard.

Export procedure 1. Export projects elements:

a. In the GeneMapper main window, select
Tools » GeneMapper Manager.

b. Select a tab:
* Projects
* Analysis Methods
+ Table Settings
* Plot Settings
* Cluster Plot Settings
* Matrices
+ Size Standards
* SNP Sets
* Report Settings

c. Select the object(s) you want to export. Press and hold
Shift or Ctrl to select multiple objects.
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d. Click Export.

e. Repeat for all remaining tabs.

2. Export projects elements:

a. In the GeneMapper main window, select
Tools » GeneMapper Manager.

b. Select a tab:
* Projects
* Analysis Methods
+ Table Settings
*+ Plot Settings
* Cluster Plot Settings
* Matrices
+ Size Standards
* SNP Sets
* Report Settings

c. Select the object(s) you want to export. Press and hold
Shift or Ctrl to select multiple objects.

d. Click Export.

e. Repeat for all remaining tabs.

3. Export studies:

a. In the GeneMapper main window, select Tools » Study
Manager.

b. Select File » Manage Study.
c. Select the studies, then click Export.

4. Export security settings:

a. In the GeneMapper main window, select
Tools » Security Manager.

b. In the Access Control Administration window, select
File » Export Database.

c. In the Save dialog box, type a file name for the exported
file, select Access Control files (.acc), then click Save to
export the security settings as an .acc file.

d. In the Export Users dialog box, click OK.
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5. Export audit records:

a. In the GeneMapper main window, select
Tools » Audit Manager » Backup Audit Records.

b. In the Save dialog box, type a file name for the exported
file, then click OK.

6. Copy all exported data to the computer on which you installed
the new version of software.
Import procedure  Import the data in the following order:
1. Security settings
2. Audit records

3. Analysis methods, Table Settings, Plot Settings, Cluster Plot
Settings, SNP Sets, Report Settings, Matrix, Kits, Panels, Bin

Sets
4. Projects
5. Studies
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ABB (Automatic
Bin Builder)

access control list

Admin profile

admin security
group

admin user group

administrator user

ADO
AE

AFLP

Glossary

The first step in accurate allele assignment. After sample files are
collected, bins are created by the ABB based on the chosen panel
information and successive allele calls from sample file collection.
As each sample file in the collection is processed, the bin definitions
are refined to reflect the actual data.

(See security group)

A pre-configured profile that cannot be removed and that has execute
access to all functions. Initially associated with the “admin” user. (A
user must always have an assigned profile.)

A pre-configured security group that cannot be removed. This
security group has been granted all rights to all data, to provide a way
for at least one user to have “admin” access to all data.

A pre-configured user group that cannot be removed and that is
always associated with the Admin security group.

A pre-configured user that cannot be removed and that is always
associated with the Admin user group.

Allele Display Overflow PQV
Allele Edit PQV

Amplified Fragment Length Polymorphism. A DNA fingerprinting
technique that allows the comparison of the DNA from different
organisms. DNA fragments of varying lengths are created by
cleaving an organism’s DNA with restriction enzymes; a specific
subset of these fragments are amplified and analyzed for comparison
purposes.
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algorithm

all user group

allele

allele call

allele-calling

allelic ladder

AN

analysis method

analysis
parameters

198

A set of ordered steps for solving a problem, such as a mathematical
formula or the instructions in a program. The terms algorithm and
logic are synonymous, where both refer to a sequence of steps to
solve a problem. However, an algorithm is an expression that solves a
complex problem rather than the overall input-process-output logic
of typical business programs.

A user group that contains all users. A user cannot be disassociated
from the user group.

One of two or more alternate forms of a marker or gene.

Reference alleles are all alleles or bins created in a bin set in the
GeneMapper Software. They are denoted by a red cross hatch + in
the Panel Manager.

Project alleles are all alleles detected in sample data in a project in
the GeneMapper Software. They are denoted by a blue asterisk in the
Panel Manager.

Identification of the specific allelic form of a marker.

Identification of alleles based on bin definitions; genotyping;
GeneMapper® Software analysis

A sample of DNA containing most possible alleles for a specific
marker or set of markers. Used to create a sample file that the
GeneMapper Software can use to genotype or make allele calls on
sample data.

Within the GeneMapper Software, you select a Sample Type of
Allelic Ladder for the sample file generated using an allelic ladder.

Allele Number PQV

A collection of user-defined parameters that determine the bin set and
analysis algorithms.

A collection of user-defined settings (including analysis method, size
standard, and panel) that determine the sizing and genotyping
algorithms used by the GeneMapper Software to analyze all sample
files in a project. Also called project settings.
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association Two identifiers combined are said to be associated. A user can be
associated with a user group. A user group associated with a security
group yields a set of data rights.

audit event A single permanent change to one or more attributes of an object.
Includes creating a new instance of an object or deleting an exiting
one.

audit map An object associated with an object type; used to tell the audit

component how to audit an object type.

audit object A collection of data defined by an application. Also referred to as an
object.

audit record The description of a single audit event.

autopanelizer A feature that uses reference data generated by the Primer Focus kit

to quickly define new SNP markers and bin sets.
BD Broad Peak PQV

bin Within the GeneMapper Software, a fragment size (bp) or basepair
range and dye color that define an allele within a marker. You create
a bin for each possible allele associated with a marker.

BIN Out of Bin Allele PQV

bin set Within the GeneMapper Software, a collection of bins (allele
definitions), typically specific to a set of experimental conditions,
usually an instrument. Bin sets are available inside a kit.

cache An “in memory” representation of the access control data. The
Admin Tool modifies the data in the cache. When the Admin Tool or

Admin API issues the “save” command, the data in the cache are
written to the data store.

CC Control Concordance PQV

challenge A term from user authentication indicating that the user is asked to
provide identification (typically by entering a password).
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chromosome

control

control security
group

data access control
data group

data rights
database

diploid

DP

dye set

electropherogram

electrophoresis

gene

200

A long stretch of coiled strands of DNA and proteins containing
many genes. Human DNA is contained within 23 pairs of
chromosomes.

See “positive control” on page 203.

See “negative control” on page 202.

The security group assigned to an Access Control administrative
identifier (user, user group, security group, profile). This security
group is used to determine access by a user to the administrative data
in the Administrative GUI and API.

The part of access control that administers access to user data.

(See security group)

Properties that define the type of access a user has to a piece of data.
One form of offline storage.

Having two sets of chromosomes and, therefore, having two alleles
per marker or gene. Human cells (other than egg and sperm cells) are
diploid.

Double Peak PQV

A set of four to five different colored dyes. A specific dye set is used
to label DNA fragments or markers in matrix standards, installation

standards, and chemistry Kkits.

A graphical representation of the intensity (y-axis) of bands produced
in a single gel lane or capillary as a function of time (x-axis).

A technique used to separate molecules by using an electric field to
pass those molecules through a porous matrix.

The basic unit of heredity that carries the genetic information for a
given RNA molecule or protein.
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genome

genotype

GQ

haploid

heterozygous
homozygous

installation
standard

kit

LMS

locus
LPH

marker

All the DNA contained in an organism or cell, including both the
chromosomes in the nucleus and the DNA in the mitochondria.

The set of allele calls for specific markers or genes within an
organism. (noun)

To determine the allele calls for specific markers or genes within an
organism. (verb)

Genotype Quality PQV

Having one set of chromosomes and, therefore, having one allele per
marker or gene. Human egg and sperm cells are haploid.

Having two different alleles for a specific marker or gene.
Having two identical alleles for a specific marker or gene.

A collection of known genetic markers, labeled with dyes from a
specific dye set, used to test the function of a genetic analyzer.

Within the GeneMapper Software, a group of panels.

Linkage Mapping Set; Life Technologies chemistry using
dinucleotide repeat microsatellite markers

The chromosomal location of a genetic marker or gene.
Low Peak Height PQV

A known segment of DNA that has two or more allelic forms. A
marker exists at a known chromosomal loci and can be a gene or a
non-gene. See also microsatellite and SNP.

Within the GeneMapper Software:

A microsatellite marker is defined by a name, fragment size range
(bp), dye color, and repeat length.

A SNaPshot® kit analysis marker is defined by a name and fragment
size range (bp).
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matrix standard

microsatellite

MNF
NB

negative control

OBA
(O]
OVL

panel

phenotype
PHR

polymorphism

202

A collection of known DNA fragments, labeled with four to five
different colored dyes from a specific dye set. The matrix standard is
run on a genetic analyzer and used for spectral calibration of sample
fragments that are run on the same instrument and labeled with the
same dye set.

Microsatellite markers, also known as short tandem repeats (STRs),
are polymorphic DNA loci consisting of a repeated nucleotide
sequence. The repeat sequence can be from 2 to 7 base pairs long.
The number of repeat units varies within a population, thereby
creating multiple alleles for a microsatellite locus.

Matrix Not Found
Narrow Bin PQV
A blank sample that contains no DNA, but all other reagents used in

the experiment. It can indicate if any contamination came from
sample preparation.

In the Sample tab of GeneMapper Software, you select a Sample
Type of Negative Control for the sample file generated from the
negative control. Additionally, in the Panel Manager you define the
negative control when creating markers.

One Basepair Allele PQV

Offscale PQV

Overlap PQV

A group of markers. Within the GeneMapper Software, you associate
a panel with a bin set to provide bin definitions for the markers.

The physical manifestation of a genotype.
Peak Height Ratio PQV

Diftferences between organisms’ or individuals’ DNA. Variations of
allele calls.
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positive control A sample that contains DNA with known alleles for specific markers.
Its purpose is to verify that the PCR amplification, electrophoresis,
and GeneMapper® Software analysis worked correctly.

In the Sample tab of GeneMapper Software, you select a Sample
Type of Positive Control for the sample file generated from the
positive control. Additionally, in the Panel Manager you define the
positive control when creating markers.

PQv Process Component-Based Quality Values reported by data analysis
and are an aid to finding and fixing problems in sample preparation
and analysis.

primer A single-stranded piece of DNA or RNA that anneals to a
complementary section of DNA and serves as a starting point for
chain extension by DNA polymerase.

Primer Focus® kit An Life Technologies kit containing reagents used to create and
amplify all four possible alleles of any SNP marker. The kit allows
you to take advantage of the Auto Panel feature in the GeneMapper
Software to automatically create bins for each allele in a SNaPshot
kit analysis.

probe A DNA or RNA fragment that has been labeled in some way (for
example, fluorescent or radioactive), then used in a molecular
hybridization assay to identify DNA or RNA sequences that are the
same or closely related to it in sequence.

profile An identifier that gives an administrator the ability to grant or revoke
access to functions.

project Within the GeneMapper Software, a collection of sample files and
the analysis parameters for genotyping them.

project settings See “analysis parameters” on page 198.
project settings Parameters set by the user to prepare a project for analysis.
reference samples All or a subset of the actual samples. The reference samples typically

contain all of the alleles present in the sample set and are used to
create a bin for each allele within the GeneMapper® Software.
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rights

security group

security ID

SFN

SFNF

SHP

silent auditing

size match editor

size standard

SNaPshot® kit

SNaPshot® System
Multiplex Analysis

SNF

SNP

204

Properties that define whether a user has access to data or a function.

An identifier that can be associated with a user group to confer a set
of data rights.

The universal identifier of the security group and the preferred name
of the column in an application table that holds the security group ID.

Sample File Normalization

Sample File Not Found

Sharp Peak PQV

Automatic audit record creation (without prompting of the user).

A window in GeneMapper® Software that allows users to examine
size-standard electropherograms, edit the identification of size-
standard peaks, and view the size-calling curve.

A collection of DNA fragments of known lengths within a range (for
example, 50 to 400 bp) all tagged with the same dye. The size
standard is co-injected into the genetic analyzer capillary with the
sample, then used to size the sample data. All Life Technologies size
standards are labeled with a red or orange dye.

An Life Technologies kit containing reagents used to PCR amplify
any SNP markers, using single-base-extension technology. Sample
files can then be sized and genotyped by using a SNaPshot analysis
in the GeneMapper Software.

Primer extension-based chemistry for SNP validation

Size Standard Not Found

Single Nucleotide Polymorphism. A marker consisting of a single
base pair that varies, thereby creating up to four alleles of the marker.
In this document, SNP refers to SNaPshot® system markers and
SNPlex® systems
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SNPlex® System
SP

SPA

SPU

SQ

High-throughput assay for genotyping.

Split Peak PQV
Single Peak Artifact PQV
Spectral Pull-Up PQV

Sizing Quality
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A

ABB (automatic bin builder), definition 197
Access Control Administration Software 64
access control list, definition 197

action maps 126

activating
auditing system 107
electronic signature system 125
user accounts 93

admin profile, definition 197

admin security group, definition 197
admin user group, definition 197
admin user, definition 197

Administrator
default user account 84
default user profile 83

administrator privileges 27
verifying 27, 165
administrator, role 150
ADO PQV column 197
Adobe Acrobat Reader 27
AE PQV column 197
algorithm, definition 198
all user group, definition 198
Allele audit map object 110
ALLELE audit map object attribute 112
allele-calling, definition 198

allelic ladders, specifying in a command line
analysis 187

allocating, disk space 154
AN PQV column 198
Analysis Method audit map object 110

Index

analysis methods
definition 198
import via a command line 186
specifying in a command line 184

analysis methods, backingup 144

analysismethod argument 184

API support 147

applications, managing 78

Applied Biosystems 3500 series genetic
analyzers 17

arguments (command line interface)
about 183
analysismethod 184
commandline 184
deleteproject 184
deletesnpset 184
exportall 184
exportanalyzedeps 184
exportbinoffsettable 184
exportclustergenotypetable 184
exportgenotypetable 185
exportplotsampletable 185
exportsampletable 185
exportsizemap 185
exportsnptable 185
folder 185
help 186
importanalysismethod 186
importsizestandard 186
importsnpset 186
ladder 187
negcontrol 187
option 187
panel 187
password 187
poscontrol 188
project 188
sizestandard 188
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snpset 188
username 188

association, definition 199
assumptions for using this guide 7
Audit Data table 152
audit event, definition 199
audit map
configuring 107
Audit Map Configuration Software
about 100

global auditing setting 107
starting 101

audit map definition 199
audit map object attributes

about 109
states 108
audit map objects
about 109
states 107

Audit Map Viewer Software
about 114
starting 115
audit maps 102, 109
about 102
configuring 107
viewing the history 114
audit object attributes 102
audit object, definition 199

audit records
archiving 118
backingup 118
filtering 116
removing 118
viewing 115
audit records, definition 199
audit state inheritance 103
auditing 63,97
auditing setting (global) 107
auditing system

about 100
maintaining 101
setup 100

Auto Extend 152

208

autoanalysis not supported 16
automatic notification 66
automating software operations 174
autopanelizer, definition 199

B

backing up
analysis methods 144
audit records 118
bin sets 144
cluster plot settings 144
database 158
kits 143
matrices 144
panels 143
plot settings 144
projects 138
report settings 144
size standards 144
SNP sets 144
studies 140
table settings 144

batch file, creating for command line
operation 175

BD PQV column 199

Bin audit map object 110

BIN audit map object attribute 111

bin offsets, export via a command line 184
BIN PQV column 199

bin sets, backingup 144

BinSet audit map object 110

BINSET audit map object attribute 110
bold text, when to use 7

C

cache, definition 199
CAUTION, description 12
CC PQV column 199
challenge, definition 199
changing, user password 92
checklist, troubleshooting 170
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Checksum settings 125

client configuration
installing client 50
client configuration (stand-alone)
description 48
installation tasks 48
Cluster Plot Genotypes table, export via a
command line 184

cluster plot settings, backingup 144

command line interface
about 174
arguments 183
example commands 179
hiding the user interface 187
specifying allelic ladders 187
specifying analysis methods 184
specifying negative controls 187
specifying panels 187
specifying port setting 187
specifying positive controls 188
specifying size standards 188
specifying SNP sets 188
specifying the project 188
commandline argument 184
compatibility matrix 26

computer requirements

full installation 23

verifying minimum 24
Configuration tab settings 125
configurations, new installation

instrument 36

stand-alone 33, 43
configuring

action maps 126

audit map 107

automatic notification 66

electronic signature system 125
connecting to a new host 60
control security group, definition 200
controlling access to the software 63, 97
conventions

bold text 7

for describing menu commands 7
IMPORTANTS! 8

italic text 7

Notes 8

safety 12

user attention words 8
creating

security profiles 81

user accounts 89

user profiles 81

D

DANGER, description 12
data
archiving 133, 145
export via a command line 184
data access control, definition 200
Data Collection services
starting on local computer 37
Data Collection Software
installing with locally 36
starting 37, 166
stopping 42, 169
data compatibility 26
data group, definition 200
data rights, definition 200
Data Service output window 38

Data Service, checking if started without
errors 38, 166

database
API support 147
backingup 158
SQL support 146
statistics, viewing 151
Database Dashboard software
about 149
logging into for the first time 57
database utilities
Audit Configuration Tool 100
Audit Map Viewer Software 114
Electronic Signature Software 122
database, definition 200

deactivating
auditing system 107
electronic signature system 125
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user accounts 93
default user name 55
deleteproject argument 184
deletesnpset argument 184
deleting, user accounts 91
destination folder, selecting 40, 44, 51
disk space, allocating 154
documentation, related 9
domain name, verifying 28, 165
DOS window, during installation 41, 47, 51
DP PQV column 200

E
editing
security profiles 82
user account 92
user accounts 91
user profiles 82
Electronic Signature Challenge Text 127

electronic signature records
about 124
viewing 128
electronic signature system
about 122
configuring 125
maintaining 123
Electronic Signature Verification dialog

box 124

electropherogram data, export via a command
line 184

enabling

auditing 107

electronic signatures 125
ergonomics, safety 14
eSig software. See electronic signature system
exportall argument 184
exportanalyzedeps argument 184
exportbinoffsettable argument 184
exportclustergenotypetable argument 184
exportgenotypetable argument 185

exporting

analysis methods 144

bin sets 144

cluster plot settings 144

database 158

Database Utility Wizard 189

kits 143

matrices 144

panels 143

plot settings 144

projects 138

reference data 142

report settings 144

security settings 96

size standards 144

SNP sets 144

studies 140

table settings 144
exportplotsampletable argument 185
exportsampletable argument 185
exportsizemap argument 185

exportsnptable argument 185

F

filtering
audit records 116
record data 116

folder argument 185

full installation
computer requirements 23

G

GeneMapper® Database Utility Wizard 189

GeneMapper® Software
logging out 61
registering after new installation 54
uninstalling 168
Genotypes table (Cluster Plot), export via a
command line 184
Genotypes table, export via a command
line 184

gm, default user name 55
GQ PQV column 201
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guidelines
Audit Map Configuration Software 107
Electronic Signature Software 122

H

hazard symbols. See safety symbols, on
instruments
help argument 186
help, online, accessing 10
history
auditing (viewing) 114
electronic signature (viewing) 128
History Viewer tab settings 128
how to use this guide 7, 12

importanalysismethod argument 186
importing
analysis methods (via a command
line) 186
projects 139
security settings 96
size standard definition (via a command
line) 186
SNP sets (via a command line) 186
studies 141

importsizestandard argument 186
importsnpset argument 186
inheritance, audit state 103
installation DVDs 28

installation process workflow 22

installation tasks

client configuration (stand-alone) 48
instrument configuration 36
stand-alone configuration 43

installation, troubleshooting 162
installed elements 83
installer, starting 39, 43, 50
installing software

instrument configuration 39
instrument compatibility 26

instrument configuration
description 36
installation tasks (new installation) 36
installing (new installation) 39

italic text, when to use 7

K

Kit audit map object 110
kits, backingup 143

L

ladder argument 187
license agreement, Oracle® database 18
Life Technologies

contacting 10
Technical Support 10

LIMS, linking the software using the command
line interface 174

LMS, definition 201

log file, collecting 162

log on requirements 27

logging out of the GeneMapper®
Software 59

LPH PQV column 201

M

maintaining

auditing system 100, 101

database 153

electronic signature system 123

security system 65

software and database 132
maintenance schedule 132
managing

software and database 132

user accounts 88

user profiles 78
Marker audit map object 111
MARKER audit map object attribute 111

matrices, backingup 144
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Matrix audit map object 111

menu commands, conventions for
describing 7

migrating data 193

migration utility. See GeneMapper® Database
Utility Wizard 189

minimum requirements for computer 24
MNF PQV column 202

monitor requirements 23

moving and lifting, safety 13

MSDSs, obtaining 10

N

NB PQV column 202

negative controls, specifying in a command line
analysis 187

negcontrol argument 187
new host, connecting to 60

new installation
instrument configuration 39
registering the software 54

O

OBA PQV column 202
OIR (Override Inherited Rights) 79
online help, accessing 10
operating system

requirements 23
Operator default user account 84
option argument 187

Oracle® database
checking installation of 162
maintenance 132
tools, use of 147
viewing statistics 151

Oracle® database license agreement 18

OS PQV column 202

OverrideGQ audit map object attribute 112
OverrideSQ audit map object attribute 112

OverrideStatus audit map object attribute 113
OVL PQV column 202

P

panel argument 187
Panel audit map object 111
PANEL audit map object attribute 110
panels
backingup 143
specifying in a command line
analysis 187
password argument 187
password policies
about 66
Max Login Attempts 66
Minimum Password Width 69
Password Grace Logins 68
Password kept per usage 68
Password Lifetime 68
Password Reuse Period 68
Send log message 67
Set User State 67

passwords
changing 55,57, 92
default user accounts 88
PHR PQV column 202
plot settings, backingup 144
poscontrol argument 188

positive controls, specifying in a command line
analysis 188

Primer Focus® kit, definition 203
primer, definition 203

procedural workflow, GeneMapper®
Software 19

profile, definition 203

project argument 188

Project audit map object 111

PROJECT audit map object attribute 113
Project Data table 152

project settings, definition 203
ProjectAdded audit map object attribute 113
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ProjectRemoved audit map object
attribute 113
projects
backingup 138
deletion via a command line 184
importing 139
specifying in a command line
analysis 188

R

Reason(s) For Change dialog box 105

recommended maintenance schedule 132

Reference Data table 152

reference data, exporting 142

registering the GeneMapper® Software
new installation 54

registration code 54

removing

audit records 118
the GeneMapper Software 168

repetitive motion, safety 14
report settings, backing up 144
Require UserID? setting 125
requirements

logon 27

user accounts 27

verifying minimum computer 24

verifying user account 27
restoring

audit records 118

projects 139

security settings 96

studies 141

rights, definition 204
Run audit map object 112
RUN audit map object attribute 111

run folder, specifying in a command line
analysis 185

RunAnalyzed audit map object attribute 113

S

safety
before operating the instrument 13
conventions 12
ergonomic 14
moving/lifting 13
repetitive motion 14
workstation 14
Sample audit map object 112
SAMPLE audit map object attribute 112
sample data file compatibility 26

Samples table, export via a command
line 184

Scientist default user account 84
Scientist default user profile 83
scripting software operations 174
security group, definition 204
security ID, definition 204
security log 94

security profiles
creating 81
editing 82

security settings
exporting 96
importing 96

security system
about 64
maintenance 65
reporting 94
setup 65

Service Console 37, 166

setting
action maps 126
audit map object attribute states 108
audit map object states 107
electronic signature settings 125
global auditing setting 107
password policies 66

setting up
auditing system 100
electronic signature system 125
security system 65

Show EULA option 89
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SHP PQV column 204
signatures (electronic) enabling 125
silent auditing, definition 204
size match editor, definition 204
Size Standard audit map object 112
size standard definition, import via a command
line 186
size standards
backingup 144
specifying in a command line
analysis 188
sizestandard argument 188
Sizing table (Samples Plot), export via a
command line 185
SNaPshot® analysis, definition 204
SNF PQV column 204
SNP sets
deletion via a command line 184
import via a command line 186
specifying in a command line
analysis 188
SNP sets, backingup 144
SNPlex® system analysis, definition 205
snpset argument 188
software
Access Control Administration 64
Audit Map Configuration Software 100
Audit Map Viewer Software 114

controlling access to 64
maintenance 132

SP PQV column 205
SPA PQV column 205
SPU PQV column 205
SQ PQV column 205
SQL support 146
stand-alone configuration
description 33

installation tasks (new installation) 43
installing (new installation) 43

starting

Access Control Administration
Software 64

Audit Map Configuration Software 101
Audit Map Viewer Software 115
Esig Administration Software 123
studies
backingup 140
importing 141
Study audit map object 113
suspending, user accounts 93

T

table settings, backing up 144
Technical Support

contacting 10

information needed before contacting 170
Technician default user profile 83
training, information on 10
troubleshooting checklist 170
troubleshooting tasks 162

U

uninstalling the GeneMapper Software 168

user accounts 88
activating 93
Administrator 84
changing password 92
creating 89
deactivating 93
deleting 91
editing 91, 92
Operator 84
requirements 27
Scientist 84
status 89
suspending 93

User Accounts dialog box 27, 165

user attention words, defined 8
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