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Chapter 1  

Introduction 

The Thermo Scientific TMT Comm communication software is designed 
to communicate with the Thermo Scientific series of density and level 
gauges via the RS485 serial port. The software allows the user to configure 
and monitor up to 32 gauges from one PC.  

TMT Comm runs on PC-compatible computers with RS232 serial 
communications port (e.g., COM1). An RS485 / RS232 converter (p/n 
670045) is required to connect the RS232 serial port on the PC to the 
RS485 serial port on the gauge. 

This manual only describes the TMT Comm software. For specific 
information on configuring and using a specific gauge, refer to the 
documentation provided with it.  
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Chapter 2  

Installation 

The software is shipped with the following items: 

● Thermo Scientific TMT Comm communication software, p/n 
595034 

● RS485 / RS232 converter, p/n 670045 or RS485 converter with 
AC adapter, p/n 670046 

● 6 ft. serial cable, p/n 810141 

● TMT Comm user guide, p/n 717820 

Hardware 
Connections 

To use the TMT Comm software, the PC must be connected to the gauge. 
In addition to the steps below, refer to wiring diagram 868604. 

1. Connect the RS485 converter to the serial communications port on the 
PC using the serial cable provided: Plug the RJ-11 (phone jack) 
connector on the serial cable into the RS485 converter and attach the 
DB9 connector on the serial cable to the serial port on the PC.  

2. Connect the RS485 converter to the RS485 port on the gauge as shown 
in drawing 868604.  

3. Connect the AC adapter to the RS485 to RS232 converter. 

Software 
Installation 

The installation disk and includes TMTCOMM.EXE (the main program) 
and TMTCOMM.HLP (the help file).  

To install the software, create a directory (or folder) named 
“TMTCOMM” on the PC hard drive. 

Insert the TMT Comm installation disk into the appropriate drive, and 
copy all the files from the disk to the directory. 
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Chapter 3  

Using the Software 

After connecting the PC to the gauge and installing the software, you are 
ready to run TMT Comm.  

Startup 

Open the folder created for the software, and double-click on the 
TMTCOMM.exe file to start the program. The main screen will be 
displayed.  

 
Figure 3–1. TMT Comm main screen 

Establishing 
Communication 

If running TMT Comm for the first time, you must first set up the serial 
communication port on the PC before you can communicate with the 
gauge(s). The communication parameters specified for the PC serial port 
must match the communication settings of each of the gauges. Refer to the 
user documentation supplied with the gauge for information on 
configuring gauge communication settings. The default communication 
settings for Thermo Scientific gauges are 9600 baud, Even parity, 7-bit 
word length, and 1 stop bit (7-E-1). 
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Using the Software 
Establishing Communication 

Go to Options > Comm Ports to open the Comm Ports screen to 
configure the port.  

 
Figure 3–2. Comm Port screen 

Party-Line 
Communication 

To communicate with multiple gauges over an RS485 network (party-line), 
the RS485 ports of the gauges must have been wired correctly. Refer to the 
appropriate wiring diagram (showing the RS485 wiring) provided with the 
gauge.  

Each unit on an RS485 party-line must be assigned a unique, non-zero ID 
number from 1 to 32 (maximum of 32 units can be connected via an 
RS485 party-line). Duplicate ID numbers will cause errors. The default 
value for the ID number in the gauge software is 0. A unit with ID number 
0 (zero) will operate as if it is always in Connect Mode. Units with a non-
zero ID number will only respond in Connect Mode or when issued a data 
update command in data streaming mode. Refer to the user documentation 
provided with the gauge for additional details regarding serial 
communications.  

In order to assign each unit a unique ID number, you must be able to 
disconnect each unit from the RS485 party-line and communicate with it 
directly. Alternately, you must be able to power up each unit individually 
or add on one gauge at a time as described below. Follow the steps below 
for each gauge to be added to the RS485 party-line. Refer to “Party-Line 
Support” later in this chapter for information on how to access the various 
commands discussed below. 

3-2     TMT Comm User Guide Thermo Fisher Scientific 



Using the Software 
Monitor Mode 

1. Before adding a new unit to the group, issue the Sleep command.  
From the main screen, select File > HandHeld Mode. Power up all of 
the units in the group except the new gauge. With all units on the 
party-line in the Disconnect Mode, send the Sleep command. The 
units will continue to operate normally but will not respond to any 
commands other than the Wakeup command.  

2. Power up the new unit to be added to the party-line and determine its 
ID by issuing a Request ID command. If the unit has not previously 
been assigned a unit number, it will have a default ID of 0 (zero).  

3. Connect to the new unit and issue the Connect command for the new 
unit.  

4. You can change the unit number for the gauge using the serial port 
menus, or you can enter the value using a direct entry code. To do this:  

a. Press X.  

b. Enter 034002 and press the down arrow.  

c. Enter the new ID number for the unit.    

d. Press X to store the new ID number and exit the direct entry mode. 

Monitor Mode This mode allows for an “at-a-glance” monitor of all units on the RS485 
party-line. At user-specified intervals, the software will poll each selected 
unit for its Measurement 1 value and display the accompanying dialog. 
Then, the monitor will also flag any unit in system fault by turning the 
unit’s display to red. The monitor dialog is shown below. 
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Using the Software 
Monitor Mode 

 
Figure 3–3. TMT Comm in Monitor mode 

General Operation The Monitor uses the “Super Blind” protocol to interrogate the units for 
measurement and alarms. This protocol employs a packet of the form:  

[Start Character][Address][Direct Entry Code][Checksum] 

where  

Start Character is the pipe ‘|’ (ASCII code 124).  

Address is 32 + the unit’s RS485 node address given by direct entry 
code 220C.  

Direct Entry Code is any legal direct entry code. 

Checksum is the 16 bit sum of the ASCII codes of all characters from the 
start to the end of the payload. This checksum is sent in Hexadecimal 
ASCII.  

Then, the instrument response packet is in the same format. This packet 
protocol offers both address and checksum validation of response packets.       
In particular, the Monitor gets Measurement 1 via direct entry 741F and 
the System Fault Alarm via 0A2B. 

Link Update Time Specify the interval time between Monitor updates from the Options 
menu.  
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Using the Software 
Handheld Mode 

Enter Link Monitor mode by selecting File > Link Monitor. The software 
will invoke the Monitor dialog and change the screen title to “TMT 
COMM for Windows – Monitor Mode” to indicate that it is running in 
Link Monitor mode.  

Entering Link 
Monitor Mode 

Link Monitor Errors The Link Monitor maintains a record of all communication and 
instrument errors that it encounters. Click the Show Errors button to view 
the error log.  

Choosing Units for 
Monitoring 

A unit is selected for monitoring by checking the appropriate box in the 
Monitor dialog.  

Select All for 
Monitoring 

This option selects all 33 units for monitoring  

Clear All from 
Monitoring 

This option clears all unit selections.  

Exiting Link Monitor 
Mode 

This mode is exited by closing the Monitor dialog. 

 

Handheld Mode The handheld mode models the behavior of the Thermo Scientific Model 
9734 handheld terminal and provides the following:  

● A simple ANSI terminal for accessing gauge menus.  

● Support for Thermo Scientific RS485 party-line protocol.  

● Data logging feature to write all data from the gauge to hard disk.  

● Clipboard support, which allows you to copy and paste data in 
other Microsoft® Windows® applications. 

Entering Handheld 
Mode 

Enter Handheld mode by selecting File > HandHeld Mode. The screen 
title will change to “TMT COMM for Windows – HHT Mode” to 
indicate that it is running in handheld mode. 
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Using the Software 
Handheld Mode 

The software supports the various RS485 party-line functions with a dialog 
invoked from its main menu bar. These functions are described below.  

Party-Line Support 

● Connect to Gauge: Allows a user access to a particular instrument’s 
setup menus. If successful, the target gauge should report 
“Connected to Unit N”. Once entered, all other units should cease 
data streaming to prevent data collisions on the link.  

● Disconnect from Gauge: Returns the connected gauge back to the 
normal “disconnected” state. All units should resume normal data 
streaming.  

● Request ID: Issues a global request to all units to report their 
individual RS485 unit numbers. Each unit should report its ID in 
succession.  

● All Units to Sleep Mode: Issues a global request for all units to 
enter sleep mode, in which they suspend data streaming and ignore 
any connect requests. This mode is useful when adding another 
unit to the party-line.  

● All Units to Shutup Mode: Issues a global request for all units to 
enter Shutup mode, in which they suspend normal data streaming 
but still acknowledge connect requests.  

● All Units to Wakeup Mode: Issues a global request to all units to 
return to normal data streaming mode. This command cancels both 
the Sleep and Shutup modes. 

Data Logging The software support a data logging function, logging all received RS485 
transmissions to hard disk. This mode is useful for capturing the data 
stream for diagnostic purposes. Open the log by selecting File > Log Data. 
You will be prompted for the log file’s name. If successful, “Log File Open” 
will be displayed in the status bar. Close the log file by selecting File > Stop 
Logging. 

Clipboard Support The software supports copy / paste operations to the Microsoft Windows 
clipboard. The text to be copied may be selected by highlighting it with the 
mouse or by selecting Edit  > Select All from the main screen. Copy the 
selected text to the clipboard by pressing Ctrl-C on the keyboard or 
selecting  Edit > Copy. The software also supports the Pause key, which 
will suspend screen updates until pressed again. This function is useful 
when copying scrolling data stream updates. 

Exiting Handheld 
Mode 

Handheld mode is exited by selecting File > Kill Active Mode or pressing 
Ctrl-K on the keyboard. 
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Using the Software 
File Transfers 

This mode supports the gauge’s ability to transmit / receive NV setup 
images over the RS485 link. All non-zero setup variables will be included in 
this dump. The NV setup data is transmitted in packets with the format of: 

File Transfers 

[Start Character][Address][Start Data][Item Count][Data 
Payload][Checksum] 

where  

Start Character is ‘~’ (ASCII code 126). 

Address is 32 + the unit’s RS485 node address given by direct entry 
code 220C.  

Start Data Character ‘{‘ marks the beginning of the payload.  

Item Count is the number of setup variables in the data payload section.  

Data Payload consists of [Item Count] Hex direct entry codes followed 
by their values. Each entry is delimited with a backslash ‘\’.  

Checksum is the 16 bit sum of the ASCII codes of all characters from the 
start to the end of the payload. This checksum is sent in Hexadecimal 
ASCII.   

As an example, the packet below is addressed to Unit 0 and contains five 
data entries. In the payload, the variable 5820 is set to 3, 600C to 1, 640C 
to 2, 871C to 70. Then, the packet checksum is given by 099B.  

~ {054A0C01\582C03\600C01\640C02\871C70\099B 

Entering File 
Transfer Mode 

Enter File Transfer mode by selecting File > File Transfer. The software 
will invoke the File Transfer dialog and change the screen title “TMT 
COMM for Windows – File Transfer” to indicate that it is running in file 
transfer mode. 

Choosing RS232 or 
RS485 

Transfers on the RS485 or RS232 are supported. When RS232 is chosen, 
the Gauge Unit list box is disabled because unit numbers are meaningless. 

Entering File Name Although the software will accept any legal file name, NV setup files use 
the extension “*.TMT” by default. 

Selecting Gauge 
Number 

Select the target gauge’s RS485 unit number with the drop-down list box.  
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Using the Software 
TMTCOMM Shortcut Keys 
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The Upload button will transfer the selected image file from the PC to the 
specified gauge. The Download button will transfer and store the gauge’s 
NV setup data to the specified file.  

Upload/Download 

Cancel Op This button may be used to abort any transfers which may have “hung”. 

 Transfer Statistics This dialog reports the error counts from the last transfer.  

Exiting File Transfer 
Mode 

This mode is exited by closing the File Transfer dialog. 

 

TMT COMM 
Shortcut Keys 

General 

● Ctrl-K: Kills the active mode.  

HHT Mode  

● Alt-C: Clears the terminal screen  

● Ctrl-C: Copies selected text to clipboard  

● ESC: Clears selected text.  

● PAUSE: Suspends screen updates for copy / paste operations. 

 

 

 

 

 

 

 

 



 

Chapter 4   
Troubleshooting & Support 

Table 4–1. General troubleshooting General 
Problem Possible Cause / Corrective Action 

Cannot establish communication with 
the party-line. 

1.  Verify COMM settings, wiring, etc. 
2.  The software works only with the “blue” RS485 
module, which automatically controls 
communication direction.  

After closing HHT, File Transfer, or 
Link Monitor the software reports 
“COMM Open Error” when trying to 
start a new mode. 

The COMM port may have been left open when the 
previous mode was exited. Type Ctrl-K to see if 
that closes the port. 

 

Table 4–2. HHT mode troubleshooting HHT Mode 
Problem Possible Cause / Corrective Action 

Cannot connect to unit N. The unit may be in Sleep mode and will not accept 
Connect requests. Issue a Wakeup command, which 
will cancel Sleep mode.  

 

 

File Transfer 
Mode 

Table 4–3. File Transfer mode troubleshooting 

Problem Possible Cause / Corrective Action 

Cannot upload / download to / from 
unit N. 

1.  The unit may be in Network Connect mode and 
cannot service transfer requests. Issue a Disconnect 
command (while in HHT mode). 
2.  The file transfer feature only works with later 
Thermo Scientific products, such as the Thermo 
Scientific DensityPRO and LevelPRO gauges. 
3. The unit may be in Sleep mode and will not 
accept Connect requests. Issue a Wakeup 
command, which will cancel Sleep mode. 
4.  The wrong port may be selected. Verify COMM 
settings. 
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Troubleshooting & Support 
Link Monitor Mode 

Table 4–4. Link Monitor mode troubleshooting Link Monitor 
Mode Problem Possible Cause / Corrective Action 

Unit N gives continuous TIMEOUT 
errors. 

1.  The unit may be in Network Connect mode. The 
Link Monitor automatically issues several 
Disconnect commands to take units out of this 
mode; however, these commands can be missed 
due to collisions on the link. Exit Link Monitor mode 
and then enter it again. 
2.  The unit may be password protected, which 
blocks all Super Blind requests. Remove the 
password. 

All units give continuous TIMEOUT 
errors. 

1.  The party-line may be in Sleep mode. Issue a 
Wakeup command from the HHT. 
2.  The Monitor uses Super Blind protocol to 
interrogate the units. This protocol is only supported 
by the DensityPRO, LevelPRO, and Accu-Wave 
(obsolete). 

The party-line does not resume data 
streaming after closing Link Monitor 
mode.  

The Monitor automatically puts the party-line in 
Shutup mode when invoked to suspend data 
streaming. When exiting, the Monitor issues a 
Wakeup command to restore the link. Issue a 
Wakeup command while in HHT mode. 

The Monitor displays sporadic errors. The software uses the built-in Windows support for 
serial communications, which can unfortunately get 
confused during periods of heavy PC usage. Close 
all unessential applications.   

During extended periods, all units 
show sporadic TIMEOUT and BAD 
CHKSUM errors. 

Thermo Scientific gauges perform periodic self-
checks every 10 minutes and may miss Monitor 
requests during this time. This error can occur even 
more frequently with fast monitor update times. Try 
increasing the update time. 
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Troubleshooting & Support 
Contact Information 

The local representative is your first contact for support and is well 
equipped to answer questions and provide application assistance. You can 
also contact Thermo Fisher directly. 

Contact 
Information 

 

Process Instruments 

1410 Gillingham Lane 
Sugar Land, TX  
77478 USA 
 
+1 (800) 437-7979 
+1 (713) 272-0404 direct 
+1 (713) 4573 fax 

14 Gormley Industrial Avenue 
Gormley, Ontario 
L0H 1G0 
CANADA 
 
+1 (905) 888-8808 
+1 (905) 888-8828 fax 

Unit 702-715, 7/F Tower West 
Yonghe Plaza No. 28 
Andingmen East Street, Beijing 
100007 CHINA 
 
+86 (10) 8419-3588 
+86 (10) 8419-3580 fax 

A-101, 1CC Trade Tower 
Senapati Bapat Road 
Pune 411 016 
Maharashtra, INDIA 
 
+91 (20) 6626 7000 
+91 (20) 6626 7001 fax 

Ion Path, Road Three  
Winsford, Cheshire 
CW7 3GA  
UNITED KINGDOM 
 
+44 (0) 1606 548700 
+44 (0) 1606 548711 fax 

 

www.thermoscientific.com 

Warranty Thermo Scientific products are warranted to be free from defects in 
material and workmanship at the time of shipment and for one year 
thereafter. Any claimed defects in Thermo Scientific products must be 
reported within the warranty period. Thermo Fisher Scientific shall have 
the right to inspect such products at Buyer’s plant or to require Buyer to 
return such products to Thermo Fisher plant. 

In the event Thermo Fisher requests return of its products, Buyer shall ship 
with transportation charges paid by the Buyer to Thermo Fisher plant. 
Shipment of repaired or replacement goods from Thermo Fisher plant shall 
be F.O.B. Thermo Fisher plant. A quotation of proposed work will be sent 
to the customer. Thermo Fisher shall be liable only to replace or repair, at 
its option, free of charge, products which are found by Thermo Fisher to be 
defective in material or workmanship, and which are reported to Thermo 
Fisher within the warranty period as provided above. This right to 
replacement shall be Buyer’s exclusive remedy against Thermo Fisher. 

Thermo Fisher shall not be liable for labor charges or other losses or 
damages of any kind or description, including but not limited to, 
incidental, special or consequential damages caused by defective products. 
This warranty shall be void if recommendations provided by Thermo 

Thermo Fisher Scientific TMT Comm User Guide     4-3 



Troubleshooting & Support 
Warranty 
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Fisher or its Sales Representatives are not followed concerning methods of 
operation, usage and storage or exposure to harsh conditions. 

Materials and/or products furnished to Thermo Fisher by other suppliers 
shall carry no warranty except such suppliers’ warranties as to materials and 
workmanship. Thermo Fisher disclaims all warranties, expressed or 
implied, with respect to such products. 

EXCEPT AS OTHERWISE AGREED TO IN WRITING BY Thermo 
Fisher, THE WARRANTIES GIVEN ABOVE ARE IN LIEU OF ALL 
OTHER WARRANTIES, EXPRESSED OR IMPLIED, AND Thermo 
Fisher HEREBY DISCLAIMS ALL OTHER WARRANTIES, 
INCLUDING THOSE OF MERCHANTABILITY AND FITNESS 
FOR PURPOSE. 
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