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Genexus | lon Torrent

Sample Run Results Report
Create or import sample records, and Plan a sequencing run with View runs in progress in real time. Review OC data and variant
track sample attributes. Create or import samples or libraries. Access run metrics as they detection results.
libraries, and track reagent usages. are generated.

* Sample—Create and manage sample records and libraries.

* Run—Plan a sequencing run by selecting samples or libraries, and assay
parameters.

* Results—View the progress of the run in real time and evaluate the assay
metrics as they are generated.

* Report—Review run results and variant detection and sign off on reports.
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Chapter 1 About Genexus™ Software 6.2
Software overview

Software overview

lon Torrent™ Genexus' Software supports the lon Torrent™ Genexus™ Integrated
Sequencer workflow for research use purposes from sample preparation through
library preparation, template preparation, and sequencing. During and after
sequencing, the software generates base calls, trims reads, and determines quality
values (primary analysis), then aligns reads, calls variants, and generates reports
(secondary analysis).

This documentation provides instructions for using the software to perform the
following functions:
* (Create and manage samples, libraries, assays, and runs in the software.

* Monitor the status of runs on the Genexus™ Integrated Sequencer, which
provides all-in-one library preparation, chip loading, template preparation, and
sequencing.

* \View data, results, and quality control (QC) reports after a run.
* Download data files.
* Export and print audit records.

* (Create and manage annotation sets, genome references, report templates,
baseline files, primer sets, plugins, and reference files.

* (Create and manage user accounts.

Software compatibility and requirements

The procedures in this guide are designed for use with Genexus™ Software 6.2 or
later. Version-specific information is provided in the software release notes for your
version of the software. An administrator-level user can view the software version in
the {&b (Settings) / Software Updates screen.

Genexus'" Software is supported on Google™ Chrome™ browser version 64 and later
and is best viewed with 1440 x 900 screen resolution. Google™ Chrome™ browser is
recommended for use with the software.

The operating system of the sequencer is Ubuntu™ 18.041.

Network and password security requirements

Network
configuration
and security

The network configuration and security settings (for example, firewalls, antivirus
software, network passwords) of your laboratory or facility are the sole responsibility
of your facility administrators and IT and security personnel. Genexus™ Software
does not provide any network or security configuration files, utilities, or instructions.

If external or network drives are connected to the sequencer, it is the responsibility of
your IT personnel to ensure that such drives are configured and secured correctly to
prevent data corruption or loss.

Genexus™ Software 6.2 User Guide 9
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security

¥ Chapter 1 About Genexus™ Software 6.2
Installation and verification run

Note: If a LIMS system is configured to retrieve analysis files from the sequencer,
manual FTP setup or drive mapping is required. This configuration is not provided as
part of sequencer installation, and must be set up by your LIMS system integration or
IT group.

Best practice is to maintain unique passwords for all accounts in use in Genexus '
Software. All passwords must be reset upon first sign in to the software. Change
passwords according to your organization's password policy.

It is the sole responsibility of your IT personnel to develop and enforce secure use of
passwords.
This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that

establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

Installation and verification run

10

The Genexus™ Integrated Sequencer and Genexus™ Software are locked until a
verification run has been performed and the report is signed by a Field Service
Engineer.

IMPORTANT! The Genexus" Integrated Sequencer and the Genexus' Software are
locked until a Field Service Engineer has installed and performed a performance
qualification verification run and provided a basic system overview.

Genexus"™ Software 6.2 User Guide
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About the Genexus  Software user interface

The Genexus™ Software user interface provides menus to help you add, select, and
manage samples, libraries, runs, and assays. You can also view and manage your
sequencing results, monitor Genexus™ Integrated Sequencer runs in progress, and

manage software settings.

Genexus | lon Torrent Samples Runs Monitor Results Assays £3 el

Samples / Manage Samples

t Create Sample [ Import Samples

Filter Samples by... Sample Name % Enter Sample Name
Sample Name Collection ... Created On Disease Category Cancer Type Sample Type ~ Gender Actions
LibSampleg1 2000-05-04 32,2201:02_]'& Cancer Gastric Cancer RMNA Male Edit | Audit | Motes

@ Samples: add new samples, import samples, prepare library batches, import library batches and manage attributes.

@ Runs: plan a run starting from a sample (Sample Run), or library (Library Run). View, edit, and manage runs.

@ Monitor: view a sequencer run in progress.

(@ Results: view sample results, run results, and verification results.

@ Assays: manage, create, and import assays. Manage assay preset parameters and panels.

@ Settings: access audit records and run logs, configure network settings, and manage data archiving, disk space, and users.
@ Profile: access Help, manage and edit user profile settings and SSH key, sign out.

Genexus™ Software 6.2 User Guide 11



5] Chapter 2 Get started with Genexus™ Software
£ User-access levels

\;

Access End A link to the End User License Agreement (EULA) is located at the bottom of the
User License screen.
Agreement 1. Scroll to the bottom of the screen.
(EULA)

2. Click the EULA link to open a PDF file of the EULA.
Contact You can access Genexus' Software technical support from the software interface.
Support 1. Scroll to the bottom of the screen.

2. Click Support to open https://www.thermofisher.com/contactus, where you
can request help and technical support.

User-access levels

Users at this

level... Can...

Operator * Add, import, and export sample files
* Prepare library batches

¢ Plan and save runs

* Monitor runs

* View results and reports

¢ Upload sample results files to lon Reporter™ Software

Manager Operator functions, plus:
* Create, edit, and delete sample attributes
* Create and import assays

* Create presets such as annotation sets, filter chains, copy
number baselines, and report templates

¢ Edit and delete sample files

¢ Audit and delete runs

* Restart a stalled or failed analysis

* Reanalyze runs and run plugins

* Approve reports and amend a signed-off report

* Manage reference sequences and panel, hotspot, and other
sequence files

® Access services information

12 Genexus"™ Software 6.2 User Guide
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System tracking

Users at this

level... Can...

Administrator | Operator and manager functions, plus:

* View, export, and print audit records

* Configure network settings

* View and manage software updates

¢ |[nstall and manage plugins

¢ Configure data archive and storage settings
* Manage sequencer and software log files

* Add and manage user accounts

System tracking

The system tracks and checks auditable user activities for samples, assays, QC
metrics and information related to reagents.

If the software detects an error at any step—for example, a scanned barcode is
inconsistent with the information given for the run—the software alerts the user and
does not proceed with the run.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

Reagent management

Users should put in place a reagent management system to inventory and track
reagent use. Proper use of a reagent management system promotes regulatory
compliance and ensures optimal use of kits, chips, and reagents.

Genexus™ Software 6.2 User Guide 13
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Request and sign in to a new user account

Request and sign in to a new user account

Operator-level users must request a new user account from the manager- or
administrator-level user before they can sign in to Genexus™ Software.

Administrator-level users receive the request and create the user account.

Your user name and password must be unique and not shared with other users.

Sign in

14

To request a new account, contact your administrator-level user.

After the admin creates a new account, the software sends an email to the new
user with a user name and temporary password.

To sign in to a new account for the first time:

a.

Obtain your user name and temporary password that is supplied by your
administrator in an email message.

Browse to the Genexus " Software home page (for example, https://<your
server address>) then sign in using your user name and the temporary

password supplied by your administrator.

Press Enter, or click Sign In.

. In the End User License Agreement that appears at first sign on, read the

agreement, then click Accept.

In the Change Password screen, enter your temporary password supplied
by your administrator.

Type a new password, confirm the password, then click Change.
— Passwords must be between 6 and 10 characters.

— Passwords must contain only alphanumeric characters (numbers 0 to 9
and letters A to Z), no spaces or special characters.

— Passwords must contain at least one alphabetic character (a-z, A-Z).
— Passwords must contain at least one numeric character (0-9).

— Passwords are case-sensitive.

After registering a new account, sign in to Genexus™ Software in the home page.

1.

Go to the Genexus'" Software home page.

2. Enter your user name and password, then press Enter or click Sign In.

Note: If you receive a message that indicates that a token is expired, refresh the
browser and re-enter the user name and password.

The software opens to the Manage Samples screen.

Genexus™ Software 6.2 User Guide



Edit a user profile

Chapter 2 Get started with Genexus™ Software ~ EF=84

Edit a user profile

After your user profile has been established, you can view your user profile
information, change your password, or change your email contact information.

1. In the menu bar, click & (Profile).

2. In the Profile screen, view your profile information.

3. To change your password:

a. Click Change Password.

b. In the Change Password dialog box, enter your current password and a
new password. Confirm the password, then click Change.

4. To change your email address:
a. Click Change Email.

b. In the Change Email dialog box, enter a new email address, then click

Save.

Genexus Software concepts

The following terms are frequently used in Genexus' Software. For additional
definitions, see “Genexus” Software definitions” on page 203.

Term or
concept

Description

Example

Sample

The genetic material from a single
source defined by a set of
attributes, such as the date of
collection and type of cancer.

DNA from a biopsy or blood draw.

Sample name

A unique identifier for a particular
sample.

Sample1

Assay

A collection of settings and
parameters for library preparation,
templating, sequencing and
sequencing data analysis.

Oncomine™ Precision Assay GX

Library

A sample associated with an
assay, including barcode
information and sample input
quantity. Libraries are associated
with an assay during library batch
creation.

DNA from a non-small cell lung
cancer specimen that is
sequenced with the Oncomine™
Precision Assay GX.

Genexus™ Software 6.2 User Guide
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Genexus™ Software concepts

Term or
concept

Description

Example

Library batch

A collection of libraries that are
prepped and sequenced in the
same run under the same
conditions on the Genexus"™
Integrated Sequencer.

¢ Alibrary batch that contains
libraries that are different
pools from a single sample.

¢ Alibrary batch that consists
of one library of sample DNA
and another library of sample
RNA (from the same sample).

Library name

A unique identifier for a library.

Library1

Library batch
ID

A unique identifier for a library
batch.

DNA_B1_Lib123456_Samples123

Genexus"™ Software 6.2 User Guide
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Workflow for a sample-to-results sequencing run using the Genexus™

Integrated Sequencer
Create and manage assays (manager/administrator)
(page 94)

System-installed assays that are specifically configured for each sample type are available in
Genexus™ Software. You can use the system-installed assays in your run without change. If you want
to modify any assay settings, copy the system-installed assay that best represents your experiment,
then edit the assay settings if needed.

Enter samples and libraries
(page 18)
Enter samples in Genexus™ Software to assign sample names and provide other information such as
sample collection date, gender, type, and disease category.

Plan and manage runs
(page 32)

Runs created in Genexus™ Software contain all of the settings that are used in library preparation,
templating, sequencing, and analysis, including sample information and plate location, assays, and
barcodes.

Dilute samples and load the sample plate (see the instrument or assay user guide)

Quantify and dilute your nucleic acid samples, then load the sample plate.

Load the sequencer and start a run (see the instrument or assay user guide)

Follow the step-by-step instructions in the sequencer touch screen to load the sample plate and
consumables in the Genexus™ Integrated Sequencer.

Monitor the run
(page 43)

Monitor the run in Genexus™ Software in real time.

Review data and results
(page 44)

Review data and results in Genexus™ Software or analyze data in lon Reporter™ Software using an
lon Reporter™ analysis workflow.

Genexus™ Software 6.2 User Guide 17
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Before planning a run in Genexus™ Software for either a sample run or a library run,
you must first enter sample information in the software to assign sample names and
provide other information. From the Samples menu, you can add samples in two
ways. You can manually enter sample information or import sample information from
a file.

About samples and library batches

Genexus™ Software guides you through the steps of planning a run starting from
either nucleic acid samples or libraries.

In Genexus™ Software, the data and attributes that characterize the genomic data
from a single source are called samples. You can preselect the attributes that you
want to associate with each sample. After adding samples to the software, you can
plan a run in five guided steps.

A library batch is a group of sample libraries that will be sequenced in a library run.
You can create library batches from samples you have previously added or uploaded
to the software. During library batch preparation, you identify the barcode adapters
that were used to prepare the libraries. After creating library batches, you can plan
and start a library run. The software guides you through four steps (naming and
reporting options, selecting assays, selecting library batches, and reviewing) when
you plan a library run.

18 Genexus™ Software 6.2 User Guide
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Chapter 3 Enter samples and libraries
Enter and manage samples
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Enter and manage samples

Create a new
sample

You can add samples to Genexus " Software in two ways.
¢ Enter information for each sample into the software

e Create a CSV file of information for a group of samples and import that file.

If you enter samples manually, you can select from system-installed sample attributes
that are available for in the software. For more information, see “Create a new
sample” on page 19 and “System-installed sample attributes” on page 195.

System-installed sample attributes are also available in the example file that you can
use for importing samples. See “Download an example samples file” on page 21 for
more information.

Note: LIMS users must create custom attributes before importing sample and run
information from LIMS for the attributes to be propagated through to output files. The
software ignores all import file content that is not a recognized attribute.

You can add a new sample in the Samples / Manage Samples screen. The new
sample will be available to use in your run.

—

In the menu bar, click Samples » Manage Samples.
2. In the Manage Samples screen, click + Create Sample.

3. In the Create Sample dialog box, complete the required fields.

Attributes identified with a red asterisk (*) in the Create Sample dialog box are
required when adding a new sample. If attribute information is not available
when adding a new sample, substitute mock information to complete the
required fields.

For more information, see “Sample attributes (manager/administrator)” on
page 21.

4. Click Save.

The new sample is listed in the Manage Samples screen and will be available to
use in your run.

Genexus™ Software 6.2 User Guide 19
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750 Chapter 3 Enter samples and libraries
® Enter and manage samples

Sample data files can be used to capture, manage, and edit sample data. You can
import sample data files in the following formats: TXT, XLS, XLSX, or CSV. For a list of
the sample attributes that are included in the import file, see “System-installed
sample attributes” on page 195. For ease of use, you can download a Microsoft™
Excel™ example file to create an import file. For more information, see “Download an
example samples file” on page 21.

1. In the menu bar, click Samples » Manage Samples, then click
Import Samples.

2. In the Import Samples dialog box, click Select samples file.
3. Navigate to the file, then click Open.

4. Click Upload.

A progress bar followed by an import report appears. If the import process fails,
an error message indicates the reason for failure (for example, an invalid
character was used). For troubleshooting, see “Batch sample import fails” on
page 198.

Successfully imported samples are listed in the Samples / Manage Samples screen.

You can view a summary of a sample in the Samples / Details screen. The Details
screen lists sample attributes as well as the Extraction Kit Barcode and the date the
sample was created in the software. For more information about sample attributes,
see “System-installed sample attributes” on page 195. For more information about
the Extraction Kit Barcode, see “Extract samples” on page 23.

To view the sample summary:

1. In the menu bar, click Samples » Manage Samples.
2. In the Sample Name column, click the sample name of interest.

3. When you are finished viewing sample details, click < Back to return to the
Manage Samples screen.
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Download a Microsoft™ Excel™ example file to create a sample import file. The
example file contains two tabs. The Instruction tab in the spreadsheet lists and
indicates mandatory and optional attributes, which are the column headings in the
Specimen Format tab. Use the Specimen Format tab to enter samples.

1. In the menu bar, click Samples » Manage Samples, then click
Import Samples.

2. In the Import Samples dialog box, click Click here to download the Microsoft™
Excel™ example file.

The example file contains default sample attributes as columns. If custom
sample attributes have been configured in the software, add these attributes as
columns to the example file.

3. Save the file.

You can now import the file in the Import Samples dialog box. For more
information, see “Import samples” on page 20.

Manager- and administrator-level users manage sample attributes and create custom
sample attributes using the Samples / Manage Attributes screen.

* “System-installed sample attributes” on page 195
* “Create a custom sample attribute (manager/administrator)” on page 21

Create a custom sample attribute (manager/administrator)

A manager- or administrator-level user can create custom sample attributes. Sample
attributes, such as the date of collection and type of cancer, characterize and define
a nucleic acid sample. A sample attribute can be made mandatory, in which case you
are required to enter the attribute information for each new sample. Custom
attributes can be used to further characterize samples.

Custom samples attributes cannot be edited or deleted after the samples that use
them have been added to a library. To remove a custom sample attribute from use,
see “Remove a sample attribute (administrator)” on page 26.

1. In the menu bar, click Samples » Manage Attributes.
2. In the Manage Attributes screen, click + Add New Attribute.

3. Complete the fields in the Add New Attribute dialog box.
a. In Attribute Name, enter the name of the attribute.

Attribute names are limited to <20 alphanumeric characters (0-9 and Aa—
Z2), full stops/periods (.), underscores (_), or hyphens (-).

b. In Data Type, specify whether the attribute is text or a number.

c. To require users to select the new attribute when adding or importing
samples, click the toggle button to designate the attribute as Required.

d. Click Submit.
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The new sample attribute is listed in the Attribute Name column and is available
when you add a new sample.

The new sample attribute is available in the Create Sample dialog box and in the
Edit Sample dialog box, even for samples that were created before the new sample
attribute was created. If the new sample attribute is a required attribute, it must be
specified in the Edit Sample dialog box in order to save the changes. For more
information, see “Edit a sample (manager/administrator)” on page 24.

Manage You can find tools for creating, searching, sorting, editing, deleting, and exporting
sam ples samples, and for viewing the sample history in the Samples / Manage Samples
screen.

Sort, search, and filter samples

Use the Samples / Manage Samples screen to sort, search, and filter the list of
samples. The samples are listed by name with the most recently created sample at
the top of the list.

* Use the Filter Samples by list and the Sample Name search box to search,
sort, and filter the list of samples.

To Do this
List only the samples In Filter Samples by, select To Be Extracted.
that have not been
extracted.
List only the samples In Filter Samples by, select To Be Prepared.

that have not been
prepared as a library.

List all samples. In Filter Samples by, select All.

Sort the samples list. 1. Click a column heading to sort the list by the entries
in that column.

2. Click the column heading again to reverse the order.

Search for samples of 1. In the Sample Name search box, enter the full or
interest. partial sample name.
2. Click Q (Search) or press Enter.
The sample or samples that match the sample
name search entry are listed.

3. Click X (Remove) to return to the complete list of
samples.
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Export samples

The Export function generates an XLS file that contains details about the selected
sample.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, select the checkbox in the row of each sample
that you want to export. To select all samples, select the checkbox in the
column heading row.

3. Click &) Export.
An XLS file is created that contains the details of the selected samples.
Depending on your browser settings, the software automatically downloads the
file or prompts you to open or save the file.

4. Open the XLS file in an appropriate viewer to review or print.

Extract samples

You can designate the samples that have been extracted and assign an extraction kit
barcode using the Extract feature of the software in the Samples / Manage
Samples screen.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, in the Filter Samples by dropdown list, select
To Be Extracted.

Note: The Extract option only appears on the screen after samples are filtered
by the To Be Extracted filter.

Only samples that are not associated with a barcode are displayed.
3. Click [ Extract.
4. In the Extract dialog box, type the Extraction Kit Barcode for the sample.

Extracted samples are excluded from the Manage Samples screen when To Be
Extracted is selected in the Filter Samples by... dropdown menu.
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View notes or add a note to a sample

You can add notes to a specific sample or view existing notes. Use Notes to capture
time-stamped written comments and observations for a sample. A sample can
contain multiple notes from different users.

1. In the menu bar, click Samples » Manage Samples.

2. In the row of the sample of interest, in the Actions column, click Notes, then
review existing notes or add a new note.

Action Description

View existing notes for | In the Notes dialog box, notes that are associated with the
a sample. sample are listed by user, date, and time.

Addanewnotetoa | {1 |,the Notes dialog box, click-+ Add Notes.

sample.
P 2. In Add Notes, enter the note, then click Save.

Edit a sample (manager/administrator)

A manager- or administrator-level user can edit samples. In the Samples / Manage
Samples screen, samples that can be edited are identified by the presence of the
Edit link in the Actions column.

Samples can be edited at any point before a sample run that uses that sample is
complete using the Edit link. After the sample is used in a run, the Edit link is no
longer available. To edit a sample after a run is complete, use the Edit Sample &
Amend Report link instead. For more information, see “Edit a sample and amend a
report after a run (manager/administrator)” on page 25.

To add a custom sample attribute to a sample, see “Create a custom sample
attribute (manager/administrator)” on page 21.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, in the Actions column, click Edit in the row of
the sample of interest.

3. In the Edit Sample dialog box, edit the sample attributes.

See “Sample attributes (manager/administrator)” on page 21 for more
information about the system-installed sample attributes.

4. Click Save.

Genexus"™ Software 6.2 User Guide



Chapter 3 Enter samples and libraries  &#
Enter and manage samples \

-
y
‘W
X
Ay
ad

,.
)

Edit a sample and amend a report after a run (manager/
administrator)

After a sequencing run and its analysis have completed, a manager- or administrator-
level user can edit a sample and amend the Lab Report for up to 30 days. Editing a
sample after a run triggers an automatic update of the report and other files
associated with the sample. In the Samples / Manage Samples screen, editable
samples are identified by the presence of the Edit link in the Actions column. After
30 days, the Edit link is unavailable, only the Audit link is available.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, in the Actions column, click Edit in the row of
the sample of interest.

3. In the Edit Sample & Amend Report dialog box, edit sample attributes as
necessary.

See “System-installed sample attributes” on page 195 for more information
about system-installed sample attributes.

4. Click Save.
The Edit Sample and Amend Report confirmation dialog box opens.

5. Click Yes to confirm the changes and continue.

The sample information is edited, and all runs and reports associated with that
sample are updated. Any test report, lab report, tab files and info.csv file that is
associated with the sample will be updated with the changes.

Review sample edit history

The entire history of defining a sample is available to review and export using the
audit feature. The history shows the original sample values and any new values or
activities. The following actions generate an audit record:

¢ Create a new sample
e Edit a sample
e Obsolete a sample
e Delete a sample
This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that

establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.
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1. In the Samples / Manage Samples screen, in the Actions column, click Audit
in the row of the sample of interest.
The Audit Trail Details window opens, listing each action that was performed
for the sample, such as sample creation or edits.

2. (Optional) Click [} Download to export the audit record to a PDF file.

3. Click < Back to close the Audit Trail Details window and return to the list of
samples.

Remove a sample attribute (administrator)

An administrator-level user can use the obsolete command to remove user-created
sample attributes from use in the software. Sample attributes can be reactivated, and
a record of their use is maintained in the audit trail of samples that are created using
that attribute. You cannot designate as obsolete system-installed sample attributes.

—

In the menu bar, click Samples » Manage Attributes.
2. In the Manage Attributes screen, select a custom sample attribute to remove.

3. Click Obsolete in the Actions column, then confirm the action.
Reactivate replaces Obsolete in the Actions column.

4. (Optional) To reactivate an attribute, click Reactivate in the Actions column.
Active sample attributes are listed in the Add New Sample dialog box.

Delete samples

You can delete samples that have not been assigned to a run. Samples that are
assigned to a run are locked and cannot be edited or deleted. Locked samples
display Audit in the Actions column.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, select the checkbox in the row of each sample
that you want to delete. To select all samples, select the checkbox in the column
heading row.

3. Click [il Delete.
The Delete Sample dialog box opens with the message Are you sure you want
to delete selected sample(s)?

4. Click Yes to delete the selected samples.

Enter and manage libraries

You can prepare a library batch manually or import library batch information from a
file. To change sample or library batch information, you can edit information in the
samples, update library batches, and delete samples and library batches.
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A library batch is a group of prepared libraries that are sequenced in the same library
run. If you are planning a run starting from libraries that you have already prepared
manually, you must first create a library batch in Genexus™ Software from samples.
You can enter samples in the software or import a sample file. For more information
see:

e “Create a new sample” on page 19
¢ “Import samples” on page 20

Select the library batch when you plan the run. If you are planning a run starting from
nucleic acid samples, skip this step and proceed to “Plan a sample run” on
page 33.

Note:
. Each library in a library batch must have a unique library name.

. When combining libraries in the same run, each library must have a unique
barcode.
. Fields identified with a red asterisk (*) are required.

No-template controls

You can add a no-template control (NTC) to a library when you create a library batch
in Genexus™ Software. No-template controls do not contain nucleic acid but are
processed in a library run. NTCs are used to monitor contamination or primer-dimer
formations that could produce false-positive results. When you plan a library run
using a library batch that contains an NTC, data generated from the NTC is shown in
the QC results. For more information, see “QC results” on page 55.

Prepare a library batch

A library batch is a group of prepared libraries that are sequenced in the same library
run. If you are planning a run starting from libraries that you have already prepared
manually, you must first create a library batch in Genexus™ Software from samples
that you have added. If you are planning a run starting from nucleic acid samples,
skip this step and proceed to “Plan a sample run” on page 33.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, in the Filter Samples by... dropdown menu,
apply the To Be Prepared filter to limit the displayed samples to those samples
that have not been placed in a library batch.

See “Sort, search, and filter samples” on page 22 for more information on the
Filter samples feature.

3. Select samples in the list by clicking the checkbox to the left of each sample,
then click + Prepare Library Batch.
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4. Inthe Create Library batch screen, in Select Assay, select the assay that you
want to run.

The assay determines specific parameters of the run, including any required
controls and post-run data analysis settings. Only locked assays appear in the
Select Assay dropdown menu. For instructions to lock an assay, see “Lock a
draft assay (manager/administrator)” on page 124.

5. In the expanded screen, in Library Batch ID, enter a unique identifier for the
library batch.

Note: Library Prep Type: automatically fills for the nucleic acid type specified
by the assay you selected: DNA, RNA, DNA+RNA, or TNA.

Library Batch IDs can contain only alphanumeric characters (0-9, Aa-Zz), full
stop/period (.), underscore (_), and hyphen (-). Required fields are indicated with
a red asterisk (¥).

6. Select the barcodes from the kit boxes into the appropriate fields.

7. Select the Include NTC checkbox to add no template control sample
processing and reporting to the library batch.

8. Type a unique library name for each DNA and/or RNA library in the appropriate
field.

® Library names can contain only alphanumeric characters (0-9, Aa-Zz), full
stop/period (.), underscore (), and hyphen (-).

¢ |f your assay requires specific controls, they are automatically listed in the
dialog box. These controls each require a unique barcode ID within the
library batch, but do not require library names.

9. Select the barcode ID of the adapter samples  Runs  Monitor  Results  Assays @ &
used to prepare each library. If
appropriate, swap the default
barcodes in the dialog box between

DNA, RNA, and Fusions by clicking Swapmdes

the Swap Barcodes swap image.

For example, click the DNA and Fusions swap button.

Each library in a library batch must have a different barcode ID. When preparing
the physical libraries, best practice is to swap barcodes between DNA and RNA
libraries in consecutive sequencing runs to prevent carryover contamination. The
barcodes that are listed in the DNA Barcode or RNA Barcode dropdown list
belong to the barcode set that was selected when the assay was created.

IMPORTANT! Ensure that the actual barcodes that you used to create the
libraries match the barcodes that you enter in the Create Library batch screen.
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10. Enter the Input Quantity for each library.

11. Click Submit to save and submit your selections.

The Manage Libraries screen opens, listing the library batch that you created.
Libraries that are prepared in the same batch have the same Library Batch ID.

Import a library batch

You can import library batch information in the form of an .XLS or .XLSX file. The
import file must include all required library and kit information.

—

In the menu bar, click Samples » Manage Libraries.

2. In the Manage Libraries screen, click Import Library Batch.

3. In the Import Library Batch dialog box, click Click here to select an assay for
which the libraries are prepared, and to download an example file for import.

4. Select an assay from the list, then click Download.
The assay name is auto-populated in the Microsoft™ Excel™ template file that

downloads to your drive.

5. In the template file, enter or confirm the library batch information.

Template item

Description

Reagents tab

Assay Name

Auto-populated when assay is selected in step 4
(required)

Library Batch ID

Must be alphanumeric (0-9, Aa-Zz), full stop/period (.),
underscore (_), and hyphen (-) (required)

Library kit barcode

For example, Genexus" Library Strips 1 and 2-AS
barcode (optional)

Panel kit barcode

For example, Oncomine™ Comprehensive Assay v3
DNA GX barcode (optional)

Libraries tab

Sample Name

Same character requirement as Library Batch ID
(required)

Library Name

Same character requirement as Library Batch ID
(required)

Barcode

Barcodes used for each sample and control library
preparation (required)

Nucleic Acid Type

DNA, RNA, or TNA (required)

Genexus™ Software 6.2 User Guide
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Template item Description
Input Quantity Library input quantity (optional)
No Template Control To Include a no template control, add a row with

Sample Name as NTC, Library Name as NA, Barcode
and Nucleic Acid Type similar to sample rows
(optional)

IMPORTANT! For DNA+Fusions assays, the DNA library and RNA libraries
must be listed in sequential order per pool for each sample. For example, for a
1-pool DNA+Fusions assay, order should be DNA, RNA for sample 1, DNA, RNA
for sample 2. For a 2-pool DNA+Fusions assay, library order should be DNA,
RNA (pool 1), DNA, RNA (pool 2) for sample1, then DNA, RNA (pool 1), DNA,
RNA (pool 2) for sample 2.

Save the file.
Click Browse, navigate to the saved file, then select it.

Click Upload.

A progress bar followed by an import report displays. If the import process falils,
an error message indicates the reason for failure (for example, an invalid
character was used). For additional troubleshooting support, see “Library batch
import fails” on page 199.
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You can find tools for searching, sorting, editing, deleting, and auditing libraries and

Manage
library batches in the Samples / Manage Libraries screen.

libraries and
library batches 1.

In the menu bar, click Samples » Manage Libraries.

2. In the Manage Libraries screen, use the tools to perform specific actions.

To...

Do the following...

View more library
information

Click a library name in the library list.

View all libraries

In the Filter Libraries by... dropdown menu, select All.

View libraries that
are not in a run

In the Filter Libraries by... dropdown menu, select To Be
Planned.

Search the list

In the search box, select search by Library Name or Library
Batch ID, type a full or partial Library Name or Library Batch
ID in the search field above the list, then click Q (Search).
Click X to clear the search criteria and display the complete
list.

Sort the list

Click the Library Batch ID, Assay Name, or Sample Name
column heading to sort the list by the information in that
column. Click the column heading again to sort in reverse
order.

View multiple
pages of libraries

Click the scroll buttons below the list.

Delete libraries

Select the checkbox next to the library batch ID or related
libraries (DNA and RNA), then click [i] Delete.

You can delete a library only if none of the libraries in the
same library batch have been assigned to a run.

Edit a library batch

In the Actions column, click Edit for the library batch, then
modify the information in the Edit Library Batch screen. Click
Submit.

View or export the
audit trail of a
library batch

1. In the Actions column, click Audit for the library batch.
The Audit Details screen opens, displaying details of the
most recent auditable action. All audit records for the
library batch are listed on the left.

2. To view audit details for other actions, click on the time
stamp and action listed in the left pane of the screen.

3. To download the record as a PDF file, in the upper right
corner of the screen, click [;] Download.

Add or modify
notes for a library

In the Actions column, click Notes.
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Runs created in Genexus " Software contain all of the settings that are used in library
preparation, templating, sequencing, and analysis, including sample information and
plate location, assays, and barcodes. Runs are used to track samples, consumables,
and chips throughout the library preparation, templating, sequencing, and data
analysis workflow.

You can plan runs for sequencing runs that use either nucleic acid samples (sample
run) or libraries that you have previously prepared manually (library run) as input.
Genexus™ Software guides you step-by-step to set up a run that tells you what
consumables are needed, and provides a printed run setup guide to help you load
the Genexus' Integrated Sequencer with the required consumables.

Before you plan a run

32

Before you plan a run in the Genexus ™ Software, check that:

* Sample information is correctly entered and the assigned sample names are
unique.

* For alibrary run, library batches have been prepared and assigned unique library
batch IDs.

* For a library run, each sample library in a library batch has been prepared with
and assigned a unique barcode or barcode pair.

The software returns an error message when any of these conditions are not met
when planning a run.
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Plan a sample run

You can plan a run starting from isolated nucleic acid samples.

Planning a sample run is organized into steps: Setup, Assays, Samples, Sample
Plate, and Review. Progress through the steps is tracked in the upper left corner of
the Runs / Plan Sample Run screen.

Before planning a run for a sample run, you must enter sample information into
Genexus " Software. For more information, see “Create a new sample” on page 19,
or “Import samples” on page 20.

1. In the menu bar, click Runs » Plan Sample Run.
Note: You can also click + Plan Sample Run in the Runs / Manage Runs
screen.

2. In the Setup step, enter or make the following selections.
a. In the Plan section, enter a unique name.

b. (Optional) In the Reporting (Optional) section, select one or more options if
needed. You can select both options, or leave both options deselected.

Reporting option Description

Generate Report Select this option to generate a Lab Report using a
report template that you specify in the list.

To create a report template, click Assays » Manage
Presets, then in the Report Templates tab, click
-+ Add New.

Upload BAM files to lon | Select this option to automatically upload data for
Reporter™ Software further analysis with lon Reporter™ Software. You
can also upload BAM files after a run if you leave
this option unselected.

Select your lon Reporter™ Software account and
release version.

To configure an lon Reporter™ Server account, see
“Configure an lon Reporter™ Server account
(administrator)” on page 129.

To configure an lon Reporter™ Software on Connect
account, see “Configure Thermo Fisher Accounts in
Genexus" Software (administrator)” on page 127.

c. Click Next.

If a chip is installed in the sequencer, the Chip View graphic in the lower left
corner indicates the lanes that are available for sequencing.

3. Inthe Assays step, select the assay or assays that you want to use in the run.

Use the Filter Assays By list and the Assay Name search box to search, sort,
and filter the list of assays.
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Options

Description

List assays by
research application

In Filter Assays by, select Research Application.
You can filter by:

* RNA
* DNA and Fusions
e DNA

* Fusions

List assays according
to chip type

In Filter Assays by, select Chip Type.

List assays according
to library chemistry

In Filter Assays by, select Library Chemistry.
You can filter by:

e lon AmpliSeq”

e lon AmpliSeq™ HD

List selected assays
only

In Filter Assays by, select Selected.

Sort the assay list

1. Click a column heading to sort the list by the entries
in that column.

2. Click the column heading again to reverse the order.

Search for assays of
interest

1. In the Assay Name search box, enter the full or
partial assay name.

2. Click Q (Search) or press Enter.
The assay or assays that match the assay name
search entry are listed.

3. Click X (Remove) to return to the complete list of
assays.

Note:

. After selecting an assay, the list is filtered to show compatible assays that can

be selected and run at the same time.
. To create a new assay, see Chapter 7, “Create and manage assays (manager/

administrator)”.

IMPORTANT! Ensure that you select the assay that corresponds with the
sample type that you will use in the run. If you select the wrong assay when you
plan a run, the instrument will use incorrect settings during the run, resulting in
invalid sequencing results. Available assays are listed in the

Assays / Manage Assays screen.

34
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If you selected the Upload BAM files to lon Reporter™ Software reporting
option in substep 2b, make the following selections from the dropdown list in
the lon Reporter™ Workflow column in the row of each assay that you
selected.

¢ Select Upload Only to upload sample data to lon Reporter™ Software
automatically upon run completion.

* Select the desired lon Reporter™ analysis workflow to upload sample data
and launch an analysis in lon Reporter™ Software automatically upon run
completion.

Note: In order for the lon Reporter™ analysis workflow to appear in the list,
you must tag the analysis workflow for use with the lonReporterUploader
plugin. For more information, see “Tag an lon Reporter™ Software analysis
workflow for use with the lonReporterUploader plugin” on page 92.

4. In the Include NTC column for each assay that you select, click the Include
NTC checkbox to include a no template control for the assay.

5. After you select an assay (or assays) and make the appropriate lon Reporter"
Software selections (if applicable), click Next.

6. In the Samples step, select the samples from the list that you want to run with
the assay, then click Assign.
The Chip View updates to show the lanes to be used in the run. Lane usage is
calculated based on the number of samples (including a no template control, if
selected), assay type, primer pools used, and minimum reads per sample
entered at assay setup. Green denotes a chip lane that will be used in the run
containing assigned samples within lane capacity. If the minimum reads per
sample x the number of samples exceeds the chip or lane well capacity, a
dialog box appears after you click Assign asking you to confirm that you want
to continue. After confirmation, the Chip View updates and shows the lane color
as red instead of green. The run is allowed, but you may not achieve the
required reads per sample to pass QC metrics.

lon Torrent™ GX5™ Chip lon Torrent™ GX5™ Chip

1-2-3 OCAV3 DNA Fus 4

OCAV3 DNA Fus 7
Lane W3.4.0 Samples w3.4.0 Samples

Green lane color denotes lane usage and Red lane color denotes sample
sample assignment within lane capacity. assignment that exceeds lane capacity.

7. If you selected more than one assay, repeat step 6 for each additional assay.
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8. If needed, edit samples in one of the following ways, then click Next.

* C(Click View & Remove, make your selections, then click Update.
* (Click Remove All, make your selections, then click Assign.

9. In the Sample Plate step, review sample positions in the sample plate. Drag and
drop samples and no template controls to edit the location of samples and
controls, if desired.

10. Modify the concentration of samples, if needed.

Click @ Bulk Edit to modify sample concentration of all samples at one time,
then click Submit to return to the Sample Plate screen.

If a sample concentration is <1,024X of the target concentration for the assay,
which is displayed as a default value for each sample in the Sample Plate
screen, the sequencer automatically dilutes the sample to the target
concentration during the run. If a sample concentration is greater than this value,
you must manually dilute the sample to the target concentration, or to a value
within range for automated dilution before loading on the sample plate.

Note: The sample volume that is required for library preparation is not
adjustable. The volume depends on the number of primer pools in the assay,
sample type, and library chemistry.

11. If sample plate information is correct, click Next.

12. |n the Review step, review the run plan summary, then click Save & Print to
print the run setup guide, if desired. Click Save to save the run without printing.

The run plan summary lists the following details:
* the consumables that are required for this run
* how much sample volume to load
* where to load samples and primer pool tubes
¢ the sample concentration.

Note: If you are using an assay with lon AmpliSeq™ HD library chemistry, the
primer pool positions show that HD primer pools occupy both rows:

Primer Tube Positions

00000000
00000000,

After saving, the run appears in the Manage Runs screen in the run list with the
name you specified.

After selecting the run and loading the sequencer, the run is started on the sequencer
screen.
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Plan a library run

Before planning a library run, you must enter sample information and prepare a
library batch in Genexus™ Software. The library batch selects the assay to be used in
the run, and the assay in turn specifies the barcode set that was used to prepare the
sample libraries. If your sample libraries were prepared using a barcode set not
specified in an assay you want to use in the run, you must

1. create a new assay, or copy an existing assay, and specify the new barcode set
in assay setup.
2. prepare a library batch that selects the new assay.
For more information, see “Create an assay (manager/administrator)” on page 97,

“Copy an assay (manager/administrator)” on page 98, and “Prepare a library batch”
on page 27.

Genexus " Software guides you through the four steps of planning a library run:
Setup, Assays, Library Batches, and Review. Progress through the steps is tracked
in the upper left corner of the Runs / Plan Library Run screen.

1. In the menu bar, click Runs » Plan Library Run.

Note: You can also click + Plan Library Run in the Runs / Manage Runs
screen.

2. In the Setup step, enter a name for the run, then configure the reporting options.
a. In Run Name, enter a unique name.

b. (Optional) In the Reporting (Optional) section, select one or more options if
needed. You can select both options, or leave both options deselected.

Reporting option Description

Generate Report Select this option to generate a Lab Report using a
report template that you specify in the list.

To create a report template, click Assays » Manage
Presets, then click + Add New.

Upload BAM files to lon | Select this option to upload data for further analysis
Reporter™ Software with lon Reporter™ Software. You can also upload
BAM files after a run if you leave this option
unselected.

Select your lon Reporter™ Software account and
release version.

To configure an lon Reporter™ Server account, see
“Configure an lon Reporter™ Server account
(administrator)” on page 129.

To configure an lon Reporter™ Software on Connect
account, see “Configure Thermo Fisher Accounts in
Genexus™ Software (administrator)” on page 127.
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Plan a library run

3.

c. Click Next.

If a chip is installed in the sequencer, the Chip View graphic in the lower left
corner indicates the lanes that are available for sequencing.

In the Assays step, select the assay or assays that you want to use in the run,

then click Next.

Use the Filter Assays By list and the Assay Name search box to search, sort,
and filter the list of assays.

Options

Description

List assays by
research application

In Filter Assays by, select Research Application.
You can filter by:

e RNA
* DNA and Fusions
e DNA

* Fusions

List assays
according to chip
type

In Filter Assays by, select Chip Type.

List assays
according to library
chemistry

In Filter Assays by, select Library Chemistry.
You can filter by:

e lon AmpliSeq™

e lon AmpliSeq™ HD

List selected assays
only

In Filter Assays by, select Selected.

Sort the assays list

1. Click a column heading to sort the list by the entries in
that column.

2. Click the column heading again to reverse the order.

Search for assays of
interest

1. In the Assay Name search box, enter the full or partial
assay name.

2. Click Q (Search) or press Enter.
The assay or assays that match the assay name search
entry are listed.

3. Click X (Remove) to return to the complete list of
assays.

Note: For the assay to be selectable at this step, you must have prepared a
library batch that assigns the assay to the batch. For more information on
preparing a library batch, see “Prepare a library batch” on page 27. The assay
specifies the barcode set that was used to prepare the sample libraries. To
create a new assay, or copy an existing assay, see “Create an assay (manager/
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administrator)” on page 97, or “Copy an assay (manager/administrator)” on
page 98.

IMPORTANT! Ensure that you select the assay that corresponds with the
sample type that you will use in the run. If you select a wrong assay when you
plan a run, the instrument will use incorrect settings during the run, resulting in
invalid sequencing results. Available assays are listed in the

Assays / Manage Assays screen.

If you selected the Upload BAM files to lon Reporter™ Software reporting
option in substep 2b, make the following selections from the dropdown list in
the lon Reporter™ Workflow column in the row of each assay that you
selected.

¢ Select Upload Only to upload sample data to lon Reporter™ Software
automatically upon run completion.

* Select the desired lon Reporter™ analysis workflow to upload sample data
and launch an analysis in lon Reporter™ Software automatically upon run
completion.

Note: In order for the lon Reporter™ analysis workflow to appear in the list,
you must tag the analysis workflow for use with the lonReporterUploader
plugin. For more information, see “Tag an lon Reporter™ Software analysis
workflow for use with the lonReporterUploader plugin” on page 92.

4. In the Library Batches step, select the library batch or batches that you want to
use in the run.

Note: Only one library batch can be selected per assay. However, you can plan
a multi-assay library run if you select multiple, different assays in the Assays
step.

The Chip View updates to show the lanes to be used in the run as green. Lane
usage is calculated based on the number of samples, assay type, primer pools
used, and minimum reads per sample entered at assay setup.

lon Torrent™ GX5™ Chip
lon Torrent™ GX5™ Chip

OCAvV3 DNA Fus 7
W3.4.0 Samples

1-2-3-4 OCAV3DNAFus 6
Lane w3.4.0 Samples

Green lane color denotes lane usage and Red lane color denotes sample
sample assignment within lane capacity. assignment that exceeds lane capacity.
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If the minimum reads per sample x the number of samples exceeds the chip or
lane well capacity, a dialog box appears after you click Next asking you to
confirm that you want to continue. After clicking Yes, the Chip View updates
and shows the lane color as red instead of green. In the example shown at right,
seven samples were included in a library batch instead of six. The run is
allowed, but you may not achieve the required reads per sample to pass QC
metrics.

After you select a library batch (or batches), click Next.

In the Review step, review the run plan summary, then click Save and Print to
print the run setup guide, if desired. Click Save to save the run without printing.

The run plan summary lists the consumables that are required for the run, where
to load the library batch on the sample plate, and how much library volume to
load.

After saving, the run appears in the run list on the Manage Runs screen with the
name you specified.

The run is started on the sequencer screen after selecting a run and loading the
sequencer.

Runs are listed in the Runs / Manage Runs screen. The most recently created run is
on the top of the list.

In this screen, you can:

Sort and search the list of runs.

Review and print a run.

View the audit trail of a run.

Edit a run.

Delete a run (manager/administrator-level users only).

Runs are listed in the Runs / Manage Runs screen. The most recently created run is
on the top of the list.

In the menu bar, click Runs » Manage Runs.

To search the run list:

a. In the Enter Run Name search box, enter the full or partial run name, then
click Q (Search).
The runs matching the search parameters are listed.

b. Click X to return to the complete list of runs.
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To sort the run list:

a. Click the column heading of interest.

The list reorders alphabetically or numerically based on the column name
selected.

b. Click the column heading a second time to reverse the sort order.

Review and You can review and print run information.
prmt arun 1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, click a run name in the list.

3. In the View Sample Run screen, review the information that was entered or

generated when you created the run.

4. (Optional) Click & Print to print the information about the run.
Review and The entire history of a run is available to review, export, or print using the audit
download a run feature. The history shows the original run values and any new values or activities.
hIStOFy This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that

establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

1.

2.

In the menu bar, click Runs » Manage Runs.

In the Manage Runs screen, in the row of the run, in the Actions column, click
Audit .

The Audit Record Details screen box opens. Each modifying event for the
selected run is listed.

In the Audit Record Details screen, review the details of changes that have
been made.

(Optional) Click [;] Download to download a print-ready PDF file of the audit
record.

Click < Back to return to the Manage Runs screen.
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You can edit runs that have not been used in a run and have a run status of Planned.
Parameters that can be edited include reporting options, assays used in the run,
samples included in the run, chip assignment, and sample concentration.

You cannot change the run name.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, in the Actions column, click Edit for the run of
interest.

3. In the Edit Sample Run workflow, change the desired settings by navigating
through the steps clicking Next, then click Save.

Manager- and administrator-level users can delete runs from the software.

In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, select one or more runs to delete by selecting the
checkbox next to the run name.

Select all of the runs in the screen by selecting the checkbox above the column.

3. Click il Delete.

4. In the Delete Plan message box, click Yes to delete the selected run.
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Genexus | lon Torrent

Monitor / Instrument View

Test @
Running

Chip on deck: 21DXEK00023285GX5

lon Torrent™ GX5™ Chip, 0 lanes consumed

a0,
o™

3
el
X @

Serial: 12345

State: Running

Status: Running

Last Init Date: 2015-08-03 14:17
Run Name: 1Q_1lane2
Operator:

Start Time: 2020-02-05 17:02

Completion Time: 2020-02-07 17:43

@ PQStatus: NotV

Monitor the run

B View run progressontheinstrument ....... ... ... .. .. .. . il 43

In the Monitor menu, you can view the status of the sequencer in an idle condition,
or the status of a run in progress.

Samples Runs Monitor R Assays o] &

C' Refresh
TestRig @
Idle

Serial: 1111

Last Init Date:

Chip on deck: 21DXEK00023283GX5

lon Torrent™ GX5™ Chip, 0 lanes consumed

@ PQ Status: Not Verified

View run progress on the instrument

1. In the menu bar, click Monitor » Instrument View.

2. In the Instrument View screen, view the status of a run in progress, or the
status of an instrument.

The following information is provided:
* Sequencer, operator, and run names
¢ PQ status of the instrument
* Instrument status at various stages of the run and post-run
® Status of the results analysis

* Run start and completion times

3. Click C Refresh to update the information.
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Review data and results

B Reviewsampleresulls ........ ... e 45
B RevieW ruNn results .. ......o. i e 46
B View sequencing resultsand assaymetrics ............. ... o ... 49
B Comparesample resSults . ...t i i e e 74
B View completed verificationruns ........ ... ... . i 84
B Lab Report ..o e e 85
B Run plugins after a sequencingruniscomplete .......................... 86
B Reanalyze arun ...t e e e e e e 87
B  Generate customized reports ..ot e e 88
B Resultsfiles . ... e 89
B Upload sample results files to lon Reporter™ Software .................... 90
B Datafilesand flow ... 93

Use the Results menu to review results and data analysis and perform data
management tasks. You can view results sorted by sample or by run.

Selection Description

Click Results » Sample Results Select this option to review completed sample
results and reports.

Click Results » Run Results Select this option to review completed run results
and reports by assay.

Click Results » Verification Select this option to review data from completed
verification runs that were performed during
sequencer installation or performance qualification.
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Review sample results

In the Results / Sample Results screen, samples that have been sequenced are
listed by sample name.

You can search the list of results by sample name. Enter a search term, then click
Q (Search).

The following information appears in the Sample Results screen.

Column

Description

Sample Name

The unique identifier created when the sample was entered into the software. Click the
Sample Name to open the Sample Details screen for the sample. Use the tabs above the
Sample Details to view the run summary, assay metrics, quality control, detailed variant
results, and results for plugins that are associated with the selected assay, if any.

Sample Name
followed by (Signed
Off)

Manager- and administrator-level users can provide their electronic signature on sample
results for completed runs. A sample name followed by (Signed Off) indicates that a
manager- or administrator-level user has approved the sample results. The signature
information appears in the Lab Report PDF file or a user-created report, if selected. For
more information, see “Sign off on the run results (manager/administrator)” on page 151.

Assay Short Name

A shortened version of the assay name you imported or created.

Run Name

The unique name of the run given when it was created in the software.

Sample Status

The status of the run or sample (for example: Completed, Running, Failed, Terminated,
Pending, Stalled).

QC Status

The QC status of a completed run.

Note:
. (Passed) indicates the sample passed all QC metrics.

. X (Failed) indicates the sample failed a QC metric.

. = (Not Calculated) indicates a sample did not undergo QC analysis.

Started On

The date and time when the run analysis was started.

Last Updated On

The date and time when the last action was completed on the run.

Actions

Click the appropriate link. To see more actions, click (More Options).
¢ Lab Report—Download the Lab Report (available only for samples with a sample
status of completed.
For more information, see “Lab Report” on page 85.
* Audit—View the audit trail for the run.
For more information, see “Review and download a run history” on page 41.
* Notes—View or add notes to a run.

¢ CSA—Download customer support archive (CSA) log files for the run to help with
troubleshooting.

For more information, see “Download a customer support archive” on page 198.
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In the Results / Run Results screen, runs that are pending, running, or completed
are listed.

You can search the list of results by run name or PCR plate number. Enter a search
term, then click Q (Search).

The following run information appears in the Results / Run Results screen.

Column

Description

Run Name

The unique name of the run given when it was created in the software. Click a run name to
open the Run Summary. For more information, see “The run summary” on page 47.

Assay Short Name

The shortened unique identifier of an Assay name. You can view the complete list of Assays
and Assay Short Names in the Assays » Manage Assays screen.

Total Samples

The total number of samples in a run.

Run Status The status of the run (for example: Not Started, Pending, Analysis Running, Executing
Plugin, Completed, Terminated, Archival: In Progress).

PCR Plate Number | A unique identifier for the 96-well plate used for library preparation and templating. For more
information, see “Assign PCR Plate” on page 47.

Started On The date and time when the run analysis was started.

Last Updated On

The date and time when the last action was completed on the run.

Actions

Click the appropriate link. To see more actions, click (More Options).

Audit—View the audit trail for the run.

For more information, see “Review and download a run history” on page 41.
CSA—Download customer support archive (CSA) log files for the run to help with
troubleshooting.

For more information, see “Download a customer support archive” on page 198.
Reanalyze —Reanalyze the results of a completed run, starting from alignment or

basecalling. Click Reanalyze, then select a new reanalysis assay that you have created
with modified settings. For more information, see “Reanalyze a run” on page 87.

Upload Samples to IR—Upload sample results files to lon Reporter™ Software for
secondary analysis.

For more information, see “Upload sample results files to lon Reporter™ Software” on
page 90.

Assign PCR Plate —Enter a unique identifier for the 96-well plate used for library

preparation and templating. For more information, see “Assign PCR Plate” on
page 47.

46
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Assign PCR Genexus™ Software allows you to track and associate a run with the PCR plate used

Plate in the run. The PCR plate is the 96-well plate that is used for library preparation and
templating. You can assign a unique identifier (PCR Plate Number) to completed
runs and runs in progress. The PCR plate number that you enter is generated on the
Lab Report and if needed, can help you track libraries and troubleshoot.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, in the Actions column, click
(More Options) » Assign PCR Plate number in the row of the run of
interest.

3. In the Assign PCR Plate dialog box, confirm, edit, or enter the PCR Plate
Number.

The PCR plate number must be between 1 and 10 characters. Only
alphanumeric characters (numbers 0 to 9 and letters A to Z), periods,
underscores, and hyphens are allowed. Spaces are not permitted.

4. Click Submit to associate the PCR plate with the run.

Locate unused You can save and sequence unused libraries from runs planned from samples.

libraries 1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, in the Run Name column, click the run name of
interest.

3. In the Run Summary tab, in the Sample Locations table, view the Library
Position and the Barcode for the sample of interest.

Store the unused libraries, if needed. Sequence unused libraries by planning and
initiating a library run. For more information, see “Plan a library run” on page 37.

The run summary

The run summary displays run information, assays used in the run, sample locations,
information about the reagents used in the run, primer tube positions, and instrument
information.

The run information includes the following items:
¢ Run Status ¢ Report Template

¢ Run Start Date * lon Reporter™ Software
¢ Run Completion Date

Assays table

Item Description
Assay The assay or assays used in the run. Click the assay name to display the details of the
assay.
Analysis Version The version of the assay used for analysis.
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Item Description
Research The research application for the assay, such as DNA or DNA and Fusions.
Application
Chip Type The semiconductor sequencing chip, such as the lon Torrent™ GX5™ chip.
Library Chemistry The type of library chemistry used, such as lon AmpliSeq™ HD.

Lane

The chip lane or lanes used in the sequencing run for the assay.

Total Samples

The total number of samples sequenced for the assay. A single sample may correlate with
multiple wells on the plate for some assays when multiple nucleic acid types are contained
within the sample.

Sample Locations table

Item

Description

Well Pos.

The well position indicates the location of the sample on the plate.

Sample Name

The unique identifier created when the sample was entered into the software.

Nucleic Acid Type

The sample nucleic acid type, such as DNA, RNA, or TNA.

Vol. (ul)

The volume of the sample.

Conc. (ng/pl)

The concentration of the sample.

Dilution Factor

The dilution factor of the sample.

Barcode

The barcode or barcodes associated with the sample.

Assay Short Name

A shortened version of the assay name for the assay that was used to sequence the sample
for the indicated well position.

Library Position

The plate location of libraries. For completed runs that were planned using samples, the
Library Position indicates the location of unused libraries that can be sequenced by
planning and initiating a library run.

Reagents table

Item

Description

Consumable

Consumables used in the run, such as the PanelKit and LibraryKit, are listed.

Barcode

The consumable barcode, if applicable.

Part #

The consumable part number, if applicable.

Expiration Date

The consumable expiration date, if applicable.

Lot #

The consumable lot number, if applicable.

48

The Primer Tube Positions table shows the locations of the primer pool tubes.

The instrument information includes the following items:

Genexus"™ Software 6.2 User Guide



* |nstrument
e Status
e Start Date

Chapter 6 Review data and results ~ #54¢
View sequencing results and assay metrics

e Completion Date
¢ Operator

View sequencing results and assay metrics

For every run, you can view assay-specific results and sample-specific results.
Assay-specific results include assay metrics, such as final read data, and assay-level
plugin information, such as execution of the customer support archive. For more
information, see “Assay metrics” on page 53 and Chapter 9, “Plugins for data

analysis”.

The following sample-specific result information is available.

Tab

Description

Summary

An overview of the results for the sample, including Sample Details,
Key Metrics, and the Variant Summary. For more information, see
“Summary of the Sample Results” on page 51.

QcC

The quality metrics for the sample sequenced in the run. For more
information, see “QC results” on page 55.

Variants

Detailed variant results for SNVs/Indels, Fusions, and CNVs. For more
information, see “View variant results” on page 59.

Plugins

Results generated from the plugins associated with the assay used to
analyze the sequenced sample. For more information, see Chapter 9,
“Plugins for data analysis”.

1. To view sequencing results for a particular sample, including variant and fusion
calls, click Results » Sample Results.

2. In the Sample Name column, click a sample name.

3. In the Results screen, click the QC, Variants, Plugins, and Summary tabs to
view the different types of sample-specific results and data.

In the Variants tab, you can toggle between SNV/INDEL, Fusion, and CNV
results. You can also export data in tabular format.

Genexus™ Software 6.2 User Guide
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4. Toggle between different assay-specific and sample-specific results for the run

with the dropdown menus.

Genexus | lon Torrent

Results / CustomGenericMultiPR0463820 ¥ / GDCAY / SRTestSample02 ¥

Select Assay

SRTestSample02
p Summary QC GDCA

Sample Details opreA

(D Run Result: The run name is listed.

@ Select Assay: Click the assay name of interest to view the assay metrics for the run.

@ Select Sample: Click a sample name to view the sequencing results for the sample. Click
a different sample name to view other sample results for the run and selected assay. Click
Select Sample to view the Assay Metrics for the assay selected in the Select Assay
dropdown list.

Options Description

Run Results The run name is listed. Multiple runs are listed only if the run
dropdown menu has been reanalyzed. For more information, see “Reanalyze a
run” on page 87.

Assays dropdown | Toggle between different assays used in the run. If only one

menu assay is associated with the run, only one assay name is
listed.
Select Sample Toggle between different sample results for the selected run

dropdown menu and assay.

All of the samples that were run with the same assay share the same assay
metrics. All other results are sample-specific. You can view the assay-level
results if no sample name is selected from the Select Sample dropdown list.
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5. To view more options, click --- (More Options).

Options

Description

Reanalyze

Reanalyze a run with a new assay.
For more information, see “Reanalyze a run” on page 87.

Run Plugin

Run plugins on your sequencing data after a sequencing run is
complete.

For more information, see “Run plugins after a sequencing run
is complete” on page 86.

Run Report

The run report includes assay metrics and the record of
reagents that were used in a run.

For more information, see “View or download a Run Report” on
page 55.

Download Files

Download all or selected variant, results, audit and logs, and lab
report files.

For more information, see “Results files” on page 89.

Generate Report

Generate a Lab Report each sample in a sequencing run.
For more information, see “Lab Report” on page 85.

Sign Off Manager- and administrator-level users can provide their
electronic signature on sample results for completed runs.
For more information, see “Sign off on the run results (manager/
administrator)” on page 151.
CSA Customer support archive (CSA) log files for the run to help with
troubleshooting.
For more information, see “Customer Support Archive (CSA)”
on page 198.
Upload to IR Upload results to lon Reporter™ Software for further analysis.
For more information, see “Upload sample results files to lon
Reporter™ Software” on page 90.
Summary of The Results screen displays a summary of the variant and fusion calls for each
the Samp|e sample in a run, as well as details about the sample and a summary of the metrics for
Results the run.

You can view the Results screen for a sample starting from sample or run results, but
navigating from sample results requires fewer steps.

* In the menu bar, click Results » Sample Results, then click a sample name to
open the Results screen.

* Inthe menu bar, click Results » Run Results, then click a run name to open the
Results / Run Results screen. In the Run Name column, click a run name to
open the Results screen. Select a sample from the Select Sample dropdown
list to open the Results screen.
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The information that is displayed depends on the assay that was used in the run. You
can toggle between different assays used in a run with the Assays dropdown list at
the top of the screen.

Section

Description

Sample Details

Sample Name

A unique identifier representing the sample. Click the Sample Name to open the
Sample Details screen for the sample. Use the tabs above the Sample Details to view
the run summary, assay metrics, quality control, detailed variant results, and results
for plugins that are associated with the selected assay, if any.

Collection Date

The date that the sample was collected.

Gender

The biological sex of the sample: Female, Male, or Unknown.

Sample Type

A term that describes the sample, for example, FFPE, DNA, DNA & RNA

Disease Category

The disease type of the sample.

Cancer Type

The type of cancer that is represented by the sample.

Cancer Stage

The stage of the cancer from which the sample was collected.

% Cellularity

The percentage of tumor cellularity in the sample. This is a whole number between
1 and 100. The % Cellularity attribute is applicable to FFPE samples only.

Key Metrics

Average Base Coverage

The average number of reads of all targeted reference bases. This is the total number

Depth of base reads on target divided by the number of targeted bases, and therefore
includes any bases that had no coverage.

Uniformity Of Base The percentage of bases in all targeted regions (or whole genome) that are covered by

Coverage at least 20% of the average base coverage depth reads. Cumulative coverage is

linearly interpolated between the nearest integer base read depths.

% Base Reads On Target

The percentage of filtered reads that are mapped to any targeted region relative to all
reads mapped to the reference. A read is considered on target if at least one aligned
base overlaps at least one target region. If no target regions (file) was specified, this
value will be the percentage of reads passing uniquely mapped and/or non-duplicate
filters, or 100% if no filters were specified.

Variant Summary

SNVs/Indels Lists and describes the SNV, MNV, and INDEL variants that are detected in the
sample.

Fusions Lists and describes the fusions that are detected in the sample.

CNVs Lists and describes the copy number variants (CNVs) that are detected in the sample.

52

Genexus"™ Software 6.2 User Guide




Assay metrics

Assay Metrics

Chapter 6 Review data and results &7
View sequencing results and assay metrics

Assay metrics include various chip metrics for the run, such as well and lon Sphere™
Particles (ISPs) statistics. For runs with multiple assays, metrics are provided for each
assay in the run. Summary metrics are displayed at the top of the screen, followed by
sample-specific metrics in the Run Samples table. Barcode-specific metrics are
listed in the Barcodes With Reads Reported table. All barcodes with reads
detected, even if unassigned or not planned in the run, are listed to allow you to
readily identify the source of any barcode cross-contamination.

To view the assay metrics for a run, in the Results / Run Results screen, in the Run
Name column, click the run name of interest. In the Run Summary screen, select an
assay from the Select Assay dropdown menu. To view the metrics for another assay
in the run, select a different assay from the dropdown menu.

Assay metrics are assay-specific and cannot be viewed within the sample results
screens. To view assay metrics, ensure that Select Sample is selected in the Select
Sample dropdown menu.

Metric Description

Loading The number and percentage of total addressable wells on the chip that contain an ISP.

Enrichment The number and percentage of wells ISPs that contain live ISPs.

Library The number and percentage of wells with live ISPs that contain Library ISPs.

Final Reads Library reads passing all filters that are recorded in the output BAM files. This value
can be different from the total number of reads due to technicalities associated with
read trimming beyond a minimal requirement.

Total Bases The number of filtered and trimmed base pairs that are reported in the output BAM

file.

Mean Raw Accuracy 1x

The mean raw accuracy across each individual base position in a read calculated as,
(1-[total errors in the sequenced reads]/[total bases sequenced]) x 100. Raw read
accuracy is measured at each base across the length of the read and is based on 1x
sequencing coverage; raw read accuracy is not based on consensus accuracy across
multiple reads for the same base position.

Wells with ISPs

The number of wells that contain an ISP.

Total Addressable Wells

Wells on the chip that can be physically reached by a library.

Empty Wells

The percentage of total addressable wells on the chip that do not contain an ISP.

Wells with Live ISPs

Loaded wells with ISPs with a signal of sufficient strength and composition to be
associated with the library or control fragment key.

Wells with Library ISPs

Loaded wells with live ISPs with a key signal that is identical to the library key signal.

Control ISPs

Loaded wells with live ISPs with a key signal that is identical to the control fragment
key signal.
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Metric Description

Polyclonal Wells with a live ISP that carries clones from two or more templates.

To view polyclonal metrics, mouse over the first low quality portion (gray) of the Final

Reads bar plot.

Final Reads 54.6% (?) Filtered 42.79%
55,478,516 s

Final Reads(55,478,516) / Wells with Library J .JO.yC.Ona._: 30,144004 (29.66%) l

Low Quality Loaded wells with a low or unrecognizable signal.

To view polyclonal metrics, mouse over the second low quality portion (gray) of the
Final Reads bar plot.
Final Reads 54.6% (?) Filtered 42.79%
55,478,516 s
Wells with Library 1SPs(101,618,073) | Low Quality: 13310077 (13.1%)

Filtered The total percentage of filtered reads, or the sum of the percentages of polyclonal, low
quality, and adapter dimer reads.

Adapter Dimer Loaded wells with a library template of an insert size less than 8 bases.

Loading Density A visual representation of chip loading. Red color indicates areas of higher density of
loading. Blue color indicates areas of lower density of loading. The following example
illustrates a sequencing experiment where two lanes on the chip are uniformly loaded
with ISPs.

Loading Density

Run Samples

The Run Samples table lists read data for each individual sample in the assay.

Column Description
Sample Name The unique identifier created when the sample was entered in the software.
Nucleic Acid Type The sample nucleic acid type, such as DNA, RNA, or TNA.
Barcode The unique identifiers of the dual barcode pair assigned to the DNA and/or RNA
library for a sample.
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Column Description

Total Reads The total number of filtered and trimmed reads with the listed dual barcodes assigned
to the sample. The reads are independent of length reported in the output BAM file.

Mean Read Length The average length, in base pairs, of usable library reads for each sample.

>Q20 Bases The total number of called bases that have >99% accuracy (or less than 1% error rate)
aligned to the reference for the sample.

Uniformity The percentage of bases in all targeted regions (or whole genome) with a depth of
coverage >20% of the mean read coverage.

Read Length Histogram A histogram that presents all filtered and trimmed library reads that are reported in the
output BAM file (Y-axis) and the mean read length in base pairs (X-axis). The shape of
the histogram should closely resemble the library size distribution trace without the
adapter sequences.

0 50 150 200 250 300

View or download a Run Report

You can view a run report or download a run report summary in PDF format. The run
report includes assay metrics and the record of reagents that were used in a run.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, in the Run Name column, click the run name of
interest.

3. In the Run Summary screen, click --- (More Options) » Run Report.
A Run Report window opens.

4. To download a run report summary in PDF format, click Download as PDF.

QC results The QC screen displays quality metrics for each sample that was sequenced in the
run. This information is also accessible through the Monitor menu within 72 hours of
starting the run on the sequencer.

To view the QC screen, in the Results / Sample Results screen, click a sample
name in the Sample Name column. In the Results screen, click the QC tab. The QC
status for each metric is indicated beneath each QC test (Run QC, Templating
Control QC-CF-1, Sample QC-DNA, and Sample QC-RNA).

If a sample fails a single test metric, the sample fails that QC test. A sample must
meet all QC parameter thresholds of a particular QC test in order to pass. The QC
status is broken down into the following categories.

. (Passed) indicates the sample passed all QC metrics.
¢ X (Failed) indicates the sample failed a QC metric.

®* — (Not Calculated) indicates a sample did not undergo QC analysis.
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Note: If a sample fails to meet one or more QC parameters, you can reanalyze a run
(see “Reanalyze a run” on page 87).
The data displayed in the screen depend on the assay that was used in the run.
Metric Description
Run QC General run quality control information.
Key Signal The average signal after software processing for library ISPs that identically match

the library key (TCAG).

Percent Loading

The number of wells with ISPs divided by the number of the total addressable wells
in a run.

Raw Read Accuracy

The average raw accuracy across each individual base position in a read, where raw
read accuracy is calculated as 100 * (1 - (sum(per base error)/sum(per base depth))).

Templating QC—CF-1
Control

Sequencing quality metrics of the control fragment. These metrics
indicate templating success.

Average Reads Per Lane

The number of CF-1 reads divided by the number of chip lanes used in the run.

Base Call Accuracy

The probability that a given base is called correctly.

1 — (total number of errors for all positions in CF-1) / (total number of CF-1 base
reads).

Mean AQ20 Read Length
(bp)

Average length, in base pairs, at which the accuracy rate is 299% for CF-1 reads.

Sample QC—DNA

Sequencing quality metrics of the sample DNA library.

MAPD

MAPD (Median of the Absolute values of all Pairwise Differences) is a quality metric
that estimates coverage variability between adjacent amplicons in CNV analyses. A
MAPD value of 0.4 indicates an acceptable level of coverage variability. High MAPD
value typically translates to a lower coverage uniformity. Lower coverage uniformity
can result in missed or erroneous CNV calls. If the MAPD QC threshold is not met,
CNVs do not get called. The MAPD metric does not affect SNVs/INDEL calls.

Mapped Reads

The number of reads that are mapped to the reference file.

Mean AQ20 Read Length
(bp)

The average length, in base pairs, at which the accuracy rate is 299% for all aligned
reads of a library.

Mean Read Length (bp)

The average length, in base pairs, of final library reads for the sample.

Uniformity of Amplicon
Coverage

The percentage of amplicons that had at least 20% of the average number of reads
per amplicon. Cumulative coverage is linearly interpolated between nearest integer
read depth counts.

Median Mol Cov

The median number of functional molecule reads per amplicon calculated over all
amplicons in the assay.

This metric is applicable to lon AmpliSeq™ HD library chemistry only.
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Metric

Description

Uniformity of Base
Coverage

The percentage of reads with a depth of coverage >20% of the mean read coverage
at each position.

This metric is applicable to lon AmpliSeq™ HD library chemistry only.

Read Length Histogram

The histogram presents all filtered and trimmed DNA library reads that are reported
in the output BAM file (Y-axis) and the mean read length in base pairs (X-axis). The
shape of the histogram should closely resemble the library size distribution trace
without the adapter sequences.

Read Ratio for Inline
Controls (Endogenous to
Spike-ins)

The ratio of genomic sample reads to control reads for each inline control amplicon.

.. Read Ratio for Inline Controls (Endogenous to Spike-ins)

a4
| I I I I I I
p4d

m 100

125 178 266 T4
In<im Control Amphcon Size (bpl

Read Ratio
o

Note: The Read Ratio for each inline control amplicon is expected to be 3 with
10 ng DNA input for both lon AmpliSeq™ and lon AmpliSeq™ HD chemistries.

Sample QC - RNA

Sequencing quality metrics of the sample RNA library.

Mapped Reads

The total number of final library reads that are aligned to the reference file for the
sample.

Mean Read Length (bp)

The average length, in base pairs, of the final library reads for the sample.

RNA Expression Ctrls
Detected

The number of expression control genes detected for the sample. This metric
measures the RNA input integrity, input amount, and the fidelity of the reverse
transcriptase that was used in library preparation.

Fusion panels include primer pairs that cover seven control housekeeping genes.

Mean AQ20 Read Length

The average length, in base pairs, of the final library reads with no more than 1%
error rate for the sample.

The average length, in base pairs, at which the accuracy rate is 299% for all aligned
reads of a library.

Read Length Histogram

The histogram presents all filtered and trimmed library reads that are reported in the
output BAM file (Y-axis) and the mean read length in base pairs (X-axis). The shape
of the histogram should closely resemble the library size distribution trace without
the adapter sequences.
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Metric

Description

Read Ratio for Inline
Controls (Endogenous to
Spike-ins)

The ratio of genomic sample reads to control reads for each inline control amplicon.
You can use this metric to measure the level of contaminating genomic DNA in RNA
libraries when you select the RNA checkbox for Include Inline Controls in assay set

up.

Note: The Read Ratio for each inline control amplicon is expected to be 3 with
10 ng DNA input for both lon AmpliSeq™ and lon AmpliSeq™ HD chemistries.

NTC QC - DNA

DNA Sequencing quality metrics of the no template control.

Average Base Coverage
Depth

The average number of DNA reads of all targeted reference bases.

Mean Read Length (bp)

The average length, in base pairs, of final DNA library reads for the no template
control.

Read Length Histogram

The histogram presents all filtered and trimmed reads for the no template control
that are reported in the output BAM file (Y-axis) and the mean read length in base
pairs (X-axis).

Read Ratio for Inline
Controls (Endogenous to
Spike-ins)

The ratio of no template control sample reads to control reads for each DNA inline
control amplicon.

NTC QC - RNA

RNA Sequencing quality metrics of the no template control.

Mapped Reads

The average number of RNA reads of all targeted reference bases.

Mean Read Length (bp)

The average length, in base pairs, of final RNA library reads for the no template
control.

RNA Expression Ctrls
Detected

The number of expression control genes detected for the no template control.

Read Ratio for Inline
Controls (Endogenous to
Spike-ins)

The ratio of no template control sample reads to control reads for each RNA inline
control amplicon.
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MAPD copy number QC metric

The Median of the Absolute values of all Pairwise Differences (MAPD) score is
reported on Aneuploidy analyses and other analyses that detect CNVs.

MAPD is one of the metrics that we define to assess whether the panel data is useful
for copy number variation (CNV) analysis.

MAPD is defined as the Median of the Absolute values of all Pairwise Differences
between log2 ratios per tile for a given run. Tiles roughly correspond to amplicons in
an lon AmpliSeq™ assay. Each pair is defined as adjacent in terms of genomic
distance. Tiles corresponding to copy humber amplicons and other amplicons are
being treated equally as no differences in variability are seen between these types.
Then, any two log2 ratios that are adjacent on the genome are a pair. Except at the
beginning and the end of a chromosome, every log2 ratio belongs to two pairs.
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Formally, if x1 is the log2 ratio at position i, with i ordered by genomic position:

MAPD = median ( | x(i - 1) - x(i) | )

MAPD is a per-sequencing run estimate of copy number variability, similar to
standard deviation (SD). If one assumes the log2 ratios are distributed normally with
mean 0 and a constant SD, then MAPD/0.95 is approximately equal to SD. However,
unlike SD, using MAPD is robust against high biological variability in log2 ratios
induced by known conditions such as cancer.

Regardless of the source of the variability, increased variability decreases the quality
of CN calls.

Note: MAPD is not shown on the QC Report.

You can view detailed variant results and toggle between different variant results,
including SNVs/Indels, Fusions, and CNVs, in the Results screen.

Variant Tables

Variant type Description

SNVs/Indels ¢ SNVs: missense and nonsense single nucleotide
variants. Multi-nucleotide variants are also included.

¢ Indels: insertion and deletion variants.

For more information, see “View SNV/INDEL results” on
page 59.

Fusions Translocations of genetic material.

For more information, see “View Fusion results” on
page 62.

CNVs Copy number variations (CNVs) are variations of the
number of copies of a given gene.

For more information, see “View CNV results” on
page 67.

The SNVs/Indels table lists the calls and other information for the SNV and INDEL
variants that are analyzed in each sample in a run.

1. In the menu bar, click Results » Sample Results.
2. Click a sample name to open the Results screen.
3. Click the Variants tab.

4. Click SNVs/Indels to view the SNVs/Indels table.

5. (Optional) Click Export in the upper right corner of the screen to export the
results data in tabular format.
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SNVs/Indels table

The data displayed in the table depend on the assay that was used in the run. You
can adjust the number of columns that are visible using the Columns dropdown
menu. Deselect the checkbox next to a column heading to remove the column from
the table. Select the checkbox to add the column back to the table. Not all of the
columns are visible on the screen; use the scrollbar under the table to view additional
columns. You can adjust column widths in the column headers to expand or reduce
the number of columns visible on the screen.

Filter the results list in the table using the Filter dropdown menu. For more
information, see “Filter results using a filter chain” on page 71. To sort and filter the
results in each column, click Y (Filter). Options for the column are displayed in the
Filter dialog box. Check the checkbox next to an option in the Filter dialog box, then
click Filter to display the option in the column. Deselect the checkbox next to an
option to hide the option. Click Clear to display all results in the column.

Column

Description

User Classifications

User-defined classification to selected from the list.

For more information, see “Create and assign variant classifications” on page 70.

Locus

The chromosome and position of the detected variant.

Oncomine Variant
Class

The type of SNV or INDEL at the locus based on Oncomine™ annotations.

This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Oncomine Gene
Class

The change in molecular function of the altered gene product due to the mutation, based on
Oncomine™ annotations:

* Gain-of-function — the altered gene product has a new molecular function or pattern of
gene expression compared to the wild-type gene

* Loss-of-function — the altered gene product lacks the molecular function of the wild-
type gene

This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Gene The gene name. Click the link to open the View Annotation Sources window to view
additional information. For more information, see “View annotation sources” on page 69.

AA Change Identification of the amino acid change using Human Genome Variation Society (HGVS)
nomenclature.

Ref The reference base or bases at that locus.

Alt The alternate base or bases at that locus.
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Column Description

Type The type of variant that is detected.
* snp (single nucleotide polymorphism)
* mnp (multi-nucleotide polymorphism)
* ins (insertion)
* del (deletion)
* complex

Call Indicates the presence or absence of an SNV/Indel variant. When the default filter chain is

applied, only the variant calls that are designated with PRESENT (HOMOZYGOUS) or
PRESENT (HETEROZYGOUS) are displayed in the results table. To view all calls, including
calls that do not pass the required filter thresholds, apply the No Filter option or download
the Variants (.vcf) file (see “Results files” on page 89).

e PRESENT (HOMOZYGOUS) or PRESENT (HETEROZYGOUS) - indicates a high
confidence call that passes all filter thresholds at a given variant position.

Note:

. When the default filter chain is applied, PRESENT (HOMOZYGOUS) or PRESENT
(HETEROZYGOUS) indicates the presence of the ALT (alternative) allele.

. When the No Filter option is applied or when viewing the Variants (.vcf) file, Present
does not imply the presence of the ALT (alternative) allele. To infer the presence of
the ALT allele, refer to the Alt column.

e NO CALL - while some evidence for the presence of a variant exists, the call does not
pass one or more filters that are required for a high confidence variant call.

e ABSENT - indicates the presence of a variant that differs from the reference allele at a
given position, however, this nucleotide is not an ALT allele that is targeted by this
assay.

No Call Reason

The reason why a variant is not reported.

Phred QUAL Score

The relative probability of either the "reference" hypothesis interval [0,cutoff], or the "variant"
hypothesis interval [cutoff,1], Phred-scaled (-10*log10). A higher score means more
evidence for the variant call.

Raw Read Depth

Total read coverage across amplicon containing SNV/INDEL hotspot locations. Count of
chip-level reads aligned at this locus that participate in variant calling.

Effective Read Depth

The number of reads covering the position.

Alt Allele Read The number of reads containing the alternate allele.

Counts

Variant ID The name of the hotspot as defined in the Browser Extensible Data (BED) file.
Nuc Change The position and identity of the nucleic acid change.

Allele Fraction

The number of variant read counts divided by the total number of read counts for the
sample.

Genexus™ Software 6.2 User Guide
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Column Description

Mol Depthl'] Reports number of interrogated DNA molecules containing target. It defines limit of
detection at hotspot position in a particular run and sample. For instance, if molecular depth
is 21,500, you can have high confidence that no variant is present at 0.2% LOD. If molecular
depth is 2,500, you can have high confidence that no variant is present down to 0.1%
LOD. For reference calls, Molecular Depth provides measurable metric that serves as
confirmation for variant absence among a large number of interrogated molecules.

WT Mol Counts!'! Number of detected molecules containing the wildtype allele.

Alt Allele Mol Number of detected molecules containing the alternate allele.

Countsl!]

Mol Freq %! Molecular frequency percentage. The percentage of mutant reads over total reads at the
locus.

% LoD Limit of detection (LOD) of a variant allele expressed as a percentage of the WT allele. LOD
is the lowest possible variant frequency in the sample that can be detected by the system
with a true positive rate greater than 98% for FFPE samples or 95% for cfTNA samples.
LOD is dependent on the molecular read depth at the locus. %LOD is reported when there
are no variant calls for the gene.

' Column appears in analyses of lon AmpliSeq™ HD sequencing data only.

View Fusion The Fusions table lists the calls and other information for the fusions analyzed in
results each sample in a run.

1. In the menu bar, click Results » Sample Results.
2. Click a sample name to open the Results screen.
3. Click the Variants tab.

4. Click Fusions to view the Fusions table.

5. (Optional) Click Export in the upper right corner of the screen to export the
results data in tabular format.

Fusions table

The data displayed in the table depend on the assay that was used in the run. Filter
the results list in the table using the filtering tools. For more information, see “Filter
results using a filter chain” on page 71.

Column Description

User Classifications | A user-defined classification selected from the list.

For more information, see “Create and assign variant classifications” on page 70.

Locus The chromosome positions in the reference genome that define the fusion junction.
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Column

Description

Oncomine Variant
Class

Oncomine variant class annotation that indicates fusion type based on Oncomine™
annotations. This information is available if the Apply Oncomine Variant Annotations
checkbox is selected in the assay that is used in the run.

Oncomine Gene
Class

The change in molecular function of the altered gene product due to the mutation, based on
Oncomine™ annotations:

* Gain-of-function — the altered gene product has a new molecular function or pattern of
gene expression compared to the wild-type gene

* Loss-of-function — the altered gene product lacks the molecular function of the wild-
type gene

This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Genes (Exon)

The name of fusion target and representative acceptor and donor exons.

Read Counts

The frequency that the fusion was detected in the sample.

Type Assay type (for example, Fusion, RNA exon variant (exon skipping), RNAExon Tile, Proc
Control).
Call Indicates the presence or absence of a fusion or RNA exon variant. When the default filter

chain is applied, only the fusion/RNA exon variant calls that are designated with PRESENT
are displayed in the results table. To view all calls, including calls that do not pass the
required filter thresholds, apply the No Filter option or download the Variants (.vcf) file (see
“Results files” on page 89).

* PRESENT - indicates a high confidence call that passes all filter thresholds at a given
variant position.

* ABSENT - indicates the absence of a fusion due to the variant call failing internal
quality control.

* NO CALL - while some evidence for the presence of a fusion exists, the call does not
pass one or more filters that are required for a high confidence fusion call.

No Call Reason

The reason for reporting a fusion as NOCALL.

Failed Reason

The reason for reporting a fusion as Absent.

Variant ID

The name of the fusion target as defined in the BED file.

Read Counts Per
Million

The number of fusion read counts detected per number of total reads (in millions).

Oncomine Driver
Gene

The gene believed to be associated with increased oncogenic properties. The gene is
inappropriately activated by the fusion.

Mol Cov. Mutant(']

The median molecular coverage across a fusion amplicon.
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Column Description

Imbalance Scorel?] Each fusion gene exhibits a characteristic Imbalance Score threshold. Scores that exceed
this threshold value indicate a high likelihood of the presence of the fusion in the test
sample.

* Observed = (sum of read count coverage of amplicons downstream (3') of a predicted
breakpoint in a target gene) / (sum of read count coverage of all amplicons of the gene)
[Read counts from test sample]

* Expected = (sum of baseline value for amplicons downstream of the breakpoint/sum of
baseline values) / (sum of baseline values of all amplicons of the gene) [Baseline values
computed from normal samples]

Imbalance P-Valuel? | The statistical significance of measure of imbalance relative to a control gene.

Predicted Break- The exonic range for predicted fusion break point in exon tiling assays.
point Rangel?

Ratio To Wild Typel'l | The molecular ratio for exon skipping assays relative to wild type control amplicons.

Norm Count Within | (Lung panel only) Exon skipping assay coverage normalized to molecular coverage of wild
Genel'l type (WT) MET control amplicons.

[ Column appears in analyses of lon AmpliSeq™ HD sequencing data only.
[l Column appears in analyses that use the exon tiling fusion detection method.

View RNA Exon Variant

The RNA Exon Variant data view displays a bar graph summary of intragenic exon
rearrangements or fusions. The displayed RNA exon variants are defined in the BED
file that is associated with an assay. The RNA Exon Variant data view is available for
all RNA and Fusion assays.

1. In the menu bar, click Results » Sample Results.
2. In the Sample name column, click the name of the sample of interest.

3. Click the Variants tab, then click Fusions.
The Fusions table opens to display fusions results.

4. In the top right corner of the screen, click Visualization » RNA Exon Variant,
then review the RNA Exon Variants plot.
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Representative RNA Exon Variant plots
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The X-axis represents specific exon variants, where each variant is labeled with a gene ID followed by a sequence of adjacent
exons. The Y-axis measures the read counts for each variant, normalized to the wild type.

@ Example analysis where only the wild type EFGR (EFGR.EBE7) was detected.

@ Example analysis where RNA exon 2-7 deletion occurred in the EFGR gene. The deletion of exons 2-7 resulted in an increase
of normalized read counts for the EFGR variant that contains the intragenic fusion of exon 1 and exon 8 (EFGR.E1E8.Del1) and
a decrease of normalized read counts for the wild type EFGR (EFGR.EGE7).

To return to the table view of fusions, click XX (Remove) next to the Visualization
dropdown menu.

View RNA Exon Tile Fusion Imbalance

The RNA Exon Tile Fusion Imbalance data view provides a visual representation of
the RNA fusion imbalance analyses.

Note: The exon tiling method for fusion detection and the RNA Exon Tile Fusion
Imbalance data view are specific to the Oncomine™ Precision Assay GX. For more
information, see the Oncomine™ Precision Assay GX User Guide

(Pub. No. MAN0OO18508).

1. In the menu bar, click Results » Sample Results.
2. In the Sample name column, click the name of the sample of interest.

3. Click the Variants tab, then click Fusions.
The Fusions table opens to display fusions results.

4. In the top right corner of the screen, click Visualization » RNA Exon Variant,
then review the RNA Exon Tile Fusion Imbalance plots.
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Representative RNA Exon Tile Fusion Imbalance plots
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@ The Fusion Imbalance Call: Imbalance Score & P-value plot shows the imbalance scores and p-values for all the genes in
the selected sample. The dashed gray lines mark the threshold for an imbalance call, which is applied to all genes across all
samples. Points that fall within the blue shaded area of the plot represent fusion-positive genes (=f=). All other points that are
outside of the blue shaded area represent fusion-negative genes (O). Control genes are marked with ‘

@ The Normalized Read Depth by Gene plot shows the mean read counts of each gene that is captured on the chip for the
selected sample. For each gene, the read counts are normalized to the number of amplicons.

@ The Sample Coverage for Imbalance Analysis plots show the expression profile for each exon-exon tiling amplicon for each
gene. The Y-axis represents the corrected molecular counts. The X-axis represents individual exon-exon junctions, which are
listed from &' to 3'. The imbalance score and p-value are listed in the panel of each gene that was called positive for fusion.

@ Baseline (a cluster of gray lines), generated from a fusion-negative sample.

@ Test sample corrected read coverage (blue line), normalized to the baseline. Each point on the line represents a unique
exon-exon junction that was covered by the assay and normalized to the baseline.

@ Predicted range for the fusion break point for a fusion-positive gene (dashed red line).
@ Sample coverage profile for the control gene (orange line).

If the collected data are insufficient to determine an imbalance score, the INVALID SAMPLE message appears in the panel for
that gene.

To return to the table view of fusions, click XX (Remove) next to the Visualization
dropdown menu.

View CNV The CNVs table lists the calls and other information for the copy number variants
results (CNVs) analyzed in each sample in a run.

1. In the menu bar, click Results » Sample Results.
2. Click a sample name to open the Results screen.
3. Click the Variants tab.

4. Click CNVs to view the CNVs table.

5. (Optional) Click Export in the upper right corner of the screen to export the
results data in tabular format.

CNVs table

The data displayed in the table depend on the assay that was used in the run.
Results in the table can be filtered using the filtering tools. For more information, see
“Filter results using a filter chain” on page 71.

Column Description

User Classifications | A user-defined classification selected from the list.

For more information, see “Create and assign variant classifications” on page 70.

Locus The starting position of the first amplicon covering the CNV gene.

Oncomine Variant Annotation that indicates whether CNV is an amplification or deletion.

Class This information is available if the Apply Oncomine Variant Annotations checkbox is

selected in the assay used in the run.
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Column Description

Oncomine Gene The change in molecular function of the altered gene product due to the mutation, based on
Class Oncomine™ annotations:

* Gain-of-function — the altered gene product has a new molecular function or pattern of
gene expression, compared to the wild-type gene

* | oss-of-function — the altered gene product lacks the molecular function of the wild-
type gene

This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Gene The gene name, which provides a link to the View Annotation Sources dialog box with
additional information about the HotSpot ID.

For more information, see “View annotation sources” on page 69.

Copy Number The copy number of a CNV gene locus per genome. This column is available when a
positive call is made.

Call Indicates the presence or absence of a CNV. When the default filter chain is applied, only
the CNV-positive calls that are designated with PRESENT are displayed in the results table.
To view all calls, including calls that do not pass the required filter thresholds, apply the No
Filter option or download the Variants (.vcf) file (see “Results files” on page 89).

* PRESENT - indicates a high confidence call that passes all filter thresholds.

* PRESENT (GAIN) — a CNV-positive call that indicates gene amplification; a high
confidence variant call that passes all filter thresholds.

* PRESENT (LOSS) - a CNV-positive call that indicates gene deletion; a high confidence
variant call that passes all filter thresholds.

e ABSENT - the absence of a variant; result is below detection threshold for a CNV call.

* NO CALL- while some evidence for the presence of a variant exists, the call does not
pass one or more filters that are required for a high confidence variant call.

P-Value The statistical significance of the CNV ratio measurement.
No Call Reason The reason for reporting a CNV as No Call.
CNV Confidence The CNV confidence interval associated with the call. The 5% lower confidence bound

value is the ploidy estimate, where there is a 5% chance that the true ploidy is below that
value. The 95% upper confidence bound is the ploidy estimate, where it is 95% certain that
the true ploidy is below that value.

Variant ID The name of the hotspot as defined in the BED file.

CNV Ratio The ratio of measured CNV gene locus coverage relative to coverage of non-CNV loci.

Med Mol Cov Gene [ The median molecular coverage of targeted CNV gene.

Med Mol Cov Ref [l | The median molecular coverage of non-CNV reference loci.

Med Read Cov Gene | The median read coverage of targeted CNV gene.
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Column

Description

Med Read Cov Ref

The median read coverage of non-CNV reference loci.

Valid CNV Amplicons

The number of amplicons spanning the CNV call.

[ Column appears in analyses of lon AmpliSeq™ HD sequencing data only.

View
annotation
sources

Visualize
variants with
IGV

You can view more information for each HotSpot ID in the sample Results screen in
the SNVs/Indels, Fusions, and CNVs tables.

In the menu bar, click Results » Sample Results, then click the sample name in the
Sample Name column in the row of a sample of interest. In the Variants tab, click
SNVs/Indels, Fusions, or CNVs.

1.

2.

In the SNVs/Indels, Fusions, or CNVs table, in the Gene column, click the gene
symbol.

The View Annotation Sources window opens, which displays information for
the particular variant.

Review annotation information in the View Annotation Sources window.
a. Click View IGV to download a JNPL file that can be opened in the
Integrative Genomics Viewer (IGV) from the Broad Institute (see

software.broadinstitute.org/software/igv).

b. If available, click a link in the row of an annotation source to navigate to the
online annotation information.

You can visualize data from Genexus™ Software with the Broad Institute Integrative
Genomics Viewer (IGV). The viewer is available at the Broad Institute website: http://
software.broadinstitute.org/software/igv/home.

1.

2.

In the menu bar, click Results » Sample Results.
Click a sample name to open the Results screen.
Click the Variants tab.

In the SNVs/Indels, Fusions, or CNV table, in the Gene column, click the gene
symbol.

In the View Annotation Sources window, click View IGV to download a JNPL
file that can be opened in the Integrative Genomics Viewer (IGV) from the Broad
Institute (see software.broadinstitute.org/software/igv).
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Create and You can create and assign user-defined variant classifications in the SNVs/Indels,
assign variant Fusions, and CNV tables in the Variants tab of the Results screen.

classifications 1. In the menu bar, click Results » Sample Results.

2. Click a sample name in the Sample Name column in the row of a sample of
interest to open the Results screen for the sample.

3. Click the Variants tab.

4. In the Variants table, click SNVs/Indels, Fusions, or CNVs to display the list of
variants for the selected variant type.

5. In the Variants table, in the User Classification column, perform any of the
following actions.

* To assign an existing classification to a variant, select it from the list.

Genexus | lon Torrent Genexus | lon Torrent Genexus | lon Torrent

Results / OCAV3MultiCustom7198771¥ / DFOCCH Results / OCAv3MultiCustom7198771Y / DFOC Results / OCAV3MultiCustom7198771 ¥ / DFOCC/

SRTestSample01 Summary  QC — SRTestSample01 Summary Q — SRTestSample01 Summary Q -

Filter | Oncomine SNVs/Indels Filter  Oncomir SNVs/Indels Filter | Oncomine
UserClassification ¥ Locus Y User Classification’ ¥ Locus v User Classification ¥ Locus Y

Classification ~ chr13:32911442 1 ” o e Likely Pathogenic ~
chr13:32911442

I |

| 911442
chr13:32911442
@ Benin jof
Likely Benign o
o Likcﬁ Pathogenic ju
@ Pathogenic g

@ Uncertain Significance @

I -Add

* To create a new classification, enter a name for the classification in the text
box, select a color for the new classification, then click Add.

Genexus | fon Torrent Genexus | lon Torrent Genexus | ion Torrent

Results / OCAv3MultiCustom7198771¥ / DFO! Results / OCAv3MultiCustom7198771Y / DFOC! Results / OCAv3MultiCustom7198771¥ / DF(
SRTestSample0l  Summary Qo — SRTestSample0l  summary  Qc — SRTestSample0l Summary Q-
SNVs/Indels Filter  Oncom SNvs/indels - g fiter™] Oncomir SNVs/Indels Filter  Oncor
User Classification ¥ Locus Y .
User Classification 'Y Locus T User Classification 'Y Locus Y
chr13:32911442
‘ Protective b11442
‘ Protective 911442 ‘ Protective 911442
| M Add
| [N
Other.

* To remove a classification from a variant, click X (Remove).
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¢ To delete a classification from the list, click [i] Delete next to the
classification name. The classification will be removed from all variants in all
results.

Filter results You can filter results in the SNVs/Indels, Fusions, and CNV tables in the Variants tab
of the Results screen in two ways. You can apply filters to columns of information
that appear in the screen. The filters, available at the top of each column,
immediately narrow the list of information in any columns to which filters are applied.

You can also apply a filter chain, a set of filters that Genexus' Software uses to
narrow the list of variants that are included in results. A manager-or administrator-
level user creates filter chains from system-installed filters.

Filter the view of results in the Results screen

You can filter results to immediately narrow the list of results that is shown in columns
in Results screen. Filters are available for each column in the list of results.

1. In the menu bar, click Results » Sample Results.

2. Click a sample name in the Sample Name column.

3. In the Results screen, click the Variants tab.

4. Select the variant class to display the results: SNVs/Indels, Fusions, or CNVs.

5. In the results table, click ¥ (Filter) in the column heading of interest, enter filter
options, then click Filter.
The options that are available depend on the column and variant class. For
example, you can filter data in the Type column to show one specific variant
type.

The column or columns to which you applied a filter change to reflect the filter and
selected options.

Filter results using a filter chain

You can filter the results that are listed in the Results screen with a system-installed
or custom filter chain. A filter chain is a set of filters that Genexus™ Software uses to
narrow the list of variants that are included in results.

Select a filter chain to change the list of variants that are included in the results. You
can apply the filter chain temporarily, then review the results before you decide
whether to save the updated results, or discard the changes.

If you save the filter chain to a result, the variants that are included reflect the filtered
results when the results are later opened.
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For information about system-installed filter chains, see “System-installed filter
chains” on page 178. Manager- and administrator-level users can create filter chains.
For more information see, “Create a custom filter chain (manager/administrator)” on
page 106

1.

2.

In the menu bar, click Results » Sample Results.

In the Sample Results screen, in the Sample Name column, select a sample of
interest.

In the Results screen, click the Variants tab.
Select the variant type to display the results: SNVs/Indels, Fusions, or CNVs.

Above the variant table in the Results screen, in the Filter dropdown menu,
select a filter chain.
The list of results changes to reflect the selected filter chain.

(Optional) Click Save next to the filter chain name if you want the filter chain to
be applied to the results when the results are later opened.

The filter chain is selected in, and applied to the results when the results are
reopened.

To view the analysis of Oncomine™ TCR Beta-LR Assay GX expression data, in
the Results / Sample Results screen, click the sample name in the Sample
Name column, then click the Results tab. Results are viewed in two tabs:
Sample Results and Sample QC.

In the Sample Results tab, select from the following options in the Views
dropdown menu.

— Spectratyping Plots — Clones detected per variable

- V-gene usage gene
— CDRS3 histogram

— Clone Summary

- VJ-gene usage
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Genexus | lon Torrent Samples  Runs  Monitor  Results  Assays 8 2

Results / TCR4461941 ¥ / TCRB-LRwW1.3.0 Y [ SRTestSample0l ¥
SRTestSampleol Summan QC Results Plugins
Sample Results Sample QC

Views: Spectratyping Plots

Mutation | Evenness | Shanmon Diversity = LargestClone Frequency | Number of Clones

Spectratyping plot highlighting mutation

Spectratyping plot highlighting frequency of mutated bases over the variable gene of identified clones. Reads for identified clones are arranged along the X-axis according to the variable gene identity and the Y-axis
according to the CDR3 nucleotide length. Size of the circles indicates the frequency of a particular variable gene-CDR3 NT length combination within the dataset, while color indicates the average frequency of
mutated bases for clones having a particular variable gene-CDR3 NT length combination. Ordering of variable genes reflects position within the TCRB locus. Key repertoire metrics are displayed along the lower
margin of the plot

TCRB V-gene usage and mutation rate

Clone Shannnon Diversity: 4.9637 Reads: 10892 Mean CDR3 NT Length: 35.6981 +/-
53504
Clone Evenness: 0.5843 Clones: 360 V-gene Shannon Diversity: 3.0161

* In the Sample QC tab, select from the following options in the Views dropdown
menu.

— Read classification

— Proportion of full length, quality-trimmed, and reads lacking P1key, by
read classification

- Base composition of overcalled and undercalled homopolymers
— Downsampling analysis
- QC metrics

For detailed information on viewing and analyzing Oncomine™ TCR
Beta-LR Assay GX results, see the Oncomine™ TCR Beta-LR Assay GX User Guide
(Pub. No. MANO018513).
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You can compare variant results across samples with Genexus™ Software.
Comparisons between a variety of results can be made. However, results generated
using the system-installed Oncomine™ TCR Beta-LR Assay GX (or any other immune
repertoire assay) can only be compared to samples within the same assay.

e For information about the comparisons of variant results of immune repertoire
workflows, see “Compare immune repertoire results” on page 80.

¢ For more information about the comparisons of variant results across all other
workflows, see “Compare variant results” on page 74.

You can compare variant results and create comparison plots from multiple sample
results with Genexus™ Software. A description of the comparison of results from
immune repertoire assays is not included here. For more information, see “Compare
sample results” on page 74. Comparisons across samples or runs can be used to
analyze results for a hotspot of interest. You can also visualize the trends of a
reported variant over time.

The following comparisons can be made in Genexus™ Software:

e Comparisons of multiple samples, sequenced and analyzed with the same or
different assays

¢ Comparisons of multiple samples over time, sequenced and analyzed with the
same or different assays

e Comparisons of the results from one sample, sequenced and analyzed with
different assays

If samples from different assays are compared, the research application (such as
DNA or DNA and Fusions) must be comparable. That is, results generated from DNA-
only assays cannot be compared to results generated from RNA-only or fusion-only
assays. However, if the results from a research application include the type of results
from another research application, the comparison can be made. That is, you can
compare variant results generated from a DNA and Fusion assay to the variant results
generated from a DNA-only assay.

View variant result comparisons

You can view variant comparisons in tabular format in Fusions, SNVs/Indels, and
CNV comparison tables in the Compare screen.

1. In the menu bar, click Results » Sample Results.

2. Click the checkboxes next to the sample names of interest.

Note: Select Filter Runs by » Sample Status » Completed to limit the entries
that are displayed on the Sample Results screen.

3. In the upper right corner of the screen, click (%) Compare.

Note: Compare is not enabled until at least two samples are selected.
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The Compare screen opens to the Compare Samples tables. The Oncomine™
Extended (5.14) filter is the default filter for the data displayed in the tables.

4. (Optional) In the Compare screen, in the upper right corner, click Filter to select
and apply a different chain to the variants displayed in the tables. For more
information, see “Filter results using a filter chain” on page 71.

5. (Optional) Click Export to download an xlIsx spreadsheet file of the variant
comparison table.

Genexus | lon Torrent

Results / Compare

Compare Samples q) @ @ @
I I
Export v

I I
@— Fusions

SRTestSample03 | 2020-02-24 X SRTestSampleol | 2020-02-24
@—'\n’a\iant 1o} @— Oncemine Driver Gene Read Counts Call Read Counts Per Million Read Counts Call Read Counts Per Million

CCDCE-RET.C1R12.CO5F1271.1 RET 142 PRESENT 2831.110314 214 PRESENT 3633.523499

EML4-ALK.E6aAZ0.AB3T4361.1 ALK 28 PRESENT 558.247104 54 PRESENT 916.870416

RET RET NA PRESENT NA PRESENT

5LC34A2-ROS51.54R32.C05F 1196 ROS1 1112 PRESENT 22170.384991 1284 PRESENT 21801140994
5LC34A2-RO51.54R34.C05F 1198 ROS51 a0 PRESENT 1794.365692 1u7 PRESENT 1986.552567

NTRK3 NTRK3 NA PRESENT

() Export: Download a Microsoft™ Excel™ file of the sample (®) The variant type. In this example: Fusions.

comparison Fusions table. (8) Variant ID: The name of the hotspot as defined in the
@ The QC status of the sample. Browser Extensible Data (BED) file.
(3 The sample name. (@) Oncomine Driver Gene: For fusion class variants, the 5’
@ The date the sample was analyzed. gene that drives proliferation of expression.

Table slider. Use to extend table to view more samples.

The following table lists and describes the default information shown in the
comparison tables.
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Description

Fusions comparison tables

Variant ID

The name of the hotspot as defined in the BED file.

Oncomine Driver Gene

For fusion class variants, the 5’ gene that drives proliferation of expression.

Read Counts

The frequency that the fusion was detected in the sample.

Call

The presence or absence of a fusion for the specific hotspot.

Read counts per million

The number of fusion read counts detected per number of total reads (in millions).

SNV/Indels comparison tables

Variant ID The name of the hotspot as defined in the BED file.
Gene The gene name.
AA Change Identification of the amino acid change using HGVS nomenclature.

Allele Fraction

The number of variant read counts divided by the total number of read counts for the
sample.

Call

Indicates the presence or absence of an SNV/Indel variant. See SNV/Indel section for
more information.

CNVs comparison tables

Variant ID

The name of the hotspot as defined in the BED file.

Gene

The gene name.

Copy Number

The frequency that the fusion was detected in the sample.

Note: Copy Number is not displayed for TNA CNV result comparisons.

Call

Indicates the presence or absence of a CNV.

CNV Ratio

Ratio of CNV amplicons after outlier removal.

Create time series graphs

You can create line graphs to visualize changes and trends in variant results over
time.

76

1. In the menu bar, click Results » Sample Results.

2. Click the checkboxes next to the sample names of interest.

Note: Select Filter Runs by » Sample Status » Completed to limit the entries
that are displayed on the Sample Results screen.

3. In the upper right corner of the screen, click (= Compare.

Note: Compare is not enabled until at least two samples are selected
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The Compare screen opens to the Compare Samples tables. Oncomine™
Extended is the default filter for the data displayed in the tables.

4. (Optional) In the Compare screen, in the upper right corner, click Filter to select
and apply a different chain to the variants displayed in the tables. For more
information, see “Filter results using a filter chain” on page 71.

5. In the Fusions, SNVs/Indels, and CNV table, select the checkboxes next to the
variant IDs you want to visualize in a plot.
The datapoints are added to the line graph with live preview.

6. (Optional) Click Download to download a PNG file of the time series line graph.

Fusions Download
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92 b P o2 W W1 b o &
%@ @ <@ Ll f(&‘h{" Qk’l."" q,&"‘ Qﬁ?“ @
Analysis Date

.lv1ET—f-ﬂET.Iv113h-115 B EGFR-SEPT14.E24310 NCOA4-RETNTR12.COSF1491
A TPM3-NTRK1.T7N10.COSF1329 .TMF‘F‘.SSE—ERG.UE2.COSF23.‘I

Create and customize comparison plots

1. In the menu bar, click Results » Sample Results.

2. Click the checkboxes next to the sample names of interest.
Note: Select Filter Runs by » Sample Status » Completed to limit the entries
that are displayed on the Sample Results screen.

3. In the upper right corner of the screen, click (= Compare.
Note: Compare is not enabled until at least two samples are selected

The Compare screen opens to the Compare Samples tables. Oncomine™
Extended is the default filter for the data displayed in the tables.
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4. (Optional) In the Compare screen, in the upper right corner, click Filter to select
and apply a different chain to the variants displayed in the tables. For more
information, see “Filter results using a filter chain” on page 71.

5. In the Fusions, SNVs/Indels, and CNV table, select the checkboxes next to the
variant IDs you want to visualize in a plot.
The datapoints are added to the line graph with live preview.

6. (Optional) To customize the chart, click Chart Options in the upper right corner
of the screen.

7. In the Preferences dialog box, change the parameters to customize the plot.

¢ X-Axis Options

Option Description
Sample Name The unique identifier for a sample.
Analysis Date The date of the sequencing run. The analysis date or run

completion date is typically included in the Sequencing
Run Retails of the Lab Report.

Collection Date The date that the sample was collected.

¢ Y-Axis Options

Option Description
SNVs/Indels See “View SNV/INDEL results” on page 59.
Fusions See “View Fusion results” on page 62.
CNVs See “View CNV results” on page 67.

Note: Y-Axis options depend on the assay or assays used to analyze the
samples.

8. Click Apply to update the chart with your selections.

9. (Optional) Click Download to download a png file of the comparison plot or time
series line graph.
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SNVs/indels Download
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LibSample2 LibSample4 LibSample3 LibSample1
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Sample Name

.COSMEM B COsM14249 COSM13424 & COSM43947

View and customize comparison tables

1. In the menu bar, click Results » Sample Results.

2. Click the checkboxes next to the sample names of interest.
Note: Select Filter Runs by » Sample Status » Completed to limit the entries
that are displayed on the Sample Results screen.

3. In the upper right corner of the screen, click (% Compare.
Note: Compare is not enabled until at least two samples are selected

The Compare screen opens to the Compare Samples tables. Oncomine™
Extended is the default filter for the data displayed in the tables.

4. (Optional) In the Compare screen, in the upper right corner, click Filter to select
and apply a different chain to the variants displayed in the tables. For more
information, see “Filter results using a filter chain” on page 71.

5. (Optional) To customize the table or tables, click Table Columns in the upper
right corner of the screen.
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Use the checkboxes next to a table column option to add (checked) or remove
(unchecked) the column to the table.

The available options depend on the assay or assays used to analyze the
samples. For descriptions of options, see the following sections.

Option Description
SNVs/Indels See “View SNV/INDEL results” on page 59.
Fusions See “View Fusion results” on page 62.
CNvVs See “View CNV results” on page 67.

Checked options are added as column headings to the Fusions, SNVs/Indels,
and CNV comparison table with live preview.

Click Table Columns again to close the dialog window.

(Optional) Click Export to download an xIsx spreadsheet file of the variant
comparison table.

Genexus | lon Torrent

Results

| Compare

Compare Samples

SNVs/Indels Export  — LibSemplea1 | 2020-02-25 — LibSampleso | 20200225
Variant ID Gene AAChange Call Phred QUALScore  RawReadDepth  AlleleFraction  Call Phred QUAL Score  RawRead Depth  Allele Fraction
CosMaTs BRAF pValé00Gls  PRESENT(HETEROZYGOUS)  29.0701 23 0173 NO CALL 00 0 0
COSMs6s CTNNBI  pThrézAla PRESENT (HETEROZYGOUS) 104333 2] 0083 NO CALL 724362 5 0
cosMezs2 EGFR pGly7I9Ser  PRESENT(HETEROZYGOUS) 433354 3 0.189 PRESENT (HETEROZYGOUS) 380352 0 0.25
COsMs32 KRAS PRESENT (HETEROZYGOUS) 36,0562 4% 0152 PRESENT (HETEROZYGOUS) 364152 e 04
COSMs21 KRAS PRESENT (HETEROZYGOUS) 360551 46 0.152 NO CALL 638683 35 0.028
CcosMTT5 PIKSCA  pHisloaTArg  PRESENT(HETEROZYGOUS)  87.022 43 028 NO CALL 00 0 0
COSMs6T3 CTNNBI  p.SerssTyr NOCALL 4.8157L b 2 0 PRESENT (HETEROZYGOUS) 582481 55 0273
COSMe128 CTNNBI  p.Serdsdel NOCALL 423464 5 0 PRESENT (HETEROZYGOUS) 544825 53 0.18
COSM123s4s1  MAP2KI  p.GlnsePro NOCALL 44187 3 o PRESENT (HETEROZVGOUS) 12657 & 0.205

You can compare immune repertoire variant results with Genexus' Software. A
description of the comparison of results generated from all other assays is not
included here. For more information, see “Compare sample results” on page 74.

Compare the immune repertoire between samples

Genexus™ Software can perform multi-sample (or cross-sample) analyses to compare

the
1.

2.

immune repertoire between samples.

In the menu bar, click Results » Sample Results.

In the Sample Results screen, click the checkboxes next to the sample names
of interest.

Select Filter Runs by » Sample Status » Completed to limit the entries that are
displayed on the Sample Results screen.

The immune repertoire comparison is only applicable to samples sequenced
with the system-installed Oncomine™ TCR Beta LR RNA Only assay (or any
other custom or system immuno-oncology workflow).
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3. In the upper right corner of the screen, click (= Compare.
Note: Compare is not enabled until at least two samples are selected.

The Overview of Repertoire Sequencing Results for Selected Samples table
is displayed.

4. (Optional) Click the hyperlinked Sample name to open the Immune Repertoire
Results for that sample. See “View Oncomine™ TCR Beta-LR Assay GX run
results” on page 72 for more information.

5. Click the checkboxes next to the analyses you would like to compare.

6. In the dropdown menu at the top of the screen, select how you would like to
compare clones across the sample.

Options Description

CDR3 NT Compare the clones based on the CDR3 nucleotide
sequence. If the nucleotide sequence is shared across the
samples, those are considered identical clones. This is the
least stringent comparison option.

Variable Gene + Compare the clones based on the rearrangement of the
CDR3 NT variable gene plus the CDR3 nucleotide sequence.

7. Click Compare Samples to generate a comparison table and plots.

Note: Compare Samples is not enabled until at least two samples are
selected.
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8.

View variable comparison results in the Comparison Table tab.

Genexus | lon Torrent Samples  Runs  Monitor  Results  Assays & 2

Results / Compare

Comparison Table | Comparison Plots

Variable Joining CDR3AA CDR3NT R_2019_05_28 16 19 10_si... | R_2019_05 28 16 19 10_si... R 2019 0528 16 19 10 si... R 2019 0528 1619 10 si...
@— TRBV3-1 TRBI2-1 ASSQQLGEQF GCCAGCAGCCAACAATTA. 01652714 0.1639175 01765607 0.1731592
TRBV3-1 TRBI-3 ASSQDGGQNTDTQY GCCAGCAGCCAAGATGG. 00976337 0111556 0.1141034 0.1087700
TRBV28 TREII-2 ASSLHHKSNYGYT GCCAGCAGTTTACATCAC, 0.0263652 0.0240425 0.0236533 0.0267215
TRBV20-1  TRBI2 SIIQNTGELF AGCATCATAATTCAGAAC 0.0230953 0.0178862 00158377 00145415
TRBV7-9 TRBI2-7 ASSRGPAYEQY GCCAGCAGTCGAGGGCC 00135201 0.0139386 0.0064417 0.0074447
TRBV2S TRBI2-7 ASSFLGAGGLYEQY GCCAGCAGTTICCTIGGT. 00135201 0.0133606 00124404 00117367
TRBV20-1  TRBI-I SVEDSLASGSGEQF AGCGTTGAAGATTCTTTG. 00103825 0.0085906 0.0070686 0.0068100
TRBV2 TRBII-2 ASTEWSGNYGYT GCCAGCACTGAATGGTCC. 0.0089116 00142535 00111303 0.0106844
TRBVII2  TRBI-3 ASSLTALGRSPDTQY GCCAGCAGCTTAACCGCC. 0.0084069 0.0069364 0.0080709 0.0085592
TRBVS-1 TRBI2-2 ASSLGFNTGELF GCCAGCAGCTTGGGATTT. 0.0073344 0.009789 0.0081009 0.0089362

1- 10 of 43498 items

10 tems per page

@ Each row represents a clone.
@ The frequency of the clone for the listed sample.

9. View comparison plots in the Comparison Plots tab.

Options Description

Comparisons between 2 An interactive scatter plot for the selected analyses is
analyses. shown in the Comparison Plots tab.

Comparisons between A Jaccard Similarity Index for the selected analyses is
more than 2 analyses. shown in the Comparison Plots tab.

The interactive scatter plot indicates the frequency of clones across two
analyses. For more information, see “Example correlation and proportion of
shared clones” on page 83.

The Jaccard similarity index is determined for each pairwise comparison and is
displayed in heat map format. For more information, see “Example Jaccard
Similarity Index for selected samples” on page 83.

Genexus"™ Software 6.2 User Guide



Chapter 6 Review data and results o
Compare sample results TS5

Example Jaccard Similarity Index for selected samples

This is an example of a Comparison Plots tab showing the Jaccard Similarity Index
for selected samples. The Jaccard similarity index is determined for each pairwise
comparison and displayed in heatmap form. The Jaccard Similarity Index ranges
from 0 to 1 and is calculated as the total number of shared clones divided by the total
number of unique clones across two samples.

Genexus | lon Torrent

Jaccard Similarity Index for selected samples

VB12-12-VB12_TCR Bera_Semin_extension_28May2019 ]

Example correlation and proportion of shared clones

This is an example of a Comparison Plots tab scatterplot. The illustration indicates
the frequency of clones across two samples. Frequency values are log10
transformed with a pseudocount frequency of 1E-6 added to each value. Hovering
over a point reveals the CDR3NT and AA sequence of a clone, the variable mutation,
and the frequency in either sample.

Genexus | lon Torrent

Results / Compare

Comparison Table  Comparison Plots

Correlation and proportion of shared clones (log10 scale with pseudocount added)

-« 3 2
Timing Verification_PBL_RANA_Hu_SR_8samples_540_C1_Rep2 RNA v2_c4555_2018-06-27-16-04-28-556
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View completed verification runs

Manager- and administrator-level users can view verification run details, including the
run summary, QC summary, and the reagents used in the run. Verification runs are
sequencing runs performed during Genexus™ Integrated Sequencer installation to
validate the performance of the sequencer.

Note: Field Service Engineers use system-installed verification templates to validate
the installation of the Genexus' Integrated Sequencer. Field Service Engineers can
view the template information but cannot modify it.

1. In the menu bar, click Results » Verification Results.

2. In the Verification Results screen, in the Run Name column, click the
verification run name of interest.
The Verification Results Details screen opens.

3. (Optional) Click [ Download as PDF to download the Verification Report file.

Verification The following information is available in the Results / Verification Results screen.
runs
Column Description
Run Name The name of the run, created when the run was planned. Click the name to open
the View Sample Run dialog box.
Assay Name The name of the assay used in the run.

Field Engineer Name

The name of the support specialist who performed the run.

Instrument Name

The name of the sequencer that was verified.

Run Status

The current status of the full sequencing run, including analysis.

QC Status

Indicates whether a sequencing run passed or failed, based on the sequencing
QC metrics selected for the assay.

Last Updated on

The date and time that the sequencing run was last updated.

Actions

* Audit—Click this link to display the list of users who created/edited the run.
You can export and print information from the list from the Audit Trail dialog
box.

® CSA—Customer Support Archive. Click this link to download all of the
sequencer log files. Log files contained within the CSA may be useful when
troubleshooting issues with the sequencer. For more information, see
“CustomerSupportArchive plugin” on page 170.

84

Genexus"™ Software 6.2 User Guide



Lab Report

Chapter 6 Review data and results
Lab Report

The Lab Report is a PDF report of the results for each sample in a sequencing run.
The assay used in the run determines the data that is included in the report.

To automatically generate a Lab Report for each sample during data analysis of a
run, select the Generate Report checkbox in the Setup step when you plan the run
(for more information, see Chapter 4, “Plan and manage runs”). To generate a Lab
Report for each sample after a run is complete, see “Generate customized reports”
on page 88.

When a Lab Report has been generated for a sample, a link is available in the
Results / Sample Results screen in the Actions column for that sample. Click the
link to download the PDF.

Lab reports can be electronically signed by manager- and administrator-level users.
Electronically signed reports have (Signed Off) after the sample name in the
Sample Results screen. The electronic signature is included in the footer of the
report. For more information, see “Sign off on the run results (manager/
administrator)” on page 151.

A Lab Report typically contains the following sections and information, depending on
the assay used.

Section

Description

Sample Details

The sample information that is entered into the software. You can customize the format of
the Sample Details section when you create a new report template. To create a new report
template, click Assays » Manage Presets, then in the Report Templates tab, click

-+ Add New.

Sequence Variations:
Detected

Variants and fusions detected in the sample, based on the targets defined by the assay.
Allele frequencies are also reported.

Test Description

A description of the report or assay that was entered in the report template.

Sequence Variations:
Not Detected

Variants and fusions not detected in the sample, based on the targets defined by the assay.

Comments

Laboratory comments entered in the report template.

Sequencing Run
Details

Contains the following subsections:
* Assay—the assay name and panel used
¢ Analysis—the run date and name of the user who sent the run to the instrument
¢ Run Details —the consumables used in the run
* Control QC Evaluation Metrics —a summary of the CF-1 quality control metrics
¢ Run QC Evaluation Metrics—a summary of the run quality control metrics
¢ Sample QC Evaluation Metrics —a summary of the sample quality control metrics
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Download the You can download the Lab Report for a sample of interest.
Lab Report

1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, in the Actions column, click Lab Report in the
row of the sample of interest.

A ZIP file that contains the PDF report downloads automatically.

3. Extract the downloaded files, then open the PDF file in an appropriate viewer.

Run plugins after a sequencing run is complete

You can run plugins on your sequencing data after a sequencing run is complete
using the Run Plugin function in the Results screen for the sample. Use this
command to run one or more plugins on the data for the first time, or to rerun any
plugin that has been run before (for example, if a plugin has been updated or failed
during analysis).

1. In the menu bar, click Results » Sample Results.

2. Click a sample name in the Sample Results screen.
3. Click --- (More Options).

4. Click Run Plugin.

5. In the Run Plugin dialog box, select one or more assays in the run, then select
the plugins to run on those assays.

6. Click Run.
While plugins are running, the Run Plugin link is unavailable for that run.

7. When analysis is complete, you can review the results. For more information,
see Chapter 9, “Plugins for data analysis”.
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Reanalyze a run

If a sequencing run fails to meet one or more QC parameters defined by the assay,
you can relax the assay parameters and reanalyze a run. Runs can be reanalyzed
starting from Alignment or Basecalling. When you reanalyze a run, the reanalysis is
applied to all samples in the assay. For more information, see “View sequencing
results and assay metrics” on page 49.

Note:

. Manager- and administrator-level users can reanalyze a sequencing run only if the
run completed without any critical alarms or errors. If the run aborted or produced
major alarms or errors, the run cannot be reanalyzed.

. QC parameters at the limits of stringency cannot be relaxed further. The sample
library must be resequenced or a new library prepared.

. An assay can be used only once.

Before you begin, create a new assay or copy the original assay that was used in a
run and modify assay parameters as needed. For more information, see Chapter 7,
“Create and manage assays (manager/administrator)”.

1. In the menu bar, click Results » Run Results.

2. In the Results / Run Results screen, in the Run Name column, click the run
name of interest.

3. In the upper right corner of the screen, click --- (More Options) » Reanalyze.

4. In the Reanalyze dialog box, enter or select the following information.
a. In Reanalysis Run Name field, enter a reanalysis run name.

b. In Start Reanalysis from dropdown list, select Alignment or Basecalling.

c. In the Current Assay in Run column, select the checkbox in the row of
each assay that you want to reanalyze, then in the Choose Assay to
Reanalyze column, select an assay that you want to use for each
reanalysis from the dropdown list.

5. Click Reanalyze.

Follow the progress of the reanalysis in the Results / Run Results screen in the Run
Status column and in the Results / Sample Results screen in the Sample Status
screen. When reanalysis is complete, the new results can be viewed by clicking the
run name corresponding to the reanalysis assay in the Results / Run Results
screen. Runs that have been reanalyzed are appended with (Reanalysis) after the run
name.
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Generate customized reports

88

When generating a customized report, you can update any report template
selections. For more information on results files, see “Results files” on page 89.

1.

2.

In the menu bar, click Results » Sample Results.

In the Results / Sample Results screen, click the sample of interest in the
Sample Name column.

In the Results screen, click :-- (More Options) » Generate Report.

In the Generate Report dialog box, select the report template and variants to
include in the report.

Click Generate.
A ZIP file that contains all the selected reports and other files is downloaded.
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The following files can be downloaded from the View Results screen for each
sample. The files that are available for download vary depending on the assay used.
For a list and descriptions of plugin output files, see “Output files generated by the
coverageAnalysis plugin” on page 161 and “Output files generated by the molecular
CoverageAnalysis plugin” on page 168.

To download the files, click Results » Sample Results, then click a sample name in
the Sample Name column. In the Results screen, click

.-+ (More Options) » Download Files. In the Download Files dialog box, select the
files to download, then click Download. The selected results files are downloaded in
one ZIP folder.

Selection

File name

Description

Variants

Filtered Variants (.vcf)

<Filter name>
_filtered.vct

Summary of filtered variant results in variant call
format (VCF).

All Variants (.vcf)

Oncomine <LibPrepID>
<analysisID>.vcf

Summary of variant results in variant call format

(VCF).

Variant Summary (.tsv)

Summary.tsv

File that lists SNV/INDEL, copy number, and fusion
results in tab-separated value format (TSV).

Snvindel (.tsv)

Snvindel.tsv

File that lists SNV/INDEL variant results in tab-
separated value format (TSV).

Fusion (.tsv)

Fusion.tsv

File that lists fusion results in tab-separated value
format (TSV).

(.bam)

CNV (.tsv) Cnv.tsv File that lists copy number variant results in tab-
separated value format (TSV).

Sequencing results

DNA Unmapped Bam File <barcode> Unmapped DNA barcode BAM file; output after

_rawlib.basecaller.bam

mapping reads to reference.

DNA mapped bam file (.bam)

merged.bam

Mapped BAM file of combined barcode reads.

DNA Mapped Bam Index File
(.bai)

merged.bam.bai

Mapped BAM Index file.

DNA Basecaller FASTAQ File
(.fastq)

<barcode> rawlib.
basecaller.fastqg

FASTQ file of the DNA barcodes used.

DNA Processed Bam File

merged.bam.ptrim.bam

Mapped BAM file of combined barcode reads.

DNA Processed Bam Index

merged.bam.ptrim.bam
.bai

Mapped BAM index file.

Genexus™ Software 6.2 User Guide
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Selection

File name

Description

RNA Unmapped Bam File
(.bam)

<barcode> rawlib.
basecaller.bam

Unmapped RNA BAM file; output of base calling,
contains unmapped reads.

RNA Mapped Bam File
(.bam)

<barcode> rawlib.
basecaller alignments
.bam

Mapped BAM file of combined barcode reads.

RNA Mapped Bam Index File
(.bai)

<barcode> rawlib.
basecaller alignments
.bam.bai

Mapped BAM index file.

RNA Basecaller FASTAQ File
(.fastq)

<barcode> rawlib.
basecaller.fastqg

FASTQ file generated from the unmapped BAM file
of the RNA barcodes used.

Test Fragment Basecaller
FASTAQ File (.fastq)

rawtf.basecaller.fastqg

FASTQ file for the test fragment.

Audit and Log

Analysis Log File

analysis.log

Analysis log file.

Run Summary

Info.csv

Contains information about the run and analysis,
including software version details, sample details,
library details, run details, assay details, reagent
and consumable information, run and sample QC
metrics, and instrument summary.

name> AD Lab Report
<assay name> <date>
.pdf

Run Audit PlannedRun-AuditTrail |Contains all audit records pertaining to the run.
.pdf

Reports

Lab Report <language> <sample A PDF report that contains sample-specific

results. For more information, see “Lab Report” on
page 85.

Upload sample results files to lon Reporter” Software

When a run completes successfully in Genexus' Software, and the results were not
automatically uploaded to lon Reporter™ Software, you can upload the sample
results (BAM files) to lon Reporter™ Software for further analysis.

You can also upload the samples to lon Reporter™ Software, then use a custom lon
Reporter™ Software analysis workflow to view analysis results. Or, you can upload
sample results files if you want to run assays that are not yet available on the
Genexus™ Software Integrated Sequencer.

Note: To automatically upload BAM files at the completion of a run, select the
Upload BAM files to lon Reporter™ Software checkbox in the Setup step of
planning a run.

90
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Before you can upload sample results files to lon Reporter™ Software, you must
configure your lon Reporter™ Software account.

To configure an lon Reporter™ Server account, see “Configure an lon Reporter™
Server account (administrator)” on page 129.

To configure an lon Reporter™ Software on Connect account, see “Configure
Thermo Fisher Accounts in Genexus™ Software (administrator)” on page 127.

In the menu bar, click Results » Run Results.

In the Run Results screen, in the Actions column, click Upload to IR in the row
of a run of interest.

In the Upload Samples to lon Reporter Software dialog box, make the
following selections.

a. From the lon Reporter™ Software Account list, select your lon Reporter™
Server account.

b. In the Assay column, select the appropriate assay from the list.

c. In the lon Reporter Workflow column, do one of the following:

* Select Upload Only to upload the sample results (BAM files) lon
Reporter™ Software. You will need to sign in to lon Reporter™ Software
to launch an analysis.

* Select an appropriate lon Reporter™ Software analysis workflow to
upload the sample results (BAM files) and automatically launch the
selected analysis workflow in lon Reporter™ Software. This results in an
analysis in lon Reporter™ Software.

d. Click Upload.

The sample results are uploaded to lon Reporter™ Software.
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Tag an lon If you configure Genexus™ Software for use with lon Reporter™ Software, you can
Reporl;erTM select an lon Reporter™ Software analysis workflow tTS transfer sample results files to
Software and launch an analysis automatically in lon Reporter ~ Software. To limit the number
analysis of analysis workflows that are listed as available in the Genexus™ Software, you can

workflow for

tag workflows for use with the lonReporterUploader plugin.

use with the

IonReporterUpI IMPORTANT! If you use the Tag for IRU option to tag analysis workflows for use

oader plugin

with the lonReporterUploader plugin, you must tag all analysis workflows that you
want to be available in Genexus™ Software. After you use the tag for the first time,

only analysis workflows that include the tag are visible.

1. Sign in to lon Reporter™ Software.

2. In the Workflows tab, click the row of the workflow of interest.

3. In the Details pane, click £ (Actions) » Tag for IRU.

Note: To remove a previously tagged workflow from the list of workflows that
are available for selection in the Genexus' Software, click £* Actions » Untag

from IRU.

The analysis workflows are available for selection when you perform one of the

following actions.

Action

Description

Plan a run

In the Setup step of run planning, select Upload
BAM files to lon Reporter™ Software, then select
an lon Reporter™ Software account and software
version.

In the Assays step, in the row of each assay, the
workflow that was tagged for use with the
lonReporterUploader plugin is available for
selection from the dropdown list in the lon
Reporter™ Workflow column.

Upload sample results files to
lon Reporter™ Software after
the sequencing run is
complete

In the Results / Run Results screen, in the
Actions column, click Upload to IR in the row of a
run.

In the Upload Samples to lon Reporter™
Software window, the workflow that was tagged
for use with the lonReporterUploader plugin is
available for selection from the dropdown list in
the lon Reporter™ Workflow column.
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Data files and flow

During a Genexus™ Integrated Sequencer run, raw data (DAT) files from the first flows
are available. The Genexus' Software starts processing the data, producing a 1.wells
file. Basecalling is performed on the 1.wells file data, producing an unmapped BAM
(uBAM) file. Subsequent analysis produces mapped reads (BAM) and variant calls
(VCF) files.

The following table shows the flow of data and typical file size generated as the
Genexus " Software processes data.

IMPORTANT! Data from approximately 200 sequencing runs can be
accommodated on the sequencer before disk space becomes a limiting factor and
data archiving is required. You can perform approximately 45-50 whole chip runs
without deleting any wells files on the system. For more information about data
archival of the analysis runs, see “Data management (administrator)” on page 141.
Note that the 1.wells file is not archived during the archival process.

Process File type File size

Sequencing!!l DAT 2TB
v

Signal Processing [? Wells 250 GB
v

Base Calls (reads) uBAM 15 GB
v

Mapped Reads BAM 15-20 GB
v

Variant Calls VCF 120 Kb

' The sequencing raw data (DAT) files are deleted from the sequencer after run completion.

2l A disk space cleanup process is executed nightly to free up space for future runs and to ensure a 2TB hard
disk space is maintained. If the system memory available for storing run analysis data reaches the 2TB
threshold, the system auto-deletes 1.wells files for the oldest completed runs. If the system approaches the
2TB threshold, an alert notifies you when you sign in. If desired, you can back up 1.wells files to an external
drive.
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About assays in Genexus Software

Find assays

94

Assays contain the settings and parameters for library preparation, templating,
controlling the sequencing run, and analyzing the results. Assays also define the
panels, kits, and chips that are used in a run, and specify the reference files and
threshold values for quality control and variant detection. Assays can be created from
system-installed templates or assays, or from custom assays that are copied and
edited.

An assay is a reusable experimental design that contains predefined settings
appropriate for use with common types of research applications. An assay can be
used to plan many runs and plays an important role in enabling rapid throughput
across the sequencing instrument. Assays help reduce the chance of errors, because
information is stored and then applied to runs instead of entered manually for each
run.

An assay can be copied and edited for a different use. Before you can create a
custom assay, you must add a panel file, and hotspot and copy number baseline files
(if needed for your assay), to the software. Custom assays are for advanced users.
For assistance, contact your local Field Service Engineer.

Assays can contain system-installed annotation sets, filter chains, copy number
baselines and report templates. You can also create custom versions of each of
these presets.

You can sort, search and filter information to narrow the list of assays shown in the
Assays / Manage Assays screen, then find a specific assay in Genexus™ Software.
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You can search for assays Genexus Software with keywords or text that are
included in an assays name.

IMPORTANT! Search terms must adhere to the following rules.

. An asterisk (*) is not allowed in the search field for use as a wildcard.

. Searches are case-insensitive, that is, both upper-case and lower-cases letters are
found regardless the case of search term letters.

. Searches find every occurrence of a continuous string. For example, a search for
demo in sample names returns a list of all samples with a name that includes
demo. For example, demo1, demo2, and so on.

. Spaces are removed during searches, and are therefore not recommended. For
example, a search for demo 1 would return results only for data that includes the
string demo1.

1. Click Assays » Manage Assays to open the Manage Assays screen.

2. In the Assay Name field, enter a full or partial assay name, then click
Q, (Search).

The list of assays is updated according to the search terms.

You can sort the list of assays in to make it easier to find assays in Genexus™
Software.

1. Click Assays » Manage Assays to open the Manage Assays screen.

2. Click a column heading in the list of assays.
If the column is sortable, the contents of the column is sorted alphabetically, or
chronologically.

3. Click the column heading again to reverse the order.

You can apply filters to the list of assays to narrow search results, or shorten the list
of assays to make easier to find assays in Genexus™ Software.

1. Click Assays » Manage Assays to open the Manage Assays screen.

2. Click the Filter Assays By dropdown menu, then apply the filters.

e Select Status to expand the list of options for status, then select a status:
— Locked & Draft

— Obsolete
— Locked
— Draft
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e Select Research Application to expand the list of options for research
application, then select the research application that is associated with the
assay:

- DNA
— Fusions
- RNA
— DNA and Fusions
e Select All to return to the complete list of assays.

The list of assays is filtered according to the selections.

Remove filters You can remove filters from the list of assays to go back to previous search results or
to return to the complete list of assays.

1. Click Assays » Manage Assays to open the Manage Assays screen.

2. Remove one or both of the filters applied to the list of assays.

* In Assay Name search field, click )X (Remove) to remove the contents of
the field.

* Select All in the field that is used to filter assays by Status or Research
Application.

The list of assays is filtered according to the selections.

Assay creation overview

Manager- and administrator-level users can create custom assays if system-installed
assays do not meet needs.

To create a custom assay in Genexus'~ Software:

e Copy an existing system-installed assay or a custom assay, then edit its settings
to create a new custom assay. For more information, see “Copy an assay
(manager/administrator)” on page 98.

e Use a template to create a custom assay that contains unique settings. The
template includes settings for common genetic research analysis applications.
You can copy an existing custom assay only if it is locked. For more information,
see “Create an assay (manager/administrator)” on page 97 and “Lock a draft
assay (manager/administrator)” on page 124.

96 Genexus™ Software 6.2 User Guide



Create an
assay
(manager/admi
nistrator)

re
S
X7

A

Chapter 7 Create and manage assays (manager/administrator)
Assay creation overview

Manager- and administrator-level users can create a new assay using a system-
installed template in Genexus™ Software. Each template allows you to select kits,
chips, primer panels, and adjustable Quality Control (QC) thresholds and other
parameters that are appropriate for the assay type. The assay is then available to
select when you plan a run. The assay generates BAM files during the sequencing

run.

IMPORTANT! Use the default settings for system-installed assays unless you are an
advanced user. Contact your Field Bioinformatics Specialist (FSB) for assistance.

IMPORTANT! For an assay to be used in run planning, it must first be locked.

3.

In the menu bar, click Assays » Create Assay.

In the Create Assay screen, click the assay type for the template that provides
the appropriate kits, chips, primer panels, and adjustable QC thresholds and
read mapping parameters.

Assay type Description
Generic Use this template to create a generic sequencing assay with
Sequencing no application-specific post-run analysis. The assay
Application generates BAM files.
DNA Germline Use this template to create an assay that detects and

annotates germline variants in DNA samples.

DNA and Fusions Use this template to create an assay that detects and
annotates somatic DNA variants and RNA fusion targets in a
sample.

DNA Somatic Use this template to create an assay that detects and
annotates somatic variants in DNA samples.

Fusions Use this template to create an assay that detects and
analyzes variants in fusion samples.

In the Panel step, select a panel and other options for the assay. For
descriptions of the panel information appropriate for your assay, see “Panel step
assay options” on page 99.

IMPORTANT! You must add an integer value greater than zero for Minimum
Read Count Per Sample. The remaining options are appropriately populated
based on the selected panel.

Click Next.

In the Reagent step, select the kits and chips that you are using. Ensure that the
reagents are appropriate for the primer panel that you are using, then click Next.

For descriptions of the reagent information appropriate for your assay, see
“Reagent step assay options” on page 101.
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6. Inthe QC step, enter QC metric values, then click Next.

For descriptions of the QC information appropriate for your assay, see “QC step
assay options” on page 102.

7. In the Parameters step, accept the recommended default values, or adjust the
values within the allowed ranges, then click Next.
Optionally, you can set these parameters by uploading an advanced parameters
configuration file that overrides the default settings. To create an advanced
parameters configuration file, at the top of the Parameters step, click
Download to download a ZIP file of the JSON template that is appropriate for
the assay, edit the file with your custom settings, then save the file to your drive.
Then, at the top of the Parameters step, click Upload, click Select file to
navigate to the file on your drive, then click Open to upload the file. The
parameters uploaded in this file override the default values in the template.
For more information about parameters, see “Parameters step assay options”
on page 105.

8. In the Plugins step, select one or more plugins to run with this assay, then click
Next.

For more information, see Chapter 9, “Plugins for data analysis”.

9. In the Save step, enter an assay name, an assay short name, and an optional
description, then click Save.
The new assay is listed in the Manage Assays screen. The Status column
indicates that the assay is in Draft status. The new assay is available to lock,
edit, or delete, and audit. You can also download parameters from assays in the
either the Draft or Locked status.

Copy an assay Manager- and administrator-level users can create a new assay by copying an
(manager/admi existing system-installed assay or other custom assay and modifying it if needed.
ni strator) Only locked assays can be copied.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, in the Actions column for the assay that you
want to copy, click Copy.
The Copy Assay screen opens to the Panel step. The assay settings can be
modified for the new assay.

3. Proceed through the workflow steps, and modify assay settings if needed.

4. When finished, enter a new name and short name for the copied assay in the
Assay Name field, then click Save.
The newly created assay is added to the list of assays in the Assays / Manage
Assays screen. The assay name is followed by (Draft) in the Assay column. The
assay remains in draft status until it is locked.

5. In the Actions column, in the row of the assay, click Lock to enable its use in a
run.
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Panel step assay options

Manager- and administrator-level users create assays for use in the Genexus™

Software.

In the Panel step, you can select the appropriate reference files to use in an assay.

Following is an alphabetical list of options that may be available in the Panel step,
depending on the type of assay.

IMPORTANT! Use the default settings for system-installed assays unless you are an
advanced user. Contact your Field Bioinformatics Specialist (FSB) for assistance.

Option

Description

Adjust Sample Copy Number by
Cellularity!'l only. It is available when a
Copy Number Baseline for CNV Calling is
selected.

The % cellularity that is the minimum value that the assay workflow
requires of a sample. The assay analysis adjusts all copy numbers
based on the % cellularity entered.

Select Do Not Adjust CN and Do Not Reject Samples if you choose to
not make the adjustment.

Annotation Sets

The annotation set to use in the assay.

Some annotation sets are system-installed. Custom annotation sets
can be created if the system-installed sets do not meet needs.

Apply Oncomine Variant Annotations

When you select the Apply Oncomine™ Variant Annotations option in
the Panel step to create or edit an assay, analysis results data from
more than 24,000 exomes across solid tumor and hematological
cancer types is used as a reference to annotate variants that are
relevant to cancer. The annotations are shown in results in the
Oncomine™ Gene class and Oncomine™ Variant class columns. For
more information, see “Annotation criteria for Oncomine™ Variant
Annotator” on page 172 or contact your local support representative,
Field Bioinformatics Specialist (FBS), or Clinical Account Consultant
(CAC).

This option is available only for assays that use lon AmpliSeq™ HD and
Oncomine™ panels.

Copy Number Baseline for CNV Calling

The software analyzes the CNV results based the selected baseline file.

The copy number baseline is a set of control samples that are used to
create a baseline for the detection of copy number variants (CNVs).You
can use system-installed baselines, import or create a baseline, or
copy and edit an existing baseline. You can view the settings that are
used for the baseline if you click on the baseline name in the
Assays/Manage Presets/Copy Number Baselines tab. For more
information, see “Copy number variant baselines (manager/
administrator)” on page 115.

Extraction Method Type

The method used to extract the DNA, RNA, or DNA and RNA from the
sample, or as a single library TNA from the sample.
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Option Description
Fusion Panel The tab-delimited BED file to use in the assay that defines the
coordinates of the regions of interest to be amplified with the selected
primer set.
Fusion Reference The tab-delimited BED file to use in the assay that indicates the

positions where an RNA fusion target is expected to occur. It also
annotates these positions.

Genome Reference The genome reference file to use in the assay. The hg19 genome
reference is installed with the system.

Hotspots The hotspots file to use in the assay. The hotspots file is a tab-
delimited BED file that indicates the positions where a DNA variant is
expected to occur. It also annotates these positions with the reference
allele, variant allele, and anchor base.

Library Chemistry The type of library chemistry to use in the assay.

Minimum Read Count Per Sample The minimum number of reads per sample that are needed to achieve
the coverage depth required in an assay.

This value, usually associated with the panel, determines the number of
samples that can be run on the lanes that are available on a chip. The
system uses this value to calculate how many lanes a run uses and
assigns samples accordingly. For example, a minimum read count per
sample of 1,000,000 allows twice as many samples on the same lane
as that of 2,000,000.

Panel The panel to use in the assay. The remaining options are appropriately
populated based on the selected panel.

The panel is a tab-delimited BED file that defines the coordinates of the
regions of interest to be amplified with the selected primer set.

Primer Pools The number of primer pools used in the assay.

Target Regions The target regions BED file that is appropriate for your sample.
Depending on your application, you may need to select a separate
DNA and Fusions Target Regions file.

Check with your local Field Service Engineer for updates to ensure that
the most current files are being used.

' This option is available for assays that use DNA and Fusions Panel
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Reagent step assay options

Manager- and administrator-level users create assays for use in Genexus'" Software.

In the Reagent step, you select the kits and chips to use in an assay. Ensure that the
kits and chips are appropriate for the primer panel that you are using.

Following is an alphabetical list of options that may be available in the Reagent step.
The available options depend on the type of assay.

IMPORTANT! Use the default settings for system-installed assays unless you are an
advanced user. Contact your Field Bioinformatics Specialist (FSB) for assistance.

Option Description
Library Kit The library kit that is used to prepare the library.
Barcode Kit The barcode kit to use in the assay.

Include Inline controls

Select RNA or DNA, or both RNA and DNA, depending on the assay
template that is used. For example, you might want to ensure that both
RNA and DNA are selected if you use the RNA/DNA template.

By default, only DNA is enabled and RNA is disabled. RNA is available
for selection only if the assay template includes it.

Sequencing Chip

The sequencing chip to use in the assay.

Sequencing Flows

The number of flows performed by the sequencer during the
sequencing stage of the run.

Sequencing Kit

The sequencing kit to use in the assay.

Templating Kit

The templating kit to use in the assay.

Template Size (bp)

The template size, measured in base pairs, to use in the assay.
e 200
* 400
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QC step assay options
Manager- and administrator-level users create assays for use in Genexus' Software.
You can specify Quality Control (QC) metric values to use in an assay in the QC step.

Following is an alphabetical list of options that may be available in the QC step. The
available options depend on the type of assay.

NTC QC - DNA
Option Description

Average Base Coverage Depth The average number of reads of all
targeted reference bases.

Mean Read Length 9bp) The average length, in base pairs, of called
reads.

NTC QC - RNA
Option Description

Mapped Reads Mapped Reads and Mean Read Length
can be configured in the QC step or in the
Parameters step in the Fusions section as
Minimum Total Valid Mapped Reads and
Minimum Mean Read Length for Valid
sample QC. The values configured in the
Parameters step overwrite those
configured in the QC step.

Mean Read Length (bp) The average length, in base pairs, of called
reads.

CF-1 Control
Option Description

Average Reads Per Lane The average number of reads per chip
lane.

Base Call Accuracy The percentage of the total number of
errors for all positions in CF-1/ total
number of CF-1 base reads.

Mean AQ20 Read Length (bp) The average length, in base pairs, at which
the accuracy rate is 299% for reads of a
library.
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Option

Description

Key Signal

The average signal after software
processing for all library ISPs that
identically match the library key (TCAG).
This value is a measure of the efficiency of
template amplification.

Percent Loading

The percentage of addressable wells on a
chip lane that are loaded with an ISP. The
percentage is derived from the number of
wells with ISPs divided by the number of

the total addressable wells in a run.

Raw Read Accuracy

The average raw accuracy across each
individual base position in a read, where
raw read accuracy is calculated as 100 * (1
- (sum(per base error)/sum(per base
depth))).

Sample QC - RNA

Option

Description

MAPD

MAPD (Median of the Absolute values of all
Pairwise Differences) is a quality metric
that estimates coverage variability between
adjacent amplicons in CNV analyses. A
MAPD value of 0.4 indicates an acceptable
level of coverage variability. High MAPD
value typically translates to a lower
coverage uniformity. Lower coverage
uniformity can result in missed or
erroneous CNV calls. If the MAPD QC
threshold is not met, CNVs do not get
called. The MAPD metric does not affect
SNVs/INDEL calls.

Mapped Reads

Mapped Reads and Mean Read Length
can be configured in the QC step or in the
Parameters step in the Fusions section as
Minimum Total Valid Mapped Reads and
Minimum Mean Read Length for Valid
sample QC. The values configured in the
Parameters step overwrite those
configured in the QC step.

Best practice to achieve consistent results
is to use the same values in both the QC
step and the Parameters step.
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Option

Description

Mean AQ20 Read Length (bp)

The average length, in base pairs, at which
the accuracy rate is 299% for reads of a
library.

Mean Read Length (bp)

The average length, in base pairs, of called
reads.

RNA Expression Ctrls Detected

The number of expression control genes
detected for the sample. This metric
measures the RNA input integrity, input
amount, and the fidelity of the reverse
transcriptase that was used in library
preparation. Fusion panels include primer
pairs that cover seven control
housekeeping genes. For Oncomine™
Precision Assay GX to pass QC, cfTNA
samples require 2 out of 7 control genes to
be detected and FFPE RNA samples
require 5 out of 7 control genes to be
detected.

Sample QC - DNA

Options

Description

Deamination score

Deamination is reported as the estimated
SNP proportion consistent with
deamination (low allele frequency C:G>T:A
SNVs). The deamination score can be used
to determine the quality of the FFPE
sample.

Mapped Reads

The number of reads aligned to the
reference.

Mean AQ20 Read Length (bp)

The average length, in base pairs, at which
the accuracy rate is 299% for reads of a
library.

Mean Read Length (bp)

The average length, in base pairs, of called
reads.

Mean Red Cov

Mean molecular coverage of targeted CNV
gene.

Median Mol Cov

Median molecular coverage of non-CNV
reference loci.
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Options Description

Number of variant calls The number of somatic variants that are
identified in the sample. This value is
reported in the statistic.txt file as Total
Somatic Filtered Variants Count (numerator
for TMB calculation) and Variant Count.

Uniformity of Base Coverage The percentage of reads showing a depth
of coverage >20% of the mean base
coverage.

Parameters step assay options

Manager- and administrator-level users create assays for use in Genexus'" Software.

IMPORTANT! Use the default parameter settings for assays unless you are an
advanced user. Contact your Field Bioinformatics Specialist (FSB) for assistance.

The available options depend on the type of assay. You can view the complete of
parameters when the All is selected. Or, you can select an option to filter the list:

¢ Library Prep & Templating Parameters
¢ Primary Analysis Parameters
¢ Read Mapping
¢ Annotation
— CNV Finding
- Fusions

Variant Finding

You can see a description of most parameters if you hover over (?) (Learn More)
next to a parameter.

In the Parameters step, you can accept the default settings for the assay
parameters, or adjust the settings if needed.

A filter chain is a set of filters that Genexus' Software uses to narrow the list of
variants that are included in results. There are two ways to use filter chains. You can
apply the filter chain to results to dynamically change the view of the variants, then
optionally save the filter chain to the results. See “Filter results using a filter chain” on
page 71.

Genexus'" Software includes predefined filter chains that you can apply to run
results. Most system-installed assays include default filter chains. For information
about system-installed filter chains, see “System-installed filter chains” on page 178.

Manager- and administrator-level users can create custom filter chains that are built
from system-installed filter chains, or from one or more system-installed filters. For
more information, see “Create a custom filter chain (manager/administrator)” on
page 106. The system-installed filters are based on public and proprietary annotation
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sources and data types that are included in the software. For more information, see
“System-installed filters” on page 178.

Review filter chain details

A filter chain is a set of filters that Genexus™ Software uses to narrow the list of
variants that are included in results. Administrator-level users create custom filter
chains from system-installed filters to meet specific variant filtering needs.

After a run, you can review the details of the filter chains that were applied to the run.
If the filter chain does not meet your needs, you can adjust the settings or apply a
different filter chain.

1. In the menu bar, click Assays » Manage Presets.
2. In the Manage Presets screen, click the Filter Chains tab.
3. Click a filter chain.

Review the following details:
¢ Version of the analysis pipeline used for the filter chain
¢ Whether the filter chain is system-installed
¢ The date that the filter chain was created
¢ The filters that are included in the filter chain
¢ The order in which the filters and/or filter chains contained within are applied

Create a custom filter chain (manager/administrator)

Manager- and administrator-level users can create and manage filter chains. A filter
chain is a set of filters that you apply to the variants identified in your results. Filter
chains are used to narrow the analysis results to only those variants of interest.

1. In the menu bar, click Assays » Manage Presets.

2. In the Manage Presets screen, in the Filter Chains tab, click + Add New.
3. In the Create Filter Chains dialog box, enter a name for the new filter chain.
4. (Optional) Add a description for the filter chain.

5. From the Choose Filter list, select the filter that you want to use, then click Set.

The selected filters are shown on the right side of the window. If the list does not
populate with the filters available in the software, you may need to reboot the
sequencet.

6. Click Save.

A confirmation message appears, and the new filter chain is listed in the Filter
Chains tab and is available for selection when you view results. For more
information, see “Filter results using a filter chain” on page 71.
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Custom filter chain examples (manager/administrator)

Manager- and administrator-level users can create custom filter chains for use in
Genexus™ Software.

Create a filter chain query (manager/administrator)

Manager- and administrator-level users can create custom filter chains that combine
filters and specify the order in which the filters are applied. The modifiers are AND
and OR, and brackets () are used to set the order. The modifiers AND and OR must
be in all caps.

IMPORTANT! If using a single filter with a NOT operator, do not use a parenthesis. If
parenthesis is used, the filter chain can be saved but an error occurs when applying
the filter chain in analyses results. For example, use NOT Filtered Coverage instead
of NOT (Filtered Coverage).

—

In the menu bar, click Assays » Manage Presets.
2. In the Manage Presets screen, click the Filter Chains tab.
3. Click + Add New.

4. Inthe Create Filter Chains dialog box, enter a name and optional description,
then in the Choose Filter list, add the filters to create a chain.

To include unannotated variants in the results, select Include Unannotated
Variants for each filter selection.

a. Select Deamination, set its value to In, then click Set.

The filter name appears on the right side of the Create Filter Chain dialog
box.

b. Select a dbsnp filter, set its value to In, then click Set.

The second filter name appears on the right side of the Selected Filter
Chains list.

c. Select COSMIC(85), set its value to In, then click Set.
The third filter name appears on the right side of the Create Filter Chain
dialog box.

5. (Optional) If you want change the order in which your filters are applied, click
il Delete to remove a filter, then reselect the filter and click Set to reinsert the
filter in the Selected Filter Chains list.

6. Click Save.

A confirmation message appears, and the new filter chain is listed in the Filter
Chains tab and is available for selection when you view results. For more
information, see “Filter results using a filter chain” on page 71.
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Create a COSMIC ClinVar and Variant Impact filter chain
(manager/administrator)

Manager- and administrator-level users can create a custom filter chain that includes
both annotation source filters and variant data type filters. This procedure shows how
to create a COSMIC, ClinVar, Allele Fraction, and Variant Effect filter chain.

IMPORTANT! If using a single filter with a NOT operator, do not use a parenthesis. If
parenthesis is used, the filter chain can be saved but an error occurs when applying
the filter chain in analyses results. For example, use NOT Filtered Coverage instead
of NOT (Filtered Coverage).

—

In the menu bar, click Assays » Manage Presets.

2. In the Manage Presets screen, click the Filter Chains tab.

3. Click + Add New.

4. In the Create Filter Chain dialog box, enter a name and optional description.

5. Select the filters to add to the filter chain.

To include unannotated variants in the results, select Include Unannotated
Variants for each filter selection.

a. In the Choose Filter list, choose a version of the COSMIC filter.
b. Select the annotations that you want to include in the filter.

c. Click Set.

d. In the Choose Filter list, select a version of clinvar.

e. Select the annotations that you want to include in the filter.

f. Click Set.

g. In the Choose Filter list, select Allele Fraction.

h. Enter a range value, then click Set.

i. Inthe Choose Filter list, select Variant Effect.

j- Select the value that you want to include in the filter to detect the effect of
variants on coding sequences.

k. Click Set.
6. Click Save.
Your filter chain can now be applied to results. For more information, see “Filter

results using a filter chain” on page 71.
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Create a PValue/dbSNP/Variant Type filter chain
(manager/administrator)

Manager- and administrator-level users can create a custom filter chain with multiple
filters. This example shows how to create a filter chain with PValue, dbSNP, and
Variant Effect filters.

IMPORTANT! If using a single filter with a NOT operator, do not use a parenthesis. If
parenthesis is used, the filter chain can be saved but an error occurs when applying
the filter chain in analyses results. For example, use NOT Filtered Coverage instead
of NOT (Filtered Coverage).

1. In the menu bar, click Assays » Manage Presets.
2. In the Manage Presets screen, click the Filter Chains tab.
3. Click + Add New.

4. Inthe Create Filter Chain dialog box, enter a name and optional description.

To include unannotated variants in the results, select Include Unannotated
Variants for each filter selection.

a. Select the PValue filter.
b. Enter arange
c. Click Set.

5. In the Choose Filter list, select a version of dbSNP.
a. Set Filter value to In.

b. Click Set.

6. In the Choose Filter list, select Variant Effect.

a. Select the value that you want to include in the filter to detect the effect of
variants on coding sequences.

b. Click Set.
7. Click Save.

Your filter chain can now be applied to results. For more information, see “Filter
results using a filter chain” on page 71.
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Delete a custom filter chain

Manager- and administrator-level users can make filter chains unavailable in the
software. You cannot designate as obsolete system-installed filter chains.

1. Click Assays » Manage Presets » .

2. In the Filter Chains tab, click Obsolete for the filter chain that you want to make
unavailable.

The filter chain status is Obsolete. The filter chain is removed from the Filter Chains
table.

Create a gene symbol filter (manager/administrator)

Manager- and administrator-level users can create a custom filter that is based on
gene symbols. This filter can be added to a filter chain that narrows analysis results
to only specific genes. If you have numerous gene symbols to filter, you can use a
text file to create the gene symbol filter chain. For more information, see “Gene
Symbol filter” on page 182.

IMPORTANT! If using a single filter with a NOT operator, do not use a parenthesis. If
parenthesis is used, the filter chain can be saved but an error occurs when applying
the filter chain in analyses results. For example, use NOT Filtered Coverage instead
of NOT (Filtered Coverage).

—

In the menu bar, click Assays » Manage Presets.
2. In the Manage Presets screen, click the Filter Chains tab.
3. Click + Add New.

4. In the Create Filter Chain dialog box, enter a name and optional description,
then in the Choose Filter list, choose the Gene Symbol filter.

5. Add genes of interest to the filter chain. Select a checkbox for the gene symbol
of the gene in the list that you want to add.

To find a gene symbol in the list, enter the gene symbol into the search field,
then click Q (Search).

6. After you select all of the gene symbols that you want to include, click Set.
Your genes appear in the Selected Filter Chains list.

7. Click Save.

Your filter chain can now be added to an assay, or applied to results. For more
information, see “Filter results using a filter chain” on page 71.
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Manager- and administrator-level users use the tools for creating and managing
annotation sets that are available in the Assays / Manage Presets screen in the
Annotation Sets tab.

View annotation set details

You can view details about an annotation set in Genexus" Software.

1. Click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, in the Annotation Sets tab, click the
annotation set name.

The following details for the selected annotation set are shown.

Annotation Set Details

Item Description

Application Version The analysis pipeline version that is used
by the annotation set.

Last Modified By For custom annotation sets, the sign-in
name of the person who created or
modified a custom annotation set.

Annotation sets that are included with the
software are labeled as System Installed.

Last Modified On Date on which a custom annotation set
was last modified.

Created By Sign-in name of the person who created a
custom annotation set.

Created On Date on which a custom annotation set
was created.

Status Statuses of the assay, including:
e Locked
e Draft

e Obsolete

Reference hg19

Annotations A list of the annotations included in the
annotation, and the version of each
annotation.
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Create a new annotation set (manager/administrator)

Manager- and administrator-level users can create custom annotation sets in
Genexus™ Software. The custom annotation sets are available as an option when you
create or copy an assay.

1. Click Assays » Manage Presets.
2. In the Manage Presets screen, in the Annotation Sets tab, click + Add New.

3. In the Create Annotation Set screen, enter a name for the set in Name, and an
optional description in Description.

4. Click the value in Application Version to accept the default version of lon
Reporter™ Software, or select the software version that is installed in your lab.
The Application Version field is highlighted and a checkmark is shown for the
selected software version.

5. In Genome Reference, the default setting for the sample is hg19.
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In the Available Annotation Sources dropdown list, select the annotation

Source

Description

5000
Exomes

Population frequency information from the 5000 Exomes project.
Source: https://evs.gs.washington.edu/EVS/

ClinVar

An assessment of impact of the variants observed from NCBI ClinVar
database.

Source: http://www.ncbi.nlm.nih.gov/clinvar

COSMIC

A catalog of known somatic mutations in cancer.
Source: https://cancer.sanger.ac.uk/cosmic

dbSNP

A database of genomic variants.
Source: http://www.ncbi.nim.nih.gov/projects/SNP

DGV

A curated database of human genomic structural variation.
Source: http://dgv.tcag.ca/dgv/app/home

DRA

Disease Research Area; a hierarchically organized database of
disease categories.

DrugBank

A database from which names of therapies that are used for
researching variants are collated.

Source: https://www.drugbank.ca

ExAC

Exome Aggregation Consortium — A database catalog of variant
frequencies.

Source: https://gnomad.broadinstitute.org

Gene Model

A set of genes that the variant overlaps.
Sources: https://www.ncbi.nim.nih.gov/refseq and
http://www.ensembl.org

Gene
Ontology

Standardized ontology for gene and gene projects (for example,
functional role or localization).

Source: http://geneontology.org

Gene Set
(Custom)

Select this option to import a TXT file that contains a custom set of
variants in a specific set of genes.

Genomic
Regions
(Custom)

Select this option to import TXT file that contains a custom set of
variants in specific gene regions.

OMIM

Online Mendelian Inheritance of Man.
Source: https://www.ncbi.nim.nih.gov/omim

Pfam

A database of protein families that includes their annotations and
multiple sequence alignments using hidden Markov models.

Source: http://pfam.xfam.org

PhyloP
Scores

A measure of conservation of the protein across a wide range of
organisms.

Source: http://compgen.cshl.edu/phast
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Source Description

SIFT / A prediction of the functional effect of a variant on a protein.
PolyPhen | Sources: https://sift.bii.a-star.edu.sg and
http://genetics.bwh.harvard.edu/pph2 and

Transcript Select this option to import a TXT file that contains a custom set of
Set transcript annotations.
(Custom)

Variant DB | Select this option to import a TXT file that contains custom set of
(Custom) variant annotations.

The annotation sources that you select are listed in the Available Annotation
Sources list.

7. Add annotation sources to the annotation set.

Options Description
Use an existing Select the checkbox next to each annotation source in
source Available Annotation Sources list that you want to include in

the annotation set.

Imptort anew i Click + Add New Source below the list, enter a name and
_CUS om 39‘”?9 '® | version for the source, browse to and select the source file,
in a TXT file [1]

then click Upload.
The new sources are added to Available Annotation Sources
list.

' You must have selected one of the following Available Annotation Sources:Gene Set (Custom),
Genomic Regions (Custom), Transcript Set (Custom), VariantDB (Custom).

8. After all of the annotation sources that you want to add to the annotation set are
selected in the Available Annotation Sources list, click Add > to move the
annotation sources to the Selected Annotation Sources list.

9. Review the list of selected annotation sources, then add or remove sources, if
needed. To remove a source from the Selected Annotation Sources list, select
the checkbox, then click Remove X.

10. Click Save to save the annotation set.

The annotation set is listed in the Annotation Sets tab and is available when you
create an assay.

114 Genexus™ Software 6.2 User Guide


https://sift.bii.a-star.edu.sg
http://genetics.bwh.harvard.edu/pph2

Copy number
variant
baselines
(manager/
administrator)

Chapter 7 Create and manage assays (manager/administrator) E=738
Assay creation overview

Make custom annotation sets unavailable

Manager- and administrator-level users can make custom annotation sets unavailable
in the software.

You cannot designate as obsolete system-installed annotation sets.

1. In the menu bar, click Assays » Manage Presets.

2. In the Annotation Sets tab, in the Actions column, click Obsolete for the
custom annotation set that you want to make unavailable.

The annotation set status is Obsolete in the list of annotation sets

A copy number baseline is a set of control samples that are used to create a baseline
for the detection of copy number variants (CNVs). A copy number baseline is
associated with a panel file in the software. CNV analysis is based on reads counts
for each amplicon. Read counts for the sample in question are compared to the
expected read counts for the amplicons in a normal sample, which are designated in
the copy number baseline. The calculations used to determine the CNV call are
based on the parameters set in the copy number baseline.

Known sources of variability include pool imbalance (when an assay has more than
one pool of amplicons), total number of reads, per-amplicon attributes of GC
proportion, and length of the amplicon insert. In practice, we observe other variability
that does not associate with known attributes yet is systematic. The software makes
adjustments to account for specific types of variability in the analysis that generates
a copy number estimate. The method that is used by the software to identify copy
number variations is based on many diverse samples, captures systematic effects,
and encodes the samples into a file that comprises the baseline for the panel.

Copy number estimates are made using a proprietary algorithm. The algorithm uses
an informatics baseline, which is created using at least 48 diverse samples, to allow
assessment of corrected log2ratios of amplicons of identified CNV regions (usually
genes) in input sample data. This algorithm is followed by a correction algorithm for
the percent tumor cellularity recorded for the sample to give copy number and
confidence interval data for the identified CNV regions. The algorithms used to
calculate the corrected log2 ratios and the correction for tumor fraction are
proprietary.
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Manager- and administrator-level users can perform the following functions related to
copy number baselines.

. See the following section for more
Option . .
information

View details for system-installed, or “View copy number baseline details

custom, copy number baselines. (manager/administrator)” on page 116

View the panel associated with a copy “Panel files (manager/administrator)” on

number baseline. page 145

Create a copy number baseline. “Create a copy number baseline (manager/
administrator)” on page 117

Edit a copy number baseline. “Edit a copy number baseline (manager/
administrator)” on page 118

Import a copy number baseline. “Import a copy number baseline (manager/
administrator)” on page 120

Remove copy number baselines that are “Remove a copy number baseline

not system-installed. (manager/administrator)” on page 120

View copy number baseline details (manager/administrator)

Manager- and administrator-lever users can view details for the system-installed
copy number baselines, or for custom copy number baselines.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Copy Number Baselines
tab.
The Copy Number Baselines table lists both system-installed and custom copy
number baselines.

3. Click the name of a copy number baseline.

Review the details in the Copy Number Baseline Details dialog box.

Copy Number Baseline Details

ltem Description

Created By Sign-in name of the person who created
the baseline. System-installed baselines
are included with the software.

Created On Date on which the baseline was created.

Number of Normal Samples The number of normal samples that are
included in the baseline.

Gender The biological sex of the sample: Female,
Male, or Unknown.
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ltem Description
Amplification Type Library amplification technology that is
used in the baseline (Ampliseq or Ampliseq
HD).
Panel Name Name of the panel that is included in the
baseline.
Reference File Name The name of the genome reference file that

is used in the baseline.

Number Amplicons per Bin for GC A threshold set for the baseline. This
normalization threshold should not be more than about
10% of the number of amplicons in the
target regions file.

Number PC for correction The number of principal components to
use for correction

Similarity Threshold Maximum similarity threshold allowed for
any two samples used for creating the
copy number baseline.

Number Amplicons per Bin for Amplicon | A threshold set for the baseline. This
Length normalization threshold should not be more than about
10% of the number of amplicons in the
target regions file.

Create a copy number baseline (manager/administrator)

Manager- and administrator-level users can create a copy number baseline.

IMPORTANT! Use the default parameter settings unless you are an advanced user.
Contact your Field Bioinformatics Specialist (FBS) for assistance.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Copy Number Baselines
tab.

3. Click + Add New.
The baseline creation tool opens in the Panel step.

Use the Next and Previous buttons to navigate the screens to configure the
baseline.

4. Complete the Panel step.
a. Enter a name in the Copy Number Baseline Name field.
The name is limited to 50 characters and no spaces are allowed.

b. Select a Panel to use.
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c. Enter information about the baseline into the Notes field.
d. Click Next.

5. In the Set Parameters step, accept the default settings or adjust the
appropriate parameters, then click Next.

6. In the Select Samples step, select samples for the baseline.
All of the samples that have been run with the selected panel are listed.

If you do not select the minimum number of samples that are required for the
baseline, an error message opens and you cannot proceed. You can adjust the
Minimum number of samples required to add to an existing baseline
parameter in the CNV Baseline Creation section of the Parameters step.

a. Select the checkbox next to each sample to use for the baseline.

b. Click § inthe Normal Sample column to designate a selected sample as
“Normal" in the baseline.

The tube icon changes to green. A Normal Sample is designated with [ .
c. Click Next.

7. In the Review Selected Samples step, review the selections, then click Save.
The new copy number baseline with a status of Draft is added to the Copy
Number Baselines tab.

8. Click Lock in the Actions column to lock the copy number baseline.

New copy number baselines that are locked are available for selection when an assay
is created or copied and edited. Copy number baselines can only be added to DNA
and Fusions, DNA Somatic and DNA Germline assays.

Note: If the status of a copy number baseline is Failed, click View Log in the
Actions column of the table of copy number baselines.

Edit a copy number baseline (manager/administrator)

Manager and administrator users edit an existing copy number baseline by adding or
removing samples in the baseline or by changing the parameters used for analysis.
Edited copy number baselines are saved with a new name and are listed as a new
copy number baseline; the original copy number baseline used as a base remains
unchanged in the software.

When a baseline is augmented with the addition of samples, new samples are run,
the size of each systematic affect encoded in the baseline is estimated, and a
correction is applied to remove the effect. Any added samples can not be designated
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as a Normal Sample and should be diverse so as to capture likely systematic
variation.

IMPORTANT! Use the default parameter settings unless you are an advanced user.
Contact your Field Bioinformatics Specialist (FBS) for assistance.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Copy Number Baselines
tab.

3. Click + Add New.
The baseline creation tool opens in the Panel step.

Use the Next and Previous buttons to navigate the screens to configure the
baseline.

4. Complete the Panel step.
a. Enter a name in the Copy Number Baseline Name field.
The name is limited to 50 characters and no spaces are allowed.

b. Select a Panel to use.

c. Select the Use an Existing Copy Number Baseline as Base checkbox,
then select the baseline you would like to edit or augment.

d. Enter information about the baseline into the Notes field.
e. Click Next.

5. In the Set Parameters step, accept the default settings or adjust the
appropriate parameters, then click Next.

6. Inthe Select Samples step, select samples for the baseline.
All of the samples that have been run with the selected panel are listed.

If you do not select the minimum number of samples that are required for the
baseline, an error message is displayed and you cannot proceed. You can adjust
the Minimum number of samples required to add to an existing baseline
parameter in the CNV Baseline Creation section of the Parameters step.

a. Select the checkbox next to each sample to use for the baseline.
b. Click Next.
7. Inthe Review Selected Samples step, review the selections, then click Save.
The new, edited copy number baseline with a status of Draft is added to the

Copy Number Baselines tab.

8. Click Lock in the Actions column to lock the copy number baseline.

Genexus™ Software 6.2 User Guide 119



0

#5908  Chapter 7 Create and manage assays (manager/administrator)
Assay creation overview

Copy number baselines that are locked are available for selection when an assay is
created or copied and edited. Copy number baselines can only be added to DNA
and Fusions, DNA Somatic and DNA Germline assays.

Note: If the status of a copy number baseline is Failed, click View Log in the
Actions column of the table of copy number baselines.
Import a copy number baseline (manager/administrator)

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Copy Number Baselines
tab.

3. Click Import Copy Number Baseline in the top right of the screen, then
browse for and select the file.
A message confirms that the file import was successful when the file import is
complete.

4. Click Lock in the Actions column to lock the copy number baseline.

Imported copy number baselines that are locked are available for selection when an
assay is created or copied and edited. Copy number baselines can only be added to
DNA and Fusions, DNA Somatic and DNA Germline assays.

Remove a copy number baseline (manager/administrator)

Manager- and administrator-level users can make copy number baselines unavailable
in the software. You cannot designate as obsolete system-installed copy number
baselines.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Copy Number Baselines
tab.

3. In the Copy Number Baselines tab, click Obsolete for the copy number
baseline that you want to make unavailable.

The copy number baseline is Obsolete in the list of copy number baselines.
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Report Manager- and administrator-level users create and manage custom report templates
templates that are used to generate PDF reports after a run. Users select a report template
(manager/adml when they plan a run.

nistrator)

Create a report template (manager/administrator)

Manager- and administrator-level users create custom report templates that are used
to generate PDF reports after a run.

IMPORTANT! For a report template to be used in a run, it must first be locked.

1. In the menu bar, click Assays » Manage Presets.

2. In the Manage Presets screen, click the Report Templates tab.
Existing report templates are listed in this tab, including any system-installed
templates.

3. Click + Add New.

4. Inthe Create Report Template screen, enter a unigue report name, then
complete the remaining sections.
a. In the Lab Information section, enter the laboratory information to display
on reports.

b. In the Sample Details section, drag and drop the sample attributes that
you want to appear in the report into one of the three column placeholders.
You can also drag and drop the additional attributes below the columns into
the columns. Select up to two checkboxes next to an attribute to include
the attribute in the report header on each page.

c. Complete the remaining sections, then click Save.
The new report template appears in the Report Templates list.

5. To preview the report layout, in the Actions column, click : (More Options),
then click Preview in the row of the new template. Click Edit to make changes.

6. When you are finished, click Lock.
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Manage report templates (manager/administrator)

Manager- and administrator-level users use the tools in the
Assays / Manage Presets screen under the Report Templates tab to manage
report templates.

1. In the menu bar, click Assays » Manage Presets

2. In the Manage Presets screen, click the Report Templates tab.

* To lock a report template, click Lock.

* To preview the template layout, in the Actions column, click
. (More Options), then click Preview.
* To make a template unavailable in the software, in the Actions column, click
Obsolete.

* To add or view a note attached to a report template, in the Actions column,
click (More Options), then click Notes.

Manage assays (manager/administrator)

Import an
assay
(manager/admi
nistrator)

Export a
locked assay
(manager/admi
nistrator)
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Manager- and administrator-level users manage assays for use in Genexus™
Software.

A manager- or administrator-level user can import an assay from another Genexus '
Integrated Sequencer if the assay has been first exported to a local drive.

1. In the menu bar, click Assays » Manage Assays.
2. In the Manage Assays screen, click Import Assay.

3. In the Import Assay dialog box, click Select Assay file, navigate to the
exported assay ZIP folder on your drive, then select it.

4. Navigate to the exported assay ZIP folder on your drive, select it, then click
Upload.

The assay appears in the list of assays in the Assays » Manage Assays screen.

An assay can be exported, for example if you want to use that assay in another
Genexus " Integrated Sequencer in your lab. Only locked assays can be exported.

1. In the menu bar, click Assays » Manage Assays.

2. In the Assays » Manage Assays screen, in the row of a locked assay, in the
Actions column, click Export.

The assay parameter files are downloaded to your local drive as a ZIP file and are
available for import to another sequencer.
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Panel reference files are not included in the exported file.

Review and You can review, export, or print the entire history of changes for an assay. The history
export an shows the original values and any new values or activities.

assay history . This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
(r_nanager/adml establishes the United States Food and Drug Administration regulations on electronic
nistrator) records and signatures, password policies, and user activity auditing.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, in the row of an assay, Actions column, click
Audit .
The Audit Details screen opens with time-stamped audit records that include
assay details and changes for each action performed on the assay.

3. (Optional) Review the audit record.

Details in the audit record

Item Description

User name The name of the person who was signed
in when the action was performed.

Action Performed Actions performed on the assay include:
Create, Edit, Delete, and Obsolete.

Assay Name The name of the assay.

Time Stamp The time and date of the action.

Data Object Name The data object that is affected by the
action.

ID An identifier to represent a specific

action in the audit record. Each action in
the audit record includes a unique
identifier.

New Values A list of all values in the assay. If a value
changed as a result of the action, the
new value is shown. If no change was
made, the value is listed as NA. For
example, Plan Executed Status=false
indicates a change; Template Kit
Barcode=NA indicates that the value did
not change.

Old Values A list of the previous values in the assay.
Values are listed for each change. For
example, State = Draft indicates that a
change was made to the state of the
assay. The new value is listed in the New
Values section.
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4. (Optional) Click [} Download to download a print-ready PDF file of the audit
record.

You can open the PDF file in an appropriate viewer, then print the record from
within the open document.

5. Click Back to return to the Manage Assays screen.

When a manager- and administrator-level user first creates an assay, the assay name
is followed by (Draft) in the Assay column. While the assay is in draft status, it can
be edited. A locked assay cannot be edited.

IMPORTANT! Use the default parameter settings for assays unless you are an
advanced user. Contact your Field Bioinformatics Specialist (FSB) for assistance.

1. In the row of a draft assay, in the Actions column, click Edit.
The Create Assay workflow reopens.

2. Edit the options on each assay step as desired, then click Save.

The assay remains a draft until you lock the assay. For more information, see “Lock a
draft assay (manager/administrator)” on page 124.

When a manager or administrator first creates an assay, the status of the assay is
Draft. To use the assay in a run, you must lock it. After an assay is locked, it cannot
be edited or deleted.

1. In the menu bar, click Assays » Manage Assays to open the Manage Assays
screen.
A draft assay has (Draft) next to the name.

2. In the row of a draft assay, in the Actions column, for an assay with a status of
Draft, click Lock.

The assay is now locked and can be used in a run. (Draft) is removed from the assay
name in the Assays » Manage Assays screen.

When an assay is in draft status, it can be deleted from the software. Only draft
assays can be deleted. Draft assays are indicated by (Draft) next to the assay name.

1. In the row of a draft assay, in the Actions column, click Delete.
2. In the Delete Assay dialog box, click Yes to confirm the deletion.

The draft assay is removed from the software and is no longer available in the
Assays / Manage Assays screen.
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A manager-or administrator-level user can remove a locked assay from use in the
software by designating it obsolete. The assay is not deleted and a record of it is
maintained in the audit trail. The results for any runs already performed with the
assay remain on the sequencer.

1.

2.

In the menu bar, click Assays » Manage Assays.

In the Assays / Manage Assays screen, in the row of a locked assay, in the
Actions column, click Obsolete.

Click Yes to confirm the operation.
The assay is no longer available for use in a sequencing run.

An assay can be exported, for example if you want to use that assay in another
Genexus ' Integrated Sequencer in your lab. Only locked assays can be exported.

Panel reference files are not included in the export.

. In the menu bar, click Assays » Manage Assays.

In the Manage Assays screen, in the row of a locked assay, in the Actions
column, click --- (More Options).

Click Download Parameters.
The assay parameter files are downloaded to your local drive as a ZIP file of
JSON files and are available for import to another sequencer.
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Manager-level users use tools in the (3 (Settings) menu to:
¢ Create and manage user email settings, and audit these settings.

¢ Create and link user accounts for to get software updates from the Connect App
Store, use lon Reporter™ Software.

¢ (Create and manage account settings, and audit these accounts.

¢ View system information and settings.

Administrator-level users use tools in the 3 (Settings) menu to:
* View and export audit records.

¢ Configure user email settings, set up laboratory information, and audit these
settings.

¢ (Create and link user accounts for to get software updates from the Connect App
Store, use lon Reporter™ Software.

¢ (Create and manage account settings, and audit these accounts.
¢ Manage software updates.

¢ Manage data archive settings and disk space usage.

¢ Manage log files.

¢ Manage services for servers, services, and active jobs.

¢ Create and manage user accounts.
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Accounts for use with Connect and lon Reporter Software

(administrator)

Configure
Thermo Fisher
Accounts in
Genexus™
Software
(administrator)

Administrator-level users can configure Genexus " Software to link to one or more
Connect user accounts and lon Reporter™ Software accounts.

Active Thermo Fisher Connect accounts can perform the following tasks in the
Genexus™ Software:

* Download the latest software updates

¢ Download additional plugin software

* Download assay configuration packages

* Download software configuration packages
Users who have an active lon Reporter”™ Softwareand an account that is linked to
Genexus " Software can upload samples results to lon Reporter™ Software, and then
use the software to further analyze those results, add annotations and create reports.

Genexus™ Software can be linked to either accounts on an lon Reporter™ Server, or
lon Reporter™ Software on Connect accounts.

Administrator-level users can configure a link in Genexus™ Software to one or more
Connect user accounts. This account type is called a Thermo Fisher Connect
account in Genexus™ Software.

When a Thermo Fisher Connect account is configured and active, administrator-
level users can perform the following tasks in the Genexus " Software:

* Download the latest software updates

¢ Download additional plugin software

¢ Download assay configuration packages

* Download software configuration packages

Before you configure a Thermo Fisher Connect account you must have a valid
Connect account on the thermofisher.com website.

1. Click ¢ (Settings) » Thermo Fisher Account.
2. In the Thermo Fisher Account Settings screen, click + Create Account.

3. In the Create Thermo Fisher Account dialog box, enter the information that is
required to create the account.

Item Description
Account Type Select Thermo Fisher Connect.
Name Enter a name to identify the account in the Thermo Fisher

Account Settings screen in Genexus™ Software.

The name can contain only alphanumeric characters (0-9,
Aa-Zz), periods (.), underscores (_), or hyphens (-). For
example, enter Lab_Admin.
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Item Description

User Name The username is the email that you used to register for the
Connect account.

Password Enter the password for the lon Reporter™ Software on
Connect account.

The configured account is listed in the {0} (Settings) / Thermo Fisher Account
screen. A successfully authenticated account has Active listed in the Status column.

When the Thermo Fisher Account is active, software updates from the Connect App
Store are automatically uploaded to the Genexus™ Software and administrator-level
users can download the updates. For more information, see “Software updates” on
page 138.

An administrator-level user can configure a link to an lon Reporter ™ Software on
Connect account in Genexus™ Software.

lon Reporter™ Software on Connect, the cloud-based platform, is available at https://
ionreporter.thermofisher.com.

When the link is configured, you can upload sample results files from Genexus"
Software directly to the lon Reporter™ Software on Connect and use lon Reporter™
Software for further data analysis, annotation and reporting. Unmapped BAM files for
the sample results are uploaded.

Access to lon Reporter™ Software on Connect is controlled by your
thermofisher.com user name and password. Before you configure the lon Reporter™
Software on Connect account, you must have a valid Connect account on the
thermofisher.com website. Users who use the account to access lon Reporter '
Software on Connect must also have valid Thermo Fisher account accounts.

1. Click &t (Settings) » Thermo Fisher Account.

2. In the Thermo Fisher Account Settings screen, click + Create Account.
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3. In the Create Thermo Fisher Account dialog box, complete the information
required to configure the account.

Option Description
Account Type Select lonReporter Cloud.
Name Enter a name to identify the account in

the list of Thermo Fisher Account
Settings in Genexus™ Software.

User Name This must the user name (email address)
for a valid lon Reporter™ Software on
Connect account.

Password Enter the password for the lon
Reporter™ Software on Connect
account.

(Optional) Set as Default Account Click the toggle button if you want to

make the account the default account
that is used to upload sample results
files.

4. Click Submit.

The configured lon Reporter™ Software on Connect account is added to the Thermo
Fisher Account Settings table. (See the row with the Account Name that you used
listed as a Thermo Fisher Cloud account.) The account can be selected in the
Setup step of a run plan to automatically upload sample results file to lon Reporter™
Software. When sample results are added to a run plan, samples samples that are
associated with the run can be uploaded.

Completed sample results files can also be uploaded to lon Reporter™ Software from
the Actions column in the Results / Run Results screen.

onfigure an n administrator-level user can configure a link to an lon Reporter™ Server account in
Config An ad level f link lon R S
enexus Software. When the server is configured, you can upload sample results
on Reporter™ G ™ Sof When th i figured load | |
Server account files from Genexus™ Software directly to the the lon Reporter™ Server and use lon
(administrator) Reporter™ Software for further data analysis, annotation and reporting. The uploads
contain unmapped BAM files.

1. Click % (Settings) » Thermo Fisher Account.

2. In the Thermo Fisher Account Settings screen, click + Create Account.

Genexus™ Software 6.2 User Guide 129



;‘.: Chapter 8 System administration and management (manager/administrator)
User accounts (administrator)

=
oY

=

3. In the Create Thermo Fisher Account dialog box, complete the information
required to configure the account.

Option Description
Account Type Select lonReporter Local
Name A name to identify the account in the list

of Thermo Fisher Account Settings

User Name This must a username for a valid lon
Reporter™ Server account.

Password Enter the password for the lon
Reporter™ Server account.

Server Enter the name of the lon Reporter™
Server that you will use to upload
sample results files.

Version Click G Get lon Reporter Software
Versions, then select the software
version.

Port Enter the port of the lon Reporter™
Server.

(Optional) Set as Default Account Enable the toggle switch if you want to

make this account a default account to
upload sample results files.

4. Click Submit.

The configured lon Reporter™ Server account is added to the Thermo Fisher
Account Settings screen. The account can be selected in the Setup step of a run
plan to automatically upload sample results files and launch analyses in lon
Reporter™ Software. Completed sample results files can also be uploaded to lon
Reporter™ Software from the Actions column in the Results / Run Results screen.

The configured account is listed in the {0} (Settings) / Thermo Fisher Account
screen. A successfully authenticated account has Active in the Status column. The
software version for the lon Reporter™ Software is listed in the Version column.

User accounts (administrator)

Administrator-level users can perform user management actions in the
b (Settings) / User Management screen.

* Add new user accounts

* Assign user privileges (roles)

* Edit user information

* View user account audit trails

* Manage user account security policies
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In addition, administrator-level users can configure an SSH key in the
2 (Profile) / My Profile screen.

Add a new user Administrator-level users add new user accounts to the software, and grant certain
account users permissions to electronically sign reports.

(admlnlstrator) This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

The email settings in the software must be configured before new users can receive
email notifications. For more information, see “Configure email notifications
(manager/administrator)” on page 137.

—

In the menu bar, click 3 (Settings) » User Management.
In the User Management screen, click + Add New.

In the Create User dialog box, enter the user account information.

User names can contain alphanumeric characters and underscores, periods,
and hyphens.

From the Role list, select the appropriate user-access level (Administrator,
Manager, or Operator).

To allow a user to sign reports (manager- and administrator-level users only),
click the Electronic Signature toggle button.

Click Save.

The software sends an email notification containing a temporary password to
the email address of the new user.

Sort the user Administrator-level users can sort the user list by user name, first name, and last
list (admin) name.

1.

2.

In the menu bar, click 3 (Settings) » User Management.

In the User Management screen, click the column name of interest to sort the
column alphabetically.

Click the column name a second time to reverse the order.
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Edit user Administrator-level users can edit user details in the

details £ (Settings) / User Management screen. An administrator can also suspend or

(administrator) disable user accounts. A history of user account changes is maintained by the audit
feature.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

1. In the menu bar, click (& (Settings) » User Management.
2. In the User Management screen, in the Actions column, click Edit.

3. In the Edit User dialog box, edit the user details.

* Enter changes in the appropriate account information fields.

* In the Role list, select the user-access level (Administrator, Manager, or
Operator).

* To enable the ability to sign reports (manager- and administrator-level users
only), click the Electronic Signature toggle button to the enabled position.

* In the State list, select the appropriate state (Active, Suspended, or
Disable).

4. Click Save to make the changes.

Reset user An administrator-level user resets passwords for user accounts. A history of user
password password changes is maintained by the audit feature.

After a password is reset, the software sends an email notification to a user of a
temporary password, which they must personalize when logging in.

Periodically, the software sends a system-generated email notification to a user that
their password is about to expire. The operator follows the directions included in the
email notification of a pending password expiration. A user can also request that an
administrator reset their password.

Passwords can contain only alphanumeric characters and no special characters or
spaces.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.
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The email settings in the software must be configured before new users can receive
email notifications. For more information, see “Configure email notifications
(manager/administrator)” on page 137.

1. Click 3 (Settings) » User Management.
2. In the Actions column, click Reset Password for the selected user.

3. In the Change Password dialog box, you can change the password in one of
two ways.

¢ C(Click Send password in Email to send a software-generated password in an
email message to the user.

e Enter a new password into the Password field to change the password for
the user. Reenter the new password into the Confirm Password field, then
click Change.

The confirmation message "Password reset link sent to your email account" or
"Password changed successfully" appears to indicate the password reset.

View user An administrator-level user can view the user account history using the audit feature.
account history The user account audit trail is a record of when the user account was created and

(administrator)  modified.
This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that

establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

—

. In the menu bar, click ¢ (Settings) » User Management.

2. In the User Management screen, in the Actions column, click Audit.

3. In the Audit Details screen, view the audit trail details. For additional
information, in the Audit Record Details column, click the time stamp of

interest.

4. (Optional) In the User Management screen, click [ Download to export the
record to a PDF file.
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Set user An administrator-level user sets security policies for Genexus™ Software user
account accounts. User account security policies include the permissible number of failed
security sign-in attempts, password lifetime, and the length of inactivity before users are
policies automatically signed out of the software. These settings apply to all users.

(administrator) This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

1. In the menu bar, click (& (Settings) » User Management.
2. In the User Management screen, click 2 Policies.

3. In the Policies dialog box, select the appropriate values to set the user-account
suspension period, password, and session timeout policies.

4. Confirm that the Enabled toggle button is set to enable the session policy

settings.
5. Click Save.
Configure an Administrator-level users can set up an SSH key in their user profile in the
SSH key & (Profile) / My Profile screen. SSH, also known as Secure Shell or Secure Socket

(administrator) Shell, is a network protocol that gives administrator-level users a secure way to
access a computer over an unsecured network. SSH also refers to the suite of
utilities that implement the SSH protocol.

Configuring an SSH key is optional, but best practice is to configure one or more
SSH keys. The ionadmin and ionservice users may need to configure SSH keys so
that they can access the system at the operating system level to configure some
system-level settings, for example mounting an archive directory on the system. A
user can have more than one SSH key.

Before configuring an SSH key, you must first generate keys by using the Keygen
command on your local system. When the public and private keys are generated,
copy the text string from the public key to use in this procedure.

1. In the menu bar, click & (Profile) » My Profile.

2. In the SSH Keys section, click + Add new SSH Key.
The SSH Keys section is available only to ionadmin and ionservice users.

3. Complete the Add new SSH Key dialog box.
a. In Label, type a unique name for this SSH key.

b. In SSH Key, paste or type the SSH key string generated by using the
Keygen command on your local system.

c. Click Save.

134 Genexus™ Software 6.2 User Guide



-
)

)

LK
S8l

8

Chapter 8 System administration and management (manager/administrator)
Audit records (administrator)

T

b
=

Audit records (administrator)

Search audit
records
(administrator)

Administrator-level users can use the tools in the {5 (Settings) / Audit Records
screen to configure and manage audit records. Information that can be audited
includes activities by users on samples, libraries, assays, planned runs, system setup
the sequencer, accounts, and software updates.

The Audit Records screen lists actions that are performed on any data object,
including the user who performed the action, the action performed, the data object
name, and the date and time of the action. Additional details concerning the action
are available in an accompanying audit record.

The actions can be searched and sorted, and the audit records can be exported and
printed.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

Note: Library batches and runs that are created in a batch with other objects in a
single LIMS transaction do not have a "Create" action that is listed in the

{+ (Settings) / Audit Records screen. However, you can view complete library batch
audit records from the Samples / Manage Libraries and Runs / Manage Runs
screens. Any subsequent actions that are performed on library batches are listed in
the Audit Records screen. A library batch or run that is created individually in a LIMS
transaction is listed.

An administrator-level user can use the search tools in the

£+ (Settings) / Audit Records screen to search for an existing audit record.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

1. In the menu bar, click {3} (Settings) » Audit Records.

2. In the Audit Records screen, select the search parameters.

a. To select a date range, click 5 Calendar next to Start Date and End
Date.

If an end date is not selected, the search results include all records from the
start date through the current date.

b. To limit the results list to actions that are performed by a specific user,
select the user from the Select User list.

c. To limit the results to specific actions, select from the Select Action list.
d. To limit the results to a particular sample, select from the Sample list.
3. Click Search.

4. Click Clear to return to the complete list of records.
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An administrator-level user can sort the columns in the
{3+ (Settings) / Audit Records screen to display the list of audit records in different
order. The default order is the newest record on top.

To return to the default display, click the Audit Records column heading or click
Clear.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

1. In the menu bar, click 8 (Settings) » Audit Records.

2. In the Audit Records screen, click the column heading of interest.

The list of records is reordered based on the heading selected. User, Action
Performed, and Data Object Name sort alphabetically.

3. Click the column heading a second time to reverse the order of records
displayed.

4. Click Clear to return to the sorted column to the default.

5. Click the Timestamp heading to return to the default order, displaying the most
recent record on top.

An administrator-level user uses the & (Settings) / Audit Records screen to export
a print-ready PDF file of selected audit records.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

1. In the menu bar, click & (Settings) » Audit Records.

2. In the Audit Records screen, select the record or records to be exported by
clicking the checkbox next to the record of interest. Select all of the records in
the screen by selecting the checkbox above the column.

3. Click 5] Download.

A PDF file is generated. Depending on your browser settings, the software
automatically downloads the file or prompts you to open or save the file.

4. Open the PDF file in an appropriate viewer to print.
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Update the An administrator-level user configures the audit details by requiring that a reason for
audit a change be included in audit records when a user changes information. When a
configuration reason is required, the user must supply a reason for change when editing the

(administrator) information, and the reason is included in the audit record.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

1. In the menu bar, click {&b (Settings) » Audit Records.
2. In the Audit Records screen, click t}} Audit Configuration.

3. In the Audit Configuration dialog box, select the Require Reason checkbox
next to the Data Object Name for which a reason for change is required.

4. Click Save.

To remove a reason for change requirement, open the Audit Configuration
dialog box, deselect the checkbox, then click Save.

Configure email settings (manager/administrator)

Manager- and administrator-level users configure email settings. Administrator-level
users can configure support contact information, such as the lab contact and the IT
contact for the organization.

Configure Manager- and administrator-level users configure the Genexus™ Software to send
email email notifications to a specified administrator.

notifications . Administrator-level users receive email notifications when any of the following
(manager/admi  conditions occur:

nIStrator) * The archive directory location has limited free disk space remaining.

* The archive directory location is not accessible when the system tries to archive
arun.

1. Obtain the SMTP server URL and port information from your IT department.
2. Click ¢ (Settings) » Configuration.

3. In the Configuration screen, in the Email Settings section, enter the server and
port information supplied by IT, and the Genexus Software user name,
password, and email address of the administrator.

4. Click Update.

5. Click Send Test Email to send a test email to the email address provided in the
settings.
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The Lab Information tab in the {3; (Settings) / Configuration screen provides a
reference for support personnel, listing points of contact if a problem with the
connected Genexus™ Integrated Sequencer occurs.

* Lab Contact—This is the person in your organization who should be notified
during a support request of problems related to the sequencer.

* IT Contact—This is the person in your organization who should be notified
during a support request of problems related to the sequencer hardware or the
network environment.

IMPORTANT! The Administrator should review the contact information periodically
to ensure that it is current and accurate.

Software updates

138

An administrator-level user can select Software Updates in the ¢c3 (Settings) menu
to:

* See the currently installed software versions for each software module, assay
configuration package, plugin, and configuration package installed on the
system under the Installed Software link.

* Check for new software updates that are available to be downloaded and
installed under the Software Updates link.

For users who have set up a Thermo

Fisher Connect account, a notification
appears in the Genexus™ Software

banner on the top of the screen upon Results / Run Results

login when updated software packages
are available for download from the Connect cloud-based platform.

Updated software packages are available from the App Store at
apps.thermofisher.com. Administrator-level users can download and install software
directly from the App Store if a Thermo Fisher Connect account has been configured.
Alternatively, a USB drive can be used to install and update the software if the
instrument is not connected to the internet.

To... See this...
Download and install software directly “Download and install software directly
from the App Store (administrator)” on
page 139

Download and install software with a USB | “Format a USB drive for a software
drive update” on page 140

“Download software from the App Store to
a USB drive (administrator)” on page 140
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Note: For first-time update of system software from the 5.100.2 version, contact a
Thermo Fisher Scientific field service engineer to update the system software.

IMPORTANT! Before updating the software, ensure that the instrument is idle, no
analysis jobs are running or are queued to run, and the screen on the instrument is
the main menu screen.

Download and In order to download and install software updates, you must first:

install software  «
directly from

the App Store
(administrator)

Configure a Thermo Fisher Connect account. For instructions, see “Configure
Thermo Fisher Accounts in Genexus™ Software (administrator)” on page 127.

Ensure that the Genexus " Integrated Sequencer has the latest software version,
Genexus™ Software version 6.2x.

Connect your Genexus™ Integrated Sequencer to the internet.

In the menu bar, click (3 (Settings) » Software Updates, then click Software
Updates in the upper right corner.
The Software Updates screen opens with App Store enabled.

(Optional) Click the desired package name to view the installation details and
version information in the View Package Details pane.

Click Download in the Actions column in the row of the software package of
interest.

After completion of the download, the Download link changes to an Install link.

Click Install. When the confirmation window appears, click Yes to confirm that
you want to install.

If you are performing a system software module installation, a command window
opens where you can monitor installation progress.

Note: There may be a delay before the command window opens.

When installation of the software package is complete, click Installed Software
to verify the installation.
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Format a USB Pre-requisites:

drive for a * An Ubuntu Linux desktop machine with disk utility software.
software .

A USB drive with a capacity of 4 GB or more.
update

1. Insert the USB drive into the Ubuntu Linux machine.

2. With Ubuntu running, open the disk utility by navigating to System
Administration » Disk Utility.

3. Select the USB Flash Drive (SMI USB DISK) under Peripheral Devices from
Storage Devices by clicking on it. Highlight the volumes (New Volume FAT >4
GB), click Unmount Volume, then click Delete Partition. Click Delete to
confirm.

4. Select the free USB volume, then click Create Partition.
The Create partition on SMI USB DISK window opens.

5. Deselect the Take ownership of file system check box.

6. Select ext3 from the Type dropdown menu, then select the entire size of the
partition. Name the partition usbinstall.

The partition name must be completely lowercase.

7. Click Mount.
The mount point of the USB drive is /media/usbinstall.

Proceed to “Download software from the App Store to a USB drive (administrator)”.

Download In order to download and install software updates, you must first:

software from * Create or access your Thermo Fisher Connect account. For instructions, see
the App Store “Configure Thermo Fisher Accounts in Genexus™ Software (administrator)” on
to a USB drive page 127.

(adminiStrator) * Format a USB drive for the software update. For more information, see “Format
a USB drive for a software update” on page 140.

1. Sign in to the Thermo Fisher App Store on Connect at apps.thermofisher.com.
2. On the left side of the App Store screen, click AppConnect.

3. On the right side of the screen, under Resource Libraries, click lon Torrent™
Genexus'™.

4. Click Software Update.
5. Select the software package name of interest, such as (name) 6.2x.
6. Click Download to download the package.

7. Copy the downloaded package (.zip) to the /media/usbinstall folder in the
USB drive.
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8. After completion, unmount the USB drive, then insert the drive into one of the
USB ports at the back of the Genexus™ Integrated Sequencer.

9. In the menu bar of the Genexus™ Software, click
3 (Settings) » Software Updates, then click Software Updates in the upper
right corner.

10. Click the App Store toggle button to select USB.

11. Click Install. When the confirmation window appears, click Yes to confirm that
you want to install.

When installation of the software package is complete, click Installed Software to
verify the installation.

Data management (administrator)

Administrator-level users use the {&; (Settings) / Data Management screen to:
* Monitor sequencer disk space usage.
* Manage archive settings.
* View an audit trail of any changes made.

Disk space An administrator-level user monitors disk space usage and data archiving on the
usage and data sequencer. Sequencer disk space usage information is available from the
archiving b (Settings) / Data Management menu.

(administrator) To maintain sufficient disk space, best practice is to implement a systematic plan to
archive older run data, results files, variants information, and signed reports to an
external file storage system. A system administrator or Field Service Engineer is
responsible for designing and establishing a data archiving system and database
backup options. After an archive system has been established, an administrator-level
user configures the archive schedule in the ¢ (Settings) / Data Management
screen.

The system ensures that free disk space is available on the sequencer for runs.

* If the sequencer has less than 1 terabyte (TB) of free disk space, no new runs
can be started. In this case, an alert notifies the user that there is insufficient disk
space when setting up a run on the sequencer. The run cannot proceed until
data on the sequencer is archived and deleted.

* |f the sequencer has less than 2 terabytes (TB) of free disk space, the raw data
for the oldest completed runs is automatically deleted to free up space for future
runs.

Contact your local system administrator to archive and delete data manually. The
administrator can also change the archive schedule.

Archived results and reports can be restored to the sequencer hard drive and
downloaded from the Results / Run Results screen. For more information, see
“Restore archived results (administrator)” on page 144.
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archive
settings
(administrator)

Data output
directory
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An administrator-level user views and configures sequencer archive settings in the
£+ (Settings) / Data Management screen.

The archive settings may need to be updated for various reasons.
* The archive location has limited free disk space remaining.
* The archive location is not accessible when the system tries to archive a run.

Consult your local Field Service Engineer to set up a database archive and backup
system. For more information, see “Set up an archive server (administrator)” on
page 143.

1. In the menu bar, click (& (Settings) » Data Management

2. In the Data Management screen, edit the archive settings.

Setting Procedure

Auto Archive After Select the number of months for data to
remain on the sequencer hard drive
before it is archived on to an external
server.

To free up additional space on the
sequencer hard drive, reduce this
interval.

Archive Directory Enter the file path to the external server
where data will be archived.

The path must be specified before data
can be archived. If blank, and if any
archive data is found, the software
sends an email notification to set up the
archive directory.

For more information, see “Data output
directory” on page 142.

Data Output Directory The default file path for the data output
directory can be viewed, but cannot be
changed.

3. Click Save.

The data output directory is the primary location on the hard drive where data
generated by the Genexus™ Integrated Sequencer is stored. The path to the directory
appears in the {&; (Settings) / Data Management screen.

The directory location is locked and cannot be changed. Users should configure their
laboratory information management systems (LIMS) to access this folder location to
receive sequencing output files.

After a sequencing run and data analysis are complete, the software creates a
separate results folder in the data output directory for each sample, and uses the
following naming conventions:
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AssayDev_<Sample Name>_<Assay Name>_<RunPlanShortCode>_

<RunPlanShortCode>
Archive Administrator-level users receive email notifications when any of the following
notifications conditions occur:

* The archive directory location has limited free disk space remaining.

* The archive directory location is not accessible when the system tries to archive
arun.

To receive email notifications, a valid administrator email address must be entered
into Genexus' Software. To configure email notifications, see “Configure email
notifications (manager/administrator)” on page 137.

Set up an Administrator-level users set up an external storage device to be an archive server to
archive server store system data.

(admmIStrator) 1. Mount your NFS to the sequencer.

The following example is for users who have an existing—read and write access
—Network File System (NFS). Mount your NFS to the sequencer using fstab so
that the mount point is persistent (NFS mounts automatically after rebooting).

Example:
For NFS share: cqtsop4:/md1200
Mount point: nfs1

2. Create a mount point to mount the external device on nfs share.
a. Create the directory /nfs1 using the following command:
sudo mkdir /nfsl

b. Append the mount point entry in /etc/fstab.
Command example:
sudo vi /etc/fstab
cgtsop4:/md1200 /nfsl nfs defaults 0 O

c. Save, then exit by pressing Esc on your keyboard, then type :wq

3. Create a permanent or temporary mount on nfs share:

®* Permanent mount command: sudo mount -a

® Temporary mount command (example): sudo mount cqgtsop4:/
md1200 /nfsl

4. Verify that the NFS share is mounted using the df -kh command.
ionadmin@eternityl:~$ df -kh
Filesystem Size Used Avail Use$% Mounted on
/dev/sda9 253G 5.9G 235G 3% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
udev 63G 4.0K 63G 1% /dev
tmpfs 13G 1.3M 13G 1% /run
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none 5.0M 0 5.0M 0% /run/lock

none 63G 0 63G 0% /run/shm

none 100M 0 100M 0% /run/user

/dev/sda5 19G 2.9G 15G 17% /var

/dev/sdal 938M 37M 854M 5% /boot

/dev/sda6 9.1G 1.7G 7.0G 20% /home
/dev/mapper/raid-serverdata 8.4T 4.3T 4.1T 52% /serverdata

/dev/mapper/raid-servershare 1.0T 9.0G 1015G 1% /
servershare

/dev/mapper/raid-scratch 1.0T 838M 1023G 1% /scratch
/dev/sda7 92G 61M 87G 1% /tmp

pluto:/md1200 37T 1.1T 36T 3% /nfs2

penguin-tsl:/local 11T 9.3T 978G 91% /nfs
ddn4.itw:/gsl/ion-data/dx-data 1.1P 1001T 115T 90% /ddn
cqgtsop4:/md1200 37T 37T 77G 100% /nfsl

For more information, see help.ubuntu.com/Its/serverguide/
network-file-system-configuration.

Genexus™ Software can be configured to archive automatically older run data, results
files, and signed reports from the sequencer to an external server, based on when the
results are generated. For more information, see “Disk space usage and data
archiving (administrator)” on page 141) and “Set up an archive server (administrator)”
on page 143.

The administrator can later restore the archived results, files, and reports to the
sequencer from the Results / Run Results screen.

Archived results are listed in the Results / Run Results screen with the Restore link
active in the Actions column.

1. In the menu bar, click Results » Run Results.
2. In the Run Results screen, click the run name of interest.
3. In --- (More Options), click Restore.

4. Click OK in the confirmation dialog box.
Click the run name in the Run Results screen to view run results.

Log files (administrator)

144

Administrator-level users use the Settings tab in the Logs screen to view log files
generated by the software. Viewing log files is useful for troubleshooting activities.

Administrator-level users can also use the Logs screen to manage the storage of log
data by setting the retention period for the audit trail function and enabling auto-
deletion rules for logs.
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Manage Iog An administrator-level user manages the length of time that log files are kept and
settings configures the software to allow log files to be automatically deleted.

(admlms'trator) This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

1. Click & (Settings) » Logs.
2. In the Logs screen, click ) Manage Logs.

3. In the Manage Logs dialog box, in Retention Period, select the number of
months that logs are to be retained on the sequencer.

4. Select Enable Auto Deletion to delete log files automatically after the
designated retention period.

5. Click Save.

Panel files (manager/administrator)

Manager- and administrator-level users use the Assays / Manage Panels screen to
manage panel files and reference files.

Note: Manager- and administrator-level users can create and obsolete panel and
reference files using + Add New and Obsolete, except for those defined by
system-installed or locked assays.

* Panelfiles (BED format) * Reference genome files (FASTA
* Hotspots files (BED format) format)

* Fusion reference sequences (FASTA  * DNAbarcode sequence files

format) ¢ Control fragments
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Manage panel Manager- and administrator-level users add new panel files to Genexus™ Software,
files (manager/ export existing panel files, and make old panel files unavailable in the software.

adminiStrator) Operators can view the panel files that are available in the software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Use the following options to manage panel files:

* To add a new panel file, click 4+ Add New, enter a name and panel type.
Click Upload when you have finished.

Large files take time to upload and may not appear immediately.

* To export a panel file, click Export in the Actions column of the panel that
you want to export.

* To make an old panel file unavailable in the software, click Obsolete in the
Actions column of the panel that you want to obsolete.

You cannot designate as obsolete system-installed panel files.

Manage Manager- and administrator-level users add, view, and manage the hotspot BED files
hotspot files that are available in Genexus™ Software.
(manager/ Operators can view the panel files that are available in the software.

administrator)
1. In the menu bar, click Assays » Manage Panels.

2. In the Manage Panels screen, select the Hotspots tab.

* To add a new hotspot file, click + Add New, then enter a name, select a
panel, then select the BED file containing the hotspots information. Click
Upload when you have finished.

Large files take time to upload and may not appear immediately.
* To export a hotspot file, in the Actions column, click Export.

* To make a hotspot file unavailable in the software, in the Actions column,
click Obsolete.

You cannot designate obsolete system-installed hotspot files.
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Manage fusion Manager- and administrator-level users add new, view, and manage the fusion
reference files reference files that are available in the software.

(manager/ Operators can view the fusion reference files that are available in the software.

administrator)
1. In the menu bar, click Assays » Manage Panels.

2. In the Manage Panels screen, select the Fusion References tab.

¢ To add a new fusion reference file, click + Add New, then enter a name,
select a genome reference and select the FASTA file containing the fusion
reference information. Click Upload when you are finished.

Large files take time to upload and may not appear immediately.
* To export a fusion reference file, in the Actions column, click Export.

* To make a fusion reference file unavailable in the software, in the Actions
column, click Obsolete.

You cannot designate obsolete system-installed fusions reference files.

Add reference Manager- and administrator-level users add new DNA reference genome files so that

genome files they are available in Genexus " Software. New reference genomes are uploaded in a
(manager/ FASTA file.
administrator) For information about the system-installed references, see “System-installed genome

reference files” on page 194.

1. In the menu bar, click Assays » Manage Panels.

2. In the Manage Panels screen, click the References tab, then click
-+ Add New.

3. In the Add Reference Genome dialog box, enter the required information, then
select the FASTA file to upload the reference sequence information.

Large files take time to upload and may not appear immediately.

4. Click Upload when you have finished.
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Control fragments (manager/administrator)

Control fragment sequences are system-installed in Genexus™ Software and are
included in reagents. These internal controls are predefined and cannot be modified
by users.

Manager- and administrator-level uses can view control fragment information in the
Assays / Manage Panels screen, in the Control Fragments tab.

Column Description
Name The control fragment name.
Sequence Single-letter nucleotide sequence of the control fragment.
Control The process in which the control fragment is used.
Status Indicates whether the control fragment information is locked and
cannot be modified by the user.

Manager- and administrator-level users add new barcode sets to the Genexus™
Software, and view the barcode IDs and sequences for each barcode set that is
available in the software.

For information about system-installed barcode sets, see “System-installed barcode
sets” on page 177.

1. In the menu bar, click Assays » Manage Panels.

2. In the Manage Panels screen, in the Barcode Sets tab, click the name of a
barcode set in the list.
A new window opens showing the name and sequence information about each
barcode in the set.

3. Click < Back to return to the list.

4. To add a new DNA barcode set, click + Add New, enter the required
information in the Add Barcode Set dialog box, and browse to and select the
barcode set file. Click Upload when you have finished.
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System services (manager/administrator)

Terminate an
active job
(manager/
administrator)

Manager- and administrator-level users can view information about system services
using the {&; (Settings) / Services screen. The information can be useful when
troubleshooting error messages that are received during an active job or why an

analysis failed.

Service Function
Jobs Server Shows a list of server information and active (running) software.
Services Shows the service name, description, and status. The Services
list can be used for troubleshooting. If a service has stopped
during a run, an option to start the service will be visible for
manager- and administrator-level users.
Active Jobs * Shows a list of analysis jobs that are active and queued on

the sequencer.

* When no job is currently active, displays a “No active jobs”
message.

ionCrawler Service
Details

Provides information about the data transfer process from the
Genexus™ Integrated Sequencer.

Smart Monitoring
Service Details

Allows remote monitoring of the Genexus™ Integrated Sequencer.

Download
Instrument
Diagnostics

Contains the initialization logs of the Genexus™ Integrated
Sequencer, and allows you to download the diagnostic archive
file (in ZIP format).

If an active job is not going to be useful or if a different job is urgent, you can opt to
terminate an active job. A manager- or administrator-level user can stop an actively
running job in the {&; (Settings) / Services screen.

1. In the menu bar, click (& (Settings) » Services.

2. In the Services screen, in the Active Jobs section, find the active job that you
want to stop, then click Terminate.

A confirmation message opens, Are you sure you want to terminate <job

name> ?.

3. Click the Terminate to terminate the job.

Genexus™ Software 6.2 User Guide
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A manager- or administrator-level user can use the {; (Settings) / Services screen
to restart a stopped service if a service has stopped running for some reason. The
two database services, postgresql and mongod are the only services that can be
restarted.

1. In the menu bar, click (5 (Settings) » Services.

2. In the Services screen, in the Services section, find the service that you want to
reactivate, then click Start.

A confirmation message opens, Are you sure you want to Start<service
name>?.

3. Click Yes to restart the service.

The ionCrawler service typically remains enabled at all times, but can be disabled by
manager- or administrator-level users if required for remote service troubleshooting.

¢ Disable the service.
a. In the menu bar, click ¢s3 (Settings) » Services.

b. In the Services screen, in the ionCrawler Service Details section, click
stop.

ionCrawler Service Details

Status: Online

c. In the confirmation message, click Yes to disable the service.
The Stop option changes to Start.

ionCrawler Service Details

Status : Ofﬂine

* Enable the service.
a. In the menu bar, click ¢s3 (Settings) » Services.

b. In the Services screen, in the ionCrawler Service Details section, click
Start.

c. In the confirmation message, click Yes to enable the service.
The Start option changes to Stop.
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The Smart Monitoring service allows Thermo Fisher Scientific personnel to monitor
the status of the Genexus' Integrated Sequencer remotely through an internet
connection. Smart Monitoring employs multiple layers of security, including a Secure
Sockets Layer (SSL) and Lightweight Directory Access Protocol (LDAP)
authentication, to provide real-time troubleshooting and problem resolution for the
Genexus™ Integrated Sequencer.

The Smart Monitoring service is active by default and can be disabled by manager-
or administrator-level users, if required.

* Disable the service.
a. In the menu bar, click 3 (Settings) » Services.

b. In the Services screen, in the Smart Monitoring Service Details section,
click Stop.

c. In the confirmation message, click Yes to disable the service.
The Stop option changes to Start.

* Enable the service.
a. In the menu bar, click ¢s3 (Settings) » Services.

b. In the Services screen, in the Smart Monitoring Service Details section,
click Start.

c. In the confirmation message, click Yes to enable the service.
The Start option changes to Stop.

Sign off on the run results (manager/administrator)

Manager- and administrator-level users can provide their electronic signature on
sample results for completed runs. In the Results / Sample Results screen, a
sample name followed by (Signed Off) indicates that a manager- or administrator-
level user has approved the sample results. The signature information appears in the
Lab Report PDF file or a user-created report, if selected. For more information, see
“Lab Report” on page 85, and “Create a report template (manager/administrator)” on
page 121.

A manager- or administrator-level user can update report template selections during
sign off.
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This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

1.

2.

10.

11.

152

In the menu bar, click Results » Sample Results.

In the Sample Results screen, click the sample of interest in the Sample Name
column.

In the upper right-hand corner of the screen, click -+ (More Options) » Sign
Off.

In the Electronic Signature dialog box, enter your user name, password, and
comments.

Items identified with a red asterisk (*) are required fields.
In the Meaning of Signature dropdown list, select Approval.

In the Report Template dropdown list, select the report template that you want
to use.

In the Report Customizations section, in the Lab Report pane, select the
types of variant calls that you want to include in each report. For assays that use
Reporting Gene Lists, you can customize the variants by reporting category.

In Footer Field, enter any text that you want to appear in the footer of the PDF
report pages.

If you entered footer information in the Footer Field when you created a report
template, the same footer information appears in the Electronic Signature
dialog box. You can enter new footer information to override the report template.

Click Sign Off to confirm your electronic signature.

In the menu bar, click Results » Sample Results to return to the
Results / Sample Results screen.

In the row of the sample of interest, in the Actions column, click Lab Report to
download the report.
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Amend a signed-off report (manager/administrator)

Manager- and administrator-level users can amend a report within 30 days of signing
off. A sample that has a signed-off report is listed with the sample name followed by
(Signed Off) in the Sample Name column in the Run Results screen. You can
change sign-off or laboratory comments, the type of calls that are reported, or the
text that appears in the report footer.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that
establishes the United States Food and Drug Administration regulations on electronic
records and signatures, password policies, and user activity auditing.

1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, click the signed off sample name of the sample
of interest.

3. In the Results screen, click --- (More Options), then click Amend Report.

4. In the Electronic Signature dialog box, make your changes in the appropriate
fields, including changes in the types of variant calls you want to include in the
Lab Report, then click Amend Report.

5. Return to the Results / Sample Results screen. Then, in the Actions column
for the sample, click Lab Report to download the amended report.
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Plugins for data analysis

B coverageAnalysis plugin in Genexus™ Software ..............cccoviinnn. 154
B  molecularCoverageAnalysis plugin in Genexus™ Software ............... 163
B  CustomerSupportArchive plugin . ...t i e 170
B samplelD plugin . ... e 171

You can expand the analysis capabilities of Genexus™ Software with plugins that are
preinstalled with the software. The plugin results are added to the report summary
and can be used for a variety of purposes.

An administrator-level user can download and install additional plugins from the
Connect cloud-based platform.

coverageAnalysis plugin in Genexus Software

Use the coverageAnalysis plugin to view statistics and graphs that describe the level
of sequence coverage produced for targeted genomic regions. The results for a run
analyzed with the plugin vary based on the library type that you select when you
configure the plugin. You can export some charts as graphics, such as the Amplicon
Coverage Chart and the Reference Coverage Chart.

Review The coverageAnalysis plugin generates a Coverage Analysis Report. This report
coverageAnaIy includes read statistics and several charts. The statistics and charts that are

sis p|ugin presented depend on the library type for the analysis.

results The report summary lists the barcode, the sample, the number of mapped reads, the

percentage of on target reads, mean base coverage depth, and base coverage
uniformity. Microsoft™ Excel -compatible reports are also generated, including
differential expression tables. Additional details regarding read coverage are also
provided on a per-barcode basis, along with a list of gene annotations for each
sequenced region.

You can download coverageAnalysis plugin output files from the Results screen for a
sample. For more information, see “Results files” on page 89 and “Output files
generated by the coverageAnalysis plugin” on page 161.

1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, in the Sample Name column, click the sample of
interest.
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. Click the Plugins tab.

A summary table of the coverage analysis, by barcode, is included in the
coverageAnalysis summary pane.

. (Optional) From the Executed At dropdown list, select an alternate timestamp, if

available, to view additional reports.

. (Optional) Click [§ View Log to view the coverageAnalysis log.

. (Optional) Click il Delete to delete the coverageAnalysis plugin output for the

selected timestamp.

IMPORTANT! If you click [i] Delete, the report is deleted without the
appearance of confirmation dialog window. Ensure that you intend to delete the

report before clicking il Delete.

In the coverageAnalysis summary pane, in the Barcode Name column, click
the link in the row of the barcode of interest.

The detailed Coverage Analysis Report for the barcode opens in a separate
window.

The detailed Coverage Analysis Report that is available when you select a barcode
in the coverageAnalysis plugin summary for a run includes a variety of reads
statistics. The statistics that are displayed in your report depend on the type of library
that is used in your sequencing experiment. Definitions are in tooltips. Almost every
statistic, plot, link, and functional widget in the report provides tooltips with
definitions. Hover over a heading or description in the report to view the tooltip.

Statistic

Description

Number of mapped reads

The total number of reads mapped to the reference genome.

Percent reads on target

The percentage of filtered reads mapped to any targeted region relative to all reads
mapped to the reference. If no target regions file is specified, this value will be the
percentage of reads passing uniquely mapped and/or non-duplicate filters, or 100%
if no filters were specified. A read is considered on target if at least one aligned
base overlaps at least one target region. A read that overlaps a targeted region but
where only flanking sequence is aligned, for example, due to poor matching of 5'
bases of the read, is not counted.

Amplicon read coverage statistics

The following statistics describe the reads that are assigned to specific amplicons. Each sequence read is assigned to exactly one
of the amplicons specified by the targets file. If a read spans multiple amplicon targets, the target region that the reads covers
most is assigned. In the event of a tie, the target that is the closest to the 3' end is assigned.

Genexus™ Software 6.2 User Guide
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Statistic

Description

Number of amplicons

The number of amplicons that is specified in the target regions file.

Percent assigned amplicon
reads

The percentage of reads that were assigned to individual amplicons relative to all
reads mapped to the reference. A read is assigned to a particular (inner) amplicon
region if any aligned bases overlap that region. If a read might be associated with
multiple amplicons, it is assigned to the amplicon region that has the greatest
overlap of aligned sequence.

Average reads per amplicon

The average number of reads assigned to amplicons.

Uniformity of amplicon
coverage

The percentage of amplicons that had at least 20% of the average number of reads
per amplicon. Cumulative coverage is linearly interpolated between nearest integer
read depth counts.

Amplicons with at least N
reads

The percentage of all amplicons that had at least N reads.

Amplicons with no strand
bias

The percentage of all amplicons that did not show a bias towards forward or
reverse strand read alignments. An individual amplicon has read bias if it has >10
reads and the percentage of forward or reverse reads to total reads is greater than
70%. Amplicons with <10 reads are considered to have no strand bias.

Amplicons reading end-to-
end

The percentage of all amplicons that were considered to have a sufficient
proportion of assigned reads (70%) that covered the whole amplicon target from
‘end-to-end'. To allow for error, the effective ends of the amplicon region for read
alignment are within 2 bases of the actual ends of the region.

Amplicon base composition
bias

A number that represents the proportion of amplicons showing low representation (
<0.2x mean reads) in the lower and/or upper quartiles of amplicons ordered by
increasing G/C base pair content of their insert sequences. The value is relative to
that in the center 50th percentile of amplicons and weighted by the standard
deviation of representation over all amplicons. An RMS (root mean square) value is
used so that a bias greater in either upper or lower quartiles produces a larger value
than a mean bias seen more equally in both outer quartiles. The value is 0 if the
uniformity of amplicon coverage metric is 100%, however, the value is not
necessarily high at lower amplicon uniformity.

Target base coverage statistics

The following statistics describe the targeted base reads of the reference. A base covered by multiple target regions is counted
only once per sequencing read.

Statistic Description

Bases in target regions The total number of bases in all specified target regions of the reference.

Percent base reads on target | The percent of all bases covered by reads aligned to the reference that covered
bases in target regions. Clipped bases, deletions, and insertions (relative to the

reference) are not included in this percentage.

If no specific target regions was specified, the targeted regions is the whole
genome.
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Statistic

Description

Average base coverage depth

The average number of reads of all targeted reference bases. This is the total
number of base reads on target divided by the number of targeted bases, and
therefore includes any bases that had no coverage.

Uniformity of base coverage

The percentage of bases in all targeted regions (or whole genome) that is covered
by at least 20% of the average base coverage depth reads. Cumulative coverage is
linearly interpolated between nearest integer base read depths.

Target base coverage at Nx

The percentage of target bases covered by at least N reads.

Target bases with no strand
bias

The percentage of all target bases that did not show a bias toward forward or
reverse strand read alignments. An individual target base is considered to have read
bias if it has >10 reads and the percentage of forward or reverse reads to total reads
is greater than 70%. Target bases with <10 reads are considered to have no strand
bias.

Percent end-to-end reads

The percentage of on-target reads that fully cover their assigned amplicon (insert)
from 'end-to-end'. To allow for error, the effective ends of the amplicon region for
read alignment are within 2 bases of the actual ends of the region.

Bases in targeted referencel]

The total number of bases in all target regions of the reference.

Bases covered (at least 1x)!"]

The total number of target bases that had at least one read aligned over the
proximal sequence. Only the aligned parts of each read are considered. For
example, unaligned (soft-cut) bases at the 5' ends of mapped reads are not
considered. Covered target reference bases can include sample DNA read base
mismatches, but does not include read base deletions in the read, nor insertions
between reference bases.

Average base read depth!']

The average number of reads of all targeted reference bases that were read at least
one time.

Genome Base Coveragel'l

Summary statistics for base reads of the reference genome.

Genome base coverage at
Nx1

The percentage of reference genome bases covered by at least N reads.

[ Applicable to whole genome library analyses only.

Example charts
generated by
the
coverageAnaly
sis plugin

Genexus™ Software 6.2 User Guide

Many of the charts in the detailed Coverage Analysis Report include a Plot menu
that allows you to change characteristics of the chart. For example, you can show
both strands (see callout 3 in Figure 5).

The Q button (in the top right corner of a chart) opens the chart Viewing Options
panel. The ? button opens a description of the chart.
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Figure 1 Representative Depth of Coverage Chart

The Depth of Coverage Chart shows the distribution of targeted base coverage. The X-axis
represents the base read depth. The left Y-axis represents the number of reads at a given base read
depth or a range (bin) of base read depths, as a percentage of the total number of base reads. The
right Y-axis represents the cumulative count of the number of reads at a given read depth or greater,
as a percentage of the total number of reads. The individual orange bars represent the percentage of
reads in the specific range of base read depths. The blue curve measures the cumulative reads at a
given base read depth or greater. If your analysis includes a regions of interest file, this chart reflects
only target regions (reads that fall within a region of interest).

In most charts, you can click a data point to open a detail pane for that data. For
example, in the Depth of Coverage Chart in Figure 1, click an individual orange bar to
open the detail pane for bases within a specific range of base read depths. Click a
point on the blue curve to open the detail pane for cumulative bases at that base
read depth or greater. For example detail panes, see Figure 2. Similarly, you can click
any point or bar within the Amplicon Coverage chart to view details for each
amplicon coverage bin (see Figure 4).

Bases at depths 1,420-1,429 = Cumulative Bases at depth 960 *
Number of target bases read: 96 Number of target bases read: 1,863
Fraction of all target bases read: 4.37% Fraction of all target bases read: 84.87%

Figure 2 Example detail panes
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Figure 3 Representation Plots

Use the Display list to view different amplicon representation plots. This figure shows an example
Pass/Fail vs. Target G/C Content plot.
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Figure 4 Representative Amplicon Coverage Chart

The Amplicon Coverage charts summarize the amplicon coverage results. Several plots views are
available. The X-axis in all plots represents individual amplicons. The left Y-axis in all plots
represents assigned reads (on a base 10 log scale). Use the Plot and Overlay lists to customize the
chart view. The right Y-axis varies depending on the plot view that is selected from the Overlay
dropdown list. Click on any bar or any point on the chart to view the detail pane for that data.

@ Example Total Reads plot with a Target GC percentage overlay

@ Click on the bar to open the detail pane for the specific amplicon. Click View in Reference
Coverage Chart to zoom in on the amplicon in the Reference Coverage Chart (see callout 3
in Figure 5).
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Figure 5 Representative Reference Coverage Chart

The Reference Coverage Chart is an overlay of where target regions are defined and overlap on the
reference. The X-axis represents the target region chromosomal position. The Y-axis represents the
Base Read Depth.

@ Example Total Base Reads plot with Viewing Options panel expanded. The plot is zoomed in
on a specific chromosomal region. Click a yellow bar (top of the chart) to open the detail pane
for a specific amplicon in the Amplicon Coverage Chart (see callout 2 in Figure 4).

@ Example Total Base Reads plot where a chromosomal region has multiple targets. In the
Resolve Multiple Targets pane, click @ to zoom in on the region, or click one of the links to
open the detail pane for the specific amplicon in the Amplicon Coverage Chart.

@ Example Strand Base Reads plot that is zoomed in on one specific amplicon. Click the yellow
box to open the detail pane for the specific amplicon in the Amplicon Coverage Chart.
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Example The detailed Coverage Analysis Report that is available when you select a barcode in
Coverage the coverageAnalysis plugin summary for a run includes a variety of reads statistics.
AnaIySis C .
overage Analysis Report
Report g y 1
Sample Name:
Library type: AmpliSeq HD - DNA and Fusions (Single Library)
Reference: hgl9 (DNA)
Target regions:
T [P et eyt A e, e P
HIEE T Number of mapped reads 48,721
i " Percent reads on target 96.16%
E Average base coverage depth 1,177
anr ane @ Uniformity of base coverage 100.00%
Referance Location
Amplicon Read Coverage Target Base Coverage
Number of amplicons 39 Bases in target regions 2,195
Percent assigned amplicon reads  96.16% Percent base reads on target 53.78%
Average reads per amplicon 1,201 Average base coverage depth 1,177
Uniformity of amplicon coverage  100.00% Uniformity of base coverage 100.00%
Amplicons with at least 1 read 100.00% Target base coverage at 1x 100.00%
Amplicons with at least 20 reads  100.00% Target base coverage at 20x 100.00%
Amplicons with at least 100 reads  100.00% Target base coverage at 100x 100.00%
Amplicons with at least 500 reads 100.00% Target base coverage at 500x 100.00%
Amplicens with no strand bias 100.00% Target bases with nc strand bias 100.00%
Amplicons reading end-to-end 100.00% Percent end-to-end reads 96.21%
Amplicon base composition bias 0.000
Output files You can download coverageAnalysis plugin results files from the Results screen for a
generated by sample. For more information, see “Results files” on page 89.
the Note: Sometimes the file name can be too long to open in applications such as
coverageAnaly  Microsoft™ Excel™. To resolve this problem, right-click the file and click Save As to
SIS plugln rename the downloaded file.

The following tables describe the files that can be generated by the coverageAnalysis
plugin. The list of files depends on the application type that was selected during
assay creation.

File download selections in the Genexus™ Software

Selection File Name

DNA Coverage Statistics <DNA Barcode><ExpName>.stats.cov.txt

DNA Chromosome base coverage summary | <DNA Barcode><ExpName>.chr.cov.xls

DNA Base depth of coverage

<DNA Barcode><ExpName>.base.cov.xls

DNA Amplicon coverage summary

<DNA Barcode><ExpName>.

amplicon.cov.xls

Genexus™ Software 6.2 User Guide
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Selection File Name
DNA Coverage Analysis Summary (.pdf) <DNA Barcode><ExpName>.summary.pdf
RNA Coverage Statistics <RNA Barcode><ExpName>.stats.cov.txt
RNA Amplicon coverage summary <RNA Barcode><ExpName>.amplicon.cov.xls
RNA Coverage Analysis Summary (.pdf) <RNA Barcode><ExpName>.summary.pdf

File contents

File Description
Coverage A summary of the statistics presented in the tables at the top of the plugin report. The first line
Statistics is the title. Each subsequent line is either blank or a particular statistic title followed by a colon
(:) and its value.
Chromosome Base reads per chromosome summary data that is used to create the default view of the
base coverage Reference Coverage Chart. This file contains the following fields.
summary

* chrom: the name of the chromosome or contig of the reference.

* start: the coordinate of the first base in this chromosome. This is always 1.

* end: the coordinate of the last base of this chromosome. Also its length in bases.

* fwd basereads: the total number of forward strand base reads for the chromosome.
* rev_ basereads: the total number reverse strand base reads for the chromosome.

* fwd trg basereads (if present): the total number of forward strand base reads that
mapped over at least one target region.

* rev_trg basereads (if present): the total number of reverse strand base reads that
mapped over at least one target region.

* total reads: the total number of sequencing reads that are mapped to individual
contigs.

Base depth of
coverage

Coverage summary data used to create the Depth of Coverage Chart. This file contains the
following fields.

* read depth: the depth at which a (targeted) reference base has been read.

* base_ cov: the number of times any base was read (covered) at this depth.
Note: Lines (read depths) for which base cov is 0 are omitted to avoid excessively large
files being produced in certain situations.

* base cum_cov: the cumulative number of reads (coverage) at this read depth or greater.

* norm read depth: the normalized read depth (depth divided by average base read
depth).

®* pc base cum_cov:same as base_cum_cov but represented as a percentage of the total
base reads.

162
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File

Description

Amplicon
coverage
summary

Coverage summary data used to create the Amplicon Coverage Chart. This file contains the
following fields:

* contig id:the name of the chromosome or contig of the reference for this amplicon.
®* contig srt:the start location of the amplicon target region.
Note: This coordinate is 1-based, unlike the corresponding 0-based coordinate in the
original targets BED file.
®* contig_ end: the last base coordinate of this amplicon target region.

Note: The length of the amplicon target is given as tlen = (contig_end - contig_srt + 1).
* region_ id:the ID for this amplicon as given as the 4th column of the targets BED file.

®* gene idorattributes: the gene symbol or attributes field as provided in the targets
BED file.

* gc_count: the number of G and C bases in the target region. The %GC that is uses this
count divided by the amplicon (insert) length.

* overlaps: the number of times this target was overlapped by any read by at least one
base.
Note: Individual reads might overlap multiple amplicons where the amplicon regions
themselves overlap.

* fwd e2e:the number of assigned forward strand reads that read from one end of the
amplicon region to the other end.

* rev_e2e:the number of assigned reverse strand reads that read from one end of the
amplicon region to the other end.

* total reads: the total number of reads assigned to this amplicon. This value is the sum

of fwd_reads and rev_reads and is the field that rows of this file are ordered by (then by
contig id, srt, and end).

* fwd reads: the number of forward strand reads that are assigned to this amplicon.
* rev_reads: the number of reverse strand reads that are assigned to this amplicon.

* covNx: the number of bases of the amplicon target that had at least N reads. There are 3
such columns for the specified coverage tiers, which by default are cov20x, cov100x,
and cov500x.

Coverage
Analysis
Summary (.pdf)

A PDF file that contains the Coverage Analysis Report, including read statistics and charts that

are generated by the coverageAnalysis plugin.

molecular Coverage Analysis plugin in Genexus™ Software

Use the molecular Coverage Analysis plugin to view statistics and graphs that
describe the level of sequence molecular coverage produced for targeted genomic
regions. The plugin generates statistics, downloadable data files, and interactive
visualization of molecular coverage over targeted regions of the reference genome.

The plugin is only compatible with libraries prepared using lon AmpliSeq™ HD or Taq

Sequencing chemistries.

Genexus™ Software 6.2 User Guide 1
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The molecularCoverage Analysis plugin generates a Molecular Coverage Analysis
Report. This report includes molecule statistics and several charts. The report
summary lists the barcodes, the samples, the median molecular coverage, the
molecular uniformity, and the median reads per functional molecule, and the median
percentage of functional reads. Additional details regarding molecular coverage are
also provided on a per-barcode basis, along with a list of gene annotations for each
sequenced region.

You can download statistics files from the file links at the bottom of the results screen
when the Plugins tab is selected. After the sequencing run completes, review the
plugin results in the report summary.

1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, in the Sample Name column, click the sample of
interest.

3. Click the Plugins tab.
A summary table of the molecular coverage analysis, by barcode, is included in
the molecularCoverage Analysis summary pane, located beneath the
coverageAnalysis summary pane, if present.

4. In the molecularCoverage Analysis summary pane, in the Barcode Name
column, click a link to open a detailed Molecular Coverage Analysis Report
for that barcoded sample.

Alternatively, click the molecularCoverageAnalysis.html link to open the
summary table for all barcodes in a new window.

5. In the Molecular Coverage Analysis Report, review the plugin results.

6. Click the links at the bottom of the Molecular Coverage Analysis Report to
download associated statistics and summary files for each barcoded sample in
the run.

The detailed Molecular Coverage Analysis Report that is available when you select
a barcode in the coverageAnalysis plugin summary for a run includes a variety of
reads statistics. The statistics that are displayed in your report depend on the type of
library that is used in your sequencing experiment. Definitions are in tooltips. Almost
every statistic, plot, link, and functional widget in the report provides tooltips with
definitions. Hover over a heading or description in the report to view the tooltip.

Statistic

Description

Median Functional Molecular A functional molecule is a collection of reads that covers the amplicon and

Coverage per Amplicon

satisfies all criteria associated with the parameters (for example,

min tag fam size andmin fam per strand cov)inthe parameter
file. Molecular coverage is the number of functional molecules. The median
is calculated across all amplicons.

Uniformity of Molecular Coverage for | Percentage of amplicons having molecular coverage between 0.5x and 2x of

all Amplicons

the median molecular coverage.
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Statistic

Description

Percentage of Amplicons larger than
0.8x Median Functional Molecular
Coverage

Percentage of amplicons having molecular coverage more than 0.8x of the
median functional molecular coverage

Median Total Molecular Coverage per
Amplicon

The number of molecules that satisfies size criteria in the parameters file.
The median is calculated across all amplicons.

Percentage of Reads with Perfect
Molecular Tags

Percentage of reads whose molecular tags are exactly the same with
design.

Median Functional Molecular Loss
due to Strand Bias per Amplicon

The metric is calculated by 1- (Functional Molecular Coverage)/
(Molecular Coverage without Strand Constraint), which
measures the loss of functional molecules due to strand constraint for
molecular functionality. The median is calculated across all amplicons. This
statistic is available in lon AmpliSeq™ HD runs only.

Median Percentage of Functional
Molecules out of Total Molecules per
Amplicon

The percentage of functional molecules out of the number of molecules that
satisfies size criteria. The median is calculated across all amplicons.

Median Reads per Functional
Molecule

For each amplicon, the number of reads supporting each functional
molecule is averaged across all functional molecules for that amplicon to
determine the number of reads per functional molecule at the amplicon
level. The median is calculated across all amplicons.

Median Reads Contributed to
Functional Molecules per Amplicon

For each amplicon, the percentage of reads supporting functional molecules
is (Number of Reads Supporting Functional Molecules)/
(Number of Reads). The median is calculated across all amplicons.

Percentage of Amplicons below
(around) n% LOD

LOD is calculated based on the number of functional molecules for each
amplicon and variant calling parameters in the parameter file. Around x n%
means in the range from 0.5x n% to 2x n%.

Example
Molecular
Coverage
Analysis
Report

Genexus™ Software 6.2 User Guide

The following is an example of a Molecular Coverage Analysis Report is available
when you select a barcode in the molecular Coverage Analysis plugin summary.

Molecular Coverage Analysis Report

Sample Name:

Library type: AmpliSeq HD - DNA
Heference: hgl9 (DNA)
Target vegions:

272
2521
90.61%
99 26%
95.59%
85 BB
1.47%
268
78.80%
30.56%

Mumier of amplicens

Median functicnal maolecules per amplicon
Unifermity of amplicon molecular coverage
Arnplicons with LOD below 5%

Arnplicons with LOD below 1%

Arnplicens with LOD below 0.5%
Amplicens with LOD around 0.1%

hedian number of reads par molezula
Median molecular loss due te strand bias
Median reads to mobecular conversion rate
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Example charts The charts in the detailed Molecular Coverage Analysis Report include Plot and

generated by Overlay menus that allow you to customize the data that is displayed in each chart.
the molecular Click Q (Search) (in the top right corner of a chart) to open the chart Viewing
Covera}ge ] Options panel. Click ? (Help) to open a description of the chart.
Analysis plugin
+ Depth of Coverage Chart Plot:  Maximum Molecular Depth v J Zoom OuI) ? P
6% 100%
Amplicons
504 Cumulative Amplicons | g0 g
8 4% E
S 60%
it g
£ 0% &=
Lo =
E
1% 20% 8
0% Drres e 0%
0 500 1000 1500 2000 2500 3000 3500 4000 4500
Molecular Depth )

Figure 6 Representative Depth of Coverage Chart

The Depth of Coverage Chart summarizes the amplicon depth of coverage results. The X-axis
represents the amplicon molecular depth. The left Y-axis represents the number of amplicons at a
given molecular depth or a range (bin) of molecular depths, as a percentage of the total number of
amplicons. The right Y-axis represents the cumulative count of the number of amplicons, at a given
molecular depth or greater, as a percentage of the total number of amplicons. The individual orange
bars represent the percentage of amplicons in the specific range of molecular depths. The blue
curve measures the cumulative amplicons at a given molecular depth or greater. Use the Plot
dropdown list to switch between Maximum Read Depth, 99.9% of All Reads, and Normalized
Coverage plots.
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Figure 7 Representative Amplicon Coverage charts

The Amplicon Coverage charts summarize the amplicon molecular coverage results. The X-axis in all
plots represents amplicons that are grouped into bins, where each bin contains amplicons that have
the same molecular coverage. Depending on the plot selection, the left Y-axis represents either the
average number of molecules (on a base 10 log scale) or the percentage of functional molecules in a
given bin. The right Y-axis represents the percentage of functional reads in a given bin. Use the Plot
and Overlay dropdown lists to customize the chart view. You can zoom in on a subset of amplicons
by using your mouse to draw a rectangle that contains the region of interest. Use Zoom Out to
revert to the initial view.

@ Representative Total Molecules plot with an Perc Functional Reads overlay
@ Representative Strand Molecules plot with an Perc Functional Reads overlay
@ Representative Reads per Molecule plot with an Perc Functional Reads overlay
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Output files
generated by
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Analysis plugin
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Amplicons at molecular depths 2,350-  * Cumulative Amplicons at molecular =
2,399 depth 3.050

Number of amplicons : 7 Number of amplicons : 56

Percentage of amplicons : 2.57% Percentage of amplicons : 20.59%

Figure 8 Example detail panes

In most plots, you can click a data point to open a detail pane for that data. For example, in the
Depth of Coverage Chart in Figure 6, click an individual orange bar to open the detail pane for
amplicons in a specific range of molecular depths or click a point on the blue curve to open the
detail pane for cumulative amplicons at that molecular depth or greater. Similarly, you can click any
point or bar within each Amplicon Coverage chart to view details for each amplicon coverage bin.
For example detail panes, see Figure 8.

You can download plugin results files from the Results screen for a sample. For more
information, see “Results files” on page 89.

Note: Sometimes the file name can be too long to open in applications such as
Microsoft " Excel™. To resolve this problem, right-click the file, then click Save As to
rename the downloaded file.

The following tables describe the results files that can be generated by the molecular
CoverageAnalysis plugin. The list of files depends on the application type that was
selected during assay creation.

File download selections in the Genexus™ Software

Selection File name
DNA Molecular Coverage Statistics <DNA Barcode><ExpName>.cov.stats.txt
DNA Molecular depth of coverage <DNA Barcode><ExpName>.mol.cov.xls
DNA Molecular Coverage Analysis <DNA Barcode><ExpName>.summary.pdf
Summary
DNA Molecular Amplicon coverage <DNA Barcode><ExpName>.amplicon.cov.xls
summary
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File contents

File Description

Molecular This file contains a summary of the statistics presented in the tables at the top of the
Coverage Statistics | Molecular Coverage Analysis Report plugin report. The first line is the title. Each subsequent
line is either blank or a particular statistic title followed by a colon () and its value.

Molecular depth of | Molecular coverage summary data used to create the Depth of Coverage Chart. This file
coverage contains the following fields:

* mol depth: the depth at which a (targeted) reference amplicon has been read.
* amp_cov: the number of times any amplicon was read (covered) at this depth.
* amp_ cum_cov: the cumulative number of reads (coverage) at this read depth or greater.

* norm mol depth:the normalized read depth (depth divided by average molecular read
depth).

* pc amb cum cov:same as amp_cum_cov but represented as a percentage of the total
reads.

Molecular A PDF file that contains the Molecular Coverage Analysis Report, including molecule statistics
Coverage Analysis | and charts that are generated by the molecular Coverage Analysis plugin.
Summary
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File

Description

Molecular
Amplicon coverage
summary

Amplicon molecular coverage summary data used to create the Amplicon Coverage Chart.
This file contains the following fields:

contig id:the name of the chromosome or contig (from contiguous) of the reference
for this amplicon.

contig srt:the start location of the amplicon target region. Note that this coordinate
is 1-based, unlike the corresponding 0-based coordinate in the original targets BED file.

contig end: the last base coordinate of this amplicon target region. Note that the
length of the amplicon target is given as (contig_end - contig_srt + 1).

region_id:the ID for this amplicon as given as the 4th column of the targets BED file.

gene _1id or attributes: the gene symbol or attributes field as provided in the
targets BED file.

func_mol cov:the number of molecules (functional molecules) which are available for
the variantCaller plugin.

lod: LOD (limitation of detection) calculated from the number of functional molecules.

strict func umt rate: the percentage of functional molecules used with strict
molecular tags.

func mol cov_loss due to_ strand: the percentage of functional molecules loss
due to strand bias.

fwd only mol cov:the number of molecules containing forward strand only.
rev_only mol cov:the number of molecules containing reverse strand only.

both strands mol cov:the number of molecules containing both forward strand
and reverse strand.

r2m_conv_rate all:the percentage of reads contributed to functional molecules.
reads_per func mol: the average reads per functional molecules.

perc to mol (<3 reads):the percentage of reads contributed to small size
molecules(size<3).

perc _to mol (>=3&<30_ reads):the percentage of reads contributed to median
size molecules (size >3 && size <30).

perc to mol (>=30_ reads): the percentage of reads contributed to large size
molecules (size >30).

CustomerSupportArchive plugin

170

The CustomerSupportArchive plugin generates a downloadable archive that a
technical support representative can use to troubleshoot and diagnose issues with
sequencing runs or with Genexus™ Software. The archive contains log files and other
technical data about the software and other files from sequencing runs on a
Genexus' Integrated Sequencer.

For more information, see “Download a customer support archive” on page 198.

Genexus"™ Software 6.2 User Guide



Chapter 9 Plugins for data analysis 548

samplelD plugin

samplelD plugin

Review
samplelD
plugin results

Use the samplelD plugin to track samples or possibly identify misassignment or mix
up between samples and barcodes in a sequencing run. The samplelD plugin
produces a unique identification code (SamplelD) for each barcode in a sample.

The plugin can be used with the lon AmpliSeq™ Sample ID Panel, which is a human
SNP genotyping panel, to ensure that the accuracy of samples increase confidence
in sample data management. The lon AmpliSeq™ Sample ID Panel is composed of
the identified human sample gender and IUPAC base letters for eight high-frequency
noncoding SNPs. lon AmpliSeq™ Sample ID Panel contains nine primer pairs that can
be combined with any lon AmpliSeq™ Ready-to-Use Panel or Custom Panel.

For the samples to work with this plugin, the lon AmpliSeq™ library must have been
prepared with lon AmpliSeq™ sample tracking amplicons.

The samplelD plugin is preconfigured and does not require input.
After the sequencing run completes, review the plugin results.
1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, in the Sample Name column, click the sample of
interest.

3. Click the Plugins tab.
A summary table of the samplelD is shown.

4. Click a barcode name to open the Sample ID Report.

5. To return to Genexus™ Software, click back in the browser.
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Annotation criteria for Oncomine Variant Annotator

When you apply Oncomine™ Variant Annotations to an assay, analysis results data
from more than 24,000 exomes across solid tumor and hematological cancer types is
used as a reference to annotate variants that are relevant to cancer.

This section summarizes the requirements that must be met in order for the
Oncomine™ Variant Annotator to annotate variants in results for each Oncomine™
Research Assay and lon AmpliSeq™ HD Panel.

For each variant type in these tables, Oncomine™ Variant Annotator annotates a
variant only if all conditions in the corresponding Annotation Criteria column are
satisfied. The annotations are shown in results in the Oncomine™ Gene class and
Oncomine™ Variant class columns.

Note: You can find all relevant annotation criteria in VCF files.

Oncomine™ Precision Assay GX

Variant type

Oncomine™
Gene class

Oncomine™
Variant class

Annotation criteria

Copy number
amplification

Gain-of-Function

Amplification

e SVTYPE = "CNV"
* FILTER = "GAIN"
* Occurs in a designated copy-gain gene
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Variant type Ol On.comlne Annotation criteria
Gene class Variant class
Copy number Loss-of-Function Deletion SVTYPE = "CNV"
deletion FILTER = "LOSS"
Occurs in a designated copy-loss gene
Gene fusion Gain-of-Function Fusion SVTYPE = "Fusion"
FILTER = "PASS"
Is a targeted fusion isoform
RNA exon variant | Gain-of-Function | RNAExonVariant SVTYPE = "RNAExonVariant" or "Fusion"

FILTER = "PASS"

Is a targeted RNA exon variant

Expression Gain-of-Function | Expressionimbala SVTYPE = "RNAExonTiles"

imbalance nce FILTER = "PASS"

Missense hotspot | Gain-of-Function Hotspot Positive mutation calll

mutation Loss-of-Function Functional impact is missense
Transcript and coding syntax occur in predefined
missense hotspot list

In-frame hotspot | Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Function, transcript, and coding syntax occur in
predefined in-frame hotspot list

Gain-of-function | Gain-of-Function Hotspot Positive mutation call

truncating Function, transcript, and coding syntax occur in

hotspot mutation predefined truncating hotspot list
Occurs in a gain-of-function gene

Loss-of-function | Loss-of-Function Truncating Positive mutation call

truncating Function, transcript, and coding syntax occur in

hotspot mutation predefined truncating hotspot list
Occurs in a loss-of-function gene

Splice site Gain-of-Function Hotspot Positive mutation call

hotspot mutation Loss-of-Function Transcript, location, and exon occur in predefined
splice site hotspot list

Intronic hotspot | Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Transcript, I‘ocatic.)n, and codling syntax occur in
predefined intronic hotspot list

MNV hotspot Gain-of-Function Hotspot Positive mutation call

mutation

Loss-of-Function

Transcript and coding syntax occur in MNV hotspot
list
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Variant type

Oncomine™
Gene class

Oncomine™
Variant class

Annotation criteria

EGFR exon 19
deletion

Gain-of-Function

EGFRExon19Dele
tion

Positive Hotspot mutation call

Functional impact is nonframeshift deletion,
nonframeshift block substitution

Deletion impacts codons 744-761 of EGFR

EGFR exon 20
insertion

Gain-of-Function

EGFRExon20Inse
rtion

Positive Hotspot mutation call

Functional impact is nonframeshift insertion,
nonframeshift block substitution

Insertion impacts codons 762-775 of EGFR or
variant is COSM26720

ERBB2 exon 20
insertion

Gain-of-Function

ERBB2Exon20Ins
ertion

Positive Hotspot mutation call

Functional impact is nonframeshift insertion,
nonframeshift block substitution

Insertion impacts codons 770-783 of ERBB2

MET exon 14
skipping

Gain-of-Function

METExon14Skipp
ing

Positive Hotspot mutation call

Location is splice site in MET exon 14, is intronic >=
4bp deletion in 30 nucleotides preceding MET exon
14, or variant is in MET Exon 14 Skipping confirmed
list

Oncomine™ Comprehensive Assay v3

Variant type

Oncomine™
Gene class

Oncomine™
Variant class

Annotation criteria

Copy number
amplification

Gain-of-Function

Amplification

SVTYPE = "CNV"
FILTER = "GAIN"

Occurs in a designated copy-gain gene

Gene fusion

Gain-of-Function

Fusion

SVTYPE = "Fusion"
FILTER = "PASS"

Is a targeted fusion isoform

RNA exon variant

Gain-of-Function

RNAExonVariant

SVTYPE = "RNAExonVariant" or "Fusion"
FILTER = "PASS"

Is a targeted RNA exon variant

Loss-of-function
truncating de
novo mutation

Loss-of-Function

Truncating

Positive mutation call

Functional impact is frameshift block substitution,
frameshift deletion, frameshift insertion, or
nonsense

Occurs in a loss-of-function gene
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Variant type Oncomine On.c omine Annotation criteria
Gene class Variant class

Missense hotspot | Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Functional impact is missense
Transcript and codon position occur in predefined
missense hotspot list

In-frame hotspot | Gain-of-Function Hotspot Positive mutation calll

mutation Loss-of-Function Functic.)n, trgnscript, and codilng syntax occur in
predefined in-frame hotspot list

Splice site Gain-of-Function Hotspot Positive mutation call

hotspot mutation Loss-of-Function Transcript, location, and exon occur in predefined
splice site hotspot list

Intronic hotspot | Gain-of-Function Hostpot Positive mutation call

mutation Loss-of-Function Transcript, location, and coding syntax occur in
predefined intronic hotspot list

Promoter hotspot | Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Transcript, location, and coding syntax occur in
predefined promoter hotspot list

Gain-of-function | Gain-of-Function Hotspot Positive mutation call

truncating Function, transcript, and coding syntax occur in

hotspot mutation predefined truncating hotspot list
Occurs in a gain-of-function gene

Loss-of-function | Loss-of-Function Truncating Positive mutation call

truncating Function, transcript, and coding syntax occur in

hotspot mutation predefined truncating hotspot list
Occurs in a loss-of-function gene

MNV hotspot Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Transcript and coding syntax occur in MNV hotspot
list

EGFRexon 19 | Gain-of-Function | EGFRExon19Dele Positive mutation call

deletion tion Functional impact is nonframeshift deletion,

nonframeshift block substitution
Deletion impacts codons 744-761 of EGFR

EGFR exon 20
insertion

Gain-of-Function

EGFRExon20Inse
rtion

Positive mutation call

Functional impact is nonframeshift insertion,
nonframeshift block substitution

Insertion impacts codons 762-775 of EGFR or
variant is COSM26720
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Variant type el On.c omine Annotation criteria
Gene class Variant class

ERBB2 exon 20 | Gain-of-Function | ERBB2Exon20Ins Positive mutation call

insertion ertion Functional impact is nonframeshift insertion,
nonframeshift block substitution
Insertion impacts codons 770-783 of ERBB2

MET exon 14 Gain-of-Function | METExon14Skipp Positive mutation call

skipping ing Location is splice site in MET exon 14, is intronic >=

4bp deletion in 30 nucleotides preceding MET exon
14, or variant is in MET Exon 14 Skipping confirmed
list

System-installed annotation sets
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Genexus™ Software includes system-installed annotation sets as presets to use in
assays. System-installed annotation sets are locked and cannot be changed.

System-installed
annotation sets

Description

All_hg19_514 A system-installed annotation set for use with hg19 assays.
Oncomine™ A system-installed annotation set for use with Oncomine™
Comprehensive | Comprehensive assays.

v3 514

Annotations

Oncomine™ A system-installed annotation set for use with Oncomine™ Myleloid

Myeloid Assay
Annotations v1

assays.

Performance
Qualification
Annotations
V7-1.6

A system-installed annotation set for use with Performance
Qualification assays.
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The Genexus™ Software includes system-installed barcode sets as presets to use in
assays. System-installed barcode sets are locked and cannot be changed.

System-installed barcode set

Description

lon AmpliSeq™ HD Dual Barcode Kit 1-24

A set of 24 unique dual-barcode primers
designed and validated for optimal
performance with lon GeneStudio™ S5
Series sequencers.

For use with lon AmpliSeq™ HD assays.

lonCode™ Barcodes 1-32

A unique set of 32 barcode adapters
designed for optimal performance with lon
GeneStudio™ S5, lon PGM™, and lon
Proton™ sequencers.

lonCode™ Barcodes 1-384

A unique set of 384 barcode adapters
designed for optimal performance with lon
GeneStudio™ S5, lon PGM™, and lon
Proton™ sequencers.

lon Select BC Set-1

A unique set of 16 barcode adaptors
supplied with the lon PGM™ Select Library
Kit.

lon SingleSeq™ Barcodes

A unique set of 96 barcode adaptors
optimized for use with lon ReproSeq™
libraries.

lon Torrent™ Dual Barcode Kit 1-96

A set of 96 unique dual-matched barcode
adapters designed to enable optimal
performance of amplicon libraries and lon
semiconductor sequencers

For use with lon AmpliSeq™ HD and
Oncomine™ assays.

lon Torrent™ Genexus™ Barcodes 1-32 HD

A unique set of 32 barcode adaptors
designed and validated for optimal
performance with the Genexus™ Integrated
Sequencer

For use with lon AmpliSeq™ HD assays.

lon Torrent™ Genexus™ Barcodes 1-96 AS

A unigue set of 96 barcode adaptors
designed and validated for optimal
performance with the Genexus™ Integrated
Sequencer

lon Xpress™ Barcodes

A unique set of 96 barcode adaptors for
use with lon AmpliSeq™ libraries and lon
Xpress™ Plus fragment libraries.

Genexus™ Software 6.2 User Guide

177




Appendix A Reference information
System-installed filter chains

System-installed filter chains

Genexus™ Software includes system-installed filter chains as that are included as
presets in assays to filter in or our variants of interest in run results. The filter chains
can also be used to dynamically change the view of the variants as you view results.
System-installed filter chains are locked and cannot be changed. You cannot edit
system-installed filter chains, but you can create custom filter chains that are built
from the system-installed filter chains.

System-installed
filter chain

Description

Oncomine™
Extended (5.14)

This filter chain includes all Oncomine"-annotated variants and
variants that may be relevant to cancer due to their inclusion in one
or more of the following classes:

* Non-targeted fusions.
®* CNV variants with FILTER value of GAIN or LOSS.

¢ Likely somatic mutations based upon dbSNP, 5000Exomes,
ExAC, and UCSC Common SNPs annotation source databases.
The minor allele frequencies range lies between 0.0 and 1.0E-6.
Mutations must also be nonsynonymous and occur in exonic or
splice-site regions.

* Variants with ClinVar annotations of pathogenic or likely
pathogenic.

Oncomine™
Variants (5.14)

This filter chain includes all Oncomine™-annotated variants.

Variant Matrix
Summary (5.14)

Returns variant types in a visualization. Variant types returned are
SNV/INDEL, CNV, fusions, and RNAExonVariants.

No Filter

Select this option to remove a previously applied filter chain and view
all called variants.

System-installed filters
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Genexus™ Software includes system-installed filters that you can add to custom filter
chains. A filter chain is a set of filters that the software uses to narrow the list of
variants that are included in results. When you create a filter chain, you can
dynamically change the view of variants in results, or you can filter in or out variants
from results by adding the filter chain to an assay that is used for a sequencing run.

The system-installed filters are based on public and proprietary annotation sources
and data types that are included in the software.
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You can create filter chains that identify variants based on the annotations associated
with those variants. The software uses annotation sources from public and
proprietary genomic databases to apply these annotations to variants during
analysis.

Filters that are made from annotation sources are available in the software and you
can use these filters to build filter chains that narrow the list of variants that appear in
the analysis results.

5000Exomes filters

The 5000Exomes filters can be added to filter chains to detect minor allele
frequencies (MAF) for specific population groups in the software. The filters are
derived from the 5000Exomes annotation database. The specific filters are:

* 5000Exomes AfricanAmerican MAF(1)

¢ 5000Exomes AfricanAmerican MAF(20161108)

¢ 5000Exomes EuropeanAmerican MAF(1)

* 5000Exomes EuropeanAmerican MAF(20161108)

* 5000Exomes Global MAF(1)

* 5000Exomes Global MAF(20161108)
Filter conditions include the ability to set minor allele frequency ranges from 0.0 to
0.5. The option to include or exclude unannotated variants in filtered analysis results

is also available. The Inclusive option, to include or exclude boundary values in the
range, is selected by default and cannot be changed.

The filter returns minor allele frequency results in samples that align with the
5000Exomes minor allele frequency database.

Clinvar filter

This filter can be added to filter chains in the software to evaluate the impact of

variants observed in samples that match those in the National Center for

Biotechnology Information (NCBI) ClinVar database. The specific databases are:
e C(Clinvar(20180725)

e (Clinvar(20190909)
The impact values that can be included in the filter chain are: Pathogenic, Likely

benign, Benign, other, Likely pathogenic, Uncertain significance, not provided, and
drug response.

The filter returns all variants with the selected impact values that match those in the
NCBI ClinVar database.
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COSMIC filter

This filter can be added to filter chains in the software to compare variants to the
catalog of somatic mutations in tumor tissue as compiled by the COSMIC database.
The specific databases are:

e COSMIC(85)
e COSMIC(89)
Filter conditions include the ability to select all COSMIC values, to select specific

annotation values, and to include or exclude unannotated variants in filtered analysis
results.

The filter returns variants that match those in the COSMIC database.

dbSNP filter

This filter can be added to filter chains in the software to compare single nucleotide
polymorphism variants in samples against the dbSNP database. The specific filters
are:

¢ dbSNP(151)
o dbSNP(153)

Filter conditions include the ability to select all dbSNP values (In), or to exclude all
dbSNP values (Not In).

The filter detects SNP variants that match those in the dbSNP database, which can
be included in or excluded from filtered analysis results.

DGV filter

This filter can be added to filter chains in the software to detect human genomic
structural variants that match those in the Database of Genomic Variants (DGV). The
specific filters are:

e DGV filter(20130723)
e DGV filter(20160515)

Filter conditions include the ability to include all DGV variants (In), or to exclude all
DGV variants (Not In) in filtered analysis results.

The filter detects human genomic structural variants as defined by DGV, which can
be included in or excluded from filtered analysis results.

DrugBank filter

This filter can be added to filter chains in the software to detect variants that are
correlated with drugs and drug targets listed DrugBank database. The specific filters
are:

e DrugBank (20180731)
¢ DrugBank (20190723)
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Filter conditions include the ability to select specific values, to include all DrugBank
values (In), or to exclude all DrugBank values (Not In). In addition, unannotated
variants can be included or excluded in filtered analysis results.

This filter detects variants that are correlated with drugs and drug targets in
DrugBank, which can be included in or excluded from filtered analysis results.

ExAC filters

These filters can be added to filter chains to detect rare gene variants for specific
population groups in the software. The filters are derived from the Exome
Aggregation Consortium (ExAC) database. The specific filters are:

e EXAC AAF(01)

* EXAC EAAF(01)

* EXAC EFAF(01)

* EXAC ENFAF(01)

* EXAC GAF(01)

* EXAC LAF(01)

* EXAC OAF(01)

* EXAC SAAF(01)
Filter conditions include the ability to set a range from 0.0 to 1.0. The option to
include or exclude unannotated variants in filtered analysis results is also available.

The Inclusive option, to include or exclude boundary values in the range, is selected
by default and cannot be changed.

The filter detects rare gene variant results that align with the ExAC database, which
can be included or excluded from filtered analysis results.

FATHMM Scores filter

This filter can be added to filter chains in the software to calculate Functional
Analysis through Hidden Markov Models (FATHMM) Scores for coding variants,
nonsynonymous single-nucleotide variants (nsSNVs), and noncoding variants. The
specific filters are:

FATHMM Scores(85)
FATHMM Scores(89)

Filter conditions include the ability to set a range from 0.0 to 1.0 for the score. The
option to include or exclude unannotated variants in filtered analysis results is also
available. The Inclusive option, to include or exclude boundary values in the range, is
selected by default and cannot be changed.

The filter calculates FATHMM scores for coding variants, nsSNVs, and noncoding
variants.
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Gene Ontology (GO) filter

This filter can be added to filter chains in the software to detect various gene
ontologies (functions of specific genes). The specific filters are:

Gene Ontology (20171101)
Gene Ontology (20190930)

Filter conditions include the ability to select all (In), none (Not In), or to select specific
annotations, and to include or exclude unannotated variants in filtered analysis
results.

This filter returns gene ontologies of samples based on the selections made.

Gene Symbol filter
This filter can be added to filter chains in the software to report on specific genes.

Filter conditions include the ability to select all (In), none (Not In), or specific gene
symbols from the list, and to include or exclude unannotated variants in filtered
analysis results.

This filter returns the gene symbols of genes that are found in your samples.

Minor Allele Frequency filter

This filter can be added to filter chains in the software to detect variants with minor
allele frequencies that match those in the dbSNP database from the 1000 genomes
project.

Filter conditions include the ability to set a range from 0.0 to 0.5 for minor allele
frequencies. The option to include or exclude unannotated variants in filtered analysis
results is also available. The Inclusive option, to include or exclude boundary values
in the range, is selected by default and cannot be changed.

The filter returns variants in samples that match those in the dbSNP database from
the 1000 genomes project.

OMIM filter

This filter can be added to filter chains in the software to detect variants that match
those in the Online Mendelian Inheritance in Man® (OMIM) database. The specific
filters are:

OMIM(20180823)
OMIM(20191001)

Filter conditions include the ability to search for all (In), none (Not In), or specific
annotations, and to include or exclude unannotated variants in filtered analysis
results.

The filter returns variants in samples that match those in the OMIM database.
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Pfam filter

This filter can be added to filter chains in the software to detect protein domain
families in the coded proteins as defined by the Pfam database. The specific filters
are:

Pfam(31)
Pfam(32)

Filter conditions include the ability to include all (In), none (Not In), or specific
annotations, and to include or exclude unannotated variants in filtered analysis
results.

The filter returns variants in the samples that match the variants in the Pfam
database.

PhyloP Scores filter

This filter can be added to filter chains in the software to measure the conservation of
protein across a wide range of organisms in 16S metagenomics analyses. The
specific filters are:

PhyloP Scores(20160919)

Filter conditions include the ability to set a score range from —14.0 to 3.0. The option
to include or exclude unannotated variants in filtered analysis results is also available.
The Inclusive option, to include or exclude boundary values in the range, is selected
by default and cannot be changed.

This filter returns PyloP scores for 16S metagenomics samples.

UCSC Common SNPs filter

This filter can be added to filter chains in the software to detect variants that match
those in the UCSC Genome Browser Common SNPs database.

Filter conditions include the ability to include (In) or exclude (Not In) variants that
match the UCSC Common SNPs in filtered results.

The filter returns variants in samples that match the UCSC Common SNPs database.
You can create filter chains that are based on variant data types in the software, such

as allele frequency and allele ratio. Many data types that are included in the results
tables are available as filters.

Allele fraction filter

The Allele fraction filter can be added to filter chains in the software to report the
frequency of alleles observed in raw data.
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Filter conditions include the ability to set allele frequency ranges from 0.0 to 1.0. The
option to include or exclude unannotated variants in filtered analysis results is also
available. The Inclusive option, to include or exclude boundary values in the range, is
selected by default and cannot be changed.

The filter returns allele frequencies of alleles observed in raw data.

Allele ratio filter

This filter can be added to filter chains in the software to narrow analysis results to
nonreference allele frequencies.

Filter conditions include the ability to set allele ratio ranges from 0.0 to 1.0. The
option to include or exclude unannotated variants in filtered analysis results is also
available. The Inclusive option, to include or exclude boundary values in the range, is
selected by default and cannot be changed.

The filter returns all variants that have at least one nonreference allele reported with a
frequency in the selected filter range.

Allele read-count filter

This filter can be added to filter chains in the software to set the minimum count for
genotype alleles.

Filter conditions include the ability to set allele read-count ranges from 0 to 100,000.
The option to include or exclude unannotated variants in filtered analysis results is
also available. The Inclusive option, to include or exclude boundary values in the
range, is selected by default and cannot be changed.

The filter removes variant candidates that do not have the required numbers of
supporting reads from analysis results.

Alternate allele count filter

This filter can be added to filter chains in the software to set the minimum count for
alternate alleles.

Filter conditions include the ability to set alternate allele read-count ranges from 0 to
100,000. The option to include or exclude unannotated variants in filtered analysis
results is also available. The Inclusive option, to include or exclude boundary values
in the range, is selected by default and cannot be changed.

The filter removes variant candidates that do not have the required numbers of reads
from analysis results.
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CNV Confidence Range filter

This filter can be added to filter chains in the software to return copy number variants
(CNV) with confidence levels between 10 and 10,000,000 and other variants.

Filter conditions include the ability to set the CNV confidence range from 10 to 1.0E7.
The option to include or exclude unannotated variants in filtered analysis results is
also available. The Inclusive option, to include or exclude boundary values in the
range, is selected by default and cannot be changed.

The filter returns copy number variants with high confidence levels and other
variants.

CNV Confidence Range—CNVs Only filter

This filter can be added to filter chains in the software to return copy number variants
(CNV) with confidence levels between 10 and 10,000,000.

Filter conditions include the ability to set the CNV confidence range from 10 to 1.0E7.
The option to include or exclude unannotated variants in filtered analysis results is
also available. The Inclusive option, to include or exclude boundary values in the
range, is selected by default and cannot be changed.

The filter returns only copy number variants with high confidence levels.

CNV Somatic Confidence Range filter

This filter can be added to filter chains in the software to make ploidy estimates with
lower and upper confidence values on somatic samples. The filter detects extra
copies over the expected normal ploidy value (2 for autosomes, 2 for X
chromosomes in females, and 1 for X chromosomes in males). The 5% lower
confidence bound value is the ploidy estimate where there is a 5% chance that the
true ploidy is below that value. The 95% upper confidence bound is the ploidy
estimate where it is 95% certain that the true ploidy is below that value. The lower
bound is the most important for gains. The upper bound is most important for losses.

By default, the filter is set to detect gains and losses using the confidence interval
values of 5% confidence interval for Minimum Ploidy Gain over the expected value
and 95% confidence interval for Minimum Ploidy Loss under the expected value. The
default boundary values are set to 0.0.

If you set the Minimum Ploidy Gain (5% CI) over expected to 2.0 (2+2=4) and the
Minimum Ploidy Loss (95% CI) under expected to 0.0, you can expect the
following example CNV call Cl data:

Gene A—A gene with suspected gain of 5% CI = 4.1 and 95% CI = 10.3 filtered in.
Gene B—A gene with suspected loss of 5% CIl = 0 and 95% CI = 1.0 filtered in.

Gene C—A gene with suspected gain of 5% Cl = 2.2 and 95% CI = 3.6 filtered out
(2.2 is less than 4).

Gene D—A gene with suspected gain of 5% Cl = 2.1 and 95% CI = 5.2 filtered out
(2.1 is less than 4).
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Gene E—A gene with 5% Cl = 0.8 and 95% CI = 2.1 filtered out (0.8 is less than 4
and 2.1 is greater than 2).
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CNV Somatic Confidence—CNVs Only filter

This filter can be added to filter chains in the software to make ploidy estimates with
lower and upper confidence levels.

Filter conditions include the ability to enable and set the range for Minimum Ploidy
Gain (5% CI) over expected, to enable and set the Minimum Ploidy Loss (95% CI)
under expected ploidy values. The option to include or exclude unannotated variants
in filtered analysis results is also available. The Inclusive option, to include or
exclude boundary values in the range, is selected by default and cannot be changed.

The filter returns only somatic copy number variants within the lower and upper limits
of the set confidence ranges.

Confident Somatic Variants filter

This filter detects confident somatic variants in tumor-normal analyses. The filter
compares tumor samples to matched normal samples. It does not apply to single
sample analyses.

Filter conditions include the ability to include the confident somatic variants (In), or to
exclude the confident somatic variants (Not In) in filtered analysis results.
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Deamination filter

Default DNA and Fusions View filter

This filter can be added to filter chains in the software to detect all of the fusion
variants, expression control markers, assay 5/3' markers, and all DNA variants that
the predefined Default DNA and Fusions View filter chain detects.

Filter conditions include the ability to select specific annotations (Present or Absent),
to include all default DNA and Fusions view variants (In), or to exclude all Default
DNA and Fusions view variants (Not In) in filtered analysis results. In addition,
unannotated variants can be included or excluded in filtered analysis results.

The filter detects the fusion variants, expression control markers, assay 5/3' markers,
and all DNA variants, which can be included or excluded in filtered analysis results.

Default Fusions View filter

This filter can be added to filter chains in the software to detect all of the fusion
variants, expression control markers, and assay 5'/3' markers that the predefined
Default Fusions View filter chain detects.

Filter conditions include the ability to select specific annotations (Present or Absent),
to include all Default Fusions View variants (In), or to exclude all Default Fusions View
variants (Not In) in filter analysis results. In addition, unannotated variants can be
included or excluded in filtered analysis results.

The filter detects fusion variants, expression control markers, and assays 5/3’
markers, which can be included or excluded in filtered analysis results.

Disease Research Area (DRA) filter

This filter can be added to filter chains in the software to annotate disease research
categories as defined by the Disease Research Area (DRA) annotation source
database. The specific filters are:

¢ Disease Research Area (DRA)(20170112)

¢ Disease Research Area (DRA)(20170914)
Filter conditions include the ability to select specific annotations, to include all
Disease Research Area values (In), or to exclude all Disease Research Area values

(Not In) in filtered analysis results. In addition, unannotated variants can be included
or excluded in filtered analysis results.

This filter annotates disease research areas that match the DRA database, and can
be included or excluded.
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Expected normal ploidy buffer filter

The Expected normal ploidy buffer filter can be added to filter chains in the software
to detect mosaic chromosomal aneuploidies in research samples and to set a buffer
for normal ploidy values (2 for autosomes, 2 for X chromosomes in females, and 1 for
Xand Y chromosomes in males) so as to identify the most likely aneuploidy samples.
Ploidy calls do not have to be integers because mosaicism detection allows decimal-
level Copy Number Gain or Loss calls.

By default, the filter is set to filter out all copy number variant segments of gain or
loss within 0.2 ploidy value of expected normal. Gains must be above ploidy 2.2 and
below ploidy 1.8 to remain filtered in on autosome and female X, and ploidy 1.2 and
ploidy 0.8 on male Y. Filter conditions include the ability to change the amount of
buffer by adjusting the From and To values. This Expected Normal Ploidy Buffer
overrides any Confidence filtering that may be in effect within the buffer zone.

If default settings are applied, ploidy values of 1.8 to 2.2 are filtered out as normal for
autosomes and X chromosomes in females, and 0.8 to 1.2 are filtered out as normal
for X and Y chromosomes in males. Values outside this range are detected as
chromosomal ploidy samples.

Filtered Coverage filter

This filter can be added to filter chains in the software to review results that meet a
specific coverage threshold. By default, the filter reports all results with a coverage
threshold greater than 100. Or, you can use the filter settings to change the threshold.

Filter conditions include the ability to set a minimum and a maximum value for minor
allele frequency for the coverage threshold. Ranges from 0.0 to 0.0045 can be
selected for the minimum in the From field and in the To field for the maximum. The
option to include or exclude unannotated variants in filtered analysis results is also
available. The Inclusive option, to include or exclude boundary values in the range, is
selected by default and cannot be changed.

Functional Scores filter

This filter can be added to filter chains in the software to provide functional scores
based on SIFT, PolyPhen, and Grantham scores. SIFT and PolyPhen scores are
predictions of the functional effect of a variant on a protein. A Grantham score
attempts to predict the distance between two amino acids, in an evolutionary sense
(lower is less distance, higher is greater distance).

Filter conditions include the ability to include or exclude SIFT, PolyPhen, and
Gratham scores, and to set ranges for those scores. SIFT and PolyPhen ranges can
be set from 0.0 to 1.0, and Grantham can be set from 0.0 to 215.0. The option to
include or exclude unannotated variants in filtered analysis results is also available.
The Inclusive option, to include or exclude boundary values in the range, is selected
by default and cannot be changed.

The filter returns a functional score based on the three (or fewer) scores.
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Fusion Read Counts filter

This filter can be added to filter chains in the software to produce counts for fusion
reads.

Filter conditions include the ability to set a minimum count of 0 or higher, to include
the boundary value for the count, and to include or exclude unannotated variants in
filtered analysis results.

This filter returns results that meet the fusion read minimum count value.

Genomic Coordinates filter

This filter can be added to filter chains in the software to narrow analysis results to
specific genomic regions. The filter can also be used to identify regions that are
targeted by an amplicon or amplicons in a user-defined assay.

The filter value is one chromosome region, or multiple regions that are separated by
OR operators or commas.

The Genomic Coordinates filter returns variants in samples that are in the range for
the genomic coordinates that you set.

IMPORTANT! Do not use AND, OR, or NOT when adding values to the Genomic
Coordinates filter.

Homopolymer Length filter
This filter can be used in a filter chain in the software to detect INDELs of specific
homopolymer lengths.

Filter conditions include the ability to set a range from 0 to 1,000 for homopolymer
length. The option to include or exclude unannotated variants in filtered analysis
results is also available. The Inclusive option, to include or exclude boundary values
in the range, is selected by default and cannot be changed.

This filter returns INDEL variants in samples that meet the specified homopolymer
length.

Hotspot filter

This filter can be added to filter chains in the software to detect variants that overlap
specific hotspots.

Filter conditions include the ability to include (In) or exclude (Not In) hotspots as
defined by a hotspots file in filtered analysis results.

The filter returns variants that overlap hotspots included in an uploaded hotspots file.
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Location filter

This filter can be added to filter chains in the software to detect variants in specific
positions, such as exonic.

Filter conditions include the ability to select all locations or specific locations in
filtered analysis results. Locations include:

* unknown * splicesite_3
® intergenic ® upstream

* intronic * downstream
® exonic ® exonic_nc

* utr 5 ® intronic_nc
* utr_3 * ncRNA

* splicesite_5 * nonCoding

The filter returns variants in samples that match the selected filter locations.

Named Variants filter

This filter can be added to filter chains in the software to detect known variants in the
lon AmpliSeq™ Community Panel for the cystic fibrosis transmembrane regulator
(CFTR) gene, for example: ¢.2054delA.

Filter conditions include the ability to select all named variants, to select specific
named variants, and to include or exclude unannotated variants in filtered analysis
results.

The filter returns variants in samples that match the CFTR variants that are specified
in the filter.

Minimum Limit of Detection at Genomic Location filter

The Minimum Limit of Detection at Genomic Location filter can be added to filter
chains to filter for a minimum limit of detection (LOD) at chromosomal locations
within a selected range.

This LOD calculation depends on the depth of coverage at a given chromosomal
location and the probability that is defined by min_callable_prob parameter.

This filter is for use with lon AmpliSeq analysis results and analysis workflows only.
For more information, see “Parameters step assay options” on page 105.

Filter conditions include the ability to set a minimum and a maximum value for minor
allele frequency. Ranges from 0.0 to 0.0045 can be selected for the minimum in the
From field and in the To field for the maximum. The option to include or exclude
unannotated variants in filtered analysis results is also available. The Inclusive
option, to include or exclude boundary values in the range, is selected by default and
cannot be changed.
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Oncomine™ filter

This filter is the default filter for most Oncomine™ assays. It presents the user with
Oncomine™ driver variants that are based on their Oncomine™ Gene Class and
Oncomine™ Variant Class annotations. It can be added to filter chains in the software
to detect Oncomine™-annotated variants in specific Oncomine™ panels.

Analysis workflows for Oncomine™ assays and analysis workflow templates for lon
AmpliSeq™ HD panels in lon Reporter™ Software include the Oncomine™ Variant
Annotator plugin. The plugin integrates into analysis results data from more than
24,000 exomes across solid tumor and hematological cancer types, and annotates
variants relevant to cancer with Oncomine™ Gene class and Oncomine™ Variant class
information. For more information and a full list of annotation rules for each
Oncomine™ assay, see “Annotation criteria for Oncomine™ Variant Annotator” on
page 172, or contact your local support representative, Field Bioinformatics
Specialist (FBS), or Clinical Account Consultant (CAC).

The Oncomine™ filter (Oncomine = In) returns variants in the samples that have
Oncomine™ Gene class and Oncomine™ Variant class annotation.

This filter can be used only if an Oncomine™ analysis workflow was used for the
analysis. You can apply filter chains that include the Oncomine™ filter only if the
analysis workflow that was used for the analysis includes the Oncomine™ Variant
Annotator plugin. Examples of filter chains that include this filter are the Oncomine™
Variants and Oncomine™ Extended filter chains.

Possible Polyploidy Alleles filter

The Possible Polyploidy Alleles filter can be added to filter chains to detect searches
alleles which have passed all variant calling filters used by the Torrent Variant Caller
(TVC) module but missed by genotype.

The Possible Polyploidy Alleles filter is useful for identification of variants beyond
diploid genomes, that is, cancer cells or polyploidy species.

Filter conditions include the ability to select YES to find alleles that have passed all
filters, NO, to find alleles that have not passed all filters in addition to genotype, or
both YES and NO.

PValue filter

This filter can be added to filter chains in the software to determine the p-value of
variants. The p-value is a statistical method for the detection of variant calls from
next-generation sequencers.

Filter conditions include the ability to set a range from 0.0 to 1.0. The option to
include or exclude unannotated variants in filtered analysis results is also available.
The Inclusive option, to include or exclude boundary values in the range, is selected
by default and cannot be changed.

The filter returns p-values for variants calls in the samples.
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Variant Classification filter

This filter can be added to filter chains in the software to narrow results to the

following user-set variant classifications:

Unclassified

Unknown

Benign

Suspected Benign
Likely Benign
Suspected Deleterious
Deleterious
Pathogenic

Likely Pathogenic
VUS

Uncertain Significance
Technical Artifact

Filter conditions include the ability to include all (Filter Option set to In), none (Filter
Option set to Not In), or to select specific classifications in filtered analysis results.

The filter returns variants that are classified by software users.

Variant Effect filter

This filter can be added to filter chains in the software to detect the effect of variants

on coding sequences. Specific values include:

refAllele

unknown

synonymous
missense
nonframeshiftinsertion
nonframeshiftDeletion
nonframshiftBlockSubstitution
nonsense

stoploss
frameshiftinsertion
frameshiftDeletion

frameshiftBlockSubstitution

Filter conditions include the ability to select all (Filter Option set to In), none (Filter
Option set to Not In), or to select specific values, and to include or exclude

unannotated variants in filtered analysis results.

The filter returns variants in samples that match the selected variant effects.
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Variant Subtype filter
This filter can be added to filter chains in the software to detect variant subtypes,
including:

¢ BigDel

* BigDup

¢ GeneCNV

* REF

e NOCALL

Filter conditions include the ability to select all or specific variant subtypes in filtered
analysis results.

The filter returns variants that match the selected specific variant subtypes.

Variant Type filter
This filter can be added to filter chains in the software to detect variants that match
the following variant types:
e SNV
e [INDEL
e MNV
* REF
e NOCALL
e CNV
e LONGDEL
e FUSION
e EXPR_CONTROL
e ASSAYS_5P_3P
* RNA_HOTSPOT
* GENE_EXPRESSION
* RNAExonVariant
* ProcControl
e FLT3ITD

Note: The FLT3ITD variant type is detected only in Oncomine™ Myeloid Assay
analysis workflows.

Filter conditions include the ability to select all variant types or specific variant types
in filtered analysis results.

The filter returns variants in analyses that match the selected specific variant types.
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Zygosity filter

This filter can be added to filter chains in the software to detect variants that are

homozygous or heterozygous.

Filter conditions include the ability to search for both homozygous and heterozygous
variants, or either of them, in filtered analysis results.

The filter returns variants in analyses that are homozygous or heterozygous.

System-installed plugins

The Genexus™ Software includes system-installed plugins to use in runs. System-
installed plugins are locked and cannot be changed.

System-installed plugin

Description

coverageAnalysis

This plugin provides statistics and graphs
that describe the level of sequence
coverage that is produced for targeted
genomic regions.

CustomerSupportArchive

This plugin generates a downloadable
archive that a technical support
representative can use to troubleshoot and
diagnose issues with sequencing runs or
with Genexus™ Software. The archive
contains log files and other technical data
about the software and other files from
sequencing runs on a Genexus" Integrated
Sequencer.

For more information, see “Download a
customer support archive” on page 198.

molecular Coverage Analysis

This plugin provides statics and graphs
that describe the level of sequence
molecular coverage that is produced for
targeted genomic regions.

System-installed genome reference files

The Genexus™ Software includes system-installed genome reference files as presets
to use in assays. System-installed genome reference files are locked and cannot be

changed.

System-installed genome
reference file

Description

hg19

Human genome reference.
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System-installed sample attributes

The following table lists and describes system-installed sample attributes. System-
installed sample attributes cannot be edited. Custom sample attributes are not listed
in this table.

Sample attribute

Description

Sample Namel'l

A unique identifier representing the sample.

The sample name can contain only alphanumeric characters (0-9, Aa-Zz), full stops/periods
(-), underscores (_), or hyphens (-), cannot contain spaces, and is limited to a maximum of
20 characters.

IMPORTANT! To prevent erroneous sample selection during run planning, make sure that
you assign a unique and distinguishable sample name for each sample.

Note:
. Samples that have been used in a run cannot be deleted.

. To prevent duplication, the software checks all sample names and returns an error
message if a non-unique sample name is detected.

Collection Date

The date that the sample was collected.

Click = Calendar to select the date in the correct format.

Gender The biological sex of the sample: Female, Male, or Unknown.
IMPORTANT! Male or Female must be selected for proper measurement of AR CNV.
Sample Type A term that describes the sample, for example, RNA. You can also select Other, then enter a

custom sample type.

Disease Category

The disease type of the sample.

Note: If you select Cancer in this list, the Cancer Stage, Cancer Type, % Cellularity, and
% Necrosis attributes listed below become available in the Add New Sample dialog box.

Cancer Stage

The stage of the cancer from which the sample was collected.

Select Stage 0-1V, or Primary, Unknown, or Other.

Cancer Type

The type of cancer that is represented by the sample.

Select the type of solid or hematologic cancer. If cancer type is unknown, select Unknown
Primary Origin.

% Cellularity

The percentage of tumor cells over normal cells in the sample. This is a whole number
between 1 and 100. The % Cellularity attribute is applicable to FFPE samples only.

IMPORTANT!
. If not set, % Cellularity is assumed to be 100% in calculations that use this attribute.

. % Cellularity is a required attribute for CNV analyses. Do not leave the field blank.
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Sample attribute Description
% Necrosis The percentage of cellular necrosis in the sample. This is a whole number between
1 and 100.
Notes An open-entry field for any additional sample information.
' Required attribute

System-installed verification templates

Field Service Engineers use the system-installed verification templates during
Genexus'" Integrated Sequencer installation.

IMPORTANT! The Assays / Verification Templates screen lists the verification
templates that are used only by service engineers during Genexus™ Integrated
Sequencer installation and performance qualification testing. These templates should
not be used or modified in any way.

Details about each verification template is available when you click the name of the
template in the software.

* Performance Qualification Assay

¢ System Install Qualification Assay
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Download Instrument Diagnostics . ... 197
Customer Support Archive (CSA) . ..o e 198
Troubleshoot Genexus™ Software ..............ccoveiiiiiieinnennn.n. 198

Download Instrument Diagnostics

You can download diagnostic files for troubleshooting purposes. Instrument
diagnostic files include:

* Diagnostic archive file (ZIP format)
* |Init.log file (a text file)
* |nstallation Acceptance Report (PDF format)

1. In the menu bar, click (&3 (Settings) » Services.

2. Scroll to the bottom of the screen.

3. In the Download Instrument Diagnostics section, in the Select Instrument
dropdown menu, select the instrument.

4. Click Download.
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Customer Support Archive (CSA)

You can download an archive that a Technical Support representative can use to
diagnose Genexus™ Software issues. The Customer Support Archive (CSA) contains
log files and other technical data about your Genexus™ Software and other files from
sequencing runs on a Genexus' Integrated Sequencer.

You can access customer support archive files from the Results / Sample Results
and the Results / Run Results screens.

Download a
customer
support
archive 1

2.

Customer support archives are available to download from the Results / Run

Results, Results / Sample Results, and from the --- (More Options) dropdown list
in the Sample Summary Results screens.

In the menu bar, click Results » Run Results.

In the Run Name row of the run result for which you want to download the
customer support archive, in the Actions column, click CSA.

An XZ compressed TAR archive (TZV) file is downloaded to the directory location that
you specified to download files from the browser. This location depends on your
browser settings. You can attach this archive to an email to send to Customer
Support.

Troubleshoot Genexus' Software

Observation

Possible cause

Recommended action

Cannot sign in to the Genexus™
Software

You have either forgotten your
password or are signed out due
to several failed login attempts.

Contact the Genexus™ Software system
administrator.

Batch sample import fails

One or more entries in the
sample-import spreadsheet
contains special characters,
lines breaks, unexpected
spaces, incorrect entry length,
incorrect date formatting, or
other formatting errors.

Check each entry for correct formatting, correct
any errors, and repeat the import.

Blank rows were copied into the
sample-import template file from
a different source.

Rows that appear empty can contain hidden
formatting that conflicts with the import function.
Start with a clean sample-import template file,
and be careful to copy only those rows that
contain actual data.

The sample import spreadsheet
contains a nonunique sample
name.

Every sample name in the software must be
unique. Ensure that the spreadsheet does not
contain any duplicate sample names, and repeat
the import. Note that the system check is not
case-sensitive, so a sample name of ABC1
conflicts with abc1.
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Observation

Possible cause

Recommended action

Batch sample import fails
(continued)

The headings in the sample
import spreadsheet do not
match the sample attributes in
the software.

The headings must match the sample attributes
in the software exactly. Check the headings for
spelling or other errors.

Library batch import fails

One or more entries in the library
batch import spreadsheet
contains special characters,
lines breaks, unexpected
spaces, incorrect entry length,
incorrect date formatting, or
other formatting errors.

Check each entry for correct formatting, correct
any errors, and repeat the import.

Blank rows were copied into the
library batch import template file
from a different source.

Rows that appear empty can contain hidden
formatting that conflicts with the import function.
Start with a clean library batch import template
file, and be careful to copy only those rows that
contain actual data.

The library batch import
spreadsheet contains a
nonunique Library Batch ID.

Every Library Batch ID in the software must be
unique. Ensure that the spreadsheet does not
contain any duplicate IDs, and repeat the
import. Note that the system check is not case-
sensitive, so a Library Batch ID of ABC1
conflicts with abc1.

A sample name entered in the
library batch import spreadsheet
does not match a sample name
listed in the Manage Samples
screen.

Ensure that the sample names entered into the
spreadsheet are correct and match an existing
sample name added to the software.

The Barcode ID name format
does not exactly match the
format that is used in the
Prepare Library Batch dialog
box.

Use the name format following the Barcode ID
name format found in the Barcode Set reference
lists (Settings » References » Barcode Set), for
example: lonDual_0101 through lonDual_0196,
or lonHDdual_0101 to lonHDdual_0132.

An invalid library, control, or
panel kit barcode has been
entered in the spreadsheet.

Ensure that you have correctly entered a valid kit
barcode in the appropriate cell of the
spreadsheet.

The assay | created does not
appear in the menu when | plan
arun

Forgot to lock your assay.

Go to Assay tab » Manage Assays and make
sure that the assay is locked.

Cannot upload my panel or
hotspots

Issues with BED file format or
files do not end in (.bed).

Ensure your file is in the correct BED format and
has a (.bed) extension.
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Observation

Possible cause

Recommended action

Variants tab is missing hotspot
entries.

The remaining entries are
present.

Hotspot BED file contains
entries that are incorrectly
formatted.

Check that BED file entry is correctly formatted.
See the following examples:

SNP entry: chr1 2337276 2337277 SVA_322 0
+ REF=C;0OBS=T,ANCHOR=G AMPL

Deletion entry: chr1 201341175 201341180
SVA_497 0 + REF=AGAAG;0BS=;ANCHOR=C
AMPL

Insertion entry: chr1 236978992 236978992
SVA_621 0 + REF=;0BS=TCTG;ANCHOR=T
AMPL

Confirm the REF values match the actual
reference coordinate of hg19.

No information for my loci of
interest in the results

The wrong hotspot or BED file is
associated with the assay.

1. Check the hotspot and BED files
associated with the assay. If either is
incorrect, create a new assay.

2. Plan a new run for the sample or sample
library with the correct assay.

3. Repeat sequencing of the sample or
sample library.

Cannot download run result files

The run failed. Links to run files
are not available for runs that fail
QC.

Create a reanalysis assay with reduced QC
parameters, then reanalyze your sample.

Repeat the run.
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Documentation and support

Related documentation

cs_lon Reporter_pub

Document Publication number
Genexus'" Integrated Sequencer User Guide MANO0017910
Genexus™ Integrated Sequencer Quick Reference MAN0017912
Genexus™ Integrated Sequencer Site Preparation Guide MANO017918
lon Reporter™ Software 5.12 User Guide MANO0018031
Oncomine™ Precision Assay GX User Guide MANO0018508
Oncomine™ Comprehensive Assay v3 GX User Guide MANO0018512
Oncomine™ TCR Beta4.R Assay GX User Guide MAN0018513

Customer and technical support

Visit thermofisher.com/support for the latest service and support information.
* Worldwide contact telephone numbers
* Product support information
- Product FAQs
- Software, patches, and updates

— Training for many applications and instruments

Order and web support

Product documentation
— User guides, manuals, and protocols
— Certificates of Analysis
— Safety Data Sheets (SDSs; also known as MSDSs)

Note: For SDSs for reagents and chemicals from other manufacturers,
contact the manufacturer.
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Limited product warranty

Life Technologies Corporation and/or its affiliate(s) warrant their products as set forth
in the Life Technologies' General Terms and Conditions of Sale at
www.thermofisher.com/us/en/home/global/terms-and-conditions.html. If you
have any questions, please contact Life Technologies at www.thermofisher.com/

support.
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Glossary

Genexus Software definitions

adapter dimer
(ISPs)

aligned read
length

aligned reads

AQ score

average base
coverage depth

average base
read depth

BAM file

barcode

ISPs that carry DNA insert length of less than 8 bp.

The aligned length of a read at a given accuracy threshold is defined as the greatest
position in the read at which the accuracy in the bases up to and including the
position meets the accuracy threshold. For example, the AQ17 length of a read is the
greatest length at which the read error rate is 2% or less. The "perfect" length is the
longest perfectly aligned segment. For all of these calculations, the alignment is
constrained to start from position 1 in the read —that is, no 5’ clipping is allowed.

The number of bases covered by reads aligned to the reference sequence.

An alignment quality (AQ) score defines read accuracy when compared to the
reference sequence. The discrepancy can be biological (real variant) or technical
(sequencing error). For example, an AQ score of 17 represents 2% aligned read error
rate, while an AQ score of 20 represents 1% aligned read error rate when compared
to the reference sequence.

The average number of reads of all targeted reference bases.

The average number of reads of all targeted reference bases that were read at least
once.

A BAM (binary alignment map) file (. bam ) is the binary version of a SAM (sequence
alignment map) file. A SAM file (.sam) is a tab-delimited text file that contains
sequence alignment data. A BAM file contains aligned reads sorted by reference
location.

A barcode is a machine-readable code in the form of numbers and a pattern of
parallel lines of varying widths, printed on and identifying a product.

There are several applications for barcodes. Libraries can be molecularly barcoded
with unique nucleic acid sequence identifiers. Library barcodes are used during data
analysis to sort the sequencing results from sequencing reactions that contain
combined libraries. Chips and sample tubes also contain unique numeric barcodes
that aid in the setup of the experimental analysis workflow.
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base calling

basecalling input
file

bead loading
bp
cellularity (%)

BED file
CNV

contig

control
sequence

CSV file

DAT file
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Base calling is the process by which raw data from the sequencing instrument is
converted to nucleotide sequences. This is performed by base calling software that is
usually run from the instrument itself.

Signal processing input files are converted to a single condensed basecalling input
file that represents the processed signal. Basecalling input files are required files for
basecalling.

The percentage of chip wells that contain live ISPs. The percentage value considers
only potentially addressable wells. Bead loading is calculated as number of loaded
ISPs divided by the number of potentially addressable wells.

Abbreviation for "base pair(s)".
The percentage of tumor cells in a given sample.
Browser Extensible Data file—BED file—defines chromosome positions or regions.

Copy number variation (CNV) is the variation in copy number of any given gene
between two samples. CNV is a phenomenon in which sections of the genome are
repeated and the number of repeats in the genome varies between individuals in the
human population.

A contig (from contiguous) is a set of overlapping DNA segments that together
represent a consensus region of DNA.

Control nucleic acid sequences can be added to DNA or RNA samples to facilitate
post-sequencing data analysis. Two types of control sequences can be used during
sample preparation. ERCC RNA Spike-In Mix is used with RNA samples to achieve a
standard measure for data comparison across gene expression experiments. lon
AmpliSeq™ Sample ID Panel, comprised of nine specially designed primers, can be
added prior to template amplification to generate a unique ID for each sample during
post-sequencing analysis.

A comma-separated values (CSV) file is a delimited text file in which each line
represents a data record with information fields separated by a comma. A CSV file
stores tabular data (numbers and text) in plain text. Each line of the file is a data
record.

CSV files are easily opened using spreadsheet software, such as Microsoft™ Excel ™
or Apache® OpenOffice ™ Calc, where each comma-separated field is listed in a
separate column.

A DAT file is a generic data file. It contains data that may be opened or referenced by
a specific application. While some DAT files can be opened directly, most contain
program data that is referenced the program when it is running. Therefore, most DAT
files are not meant to be opened manually.
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empty wells

enrichment (%)

FASTA file

FASTQ file

FD (flow
disruptiveness)

final library reads

flow

flow order

flow transfer

fusions
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Wells on a chip that do not contain an ISP.

Predicted number of live ISPs that have a key signal identical to the library key signal.
The percent enrichment value reported is the number of loaded ISPs that are library
ISPs, after taking out the test fragment ISPs.

A FASTA file is a text-based format for representing either nucleotide sequences or
peptide sequences, in which base pairs or amino acids are represented using single-
letter codes. A sequence in FASTA format begins with a single-line description,
followed by lines of sequence data.

A FASTQ file is a text-based format for storing both a biological sequence (usually
nucleotide sequence) and its corresponding quality scores. Both the sequence letter
and quality score are each encoded with a single ASCII character for brevity.

A data filtering parameter that is used instead of INDEL, SNP, and MNP.

Number (and percentage) of reads, passing all filters that are recorded in the
unmapped BAM file. This value may be different from the total number of reads
located in the Library Summary Section due to specifications associated with read
trimming beyond a minimal requirement resulting in total number of reads being
slightly less than Final Library Reads.

A flow is the event of exposing a chip to one particular dNTP ( deoxyribonucleotide
triphosphate), followed by a washing step.

The order in which a chip is exposed to each particular dNTP. The default Samba
flow order consists of a 32-base sequence, repeated. This flow order resists phase
errors by providing opportunities for out-of phase molecules to catch up and is
designed to sample all dimer (nucleotide pair) sequences efficiently. Samba is the
default flow order because it improves sequencing accuracy for longer reads by
resisting phase errors.

Progress of the sequencing run expressed as number of total flows completed. For
example, a sequencing run set to 500 flows shows 250/500 flows in the status
column of the Runs in Progress table when the sequencing run is half completed.

A target technique used for detection and annotation of gene fusions (or
translocation of genetic material) in samples.
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hotspots file

1A

INDEL
intermediate
files

ISPs

key signal
library ISPs
LIMS metadata

live ISP

low quality ISP
library key

MAPD

mapped reads
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A BED or a VCF file that defines regions in the gene that typically contain variants.
Specifying a hotspots file to use in a run enables Torrent Variant Caller to identify if a
specific variant is present or absent. A hotspot file instructs the Torrent Variant Caller
to include these positions in its output files, including evidence for a variant and the
filtering thresholds that disqualified a variant candidate. A hotspot file affects only the
variantCaller plugin, not other parts of the analysis pipeline. If you don't specify a
hotspots file, the software tells only the difference between your sequence and the
reference genome.

Isothermal application (IA) is a template preparation technique that uses nonemulsion
isothermal reaction to clonally amplify DNA onto an ISP surface.

INDEL is an abbreviation used to designate an insertion or deletion of bases in the
genome of an organism.

Intermediate files contain information used for debugging runs.

lon Sphere™ Particles (ISPs) are particles that contain bound copies of a single
(ideally) DNA fragment amplified during template preparation.

Average 1-mer signal in the library key.

Live ISPs that have a key signal identical to the library key signal.

Laboratory Information Management System (LIMS) software is used for recording
sequencing metadata. Entered text is associated with the Planned Run and can be
extracted using APIs for LIMS consumption.

An ISP with a signal of sufficient strength and composition to be associated with the
library or test fragment key.

An ISP with a low or unrecognizable signal.

A short known sequence of bases used to distinguish a library fragment from
a test fragment (for example, "TCAG").

Acronym for median absolute pairwise difference. Assuming that adjacent amplicons
in the genome most likely have the same underlying copy number in a sample, the
difference between the log2(read count ratio) values against the reference baseline
for all adjacent amplicons contains information for the noise level of the data. The
median of the absolute values of all such difference in log2(read count ratio) is the
measure for how informative the results fare for copy number estimates.

Sequencing reads that have been mapped to the reference sequence.
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mean raw
accuracy

MNP

on target reads

Planned Run

Planned Run

template

polyclonal ISP

primer dimer

primer dimer
ISP

read length

read

reference library

relationship
group

SAM file

sample
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Average raw accuracy of 1-mers at a specific position in the read.

Multiple nucleotide polymorphism (MNP) is a genetic mutation in an allele that differs
from the reference allele of the same length by >1 nucleotide.

Sequencing reads mapped to any target region of the reference. A read is considered
to be on target if at least one aligned base overlaps a target region. A read that
overlaps a targeted region but where only flanking sequence is aligned, for example,
due to poor matching of 5’ bases of the read, is not counted.

A Planned Run is a file that contains executable instructions for individual runs. The
file contains all the specifications, settings, and parameters for template preparation
and chip loading on the lon Chef™ Instrument, and sequencing on an lon S5™/lon
S5™ XL or lon GeneStudio™ S5 Series system.

A reusable experimental design (digital protocol) for the sequencing instrument that
holds specifications for sample preparation, sequencing, data export, and post-
sequencing data analysis.

An ISP that carries clones from two or more library sequences.

A primer dimer (PD) is a potential by-product in PCR, a common biotechnological
method. As its name implies, a PD consists of primer molecules that have attached
(hybridized) to each other because of strings of complementary bases in the primers

An ISP that carries an insert length of less than 8 base pairs.

The length of called reads measured in base pairs.

The sequence of a section of a unique fragment obtained after the end of the
sequencing process.

A consensus nucleotide sequence that represents the genome of a particular
species. The results from a sequencing run are compared to the reference library to
identify sequence variants.

Defines related samples within a Sample Set. Related samples are designated by the
same relationship group number.

A SAM (Sequence Alignment Map) file is a tab-delimited text file that contains
sequence alignment data. It stores biological sequences aligned to a reference
sequence.

Genetic material from one source (for example, DNA from one individual).
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Signal processing input files consist of the raw voltage measurement data collected
during the sequencing run. These files are required to reanalyze the run from signal
processing.

Single nucleotide polymorphism (SNP) is a genetic mutation in an allele that differs
from the reference allele of the same length by one nucleotide.

SSH, also known as Secure Shell or Secure Socket Shell, is a network protocol that
gives users, particularly system administrators, a secure way to access a computer
over an unsecured network. SSH also refers to the suite of utilities that implement the
SSH protocol.

Genetic mutations that cause a change in the organism's chromosome structure,
such as insertions, deletions, copy number variations, duplications, inversions, and
translocations.

System signal-to-noise ratio.

Summary statistics for targeted base reads of the reference. A base covered by
multiple target regions is counted only once per sequencing read.

A BED file that specifies all of the regions that a panel represents such as the
amplified regions that are used with target sequencing. The complete software
analysis pipeline, including plugins, is restricted to only these specified regions
instead of analyzing the entire reference library.

A test fragment (TF) is a known nucleotide sequence that is used to monitor system
characteristics.

Live ISPs with a key signal that is identical to the test fragment key signal.

A test fragment key (TF key) is the nucleotide sequence that is used to identify test
fragment reads.

Signal strength of the first three bases of the TF key.

Total number of filtered and trimmed reads independent of length reported in the
output BAM file.

A tab-separated values (TSV) file is a tab-delimited file that is used with spreadsheet
software. TSV files are essentially text files, and the raw data can be viewed by text
editors, though they are often used when moving raw data between spreadsheets.
See also VCF file
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uBAM file A uBAM file is a variant form of the BAM file format in which the read data does not
contain mapping information. This is basically an "off-label" use of the BAM format
(which was specifically designed to contain mapping information) that is used for
data management reasons. It allows you to attach metadata to the reads from as
early on in the analysis process as possible.

unaligned reads Nucleotide bases covered by reads that are not aligned to the reference.

uniformity of The percentage of bases in all targeted regions (or whole genome) covered by at
base coverage least 0.2X the average base coverage depth.

usable Usable reads consist of library ISPs that pass the polyclonal, low quality, and primer
sequence / dimer filter.
usable reads

\VCF file A variant call format (VCF) file specifies a variant of interest and its location. This file
stores only the differences between the BAM file and the reference file.

wells with 1SPs Number of wells that were determined to be positive for the presence of an ISP
within the well. Wells containing ISPs have a delayed pH change due to the presence
of an ISP slowing the detection of the pH change from the solution.

XLS file Microsoft™ Excel™ format of a VCF file.
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