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Software overview

lon Torrent™ Genexus™ Software supports the lon Torrent™ Genexus™ Integrated Sequencer workflow
for research use purposes from sample preparation through library preparation, template preparation,
and sequencing. During and after sequencing, the software generates base calls, trims reads, and
determines quality values (primary analysis), then aligns reads, calls variants, and generates reports
(secondary analysis). The software also supports the lon Torrent™ Genexus™ Purification System for
nucleic acid isolation, followed by sequencing on the Genexus™ Integrated Sequencer.
This documentation provides instructions for using the software to perform the following functions:

* (Create and manage samples, libraries, assays, and runs in the software.

* Monitor the status of runs on the Genexus™ Purification System and the Genexus™ Integrated
Sequencer, which provides all-in-one library preparation, chip loading, template preparation, and
sequencing.

* \View data, results, and quality control (QC) reports after a run.
* Download data files.
* Export and print audit records.

¢ Create and manage annotation sets, genome references, report templates, baseline files, primer
sets, plugins, and reference files.

* (Create and manage user accounts.

Software compatibility and requirements

The procedures in this guide are designed for use with Genexus™ Software 6.8 or later. Version-specific
information is provided in the software release notes for each version of the software. An administrator-
level user can view the software version in the & (Settings) / Software Updates screen.

Genexus™ Software is supported on Google Chrome™ browser version 90 and later and is best
viewed with 1440 x 900 screen resolution. Google Chrome™ browser is recommended for use with
the software.

The operating system of the sequencer is Ubuntu™ 18.04.1 LTS.

Genexus™ Software 6.8 User Guide 13



¥ Chapter 1 Introduction to Genexus™ Software
Network and password security requirements

Software anomalies

For Genexus™ Software anomalies, see the release notes for your version of the software. You can also
download the release notes, as well as the Genexus™ Software 6.8 User Guide (Pub. No. MAN0026409),
at http://www.thermofisher.com/ngssoftwaresupport.

Network and password security requirements

Network configuration and security

The network configuration and security settings (for example, firewalls, antivirus software, network
passwords) of your laboratory or facility are the sole responsibility of your facility administrators and
IT and security personnel. Genexus™ Software does not provide any network or security configuration
files, utilities, or instructions.

If external or network drives are connected to the sequencer, it is the responsibility of your IT personnel
to ensure that such drives are configured and secured correctly to prevent data corruption or loss.

If a LIMS connection is set up, you can use the LIMS API to get the list of files generated for the assay.
For more information, see “LIMS introduction” on page 360.

Note: If a LIMS system is configured to retrieve files from the sequencer, you have the option to
manually set up an FTP directory or drive mapping. This configuration is not provided as part of
sequencer installation, and must be set up by your LIMS system integration or IT group.

Password security

Best practice is to maintain unique passwords for all accounts in use in Genexus™ Software. All
passwords must be reset the first time a user signs into the software. Change passwords according to
your organization's password policy.

It is the sole responsibility of your IT personnel to develop and enforce secure use of passwords.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the

United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

Installation and verification run

IMPORTANT! The Genexus™ Integrated Sequencer and the Genexus™ Software provides the option to
perform a performance qualification verification run.

Notifications are sent when the PQ run is expired. Contact your Field Support Engineer (FSE) or
Technical Support if you have questions about an expired PQ status.

14 Genexus™ Software 6.8 User Guide
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5 Chapter 2 Get started with Genexus™ Software
About Genexus™ Software

About Genexus™ Software

Genexus™ Software provides menus to help you add, select, and manage samples, libraries, runs, and
assays. You can also view and manage sequencing results, monitor Genexus™ Integrated Sequencer
runs in progress, and manage software settings.

S s

Genexus | lon Torrent Dashboard Samples Runs Results Assays Jii L

Filter Samples by... = TP Manage Tags  + Create Sample
Selected Samples:1 D Clear  ¢F Edit [ Copy [ Delete [ Export P AssignTags  + Prepare Library Batch

= Sample Name T Tags T CreatedOn  + T Application Category T Cancer Stage T Sample Type

2021-05-13 11:05 Cancer Primary Cerebrospinal Fluid {CSF)

2021-05-1311:05 Cancer Primary Cerebrospinal Fluid {CSF)

2021-05-1311:05 Cancer Primary Cerebrospinal Fluid {CSF)

@ Dashboard—View recent run history, and current purification or sequencing run status.
@ Samples—Add new samples, import samples, prepare library batches, import library batches and manage attributes.
@ Runs—Plan a run starting from a sample, a nucleic acid sample, a BAM sample, or a library. View, edit, and manage runs.

Sample to result runs are for nucleic acid isolation on a Genexus™ Purification Instrument followed by sequencing on a
Genexus™ Integrated Sequencer.

@ Results —View sample results, run results, and verification results.

@ Assays —Manage, create, and import assays. Manage assay preset parameters and panels.

@ Notifications —Receive alerts and messages for password expiration, system critical service failures, system backup failures,
available software updates, and full disk space.

@ Settings—Access audit records and run logs, configure network settings, manage backup settings, restore runs, manage
gene lists, link to Connect user accounts and lon Reporter™ Software accounts, check for software updates, and manage data
archiving, disk space, and users. Field Service Engineers access verification templates during sequencer installation.

Profile—Access the Help system, manage and edit user profile settings, configure an SSH key (system administrator only),
and sign out.
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Chapter 2 Get started with Genexus™ Software =18
User-access levels
Access the End User License Agreement (EULA)

A link to the End User License Agreement (EULA) is located at the bottom of the screen.

1. Scroll to the bottom of the screen.

2. Click the EULA link to open a PDF file of the EULA.

Contact Support

You can access Genexus™ Software technical support from the software.

1. Scroll to the bottom of the screen.

2. Click Support to open https://www.thermofisher.com/contactus, where you can request help
and technical support.

User-access levels

Users at this level Can perform these actions

Report * Access the Sample Results and Run Results screens to view results
* Generate, view, and sign variant reports

* Send notifications

* Download results files

* View and edit notes for the sample result

* View the audit trail for sample results

* \iew notifications

Operator Report functions, plus:

* Add, import, and export sample files

* Edit sample files

* Prepare library batches

* Plan, save, audit, and delete runs

® Monitor runs

* View results and reports

* Upload sample results files to lon Reporter™ Software

* View the audit trail for samples, library batches, runs, and assays
® Reanalyze runs and run plugins
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(continued)

Users at this level Can perform these actions

Manager Operator functions, plus:
* Create, edit, and obsolete sample attributes
* Create and import assays

* Create presets for annotation sets, filter chains, copy number baselines,
sequence variant baselines, exon tile assay baselines, and report templates

* Edit and delete sample files

* Add or edit Thermo Fisher accounts

* Manage gene lists

* Restart a stalled or failed run

* Manage reference sequences and panel, hotspot, and other sequence files

® Access services information

Administrator Operator and manager functions, plus:

* View, export, and print audit records

* Configure network settings

* View and manage software updates

¢ Install and manage plugins

* Configure backup settings and restore runs
* Manage sequencer and software log files

* Add and manage user accounts

System tracking

The system tracks and checks auditable user activities for samples, assays, QC metrics and information
related to reagents.

If the software detects an error at any step—for example, a scanned barcode is inconsistent with the
information given for the run—the software alerts the user and does not proceed with the run.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

Reagent management

Put in place a reagent management system to inventory and track reagent use.

Proper use of a reagent management system ensures optimal use of kits, chips, and reagents.
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View notifications

View notifications

You can view notifications for files that you upload and import in Genexus™ Software.

1. In the menu bar, click @ (Notifications).

If you have any unread notifications, the number of unread notifications is shown to the upper right
of the notification button.

2. View the list of notifications in the dialog box that appears.

3. To delete a natification, click X (Remove) in the section of the notification.

Request and sign in to a new user account

Operator-level users must request a new user account from the manager- or administrator-level user
before they can sign in to Genexus™ Software.

Administrator-level users receive the request and create the user account.

Your user name and password must be unique and not shared with other users.

* To request a new account, contact your administrator-level user.

After the administrator creates a new account, the software sends an email to the new user with a
user name and temporary password.

* To sign in to a new account for the first time:

a.

Obtain your user name and temporary password that is supplied by your administrator in an
email message.

Browse to the Genexus™ Software sign in page (for example, https://<your server address>)
enter your user name and the temporary password supplied by your administrator.

Press Enter, or click Sign In.

. In the End User License Agreement that appears at first sign on, read the agreement, then

click Accept.

In the Change Password screen, enter your temporary password supplied by your
administrator.

Type a new password, confirm the password, then click Change.

Passwords must be between 8 and 80 characters.

Passwords must contain only alphanumeric characters (numbers 0 to 9 and letters A to Z),
no spaces or special characters.

Passwords must contain at least one alphabetic character (a-z, A-Z).
Passwords must contain at least one numeric character (0-9).
Passwords are case-sensitive.
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Sign in

Genexus™ Software opens to the Dashboard screen.

Sign in

Before you can sign in to Genexus™ Software, you must have a registered account. For more
information, see “Request and sign in to a new user account” on page 19.

1. Go to the Genexus™ Software sign in page.

2. Click Switch Language, then select the preferred language from the dropdown list that appears, if
desired.

3. Enter your user name and password, then press Enter or click Sign In.

Note: If a message appears that indicates that there is a problem with the security token, refresh
the browser and enter the user name and password again.

The software opens to the Dashboard screen.

Edit a user profile

After your user profile has been established, you can view user profile information, change a password,
or change email contact information.

1. In the menu bar, click & (Profile) » My Profile.

2. In the Profile screen, view the profile information.

To Do this

Change a password 1. Click Change Password.

2. In the Change Password dialog box, enter the current password and
a new password. Confirm the password, then click Change.

Change an email address | 1 Click Change Emiail.

2. In the Set Email dialog box, enter a new email address, and a
password, then click Save.

Edit security questions

1. Click Edit Security questions and answers.
and answers

2. In the Edit Security questions and answers dialog box, select a
security question from the dropdown list, then enter an answer.

3. Enter the password for the account that is associated with the profile.
4. Click Submit.

The changes are applied immediately. After the password is changed, you must sign in with the new
password.
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Genexus™ Software concepts

The following terms are frequently used in Genexus™ Software.

e

"<
Genexus™ Software concepts

For more definitions, see “Genexus™ Software definitions” on page 433.

Term or concept

Description

Example

Sample

The information that describes the
material from a single source. Each
sample is defined by a set of attributes,
which are categories of information
that describe important aspects of
each sample, such as date of sample
collection, gender, or a sample type.

In the software, a sample can be isolated
nucleic acid or a sample can be a
specimen that requires integrated nucleic
acid purification before sequencing.

Data from a biopsy or blood draw.

Sample name

A unique identifier for a particular sample.

Sample1

Assay A collection of settings and parameters Oncomine™ Precision Assay GX
for library preparation, templating,
sequencing, and sequencing data
analysis.

Library A sample associated with an assay, DNA from a non-small cell lung cancer
including barcode information and sample | specimen that is sequenced with the
input quantity. Libraries are associated Oncomine™ Precision Assay GX.
with an assay during library batch
creation.

Library batch A collection of libraries that are prepared | A library batch that consists of one library

and sequenced in the same run under
the same conditions on the Genexus™
Integrated Sequencer.

of sample DNA and another library of
sample RNA (from the same sample).

Library batch ID

A unique identifier for a library batch.

DNA_B1_Lib123456_Samples123

Workflows

Type of workflow

More information

Sample to Result

“Sample to Result workflow” on page 22

Library to Result

Nucleic Acid to Result

“Nucleic Acid to Result or Library to Result
workflow” on page 24

BAM to Result

“Bam to Result workflow” on page 26

Genexus™ Software 6.8 User Guide
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Sample to Result workflow

This is a workflow for a Sample to Result purification and sequencing run using the Genexus™
Purification Instrument and the Genexus™ Integrated Sequencer.

Sample to Result workflow

Create and manage assays (page 215)

System-installed assays that are specifically configured for each sample type
are available in Genexus™ Software. You can use the system-installed assays in
a run without change. To modify any assay settings, copy the system-installed
assay that best represents the experiment, then edit the assay settings if
needed.

Enter and manage samples and library batches
(page 27)
Enter samples in Genexus™ Software to assign sample names and provide g

other information such as sample collection date, gender, type, and application
category.

Plan a Sample to Result run (page 66)

Runs created in Genexus™ Software contain the settings that are used in
purification, library preparation, templating, sequencing, and analysis, including
sample information and plate location, assays, and barcodes.

Prepare samples and load the instrument
Load reagents on to the instrument for purification of DNA, then start the run.

For more information the Genexus™ Furification System User Guide
MANO0018475.

Review samples (page 71)
You can review samples before sequencing.

Load the sequencer and start a run (see user guide for
the instrument or assay)

Follow the step-by-step instructions in the sequencer touch screen to load the
sample plate and consumables in the Genexus™ Integrated Sequencer.

a) U Gl
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Sample to Result workflow

Monitor the run (page 88)

Monitor the run in Genexus™ Software in real time.

Review results (page 94) » E X

Review data and results in Genexus™ Software.

You can also analyze data in lon Reporter™ Software using an lon Reporter™
analysis workflow.
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Nucleic Acid to Result or Library to Result workflow

This is a workflow for a Nucleic Acid to Result purification and sequencing run or a Library to
Result purification and sequencing run using the Genexus™ Purification Instrument and the Genexus™
Integrated Sequencer.

Nucleic Acid to Result or Library to Result workflow

Create and manage assays (page 215)

System-installed assays that are specifically configured for each sample type
are available in Genexus™ Software. You can use the system-installed assays in
a run without change. To modify any assay settings, copy the system-installed
assay that best represents the experiment, then edit the assay settings if
needed.

Enter and manage samples and library batches
(page 27)
Enter samples in Genexus™ Software to assign sample names and provide

other information such as sample collection date, gender, type, and application A
category.

Plan a Nucleic Acid to Result run (page 72) or Plan a
Library to Result run (page 76)

Runs created in Genexus™ Software contain the settings that are used in
library preparation, templating, sequencing, and analysis, including sample
information and plate location, assays, and barcodes.

Dilute samples and load the sample plate (see the
instrument or assay user guide)
Quantify and dilute the nucleic acid samples, then load the sample plate.

Load the sequencer and start a run (see the
instrument or assay user guide)

Follow the step-by-step instructions in the sequencer touch screen to load the
sample plate and consumables in the Genexus™ Integrated Sequencer.

al "~
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Nucleic Acid to Result or Library to Result workflow

Monitor the run (page 88)
S R

Monitor the run in Genexus™ Software in real time.

Review results (page 94)
Review data and results in Genexus™ Software.
You can also analyze data with an analysis worklow in lon Reporter™ Software.
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Bam to Result workflow

This is a workflow for a Bam to Result sequencing run using the Genexus™ Integrated Sequencer.

Bam to Result workflow

Create and manage assays (page 215)

System-installed assays that are specifically configured for each sample type
is available in Genexus™ Software. You can use the system-installed assays in
a run without change. To modify any assay settings, copy the system-installed
assay that best represents the experiment, then edit the assay settings if
needed.

Upload a BAM file to create a sample (page 35)

Enter samples in Genexus™ Software to assign sample names and provide
other information such as sample collection date, gender, type, and application A
category.

Plan a BAM to Result run (page 80)

Plan a BAM to Result run, then save and launch it in Genexus™ Software. Runs
created in the software contain the settings that are used for the analysis of
BAM samples.

Review results (page 94)
S R

Review data and results in Genexus™ Software or analyze data with an analysis
workflow in lon Reporter™ Software.
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Before you plan a run in Genexus™ Software, you must first enter sample information in the software to
assign sample names and provide other information.

From the Samples menu, you can add samples in three ways. You can enter sample information for
individual samples, you can import sample information from a file to create multiple samples, or you can
upload a BAM file to create samples.

About samples and library batches

In Genexus™ Software, the data and attributes that characterize genomic data are called samples. A
sample can be isolated nucleic acid, a specimen that requires nucleic acid isolation, or the sequencing
data that are created from a BAM file that contains sample reads. Before you can plan a run to
sequence or analyze a sample, you must add the information that characterizes each sample in the
software.

A library batch is a group of samples that are sequenced in a Library to Result run. You can create
library batches from samples you have previously added or uploaded to the software. During library
batch preparation, you identify the barcode adapters that were used to prepare the libraries. After you
create a library batch, you can plan and start a run to sequence and analyze the samples in the library.

Enter and manage samples

There are two types of samples in Genexus™ Software.

Sample Description

Sample A sample of isolated nucleic acid that is ready for library preparation, sequencing, and
analysis or a specimen sample that requires nucleic acid isolation on a connected
integrated purification system before sequencing.

BAM sample A sample created from a BAM file that contains sample reads. BAM samples can be
uploaded and analyzed by the software. BAM samples are denoted with BAM after the
sample name in the list of samples.
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You can add samples to the software in three ways.
* Enter information for a single sample or multiple samples into the software.
* Create a file of information for a group of samples and import that file.
* Enter information and import a BAM or BAM files for a single sample or multiple samples.

The name of the sample that you create in the software cannot be NTC, Control Sample, or Positive
Control.

If you enter the information for samples in the software, you can select from system-installed sample
attributes that are available in the software. For more information, see “Create a new sample” on
page 33 and “System-installed sample attributes” on page 424.

System-installed and custom sample attributes are also available in the example file that you can use

for importing samples. See “Download a template file for sample creation” on page 38 for more
information.

Samples are listed in the Manage Samples screen. For more information, see “Manage samples” on
page 49 and “Customize the samples table” on page 28.

Customize the samples table

The samples table is organized into columns of sample attributes. You can customize the table with
table preferences to determine which columns appear. When you save the table customizations, the
changes you make are saved only for your user profile.

1. In the menu bar, click Samples » Manage Samples.

2. Click Columns.

* Select the checkbox next to each attribute you would like to display.

* Deselect the checkbox next to each attribute you would like to remove from the table.

3. Scroll to the bottom of the list.

¢ Click Save to save your new selections. Your selections persist when you reopen the table.
¢ Click Restore default to restore the table to the default column settings.

Find samples

28

You can sort, search, and filter information to refine and narrow the samples that are listed in the
Samples / Manage Samples screen in Genexus™ Software. The sort, search, and filter tools help you
organize samples and find a samples of interest.

For information to search for a sample by a unique identifier, such as the sample name, see “Search for
samples” on page 29.

For information to filter samples by a common trait, such as the date the sample was created, see
“Filter the list of samples by the date of sample creation” on page 31.

Genexus™ Software 6.8 User Guide



Chapter 3 Samples and library batches ~ [208
Enter and manage samples

Search for samples

Samples are listed in the Samples / Manage Samples screen in Genexus™ Software. The most
recently created sample is at the top of the list.

You can search for samples with keywords or text that are included in the sample names, tags, or by
the application category for the sample.

IMPORTANT! Search terms must adhere to the following rules.

. An asterisk (*) is not allowed in the search field for use as a wildcard.

. Searches are case-insensitive, that is, both upper-case and lower-cases letters are found regardless
the case of search term letters.

. Searches find every occurrence of a continuous string. For example, a search for demo in analysis
names returns a list of all analysis with a name that includes demo. For example, demo1, demo2,
and so on.

. Spaces are removed during searches, and therefore are not recommended. For example, a search for
demo 1 would return results only for data that includes the string demo1.

1. In the menu bar, click Samples » Manage Samples.
2. In the Manage Samples screen, in the column heading of interest, click Y (Filter).

3. In the search field, enter a full or partial name or ID of at least 3 characters.
When you have entered at least 3 characters, the filter dialog box limits the list in the filter dialog
box based on the entry.

4. In the filter dialog box, select from the limited list.

* Select a checkbox next to the name or ID to select one or more items.
* C(Click Select All to select all of the items listed in the filter dialog box.
* C(Click Clear to close the filter dialog box.

5. Click Filter.
In the column heading, j§ changes color to indicate that a filter is applied.

The filtered list of samples is shown in the Manage Samples screen.

Click {x] Clear Filters to remove all filters and view the full list of samples.
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Sort the list of samples
You can sort the list of samples to make it easier to find a sample in Genexus™ Software.

By default, samples are listed in the Samples / Manage Samples screen by the date that the sample
was created. The most recently created sample is at the top of the list.

You can change the order that the samples are listed in the table.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, click a column heading of interest.
The list of samples is sorted by the sample attribute, in alphabetical or chronological order of the
attribute, depending on the heading.

3. Click the column heading again to reverse the order.
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Filter the list of samples by the date of sample creation

You can apply filters to narrow search results, or shorten the list of samples when you view the list of

samples in Genexus™ Software.

In addition to the filter tools in the column headings, you can also filter the list of samples with a
dropdown list and search by the sample name or other column headings. For more information, see
“Refine the list of samples” on page 32 and “Search for samples” on page 29.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, select one or more filters.

Option Description

List only samples created on | 1 | the Created On column heading, click Y (Filter).

an exact date. i )
2. In the first dropdown list, select Is equal to.
3. In the calendar that appears, select the date of interest.
4. Click Filter.

(';istt samples created withina| 4 | the Created On column heading, click Y (Filter).

ate range.
9 2. In the first dropdown list, select Is after or equal to.

3. In the calendar that appears, select the earliest date that the
samples of interest were created.

In the Boolean operator dropdown list, select And.
5. In the second dropdown list, select Is before or equal to.

In the calendar that appears, select the latest date that the
samples of interest were created.

7. Click Filter.

Records are listed for samples created on dates that meet both
conditions.

List samples according to
a date that meets either
one condition or a second
condition.

In the Created On column heading, click Y (Filter).
2. In the first dropdown list, select Is after or equal to.

3. In the calendar that appears, select the earliest date that the
samples of interest were created.

In the Boolean operator dropdown list, select Or.
5. In the second dropdown list, select Is before or equal to.

In the calendar that appears, select the latest date that the
samples of interest were created.

7. Click Filter.

Records are listed for samples created on dates that meet at least one
of the conditions.
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Option Description
List only samples that were | { |, the Created On column heading, click Y (Filter).
created before a date that i )
o 2. In the first dropdown list, select Is before or equal to.

you indicate.
3. In the calendar that appears, select the date of interest.
4. Click Filter.

List only samples that were | { |, the Created On column heading, click Y (Filter).

created after a date that you . .

indicate. 2. In the first dropdown list, select Is after or equal to.
3. In the calendar that appears, select the date of interest.
4. Click Filter.

Remove all selections and In the filter dialog box, click Clear.

close the filter dialog box.

3. In the filter dialog box, click Filter to apply the filtered selections.
In the column heading, changes color to indicate that a filter is applied.

The list of samples is filtered according to the selections.

Click {x] Clear Filters to remove all filters and view the full list of samples.

Refine the list of samples

You can shorten the list of samples that are shown in Genexus™ Software.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, in the Filter Samples by dropdown list, select the type of sample
you want to view.

Option Description

List only the samples that have not been prepared as a library. | Select To Be Prepared.

List samples created from BAM files. Select BAM Samples.

List all samples. Select All.

Only the selected type of samples are listed.
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Create a new sample

You can enter information individually for each sample that you add in the software. Complete this
procedure to make a sample available for use in a run, or to add the sample to a library batch. If you

have many samples to add, see instead “Create multiple samples” on page 33 and “Import samples”
on page 34.

1. In the menu bar, click Samples » Create Sample.

2. In the Samples/Create Sample screen, enter a name for the sample, select an Application
Category, then complete the required fields, and optional fields if needed.

* In the Tags field, enter a full or partial tag name of at least 3 characters, then select one or
more tags of interest to assign a tag to the sample.

¢ [f the tag that you want to assign to the sample does not exist in the software, a manager-or
administrator-level user can enter a new tag name in the Tags field to create a new tag and
assign it to the sample.

The fields for sample attributes change based on the Application Category. Attributes identified
with a red asterisk (*) are required.

If you select Other as the Sample Type, you must enter a name for the custom sample type in the
text box that is shown. For example, enter Nasopharyngeal Swab.

Sample Type *

Other v s Nasopharyngeal Swab +/

3. Click Save.
The new sample is listed in the Manage Samples screen and is available to use in a run plan.

Create multiple samples

There are two ways you can create multiple new samples in Genexus™ Software.
* You can enter sample information for multiple samples in a table format in the software.

* You can import a file that contains sample data. For more information, see instead “Import
samples” on page 34.

1. In the menu bar, click Samples » Create Sample.
2. In the Create Sample screen, click the Multiple (.xls, .csv, .tsv) tab.

3. In Application Category, select the application category for the samples.
A table with columns that are specific for the selected application category appears.
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4. (Optional) Click Columns in the upper right corner of the screen to customize the optional
attributes for the samples that you want to create.

* Select the checkbox for a sample attribute to add a column to the table. Click the row to view
fields into which you can enter attribute information.

* Deselect the checkbox for a sample attribute to remove the attribute from the table.

5. Enter the information for a sample.
Attributes identified with a red asterisk (*) are required.

6. Click Add Row, then enter the information in the new row for each new sample.
7. Repeat step 6 for each new sample.

8. Select the checkbox in the row for each sample in the list that you want to create. To select all
samples, select the checkbox in the column heading row.

IMPORTANT! The information for samples that are not selected is not retained by the software.
Ensure that you select the checkbox for every sample that you will create.

9. Click Save.
The new samples are listed in the Manage Samples screen and are available to use in a run plan.

Import samples

34

You can enter sample information for multiple samples directly in Genexus™ Software. When you want
to create more than a few samples, an easy and fast way to add multiple samples in the software is to
create a file of information for a group of samples and import that file.

Sample data files can be used to capture, manage, and edit sample data. You can import sample data
files in TSV, XLS, XLSX, or CSV file formats. For a list of the sample attributes that are included in the
import file, see “System-installed sample attributes” on page 424. For ease of use, you can download a
Microsoft™ Excel™ template file to create an import file.

You must create custom attributes before importing sample and run information for the attributes to

be propagated through to output files. All attributes that are included in the file that you use to import
samples must be either system-installed attributes or custom attributes that exist in the software. Other
file content is not transferred with the sample.

You can use a file to import sample information into the software. You can create the file, or use a file
that is exported from external LIMS software. Before you import a file from LIMS software, you must
first map the sample attribute names that are named differently in the LIMS file to the attribute used

in Genexus™ Software. For more information, see “Map a sample attribute (manager/administrator)” on
page 43.

1. In the menu bar, click Samples » Create Sample.
2. In the Create Sample screen, click the Multiple (.xls, .csv, .tsv) tab.

3. In the Application Category dropdown list, select the application category for the samples.

Tip: Use the search field to search for the application category of interest.
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4. Set up a sample file using one of two options.

Option Description

Download a template For more information, see “Download a template file for sample creation” on
file, then edit it to page 38. Upload the edited file using the Browse button.
create a new file.

Note: When you select Other as the Application Category, you must enter
text in the Application Category text box, then click anywhere in the screen
in order for the template file to be available.

Upload the sample 1. Click Browse.
data from an existing , ! .
file. 2. Navigate to the file, then click Open.

The data contained in the file populates the table in the screen.

5. In the sample file, edit the sample table and data, if needed.

Option Description

Remove an attribute column. Click Columns, then deselect the column name.

Add an attribute column to the Click Columns, then select the column name. The column names
table. that are listed are Application Category-specific.

Edit sample data. Click the sample row of interest, then edit the text field or
dropdown list for the sample.

Add more samples to the table. Click Add Row, then enter the sample data.

Remove a sample from the table. | Select the checkbox for the row, then click Remove Row.

6. Select the checkbox in the row for each sample to create. To select all samples, select the
checkbox in the column heading row.

IMPORTANT! The information for samples that are not selected is not retained by the software.
Ensure that you select the checkbox for every sample you intend to create.

7. Click Save.
You can place the pointer over (¥) (alert) to view more information if needed.

The new samples are listed in the Manage Samples screen and are available to assign to a run plan.

Upload a BAM file to create a sample or samples

You can upload BAM files to create samples in Genexus™ Software. You can also redefine existing BAM
files as new samples. That is, you can upload a BAM file and create a new sample name for the BAM
file and enter the same or different values for the sample attributes that are associated with the BAM
file.

If the BAM file is not on the Genexus™ Integrated Sequencer, you can upload a BAM file from the
computer that is used to access Genexus™ Software. You can upload the BAM file directly from the
computer or from a USB drive connected to the computer.
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BAM files can be analyzed in the software. For more information, see “Plan a BAM to Result run” on
page 80.

1. In the menu bar, click Samples » Create Sample.
2. In the Create Sample screen, click the From Sequence Files (.bam) tab.
3. In Application Category, select the application category for the samples.

4. Click Browse, then navigate to the file.

Option Description

Find the file on the instrument. Click Server, then navigate to the file.

Find the file on the computer used | Click & My Computer, then in the Browse dialog box that
to access the software. appears, navigate to the file.

5. Navigate to the file, then click Select.

The file is now available to select and assign to a sample. The BAM file name is visible in the
dropdown lists in the DNA BAM File, RNA BAM File, and TNA BAM File columns.

6. Enter the information for the sample.
Attributes identified with a red asterisk (*) are required.

7. In one or more of the DNA BAM File, RNA BAM File, and TNA BAM File dropdown lists for the
sample, select the BAM file that you want to assign to the sample.

8. To add more samples, click Add Row.
9. Repeat step 4 to step 8 for each extra BAM sample you want to create.

10. Select the checkbox in the row for each sample that you want to create. To select all samples,
select the checkbox in the column heading row.

11. Click Save.

The new samples are listed in the Manage Samples screen, are denoted with BAM after the sample
name, and are available to assign to a BAM to Result run plan.
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View sample summary

You can view a summary of the details for the attributes of a sample. The sample summary lists the
information for sample attributes for the sample and the date the sample was created in the software.
For a list of the information that is shown in the sample summary, see “Sample summary” on page 37.

For more information about sample attributes, see “System-installed sample attributes” on page 424.

To view the sample summary:

1. In the menu bar, click Samples » Manage Samples.

2. In the Sample Name column, click the sample name of interest.
Details for the sample are shown in the sample summary pane.

3. When you are finished viewing the sample details, click another sample name to view details for
another sample, or click X (Close) to return to the Manage Samples screen.

If needed, you can click --- (More Options) to perform more actions, such as copy, edit, assign

tags, add notes, or audit the sample. The options that are available depend on whether the sample is
assigned to a run plan. The actions for each sample are also available in the Manage Samples screen
when you place the pointer over the row of a sample.

Sample summary

You can view details for its attributes when you select a single sample that is listed in the
Samples/Manage Samples screen in Genexus™ Software. The sample summary lists details that
describe sample attributes, such as gender and the date that the sample was created in the software.

Notes for a sample are not shown in the sample summary pane. For more information, see “View notes
or add a note to a sample” on page 51.

The sample attributes that are shown in the sample summary pane depend on the application category
for the sample. The following table lists the system-installed sample attributes for a sample that has an
application category of cancer. Custom sample attributes are also shown in the sample summary pane,
but are not listed in the following table.

Sample attribute Description
Sample Name A unique identifier representing the sample.
Collection Date The date that the sample was collected.
Created On The date the sample was imported or created in the software.
Application Category The application type of the sample.
Cancer Type The type of cancer that is represented by the sample.
Sample Type A term that describes the sample, for example, RNA.
Gender The biological sex of the sample: Female, Male, or Unknown.
%Cellularity The percentage of tumor cells over normal cells in the sample. The %Cellularity
attribute is applicable to FFPE samples only.
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Sample attribute

Description

%Necrosis

The percentage of cellular necrosis in the sample.

Cancer Stage

The stage of the cancer from which the sample was collected.

Stage 0-1V, or Primary, Unknown, or Other.

BAM File Path The path and file name for the BAM files associated with the sample. Files are listed
for samples created only from BAM files.
This information is available only for BAM samples.

Metadata The data for the BAM sample is shown. Metadata can include the device ID and the

type of instrument that generated the BAM file. Other information, such as the assay,
analysis pipeline version, chip type, chip ID, sequencing kit, library kit, templating kit,
and name of the run results from the BAM file source instrument are shown.

This information is available only for BAM samples.

Download a template file for sample creation

You can download a template file, add sample information to it, then use the file to import the sample
data for multiple samples.

Template files contain two tabs. The Instruction tab in the spreadsheet lists and indicates required and
optional attributes, which are the column headings in the Sample Details tab. Use the Sample Details
tab to enter sample information.

Template files contain both the system-installed and the custom sample attributes as column headings.

—

In the menu bar,

click Samples » Create Sample.

2. In the Create Sample screen, click the Multiple (.xls, .csv, .tsv) tab.

3. In Application Category, select the application category for the samples.

Template files are specific for each application category.

4. Click Download Template to download the Microsoft™ Excel™ template file.

The template file contains default sample attributes as columns. If custom sample attributes have
been configured in the software, the custom attributes are added to the template file.

5. Save the file to the computer, then open the file, enter sample data in the Sample Details tab.

6. When you are finished adding sample information to the file, save the file.

You can now import the file to Genexus™ Software. For more information, see “Import samples” on

page 34.
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Sample attributes (manager/administrator)

Samples contain attributes that are relevant to genetic research. For example, attributes can include
sample information such as gender, a tumor, the nucleic acid type such as DNA, RNA or cfTNA, or a
sample type such as Blood, Urine, or Swab. In Genexus™ Software, manager- and administrator-level
users can add custom attributes and add or change values of those attributes. For more information,
see “Create a new sample” on page 33, “Create multiple samples” on page 33, “Import samples” on
page 34, and “Edit a sample” on page 51.

Custom and predefined sample attributes can be viewed in the Samples table. Each column in the
Samples table represents a single sample attribute.

For more information, see:
* “System-installed sample attributes” on page 424
* “Create a custom sample attribute (manager/administrator)” on page 39

Create a custom sample attribute (manager/administrator)

A manager- or administrator-level user can create custom sample attributes. Sample attributes, such as
the date of collection and Application Category, characterize and define a purification sample, nucleic
acid sample, or a sample from a BAM file. A sample attribute can be required, in which case you

are required to enter the attribute information for each new sample. Custom attributes can be used to
further characterize samples.

Sample attributes can be assigned to an application category, such as cancer or infectious disease,
because some attributes are not applicable to all application categories. The default application
category for new custom attributes is ALL, which means that the custom attribute is available for all
samples. When you restrict custom attributes to one or more application types, the field for the custom
attribute is only visible for samples for the application types that you designate.

Custom samples attributes cannot be edited or obsoleted after the samples that use the attributes are
added to a library. To remove a custom sample attribute from use, see “Obsolete a sample attribute
(manager/administrator)” on page 42.

Genexus™ Software supports following types of sample data:
* Text—Accepted values: general text.
* Date—Accepted values: provides a calendar tool to select a date.
* Integer—Accepted values: integer numbers. Examples: 0, 9, —44.
* Decimal—Accepted values: decimal numbers Examples: 0.1, 9.0, —-44.3.
¢ List—Creates a list of these choices that you define with the preset terms.

* Boolean—Creates a list of these two choices: True, False.

1. In the menu bar, click Samples » Manage Attributes.
2. In the Manage Attributes screen, click + Add New Attribute.

3. In the Add New Attribute dialog box, in Attribute Name, enter a name for the attribute.

Attribute names are limited to <50 alphanumeric characters (0-9 and Aa-Zz), period (.), underscore
(), or hyphen (-).
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4. In Application Category, select an applicable application category or application categories to
change the application category from All.

The default setting All makes the attribute available for all samples when you create new samples
and when you edit existing samples. You can refine the availability of the attribute to selected
application categories when you select an application category.

5. In Data Type, specify the data type to create.

6. Click the toggle switch to designate the attribute as Required to require users to select the new
attribute when adding or importing samples, if needed.

7. Click the toggle switch to designate the attribute as Unique, if needed.

When enabled, the Unique setting allows you to require a unique attribute value for samples. For
example, you can create a unique attribute called Sample number. Then, when each new sample
is created, you enter a unique number for each sample in the custom Sample number attribute
field.

8. For List and Boolean data types, complete the following options.

Data type Steps

List 1. In Vocabulary List, enter a list of values separated by commas, then click Add.

The first option that you enter is designated as the default option.

2. Change the default option, if needed.
Deselect Use default if you want the new attribute to be shown without a default
preset.
Select a different option to change the value that is shown as the default option.
Click Ti] (Delete) to remove an attribute list value.

Boolean |Select True or False to designate one option as the default value for the attribute.

9. Click Save.
The new sample attribute is listed in the Attribute Name column and is available when you add a
new sample.

You can now add information for the custom sample attribute to samples when you create new
samples. In addition, you can enter information for the attribute to existing samples that were created
before the custom attribute was created. For more information, see “Enter and manage samples” on
page 27 and “Edit a sample” on page 51.

Example custom attribute

When you create a custom attribute, you can add metadata pertinent to that attribute when you create
or edit samples in the software. Attributes that are created with the List data type allow you to restrict
the information to a list of terms.

This example shows the creation of the options High and Low for a custom attribute of Grade for
Cancer samples. Low is set as the default value in this example. Consider the convenience and
consequences of assigning a default value to any custom attribute. Unless the default value is changed
during sample creation, all samples will be associated with the default value.
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After the new attribute has been saved, it is available for sample creation in the software. When you
create a new cancer sample in this example, Low appears as the default Grade value. You can select
High from the Grade dropdown list to change the value.
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Edit a custom sample attribute (manager/administrator)

A manager- or administrator-level user can edit custom sample attributes. Some attribute values, such
the Attribute name, Data Type, and whether or not the attribute is required, cannot be edited.

Custom attributes created in Genexus™ Software version 6.2 are set to All application categories. If
desired, you can edit the custom attributes to associate the application categories with the applicable
applications.

1. In the menu bar, click Samples » Manage Attributes.

2. In the Manage Attributes table, place the pointer over the row of a custom sample attribute that
you want to change, then click Edit.

3. In the Edit Attribute dialog box:

Option Description
Add an application category or In Application Category, select the checkbox for the
categories to the sample attribute application category.
Remove an application category or In Application Category, deselect the checkbox for the
categories from the sample attribute | application category.
Add a new option for List type of 1. In the Vocabulary List text box, enter the new option,
sample attributes only then click Add.

2. Change the default option, if needed.

Deselect Use default if you want the attribute to be
shown without a default preset.

Select a different option to change the value that is
shown as the default option.

Click Til (Delete) to remove an attribute list value.

4. Click Save.

Obsolete a sample attribute (manager/administrator)

Manager- and administrator-level users can obsolete custom sample attributes from use in the
software. You cannot designate as obsolete system-installed sample attributes.

When you obsolete an attribute, no change is made to the samples that already have an assigned value
for the attribute, but the attribute is no longer available when you create new samples.

1. In the menu bar, click Samples » Manage Attributes.
The Manage Attributes screen opens to the Manage Attributes tab.

2. Place the pointer over the row of the custom sample attribute that you want to make obsolete, then
click Obsolete.

3. In the confirmation dialog box that appears, click Yes to confirm that you want to obsolete the
sample attribute.
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The sample attribute that has been made obsolete is listed in the Manage Attributes screen, but is no
longer available when you create a sample.

Custom sample attributes that have been made obsolete can be reactivated. For more information, see
“Reactivate a sample attribute (manager/administrator)” on page 43.

Reactivate a sample attribute (manager/administrator)

Manager- and administrator-level users can reactivate custom sample attributes that have been made
obsolete.

1. In the menu bar, click Samples » Manage Attributes.
The Manage Attributes screen opens to the Manage Attributes tab.

2. In the Manage Attributes table, place the pointer over the row of a custom sample attribute that
you want to reactivate, then click Reactivate.

3. In the confirmation dialog box, click Yes to confirm that you want to reactivate the sample
attribute.

The sample attribute is available when you create a sample relevant to the attribute.

Map a sample attribute (manager/administrator)

You can import a file that you have exported from external LIMS software to add samples in Genexus™
Software. Each column heading in the file that you want to import to create samples in the software is a
name for a sample attribute. Before you import samples with the file, a manager- or administrator-level
user must map the names of sample attributes that are used by the LIMS software to the names of the
sample attributes recognized by Genexus™ Software.

For example, in Genexus™ Software, the sample attribute for the name of a sample is Sample Name.
In the file that you want to import, however, the same attribute can be called Name. You can map
the sample attribute Name to Sample Name so that the software recognizes Name as the name of a
sample.

If the attribute values in the file contain vocabulary that is not recognized in the software, you can
map the associated vocabulary so that you can seamlessly import the file to create samples. For more
information, see “Map the name of a value for a sample attribute (manager/administrator)” on page 44.

1. In the menu bar, click Samples » Manage Attributes.

2. In the Manage Attributes screen, click the Sample Attribute Mapping tab.

If any attributes have been mapped, a list of sample attributes and any associated attribute names
for all application categories is shown. Attributes identified with a red asterisk (*) are the attributes
that are required when you create a sample.

3. Click @ Edit Mapping.
The names of the sample attribute are case-sensitive.
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Option

Description

Populate attribute name options
from a file, then select the attribute
names to add the names in the
software.

1. Click Click here, then find and upload the file that you
want to import.

The attribute names are listed in the right pane.
2. In the Associated Attribute Name field for the attribute of

interest, select the attribute name from the dropdown list
that appears.

For sample attributes that include a date, select the proper
date format for the LIMS software from the dropdown list.

3. Select the checkbox of an associated attribute name to
map the name to an Attribute Name.

Enter an associated attribute name
to add the name in the software.

1. In the Associated Attribute Name field for the attribute of
interest, enter the attribute name used in the file that you
want to import.

For sample attributes that include a date, select the proper
date format for the LIMS software from the dropdown list.

2. Select the checkbox of an associated attribute name to
map the name to an Attribute Name.

Remove an associated attribute
name.

In the Associated Attribute Name field for the attribute of
interest, in the tile for the name that you want to remove, click
X (Remove).

4. Click Save.

The external attribute names are mapped to the attribute names used in Genexus™ Software and are
listed as associated attribute names in the Manage Attribute Mapping list.

You can then import the LIMS software file to create samples with the sample data. For more
information, see “Import samples” on page 34.

Map the name of a value for a sample attribute (manager/administrator)

You can import a file that you have exported from external LIMS software to add samples in Genexus™
Software. Each column cell in the file to create samples in the software can contain alternate vocabulary
for a sample attribute that are not recognized in the software. Before you import samples, a manager-
or administrator-level user must map the vocabulary for the sample attributes that is used by the LIMS
software to the names of the sample attributes recognized by Genexus™ Software.

44
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For example, in Genexus™ Software, one of the sample attribute values for Sample Type is Blood
(Whole). In the file that you want to import, however, the same attribute value can be called whole
blood. You can map the sample attribute value, whole blood, to Blood (Whole) so that the software
recognizes whole blood as Blood (Whole).

1. In the menu bar, click Samples » Manage Attributes.

2. In the Manage Attributes screen, click the Sample Attribute Mapping tab.

If any attributes have been mapped, a list of sample attributes and any associated attribute names
for all application categories is shown. Attributes identified with a red asterisk (*) are the attributes
that are required when you create a sample.

3. Click Manage Vocabulary Mapping.

By default, sample attributes that are a list type, such as Sample Type and Cancer Stage, and
have vocabulary values defined in the software, are shown in the pane on the left. Any sample
attributes that have associated vocabulary mapped to the attribute are also listed.

* C(Click an attribute name in the left pane to view the vocabulary value and associated
vocabulary value in the pane on the right.

4. Click @ Edit Mapping.

5. In the Associated Vocabulary Value field for the attribute value of interest, enter the term of the
attribute value used in the file that you want to import, then click Save.

* To remove a term that you have added, in the Associated Vocabulary Value field for the
attribute of interest, delete the text.

6. Click Save.

The name for the external attribute value is mapped to the attribute vocabulary value recognized
in Genexus™ Software and is listed as an associated vocabulary value in the Manage Vocabulary
Mapping list.

You can then import the LIMS software file to create samples with the sample data. For more
information, see “Import samples” on page 34.
Review sample attribute mapping history (manager/administrator)

A manager- or administrator-level user can review and export the history of sample attribute mapping in
Genexus™ Software.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. In the menu bar, click Samples » Manage Attributes.

2. In the Manage Attributes screen, click the Sample Attribute Mapping tab.
A list a sample attributes and any associated attribute names appears.

3. Click J Audit.
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4. In the Audit Details screen:

Option Description

Review the audit trail details. Each action that was performed for the sample attribute mapping,
such as creation of mapped attributes, or edits, is listed.

Export the audit record. Click Download to generate a PDF file. Depending on the
browser settings, the software automatically downloads the file or
prompts you to open or save the file.

Close the Audit Details screen. | Click < Back to return to the list of sample attributes.

Sample tags

A sample tag is a label that you add to a sample to help you group and track samples in Genexus™
Software. For example, you can assign a tag to each sample in a study or project so that you can easily
find that group of samples in the software. A manager-or administrator-level user firsts creates a tag,
then any user can assign that tag to a single sample or a group of samples. You can assign multiple
tags to each sample.

You can assign a tag when you create a sample or you can add, edit, or remove the tags that are
assigned to a sample later. You can apply sample tags to multiple samples at one time. Later, you can
filter the table of samples with that tag to list only the samples that have the tag. The tags that you
assign to samples are also shown in the list of sample results so sample tags can be used to group and
find sample results that are part of a study or project.

If you edit a sample and make a change to the tags associated with the sample, the changes you
make are tracked in the software and can be reviewed. For more information, see “Edit a sample” on
page 51 and “Review sample edit history” on page 53.

Tags are preserved with the sample when you archive a run that includes a sample with one or more
assigned tags.

You can also add tags to sample results. For more information, see “Assign sample tags to a sample
result” on page 138 and “Assign sample tags to multiple sample results” on page 138.

Create a sample tag (manager/administrator)

A manager-or administrator-level user can create sample tags in Genexus™ Software that can be used
to label and group samples.

You can create parent tags to nest the labels if desired. For example, if a large project is divided

into sections, you can create a parent tag called Master project and a child tag called New variant
of concern. You can create multiple layers of nested tags to help sort projects and sections within
projects. When you assign nested tags to a sample, the parent tag and all child tags are listed as tags
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for the sample. Later, when you search or filter for nested tags, the parent tags are also shown to help
you group and track the samples.

1. In the menu bar, click Samples » Manage Samples.

Alternatively, you can create a tag when you create a sample. For more information, see “Create a
new sample” on page 33 and “Import samples” on page 34.

2. In the Manage Samples screen, click Manage Tags.
The Manage Tags screen opens and lists tags, if any, that have been created in the software.

3. Click + Create Tag.

4. Inthe Create Tag dialog box, enter a name for the tag.

* Select a Parent Tag from the list to create a hierarchical tag that is nested below the parent
tag, if desired.

5. Click Save.
The tag is available to assign to samples.

Assign sample tags

You can assign tags to samples in Genexus™ Software to label and group samples.
1. In the menu bar, click Samples » Manage Sample.

2. In the Manage Samples screen, place the pointer over the row of the sample that you want to tag,
then click Assign Tags.

3. In the Assign Tags dialog box, search for or scroll to a tag.

If the tag that you want to assign to a sample does not exist in the software, a manager-or
administrator-level user can click + Create Tag to create a new sample tag.

4. Select one or more tags that you want to assign to the sample, then click Save.
The tag is assigned to the sample and is listed in the row for the sample in the samples table.

Assign a sample tag to multiple samples

You can assign tags to multiple samples at once in Genexus™ Software.
1. In the menu bar, click Samples » Manage Sample.

2. In the Manage Samples screen, click the checkbox to the left of each sample of interest, then
click © Assign Tags above the list of samples.

© Assign Tags is not shown until you select at least one sample.
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3. In the Assign Tags dialog box, search for or scroll to a tag.

If the tag that you want to assign to a sample does not exist in the software, a manager-or
administrator-level user can click + Create Tag to create a new sample tag.

4. Select one or more tags that you want to assign to the samples, then click Save.

The tag is assigned to the selected samples and is listed in the row for each sample in the samples
table.

Change or remove the tags that are assigned to a sample

You can change or remove the tags that are assigned to a sample in Genexus™ Software.
1. In the menu bar, click Samples » Manage Sample.

2. In the Manage Samples screen, place the pointer over the row of the sample of interest, then click
Assign Tags.

3. In the Assign Tags dialog box:

* Deselect the checkbox next to each tag that you want to remove from the sample.
* Select the checkbox next to each tag that you want to add to the sample.

4. Click Save.

Edit a sample tag (manager/administrator)

A manager-or administrator-level user can rename a tag and change the parent tag associated with a
tag in Genexus™ Software to change the hierarchy of the tags. When a tag is edited, the change is
applied to all samples assigned with the tag.

1. In the menu bar, click Samples » Manage Sample.

2. In the Manage Samples screen, click ©» Manage Tags.
The Manage Tags screen opens and lists tags, if any, that have been created in the software.

3. In the Manage Tags dialog box, click ¢ (Edit).
4. Change the name of the tag and parent tag assignment if needed, then click Save.

5. In the confirmation dialog box that appears, click Yes to confirm that you want to edit the sample
tag.

All samples that have the tag that you edit are updated with the change. If the name of the tag is
changed, the new name is shown for all samples and sample results with the tag. If the hierarchy of the
tag is changed, that change is also applied to all samples and sample results with the tag.
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Delete a sample tag (manager/administrator)

A manager-or administrator-level user can delete sample tags in Genexus™ Software. When a tag is
deleted, the tag is also removed from any samples assigned with the tag. Additionally, when you delete
a parent tag, all tags that are nested under the parent tag are also deleted.

1.

2.

3.

4.

In the menu bar, click Samples » Manage Sample.

In the Manage Samples screen, click Manage Tags.
The Manage Tags screen opens and lists tags, if any, that have been created in the software.

In the Manage Tags dialog box, click [i] Delete.

In the Confirm dialog box, click Yes to confirm the changes.

The tag is no longer listed in the Manage Tags list and is removed from all samples and sample results.

Manage samples

You can find tools for creating, searching, sorting, editing, deleting, and exporting samples, and for
viewing the sample history in the Samples / Manage Samples screen.

Copy a sample

You can copy a sample and change the information for the sample, if needed, to create a new sample in
Genexus™ Software.

1.

2.

4.

In the menu bar, click Samples » Manage Samples.

In the Manage Samples screen, place the pointer over the row of a sample that you want to copy,
then click Copy.

The Copy Sample screen opens. The sample information for the source sample is shown. The
Sample Name for the new sample is the sample name of the sample that was copied, appended
with _Copy.

In the Copy Sample screen, edit the sample information and sample tags, and change the sample
name, if needed.

Click Save.

The new sample is listed in the Manage Samples table and is available to assign to a run plan.
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Copy multiple samples

You can copy multiple samples at once in Genexus™ Software. You can only copy multiple samples that
have not been assigned to a run plan. To copy samples that have been assigned to a run plan, you
must copy one sample at a time. For more information, see “Copy a sample” on page 49.

1.

2.

5.

In the menu bar, click Samples » Manage Samples.

In the Manage Samples screen, select two or more samples.
The actions that you can apply to multiple samples appear.

Click ] Copy.

The Copy Sample screen opens. The sample information for each source sample is shown. The
Sample Name for each new sample is the sample name of the sample that was copied, appended
with _Copy.

In the Copy Sample screen, edit the sample information and sample tags, and change the sample
names, if needed.

Click Save.

The new samples are listed in the Manage Samples table and are available to assign to a run plan.

Export samples

The Export function generates an XLS file that contains details about the selected sample.

1.

2.

50

In the menu bar, click Samples » Manage Samples.

In the Manage Samples screen, select the checkbox in the row of each sample that you want to
export. To select all samples, select the checkbox in the column heading row.

Click Export.

An XLS file is created that contains the details of the selected samples. Depending on your
browser settings, the software automatically downloads the file or prompts you to open or save the
file.

Open the XLS file in an appropriate viewer to review or print.
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View notes or add a note to a sample

You can view existing notes or add new notes to a sample in Genexus™ Software. Use notes to capture
time-stamped written comments and observations for a sample. A sample can contain multiple notes
from different users.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, place the pointer over the row of the sample of interest, then click
Notes.

Action Description

View existing notes | In the Add Notes dialog box, notes that are associated with the sample are
for a sample. listed by user, date, and time.

Add a| newnotetoa | 1 |nthe Add Notes dialog box, click + Add Note.
sample.
P 2. Enter the note, then click Save.

The note is added to the sample and includes the username for the account of
the person who entered the note, and a timestamp that records the note entry
date and time.

Delete a sample note

You can delete notes that have been added to a sample in Genexus™ Software.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, place the pointer over the row of the sample of interest, then click
Notes.

3. In the Add Notes dialog box, in the row of the note that you want to delete, click i (Delete).

The note is no longer listed in the Add Notes dialog box and the note is removed from the software.

Click Close to return to the Manage Samples screen.

Edit a sample

You can edit the information that describes a sample in Genexus™ Software. When you edit a sample,
you can change the application category, update sample data, and remove data that are not required.

For samples created from BAM files, you can add or remove the associated BAM data files.

You can edit a sample until a run that uses that sample is started. You cannot edit a sample during

a run. After a run is complete, a manager- or administrator-level user can edit a sample for 30 days.
However, when a manager- or administrator-level user edits a sample during the 30-day period after the
run is complete, the sample status for the result is changed to obsolete and the report and other files
associated with the sample are no longer available.

If a manager- or administrator-level user edits a sample within 30 days after the run and the sample
result is obsolete, you must reanalyze the sample to generate sample results and a new variant report
for the sample. For more information, see “Reanalysis” on page 192.
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To add a custom sample attribute to a sample, see “Create a custom sample attribute (manager/
administrator)” on page 39.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, place the pointer over the row of a sample that you want to edit,
then click Edit.

3. In the Edit Sample screen, modify the sample information.

See “System-installed sample attributes” on page 424 for more information about system-installed
sample attributes.

4. For samples created from BAM files, change the associated BAM file if desired.
a. Click the dropdown list in DNA BAM File, RNA BAM File, or TNA BAM file.

b. Click Browse, then click Server or My Computer.
c. Navigate to the file, then click Select.

5. Click Save.

Edit multiple samples
You can edit multiple samples at once in Genexus™ Software.

You can edit samples until a run that uses that sample is started. You cannot edit samples during

a run. After a run is complete, a manager- or administrator-level user can edit samples for 30 days.
However, when a manager- or administrator-level user edits samples during the 30-day period after the
run is complete, the status for the sample results is changed to obsolete and the report and other files
associated with the samples are no longer available.

If a manager- or administrator-level user edits samples within 30 days after the run and the sample
results are obsolete, you must reanalyze the samples to generate sample results and a new variant
report for the samples. For more information, see “Reanalysis” on page 192.

Only samples that have the same sample application category can be edited together.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, select two or more samples.
The options that you can apply to multiple samples appear.

3. Click ¢ Edit.

4. In the Edit Sample screen, modify the sample information.
For more information about edit options, see “Create multiple samples” on page 33.

5. Click Save.

The changes to the samples are saved and the edited samples are available to assign to run plans.

You can view a history of changes that have been made to each sample. For more information, see
“Review sample edit history” on page 53.
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Review sample edit history

The entire history of defining a sample is available to review and export in Genexus™ Software. The
history shows the original sample values and any new values or activities. The following actions
generate an audit record:

* Create a new sample
¢ Edit a sample, including changes to sample tags
* Delete a sample

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, place the pointer over the row of a sample of interest, then click
Audit.

3. In the Audit Details screen:

Option Description

Review the audit trail details. | Each action that was performed for the sample, such as sample
creation or edits, is listed.

Export the audit record. Click Download to generate a PDF file. Depending on the browser
settings, the software automatically downloads the file or prompts you
to open or save the file.

Close the Audit Details Click < Back to return to the list of samples.
screen.

Delete samples

You can delete samples that have not been assigned to a run. Samples that are assigned to a run or
library batch cannot be deleted.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, select the checkbox in the row of each sample that you want to
delete.
The options that you can apply to multiple samples appear.

3. Click Til Delete.
The Delete Sample dialog box opens with the message Are you sure that you want to delete
selected sample(s)?

4. Click Yes to delete the selected samples.

The samples are removed from the software.
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Enter and manage library batches

You can prepare a library batch manually or import library batch information from a file. To change
sample or library batch information, you can edit the information in the samples, update library batches,
or delete samples or library batches.

Prepare or import a library batch

54

A library batch is a group of prepared libraries that are sequenced in the same Library to Result run. If
you are planning a run starting from libraries that you have already prepared manually, you must first
create a library batch in Genexus™ Software from samples. You can enter samples in the software or
import a sample file. For more information see, “Enter and manage samples” on page 27.

Select the library batch when you plan the run. If you are planning a run starting from nucleic acid
samples, skip this step and proceed to “Plan a Nucleic Acid to Result run” on page 72.

Note:
. Each library batch must have a unique library batch ID.

. Fields identified with a red asterisk (*) are required.

No-template controls

You can add a no-template control (NTC) or a positive control when you assign samples in run planning,
or when you create a library batch in Genexus™ Software. The controls are added automatically after
you assign samples to a run plan, or when you create a library batch. The configuration of each control
is based on the assay that is used. For more information, see the user guide for the panel that you use.

Prepare a library batch

A library batch is a group of prepared libraries that are sequenced in the same library run. If you are
planning a run starting from libraries that you have already prepared manually, you must first create

a library batch in Genexus™ Software from samples that you have added. If you are planning a run
starting from nucleic acid samples, skip this step and proceed to “Plan a Nucleic Acid to Result run” on
page 72.

1. In the menu bar, click Samples » Manage Samples.

2. In the Manage Samples screen, in the Filter Samples by dropdown menu, apply the To Be
Prepared filter to limit the displayed samples to those samples that have not been placed in a
library batch.

For more information about how to filter the list of samples, see “Find samples” on page 28.

3. Select samples in the list by clicking the checkbox to the left of each sample, then click
-+ Prepare Library Batch.
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4. Inthe Create Library batch screen, select the assay that you want to use in the run plan from the
Select Assay dropdown menu.
The assay determines parameter selections for the run, including any required controls and post-
run data analysis settings. If you select an assay that includes one library preparation type, the
Library Prep Type: automatically fills with the library preparation type for the nucleic acid type that
is specified by the assay you selected. For example, DNA, RNA, DNA+RNA, or TNA.
a. For assays that include more than one library prep type, select an item from the Library Prep
Type: drop-down menu, such as DNA, RNA, DNA+RNA, or TNA for the library batch.

5. In the expanded screen, in Library Batch ID, enter a unique identifier for the library batch.

Note: Library Batch IDs can contain only alphanumeric characters (0-9, Aa-Zz), period (.),
underscore (_), and hyphen (-). Required fields are indicated with a red asterisk (*).

6. (Optional) Enter the Library Kit Barcode and the Panel Kit Barcode.

7. Select the Include NTC checkbox to add no-template control sample processing and reporting to
the library batch.

8. Select the barcode ID of the adapter used to prepare each library. If appropriate, swap the default
barcodes in the dialog box between DNA, RNA, and Fusions by clicking the Swap Barcodes swap
image.

For example, click ona = rusions to swap barcodes.

Each library in a library batch must have a different barcode ID. When preparing the physical
libraries, best practice is to swap barcodes between DNA and RNA libraries in consecutive
sequencing runs to prevent carryover contamination. The barcodes that are listed in the DNA
Barcode or RNA Barcode dropdown list belong to the barcode set that was selected when the
assay was created.

IMPORTANT! Ensure that the barcodes that you used to create the libraries match the barcodes
that you enter in the Create Library batch screen.

9. Enter the DNA, RNA, DNA+RNA, or TNA Input Quantity for each library.

10. Inthe DNA, RNA, or TNA Kit Barcodes columns, enter the extraction kit barcode for each sample
and no template control, if applicable.

11. Click Submit to save and submit your selections.

The Samples / Manage Library Batches screen opens, listing the library batch that you created.
Libraries that are prepared in the same batch have the same Library Batch ID.

Import a library batch

You can import library batch information in the form of an XLS or XLSX file. The import file must include
all required library and kit information.

1. In the menu bar, click Samples » Manage Library Batches.

2. In the Manage Library Batches screen, click [ Import Library Batch.
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3. In the Import Library Batch dialog box, click Click here to select an assay for which the libraries
are prepared, and to download an example file for import.

If the assay includes more than one library preparation type, a library preparation type dropdown

list appears.

4. Select the library preparation type, such as DNA, RNA, DNA+RNA, or TNA for the library batch.

5. Select an assay from the list, then click Download.
The assay name is auto-populated in the Microsoft™ Excel™ template file that downloads to your

drive.

6. In the template file, enter or confirm the library batch information.

Template item Description
Reagents tab
Assay Name Auto-populated when assay is selected in step 5 (required).

Extraction Method Type

Auto-populated when assay and library prep type, if applicable, is
selected in step 5 (required).

Library Batch ID

Must be alphanumeric (0-9, Aa-Zz), period (.), underscore (_), and
hyphen (-) (required).

Library Kit Barcode

For example, Genexus™ Library Strips 1 and 2-AS barcode
(optional).

Panel Kit Barcode

For example, Oncomine™ Comprehensive Assay v3 DNA GX
barcode (optional).

Libraries tab

Sample Name

Must be alphanumeric (0-9, Aa-Zz), period (.), underscore (_), and
hyphen (-) (required).

To Include a no template control, add a row with NTC for the
Sample Name.

Barcode Barcodes used for each sample and control library preparation
(required).

Nucleic Acid Type DNA, RNA, or TNA (required).

Input Quantity Library input quantity (optional).

Control Kit Barcode

The barcode for the kit used for nucleic acid extraction of no
template controls (optional).

Extraction Kit Barcode

The barcode for the kit used for nucleic acid extraction of a sample
(optional).

IMPORTANT! For DNA and Fusions assays, the DNA library and RNA libraries must be listed in
sequential order per pool for each sample. For example, for a 1-pool DNA and Fusions assay, order
should be DNA, RNA for sample 1, DNA, RNA for sample 2. For a 2-pool DNA and Fusions assay,
library order should be DNA, RNA (pool 1), DNA, RNA (pool 2) for sample1, then DNA, RNA (pool
1), DNA, RNA (pool 2) for sample 2.
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7. Save the file.

8. In the Import Library Batch dialog box, click Select Library batch file, navigate to the saved file,
then select it.

9. Click Upload.
A progress bar followed by an import report displays. If the import process fails, click View errors
to review the reason for failure. The use of an invalid character is an example of an error. For more
troubleshooting support, see “Library batch import fails” on page 429.

Find library batches

You can sort, search, and filter information to narrow the library batches that are listed in the Samples /
Manage Library Batches screen in Genexus™ Software. The sort, search, and filter tools help you
organize the library batches and find a specific library batch.

For information to search for a library batch by a unique identifier, such as the library batch ID, see
“Search for library batches” on page 57.

For information to filter libraries by a common trait, such as the type of nucleic acid in the library batch,
see “Filter the list of library batches” on page 59.

Search for library batches

Library batches are listed in the Samples / Manage Library Batches screen in Genexus™ Software.
The most recently created library batch is at the top of the list.

You can search for library batches with full or partial keywords of the following items that are associated
with the library batches.

¢ Library Batch ID * Nucleic Acid Type
* Assay Full Name e Sample Name

IMPORTANT! Search terms must adhere to the following rules.

. An asterisk (*) is not allowed in the search field for use as a wildcard.

. Searches are case-insensitive, that is, both upper-case and lower-cases letters are found regardless
the case of search term letters.

. Searches find every occurrence of a continuous string. For example, a search for demo in analysis
names returns a list of all analysis with a name that includes demo. For example, demo1, demo2,
and so on.

. Spaces are removed during searches, and therefore are not recommended. For example, a search for
demo 1 would return results only for data that includes the string demo1.

1. In the menu bar, click Samples » Manage Library Batches.
2. In the Manage Library Batches screen, in the column heading of interest, click Y (Filter).

3. In the search field, enter a full or partial name or ID of at least 3 characters.
When you have entered at least 3 characters, the filter dialog box limits the list in the filter dialog
box based on the entry.
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4. In the filter dialog box, select from the limited list.

* Select a checkbox next to the name or ID to select one or more items.
¢ Click Select All to select all of the items listed in the filter dialog box.

¢ Click Clear to close the filter dialog box.

5. Click Filter.
In the column heading, changes color to indicate that a filter is applied.

The filtered list of libraries is shown in the Manage Library Batches screen.

Click {x] Clear Filters to remove all filters and view the full list of library batches.

Sort the list of library batches
You can sort the list of library batches to make it easier to find a library batch in Genexus™ Software.

By default, library batches are listed in the Samples / Manage Library Batches screen by the date the
library batch was created. The most recently created library batch is at the top of the list.

You can change the order that the library batches are listed and sort the library batches alphabetically
or reverse alphabetically by the Library Batch ID or Assay Full Name.

1. In the menu bar, click Samples » Manage Library Batches.

2. In the Manage Library Batches screen, click the column heading of interest.
The list of library batches is sorted alphabetically.

3. Click the column heading again to reverse the order.
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Filter the list of library batches

You can apply filters to narrow search results, or shorten the list of library batches when you view the
list of library batches in Genexus™ Software.

You can also search for library batches with keywords or text. For more information, see “Search for
library batches” on page 57.

In addition to the filter tools in the column headings, you can also filter the list of library batches with a
dropdown list. For more information, see “Manage library batches” on page 60.

1. In the menu bar, click Samples » Manage Library Batches.

2. In the Manage Library Batches screen, select one or more filters.

Option Description
List all library batches In the Total Samples column heading, click Y (Filter) then select one or
that are associated with a | more samples of interest.

sample

Filter and search by the In the Library Batch ID column heading, click Y (Filter) then use the
Library Batch ID or other | options to filter the list in the filter dialog box.
column headings.

Filter by the type of nucleic | In the Nucleic Acid Type column heading, click Y (Filter) then use the
acid in the library. options to filter the list in the filter dialog box.

Filter by the full assay In the Assay Full Name column heading, click Y (Filter) then use the
name in the library batch. | options to filter the list in the filter dialog box.

Filter the list of all samples | In the Total Samples column heading, click Y (Filter) then use the
that are included in library | options to filter the list in the filter dialog box.
batches.

Remove all selections and | In the filter dialog box, click Clear.
close the filter dialog box.

3. In the filter dialog box, click Filter to apply the filtered selections.
In the column heading, changes color to indicate that a filter is applied.

The list of library batches is filtered according to the selections.

Click {x] Clear Filters to remove all filters and view the full list of libraries.
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Manage library batches

You can view library batch information, edit, delete, add notes, and review the history of changes to
library batches in Genexus™ Software.

You can also search, sort, and filter the list of libraries batches. For more information, see “Find library

batches” on page 57.

1. In the menu bar, click Samples » Manage Library Batches.

2. In the Manage Library Batches screen, perform one or more actions.

Option

Description

View more library batch
information, such as the
list of samples included in
the library batch.

Click a Library Batch ID in the library batches list. Alternatively, in the Total
Samples column, click the number of samples in the library batch.

In the pane that shows details for the library batch, you can click

-++ (More Options) to perform more actions, such as edit, audit, or add
notes to the library batch.

View all library batches.

In the Filter Library Batches By dropdown menu, select All.

View libraries that are not
in a run plan.

In the Filter Library Batches By dropdown menu, select To Be Planned.

View multiple pages of
libraries.

Click the page numbers and arrows at the bottom of the screen.

Delete a library batch.

Select the checkbox next to one or more library batch IDs, then click
[i] Delete.

Edit a library batch.

1. Place the pointer over the row of a library batch that you want to edit,
then click Edit.

2. Modify the information in the Edit Library batch screen, then click
Submit.

Alternatively, in the library batch details pane, click the library batch ID to
perform this action.

You can edit a library batch only if none of the libraries in the library batch
have been assigned to a run.

View or export the audit
trail of a library batch.

1. Place the pointer over the row of a library batch that you want to
audit, then click Audit.
The Audit Records screen opens with time-stamped audit records
that include details and changes for each action performed on the
library batch.

2. Click the time stamp and action listed in the left pane of the screen to
view audit details for other actions.

3. Click Download in the upper right corner of the screen to
download the record as a PDF file.
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Option Description

View, add, or delete notes 1.

Place the pointer over the row of a library batch of interest, then click
for a library batch.

Notes.

The Add Notes dialog box opens and notes that are associated with
the library batch are listed by user, date, and time.

2. In the Add Notes dialog box, click 4 Add Note.
3. Enter the note, then click Save.

4. If needed, in the Add Notes dialog box, in the row of the note that
you want to delete, click [i] (Delete).
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Runs created in Genexus™ Software contain the settings that are used in library preparation, templating,
sequencing, and analysis, including sample information and plate location, assays, and barcodes. Runs
are used to track samples, consumables, and chips throughout the library preparation, templating,
sequencing, and data analysis workflow.

There are four types of runs that you can plan in Genexus™ Software. The type of run that you plan
depends on the sample type. For more information about samples, see “About samples and library
batches” on page 27.

Types of runs in Genexus™ Software

Run type Description

Sample to Result An integrated run for sequential and automated nucleic acid purification and
sequencing. This run type requires the Genexus™ Purification Instrument.

Nucleic Acid to Result A sequencing run that uses nucleic acid samples as input.

Library to Result A sequencing run that uses libraries that you have previously prepared as input.

BAM to Result A run that analyzes BAM samples.

Genexus™ Software guides you step-by-step through the process to set up a run. The software prompts
you to select required information and consumables, then provides a printed run setup guide to

help you load consumables on the Genexus™ Integrated Sequencer and the Genexus™ Purification
Instrument, if applicable.

You can plan sequencing runs that use nucleic acid samples with a Nucleic Acid to Result run or that
use manually prepared libraries with a Library to Result run.

You can plan runs for sequential and automated nucleic acid purification and sequencing with a
Sample to Result run. You must connect at least one Genexus™ Purification Instrument in order to
execute a Sample to Result run. For more information, see “Integrated nucleic acid isolation in Sample
to Result runs” on page 66.
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Samples that are imported from BAM files can be analyzed in the software. For more information, see
“Plan a BAM to Result run” on page 80.

Before you plan a run

The following conditions must be met before you plan a run in Genexus™ Software.

* Sample information is accurate in the software and the name assigned to each sample is unique.
For more information, see “Enter and manage samples” on page 27.

* A Genexus™ Purification Instrument is integrated for use with the system before you plan a Sample
to Result run.

* Ensure that the following conditions are met for a Library to Result run.
— Library batches are prepared and each batch uses a unique library batch ID.
— Each sample library in a library batch is prepared with and assigned a unique barcode or
barcode pair.
For more information, see “Enter and manage library batches” on page 54.

The software returns an error message when any of the conditions are not met.

Find a run plan

You can sort, search, and filter information to narrow the run plans that are listed in the Runs / Manage
Runs screen. The sort, search, and filter tools help you organize runs and find a specific run plan in
Genexus™ Software. You can also apply the search, sort, and filter tools in the Assays step when you
plan a run. Use the tools to limit the assays that are listed so that you can easily identify one or more
assays to include in the run plan.

For information to search for a run plan by a unique identifier, such as the name of the run plan or the
assay applied to the run plan, see “Search for a run plan” on page 64.

For information to filter run plans by a common trait, such as the run plans that include purification, see
“Filter the list of run plans” on page 65.
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Search for a run plan

Run plans are listed in the Runs / Manage Runs screen in Genexus™ Software. The most recently
created run plan is on the top of the list.

You can search for run plans with keywords or text that are included in the name of the run plan or the
name of an assay applied to the run plan.

IMPORTANT! Search terms must adhere to the following rules.

. An asterisk (*) is not allowed in the search field for use as a wildcard.

. Searches are case-insensitive, that is, both upper-case and lower-cases letters are found regardless
the case of search term letters.

. Searches find every occurrence of a continuous string. For example, a search for demo in analysis
names returns a list of all analysis with a name that includes demo. For example, demo1, demo2,
and so on.

. Spaces are removed during searches, and therefore are not recommended. For example, a search for
demo 1 would return results only for data that includes the string demo1.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, in the Run Name column heading or Assay Name column heading,
click Y (Filter).

3. In the search field, enter a full or partial assay or run name of at least 3 characters.

When you have entered at least 3 characters, the filter dialog box limits the list in the filter dialog
box based on the entry.

4. In the filter dialog box, select from the limited list.

* Select a checkbox next to a run or assay name to select one or more items.
¢ Click Select All to select all items listed in the filter dialog box.
¢ Click Clear to close the filter dialog box.

5. Click Filter.
In the column heading, (Filter) changes color to indicate that a filter is applied.

The filtered list of run plans is shown in the Manage Runs screen.

Click {x] Clear Filters to remove all filters and view the full list of run plans.
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Sort the list of run plans

You can sort the list of run plans to make it easier to find run plans in Genexus™ Software.

By default, run plans are listed in the Runs / Manage Runs screen by the date the run plan was
created. The most recently created run plan is at the top of the list.

You can change the order that the run plans are listed and sort the run plans alphabetically or reverse
alphabetically.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, click the Run Name heading.
The list of runs is sorted alphabetically.

3. Click the column heading again to reverse the order.

Filter the list of run plans

You can apply filters to narrow search results, or shorten the list of run plans when you view the list of
run plans in Genexus™ Software. You can also apply filters in the Assays step when you plan a run to
help find one or more assays to include in the run plan.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, select one or more filters.

Option Description

Filter and search by the For more information, see “Search for a run plan” on page 64.
run name or the assay
selected in the run.

Filter by the number of In the Total Samples column heading, click Y (Filter) then use the

samples in the run. options to filter the list in the filter dialog box based on the number or
span of numbers of samples in the run.

List runs based on In the Run Status column heading, click Y (Filter) then select a status.

whether the run includes .

Select Planned to list all Nucleic Acid to Result, Library to Result,

purification. and BAM to Result planned runs.

¢ Select Purification Planned to list planned Sample to Result runs
only.

Remove all selections and | In the filter dialog box, click Clear.
close the filter dialog box.

3. In the filter dialog box, click Filter to apply the filtered selections.
In the column heading, (Filter) changes color to indicate that a filter is applied.

The list of run plans is filtered according to the selections.

Click {x] Clear Filters to remove all filters and view the full list of run plans.
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Integrated nucleic acid isolation in Sample to Result runs

A Sample to Result run is an integrated run for sequential and automated nucleic acid purification and
sequencing. You can create Sample to Result runs for the following sample types:

* Blood (buffy coat)

* Blood (plasma)

* Blood (whole)

* Bone marrow

* C(Cellline

* (Core needle biopsy (CNB)

* Formalin-fixed, paraffin-embedded (FFPE) tissue

* Fine needle aspiration (FNA)

* Fresh frozen tissue
When you plan a Sample to Result run with multiple assays, the nucleic acid isolation is performed in
a separate batch for each assay. Nucleic acid isolation is also performed in a separate batch for each
sample type, except for FFPE tissue and FNA, which are grouped together in a single batch for each
assay. The Genexus™ Purification Instrument can run one nucleic acid isolation batch at a time. You
can run different nucleic acid isolation batches simultaneously on multiple purification instruments or
sequentially on a single instrument.
You can select which samples are sequenced after nucleic acid isolation. The options are as follows.

® Sequence all samples.

* Sequence only the samples that have a concentration within a specified threshold.

* Review the samples that do not have a concentration within a specified threshold, then select

samples to sequence on a per sample-basis.

For more information, see the Genexus™ Purification System User Guide (Pub. No. MAN0Q18475).

Plan a Sample to Result run

This procedure applies only if a Genexus™ Purification Instrument is used with the Genexus™ Integrated
Sequencer.

Ensure that the following prerequisites are complete before you plan a Sample to Result run.
* Integrate a Genexus™ Purification Instrument with the system.
* Enter sample information into Genexus™ Software. For more information, see “Create a new
sample” on page 33, or “Import samples” on page 34.

Planning a Sample to Result run is organized into five steps: Setup, Assays, Samples, Purification,
and Review. Progress through the steps is tracked in the upper left corner of the Runs / Sample to
Result screen.

1. In the menu bar, click Runs » Sample to Result.

Note: You can also click + Sample to Result in the Runs / Manage Runs screen.
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2. In the Setup step, enter or make the following selections.

a. In the Plan section, enter a unique name.

The name is limited to 50 characters and no spaces are allowed.

b. (Optional) In the Reporting (Optional) section, enable Generate Report to generate a variant
report that uses the default report template.

c. (Optional) In the Reporting (Optional) section, enable Upload BAM files to Server to upload
BAM files to another Genexus™ Integrated Sequencer or to lon Reporter™ Software.

Option

Description

Upload BAM files to another
Genexus™ Integrated Sequencer.

In the dropdown lists that appear, select the Genexus™
Software account and the software version.

To configure a Genexus™ Software account that you can
use for data uploads, click Set up Account. For more
information, see “Register Genexus™ Software accounts
(manager/administrator)” on page 300.

Automatically upload data for
further analysis with lon Reporter™
Software.

In the dropdown lists that appear, select the lon Reporter™
Software account and the software version.

To configure an lon Reporter™ Software account that you
can use for data uploads, click Set up Account.

Note: To transfer data to lon Reporter™ Software, you
must add one or more lon Reporter™ Software accounts
in Genexus™ Software. To configure an lon Reporter™
Software account that you can use for data uploads,

see “Register an lon Reporter™ Server account (manager/
administrator)” on page 301 and “Register Genexus™
Software accounts (manager/administrator)” on page 300.

Alternatively, you can upload BAM files to another Genexus™ Integrated Sequencer or to lon
Reporter™ Software after a run is successfully completed. For more information, see “Upload
results files to another Genexus™ Integrated Sequencer” on page 195 and “Upload results
files to lon Reporter™ Software” on page 196.

d. Click Next.

3. Inthe Assays step, select one or more assays that you want to include in the run.

Only assays that are configured for Sample to Result runs are listed. If a chip is installed in the
sequencer, the Chip View graphic in the lower left corner indicates the lanes that are available for

sequencing.

a. Use the Y (Filter) tools in table column headings to find assays of interest, if desired.

For more information, see “Find the assay that you want to use in a run plan” on page 81.
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b. In the Research Application column for the assay of interest, select one or more research
applications, such as DNA and Fusions, to include the research application for the assay in
the run plan.

After selecting an assay, the list is filtered to show compatible assays that can be selected
and run at the same time. Assays must have the same Analysis Version, Chip Type, and
Library Chemistry to be compatible with the selected assay.

Note: To create a new assay, see Chapter 8, “Create and manage assays (manager/
administrator)”.

c. If more assays are included in the run, repeat the previous substep for each extra assay.
d. Click Next.

4. In the Samples step, select the samples that you want to run with each research application of
each assay.

a. Select the checkbox next to each sample that you want to assign to the research application
of an assay, then in the Selected Assays pane, for the assay and research application that
you want to use for the selected samples, click Assign.

The Chip View updates to show the lanes used in the run. Lane usage is calculated based
on the number of samples (including a no template control, if selected) and the minimum read
counts per sample for the assay. Green denotes a chip lane in the run containing assigned
samples within lane capacity.

If the

minimum reads per sample x number of samples
exceeds the chip or lane well capacity, a dialog box appears after you click Assign asking you
to confirm that you want to continue. After confirmation, the Chip View updates and shows

the lane color as red instead of green. The run is allowed if the lane capacity is exceeded, but
you may not achieve the required reads per sample to pass QC metrics.

lon Torrent™ GX5™ Chip lon Torrent™ GX5™ Chip

123 OCAV3DNAFus 1 OCAVE DNA Fus 7
Lare s02 Samples wE02 samples

Green lane color denotes lane usage and sample Red lane color denotes sample assignment that
assignment within lane capacity. exceeds lane capacity.

b. If you selected more than one research application or assay, repeat the previous substep for
each research application for each assay in the run plan.
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c. If needed, edit samples in one of the following ways.
¢ (Click View & Remove, make the selections, then click Update.

* Click Remove All, to remove all sample assignments for all assays.

d. If you selected the Upload BAM files to Server reporting option in the Setup step, make the
following selections from the Genexus Workflow or lon Reporter Workflow dropdown list
for each assay that you selected.

¢ Select Upload Only to upload sample data to the selected server automatically after run
completion.

® Select the desired Genexus™ Software assay or lon Reporter™ Software analysis workflow
to upload sample data and perform an analysis in the target software automatically after
run completion.

Note: In order for the lon Reporter™ Software analysis workflow to appear in the list, you
must tag the analysis workflow for use with the lonReporterUploader plugin. For more
information, see the lon Reporter™ Software 5.18 User Guide (Pub. No. MAN0024776).

e. If desired, for each research application of each assay in the run plan, select NTC to include a
no template control and select Control Sample to include a positive control.

The Chip View updates to show the lanes used in the run for the included controls.
f. Click Next.

5. In the Purification step, review and edit selections.
a. Review and edit purification selections.

Option Description
Protocol Selection Select a protocol from the dropdown list for each purification kit.
Elution Vol. (uL) Modify the elution volume within the allowable range, if needed.
Review? * Select the checkbox in the row of a purification kit to review

the run after purification, before sequencing, for the kit. This
allows you to review samples when the quantity of a nucleic acid
is below the quality threshold. You can then decide on a per
sample-basis whether or not to sequence the samples.

* Deselect the Review? checkbox in the row of a purification kit
to enable the sequencer to bypass sequencing samples with
concentrations below the threshold for the kit. This option does
not require you to review samples during the run.

Note: This selection, whether or not it is selected, overrides the
Review? setting of the assay.

b. Review and edit the information for control samples, if applicable.

Option Description
Conc. (ng/pL) Review and edit the concentration of control samples, if needed.
Kit Barcodes Enter the extraction kit barcode for each control sample, if needed.
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c. Click Next.

6. In the Review step, review the run plan summary, then click Save.

Note: A run can include multiple purification batches.
For more information, see “Integrated nucleic acid isolation in Sample to Result runs” on page 66.

The run plan summary lists the following details:

* the consumables that are required for * the consumables that are required for
purification sequencing
* how much volume to load ® details about the assay or assays.

* where to load samples

Tip: Click Sequencing to expand the sequencing section of the run plan summary.

IMPORTANT! The consumables required for sequencing can change. After purification, review
the run plan in the Runs / Manage Runs screen for updated sequencing consumable information.
For more information, see “Print a run plan” on page 85.

Note: If you are using an assay with lon AmpliSeq™ HD library chemistry, the primer pool positions
show that HD primer pools occupy both rows.

Primer Tube Positions

1 2 3 4 5 6 7 8
: 1 2. 3 4 5 6 T 8
1. OPA DNA w2.8.0-0.0.2 [ 100085165: OPA Pool 1] 2. OPA DNA w2.8.0-0.0.2 [ 100085165: OPA Pool 1]
3. OPA DNA Fus w2.8.0-0.0.2 [ 100085165 OPA Pool 1] 4. OPA DNA Fus w2.8.0-0.0.2 [ 100085165: OPA Pool 1]
5. OPA Fusions w2.8.0-0.0.2 [ 100085165: OPA Pool 1] 6. OPA Fusions w2.8.0-0.0.2 [ 100085165: OPA Pool 1]
7. OPA DNA Fus w2.8.0-0.0.1 [ 100085165: OPA Pool 1] 8. OPA DNA Fus w2.8.0-0.0.1 [ 100085165: OPA Pool 1]

@ The position of the primer tubes.
@ The legend for the image.

In the example outlined in red, primer tube 7, which contains OPA Pool 1 for the OPA DNA Fusion assay, is in
the seventh position from the left.

The run plan appears in the Manage Runs screen with the name that you specified.

After you select the run and load the Genexus™ Purification Instrument, the run is started on the
purification instrument screen.

When purification and sequencing are complete, you can recover the leftover volume from each library
that was prepared in the run. For more information to find, recover, and purify the leftover library
preparations, see the Genexus™ Integrated Sequencer User Guide.
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Review samples for Sample to Result runs

A Sample to Result run integrates nucleic acid purification and sequencing. When you create a
Sample to Result run plan, you can include an option that allows samples to be reviewed before library
preparation starts. Samples that do not meet a specified concentration threshold after purification have
a run status of Purification Review Required.

For more information about Sample to Result runs, see “Integrated nucleic acid isolation in Sample to
Result runs” on page 66.

You can also apply this option when you create an assay. For more information, see “Custom assays for
Sample to Result runs (manager/administrator)” on page 234.

1. In the menu bar, click Results » Run Results.

Note: Sample to Result runs that require review after purification have a Run Status of
Purification Review Required.

2. In the Run Results screen, place the pointer over the row of the run plan of interest, then click
Review.

The Purification Samples screen opens.

3. Review the concentration for each sample, then select the checkbox in the row for each sample
you want to sequence.

4. Click Submit.

The samples are ready for sequencing. For more information, see the Genexus™ Purification System
User Guide (Pub. No. MAN0OO18475).

Abort a Sample to Result run
When you create a Sample to Result run plan, you can include an option that allows samples to be

reviewed before library preparation starts. When you enable the review of samples after purification, you
can end the run before sequencing if needed.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, place the pointer over the row of the run that you want to abort, then
click Abort.

3. In the confirmation dialog box that appears, click Yes to confirm that you want to abort the run.

In the Run Summary, you can view information about the purification run. The status of the run in the
Run Summary is Aborted. For more information, see “View the run summary” on page 146.
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Plan a Nucleic Acid to Result run

72

You can plan a run for sequencing that starts with nucleic acid samples. A run that starts with nucleic
acid samples is called a Nucleic Acid to Result run.

Planning a Nucleic Acid to Result run is organized into steps: Setup, Assays, Samples, Sample
Plate, and Review. You can view progress through the steps in the upper left corner of the
Runs / Nucleic Acid to Result screen.

Ensure that the following prerequisites are complete before you plan a Nucleic Acid to Result run.

* Enter sample information into Genexus™ Software. For more information, see “Create a new
sample” on page 33, or “Import samples” on page 34.

¢ Ensure that the assay that you want to use in the run exists in the software. For more information,
see “Assays in Genexus™ Software” on page 215.

Quantify sample concentration, if you do not intend to dilute sample concentrations manually to the

target concentration of the assay. For more information, see the Genexus™ Integrated Sequencer
User Guide (Pub. No. MANOO17910)..

1. In the menu bar, click Runs » Nucleic Acid to Result.

Note: Alternatively, you can click 4 Nucleic Acid to Result in the Runs / Manage Runs screen.

2. In the Setup step, enter or make the following selections.
a. In the Plan section, enter a unique name.
The name is limited to 50 characters and no spaces are allowed.

b. (Optional) In the Reporting (Optional) section, ensure that Generate Report is enabled to
generate a variant report using the default report template.
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c. (Optional) In the Reporting (Optional) section, enable Upload BAM files to Server to upload
BAM files to another Genexus™ Integrated Sequencer or lon Reporter™ Software.

Option Description
Upload BAM files to In the dropdown lists that appear, select the Genexus™ Software
another Genexus™ Integrated | account and the software version.
Sequencer. To configure a Genexus™ Software account that you can

use for data uploads, click Set up Account. For more
information, see “Register Genexus™ Software accounts
(manager/administrator)” on page 300.

Automatically upload data In the dropdown lists that appear, select the lon Reporter™
for further analysis with lon Software account and software version.
Reporter™ Software. To configure an lon Reporter™ Software account that you can

use for data uploads, click Set up Account.

Note: To transfer data to lon Reporter™ Software, you

must add one or more lon Reporter™ Software accounts in
Genexus™ Software. To configure an lon Reporter™ Software
account that you can use for data uploads, see “Register

an lon Reporter™ Server account (manager/administrator)” on
page 301 and “Register Genexus™ Software accounts (manager/
administrator)” on page 300.

Alternatively, you can upload BAM files to another Genexus™ Integrated Sequencer or lon
Reporter™ Software after a run is successfully completed. For more information, see “Upload
results files to another Genexus™ Integrated Sequencer” on page 195 and “Upload results
files to lon Reporter™ Software” on page 196.

d. Click Next.

3. In the Assays step, select one or more assays that you want to include in the run.
a. Use the Y (Filter) tools in table column headings to find assays of interest, if desired.
For more information, see “Find the assay that you want to use in a run plan” on page 81.

b. In the Research Application column for the assay of interest, select one or more research
applications, such as DNA and Fusions or DNA, to include the research application for the
assay in the run plan.

After you select an assay and the research application for the assay, the list is filtered to show
compatible assays that can be selected and run at the same time.

Note: To create a new assay, see Chapter 8, “Create and manage assays (manager/
administrator)”.

c. If more assays are included in the run, repeat substep 3b for each extra assay.

d. Click Next.
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In the Samples step, select the samples that you want to run with each research application of
each assay.

a. Select the checkbox next to each sample that you want to assign to the research application

of an assay, then in the Selected Assays pane, for the assay and research application that
you want to use for the selected samples, click Assign.

The Chip View updates to show the lanes used in the run. Lane usage is calculated based
on the number of samples (including a no template control, if selected) and the minimum read
counts per sample for the assay. Green denotes a chip lane in the run containing assigned
samples within lane capacity.

If the

minimum reads per sample x number of samples

exceeds the chip or lane well capacity, a dialog box appears after you click Assign asking you
to confirm that you want to continue. After confirmation, the Chip View updates and shows
the lane color as red instead of green. The run is allowed if the lane capacity is exceeded, but
you may not achieve the required reads per sample to pass QC metrics.

lon Torrent™ GX5™ Chip lon Torrent™ GX5™ Chip

123 | OCAVS DNAFus 1 OCAVE DNA Fus 7
(s w5.0.2 Samples. WE.0.2 Samples

Green lane color denotes lane usage and sample Red lane color denotes sample assignment that
assignment within lane capacity. exceeds lane capacity.

. If you selected more than one research application or assay, repeat substep 4a for each

research application for each assay in the run plan.

. If needed, edit samples in one of the following ways.

* (Click View & Remove, make the selections, then click Update.

* Click Remove All, to remove all sample assignments for all assays.

. If you selected the Upload BAM files to Server reporting option in the Setup step, make the

following selections from the Genexus Workflow or lon Reporter Workflow dropdown list
for each assay that you selected.

¢ Select Upload Only to upload sample data to the selected server automatically after run
completion.

® Select the desired Genexus™ Software assay or lon Reporter™ Software analysis workflow
to upload sample data and perform an analysis in the target software automatically after
run completion.

Note: In order for the lon Reporter™ Software analysis workflow to appear in the list, you
must tag the analysis workflow for use with the lonReporterUploader plugin. For more
information, see the lon Reporter™ Software 5.18 User Guide (Pub. No. MAN0024776).
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e. If desired, for each research application of each assay in the run plan, select NTC to include a
no template control.
The Chip View updates to show the lanes used in the run for the included no template
controls.

f. Click Next.

5. In the Sample Plate step, review position assignments in the sample plate. Drag-and-drop
samples and no template controls to edit the location of samples and controls, if applicable.

a. If desired, enter the extraction kit barcode for one or more samples or controls. For a single
sample, in the row of the sample of interest, in the Kit Barcodes column, enter the extraction
kit barcode or control kit barcode, if applicable. For multiple samples or controls, select the
samples and controls, then click [ Assign Kit Barcodes. In the Assign Kit Barcodes dialog
box, enter the extraction kit barcode for the samples, and if applicable, enter the barcode for
the no template control.

b. Modify the concentration of samples, if needed. For a single sample, in the row of the sample
of interest, in the Conc. (ng/pl) column, edit the concentration.

To modify the concentration of multiple samples, select the samples of interest, then click
@ Edit Concentration. In the Bulk Edit dialog box, enter the concentration for all selected
samples, then click Submit. The concentration for each selected sample is updated to the
new value.

The sequencer automatically dilutes the sample to the target concentration during the run if
either of the following is true:

* The sample concentration is less than or equal to 1,024.00X the target concentration for
an assay that performs 4 reactions per library.

* The sample concentration is less than or equal to 40.00X the target concentration for an
assay that performs 6 reactions per library strip.

If a sample concentration is greater than 1,024.00X or 40.00X the target concentration,
depending on the assay, you must manually dilute the sample to the target concentration,
or to a value within range for automated dilution before loading on the sample plate.

IMPORTANT! A warning symbol ((!)) with a message that states “Sample concentration out
of range” can be shown in error for automated sample dilution in the Run Plan screen when
you plan a run, or view the Run Summary screen, in Genexus™ Software.

. If the sample concentration is below the required minimum concentration and shows a
Dilution Factor of 1.00 (that is, no dilution), the message is valid.

. If a sample that includes the warning message shows a Dilution Factor >1.00 and
<1,024.00 (4 reactions per strip) or >1.00 and <40.00 (6 reactions per strip), the message is
not valid and can be ignored.

. When you see the maximum Dilution Factor of 1,024.00 (4 reactions per strip) or 40.00
(6 reactions per strip), multiply the maximum value of the target concentration range by
the maximum dilution factor (that is, 1,024.00 or 40.00). If the product of the calculation is
greater than the sample concentration, the message is not valid and can be ignored.

Note: The sample volume that is required for library preparation is not adjustable. The volume
depends on the number of primer pools in the assay, sample type, and library chemistry.
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c. Ensure that sample plate information is correct, then click Next.

6. In the Review step, review the run plan summary, then click Save & Print to print the run setup
guide, if desired. Click Save to save the run without printing.

Note: To print the run setup guide, you must allow pop-ups in the browser.

The run plan summary lists the following details.

¢ the consumables that are required for this * where to load samples and primer pool
run tubes
* how much sample volume to load ¢ details about the assay.

Note: If you are using an assay with lon AmpliSeq™ HD library chemistry, the primer pool positions
show that HD primer pools occupy both rows:

Primer Tube Positions

1. OPA DNA w2.8.0-0.0.2 [ 100085165: OPA Pool 1] 2. OPA DNA w2.8.0-0.0.2 [ 100085165: OPA Pool 1]

3. OPA DNA Fus w2.8.0-0.0.2 [ 100085165: OPA Pool 1] 4. OPA DNA Fus w2.8.0-0.0.2 [ 100085165: OPA Pool 1]
5. OPA Fusions w2.8.0-0.0.2 [ 100085165: OPA Pool 1] 6. OPA Fusions w2.8.0-0.0.2 [ 100085165: OPA Pool 1]
7. OPA DNA Fus w2.8.0-0.0.1 [ 100085165: OPA Pool 1] 8. OPA DNA Fus w2.8.0-0.0.1 [ 100085165: OPA Pool 1]

@ The position of the primer tubes.
@ The legend for the image.

In the example outlined in red, primer tube 7, which contains OPA Pool 1 for the OPA DNA Fusion assay, is in
the seventh position from the left.

After saving, the run appears in the Manage Runs screen in the run list with the name you
specified.

After you select the run and load the sequencer, the run is started on the sequencer screen.

When the sequencing run is complete, you can recover the leftover volume from each library that was
prepared in the run. For more information to find, recover, and purify the leftover library preparations,
see the Genexus™ Integrated Sequencer User Guide (Pub. No. MANOO17910).

Plan a Library to Result run

You can plan runs for sequencing that start with libraries. In Genexus™ Software 6.6 and later, this is
called a Library to Result run. Before you can plan a Library to Result run, you must first enter sample
information and prepare a library batch that associates an assay with the library batch. The library batch
must be created with the assay to be used in the run. The assay specifies the barcode set that was
used to prepare the sample libraries.

For more information, see “Enter and manage library batches” on page 54.
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If the sample libraries were prepared using a barcode set that is not specified in an assay you want to
use in the run, you must do the following:

* (Create a new assay, or copy an existing assay, and specify the new barcode set in assay setup.
* Prepare a library batch that selects the new assay.

For more information, see “Create an assay (manager/administrator)” on page 219, “Copy an assay
(manager/administrator)” on page 221, and “Prepare a library batch” on page 54.

Genexus™ Software guides you through the four steps of planning a Library to Result run: Setup,
Assays, Library Batches, and Review. You can view progress through the steps in the upper left
corner of the Runs / Library to Result screen.

1. In the menu bar, click Runs » Library to Result.

Note: You can also click + Library to Result in the Runs / Manage Runs screen.

2. In the Setup step, enter a name for the run, then configure the reporting options.
a. In Run Name, enter a unique name.
The name is limited to 50 characters and no spaces are allowed.

b. (Optional) In the Reporting (Optional) section, ensure that Generate Report is enabled to
generate a variant report using the default report template.
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c. (Optional) In the Reporting (Optional) section, enable Upload BAM files to Server to upload
BAM files to another Genexus™ Integrated Sequencer or to lon Reporter™ Software.

Option

Description

Upload BAM files to another
another Genexus™ Integrated
Sequencer.

In the dropdown lists that appear, select the Genexus™ Software
account and the software version.

To configure a Genexus™ Software account that you can
use for data uploads, click Set up Account. For more
information, see “Register Genexus™ Software accounts
(manager/administrator)” on page 300.

Automatically upload data
for further analysis with lon
Reporter™ Software.

In the dropdown lists that appear, select the lon Reporter™
Software account and software version.

To configure an lon Reporter™ Software account that you
can use for data uploads, click Set up Account. For more
information, see “Register an lon Reporter™ Server account
(manager/administrator)” on page 301.

Note: To transfer data to lon Reporter™ Software, you

must add one or more lon Reporter™ Software accounts in
Genexus™ Software. To configure an lon Reporter™ Software
account that you can use for data uploads, see “Register

an lon Reporter™ Server account (manager/administrator)” on
page 301 and “Register an lon Reporter™ Software on Thermo
Fisher™ Connect Platform account (manager/administrator)” on
page 300.

Alternatively, you can upload BAM files to another Genexus™ Integrated Sequencer or to lon
Reporter™ Software after a run is successfully completed. For more information, see “Upload
results files to another Genexus™ Integrated Sequencer” on page 195 and “Upload results
files to lon Reporter™ Software” on page 196.

d. Click Next.

If a chip is installed in the sequencer, the Chip View graphic in the lower left corner indicates
the lanes that are available for sequencing.

3. Inthe Assays step, select one or more assays that you want to include in the run.

For the assay to be selectable at this step, you must have prepared a library batch that assigns
the assay to the batch. The assay specifies the barcode set that was used to prepare the sample

libraries.

a. Use the Y (Filter) tools in table column headings to find assays of interest, if desired.

For more information, see “Find the assay that you want to use in a run plan” on page 81.
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b. In the Research Application column for the assay of interest, select one or more research
applications, such as DNA and Fusions, to include each selected research application for the
assay in the run plan.

After you select an assay and the research application for the assay, the list is filtered to show
compatible assays that can be selected and run at the same time.

Note: To create a new assay, see Chapter 8, “Create and manage assays (manager/
administrator)”.

c. If more assays are included in the run, repeat substep 3b for each extra assay.
d. Click Next.

4. In the Library Batches step, select the library batch that you want to use in the run, then click
Next.

Note: Only one library batch can be selected per assay. However, you can plan a library run that
uses multiple assays if you select multiple compatible assays in the Assays step.

a. If you selected the Upload BAM files to Server reporting option in the Setup step, make the
following selections from the Genexus Workflow or lon Reporter Workflow dropdown list.

¢ Select Upload Only to upload sample data to the selected software account
automatically after run completion.

® Select the desired Genexus™ Software assay or lon Reporter™ Software analysis workflow
to upload sample data and perform an analysis in the target software automatically after
run completion.

Note: In order for the lon Reporter™ Software analysis workflow to appear in the list, you
must tag the analysis workflow for use with the lonReporterUploader plugin. For more
information, see the lon Reporter™ Software 5.18 User Guide (Pub. No. MAN0024776).

The Chip View updates to show the lanes to be used in the run as green. Lane usage is calculated
based on the number of samples and minimum reads per sample entered at assay setup.

lon Torrent™ GX5™ Chip lon Torrent™ GX5™ Chip

123 | OCAV3DNA Fus 4 OCAv3 DNA Fus 7
o W5.0.2 Samples. W02 Samples

Green lane color denotes lane usage and sample Red lane color denotes sample assignment that
assignment within lane capacity. exceeds lane capacity.

If the

minimum reads per sample x number of samples
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exceeds the chip or lane well capacity, a dialog box appears after you click Next asking you to
confirm that you want to continue. After clicking Yes, the Chip View updates and shows the lane
color as red instead of green. In the example shown at right, seven samples were included in a
library batch instead of four. The run is allowed if the lane capacity is exceeded, but you may not
achieve the required reads per sample to pass QC metrics.

. In the Review step, review the run plan summary.

* C(Click Save and Print to print the run setup guide.
¢ Click Save to save the run without printing.

Note: To print the run setup guide, you must allow pop-ups in the browser.

The run plan summary lists the consumables that are required for the run, where to load the library
batch on the sample plate, and how much library volume to load.

The run appears in the run list on the Manage Runs screen with the name you specified.

After you select the run and load the sequencer, the run is started on the sequencer screen.

Plan a BAM to Result run

80

Before you can plan a BAM to Result run, you must enter BAM samples into Genexus™ Software. For
more information, see “Upload a BAM file to create a sample or samples” on page 35.

Planning a run to analyze BAM samples is organized into steps: Assays, Samples, and Review. You
can view progress through the steps in the upper left corner of the Runs / BAM to Result screen.

. In the menu bar, click Runs » BAM to Result.

Note: You can also click + BAM to Result in the Runs / Manage Runs screen.

In the Assays step, enter or make the following selections.
a. Enter a unique name.
The name is limited to 50 characters and no spaces are allowed.

b. Use the Y (Filter) tools in table column headings to find assays of interest, if desired.
For more information, see “Find the assay that you want to use in a run plan” on page 81.

c. In the Research Application column for the assay of interest, select the research application,
such as DNA and Fusions or DNA, to include the selected research application for the assay
in the run plan.

You can select only one research application of an assay per run.

d. Click Next.
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3. In the Samples step, select the BAM samples from the list that you want to analyze, then click
Assign.

Note: Only BAM samples that are compatible with the selected assay are listed. Compatibility is
determined by the sample type, such as DNA or DNA and Fusion.

a. If needed, click ® in an assigned sampile tile to remove the sample from the plan.
b. Click Next.

4. Inthe Review step, review the samples in the run plan summary, then click Save and Launch.

The run is listed in the Results / Run Results screen. The run is launched or the run is queued if
other runs are in progress.

Find the assay that you want to use in a run plan

You can search and filter the list of assays when you plan a run to help you find the assay that you want
to use in a run plan in Genexus™ Software.

For information to search for an assay by a unique identifier, such as the name of the assay, see
“Search for an assay to use in a run plan” on page 81.

For information to filter assays by a common trait, such as the analysis version, see “Filter the list of
assays shown when you plan a run” on page 82.

Search for an assay to use in a run plan

You can search for an assay with keywords or text that are included in the name or full name of an
assay to help find the assay that you want to use in a run plan.

IMPORTANT! Search terms must adhere to the following rules.

. An asterisk (*) is not allowed in the search field for use as a wildcard.

. Searches are case-insensitive, that is, both upper-case and lower-cases letters are found regardless
the case of search term letters.

. Searches find every occurrence of a continuous string. For example, a search for demo in analysis
names returns a list of all analysis with a name that includes demo. For example, demo1, demo2,
and so on.

. Spaces are removed during searches, and therefore are not recommended. For example, a search for
demo 1 would return results only for data that includes the string demo1.

1. In the menu bar, click Runs, then click Sample to Result, Nucleic Acid to Result, Library to
Result, or BAM to Result, based on the type of run that you want to plan.

2. Enter and make the selections in the Setup step, if applicable, then click Next.

3. In the Assays step, in the Assay Full Name column heading, click Y (Filter).
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4. In the search field, enter a full or partial assay name of at least 3 characters.

When you have entered at least 3 characters, the filter dialog box limits the list in the filter dialog
box based on the entry.

5. In the filter dialog box, select assays from the limited list.

* Select a checkbox next to an assay name to select one or more assays.
¢ Click Select All to select all of the assays in the filter dialog box.
¢ Click Clear to close the filter dialog box.

6. Click Filter.
In the column heading, (Filter) changes color to indicate that a filter is applied.

The filtered list of assays is shown in the Assays step. You can select the assay of interest from the
limited list and proceed through the remaining steps for the run plan. see “Plan a Sample to Result run”
on page 66, “Plan a Nucleic Acid to Result run” on page 72, “Plan a Library to Result run” on page 76,
or “Plan a BAM to Result run” on page 80.

Click {x] Clear Filters to remove all filters and view the full list of assays.
Filter the list of assays shown when you plan a run

When you plan a run in Genexus™ Software, you can apply filters to narrow the list of assays that are
shown to help find the assay that you want to use in the run plan.

1. In the menu bar, click Runs, then click Sample to Result, Nucleic Acid to Result, Library to
Result, or BAM to Result, based on the type of run that you want to plan.

2. Enter and make the selections in the Setup step, if applicable, then click Next.

3. Select from the filter and search options in the column heading of interest.

Option Description

List assays according to 1

. ) . Click Y (Filter) in the Analysis Version column.
the analysis version

2. Select one or more of the versions that are shown, then click Filter.

List assays according to 1. Click Y (Filter) in the Chip Type column.

chip type
PP 2. Select lon Torrent™ GX5™ Chip or lon Torrent™ GX7™ Chip then
click Filter.
List assays according to 1. Click Y (Filter) in the Library Chemistry column.

library chemist
orary ISty 2. Select the library chemistry:

* AmpliSeq - The standard library preparation chemistry for
targeted next-generation sequencing.

* AmpliSeq HD - High sensitivity library preparation chemistry for
targeted next-generation sequencing with unique molecular tags
to reduce the number of false positives and improve confidence
in variant calling.

3. Click Filter.
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4. (Optional) Click <] Clear Filters to return to the entire list of assays.

5. In the shortened list of assays, select one or more checkboxes in the Research Application
column for each assay that you want to add to the run, then click Next.

6. Click the Filter Assays By dropdown menu, if applicable, then select Assigned to list only the
assays that you have selected for the run plan.

* C(Click Filter Assays By » All dropdown menu, to show all assays again, if desired.

You can proceed through the remaining steps for the run plan. For more information, see “Plan a
Sample to Result run” on page 66, “Plan a Nucleic Acid to Result run” on page 72, “Plan a Library to
Result run” on page 76, or “Plan a BAM to Result run” on page 80.

Manage runs

Run plans are listed in the Runs / Manage Runs screen. The most recently created run is on the top of
the list. Only runs that have not started are listed.

In this screen, you can:

* Planarun. e Editarun plan.
* Sort and search the list of run plans. ® Delete arun plan.
* Review and print a run plan. * View, add, or delete the notes for a run plan.

* View the audit trail of a run plan.

View a run plan
You can view detailed run plan information in Genexus™ Software.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, click the run name of interest.
Run plan details are shown in the run plan summary pane. For more information, see “Run plan
details” on page 84.

3. When you are finished viewing the run plan details, click another run name to view details for
another run plan, or click X (Close) to return to the Manage Runs screen.

4. (Optional) Click & Print to print the information about the run.
To print the run plan, you must allow pop-ups in the browser.

You can click --- (More Options) to perform more actions, such as edit, add notes, or audit the run
plan. The actions for each run plan are also available in the Manage Runs screen when you place the
pointer over the row of a run name. For more information, see “Edit a run” on page 86, “Add a note to
arun” on page 87, “Review and download a run history” on page 85.
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Run plan details

Detailed run plan information is shown in the run plan summary pane.

Run plan detail

Description

Generate Report

Indicates if a report is automatically generated for the run.

Server The lon Reporter™ Software account or the Genexus™ Software account
and the software version that was selected for uploading BAM files when
the run is complete.

Run Status The run status. For example, Planned or Purification Planned.

Run Start Date

This information is available when the run is started.

Run Completion Date

This information is available when the run is completed.

Sequencing!']

Consumables Required For This
Run

A list of the required consumables, for example, the chip and barcodes.
The quantity of each consumable is shown in parentheses before the
name of the consumabile.

Consumables Installed Ready
To Use

A list of consumables installed on the sequencer and available for the
run.

Primer Tube Positions

An image that shows the locations of the primer pool tubes.

Sample Locations

Detailed sample information and an image that shows sample locations
on the 96-well plate. For more information, see “The run summary” on
page 147.

Assays

Assay

Detailed assay information for each assay in the run. For more
information, see “The run summary” on page 147.

' The Sequencing section is collapsible and expandable.

Additional information for Sample to Result runs

Run plan detail

Description

Purification[-2l

Consumables Required For
Purification Batch x

A list of the required consumables. For example, the Quantitation Plate
and Quantitation Tubes. The quantity of each consumable is shown in
parentheses before the name of the consumable. Information for each
purification batch is listed in a separate table.

Input Sample Locations For
Purification Batch x

Detailed sample information and an image that shows sample locations
on the 96-well plate. Information for each purification batch is listed in a
separate table.

' The Purification section is collapsible and expandable.
' For information about purification batches, see “Integrated nucleic acid isolation in Sample to Result runs” on page 66.
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Print a run plan

You can print detailed run plan information in Genexus™ Software.

1. In the menu bar, click Runs » Manage Runs.
2. In the Manage Runs screen, click a run name in the list.

3. Click & Print to print the information about the run plan.
To print the run plan, you must allow pop-ups in the browser.

Run plan details are shown in the run plan summary pane. You can review the information that was
entered or generated when you created the run. For more information, see “Run plan details” on
page 84.

Review and download a run history
The entire history of a run plan is available to review, export, or print in Genexus™ Software. The history
shows the original run plan values and any new values or activities.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, place the pointer over the row of the run plan of interest, then click
Audit.

The Audit Details screen opens with time-stamped audit records that include run plan details and
changes for each action performed on the run plan. Details for the most recent action are shown.

3. Click the time stamp and action listed in the left pane of the screen to view audit details for other
actions.

4. Review the audit record.

Details in the audit record

Item Description
User name The name of the person who was signed in when the action was
performed.
Run Plan The name of the run plan.
Data Object Name The data object that is affected by the action.
Action Performed Actions performed on the run plan include:
* Create
* Edit
Time Stamp The time and date of the action.
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Details in the audit record (continued)

Item Description

ID An identifier to represent a specific action in the audit record.
Each action in the audit record includes a unique identifier.

New Values A list of all values in the run plan. If a value changed as a result of
the action, the new value is shown.

Old Values A list of the previous values in the run plan.

5. Click Download to generate a PDF file, if needed.

Depending on the browser settings, the software automatically downloads the file or prompts you
to open or save the file.

6. Click < Back to return to the list of runs.

Edit a run

You can edit runs that have a run status of Planned or Purification Planned. Parameters that can be
edited include reporting options, assays used in the run, samples included in the run, chip assignment,
and sample concentration.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, place the pointer over the row of the run plan of interest, then click
Edit.

3. In the Edit Sample Run workflow, change the desired settings by navigating through the steps
clicking Next, then click Save.

For more information about the settings, see “Plan a Sample to Result run” on page 66, “Plan a
Nucleic Acid to Result run” on page 72 and “Plan a Library to Result run” on page 76.

Delete a run

You can delete runs from the software.

You must select at least one run in the Manage Runs screen before the option to delete a run appears.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, select one or more runs to delete by selecting the checkbox next to
the run name.

Select all of the runs in the screen by selecting the checkbox above the column.
If needed, click Clear to deselect all of the runs.

3. Click 1] Delete.

4. Inthe Delete Plan message box, click Yes to delete the selected run.
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Add a note to a run

You can add a note or notes to Nucleic Acid to Result and Library to Result runs that have a
run status of Planned, or Sample to Result runs that have a run status of Purification Planned in
Genexus™ Software. A note is any written comment or observation that you want to add to the run.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, place the pointer over the row of the run plan of interest, then click
Notes.

3. Inthe Add Notes pane, click 4 Add Note.
4. Inthe Add Notes dialog box, enter the note.
5. Click Save.
The note appears in the Add Notes pane of a selected run in the list of runs.

View a run note

You can view the notes that have been added to a run. Run notes are time-stamped written notes to
capture comments or observations for a run that is planned or completed. A run can contain multiple
notes from different users.

You cannot edit run notes. However, you can add multiple notes to a run.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, place the pointer over the row of the run plan of interest, then click
Notes.

3. Review the note or notes information.
Delete a run note

You can delete a run note in Genexus™ Software.

Notes record any written comments or observations for a run plan.

1. In the menu bar, click Runs » Manage Runs.

2. In the Manage Runs screen, place the pointer over the row of the run plan of interest, then click
Notes.

3. Inthe Add Notes pane, in the row of the note you want to delete, click [i (Delete).

The note is no longer listed in the Add Notes dialog box and the note is removed from the software.

Click Close to return to the Manage Samples screen.
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In the Dashboard screen you can view instrument status and details for recent and current runs.
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Genexus | lon Torrent Dashboard  Samples Runs  Results Assays A & 2
Dashboard
Recent Runs —@ Welcome  admin
ADF_OCAv3_DNA2 Analysis In Progress ch_OCAv3_DnF_4778439 QC Status
v 5Pass
Cpy_OCAv3_DNA_1 Analysis Aborted Analysis Completed —@ O
Cpy_OCAv3_DNA_28 Analysis In Progress ° ° ° °
o i Purification  Quantification Library Templating Sequencing Analysis Plugins
Cpy_OCAv3_DnF_47 Analysis Completed
Results
ADF_OCAv3_DnF4 Analysis Completed
CpyOCAV3DNFA4516433
SRTestSample0l SRTestSample02 SRTestSample03 v
SRTestSample04 v SRTestSample05
Instruments —@ C Refresh

GNXP-0017

DL_TSBuffer_17
Run Completed

lon Torrent™ Genexus™ FFPE DNA/RNA
Purification Combo Kit

Batch 1: Started

100% Completed

Run
DL_TSBuffer_17

Serial Operator
0022 ion
Started Estimated Completion
Mon Mar 29 14:46:00 EDT Time
2021
Details ~

Systeml = G
Re_GenericHDRNA_assayPage
Templating Completed

lon Torrent™ GX5™ Chip
21DAGK01664241GX5, 3 lanes consumed

Templating

Run
Re_GenericHDRNA_assayPage

Serial Operator
0022 Autol
Started
2021-04-1317:50

Details A~

@ The five most recent runs are listed in the left pane.

* You can click the row of a run of interest to view details for the run in the right pane.
* You can click the name of the run to leave the dashboard and view the results for the run.

@ Instruments that are integrated with the software are shown.

@ In the details pane on the right, you can place the pointer over the status for the run to view the progress of the run.

@ For the recent run that is selected in the left pane, each assay for the run is shown. You can click the name of an
assay to leave the dashboard and open the results for the run and view assay metrics.

@ For the recent run that is selected in the left pane, each sample in the run is shown. You can click a sample name to
leave the dashboard and open the sample results.
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View run progress on the instrument

You can view details for the five most recent and current runs in the Dashboard in Genexus™ Software.

Runs that are reanalyzed are listed with & (Reanalysis) after the run name. For more information, see

“Reanalyze a run” on page 192.

1. In the menu bar, click Dashboard.

2. In the Dashboard screen, in the Recent Runs section, view information for recent runs.

Option

Description

View detailed run result
information for completed runs.

In the left side of the screen, click the run name of interest.

The Run Summary tab opens. For more information, see “The run
summary” on page 147.

In the menu bar, click Dashboard to return to the Dashboard.

View the quality control
information.

In the left side of the screen, click the row of the run of interest.
The QC status for the run and for the samples is shown in the
details pane in the right side of the screen. For more information,
see “QC results” on page 133.

View assay-level metrics and
results for the run.

1. In the left side of the screen, click the row of the run of
interest.

2. In the run details pane in the right side of the screen, click the
assay name of interest.

The Assay Metrics tab opens. For more information, see “Assay
metrics and the run report” on page 151.

In the menu bar, click Dashboard to return to the Dashboard.

View the sample results.

1. In the left side of the screen, click the row of the run of
interest.

2. In the run details pane in the right side of the screen, click the
sample name of interest.

The Key Findings tab opens. For more information, see “Key
findings” on page 99.
In the menu bar, click Dashboard to return to the Dashboard.

90
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Option

Description

View the progress of the run.

1. In the left side of the screen, click the row of the run of
interest.

2. Inthe run details pane in the right side of the screen, place the
pointer over the status for the run.

A progress bar for the run is shown. Steps in the run that are
complete are listed with a check mark. Steps that are in progress
are shown with a flashing circle. Steps that remain to be completed
are listed in grey. If any failures occur, failed steps are also listed in
grey.

Analysis In Progress

o o o

Library Templating Sequencing

\ [ 6 o
!

@ Completed steps are shown with a check mark. In
this example, Library preparation, Templating, and
Sequencing are complete.

@ Steps that are in progress are shown with a flashing
circle. In this example, Analysis is in progress.

@ Steps that remain to be completed are shown in grey.
In this example, the Plugins step remains to be started
after Analysis is complete.

Tip: If the recent run includes many samples, limit the samples that are listed. For more
information, see “Filter the list of samples shown in the dashboard” on page 92.
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Filter the list of samples shown in the dashboard
You can apply filters to shorten the list of samples shown in the Dashboard in Genexus™ Software.
1. In the menu bar, click Dashboard.

2. In the Dashboard screen, in the Recent Runs section, click the row of the run of interest.
Assays and samples in the run are listed in the details pane in the right side of the screen. In
addition, the QC status is shown.

3. In the details pane, filter the list of samples.

Option Description

Shorten the list of samples. | Click ¢ (Filter), select the samples of interest, scroll to the bottom of the
filter dialog box, then click Filter.

(Filter) changes color to indicate that a filter is applied.

Refine the samples shown | In the details pane, in the QC Status section, click Pass to list only
by the QC status of the samples that passed QC metrics or click Fail to list only samples that
sample result. failed QC metrics.

The list of samples is filtered according to the selections.

Click {x] Clear Filters to remove all filters and view the full list of samples.

View the status of an instrument

You can view the status of the Genexus™ Integrated Sequencer and any Genexus™ Purification
Instrument that is integrated with Genexus™ Software.

1. In the menu bar, click Dashboard.

2. In the Dashboard screen, in the Instruments section, view the status of an instrument.
The following information is provided for all integrated instruments.
* instrument name
* run status of the current or most recent run
* PQ status

e A (Alarms)- instrument alarms, if any

If the instrument displays one or more alarms, the number of alarms is shown in parentheses.
You can place the pointer over Alarms to view more information about an alarm.

3. In the Instruments section, in an instrument pane, click Details to view the current or most recent
run name, serial number, the operator, run start and completion times, and instrument alarms, if
any.

Tip: Check the status of a purification instrument for Run completed waiting user input to know
when you must perform an action to proceed through the run.

4. Click C Refresh to update the information.
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Information about connected instruments on the
Dashboard

The following information is available in the Dashboard screen. You can expand the Details section for
each instrument to view more information.

Item Description

Run The name of the run that is in progress or the last completed run on the
instrument.

Serial The serial number of the instrument.

Operator The name of the operator who started the run on the instrument.

Started The date and time that the run started on the instrument.

Last Init The last initialization completion date and time.

PQ Status Indicates whether the performance qualification (PQ) status of the
instrument is Verified or Expired.

Next PQ Due The expiration date of the current PQ verification run. Expiration of the PQ
status prevents the instrument from performing a non-PQ run until a valid
PQ run has been performed and signed off.
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Use the Results menu to review results and data analysis, and to perform data management tasks. You
can view results sorted by sample or by run.

Selection Description

Click Results » Sample Results Select this option to review completed sample results and
reports.

Click Results » Run Results Select this option to review completed run results and reports
by assay.

Click Results » Verification Results Select this option to review data from completed verification
runs that were performed during sequencer installation or
performance qualification.

Results navigation bar overview

94

After you select a run result or a sample result, a results navigation bar appears and allows you to

easily toggle between different results screens for each run. You can quickly switch between run-level
results, assay-level results, and sample-level results for the run. In addition, you can easily find samples
or assays in the run with the search field that appears in each dropdown list.

Assay-level results include assay metrics, such as final read data.

Samples that are run with the same assay in the same run share the same run report. All other results
are specific to the sample and are shown in the sample results.
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Results navigation bar overview
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o

Results / OPAlY / SelectAssay ¥ / Select Sample ¥

OPA1l

Run Report RunS | |
Select Sample
Run Name: OPAl
_ Samplel_OPA
Run Status: Analysis
Completed Sample2_OPA
Library AmpliSeq HD Sample3_OPA
Chemistry:
Callout Dropdown menu Description
1 Run name The run name is listed. Multiple runs are listed only if the run has been
reanalyzed. For more information, see “Reanalyze a run” on page 192.
2 Select Assay You can click the assay name of interest to view assay metrics for the run.
You can search for or toggle between different assays used in the run. If only
one assay is associated with the run, only one assay name is listed.
Some results from a plugin that is included in the run, such as the customer
support archive plugin, apply to all of the samples for an assay in a run. In this
case, the results from assay-level plugin are shown in the Plugins tab when you
select an assay but do not select any samples for the run. For more information
about plugins, see Chapter 11, “Plugins for data analysis”.
You can select Select Assay from the dropdown menu to remove the assay
selection. If you remove the assay and sample selections, the Run Summary
tab opens with a summary of results for the run selected in the Run Results
dropdown menu. Assay metrics are also shown in the Run Report tab. For more
information, see “Assay metrics and the run report” on page 151.
3 Select Sample You can click a sample name to view the sequencing results for the sample. You

can click a different sample name to view other sample results for other samples
in the run for the assay that is selected in Select Assay. The search field allows
you to find samples in the run.

For Sample to Result runs that include a positive control, results for the positive
control are shown when you select Control Sample.

You can select Select Sample from the dropdown menu to remove the sample
selection. If you remove the sample selection, the Assay metrics tab for the
selected assay opens. If you select Select Assay with Select Sample shown,
the Run Summary tab opens. Assay metrics are also shown in the Run Report
tab. For more information, see “Assay metrics and the run report” on page 151.
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Review sample results

In the Results / Sample Results screen, samples that have been sequenced are listed by sample

name.

See “Find sample results” on page 140 for information about how to find sample results of interest.

The following information appears in the Sample Results screen. You can add columns to the Sample
Results table to view more information. For example, you can add a column for Electronic Signatures
to view signature and lock information for variant reports. For more information, see “Customize the
sample results table” on page 139.

Column

Description

Sample Name

The unique identifier created when the sample was entered into the software. Click the
Sample Name to open the Sample Results screen for the sample.

Assay Name

The name of the assay used in the run plan.

Run Name

The unique name of the run given when it was created in the software.

Sample Status

The status of the run or sample (for example: Completed, Running, Failed, Terminated,
Pending, Stalled).

Annotations

QC Status The QC status of a completed run.
. (Passed) indicates the sample passed all QC metrics.
¢ X (Failed) indicates the sample failed a QC metric.
® — (Not Calculated) indicates a sample did not undergo QC analysis.
Started On The date and time when the run was started.
Updated On The date and time when the last action was completed on the run.
Tags Tags that are assigned to the sample are listed.
Updated The information that is shown depends on the type of the assay and whether the option to

use the latest annotation is configured in the assay.

* The name and version of the annotation source that is applied to the sample result is
shown when an assay is configured to use the latest annotations but the annotation
that is applied to the results is not the latest annotation source.

* No information is shown in the column (the value is blank) when the latest annotation
source version is applied to the result, regardless of whether the assay is configured to
use the latest annotation source.

* No information is shown in the column (the value is blank) when an assay is configured
to not use the latest annotation source, and instead uses a fixed version of an
annotation source.

* N/A is shown when an assay does not use an annotation set.

You can also perform the following actions in the Sample Results screen.
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Option

Description

Actions

Available action links for a sample are shown when you place the pointer over the row of a
sample.

Report—Download the report (available only for samples with a sample status of
completed).

For more information, see “Variant report” on page 198.

Assign Tags—Add or remove the tags assigned to a sample result.

For more information, see “Sample tags” on page 46.

Audit—View the audit trail for the run.

For more information, see “Review and download a run history” on page 85.
Notes—View, add, or delete notes for sample result.

CSA—Download customer support archive (CSA) log files for the run to help with
troubleshooting.

For more information, see “Download a Customer Support Archive” on page 428.
Reanalyze —Reanalyze a sample from the alignment step when a sample or reanalysis
successfully completes the basecalling step.

For more information, see “Reanalyze a sample” on page 194.

Variant Audit—View the history of variant classifications.

Actions that you can
perform when you
select samples

More actions are shown when you select one or more samples.

Assign Tags—Assign a tag or tags to selected sample results in one action. The ©
Assign Tags command appears above the Sample Results table after you select one
or more samples.

For more information, see “Assign sample tags to multiple sample results” on page 138.
Compare—Compare variant results between multiple samples, or from a single sample

over time. The Compare command is not shown until you select at least two
samples.

For more information, see “Compare sample results” on page 161.
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View sequencing results

1. Click Results » Sample Results to view sequencing results, including variant and fusion calls, for
a particular sample.

2. In the Sample Name column, click a sample name.

3. In the Results screen, click the tabs to view the different types of sample-specific results and data.

Tab Description

QC The quality metrics for the sample sequenced in the run. For more information, see “QC
results” on page 133.

Key Findings An overview of the results for the sample, including Sample Details, Key Metrics, Genes,
and Coverage graphs. For more information, see “Sample summary” on page 37.

Variants Detailed variant results for SNVs/Indels, Fusions, and CNVs. For more information, see
“View variant results” on page 103.

Plugins Results generated from the plugins associated with the assay used to analyze the
sequenced sample. For more information, see Chapter 11, “Plugins for data analysis”.

Reports You can download and generate summaries of run results. There are two types of reports:
* Run reports — include assay metrics and the record of reagents that were used in a run.

* Variant reports — include the variant results for each sample in a sequencing run,
reagents used, and QC evaluation metrics.

For more information, see Chapter 7, “Create, view, and sign reports”.

View key findings

You can view Sample Details, a summary of the metrics for the run, and the Key Variants matrix for
genes assayed in the run in Genexus™ Software.

1. In the menu bar, click Results » Sample Results.
2. In the Sample Name column, click the sample name of interest.

Review the key findings. For more information, see “Sample summary” on page 37.
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The Key Findings tab shows details about the sample, a summary of key metrics for the run, and key
variants for genes assayed in the run.

Note: The Key Findings tab is by default the first view that is first shown for sample results.

The information that is displayed depends on the assay that was used in the run.

Sample details

Section

Description

Sample Name

A unique identifier representing the sample.

Collection Date

The date that the sample was collected.

Gender

The biological sex of the sample: Female, Male, or Unknown.

Sample Type

A term that describes the sample, for example, FFPE, DNA, DNA & RNA.

Application Category

The application type of the sample.

Cancer Type

The type of cancer that is represented by the sample.

Cancer Stage

The stage of the cancer from which the sample was collected.

%Cellularity

The percentage of tumor cellularity in the sample. This is a whole number between
1 and 100. The % Cellularity attribute is entered when a sample is created.

This attribute applies only to FFPE samples.

Key metrics

Section

Description

Target Coveragell

Target base coverage at Nx

The percentage of reference genome bases covered by at least N reads.

Amplicon Summary

Average Base Coverage
Depth

The average number of reads of all targeted reference bases. This is the total number
of base reads on target divided by the number of targeted bases, and therefore
includes any bases that had no coverage.

Uniformity Of Base
Coverage

The percentage of bases in all targeted regions (or whole genome) with a depth
of coverage =20% of the mean read coverage. Cumulative coverage is linearly
interpolated between the nearest integer base read depths.

Percent Reads On Target

The percentage of filtered reads that are mapped to any targeted region relative to all
reads mapped to the reference. A read is considered on target if at least one aligned
base overlaps at least one target region. If no target regions (file) was specified, this
value will be the percentage of reads passing uniquely mapped and/or non-duplicate
filters, or 100% if no filters were specified.

[ Metrics are shown only for analyses that run the coverageAnalysis plugin.

Genexus™ Software 6.8 User Guide 99




2¥ Chapter 6 Review data and results
Review sample results

The Key Variants matrix

The Key Variants matrix provides a color-coded visual representation of the variant results. When the
application category of the sample is Solid Tumor, Cancer (Germline) or Hematologic Cancer, the
genes that are shown in the Key Variants matrix are determined by the filter chain and the gene list
applied to the results. You can change the filters that are applied to expand or restrict the genes that are
shown. For more information, see “View the Key Variants matrix” on page 100.

Each tile in the Key Variants matrix represents one gene and indicates whether a variant is detected
or not. Note that a single gene is represented with multiple tiles when there are multiple mutations
detected in that gene.

View the Key Variants matrix

You can view a color-coded visual summary of variant results in Genexus™ Software.

1. In the menu bar, click Results » Sample Results.

2. Click a sample name.

The Results screen opens to the Key Findings tab, which shows the Sample Details, Key
Metrics, the Key Variants, and the Coverage Graphs.

3. Refine the genes that are shown in the Key Variants matrix.

Action Procedure

Hide the genes that are not Deselect the Not Assayed checkbox.
assayed.

Refine the genes that are shown in 1. Click Edit Filters.

the Key Variants matrix.
y 2. To refine or expand the genes, change one or both of the

filters.
* Select a different filter chain or no filter chain.
For more information, see “Filter results” on page 121.
* Select a different gene list or no gene list.

For more information, see “Gene lists (manager/
administrator)” on page 243.

3. Click Save.

Here is an example Key Variants matrix.
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SRTestSample01 QC Key Findings ~ Variants Plugins Reports

Sample Details

Sample Name Collection Date Gender Sample Type Application Category Cancer Type Cancer Stage %Cellularity
SRTestSample0l 29APR2018 Male FFPE Cancer Non-Small Cell Lung Cancer Primary 10
Key Metrics

Amplicon Summary

Average Base Coverage Depth Uniformity Of Base Coverage Percent Reads on Target
1705 94.14% 97.05%
Key Variants ’ ’ ’ , Qs ®
[ Key Variants Detected ] [ Other Variants Detected } [ None Detected ] Not Assayed Not Assayed (4) Oncomine Variants (5.14) filter chain and Non-Small Cell Lung Cancer gene list applied m
(7
KRAS \|J SNV/Indel ALK BRAF EGFR
KRAS G13D

AA Change: p.Gly13Asp
Allele Frequency: 0.39

MET NTRK2 NTRK3 ERBB2

NTRK1 RET ROS1

@ Key Variants Detected — A gene is present in the gene list, variants are called by the Oncomine™ Variant Annotator,
and the variants are Key Variants. Genes that are called are listed in the Variants tab with Present in the Call
column. Key Variants are listed in the Variants tab, with a value of Yes in the Key Variant column. For more
information about gene lists, see “Gene lists (manager/administrator)” on page 243.

@ Other Variants Detected — A gene is present in the gene list and variants are called by the Oncomine™ Variant
Annotator, but the variants are not Key Variants. Genes that are called are listed in the Variants tab with Present
in the Call column. Variants that are not Key Variants are listed in the Variants tab, with a value of No in the Key
Variant column. For more information about gene lists, see “Gene lists (manager/administrator)” on page 243.

@ None Detected — A gene is present in the gene list but no variants are called by the Oncomine™ Variant Annotator.
@ Not assayed — A gene is present in the gene list, but is not included in the panel used in the assay.
@ Checkbox to hide or show genes that are not assayed.

@ Edit filters allows you to select an available filter chain and gene list. Changes of the filter chain or gene list change
the genes that appear in the Key Variants matrix.

@ Variant Name - The name of the variant. The Variant Name is a hyperlink to the pileup for the variant in the Variants
tab.

Gene tiles in the Key Variants matrix

Each blue tile in the Key Variants matrix represents a variant and summarizes information for the
variant.
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¥

KRAS SNV/Indel |—@
(2)——cosm19940
O

— AA Change: p.K117N
Allele Frequency: 0.047
|

®

@ The gene name. @ The number of variant read counts divided by the total
() The Variant Name - link to the variant details in the number of read counts for the sample.
Variants tab. @ The variant type.

@ The amino acid change using Human Genome
Variation Society (HGVS) nomenclature.

View the amplicon coverage

You can view DNA exon amplicon coverage in Genexus™ Software to help you determine whether

the sequencing reads across a gene are uniform and sufficient. The default genes that are shown are
determined by the gene list that is designated as default for the cancer type of the sample. You can also
view amplicon coverage graphs for more genes. These amplicon coverage graphs provide a high-level
overview of coverage. More detailed coverage information is also available in the software.

1. In the menu bar, click Results » Sample Results.

2. Click a sample name to open the Key Findings tab in the Results screen.
3. Scroll to the amplicon Coverage Graphs.

4. Review the coverage graphs.

5. To show coverage graphs for more genes, scroll to the bottom of the screen. Click Show
Coverage for Gene, then select the gene of interest.

6. You can adjust the amplicon coverage graph with the pointer and the buttons in the upper right
corner of each graph. The coverage graphs change to show coverage for the selected gene.

Action Procedure
Zoom in on a region of interest. Click @ one or multiple times.
Zoom out for an expanded view. Click @ one or multiple times.
Revert to the default view. * (Click @ one or multiple times.
¢ Click Reset.
Move the image left or right in the screen. | After you zoom in, click-drag at any position in the image.

Example amplicon coverage graph

Here is an example of an amplicon coverage graph for the KRAS gene.
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@ The location of the known hotspots are denoted with gray bars.

@ The location and span of the amplicons are represented with orange bars. You can hover the mouse over an orange
bar to view the amplicon name.

@ The location and span of the transcript track is denoted with green bars. You can hover the mouse over the green bar
to view the exon number.

(® The line along the x-axis is broken to indicate that the graph is discontinuous to show exons.
@ The genome coordinate position is shown on the x-axis.

@ Called variants are indicated with a vertical line above the blue coverage plot. The variants noted in the graph depend
on the filter chain applied to the results in the Key Variants matrix. For more information, see “View the Key Variants
matrix” on page 100.

You can place the pointer over the hotspots that are represented with gray lines to view the hotspot name.
@ You can adjust the amplicon coverage graph. For more information, see “View the amplicon coverage” on page 102.

View variant results

You can view detailed variant results in the Variants table. In the default view, all variants are listed. You
can download the information for the variants in XLS or TSV format.

You can make changes to the filter chains that are applied to the variants. For more information, see
“Filter results with a filter chain” on page 122.

You can also limit the types of variants that are shown and toggle between different variant results:
SNVs/Indels, Fusions, and CNVs.

Variant Tables

Variant type Description

SNVs/Indels * SNVs: missense and nonsense single-nucleotide variants. Multi-
nucleotide variants are also included.

* |ndels: insertion and deletion variants.

For more information, see “View SNV/INDEL results” on page 104.
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Variant Tables (continued)

Variant type Description

Fusions Translocations of genetic material.

For more information, see “View fusion results” on page 110.

CNVs Copy number variations (CNVs) are variations of the number of copies

of a given gene.

For more information, see “View CNV results” on page 117.

View SNV/INDEL results

The SNVs/Indels table lists the calls and other information for the SNV and INDEL variants that are
analyzed in each sample in a run.

1. In the menu bar, click Results » Sample Results.
2. Click a sample name to open the Results screen.
3. Click the Variants tab.
4. Click SNVs/Indels to view the SNVs/Indels table.
For more information about the data shown in the table, see “SNVs/Indels table” on page 104.
5. Click Export in the upper right corner of the screen to export the results data in XLS or TSV format,
if needed.
The information that is included in the file is based on the gene list, the filters that are applied to
each column, and filter chain that is applied.
* The file in XLS format contains the information that is shown in the SNV/Indels variant table.
e The file in in tab-separated value format (TSV) format contains the information that is shown
in the SNV/Indels variant table, and information for table columns that are available but not
currently shown in the SNV/Indels table. The file also includes information that is listed in the
Annotations table.
SNVs/Indels table

The data displayed in the SNVs/Indels table depends on the assay that was used in the run.

You can filter the results list in the table using filtering tools and filter chains. For more information, see
“Filter results” on page 121.

Column Description

User Classifications | User-defined classification to select from the list.

For more information, see “Create and assign variant classifications” on page 126.

Variant ID The name of the hotspot as defined in the Browser Extensible Data (BED) file.
Click the link to view more annotation information. For more information, see “View more
annotations and annotation sources” on page 133.
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Column

Description

Variant Name

The name of the variant.

Key Variant Indicates whether the variant is a key variant.
Possible values are Yes or No.
This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Locus The chromosome and position of the detected variant.

Oncomine Variant
Class

The type of SNV or INDEL at the locus based on Oncomine™ annotations.

This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Oncomine Gene
Class

The change in molecular function of the altered gene product due to the mutation, based on
Oncomine™ annotations:

¢ Gain-of-function—The altered gene product has a new molecular function or pattern of
gene expression compared to the wild-type gene

¢ Loss-of-function—The altered gene product lacks the molecular function of the wild-
type gene

This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Gene The gene name.

AA Change Identification of the amino acid change using Human Genome Variation Society (HGVS)
nomenclature.

Ref The reference base or bases at that locus.

Alt The alternate base or bases at that locus.

Type The type of variant that is detected.

* snp (single nucleotide polymorphism)
* mnp (multi-nucleotide polymorphism)
* ins (insertion)

* del (deletion)

e complex

e FLT3-ITD
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(continued)
Column Description
Call Indicates the presence or absence of an SNV/Indel variant. When the default filter chain
is applied, only the variant calls that are designated with PRESENT (HOMOZYGOUS) or
PRESENT (HETEROZYGOUS) are displayed in the results table. To view all calls, including
calls that do not pass the required filter thresholds, apply the No Filter option or download
the Variants (VCF) file (see “Results files” on page 171).
¢ PRESENT (HOMOZYGOUS) or PRESENT (HETEROZYGOUS)—Indicates a high
confidence call that passes all filter thresholds at a given variant position.
— When the default filter chain is applied, PRESENT (HOMOZYGOUS) or PRESENT
(HETEROZYGOUS) indicates the presence of the ALT (alternative) allele.
— When the No Filter option is applied or when viewing the Variants (VCF) file,
Present does not imply the presence of the ALT (alternative) allele. To infer the
presence of the ALT allele, see the Alt column.
* NO CALL—Although some evidence for the presence of a variant exists, the call does
not pass one or more filters that are required for a high confidence variant call.
e ABSENT—Indicates that the variant is unlikely to be present in the sample.
Call Details The reason why a variant is reported as NO CALL.

Phred QUAL Score

The relative probability of either the "reference" hypothesis interval [0,cutoff], or the
"variant" hypothesis interval [cutoff,1], Phred-scaled (-10*log10). A higher score means more
evidence for the variant call.

Raw Read Depth

Total read coverage across amplicon containing SNV/Indel hotspot locations. Count of
chip-level reads aligned at this locus that participate in variant calling.

Effective Read Depth

The number of reads covering the position.

Alt Allele Read The number of reads containing the alternate allele.
Counts

Coverage The number of total reads at a locus, wild-type + alt allele.
Nuc Change The position and identity of the nucleic acid change.

Allele Frequency

The number of variant read counts divided by the total number of read counts for the
sample.

Allele Frequency (%)

The allele frequency, represented as a percentage.

Allele Ratio The relative frequency of each allele.
Mut/WT The ratio of mutant allele to wild-type allele.
Zygosity Describes whether the variant is homozygous (0) or heterozygous (1).

Filtered Read
Coverage

Coverage at the position considering only filtered reads.

Allele read Count

The number of reads detected for the allele. The Allele Read Count filter sets the minimum
count of the genotype alleles.
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Column

Description

Raw Alt Allele Read
Counts

The number of unfiltered reads containing the alternate allele.

PPA Possible Polyploidy Alleles (PPA).
A value of Yes indicates variants that are PPA alleles. A value of No indicates variants that
are not PPA alleles.

P-Value The probability value for the detection of variant calls.

Mol Depthl'] The reports number of interrogated DNA molecules containing target. This metric defines

the limit of detection at a hotspot position in a particular run and sample. For reference
calls, molecular depth provides a measurable metric that serves as confirmation of variant
absence among a large number of interrogated molecules. For instance, if molecular depth
is 21,500, you can have high confidence that no variant is present at =0.2% variant allele
frequency. If molecular depth is =2,500, you can have high confidence that no variant is
present at =0.1% variant allele frequency.

WT Mol Countsl']

The number of detected molecules containing the wildtype allele.

Alt Allele Mol
Countsl!l

The number of detected molecules containing the alternate allele.

Mol Freq %!

Molecular frequency percentage. The percentage of alternate allele reads over total reads at
the locus.

% LODI]

the limit of detection (LOD) of a variant allele expressed as a percentage of the WT allele.
LOD is the lowest possible variant frequency in the sample that can be detected by the
system with a true positive rate greater than 98% for FFPE samples or 95% for cfTNA
samples. LOD is dependent on the molecular read depth at the locus. %LOD is reported
when there are no variant calls for the gene.

' Column appears only in analyses of lon AmpliSeq™ HD sequencing data.

View TMB results

You can view graphs and charts in Genexus™ Software for some assays to help you visualize the
amount and type of tumor mutational burden (TMB).

1. In the menu bar, click Results » Sample Results.

2. In the Sample name column, click the name of the sample of interest.

3. Click the Variants tab, then click SNVs/Indels.

The SNVs/Indels table opens to display SNV/Indel results. For more information, see “View SNV/
INDEL results” on page 104.

4. In the top right corner of the screen, click Visualization » TMB, then review the TMB plots.

To return to the table view of SNV/Indel, click XX (Remove) next to the Visualization dropdown menu.
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Example results for tumor mutational burden

Germline and Somatic Variants histogram

This histogram shows the frequency distribution of allele 540
ratio for total called germline and somatic variants. 590 1
Listed below the figure is the combined total of called 480 1

400

germline and somatic variants. The value is reported in
the statistic.txt file as Variant count (Germline
+ somatic). For more information, see “QC step assay

320 4

No. of Variants

240 4

options” on page 229. 160 1
’ ] ‘l
Only Somatic Variants histogram N O R
This histogram shows the frequency distribution of allele 64
ratio for only somatic mutations as determined by the 61
selected TMB filter chain. Metrics that are listed below the 45

graph are as follows.

* The number of Total Somatic Variants reported in
the statistic. txt file as Total Somatic Filtered

No. of Variants

Variants Count (hnumerator for TMB calculation). 1 i
* Of the Total Somatic Variants, the number of SNVs ZJ | | | |
that are determined to be nonsynonymous (detrimental) e o2 4 ele ratio o8 1o

and synonymous (non-detrimental) as annotated by
the software. Values are reported by different Genexus™ Software annotation types in the
statistic.txt file.

* The number of detected somatic variants found in the COSMIC database. The value is reported in
the statistic. txt file as COSMIC Annotated Somatic Variants.

Substitution Type and Context of Somatic Mutations

No. of Mutations

C>A B T>A
C>G T>C
B C>T T>G

Somatic mutations can be divided into 6 base substitution classes (that is, C>A, C>G, C>T, T>A, T>C, T>G) based on
their substitution type. After incorporating information on the bases immediately 5’ and 3’ to each mutated base, 96
possible mutation types are in this classification. These 96 mutation types are represented on the x-axis, and variant

frequency for mutation type on the y-axis. Bars for each substitution class are grouped and displayed with different color.

A summary TXT file of these results is also available.
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Substitution Type of Somatic Mutations

A pie chart dividing somatic mutations into 6 base substitution classes (that is, C>A, C>G, C>T, T>A,
T>C, T>G) based on their substitution type.

49.1%

C>T

0.9% C>G
755 [ C>A
B T7>G
| T>C
T>A

8.5%

3.8%

30.2%

Signature Pattern of Somatic Mutations

A pie chart dividing somatic mutations in groups consistent with specific mechanisms.

18.9%

C>T at [AG]CG

C>T at [CT]CG

C>T at NCC,CC[ACT], TC[ACT]
C>T at other sites

C>A

T>Aand T>C

Rest

13.2% 13.2%

75%
9.4%

34%

In the pie chart, a small fraction of multiple signature types can be observed in the sample. However,
significant dominance of a single signature pattern often correlates to the respective tumor type. For
example, 56.7% of the variants detected (sum of blue, green, and yellow) are an observed UV damage
signature in this sample.

Note: Underlined bases represent the reference base being substituted (for example, CpG in the first
bullet is the same as [ACGT]CG).

* High C>T at CpC, CpC, TpC, T>A, and T>C is consistent with UV damage. (Blue + Green + Yellow)
For more information, see https://www.nature.com/articles/nature22071.

* High C>T at CpG is consistent with spontaneous deamination of 5-methylcytosine. (Red + Blue).
For more information, see https://www.nature.com/articles/nature12477.

* High C>A is consistent with smoking damage.(Orange)
For more information, see https://science.sciencemag.org/content/354/6312/618.full.

* High C>T (site independent) is consistent with FFPE processing. (Green + Purple)
For more information, see https://www.ncbi.nlm.nih.gov/pmc/articles/PMC4032349/.

Note: Samples of low quality that exhibit deamination (high C>T) can be analyzed if you increase
the minimum allele frequency in an assay. For more information, see “Reduce the impact of
deamination in low-quality FFPEs” on page 227.
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View fusion results

You can view calls and other information for the fusions that are analyzed within each sample in a run.

1. In the menu bar, click Results » Sample Results.

2. Click a sample name to open the Results screen.

3. Click the Variants tab.

4. Click Fusions to view the Fusions table.

For more information about the data displayed in the table, see “Fusions table” on page 110.

5. Click Export in the upper right corner of the screen to export the results data in XLS or TSV format,

if needed.

The information that is included in the file is based on the gene list, the filters that are applied to
each column, and filter chain that is applied.

* The file in XLS format contains the information that is shown in the Fusions variant table.

* The file in in tab-separated value format (TSV) format contains the information that is shown in
the Fusions variant table, and information for table columns that are available but not currently
shown in the Fusions table. The file also includes information that is listed in the Annotations

table.

Fusions table

The data displayed in the Fusions table depends on the assay that was used in the run.

You can filter the results list in the table using filtering tools and filter chains. For more information, see
“Filter results” on page 121.

Column

Description

User Classifications

A user-defined classification selected from the list.

For more information, see “Create and assign variant classifications” on page 126.

Variant ID

The name of the fusion target as defined in the BED file.

Click the link to view more annotation information. For more information, see “View more
annotations and annotation sources” on page 133.

Variant Name

The name of the variant.

For more information, see “Rules for variant names in Genexus™ Software” on page 383 .

Key Variant Indicates whether the variant is a key variant.
Possible values are Yes or No.
This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Locus The chromosome positions in the reference genome that define the fusion junction.
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Column

Description

Oncomine Variant
Class

Oncomine variant class annotation that indicates fusion type based on Oncomine™
annotations. This information is available if the Apply Oncomine Variant Annotations
checkbox is selected in the assay that is used in the run.

Oncomine Gene
Class

The change in molecular function of the altered gene product due to the mutation, based on
Oncomine™ annotations:

¢ Gain-of-function—the altered gene product has a new molecular function or pattern of
gene expression compared to the wild-type gene

* Loss-of-function—the altered gene product lacks the molecular function of the wild-
type gene

This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Genes (Exon)

The name of fusion target and representative acceptor and donor exons.

Read Counts

The frequency that the fusion was detected in the sample.

Type

Assay type (for example, Fusion, RNA exon variant (exon skipping), RNAExon Tile, Proc
Control).

Call

Indicates the presence or absence of a fusion or RNA exon variant. When the default filter
chain is applied, only the fusion/RNA exon variant calls that are designated with PRESENT
are displayed in the results table. To view all calls, including calls that do not pass the
required filter thresholds, apply the No Filter option or download the Variants (VCF) file (see
“Results files” on page 171).

* PRESENT—indicates a high confidence call that passes all filter thresholds at a given
variant position.

e ABSENT—indicates the absence of a fusion due to a variant call that falls below
thresholds.

* NO CALL—although some evidence for the presence of a fusion exists, the call does
not pass one or more filters that are required for a high confidence fusion call.

Call Details

The reason for reporting a fusion as NO CALL or ABSENT.

Read Counts Per
Million

The number of fusion read counts detected per million total reads.

Oncomine Driver
Gene

The gene believed to be associated with increased oncogenic properties. The gene is
inappropriately activated by the fusion.

Gene Isoform

The name of the fusion target as defined in the BED file.

Mol Cov. Mutantl'!

The median molecular coverage across a fusion amplicon.
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Column

Description

Imbalance Scorel?]

Each fusion gene exhibits a characteristic Imbalance Score threshold. Scores that exceed
the threshold value indicate a high likelihood of the presence of the fusion in the sample.
Imbalance score calculation starts with the normalization of reads in the exon-tiling
amplicons of the gene, followed by correction with a baseline that represents expression
values in normal samples. Reads for observed imbalance scores come from samples.
Baseline scores come from normal, fusion-negative samples and are stored in the exon
tile assay baseline file for the assay.

Imbalance score = Observed imbalance (in samples) / Expected imbalance (in the baseline)
where

Observed imbalance = 3' of breakpoint (in samples) / 5' of breakpoint (in samples)

¢ 3' of breakpoint is the sum of the normalized reads of amplicons 3' of a predicted
breakpoint for the gene in the sample.

* 5' of breakpoint is the total normalized reads of the amplicons for the gene in the
sample.
Expected imbalance = 3' of breakpoint (in the baseline) / 5' of breakpoint (in the baseline)

¢ 3' of breakpoint is the sum of normalized baseline values of amplicons 3' of the
breakpoint for the gene.

¢ 5'of breakpoint is the total normalized baseline values of the amplicons for the gene.

Imbalance P-Valuel?!

The statistical significance of measure of imbalance relative to a control gene.

Predicted Break-
point Rangel?

The exonic range for predicted fusion break point in exon tiling assays.

Ratio To Wild Typel'!

The molecular ratio for exon skipping assays relative to wild type control amplicons.

Norm Count Within
Genelll

Exon skipping assay coverage normalized to molecular coverage of wild type (WT) MET
control amplicons.

' Column appears only in analyses of lon AmpliSeq™ HD sequencing data.
] Column appears only in analyses that use the exon tiling fusion detection method.

View RNA Exon Variants

The RNA Exon Variant data view displays a bar graph summary of intragenic exon rearrangements or
fusions. The displayed RNA exon variants are defined in the BED file that is associated with an assay.
The RNA Exon Variant data view is available for all RNA and fusion assays.

1. In the menu bar, click Results » Sample Results.

2. In the Sample name column, click the name of the sample of interest.
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3. Click the Variants tab, then click Fusions.

The Fusions table opens to display fusions results. For more information, see “Fusions table” on
page 110.

4. In the top right corner of the screen, click Visualization » RNA Exon Variant, then review the RNA
Exon Variants plot.

Representative RNA Exon Variant plots

RNA Exon Variants RNA Exon Variants

gene

II I . :
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I . MET

The X-axis represents specific exon variants, where each variant is labeled with a gene ID followed by a sequence of adjacent
exons. The Y-axis measures the read counts for each variant, normalized to the wild type.
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MET.E11E12.NM_000245.2.
MET.E11E12.NM_000245.2.

@ Example result where only the wild type EFGR (EFGR.EGE7) was detected.

@ Example result where RNA exon 2-7 deletion occurred in the EFGR gene. The deletion of exons 2-7 resulted in an increase of
normalized read counts for the EFGR variant that contains the intragenic fusion of exon 1 and exon 8 (EFGR.E1E8.Del1) and a
decrease of normalized read counts for the wild type EFGR (EFGR.EGE7?).

To return to the table view of fusions, click XX (Remove) next to the Visualization dropdown menu.

View RNA Exon Tile Fusion Imbalance

The RNA Exon Tile Fusion Imbalance data view provides a visual representation of the RNA fusion
imbalance analyses.

Driver genes, for example ALK, RET, NTRK1, have amplicons that span exon-exon junctions to probe
the expression difference between the 3’ and the 5’ regions of the gene.

An imbalance score is calculated for each driver gene in a sample to quantify the magnitude of the
expression imbalance change between the two parts of the gene. For example, the 3’:5’ ratio in ALK;
and the 5’:3’ ratio in FGFR2.
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Note: The exon tiling method for fusion detection and the RNA Exon Tile Fusion Imbalance data view
are specific to the Oncomine™ Precision Assay GX. For more information, see the Oncomine™ Precision
Assay GX User Guide (Pub. No. MANO018508).

—h
.

In the menu bar, click Results » Sample Results.
2. In the Sample name column, click the name of the sample of interest.

3. Click the Variants tab, then click Fusions.

The Fusions table opens to display fusions results. For more information, see “Fusions table” on
page 110.

4. In the top right corner of the screen, click Visualization » RNA Exon Tile Fusion Imbalance, then
review the RNA Exon Tile Fusion Imbalance plots.

Representative RNA Exon Tile Fusion Imbalance plots

O ©

Fusion Imbalanlce Call: Imbalance Score & P-value Normalized Readl Depth by Gene
Imbalance Calls: Auto_Samples_c13443_2019-06-13-14-07-19-... Read Counts
T
< |
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|
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| o _ B FGFR1
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@ The Fusion Imbalance Call: Imbalance Score & P-value plot shows the imbalance scores and p-values for all the genes in
the selected sample. The dashed gray lines mark the threshold for an imbalance call, which is applied to all genes across all
samples. Points that fall within the blue shaded area of the plot represent fusion-positive genes (==). All other points that are
outside of the blue shaded area represent fusion-negative genes (O). Control genes are marked with ‘

@ The Normalized Read Depth by Gene plot shows the mean read counts of each gene that is captured on the chip for the
selected sample. For each gene, the read counts are normalized to the number of amplicons.
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@ The Sample Coverage for Imbalance Analysis plots show the expression profile for each exon-exon tiling amplicon for each
gene. The Y-axis represents the corrected molecular counts. The X-axis represents individual exon-exon junctions, which are
listed from 5’ to 3'. The imbalance score and p-value are listed in the panel of each gene that was called positive for fusion.

@ Baseline (a cluster of gray lines), generated from a fusion-negative sample.

@ Test sample corrected read coverage (blue line), normalized to the baseline. Each point on the line represents a unique

exon-exon junction that was covered by the assay and normalized to the baseline.

@ Predicted range for the fusion break point for a fusion-positive gene (dashed red line).

@ Sample coverage profile for the control gene (orange line).

@ If the collected data are insufficient to determine an imbalance score, the INVALID SAMPLE message appears in the panel for

that gene.

To return to the table view of fusions, click X (Remove) next to the Visualization dropdown menu.

Non-targeted fusion detection

In the non-targeted fusion detection method, the panel primers are used to detect fusions between

novel combinations of known driver and partner genes. The sequencing reads are mapped to a broader
reference, such as the whole-exome. Mapping the reads to a broader reference allows for the detection
of multiple configurations of driver and partner genes as well as detection of novel breakpoints between

the known partner and driver genes.

Genexus™ Software 6.8 User Guide
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Low confidence non-targeted fusions are identified in VCF output files with key value pairs as follows.

Key value pairs for non-targeted fusions

Type of non-targeted fusion
identified

Definition

Key value pair

Out-of-frame sequence

The expected non-targeted sequence
from the amplicon reference file is used
to check whether the sequence is in
frame. If the non-targeted sequence is
out of frame (compared to the original
partner or driver genes), the key-value
pair NT FUSION IN FRAME=FALSEis
included in the VCF file.

NT FUSION IN FRAME

Values:
® FALSE
® TRUE

f the key value pair

is not included, then

NT FUSION IN FRAME is
assumed to be TRUE, indicating
that an out-of-frame sequence
is not found.

Partner-partner fusion

Non-targeted fusions are identified if
one of the genes in an isoform is not a
driver gene and another is (i.e., partner-
driver fusion). The input reference BED
file includes annotations for driver
genes, for example, in the case

of EML4-ALK.E6A19.COSF1296.2, the
DRIVER_GENE=ALK. In cases where
the DRIVER GENE field is missing in the
BED file, the software checks whether at
least one of the two genes involved in
the non-targeted fusion is a 3p gene.

NT FUSION DRIVER
INVOLVED

Values:
® FALSE
® TRUE

If the key value pair is not
included, then

NT FUSION DRIVER INVOLV
ED is assumed to be TRUE,
indicating that a partner-partner
fusion is not found.

Secondary isoform fusion

In some samples, a non-targeted fusion
isoform might be detected in a sample
while additional targeted isoforms with
the same gene pair are also detected
(that is, isoforms that are defined in the
panel). In this case, the non-targeted
fusion isoform should be identified as
NT FUSION SECONDARY=TRUE, if its
read count coverage is below <5% of
the reads of any of the other isoforms
with the same gene pair.

NT FUSION_ SECONDARY

Values:
® FALSE
® TRUE

If the key value pair

is not included, then

NT FUSION SECONDARY is
assumed to be FALSE,
indicating that a secondary
isoform fusion is not found.
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View CNV results

The CNVs table lists the calls and other information for the copy number variants (CNVs) analyzed in
each sample in a run.

1. In the menu bar, click Results » Sample Results.
2. Click a sample name to open the Results screen.
3. Click the Variants tab.

4. Click CNVs to view the CNVs table.
For more information about the data displayed in the table, see “CNVs table” on page 117.

5. Click Export in the upper right corner of the screen to export the results data in XLS or TSV format,
if needed.

The information that is included in the file is based on the gene list and filter chain that are applied.
* The file in XLS format contains the information that is shown in the CNVs variant table.

* The file in in tab-separated value format (TSV) format contains the information that is shown in
the CNVs variant table, and information for table columns that are available but not currently
shown in the CNVs table. The file also includes information that is listed in the Annotations
table.

CNVs table
The data displayed in the table depends on the assay that was used in the run.

You can filter the results list in the table using filtering tools and filter chains. For more information, see
“Filter results” on page 121.

IMPORTANT! (FFPE samples only) If the %Cellularity value for a sample is set to <100, then the
magnitude of copy number gain or loss can be decreased. For more information, see “System-installed
sample attributes” on page 424.

Column Description

User Classifications | A user-defined classification selected from the list.

For more information, see “Create and assign variant classifications” on page 126.

Variant ID The identifier of the CNV variant.

Click the link to view more annotation information. For more information, see “View more
annotations and annotation sources” on page 133.

Variant Name The name of the variant.
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(continued)
Column Description
Key Variant Indicates whether or not the variant is a key variant.
Possible values are Yes or No.
This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.
Locus The starting position of the first amplicon covering the CNV gene.

Oncomine Variant
Class

Annotation that indicates whether CNV is an amplification or deletion.

This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Oncomine Gene
Class

The change in molecular function of the altered gene product due to the mutation, based on
Oncomine™ annotations:

* Gain-of-function—The altered gene product has a new molecular function or pattern of
gene expression, compared to the wild-type gene.

* Loss-of-function—The altered gene product lacks the molecular function of the wild-
type gene.

This information is available if the Apply Oncomine Variant Annotations checkbox is
selected in the assay used in the run.

Gene

The gene name.

Copy Number

The copy number of a CNV gene locus per genome. This column is available when a
positive call is made.

Call

Indicates the presence or absence of a CNV. When the default filter chain is applied, only
the CNV-positive calls that are designated with PRESENT are displayed in the results table.
To view all calls, including calls that do not pass the required filter thresholds, apply the No
Filter option or download the Variants (VCF) file (see “Results files” on page 171).

* PRESENT—Indicates a high confidence call that passes all filter thresholds.

* PRESENT (GAIN)—A CNV-positive call that indicates gene amplification; a high
confidence variant call that passes all filter thresholds.

* PRESENT (LOSS)—A CNV-positive call that indicates gene deletion; a high confidence
variant call that passes all filter thresholds.

e ABSENT—The absence of a variant; result is below the detection threshold for a CNV
call.

* NO CALL—Although some evidence for the presence of a variant exists, the call does
not pass one or more filters that are required for a high confidence variant call.

P-Value

The statistical significance of the CNV ratio measurement.

Call Details

The reason for reporting a CNV as NO CALL.
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(continued)
Column Description
CNV Confidence The CNV confidence interval associated with the call. The 5% lower confidence bound
value is the ploidy estimate, where there is a 5% chance that the true ploidy is below that
value. The 95% upper confidence bound is the ploidy estimate, where it is 95% certain that
the true ploidy is below that value.
CNV Ratio The ratio of measured CNV gene locus coverage relative to coverage of non-CNV loci.

Med Read Cov Gene | The median read coverage of targeted CNV gene.

Med Read Cov Ref | The median read coverage of non-CNV reference loci.

Valid CNV Amplicons | The number of amplicons spanning the CNV call.

Type The type of variant that is detected.
¢ CNV—Copy number variant.
* LOH-—Loss of heterozygosity.

Subtype The CNV subtype.

¢ BigDel—Deletion of at least one exon.

¢ BigDup—Duplication of at least one exon.

* GeneCNV—Whole BRCA1/BRCA2 gene deletion or duplication.

* NOCALL—Read count differs from baseline by non-integer amount; evidence for a
BigDel or BigDup call is weak.

* REF—Read count matches reference baseline.
* ARM-—Aneuploidy of a chromosome arm.

Visualize exon and whole gene CNVs

With some assays used in Genexus™ Software, you can visualize read counts of BRCA1 and BRCA2
exons that are normalized to the Oncomine™ BRCA DNA baseline.

1. In the menu bar, click Results » Sample Results, then in the Sample name column, click the
name of the sample of interest.

2. In the Variants tab, click CNVs to open the CNV results screen.
3. Click Visualization » Exon CNV to visualize exon read counts.

A plot opens with Normalized Read Counts in log2 scale for each exon CNV that is detected.
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Figure 1 Exon-level deletion detected with Oncomine™ BRCA Assay GX.

@ Menu bar that shows the selected results, the assay, and the sample name.
@ CNVs selection shows the CNV results screen.
@ Toggle selection for Pre-corrected and Post-Corrected plot views.
e The pre-corrected plot shows amplicon coverage data normalized to total reads in a sample.
e The post-corrected plot shows amplicon coverage after applying GC-content, amplicon length, and principal
components analysis corrections to the log2 ratios.
@ Scale values of -6 to +2 or -2 to +2, to zoom out or zoom in on the plot.
@ This example shows an exon-level deletion. Exons 14 and 15 are deleted in this example.

You can use the visualizations in the software to confirm deletions and duplications. Use the post-
corrected visualization to confirm exon deletions and duplications.

Whole gene deletion or duplication results can be confirmed only in the pre-corrected view. If a BRCA1
deletion (BRCA1DEL) for a GeneCNV subtype is shown in the Call Details of the CNV variants table,
review the visualization to verify the deletion of the gene. Click Pre-corrected and Compare the
SamplelD (sid) amplicons to the BRCA1 genes.
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Figure 2 Verification of duplications.

(D Pre-Corrected selection.

@ The location of the SamplelD (sid) amplicons show information about BRCA1 and BRCA2 genes.
(3 BRCAT1 genes

@ BRCA2 genes

@ SamplelD (sid) amplicons

In this example, a BRCA2 duplication can be verified because the sid amplicons are aligned with the BRCA1 genes in the
visualization. Therefore the BRCA1 gene is normal, the sid amplicons are normal and the BRCA2 gene is a duplication.

Filter results

You can filter results in the SNVs/Indels, Fusions, and CNV tables in the Variants tab of the Results
screen in two ways. You can apply filters to columns of information that appear in the screen. The
filters, available at the top of each column, immediately narrow the list of information in any columns to
which filters are applied.

You can also apply a filter chain, a set of filters that Genexus™ Software uses to narrow the list of
variants that are included in results. A manager-or administrator-level user creates filter chains from
system-installed filters.
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Search and filter the list of variants

You can search and filter to immediately narrow the list of results that are shown in the variant tables.
You can apply filters to columns of information that appear in the screen. The filters, available at the top
of each column, immediately narrow the list of information in any columns to which filters are applied.

1. In the menu bar, click Results » Sample Results.
2. Click a sample name in the Sample Name column.
3. In the Results screen, click the Variants tab.

4. Select the variant class to display the results: SNVs/Indels, Fusions, or CNVs.

5. In the table of variants, in the column heading of @ v
interest, click Y (Filter). Type Call
* |In the search field, enter at least 3 characters, then
click Filter. =P
* Select the checkbox in the row of each filter that ¢ oo
you want to apply, then click Filter. snp i
del

The options that are available depend on the column
and variant class. For example, you can filter data in snp
the Type column to show one specific variant type.

del
6. Click {x] Clear Filters to remove all filters and view )

the full list of run results.

The column or columns to which you applied a filter change
to reflect the filter and selected options.

Filter results with a filter chain

You can filter the results that are listed in the Results screen with a system-installed or custom filter
chain. A filter chain is a set of filters that Genexus™ Software uses to narrow the list of variants that are
included in results.

Select a filter chain to change the list of variants that are included in the results. You can apply the filter
chain temporarily, then review the results before you decide whether to save the updated results, or
discard the changes.

If you save the filter chain to a result, the variants that are included reflect the filtered results when the
results are later opened.
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For information about system-installed filter chains, see “System-installed filter chains” on page 405.
Manager- and administrator-level users can create filter chains. For more information see, “Create a
custom filter chain (manager/administrator)” on page 256.

1. In the menu bar, click Results » Sample Results.
2. In the Sample Results screen, in the Sample Name column, select a sample of interest.
3. In the Results screen, click the Variants tab.

4. To refine the list of variants shown in the table, select a variant type.
* SNVs/Indels

* Fusions
* CNVs

5. Above the variant table in the Results screen, click Edit Filters, then select a filter chain.

¢ Click @ Edit to make changes to a draft filter chain, if needed. For more information, see “Edit
a filter chain (manager/administrator)” on page 260.

¢ (Click [0 Copy to copy, then edit the selected filter chain, if needed. For more information, see
“Copy a filter chain (manager/administrator)” on page 259.

The list of results changes to reflect the selected filter chain. If you made edits to the filter chain, all
sample results to which the edited filter chain is applied are also updated with the changes.

6. Click Save if you want the filter chain to be applied to the results when the results are later opened.
The filter chain is selected and applied to the results when the results are reopened.

Show gene list variants

You can refine the variants that are shown in the Variants tab in Genexus™ Software.
* Filter the variants. For more information, see “Filter results” on page 121.

* Show only the gene list variants. For more information, see “Gene lists (manager/administrator)” on
page 243.
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1. In the menu bar, click Results » Sample Results.

2. Click a sample name to open the Results screen.

3. Click the Variants tab.

Option

Description

Show only the variants for
the genes that are listed
in the gene list.

Click the Gene List Only checkbox.

Changes to the Gene List Only checkbox, whether the gene list is shown
or not shown, persist for the selected result only. When you select a new
sample in the same run, the selection persists. When you open a new run
result or a sample result from a different run, the checkbox is deselected
by default.

Change the gene list that
is applied to the results.

1. Click Edit Filters, then select a different gene list.
2. Click Save.
The changed gene list is saved for the selected sample result only. The

saved change applies only to a single sample, even if other samples are
present in the same run.

Note: The Gene List Only checkbox is shown only when a gene list is applied to the results.
When No Gene List is selected, the Gene List Only checkbox is not shown in the results screen.

Customize the view of the variants table

The Variants table includes detailed variant results in Genexus™ Software. You can customize the table
to reflect the information that is most relevant to your research.

Variants table column options

When you view the Variants table in Genexus™ Software, a default set of columns is included. The table
columns are based on various factors, including the samples that are sequenced and the assay used

for sequencing.

Add or remove columns in the variants table

You can add columns to the Variants table that you view in Genexus™ Software.

1. In the menu bar, click Results » Sample Results.

2. Click a sample name to view results for the sample.

3. Click Columns, then select the columns that you want to add to the Variants table, or deselect the
columns that you want to remove from the table.
The selected columns are added to the Variants table until you close the table.

4. To save the custom table so that the changes to the columns persist the next time the table is

viewed, click Save.
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Change the width of columns in the variants table

You can change width of columns in the Variants table in Genexus™ Software. Not all columns are
visible on the screen. You can use the scrollbar under the table to view more columns.

1. In the menu bar, click Results » Sample Results.
2. Click a sample name to open the Results screen.
3. Change the width of each column, as desired.

Restore default settings for the variants table

You can restore default column headings in the Variants table in Genexus™ Software.

1. In the menu bar, click Results » Sample Results.
2. Click a sample name to open the Results screen.
3. Click Columns » Restore default.

The default columns shown in the table are restored.

View variants with Integrative Genomics Viewer (IGV)

You can view data from Integrative Genomics Viewer with the Broad Institute Integrative Genomics
Viewer (IGV). The viewer is available at the Broad Institute website:http://software.broadinstitute.org/
software/igv/home.

1. In the menu bar, click Results » Sample Results.
2. Click a sample name to open the Results screen.
3. Click the Variants tab.

4. In the variants table, in the Variant ID column, click the identifier of the variant of interest.
The Pileup view is shown below the table.

5. Click View in IGV to download a JNPL file that can be opened in the Integrative Genomics Viewer
(IGV) from the Broad Institute (see software.broadinstitute.org/software/igv).
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Create and assign variant classifications

You can create and assign user-defined variant classifications in the variant tables.

1. In the menu bar, click Results » Sample Results.

2. Click a sample name in the Sample Name column in the row of a sample of interest to open the

Results screen for the sample.

3. Click the Variants tab.

4. To refine the list of variants shown in the table, select a variant type to display: SNVs/Indels,

Fusions, or CNVs.

5. In the Variants table, in the User Classification column, perform any of the following actions.

* To assign an existing classification to a variant, select it from the list. The Classification menu
changes to the name of the classification, as shown in this example.

Results / OCAv3MultiCustom7198771LY / DFOCC/

SRTestSample01 Summary QC —

SNVs/Indels Filter Oncomine

User Classification 'Y Locus Y ‘

chr13:32911442
chr13:32911442

Results / OCAv3MultiCustom7198771Y / DFOC

SRTestSample0l Summary QC =—

SNVs/Indels Filter Oncomir

User Classification 'Y Locus h g

chr13:32911442

‘ 911442

@ Eenign

Likely Benign

B B

@ Likely Pathogenic juf
@ Pathogenic

@ Uncertain Significance @

—v

Results / OCAv3MultiCustom7198771Y / DFOCCI
SRTestSample01 Summary QC —

SNVs/Indels Filter Oncomine

User Classification 'Y Locus Y

chrl3:32911442

x

chr13:32011442

* To create a new classification, enter a name for the classification in the text box, select a color
for the new classification, then click Add.

Results / OCAv3MultiCustom7198771¥ / DFO

SRTestSample01 Summary QC —

SNVs/Indels Filter Oncom

User Classification 'Y Locus Y

chrl3:32911442

| Protective 011402

_'

* To remove a classification from a variant, click X (Remove).
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Results / OCAv3MultiCustom7198771L¥ / DFOC!

SRTestSample01 Summary Qc —

SNVs/Indels Filter Oncomir

User Classification ¥ Locus Y
chr13:32911442
Protective 911442

| Add

Results / OCAv3MultiCustom7198771 Y / DF(

SRTestSample0l Summary Qc -

SNVs/Indels Filter Oncon

User Classification 'Y Locus Y
chri3:32911442
Protective 011442

= B
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¢ To delete a classification from the list, click [i] Delete next to the classification name. The
classification will be removed from all variants in all results.

Review the variant pileup view

You can review variant tracks with the pileup view in Genexus™ Software. The pileup view is a figure
that the software generates to show each BAM track represented by a single bar, with the sequence
variation or variations denoted in each track. The BAM tracks are aligned against a reference track. The
variant pileup view can be used to identify potential variants.

1.

2.

3.

4.

In the menu bar, click Results » Sample Results.

Click a sample name to open the Results screen.

Click the Variants tab.

In the variants table, in the Variant ID column, click the identifier of the variant of interest.

The pileup view is shown below the variants table.

Change the view of the variant pileup

You can zoom and pan the variant pileup view and add or remove guides and track labels to more
easily understand the data. You can also adjust the view of the individual pileup tracks. For more

information, see “Adjust pileup tracks” on page 128.

1.

2.

In the menu bar, click Results » Sample Results.

Click a sample name to open the Results screen.

Click the Variants tab.

In the variants table, in the Variant ID column, click the identifier of the variant of interest.

Action

Procedure

Track the position as you place the pointer over
the variant pileup.

Click Cursor Guide.

Mark the center of the variant pileup.

Click Center Line.

Remove the track labels.

Click Track Labels.

Zoom in to increase the magnification of the
image.

Click @ (Zoom in) one or more times, or double-
click the image.

Zoom out to decrease the magnification of the
image.

Click @ (Zoom out) one or more times.

Pan across the image to move the view to
another location on the screen with its current
magnification.

Click and drag the pointer over the image.
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Adjust pileup tracks

You can adjust the BAM read coverage track, the reference track, hotspot tracks, the target region
track, and annotation tracks in Genexus™ Software to make it easier to view the data. When you adjust
a track, it changes the amount of data that is shown in the plot. For example, you can see more tracks
when you use the Squish setting.

Note: For best results, click the Expanded option to view details about variants and base calls that are
shown in each read coverage track

1.

2.

In the menu bar, click Results » Sample Results.

Click a sample name to open the Results screen.

Click the Variants tab.

In the variants table, in the Variant ID column, click the identifier of the variant of interest.

In the Variants tab, in the Pileup subtab, click £ (Actions) next to a track, then select an option to
adjust the view of the track.

Option Description
Expanded Select this option to view the tracks with the maximum visible height.
Squish Select this option to view the tracks with the minimal height for each track.
Collapse Select this option to view the tracks with overlapping transcripts shown along a
single line. When Collapse is selected for BAM tracks, the BAM tracks are not
shown; only the coverage density is shown.

Adjust the view of the reference track

You can adjust the view of the reference track in Genexus™ Software to view or hide the three-frame
translation of the reference track sequence. You can also view the forward or reverse reference track
sequence.

1.

2.

128

In the menu bar, click Results » Sample Results.
Click a sample name to open the Results screen.
Click the Variants tab.

In the variants table, in the Variant ID column, click the identifier of the variant of interest.
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In the Variants tab, in the Pileup subtab, click £ (Actions) next to the reference track.

Option

Description

View the reverse
strand

Click Reverse.
This option is available only when the forward strand is shown.

View the forward
stand

Click Forward.

This option is available only when the reverse strand is shown.

View the reference
sequence translation

Click Three-Frame Translate.
This option is available only when the amino acid sequence is not shown.

Hide the reference
sequence translation

Click Close Translation.
This option is available only when the amino acid sequence is shown.

Adjust the view of the BAM tracks

You can adjust the view of the BAM tracks in Genexus™ Software to dynamically customize the view of
the data.

1.

2.

In the menu bar, click Results » Sample Results.

Click a sample name to open the Results screen.

Click the Variants tab.

In the variants table, in the Variant ID column, click the identifier of the variant of interest.

In the Variants tab, in the Pileup subtab, click £ (Actions) next to the BAM tracks.

Option

Description

View all BAM tracks
in monochrome gray

In Color By, deselect the checkmark next to Read Strand.
This option is available only when the BAM tracks are colored by read strand.

Distinguish between
the direction of the
BAM tracks with
color

In Color By, click Read Strand.

This option is available only when the BAM tracks are not colored by read
strand.

Expand, squish or
collapse the BAM
tracks

For more information, see “Adjust pileup tracks” on page 128.

Show all the bases
in the BAM tracks

Click Show all bases.
This option is available only when all bases in the BAM tracks are not shown.

Change the
minimum threshold
for the visibility of
BAM tracks

1. Click Set visibility window.

2. In the Set visibility window dialog box, enter the minimum number of
bases needed to show the BAM tracks.

When you zoom in and out to view the variant pileup, the scale of the tracks
shown in the screen changes. For more information, see “Change the view of
the variant pileup” on page 127. You can adjust the visibility window according
to the scale shown in the screen.

Genexus™ Software 6.8 User Guide

129



M Chapter 6 Review data and results

Review sample results

Examples of a variant pileup view

The following figure is an example of a variant pileup view, shown in the Gene Browser in the Variant
tab. The variant pileup view graphically represents the sequencing tracks, the reference track, and the
annotation tracks, and can help you understand the variant data and analyze results. The reference
allele and the alternate base for the selected variant are indicated in the image, both in the variant table
and the in the pileup view. You can customize your pileup view. Reorder the tracks displayed by clicking
a gray bar on the right edge of a track, then dragging the track to a different location. You can also
click-drag the cursor at any position in the image to move the image left or right in the screen. For more
information, see “Adjust pileup tracks” on page 128.

SRTestSample0l  QC —  KeyFindings  Variants  Plugins  Reports

Gene ListOnly Oncomine Variants (5.14) Filter Chain Applied [ SRR .
120f1,792 Variants

Y omer Y Type T OncomineGeneCiass Y OncomineVariamtClass Y Gene Y Locus Y machamge Y Rt Y At Yl Y oncomineDriverGene Y

Hotspot s Chris28592623 pAspazGly T C PRESENT (HETEROZYGOUS) <
c

Hatspot FTs chri3:28592642 pAspasSTyr

.
:

Hatspot KRS chr12:25378647 plysi17Asn T

PRESENT (HETEROZYGOUS}

PRESENT (HETEROZYGOUS} >

PR 50 v itemsperpage 1-120f12items

Pileup | Annotations x

ewin 16V

(Crmrs) o) (D © e ©

orags0e sorapssee somageote sorapesee somagmobe somapTsee somazeoe sorapesee

%
chr3'5,073778
@_ Total Count 77
Alignment Start 5,073,707
Read Strand ()

A TT(100%, 33+, 44- )|
= co
@ G0 Cigar 97M428 —
Mapped Yes =

A _®
c A
—%-—@
Read Name 935A5:00640:01447 ~ :
A
A
A
A
A

e

TO

Mapping Quality 87
L secondary No
INS 0 Supplementary No
DEL 0 Duplicate No

Failed QC No

ZG 307

ZB 23

ZC 307,308,1,0

YK CTGAGTGACTCTATTCG
Zza13g 0000000000 7

@ The reference track. When zoomed out, the nucleotide sequence is no longer displayed, but the sequence is
represented by colored bars.

@ The three-frame translation is shown in this example (not by default). For more information, see “Adjust the view of
the reference track” on page 128.

(3) The coverage track.
(@) The BAM track.

@ Click the coverage track to see detailed information, such as the total count, the number of reads, and the number of
molecules.

@ Click a BAM track to see detailed information, such as the Mapping Quality and Base Quality.
(@) Use the sliders to view more tracks.

Deletion.
@ Insertion.
@ Alternate base in the BAM read coverage track.

The following figure is an example of the reference tracks and annotation tracks shown beneath the
BAM tracks in the Gene Browser.
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chr chr9

start 5073770

end 5073770

score NalN

name COSM12600
strand JAK2 3.138844

CosMAaaTETE cosmzseas

cosmize00

-3
—— x|

chr chrg

start 5073555

Chr 9 end 5073803

Pos 5073770 score Nal
name JAKZ_ 3138844

strand GENE_ID=JAK2;Pool=1;PURPOSE=Hotspot|

Names 29763

Ref G

Alt A

Qual .

Filter

ALLELEID 38718

CLNDISDB MedGen:C3281125,0MIM:614521
CLNDN Thrombocythemia_3

CLNHGVS NC_000009.11:9.5073770G>A
CLNREVSTAT no_assertion_criteria_provided
CLNSIG Pathogenic

CLNVC single_nucleotide_variant

CLNVCSO 500001483 M

@ The hotspot track.
@ The target region track.
@ Annotation tracks (COSMIC and ClinVar). In this example, only ClinVar is shown.

@ Click the annotation track for additional details; for example the CLNHGVS (the top-level genomic HGVS expression
for the variant).

(® Click a hotspot track for additional details, such as the start and end positions.
@ Click the target region track for additional details, such as the start and end positions.

Coverage histogram

When you zoom in on the pileup, you see the coverage histogram and reads from the BAM track. The
histogram in gray shows read depth at that location and reads from the BAM track show read direction
and location of variants.

—— I O)
IR W ] - [ . |
y n |
< | I |
1 D HI
i |

(1) Read depth
@ Read location and direction of variants
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View the variants from an lon AmpliSeq™ HD-Library Chemistry run

You can view a summary of data about the identified variants, and toggle to other views that provide
more details about the same variants.

1.

2.

In the menu bar, click Results » Sample Results.

Click a sample name to open the Results screen.

Click the Variants tab.

In the variants table, in the Variant ID column, click the identifier of the variant of interest.

Review detailed variant data and read coverage tracks.

Gene Browser 40t et o e ) (Conter ) () @) e—

Figure 3 Example visualization

lon AmpliSeg™ HD sequencing runs group consensus reads into families. A family is a group of
reads that are associated with the same DNA molecule before library amplification. Each family

is identified using the molecular tags, and consensus reads with the same molecular tags are
grouped into the same family. The color of the consensus reads is used to indicate a family.
Within each read track, each nucleotide variant is indicated by a different color. T, A, C, and G are

red, green, blue, and orange, respectively. An "I" denotes insertion, and white color with a dash
indicates deletion.

You can sort, adjust, and view details about variants and base calls that are visualized in each read
coverage track.

Option Description
View the read coverage Click £* (Actions) next to the read coverage track, then select
tracks sorted by family Color » Molecule.
Adjust the BAM tracks Click £# (Actions) next to the read coverage track, then select an option

to adjust the view of the track. For more information, see “Adjust pileup
tracks” on page 128.

Review detailed data Single-click the read track to get information such as the mapping quality,
about a BAM read the strand, and the read base.

Review distribution of Click the density plot (the gray bar at the top of the read coverage tracks)
base calls at a selected to view information about the total count, total reads, and total number of
position molecules, the distribution of single nucleotides at that position, and the

number of insertions and deletions.
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View more annotations and annotation sources

In addition to the annotations that are included with Genexus™ Software, you can view annotations and
annotation source information from public websites for each variant.

1. In the menu bar, click Results » Sample Results.
2. Click the sample name in the Sample Name column in the row of a sample of interest.
3. Click the Variants tab.

4. In the Variants table, click the Variant ID of the variant of interest.

Note: You can click the row even if a Variant ID is not listed.

The Pileup view is shown below the variants table. For more information, see “Review the variant
pileup view” on page 127.

5. Click the Annotations tab.

6. Review annotation information in the Annotations tab, and if available, click a link in the row of an
annotation to open a website with information about the annotation.

View the QC results

You can view the quality control (QC) metrics for each sample that was sequenced in a run in Genexus™
Software.

1. In the menu bar, click Results » Sample Results.
2. In the Sample Name column, click the sample name of interest.

3. Click the QC tab.
The QC metrics are shown.

4. Review the QC metrics.
For more information, see “QC results” on page 133.

QC results

The quality control (QC) metrics for each sample that was sequenced in a run are displayed in
Genexus™ Software.

If a sample fails a single test metric, the sample fails that QC test. A sample must meet all QC
parameter thresholds of a particular QC test in order to pass. The QC status is divided into the following
categories.

. (Passed) indicates the sample passed all QC metrics.
* X (Failed) indicates the sample failed a QC metric.

* — (Not Calculated) indicates a sample did not undergo QC analysis.
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Note: If a sample fails to meet one or more QC parameters, you can reanalyze a run after adjusting the
parameter or parameters. For more information, see “Reanalyze a run” on page 192.

The data displayed in the screen depend on the assay that was used in the run.

Metricll

Description

Purification QC

Quality control information for nucleic acid extraction that is performed on a
Genexus™ Purification Instrument.

Sample Concentration
RNA

The concentration of extracted RNA after purification.

Sample Concentration
DNA

The concentration of extracted DNA after purification.

Sample Concentration
TNA

The concentration of extracted TNA after purification.

Resequencing

Run QC General run quality control information.

Final Reads Library reads passing all filters that are recorded in the output BAM files. This value
can be different from the total number of reads due to technicalities associated with
read trimming beyond a minimal requirement.

Key Signal The average signal after software processing for library ISPs that identically match the
library key (TCAG).

Key Signal - The average signal after software processing for library ISPs that identically match the

library key (TCAG) for the resequencing run. This metric is only shown for assays that
include resequencing.

Percent Loading

The number of wells with ISPs divided by the number of the total addressable wells in
arun.

Percent Loading -
Resequencing

The number of wells with ISPs divided by the number of the total addressable wells in
the resequencing run. This metric is shown only for assays that include resequencing.

Raw Read Accuracy

The average raw accuracy across each individual base position in a read, where raw
read accuracy is calculated as 100 * (1 - (sum(per base error)/sum(per base depth))).

Templating QC—CF-1
Control

Sequencing quality metrics of the control fragment. These metrics indicate
templating success.

Average Reads Per Lane

The number of CF-1 reads divided by the number of chip lanes used in the run.

Base Call Accuracy

The probability that a given base is called correctly.

1 — (total number of errors for all positions in CF-1) / (total number of CF-1 base
reads).

Mean AQ20 Read Length
(bp)

Average length, in base pairs, at which the accuracy rate is 299% for CF-1 reads.
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Metricll

Description

Sample QC—DNA

Sequencing quality metrics of the sample DNA library.

MAPD

MAPD (Median of the Absolute values of all Pairwise Differences) is a quality metric
that estimates coverage variability between adjacent amplicons in CNV analyses. A
MAPD value of less than or equal to 0.4 indicates an acceptable level of coverage
variability. High MAPD value typically translates to a lower coverage uniformity. Lower
coverage uniformity can result in missed or erroneous CNV calls. If the MAPD

QC threshold is not met, CNVs are not called. The MAPD metric does not affect
SNVs/INDEL calls.

Mapped Reads

The total valid mapped reads.

Mean AQ20 Read Length
(bp)

The average length, in base pairs, at which the accuracy rate is 299% for all aligned
reads of a library.

Mean Read Cov

The number of average reads per amplicon.

Molecular Uniformity

Uniformity of molecular coverage for all amplicons.

Mean Read Length (bp)

The average length, in base pairs, of final library reads for the sample.

Uniformity of Amplicon
Coverage

The percentage of amplicons that had at least 20 percent of the average number
of reads per amplicon. Cumulative coverage is linearly interpolated between nearest
integer read depth counts.

Median Mol Cov

The median number of functional molecule reads per amplicon calculated over all
amplicons in the assay.

This metric is applicable to lon AmpliSeq™ HD library chemistry only.

Uniformity of Base
Coverage

The percentage of reads with a depth of coverage =20% of the mean read coverage
at each position.

This metric is applicable to lon AmpliSeq™ HD library chemistry only.

Read Length Histogram

The histogram presents all filtered and trimmed DNA library reads that are reported
in the output BAM file (Y-axis) and the mean read length in base pairs (X-axis). The
shape of the histogram should closely resemble the library size distribution trace
without the adapter sequences.
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Metricll

Description

Read Ratio for Inline
Controls (Endogenous to
Spike-ins)

The ratio of genomic sample reads to control reads for each inline control amplicon.

_ Read Ratio for Inline Controls (Endogenous to Spike-ins)

34
od
o 100 125 178 374
In-ling Cont

266
trol Amplicon Size (b

Read Ratio

Note: The Read Ratio for each inline control amplicon is expected to be
approximately 3 with 10 ng DNA input for both lon AmpliSeq™ and lon AmpliSeq™
HD chemistries.

Sample QC - RNA

Sequencing quality metrics of the sample RNA library.

Mapped Fusion Reads

The total valid mapped reads. That is, the mapped reads that pass the thresholds and
filters across all of the RNA targets in the reference file. This number is a subset of the
mapped reads shown in the Run Samples table in the Assay Metrics.

Mean Read Length (bp)

The average length, in base pairs, of the final library reads for the sample.

RNA Expression Ctrls
Detected

The number of expression control genes detected for the sample. This metric
measures the RNA input integrity, input amount, and the fidelity of the reverse
transcriptase that was used in library preparation.

Fusion panels include primer pairs that cover control housekeeping genes.

Mean AQ20 Read Length

The average length, in base pairs, at which the accuracy rate is 299% for all aligned
reads of a library.

Read Length Histogram

The histogram presents all filtered and trimmed library reads that are reported in the
output BAM file (Y-axis) and the mean read length in base pairs (X-axis).

Read Ratio for Inline
Controls (Endogenous to
Spike-ins)

The ratio of genomic sample reads to control reads for each inline control amplicon.
You can use this metric to measure the level of contaminating genomic DNA in RNA
libraries when you select the RNA checkbox for Include Inline Controls in assay set
up. Using inline controls in RNA assays will reduce the total number of panel reads.

Note: The Read Ratio for each inline control amplicon is expected to be
approximately 3 with 10 ng DNA input for both lon AmpliSeq™ and lon AmpliSeq™
HD chemistries.

NTC QC - DNAPI

DNA Sequencing quality metrics of the no-template control.

Average Base Coverage
Depth

The average number of DNA reads of all targeted reference bases.
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Metricll

Description

Mean Read Length (bp)

The average length, in base pairs, of final DNA library reads for the no template
control.

Read Length Histogram

The histogram presents all filtered and trimmed reads for the no template control that
are reported in the output BAM file (Y-axis) and the mean read length in base pairs
(X-axis).

Read Ratio for Inline
Controls (Endogenous to
Spike-ins)

The ratio of no template control sample reads to control reads for each DNA inline
control amplicon.

NTC QC - RNAR

RNA Sequencing quality metrics of the no template control.

Mapped Fusion Reads

The total number of valid mapped reads for the NTC.

Mean Read Length (bp)

The average length, in base pairs, of final RNA library reads for the no template
control.

Read Length Histogram

The histogram presents all filtered and trimmed reads for the no template control that
are reported in the output BAM file (Y-axis) and the mean read length in base pairs
(X-axis).

Read Ratio for Inline
Controls (Endogenous to
Spike-ins)

The ratio of no template control sample reads to control reads for each RNA inline
control amplicon.

' For BAM to Result runs, only the Sample QC—DNA or Sample QC—RNA metrics are shown.
2l Metrics are shown only if NTC is included in the run plan.

MAPD copy number QC metric

The Median of the Absolute values of all Pairwise Differences (MAPD) score is reported on Aneuploidy
run results and other runs that detect CNVs.

MAPD is one of the metrics that we define to assess whether the panel data is useful for copy number
variation (CNV) run results.

MAPD is defined as the Median of the Absolute values of all Pairwise Differences between log2 ratios
per tile for a given run. Tiles roughly correspond to amplicons in an lon AmpliSeq™ assay. Each pair is
defined as adjacent in terms of genomic distance. Tiles corresponding to copy nhumber amplicons and
other amplicons are being treated equally as no differences in variability are seen between these types.
Then, any two log2 ratios that are adjacent on the genome are a pair. Except at the beginning and the
end of a chromosome, every log2 ratio belongs to two pairs.

Formally, if x1i is the log2 ratio at position i, with i ordered by genomic position:

MAPD = median

(

I x(1 - 1) - x(1) | )

MAPD is a per-sequencing run estimate of copy number variability, similar to standard deviation (SD). If
one assumes the log2 ratios are distributed normally with mean 0 and a constant SD, then MAPD/0.95
is approximately equal to SD. However, unlike SD, using MAPD is robust against high biological
variability in log2 ratios induced by known conditions such as cancer.
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Regardless of the source of the variability, increased variability decreases the quality of CNV calls.

Sample tags in sample results

You can assign tags to sample results in Genexus™ Software. Tags are used to label and group sample
results. A tag can be assigned to a single sample or to multiple samples at once.

Assign sample tags to a sample result

You can assign tags to sample results in Genexus™ Software to label and group sample results. For
more information, see “Sample tags” on page 46.

1.

2.

4.

In the menu bar, click Results » Sample Results.

In the Sample Results screen, place the pointer over the row of the sample result that you want to
tag, then click Assign Tags.

In the Assign Tags dialog box, search for or scroll to a tag.

If the tag that you want to assign to a sample does not exist in the software, a manager- or
administrator-level user can create a new sample tag. For more information, see “Create a sample
tag (manager/administrator)” on page 46.

Select one or more tags that you want to assign to the sample result, then click Save.

The tag or tags are assigned to the sample result and are listed in the row for the sample result in the
list of sample results.

Assign sample tags to multiple sample results

You can assign one or more tags to multiple sample results in Genexus™ Software. For more information
about sample tags, see “Sample tags” on page 46.

1.

2.

4.

In the menu bar, click Results » Sample Results.

In the Sample Results screen, click the checkbox to the left of each sample result of interest, then
click © Assign Tags above the list of sample results.

© Assign Tags is not shown until you select at least one sample result.

In the Assign Tags dialog box, search for or scroll to a tag.

If the tag that you want to assign to a sample result does not exist in the software, a manager- or
administrator-level user can create a new sample tag. For more information, see “Create a sample
tag (manager/administrator)” on page 46.

Select one or more tags that you want to assign to the sample results, then click Save.

The tag or tags are assigned to the selected sample results and are listed in the row for each sample
result in the list of sample results.
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Customize the sample results table

By default, the following information is listed in the sample results table in Genexus™ Software.

* Name of the sample, assay, and run. e QC status.
¢ Status of the sample result, such as ® Date and time that the run was started and
completed. updated.

More information is available to show in the sample results table. You can customize the table to reflect
the information that is most relevant.

Change the columns in the sample results table

The sample results table in Genexus™ Software includes a default set of columns. The columns that
are available depend on the assays that are installed in the software. Table columns are based on
sample attributes. You can also add or remove columns for information about Electronic Signatures,
and Annotations Used.

—

In the menu bar, click Results » Sample Results.
2. In the Sample Results screen, click Columns.

3. Select the columns that you want to add to the sample results table, or deselect the columns that
you want to remove from the table.

The selected columns are added to the table or are removed from the table until you close the
table.

4. Click Save to save the changes to the table columns.

The changes that you have made to the table appear each time that you view the sample results
table. The changes are saved until you add or remove other columns, then save those changes.

To restore the table to the default view, see “Restore the default columns in the sample results table” on
page 139.

Restore the default columns in the sample results table

You can restore the default view of the columns in the sample results table in Genexus™ Software.

1. In the menu bar, click Results » Sample Results.
2. In the Sample Results screen, click Columns.
3. At the end of the list of columns that appears, click Restore default.

The default columns in the sample results table are restored.
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Find sample results

You can sort, search, and filter information to narrow the sample results that are listed in the Results /
Sample Results screen. The sort, search, and filter tools help you organize sample results and find a
specific sample result in Genexus™ Software.

For information to search for a sample result by a unique identifier, such as the name of a run or the
name of a sample, see “Search for sample results” on page 140.

For information to filter sample results by a common trait, such as QC status, see “Filter the list of
sample results” on page 142.

Search for sample results

Sample results are listed in the Results / Sample Results screen in Genexus™ Software. The most
recent sample result is on the top of the list.

You can search for sample results with keywords or text that are included in the name of the sample,
run name, or the name of an assay applied to the run.

IMPORTANT! Search terms must adhere to the following rules.

. An asterisk (*) is not allowed in the search field for use as a wildcard.

. Searches are case-insensitive, that is, both upper-case and lower-cases letters are found regardless
the case of search term letters.

. Searches find every occurrence of a continuous string. For example, a search for demo in analysis
names returns a list of all analysis with a name that includes demo. For example, demo1, demo2,
and so on.

. Spaces are removed during searches, and therefore are not recommended. For example, a search for
demo 1 would return results only for data that includes the string demo1.

1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, in the Sample Name, Run Name, or Assay Name column
heading, click Y (Filter).

a. In the search field, enter a full or partial assay, sample, or run name of at least 3 characters.

When you have entered at least 3 characters, the filter dialog box limits the list in the filter
dialog box based on the entry.

b. In the filter dialog box, select from the limited list.
* Select a checkbox next to a sample, run, or assay name to select one or more items.
* Click Select All to select all items listed in the filter dialog box.

Note: If you click Clear, all selections are removed and the filter dialog box closes.

c. In the filter dialog box, click Filter.
In the column heading, (Filter) changes color to indicate that a filter is applied.

The filtered list of sample results is shown in the Sample Results screen.

Click {x] Clear Filters to remove all filters and view the full list of sample results.
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Sort the list of sample results
You can sort the list of sample results to make it easier to find sample results in Genexus™ Software.

By default, sample results are listed in the Results / Sample Results screen by date. The most recent
sample result is at the top of the list.

You can change the order that the sample results are listed in the table.

For example, you can sort the Call column alphabetically so that the Absent calls appear first. This
allows you to easily view hotspots that did not pass thresholds for a variant call, such as when the allele
fraction is zero.

1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, click a column heading of interest.
The list of sample results is sorted in alphabetical or chronological order depending on the entries
in the column.

3. Click the column heading again to reverse the order.
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Filter the list of sample results

You can apply filters to narrow search results, or shorten the list of sample results when you view the list
of sample results in Genexus™ Software.

In the menu bar, click Results » Sample Results.

In the Sample Results screen, select one or more filters.

Option

Description

Filter and search by the
name of the sample, the
run name or the assay
selected in the run.

For more information, see “Search for sample results” on page 140.

Show or hide sample
results that are archived

In the dropdown list in the upper left corner, select an archive status.
¢ Archived ¢ Non Archived
Select All to list all sample results.

Filter by the status of the
sample result.

1. In the Sample Status column heading, click Y (Filter) then select
at least one status.

¢ Completed e Stalled
¢ Running ¢ Aborted
¢ Failed ¢ Pending
¢ Terminated
2. Click Filter.
Records are listed for sample results that meet the sample status
criteria.

Filter by the QC status.

1. In the QC Status column heading, click Y (Filter) then select at
least one QC status.

* Failed * Not Calculated
* Passed
2. Click Filter.

Records are listed for sample results that meet the QC status criteria.

List only sample results
from runs that were started
on or updated on an exact
date.

In the Started On or Updated On column heading, click Y (Filter).
In the first dropdown list, select Is equal to.

In the calendar that appears, select the date of interest.

Click Filter.

Ao b~

Records are listed for sample results from runs that were started on or
updated on the date entered.

List only sample results
from runs that were started
on or updated within a
date range.

1. In the Started On or Updated On column heading, click Y (Filter).
2. In the first dropdown list, select Is after or equal to.
3. In the calendar that appears, select the earliest date of the range.
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Option Description

In the Boolean operator dropdown list, select And.

In the second dropdown list, select Is before or equal to.

In the calendar that appears, select the latest date of the range.
Click Filter.

N o o A

Records are listed for sample results from runs started on or updated on
dates that meet both conditions.

List sample results 1. In the Started On or Updated On column heading, click Y (Filter).
according to a date that

meets either one condition
or a second condition 3. In the calendar that appears, select the earliest date for the sample

results of interest.

2. In the first dropdown list, select Is after or equal to.

4. In the Boolean operator dropdown list, select Or.
In the second dropdown list, select Is before or equal to.

6. In the calendar that appears, select the latest date for the sample
results of interest.

7. Click Filter.

Records are listed for sample results from runs that were started on or
updated on dates that meet at least one of the conditions.

List only sample results for

1. In the Started On or Updated On column heading, click Y (Filter).
runs that were started on ) .
2. In the first dropdown list, select Is before or equal to.
or before or updated on
or before a date that you 3. In the calendar that appears, select the date of interest.
indicate. 4. Click Filter.

Records are listed for sample results from runs that were started on or
before the date entered.

List only sample results

1. In the Started On or Updated On column heading, click Y (Filter).
for runs that were started ) .
2. In the first dropdown list, select Is after or equal to.
on or after or updated on
or after a date that you 3. In the calendar that appears, select the date of interest.
indicate. 4. Click Filter.

Records are listed for sample results from runs that were started on or
after, or updated on or after, the date entered.

In the column heading, (Filter) changes color to indicate that a filter is applied.

Click {x] Clear Filters to remove all filters and view the full list of sample results.
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Review run results

In the Results / Run Results screen, runs that are pending, in progress, or completed are listed. Runs
with a status of failed, aborted, or stalled are also listed.

See “Find a run result” on page 157 for information about how to find run results of interest.

The following run information appears in the Results / Run Results screen.

Column Description

Run Name The unique name of the run given when it was created in the software. Click a run name to
open the Run Summary. For more information, see “The run summary” on page 147.
Runs that are reanalyzed are listed with & (Reanalysis) after the run name. For more
information, see “Reanalyze a run” on page 192.

Assay Name The name of the assay selected for the run. You can view the Assay Name and
corresponding Assay Full Name for all assays in the Assays » Manage Assays screen.

Run Status The status of the run. For example, Analysis In Progress, Executing Plugins, Analysis

Completed, Terminated, Archival: In Progress, Purification In Progress, or Purification
Completed).

For purification runs that have a status of Purification In Progress, Purification Complete,
or for failed or aborted purification runs, you can place the pointer over the shaded number,
in the Status column to view the status of each purification batch for the run. The shaded
number, suchas 1 or 2, represents a purification batch for the run. For example, a status
can be 1 Completed, 2 Started, and 3 Planned, which indicates that the first batch is
complete, the second batch has started, and the third purification batch has not yet started,
but is planned. For more information about purification batches, see “Integrated nucleic acid
isolation in Sample to Result runs” on page 66.

Total Samples

The total number of samples in a run.

PCR Plate Number

A unique identifier for the 96-well plate used for library preparation and templating. For more
information, see “Assign PCR Plate” on page 156.

Started On

The date and time when the run was started.

Updated On

The date and time when the last action was completed on the run.

You can also perform the following actions in the Results / Run Results screen.
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Option Description
Actions Available action links for a run are shown when you place the pointer over the row of a run.
The actions that are available depend on the type of run.

¢ Delete—Delete the run.

¢ BAM Uploader—Upload run information to another Genexus™ Integrated Sequencer or
to lon Reporter™ Software for further analysis.
BAM Uploader is not available for BAM run results or for archived runs in which BAM
files have been removed.
For more information, see “Upload results files to another Genexus™ Integrated
Sequencer” on page 195 and “Upload results files to lon Reporter™ Software” on
page 196.

¢ Audit—View the audit trail for the run.
For more information, see “Review and download a run history” on page 85.

* CSA—Download customer support archive (CSA) log files for the run to help with
troubleshooting.
For more information, see “Download a Customer Support Archive” on page 428.

* Assign PCR Plate—Enter a unique identifier for the 96-well plate used for library
preparation and templating. For more information, see “Assign PCR Plate” on
page 156.

Actions These actions are available only for Sample to Result runs.

View Plan—View detailed run plan information.

For more information, see “Run plan details” on page 84.

Review—Review samples that do not have a concentration within a specified threshold
after purification, but before library preparation.

For more information, see “Review samples for Sample to Result runs” on page 71.
Abort—Allows you to abort a run after purification, but before sequencing. This action
is available when the run status is Purification Review Required, or when the run
status is Purification Completed and some purification samples have been excluded
from sequencing.
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View the run summary

The run summary provides an overview of the run. The information that is displayed includes the

name of the assay used in the run, sample locations, information about the reagents used in the run,
primer tube positions, and instrument information. Metrics from sample purification are also provided, if
applicable.

1.

2.

146

Review the run summary.

In the menu bar, click Results » Run Results.

In the Run Name column, click the run name of interest.
The Run Summary tab opens.

Action

Procedure

View the assay metrics.

In the Assays section, click the assay name of interest.

View the sample locations in an image
of a 96-well sample plate.

In the Sample Locations section, click PCR Plate View.

Reanalyze a run with a new assay.

In the upper right corner of the screen, click
-+« (More Options) » Reanalyze.

For more information, see “Reanalyze a run” on page 192.

Run plugins on the sequencing data
after a sequencing run is complete.

In the upper right corner of the screen, click

-+« (More Options) » Run Plugin.

For more information, see “Run plugins after a sequencing run
is complete” on page 191.

Download customer support archive
(CSA) log files for the run to help with
troubleshooting.

In the upper right corner of the screen, click

-+« (More Options) » CSA.

For more information, see “Customer Support Archive (CSA)”
on page 428.

Upload results to another Genexus™
Integrated Sequencer or to lon
Reporter™ Software for further
analysis.

In the upper right corner of the screen, click

.-+ (More Options) » BAM Uploader.

For more information, see “Upload results files to another
Genexus™ Integrated Sequencer” on page 195 and “Upload
results files to lon Reporter™ Software” on page 196.

View the history of variant
classifications.

In the upper right corner of the screen, click

+++ (More Options) » Variant Audit.

The information is available only for results that include variant
classifications.

View the run report.

Click the Run Report tab.
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The run summary

The run summary displays run information, assays used in the run, sample locations, metrics from
sample purification, information about the reagents used in the run, primer tube positions, and
instrument information.

Depending on the type of the run and the selections made in the run plan, the run information can
include the following items.

Run information

Item Description
Run Name The name of the run.
Started On The date and time when the run was started.

Completed On

The date and time when the run was completed.

Run Status The status of the run.

Report Template If the option to generate a report was enabled in the run plan, the report template used is
listed.

Chip Type The semiconductor sequencing chip used in the run, such as the lon Torrent™ GX5™ Chip.

Library Chemistry The type of library chemistry used in the run, such as lon AmpliSeq™ HD.

Server The lon Reporter™ Software account or the Genexus™ Software account and the respective
software version that was selected for uploading BAM files when the run is complete.

Run Type The type of run. For example, Sample to Result.

Sequencing instrument information

Item

Description

Instrument Name

The name of the sequencer.

Instrument Serial

The serial number of the sequencer.

Number

Status The status of the sequencing portion of the run.

Operator The name of the person who was signed in the Genexus™ Integrated Sequencer when the
sequencing run was performed.

Start Date The date and time when the run was started on the sequencer.

Completion Date

The date and time when the run was completed on the sequencer.

Sequencing Flows

The number of flows performed by the sequencer.
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Purification instrument information

Item

Description

Purif. Instrument

The name of the purification instrument.

Instrument Serial
Number

The serial number of the purification instrument.

Status The status of the purification portion of the run for the batch.

Operator The name of the person who was signed in the Genexus™ Purification Instrument when
purification was performed.

Start Date The date and time when the batch was started on the purification instrument.

Completion Date

The date and time when the batch was completed on the purification instrument.

Purif. Batch

The nucleic acid isolation batch.

Assays table

Item

Description

Assay Full Name

The name of the assay used in the run. Click the assay name to display the details of the
assay.

Assay Name

An abbreviated name of the assay or assays used in the run.

Analysis Version

The version of the assay used for analysis.

Research The research application for the assay, such as DNA or DNA and Fusions.
Application
Lane The chip lane or lanes used in the sequencing run for the assay.

Total Samples

The total number of samples sequenced for the assay. A single sample can correlate with
multiple wells on the plate for some assays when multiple nucleic acid types are contained
within the sample.

Updated
Annotations

The information that is shown depends on the settings and the type of the assay.

* The name and version of the annotation source that is applied to the sample result is
shown when an assay is configured to use the latest annotations but the annotation
that is applied to the results is not the latest annotation source.

¢ No information is shown in the column (the value is blank) when the latest annotation
set version is applied to the result, regardless of whether the assay is configured to use
the latest annotation source.

* No information is shown in the column (the value is blank) when an assay is configured
to not use the latest annotation source, and instead uses a fixed version of an
annotation source.

* N/A is shown when an assay does not use an annotation set.
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Purification Samples table

Item

Description

Batch ID

When the run includes more than one purification batch, the Batch ID is listed. The Batch
ID, such as 1 or 2, indicates the purification group for each sample.

Sample Name

The unique identifier created when the sample was entered into the software.

Sample Type

A term that describes the sample, for example, FFPE or Blood (Plasma).

Nucleic Acid Type

DNA, RNA, or DNA+RNA.

Conc. (ng/pl)

The concentration of the sample measured by the purification instrument.

In some instances, such as when purification is in progress or when the sample is a no-
template control, the values is listed as N/A.

If the concentration is not within the QC concentration range specified by the assay, a
Quantity Not Sufficient (QNS) alert is displayed.

QC Conc. Range
(ng/pl)

The QC concentration range for the assay.

Batch Status

The run status of a purification batch.

The status can be N/A, Planned, Review, Started, Aborted, or Completed.

Archive Position

The sample positions in the archive plate.

Sample positions can be in rows A to D and in columns 1 to 8.

Library Prep

An indicator of whether the sample is selected for sequencing.
. (Checkmark) — indicates that the sample is selected for sequencing.
* @ - (Noicon) indicates that the sample is not selected for sequencing.

* N/A - indicates that purification has not started or is in progress.

Sample Locations table

Item

Description

PCR Plate View

Click to view the sample locations in an image of a 96-well sample plate.

Well Pos.

The well position indicates the location of the sample on the plate.

Library Batch ID

The unique identifier created for the library batch. This information is available only for
Library to Result runs.

Sample Name

The unique identifier created when the sample was entered into the software.

Nucleic Acid Type

The sample nucleic acid type, such as DNA, RNA, or TNA.

Vol. (pl)

The volume of the sample.

Conc. (ng/pl)

The concentration of the sample.

Dilution Factor

The dilution factor of the sample.
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Sample Locations table (continued)

Item

Description

Kit Barcodes

The barcode for the kit used for nucleic acid extraction, if applicable.

Barcode

The name of the barcode adapter or adapters that are associated with the sample, for
example, lonHDdual_0101.

Assay Name

The assay that was used to sequence the sample for the indicated well position.

Library Position

The plate location of libraries. For completed runs that were planned using samples,
the Library Position indicates the location of unused libraries that can be sequenced by
planning and initiating a library run.

Reagents table

Item Description
Consumable Consumables used in the run, such as the PanelKit and LibraryKit, are listed.
Barcode The consumable barcode, if applicable.
Part # The consumable part number, if applicable.

Expiration Date

The consumable expiration date, if applicable.

Lot #

The consumable lot number, if applicable.

The Primer Tube Positions table shows an image that indicates the locations of the primer pool tubes.

View assay metrics and the run report

The run report provides detailed information about a run, such as the Total Bases and Final Reads. For
runs with multiple assays, metrics are provided for each assay in the run. The run report contains the
assay metrics for all assays in the run.

For runs with only one assay, the run report and assay metrics show the same information for assay
metrics. In addition to the metrics for the assay, the run report shows information about the run and the
instruments used in the run.

1. Click Results » Run Results to view sequencing results for a particular sample.

2. In the Run Name column, click the run name of interest.

Action Procedure

View the run report

Click the Run Report tab.

View the assay metrics for a single assay

In the Select Assay dropdown list at the top of
the screen, select the assay of interest.

For more information, see “Assay metrics and the run report” on page 151.
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Assay metrics and the run report

The run report provides detailed information, such as chip metrics for the run, well, and lon Sphere™
Particles (ISPs) statistics. For runs with multiple assays, metrics are provided for each assay in the run.
Sequencing metrics are shown at the top of the screen, followed by sample-specific metrics in the Run
Samples table. Read data for individual samples for the assay are listed in the Run Samples table.

Barcode-specific metrics for barcodes that are included in the run are listed in the Barcodes With
Reads Reported table, which follows the Run Samples table. The CSA file for the run contains
information for barcodes that are not assigned to samples in the run. Information in the CSA file can
help you troubleshoot results, if needed. For more information, see “Download a Customer Support
Archive” on page 428.

Run Report
Metric Description
Loading The number and percentage of total addressable wells on the chip that contain an ISP.
Enrichment The number and percentage of wells ISPs that contain live ISPs.
Library The number and percentage of wells with live ISPs that contain Library ISPs.

Combined Final Reads

For runs that include resequencing, the combined final reads is the sum of library
reads from both sequencing and resequencing.

Final Reads Library reads passing all filters that are recorded in the output BAM files. This value
can be different from the total number of reads due to technicalities associated with
read trimming beyond a minimal requirement.

Total Bases The number of filtered and trimmed base pairs that are reported in the output BAM

file.

Combined Total Bases

For runs that include resequencing, the combined total bases is the sum from
sequencing and resequencing.

Raw Read Accuracy

The raw read accuracy across each individual base position in a read calculated as,
(1-[total errors in the sequenced reads]/[total bases sequenced]) x 100. Raw read
accuracy is measured at each base across the length of the read and is based on 1x
sequencing coverage; raw read accuracy is not based on consensus accuracy across
multiple reads for the same base position.

Wells with ISPs

The number of wells that contain an ISP.

Unenriched

The number and percentage of wells with ISPs that do not contain live ISPs.

Total Addressable Wells

Wells on the chip that can be physically reached by a library.

Empty Wells

The percentage of total addressable wells on the chip that do not contain an ISP.

Wells with Live ISPs

Loaded wells with ISPs with a signal of sufficient strength and composition to be
associated with the library or control fragment key.

Wells with Library ISPs

Loaded wells with live ISPs with a key signal that is identical to the library key signal.
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Run Report (continued)

Metric Description
Control ISPs Loaded wells with live ISPs with a key signal that is identical to the control fragment
key signal.
Filtered out The total percentage of filtered reads, or the sum of the percentages of polyclonal, low
quality, and adapter dimer reads.
Polyclonal Wells with a live ISP that carries clones from two or more templates.
To view polyclonal metrics, mouse over the first low quality portion (gray) of the Final
Reads bar plot.
Final Reads 58.39% (® Filtered out 41.61%
30,735,120
Final Reads(30,735,120) / Wells with Library 5P:[52,635,12¢}% Polyclonal: 139351086 (30.27%) |
Low Quality Loaded wells with a low or unrecognizable signal.
To view polyclonal metrics, mouse over the second low quality portion (gray) of the
Final Reads bar plot.
Final Reads 58.39% (® Filtered out 41.61%
30,735,120
Final Reads({30,735,120) / Wells with Library 15P=(52,635,124) % Low Quality: 3208258 (6.1%)
Adapter Dimer Loaded wells with a library template of an insert size less than 8 bases.
To view adapter dimer metrics, mouse over the lightest gray portion of the Final
Reads bar plot.
Final Reads 43.57% @ Filtered out 56.44%
52,494,934 s
Final Reads(52,494,934) / Wells with Library ISPs(120,492,758) Adapter Dimer: 10862754 (9.02%)
Note: In assays using lon AmpliSeq™ HD library chemistry, adapter dimer reads
represent a small proportion of total reads and can be seen by hovering the pointer
over the right end of the Final Reads bar.
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Metric

Description

Loading Density

A visual representation of chip loading. Red color indicates areas of higher density of
loading. Blue color indicates areas of lower density of loading. The following example
shows a sequencing experiment where two lanes on the chip are uniformly loaded
with ISPs.

Run Samples

The Run Samples table lists read data for each individual sample in the assay.

Column

Description

Sample Name

The unique identifier created when the sample was entered in the software.

Nucleic Acid Type The sample nucleic acid type, such as DNA, RNA, or TNA.

Barcode The unique identifiers of the dual barcode pair assigned to the DNA and/or RNA library
for a sample.

Total Reads The total number of filtered and trimmed reads with the listed dual barcodes assigned

to the sample.

Mean Read Length

The average length, in base pairs, of usable library reads for each sample.

=Q20 Bases

The total number of called bases that have =99% accuracy (or less than 1% error rate)
aligned to the reference for the sample.

Mapped Reads

The number of reads that are mapped to the reference file.

On Target Reads

The percentage of sequencing reads mapped to any target region of the reference.

Mean Depth

The average number of reads of all targeted reference bases.

Uniformity

The percentage of bases in all targeted regions (or whole genome) with a depth of
coverage =20% of the mean read coverage.

Read Length Histogram

A histogram that presents all filtered and trimmed library reads that are reported in the
output BAM file (Y-axis) and the mean read length in base pairs (X-axis).

0 50 0o 150 200 250 300
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Barcodes with Reads Reported

The Barcodes with Reads Reported table lists barcode-specific metrics

Column

Description

Barcode

The unique identifiers of the dual barcode pair assigned to the DNA and/or RNA library
for a sample.

Total Reads

The total number of filtered and trimmed reads with the listed dual barcodes assigned
to the sample. The reads are independent of length reported in the output BAM file.

Mean Read Length

The average length, in base pairs, of usable library reads for each sample.

=Q20 Bases

The total number of called bases that have =99% accuracy (or less than 1% error rate)
aligned to the reference for the sample.

Read Length Histogram

A histogram that presents all filtered and trimmed library reads that are reported in the
output BAM file (Y-axis) and the mean read length in base pairs (X-axis).

0 50 0o 150 200 250 300

Download information about run samples

Information about each sample in a run, such as the barcode for the sample and the total reads, are
shown in the run samples table. You can download the information shown in the run samples table.

—

In the menu bar, click Results » Run Results.

2. In the Run Results screen, in the Run Name column, click the run name of interest.

w

. Click the Run Report tab, then scroll to the Run Samples table.

4. In the upper right corner above the Run Samples table, click [{] Export to Excel.

An XLSX file that contains the information shown in the run samples table is downloaded.

Read length histograms are not included in the file.

Download reads reported by barcodes

Metrics for the barcodes that are included in a run are listed in the barcodes with reads reported table.
You can download the information shown in the barcodes with reads reported table.

—

In the menu bar, click Results » Run Results.

2. In the Run Results screen, in the Run Name column, click the run name of interest.

3. Click the Run Report tab, then scroll to the Barcodes with Reads Reported table.

4. In the upper right corner above the Barcodes with Reads Reported table, click Export to

Excel.
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An XLSX file that contains the information shown in the barcodes with reads reported table is
downloaded.

Read length histograms are not included in the file.

View resequencing metrics

For assays that include resequencing, you can view resequencing metrics when a run is complete.

1. In the menu bar, click Results » Run Results.
2. In the Run Results screen, in the Run Name column, click the run name of interest.

3. In Select Assay, select the assay name of interest.
The assay metrics for the sequencing run are shown.

4. Click Resequencing Metrics.
The resequencing assay metrics are shown. For more information, see “Assay metrics and the run
report” on page 151.

Retain run results

You can retain run results in Genexus™ Software. When you retain a run result, run data, including

the run result, .wells files, and intermediate files, are retained and cannot be deleted. Users with any
level of permissions can retain run results. When a run result is retained, it overrides the automatic
deletion settings in the software. For more information, see “Set a schedule to permanently delete files
(administrator)” on page 327.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, select the checkbox in the row of one or more run results that you want
to retain.

3. Click [] Retain Data.

Run results that have been retained are denoted with [] after the run name in the Run Results screen.
The run result is retained in the system and cannot be deleted. For information to revert the run to a run
that is not retained, see “Release run results” on page 156.
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Release run results

Only run results that have been retained in Genexus™ Software can be released. For more information,
see “Retain run results” on page 155.

When you release run results, you can delete the run results. The run results, the associated .wells
files, and intermediate files are available to be auto-deleted according to system settings. For more
information, see “Set a schedule to permanently delete files (administrator)” on page 327.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, click Release Data in the row of the run of interest.
Run results that have been retained are denoted with [] (retained) after the run name.

3. Click Yes to confirm that you want to proceed with the data release.

The run result is released. The run result can be deleted or auto-deleted.

Assign PCR Plate

156

Genexus™ Software allows you to track and associate a run with the PCR plate used in the run. The
PCR plate is the 96-well plate that is used for library preparation and templating. You can assign a
unique identifier, a PCR Plate Number, to runs that have a status of Library Preparation Completed,
Sequencing Completed, or Run Completed. The PCR plate number that you enter is shown in the
Run Results screen and if needed, can help you track libraries and troubleshoot. Later, if you sequence
the remaining libraries in a different sequencing run and assign the PCR plate number to the run, you
can easily search for and find all run results associated with the libraries in the PCR plate.

Note: You should assign a PCR plate to a run if there are leftover libraries that you want to use at later
time to perform a Library to Result run. You can look up the PCR plate number on completed runs to
get the library and barcode mapping, then enter the same Barcode information into the Library to Result
run.

For more information to find a run with a search of the PCR Plate Number, see “Search for run results”
on page 157.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, place the pointer over the row of a run of interest, then click Assign
PCR Plate number.

3. In the Assign PCR Plate Number dialog box, confirm, edit, or enter the PCR Plate Number.

The PCR plate number must be between 1 and 10 characters. Only alphanumeric characters
(numbers 0 to 9 and letters A to Z), period (.), underscore (_), or hyphen (-) are allowed. Spaces are
not allowed.

4. Click Submit to associate the PCR plate with the run.
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Find a run result

You can sort, search, and filter information to narrow the run results that are listed in the Results / Run
Results screen. The sort, search, and filter tools help you organize run results and find a specific run
result in Genexus™ Software.

For information to search for a run result by a unique identifier, such as the name of a run, see “Search
for run results” on page 157.

For information to filter run results by a common trait, such as run results that have a status of analysis
completed, see “Filter the list of run results” on page 159.

Search for run results

Run results are listed in the Results / Run Results screen in Genexus™ Software. The most recent run
result is on the top of the list.

You can search for run results with keywords or text that are included in the name of the run name, the
name of an assay applied to the run, or by the PCR Plate number. For more information about how to
use the PCR Plate number to track libraries, see “Assign PCR Plate” on page 156.

IMPORTANT! Search terms must adhere to the following rules.

. An asterisk (*) is not allowed in the search field for use as a wildcard.

. Searches are case-insensitive, that is, both upper-case and lower-cases letters are found regardless
the case of search term letters.

. Searches find every occurrence of a continuous string. For example, a search for demo in analysis
names returns a list of all analysis with a name that includes demo. For example, demo1, demo2,
and so on.

. Spaces are removed during searches, and therefore are not recommended. For example, a search for
demo 1 would return results only for data that includes the string demo1.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, in the Run Name, Assay Name, or PCR Plate Number column
heading, click Y (Filter).

a. In the search field, enter a full or partial assay or run name or PCR plate number of at least 3
characters.

When you have entered at least 3 characters, the filter dialog box limits the list in the filter
dialog box based on the entry.

b. In the filter dialog box, select from the limited list.
* Select a checkbox next to a run or assay name to select one or more items.

* Click Select All to select all items listed in the filter dialog box.

Note: If you click Clear, all selections are removed and the filter dialog box closes.

c. In the filter dialog box, click Filter.
In the column heading, (Filter) changes color to indicate that a filter is applied.
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The filtered list of run results is shown in the Run Results screen.

3. Click {x] Clear Filters to remove all filters and view the full list of run results.

Sort the list of run results
You can sort the list of run results to make it easier to find a run result of interest in Genexus™ Software.

By default, run results are listed in the Runs / Run Results screen by date. The most recent run result is
at the top of the list.

You can change the order that the run results are listed and sort the run results alphabetically or reverse
alphabetically.

1. In the menu bar, click Runs » Run Results.

2. In the Run Results screen, click the Run Name heading.
The list of run results is sorted alphabetically.

3. Click the column heading again to reverse the order.
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Filter the list of run results

You can apply filters to narrow search results, or shorten the list of run results when you view the list of
run results in Genexus™ Software.

1. In the menu bar, click Runs » Run Results.

2. In the Run Results screen, select one or more filters.

Option Description
Filter and search by the For more information, see “Search for run results” on page 157.
run name or the assay
selected in the run.
tShh?W or hidh‘? ru(l; results 1. In the dropdown list in the upper left corner, select an archive status.
at are archive
2. ¢ Archived * Non Archived
3. Select All to list all run results.
Filter by the status of the 1. In the Run Status column heading, click 'Y (Filter) then select at
run result. least one status.
* Analysis Completed ¢ Executing Plugins
* Analysis In Progress * Library Preparation
* Analysis Failed Aborted
e Analysis Aborted * Library Preparation
Completed
* Analysis Stalled Lib P p
* Library Preparation
¢ User Aborted Started
* Run Aborted * Selected on Instrument
* Purification Completed « Sequencing Completed
¢ Purification Run Aborted « Sequencing Started
¢ Purification Failed « Sequencing Aborted
° PUI’IfI.Catlon Review « Templating Aborted
Required T | c loted
* Templating Complete
* Purification In Progress T pl 9 s pd
* Templating Starte
¢ Selected on Purification P 9
Instrument ¢ Kit Barcodes Required
e Backup In Progress
2. Click Filter.
Records are listed for run results that meet the run status criteria.
Filter by the number of In the Total Samples column heading, click Y (Filter) then use the
samples in the run. options to filter the list in the filter dialog box based on the number or
span of numbers of samples in the run.
List only run results from 1. In the Started On or Updated On column heading, click Y (Filter).
runs that were started on 5. Inthe first dropd list select I It
or updated on an exact . In the first dropdown list, select Is equal to.
date.
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Option

Description

3. In the calendar that appears, select the date of interest.
4. Click Filter.

Records are listed for run results that were started on or updated on the
date entered.

List only run results from
runs that were started on
or updated within a date
range.

In the Started On or Updated On column heading, click Y (Filter).
In the first dropdown list, select Is after or equal to.

In the calendar that appears, select the earliest date of the range.

In the Boolean operator dropdown list, select And.

In the second dropdown list, select Is before or equal to.

In the calendar that appears, select the latest date of the range.
Click Filter.

N o o~ b=

Records are listed for sample results started on or updated on dates that
meet both conditions.

List run results according
to a date that meets either
one condition or a second
condition.

1. In the Started On or Updated On column heading, click Y (Filter).
2. In the first dropdown list, select Is after or equal to.

In the calendar that appears, select the earliest date for the sample
results of interest.

In the Boolean operator dropdown list, select Or.
5. In the second dropdown list, select Is before or equal to.

6. In the calendar that appears, select the latest date for the sample
results of interest.

7. Click Filter.

Records are listed for sample results for runs that were started on or
updated on dates that meet at least one of the conditions.

List only run results for
runs that were started on
or before or updated on
or before a date that you
indicate.

In the Started On or Updated On column heading, click Y (Filter).
In the first dropdown list, select Is before or equal to.

In the calendar that appears, select the date of interest.

Click Filter.

> b=

Records are listed for run results that were started on or before the date
entered.

List only run results for
runs that were started on
or after, or updated on
or after, a date that you
indicate.

In the Started On or Updated On column heading, click Y (Filter).
In the first dropdown list, select Is after or equal to.

In the calendar that appears, select the date of interest.

Click Filter.

Ao b~

Records are listed for runs that were started on or after, or updated on or
after, the date entered.

In the column heading, (Filter) changes color to indicate that a filter is applied.
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Click {x] Clear Filters to remove all filters and view the full list of run results.

Compare sample results

You can compare variant results across samples with Genexus™ Software. Comparisons between
various results can be made.

* For information about the comparison of results from immune repertoire assays, see “Compare
immune repertoire results” on page 167.

* For more information about the comparisons of variant results across all other assays, see
“Compare variant results” on page 161.

Results generated using the system-installed Oncomine™ TCR Beta-LR Assay GX or any other immune
repertoire assay can only be compared to sample results from runs that use the same assay.

Compare variant results

You can compare variant results and create comparison plots from multiple sample results with
Genexus™ Software. A description of the comparison of results from immune repertoire is not included
here. For more information, see “Compare sample results” on page 161. Comparisons across samples
or runs can be used to analyze results for a hotspot of interest. You can also view the trends of a
reported variant over time.

The following comparisons can be made in Genexus™ Software.
* Comparisons of multiple samples, sequenced and analyzed with the same or different assays

* Comparisons of multiple samples over time, sequenced and analyzed with the same or different
assays

* Comparisons of the results from one sample, sequenced and analyzed with different assays
If samples from different assays are compared, the research application (such as DNA or DNA and
Fusions) must be comparable. That is, results generated from DNA-only assays cannot be compared
to results generated from RNA-only or fusion-only assays. However, if the results from a research
application include the type of results from another research application, the comparison can be made.
That is, you can compare variant results generated from a DNA and Fusion assay to the variant results
generated from a DNA-only assay.

View variant result comparisons

You can view variant comparisons in tabular format in Fusions, SNVs/Indels, and CNV comparison
tables in the Compare screen.

1. In the menu bar, click Results » Sample Results.

2. Click the checkboxes next to the sample names of interest.

Tip: In the Sample Status column heading, click Y (Filter), then select Completed to limit the
entries that are displayed on the Sample Results screen.
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3. Above the list of sample results, click ( Compare.

Note: Compare is not enabled until at least two samples are selected.

The Compare screen opens to the Compare Samples tables. The Oncomine™ Extended filter is
the default filter for the data displayed in the tables.

4. (Optional) In the Compare screen, in the upper right corner, select a different Filter Chain to apply

a different filter chain to the variants displayed in the tables. For more information, see “Filter

results” on page 121.

5. (Optional) Click Export to download an XLSX spreadsheet file of the variant comparison table.

Results / Compare

Compare Samples

OO ©

@—SNVs/Indels

Export /" SRTestSample01 | 2021-03-26

+/ SRTestSample03 | 2021-03-26

@—VariantlD @—Gene Mchange

@_ call

Call

COSM5673 CTNNB1
COSMe128 CTNNB1
COsSM763 PIK3CA

COSMT75 PIK3CA

COSMe252 EGFR

@ Export: Download a Microsoft™ Excel™ file of the sample

comparison Fusions table.
(@ The QC status of the sample.
@ The sample name.

p.S33Y

p.S45del

p.E545K

p.H1047R

p.G719S

@ The date the sample was analyzed.

@ The variant type. In this example: SNVs/Indels.

PRESENT (HETEROZYGOUS)

PRESENT (HETEROZYGOUS)

PRESENT (HETEROZYGOUS)

PRESENT (HETEROZYGOUS)

PRESENT (HETEROZYGOUS)

PRESENT (HETEROZYGOUS)

PRESENT (HETEROZYGOUS)

PRESENT (HETEROZYGOUS)

PRESENT (HETEROZYGOUS)

PRESENT (HETEROZYGOUS)

(@ Gene: The gene name.

AA Change: Identification of the amino acid change using
Human Genome Variation Society (HGVS) nomenclature.

(9) cCaill: Indicates the presence or absence of an SNV/Indel

variant.

@ Variant ID: The name of the hotspot as defined in the
Browser Extensible Data (BED) file.

The following table lists and describes the default information shown in the comparison tables.

162

Table slider. Use to extend table to view more samples.
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Column

Description

Fusions comparison tables

Variant ID

The name of the hotspot as defined in the BED file.

Oncomine Driver Gene

For fusion class variants, the 5’ gene that drives proliferation of expression.

Read Counts

The frequency that the fusion was detected in the sample.

Call

The presence or absence of a fusion for the specific hotspot.

Read counts per million

The number of fusion read counts detected per number of total reads (in millions).

SNV/Indels comparison tables

Variant ID The name of the hotspot as defined in the BED file.

Gene The gene name.

AA Change Identification of the amino acid change using HGVS nomenclature.

Call Indicates the presence or absence of an SNV/Indel variant. See SNV/Indel section for

more information.

CNVs comparison tables

Variant ID

The name of the hotspot as defined in the BED file.

Gene

The gene name.

Copy Number

The frequency that the fusion was detected in the sample.

Note: Copy Number is not displayed for TNA CNV result comparisons.

Call

Indicates the presence or absence of a CNV.

CNV Ratio

Ratio of CNV amplicons after outlier removal.

Create time series graphs

You can create line graphs to view changes and trends in variant results over time.

1. In the menu bar, click Results » Sample Results.

2. Click the checkboxes next to the sample names of interest.

Note: Select Filter Runs by » Sample Status » Completed to limit the entries that appear in the
Sample Results screen.

3. Above the list of sample results, click (@ Compare.

Note: Compare is not enabled until at least two samples are selected.

The Compare screen opens to the Compare Samples tables. Oncomine™ Extended is the
default filter for the data that appear in the tables.
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4.

Read Counts Per Million

(Optional) In the Compare screen, in the upper right corner, select a different Filter Chain to apply
a different filter chain to the variants that are shown in the tables. For more information, see “Filter

results” on page 121.

In the Compare Samples table, select the checkboxes next to the Variant IDs that you want to
view in a plot.

The datapoints are added to the line graph with a live preview that is shown to the right of the
Compare Samples table.

Download a file of the line graph and the information in the variant table that was used to create
the graph, if needed.

* (Click Export Variants to download the information in the Compare Samples variant table for
the selected variants in XLSX format.

¢ C(Click Download Chart to download a PNG file of the time series line graph.

Fusions Expoct Variants Download Chart
12000
10000
n
2000
&000 .
z
2000
0 *—@ @

Jun12 Jun 13 Juni1d Jun15 Jum16 Juni17 Jum18 Juni1® Jun20 Jum 21
Analysis Date

@ PML-RARA PBdei11ins13343 [l TCF3-PBX1.T16P3.COSF1489 4y RUNX1-RUNX1T1.R3R3
A 51C45A3-BRAFS188.COSFET1 () LMNA-NTRK1.L2N11

Create and customize comparison plots

1.

2.

In the menu bar, click Results » Sample Results.

Click the checkboxes next to the sample names of interest.

Note: Select Filter Runs by » Sample Status » Completed to limit the entries that appear in the
Sample Results screen.
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3. In the upper right corner of the screen, click (¥ Compare.

Note: Compare is not enabled until at least two samples are selected.

The Compare screen opens to the Compare Samples tables. Oncomine™ Extended is the
default filter for the data that appear in the tables.

4. (Optional) In the Compare screen, in the upper right corner, select a different Filter Chain to apply
a different filter chain to the variants that are shown in the tables. For more information, see “Filter
results” on page 121.

5. In the Compare Samples table, select the checkboxes next to the Variant IDs you want to view in
a plot.
The datapoints are added to the line graph with a live preview that is shown to the right of the
Compare Samples table.

6. (Optional) To customize the chart, click Chart Options in the upper right corner of the screen.

7. Inthe Preferences dialog box, change the parameters to customize the plot.

X-Axis Options
Option Description
Sample Name The unique identifier for a sample.
Analysis Date The date of the sequencing run. The analysis date or run completion date is
typically included in the Sequencing run details of the variant report.
Collection Date The date that the sample was collected.
Y-Axis Options
Option Description
SNVs/Indels See “View SNV/INDEL results” on page 104.
Fusions See “View fusion results” on page 110.
CNVs See “View CNV results” on page 117.

Note: Y-Axis options depend on the assay or assays used to analyze the samples.

8. Click Apply to update the chart with the new selections.
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9. If needed, download a file of the image and the information in the variant table that was used to
create the graph.

* (Click Export Variants to download in XLSX format the information in the Compare Samples
variant table for the selected variants.
The columns that are selected in Table Columns determine the headings that appear in the
spreadsheet. If you change the column selections, you can download a new spreadsheet with
updated headings.

* (Click Download Chart to download a PNG file of the comparison plot or time series line

graph.
SNVs/Iindels ExportVariants = Download Chart
0.16
0.14
0.12 A
E 0.10
g
0.08
'S
< o
=
= 008
0.04
. &
0.02 =
0 = ¢
LinSample2 LipSample4 LinSample3 LibSample1
2020-02-18 2020-02-18 2020-02-18 2020-02-18

Sample Name

.COSMEN B COsSmM14249 COSM13424 & COSM43947

View and customize comparison tables

1. In the menu bar, click Results » Sample Results.

2. Click the checkboxes next to the sample names of interest.

Note: Select Filter Runs by » Sample Status » Completed to limit the entries that appear in the
Sample Results table.

3. In the upper right corner of the screen, click (@ Compare.

Note: Compare is not enabled until at least two samples are selected.

The Compare screen opens to the Compare Samples tables. Oncomine™ Extended is the
default filter for the data that appear in the tables.

4. (Optional) In the Compare screen, in the upper right corner, select a different Filter Chain to apply
a different chain to the variants that are shown in the tables. For more information, see “Filter
results” on page 121.
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(Optional) To customize the table or tables, click Table Columns in the upper right corner of the
screen. Then, select or deselect which columns to add or remove.

The available options depend on the assay or assays used to analyze the samples. For
descriptions of options, see the following sections.

Option Description
SNVs/Indels See “View SNV/INDEL results” on page 104.
Fusions See “View fusion results” on page 110.
CNVs See “View CNV results” on page 117.

Selected options are added as column headings to the Fusions, SNVs/Indels, and CNV
comparison table with live preview.

Click Table Columns again to close the dialog window.

Click Export Variants to download an XLSX spreadsheet file of the Fusions, SNVs/Indels, or CNVs
variant comparison table if needed.

Compare immune repertoire results

You can compare immune repertoire variant results with Genexus™ Software. A description of the
comparison of results generated from all other assays is not included here. For more information, see
“Compare sample results” on page 161.

Compare the immune repertoire between samples

Genexus™ Software can perform multi-sample (or cross-sample) analyses to compare the immune
repertoire between samples.

1.

2.

In the menu bar, click Results » Sample Results.

In the Sample Results screen, click the checkboxes next to the sample names of interest.
Select Filter Runs by » Sample Status » Completed to limit the entries that are displayed on the
Sample Results screen.

The immune repertoire comparison is only applicable to samples sequenced with the system-
installed Oncomine™ TCR Beta LR - GX5 - RNA assay (or any other custom or system immuno-
oncology assay).

In the upper right corner of the screen, click (M) Compare.

Note: Compare is unavailable until at least two samples are selected.

The Overview of Repertoire Sequencing Results for Selected Samples table is displayed.

Genexus™ Software 6.8 User Guide 167



E’t 5 jL

~
|~ ]

Chapter 6 Review data and results
Compare sample results

Results / Compare

Go | JoinType: CDR3 NT

Overview of Repertoire Sequencing Results for Selected Samples

Metrics indicate the total number of reads reported after data processing, the number of clones detected, and the Shannon Diversity and Evenness of detected clones. Click on sample name to view detailed report. Data visualizations, clone summary and repertoire metrics are available via
Download button. To track clones across samples, use the checkbox to select two or more samples, then click Compare Samples.

Sample Barcode Project

TonDual 0122

TorDual 0121

TorDual 0124

TorDual 0123

Reads Clones Shannon Diversity Evenness Sequenced On Actions

25360 68, 04818 5 92019 06:26 AM Download
,,,,, 116 6843 May 202018 0626 AM Download
286330 14113 EEE 0679 May 202019 06:26 AM Download

§ 6883 May 20 2018 06:26 AM Download

4. (Optional) Click the hyperlinked Sample name to open the Immune Repertoire Results for that
sample. See “View Oncomine™ TCR Beta-LR Assay GX results” on page 188 for more information.

5. Click the checkboxes next to the analyses you would like to compare.

6. In the dropdown menu at the top of the screen, select how you would like to compare clones
across the sample. The options that are available depend on the immune repertoire assay.

Options

Description

CDR3 NT

Compare the clones based on the CDR3 nucleotide sequence. If
the nucleotide sequence is shared across the samples, those are
considered identical clones. This is the least stringent comparison
option.

Variable Gene + CDR3 NT

Compare the clones based on the rearrangement of the variable gene
plus the CDR3 nucleotide sequence.

Variable Gene + CDR3

Compare the clones based on the rearrangement of the variable gene

NT + Variable Gene SHM
Locations + Isotype

NT + Variable Gene SHM plus the CDR3 nucleotide sequence plus somatic hypermutation (SHM)
Locations locations.
Variable Gene + CDR3 Compare the clones based on the rearrangement of the variable gene

plus the CDR3 nucleotide sequence plus somatic hypermutation (SHM)
locations plus isotype. This is the most stringent comparison option.

7. Click Compare Samples to generate a comparison table and plots.

Note: Compare Samples is not enabled until at least two samples are selected.
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8. View variable comparison results in the Comparison Table tab.

Results / Compare

Comparison Table Comparison Plots

mew

Compare sample results

Go
Variable Joining CDR3AA CDR3NT R 2019 05 28 16_19 10 si... =R 2019 05 28 16_19 10 si... =R 2019 05 28 16 19 10_si... | R _2019_05 28 16_19_10_si...
@_ TRBV3-1 TRBI2-1 ASSQQLGEQF GCCAGCAGCCAACAATTA.. 0.1652714 0.1639175 0.1765607 0.1731592
TRBV3-1 TRBI2-3 ASSQDGGQNTDTQY GCCAGCAGCCAAGATGG... 0.0976337 0.111556 0.1141034 0.1087709
TRBV28 TRBJ1-2 ASSLHHKSNYGYT GCCAGCAGTTTACATCAC.. 0.0263682 0.0240425 0.0236533 0.0267215
TRBV29-1 TRBJ2-2 SIIIQNTGELF AGCATCATAATTCAGAAC... 0.0230953 0.0178862 0.0158377 0.0145415
TRBV7-9 TRBI2-7 ASSRGPAYEQY GCCAGCAGTCGAGGGCC 0.0135291 0.0139386 0.0064417 0.0074447
TRBV28 TRBI2-7 ASSFLGAGGLYEQY GCCAGCAGTTTCCTTGGT. 0.0135291 0.0133606 0.0124404 0.0117367
TRBV29-1 TRBI2-1 SVEDSLASGSGEQF AGCGTTGAAGATTCTTTG. 0.0103825 0.0085906 0.0070686 0.0068109
TRBV2 TRBJ1-2 ASTEWSGNYGYT GCCAGCACTGAATGGTCC, 0.0089116 0.0142535 0.0111303 0.0106844
TRBV11-2 TRBI2-3 ASSLTALGRSPDTQY GCCAGCAGCTTAACCGCC.. 0.0084069 0.0069364 0.0080709 0.0085592
TRBVS-1 TRBJ2-2 ASSLGFNTGELF GCCAGCAGCTTGGGATTT... 0.0073344 0.009789 0.0081009 0.0089362
- 2 3 4 5 6 7 8 10 10 items per page 1-10 of 43498 items
@ Each row represents a clone.
@ The frequency of the clone for the listed sample.
9. View comparison plots in the Comparison Plots tab.
Options Description

analyses.

Comparisons between 2

An interactive scatter plot for the selected analyses is shown in the
Comparison Plots tab.

than 2 analyses.

Comparisons between more

A Jaccard Similarity Index for the selected analyses is shown in the
Comparison Plots tab.

* The interactive scatter plot indicates the frequency of clones across two analyses. For more
information, see “Example correlation and proportion of shared clones” on page 170.

* The Jaccard similarity index is determined for each pairwise comparison and is displayed in heat
map format. For more information, see “Example Jaccard Similarity Index for selected samples” on

page 170.
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Example Jaccard Similarity Index for selected samples

This is an example of a Comparison Plots tab showing the Jaccard Similarity Index for selected
samples. The Jaccard similarity index is determined for each pairwise comparison and displayed in
heatmap form. The Jaccard Similarity Index ranges from 0 to 1 and is calculated as the total number of
shared clones divided by the total number of distinct clones across two samples.

Resalts / Compare

Comparison Table  Comparison Plots

Jaccard Similarity Index for selected samples &

Legend
Label  Analysis Name

Analysis 1 R_2019_05_28_16_19_10_sierra_VB12-12-VB12_TCR-Beta_Smin_extension_28May2019_DY

2_VB12-12-VB12_TCR-Beta_Smin_extension_28May2019 DY

a_VB12-12-VB12_TCR-Beta_Smin_extension_28May2019 DY

Example correlation and proportion of shared clones

This is an example of a Comparison Plots tab scatterplot. The illustration indicates the frequency of
clones across two samples. Frequency values are log10 transformed with a pseudocount frequency of
1E-6 added to each value. Hovering over a point reveals the CDR3NT and AA sequence of a clone, the
variable mutation, and the frequency in either sample.

Results / Compare

Comparison Table | Comparison Plots

Correlation and proportion of shared clones (log10 scale with pseudocount added)

o

V-gene: IGHVS-51

Joining: IGHJE

CDR3 NT: GCGAGACAACGAGGGAAAGCTGGAACTTGGAGCGGTATGGACGTC
CDR3 AA: ARQRGKAGTWSGMDV

Timing_Verificaion_PBL_ANA_Hu_SR_8samples 540 C1_Rep3 ANA_v2_c4810_2010-06-27-1
6-02-28-556

Timing_Verification_PBL_RNA_Hu_SR_Bsamples_540_C1_Rep2_AINA v2_cdS55_2018.06-27-16-04-28-556
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Results files

The following files can be downloaded for each sample. Results files include the sequencing data,
results from the analyses, such as variant files, and audit and log files.

The files that are available for download depend on the assay.

For a list and descriptions of plugin output files, see “Output files generated by the coverageAnalysis
plugin” on page 346, “Output files generated by the molecularCoverage Analysis plugin” on page 3583,
and “Output files generated by the samplelD plugin” on page 359.

For instructions to download results files, see “Download results files for multiple sample results” on
page 174 and “Download results files for a sample result” on page 175.

Option

File name

Description

Variants

Filtered Variants (.vcf)

<Sample name>
_<LibPrepID>
_filtered.vct

Summary of filtered variant results in variant call
format (VCF). The variants that are included in the
VCF file depend on the filter chain that is applied
to the sample results. For more information, see
“Filter results with a filter chain” on page 122.
You can view the extracted files individually,

or upload a VCF file to a software application
that accepts VCF files, such as lon Torrent™
Oncomine™ Reporter software.

All Variants (.vcf)

<Sample name>
_<LibPrepID>
<analysisID>.vcf

Summary of variant results in variant call
format (VCF). You can view the extracted files
individually, or upload a VCF file to a software
application that accepts VCF files, such as lon
Torrent™ Oncomine™ Reporter software.

All Variants (.tsv)

<Sample name>
_<LibPrepID>
<analysisID>.tsv

The file in TSV format contains the information
that is shown in the variants table in tab-
separated value format (TSV). The information
that is included in the file is based on the gene
list and filter chain that are applied. In addition
to the information shown in the variants table,
the file includes information for the columns
that are available, but are not selected. The file
also includes information that is listed in the
Annotations table.

Variant Summary (.tsv)

Summary.tsv

File that lists SNV/INDEL, copy number, and
fusion results in tab-separated value format (TSV).

Snvs/Indels (.tsv)

Snvindel.tsv

File that lists SNV/INDEL variant results in tab-
separated value format (TSV).

Fusions (.tsv)

Fusion.tsv

File that lists fusion results in tab-separated value
format (TSV).
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Results files
(continued)
Option File name Description
CNVs (.tsv) Cnv.tsv File that lists copy number variant results in tab-

separated value format (TSV).

Copy Number results (.png)

cn_results.png

A file that represents the CNV amplicons in the X
scale and log2 ratio in Y scale. You can open the
file with a text editor.

Amplicon Data (.txt)

amplicon data.txt

A tab delimited file that contains information
about the copy number estimates calculated

per gene and the adjustments applied from the
baseline, including pool correction, amplicon GC
correction, amplicon length correction, and PC
correction.

Sequencing Results

DNA Unmapped Bam File
(.bam)

<barcode>
_rawlib.basecaller.bam

Unmapped DNA barcode BAM file; output after
mapping reads to reference.

DNA Mapped Bam File
(.bam)

merged.bam

Mapped BAM file of combined barcode reads.

DNA Mapped Bam Index
File (.bai)

merged.bam.bai

Mapped BAM Index file.

DNA Basecaller FASTAQ File
(.fastq)

<barcode> rawlib.
basecaller.fastqg

FASTQ file of the DNA barcodes used.

DNA Processed Bam File
(.bam)

merged.bam.ptrim.bam

Mapped BAM file of combined barcode reads.

DNA Processed Bam Index
File (.bai)

merged.bam.ptrim.bam
.bai

Mapped BAM index file.

RNA Unmapped Bam File
(.bam)

<barcode> rawlib.
basecaller.bam

Unmapped RNA BAM file; output of base calling,
contains unmapped reads.

RNA Mapped Bam File
(.bam)

<barcode> rawlib.
basecaller alignments
.bam

Mapped BAM file of combined barcode reads.

RNA Mapped Bam Index
File (.bai)

<barcode> rawlib.
basecaller alignments
.bam.bai

Mapped BAM index file.

RNA Basecaller FASTAQ File
(.fastq)

<barcode> rawlib.
basecaller.fastqg

FASTQ file generated from the unmapped BAM
file of the RNA barcodes used.

Test Fragment Basecaller
FASTAQ File (.fastq)

rawtf.basecaller.fastg

FASTQ file for the test fragment.
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Results files

(continued)
Option File name Description
Reports
Report <language> <sampleName> | A PDF report that contains sample-specific

_<mode> <templateName>
<assayName> <date>.pdf

results. For more information, see “Variant report”
on page 198.

Sample Summary

Info.csv

Contains information about the run and analysis,
including software version details, sample details,
library details, run details, assay details, reagent
and consumable information, run and sample QC
metrics, and instrument summary.

Files are available for both custom and system
installed assays in Genexus™ Software 6.6.

Audit and Log

Analysis Log File

analysis.log

Analysis log file.

Sample Summary

Info.csv

Contains information about the run and analysis,
including software version details, sample details,
library details, run details, assay details, reagent
and consumable information, run and sample QC
metrics, and instrument summary.

Files are available only for assays from Genexus™
Software version 6.2 and earlier.

Run Audit

PlannedRun-AuditTrail
.pdf

Contains all audit records pertaining to the run.

Troubleshooting Files

Log Files('

analysis.log

Analysis log file.

summary.<timestamp>.log

Start and end time for each time an assay module
is executed for the analysis.

various.err

various.out

Analysis pipeline logs used by field service
engineers for troubleshooting.

Info.csv

Contains information about the run and analysis,
including software version details, sample details,
library details, run details, assay details, reagent
and consumable information, run and sample QC
metrics, and instrument summary.

PlannedRun-
AuditTrail.pdf

Contains the audit trail of the run plan in PDF
format.
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Results files
(continued)
Option File name Description
Otherl'! analysis.ini Analysis configuration files, including secondary
analysisSamples.3son and tertiary INI files.
VCF Files analysis.vcf Summary of variant results in variant call format

SmallVariants.vcf

SmallVariants.filtered.
vcf

(VCF).

Summary of all results for small variant in variant
call format (VCF).

Summary of filtered results for small variant in
variant call format (VCF).

[ Separate folders are generated for each sample. If included in the run, separate folders are also generated for an NTC and positive control.

Download results files for multiple sample results

You can download results files for multiple sample results in Genexus™ Software. If the run included
more than one assay or more than one research application for the assay, you can download the results
for each assay or research application at once.

1.

2.

In the menu bar, click Results » Run Results.

In the Run Results screen, place the pointer over the row of a run of interest, then click

Download.

Alternatively, in the Run Results screen, click the name of a run, then in the Run Summary tab,
click --- (More Options) » Download Files to download the results files.

Select the assay if the run included more than one assay or more than one research application for

the assay.

In the Download Files dialog box, select the files to download, then click Download.
For information about the files, see “Results files” on page 171.

The selected results files are downloaded in one ZIP folder named Runname assayname. The folder
contains subfolders for each sample result except for any NTC and positive control samples.

Control sample information is in the Smallvariants.vcf. For more information, see “Results files” on
page 171.
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Download results files for a sample result

You can download results files in Genexus™ Software.

—

. In the menu bar, click Results » Sample Results.
2. In the Sample Name column, click the sample name of interest.
3. Click --- (More Options) » Download Files.

4. In the Download Files dialog box, select the files to download, then click Download.
For information about the files, see “Results files” on page 171.

The selected results files are downloaded in one ZIP folder.

Results from some system-installed assays

The following sections provide more information and example results for some system-installed assays.
For more detailed information about results from each system-installed assay, see the user guide for

the assay. For a list of user guides with more detailed information, see “Related documentation” on
page 431.

* For information about lon AmpliSeg™ Microbiome Health Research Assay GX results, see
“Microbiome assay results” on page 175.

* For information about Oncomine™ BRCA Assay GX results, see “Visualize exon and whole gene
CNVs” on page 119.

* For information about Oncomine™ TCR Beta-LR Assay GX results, see “View Oncomine™ TCR
Beta-LR Assay GX results” on page 188.

Microbiome assay results

lon AmpliSeq™ Microbiome Health Research Assay GX library sequencing in Genexus™ Software
provides the following results.

¢ Taxonomic profiling and relative abundance estimation of all bacterial species in the human colon
with the lon AmpliSeq™ Microbiome Health Research — 16S rRNA Gene Pool.

* Detection and quantification of 73 key bacterial species associated with human health and chronic
disease with the lon AmpliSeq™ Microbiome Health Research — Target Species Pool.

The lon AmpliSeg™ Microbiome Health Research Assay GX is designed to help you study the potential
impacts of the microbiome on human health, such as research on disease and chronic conditions, and
the maintenance of a healthy immune system.
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Results from some system-installed assays

View microbiome assay results

You can view the results from runs that you plan with microbiome assays in Genexus™ Software.

You can download tables of the results and the images that are shown in the software. For more
information, see “Results files” on page 171 and “Results files for microbiome assays” on page 187.

1. In the menu bar, click Results » Sample Results.

2. In the Sample Name column, click the sample name of interest.

Tip: In the Assay Name column, click Y (Filter), then enter microbiome to narrow the list to
microbiome assay results.

You can further refine the list of results with other filters, or click column headings to sort the list.

The Key Findings tab opens. For more information, see “Key Findings for microbiome assays” on

page 185.
Tab Description
QC The quality metrics for the sample sequenced in the run. For more information, see “QC
results” on page 133.
Key Findings An overview of the results for the sample, including Sample Details and Key Metrics, which

includes Target Species Metrics and 16S rRNA Gene Metrics. For more information, see
“Sample summary” on page 37.

Target species

The lon AmpliSeg™ Microbiome Health Research — Target Species Pool reports a table of up
to 73 bacterial species that are found by the assay and are associated with human health
and chronic disease, and graphics for species distribution.
* Source Data—lists all detected species above the threshold for abundance including:
— Species Name
— Detected Target Species Abundance (%)
- Read Count

— Normalized Read Count—the total read count per species normalized by the
number of amplicons used to detect that species.

* Species Distribution—shows a graphical representation of the percent abundance of
each detected species.

Note: Some of the primer pairs designed to detect the 73 targeted species can sometimes
amplify trace amounts of other non-targeted species. As a result, 18 other species can be
reported as well. When such species are detected the species names are reported with an
asterisk (), indicating that it is one of the non-targeted species.
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Tab

Description

16S rRNA Gene The lon AmpliSeq™ Microbiome Health Research — 16S rRNA Gene Pool shows the

following views.

taxonomy.

* Source Data lists all detected species and the relative abundance at the Family and
Genus level. To view details at the Species level download the results file.

¢ Microbe Distribution shows stacked bar plots for the detected bacteria at the Phylum,
Family, and Genus levels.

* Interactive Taxonomy View shows an interactive Krona plot of the detected bacterial

¢ Diversity Analysis shows alpha diversity analysis plots (shannon, simpson, and chao1)
of the detected bacterial species.

Plugins Results generated from the plugins associated with the assay used to analyze the
sequenced sample. For more information, see Chapter 11, “Plugins for data analysis”.

Reports You can download a summary of assay metrics and the record of reagents that were used in

a run in a Run Report.

For more information, see “Download a run report” on page 214.

3. Click the Target Species tab to view the target species results for a sample.

Note: The Target Species tab does not appear unless the lon AmpliSeq™ Microbiome Health
Research - Target Species Pool was run.

The Source Data table that lists parameters for each detected species is shown.

Parameter

Description

Species name

Bacterial species.

Some primer pairs designed to detect the 73 targeted species
can sometimes amplify strains of other non-targeted species. As
a result, an extra 16 species can be reported as well. When such
species are detected the species names are reported with (*),
indicating that it is one of the non-targeted species.

Detected Target species
abundance

Percentage abundance of the species in the sample.

Read Count

Raw read count.

Normalized read count

Read counts are normalized by the number of amplicons per
sequence and the sampling depth per sample. Normalized read
counts are comparable across different microbes and samples.

* C(Click Species Distribution to view a bar chart of the abundance of the species that are
detected. For more information, see “Example target species distribution chart” on page 178.
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4. To view taxonomy data, click the 16s rRNA Gene tab, then select an option.

Note: The 16s rRNA Gene tab does not appear unless the lon AmpliSeg™ Microbiome Health
Research — 16S rRNA Gene Pool was run.

¢ C(Click Source Data to view a summary of the taxonomy data.

¢ Click Microbe Distribution to view bar charts of the abundance of detected species at the
phylum, family, and genus levels. For more information, see “Example microbe distribution
charts” on page 179.

¢ (Click Interactive Taxonomy View to view the species that are detected in the sample. For
more information, see “Example interactive taxonomy view” on page 181.

* C(Click Diversity Analysis, then select an option from the Alpha Rarefaction Metric dropdown
menu to view an Alpha rarefaction plot. For more information, see “Example alpha diversity
analysis graphs” on page 184.

Example target species distribution chart

You can view a species distribution chart in the sample results from microbiome assays. A species
distribution chart is a bar chart that shows the abundance of the species that are detected.
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Example microbe distribution charts

You can view microbe distribution charts in the sample results from microbiome assays. Images include
bar charts of the abundance of detected species at the phylum, family, and genus levels.

EK_Microbiome_BAM QC Vv Key Findings Target Species 16S rRNA Gene Plugins Reports

Microbe Distribution

Interactive Taxonomy View I Diversity Analysis
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Genus Level

100 A Bacteroides
Faecalibacterium
Ruminococcus
Clostridium
Bifidobacterium
Ruminiclostridium
Alistipes
Eubacterium
Phascolarctobacterium
Blautia
Oscillibacter
Parasutterella
Lachnoclostridium
Succiniclasticum
Subdoligranulum
Collinsella
Roseburia
Gemmiger

80 1

Arnnnni

60 1

Genus Relative Abundance (%)

20 1

2111
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Example interactive taxonomy view

The interactive taxonomy view shows the species that are detected from a run with a microbiome
assay. You can customize the view of the taxonomy classification chart and download the customized
image. You can also select different sections of the pie chart to view more information. In the taxonomy
classification chart, the outer layer is the species, the next layer is the genus, and so on.

EK_Microbiome_BAM QC Vv Key Findings ~ Target Species  16SrRNA Gene Plugins  Reports

{ Source Data I Microbe Distribution Interactive Taxonomy View Diversity Analysis

— | = Sean:h:| I X I
BE +  Max depth

Bﬁ Font size
Chart size
Collapse

ﬂ

R
& B
(]

Figure 4 A full view of the taxonomy classification chart.
You can adjust the taxonomy view.
e Enter a species to highlight that species in the Search field.
¢ To adjust the number of taxonomy classes that appear, in Max depth, click — or <.
¢ To change the font size of the characters, in Font size, click — or <.
* To change the size of the plot, in Chart size, click — or +.
* To toggle the number of displayed taxonomy classes between 4 and 6, select or deselect the Collapse checkbox.
* To display the plot in a new window to enable saving the plot as a graphic, click Snapshot.
* To display a link that can be copied for sharing or bookmarking, click Link.
* To open the help system for generating the interactive taxonomy view, click 2.
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When you click a section of the chart, you can view details for the section. For example, you can click
the genus Bifidobacterium to view more information.

Bifidobacterium —@

Total: 3.89 —(2)

84% of
Actinobacteria e @

Figure 5 A customized view of the taxonomy classification chart.

@ The selected category is listed.

(2) The percent of the selected classification relative to the total is listed.

@ A pie chart the shows the percent of Bifidobacterium relative to the total number of Actinobacteria.
@ A pie chart of the percent of the selected classification relative to the total is shown.

When you double-click a classification in the taxonomy chart, you can view an updated chart limited to
the selected classification. For an example, see Figure 6.
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biﬁdulrn

Pseudocatenulatym

Figure 6 A focused view of the taxonomy.
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Example alpha diversity analysis graphs

You can view alpha diversity analysis graphs when you view the sample results from microbiome
assays. Alpha diversity graphs provide a visual representation of the diversity of the samples.

EK_Microbiome_BAM  qc «/  KeyFindings  TargetSpecies  16SrRNAGene  Plugins  Reports
Source Data | Microbe Distibution | Interactive Toxanomy View
Alpha Rarefaction Metric
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Figure 7 Chao1 diversity analysis plot
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Figure 8 Simpson diversity analysis plot
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Alpha Rarefaction Metric

shannon v
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Figure 9 Shannon diversity analysis plot

Key Findings for microbiome assays

For sample results from microbiome assays, the Key Findings tab shows details about the target
species metrics and 16S rRNA gene metrics.

Key Metrics

Section

Description

Target Species Metrics

Total Reads

The total number of filtered and trimmed reads independent of length reported in the
output BAM file.

Mean Read Length

The average length of all reads from the BAM file.

Percent Valid Mapped
Reads

The percent of reads mapped to the reference sequences with good mapping
quality (reads with alignment score greater than the minimum local alignment score
threshold).

Number of Targeted
Species Detected

The total number of detected species.

16S rRNA Gene Metrics

Total Reads

The total number of filtered and trimmed reads independent of length reported in the
output BAM file.

Mean Read Length

The average length of all reads from the BAM file.

Percent Valid Mapped
Reads

The percent of reads mapped to the reference sequences with good mapping
quality (reads with alignment score greater than the minimum local alignment score
threshold).
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Key Metrics (continued)

Section Description

Number of Genera The total number of detected genera.
Detected

Alpha Diversity (Shannon) | A value to describe the diversity of the sample at the species, genus, and family

levels.

QC results

If a sample fails a single test metric, the sample fails that QC test. A sample must meet all QC
parameter thresholds of a particular QC test in order to pass. The QC status is divided into the following
categories.

. (Passed) indicates the sample passed all QC metrics.
* X (Failed) indicates the sample failed a QC metric.
® — (Not Calculated) indicates a sample did not undergo QC analysis.

Note: If a sample fails to meet one or more QC parameters, you can reanalyze the sample or the run
after adjusting the parameter or parameters. For more information, see “Reanalyze a run” on page 192.

The data displayed in the screen depend on the assay that was used in the run.

Metric Description
Run QC General run quality control information.
Key Signal The average signal for library ISPs that identically match the library key (TCAG)

after software processing.

Key Signal — Resequencing The average signal after software processing for library ISPs that identically match

the library key (TCAG) for the resequencing run. This metric is shown for assays
that include resequencing only.

Percent Loading The number of wells with ISPs divided by the number of the total addressable

wells in a run.

Percent Loading - The number of wells with ISPs divided by the number of the total addressable
Resequencing wells in the resequencing run. This metric is shown for assays that include

resequencing only.

Raw Read Accuracy The average raw accuracy across each individual base position in a read, where

raw read accuracy is calculated as 100 * (1 - (sum(per base error) / sum(per base
depth)).

Templating QC — CF-1 Control | Sequencing quality metrics of the control fragment. These metrics indicate

templating success.

Average Reads Per Lane The number of CF-1 reads divided by the number of chip lanes used in the run.

Base Call Accuracy The probability that a given base is called correctly.

1 - (total number of errors for all positions in CF-1) / (total number of CF-1 base
reads).
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Metric

Description

Mean AQ20 Read Length (bp)

Average length, in base pairs, at which the accuracy rate is 299% for CF-1 reads.

Sample QC - 16s rRNA Gene
or
Sample QC - Target Species

Sequencing quality metrics of the sample 16s rRNA library or the target
species library.

Mapped Reads

The total valid mapped reads. That is, the mapped reads that pass the thresholds
and filters across all of the RNA targets in the reference file. This number is

a subset of the mapped reads shown in the Run Samples table in the Assay
Metrics.

Mean Read Length (bp)

The average length, in base pairs, of the final library reads for the sample.

Read Length Histogram

The histogram presents all filtered and trimmed library reads that are reported in
the output BAM file (Y-axis) and the mean read length in base pairs (X-axis).

Results files for microbiome assays

The following files for results from microbiome assays can be downloaded from Genexus™ Software.

For instructions to download results files, see “Download results files for a sample result” on page 175
and “Download results files for multiple sample results” on page 174.

File

File extension Description

Target Species & 16S rRNA Gene Results

Parameters INI Analysis configuration files.
Target Species Results
Species distribution plot PNG A bar chart of the abundance of the microbial

species that are detected.

Target Species Panel List

XLSX A list of the 73 bacterial species that are
detected by the lon AmpliSeq™ Microbiome
Health Research — Target Species Pool. Not all
species are detected in a particular sample.

16S rRNA Gene Results

Microbe distribution plot

PNG A bar chart of the abundance of the
microbes/bacteria that are detected.

Genus level relative abundance plot PNG A bar chart of the abundance of detected

microbes/bacteria at the genus level.

Phylum level relative abundance plot PNG A bar chart of the abundance of detected

microbes/bacteria at the phylum level.

Folders for alpha diversity tests various Data for Alpha diversity tests.
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(continued)
File File extension Description
Interactive taxonomy view output TXT Data for the plot that shows the interactive
taxonomy view.
Interactive taxonomy view HTML The plot that shows the interactive taxonomy
view.

View Oncomine™ TCR Beta-LR Assay GX results

* To view the Oncomine™ TCR Beta-LR Assay GX expression data, in the Results / Sample Results
screen, click the sample name in the Sample Name column, then click the Results tab. Results
are viewed in two tabs: Sample Results and Sample QC.

* In the Sample Results tab, select from the following options in the Views dropdown menu.

— Spectratyping Plots — Clones detected per variable gene
— V-gene usage — CDR3 histogram
- VJ-gene usage — Clone Summary

Results / TCR4461941 ¥ / TCRE-LRwL3.0 ¥ [ SRTestSample0l ¥

SRTestSample0l Summary QC v Results Plugins

Sample Results Sample QC

Views: Spectratyping Plots

Mutation | Evenness Shannon Diversity Largest Clone Frequency Numbe:

Spectratyping plot highlighting mutation

Spectratyping plot highlighting frequency of mutated bases over the variable gene of identified clones. Reads for identified clones are arranged along the X-axis according to the variable gene identity and the Y-axis
according to the CDR3 nuclectide length. Size of the circles indicates the frequency of a particular variable gene-CDR3 NT length combination within the dataset, while coler indicates the average frequency of

mutated bases for clones having a particular variable gene-CDR3 NT length combination. Ordering of variable genes reflects position within the TCRB locus. Key repertoire metrics are displayed along the lower
margin of the plot

TCRB V-gene usage and mutation rate

Clone Shannnen Diversity: 4.9637 Reads: 10892 Mean CDR3 NT Length: 35.6981 +/-
53504
Clone Evenness: 0.5845 Clones: 360 V-gene Shannon Diversity: 3.0161
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* In the Sample QC tab, select from the following options in the Views dropdown menu.

Read classification

Proportion of full length, quality-trimmed, and reads lacking P1key, by read classification
Base composition of overcalled and undercalled homopolymers

Downsampling analysis

QC metrics

For detailed information on viewing and analyzing Oncomine™ TCR Beta-LR Assay GX results, see the
Oncomine™ TCR Beta-LR Assay GX User Guide (Pub. No. MAN0018513).

View verification run results

Manager- and administrator-level users can view verification run details, including the run summary,
QC summary, and the reagents used in the run. Verification runs are performed during installation to
validate the performance of the instrument or instruments. Sequencing verification runs are performed
to validate the Genexus™ Integrated Sequencer.

If a Genexus™ Purification Instrument is also connected, a verification run that validates both the
purification instrument and sequencer is performed.

Note: Field Service Engineers use system-installed verification templates to validate the installation of
the Genexus™ Integrated Sequencer. Field Service Engineers can view the template information but
cannot modify it.

1. In the menu bar, click Results » Verification Results.

2. In the Verification Results screen, view or download information for the verification run.

Option Description

View In the Run Name column, click the verification run name of interest to open the
verification Verification Results Details screen.
results details | |n the QC section of the Verification Results Details screen, click the > symbol to

the left of the Lane column in the lane of interest to expand the results details pane.

Download a Place the pointer over the row of the verification run of interest, then click Report.
verification
report that has
been signed
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3. You can perform the following actions for Verification Results. Action links are available when you
place the pointer over the row of a verification result.

Option Description

View Plan If the run has not started on an instrument, you can view the run plan for the
verification run.

Audit Displays the list of users who created and edited the run. You can export and print
information from the list from the Audit Trail dialog box.

CSA CSA—Customer Support Archive. Click this link to download the sequencer log files.
Log files contained within the CSA can be useful when troubleshooting problems
with the sequencer. For more information, see “Customer Support Archive” on

page 357.

Report Download a verification report that has been signed.

Verification runs

The following information is available in the Results / Verification Results screen.

Column Description

Run Name The name of the run, created when the run was planned. Click the name to open
the Verification Results Details screen.

Assay Full Name The name of the assay used in the run.

Field Engineer Name The name of the support specialist who performed the run.

Instrument Name The name of the sequencer that was verified.

Run Status The current status of the full sequencing run, including analysis.

QC Status Indicates whether a sequencing run passed or failed, based on the sequencing

QC metrics selected for the assay.

Started On The date and time that the run was started.

Updated On The date and time that the run was last updated.

Sign verification run reports (manager/administrator)

Manager- and administrator-level users can sign results reports for verification runs. However, we
recommend that only qualified support specialists sign performance qualification (PQ) reports.

Verification reports can be electronically signed only when all samples pass QC analyses.

1. Click Results » Verification Results.
2. In the Verification Results screen, click the name of the verification run of interest.

3. In the Verification Results Details screen, click [ Sign Off.
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Run plugins after a sequencing run is complete

In the Sign Off Report dialog box, enter or make the following selections.
a. Enter the password.

b. In Electronic Signature, select Approval.

(2}

. In Sign off Comments, enter a comment.
d. In Laboratory Comments and Footer Field, enter optional information.

Click Sign Off.

The verification run report is electronically signed.

You can view, print, or download the report in a PDF file. For more information, see “Verification runs”
on page 190.

Run plugins after a sequencing run is complete

You can run plugins on your sequencing data after a sequencing run is complete using the Run Plugin
function in the Results screen for the sample. Use this command to run one or more plugins on the
data for the first time, or to rerun any plugin that has been run before (for example, if a plugin has been
updated or failed during analysis).

1.

2.

3.

4.

In the menu bar, click Results » Sample Results.
Click a sample name in the Sample Results screen.
Click :-- (More Options).

Click Run Plugin.

In the Run Plugin dialog box, select one or more assays in the run, then select the plugins to run
on those assays.

Click Run.
While plugins are running, the Run Plugin link is unavailable for that run.

When analysis is complete, you can review the results. For more information, see Chapter 11,
“Plugins for data analysis”.
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Reanalysis

If a run fails to meet one or more QC parameters defined by the assay, you can adjust the assay
parameters and reanalyze a run or a sample from the run. For more information to adjust assay
parameters, see “Edit the QC parameters of a locked assay (manager/administrator)” on page 241 and
Chapter 8, “Create and manage assays (manager/administrator)”.

Runs can be reanalyzed with the same assay or a different assay. Reanalysis of runs can start from the
alignment, basecalling, or signal processing steps. A sample can be reanalyzed starting only from the
alignment step.

For more information, see “Reanalyze a sample” on page 194 and “Reanalyze a run” on page 192.

Reanalyze a run

192

Runs can be reanalyzed with the same assay or a different assay in Genexus™ Software. Reanalysis of
runs can start from the alignment, basecalling, or signal processing steps. When you reanalyze a run,
the reanalysis is applied to all samples in the assay.

Reanalysis from the Description
Signal processing The option to reanalyze a run from the signal processing step is only available when
step the following conditions are met.

* When a run fails during the basecalling step or earlier.

* When the run has not already been successfully reanalyzed.

Reanalysis at the signal processing step uses DAT files.

Basecalling step The option to reanalyze a run from the basecalling step is only available when a run
or reanalysis successfully completes the signal processing step.

Reanalysis at the basecalling step uses .wells files.

Alignment step The option to reanalyze a run from the alignment step is only available when a run or
reanalysis successfully completes the basecalling step.

Reanalysis at the alignment step uses BAM files.

Note:

. Manager- and administrator-level users can reanalyze a sequencing run only if the run completed
without any critical alarms or errors. If the run aborted or produced major alarms or errors, the run
cannot be reanalyzed.

. QC parameters at the limits of stringency cannot be adjusted further. If samples fail QC and you
cannot adjust the QC parameters further, you can sequence the sample library again. For information
to find, recover, and purify the leftover library preparations, see the Genexus™ Integrated Sequencer
User Guide (Pub. No. MAN0OO17910). Alternatively, you can prepare a new library for sequencing.

The files needed for the stage of reanalysis that you select must be present in the software. For
example, if the .wells files for the run have been removed from the software, you cannot reanalyze from
basecalling. Instead, reanalyze the BAM files at alignment. Administrator-level users can manage the
settings and schedule to backup and delete files and data. For more information, see “Manage backup
settings and restore runs (administrator)” on page 315.

Genexus™ Software 6.8 User Guide



Chapter 6 Review data and results [z
Reanalysis

You can reanalyze a run with any compatible assay that exists in the software. Alternatively, you can
create a new assay or copy the original assay that was used in a run and modify assay parameters if
needed. For more information, see Chapter 8, “Create and manage assays (manager/administrator)”.

—

In the menu bar, click Results » Run Results.

2. In the Results / Run Results screen, in the Run Name column, click the run name of interest.

w

In the upper right corner of the screen, click --- (More Options) » Reanalyze.

»

In the Reanalyze dialog box, enter or select the following information.
a. In Reanalysis Run Name field, enter a reanalysis run name.

b. In Start Reanalysis from dropdown list, select Alignment, Basecalling or Signal
Processing.

C. In the Current Assay in Run column, select the checkbox in the row of each assay that you
want to reanalyze. Then, in the Choose Assay to Reanalyze column, select an assay for each
reanalysis from the dropdown list.

Reanalyze

Reanalysis Run Name

‘ Reanalysis Run 1

Start Reanalysis from

Alignment

“»

Current Assay in Run Choose Assay to Reanalyze Updated Annotations

Oncomine Myeloid v2 - GX5 - DNA - w5.0.0 -
v0.0.2

clinvar(20220328)

Cance\

Oncomine Comprehensive Plus-Cc %

5. Click Reanalyze.

Follow the progress of the reanalysis in the Results / Run Results screen in the Run Status column
and in the Results / Sample Results screen in the Sample Status screen. When reanalysis is
complete, the new results can be viewed by clicking the run name corresponding to the reanalysis
assay in the Results / Run Results screen. Runs that have been reanalyzed are appended with & after
the run name.
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Reanalyze a sample

A sample can be reanalyzed starting only from the alignment step. Reanalysis at the alignment step
uses BAM files. You can reanalyze all samples in a run from the basecalling or signal processing steps.
For more information, see “Reanalyze a run” on page 192.

Note: Manager- and administrator-level users can reanalyze a sample only if the run completed without
any critical alarms or errors. If the run aborted or produced major alarms or errors, the sample cannot
be reanalyzed.

The option to reanalyze a sample from the alignment step is only available when a sample or reanalysis
successfully completes the basecalling step.

You can reanalyze a sample with any compatible assay that exists in the software. Alternatively, you can
create a new assay or copy the original assay that was used in a run and modify assay parameters if
needed. For more information, see Chapter 8, “Create and manage assays (manager/administrator)”.

1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, place the pointer over the row of a sample of interest, then click
Reanalyze.

Alternatively, you can reanalyze a sample when you click a sample name, then click
.-+ (More Options) » Reanalyze.

3. In the Reanalyze Sample dialog box, enter or select the following information.
a. In Reanalysis Run Name field, enter a reanalysis run name.

b. In Start Reanalysis from dropdown list, select Alignment, Basecalling or Signal
Processing.

c. Inthe Current Assay in Run column, select the checkbox in the row of each assay that you
want to reanalyze. Then, in the Choose Assay to Reanalyze column, select an assay for each
reanalysis from the dropdown list.

4. Click Reanalyze.

Follow the progress of the reanalysis in the Results / Sample Results screen in the Sample Status
screen. When reanalysis is complete, the new results can be viewed by clicking the sample name
corresponding to the reanalysis assay in the Results / Sample Results screen. Samples that have
been reanalyzed are listed in the table of sample results with the run name appended with ©&.
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Upload results to another software account

You can upload results (BAM files) to another Genexus™ Integrated Sequencer or to lon Reporter™
Software.

Before you can upload results files to another Genexus™ Integrated Sequencer, you must register the
account that you can use for data uploads. For more information, see “Register Genexus™ Software
accounts (manager/administrator)” on page 300.

Before you can upload results files to lon Reporter™ Software, you must configure an lon Reporter™
Software account.

* To configure an lon Reporter™ Server account, see “Register an lon Reporter™ Server account
(manager/administrator)” on page 301.

* To configure an lon Reporter™ Software on Thermo Fisher™ Connect Platform account, see
“Register an lon Reporter™ Software on Thermo Fisher™ Connect Platform account (manager/
administrator)” on page 300.

Upload results files to another Genexus™ Integrated Sequencer

When a run completes successfully in Genexus™ Software, you can upload the results (BAM files) to
another Genexus™ Integrated Sequencer.

Tip: To automatically upload BAM files when a run is complete, select the Upload BAM files to Server
checkbox in the Setup step of planning a run.

Before you can upload results files to another Genexus™ Integrated Sequencer, you must link the
accounts that you can use for data uploads. For more information, see “Register Genexus™ Software
accounts (manager/administrator)” on page 300.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, place the pointer over the row of a run of interest, then click BAM
Uploader.

3. Inthe Upload Samples to Server dialog box, make the following selections.

a. From the Configured Account list, select the Genexus™ Software account and the software
version.

b. In the Select column, select one or more assays from the list to upload the results files from
the selected assays.

c. In the Genexus Workflow column, select whether you want analysis to start on the selected
Genexus™ Integrated Sequencer immediately.

* Select Upload Only to upload the sample results (BAM files) to the software.

® Select an assay of interest to upload the sample results (BAM files) and automatically
start analysis with the selected assay on the Genexus™ Integrated Sequencer.

d. Click Upload.
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The results are uploaded to another Genexus™ Integrated Sequencer.

Upload results files to lon Reporter™ Software

When a run completes successfully in Genexus™ Software, and the results were not automatically

uploaded to lon Reporter™ Software, you can upload the results (BAM files) to lon Reporter™ Software
for further analysis.

You can also upload the samples to lon Reporter™ Software, then use a custom lon Reporter™ Software
analysis workflow to view analysis results. Or, you can upload sample results files to run assays that are
not yet available on the Genexus™ Software Integrated Sequencer.

Note: To automatically upload BAM files when a run is complete, select the Upload BAM files to lon
Reporter™ Software checkbox in the Setup step of planning a run.

Before you can upload results files to lon Reporter™ Software, you must configure an lon Reporter™
Software account.

* To configure an lon Reporter™ Server account, see “Register an lon Reporter™ Server account
(manager/administrator)” on page 301.

* To configure an lon Reporter™ Software on Thermo Fisher™ Connect Platform account, see

“Register an lon Reporter™ Software on Thermo Fisher™ Connect Platform account (manager/
administrator)” on page 300.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, place the pointer over the row of a run of interest, then click BAM
Uploader.

3. In the Upload Samples to Server dialog box, make the following selections.
a. From the lon Reporter™ Software Account list, select the lon Reporter™ Server account.

b. In the Select column, select one or more assays from the list to upload the results files from
the selected assays.

c. Inthe lon Reporter Workflow column, do one of the following:

* Select Upload Only to upload the sample results (BAM files) lon Reporter™ Software. You
must sign in to lon Reporter™ Software to launch an analysis.

® Select an appropriate lon Reporter™ Software analysis workflow to upload the sample

results (BAM files) and automatically launch the selected analysis workflow in lon
Reporter™ Software. This results in an analysis in lon Reporter™ Software.

d. Click Upload.

The results are uploaded to lon Reporter™ Software.
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Data files and flow

During a Genexus™ Integrated Sequencer run, raw data (DAT) files from the first flows are available.
Genexus™ Software starts processing the data, producing a 1.wells file. Basecalling is performed on
the 1.wells file data, producing an unmapped BAM (UBAM) file. Subsequent analysis produces mapped

reads (BAM) and variant calls (VCF) files.

The following table shows the flow of data and typical file size from runs that use a GX5™ Chip or GX7™

Chip as Genexus™ Software processes data.

IMPORTANT! Data from approximately 200 sequencing runs can be accommodated on the sequencer
before disk space becomes a limiting factor and data archiving is required for runs if you ensure that
backup settings are set to delete 1.wells files and intermediate files for after a cleanup threshold for
disk space is reached. You can perform approximately 45 to 50 whole chip runs with a GX5™ Chip, and
20 to 25 whole chip runs with a GX7™ Chip without deleting any wells files on the system. For more
information about data archival of the analysis files, see “Manage backup settings and restore runs

(administrator)” on page 315.

Process File type File siz_e for GX5™ File siz_e for GX7™
Chip runs Chip runs

Sequencing(!l DAT 27TB 2TB
v

Signal Processing 12! Wells 250 GB 300 GB
v

Base Calls (reads) uBAM 15 GB 40 GB
v

Mapped Reads BAM 15t0 20 GB 45 GB
v

Variant Calls VCF 120 Kb 25 MB

' The sequencing raw data (DAT) files are deleted from the sequencer after run completion.

[l A configurable disk space cleanup process is executed nightly to free up space for future runs and to ensure sufficient hard disk
space is maintained. If the system memory available for storing run analysis files reaches the threshold that is configured, the system
auto-deletes 1.wells files for the oldest completed runs. A minimum of 1TB of space is required to start new runs. If the system
approaches the 1TB threshold, an alert notifies you when you sign in. New run cannot be started if the 1TB threshold is reached. If

desired, you can back up 1.wells files to an external drive.
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Genexus™ Software provides two types of reports.

* Variant report - A PDF report of the results for a sample in a run. You can customize the layout and
contents of a variant report, or you can use a system-installed report template. Multiple users can

electronically sign the variant report and one user can be designated to lock the report after sign
off.

* Run report - A PDF report of the information that is shown in the Run Report tab. The run report
includes assay metrics and the record of reagents that were used in a run. For more information,
see “Assay metrics and the run report” on page 151.

To save or distribute a variant or run report, you can download the report.

Variant report

198

The variant report is a PDF report of the results for each sample in a sequencing run. You can use
a system-installed report template to generate a variant report, or you can customize the layout and
contents of a variant report.

To make a variant report available for each sample result upon completion of a sequencing run, enable
Generate Report in the Setup step when you plan the run. For more information, see Chapter 4, “Plan
and manage runs”). To generate a variant report after a run is complete, see “Generate a variant report”
on page 200.

When a variant report has been generated for a sample result, it is available for download in three
places:

¢ In the Results / Sample Results screen when you place the pointer over the row for that sample,
then click the Report link to download the PDF.

* In the variant report pane for the sample results in the Reports tab when you click
: (More) » Download Report.

* In the Results screen for the sample when you click -+ (More Options) » Download Files.

Variant reports can be electronically or manually signed by users. Electronic signatures are shown in the
Electronically Signed By section of the report, if the section is included in the report template.

For information about the sections that can be included in a variant report, see “Sections of a variant
report” on page 208.
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View a variant report

You can view a variant report in Genexus™ Software. A variant report includes details of sample results.
The results depend on the filter chain applied to the results.

A variant report must be generated before you can view the report. If a report template is set as

the default template for the assay associated with the run, one or more variant reports are generated
after a run completes successfully. For more information, see “Create a report template (manager/
administrator)” on page 205. Alternatively, you can generate one or more variant reports after a run
completes successfully. For more information, see “Generate a variant report” on page 200.

1. In the menu bar, click Results » Sample Results.
2. In the Sample Results screen, click the sample name of interest in the Sample Name column.

3. Click the Reports tab.

A pane for the run report and each variant report that has been generated is shown. The pane for a
variant report includes the following information.

¢ Report name

e Report template name

e Date that the report was generated

¢ Username for the user who generated the report
¢ |anguage used for the report

¢ If a variant report has been electronically signed at least once, the signature information is
listed in the pane for the variant report. If multiple users have signed the report, you can place
the pointer over the electronic signature information to view more details. If the electronic
signature that is used is associated with a lock-level signature type, the report is locked.

e [f a variant report is locked, & (Lock) is shown in the upper right corner of the pane.
4. In the pane of the report of interest, click (More) » Download Report.

The report opens in a new browser tab. You can download variant reports as PDF files.
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Download a variant report

You can download a variant report for a sample result of interest from the Results / Sample Results
screen, from the pane that shows the report, or as part of a download of results files.

1. In the menu bar, click Results » Sample Results.

2. Download the report with one of the following options.

Option Procedure
Download a ZIP file that contains all variant In the Sample Results screen, click the sample
reports for a sample result. name of interest in the Sample Name column,

then click -+ (More Options) » Download Files.

Download the variant report in PDF format from Click the Reports tab then, in the pane of the
the Reports tab for the sample results report of interest, click (More) » Download
Report.

Download the variant report as part of the results | For more information, see “Results files” on
files for a specific sample in the Results screen. page 171.

A ZIP file that contains the PDF report is downloaded to the computer if you download reports
from the Sample Results screen or as part of the results files. A report in PDF format downloads if
you use the Reports tab for the download.

3. Extract the downloaded files, then open the PDF file in an appropriate viewer.

Generate a variant report

You can generate a new variant report for sample results after a run is complete. A & (Lock) in the
variant report indicates that the electronic signature option for the report is locked. After a variant report
is locked, the report cannot be electronically signed by any other user.

You can generate multiple reports for a sample result, if each report is named uniquely, and is
generated in a different language, or uses a different report template.

—h

In the menu bar, click Results » Sample Results.
2. In the Results / Sample Results screen, click the sample of interest in the Sample Name column.
3. Select the Reports tab, then click + Generate Variant Report.

4. Inthe Generate Report dialog box, change the name of the report that is generated by the
software, if needed, and select the report template and language of the report.
a. If the report template includes the option to include custom images from the results, click

Upload Image, then select the images to include in the report, and enter a title for the image,
and if needed enter a description and footnote for the image.

b. If the option to make custom text Editable on Report Generation was selected when the

report template was created, enter a title in the Custom Text section and if needed, a
description.
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Report templates that are associated with the assay that was used in the run are included

in the Report Template list. For more information, see “Create a report template (manager/
administrator)” on page 205.

If you select the same report template that was used to generate a variant report, and have not
locked that report, the new selections you make override the previous variant report.

5. Click Generate.
A draft version of the report is added to the Reports tab.

A pane for the new report is added next to the Run Report pane in the Reports tab. Reports that have
been generated are available for download in the Reports tab, in the Sample Results screen, and in
the ZIP package that contains results files.

Delete a variant report

You can delete a variant report that is not locked for electronic sign-offs if you have account
permissions to electronically sign reports.

1. In the menu bar, click Results » Sample Results.
2. In the Sample Results screen, click the sample name of interest in the Sample Name column.

3. Click the Reports tab.
A pane for the run report and each variant report that has been generated is shown.

4. In the pane of the report of interest, click (More) » Download Report, then click Delete.

5. Click Yes to confirm that you want to delete the report.
The pane for the report is removed from the Reports tab.

Sign off variant reports

Manager, administrator, and report-level users can electronically sign a variant report for sample results
in Genexus™ Software. A sample result can have multiple variant reports if each report has a unique
name, and uses a different report template, or a different language. However, only one of the reports
can include electronic signatures. Multiple signatures can be added to the variant report that is used for
sign-offs.

Account permissions to sign reports electronically are associated with a signature type. One signature
type is designated as lock-level to lock the report. If your signature permissions are designated with

a lock-level signature type and you sign the report, the report cannot be electronically signed by any
other user.

The filter chain that is applied to the results must be locked before you can electronically sign a variant
report. After users begin to electronic sign-offs, changes cannot be made to the filter chain, gene list, or
classification, and plugins cannot be run for the sample results.

The signature information appears in the variant report PDF file or a user-created report, if electronic
signatures are included in the template that is used to generate the report. For more information, see
“Variant report” on page 198, and “Create a report template (manager/administrator)” on page 205.

Multilanguage support for PDF report generation is provided.
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This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

You must have electronic permissions enabled to sign reports. Reports that can be electronically signed
must be labeled as Draft, and not be locked.

1. In the menu bar, click Results » Sample Results.
2. In the Sample Results screen, click the sample result of interest in the Sample Name column.

3. In a variant report pane that is labeled as Draft, click Sign Off.
The Sign Off Report dialog box opens and shows the name of the report, the template used for
the report, and the following information, which is based on the profile of the user who signs the
report.

* Electronic Signature
* User Name
¢ Language

4. In Password, enter the password.
5. In Sign Off Comments, enter a comment.

6. In Footer Field, enter any text that you want to appear in the footer of the PDF report pages.

If you entered footer information in the Footer Field when you created a report template, or if
text was entered during a previous sign off, the same footer information is shown in the Sign Off
Report dialog box. You can edit the text in the Footer Field to change the information that will be
shown in the footer of the PDF report.

7. Select an image to an include with the electronic signature, and enter a description and footnote
for the image, if needed.

Only one image can be added when a report is signed off. If an image was previously added, the
option to add an image is not available.

8. Click Sign Off to confirm the electronic signature.
The pane for the signed variant report is updated to include the signature information is listed
in the pane for the variant report. If the electronic signature that is associated with a lock-level
signature type is used, a & (Lock) is shown in the variant report pane and the report is locked.

The report is signed. The Electronic Signatures section of the report pane is updated to include your
username and the signature type for your account. You can hover over signature type that is shown to
open the list of signature types that are completed for the report. If multiple electronic signatures are
added to the report, an electronic signature type for each signer is shown in the Electronic Signatures
column of the sample results table. For more information, see “Customize the sample results table” on
page 139.

If a signature type used is designated to lock the report, the variant report is signed and locked, and no
other variant reports for the sample result can be signed or generated. If you need to change the report,
reanalyze the sample and generate a report for the reanalyzed sample.
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Report templates (manager/administrator)

You can send notifications for report sign-offs to other users. For more information, see “Send
a notification to another user” on page 203. For information to download the signed report, see
“Download a variant report” on page 200.

Send a notification to another user

You can send notifications to other users in Genexus™ Software. For example, you can notify another
user when you have signed a variant report.

To receive email notifications, the recipient must have an email address that is configured in
the software. For more information, see “Configure email notifications (manager/administrator)” on
page 310.

1. In the menu bar, click Results » Sample Results.
2. In the Sample Results screen, in the Sample Name column, click the sample result of interest.

3. In the upper right corner of the screen, click --- (More Options) » Send Notification.
The Send Notification dialog box opens.

4. In Send Notification to, select one or more administrator-level users of interest.
5. In Comments enter the message.
6. Click Send to send the message.

An email message with the text that you entered is sent to the users that you selected. In addition,
when a recipient signs in to the software, an unread notification, @ (Notifications), is shown. For more
information, see “View notifications” on page 19.

Report templates (manager/administrator)

Manager- and administrator-level users create and manage custom report templates that are used to
generate PDF reports after a run. Users select a report template when they plan a run.

Preview a report template (manager/administrator)

Manager- and administrator-level users can view custom and system-installed report templates in
Genexus™ Software.

For more information about system-installed report templates, see “System-installed report templates”
on page 424.

1. In the menu bar, click Assays » Manage Presets.

2. In the Manage Presets screen, click the Report Templates tab.
Existing report templates are listed in this tab, including system-installed report templates. For
more information, see “The report templates table” on page 204.
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3. In the Report Templates table, place the pointer over the row of the report template that you want

to view, then click Preview.

The Report Template Preview opens.

4. Inthe Report Template Preview screen, click Open to download a PDF file of the report template.

a. Click Close to close the Report Template Preview and return to the list of report templates.

You can place the pointer of the row of a report template to perform more actions, such as lock, edit,
delete, or add notes to a report template. The options that are available depend on whether the report

template is a draft or is locked.

The report templates table

You can view details about report templates in Genexus™ Software.

Details about report templates

Iltem

Description

Name

The name of the template. System-installed report templates are
included with the software. Custom report templates are named by the
person who creates the template.

Application Category

The application category that is associated with the report template,
such as Cancer or All.

Assay Name

If the report template is associated with an assay, the assay is listed.
If no assay is listed, the report template is available to select when you
generate a report for any result for samples with the same application
category of the report template.

Status

Status of the report template.
e Locked
e Draft

Default

Indicates if the report template is designated as the default report
template.

Created On

Date on which the report template was created.

204
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Create a report template (manager/administrator)

Manager- and administrator-level users create custom report templates that are used to generate PDF
reports after a run. As you create the report template, you can reorder sections, and add or remove
sections. For more information, see “Sections of a variant report” on page 208.

To easily create a new report template, you can start from an existing report template and make
changes to the layout and content of the sections if needed.

After you create the first custom report template, you can no longer use the system-installed report that
is named Default to generate a report or to create another custom report template.

IMPORTANT! For a report template to be used in a run, it must first be locked.

1. In the menu bar, click Assays » Manage Presets.

2. In the Manage Presets screen, click the Report Templates tab.
Existing report templates are listed in this tab, including system-installed templates.

3. Click + Add New.

4. In the Report Template screen, enter a unigue report template name, then complete the remaining
sections.

a. In Application Category, select the application category for the report template.

The application category that you select determines the sample attributes that are available to
add to the report template.

b. In Select Assay, select the assay that you want to associate with the report.

Note: After you associate an assay and application category with a report template, that
report template becomes available for use with samples for that application category that are
processed with the associated assay.

If you select None for the assay, the report template is available to select when you generate
a report from a result that was processed with any assay. That is, a report template that is
associated with Select Assay of None is available to select for all results when you generate
a report.

c. In Start From Existing Report Template, select a report template to start from an existing
report template if desired.

Only report templates that have the same application category that you selected in substep 4a
are listed.

d. In Languages Setting, select the language for the report.
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e.

Enable or disable the option to set the report template as the default template.

When a report template is set as default, a report is generated from the report template each
time you complete a run with an assay that is associated with the report template. Each assay
can be associated with 3 default report templates in various languages. A report pane for each
report is visible in the Reports tab of the sample results table. If you do not designate a report
template as default, you can generate reports from the report template after a run is complete
in the Reports tab. For more information, see “Generate a variant report” on page 200.

* To set the new report template as default, keep the Set as Default toggle switch enabled.
¢ If you do not want the report template to be set as default, disable the Set as Default
toggle switch.

Report templates that are not associated with an assay and are designated as default
are used to generate a report each time a run completes that includes samples with the
application category that you selected in substep 4a.

5. Add information to the Header section.

The Header and Footer sections are required. All other sections are optional. For more information
about the sections that can be included in a report, see “Sections of a variant report” on page 208.

a.

b.

d.

Enter a report title and the organization address.

To include a logo on the report, in the Logo field, click Select File to browse to the logo file.
Acceptable formats are PNG, GIF, and JPG.

In Header Fields, click the field, then in the list that appears, select a term to add it to the
Header.

Enable or disable the Report Date and Assay Name checkboxes if needed.

6. In the Configuration pane on the left, you can add new sections, then move or delete sections
from the template if needed.

a.

b.

206

In Add Section, select the section, then click 4 (Add).
The new section is added at the bottom of the list.

Use the following options to move or delete sections from the template.
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Option

Description

Add multiple sections.

1. Click Bulk Add.

2. In the Bulk Add dialog box, in the Available Sections pane on the left,
for each section to include, click the section name of interest, then click
» (Add).
Repeat for each section to include in the report template.
3. Click Apply.

Remove a section.

In the box for the section, click X (Remove).

Remove multiple
sections.

1. Click Bulk Add.

2. In the Bulk Add dialog box, in the Configured Sections pane on the
right, click the section name of interest, then click « (Remove).

Repeat for each section to remove from the report template.
3. Click Apply.

Add all sections.

1. Click Bulk Add.

2. In the Bulk Add dialog box, in the Available Sections pane on the left,
click Select All.

3. Click Apply.

Remove all sections.

1. Click Bulk Add.

2. In the Bulk Add dialog box, in the Configured Sections pane on the
right, click Select All.

3. Click Apply.

Rearrange sections of
the report template.

Click-drag the section boxes to rearrange the order.

Apply the gene list to
the report template.

Select Apply Gene List.

You can add the following items and sections to a report template multiple times. Each section,
except for a page break, can be uniquely customized.

* Variant Details
* Image
® Custom Text

* Page Break

You can add text that can be edited
when you generate a report. For more
information, see “Generate a variant report”

on page 200.

The following items and sections can appear in the report template in one place.
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Key Metrics
Manual Signatures
Sample Details
QcC

Sequencing Run Details
Reagents

Electronic Signatures
Complex Biomarkers

7. Enter and customize the information for each section of the report template.

a.

For each unlocked section of the template, in the Configuration pane on the left, click the

section name of interest.

In the Section pane on the right, add or remove information for the section.

You can click any customizable field to populate a list of available options for the field.

Sections that are locked and cannot be customized are designated with & (locked).

8. To preview the report layout, click Preview Report.

You must enter information in the required fields before you can preview a report template.

9. When you are finished, click Save.

The new report template appears in the Report Templates list.

Sections of a variant report

Manager- and administrator-level users can create custom report templates that can include various
sections. Each section contains details about a result, so you can include information to meet
laboratory requirements.

A variant report can contain the following sections and information, depending on the assay used.

Section

Description

Header

Information that repeats on each page of the variant report. Includes the title of the report,
the organization address, the date that the report was generated, an optional logo, and
other optional fields about the sample.

Sample Details

The sample information that is entered into the software. You can customize the format of
the Sample Details section when you create a new report template. For more information,
see “Create a report template (manager/administrator)” on page 205.
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Section

Description

QC

¢ Run QC—A summary of the run quality control metrics
¢ NTC QC - DNA—A summary of the DNA no template control quality control metrics
¢ NTC QC - RNA—A summary of the RNA no template control quality control metrics

¢ Positive Control01 QC - DNA—A summary of the DNA positive control quality control
metrics

* Positive Control01 QC - RNA—A summary of the RNA positive control quality control
metrics

* Purification QC—A summary of QC metrics for the purification run.

¢ Sample QC - RNA—A summary of RNA sample quality control metrics

¢ Sample QC - DNA—A summary of DNA sample quality control metrics

¢ Templating Control QC — CF-1—A summary of the CF-1 quality control metrics

This section is locked and cannot be customized.

Sequencing Run
Details

Contains the following subsections:

¢ Assay Name—The assay used in the run

* Panel—The panel used in the run

¢ Started On—The date and time that the run was started

* Completed On—The date and time when the run was completed

® Operator—The user who sent the run to the instrument

¢ Instrument—The name of the instrument

¢ Serial Number—The serial number of the instrument

* Filter Chain—The filter chain applied to results

* Gene List—The gene list applied to the results

* Latest Annotations—The name and version of the latest annotation set that is applied
to the sample result, if applicable.

This section is locked and cannot be customized.

Reagents

Details about run consumables, including part numbers, expiration dates, and lot numbers.

This section is locked and cannot be customized.

Kit Barcodes

Details about each barcode for the kit that is used in the run, including sample name, assay
name, nucleic acid type, extraction kits and control kits.

Key Metrics

Includes amplicon information for the results, such as the average base coverage depth,
uniformity of base coverage, and percent reads on target. The options that are available to
customize in this section depend on the assay that you select for the report template.

Electronically Signed
By

A section with information about one or more electronic signatures for the report, including
the name of the user who signed the report, the signature type, the date, and comments.

This section is locked and cannot be customized.
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(continued)
Section Description

Image A section for one or more images. There are two types of images that you can add to
reports. You can add custom images that are selected later, when you generate the report.
Or, if the report template is associated with an assay, you can include images for the results
that are shown in the software.

Footer The footer is repeated on each page of the report.

Signature A section for a physical signature of the printed report.

Custom Text A section for custom text. You can allow the text to be edited when the report is generated
if desired.

Variant details Details about variants in the run. You can customize the title of this section and the
columns that are includes in the report.

Edit a draft report template (manager/administrator)

You can edit a variant report that is not locked for electronic sign-offs if you have account permissions
to electronically sign reports. A locked report template cannot be edited.

1. In the menu bar, click Assays » Manage Presets
2. In the Manage Presets screen, click the Report Templates tab.

3. In the Report Templates table, place the pointer over the row of the report template that you want
to edit, then click Edit.

4. Edit the sections of the report template as desired, then click Save.

The report template remains a draft until you lock the report template. For more information, see “Lock
a draft report template (manager/administrator)” on page 211.

Delete a draft report template (manager/administrator)

When a report template is in draft status, it can be deleted from the software. Only draft report
templates can be deleted.

1. In the menu bar, click Assays » Manage Presets
2. In the Manage Presets screen, click the Report Templates tab.

3. In the Report Templates table, place the pointer over the row of the report template that you want
to delete, then click Delete.

4. Inthe Delete Report Template dialog box, click Yes to confirm the deletion.

The draft report template is removed from the software.
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Lock a draft report template (manager/administrator)

Manager- and administrator-level users can lock draft report templates in the
Assays / Manage Presets screen under the Report Templates tab to manage report templates.

When a manager or administrator first creates an report template, the status of the report template is
Draft. After a report template is locked, it cannot be edited or deleted.

1. In the menu bar, click Assays » Manage Presets
2. In the Manage Presets screen, click the Report Templates tab.

3. In the Report Templates table, place the pointer over the row of the report template that you want
to lock, then click Lock.

The report template is now locked and cannot be edited or deleted.

View or add notes to a report template (manager/administrator)

Manager- and administrator-level can view existing notes or add new notes to draft or locked report
templates in Genexus™ Software.

1. In the menu bar, click Assays » Manage Presets
2. In the Manage Presets screen, click the Report Templates tab.

3. In the Report Templates table, place the pointer over the row of the report template of interest,
then click Notes.

Action Description

View existing notes for a | In the Add Notes dialog box, notes that are associated with the report
report template. template are listed by user, date, and time.

Add 2 ?eW Totte toa 1. In the Add Notes dialog box, click + Add Note.
report template.
P P 2. Enter the note, then click Save.

The note is added to the report template and includes the username for the
account of the person who entered the note, and a timestamp that records
the note entry date and time.

Delete a note from a In the Add Notes dialog box, in the row of the note that you want to delete,
report template click T (Delete).

Click Close to return to the list of report templates.

Configure electronic signatures (administrator)

Administrator-level users configure electronic signatures in Genexus™ Software. For more information
about electronic signatures, see “Sign off variant reports” on page 201.
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Manage electronic signature types (administrator)

Signature types in Genexus™ Software are associated with electronic signature permissions to
designate how a signature is used. Different types of signatures, such as review, approve, and lock,
can be required to sign off on a variant report.

Administrator-level users can add new electronic signature types. Each user account can be associated
with just one signature type. Signature types can be renamed, made obsolete, restored, or deleted.
Changes to electronic signature types are shown in the audit trail for the signature type.
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Designate one of the signatures to lock the report during sign-off.

1.

2.

Click 3 (Settings) » Configuration.

In the Configuration screen, in the Electronic Signature section, manage signatures.

Option

Description

Add new types of
electronic signatures.

In the Bulk add list of comma delimited meaning of signature field,
enter new types of signatures, separated by commas. For example, enter
Review,Inconclusive to add two new signature types.

Signature types that are added can be associated with users who are
granted permission to electrically sign reports. For more information, see
“Add a new user account (administrator)” on page 304 and “Edit user
details (administrator)” on page 305.

Rename a type of
signature.

Click (& Edit, then enter a new name for the signature type.

Associate locking a report
with a type of signature.
A report becomes locked
when a user whose
account is associated
with the selected type

of signature electronically
signs the report.

In the Select a type of signature to lock report when signing off
section, select the radio button next to the type of signature that you
want to use to lock a report during report sign-off.

Obsolete a type of
signature.

Click @ Obsolete to remove the signature type as an option during
variant report sign-off.

If an obsolete signature type is associated with a user account, an alert
is added to the User Management screen next to Electronic Signature
Type. An alert is also shown if no signature type is associated with a
user account that includes permissions for electronic signatures. The
signature type must be edited by an administrator before the user can
electronically sign reports. For more information, see “Edit user details
(administrator)” on page 305.

Restore a type of signature.

Click O Reactivate to reactivate a type of signature that has been made
obsolete.

Delete a custom type of
signature.

Click [i] Delete to delete a type of signature. A custom electronic
signature type can be deleted if is not associated with a user, is not
set as lock-level, and is not used in electronic sign-offs for any reports.
System-installed signature types cannot be deleted.

Review the changes made
to a type of signature.
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1. Click [ Audit.
2. In the Audit Trail - Electronic Signature screen:
3. o

* (Click a time stamp of interest to view the details for other
changes that have been made to the selected signature.

Review the audit trail details for the most recent change.
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Run report
Option Description
* Click Download to export the record of the single change to
a PDF file.
* (Click < Back to return to the Configuration screen.
Run report

The run report includes assay metrics and the record of reagents that were used in a run. For
information about the contents of the run report, see “Assay metrics and the run report” on page 151. If
you entered extraction kit barcodes for samples or control samples when you prepared library batches
or when you planned the run, the extraction kit barcodes are listed in the run report.

View a run report

You can view or download a run report in Genexus™ Software.

For information to download a run report, see “Download a run report” on page 214.

1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, click the sample name of interest in the Sample Name column.

3. Click the Reports tab.
A pane for the run report and each variant report that has been generated is shown. The name of
the report is listed at the top of the pane.

4. Inthe Run Report pane, click View Report.

The run report opens in a new browser tab.

Download a run report
You can download a run report summary in PDF format.

1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, in the Sample Name column, click the sample name of interest.

3. Click the Reports tab.
Multiple panes including a Run Report pane, a Variant Report pane, and any panes for
customized reports that have been generated are shown.

4. Inthe Run Report pane, click Download Report to download a run report summary in PDF
format.

214 Genexus™ Software 6.8 User Guide



Create and manage assays
(manager/administrator)

B Assays in Genexus™ SOfWAIE . ... .....utir ittt e i e e e 215
LT g = g =TT 216
B ASSay Creation OVEIVIEW . .. ...ttt e e et et et e e e et 218
B MANAGgE GSSAYS - -ttt ettt ettt et e e e e e 236
B Gene lists (manager/administrator) . ....... ... 243

Assays in Genexus™ Software

Assays contain the settings and parameters for library preparation, templating, controlling the
sequencing run, analyzing, and reporting the results. Assays also define the panels, kits, and chips

that are used in a run, and specify the reference files and threshold values for quality control and variant
detection. The software files that contain the assay settings and parameters are packaged in a ZIP file
called an assay definition file (ADF).

An assay is a reusable experimental design that contains predefined settings appropriate for use with
common types of research applications. An assay can be used to plan many runs and plays an
important role in enabling rapid throughput across the sequencing instrument. Assays help reduce the
chance of errors, because information is stored and then applied to runs instead of entered manually for
each run.

Custom assays can be created from system-installed templates, and you can copy a locked assay
to create an assay, or copy and edit custom assays. You can also create custom versions of the
system-installed presets that you can add to assays, including annotation sets, and copy number
baselines, sequence variant baselines, exon tile assay baselines, and report templates.

Before you can create a custom assay, you must add a panel file, and hotspot and copy number
baseline files (if needed for the assay), to the software. Custom assays are for advanced users. For help,
contact a Field Service Engineer.
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Find an assay

You can sort, search and filter information to narrow the list of assays shown in the Assays / Manage
Assays screen, then find a specific assay in Genexus™ Software.

For information to search for an assay by a unique identifier, such as the name of the assay, see
“Search for assays” on page 216.

For information to filter assays by a common trait, such as the name of the creator of the assay, see
“Filter and search in the list of assays” on page 217.

Search for assays

You can search for assays in Genexus™ Software with keywords or text that are included in the name or
full name of an assay.

IMPORTANT! Search terms must adhere to the following rules.

. An asterisk (*) is not allowed in the search field for use as a wildcard.

. Searches are case-insensitive, that is, both upper-case and lower-cases letters are found regardless
the case of search term letters.

. Searches find every occurrence of a continuous string. For example, a search for demo in analysis
names returns a list of all analysis with a name that includes demo. For example, demo1, demo2,
and so on.

. Spaces are removed during searches, and therefore are not recommended. For example, a search for
demo 1 would return results only for data that includes the string demo1.

1. Click Assays » Manage Assays.

2. In the Manage Assays screen, in the Assay Full Name column heading or Assay Name column
heading, click Y (Filter).

a. In the search field, enter a full or partial assay name of at least 3 characters.

When you have entered at least 3 characters, the filter dialog box limits the list in the filter
dialog box based on the entry.

b. In the filter dialog box, select from the limited list.
* Select a checkbox next to the name of an assay to select one or more assays.
* Click Select All to select all assays listed in the filter dialog box.

Note: If you click Clear, all selections are removed and the filter dialog box closes.

c. In the filter dialog box, click Filter.
In the column heading, (Filter) changes color to indicate that a filter is applied.

The filtered list of assays is shown in the Manage Assays screen.

Click {x] Clear Filters to remove all filters and view the full list of assays.
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Sort the list of assays

You can sort the list of assays to make it easier to find assays in Genexus™ Software.

1. Click Assays » Manage Assays to open the Manage Assays screen.

2. Click a column heading in the list of assays.
If the column is sortable, the contents of the column is sorted alphabetically, or chronologically.

3. Click the column heading again to reverse the order.

Filter and search in the list of assays

You can apply filters to narrow search results, or shorten the list of assays when you view the list of
assays in Genexus™ Software.

You can also search for assays in Genexus™ Software with keywords or text that are included in an
assay name.

IMPORTANT! Search terms must adhere to the following rules.

. An asterisk (*) is not allowed in the search field for use as a wildcard.

. Searches are case-insensitive, that is, both upper-case and lower-cases letters are found regardless
the case of search term letters.

. Searches find every occurrence of a continuous string. For example, a search for demo in analysis
names returns a list of all analysis with a name that includes demo. For example, demo1, demo2,
and so on.

. Spaces are removed during searches, and therefore are not recommended. For example, a search for
demo 1 would return results only for data that includes the string demof1.

1. Click Assays » Manage Assays to open the Manage Assays screen.

2. Click the Filter Assays By dropdown menu, then apply the filters.
* Select IRU Shortlist to limit the assays shown to the assays that are tagged for use with the
lonReporterUploader plugin.

* Select Status to expand the list of options for status, then select a status:
— Locked & Draft

— Obsolete
— Locked
— Draft
¢ Select All to return to the complete list of assays.
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3. Select from the filter and search options in the column heading of interest.

Option

Description

Filter and search by name
of an object.

Click Y (Filter) in the column heading of interest, then select one or more
of the search options.

* Enter at least 3 characters to search by the full or partial name for
the object. Select one or more matches from the filter dialog box. To
select all matches, click Select All. Next, click Filter.

The filtered list of assays is shown in the Manage Assays screen.

Filter and search by
research application.

Click Y (Filter) in the Research Application column, then select one or
more of the search options.

* Enter at least 3 characters to search by the full or partial research
application name. Select one or more matches from the filter dialog
box. To select all matches, click Select All. Next, click Filter.

The filtered list of assays is shown in the Manage Assays screen.
* Select from the research applications shown, then click Filter.

Filter and search by the
creator of the assay.

Click Y (Filter) in the Created By column, then select one or more of the
search options.

* Enter at least 3 characters to search by the full or partial assay name.
Select one or more matches listed in the filter dialog box. To select all
matches, click Select All. Next, click Filter.

The filtered list of assays is shown in the Manage Assays screen.

* Select from the user names that are shown, then click Filter.

Filter by the exact or
approximate date on which
assays were created.

Click Y (Filter) in the Created On column, then use the options to filter
by a date or range of dates to filter the list based on the assay creation
date.

4. (Optional) Click {x] Clear Filters to return to the entire list of assays.

The list of assays is filtered according to the selections.

Assay creation overview
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You can view the assay parameters and other components of the assays in Genexus™ Software. For
more information, see “View assay details” on page 236 and “Assay details” on page 236. Manager-
and administrator-level users can create custom assays if system-installed assays do not meet needs.

To create a custom assay:

* Copy an existing system-installed assay or a locked custom assay, then edit the settings of
the assay to create a new custom assay. For more information, see “Copy an assay (manager/
administrator)” on page 221.

¢ Use a template to create a custom assay that contains preconfigured settings. The template
includes settings for various genetic research analysis applications. For more information, see
“Create an assay (manager/administrator)” on page 219.
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After you create an assay, you can optimize the assay configuration if needed. You can plan a run with a
draft assay, view the results, then change the configuration and plan new runs before you lock the draft
assay. For more information, see “Lock a draft assay (manager/administrator)” on page 240.

Create an assay (manager/administrator)

Manager- and administrator-level users can create a new assay from a system-installed template in
Genexus™ Software. Each template allows you to select kits, chips, primer panels, and adjustable
Quality Control (QC) thresholds and other parameters that are appropriate for the assay type. The assay
is then available to select when you plan a run.

IMPORTANT! Use the default settings for system-installed assays unless you are an advanced user.
Contact your Field Bioinformatics Specialist (FBS) for assistance.

1. In the menu bar, click Assays » Create Assay.
The Create Assay screen opens.

2. Click the assay type for the template that provides the appropriate kits, chips, primer panels, and
adjustable QC thresholds and read mapping parameters.

Assay type

Description

Generic Sequencing
Application

Use this template to create a generic sequencing assay with no
application-specific post-run analysis. The assay generates BAM files.

Non-Human Reference

Use this template to create an assay that detects germline variants.
Annotations are not included in the results.

DNA and Fusions

Use this template to create an assay that detects and annotates somatic
DNA variants and RNA fusion targets in a sample.

The DNA and Fusions template creates a DNA-only, a Fusion-only, and a
DNA and Fusions research application for the assay. Then, when you plan
a run, you can select one or more research applications of the assay to
use in the run.

DNA Somatic Use this template to create an assay that detects and annotates somatic
variants in DNA samples.

DNA Germline Use this template to create an assay that detects and annotates germline
variants in DNA samples.

Fusions Use this template to create an assay that detects and analyzes variants in
fusion samples.

TNA Use this template to create an assay that detects and annotates DNA and

Fusion variants in total nucleic acid (TNA) samples

3. In the Panel step, select a panel and other options for the assay. For descriptions of the panel
information appropriate for the assay, see “Panel step assay options” on page 222.

4. Click Next.
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5. In the Reagent step, select the kits and chips that you are using. Ensure that the reagents are
appropriate for the primer panel that you are using.

For descriptions of the reagent information that is available for the assay, see “Reagent step assay
options” on page 225.

6. Click Next.

7. In the Parameters step, accept the recommended default values, or adjust the values within the
allowed ranges, then click Next.

You can set the parameters by uploading an advanced parameters configuration file that overrides
the default values in the template.

a. At the bottom of the Parameters step, click Download to download a ZIP file of the JSON
template that is appropriate for the assay.

b. Edit the file with custom settings, then save the file to the computer.
c. At the bottom of the Parameters step, click Upload.

d. Click Select files, navigate to the file on the computer, then click Open. Click Upload to
upload the file and override the default values in the template.

For more information about parameters, see “Parameters step assay options” on page 226.

8. In the QC step, enter QC metric values, then click Next.
For descriptions of the QC information for the assay, see “QC step assay options” on page 229.

9. In the Plugins step, select one or more plugins to run with this assay, then click Next.
For more information, see Chapter 11, “Plugins for data analysis”.

10. In the Save step, enter an assay name, an assay full name, and an optional description, then click
Save.
The types of runs that the assay is compatible with are listed in the Save step. The types of assays
listed depends on the selections in the Reagent step. For example, if a purification kit is selected,
Sample to Report run types are shown. If library kits are selected, then Nucleic Acid to Report run
types are shown.
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Assays |/ Create Assay

0 Panel Save

Assay Name *
o Reagent
‘ TAL v
0 Parameters
Assay Full Name *
° Qc ‘ TestAssay1 v

Description

Run Workflows: Library to Result, Nucleic Acid to Result

Exit Previous

The new assay is listed in the Manage Assays screen. The Assay Full Name is followed by Draft

to indicate that the assay is in draft status. You can plan a run with the draft assay and the assay is
available to lock, edit, or delete, and audit. You can also download parameters from assays in Draft or
Locked statuses.

Copy an assay (manager/administrator)

Manager- and administrator-level users can create a new assay by copying an existing system-installed
assay or other custom assay and modifying it if needed. Only locked assays can be copied.

1.

2.

In the menu bar, click Assays » Manage Assays.

In the Manage Assays screen, place the pointer over the row of the assay that you want to copy,
then click Copy.

The Copy Assay screen opens to the Panel step. The assay settings can be modified for the new
assay.

Proceed through the workflow steps, and modify assay settings if needed. For more information,
see “Assay options” on page 222.

In the Save step, enter a new assay name, an assay full name, and an optional description, then
click Save.

The newly created assay is added to the list of assays in the Assays / Manage Assays screen.
The Assay Full Name is followed by bpraft to indicate that the assay is in draft status. You can plan
a run with the draft assay. The assay remains in draft status until it is locked. You can lock the draft
assay to ensure that the assay cannot be edited. For more information, see “Lock a draft assay
(manager/administrator)” on page 240.
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Assay options

Panel step assay options

Manager- and administrator-level users can use the Panel step to select the appropriate reference files
and other settings for use with an assay in Genexus™ Software.

In the Panel step, you can select the appropriate reference files to use in an assay.

The following table lists options that are available in the Panel step. The available options depend on
the type of assay.

IMPORTANT! Use the default settings for system-installed assays unless you are an advanced user.
Contact your Field Bioinformatics Specialist (FBS) for assistance.

Option Description

Panel The panel to use in the assay. The remaining options are appropriately
populated based on the selected panel.

The panel is a tab-delimited BED file that defines the coordinates of the
regions of interest to be amplified with the selected primer set.

Hotspots The hotspots file to use in the assay. The hotspots file is a tab-delimited
BED file that indicates the positions where a DNA variant is expected to
occur. It also annotates these positions with the reference allele, variant
allele, and anchor base.

Target Regions The target regions BED file that is appropriate for the sample. Depending on
the application, you may need to select a separate DNA and Fusions Target
Regions file.

Check with a Field Service Engineer for updates to ensure that the most
current files are being used.

Genome Reference The genome reference file for the panel that is selected is displayed. When
you create or upload a panel, you select the genome reference. For more
information, see “Add new panel files (manager/administrator)” on page 286.

The hg19 and GRCh38 and genome references are installed with the

system.
Library Chemistry The type of library chemistry to use in the assay.
Extraction Method Type The method used to extract the DNA, RNA, or DNA and RNA from the

sample, or as a single library TNA from the sample.

Available options depend on the panel that is selected.
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Option

Description

Minimum Read Count Per Sample

The minimum number of reads per sample that are needed to achieve the
coverage depth required in an assay.

This value, usually associated with the panel, determines the number of
samples that can be run on the lanes that are available on a chip. The
system uses this value to calculate how many lanes a run uses and assigns
samples according to the calculation. For example, a minimum read count
per sample of 1,000,000 allows twice as many samples on the same lane as
that of 2,000,000.

Run CNV

When Run CNV is enabled, the software analyzes CNV results based on
the selected CNV baseline file. You must select a baseline file from the
dropdown list to detect copy number variants (CNVs). If the default setting,
Do Not Run CNV Algorithm, is selected in the dropdown list, the software
does not run the CNV algorithm even if Run CNV is enabled.

Copy Number Baseline for CNV
Calling

You must select a baseline file from the dropdown list to detect copy
number variants (CNVs).

The copy number baseline is a set of control samples that are used to
create a baseline for the detection of copy number variants (CNVs). You

can use system-installed baselines, import or create a baseline, or copy and
edit an existing baseline. You can view the settings that are used for the
baseline in the Assays/Manage Presets/Copy Number Baselines tab. For
more information, see “Copy number baselines (manager/administrator)” on
page 265.

CNV Calling method

Select either Mosaic, Full Ploidy, or both.

When mosaicism detection is enabled, the software can make non-integer
ploidy calls. CNV events are reported as a decimal ploidy value instead of an
integer value.

CNV calling with Full Ploidy includes read coverage correction for GC
bias. Corrected coverage is compared to a baseline coverage from control
samples of regions with known expected normal ploidy. That is, 2 on
autosomes and X in females, and 1 on sex chromosomes in males.

This option is available only for Aneuploidy assays.

Adjust Sample Copy Number by
Cellularity

The % cellularity that is the minimum value that the assay requires of a
sample. Only samples above the threshold value can be assigned to a run
plan with the assay when the selection is enabled.

Click Adjust Copy Number by Sample Cellularity to enable the setting in
the software. When the setting is enabled, the toggle switch is shown in
blue. You can adjust the percentage in the dropdown list that appears when
the setting is enabled. For example, if you select 50, you cannot add a
sample with a %Cellularity of 49 to a run plan that uses the assay.

This option is available only for assays that use a DNA and Fusions panel or
a DNA panel.
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(continued)

Option

Description

Fusion Reference

The tab-delimited BED file to use in the assay that indicates the positions
where an RNA fusion target is expected to occur. It also annotates these
positions.

Fusion Panel

The tab-delimited BED file to use in the assay that defines the coordinates of
the regions of interest to be amplified with the selected primer set.

Fusion Baseline

The fusion baseline used in the assay.

Primer Pools

The number of primer pools used in the assay.

Annotation Sets

The annotation set to use in the assay.

Some annotation sets are system-installed. Custom annotation sets can be
created as required. For more information, see “Create a new annotation set
(manager/administrator)” on page 250.

Apply Oncomine Variant
Annotations

When you select the Apply Oncomine™ Variant Annotations option in the
Panel step to create or edit an assay, analysis results data from more

than 24,000 exomes across solid tumor and hematological cancer types

is used as a reference to annotate variants that are relevant to cancer.

The annotations are shown in results in the Oncomine™ Gene class and
Oncomine™ Variant class columns. For more information, see “Annotation
criteria for Oncomine™ Variant Annotator” on page 385 or contact a support
representative, Field Bioinformatics Specialist (FBS), or Clinical Account
Consultant (CAC).

This option is available only for assays that use custom lon AmpliSeq™ HD
and Oncomine™ panels.

Use Latest Annotation

When enabled, this setting instructs the assay to use the most recent
version of the annotation source in the software. The version of the
annotation source that is used with the run depends on installation of newer
versions of the annotation source. After this setting is enabled, any new run
plan uses the latest version of the annotation source that is available in the
software. This means that run plans with the same assay can use a different
version of the annotation source.

This option is available only for some assays.
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Manager- and administrator-level users can use the Reagent step to select options that are related to
the reagents for use with an assay in Genexus™ Software.

In the Reagent step, you select the kits and chips to use in an assay. Ensure that the kits and chips that
you select are appropriate for the primer panel that you are using.

The following tables list options that can be available in the Reagent step. The available options

depend on the type of assay.

IMPORTANT! Use the default settings for system-installed assays unless you are an advanced user.
Contact your Field Bioinformatics Specialist (FBS) for assistance.

Purification

Option

Description

Purification Kit

The purification kit that is used for nucleic acid purification.

Library Preparation

Option Description
Library Kit The library kit that is used to prepare the library.
Barcode Kit The barcode kit to use in the assay.

Include Inline controls

You can select DNA or RNA, or both DNA and RNA, depending on the
assay template that is used. For example, you might want to ensure
that both DNA and RNA are selected if you use the DNA/RNA template.

By default, only DNA is enabled and RNA is disabled. RNA is available
for selection only if the assay template includes it.

TNA is an option for TNA assays.

Templating

Option

Description

Sequencing Chip

The sequencing chip to use in the assay.

When you change the Sequencing Chip option, other assay
parameters are changed to the default settings that are associated with
the chip. Review the settings in the Parameters step after you make
this change.

Templating Kit

The templating kit to use in the assay.

When you change the Templating Kit option, other assay parameters
are changed to the default settings that are associated with the
templating kit. Review the runparameter. json after you make this
change.
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Templating (continued)

Option Description
Template Size (bp) The template size, measured in base pairs, to use in the assay.
e 200
* 400
Sequencing
Option Description
Sequencing Kit The sequencing kit to use in the assay.
Sequencing Flows The number of flows performed by the sequencer during the
sequencing stage of the run.

Parameters step assay options

Manager- and administrator-level users can use the Parameters step to select options related to
parameters for use with an assay in Genexus™ Software.

IMPORTANT! Use the default parameter settings for assays unless you are an advanced user. Contact
your Field Bioinformatics Specialist (FBS) for assistance.

When you click the field of a parameter, the software shows the default value and the range that is
allowed for the parameter. You can see a description of most parameters when you place the pointer
over (» (Learn More) next to a parameter.

The options that are available depend on the type of assay and the selections that are made in the
Reagent step.

Purification
Library Prep & Templating
Primary Analysis

Advanced Command Line Arguments in the Primary Analysis section can only be adjusted
when you click Enable customization.

Annotation

MSI (Microsatellite Instability)
CNV Finding

Fusions

Read Mapping

Variant Finding

In the Parameters step, you can accept the default settings for the assay parameters, or adjust the
settings if needed.

226

Genexus™ Software 6.8 User Guide



Chapter 8 Create and manage assays (manager/administrator)  [Eepg

b€
Assay creation overview

Edit assay parameters in a file
Manager- and administrator-level users create assays in Genexus™ Software.

You can edit assay parameters in the Parameters step. Not all parameters appear in the software.
You can download a JSON file that contains the parameters that appear in the software and more
parameters that do not appear in the software. If you are advanced and understand how the changes
can affect results, you can edit the parameters file and then upload the edited file to create an assay
that captures that values of the JSON file.

1. In the menu bar, click Assays » Create Assays.

2. Select the type of assay you want to create.

3. In the Panel step, select a panel and other options , then click Next.
4. In the Reagent step, select the kits and chips, and then click Next.

5. In the Parameters step:

a. In the Filter Parameters by dropdown list at the bottom of the screen, select the section
for the parameters you want to change or select All to download a file that contains all
parameters.

b. Click Download to download a JSON file for the parameters.
6. Edit the parameter values in the file and save the file.

7. Click Upload.
a. Click Select File.

b. Navigate to the edited file.

(2}

. Click Open.

o

. In the Upload Parameters dialog box, click Upload to upload the file.
The parameter values in the uploaded file are added to the assay.

Reduce the impact of deamination in low-quality FFPEs

Samples of low quality that exhibit deamination can be analyzed if you increase the minimum allele
frequency in an assay. For example, a minimum allele frequency of 10% for the tumor mutational
burden (TMB) calculation can reduce the impact of deamination on the reported TMB value. It is
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important to consider the tumor content of a given sample when you increase the minimum allele
frequency of the TMB calculation.

* Samples with low tumor content can have many true somatic mutations that are excluded from the
tumor mutational burden calculation when a higher minimum allele frequency filter is included in the
assay.

* The tumor mutational burden values cannot be reliable if you adjust the minimum allele frequency
parameters for samples with a high estimated SNP proportion consistent with deamination,
(primarily an FFPE number) or a high deamination score, (for example >100).

* The mean depth and uniformity of the sample as determined by the coverageAnalysis plugin can
also indicate sample quality. For more information, see “coverageAnalysis plugin in Genexus™
Software” on page 338.

IMPORTANT! Use the default parameter settings unless you are an advanced user.

Resequencing

Resequencing is repeat sequencing of the same DNA template a second time. The benefits of
resequencing depend on the assay. Resequencing can improve sequencing metrics, increase the
number of reads, improve sensitivity, or increase the number of samples that can be sequenced on
a chip. Runs that include the resequencing option have longer run times.

When you copy and edit or create an assay in Genexus™ Software, the custom assay that you create
can include an option to sequence and resequence samples in the same run. The option to resequence
samples is available only in assays that specify a 200-bp template size. For more information about
resequencing samples, see the sequencing instrument or assay user guides.

Resequencing settings are available in the Primary Analysis section of the Parameters step when you
create an assay. Template size is specified in the Templating section of the Reagent step.

The way that resequencing is implemented depends on the library chemistry of an assay. For
system-installed assays with lon AmpliSeq™ library chemistry, resequencing is not needed to improve
performance. Therefore, resequencing is not enabled for system-installed lon AmpliSeq™ assays.
Resequencing is enabled for system-installed lon AmpliSeq™ HD assays.

By default, resequencing is enabled for custom lon AmpliSeq™ HD assays and disabled in custom
lon AmpliSeq™ assays. Assay parameters can require optimization if resequencing is enabled for lon
AmpliSeq™ assays.

Flow order

The flow order is the order in which a chip is exposed to each particular ANTP. The default lon
samba flow order consists of a 32-base sequence, repeated. This flow order resists phase errors

by providing opportunities for out-of-phase molecules to catch up, and is designed to sample all
dimer (nucleotide pair) sequences efficiently. lon samba is the default flow order because it improves
sequencing accuracy for longer reads by resisting phase errors.

When you create or copy an assay and enable resequencing, the flow order for resequencing must
be different from the flow order for sequencing. We recommend lon samba for the flow order for
sequencing and lon samba.contradanza for the flow order for resequencing.
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Manager- and administrator-level users create assays in Genexus™ Software.

You can specify Quality Control (QC) metric values to use in an assay in the QC step.

The following tables list options that are available in the QC step. The available options depend on the

type of assay.

CF-1 Control

Option

Description

Min Average Reads Per Lane

The number of average reads per chip lane.

You can specify the minimum threshold value required for the CF-1
(templating Control Fragment-1) to pass the QC metric.

Min Base Call Accuracy

The total number of errors for all positions in CF-1/ total number of CF-1
base reads.

You can specify the minimum threshold value required for CF-1 to pass the
QC metric.

Min Mean AQ20 Read Length (bp)

The average length, in base pairs, at which the accuracy rate is =99% for
reads of a library.

You can specify the minimum threshold value required for CF-1 to pass the
QC metric.

NTC QC - DNA

Option

Description

Max Average Base Coverage Depth

The average number of reads of all targeted reference bases.

You can specify the maximum threshold value required for the DNA no
template control to pass the QC metric.

Max Mean Read Length (bp)

The average length, in base pairs, of called reads.

You can specify the maximum threshold value required for the DNA no
template control to pass the QC metric.
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NTC QC - RNA

Option

Description

Max Mapped Reads

The total number of reads that are mapped to the reference genome in
Genexus™ Software.

You can specify the maximum threshold value required for the RNA no
template control to pass the QC metric.

Mapped Reads can be configured in the QC step or in the Parameters step
in the Fusions section as Minimum Total Valid mapped reads. The values
configured in the Parameters step overwrite those configured in the QC
step.

Max Mean Read Length (bp)

The average length, in base pairs, of called reads.

You can specify the maximum threshold value required for the RNA no
template control to pass the QC metric.

Mapped Reads and Mean Read Length can be configured in the QC step
or in the Parameters step in the Fusions section as Minimum Total Valid
mapped reads and Minimum mean read length for valid sample QC. The
values configured in the Parameters step overwrite those configured in the
QC step.

Purification QC — DNA

Option

Description

Min Sample Concentration DNA
(ng/pl)

The minimum threshold value for the sample concentration of purified DNA
is shown. This value cannot be changed in the QC step, but can be changed
in the Parameters step. For more information, see “Create an assay for a
Sample to Result run (manager/administrator)” on page 235.

Max Sample Concentration DNA
(ng/pl)

The maximum threshold value for the sample concentration of purified DNA
is shown. This value cannot be changed in the QC step, but can be changed
in the Parameters step. For more information, see “Create an assay for a
Sample to Result run (manager/administrator)” on page 235.

Purification QC - RNA

Option

Description

Min Sample Concentration RNA
(ng/i)

The minimum threshold value for the sample concentration of purified RNA
is shown. This value cannot be changed in the QC step, but can be changed
in the Parameters step. For more information, see “Create an assay for a
Sample to Result run (manager/administrator)” on page 235.

Max Sample Concentration RNA
(ng/pl)

The maximum threshold value for the sample concentration of purified RNA
is shown. This value cannot be changed in the QC step, but can be changed
in the Parameters step. For more information, see “Create an assay for a
Sample to Result run (manager/administrator)” on page 235.
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Option

Description

Min Sample Concentration TNA
(ng/pl)

The minimum threshold value for the sample concentration of purified TNA
is shown. This value cannot be changed in the QC step, but can be changed
in the Parameters step. For more information, see “Create an assay for a
Sample to Result run (manager/administrator)” on page 235.

Max Sample Concentration TNA
(ng/pl)

The maximum threshold value for the sample concentration of purified TNA
is shown. This value cannot be changed in the QC step, but can be changed
in the Parameters step. For more information, see “Create an assay for a
Sample to Result run (manager/administrator)” on page 235.

Run QC

Option

Description

Min Key Signal

The average signal after software processing for all library ISPs that
identically match the library key (TCAG). This value is a measure of the
efficiency of template amplification.

You can specify the minimum threshold value required for a run to pass QC
for the key signal metric.

Min Percent Loading

The percentage of addressable wells on a chip lane that are loaded with an
ISP. The percentage is derived from the number of wells with ISPs divided
by the number of the total addressable wells in a run.

You can specify the minimum threshold value required for a run to pass QC
for the percent loading metric.

Min Raw Read Accuracy

The average raw accuracy across each individual base position in a read,
where raw read accuracy is calculated as 100 * (1 - (sum(per base error) /
sum(per base depth))).

You can specify the minimum threshold value required for a run to pass QC
for the raw read accuracy metric.

Sample QC - DNA

Options

Description

Min Deamination score

Deamination is reported as the estimated SNP proportion consistent with
deamination (low allele frequency C:G>T:A SNVs). The deamination score
can be used to determine the quality of the FFPE sample.

You can specify the minimum threshold value required for a DNA sample to
pass the QC metric.

Min Mapped Reads

The number of reads aligned to the reference genome.

You can specify the minimum threshold value required for a DNA sample to
pass the QC metric.
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Sample QC - DNA (continued)

Options

Description

Min Mean AQ20 Read Length (bp)

The average length, in base pairs, at which the accuracy rate is =299% for
reads of a library.

You can specify the minimum threshold value required for a DNA sample to
pass the QC metric.

Min Mean Read Length (bp)

The average length, in base pairs, of called reads.

You can specify the minimum threshold value required for a DNA sample to
pass the QC metric.

Min Number Of Bases Used In
Calculating TMB

The number of exonic bases or all of the genomic bases that are covered
by the panel. Only bases with sufficient base coverage are used in the
calculation, as defined in the workflow parameters. By default, the TMB
calculation uses total exonic bases with =60 bp coverage. In the TMB
parameter settings, you can select between exonic bases or all of the
genomic bases. You can also modify the sufficient coverage value.

You can specify the minimum threshold value required for a DNA sample to
pass the QC metric.

Min Mean Red Cov

The mean molecular coverage of targeted CNV gene.

You can specify the minimum threshold value required for a DNA sample to
pass the QC metric.

Min Median Mol Cov

The median molecular coverage of non-CNV reference loci.

You can specify the minimum threshold value required for a DNA sample to
pass the QC metric.

Min Number of variant calls

The number of somatic variants that are identified in the sample. This value
is reported in the statistic.txt file as Total Somatic Filtered Variants Count
(numerator for TMB calculation) and Variant Count.

You can specify the minimum threshold value required for a DNA sample to
pass the QC metric.

Min Uniformity of Base Coverage

The percentage of reads showing a depth of coverage =20% of the mean
base coverage.

You can specify the minimum threshold value required for a DNA sample to
pass the QC metric.
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Option

Description

Min MAPD

MAPD is a quality metric that estimates coverage variability between
adjacent amplicons in CNV analyses. A MAPD value of 0.4 indicates an
acceptable level of coverage variability. High MAPD value typically translates
to a lower coverage uniformity. Lower coverage uniformity can result in
missed or erroneous CNV calls. If the MAPD QC threshold is not met, CNVs
do not get called. The MAPD metric does not affect SNVs/INDEL calls.

You can specify the minimum threshold value required for an RNA sample to
pass the QC metric.

This option is available only when a Copy Number Baseline for CNV Calling
is selected in the panel step.

Max MAPD

You can specify the maximum threshold value required for an RNA sample
to pass the QC metric.

This option is available only when a Copy Number Baseline for CNV Calling
is selected in the panel step.

Min Mapped Fusion Reads

The number of reads aligned to the reference genome.

You can specify the minimum threshold value required for an RNA sample to
pass the QC metric.

The minimum allowed value for mapped reads. Min Mapped Fusion Reads
and Mean Read Length can be configured in the QC step or in the
Parameters step in the Fusions section as Minimum Total Valid mapped
reads and Minimum mean read length for valid sample QC. The values
configured in the Parameters step overwrite those configured in the QC
step.

The best practice to achieve consistent results is to use the same values in
both the QC step and the Parameters step.

Min Mean AQ20 Read Length (bp)

The average length, in base pairs, at which the accuracy rate is =299% for
reads of a library.

You can specify the minimum threshold value required for an RNA sample to
pass the QC metric.
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Sample QC - RNA (continued)

Option

Description

Min Mean Read Length (bp)

The average length, in base pairs, of called reads.

You can specify the minimum threshold value required for an RNA sample to
pass the QC metric.

Min RNA Expression Ctrls Detected

The number of expression control genes detected for the sample. This
metric measures the RNA input integrity, input amount, and the fidelity

of the reverse transcriptase that was used in library preparation. Fusion
panels include primer pairs that cover seven control housekeeping genes.
For Oncomine™ Precision Assay GX to pass QC, cfTNA samples require 2
out of 7 control genes to be detected and FFPE RNA samples require 5 out
of 7 control genes to be detected.

You can specify the minimum threshold value required for an RNA sample to
pass the QC metric.

This option is available only for cfTNA panels.

Custom assays for Sample to Result runs (manager/administrator)

Manager- and administrator-level users can create a new assay or copy and edit an existing assay
for a Sample to Result run. For more information, see “Create an assay (manager/administrator)” on
page 219 and “Copy an assay (manager/administrator)” on page 221.

Sample to Result runs integrate sequential nucleic acid purification and sequencing. The concentration
of purified nucleic acid for each sample is calculated after purification, before sequencing. You can
choose to review samples after purification or proceed directly to sequencing.

Option Description

Sequence all nucleic acid samples, regardless of All samples in the run are sequenced.

concentration

Sequence only samples that have a nucleic acid All samples that have a concentration within a

concentration within a set range specified range are sequenced.
Samples with a concentration outside the specified
range are not sequenced.

Review samples after purification You can review the concentration of all samples and
determine which samples to sequence.
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Create an assay for a Sample to Result run (manager/administrator)

1.

2.

8.

In the menu bar, click Assays » Create Assay.

In the Create Assay screen, click the assay type for the template that provides the appropriate
kits, chips, primer panels, and adjustable QC thresholds and read mapping parameters. For more
information about selections, see “Create an assay (manager/administrator)” on page 219.

In the Panel step, select a panel and other options for the assay. For descriptions of the panel
information appropriate for the assay, see “Panel step assay options” on page 222.

Click Next.

In the Reagent step, in Purification Kit, select the appropriate kit.

Note: If you select Other, the assay cannot be used in a Sample to Result run.

Select the kits and chips that you are using. Ensure that the reagents are appropriate for the primer
panel that you are using, then click Next.

For descriptions of the reagent information appropriate for the assay, see “Reagent step assay
options” on page 225.

In the Parameters step, accept the recommended default values, or adjust the values within the
allowed ranges, then click Next.

You can set the parameter values with an advanced configuration file. For more information, see
“Edit assay parameters in a file” on page 227.

Purification Parameters

Option Description

Sample Type The types of samples that are compatible with the selected
purification kit are listed.

Review Require * Select True to review the concentration of all samples after
purification and select which samples to sequence.

® Select False to enable automated sequencing of all samples
that are within the specified concentration after purification.

Note: You can override this assay setting when you plan a
purification run. For more information, see “Plan a Sample to
Result run” on page 66.

QC Concentration Minimum QC concentration minimum thresholds in ng/ul for DNA or RNA.

QC Concentration Maximum QC concentration maximum thresholds in ng/pl for DNA or RNA.

For more information about parameters, see “Parameters step assay options” on page 226.

In the QC step, enter QC metric values, then click Next.

For descriptions of the QC information appropriate for the assay, see “QC step assay options” on
page 229.
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9. In the Plugins step, select one or more plugins to run with this assay, then click Next.
For more information, see Chapter 11, “Plugins for data analysis”.

10. In the Save step, enter an assay name, an assay full name, and an optional description, then click
Save.

The new assay is listed in the Manage Assays screen. The Assay Full Name is followed by Draft

to indicate that the assay is in draft status. You can plan a run with the draft assay and the assay is
available to lock, edit, or delete, and audit. You can also download parameters from assays in Draft or
Locked statuses.

Manage assays

You can view assay details, view the audit trail of an assay, and download assay parameters in
Genexus™ Software.

In addition, manager- and administrator-level users can import an assay, export a locked assay, edit,
lock, or delete a draft assay, edit the QC parameters of a locked assay, and obsolete a locked assay.

View assay details

236

You can view assay details in Genexus™ Software.

1. In the menu bar, click Assays » Manage Assays.
2. In the Manage Assays screen, click the assay name of interest.

The assay details are shown.

If needed, you can click --- (More Options) to perform more actions, such as export, copy, edit, lock,
delete, obsolete, edit QC, download parameters, or audit the assay. The options that are available
depend on whether the assay is system-installed or is a custom assay. For custom assays, the options
that are available also depend on whether or not the assay is locked.

The actions for each assay are also available in the Manage Assays screen when you place the
pointer over the row of an assay. For more information, see “Export a custom, locked assay (manager/
administrator)” on page 238, “Copy an assay (manager/administrator)” on page 221, “Edit a draft assay
(manager/administrator)” on page 239, “Lock a draft assay (manager/administrator)” on page 240,
“Delete a draft assay (manager/administrator)” on page 240, “Remove access to an assay (manager/
administrator)” on page 242, “Edit the QC parameters of a locked assay (manager/administrator)” on
page 241, “Download assay parameters” on page 242, and “Review and export an assay history” on
page 238.

Assay details

When you view assay details in Genexus™ Software, you can view information about the components of
the assay. The information that is shown depends on the type of assay.

You can install and use multiple versions of an assay in the software. When there is a new
version of an assay that is available to download, the available assay definition file is listed in the
¢ (Settings) / Software Updates screen, in the Software Updates table. In some cases, the most
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recent version (wx.x.x) of an assay allows you to perform actions in the software that you cannot
perform with previous versions of the assay. For example, you can only create custom exon tile
assay baselines for some versions of some assays. For more information about software updates,
see “Software updates” on page 312.

Note: For system-installed assays or assays that you install in the software, the end of the assay name,
for example w4.1.2 or w5.0.0, is the version number. The assay version number is not the same as the
Version shown in the assay details. See the following table for more information about Version.

Assay detaill'l Description
Assay creation details ¢ Research Application-The e Created On-The date on which the
research application for the assay, assay was created.
such as DNA or DNA and Fusions.  Assay Name-The name and
e Created By-The sign-in name of version of the assay.
the person who created the assay.  Version-The revision number tracks
Assays that are included with the the number of times that changes
software are labeled as System that have been made to the assay
Installed. in the software. For example, when
* Analysis Pipeline Version-The you edit a custom assay for the first
version of the analysis pipeline used time, the version changes from 1 to
for the assay. 2.
Panel In addition to other components, the panel section lists the reference files used in an
assay.
One item that is listed is the Minimum Read Count Per Sample, which is the
minimum number of reads per sample that are needed to achieve the coverage
depth required for the assay. The minimum read counts per sample is used to
calculate the number of samples that are allowed in a chip lane when you plan a run.
For more information and a complete list of components in the panel section, see
“Panel step assay options” on page 222.
Reagents In addition to other components, the reagents section lists the kits and chips for the

assay.

For more information and a complete list of components in the reagents section, see
“Reagent step assay options” on page 225.

e NTC QC -RNA
e CF-1 Control

e Purification QC
e NTC QC -DNA

The QC sections list the Quality Control (QC) metric values for the assay.

For more information and a complete list of components in the reagents section, see
“QC step assay options” on page 229.

e RunQC
e Sample QC
Plugins The plugins sections lists the plugins that are associated with the assay.
For more information about plugins, see Chapter 11, “Plugins for data analysis”.
Description A short description of the assay, similar to the assay full name.

' The details that are shown depend on the assay.
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Import an assay (manager/administrator)

A manager- or administrator-level user can import an assay from another Genexus™ Integrated
Sequencer if the assay has been first exported to a local drive.

1. In the menu bar, click Assays » Manage Assays.
2. In the Manage Assays screen, click [ Import Assay.

3. In the Import Assay dialog box, click Select Assay file, then go to the folder on the computer that
contains the exported assay and select the ZIP file for the assay.

4. Click Upload.

The assay appears in the list of assays in the Assays » Manage Assays screen.

Export a custom, locked assay (manager/administrator)

An assay can be exported, for example to use that assay in another Genexus™ Integrated Sequencer.
You cannot export system-installed assays. Only custom assays that are locked can be exported.

1. In the menu bar, click Assays » Manage Assays.

2. In the Assays » Manage Assays screen, place the pointer over the row of a locked, custom assay,
then click Export.

The assay parameter files are downloaded to the computer as a ZIP file and are available for import to
another sequencer.

Panel reference files are not included in the exported file.

Review and export an assay history

You can review, export, or print the entire history of changes for an assay. The history shows the original
values and any new values or activities.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, place the cursor in the row for the assay of interest, then click
Audit.

The Audit Details screen opens with time-stamped audit records that include assay details and
changes for each action performed on the assay.
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3. (Optional) Review the audit record.

Details in the audit record

Item

Description

User name

The name of the person who was signed in when the action was
performed.

Assay Full Name

The name of the assay.

Data Object Name

The data object that is affected by the action.

Action Performed

Actions performed on the assay include:

e Create
e Edit
e Delete
¢ Obsolete
Time Stamp The time and date of the action.
ID An identifier to represent a specific action in the audit record. Each
action in the audit record includes a unique identifier.
New Values A list of all values in the assay. If a value changed as a result of the
action, the new value is shown. If no change was made, the value is
listed as NA. For example, Plan Executed Status=false indicates a
change; Template Kit Barcode=NA indicates that the value did not
change.
Old Values A list of the previous values in the assay. Values are listed for each

change. For example, State = Draft indicates that a change was
made to the state of the assay. The new value is listed in the New
Values section.

4. (Optional) Click [} Download to download a print-ready PDF file of the audit record.

You can open the PDF file in an appropriate viewer, then print the record from within the open

document.

5. Click Back to return to the Manage Assays screen.

Edit a draft assay (manager/administrator)

When a manager- and administrator-level user first creates an assay, the assay name is followed by
Draft. While the assay is in draft status, it can be edited. A locked assay cannot be edited. Each time
you edit a draft assay, the software creates a new version of the draft assay. The version number of the
assay is shown in the assay details. For more information, see “View assay details” on page 236. You
can view the history of changes made to a draft assay. For more information, see “Review and export

an assay history” on page 238.

Genexus™ Software 6.8 User Guide

239



S Chapter 8 Create and manage assays (manager/administrator)
Manage assays

You can optimize the configuration of an assay when you edit an assay. You can plan a run with a

draft assay, view the results, then change the configuration and plan new runs before you lock the draft
assay.

IMPORTANT! Use the default parameter settings for assays unless you are an advanced user. Contact
your Field Bioinformatics Specialist (FBS) for assistance.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, place the pointer over the row of a draft assay, then click Edit.

The Edit Assay workflow reopens.

3. Edit the options on each assay step as desired, then click Save.

The assay remains a draft until you lock the assay. For more information, see “Lock a draft assay
(manager/administrator)” on page 240.

Lock a draft assay (manager/administrator)

When a manager or administrator first creates an assay, the status of the assay is Draft. After an assay
is locked, it cannot be edited or deleted.

1. In the menu bar, click Assays » Manage Assays to open the Manage Assays screen.
An assay full name followed by Draft indicates that the assay is in draft status.

2. In the Manage Assays screen, place the pointer over the row of a draft assay, then click Lock.

The assay is now locked and cannot be edited or deleted. Draft is removed from the assay full name in
the Assays » Manage Assays screen.

Delete a draft assay (manager/administrator)

When an assay is in draft status, it can be deleted from the software. Only draft assays can be deleted.
Draft assays are indicated by Draft next to the Assay Full Name.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, place the pointer over the row of a draft assay, then click Delete.

3. In the Delete Assay dialog box, click Yes to confirm the deletion.

The draft assay is removed from the software and is no longer available in the Assays / Manage
Assays screen.
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Edit the QC parameters of a locked assay (manager/administrator)

Manager- and administrator-level users can edit the QC parameters of a locked assay. The QC
parameters can be adjusted according to research needs that can change over time. You can edit

the QC parameters of any locked assay, including system-installed assays, if needed. When the QC
parameters are changed, the edited QC parameters are applied to any new run that uses the assay.
Edits to QC parameters do not affect runs that use the assay and are completed before edits are made.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, place the pointer over the row of a locked assay, then click Edit
QcC.
The Edit QC dialog window opens.

3. Edit the QC parameters as desired.

To reset the QC parameters to the original values in a subsection, such as Run QC or Sample QC
- DNA, click Reset in the upper right corner of the subsection.

4. Click Save.

The new QC parameter values are saved and applied in any run that uses the assay after the changes
are saved.

Use the latest annotation source (manager/administrator)

Manager- and administrator-level users can select to use the latest version of an annotation source with
a locked assay. For information to use the latest version of an annotation source for a draft assay, see
“Edit a draft assay (manager/administrator)” on page 239 and “Panel step assay options” on page 222.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, place the pointer over the row of the assay of interest, then click
Use Latest Annotation.

3. Inthe Use Latest Annotation dialog box, click Yes.

The most recent version of the annotation set in the software is used for any new run plan to which
the assay is applied. This setting persists so that every time a new annotation source is installed in
the software, each new run plan uses the latest version of the annotation source that is installed in the

software.
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Use a fixed version of an annotation source (manager/administrator)

Manager- and administrator-level users can select to use a fixed version of an annotation source with a
locked assay. For information to use a fixed version of an annotation source for a draft assay, see “Edit
a draft assay (manager/administrator)” on page 239 and “Panel step assay options” on page 222.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, place the pointer over the row of the assay of interest, then click
Use Default Annotation.

3. In the Use Default Annotation dialog box, click Yes.

The annotation source that is part of the annotation set that is associated with the assay is used for
any new run plan to which the assay is applied, regardless of whether newer versions of the annotation
source are installed in the software.

Remove access to an assay (manager/administrator)

A manager-or administrator-level user can remove a locked, custom assay from use in the software by
designating it obsolete. The assay is not deleted and a record of it is maintained in the audit trail. The
results for any runs already performed with the assay remain available in the software. System-installed
assays cannot be made obsolete.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, place the pointer over the row of a locked assay, then click
Obsolete.

3. Click Yes to confirm the operation.
The assay is no longer available for use in a run.

Download assay parameters

Assay parameters can be downloaded and exported, for example to use that assay in another
Genexus™ Integrated Sequencer.

Panel reference files are not included in the export.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, place the pointer over the row of a locked assay, then click
Download Parameters.

The assay parameter JSON files are downloaded to the computer in a ZIP file and are available to
import to another sequencer.
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Gene lists (manager/administrator)

A gene list is a collection of genes relevant to a particular cancer type. In Genexus™ Software, there are
system-installed gene lists. Manager- and administrator-level users can also create custom gene lists
that are relevant to their research. Each gene list is specific for a particular cancer type. You can create
multiple gene lists for each cancer type, but only one gene list can be designated as the default for that
cancer type.

When a gene list is designated as the default gene list for a particular cancer type, that gene list is
applied, by default, to the sample results. You can change the gene list that is applied to the Key
Variants matrix in the sample results. For more information, see “View the Key Variants matrix” on
page 100.

Although you cannot directly edit system installed gene lists, you can indirectly edit the lists. When

you create a new gene list in the software for a cancer type that has a system installed gene list, the
software generates a list of draft genes to include in the gene list as a starting point. The genes initially
included in the gene list are populated with the system installed genes for that cancer type. Manager-
and administrator-level users can then add or remove genes to create a custom gene list that is derived
from the genes included in a system installed gene list.

A record of how each gene list is used, removed, or changed, and by whom, is maintained in the audit
trail of a gene list.

View a gene list (manager/administrator)

Manager- and administrator-level users can view the genes included in a gene list in Genexus™
Software. For each type of cancer, a gene list can be designated as the default gene list. Default
gene lists are designated with a ¥ after the gene list name.

1. Click Assays » Manage Gene Lists to open the Manage Gene Lists screen.

2. In the Name column, click the gene list name of interest.
Details for the gene list are shown. For more information, see “The View Gene List pane (manager/
administrator)” on page 243.

3. When you are finished viewing the gene list details, click X to return to the Manage Gene Lists
screen.

The View Gene List pane (manager/administrator)

Manager- and administrator-level users can select a gene list in the Manage Gene Lists screen in
Genexus™ Software to view details for the gene list in the View Gene List pane.

Detail Description

Name

The name of the gene list.

Cancer Type

Cancer type for the gene list

Content Version

The version of the gene list.

Default for Cancer Type

Indicates if the gene list is designated as the default gene list. Each cancer type can
have only one default gene list.
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1]

(continued)

Detail Description
Created On The date the gene list was created in the software.
Created By Sign-in name of the person who created the gene list.

System-installed gene lists are created by System Installed.

Updated On The date the gene list was updated in the software.
Updated By Sign-in name of the person who last updated the gene list.
Relevant Genes The genes in the gene list.

Create a gene list (manager/administrator)

Manager- and administrator-level users can create a new gene list in Genexus™ Software. If a gene list
does not already exist in the software for the cancer type that is associated with the gene list when a
gene list is created, the new gene list is set as the default gene list for that cancer type.

When a gene list is designated as the default gene list for a specific cancer type, that gene list is
applied, by default, to the sample results. You can change the gene list that is applied to the Key
Variants matrix in the sample results. For more information, see “The Key Variants matrix” on page 100.

1. Click Assays » Manage Gene Lists to open the Manage Gene Lists screen.

2. Click + Add New.

3. In the Create Gene List screen, enter a unique gene list name, then complete the remaining
sections.

a.

b.

C.

244

In Cancer Type, select the cancer type for the new gene list.

If a default gene list for the selected cancer type already exists in the software, the relevant
genes are populated by the software. If a default gene list for the selected cancer type does
not already exists in the software, the new gene list is designated as the default gene list for
the cancer type.

To set the new gene list as default, enable the Set as Default toggle switch.

In the Relevant Genes field:
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Option Description
Remove a gene from the | Click X in the gene box for the gene you want to remove.
gene list
‘ NTRK1]X ‘
Add a gene to the gene 1. Enter the name of partial name of a gene to autopopulate a master
list. gene list.
2. Select the gene from the populated list.
In this example, typing MAGE in the Relevant Genes field allows you to
select and add the MAGEAS3 gene from the master gene list.
Create Gene List
Name * Cancer Type *
test v | | Melanoma v 3
Relevant Genes *
"BRAF X ‘ "KIT X H NTRK1 X HNTRKZX ‘ ‘4NTRK3 X ‘ I mage I
MAGEA10-MAGEAS -
MAGEA11
MAGEA12
MAGEA2
MAGEA2B
MAGEA3
4. Click Save.

The new gene list is included in the Manage Gene Lists screen and can be applied to filter the genes
displayed in the Key Variants matrix. For more information, see “The Key Variants matrix” on page 100.

Edit a gene list (manager/administrator)

Manager- and administrator-level users can edit the genes in custom gene lists in Genexus™ Software.
Only custom gene lists that are not locked can be edited. System-installed gene lists are always locked
and cannot be edited.

1. Click Assays » Manage Gene Lists.

2. In the Manage Gene Lists screen, place the pointer over the row of the gene list that you want to
edit, then click Edit.
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3. In the Edit Gene List screen, in the Relevant Genes field:

Option Description

Remove a gene from the gene list Click X.

Add a gene to the gene list. 1. Enter the name of partial name of a gene to autopopulate a

master gene list.
2. Select the gene from the populated list.

4. Click Save.

The updated gene list can be applied to filter the genes that appear in the Key Variants matrix. For
more information, see “The Key Variants matrix” on page 100.

Change the default gene list (manager/administrator)

Manager- and administrator-level users can change the default gene list for a cancer type. When a gene
list is designated as the default gene list for a particular cancer type, that gene list is applied to the
sample results. For more information, see “The Key Variants matrix” on page 100.

You must have more than one gene list for the cancer type to change the default gene list for that
cancer type. When there is only one gene list for a cancer type, that gene list is the default gene list. For
more information about default gene lists, see “Gene lists (manager/administrator)” on page 243.

1. Click Assays » Manage Gene Lists.

2. In the Manage Gene Lists screen, place the pointer over the row of the gene list that you want to
designate as default, then click Set as default.

3. Click Yes to confirm that you want to change the default gene list.

The gene list is noted as default in the Manage Gene Lists screen and is applied to the Key Variants
matrix in the sample results for the cancer type. Default gene lists include a v¢ after the gene list name.

Delete a gene list (manager/administrator)

Manager- and administrator-level users can delete custom gene lists that have a draft status in
Genexus™ Software. Only custom gene lists that are not locked can be deleted. System installed gene
lists are always locked and cannot be deleted.

1. Click Assays » Manage Gene Lists.

2. In the Manage Gene Lists screen, place the pointer over the row of the gene list that you want to
delete, then click Delete.

The Confirm dialog box opens with the message Are you sure that you want to delete the Gene
List?

3. In the Confirm dialog box, click Yes to delete the gene list.

The gene list is removed from the software and is no longer listed in the Manage Gene Lists screen.
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Lock a gene list (manager/administrator)

Manager- and administrator-level users can lock custom gene lists in Genexus™ Software. Custom gene
lists that are locked cannot be edited or deleted. System installed gene lists are always locked.

1. Click Assays » Manage Gene Lists.

2. In the Manage Gene Lists screen, place the pointer over the row of the gene list that you want to
lock, then click Lock.

The Confirm dialog box opens with the message Are you sure that you want to lock the Gene
List?

3. In the Confirm dialog box, click Yes to lock the selected gene list.

The gene list is now locked and cannot be edited or deleted.

Remove a gene list (manager/administrator)

Manager and administrator-level users can remove custom gene lists that have been locked from use
in Genexus™ Software. You cannot designate as obsolete system-installed gene lists. Obsoleted gene
lists are not available to apply to sample results, but are listed in the Manage Gene Lists screen with a
Status of Obsolete. You can view the gene list and the audit trail for gene lists that are obsolete. You
cannot reactivate gene lists that are obsolete.

1. Click Assays » Manage Gene Lists.

2. In the Manage Gene Lists screen, place the pointer over the row of the gene list that you want to
remove, then click Obsolete.

The Confirm dialog box opens with the message Are you sure that you want to obsolete the
Gene List?

3. In the Confirm dialog box, click Yes to obsolete the gene list.

The gene list is listed in the Manage Gene Lists screen with the status of Obsolete.

Review a gene list history (manager/administrator)

Manager- and administrator-level users can review and export the entire history of a gene list in
Genexus™ Software. The history shows the original gene list values and any new values or activities.
The following actions generate an audit record:

¢ Create a new gene list. * Obsolete a gene list.
¢ Edit a gene list. * Content version updates that change the
* Lock a gene list. genes in system installed gene lists.

* Delete a gene list.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.
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1. Click Assays » Manage Gene Lists.

2. In the Manage Gene Lists screen, place the pointer over the row of the gene list that you want to
review, then click Audit.
The Audit Details screen opens with time-stamped audit records that include changes for each
action performed on the gene list. For more information, see “Details in the gene list audit record”

on page 248.

3. In the Audit Details screen:

Option Description

Review the audit trail details. Each action that was performed for the gene list, such as gene

list creation or edits, is listed.

Export the audit record. Click Download to generate a PDF file. Depending on the

browser settings, the software automatically downloads the file or
prompts you to open or save the file.

Close the Audit Details screen. Click < Back to return to the Manage Gene Lists screen.

Details in the gene list audit record

The Audit Details screen for gene lists shows the actions that are performed on a gene list.

Audit details for gene lists

ltem Description

User Name The name of the person who was signed in when the action was performed.

Gene List Name | The name of the gene list.

Data Object The data object that is affected by the action. For gene lists, the data object is Gene List.

Name

Action Actions performed on the gene list include: Create, Edit, Lock, Delete, and Obsolete.

Performed Content version updates that change the genes in system installed gene lists are also
included.

Time Stamp The time and date of the action.

ID An identifier for the gene list.

New Values A list of new values in the gene list for the listed action. If a value changed as a result of
the action, the new value is shown. If no change was made to the genes in the gene list,
the value is listed as NA for the action. For example, when the action is to change the
default gene list, but there is no change to the genes included in the list, Genes=NA is
shown. A change to the default gene list is designated as Primary. For example, Primary
= false indicates that the action made another gene list the default gene list.

Old Values A list of the previous values in the assay. Values are listed for actions that resulted in a
change.
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Genexus™ Software includes system-installed presets and panels. In addition, manager-and
administrator-level users can create new presets and panels to use in the software.

In Genexus™ Software, presets include annotation sets, filter chains, copy number baselines, sequence
variant baselines, exon tile assay baselines, and report templates. In addition to the panels that are
used by each assay, manager-and administrator-level users can view and manage hotspots, fusion
references, references, and barcode sets in the software. The control fragment can only be viewed.

For information about report templates, see “Report templates (manager/administrator)” on page 203.

Annotation sets (manager/administrator)

Annotation sets are compiled from various annotation sources to provide information about the
biological meaning of variants and allow variant sorting and prioritization. Annotation sets are derived
from public and private annotation databases for hg19 and GRCh38. For more information about
system-installed annotation sets, see “System-installed annotation sets” on page 403.

If the annotation set that you need is not available for selection, you can create a custom annotation
set.

Manager- and administrator-level users use the tools for creating and managing annotation sets that are
available in the Assays / Manage Presets screen in the Annotation Sets tab.

Genexus™ Software 6.8 User Guide 249



5 Chapter 9 Presets and panels (manager/administrator)
Annotation sets (manager/administrator)
View annotation set details

You can view details about an annotation set in Genexus™ Software.

1. Click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, in the Annotation Sets tab, click the annotation set
name.

The following details for the selected annotation set are shown.

Annotation Set Details

Item Description
Analysis Pipeline Version The analysis pipeline version that is used by the annotation set.
Last Modified By For custom annotation sets, the sign-in name of the person who

created or modified a custom annotation set.

Last Modified On Date on which a custom annotation set was last modified.

Created By Custom annotation sets show the sign-in name of the person who
created the annotation set.

Annotation sets that are included with the software are labeled as
System Installed.

Created On Date on which a custom annotation set was created.

Status Status of the annotation set, including:
¢ Locked

¢ Draft

¢ Obsolete

Reference Genome reference that is available in the annotation set.
e hgl9
¢ GRCh38

Annotation Versions A list of the annotations included in the annotation, and the version of
each annotation.

Create a new annotation set (manager/administrator)

Manager- and administrator-level users can create custom annotation sets in Genexus™ Software. The
custom annotation sets are available as an option when you create or copy an assay.

1. Click Assays » Manage Presets.

2. In the Manage Presets screen, in the Annotation Sets tab, click + Add New.
The Create Annotation Set screen opens and you can view the current Application Version.

3. Enter a name for the new annotation set in Name, and an optional description in Description.
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4. In Genome Reference, select a reference genome from the dropdown list.

Note: The default reference is hg19.
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5. In the Available Annotation Sources dropdown list, select the annotation source.

Source Description

5000 Exomes | Population frequency information from the 5000 Exomes project.
Source: https://evs.gs.washington.edu/EVS/

ClinVar An assessment of impact of the variants observed from NCBI ClinVar database.
Source: http://www.ncbi.nlm.nih.gov/clinvar

COSMIC A catalog of known somatic mutations in cancer.
Source: https://cancer.sanger.ac.uk/cosmic

dbSNP A database of genomic variants.
Source: http://www.ncbi.nlm.nih.gov/projects/SNP

DGV A curated database of human genomic structural variation.
Source: http://dgv.tcag.ca/dgv/app/home

DRA Disease Research Area; a hierarchically organized database of disease categories.
https://meshb.nim.nih.gov

DrugBank A database from which names of therapies that are used for researching variants are
collated.

Source: https://www.drugbank.ca

ExAC Exome Aggregation Consortium—A database catalog of variant frequencies.
Source: https://gnomad.broadinstitute.org

Gene Model A set of genes that the variant overlaps.
Sources: https://www.ncbi.nlm.nih.gov/refseq and
http://www.ensembl.org

Gene Standardized ontology for gene and gene projects (for example, functional role or
Ontology localization).

Source: http://geneontology.org

GnomAD The gnomAD v2.1.1 data set (Exomes)
Source: GhomAD
Gene Set Select this option to import a TXT file that contains a custom set of variants in a
(Custom) specific set of genes.
Genomic Select this option to import BED file that contains a custom set of variants in specific
Regions gene regions.
(Custom)
OMIM Online Mendelian Inheritance of Man.

Source: https://www.ncbi.nlm.nih.gov/omim

Pfam A database of protein families that includes their annotations and multiple sequence
alignments using hidden Markov models.

Source: http://pfam.xfam.org

PhyloP Scores | A measure of conservation of the protein across a wide range of organisms.
Source: http://compgen.cshl.edu/phast
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Source Description
SIFT / A prediction of the functional effect of a variant on a protein.
PolyPhen Sources: https://sift.bii.a-star.edu.sg and http://genetics.bwh.harvard.edu/pph2
Transcript Set | Select this option to import a TSV file that contains a custom set of transcript
(Custom) annotations.
Variant DB Select this option to import a VCF file that contains custom set of variant
(Custom) annotations.

The annotation sources that you select are listed in the Available Annotation Sources list.

6. Add annotation sources to the annotation set.

Options Description

Use an existing source. | Select the checkbox next to each annotation source in Available Annotation
Sources list that you want to include in the annotation set.

Import a new custom Click 4+ Add New Source below the list, enter a name and version for the
source file in a TXT source, browse to and select the source file, then click Upload.

file. [1] The new sources are added to Available Annotation Sources list.

' You must have selected one of the following Available Annotation Sources:Gene Set (Custom), Genomic Regions
(Custom), Transcript Set (Custom), VariantDB (Custom).

7. After all of the annotation sources that you want to add to the annotation set are selected in the
Available Annotation Sources list, click Add » to move the annotation sources to the Selected
Annotation Sources list.

8. Review the list of selected annotation sources, then add or remove sources, if needed. To remove
a source from the Selected Annotation Sources list, select the checkbox, then click Remove X.

9. Click Save to save the annotation set.

The annotation set is listed in the Annotation Sets tab and is available when you create an assay.

Make custom annotation sets unavailable

Manager- and administrator-level users can make custom annotation sets unavailable in the software.

You cannot designate as obsolete system-installed annotation sets.

1. In the menu bar, click Assays » Manage Presets.

2. In the Annotation Sets tab, place the pointer over the row of the custom annotation set that you
want to make unavailable, then click Obsolete.

The annotation set status is Obsolete in the list of annotation sets.
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Updated versions of annotations

254

In Genexus™ Software, for some annotations, you can change the version of the annotation source that

is used by an assay.

When you use an assay with the setting of use the latest annotation set enabled, you can view
the version of the annotation set that is applied when you plan a run, reanalyze a sample or a run,
download files, view the run report screen, and view PDF reports.

You can enable or disable this setting when you perform the following actions in the software.

* Create an assay.
* Edit a draft assay.

* Place the pointer over the row of a locked assay in the Assays / Manage Assays screen.

Option

Description

Use Latest Annotations when you
create an assay

* When you enable this setting, the most recent version of the
annotation source that is available in the software is used by the
assay.

* When you disable this setting, the annotation that is associated
with the assay is used regardless of whether newer versions of the
annotation set are installed in the software.

This option is available only for some versions of some assays.

For more information, see “Panel step assay options” on page 222.

Use Latest Annotations when you
place the pointer over the row of
a locked assay in the Assays /
Manage Assays screen

The most recent version of the annotation source that is available in the
software is used by the assay for any new run plan. This means that
older run plans with this assay can use different versions of annotation
sources than future run plans.

Use Default Annotations when
you place the pointer over the row
of a locked assay in the Assays /
Manage Assays screen

The annotation set that is associated with the assay is used for any
new run plan to which the assay is applied, regardless of whether
newer versions of the annotation sources are installed in the software.

Get the latest annotation source (administrator)

An administrator-level user can get the latest additions, deletions, or changes to the Clinvar database in
Genexus™ Software. This is an example of an update from the Clinvar database.

In order to download and install a new version of the Clinvar database from the App Store, you must

first do the following.

* Configure a Thermo Fisher Connect account. For instructions, see “Configure a Thermo Fisher™
Connect Platform account with a QR code (manager/administrator)” on page 299.

* Ensure that the Genexus™ Integrated Sequencer has the latest software version of Genexus™

Software.

* Connect the Genexus™ Integrated Sequencer to the internet.

Genexus™ Software 6.8 User Guide



Chapter 9 Presets and panels (manager/administrator) B
Filters and filter chains

1. In the menu bar, click ¢ (Settings) » Software Updates, then click Software Updates in the
upper right corner.

The Software Updates screen opens with App Store enabled.

2. If needed, click the desired package name to view the installation details and version information in
the View Package Details pane.

3. Click Download in the Actions column in the row of the software package of interest.

Clinvar packages have a Category type of Configurations. Clinvar packages are named as
Clinvar <Release date>.

After the download is complete, the Download link changes to an Install link.
4. Click Install.
5. In the Install Annotation Source dialog box, click Yes.

6. When installation of the software package is complete, click Installed Software to verify the
installation.

Filters and filter chains

A filter chain is a set of filters that Genexus™ Software uses to narrow the list of variants that appear in a
sample result.

Genexus™ Software includes predefined filter chains that you can apply to results. Most system-
installed assays include default filter chains. For information about system-installed filter chains, see
“System-installed filter chains” on page 405.

You can apply filter chains to results to dynamically change the view of the variants, then save the
filter chain to the results, if needed. See “Filter results with a filter chain” on page 122. When you view
results, a more stringent filter yields fewer results and a less stringent filter yields more results.

If system-installed filter chains do not meet research needs, manager- and administrator-level users can
create custom filter chains. Alternatively, manager- and administrator-level users can copy, then edit, a
system-installed filter chain. Custom filter chains can be built from system-installed filter chains or from
one or more system-installed filters. For more information, see “Create a custom filter chain (manager/
administrator)” on page 256. When you create a custom filter chain, the filter chain is in draft status.
You can apply a draft filter chain to sample results. However, only reports that are generated with a filter
chain that is locked can be signed.

System-installed filters are based on public and proprietary annotation sources and data types that are
included in the software. For more information, see “System-installed filters” on page 406.
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Review filter chain details

A filter chain is a set of filters that Genexus™ Software uses to narrow the list of variants that are
included in results. Administrator-level users create custom filter chains from system-installed filters to
meet specific variant filtering needs.

After a run, you can review the details of the filter chains that were applied to the run. If the filter chain
does not meet your needs, you can adjust the settings or apply a different filter chain.

1. In the menu bar, click Assays » Manage Presets.
2. In the Manage Presets screen, click the Filter Chains tab.
3. Click a filter chain.

Review the following details:
* The version of the analysis pipeline used for the filter chain.
* Whether the filter chain is system-installed.
* The date that the filter chain was created.
* The filters that are included in the filter chain.
* The order in which the filters and/or filter chains contained within are applied.

Create a custom filter chain (manager/administrator)

256

Manager- and administrator-level users can create filter chains. A filter chain is a set of filters that you
apply to the variants identified in the results. Filter chains are used to narrow the results to only those
variants of interest.

1. In the menu bar, click Assays » Manage Presets.

2. In the Manage Presets screen, click the Filter Chains tab.

3. Click + Add New.

4. In the Create Filter Chains screen, enter a name for the new filter chain.

5. Select the Genome Reference for the filter chain.
The default reference is hg19.

6. In the Annotation Sets list, select an annotation set to limit the list of filters, if needed. Then, enter
the full or a partial name of an annotation set in the search field.

By default, no annotation set is selected. If you do not select an annotation set, all filters are
available for you to select. If you select an annotation set, the filters that are available are limited by
the selected annotation set.

7. Click Add description to add information, if needed.
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8. In the Add Filter dropdown list, select a system-installed filter, then enter the full or a partial name
of afilter in the search field.

If the list does not populate with the filters available in the software, restart the sequencer.
a. Select the NOT checkbox to exclude the selected items, if needed.

b. Make more selections, if needed.
Filters are grouped by the type of filter.

* Genes & Variants * Annotation Sources
¢ Population Frequencies * Functional Scores
* Metrics * Other

For more information, see “System-installed filters” on page 406.

9. Repeat step 8 for each filter that you want to add to the filter chain.
a. Select AND, OR, or NOT for each filter that you add.

b. Make changes to the selections, if needed.
* Click {x] Clear to remove all selections for the filter.
* Click X Cancel to remove the filter from the filter chain.

c. Click @ Update to add the filter to the filter chain.

10. Place the pointer over a filter description, then make the following changes, if needed.
* Click £ Group to create a group of filters. For more information, see “Create a custom filter
chain with groups (manager/administrator)” on page 258.

¢ Click @ Edit to make changes to the filter. For more information, see “Edit a filter chain
(manager/administrator)” on page 260.

e Click [i] Delete to delete the filter.

11. Click Save.
A confirmation message appears, and the new filter chain is listed in the Filter Chains table and is

available for selection when you view results. For more information, see “Filter results with a filter
chain” on page 122.

The filter chain is in draft status.

You can lock the filter chain if needed. Locked filter chains cannot be edited or deleted. For more
information, see “Lock a filter chain (manager/administrator)” on page 261.
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Create a custom filter chain with groups (manager/administrator)

258

Manager- and administrator-level users can create filter chains with groups. Filter chains with groups
include Boolean operators so that you can create more complex filter chains. You can group filters
together to combine a subset of requirements when you create a custom filter chain.

This is an example of a custom filter chain created with groups. When applied to a sample result, the
filter chain in this example returns all variants that are CNV variants of the ERBB2 gene as well as all
BigDel or BigDup variants of the BRCA1 gene.

1.

2.

8.

In the menu bar, click Assays » Manage Presets.

In the Manage Presets screen, click the Filter Chains tab.

Click 4+ Add New.

In the Create Filter Chains screen, enter a name for the new filter chain.

Change the Genome Reference for the filter chain, if needed.

The default reference is hg19.

In the Annotation Sets list, select an annotation set to limit the list of filters, if needed.
* In the search field, enter the full or a partial name of an annotation set.

By default, no annotation set is selected. If you do not select an annotation set, all filters are
available for you to select. If you select an annotation set, the filters that are available are limited by
the selected annotation set.

Add a filter group.
a. In the Add Filter dropdown list, select Variant Type.

b. In the list of annotations that appears, select CNV, then click [ Update to add the filter.
Information about the filter that you have created appears.

c. Place the pointer over the information for the new filter, then click & Create Group.
The information that you have added appears in a new pane for the group.

d. In the new pane that appears, in the dropdown list of filters, select Gene Symbol.
e. In the search field that appears, enter ERBB2, then select ERBB2.

f. Click @ Update to group the gene symbol filter with the variant type.
The filter group of a CNV Variant Type AND ERBB2 Gene Symbol is added to the filter chain.

Add another filter group.
a. In the dropdown list of filters for a new group, select Gene Symbol.

Ensure that you select the filter list that is associated with the group. The parentheses in
the information for the groups indicate the start and the end of the groups. In addition, the
indentation of the dropdown lists for the filters indicates the group.
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b. In the new pane that appears, click OR, then, in the search field, enter BRCA1, then select
BRCAH1, then click [ Update to add the filter.
Information about the filter that you have created appears.

c. Place the pointer over the information for the BRCAT1 filter, then click & Create Group.

d. In the new pane that appears, click AND, then, in the dropdown list of filters, select Variant
Subtype.

e. Select BigDel and BigDup, then click [ Update to add the filter.
The filter group of an BigDel and BigDup variants of the BRCA1 gene is added to the filter
chain.

9. Click Save.

A confirmation message appears, and the new filter chain is listed in the Filter Chains table and is
available for selection when you view results. For more information, see “Filter results with a filter chain”
on page 122.

Query

(Variant Type = CNV

(: ) AND Gene Symbol=ERBB2)

Add Filter v C?
OR (Gene Symbol =BRCA1

[Z Edit [ Delete & Create group ‘

AND Variant Subtype = BigDel, BigDup)

: Add Filter v

‘ Variant Subtype v

Figure 10 Example of a filter chain with groups

@ A group of filters in the filter chain.
@ Another group of filters in the filter chain.
@ Actions that are available when you place the pointer over the row of the filter.

Copy a filter chain (manager/administrator)

Manager- and administrator-level users can copy then edit a filter chain. To customize a system-
installed filter chain, copy the locked system-installed filter chain, then make changes.

1. In the menu bar, click Assays » Manage Presets.
2. Inthe Assays / Manage Presets screen, click the Filter Chains tab.

3. Place the pointer over the row of the filter chain of interest, then click Copy.
The Copy Filter Chain screen opens. The presets can be modified for the new filter chain.
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Change the software-generated name of the filter chain and make changes, if needed. For more
information, see “Create a custom filter chain (manager/administrator)” on page 256.

Click Save.
The new filter chain is added to the Filter Chains tab.

The filter chain is available to apply to sample results.

Edit a filter chain (manager/administrator)

Manager- and administrator-level users can edit custom filter chains in Genexus™ Software. Only
custom filter chains that are not locked can be edited. System-installed filter chains are always locked
and cannot be edited. When you edit a filter chain that is applied to sample results, the changes that
you make apply to all sample results to which the filter chain is applied.

1.

2.

5.

Click Assays » Manage Presets.
In the Assays / Manage Presets screen, click the Filter Chains tab.
Place the pointer over the row of the filter chain of interest, then click Edit.

In the Edit Filter Chains screen, make changes. For more information, see “Create a custom filter
chain (manager/administrator)” on page 256.

Click Save.

The updated filter chain is available to apply to sample results.

Delete a filter chain (manager/administrator)

Manager- and administrator-level users can delete custom filter chains that have a draft status in
Genexus™ Software. System installed filter chains are always locked and cannot be deleted. Only
custom filter chains that are not locked can be deleted. If a filter chain is saved with a sample result,
you cannot delete the filter chain.

1.

2.

4.

Click Assays » Manage Presets.
In the Assays / Manage Presets screen, click the Filter Chains tab.

In the Filter Chains table, place the pointer over the row of the filter chain that you want to delete,
then click Delete.

The Delete Filter Chain dialog box opens with the message Are you sure that you want to
delete the filter chain?

In the Delete Filter Chain dialog box, click Yes to delete the filter chain.

The filter chain is removed from the software and is no longer listed in the Filter chains table.

260
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Lock a filter chain (manager/administrator)

Manager- and administrator-level users can lock custom filter chains in Genexus™ Software. Custom
filter chains that are locked cannot be edited or deleted. System installed filter chains are always

locked.

1. Click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Filter Chains tab.

3. In the Filter Chains table, place the pointer over the row of the filter chain that you want to lock,

then click Lock.
The Lock Filter Chain dialog box opens with the message Are you sure that you want to lock

the filter chain?
4. In the Lock Filter Chain dialog box, click Yes to lock the selected filter chain.

The filter chain is now locked and cannot be edited or deleted.

You can obsolete the locked, custom filter chain, if needed.

Obsolete a custom filter chain

Manager- and administrator-level users can make locked, custom filter chains unavailable in the
software. You cannot designate as obsolete system-installed filter chains.

When you obsolete a filter chain, no change is made to sample results that already have the filter chain
applied.

1. Click Assays » Manage Presets.

2. In the Filter Chains tab, place the pointer over the row of the filter chain that you want to make
unavailable, then click Obsolete.

The filter chain status is Obsolete and is not available to apply to sample results.

Review and export a filter chain history (manager/administrator)
Manager- and administrator-level users can review, export, or print the entire history of changes for a
filter chain. The history shows the original values and any new values or activities.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. In the menu bar, click Assays » Manage Presets.
2. In the Manage Presets screen, click the Filter Chains tab.

3. Place the pointer over the row of the filter chain of interest, then click Audit.
The Audit Details screen opens with time-stamped audit records that include details and changes
for each action performed on the filter chain. For more information, see “Details in the audit record

for a filter chain” on page 262.
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Option

Description

Review the audit trail details.

Each action that was performed for the filter chain, such as filter
chain creation or edits, is listed.

Export the audit record.

Click Download to generate a PDF file. Depending on the
browser settings, the software automatically downloads the file or
prompts you to open or save the file.

Close the Audit Details screen. Click < Back to return to the Manage Presets screen.

Details in the audit record for a filter chain

The Audit Details screen for filter chains shows the actions that are performed on a filter chain.

Details in the audit record

Item Description
User name The name of the person who was signed in when the action was
performed. System-installed filter chains are indicated.
Filter Chain The name of the filter chain.

Data Object Name

Filter chain.

Action Performed

Actions performed on the filter chain include:

* Create * Delete
e Edit * Obsolete
¢ Lock

Time Stamp The time and date of the action.

ID An identifier to represent a specific action in the audit record. Each
action in the audit record includes a unique identifier.

Description The description entered when the filter chain was created.

Reference The reference genome for the filter chain.

New Values A list of new values in the filter chain for the listed action. If a value
changed as a result of the action, the new value is shown. If no change
was made, the value is listed as NA for the action.

Old Values A list of the previous values in the filter chain. Values are listed for

actions that resulted in a change.
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Custom filter chain examples (manager/administrator)

Manager- and administrator-level users can create custom filter chains for use in Genexus™ Software.

Create a gene symbol filter chain (manager/administrator)

Manager- and administrator-level users can create a custom filter chain that is based on gene symbols.
This is an example of a filter chain that narrows results to only specific genes. For more information, see
“Gene Symbol filter” on page 407.

1. In the menu bar, click Assays » Manage Presets.

2. In the Manage Presets screen, click the Filter Chains tab.

3. Click + Add New.

4. Inthe Create Filter Chains screen, enter a name and optional description.

5. Select the Genome Reference for the filter chain.
The default reference is hg19.

6. In the Annotation Sets list, select an annotation set to limit the list of filters, if needed.
7. In the Add Filter list, select the Gene Symbol filter.

8. Enter genes of interest in the search field, then in the list that appears, select the checkbox for
each gene symbol that you want to add.

9. After you select the gene symbols that you want to include, click [z Update.
The selected genes are added to the filter chain.

10. Click Save.

The filter chain can be applied to results to refine the variants that appear. For more information, see
“Filter results with a filter chain” on page 122.

Create a COSMIC ClinVar and Variant Impact filter chain (manager/administrator)

Manager- and administrator-level users can create a custom filter chain that includes both annotation
source filters and variant data type filters. This procedure shows how to create a COSMIC, ClinVar,
Allele Fraction, and Variant Effect filter chain. In addition, this example shows how to include
unannotated variants in the filter chain. Unannotated variants are variants that do not have annotation
information in the annotation source. If you include unannotated variants in a filter in the filter chain,
variants that are not annotated by that filter are listed in the results when the filter chain is applied.

1. In the menu bar, click Assays » Manage Presets.
2. In the Manage Presets screen, click the Filter Chains tab.
3. Click + Add New.

4. In the Create Filter Chains screen, enter a name and for the filter chain.
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5. Select the Genome Reference for the filter chain.

The default reference is hg19.

6. In the Annotation Sets list, select an annotation set to limit the list of filters, if needed.

7. Select the filters to add to the filter chain.
To include unannotated variants in the results, select Include Unannotated for each filter

selection.

a. In the Add Filter list, select a version of the COSMIC filter.

b. Select the annotations that you want to include in the filter.
For more information, see “Create a custom filter chain (manager/administrator)” on page 256
and “COSMIC filter” on page 415.

c. Click @ Update.

d. In the Add Filter list, select a version of ClinVar.

e. Select the annotations that you want to include in the filter.
For more information, see “Clinvar filter” on page 415.

f. Click @ Update.

d. In the Add Filter list, select Allele Frequency.

h. Enter a range value.
For more information, see “Allele Frequency filter” on page 419.

i. Click @ Update.

j- Inthe Add Filter list, select Variant Effect.

k. Select the value that you want to include in the filter to detect the effect of variants on coding
sequences.
For more information, see “Variant Effect filter” on page 409.

I. Click @ Update.

8. Click Save.

The filter chain can now be applied to results. For more information, see “Filter results with a filter chain”
on page 122.
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Create a PValue/dbSNP/Variant Type filter chain (manager/administrator)

Manager- and administrator-level users can create a custom filter chain with multiple filters. This
example shows how to create a filter chain with PValue, dbSNP, and Variant Effect filters.

1. In the menu bar, click Assays » Manage Presets.
2. In the Manage Presets screen, click the Filter Chains tab.
3. Click + Add New.

4. In the Create Filter Chains screen, enter a name and optional description.
The default reference is hg19.

5. In the Add Filter list, select the filters to add to the filter chain.

a. Select the PValue filter, select Between, Greater than or equal to, or Less than or equal to,
enter a range, then click [ Update.

b. Select a version of dbSNP, then click (& Update.

c. Select Variant Effect, in Select Specific Annotations, select In or Contains, then select the
annotations to include in the filter to detect the effect of variants on coding sequences, then
click [ Update.

6. Click Save.

Your filter chain can now be applied to results. For more information, see “Filter results with a filter
chain” on page 122.

Copy number baselines (manager/administrator)

A copy number baseline is a set of control samples that are used to create a baseline for the detection
of copy number variants (CNVs). A copy number baseline is associated with a panel file in the software.
CNV analysis is based on reads counts for each amplicon.

Known sources of variability include pool imbalance (when an assay has more than one pool of
amplicons), total number of reads, per-amplicon attributes of GC proportion, and length of the amplicon
insert. In practice, we observe other variability that does not associate with known attributes yet is
systematic.

Copy number estimates are made using a proprietary algorithm.

Genexus™ Software includes predefined copy number baselines.
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Manager- and administrator-level users can perform the following functions related to copy humber

baselines.

Option See the following section for more information
View details for system-installed, or custom, copy “View copy number baseline details (manager/
number baselines. administrator)” on page 266
View the panel associated with a copy number “Panel files (manager/administrator)” on page 286
baseline.
Create a copy number baseline. “Create a copy number baseline (manager/

administrator)” on page 267

Create a copy number baseline that uses an existing | “Copy a copy number baseline (manager/
copy number baseline as the base administrator)” on page 270

View or add notes to a copy humber baseline “View, add, or remove a note in a copy humber
baseline (manager/administrator)” on page 271

Augment a copy number baseline. “Augment a copy number baseline with more
samples (manager/administrator)” on page 269

Import a copy number baseline. “Import a copy number baseline (manager/
administrator)” on page 271

Export a copy number baseline that has been “Export a custom copy number baseline (manager/
created in the software or imported into the software | administrator)” on page 273

Delete a copy number baseline that fails during job “Delete a copy number baseline (manager/
creation administrator)” on page 272

Download log files “Download the log files for copy humber baseline
creation (manager/administrator)” on page 272

Remove copy number baselines that are not system- | “Remove a copy number baseline (manager/
installed. administrator)” on page 273

View copy number baseline details (manager/administrator)

Manager- and administrator-lever users can view details for the system-installed copy number
baselines, or for custom copy number baselines.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Copy Number Baselines tab.

The Copy Number Baselines table lists both system-installed and custom copy number
baselines.

266 Genexus™ Software 6.8 User Guide



Chapter 9 Presets and panels (manager/administrator) Bz
Copy number baselines (manager/administrator)
3. Click the name of a copy number baseline.

4. Review the details in the Copy Number Baseline Details pane.

The details that are shown depend on the setup of the copy number baseline. Parameters used to
create copy number baselines are also shown, but are not listed in this table.

Copy Number Baseline Details

Item Description

Created By Sign-in name of the person who created the baseline. System-installed
baselines are included with the software.

Created On Date on which the baseline was created.

Number of Normal Samples | The number of normal samples that are included in the baseline.

Gender The biological sex of the sample: Female, Male, or Unknown.
Number of Samples The total number samples that are included in the baseline.
Amplification Type Library amplification technology that is used in the baseline (lon AmpliSeq™

or lon AmpliSeq™ HD).

Panel Name Name of the panel that is included in the baseline.
Reference The reference genome for the baseline.
Reference File Name The name of the reference genome file that is used in the baseline.

You can click --- (More Options) to perform more actions, such as obsolete, export, copy, edit, or audit
the copy number baseline. The options that are available depend on whether the copy number baseline
is system-installed or is a custom copy number baseline.

The actions for each baseline are also available in the Copy Number Baselines table when you place
the pointer over the row of a copy number baseline.

Create a copy number baseline (manager/administrator)

Manager- and administrator-level users can create a copy nhumber baseline.

IMPORTANT! Use the default parameter settings unless you are an advanced user. Contact a Field
Bioinformatics Specialist (FBS) for help.

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Copy Number Baselines tab.
3. Click + Add New.

4. Select the type of library for the copy number baseline.

* AmpliSeq - Create a copy number baseline for lon AmpliSeg™ libraries.
* AmpliSeq HD - Create a copy number baseline for lon AmpliSeg™ HD libraries.
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The baseline creation tool opens in the Panel step.
Use the Next and Previous buttons to navigate the screens to configure the baseline.

5. Complete the Panel step.

6.

8.

a.

Enter a name in the Copy Number Baseline Name field.
The name is limited to 50 characters and no spaces are allowed.

Leave Augment an Existing Copy Number Baseline as Base unselected.

For information to Augment an Existing Copy Number Baseline as Base, see “Augment a
copy number baseline with more samples (manager/administrator)” on page 269.

. Select the panel.

Select CNV VCIB in Algorithm Type.

. (Optional) Enter information about the baseline into the Description field.

Click Next.

In the Parameters step, accept the default settings or adjust the appropriate parameters, then
click Next.

In the Samples step, select samples for the baseline.

All of the samples that have been run with the selected panel are listed.

If you do not select the minimum number of samples that are required for the baseline, an error
message appears and you cannot proceed. You can adjust the Minimum number of samples
required to add to an existing baseline parameter in the CNV Baseline Creation section of the
Parameters step.

a.

b.

C.

Select the checkbox next to each sample to use for the baseline.

Click § inthe Normal Sample column to designate a selected sample as "Normal" in the
baseline.

The tube icon changes to green. A Normal Sample is designated with [ .

If you do not designate the minimum number of normal samples that are required for the
baseline, an error message appears and you cannot proceed.

Click Next.

In the Review step, review the selections, then click Save.
The new copy number baseline is added to the Copy Number Baselines tab.

Copy number baselines that have a State of Completed are available for selection when an assay is
created or copied and edited. Copy number baselines can only be added to DNA and Fusions, DNA
Somatic and DNA Germline assays.

If the State of a copy number baseline is Failed, place the pointer over the row of the copy number
baseline and click View Log to open the log in a separate browser tab. The log file can help with
troubleshooting if the baseline creation job fails.
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Augment a copy number baseline with more samples
(manager/administrator)

Manager and administrator-level users can augment an existing copy number baseline. The newly
created copy number baseline is saved with a new name and is listed as a new copy number baseline;
the original copy number baseline used as a base remains unchanged in the software.

When a baseline is augmented with the addition of samples, new samples are run, the size of each
systematic affect encoded in the baseline is estimated, and a correction is applied to remove the effect.
Any added samples cannot be designated as a Normal Sample and should be diverse so as to capture
likely systematic variation.

IMPORTANT! Use the default parameter settings unless you are an advanced user. Contact a Field
Bioinformatics Specialist (FBS) for help.

1.

In the menu bar, click Assays » Manage Presets.
In the Assays / Manage Presets screen, click the Copy Number Baselines tab.
Click 4+ Add New.

Select the type of library for the copy number baseline.

* AmpliSeq - Create a copy number baseline for lon AmpliSeg™ libraries.
* AmpliSeq HD - Create a copy nhumber baseline for lon AmpliSeq™ HD libraries.

The baseline creation tool opens in the Panel step.
Use the Next and Previous buttons to navigate the screens to configure the baseline.

Complete the Panel step.
a. Enter a name in the Copy Number Baseline Name field.
The name is limited to 50 characters and no spaces are allowed.

b. Select the panel.

c. Select Augment an Existing Copy Number Baseline as Base, then select the baseline you
would like to edit or augment.

d. Select CNV VCIB in Algorithm Type.
e. (Optional) Enter information about the baseline into the Description field.
f. Click Next.

In the Parameters step, accept the default settings or adjust the appropriate parameters, then
click Next.

In the Samples step, select samples for the baseline.
All of the samples that have been run with the selected panel are listed.

Genexus™ Software 6.8 User Guide 269



5§  Chapter 9 Presets and panels (manager/administrator)
Copy number baselines (manager/administrator)

If you do not select the minimum number of samples that are required for the baseline, an error
message is displayed and you cannot proceed. You can adjust the Minimum number of samples
required to add to an existing baseline parameter in the CNV Baseline Creation section of the
Parameters step.

a. Select the checkbox next to each sample to use for the baseline.
b. Click Next.

8. In the Review step, review the selections, then click Save.
The new copy number baseline is added to the Copy Number Baselines tab.

Augmented copy number baselines that have a State of Completed are available for selection when an
assay is created or copied and edited. Copy number baselines can only be added to DNA and Fusions,
DNA Somatic and DNA Germline assays.

If the State of a copy number baseline is Failed, place the pointer over the row of the copy number
baseline and click View Log to open the log in a separate browser tab. The log file can help with
troubleshooting if the baseline creation job fails.

Copy a copy number baseline (manager/administrator)

Manager- and administrator-level users can copy then edit a copy number baseline.

—

. In the menu bar, click Assays » Manage Presets.
2. Inthe Assays / Manage Presets screen, click the Copy Number Baselines tab.

3. Place the pointer over the row of the copy number baseline that you want to copy, then click
Copy.
The Copy Copy Number Baseline screen opens to the Panel step. The settings and samples that
are included can be modified for the new baseline.

4. Change the software-generated name of the baseline, proceed through the workflow steps, and
modify settings, if needed. For more information, see “Augment a copy number baseline with more
samples (manager/administrator)” on page 269.

5. In the Review step, review the selections, then click Save.
The new copy number baseline is added to the Copy Number Baselines tab.

The copy number baseline is available for selection when an assay is created or copied and edited.

Copy number baselines can only be added to DNA and Fusions, DNA Somatic and DNA Germline
assays.
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View, add, or remove a note in a copy humber baseline (manager/
administrator)

Manager- and administrator-level users can add notes to a copy humber baseline or view existing
notes. Use Notes to capture time-stamped written comments and observations for a copy number
baseline. A copy number baseline can contain multiple notes from different users.

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Copy Number Baselines tab.

3. Place the pointer over the row of the copy number baseline of interest, click Notes, then review
existing notes or add a new note.

Action Description

View existing notes for a | In the Add Notes dialog box, notes that are associated with the copy
copy number baseline. | number baseline are listed by user, date, and time.

Add a new note to a 1

: . In the Add Notes dialog box, click + Add Note.
copy number baseline.

2. Enter the note, then click Save.
The note is added to the copy number baseline and includes the username

for the account of the person who entered the note, and a timestamp that
records the note entry date and time.

Delete a copy number In the Add Notes dialog box, in the row of the note that you want to delete,
baseline note click Tl (Delete).

Click Close to return to the Manage Presets screen.

Import a copy nhumber baseline (manager/administrator)

Manager- and administrator-level users can import a copy number baseline. Two types of files are
supported:

e H5
e ZIP

For ZIP files, the panel must be available in the software before you import the copy number baseline.
For more information, see “Panel files (manager/administrator)” on page 286.
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1. In the menu bar, click Assays » Manage Presets.
2. Inthe Assays / Manage Presets screen, click the Copy Number Baselines tab.

3. Click Import Copy Number Baseline in the top right of the screen.

Option Description
Importa | 4 | File Type, select ZIP.
ZIPfile 1 5 Glick Select Copy Number Baseline file.
3. Browse for and select the file.
4. Click Upload.
Impc?rt an | 1. In File Type, select H5.
HS5 file 2. Inthe Panel list, select the panel.
3. Click Select Copy Number Baseline file.
4. Browse for and select the file.
5. Click Upload.

A message confirms that the file import was successful when the file import is complete.

Imported copy number baselines are available for selection when an assay is created or copied and
edited. Copy number baselines can only be added to DNA and Fusions, DNA Somatic and DNA
Germline assays.

Download the log files for copy number baseline creation
(manager/administrator)

Manager- and administrator-level users can download and view log files that show the details for copy
number baseline creation. The log files are available after the copy number baseline creation job is
complete.

1. In the menu bar, click Assays » Manage Presets.
2. Inthe Assays / Manage Presets screen, click the Copy Number Baselines tab.

3. Place the pointer over the row of the custom copy number baseline of interest, then click
Download Log.

Delete a copy number baseline (manager/administrator)

If a copy humber baseline fails during job creation, it can be deleted from the software by a manager-
and administrator-lever user.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Copy Number Baselines tab.
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3. Place the pointer over the row of a failed copy number baseline, then click Delete.
The Delete Copy Number Baseline dialog box opens with the message Are you sure that you
want to delete this Copy Number Baseline?

4. Click Yes to delete the copy number baseline.

The failed copy number baseline is removed from the software and is no longer listed in the Copy
Number Baselines table.

Export a custom copy number baseline (manager/administrator)

Manager- and administrator-level users can export copy humber baselines that have been created,
copied and edited, or imported in Genexus™ Software. Only custom copy number baselines can be
exported. System installed copy number baselines cannot be exported.

A copy number baseline can be exported, for example to use that copy number baseline in another
Genexus™ Integrated Sequencer.

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Copy Number Baselines tab.

3. Place the pointer over the row of the copy number baseline that you want to export, then click
Export.

The copy number baseline files are downloaded as a ZIP file and are available for import to another
sequencer.

Remove a copy number baseline (manager/administrator)

Manager- and administrator-level users can make copy number baselines unavailable in the software.
You cannot designate as obsolete system-installed copy number baselines.

1. In the menu bar, click Assays » Manage Presets.
2. Inthe Assays / Manage Presets screen, click the Copy Number Baselines tab.

3. Place the pointer over the row of the copy number baseline that you want to make unavailable,
then click Obsolete.

The copy number baseline is Obsolete in the list of copy number baselines.
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Sequence variant baselines

A sequence variant baseline is used to reduce the number of false positives for panels that detect
somatic variants.

Variant calling filters in Genexus™ Software suppress and remove most sequencing errors. However, it
is possible that some errors can pass through the filters and be reported as false positives. In somatic
panels, sequencing errors that survive filtering are reported as false positives that require investigation.

A sequence variant baseline is a BED file that contains a list of alleles that are known sequencing errors.
The baseline file includes detailed properties for each sequencing error. The errors and properties

are based on known germline normal samples. When added to an assay in Genexus™ Software, the
baseline detects and filters out the errors in sequencing that could lead to false positive variant calls.

Genexus™ Software includes predefined sequence variant baselines.

You can also create a custom sequence variant baseline.

View sequence variant baseline details (manager/administrator)

274

Manager- and administrator-lever users can view details for custom sequence variant baselines. You
can view the name of a system installed sequence variant baseline file for an assay in the Variant
Finding section of the Parameters step when you copy an assay.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Sequence Variant Baselines tab.
The Sequence Variant Baselines table lists custom sequence variant baselines.

3. Click the name of a sequence variant baseline.

Review the details in the Sequence Variant Baselines pane. The details that are shown depend on the
setup of the sequence variant baseline. Parameters used to create sequence variant baselines are also
shown, but are not listed in this table.

Sequence variant baseline details

Item Description
Created By Sign-in name of the person who created the baseline.
Created On The date the baseline was created.

Number of Samples The number of samples that are included in the baseline.

Ampilification Type Library amplification technology that is used in the baseline (lon AmpliSeg™ or lon
AmpliSeg™ HD).

Panel Name The name of the panel that is included in the baseline.
Chip Type The semiconductor sequencing chip for the panel and baseline.
Reference The reference genome for the panel and baseline.
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You can click --- (More Options) to perform more actions, such as obsolete, export, copy, edit, or audit
the sequence variant baseline.

The actions for each baseline are also available in the list of Sequence Variant Baselines when you
place the pointer over the row of a sequence variant baseline.

Create a sequence variant baseline (manager/administrator)

Manager- and administrator-level users can create a sequence variant baseline (SVB) if system-installed
sequence variant baselines do not meet research needs. You can add the custom baseline to an assay
to use as a baseline for a run.

IMPORTANT! Use the default parameter settings unless you are an advanced user. Contact a Field
Bioinformatics Specialist (FBS) for help.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Sequence Variant Baselines tab.

3. Click + Add New.

4. Complete the Panel step.

a.

d.

e.

Enter a name in the Sequence Variant Baseline Name field.
The name is limited to 50 characters and no spaces are allowed.

Select or leave Augment an Existing Sequence Variant Baseline as Base unselected.

* Select Augment an Existing Sequence Variant Baseline as Base, then select an SVB
from the dropdown list to use the existing sequence variant baseline as a starting point
for the new baseline.

* Leave Augment an Existing Sequence Variant Baseline as Base unselected to create a
new baseline.

. Select the panel.

(Optional) Enter information about the baseline into the Description field.

Click Next.

5. In the Parameters step, accept the default settings or adjust the appropriate parameters, then
click Next.

6. In the Samples step, select at least 40 DNA, DNA & RNA, or TNA samples for the baseline.
The samples that you select must have the same library chemistry, chip type, and flow order.

7. In the Review step, review the selections, then click Launch.
The new sequence variant baseline is added to the Sequence Variant Baselines list.
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Sequence variant baselines with a State of Completed are available for selection when an assay is
created or copied and edited. For assays that are compatible with the sequence variant baseline, you
can select the sequence variant baseline file in the Variant Finding section of the Parameters step, in
the Analysis SVB File dropdown list.

If the State of a sequence variant baseline is Failed, place the pointer over the row of the sequence
variant baseline and click View Log to open the log in a separate browser tab. The log file can help with
troubleshooting if the baseline creation job fails.

Copy a sequence variant baseline (manager/administrator)

Manager- and administrator-level users can copy then edit a sequence variant baseline. You cannot
copy sequence variant baselines that have been imported.

1. In the menu bar, click Assays » Manage Assays.

2. In the Manage Assays screen, place the pointer over the row of the sequence variant baseline that
you want to copy, then click Copy.

The Copy Sequence Variant Baseline screen opens to the Panel step with the panel and samples
predefined. The settings and samples that are included can be modified for the new baseline.

3. Change the software-generated name of the baseline if needed, proceed through the workflow
steps, and modify settings. For more information, see “Create a sequence variant baseline
(manager/administrator)” on page 275.

4. Inthe Review step, review the selections, then click Launch.

The new sequence variant baseline is added to the Sequence Variant Baseline list. When the State
of the SVB is Completed and the Status is Locked, the sequence variant baseline is available for
selection when an assay is created or copied and edited.

For assays that are compatible with the sequence variant baseline, you can select the sequence variant
baseline file in the Variant Finding section of the Parameters step, in the Analysis SVB File dropdown
list. For more information, see “Create an assay (manager/administrator)” on page 219.

Import a sequence variant baseline (manager/administrator)

Manager- and administrator-level users can import a sequence variant baseline. Two types of files are
supported:

e ZIP
e BED
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1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Sequence Variant Baselines tab.

3. Click Import Sequence Variant Baseline in the top right of the screen.

N

I C)

Option

Description

Import a ZIP file

b=

In File Type, select ZIP.

Click Select Sequence Variant Baseline file.
Browse for and select the file.

Click Upload.

Import a BED file

2B o

In File Type, select BED.

Enter a name for the baseline.

In the Panel list, select the panel.

Click Select Sequence Variant Baseline file.
Browse for and select the file.

Click Upload.

A message confirms that the file import was successful when the file import is complete.

The imported sequence variant baseline is added to the Sequence Variant Baseline list. When the

State of the SVB is Completed and the Status is Locked, the sequence variant baseline is available for
selection when an assay is created or copied and edited.

For assays that are compatible with the sequence variant baseline, you can select the imported
sequence variant baseline file in the Variant Finding section of the Parameters step, in the Analysis
SVB File dropdown list. For more information, see “Create an assay (manager/administrator)” on

page 219.
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View, add, or remove a note in a sequence variant baseline (manager/
administrator)

Manager- and administrator-level users can view existing notes or add notes to a sequence variant
baseline. Use notes to capture time-stamped written comments and observations for a sequence
variant baseline. A sequence variant baseline can contain multiple notes from different users.

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Sequence Variant Baselines tab.

3. Place the pointer over the row of the sequence variant baseline of interest, click Notes, then review
existing notes or add a new note.

Action Description

View existing notes In the Add Notes dialog box, notes that are associated with the sequence

for a sequence variant variant baseline are listed by user, date, and time.

baseline.

Add a new note to 1. In the Add Notes dialog box, click-+ Add Note.

a sequence variant 2. Enter th te. th lick S

baseline. . Enter the note, then click Save.
The note is added to the sequence variant baseline and includes the
username for the account of the person who entered the note, and a
timestamp that records the note entry date and time.

Delete a sequence In the Add Notes dialog box, in the row of the note that you want to delete,

variant baseline note click Tl (Delete).

Click Close to return to the Manage Presets screen.

Download the log files for sequence variant baseline creation
(manager/administrator)

Manager- and administrator-level users can download and view log files that show the details for

sequence variant baseline creation. Log files include ERR, TXT and JSON files. The log files are
available after the copy number baseline creation job is complete.

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Sequence Variant Baselines tab.

3. Place the pointer over the row of the custom sequence variant baseline of interest, then click
Download Log.
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Delete a sequence variant baseline (manager/administrator)

If a custom sequence variant baseline fails or is terminated during job creation, the sequence variant
baseline can be deleted from the software by a manager- or administrator-lever user.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Sequence Variant Baselines tab.
3. Place the pointer over the row of a failed sequence variant baseline, then click Delete.
4. Inthe Delete Sequence Variant Baseline dialog box, click Yes to confirm the deletion.

The failed or terminated sequence variant baseline is removed from the software and is no longer
included in the Sequence Variant Baselines table.

Export a custom sequence variant baseline (manager/administrator)

Manager- and administrator-level users can export sequence variant baselines that have been created,
copied and edited, or imported in Genexus™ Software. Only custom sequence variant baselines can be

exported.

A sequence variant baseline can be exported, for example to use that sequence variant baseline in
another Genexus™ Integrated Sequencer.

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Sequence Variant Baselines tab.

3. Place the pointer over the row of the sequence variant baseline that you want to export, then click
Export.

The sequence variant baseline files are downloaded as a ZIP file and are available for import to another
sequencer.

Remove a sequence variant baseline (manager/administrator)

Manager- and administrator-level users can make custom sequence variant baselines unavailable in the
software.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Sequence Variant Baselines tab.

3. Place the pointer over the row of the sequence variant baseline that you want to make unavailable,
then click Obsolete.

The status of the sequence variant baseline is Obsolete in the list of sequence variant baselines and is
unavailable for selection during assay creation.
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Exon tile assay baselines

An exon tile assay baseline is used to model the amplicon expression variation within a gene. When
added to an assay in Genexus™ Software, the exon tile fusion baseline normalizes a test sample,
corrects the coverage in exon-tile amplicons, and identifies the presence or absence of expression
imbalance in a gene. Exon tile assay baselines that you have created can only be incorporated into
some assays. Contact a Field Bioinformatics Specialist (FBS) for guidance.

An exon tile assay baseline is a TXT file that contains the following items.
* The normalized expression values of exon-tile amplicons for genes with imbalance assays.
* The median normalized expression for each amplicon.

Exon tile assay baselines are associated with a panel BED file in the software.

Genexus™ Software includes predefined exon tile assay baselines.

You can also create an exon tile assay baseline in the software. You can later add the exon tile fusion
baseline to an assay and use it as a baseline control for analyses.

An exon tile assay baseline must include at least 40 RNA, DNA & RNA, or TNA samples. Various
parameters and thresholds used in the baseline computation determine the inclusion or exclusion of
samples in the baseline for each of the genes, for example, ALK, RET, NTRK1.

View exon tile assay baseline details (manager/administrator)
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Manager- and administrator-lever users can view details for the system-installed exon tile assay
baselines, or for custom exon tile assay baselines.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Exon Tile Assay Baselines tab.

The Exon Tile Assay Baselines table lists both system-installed and custom exon tile assay
baselines.

3. Click the name of an exon tile assay baseline.

Review the details in the Exon Tile Assay Baselines pane.

The details that are shown depend on the setup of the exon tile assay baseline. Parameters used to
create exon tile assay baselines are also shown, but are not listed in this table.

Exon Tile Assay Baselines

Item Description

Created By Sign-in name of the person who created the baseline. System-installed
baselines are included with the software.

Created On Date on which the baseline was created.

Number of Samples The total number samples that are included in the baseline.
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Exon Tile Assay Baselines (continued)

Item Description

Ampilification Type Library amplification technology that is used in the baseline.

Note: This applies only to lon AmpliSeq™ or lon AmpliSeq™ HD.

Panel Name Name of the panel that is included in the baseline.

Reference The file name of the fusion reference for the baseline.

You can click --- (More Options) to perform more actions, such as obsolete, export, copy, edit, or
audit the exon tile assay baseline. The options that are available depend on whether the exon tile assay
baseline is system-installed or is a custom exon tile assay baseline.

The actions for each baseline are also available in the list of Exon Tile Assay Baselines when you
place the pointer over the row of a exon tile assay baseline.

Create an exon tile assay baseline (manager/administrator)

Manager- and administrator-lever users can create custom exon tile assay baselines for some assays.
In some cases, custom exon tile baselines can be added only to the latest version of an assay. For more
information about assay versions, see “Available versions of software update packages” on page 312.
Contact a Field Bioinformatics Specialist (FBS) for guidance.

By default, you must use at least 40 RNA, DNA & RNA, or TNA samples to create an exon tile assay
baseline.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Exon Tile Assay Baselines tab.

The Exon Tile Assay Baselines table lists both system-installed and custom exon tile assay
baselines.

3. Click + Add New.

4. In the Create Exon Tile Assay Baseline screen, select the library chemistry for the panel that you
want to use for baseline creation.
* AmpliSeq
¢ AmpliSeq HD

5. In the Panel step, enter a name for the baseline, select the panel that you want to use, and enter
an optional description for the baseline.

Only panels that are compatible with the selected library chemistry and exon tile assay baseline
creation are listed. In some cases, custom exon tile assay baselines can be created only for the
latest version of an assay panel.

6. Inthe Parameters step, do not change parameters from the default settings unless you
understand how the change can affect the results.

Gene-specific parameters can be enabled with a TXT file.
a. Click Download Example.
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b. Open the file with a text editor, enter new values if needed, and save the file with a new file
name.

c. Click Upload, navigate to the file, then click Open.

d. In the Gene specific threshold file dropdown list, select the file to enable gene specific
thresholds.

e. Click Next.

7. In the Samples step, select the samples to be used in the baseline creation, then click Next.

You can add BAM samples or RNA, DNA & RNA, or TNA samples that have been sequenced or a
combination of both.

8. In the Review step, review the information.
9. Click Launch.

The software creates the exon tile assay baseline with a Status of Locked. The new exon tile assay
baseline is listed in the Exon Tile Assay Baselines table with a State of Creating. If there are other
active jobs in the software, the State is Pending until the software starts exon tile assay baseline
creation.

When the software completes the process of exon tile assay baseline creation, the State changes

to Completed and the exon tile assay baseline is available to add to an assay. The new exon tile
assay baseline is available in the Fusion Baseline dropdown list in the Panel step when you create an
assay that contains a fusion panel that is associated with the new exon tile assay baseline. For more
information, see “Panel step assay options” on page 222.
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View, add, or remove a note in an exon tile assay baseline (manager/
administrator)

Manager- and administrator-level users can view existing notes or add notes to an exon tile assay
baseline. Use Notes to capture time-stamped written comments and observations for an exon tile
assay baseline. An exon tile assay baseline can contain multiple notes from different users.

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Exon Tile Assay Baselines tab.

3. Place the pointer over the row of the exon tile assay baseline of interest, click Notes, then review
existing notes or add a new note.

Action Description

View existing notes for an | In the Add Notes dialog box, notes that are associated with the exon tile
exon tile assay baseline. |assay baseline are listed by user, date, and time.

Add a new note to an 1.

. ) In the Add Notes dialog box, click-+ Add Note.
exon tile assay baseline.

2. Enter the note, then click Save.
The note is added to the exon tile assay baseline and includes the

username for the account of the person who entered the note, and a
timestamp that records the note entry date and time.

Delete an exon tile assay |In the Add Notes dialog box, in the row of the note that you want to delete,
baseline note click T (Delete).

Click Close to return to the Manage Presets screen.
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Import an exon tile assay baseline (manager/administrator)

Manager- and administrator-level users can import an exon tile assay baseline. You can import
baselines in ZIP format, and in some instances in TXT format. ZIP-format files contain a fusion panel file
and a fusion FASTA file. For more information about the option to import an exon tile assay baseline in
TXT format, contact a Field Bioinformatics Specialist (FBS).

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Exon Tile Assay Baselines tab.

3. Click [ Import Exon Tile Assay Baseline in the top right of the screen.

Option Description
Import a ZIP file 1. In File Type, select ZIP.
2. Click Select Exon Tile Assay Baseline file.
3. Browse for and select the file.
4. Click Upload.

Import a TXT file In File Type, select TXT.

In the Panel list, select the panel.
Click Select Exon Tile Assay Baseline file.

oD =

Browse for and select the file.
The Name field is autopopulated based on the file name.

5. Enter a name for the baseline to change the name from the software-
generated name.

6. Click Upload.

A message confirms that the file import was successful when the file import is complete. Imported
exon tile assay baselines are locked by the software.

The imported exon tile assay baseline is available in the Fusion Baseline dropdown list in the Panel
step when you create an assay that contains a fusion panel that is associated with the imported exon
tile assay baseline. For more information, see “Panel step assay options” on page 222.

Download the log file for custom exon tile assay baselines
(manager/administrator)

Manager- and administrator-level users can download and view a log file that shows the details for exon
tile assay baselines creation. The log file is available after the exon tile assay baseline creation job is
complete. The log file can help with troubleshooting if the exon tile assay baseline creation fails.

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Exon Tile Assay Baselines tab.

3. Place the pointer over the row of the custom exon tile assay baseline of interest, then click
Download Log.
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Delete an exon tile assay baseline (manager/administrator)

If a custom exon tile assay baseline fails or is terminated during job creation, the exon tile assay
baseline can be deleted from the software by a manager- or administrator-lever user.

1. In the menu bar, click Assays » Manage Presets.

2. In the Assays / Manage Presets screen, click the Exon Tile Assay Baselines tab.
The Exon Tile Assay Baselines table lists both system-installed and custom exon tile assay
baselines.

3. Place the pointer over the row of the draft exon tile assay baseline that you want to delete, then
click Delete.

4. Inthe Delete Exon Tile Assay Baseline dialog box, click Yes to confirm the deletion.

The failed or terminated exon tile assay baseline is removed from the software and is no longer included
in the Exon Tile Assay Baselines table.

Export an exon tile assay baseline (manager/administrator)

Manager- and administrator-level users can export exon tile assay baselines that have been created in
Genexus™ Software. System installed exon tile assay baselines cannot be exported.

An exon tile assay baseline can be exported, for example to add the exon tile assay baseline to an
assay for use on a different Genexus™ Integrated Sequencer.

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Exon Tile Assay Baselines tab.

3. Place the pointer over the row of the locked exon tile assay baseline that you want to export, then
click Export.

The exon tile assay baseline files are downloaded as a ZIP file and are available for import for use with
another Genexus™ Integrated Sequencer.

Remove an exon tile assay baseline (manager/administrator)

Manager- and administrator-level users can make exon tile assay baselines unavailable in the software.
You cannot designate as obsolete system-installed exon tile assay baselines.

1. In the menu bar, click Assays » Manage Presets.
2. In the Assays / Manage Presets screen, click the Exon Tile Assay Baselines tab.

3. Place the pointer over the row of the exon tile assay baseline that you want to make unavailable,
then click Obsolete.

The Status of the exon tile assay baseline is Obsolete in the list of exon tile assay baselines. Exon tile
assay baselines that have been made obsolete cannot be added to an assay when an assay is created
or copied and edited.
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Panel files (manager/administrator)

Manager- and administrator-level users use the Assays / Manage Panels screen to manage panel files
and reference files.

Note: Manager- and administrator-level users can create and obsolete panel and reference files using
-+ Add New and Obsolete, except for those defined by system-installed or locked assays.

* Panel files (BED format) * Reference genome files (FASTA format)
* Hotspots files (BED format) * DNA barcode sequence files
* Fusion reference sequences (FASTA format) * Control fragments

Manage panels (manager/administrator)

286

Manager- and administrator-level users can add new panels, export existing panel files, and make
panels that have been added in the software unavailable in Genexus™ Software.

Operators can view the panels that are available in the software.

View panel details

You can view details about system-installed and panels that have been added in Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. View the panel details.

Add new panel files (manager/administrator)
Manager- and administrator-level users can add new panel files to Genexus™ Software.

You can upload BED panel files or you can upload a ZIP file that contains the panel file and related files.

* For DNA panels, you can upload a BED panel file or you can upload a ZIP file that contains the
panel file and the hotspot file.

¢ For DNA and Fusion panels, you can upload a target region BED file and a Fusion panel file
individually and select a fusion reference file, or you can upload a ZIP file that contains a target
region file, a hotspot file, and a fusion reference file.

* For Fusion panels, you can upload a Fusion panel file individually and select a fusion reference file,
or you can upload a ZIP file that contains the target region file and the fusion reference file.

* For RNA panels, BED is the only supported file format.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click + Add New.

Genexus™ Software 6.8 User Guide



Chapter 9 Presets and panels (manager/administrator) B
Panel files (manager/administrator)

3. In the Add Panel dialog box, enter the required information.

Field Description
Name Enter a name for the new panel.
Panel Type Select the panel type, such as DNA and Fusion Panel or DNA Panel.
Reference Select a reference genome.
File Type Select the file format when multiple file types are supported.
Target Regions Navigate to the target regions file.
Fusion Reference For Fusions panels and DNA and Fusions panels, select the fusion
reference.
Fusion Panel Navigate to the fusion panel file.
4. Click Upload.

Note: Large files take time to upload. You can see the file listed only when the upload is complete.

The new panel is listed in the Panels tab and is available to add to a custom assay. For more
information, see “Assay creation overview” on page 218. Hotspot uploads are listed in the Hotspot
tab and are available to add to a custom assay. For ZIP file uploads, the name of the hotspot is the
name of the panel followed by _Hotspot. Fusion references are listed in the Panels tab with more
details available in the Fusion References tab.

Import panel files from lon AmpliSeq™ Designer (manager/administrator)

Manager- and administrator-level users can import custom or fixed panel files into Genexus™ Software
from lon AmpliSeq™ Designer.

Before you can import custom panel files, ensure that the following prerequisites are complete.
* You know the username and access code for an AmpliSeq.com account.
* You have ordered a custom panel at AmpliSeq.com.

For more information, see lon AmpliSeq™ Designer Help (Pub. No. MAN0OO18937).

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click & Import from AmpliSeq.

Genexus™ Software 6.8 User Guide 287


https://www.ampliseq.com
https://www.ampliseq.com

e

oW

Chapter 9 Presets and panels (manager/administrator)
Panel files (manager/administrator)

288

3. In the Import from AmpliSeq dialog box, enter the information for the panel that you want to

import.

For Custom Panels

Item Description
Panel type Select the panel type, such as DNA and Fusion Panel or DNA Panel.
Reference Select a reference genome.
Library Chemistry | Select the type of library chemistry for the panel, such as lon AmpliSeq™ HD.

AmpliSeq Panels

Select Custom Panel.

AmpliSeq
Username

Enter the username that you used when you created an account for
AmpliSeq.com.

AmpliSeq Access
code

Enter the access code the you generated at AmpliSeq.com.

List My AmpliSeq
Panels

Select the panel you want to import from the dropdown list.

Only panels that have a status of ordered in lon AmpliSeq™ Designer are listed.
Draft and results ready panels are not listed.

For Fixed Panels

Item Description
Panel type Select the panel type, such as DNA and Fusion Panel or DNA Panel.
Reference Select a reference genome.
Library Chemistry Select the type of library chemistry for the panel, such as lon AmpliSeq™ HD.

AmpliSeq Panels

Select Fixed Panel.

Fixed Panel

Select the panel you want to import from the dropdown list.

4. Click Import.

The imported panel appears in the list of panels in the Manage Panels screen and can be added to an
assay. For more information, see “Assay creation overview” on page 218.

Any hotspots and fusions references associated with the imported panel are also listed in the respective
Hotspots and Fusion References tabs after panel file upload.

Export panel files (manager/administrator)

Manager- and administrator-level users can export existing panel files from Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.
2. Place the pointer over the row of the panel that you want to export, then click Export to download

the panel BED file.
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Obsolete panels (manager/administrator)

Manager- and administrator-level users can make panels unavailable that have been added or imported
in Genexus™ Software. You cannot designate as obsolete system-installed panels.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Place the pointer over the row of the panel that you want to remove from the software, then click
Obsolete.

The panel is listed in the Panels table with a Status of Obsolete. Panels that have been made obsolete
cannot be added to a new assay. Manager- and administrator-level users can reactivate panels that
have been made obsolete. For more information, see “Reactivate panels (manager/administrator)” on
page 289.

Reactivate panels (manager/administrator)

Manager- and administrator-level users can reactivate panels that have been made obsolete in
Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Place the pointer over the row of the panel that you want to reactivate, then click Reactivate.

The panel is listed in the Panels table with a Status of Locked and is available to add to a new assay.

Manage hotspot files (manager/administrator)

Manager- and administrator-level users add, view, and manage the hotspot BED files that are available
in Genexus™ Software.

Operators can view the hotspot files that are available in the software.

View hotspot file details

You can view details about system-installed hotspot files and hotspot files that have been added in
Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the Hotspots tab.

3. In the Hotspots table, view the details for the hotspot files, including the panel with which the
the file is associated, whether the file is Locked, if the file is Active, who created the file, and the
date on which the file was created. You can also view the genomic coordinates and alleles that are
included in the hotspot file.
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Add new hotspot files (manager/administrator)

Manager- and administrator-level users can add new hotspot files in Genexus™ Software.

Hotspot files can also be added when you add or import a panel file. For more information, see “Add
new panel files (manager/administrator)” on page 286 and “Import panel files from lon AmpliSeq™
Designer (manager/administrator)” on page 287.

1.

In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

Click the Hotspots tab.
Click + Add New.

In the Add Hotspot File dialog box, enter a name, select a panel, then select the BED file that you
want to upload.

Click Upload.
Large files take time to upload and may not appear immediately.

The hotspot file is listed in the Hotspot table and is available to select when you create or copy and edit
some custom assays.

Export hotspot files (manager/administrator)

Manager- and administrator-level users can export hotspot files from Genexus™ Software.

1.

In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

Click the Hotspots tab.

Place the pointer over the row of the hotspot file that you want to export, then click Export to
download the hotspot BED file.

Obsolete hotspot files (manager/administrator)

Manager- and administrator-level users can make hotspot files that have been added to the software
unavailable in Genexus™ Software. You cannot designate as obsolete system-installed hotspot files.

1.
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In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

Click the Hotspot tab.

Place the pointer over the row of the hotspot file that you want to remove from the software, then
click Obsolete.
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The hotspot file is listed in the Hotspot table with a Status of Obsolete. Hotspot files that have

been made obsolete cannot be added to a new assay. Manager- and administrator-level users can
reactivate hotspot files that have been made obsolete. For more information, see “Reactivate hotspot
files (manager/administrator)” on page 291.

Reactivate hotspot files (manager/administrator)

Manager- and administrator-level users can reactivate hotspot files that have been made obsolete in
Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the Hotspots tab.
3. Place the pointer over the row of the hotspot file that you want to reactivate, then click Reactivate.

The hotspot file is listed in the Hotspots table with a Status of Locked and is available to add to a new
assay. Hotspot files are only available to select for some assays.

Manage fusion reference files (manager/administrator)

Manager- and administrator-level users add, view, and manage the fusion reference files that are
available in Genexus™ Software.

Operators can view the fusion reference files that are available in the software.
View fusion reference file details

You can view details for system-installed fusion reference files and fusion reference files that have been
added in Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the Fusion References tab.

3. In the Fusion References table, view the details for the fusion reference files.
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Add fusion reference files (manager/administrator)

Manager- and administrator-level users can add new fusion reference files in Genexus™ Software.

Fusion reference files can also be added when you add or import a panel file. For more information, see
“Add new panel files (manager/administrator)” on page 286 and “Import panel files from lon AmpliSegq™
Designer (manager/administrator)” on page 287.

1. In the menu bar, click Assays » Manage Panels.

2. In the Manage Panels screen, select the Fusion References tab.
The Panels tab in the Manage Panels screen opens.

3. Click the Fusion References tab.
4. Click + Add New.

5. In the Add Fusion Reference dialog box, enter a name, select a reference genome, then select the
FASTA file that you want to upload.

Large files take time to upload and may not appear immediately.
6. Click Upload.

The fusion reference file is listed in the Fusion References table and is available to select when you
create or copy and edit some custom assays, or when you add a new panel.

Export fusion reference files (manager/administrator)
Manager- and administrator-level users can export fusion reference files from Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the Fusion References tab.

3. Place the pointer over the row of the fusion reference file that you want to export, then click Export
to download the fusion reference FASTA file.

Obsolete fusion reference files (manager/administrator)

Manager- and administrator-level users can make fusion reference files that have been added to the
software unavailable in Genexus™ Software. You cannot designate as obsolete system-installed fusion
reference files.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the Fusion References tab.

3. Place the pointer over the row of the fusion reference file that you want to remove from the
software, then click Obsolete.
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The fusion reference file is listed in the Fusion References table with a Status of Obsolete. Fusion
reference files that have been made obsolete cannot be added to a new assay. Manager- and
administrator-level users can reactivate fusion reference files that have been made obsolete. For more
information, see “Reactivate fusion reference files (manager/administrator)” on page 293.

Reactivate fusion reference files (manager/administrator)

Manager- and administrator-level users can reactivate fusion reference files that have been made
obsolete in Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the Fusion References tab.

3. Place the pointer over the row of the fusion reference file that you want to reactivate, then click
Reactivate.

The fusion reference file is listed in the Fusion References table with a Status of Locked and is
available to add to a new assay. Fusion reference files are only available to select for some assays.

Manage reference genome files (manager/administrator)

Manager- and administrator-level users add new DNA reference genome files so that they are available
in Genexus™ Software. New reference genomes are uploaded in a FASTA file.

Operators can view the reference genome files that are available in the software.

For information about the system-installed reference genome files, see “System-installed reference
genome files” on page 423.

View reference genome file details

You can view details for system-installed reference genome files and reference genome files that have
been added in Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the References tab.

3. In the References table, view the details for the reference genome files.

Add reference genome files (manager/administrator)
Manager- and administrator-level users can add new reference genome files in Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.

2. In the Manage Panels screen, click the References tab, then click + Add New.
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3. In the Add Reference Genome dialog box, enter the required and optional information, then select
the FASTA file to upload the reference sequence information.

Large files take time to upload and may not appear immediately.
4. Click Upload when you have finished.

The reference genome file is listed in the References table and is available to select when you add

or import a panel or a fusion reference file. For more information, see “Add new panel files (manager/
administrator)” on page 286, “Import panel files from lon AmpliSeq™ Designer (manager/administrator)”
on page 287, and “Add fusion reference files (manager/administrator)” on page 292.

Obsolete reference genomes (manager/administrator)

Manager- and administrator-level users can make reference genomes that have been added to
the software unavailable in Genexus™ Software. You cannot designate as obsolete system-installed
reference genomes.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the References tab.

3. Place the pointer over the row of the reference genome that you want to remove from the software,
then click Obsolete.

The reference genome is listed in the References table with a Status of Obsolete. Reference genomes
that have been made obsolete cannot be added to a panel or a new fusion reference file. Manager- and
administrator-level users can reactivate reference genomes that have been made obsolete. For more
information, see “Reactivate reference genomes (manager/administrator)” on page 294.

Reactivate reference genomes (manager/administrator)

Manager- and administrator-level users can reactivate reference genomes that have been made
obsolete in Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the References tab.

3. Place the pointer over the row of the reference genome that you want to reactivate, then click
Reactivate.

The reference genome is listed in the References table with a Status of Locked and is available to add
to a new panel or fusion reference.
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Manage barcode sets (manager/administrator)

Manager- and administrator-level users add new barcode sets to Genexus™ Software, and view the
barcode IDs and sequences for each barcode set that is available in the software.

For information about system-installed barcode sets, see “System-installed barcode sets” on page 404.

View barcode set details (manager/administrator)

You can view details for system-installed barcode sets and barcode sets that have been added in
Genexus™ Software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the Barcode Sets tab.
3. In the Barcode sets table, view the list of barcode sets.

4. Click the name of a barcode set in the list to view the barcode IDs, sequences, and other details
for the barcode set.

5. Click X (Remove) to return to the complete list of barcode sets.

Add new barcode sets (manager/administrator)

Manager- and administrator-level users add new barcode sets to Genexus™ Software. You can upload
XLS or XLSX barcode set files. An example barcode set file is available in the software.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the Barcode Sets tab.

3. Click + Add New, enter the required information in the Add Barcode Set dialog box, and browse
to and select the barcode set file.

Click the Click here link to download an example barcode file.
4. Click Upload.

The barcode set is listed in the Barcode Sets table and is available to select in the reagent step when
you create an assay. For more information, see “Reagent step assay options” on page 225.

Genexus™ Software 6.8 User Guide 295



FP5¥ Chapter 9 Presets and panels (manager/administrator)
Control fragments (manager/administrator)

Obsolete barcode sets (manager/administrator)

Manager- and administrator-level users can make barcode sets that have been added to the software
unavailable in Genexus™ Software. You cannot designate as obsolete system-installed barcode sets.

1. In the menu bar, click Assays » Manage Panels.
The Panels tab in the Manage Panels screen opens.

2. Click the Barcode Sets tab.

3. Place the pointer over the row of the barcode set that you want to remove from the software, then
click Obsolete.

4. In the confirmation dialog box that appears, click Yes to confirm that you want to obsolete the
barcode set.

You cannot reactivate barcode sets that have been made obsolete.

Control fragments (manager/administrator)

Control fragment sequences are system-installed in Genexus™ Software and are included in reagents.
These internal controls are predefined and cannot be modified by users.

Manager- and administrator-level users can view control fragment information in the
Assays / Manage Panels screen, in the Control Fragments tab.

Column Description
Name The control fragment name.
Sequence Single-letter nucleotide sequence of the control fragment.
Control The process in which the control fragment is used.
Status Indicates whether the control fragment information is locked and cannot be
modified by the user.
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Manager-level users use tools in the 3 (Settings) menu to:

System administration
and management
(manager/administrator)

Linked accounts in Genexus™ Software (manager/administrator) .......................... 298
User accounts (@dministrator) . ...... ...ttt i i e e 304
Audit records (@dministrator) . ... e e 308
Configure email settings (manager/administrator) .......... ... . o i i 310
SOftWaAre UPAates . ..o ottt e e 312
Manage backup settings and restore runs (administrator) ............. ... ..o il 315
Log files (@dministrator) . .. ...t e 334
System services (manager/administrator) . ......... ... e 335

Create and link user accounts to get software updates from the Connect App Store, and use lon
Reporter™ Software.

View system information and settings.

Administrator-level users use tools in the 83 (Settings) menu to:

View and export audit records.
Configure user email settings, set up laboratory information, and audit these settings.

Create and link user accounts for to get software updates from the Connect App Store, use lon
Reporter™ Software.

Create and manage account settings, and audit these accounts.
Manage software updates.

Manage data backup, disk cleanup settings, and disk space usage.
Manage log files.

Manage services for servers, services, and active jobs.

Create and manage user accounts.
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Linked accounts in Genexus™ Software
(manager/administrator)

Manager- and administrator-level users can configure software accounts in Genexus™ Software and on
the Genexus™ Integrated Sequencer.

Account Type Description

Thermo Fisher Connect When a Thermo Fisher Connect account is configured and active, Administrator-level
users can perform the following tasks in the Genexus™ Integrated Sequencer.

* Download the latest software updates

* Download more plugin software

* Download assay definition files

* Download software configuration packages

The first Thermo Fisher Connect account that is added in the software is designated
as the administrator (Admin) account and cannot be unlinked or removed.

Genexus Upload samples results to another Genexus™ Integrated Sequencer.

lon Reporter Cloud Upload samples results to an lon Reporter™ Software on Thermo Fisher™ Connect
Platform account, and then use the lon Reporter™ Software to further analyze those
results.

lon Reporter Server Upload samples results to an lon Reporter™ Server, and then use the lon Reporter™

Software to further analyze those results.

Create a Connect account

Before you configure a Thermo Fisher Connect account in Genexus™ Software, you must have a valid
Connect account on the thermofisher.com website.

1. Navigate to thermofisher.com/connect.
2. Click Sign up now, then enter the information to create a new account.

3. Click Create account at the bottom of the screen to complete the registration.
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Configure a Thermo Fisher™ Connect Platform account with a QR code
(manager/administrator)

Manager- and administrator-level users can link their Connect account at Genexus™ Software with a QR
code generated in the software.

When a Connect account at thermofisher.com/connect is configured and active, administrator-level
users can perform the following tasks in the Genexus™ Software:

* Download the latest software updates

* Download more plugin software

* Download assay definition files

¢ Download software configuration packages
Before you link a Connect account to create a Thermo Fisher Connect account, you must have a valid
Connect account. You must also have the InstrumentConnect mobile app to link the account with a

QR code that is scanned on a mobile device. For more information, see the Thermo Fisher™ Connect
Platform Help System (Pub. No. MANOO10954).

1. Click & (Settings) » Thermo Fisher Account.

2. Click + Link Account to Device.

The Link Account to Device dialog box opens and a QR code image and QR code text are
shown.

3. Link the Connect account with the software.

Option Description

Link a Connect 1
account with

the InstrumentConnect
mobile app 3. Click QR Code, then scan the QR code shown in the Link Account to

Device dialog box in Genexus™ Software.

. Open the InstrumentConnect app, then sign in.
In the app, click <.

Link the account through 1. Click the link in the QR Code to open the Thermo Fisher Connect
the Connect website website.

2. Inthe Connect website, click @ InstrumentConnect in the left
sidebar.
3. Click Link instrument in the upper right corner of the screen.
. Enter the QR code text shown in the Link Instrument screen.
5. Click Link.

The linked account is listed in the & (Settings) / Thermo Fisher Account screen. A successfully
authenticated account has Active listed in the Status column.

When the Thermo Fisher Account is active, software updates are available in Genexus™ Software.
Administrator-level users can download and install the updates. For more information, see “Software
updates” on page 312.
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Manager- and administrator-level users can register Genexus™ Software accounts. After the accounts
are registered, you can transfer results from one Genexus™ Integrated Sequencer to another.

1. In Genexus™ Software, click (& (Settings) » Thermo Fisher Account.
2. In the Thermo Fisher Account Settings screen, click + Register Account.

3. In the Register Thermo Fisher Account dialog box, enter the information that is required to create
the account.

Item Description
Account Type Select Genexus.
Name Enter a name to identify the account in the Thermo Fisher Account Settings

screen in Genexus™ Software.

The name can contain only alphanumeric characters (0-9, Aa-Zz), periods (.),
underscores (_), or hyphens (-). For example, enter Lab_Admin.

User Name Enter the name that is used to sign in to the Genexus™ Software account
that you want to link.

Password Enter the password for the Genexus™ Software account that you want to
link.

Server Enter the name of the Genexus™ Integrated Sequencer account that will be
used for file uploads.

Port Enter the port of the Genexus™ Integrated Sequencer.

Version Click & Get lon Reporter Software Versions, then select the software
version.

Set as Default Account | Click the toggle switch to make the account the default account that is used
to upload results files.

The configured account is listed in the & (Settings) / Thermo Fisher Account screen. The Account
Type is Genexus. A successfully authenticated account has Active listed in the Status column.

Register an lon Reporter™ Software on Thermo Fisher™ Connect Platform
account (manager/administrator)

Manager- and administrator-level users can register an lon Reporter™ Software on Thermo Fisher™
Connect Platform account in Genexus™ Software.

lon Reporter™ Software on Thermo Fisher™ Connect Platform, the cloud-based platform, is available at
https://ionreporter.thermofisher.com.

When the account is registered, you can upload results files from Genexus™ Software directly to the lon
Reporter™ Software on Thermo Fisher™ Connect Platform and use lon Reporter™ Software for further
data analysis, annotation and reporting. Unmapped BAM files for the sample results are uploaded.
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Access to lon Reporter™ Software on Thermo Fisher™ Connect Platform is controlled by your
thermofisher.com user name and password. Before you register the lon Reporter™ Software

on Thermo Fisher™ Connect Platform account, you must have a valid Connect account on the
thermofisher.com website. Users who use the account to access lon Reporter™ Software on Thermo
Fisher™ Connect Platform must also have a valid Thermo Fisher account.

1. Click & (Settings) » Thermo Fisher Account.

2. In the Thermo Fisher Account Settings screen, click + Register Account.

3. In the Register Thermo Fisher Account dialog box, complete the information required to register

the account.
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Option

Description

Account Type

Select lonReporter Cloud.

Name Enter a name to identify the account in the list of Thermo Fisher
Account Settings.

User Name This must the user name (email address) for a valid lon Reporter™
Software on Thermo Fisher™ Connect Platform account.

Password Enter the password for the lon Reporter™ Software on Thermo
Fisher™ Connect Platform account.

Version Click & Get lon Reporter Software Versions, then select the

software version.

(Optional) Set as Default
Account

Click the toggle switch if you want to make the account the default
account that is used to upload results files.

4. Click Submit.

The registered lon Reporter™ Software on Thermo Fisher™ Connect Platform account is added to the
Thermo Fisher Account Settings table. (See the row with the Account Name that you used listed
as a Thermo Fisher Cloud account.) The account can be selected in the Setup step of a run plan to
automatically upload results file to lon Reporter™ Software when the run is complete.

Results files can also be uploaded to lon Reporter™ Software from the Results / Run Results screen.
For more information, see “Upload results files to lon Reporter™ Software” on page 196.

Register an lon Reporter™ Server account (manager/administrator)

Manager- and administrator-level users can register a link to an lon Reporter™ Server account in
Genexus™ Software. When the server is registered, you can upload results files from Genexus™
Software directly to the lon Reporter™ Server and use lon Reporter™ Software for further data analysis,
annotation and reporting. The uploads contain unmapped BAM files.

1. Click & (Settings) » Thermo Fisher Account.

2. In the Thermo Fisher Account Settings screen, click + Register Account.
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3. In the Register Thermo Fisher Account dialog box, complete the information required to register
the account.

Option Description
Account Type Select lonReporter Local
Name A name to identify the account in the list of Thermo Fisher
Account Settings
User Name This must a username for a valid lon Reporter™ Server account.
Password Enter the password for the lon Reporter™ Server account.
Server Enter the name of the lon Reporter™ Server that you want to use to

upload results files.

Version Click & Get lon Reporter Software Versions, then select the
software version.

Port Enter the port of the lon Reporter™ Server.
(Optional) Set as Default Enable the toggle switch to make this account a default account to
Account upload results files.

4. Click Submit.

The registered lon Reporter™ Server account is added to the Thermo Fisher Account Settings screen.
The account can be selected in the Setup step of a run plan to automatically upload sample results files
and launch analyses in lon Reporter™ Software. Results files can also be uploaded to lon Reporter™
Software from the Results / Run Results screen. For more information, see “Upload results files to lon
Reporter™ Software” on page 196.

The registered account is listed in the < (Settings) / Thermo Fisher Account screen. A successfully
authenticated account has Active in the Status column. The software version for the lon Reporter™
Software is listed in the Version column.

Manage connected accounts

302

Manager- and administrator-level users can edit, unlink, delete, obsolete, and view changes made to
the accounts that are connected to Genexus™ Software.

Edit a connected account (manager/administrator)

Manager- and administrator-level users can edit the connected accounts in Genexus™ Software. For
example, edit a connected account when the password of the connected account has changed.

1. Click & (Settings) » Thermo Fisher Account.

2. In the Thermo Fisher Account Settings screen, place the pointer over the row of the account that
you want to edit, then click Edit.

3. In the Edit Thermo Fisher Account dialog box, enter the new information, then click Submit to
save the changes.
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Unlink a Thermo Fisher™ Connect Platform account (manager/administrator)

Manager- and administrator-level users can unlink Thermo Fisher™ Connect Platform accounts in
Genexus™ Software.

The first Thermo Fisher™ Connect Platform account that is added is designated as the administrator
(Admin) account and cannot be unlinked or removed in the software.

1. Click & (Settings) » Thermo Fisher Account.
2. Place the pointer over the row of the account that you want to unlink, then click Unlink.
The Thermo Fisher™ Connect Platform account is no longer linked in Genexus™ Software.

Obsolete a connected account (manager/administrator)

Manager- and administrator-level users can obsolete accounts that are connected in Genexus™
Software.

1. Click & (Settings) » Thermo Fisher Account.

2. In the Thermo Fisher Account Settings screen, place the pointer over the row of the account that
you want to obsolete, then click Obsolete.

Delete a connected account (manager/administrator)

Manager- and administrator-level users can delete accounts that are connected in Genexus™ Software.

1. Click & (Settings) » Thermo Fisher Account.

2. In the Thermo Fisher Account Settings screen, place the pointer over the row of the account that
you want to delete, then click Delete.

The account is removed from the Thermo Fisher Account Settings screen.

View the changes made to a connected account (manager/administrator)

Manager- and administrator-level users can view the changes made to connected accounts in
Genexus™ Software.

1. Click & (Settings) » Thermo Fisher Account.

2. In the Thermo Fisher Account Settings screen, place the pointer over the row of the account that
you want to audit, then click Audit.

3. In the Audit Details screen, view the most recent change for the selected account.

4. In the Audit Record Details pane, click a time stamp of interest to view the details for other
changes that have been made to the selected account.

5. (Optional) Click Download to export the record of the single change to a PDF file.

Genexus™ Software 6.8 User Guide 303



=Y Chapter 10 System administration and management (manager/administrator)
User accounts (administrator)

)

User accounts (administrator)

Administrator-level users can perform user management actions in the
& (Settings) / User Management screen.

Add new user accounts

Assign user privileges (roles)

Edit user information

View user account audit trails

Manage user account security policies

Add a new user account (administrator)

Administrator-level users add new user accounts to the software, and grant some users permissions to
electronically sign reports.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

The email settings in the software must be configured before new users can receive email notifications.
For more information, see “Configure email notifications (manager/administrator)” on page 310.

1.

2.

304

In the menu bar, click 3 (Settings) » User Management.
In the User Management screen, click + Add New.

In the Create User dialog box, enter the user account information.
User names can contain alphanumeric characters and underscores, periods, and hyphens.

From the Role list, select the appropriate user-access level (Administrator, Manager, or
Operator.

The Report role has electronic signature permissions enabled by default.

Grant permissions for a manager, administrator, or report user to electronically sign reports.
a. Enable the Electronic Signature toggle switch.

b. Select an Electronic Signature Type to associate with the user account. For example,
Approved. A & (Lock) is shown when you select the Electronic Signature Type that is
configured to lock a report upon sign off.

Click Save.

The new account is added to the list in the User Management screen. The software sends an
email notification containing a temporary password to the email address of the new user.
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Sort the user list (admin)

Administrator-level users can sort the user list by user name, first name, and last name.

1. In the menu bar, click 8 (Settings) » User Management.

2. In the User Management screen, click the column for User Name, First Name, or Last Name to
sort the column alphabetically.

3. Click the column name a second time to reverse the order.

Edit user details (administrator)

Administrator-level users can edit user details in the & (Settings) / User Management screen.
An administrator can also suspend or disable user accounts. A history of user account changes is
maintained by the audit feature.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. In the menu bar, click 8 (Settings) » User Management.

2. In the User Management screen, place the pointer over the row of the user account, then click
Edit.

3. In the Edit User dialog box, enter changes in the appropriate account information fields.

* In the Role list, select the user-access level (Administrator, Manager, or Operator.
The Report role has electronic signature permissions enabled by default.

* To grant permissions for administrator, manager or report users to sign reports, enable the
Electronic Signature toggle switch, and select an Electronic Signature Type.

A & (Lock) is shown when you select the Electronic Signature Type that is configured to
lock a report upon sign off.

* |n the State list, select the appropriate state (Active, Suspended, or Disable).
4. Click Save to make the changes.

Changes that are made to the user account are shown in the User Management screen, and shown in
the Audit Trail screen for the user.

Reset user password

An administrator-level user resets passwords for user accounts. A history of user password changes is
maintained by Genexus™ Software.

After a password is reset, the software sends an email notification to a user of a temporary password,
which they must personalize when logging in.

Periodically, the software sends a system-generated email notification to a user that their password
is about to expire. The operator follows the directions included in the email notification of a pending
password expiration. A user can also request that an administrator reset their password.
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Passwords can contain only alphanumeric characters and no special characters or spaces.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

The email settings in the software must be configured before new users can receive email notifications.
For more information, see “Configure email notifications (manager/administrator)” on page 310.

1. Click ¢ (Settings) » User Management.
2. Place the pointer over the row of the user of interest, then click Reset Password.

3. In the Change Password dialog box, you can change the password in one of two ways.

¢ C(Click Send password in Email to send a software-generated password in an email message
to the user.

e Enter a new password into the Password field to change the password for the user. Reenter
the new password into the Confirm Password field, then click Change.

The confirmation message "Password reset link sent to your email account" or "Password
changed successfully" appears to indicate the password reset.

View user account history (administrator)

An administrator-level user can view the user account history in Genexus™ Software. The user account
audit trail is a record of when the user account was created and modified.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. In the menu bar, click 8 (Settings) » User Management.

2. In the User Management screen, place the pointer over the row of the user of interest, then click
Audit.

3. In the Audit Details screen, view the audit trail details for the selected user. For more information,
in the Audit Record Details column, click the time stamp of interest.

4. (Optional) In the User Management screen, click [§] Download to export the record to a PDF file.
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Set user account security policies (administrator)

An administrator-level user sets security policies for Genexus™ Software user accounts. User account
security policies include the permissible number of failed sign-in attempts, password lifetime, and the
length of inactivity before users are automatically signed out of the software. These settings apply to all
users.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. In the menu bar, click 8 (Settings) » User Management.

2. In the User Management screen, click & Policies.

3. In the Policies dialog box, select the appropriate values to set the user-account suspension
period, password, and session timeout policies.

4. Confirm that the Enabled toggle switch is set to enable the session policy settings.

5. Click Save.

Configure an SSH key (system administrator)

System administrator-level users can set up an SSH key in their user profile in the

& (Profile) / My Profile screen. SSH, also known as Secure Shell or Secure Socket Shell, is a network
protocol that gives administrator-level users a secure way to access a computer over an unsecured
network. SSH also refers to the suite of utilities that implement the SSH protocol.

IMPORTANT! Ensure that you use only an SSH key that is password protected. The software does
not enforce the use of password protected SSH keys, but the use of a password for the SSH keys is
strongly recommended.

Do not share the SSH private key or the credentials for the SSH private key. The SSH private key should
be used only by the user who creates the SSH private key.

Configuring an SSH key is optional, but best practice is to configure one or more SSH keys. The
ionadmin and ionservice users may need to configure SSH keys so that they can access the system at
the operating system level to configure some system-level settings, for example mounting an archive
directory on the system. A user can have more than one SSH key.

Before configuring an SSH key, you must first generate keys by using the Keygen command on your
local system. When the public and private keys are generated, copy the text string from the public key
to use in this procedure.

1. In the menu bar, click & (Profile) » My Profile.

2. In the SSH Keys section, click + Add new SSH Key.
The SSH Keys section is available only to ionadmin and ionservice users.

3. Complete the Add new SSH Key dialog box.
a. In Label, type a unique name for this SSH key.
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b. In SSH Key, paste or type the SSH key string generated by using the Keygen command on
your local system.

c. Click Save.

Audit records (administrator)

Administrator-level users can use the tools in the & (Settings) / Audit Records screen to configure
and manage audit records. Information that can be audited includes activities by users on samples,
libraries, assays, planned runs, system setup of the sequencer, accounts, and software updates.

The Audit Records screen lists actions that are performed on any data object, including the user who
performed the action, the action performed, the data object name, and the date and time of the action.
Additional details concerning the action are available in an accompanying audit record.

The actions can be searched and sorted, and the audit records can be exported and printed.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

Note: Library batches and runs that are created in a batch with other objects in a single LIMS
transaction do not have a "Create" action that is listed in the & (Settings) / Audit Records screen.
However, you can view complete library batch audit records from the Samples / Manage Library
Batches and Runs / Manage Runs screens. Any subsequent actions that are performed on library
batches are listed in the Audit Records screen. A library batch or run that is created individually in a
LIMS transaction is listed.

Search audit records (administrator)

An administrator-level user can use the search tools in the & (Settings) / Audit Records screen to
search for an existing audit record.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. In the menu bar, click & (Settings) » Audit Records.

2. In the Audit Records screen, select the search parameters.
a. To select a date range, click 5] Calendar next to Start Date and End Date.

If an end date is not selected, the search results include all records from the start date through
the current date.

b. To limit the results list to actions that are performed by a specific user, select the user from the
Select User list.

c. To limit the results to specific actions, select from the Select Action list.
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d. To list more items in the table, select from the data object list.

The list is set to Sample by default and all items listed in the Audit Records screen have the
data object of Sample in the Data Object Name column. You can change the type of objects
that are shown in the table. For example, when you select Planned Runs in the data object
list, all planned runs are listed.

3. Click Search.

4. Click Clear to return to the default list of records, with the data object of Sample in the Data

Object Name column.

Sort audit records (administrator)

An administrator-level user can sort the columns in the ¢ (Settings) / Audit Records screen to display
the list of audit records in a different order. The default order is the newest record on top.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1.

2.

4.

5.

In the menu bar, click 3 (Settings) » Audit Records.

In the Audit Records screen, click the column heading of interest.

The list of records is reordered based on the heading selected. User, Action Performed, and Data
Object Name sort alphabetically.

Click the column heading a second time to reverse the order of records displayed.
Click Clear to return to the sorted column to the default order.

Click the Timestamp heading to return to the default order, with the most recent record on top.

Export audit records (administrator)

An administrator-level user uses the ¢ (Settings) / Audit Records screen to export a print-ready PDF
file of selected audit records.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1.

2.

In the menu bar, click 3 (Settings) » Audit Records.

In the Audit Records screen, select the record or records to be exported by clicking the checkbox
next to the record of interest. Select the checkbox above the column to select all of the records.

Click [&1 Export.
A PDF file is generated. Depending on your browser settings, the software automatically
downloads the file or prompts you to open or save the file.

Open the PDF file in an appropriate viewer to print.
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Update the audit configuration (administrator)

An administrator-level user configures the audit details by requiring that a reason for a change be
included in audit records when a user changes information. When a reason is required, the user must
supply a reason for change when editing the information, and the reason is included in the audit record.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. In the menu bar, click & (Settings) » Audit Records.
2. In the Audit Records screen, click tlf Audit Configuration.

3. In the Audit Configuration dialog box, select the Require Reason checkbox next to the Data
Object Name for which a reason for change is required.

4. Click Save.

To remove a reason for change requirement, open the Audit Configuration dialog box, deselect
the checkbox, then click Save.

Configure email settings (manager/administrator)

Manager- and administrator-level users configure email settings. Administrator-level users can configure
support contact information, such as the lab contact and the IT contact for the organization.

Configure email notifications (manager/administrator)

310

Manager- and administrator-level users configure the Genexus™ Software to send email notifications to
a specified administrator.

Administrator-level users receive email notifications when there is a restore system failure.
Administrator-level users can also select to receive email notifications when other conditions are met,
such as when the system has limited free disk space remaining. For more information, see “Change
email notification settings (administrator)” on page 330.

1. Obtain the SMTP server URL and port information from your IT department.
2. Click ¢ (Settings) » Configuration.

3. In the Configuration screen, in the Email Settings section, enter the server and port information
supplied by IT, and the Genexus™ Software user name, password, and email address of the
administrator.

* Keep the Use TLS toggle switch enabled to send email notifications with transport layer
security.

¢ Click the Use TLS toggle switch to send email notifications without transport layer security.
4. Click Update.

5. Click Send Test Email to send a test email to the email address provided in the settings.

Genexus™ Software 6.8 User Guide



Chapter 10 System administration and management (manager/administrator) — ey

Configure email settings (manager/administrator)

Lab information

The Lab Information tab in the & (Settings) / Configuration screen provides a reference for support
personnel, listing points of contact if a problem with the connected Genexus™ Integrated Sequencer
occurs.

¢ Lab Contact—This is the person in your organization who should be notified during a support
request of problems related to the sequencer.

* IT Contact—This is the person in your organization who should be notified during a support
request of problems related to the sequencer hardware or the network environment.

IMPORTANT! Administrator and Manager-level users should review the contact information
periodically to ensure that it is current and accurate.

Edit the reference lab information (manager/administrator)

Manager- and administrator-level users can edit the reference lab information in Genexus™ Software.
You can view the history of changes to the contact information. For more information, see “View the
changes made to the lab information (manager/administrator)” on page 311.

1. Click & (Settings) » Configuration.

2. In the Lab Information section, below the Lab Contact or IT Contact pane, click Edit.
The fields for the Lab Contact or IT Contact are now available to edit.

3. Enter the updated contact information.
4. Click Save to save the new selections or click Reset to revert to the original information.

View the changes made to the lab information (manager/administrator)

Manager- and administrator-level users can view the changes made to the lab information in Genexus™
Software.

1. Click & (Settings) » Configuration.
2. In the Lab Information section, in the Lab Contact or IT Contact pane, click Audit.
3. In the Audit Details screen, view the most recent change for the selected contact.

4. In the Audit Record Details pane, click a time stamp of interest to view the details for other
changes that have been made for the selected contact.

5. (Optional) Click [5) Download to export the record of the single change to a PDF file.
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Software updates

An administrator-level user can select Software Updates in the ¢s3 (Settings) menu to:

¢ See the currently installed software versions for each software module, assay definition files,
plugin, and configuration package installed on the system under the Installed Software link.

* Check for new software updates that are available to be downloaded and installed under the
Software Updates link.

For users who have set up a Thermo Fisher™ Connect Platform account, @ (Notification) appears in
the Genexus™ Software banner on the top of the screen upon login when updated software packages
are available for download from the Connect Platform.

Updated software packages are available from the App Store at apps.thermofisher.com. Software
packages can include assay definition files, for example. Administrator-level users can download
and install software directly from the App Store if a Connect Platform account has been configured.
Alternatively, a USB drive can be used to install and update the software if the instrument is not
connected to the internet.

Option For more information, see this section

Download and install software directly “Download and install software from the App Store
(administrator)” on page 313

Download and install software with a USB drive “Format a USB drive for a software update” on
page 314

“Download and install software with a USB drive
(administrator)” on page 314

Note: For first-time update of system software from the 5.100.2 version, contact a Field Service
Engineer (FSE) to update the system software.

IMPORTANT! Before updating the software, ensure that the instrument is idle, no runs are in progress
or are queued to run, and the screen on the instrument is the main menu screen.

Available versions of software update packages

312

When a software update package is available to install, you can view the available version of the
package in the Software Updates table in & (Settings) / Software Updates. The available version,
for example 1.0.0, is listed for all assay definition files, plugins, configuration packages, and software
updates that are available to install.

Assays that are available to install are listed in the Category of Assay Definition Files in the Software
Updates table. The software files that contain the assay settings and parameters are packaged in a
ZIP file called the assay definition file (ADF). You can install and use multiple versions of assays in the
software. For more information about version numbers for assays, see “Assay details” on page 236.
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Download and install software from the App Store (administrator)

In order to download and install software updates from the App Store on thermofisher.com/connect,
you must first:

Configure a Thermo Fisher Connect account. For instructions, see “Configure a Thermo Fisher™
Connect Platform account with a QR code (manager/administrator)” on page 299.

Ensure that the Genexus™ Integrated Sequencer has the latest software version, Genexus™
Software 6.8.

Connect the Genexus™ Integrated Sequencer to the internet.

- In the menu bar, click 3 (Settings) » Software Updates, then click Software Updates in the

upper right corner.
The Software Updates screen opens with App Store enabled.

(Optional) Click the desired package name to view the installation details and version information in
the View Package Details pane.

Click Download in the Actions column in the row of the software package of interest.
After the download is complete, the Download link changes to an Install link.

Click Install. When the confirmation window appears, click Yes to confirm that you want to install.

If you are performing a system software module installation, a command window opens to show
the progress of the installation.

Note: There may be a delay before the command window opens.

When installation of the software package is complete, click Installed Software to verify the
installation.
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Format a USB drive for a software update

Prerequisites:
¢ An Ubuntu Linux desktop computer with disk utility software.
* A USB drive with a capacity of 128 GB or more.

IMPORTANT! Ensure that the USB drive does not contain any viruses or malware before you insert the
USB drive into the instrument.

1. Insert the USB drive into the Ubuntu Linux computer.

2. With Ubuntu running, open the disk utility by navigating to System » Administration » Disk
Utility.

3. If the USB drive has partitions, delete the partitions.

a. Under Peripheral Devices from Storage Devices, click the USB Flash Drive (SMI USB
DISK) to select the USB drive.

b. Highlight the volumes (New Volume FAT >60 GB).
c. Click Unmount Volume, then click Delete Partition.
d. Click Delete to confirm.

4. Select the free USB volume, then click Create Partition.
The Create partition on SMI USB DISK window opens.

5. Deselect the Take ownership of file system checkbox.

6. Select ext3 from the Type dropdown menu, then select the entire size of the partition. Name the
partition usbinstall.

The partition name must be completely lowercase.

7. Click Mount.
The mount point of the USB drive is /media/usbinstall.

Proceed to “Download and install software with a USB drive (administrator)”.

Download and install software with a USB drive (administrator)

In order to download and install software updates, you must first:

¢ Create or access a Thermo Fisher™ Connect Platform account. For instructions, see “Configure a
Thermo Fisher™ Connect Platform account with a QR code (manager/administrator)” on page 299.

* Format a USB drive for the software update. For more information, see “Format a USB drive for a
software update” on page 314.
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. In the Ubuntu Linux computer where the USB is mounted, sign in to the Thermo Fisher App Store

on Connect at apps.thermofisher.com.
On the left side of the App Store screen, click &= (AppConnect).
On the right side of the screen, under Resource Libraries, click lon Torrent™ Genexus™.

Click Software Update.

In the lon Torrent™ Genexus™ Software table, select the row that contains the software package for
the version that you want to install.

Click #% (Download) to download the package.
Copy the downloaded package (.zip) to the /media/usbinstall folder in the USB drive.

After completion, unmount the USB drive, then insert the drive into one of the USB ports at the
back of the Genexus™ Integrated Sequencer.

In the menu bar of Genexus™ Software, click (3 (Settings) » Software Updates, then click
Software Updates in the upper right corner.

Select USB.

Click Install. When the confirmation window appears, click Yes to confirm that you want to install.

When installation of the software package is complete, click Installed Software to verify the
installation.

Manage backup settings and restore runs (administrator)

Administrator-level users can view and manage backup settings and restore runs in Genexus™ Software
with the following actions:

Monitor system storage space usage.

Manage settings to backup and delete files and data.
View an audit trail of any changes made.

View and change email notification settings.

Restore runs.
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Disk space usage and backup settings (administrator)

An administrator-level user can monitor disk space usage for the Genexus™ Integrated Sequencer and
can change data backup settings in Genexus™ Software. System disk space usage information is
available in the & (Settings) / Backup & Restore menu. You can view the date and time of the last
successful backup for data and analysis results and the date and time of the last successful backup for
additional files such as sequencing output and intermediate files, based on the backup settings.

A best practice to maintain sufficient disk space is a systematic plan that archives run data, results
files, variant information, and signed reports that you want to store to an external file storage system. A
system administrator or Field Service Engineer (FSE) sets up a data backup strategy and disk cleanup
settings. An administrator-level user then configures the backup schedule. For more information, see
“Change the backup settings (administrator)” on page 325.

Before data can be backed up or archived, you must add a mount point. The mount point can be an
external storage device or a cloud-based storage. After data backup, files are saved in a folder in the
external storage that is named AssayDev. If multiple sequencers are connected to the software, the
software generates a parent folder for each instrument.

When files are backed up, the files are copied to an external storage device or to a cloud system. The
files remain on both the sequencer and the external storage system.

When files are cleaned up, the files are deleted from the sequencer, but remain on the external storage
system.

Backup and cleanup settings

Option Description

Back up system data and run results | Backup occurs daily, at approximately midnight, after an administrator-level
user adds a mount point.

After backup, you can view the results for runs that are backed up in the
Run Results and Sample Results screens.

Clean up system data and run results | If enabled, run results are deleted from the sequencer after a specified
interval of time. For example, 12 months after a run is completed. Runs that
are backed up and deleted are marked as Archived.

Cleanup settings do not apply for run results that you retain. When you
retain run results, the run data, including the run results, 1.wells files, and
intermediate files, are retained on the instrument and in the storage system.
Runs that have been retained are shown in the software and are not deleted.

Archived runs are listed in the Run Results screen with the archived symbol
(T) after the run name. By default, archived runs are not listed. To see

the archived runs, select Archived in the Filter runs by list. An administrator-
level user can restore the runs to access the data.

316 Genexus™ Software 6.8 User Guide



Chapter 10 System administration and management (manager/administrator) — [Fi=y
Manage backup settings and restore runs (administrator)

Backup and cleanup settings (continued)

Option Description
Back up intermediate files and If enabled, intermediate files and 1.wells files are backed up at a specified
1.wells files time. For example, every Friday at 10 pm.

Because 1.wells files are 10 times larger than the run results files (BAM
files), the time required to back up 1.wells files takes longer than backups of
system data and run results.

Clean up intermediate files and If enabled, intermediate files and 1.wells files are deleted when the system
1.wells files disk space falls below a specified threshold, such as 4 TB. If you have

not configured the mount point, or if you have not configured the backup
settings for additional files, files are cleaned up when the space threshold is
met.

Cleanup settings do not apply for run results that you retain. When you
retain run results, the run data, including the run results, 1.wells files, and
intermediate files, are retained on the instrument and in the storage system.
Runs that have been retained are shown in the software and are not deleted.

Because 1.wells files are 10 times larger than the run results files (BAM
files), the time required to back up 1.wells files takes longer than backups of
system data and run results.

The software ensures that disk space is available for runs. If the system has less than 1 terabyte (TB) of
unused disk space, no new runs can be started on the sequencer. In this case, an alert notifies the user
that there is insufficient disk space when a run is set up on the sequencer. The run cannot proceed until
data are backed up and deleted.

An administrator-level user can perform the following actions to free up system disk space, if needed.

¢ In the Backup & Restore screen, you can click Start Now to start a backup and cleanup at any
time.

¢ In the Run Results screen, you can delete one or more run results.

¢ |n the Run Results screen, you can archive one or more run results if you have added a mount
point. The settings in the Backup and Restore screen are not applied when you archive runs in the
Run Results screen.

Contact a local system administrator to backup and delete data manually. An administrator-level user
can also change the schedule to backup and delete data.

Results and reports that have been backed up can be restored in Genexus™ Software. For more
information, see “Restore run results for a single run (administrator)” on page 331.
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Types of files for backup

Chapter 10 System administration and management (manager/administrator)

There are three categories of files for backup in Genexus™ Software.

* Plugin results

Category Types of files Cumulative size per run Reanalysis use
Sequencing output 1.wells 250-500 GB Reanalysis from the
basecalling step
Intermediate files Troubleshooting 150-180 GB Not applicable
Analysis results * BAM 150-180 GB Reanalysis from the
e VCF alignment step
* Reports

Specifications and disk space usage

The amount of disk space used for a run on the Genexus™ Integrated Sequencer depends on the
nucleic acid sample type and the assay that is used for sequencing. The system has 20 TB of data
storage and can store 40 to 50 whole chip data runs. If the system has less than 1 terabyte (TB) of
available storage space, no new runs can be started. For more information, see “Disk space usage and
backup settings (administrator)” on page 316.

The following table lists chip specifications and data usage for a run with the lon Torrent™ GX5™ chip.

Oncomine™ Oncomine™ Oncomine™ TCR
Assay Oncomine™ Precision Assay GX | Myeloid Assay | Comprehensive Beta.LR Assay GX
GX v2 Assay v3 GX y
Sample type cfTNA FFPE DNA+RNA DNA+RNA DNA+RNA RNA
Number of reads 48-60 million 48-60 million 48-60 million 48-60 million 48-60 million
per chip (4 lanes)
Number of reads 12-15 million 12-15 million 12-15 million 12-15 million 12-15 million

per lane

Signal processing
input size per

~2 terabytes

~2 terabytes

~3.5 terabytes

~2 terabytes

~3.5 terabytes

chipll

Basecalling input | 200-300 200-300 400-600 200-300 400-600 gigabytes
size per chipl? gigabytes gigabytes gigabytes gigabytes

Data size of 120-180 120-180 160-240 120-180 160-240 gigabytes
intermediate and gigabytes gigabytes gigabytes gigabytes

results files and
logst]
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(continued)
Oncomine™ Oncomine™ Oncomine™ TCR
Assay Oncomine™ Precision Assay GX | Myeloid Assay | Comprehensive Beta-LR Assay GX
GXv2 Assay v3 GX y

Data size per lane
of intermediate and
results files and
logs

30-45
gigabytes

30-45 gigabytes

40-60 gigabytes

30-45 gigabytes

40-60 gigabytes

Data size of 30-45 30-45 gigabytes |40-60 gigabytes |30-45 gigabytes |40-60 gigabytes
backed up files gigabytes

and logs

Data size of results | ~10-20 ~8-24 gigabytes | ~32-48 ~9-15 gigabytes | ~16-48 gigabytes
files per lanel! gigabytes gigabytes

Recommended
number of samples
per lane

1 sample per
lane

4 samples per
lane

8 samples per
lane

1.5 samples per
lane

4 samples per lane

Data size of the
results per sample

~10-20
gigabytes

~2-6 gigabytes

~4-6 gigabytes

~6-10 gigabytes

~2-6 gigabytes

' The signal processing input on the sequencer is deleted after analysis is complete and successful.

2l Administrator- level users can schedule when basecalling input files are deleted. By default, these files are not retained. For more information,
see “Set a schedule to permanently delete files (administrator)” on page 327.

Bl Includes QC, plugins, logs, results, and other assay and variant database files.
4l For more information about results files, see “Results files” on page 171.

Configure backup settings (administrator)

An administrator-level user views and configures sequencer backup settings in the
¢ (Settings) / Backup & Restore screen.

Update backup settings for various reasons, including:

* The backup location has limited free disk space remaining.

* The backup location is not accessible when the system tries to back up a run.

Consult a local Field Service Engineer to set up a backup system. For more information, see “Customer
and technical support” on page 431.

The following options are available only after a backup directory has been configured:

* View the backup disk space.

¢ Change the backup settings.
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1. In the menu bar, click 3 (Settings) » Backup & Restore

2. In the Backup Settings tab, edit the backup settings.

Option

Description

View the system disk space

View the chart that shows the percentage of system disk space that is used.

View the total amount of disk space, the amount of free disk space, and the amount of
used disk space, shown in terabytes.

View the backup disk
space

View the chart that shows the percentage of backup disk space that is used.

View the total amount of backup disk space, the amount of free disk space, and the
amount of used disk space, shown in terabytes.

This option is available only when Network is the selected Connection type.

Change the backup
directory

Change the backup directory.

For more information, see “Add or change the backup directory (administrator)” on
page 321.

Change the email
notification settings

Select when administrator-level users receive email notifications.

For more information, see “Change email notification settings (administrator)” on
page 330.

Change the backup
settings

Backup .wells files and intermediate files.
This option is available only when Network is the selected Connection type.
For more information, see “Change the backup settings (administrator)” on page 325.

Change the disk cleanup
settings

Set the schedule to permanently delete analysis results files.
Set the conditions to permanently delete other files.

For more information, see “Set a schedule to permanently delete files (administrator)”
on page 327.

Enable backup and
cleanup

Click the Backup & Cleanup Enabled toggle switch to the enabled position to start
the backup and cleanup process at the scheduled time.

Disable backup and
cleanup

Click the Backup & Cleanup Enabled toggle switch to the disabled or off position for
temporary instances, such as when the backup server is down.

This setting overrides all other backup settings.

Start backup

Click Start Now to start:
* the backup of system data and analysis results to the selected backup directory.

¢ if enabled, the backup of sequencing output and intermediate files to the selected
backup directory.

* data clean up based on cleanup settings.

Backup can take a considerable amount of time when the backup is set up for first
time on the system.

3. Click Save.

320

Genexus™ Software 6.8 User Guide




Chapter 10 System administration and management (manager/administrator) ¥

Manage backup settings and restore runs (administrator)

Add or change the backup directory (administrator)

Administrator-level users can use a Network File System (NFS) to set up an external storage device that
is a backup server to store system data. When the current backup directory has limited free disk space
remaining, change the backup directory used by the system.

IMPORTANT! We recommend NFS version 3 (NFSv3) or NFS version 4 (NFSv4) with Linux Operating
System external storage devices for Genexus™ Software.

1. In the menu bar, click 8 (Settings) » Backup & Restore.

2. In the Backup & Restore screen, select either Network or Cloud as the connection type.
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3. Edit the backup settings.
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Option

Description

Add a new mount point

1.
2.

3.

In the Backup Disk Space section, click Add Mount.
In the Add Mount dialog box:

¢ Enter the name of the mount directory. For example,
dadn.

Note: Do not include information from a hostname in
the mount directory name. For example, if the host
name is gnx001, do not use gnx001 in the mount
directory name.

You can type a new name to create a new directory.

¢ Enter the storage source. For example,
ddn.itw:/gs1/ion-data/dx-data
(Optional) Select Automount to allow the system to
mount backup directories automatically when the system is
restarted.
When the option is unselected, you must mount a directory
after a restart.

Change the existing backup
directory

In the Backup Disk Space section, select the directory that you
want to use for backups from the Backup Directory dropdown
menu.

You must add a mount point before it can be selected in the
dropdown.

Backup directory: @

Select a Mount point

°»

Select a Mount point
/ddn (Source: ddn4.itw:/gs1/ion-data/dx-data)

/ifs (Source: isilon.itw:/ifs)

Remove a backup directory that is
not in use, for example a directory
that is full or is no longer available

3.

If you remove a directory that is in use for backup, backups
cannot not be performed until you select a new backup directory.

Click Remove Mount.
In the Remove Mount dialog box, select the mounted drive
you want to remove.

Click Remove.

4. Inthe Backup & Restore screen, click Save to save the new selections.
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Add or change the cloud backup directory (administrator)

You can change the cloud backup directory that is used by the system. For example, you might
change the directory if the current backup directory has limited storage space. You can also add a new
directory, or remove a directory.

1. In the menu bar, click ¢ (Settings) » Backup & Restore.
The Backup & Restore screen opens.

2. Under Backup Disk Space select Cloud as the connection type.

3. Edit the backup settings.

Option Description
Add a new 1. In the Backup Disk Space section, click Add Mount.
mount point .
2. In the Add Mount dialog box:
¢ Enter the name of the Mount Point directory. For example, ddn.
You can type a new name to create a new directory.
¢ Enter the Cloud Provider. For example, AWS-S3.
3. Enter the Configuration information.
¢ Nick Name—A name to uniquely identify the directory and mount point on
the directory. Do not use spaces or special characters in the name.
Note: The following information must be entered correctly to ensure
that the mount works correctly. Information should be provided by an
administrator for the network or Amazon™ Web Services (AWS).
¢ Bucket Name—The name of the AWS S3 bucket.
* Access Key Id—A key identifier that, similar to a username, provides
programmatic and CLI access to AWS resource, such as the S3 bucket
* Secret Access Key—An access key that, similar to a password, provides
programmatic and CLI access to AWS resource, such as the S3 bucket.
* Region—The AWS region in which for the S3 bucket resides. For example,
us-east-1, us-west-1.
4. (Optional) Select Automount to allow the system to mount backup directories
automatically when the system is rebooted.
When the option is unselected, you must mount a directory after a reboot.
5. Click Save.
Change the In the Backup Disk Space section, select the directory that will be used for backups
existing backup | from the Backup directory drop-down list.
directory You must add a mount point before for the backup directory can be selected.
Backup directory: @
Select a Mount point s
Select a Mount point
/ddn (Source: ddn4.itw:/gs1/ion-data/dx-data)
/ifs (Source: isilon.itw:/ifs)
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(continued)

Option

Description

Remove a
backup
directory that is
not in use, for
example a
directory that is
full or is no
longer available

Click Remove Mount.

Click Remove.
Click Save.

P W N2

If you remove a directory that is in use for backup, backups cannot not be performed

until you select a new backup directory.

In the Remove Mount dialog box, select the mounted drive you want to remove.

4. In the Backup & Restore screen, click Save to save the new selections.

The changes that you made are shown in the Backup Disk Space section of the Backup Settings

Sscreen.

Set up a backup server (administrator)

Administrator-level users can set up an external storage device to be a backup server to store system
data with this procedure. Alternatively, administrator-level users can directly set up a backup server in
Genexus™ Software. For more information, see “Add or change the backup directory (administrator)” on

page 321.

IMPORTANT! We recommend Network File System (NFS) version 3 (NFSv3) or NFS version 4 (NFSv4)
with Linux Operating System external storage devices for Genexus™ Software.

1. Mount the NFS to the sequencer.

The following example is for users who have an existing NFS with read and write access. Mount
the NFS to the sequencer using the fstab file so that the mount point is persistent (NFS mounts
automatically after rebooting).

Example:

For NFS share: cqtsop4:/md1200
Mount point: nfs1

2. Create a mount point to mount the external device on nfs share.

a. Create the directory /nfs1 using the following command:
sudo mkdir /nfsl

b. Append the mount point entry in /etc/fstab.

Command example:
sudo vi /etc/fstab
cgtsop4:/md1200 /nfsl nfs defaults 0 O

c. Save, then exit by pressing Esc on your keyboard, then type :wq
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3. Create a permanent or temporary mount on nfs share:

* Permanent mount command: sudo mount -a
® Temporary mount command (example): sudo mount cgtsop4:/md1200 /nfsl

4. Verify that the NFS share is mounted using the df -kh command.
ionadmin@eternityl:~$ df -kh
Filesystem Size Used Avail Use$% Mounted on
/dev/sda9 253G 5.9G 235G 3% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
udev 63G 4.0K 63G 1% /dev
tmpfs 13G 1.3M 13G 1% /run
none 5.0M 0 5.0M 0% /run/lock
none 63G 0 63G 0% /run/shm
none 100M 0 100M 0% /run/user
/dev/sdab 19G 2.9G 15G 17% /var
/dev/sdal 938M 37M 854M 5% /boot
/dev/sda6 9.1G 1.7G 7.0G 20% /home
/dev/mapper/raid-serverdata 8.4T 4.3T 4.1T 52% /serverdata
/dev/mapper/raid-servershare 1.0T 9.0G 1015G 1% /servershare
/dev/mapper/raid-scratch 1.0T 838M 1023G 1% /scratch
/dev/sda7 92G 61M 87G 1% /tmp
pluto:/md1200 37T 1.1T 36T 3% /nfs2
penguin-tsl:/local 11T 9.3T 978G 91% /nfs
ddn4.itw:/gsl/ion-data/dx-data 1.1P 1001T 115T 90% /ddn
cqgtsop4:/md1200 37T 37T 77G 100% /nfsl

The mounted directory is listed in the Backup Directory dropdown list in the Backup & Restore
screen.

For more information, see help.ubuntu.com/Its/serverguide/network-file-system-configuration.

Change the backup settings (administrator)

A backup directory must be set up before an administrator-level user can change the backup settings.
For more information, see “Disk space usage and backup settings (administrator)” on page 316.

The following types of data are backed up daily at midnight and cannot be changed:

¢ System Data-Includes the system database, reference files, assay definition files, annotation
content, and custom and system-installed panel files, hotspot files, fusion reference files, and CNV
baseline files.

* Analysis Results-The final results generated after sequencing and analysis. Analysis results
include run details, all BAM files, filtered results, graphs, run reports, metrics, plugin results,
annotated variant data, and VCF files.
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IMPORTANT! The first time you back up the system, it takes a considerable amount of time. The
amount of time required for system backup depends on the number of runs that require backup and
the amount of disk space used. For more information, see “Specifications and disk space usage” on
page 318.

A system restart also takes time. When the system restarts, it resumes the backup where it left off.

1. In the menu bar, click ¢ (Settings) » Backup & Restore.

2. In the Backup & Restore screen, in the Backup Settings tab, edit the backup settings.

Option Procedure

Back up .wells files Select the Sequencing Output checkbox.
Sequencing output backup takes time.

Back up intermediate files, such | Select the Intermediate Files checkbox.
as intermediate BAM files and
log files

Change the frequency or timing | Select Daily or Weekly, then select the time and day, if applicable,
of the .wells and intermediate for the backup.

files backup Intermediate file backup takes time. Consider scheduling the
backup of intermediate file on a weekend or at a time when the
system is not in use.

3. Click Save.

View and export the audit trail for backup settings (administrator)

An administrator-level user can view the audit trail for backup settings, disk cleanup settings, and email
notification settings in Genexus™ Software.

1. In the menu bar, click ¢ (Settings) » Backup & Restore

2. In the Backup & Restore screen, view the audit trail.

Option Procedure
View the audit trail for the In the Backup Settings section, click audit to review changes made to
backup settings the backup settings.

View the audit trail for email | In the Email Notification Settings section, click audit to review changes
notification settings made to the email notification settings.

View the audit trail for disk | In the Disk Cleanup Settings section, click audit to review changes
cleanup settings made to the disk cleanup settings.

3. In the Audit Trail - Archive Settings screen:

Option Procedure
Export the record to a PDF file Click Download.
Return to the Backup Settings tab. Click < Back.
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Set a schedule to permanently delete files (administrator)

Results files and .wells files, and intermediate files that have been backed up can be scheduled to be
deleted by an administrator-level user in Genexus™ Software.

Intermediate and .wells files include intermediate BAM files, log files, and Sequencing output files.
These files are not backed up by default. When you set a schedule to delete these files, by default, the
files are deleted when they are not backed up and the system disk space falls below 4 terabytes (TB).
You can change the system disk space threshold to delete these files.

Run results that are retained are never deleted in the software, even when you set a schedule to
permanently delete run results in the software. For more information, see “Retain run results” on
page 155.

IMPORTANT!

. By default, when the Disk Cleanup Settings are enabled, the software is set to delete results 12
months after the run was last updated and backed up. You can change this setting.

. Intermediate and .wells files are not backed up unless an administrator-level user sets a schedule to
back up these files. By default, these files are auto-deleted when the free disk space threshold is
met, even when these files are not backed up. If you select to keep the default auto-delete setting for
intermediate and .wells files and the files are deleted, the impact is minimal.

You cannot perform the following actions when these files are deleted.
. Reanalyze a run from basecalling.
. Upload to lon Reporter™ Software.

« Run the CustomerSupportArchive plugin.
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1. In the menu bar, click 3 (Settings) » Backup & Restore

2. In the Backup & Restore screen, in the Disk Cleanup Settings section:

Option Procedure
Do not auto-delete In Delete Analysis Results, click No.
analysis results at any
time.
Change the schedule Analysis results are deleted only if the results have been backed up.
to permanently delete . .
analysis results. 1. In Delete Analysis Results, click Yes.
2. In months after completion, set the schedule to delete the files:
¢ 3 months * 12 months
®* 6 months * 24 months - default setting
* 9 months ® 36 months
Do not auto- In Delete additional files, click No.
delete .wells files and
intermediate files at any
time.
Change the schedule In Delete additional files, click Yes, then select the threshold of free disk
to permanently space on the instrument, from 1 to 10 TB, that triggers the system to delete
delete .wells files and these files.
intermediate files. The system automatically deletes .wells and intermediate files when the disk
space falls below the selected threshold.
If you have enabled the backup of intermediate files and .wells files, these
additional files must be backed up before they can be deleted.
3. Click Save.

Archive a run result (administrator)

In addition to system cleanup, in which all backed up runs that are older than a specified length of time
are archived, an administrator-level user can archive one to five run results at any time. Archived run
results are copied to the external storage device or to a cloud system that you have set up. Then the
archived run results are removed from the sequencer.

When you archive a run result, the analysis results files are archived. In addition, you can archive the
intermediate and 1.wells files, if needed. You can archive run results that are no longer needed to
ensure that there is sufficient disk space on the sequencer.
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If you archive a run result at the time of a scheduled system archive, the system cleanup is skipped for
that instance.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, place the pointer over one or more run result that you want to archive,
then click & Archive Data.

3. In the Confirm archive data for selected result(s) dialog box, select Sequencing Output and
Intermediate files to include 1.wells and intermediate files, if needed.

4. Click Archive.

Archived runs results are listed in the Run Results screen with the archived symbol () after the run
name. An administrator-level user can restore the run result to access the data.

Delete a run result (administrator)

An administrator-level user can delete a run result in Genexus™ Software. When you delete a run result,
files for the run result are deleted from the sequencer.

IMPORTANT! This action cannot be reversed if you proceed. You can delete a run result even if it is
not backed up. Ensure that you do not need the run result before you delete the run result from the
sequencer and the software if the run result has not been backed up.

1. In the menu bar, click Results » Run Results.

2. In the Run Results screen, select the checkbox in the row of one or more run results that you want
to delete.

3. In the Confirm delete data for selected result(s) dialog box, confirm that the data are backed up,
if needed, and select the files to delete.

* Sequencing Output
* Intermediate Files
¢ Analysis Results

If you delete the analysis results files, the sequencing output and intermediate files are also
deleted.
4. Click 1il Delete.

5. Click Yes to confirm the deletion.

The files for the run result that you select are deleted from the sequencer and are no longer available in
the software. If the run results are backed up before the deletion, an administrator-level user can restore
the run result to access the data.

You can view the audit trail for a run result that you have deleted in the & (Settings) / Audit Records
screen. Deleted run results are listed as Planned Runs. For more information, see “Search audit
records (administrator)” on page 308.
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Data output directory

The data output directory is the primary location on the hard drive where data generated by the
Genexus™ Integrated Sequencer is stored.

The directory location is locked and cannot be changed. Users should configure their laboratory
information management systems (LIMS) to access this folder location to receive sequencing output
files.

After a sequencing run and data analysis are complete, the software creates a separate results folder in
the data output directory for each sample, and uses the following naming conventions:

AssayDev_<Sample Name>_<Assay Name>_<RunPlanShortCode>_<RunPlanShortCode>

Email notifications

Administrator-level users receive email notifications when there is a restore run failure. Administrator-
level users can also receive email notifications when other conditions are met, such as when the
system has limited free disk space remaining. To review or update these settings, see “Change email
notification settings (administrator)” on page 330.

Before administrator-level users can receive email notifications, an administrator or manager must first
set up notifications for valid Genexus™ Software user accounts. For more information, see “Configure
email notifications (manager/administrator)” on page 310.

Change email notification settings (administrator)

Administrator-level users can select when to receive email notifications, such as when the system
has limited disk space remaining. Administrator-level users receive an email message when conditions
occur according to the selections in the email notification settings.

1. In the menu bar, click 3 (Settings) » Backup & Restore

2. In the Backup & Restore screen, in the Email Notifications Settings section, select or deselect
the checkbox next to one or more of the following options. Administrator-level users receive email
notifications for options that are selected. They do not receive email messages for options that are
deselected.

* Backup fails or has insufficient storage space.
* Backup is successfully completed.

* Genexus™ Integrated Sequencer has insufficient system disk space. Select the amount of
sequencer disk space that must be available in the dropdown list.

* Backup fails or has insufficient disk space. Select the amount of backup disk space that must
be available in the dropdown list.

3. Click Save.

Changes to the email notifications take effect immediately.

330 Genexus™ Software 6.8 User Guide



Chapter 10 System administration and management (manager/administrator) ey

Manage backup settings and restore runs (administrator)

Restore run results (administrator)

An administrator-level user can configure Genexus™ Software to automatically back up older run data,
results files, and signed reports to external data storage or a cloud storage space. For more information,
see “Disk space usage and backup settings (administrator)” on page 316 and “Add or change the
backup directory (administrator)” on page 321. In addition, an administrator-level user can set a
schedule to automatically delete backed up runs after a specified amount of time. For more information,
see “Set a schedule to permanently delete files (administrator)” on page 327. Runs, for which analysis
results have been backed up and deleted in the software, are listed in the Run Results screen and are
denoted with the archived symbol () after the run name.

An administrator-level user can later restore the run results, files, and reports in the software. There are
two ways to restore run results in Genexus™ Software.

* For information about how to restore run results for a single run, see “Restore run results for a
single run (administrator)” on page 331.

* For information about how to restore or import multiple run results, see “Restore or import multiple
archived run results (administrator)” on page 331.

Restore run results for a single run (administrator)

An administrator-level user can restore run results, files, and reports that have been archived in
Genexus™ Software.

Archived runs that can be restored are listed in the Results / Run Results screen with the Restore
link active when you place the pointer over the row of run. Runs, for which analysis results have

been backed up and deleted (archived) from the system, are listed in the Run Results screen and are
denoted with the archived symbol () after the run name.

—

In the menu bar, click Results » Run Results.
2. In the Run Results screen, click the run name of interest.

3. In --- (More Options), click Restore.

b

Click OK in the confirmation dialog box.

o

Click the run name in the Run Results screen to view run results.

Restore or import multiple archived run results (administrator)

An administrator-level user can:
* Restore run results, files, and reports that have been archived.

* Import run results, files and reports from external data storage or another Genexus™ Integrated
Sequencer.

Note: Do not attempt to import verification runs because they are specific to a single system.

Sample to Result run details for the Genexus™ Purification Instrument are not displayed in the target
system (the system results are imported to) if the target system does not have a connected purification
instrument.

After a run is imported, you can access Run Results and Sample Results in the target system.
Genexus™ Integrated Sequencer details are also listed with the instruments in the target system.

Genexus™ Software 6.8 User Guide 331



P Chapter 10 System administration and management (manager/administrator)
Manage backup settings and restore runs (administrator)

Results that have been backed up, then deleted in the software, are listed in the Results / Run Results
screen with [ (archived) after the run name.

Before you can import a run from external data storage or another Genexus™ Integrated Sequencer:

* The run data must be archived to external data storage, and the same external data storage must
be connected to the Genexus™ Integrated Sequencer to which you will import the run.

* The samples for the run or runs that you want to import must have been created in the software
with identical names. For more information about how to import a sample from another system, see
“Import samples” on page 34.

* The assay for the run or runs that you want to import must exist in the software. Ensure that
the name of the assay, the barcode kit, and the extraction method type for the source system
and the target system are identical. Other assay parameters, such as hotspots, the filter chain,
gene list, and report template do not need to match and are not imported to the target system.
For information about how to import an assay, see “Import an assay (manager/administrator)” on
page 238.

You can search the list of runs that can be restored by the run name or a sample tag name. However, if
you restore a run that has an assigned sample tag name that has been deleted in the software, the tag
is not shown in the software when you restore the run. In this case, you can reassign the tag if needed.
For more information, see “Sample tags” on page 46.
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1. In the menu bar, click 8 (Settings) » Backup & Restore.

2. In the Backup & Restore screen, click the Restore Runs tab and select from the following

options.

Option

Description

Restore archived run
results

In the type of runs dropdown menu, keep the selection of Archived runs.

2. In the dropdown menu, select the mounted drive that contains the runs
that you want to restore, then click Browse.

3. In the Select backup folder to list runs dialog box, navigate to the folder
with the name of the system that you use, then select the subfolder that
contains the runs you want to restore and click Select.

4. In the Restore Runs tab, select the checkbox in the row for each run that
you want to restore, then click Restore Runs.

Use the Search By dropdown list and the search field to search for
samples by a run name or by sample tags.

The process to restore runs takes time. After the archived run is restored,
you can view the run results for the run in the software.

5. (Optional) After the archived run is restored, click Check Log to view if the
process was successful or if there are problems.

Import run results
from another system

In the type of runs dropdown menu, keep the selection of Archived runs.

2. In the dropdown menu, select the mounted drive that contains the runs
that you want to restore, then click Browse.

3. In the Select backup folder to list runs dialog box, navigate to the folder
for a different system, then click Select.

4. In the Restore Runs tab, select the checkbox in the row for each run that
you want to import, then click Restore Runs.
Use the Search By dropdown list and the search field to search for
samples by a run name or by sample tags.
The process to restore runs takes time. After the archived run is restored,
you can view the run results for the run in the software.

5. (Optional) After the archived run is imported, click Check Log to view
if the process was successful or if there are any problems, such as if a
sample has not been created in the software.

Restore runs if there
is a system crash

Genexus™ Software 6.8 User Guide

Use this procedure only if there is a system crash and you have worked with a
Field Service Engineer (FSE) to restore the data onto a new system. When you
select All runs in any other instance, the software overwrites existing data with
identical data.

In the type of runs dropdown menu, select All runs.

2. In the dropdown menu, select the mounted drive that contains the runs
that you want to restore, then click Browse.

3. In the Select backup folder to list runs dialog box, navigate to the folder
that contains the runs that you want to restore, then click Select.
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Option Description

4. In the Restore Runs tab, select the checkbox in the row for each run that
you want to restore, then click Restore Runs.
Use the Search By dropdown list and the search field to search for
samples by a run name or by sample tags.
The process to restore runs takes time. After the archived run is restored,
you can view the run results for the run in the software.

5. (Optional) After the archived run is restored, click Check Log to view if the
process was successful or if there are problems.

Log files (administrator)

Administrator-level users use the Logs screen to view log files generated by the software and
connected purification and sequencing instruments. Viewing log files is useful for troubleshooting
activities.

Administrator-level users can also use the Logs screen to manage the storage of log data by setting the
retention period for the audit trail function and enabling auto-deletion rules for logs.

View log files (administrator)
Administrator-level users can view software and instrument log files in Genexus™ Software.
1. Click ¢ (Settings) » Logs.

2. In the Logs screen, select an option in the software or connected instrument dropdown menu.

Option Description
View software log files. Click lon Torrent Genexus Software.
View log files for a connected purification or Click Instrument.

sequencing instrument.

3. Click the log file name of interest.

File name Description

ApplicationLog <date>.log A log file with information related to some actions
in the Genexus™ Software, including user sign-ins
and sign-outs and failed attempts to sign-in or

sign-out.
InstrumentGX5 date.log A log of activity on the sequencer instrument.
InstrumentPurif date.log A log of activity on the purification instrument.

The log file opens in a new tab in the browser.
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Manage log settings (administrator)

An administrator-level user manages the length of time that log files are kept and configures the
software to allow log files to be automatically deleted.

This feature allows you to meet Title 21 CFR Part 11 of Federal Regulations that establishes the
United States Food and Drug Administration regulations on electronic records and signatures, password
policies, and user activity auditing.

1. Click ¢ (Settings) » Logs.
2. Inthe Logs screen, click [2 Manage Logs.

3. In the Manage Logs dialog box, in Retention Period, select the number of months that logs are to
be retained on the sequencer.

4. Select Enable Auto Deletion to delete log files automatically after the designated retention period.

5. Click Save.

View the log settings history

Administrator-level users can view the history of changes made to the settings for the retention of log
files in Genexus™ Software.

1. Click ¢ (Settings) » Logs.

2. Inthe Logs screen, click ¥ Audit Trail.
The Audit Trail - Log Settings screen opens.

3. Click < Back to return to the list of log files.

System services (manager/administrator)

Manager- and administrator-level users can view information about system services using the
& (Settings) / Services screen. The information can be useful to troubleshoot error messages that
are received during an active job, or determine why a run failed.

Service Function
Jobs Server Shows a list of server information and active (running) software.
Services Shows the service name, description, and status. The Services list can be used

for troubleshooting. If a service has stopped during a run, an option to start the
service is visible for manager- and administrator-level users.

For more information, see “Start a stopped service (manager/administrator)” on
page 336.
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(continued)
Service Function
Active Jobs e Shows a list of runs in progress that are active and queued on the
sequencer.
* The message “No records available” indicates that no jobs are currently
active.
¢ Allows manager- and administrator-level users to stop a job.
For more information, see “Terminate an active job (manager/
administrator)” on page 336.
ionCrawler Service Provides information about the data transfer process from the Genexus™
Details Integrated Sequencer. The information includes whether the service was started
or stopped, which user completed the action, and a timestamp for the action.
Smart Monitoring Allows remote monitoring of the Genexus™ Integrated Sequencer. Allows
Service Details manager- and administrator-level users to start or stop the service. For more
information, see “Start a stopped service (manager/administrator)” on page 336.
Download Instrument Contains the initialization logs of the Genexus™ Integrated Sequencer, and
Diagnostics allows you to download the diagnostic archive file in ZIP format.
System Check Report Manager and administrator-level users can click Run System Check to view the
system check report.

Terminate an active job (manager/administrator)

If an active job is not going to be useful or if a different job is urgent, you can terminate an active job. A
manager- or administrator-level user can stop an active job in the & (Settings) / Services screen.

1. In the menu bar, click 3 (Settings) » Services.

2. In the Services screen, in the Active Jobs section, find the active job that you want to stop, then
click Terminate.
A confirmation message opens, Are you sure you want to terminate <job name> ?.

3. Click Terminate to terminate the job.

Start a stopped service (manager/administrator)

A manager- or administrator-level user can use the & (Settings) / Services screen to restart a
stopped service if a service has stopped running for some reason. The two database services, ntp
and deeplaser, are the only services that can be restarted.

1. In the menu bar, click & (Settings) » Services.

2. In the Services screen, in the Services section, find the service that you want to restart, then click
Start.

A confirmation message opens, Are you sure you want to Start <service name>?.

3. Click Yes to restart the service.
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Disable or enable the Smart Monitoring service (manager/administrator)

The Smart Monitoring service allows Thermo Fisher Scientific personnel to monitor the status of the
Genexus™ Integrated Sequencer remotely through an internet connection. Smart Monitoring employs
multiple layers of security, including a Secure Sockets Layer (SSL) and Lightweight Directory Access
Protocol (LDAP) authentication, to provide real-time troubleshooting and problem resolution for the
Genexus™ Integrated Sequencer.

The Smart Monitoring service is active by default and can be disabled by manager- or administrator-
level users, if required.

¢ Disable the service.
a. In the menu bar, click ¢ (Settings) » Services.

b. In the Services screen, in the Smart Monitoring Service Details section, click Stop.

c. In the confirmation message, click Yes to disable the service.
The Stop option changes to Start.

* Enable the service.
a. In the menu bar, click 3 (Settings) » Services.

b. In the Services screen, in the Smart Monitoring Service Details section, click Start.

c. In the confirmation message, click Yes to enable the service.
The Start option changes to Stop.
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You can expand the analysis capabilities of Genexus™ Software with plugins that are preinstalled with
the software. The plugin results are added to the report summary and can be used for a various
purposes.

An administrator-level user can download and install more plugins from the Thermo Fisher™ Connect
Platform.

coverageAnalysis plugin in Genexus™ Software

Use the coverageAnalysis plugin to view statistics and graphs that describe the level of sequence
coverage produced for targeted genomic regions. The results for a run analyzed with the plugin vary
based on the library type that you select when you configure the plugin. You can export some charts as
graphics, such as the Amplicon Coverage Chart and the Reference Coverage Chart.

Review coverageAnalysis plugin results

The coverageAnalysis plugin generates a Coverage Analysis Report. This report includes read statistics
and several charts. The statistics and charts that are presented depend on the library type for the
analysis.

The report summary lists the barcode, the sample, the number of mapped reads, the percentage of on
target reads, mean base coverage depth, and base coverage uniformity. Microsoft™ Excel™-compatible
reports are also generated, including differential expression tables. Additional details regarding read
coverage are also provided on a per-barcode basis, along with a list of gene annotations for each
sequenced region.

You can download coverageAnalysis plugin output files from the Results screen for a sample. For
more information, see “Results files” on page 171 and “Output files generated by the coverageAnalysis
plugin” on page 346.

1. In the menu bar, click Results » Sample Results.

2. In the Sample Results screen, in the Sample Name column, click the sample of interest.
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3. Click the Plugins tab.

A summary table of the coverage analysis, by barcode, is included in the coverageAnalysis
summary pane.

4. (Optional) From the Executed At dropdown list, select an alternate timestamp, if available, to view
additional reports.

5. (Optional) Click [3 View Log to view the coverageAnalysis log.

6. (Optional) Click Ti] Delete to delete the coverageAnalysis plugin output for the selected timestamp.

IMPORTANT! If you click Ti] Delete, the report is deleted without the appearance of confirmation

dialog window. Ensure that you intend to delete the report before clicking [i] Delete.

7. In the coverageAnalysis summary pane, in the Barcode Name column, click the link in the row of
the barcode of interest.

The detailed Coverage Analysis Report for the barcode opens in a separate window.

Reads statistics

The detailed Coverage Analysis Report that is available when you select a barcode in the
coverageAnalysis plugin summary for a run includes a variety of reads statistics. The statistics that
are displayed in your report depend on the type of library that is used in your sequencing experiment.
Definitions are in tooltips. Aimost every statistic, plot, link, and functional widget in the report provides
tooltips with definitions. Hover over a heading or description in the report to view the tooltip.

General statistics

Statistic Description
Number of mapped reads The total number of reads mapped to the reference genome.
Percent reads on target The percentage of filtered reads mapped to any targeted region relative to all reads

mapped to the reference. If no target regions file is specified, this value will be the
percentage of reads passing uniquely mapped and/or nonduplicate filters, or 100%
if no filters were specified. A read is considered on target if at least one aligned
base overlaps at least one target region. A read that overlaps a targeted region but
where only flanking sequence is aligned, for example, due to poor matching of 5
bases of the read, is not counted.
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Amplicon read coverage statistics

The following statistics describe the reads that are assigned to specific amplicons. Each sequence
read is assigned to exactly one of the amplicons specified by the targets file. If a read spans multiple
amplicon targets, the target region that the reads covers most is assigned. In the event of a tie, the
target that is the closest to the 3' end is assigned.

Statistic

Description

Number of amplicons

The number of amplicons that is specified in the target regions file.

Percent assigned amplicon
reads

The percentage of reads that were assigned to individual amplicons relative to all
reads mapped to the reference. A read is assigned to a particular (inner) amplicon
region if any aligned bases overlap that region. If a read might be associated with
multiple amplicons, it is assigned to the amplicon region that has the greatest
overlap of aligned sequence.

Average reads per amplicon

The average number of reads assigned to amplicons.

Uniformity of amplicon
coverage

The percentage of amplicons that had at least 20% of the average number of reads
per amplicon. Cumulative coverage is linearly interpolated between nearest integer
read depth counts.

Amplicons with at least N
reads

The percentage of all amplicons that had at least N reads.

Amplicons with no strand
bias

The percentage of all amplicons that did not show a bias towards forward or
reverse strand read alignments. An individual amplicon has read bias if it has =10
reads and the percentage of forward or reverse reads to total reads is greater than
70%. Amplicons with <10 reads are considered to have no strand bias.

Amplicons reading end-to-
end

The percentage of all amplicons that were considered to have a sufficient
proportion of assigned reads (70%) that covered the whole amplicon target from
‘end-to-end'. To allow for error, the effective ends of the amplicon region for read
alignment are within 2 bases of the actual ends of the region.

Amplicon base composition
bias

A number that represents the proportion of amplicons showing low representation
(<0.2x mean reads) in the lower and/or upper quartiles of amplicons ordered by
increasing G/C base pair content of their insert sequences. The value is relative
to that in the center 50th percentile of amplicons and weighted by the standard
deviation of representation over all amplicons. An RMS (root mean square) value
is used so that a bias greater in either upper or lower quartiles produces a larger
value than a mean bias seen more equally in both outer quartiles. The value is 0

if the uniformity of amplicon coverage metric is 100%, however, the value is not
necessarily high at lower amplicon uniformity.
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Target base coverage statistics

The following statistics describe the targeted base reads of the reference. A base covered by multiple
target regions is counted only once per sequencing read.

Statistic

Description

Bases in target regions

The total number of bases in all specified target regions of the reference.

Percent base reads on target

The percent of all bases covered by reads aligned to the reference that covered
bases in target regions. Clipped bases, deletions, and insertions (relative to the
reference) are not included in this percentage.

If no specific target regions were specified, the whole genome is the targeted
regions.

Average base coverage
depth

The average number of reads of all targeted reference bases. This is the total
number of base reads on target divided by the number of targeted bases, and
therefore includes any bases that had no coverage.

Uniformity of base coverage

The percentage of bases in all targeted regions (or whole genome) that is covered
by at least 20% of the average base coverage depth reads. Cumulative coverage is
linearly interpolated between nearest integer base read depths.

Target base coverage at Nx

The percentage of target bases covered by at least N reads.

Target bases with no strand
bias

The percentage of all target bases that did not show a bias toward forward or
reverse strand read alignments. An individual target base is considered to have read
bias if it has =10 reads and the percentage of forward or reverse reads to total
reads is greater than 70%. Target bases with <10 reads are considered to have no
strand bias.

Percent end-to-end reads

The percentage of on-target reads that fully cover their assigned amplicon (insert)
from 'end-to-end'. To allow for error, the effective ends of the amplicon region for
read alignment are within 2 bases of the actual ends of the region.

Bases in targeted reference

The total number of bases in all target regions of the reference.

This statistic applies only to whole genome library analyses.

Bases covered (at least 1x)

The total number of target bases that had at least one read aligned over the
proximal sequence. Only the aligned parts of each read are considered. For
example, unaligned (soft-cut) bases at the 5' ends of mapped reads are not
considered. Covered target reference bases can include sample DNA read base
mismatches, but does not include read base deletions in the read, nor insertions
between reference bases.

This statistic applies only to whole genome library analyses.

Average base read depth

The average number of reads of all targeted reference bases that were read at least
one time.

This statistic applies only to whole genome library analyses.

Genexus™ Software 6.8 User Guide 341



!l | ]

Chapter 11 Plugins for data analysis
coverageAnalysis plugin in Genexus™ Software

(continued)
Statistic Description
Genome Base Coverage Summary statistics for base reads of the reference genome.

This statistic applies only to whole genome library analyses.

Nx

Genome base coverage at The percentage of reference genome bases covered by at least N reads.

This statistic applies only to whole genome library analyses.

Example charts generated by the coverageAnalysis plugin

342

Many of the charts in the detailed Coverage Analysis Report include a Plot menu that allows you
to change characteristics of the chart. For example, you can show both strands (see callout 3 in
Figure 15).

The Q button (in the top right corner of a chart) opens the chart Viewing Options panel. The ? button
opens a description of the chart.

+ Depth of Coverage Chart Plot: Maximum Read Depth v Zoom Out ) ? R
4.0% 100%
Bases
Cumulative Bases 80% 4
3.0% k4
w
®
60%
2 o
@B32.0% =
3 g
(] 0% 5
g
%
L 20% ©
0.0% 0%
0 1000 2000 3000 4000 5000 6000 7000 8000 9000 10000 11000
Base Read Depth v
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Figure 11 Representative Depth of Coverage Chart

The Depth of Coverage Chart shows the distribution of targeted base coverage. The X-axis represents the base read
depth. The left Y-axis represents the number of reads at a given base read depth or a range (bin) of base read depths, as
a percentage of the total number of base reads. The right Y-axis represents the cumulative count of the number of reads
at a given read depth or greater, as a percentage of the total number of reads. The individual orange bars represent the
percentage of reads in the specific range of base read depths. The blue curve measures the cumulative reads at a given
base read depth or greater. If your analysis includes a regions of interest file, this chart reflects only target regions (reads
that fall within a region of interest).

In most charts, you can click a data point to open a detail pane for that data. For example, in the

Depth of Coverage Chart in Figure 11, click an individual orange bar to open the detail pane for bases
within a specific range of base read depths. Click a point on the blue curve to open the detail pane for
cumulative bases at that base read depth or greater. For example detail panes, see Figure 12. Similarly,
you can click any point or bar within the Amplicon Coverage chart to view details for each amplicon
coverage bin (see Figure 14).

Bases at depths 1,420-1,429 = Cumulative Bases at depth 2,600 L]
Number of target bases read: 96 Number of target bases read: 61,209
Fraction of all target bases read: 4.37% | Fraction of all target bases read: 65.20%

Figure 12 Example detail panes
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Figure 13 Representation Plots

Use the Display list to view different amplicon representation plots. This figure shows an example Pass/Fail vs. Target G/C

Content plot.
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Figure 14 Example Amplicon Coverage Chart

The Amplicon Coverage charts summarize the amplicon coverage results. Several plots views are available. The X-axis in
all plots represents individual amplicons. The left Y-axis in all plots represents assigned reads (on a base 10 log scale).
Use the Plot and Overlay lists to customize the chart view. The right Y-axis varies depending on the plot view that is
selected from the Overlay dropdown list. Click on any bar or any point on the chart to view the detail pane for that data.

@ Example Total Reads plot with a Target GC percentage overlay

@ Click on a bar to open the detail pane for the specific amplicon. Click View in Reference Coverage Chart to zoom
in on the amplicon in the Reference Coverage Chart (see callout 3 in Figure 15).
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Figure 15 Example Reference Coverage Chart

The Reference Coverage Chart is an overlay of where target regions are defined and overlap on the reference. The X-axis
represents the target region chromosomal position. The Y-axis represents the Base Read Depth.

@ Example Total Base Reads plot with Viewing Options panel expanded. The plot is zoomed in on a specific
chromosomal region. Click a yellow bar (top of the chart) to open the detail pane for a specific amplicon in the
Amplicon Coverage Chart (see callout 2 in Figure 14).

@ Example Total Base Reads plot where a chromosomal region has multiple targets. In the Resolve Multiple Targets
pane, click @ to zoom in on the region, or click one of the links to open the detail pane for the specific amplicon in
the Amplicon Coverage Chart.

@ Example Strand Base Reads plot that is zoomed in on one specific amplicon. Click the yellow box to open the detail
pane for the specific amplicon in the Amplicon Coverage Chart.

344 Genexus™ Software 6.8 User Guide



Example Coverage Analysis Report

The detailed Coverage Analysis Report that is available when you select a barcode in the
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coverageAnalysis plugin summary for a run includes a variety of reads statistics.

Coverage Analysis Report

Sample Name:

Library type: AmpliSeq HD - DNA and Fusions (Single Library)
Reference: hgl9 (DNA)
Target regions:

Log10{Base Reads)

a2 ety

Reforance Locaion

Amplicon Read Coverage

Number of amplicons

Percent assigned amplicon reads
Average reads per amplicon
Uniformity of amplicon coverage
Amplicons with at least 1 read
Amplicons with at least 20 reads
Amplicons with at least 100 reads
Amplicons with at least 500 reads
Amplicons with no strand bias
Amplicons reading end-to-end
Amplicon base composition bias
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38
96.16%
1,201
100.00%
100.00%
100.00%
100.00%
100.00%
100.00%
100.00%
0.000

Number of mapped reads
Percent reads on target

Average base coverage depth
Uniformity of base coverage

Target Base Coverage

Bases in target regions

Percent base reads on target
Average base coverage depth
Uniformity of base coverage
Target base coverage at 1x
Target base coverage at 20x
Target base coverage at 100x
Target base coverage at 500x
Target bases with no strand bias
Percent end-to-end reads

48,721
96.16%
1,177
100.00%

2,195
53.78%
1177
100.00%
100.00%
100.00%
100.00%
100.00%
100.00%
96.21%

! l! L

1.1
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Output files generated by the coverageAnalysis plugin

You can download coverageAnalysis plugin results files from the Results screen for a sample. For more
information, see “Results files” on page 171.

Note: Sometimes the downloaded file name can be too long to open a file in applications such
as Microsoft™ Excel™. To resolve this problem, right-click the file, click Save As, then rename the
downloaded file with a shorter name.

The following tables describe the files that can be generated by the coverageAnalysis plugin. The list of

files depends on the type of assay template that was selected during assay creation.

File download selections in the Genexus™ Software

Selection File Name
DNA Coverage Statistics <DNA Barcode><ExpName>.stats.cov.txt
DNA Chromosome base coverage summary | <DNA Barcode><ExpName>.chr.cov.xls
DNA Base depth of coverage <DNA Barcode><ExpName>.base.cov.xls
DNA Amplicon coverage summary <DNA Barcode><ExpName>.amplicon.cov.xls
DNA Coverage Analysis Summary (.pdf) <DNA Barcode><ExpName>.summary.pdf
RNA Coverage Statistics <RNA Barcode><ExpName>.stats.cov.txt
RNA Amplicon coverage summary <RNA Barcode><ExpName>.amplicon.cov.xls
RNA Coverage Analysis Summary (.pdf) <RNA Barcode><ExpName>.summary.pdf
TNA Coverage Statistics <TNA Barcode><ExpName>.stats.cov.txt
TNA Chromosome base coverage summary | <TNA Barcode><ExpName>.chr.cov.xls
TNA Base depth of coverage <TNA Barcode><ExpName>.base.cov.xls
TNA Amplicon coverage summary <TNA Barcode><ExpName>.amplicon.cov.xls
TNA Coverage Analysis Summary (.pdf) <TNA Barcode><ExpName>.summary.pdf

346

Genexus™ Software 6.8 User Guide




File contents

Chapter 11 Plugins for data analysis  [Fi0g
coverageAnalysis plugin in Genexus™ Software

File Description
Coverage A summary of the statistics presented in the tables at the top of the plugin report. The first line
Statistics is the title. Each subsequent line is either blank or a particular statistic title followed by a colon
(:) and its value.
Chromosome Base reads per chromosome summary data that is used to create the default view of the
base coverage Reference Coverage Chart. This file contains the following fields.
summary

* chrom: the name of the chromosome or contig of the reference.

* start: the coordinate of the first base in this chromosome. This is always 1.

* end: the coordinate of the last base of this chromosome. Also its length in bases.

* fwd basereads: the total number of forward strand base reads for the chromosome.
®* rev_basereads: the total number reverse strand base reads for the chromosome.

* fwd trg basereads (if present): the total number of forward strand base reads that
mapped over at least one target region.

* rev_trg basereads (if present): the total number of reverse strand base reads that
mapped over at least one target region.

* total reads: the total number of sequencing reads that are mapped to individual
contigs.

Base depth of
coverage

Coverage summary data used to create the Depth of Coverage Chart. This file contains the
following fields.

* read depth: the depth at which a (targeted) reference base has been read.
* base_cov: the number of times any base was read (covered) at this depth.

Note: Lines (read depths) for which base cov is 0 are omitted to avoid excessively large
files being produced in specific situations.

* base cum_cov: the cumulative number of reads (coverage) at this read depth or greater.

* norm read depth: the normalized read depth (depth divided by average base read
depth).

®* pc base cum_cov: same as base_cum_cov but represented as a percentage of the total
base reads.
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File contents (continued)

File

Description

Amplicon
coverage
summary

Coverage summary data used to create the Amplicon Coverage Chart. This file contains the
following fields:

contig id:the name of the chromosome or contig of the reference for this amplicon.
contig srt:the start location of the amplicon target region.

Note: This coordinate is 1-based, unlike the corresponding 0-based coordinate in the
original targets BED file.

contig_ end: the last base coordinate of this amplicon target region.

Note: The length of the amplicon target is given as tlen = (contig_end - contig_srt + 1).
region_id:the ID for this amplicon as given as the fourth column of the targets BED file.

gene_idorattributes:the gene symbol or attributes field as provided in the targets
BED file.

gc_count: the number of G and C bases in the target region. The %GC that is uses this
count divided by the amplicon (insert) length.

overlaps: the number of times this target was overlapped by any read by at least one
base.

Note: Individual reads might overlap multiple amplicons where the amplicon regions
themselves overlap.

fwd_e2e: the number of assigned forward strand reads that read from one end of the
amplicon region to the other end.

rev_eZ2e: the number of assigned reverse strand reads that read from one end of the
amplicon region to the other end.

total reads: the total number of reads assigned to this amplicon. This value is the sum
of fwd_reads and rev_reads and is the field that rows of this file are ordered by (then by
contig id, srt, and end).

fwd reads: the number of forward strand reads that are assigned to this amplicon.
rev_reads: the number of reverse strand reads that are assigned to this amplicon.

covNx: the number of bases of the amplicon target that had at least N reads. There are
3 such columns for the specified coverage tiers, which by default are cov20x, cov100x,
and cov500x.

Coverage
Analysis
Summary (.pdf)

A PDF file that contains the Coverage Analysis Report, including read statistics and charts that
are generated by the coverageAnalysis plugin.

molecularCoverage Analysis plugin in Genexus™ Software

Use the molecular Coverage Analysis plugin to view statistics and graphs that describe the level of
sequence molecular coverage produced for targeted genomic regions. The plugin generates statistics,
downloadable data files, and interactive visualizations of molecular coverage over targeted regions of
the reference genome.

The plugin is compatible only with lon AmpliSeg™ HD library chemistry.
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Review molecularCoverage Analysis plugin results

The molecularCoverage Analysis plugin generates a Molecular Coverage Analysis Report. This report
includes molecule statistics and several charts. The report summary lists the barcodes, the samples,
the median molecular coverage, the molecular uniformity, and the median reads per functional
molecule, and the median percentage of functional reads. Details regarding molecular coverage are
also provided on a per-barcode basis, along with a list of gene annotations for each sequenced region.

You can download statistics files from the file links at the bottom of the results screen when the Plugins
tab is selected. After the sequencing run completes, review the plugin results in the report summary.

1.

2.

In the menu bar, click Results » Sample Results.

In the Sample Results screen, in the Sample Name column, click the sample of interest.

Click the Plugins tab.

A summary table of the molecular coverage analysis, by barcode, is included in the molecular
Coverage Analysis summary pane, located beneath the coverageAnalysis summary pane, if

present.

In the molecular Coverage Analysis summary pane, view detailed plugin information.

Option

Description

View a detailed Molecular Coverage Analysis
Report for a barcoded sample.

In the Barcode Name column, click the barcode
name of interest.

View the molecular Coverage Analysis log.

Click [§ View Log.

View more reports.

In Executed At, select an alternate timestamp, if
available.

Delete the molecular Coverage Analysis plugin
output for the selected timestamp.

Click Ti] Delete.

Download a JSON file that shows the parameter
settings for the plugin.

Click the Parameters link.

5. Click the links at the bottom of the Molecular Coverage Analysis Report to download associated
statistics and summary files for each barcoded sample in the run.
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Molecule statistics

The detailed Molecular Coverage Analysis Report that is available when you select a barcode in the
coverageAnalysis plugin summary for a run includes a variety of reads statistics. The statistics that
are displayed in your report depend on the type of library that is used in your sequencing experiment.
Definitions are in tooltips. Almost every statistic, plot, link, and functional widget in the report provides
tooltips with definitions. Hover over a heading or description in the report to view the tooltip.

Statistic

Description

Median Functional Molecular
Coverage per Amplicon

A functional molecule is a collection of reads that covers the amplicon

and satisfies all criteria associated with the parameters (for example,

min tag fam size andmin fam per strand cov)in the parameter
file. Molecular coverage is the number of functional molecules. The median
is calculated across all amplicons.

Uniformity of Molecular Coverage for
all Amplicons

Percentage of amplicons having molecular coverage between 0.5x and 2x of
the median molecular coverage.

Percentage of Amplicons larger than
0.8x Median Functional Molecular
Coverage

Percentage of amplicons having molecular coverage more than 0.8x of the
median functional molecular coverage

Median Total Molecular Coverage per
Amplicon

The number of molecules that satisfies size criteria in the parameters file.
The median is calculated across all amplicons.

Percentage of Reads with Perfect
Molecular Tags

Percentage of reads whose molecular tags are exactly the same with design.

Median Functional Molecular Loss
due to Strand Bias per Amplicon

The metric is calculated by 1- (Functional Molecular Coverage)/
(Molecular Coverage without Strand Constraint), which
measures the loss of functional molecules due to strand constraint for
molecular functionality. The median is calculated across all amplicons. This
statistic is available in lon AmpliSeq™ HD runs only.

Median Percentage of Functional
Molecules out of Total Molecules per
Amplicon

The percentage of functional molecules out of the number of molecules that
satisfies size criteria. The median is calculated across all amplicons.

Median Reads per Functional
Molecule

For each amplicon, the number of reads supporting each functional
molecule is averaged across all functional molecules for that amplicon to
determine the number of reads per functional molecule at the amplicon
level. The median is calculated across all amplicons.

Median Reads Contributed to
Functional Molecules per Amplicon

For each amplicon, the percentage of reads supporting functional molecules
is (Number of Reads Supporting Functional Molecules)/
(Number of Reads). The median is calculated across all amplicons.

Percentage of Amplicons below
(around) n% LOD

LOD is calculated based on the number of functional molecules for each
amplicon and variant calling parameters in the parameter file. Around x n%
means in the range from 0.5x n% to 2x n%.
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The following is an example of a Molecular Coverage Analysis Report that is available when you
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select a barcode in the molecular Coverage Analysis plugin summary.

Example charts generated by the molecularCoverage Analysis plugin

Molecular Coverage Analysis Report

Sample Name:

Library type: AmpliSeq HD - DNA
Reference: hgl® (DNA)
Targer regions:

MNumber of amplicons

Median functional malecules per amplicon
Unifzernity of amplizon melecular coverage
Amplicens with LOD below 5%

Amplicens with LOD below 1%

Amplicens with LOD below 0.5%
Amplicens with LOD around 0.1%

Median number of reads per malecule
Median molecular less due to strand bias.
Median reads to molecular conversion rate

272
2,521
S0.81%
99.26%
$5.59%
25.66%
1.47%
268
78.90%
30.56%

111

The charts in the detailed Molecular Coverage Analysis Report include Plot and Overlay menus that

allow you to customize the data that is displayed in each chart.

Click Q (Search) (in the top right corner of a chart) to open the chart Viewing Options panel. Click ?
(Help) to open a description of the chart.
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Figure 16 Representative Depth of Coverage Chart

The Depth of Coverage Chart summarizes the amplicon depth of coverage results. The X-axis represents the amplicon

molecular depth. The left Y-axis represents the number of amplicons at a given molecular depth or a range (bin) of

molecular depths, as a percentage of the total number of amplicons. The right Y-axis represents the cumulative count of
the number of amplicons, at a given molecular depth or greater, as a percentage of the total number of amplicons. The
individual orange bars represent the percentage of amplicons in the specific range of molecular depths. The blue curve
measures the cumulative amplicons at a given molecular depth or greater. Use the Plot dropdown list to switch between
Maximum Read Depth, 99.9% of All Reads, and Normalized Coverage plots.
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Figure 17 Representative Amplicon Coverage charts

The Amplicon Coverage charts summarize the amplicon molecular coverage results. The X-axis in all plots represents
amplicons that are grouped into bins, where each bin contains amplicons that have the same molecular coverage.
Depending on the plot selection, the left Y-axis represents either the average number of molecules (on a base 10 log
scale) or the percentage of functional molecules in a given bin. The right Y-axis represents the percentage of functional
reads in a given bin. Use the Plot and Overlay dropdown lists to customize the chart view. To zoom in on a subset of
amplicons, use the pointer to draw a rectangle that contains the region of interest. Use Zoom Out to revert to the initial

view.

@ Representative Total Molecules plot with an Perc Functional Reads overlay
@ Representative Strand Molecules plot with an Perc Functional Reads overlay

@ Representative Reads per Molecule plot with an Perc Functional Reads overlay
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molecular Coverage Analysis plugin in Genexus™ Software

Amplicons at molecular depths 2,350- % Cumulative Amplicons at molecular L
2,399 depth 3.050

Number of amplicons : 7 Number of amplicons : 56

Percentage of amplicons : 2.57% Percentage of amplicons : 20.59%

Figure 18 Example detail panes

In most plots, you can click a data point to open a detail pane for that data. For example, in the Depth of Coverage Chart
in Figure 16, click an individual orange bar to open the detail pane for amplicons in a specific range of molecular depths
or click a point on the blue curve to open the detail pane for cumulative amplicons at that molecular depth or greater.
Similarly, you can click any point or bar within each Amplicon Coverage chart to view details for each amplicon coverage
bin. For example detail panes, see Figure 18.

Output files generated by the molecularCoverage Analysis plugin

You can download plugin results files from the Results screen for a sample. For more information, see
“Results files” on page 171.

Note: Sometimes the file name can be too long to open in applications such as Microsoft™ Excel™. To
resolve this problem, right-click the file, then click Save As to rename the downloaded file.

The following tables describe the results files that can be generated by the molecular Coverage Analysis
plugin. The list of files depends on the type of assay template that was selected during assay creation.

File download selections in the Genexus™ Software

Selection

File name

TNA Molecular Coverage Statistics

<Barcode><ExpName>.

cov.stats.txt

TNA Molecular depth of coverage

<Barcode><ExpName>.

mol.cov.xls

TNA Molecular Coverage Analysis
Summary

<Barcode><ExpName>.

summary.pdf

TNA Molecular Amplicon coverage
summary

<Barcode><ExpName>.

amplicon.cov.xls
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molecular Coverage Analysis plugin in Genexus™ Software

File contents

File Description

Molecular This file contains a summary of the statistics presented in the tables at the top of the
Coverage Statistics | Molecular Coverage Analysis Report plugin report. The first line is the title. Each subsequent
line is either blank or a particular statistic title followed by a colon (:) and its value.

Molecular depth of | Molecular coverage summary data used to create the Depth of Coverage Chart. This file
coverage contains the following fields:

* mol depth: the depth at which a (targeted) reference amplicon has been read.
* amp_cov: the number of times any amplicon was read (covered) at this depth.
* amp_ cum_cov: the cumulative number of reads (coverage) at this read depth or greater.

* norm mol depth: the normalized read depth (depth divided by average molecular read
depth).

* pc amb cum cov:same as amp_cum_cov but represented as a percentage of the total
reads.

Molecular A PDF file that contains the Molecular Coverage Analysis Report, including molecule statistics
Coverage Analysis |and charts that are generated by the molecular Coverage Analysis plugin.
Summary
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lonReporterUploader plugin

File contents (continued)

File

Description

Molecular
Amplicon coverage
summary

Amplicon molecular coverage summary data used to create the Amplicon Coverage Chart.
This file contains the following fields:

[ )

contig id:the name of the chromosome or contig (from contiguous) of the reference
for this amplicon.

contig srt: the start location of the amplicon target region. Note that this coordinate
is 1-based, unlike the corresponding 0-based coordinate in the original targets BED file.

contig end: the last base coordinate of this amplicon target region. Note that the
length of the amplicon target is given as (contig_end - contig_srt + 1).

region_id:the ID for this amplicon as given as the 4th column of the targets BED file.

gene 1id or attributes: the gene symbol or attributes field as provided in the
targets BED file.

func_mol cov: functional molecular coverage utilized for variant calling.
lod: LOD (limit of detection) calculated from the number of functional molecules.

strict func umt rate: the percentage of functional molecules used with strict
molecular tags.

func mol cov_loss due to_ strand: the percentage of functional molecules not
formed.

fwd only mol cov:the number of molecules containing forward strand only.
rev_only mol cov:the number of molecules containing reverse strand only.

both strands mol cov:the number of molecules containing both forward strand
and reverse strand.

r2m_conv_rate all:the percentage of reads contributed to functional molecules.
reads per func_mol: the average reads per functional molecules.

perc_to mol (<3 reads):the percentage of reads contributed to small size
molecules (size <3).

perc to mol (>=3&<30_ reads):the percentage of reads contributed to median
size molecules (size =3 && size <30).

perc_to mol (>=30_ reads): the percentage of reads contributed to large size
molecules (size =30).

lonReporterUploader plugin

Sample results files that are generated in Genexus™ Software can be directly transferred to lon
Reporter™ Software with the lonReporterUploader plugin.

lon Reporter™ Software performs analysis on unmapped BAM files that are output from Genexus™
Software. To transfer the BAM files to lon Reporter™ Software, you must add one or more lon Reporter™
Software accounts in Genexus™ Software. To configure an lon Reporter™ Software account that you
can use for data uploads, see “Register an lon Reporter™ Server account (manager/administrator)”
on page 301 and “Register an lon Reporter™ Software on Thermo Fisher™ Connect Platform account
(manager/administrator)” on page 300.
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lonReporterUploader plugin

After an account is configured, there are two ways that you can transfer files to lon Reporter™ Software.

When you plan a run, you can select to have Genexus™ Software directly transfer output files to lon
Reporter™ Software. For more information, see “Plan a Sample to Result run” on page 66, “Plan a
Nucleic Acid to Result run” on page 72, and “Plan a Library to Result run” on page 76.

You can select to upload data manually to lon Reporter™ Software. Use this option if, for example,
you want to upload data to multiple lon Reporter™ Software servers. For more information, see

“Upload results files to lon Reporter™ Software” on page 196.

Note: lon Reporter™ Software is available under separate license and is not included with Genexus™
Software.

Review lonReporterUploader plugin results

After the analysis is complete, review the plugin results. You can view the information that is related to
the data transfer. The information includes the name of the lon Reporter™ Server used, the version of
lon Reporter™ Software that is on the server, the server folder that contains the uploaded files, and the
lon Reporter™ Software organization and user account that was used. You can also review details about
barcoded samples that were uploaded with the lonReporterUploader plugin, or samples that failed to
upload.

1.

2.

356

In the menu bar, click Results » Run Results.

In the Run Results screen, in the Run Name column, click the run of interest.

In Select Assay, select the assay of interest.

Click the Plugins tab.
A summary table of the lonReporterUploader plugin is shown.

In the lonReporterUploader plugin results, view the information that is related to the data transfer.

used in the plugin run.

To do this Click
View error messages associated with the plugin run. Errors
View warnings that contain details about the barcoded samples that are | Warnings

Show or hide a detailed status of the pre- and post-processing of the
data transfer.

Show detailed status/Hide
detailed status

Open the plugin log files in a separate browser tab.

[2 View Log

Download a CSV file that contains a list of the uploaded and defined
samples.

Download CSV list of
samples that are uploaded
and defined.

Download a compressed folder of the lonReporterUploader plugin log
files and other plugin files.

Download IRU logs

Delete the plugin table.

[i] Delete
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Customer Support Archive

Customer Support Archive

The Customer Support Archive is a downloadable archive that a technical support representative can
use to troubleshoot and diagnose issues with sequencing runs or with Genexus™ Software. The archive
contains log files and other technical data about the software and other files from sequencing runs on a
Genexus™ Integrated Sequencer.

For more information, see “Download a Customer Support Archive” on page 428.

samplelD plugin

Use the samplelD plugin to track samples or possibly identify misassignment or mix up between
samples and barcodes in a sequencing run. The samplelD plugin produces a unique identification code
(SamplelD) for each barcode in a sample.

The samplelD plugin can be run on sequencing results from any panel that includes the 9 primer pairs
of the lon AmpliSeg™ Sample ID Panel.

For example, the lon AmpliSeq™ Sample ID Panel contains 9 primer pairs that can be combined with
any lon AmpliSeq™ Ready-to-Use Panel or Custom Panel. The samplelD plugin can be used with the
lon AmpliSeq™ Sample ID Panel, which is a human SNP genotyping panel, to ensure the accuracy of
samples and increase confidence in sample data management. The lon AmpliSeq™ Sample ID Panel
is composed of the identified human sample gender and IUPAC base letters for eight high-frequency
noncoding SNPs.

For the samples to work with this plugin, the lon AmpliSeg™ library must have been prepared with lon
AmpliSeq™ sample tracking amplicons.

The samplelD plugin is preconfigured and does not require input.
Review samplelD plugin results in Genexus™ Software

After the sequencing run completes, review the plugin results.

1. In the menu bar, click Results » Sample Results.
2. In the Sample Results screen, in the Sample Name column, click the sample of interest.

3. Click the Plugins tab.
A summary table of the samplelD results is shown.

4. Click a barcode name to open the Sample ID Report.

5. To return to Genexus™ Software, click back in the browser.
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samplelD plugin

Sample ID Report

#%  Chapter 11 Plugins for data analysis

The Sample ID Report that is available when you select a barcode in the SamplelD plugin summary
for a run includes a variety of reads statistics.

The statistics that are displayed in your report depend on the type of library that is used in your
sequencing experiment. Definitions are in tooltips. Almost every statistic, plot, link, and functional
widget in the report provides tooltips with definitions. Hover over a heading or description in the report

to view the tooltip.

Statistic

Description

Number of mapped reads

The total number of reads mapped to the reference genome.

Number of reads in sample ID
regions

The total number of reads mapped to Sample ID regions.

Percent reads in sample ID regions

The percent of all reads aligned to the reference that covered bases in
Sample ID regions.

Total base reads in sample ID
regions

The total base reads aligned to the reference that covered bases in Sample
ID regions.

Percent base reads in sample ID
regions

The percent of all bases covered by reads aligned to the reference that
covered bases in Sample ID regions.

Male sample ID region reads

Number of reads mapped to the specific male (Y) identification target(s).

Female sample ID region reads

Number of reads mapped to the specific female (X) identification target(s).

Sample ID Regions and Sample ID S

NPs

Bases in target regions

The total number of bases in all specified target regions of the reference.

Average base coverage depth

The average number of DNA reads of all targeted reference bases.

Uniformity of coverage

The percentage of target bases covered by at least 0.2x of the average base
coverage depth.

Coverage at 1x

The percentage of target bases covered by at least 1 read.

Coverage at 20x

The percentage of target bases covered by at least 20 reads.

Coverage at 100x

The percentage of target bases covered by at least 100 reads.
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samplelD plugin

Output files generated by the samplelD plugin

You can download samplelD plugin results files from the Results screen for a sample. For more

information, see “Results files” on page 171.

Note: Sometimes the file name can be too long to open in applications such as Microsoft™ Excel™. To
resolve this problem, right-click the file and click Save As to rename the downloaded file.

The following tables describe the files that can be generated by the samplelD plugin. The list of files
depends on the application type that was selected during assay creation.

File download selections in the Genexus™ Software

Selection

File Name

Tracking Loci Regions (SNPs) File

tracking loci.bed

Aligned Tracking Reads Index (BAI) File

<DNA Barcode><ExpName>.bam.bai

Hard-copy A4 PDF Image Of This Report Page

<DNA Barcode><ExpName>.samplelD.pdf

Tracking Target Regions File

tracking regions.bed

Aligned Tracking Reads (BAM) File

<DNA Barcode><ExpName>.bam

All Variant Calls As a Table File

allele counts.xls
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API

LIMS introdUCHION . . ..o ottt e e e e e 360
APl COMMON Parameters ... .o e e e 363
Get list of lon Reporter™ Software aCCOUNTS . ... uutttt ettt eieeess 364
Gt assay lISt . ... oi i e e e e 365
Gt SAMPIES . oot e e e 366
Getlibrary batChes ... ... e 366
Gt TUN PlaNS . ot i e e e e e e 368
Gt report temPIates . ... oot e 369
Gt rESURS . .o 369
Get signed off SamMPIES .. ..o e 375
Download files for completed runs . ... ... . i e 376
Create SAMPIES . ..ottt e e e i 377
Create alibrary batCh ... ... e e 379
Create a Sample to Result (purification) run ........ ... .. i e 380
Create a Nucleic ACIdto Result run . ... ... e 381
Create alibrary rUn .. ... e e 381

Genexus™ Software has a web services API that allows you to automate the retrieval of key information

from the system.

This section provides examples to show you how to leverage the API.

LIMS introduction

360

Genexus™ Software integrates with laboratory information management systems (LIMS) to help with

sample, library, and run plan creation. The interaction is through the LIMS calling a set of RESTful APIs

provided by the software (see the following table). The LIMS connects to the software by making an

HTTP call to the URL of an API, and sending a user name and a password in the HTTP header. The user

name and password must be for a registered active user account of the software. The LIMS passes
the input information in JSON format within the HTTP body, while the response from the software is
returned in JSON format as well. Users must configure their LIMS to create JSON files containing the
required attributes for each LIMS request file.
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LIMS introduction

Outlined in the following table are the API names, functions, and URLs of the five RESTful APIs that are

provided.

API

Function

APl URL

Get a list of lon Reporter™
Software accounts

For more information, see
“Get list of lon Reporter™
Software accounts” on
page 364.

Returns a list and

the details of active

lon Reporter™ Software
accounts.

https://
<host>/genexus/api/lims/v2/accounts

Get a list of assays

For more information,
see “Get assay list” on
page 365.

Returns a list of the assays
in the system. PQ assays
are excluded.

https://
<host>/genexus/api/lims/v2/assays

Get a list of samples

For more information,
see “Get samples” on
page 366.

Returns a list of the
samples in the system.

https://
<host>/genexus/api/lims/v2/samples

Get a list of library batches

For more information, see
“Get library batches” on
page 366.

Returns a list of the library
batches in the system.

https://
<host>/genexus/api/lims/v2/library-
batches

Get a list of run plans

For more information,
see “Get run plans” on
page 368.

Returns a list of available
run plans in the system.

https://<host>/genexus/api/lims/v2/plans

Get results

For more information, see
“Get results” on page 369.

Returns results, including
plugins and plugin results.
Returns a JSON obiject for
each plugin. All plugins for
the run and the sample are
returned.

https://
<host>/genexus/api/lims/v2/results

Get a list of signed off
samples

For more information, see
“Get signed off samples”
on page 375.

Returns a list of

the samples that are
designated with (Signed
Off).

https://
<host>/genexus/api/lims/v2/signedOffSamp
les

Download files for
completed runs

For more information,
see “Download files
for completed runs” on
page 376.

Returns a compressed file
in ZIP format that contains
the requested files for the
sample.

https://
<host>/genexus/api/lims/v2/download
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LIMS introduction

(continued)

API

Function

API URL

Create samples

For more information,
see “Create samples” on
page 377.

Create samples.

https://
<host>/genexus/api/lims/v2/samples

Create a library batch

For more information, see
“Create a library batch” on
page 379.

Create a library batch from
existing samples.

https://
<host>/genexus/api/lims/v2/library-
batches

Create a Sample to Result
(purification) run

For more information, see
“Create a Sample to

Result (purification) run” on
page 380.

Create a Sample to Result
run from one or more
samples and an assay.

https://<host>/genexus/api/lims/v2/plan-
by-purification

Create a Nucleic Acid to
Result run

For more information, see
“Create a Nucleic Acid to
Result run” on page 381.

Create a Nucleic Acid
to Result run from one
or more samples and an
assay.

https://<host>/genexus/api/lims/v2/plan-
by-samples

Create a library run

For more information, see
“Create a library run” on
page 381.

Create a library run from
one or more library batches
and an assay.

https://<host>/genexus/api/lims/v2/plan-
by-library

LIMS system FTP setup or drive mapping

To enable the LIMS system to retrieve data analysis files from the sequencer, a manual FTP setup or
drive mapping is required. This configuration is not provided as part of the sequencer installation, and
must be set up as part of the LIMS system by the system integration or laboratory IT group. See the
sections in this appendix for file paths and other setup information.
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APl common parameters

APl common parameters

If the JSON download process converts @ symbols to $40, do not change the text. Instead, copy the
JSON files as is into the browser.

Parameter Entry
BASE_URL https://<host>/genexus/api/lims/v2
Request Authorization:Basic

Accept : application/json
Response Content-Type : application/json

Response fields

Code Status
200 Successful response
400 Bad request
Error response:
{
"errors": [
{ "field":"validation error"
}
]
}
401 Unauthorized
500 Internal Server Error

Get requests

Type of request

Entry

Get list of resources

BASE URL/resource url/

Get single object

BASE URL/resource url?id=object id
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Get list of lon Reporter™ Software accounts

Common request parameters

Parameter Entry Value

Starting page number pageNumber The default value is "1".

Number of items to fetchl] pageSize The default value is "20".

A filed based on which, the result |orderBy Only specific values are allowed. If
set needs to be ordered no value is provided, the result set

is ordered by ID.

Order direction of the result set sortOrder Valid values are "asc" or "desc".

The default value is "asc".

' You can limit the number of items that are fetched when you add parameters to the request. For example, add "status" to the get
assay list request.

Get list of lon Reporter™ Software accounts

accounts
URL BASE URL/accounts
Description Returns a list and the details of active lon Reporter™ Software accounts.
Method GET
Header curl -k --header 'username:<user name>' --header 'password:
<user password>
Example request curl -k --header 'username:<user name>' --header 'password: <user password>'https://

server/genexus/api/lims/v2/accounts

Request query ® irversion
parameters String. Mandatory.

lon Reporter™ Software version.

Example response

"total": 2,
"objects": [
{
nigr: won,
"displayName": "TFAccount Local 516 (Default)",
"serverType": "HTTPS",
"port™: "443",
"state": "Active",
"userName": "firstname.lastname@tfc.com",
"org": "IR Org",
"status": "ENABLED",
"server": "thinkl5dx.itw",
"irVersion": "IR516",
"defaultAccount": true,
"accountType": "Ion Reporter Local"
"usedAccount": false,
"irAccountListError": false,
"irAccount": true,
"createdBy": "AutolAdmin"
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Get assay list
assays
URL BASE URL/assays
Description Returns a list of the assays in the system. PQ assays are excluded.
Method GET
Header curl -k --header 'username:<user name>' --header 'password:
<user password>
Example URL curl -k --header 'username:<user name>' --header 'password: <user password>'https://
<host>/genexus/api/lims/v2/assays
Supported ® assayName
parameters String. Optional.
Assay name.
® status
String, Optional.
Valid values are "draft", "obsolete", or "locked".
Example response | ¢
"total": 1,
"objects": [
{
"id": 122,
"assayName": "copy of OCAv3 GX5 DNA RNA w5.0.2"
"assayShortName": "OCAv3 DNA Fus w5.0.2",
"assayDisplayedName": "Oncomine Comprehensive v3 - GX5 - DNA and Fusions -
w5.0.2",
"application": "DNA+RNA",
"createdBy": "System Installed",
"createdDate": "2021-06-22T16:50:15.000+0000",
"isReanalysisAssay": false,
"genomeReference": "hgl9"
"targetRegions": "OCAv3 w5.0.2 dna fusions 20200626.GX5.designed.bed",
"hotspots": "OCAv3 w5.0.2 dna fusions 20201117.GX5.hotspots.bed",
"fusionReference": "OCAv3 w5.0.2 designs_072720_ Reference.fasta",
"fusionTargetRegions": "OCAv3 w5.0.2 dna_fusions_designs_072720 Reference.bed",
"chipType": "Ion Torrent™ GX5™ Chip",
"panelKit": "Oncomine™ Comprehensive Assay v3 DNA and RNA, GX",
"controlKit": "Other"
"extractionKit": "Ion Torrent™ Genexus™ FFPE DNA/RNA Purification Combo Kit",
"libraryKit": "Ion Torrent™ Genexus™ Library Strips 1 and 2-AS",
"templatingKit": "Ion Torrent™ Genexus™ Templating Strips 3-GX5 and 4",
"barcodeKit": "Ion Torrent™ Genexus™ Barcodes 1-96 AS",
"sequencingKit": "Ion Torrent™ Genexus™ Sequencing Kit",

"flows": 400,
"templatingSize": 200,

"status": "Locked",
"tumorCellularity™: "1",
"reanalysisAssay": false
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Get samples

Get samples

<host>/genexus/api/lims/v2/samples

samples
URL BASE URL/samples
Description Returns a list of the samples in the system.
Method GET
Header curl -k --header 'username:<user name>' --header 'password:
<user password>
Example URL curl -k --header 'username:<user name>' --header 'password: <user password>'https://

Request query ® sampleld
parameters String. Optional.

Sample name.

Example response |

"total": 1,
"objects": [
{

"otherAttributes": {},
"id": 554,
"sampleId": "Test_Samplel_ 127",
"collectionDate": "2018-10-02",
"gender": "Male",
"sampleType": "DNA",
"tumorCellularity": "70",
"origin": "Non-Small Cell Lung Cancer",
"cancerStage": "Stage 0",
"diseaseCategory": "Solid Tumor"

Get library batches

library-batches

<user password>

URL BASE URL/library-batches

Description Returns a list of the library batches in the system.

Method GET

Header curl -k --header 'username:<user name>' --header 'password:

<host>/genexus/api/lims/v2/library-batches

Example URL curl -k --header 'username:<user name>' --header 'password:

<user password>'https://
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Appendix A Genexus™ Software web services API

Get library batches

library-batches

Request query
parameters

id
String. Required.
Library batch ID.

Example response

"total": 1,
"objects": [
{
"libraries": [
{
"libraryType": "DNA",
"barcodeID": "IonHDdual 0102"

"libraryName": "NTC DNAOPA DNA Fusion Library Bacth 013",

"inputQuantity": 3.0,
"sampleId": "NTC",
"tumorCellularity": null,

"controlKitBarcode": "9110008037510224548317211230"

"extractionKitBarcode": null

"libraryType": "RNA",
"barcodeID": "IonHDdual 0104",

"libraryName": "NTC_RNAOPA DNA Fusion Library Bacth 014",

"inputQuantity": 3.0,
"sampleId": "NTC",
"tumorCellularity": null,

"controlKitBarcode": "9110008037510224548317211230"

"extractionKitBarcode": null

"libraryType": "DNA",
"barcodeID": "IonHDdual 0101",
"libraryName": "DNA 01"
"inputQuantity": 3.0,
"sampleId": "Test Samplell 218",
"tumorCellularity": null,
"controlKitBarcode": null,

"extractionKitBarcode": "9110009055910123456717211019"

"libraryType": "RNA",
"barcodeID": "IonHDdual 0103"
"libraryName": "RNA701"7
"inputQuantity": 3.0,
"sampleId": "Test Samplell 218",
"tumorCellularity": null,
"controlKitBarcode": null,

"extractionKitBarcode": "9110009056010123456717211231"

}

1,
"id": 233,

"assayName": "Oncomine Precision - GX5 - Solid Tumor - DNA and Fusions -
w3.0.0",
"libraryBatchId": "OPA_DNA Fusion_Library Bacth_ 01"

nw
’

"libraryKitBarcode":
"panelKitBarcode": "",
"libraryPrepType": "DNA+RNA",
"ampliSegHd": false
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Get run plans

Get run plans

plans

URL BASE URL/plans

Description Returns a list of available run plans in the system.

Method GET

Header curl -k --header 'username:<user name>' --header 'password:
<user password>

Example URL curl -k --header 'username:<user name>' --header 'password: <user password>'https://
<host>/genexus/api/lims/v2/plans

Request query ¢ planName

parameters String. Optional.

Name of the run plan.
® viewType
String. Optional.
Valid values are "all" or "toBeProcessed".

Example response

"objects": [
{
"id": 184,
"planName": "OPA_DNA Fusion_PlanRun_ 01",
"planShortId": "4RSKR",
"type": "sample",
"createdBy": "System Installed",
"updatedOn": "2021-07-22T06:08:03.000+0000"
"noOfSamples": 2,

"noOfLibraries": 4,
"samples": [
{
"id": 973,
"sampleId": "NTC",
"assayName": "Oncomine Precision - GX5 - Solid Tumor - DNA and
Fusions - w3.0.0"
"dnaBarcodes": [],
"rnaBarcodes": [],
"libraryBatchId": "234",
"libraryPrepType": "DNA+RNA",

"pauseForReview": false

"id": 972,
"sampleId": "Test Samplell 278",
"assayName": "Oncomine Precision - GX5 - Solid Tumor - DNA and
Fusions - w3.0.0"
"dnaBarcodes": [],
"rnaBarcodes": [],
"libraryBatchId": "234",
"libraryPrepType": "DNA+RNA",
"pauseForReview": false
}
1,
"runAssays": [

"Oncomine Precision - GX5 - Solid Tumor - DNA and Fusions - w3.0.0"
]
}
1y
"total": 1
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Get report templates

report-templates

URL for a list of BASE URL/report-templates

resources

URL for a single BASE URL/report-templates

object

Description Returns report templates. API supports multiple filters.

Method GET

Header curl -k --header 'username:<user name>' --header 'password:
<user password>

Exarnpﬂe URL curl -k --header 'username:<user name>' --header 'password: <user password>'https://
<host>/genexus/api/lims/v2/report-templates

Request query assayName

parameters

String. Optional.
Get the report template for the given assay.

Use the Assay Name. Do not use the Assay Full Name.

Example response

"mode": "AssayDev",
"reportingTemplate": [

{

"name": "default",
"description": "Default",
"locale": "en"
I
{
"name": "oca3_dr_ oncominepositive",
"assayName": "Oncomine Comprehensive v3 - GX5 - DNA and Fusions - w5.0.2",
"assayId": 50,
"description": "OCA3_DR_OncominePositive",
"locale": "en"
}
1,
"total": 1
}
results
URL BASE URL/results
Description Returns results, including plugins and plugin results. Returns a JSON object for each plugin.
All plugins for the run and the sample are returned.
Method GET
Header curl -k --header 'username:<user name>' --header 'password: <user
password>
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results

Example URL

curl -k --header 'username:<user name>'

genexus/api/lims/v2/results

--header

'password:

<user password>'https://<host>/
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results

Request query
parameters

id

String. Optional.

Results for the selected result id.
Example: 123

assay_ id

String. Optional.

Results for the assay id.
Example: 123

plan_id

String. Optional.

Results for selected run plan id.
Example: 123

sampleId

String. Optional.

Results for the selected sample name.
Example: MySample

planName

String. Optional.

Results for selected run plan name.
Example: MyPlan
analysisComplete

String. Optional.

Results for completed runs. Results included for failed and successfully completed
runs.

Example: true
updatedBefore
String. Optional.

Returns results updated before the selected date. Use date format: yyyy-MM-dd
HH:MM.

Example: 2019-01-15 10:30

updatedAfter

String. Optional.

Returns results updated after the selected date. Use date format: yyyy-MM-dd
Example: 2019-01-15

orderBy

String. Optional.

Parameter to sort results by selected field. The default sort is by updatedBefore or
updatedAfter. Results are listed in descending order, with the most recent results
listed first.

Output is as follows.
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"objects": [

{

"id": 328,
"planName": "EK ODxET FFPE EU D5 0.3.0 6.5.26-NA-T2.0.0-2",
"sampleId": "SRTestSample6l",
"assay": {
"id": 18,
"value": "Generic Assay - DNA and Fusions - EU v0.3.0",
"accountType": null,
"isGreaterVersion": false,
"runType": null,
"greaterVersion": false
b
"planRun": {
"id": 59,
"value": "EK ODxET FFPE EU D5 0.3.0 6.5.26-NA-T2.0.0-2",
"accountType": null,
"isGreaterVersion": false,
"runType": null,
"greaterVersion": false
}y
"sample": {
"id": 45,
"value": "SRTestSample6l",
"accountType": null,
"isGreaterVersion": false,
"runType": null,
"greaterVersion": false
}y
"planShortCode": "YYRU2",
"resultName":

"Auto R 2021 05 19 14 48 13 ionservice GNXS-0128-37-19MAY2021 AEG 59 328",

Auto R 2021

Auto R 2021

"libraryNames": "SRTestSampletl RNAS831, SRTestSample61_DﬁA831",
"runStartDate": "2021-07-23T00:00-0400",
"runCompleteDate": "2021-07-24T00:45-0400",
"updatedDate": "2021-07-24T00:44-0400",
"libraryprepId": 428,
"analysisComplete": true,
"analysisVersion": "6.5.26",
"isThumbnail": false,
"isArchived": false,
"isReanalysis": false,
"runStatus": {
"id": null,
"name": "Analysis",
"value": "Completed"
by
"gcStatus": "Passed",
"instrumentName": "ValkyrieTestRig",
"outputsLink": "/analysis output/
05 19 14 48 13 ionservice GNXS-0128-37-19MAY2021 AEG 59/
05 19 14 48 13 ionservice GNXS-0128-37-19MAY2021 AEG 59 202107232

15902373/ChipLanel 2/SRTestSample6l LibPrep428/outputs”,

Auto R 2021

Auto R 2021

"outputsDir": "/serverdata/dxdata/IR/data/analysis output/
05 19 14 48 13 ionservice GNXS-0128-37-19MAY2021 AEG 59/
05 19 14 48 13 ionservice GNXS-0128-37-19MAY2021 AEG 59 202107232

15902373/ChiplLanel 2/SRTestSample6l LibPrep428/outputs",

"loadingMetrics": [

{
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"name": "Total Addressable Wells",
"count": 64847855
br
{
"name": "Wells With ISPs",
"count": 60145720,
"percentage": 92.75
b
I
"filteringMetrics": [
{
"name": "Filtered: Polyclonal",
"count": 22931697,
"percentage": 38.27
}y
{
"name": "Filtered: Primer-Dimer",
"count": 9955,
"percentage": 0.02
by
1y
"runQCMetrics": [
{
"data": [
{
"metricName": "Key Signal",
"value": "75",
"referenceRange": "Not Set",
"gCStatus": "Not Calculated",
"percentValue": false,
"iscosmic": false,
"isPQControl": false,
"uniqueName": "RunQC KeySignal",
"isDisplayMetric": false,
"isDisplayQc": false,
"libraryType": "NA",
"dataType": "INT",
"pgcontrol": false,
"displayMetric": false,
"displayQc": false
by
1y
"sequence": O,
"localizationKey": "RunQC",
"inlineControlQc": false,
"customApp": "",
"images": []
}
I
"purificationQCMetrics": [...],
"controlQCMetrics": [...],
"sampleQCMetrics": [...],
"sampleInlineControlQCMetrics": [],
"ntcQCMetrics": [],
"plugins": [
{
"results": {
"Library Type": "AmpliSeg HD - DNA and Fusions
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(Single Library)",

"Min Mapping Quality": "0",
"Percent end-to-end reads": "91.62%",
"Use Only Non-duplicate Reads": "No",
"Sample Tracking": "No",
"barcodes": {
"IonDxHDdual 18": ({
"Alignments":

"IonDxHDdual 18 EK ODXET FFPE EU D5 0.3.0 6.5.26-NA-
T72.0.0-2 Auto R 2021 05 19 14 48 13 ion",
"Amplicon base composition bias": "1.141",
"Amplicons reading end-to-end": "98.80%",
"Amplicons with at least 1 read": "100.00%",
}y
y
"Amplicons reading end-to-end": "86.40%",
"Min Aligned Length": "0",
"Targeted Regions": "Barcode specific",
"Tier 2 Coverage Depth": "350",
"Reference Genome": "Barcode specific",
"Use Only Uniquely Mapped Reads": "No",
"Target Padding": "0",
"Launch Mode": "Autostart with default
configuration",
"barcoded": "true",
"Tier 3 Coverage Depth": "500",
"Tier 1 Coverage Depth": "100"
by
"id": 455,
"pluginName": "coverageAnalysis",
"pluginVersion": "5.16.0.4",
"updatedOn": "2021-07-24T01:58:19.000+0000",
"status": "COMPLETED",
"path": "/serverdata/dxdata/IR/data/analysis output/
Auto R 2021 05 19 14 48 13 ionservice GNXS-0128-37-19MAY2021 AEG 59/
Auto R 2021 05 19 14 48 13 ionservice GNXS-0128-37-19MAY2021 AEG 59 202107232
15902373/ChipLanel 2/SRTestSample6l LibPrep428/plugins/
coverageAnalysis 5.16.0.4/1627091942777",

"runType": "SAMPLE"
by
1,
"biomarkers": [
{
"Variant": "ALK fusion, AR fusion",
"level": "Level 3"

}

I
"total": 1
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Get signed off samples

signedOffSamples

URL BASE URL/signedOffSamples

Description Returns a list of the samples that are designated with (Signed Off).

Method GET

Header curl -k --header 'username:<user name>' --header 'password:
<user password>

Example URL curl -k --header 'username:<user name>' --header 'password: <user password>'https://
<host>/genexus/api/lims/v2/signedOffSamples

Request query ® start date

parameters String. Optional.

Provide the start date as yyyy-mm-dd.
¢ end date
String, Optional.
Provide the end date as yyyy-mm-dd.
® signedOff
String, Required
A Boolean data type. Valid values are "true" or a "false".
The default value is "true".

Example response

"meta": {
"pageSize": 20,
"next": null,
"pageNumber": 0,
"previous": null,
"total count": 76
I
"objects": [
{
"sample": {
"assay_name": "qualification_ ampliseq genexus_pq_ template516_4.0.0"
"base_url":
"AssayDev_PQSamplel qualification_ampliseq_genexus_pqg_ template516_4.0.0 A9GHS_ A9GHS",

"checksum_file": "CHECKSUM",
"created date": "2021-06-23",
"sample file": "Info.csv",
"sample id": "92",
"sample name": "PQSamplel",
"planName": "IQ Lib"
}
I
{
"sample": {
"assay_name": "qualification_ampliseq genexus_pq_ template516_4.0.0"
"base url":

"AssayDev_PQSampleZ_qaalification_ampliseq_genexus_pq_template516_4.0.0_A9GHS_A9GHS",

"checksum file": "CHECKSUM",
"created date": "2021-06-23",
"sample file": "Info.csv",
"sample id": "93",

"sample name": "PQSample2",
"planName": "IQ Lib"

Genexus™ Software 6.8 User Guide

375



Appendix A Genexus™ Software web services API
Download files for completed runs

Download files for completed runs

376

download

URL BASE URL/download

Description Returns a compressed file in ZIP format that contains the requested files for the
sample.

Method GET

Header curl -k --header 'username:<user name>' --header 'password:
<user password>

Example URL

curl -k --header 'username:<user name>' --header 'password: <user password>'https://
<host>/genexus/api/lims/v2/download

Request query
parameters

e file list

String. Required.

Provide the file name in comma separated format.
® path

String, Required.

Provide the LIMS folder path of the analyzed sample. You can request the
folder path when you get signed off samples. The folder path is listed as the
"base_URL". For more information, see “Get signed off samples” on page 375.

Example request

1. Perform a checksum function to query for the list of files for a sample that has
been sequenced and analyzed.

https://BASE URL/download?file 1ist=CHECKSUM&path=AssayDev
Sample Cl1 qualification ampliseq Genexus_pq template516 1.3.2 3MI8Q 3MI8Q

2. Parse the checksum to get the file name, then request that file.

https://BASE_URL/download?
file list=Info.csv,BaseCaller.json,analysis.log&path=AssayDev_
Sample_Cl_qualification_ampliseq Genexus_pqg_ template516_1.3.2_ 3MI8Q 3MI8Q

3. Ensure that the name of the downloaded file matches the checksum requested
in step 1.
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Create samples

samples

URL BASE URL/samples

Description Create 1 to n samples. "All" or "None" is followed for
all samples in a request. If the creation of any one
sample fails, creation of the entire batch fails.

Method POST

Header curl -k --header 'username:<user
name>' --header 'password: <user
password>

Example URL curl -k --header 'username:<user name>' --
header 'password: <user password>'https://<host>/
genexus/api/lims/v2/samples
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(continued)

samples

Attribute definitions

sampleId. String. Required. Sample name.

sampleType. String. Required. Examples of
valid values are "DNA" or "RNA".

collectionDate. String. Required. The date
that the sample was collected.

gender. String. Required. The biological sex of
the sample: Female, Male, or Unknown.

diseaseCategory. String. Required. The
sample application category.

cancerStage. String. Required. Cancer stage.
origin. String. Required. Cancer type.

notes. String. Required. An open-entry field for
more sample information.

necrosis. String. Optional. The percentage of
cellular necrosis in the sample.

tumorCellularity. String. Optional. The
percentage of tumor cells over normal cells in
the sample.

condition. String. Optional. The condition of
the sample.

Example request

"sampleId":"Sample NSCLC Tag {{$randomInt}}",

existing Tag NSCLC"

"objects": [

{

"diseaseCategory":"Solid Tumor"
"sampleType":"DNA & RNA",
"origin":"Non-Small Cell Lung Cancer"
"cancerStage":"Unknown",
"necrosis":100,
"tumorCellularity":31,
"gender":"Unknown",
"collectionDate™:"2018-10-02"
"condition":"good",

"tagDisplayName": ["NSCLC"],
"notes":"LIMS API created Cancer sample and

}
1
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Create a library batch

library-batches

URL BASE URL/library-batches

Description Create a library batch from one or more existing samples. If any requested sample
does not exist in the software, the creation of the entire library batch fails.

Method POST

Header curl -k --header 'username:<user name>' --header 'password:
<user password>

Exarnpﬂe URL curl -k --header 'username:<user name>' --header 'password: <user password>'https://

<host>/genexus/api/lims/v2/library-batches

Example request

{
"objects": [

{
"libraryBatchId": "LibBatch DNA NTC 01",
"assayName": "Oncomine Comprehensive v3 - GX5 - DNA - w5.0.2"
"libraryPrepType": "DNA",
"libraryKitBarcode": "01ABC0012300000017221123102-321AB234240A40252",
"panelKitBarcode": "01ABC0012300000017221123102-321AB234240A44351",

"libraries": [

{
"barcodeID": "IonDual 0101",
"inputQuantity": 77.0,
"libraryType": "DNA",
"libraryName": "DNA Libl 99",
"sampleId": "Test Samplel 127",
"extractionKitBarcode": "9110009055910123456717211019"

}

{
"barcodeID": "IonDual 0102"
"inputQuantity": 77.0,
"libraryType": "DNA",
"libraryName": "DNA Lib2 99",
"sampleId": "Test_ Samplel_ 127",
"extractionKitBarcode": "9110009055910123456717211019"

}

{
"barcodeID": "IonDual 0103"
"inputQuantity": 77.0,
"libraryType": "DNA",
"libraryName": "",

"sampleId": "NTC",
"controlKitBarcode": "9110008037510224548317211230"

"barcodeID": "IonDual 0104",

"inputQuantity": 77.0,

"libraryType": "DNA",

"libraryName": "",

"sampleId": "NTC",

"controlKitBarcode": "9110008037510224548317211230"
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Create a Sample to Result (purification) run

plan-by-purification

URL BASE URL/plan-by-purification

Description Create a Sample to Result run from one or more samples and an assay. The sample
or samples and the assay must exist in the system.

Method POST

Header curl -k --header 'username:<user name>' --header 'password:
<user password>

Exarnpﬂe URL curl -k --header 'username:<user name>' --header 'password: <user password>'https://
<host>/genexus/api/lims/v2/plan-by-purification

Example request {

"irAccountName": "iraccount",

"reportTemplateName": "mytemplate",

"samples": [

{

"assayName": "Purification FFPE DNA and Fusion Assay"
"sampleId": "Samplel",
"purificationProtocol": "FFPE DNA + RNA",

"elutionVolumeDNA": 50,
"elutionVolumeRNA": 50,
"pauseForReview": false

"assayName": "Purification DNA Assay"
"sampleId": "Sample2"
"purificationProtocol": "Blood 50-100 pl"
"elutionVolumeDNA": 40,
"pauseForReview": false

by

{
"assayName": "Purification DNA Assay",
"sampleId": "Sample3"
"purificationProtocol": "Blood 50-100 npl",

"elutionVolumeDNA": 40,
"pauseForReview": false

"assayName": "Purification RNA Assay"
"sampleId": "Sampled",
"purificationProtocol": "Biofluid",
"elutionVolumeDNA": 90,
"pauseForReview": false

"assayName": "Purification RNA Assay",
"sampleId": "Sample5"
"purificationProtocol": "Cells and tissue",
"elutionVolumeDNA": 90,
"pauseForReview": false
}

1,

"notes": "my notes"

"planName": "plan purification_run"

}
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Create a Nucleic Acid to Result run

plan-by-samples

URL BASE URL/plan-by-samples

Description Create a Nucleic Acid to Result run from one or more samples and an assay. The
sample or samples and the assay must exist in the system.

Method POST

Header curl -k --header 'username:<user name>' --header 'password:
<user password>

Exarnpﬂe URL curl -k --header 'username:<user name>' --header 'password: <user password>'https://
<host>/genexus/api/lims/v2/plan-by-samples

Example request {
"irAccountName": "iraccount"
"reportTemplateName": "mytemplate",
"samples": [
{
"assayName": "Generic Sequencing Ampliseqg Assay",
"sampleId":"Samplel"

"assayName": "Custom DNA Assay"
"sampleId":"Sample2"

"assayName": "Custom DNA Assay"
"sampleId":"Sample3"
by
"notes":"my notes"
"planName":"plan_sample_run"

Create a library run

plan-by-library
URL BASE URL/plan-by-library
Description Create a library run from one or more library batches and an assay. The library batch

or batches and the assay must exist in the system.

Method POST

Header curl -k —--header 'username:<user name>' --header 'password:
<user password>
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(continued)

plan-by-library

Example URL

curl -k --header

'username:<user name>' --header

<host>/genexus/api/lims/v2/plan-by-library

'password: <user password>'https://

Example request

"irAccountName": "iraccount",
"samples": [

{

o

"notes":

"assayName":
"libraryBatchId":"LibraryBatchl"

"assayName": "Custom DNA Assay"
"libraryBatchId":"LibraryBatch2"

"assayName": "Custom DNA Assay"
"libraryBatchId":"LibraryBatch3"

"my notes",

"planName":"plan library run"

"Generic Sequencing Ampliseq Assay",
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Rules for variant names in Genexus™ Software

Genexus™ Software provides standard conventions for the names of genomic variants. Standard variant

names are derived from sample and results data and properties that are available in the software for

each variant, such as variant, gene name, and amino acid change. The conventions are used for both

de novo variants and variants that are included in a hotspots file. Variant names are shown in the

Variant Name column of variant tables, in the gene tiles in the Key Variants matrix, and in the reports

generated by the software.
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Rules for variant names in Genexus™ Software

Summary of variant types and examples of standardized variant names

Genexus™ Software applies a set of rules to a variant, then assigns or returns a name for the variant that
best describes variant details. The following table describes the rules that are used to name variants.

Variant type

Description

Variant name examples

Variants with protein change

Variants that provide an amino
acid change syntax.

BRAF V600E
BRAF p.(V600E) c.1799A>C

Variants with coding change but
no protein change

Variants that provide a coding
change, but for which an amino
acid is missing oris p. 2.

MET ¢.2942-29_2942-28delinsGG

Oncomine class-based variants

Any variant with a variant type of
SNV or INDEL at the locus based
on Oncomine™ annotations. These
changes are typically complex
and are frequently referenced in
scientific literature.

EGFR exon 19 deletion
MET exon 14 skipping

EGFR exon 19 insertion variants

Variant with
Function="nonframeshiftI
nsertion" in exon 19 of EGFR
gene.

EGFR exon 19 insertion

Copy number variants

Copy number gain or loss,
signified by a variant type of CNV.

ALK amplification
PTEN deletion

RNA exon variants

Specific RNA exon variants,
identified by variant ID.

MET exon 14 skipping
EGFRuvlII

Long deletion Variants

Oncomine Variant Class equals
LongDel and length attribute is a
positive integer.

BRCA1 40 base deletion

Exon deletions

A special type of CNV that
impacts BRCA genes only. These
variants are identified by a type of
CNV, a subtype of BigDel, and
call details that specify the exon
range affected.

BRCA1 exon 1 deletion

Exon duplications

A special type of CNV that
impacts BRCA genes only. These
variants are identified by a type of
CNV, a subtype of BigDup, and
call details that specify the exon
range affected.

BRCAT1 exon 1 duplication
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(continued)

Variant type Description Variant name examples

Chromosome arm-level alterations | Copy-number alterations occurring | 9p amplification
at the length of chromosome Xq deletion

arms. These variants are identified
by a type of CNV and a subtype of

ARM.
Targeted fusions Fusions detected by targeting a SLC34A2-ROS1 fusion
specific breakpoint.
Non-targeted fusions Non-targeted fusions SLC45A3-ETV1 fusion
Expression imbalance variants Variants for which the MET fusion

Oncomine Variant Class is
"ExpressionImbalance";.
This is measured by the partner-
agnostic detection of fusions in
driver genes using imbalance in
exonic expression.

All other mutations Mutation variants that do not ADAMTSL4-AS1 mutation
match the criteria of other variants
in this table.

Expression control variants Variants with LMNA expression control

SVTYPE=ExprControl.

Gene expression variants Variants with MET expression
SVTYPE=GeneExpression.

Annotation criteria for Oncomine™ Variant Annotator

In Genexus™ Software, analysis results are the final results generated by a run analysis. The analysis
results include run details, all BAM files, filtered results, graphs, run reports, metrics, plugin results,
annotated variant data, and VCF files. When you apply Oncomine™ variant annotations to an assay,
analysis results data from more than 24,000 exomes across solid tumor and hematological cancer types
is used as a reference to annotate variants that are relevant to cancer. For information about applying
Oncomine™ variant annotations to a custom assay, see “Panel step assay options” on page 222.

This section summarizes the requirements that must be met in order for the Oncomine™ Variant
Annotator to annotate variants in results for each Oncomine™ Research Assay and lon AmpliSeq™ HD
Panel.

For each variant type in these tables, Oncomine™ Variant Annotator annotates a variant only if all
conditions in the corresponding Annotation Criteria column are satisfied. The annotations are shown in
results in the Oncomine™ Gene Class and Oncomine™ Variant Class columns.

Note: You can find all relevant annotation criteria in VCF files.
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Oncomine™ BRCA Assay GX

Variant type

Oncomine™ Gene
class

Oncomine™ Variant class

Annotation criteria

Copy number
deletion

Loss-of-Function

Deletion

SVTYPE = "CNV"
FILTER = "LOSS"
SUBTYPE = "GeneCNV"

Copy number exon
deletion

Loss-of-Function

ExonDeletion

SVTYPE = "CNV"
FILTER = "LOSS"
SUBTYPE = "BigDel"

Copy number exon
duplication

Loss-of-Function

ExonDuplication

SVTYPE = "CNV"
FILTER = "GAIN"
SUBTYPE = "BigDup"

Long deletion Loss-of-Function LongDel Positive mutation call
SVTYPE = "LongDel"

Loss-of-function Loss-of-Function Truncating Positive mutation call

truncating de novo Functional impact is frameshift

mutation block substitution, frameshift deletion,
frameshift insertion, or nonsense
Occurs in a designated loss-of-function
gene

Missense hotspot Loss-of-Function Hotspot Positive mutation call

mutation Functional impact is missense
Transcript and codon position occur in
predefined missense hotspot list

Splice site hotspot Loss-of-Function Hotspot Positive mutation call

mutation

Transcript, location, and exon occur in
predefined splice site hotspot list

Oncomine™ Comprehensive Assay v3 GX

Variant type

Oncomine™ Gene
class

Oncomine™ Variant class

Annotation criteria

Copy number
amplification

Gain-of-Function

Amplification

SVTYPE = "CNV"
FILTER = "GAIN"

Occurs in a designated copy-gain gene

Long deletion

Loss-of-Function

LongDel

Positive mutation call
SVTYPE = "LongDel"
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(continued)
Variant type Oncon:lr;:s (S Oncomine™ Variant class Annotation criteria
Gene fusion Gain-of-Function Fusion SVTYPE = "Fusion”

FILTER = "PASS"
Is a targeted fusion isoform

Non-targeted fusion

Gain-of-Function

NonTargetedFusion

SVTYPE = "Fusion"

FILTER = "PASS"

Non-Targeted field is present
NT_FUSION_IN_FRAME is not FALSE

NT_FUSION_DRIVER_INVOLVED is not
FALSE

NT_FUSION_SECONDARY is not TRUE

RNA exon variant Gain-of-Function RNAExonVariant SVTYPE = "RNAExonVariant" or
"Fusion"
FILTER = "PASS"
Is a targeted RNA exon variant

Loss-of-function Loss-of-Function Truncating Positive mutation call

truncating de novo Functional impact is frameshift

mutation block substitution, frameshift deletion,
frameshift insertion, or nonsense
Occurs in a loss-of-function gene

Missense hotspot Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Functional impact is missense
Transcript and codon position occur in
predefined missense hotspot list

In-frame hotspot Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Functic.)n, transclzript,.and coding syntax
occur in predefined in-frame hotspot
list

Splice site hotspot Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Transc.ript, Iocgtion., and exon oceur in
predefined splice site hotspot list

Intronic hotspot Gain-of-Function Hotspot Positive mutation call

mutation

Loss-of-Function

Transcript, location, and coding syntax
occur in predefined intronic hotspot list
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(continued)
Variant type Oncon;:r;:s (S Oncomine™ Variant class Annotation criteria

Promoter hotspot Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Transcript, location, and coding syntax
occur in predefined promoter hotspot
list

Gain-of-function Gain-of-Function Hotspot Positive mutation call

truncating hotspot Function, transcript, and coding syntax

mutation occur in predefined truncating hotspot
list
Occurs in a gain-of-function gene

Loss-of-function Loss-of-Function Truncating Positive mutation call

truncating hotspot Function, transcript, and coding syntax

mutation occur in predefined truncating hotspot
list
Occurs in a loss-of-function gene

MNV hotspot Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Transcript and.coding syntax occur in
MNYV hotspot list

EGFR exon 19 Gain-of-Function | EGFRExon19Deletion Positive mutation call

deletionl']

Functional impact is nonframeshift
deletion, nonframeshift block
substitution

Deletion impacts codons 744-761 of
EGFR

EGFR exon 20
insertionl']

Gain-of-Function

EGFRExon20Insertion

Positive mutation call

Functional impact is nonframeshift
insertion, nonframeshift block
substitution

Insertion impacts codons 762-775 of
EGFR or variant is in EGFR exon 20
insertion confirmed list

ERBB2 exon 20
insertionl!!

Gain-of-Function

ERBB2Exon20Insertion

Positive mutation call

Functional impact is nonframeshift
insertion, nonframeshift block
substitution

Insertion impacts codons 770-783 of
ERBB2
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Variant type

Oncomine™ Gene
class

Oncomine™ Variant class

Annotation criteria

KIT exon 11
deletionl

Gain-of-Function

KITExon11Deletion

Positive mutation call

Functional impact is nonframeshift
deletion, nonframeshift block
substitution

Deletion impacts codons 550-580 of
KIT

Alternatively, mutation occurs in splice
site flanking the 5' end of exon 11

KIT exon 11
insertionl']

Gain-of-Function

KITExon11lInsertion

Positive mutation call

Functional impact is nonframeshift
insertion, nonframeshift block
substitution

Insertion impacts codons 550-580 of
KIT

MET exon 14
skipping!!

Gain-of-Function

METExon14Skipping

Positive mutation call

Location is splice site in MET exon
14, is intronic >= 4bp deletion in 30
nucleotides preceding MET exon 14,
or variant is in MET Exon 14 Skipping
confirmed list

PDGFRA exon 18
deletionl

Gain-of-Function

PDGFRAExon18Deletion

Positive mutation call

Functional impact is nonframeshift
deletion, nonframeshift block
substitution

Deletion impacts codons 841-847 of
PDGFRA

' For more information, see “lon Torrent™ Class-Based Variants” on page 399.

Oncomine™ Myeloid Assay GX v2

Variant type

Oncomine™ Gene
class

Oncomine™ Variant class

Annotation criteria

Gene fusion

Gain-of-Function

Fusion

SVTYPE = "Fusion"
FILTER = "PASS"

Is a targeted fusion isoform
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(continued)

Variant type

Oncomine™ Gene
class

Oncomine™ Variant class

Annotation criteria

Non-targeted fusion

Gain-of-Function

NonTargetedFusion

SVTYPE = "Fusion"

FILTER = "PASS"

Non-Targeted field is present
NT_FUSION_IN_FRAME is not FALSE

NT_FUSION_DRIVER_INVOLVED is not
FALSE

NT_FUSION_SECONDARY is not TRUE

RNA exon variant Gain-of-Function RNAExonVariant SVTYPE = "RNAExonVariant" or
"Fusion"
FILTER = "PASS"
Is a targeted RNA exon variant

Loss-of-function Loss-of-Function Truncating Positive mutation call

truncating de novo Functional impact is frameshift

mutation block substitution, frameshift deletion,
frameshift insertion, or nonsense
Occurs in a loss-of-function gene

Missense hotspot Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Functional impact is missense
Transcript and codon position occur in
predefined missense hotspot list

In-frame hotspot Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Functi(.)n, transc':ript,.and coding syntax
occur in predefined in-frame hotspot
list

Promoter hotspot Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Transcript, location, and coding syntax
occur in predefined promoter hotspot
list

Gain-of-function Gain-of-Function Hotspot Positive mutation call

truncating hotspot
mutation

Function, transcript, and coding syntax
occur in predefined truncating hotspot
list

Occurs in a gain-of-function gene
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(continued)
Variant type Oncon:lr;:s (S Oncomine™ Variant class Annotation criteria
Loss-of-function Loss-of-Function Truncating Positive mutation call
truncating hotspot Function, transcript, and coding syntax
mutation occur in predefined truncating hotspot
list
Occurs in a loss-of-function gene
MNV hotspot Gain-of-Function Hotspot Positive mutation call
mutation

Loss-of-Function

Transcript and coding syntax occur in
MNYV hotspot list

JAK2 exon 12 indell]

Gain-of-Function

JAK2Exon12Indel

Positive mutation call

Functional impact is nonframeshift
deletion, nonframeshift insertion,
nonframeshift block substitution

Indel impacts codons 536-547 of JAK2

KIT exon 11
deletionl]

Gain-of-Function

KITExon11Deletion

Positive mutation call

Functional impact is nonframeshift
deletion, nonframeshift block
substitution

Deletion impacts codons 550-580 of
KIT

Alternatively, mutation occurs in splice
site flanking the 5' end of exon 11

KIT exon 11
insertionl']

Gain-of-Function

KITExon11Insertion

Positive mutation call

Functional impact is nonframeshift
insertion, nonframeshift block
substitution

Insertion impacts codons 550-580 of
KIT

FLT3 internal tandem
duplication

Gain-of-Function

FLT3ITD

Positive mutation call

Functional impact is a non-frameshift
insertion in exon 14/15 of FLT3 or
SVTYPE = "FLT3ITD"

' For more information, see “lon Torrent™ Class-Based Variants” on page 399.
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Oncomine™ Precision Assay GX

Variant type

Oncomine™ Gene
class

Oncomine™ Variant class

Annotation criteria

Copy number
amplification

Gain-of-Function

Amplification

SVTYPE = "CNV"
FILTER = "GAIN"

Occurs in a designated copy-gain gene

Copy number Loss-of-Function Deletion SVTYPE = "CNV"
deletion FILTER = "LOSS"
Occurs in a designated copy-loss gene
Gene fusion Gain-of-Function Fusion SVTYPE = "Fusion"
FILTER = "PASS"
Is a targeted fusion isoform
RNA exon variant Gain-of-Function RNAExonVariant SVTYPE = "RNAExonVariant" or

“Fusion”
FILTER = "PASS"

Is a targeted RNA exon variant

Expression
imbalance

Gain-of-Function

Expressionimbalance

SVTYPE = "RNAExonTiles"
FILTER = "PASS"

Record meets Targeted Isoforms
Detected Requirement

Loss-of-function Loss-of-Function Truncating Positive mutation call
truncating de novo Functional impact is frameshift
mutation block substitution, frameshift deletion,
frameshift insertion, or nonsense
Occurs in a loss-of-function gene
Missense hotspot | Gain-of-Function Hotspot Positive mutation call
mutation Loss-of-Function Functional impact is missense
Transcript and coding syntax occur in
predefined missense hotspot list
In-frame hotspot Gain-of-Function Hotspot Positive mutation call
mutation Loss-of-Function Functign, transc.:ript,.and coding syntax
occur in predefined in-frame hotspot
list
Splice site hotspot | Gain-of-Function Hotspot Positive mutation call

mutation

Loss-of-Function

Transcript, location, and exon occur in
predefined splice site hotspot list
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(continued)
Variant type Oncon:lr;:s Gene Oncomine™ Variant class Annotation criteria
Intronic hotspot Gain-of-Function Hotspot Positive mutation call
mutation Loss-of-Function Transcript, location, and coding syntax
occur in predefined intronic hotspot list
Gain-of-function Gain-of-Function Hotspot Positive mutation call
truncating hotspot Function, transcript, and coding syntax
mutation occur in predefined truncating hotspot
list
Occurs in a gain-of-function gene
Loss-of-function Loss-of-Function Truncating Positive mutation call
truncating hotspot Function, transcript, and coding syntax
mutation occur in predefined truncating hotspot
list
Occurs in a loss-of-function gene
MNV hotspot Gain-of-Function Hotspot Positive mutation call
mutation Loss-of-Function Transcript and coding syntax occur in
MNYV hotspot list
EGFR exon 19 Gain-of-Function | EGFRExon19Deletion Positive mutation call

deletion

Functional impact is nonframeshift
deletion, nonframeshift block
substitution

Deletion impacts codons 744-761 of
EGFR

EGFR exon 20
insertion

Gain-of-Function

EGFRExon20Insertion

Positive mutation call

Functional impact is nonframeshift
insertion, nonframeshift block
substitution

Insertion impacts codons 762-775 of
EGFR or variant is in EGFR exon 20
insertion confirmed list

ERBB2 exon 20
insertion

Gain-of-Function

ERBB2Exon20Insertion

Positive mutation call

Functional impact is nonframeshift
insertion, nonframeshift block
substitution

Insertion impacts codons 770-783 of
ERBB2
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(continued)

Variant type

Oncomine™ Gene
class

Oncomine™ Variant class

Annotation criteria

KIT exon 11 deletion

Gain-of-Function

KITExon11Deletion

Positive mutation call

Functional impact is nonframeshift
deletion, nonframeshift block
substitution

Deletion impacts codons 550-580 of
KIT

Alternatively, mutation occurs in splice
site flanking the 5' end of exon 11

KIT exon 11 insertion

Gain-of-Function

KITExon11Insertion

Positive mutation call

Functional impact is nonframeshift
insertion, nonframeshift block
substitution

Insertion impacts codons 550-580 of
KIT

MET exon 14
skipping

Gain-of-Function

METExon14Skipping

Positive mutation call

Location is splice site in MET exon
14, is intronic >= 4bp deletion in 30
nucleotides preceding MET exon 14,
or variant is in MET Exon 14 Skipping
confirmed list

PDGFRA exon 18
deletion

Gain-of-Function

PDGFRAExon18Deletion

Positive mutation call

Functional impact is nonframeshift
deletion, nonframeshift block
substitution

Deletion impacts codons 841-847 of
PDGFRA
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Annotation criteria for Oncomine™ Variant Annotator

The Oncomine™ Variant Annotator plugin applies universal annotation rules for custom assays that
include a custom panel. To apply the rules, the Apply Oncomine Variant Annotations checkbox
must be selected when the assay is created. For more information, see “Panel step assay options” on

page 222.

IMPORTANT! Because these annotations are generic, the annotations can be different from those
generated with a system-installed or fixed panel.

Variant type

Oncomine™ Gene
class

Oncomine™ Variant class

Annotation criteria

Copy number
amplification

Gain-of-Function

Amplification

SVTYPE = "CNV"
FILTER = "GAIN"

Occurs in a designated copy-gain gene

Copy number
deletion

Loss-of-Function

Deletion

SVTYPE = "CNV"
FILTER = "LOSS"
Occurs in a designated copy-loss gene

Copy number exon
deletion

Loss-of-Function

ExonDeletion

SVTYPE = "CNV"
FILTER = "LOSS"
SUBTYPE = "BigDel"

Copy number exon Loss-of-Function ExonDuplication SVTYPE = "CNV"
duplication FILTER = "GAIN"
SUBTYPE = "BigDup"
Loss of Loss-of-Function LOH SVTYPE = "LOH"
Heterozygosity LOH = "{"
FILTER = "GAIN" or "LOSS" or "PASS"
Gene fusion Gain-of-Function Fusion SVTYPE = "Fusion"

FILTER = "PASS"

Is a targeted fusion isoform

Non-targeted fusion

Gain-of-Function

NonTargetedFusion

SVTYPE = "Fusion"

FILTER = "PASS"

Non-Targeted field is present
NT_FUSION_IN_FRAME is not FALSE

NT_FUSION_DRIVER_INVOLVED is not
FALSE

NT_FUSION_SECONDARY is not TRUE
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(continued)

Variant type

Oncomine™ Gene
class

Oncomine™ Variant class

Annotation criteria

RNA exon variant

Gain-of-Function

RNAExonVariant

SVTYPE = "RNAExonVariant" or
"Fusion"

FILTER = "PASS"

Is a targeted RNA exon variant

Expression
imbalance

Gain-of-Function

Expressionimbalance

SVTYPE = "RNAExonTiles"
FILTER = "PASS"

Record meets Targeted Isoforms
Detected Requirement

Long deletion Loss-of-Function LongDel Positive mutation call
SVTYPE = "LongDel"
Loss-of-function Loss-of-Function Truncating Positive mutation call
truncating de novo Unclassified Functional impact is frameshift
mutation block substitution, frameshift deletion,
frameshift insertion, or nonsense
Occurs in a loss-of-function or
unclassified gene
Missense hotspot Gain-of-Function Hotspot Positive mutation call
mutation Loss-of-Function Functional impact is missense
Unclassified Transcript and codon position occur in
predefined missense hotspot list
In-frame hotspot Gain-of-Function Hotspot Positive mutation call
mutation Loss-of-Function Function, transcript, and coding syntax
occur in predefined in-frame hotspot
Unclassified list
Splice site hotspot Gain-of-Function Hotspot Positive mutation call
mutation Loss-of-Function Transcript, location, and exon occur in
predefined splice site hotspot list
Unclassified
Intronic hotspot Gain-of-Function Hotspot Positive mutation call
mutation Loss-of-Function Transcript, location, and coding syntax
occur in predefined intronic hotspot list
Unclassified
Promoter hotspot Gain-of-Function Hotspot Positive mutation call

mutation

Loss-of-Function

Unclassified

Transcript, location, and coding syntax
occur in predefined promoter hotspot
list
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(continued)
Variant type Oncon;:r;:s Gene Oncomine™ Variant class Annotation criteria
Gain-of-Function Hotspot Positive mutation call
Synonymous hotspot | Loss-of-Function Functional impact is synonymous
mutation i i i
Unclassified Transc.rlpt and coding syntax OCCLI,II’ in

predefined synonymous hotspot list

Gain-of-function Gain-of-Function Hotspot Positive mutation call

truncating hotspot Function, transcript, and coding syntax

mutation occur in predefined truncating hotspot
list
Occurs in a gain-of-function gene

Loss-of-function Loss-of-Function Truncating Positive mutation call

truncating hotspot Function, transcript, and coding syntax

mutation occur in predefined truncating hotspot
list
Occurs in a loss-of-function gene

MNV hotspot Gain-of-Function Hotspot Positive mutation call

mutation Loss-of-Function Transcript and coding syntax occur in
MNYV hotspot list

Unclassified
EGFR exon 19 Gain-of-Function EGFRExon19Deletion Positive mutation call

deletionl]

Functional impact is nonframeshift
deletion, or nonframeshift block
substitution

Deletion impacts codons 744-761 of
EGFR

EGFR exon 20
insertionl']

Gain-of-Function

EGFRExon20Insertion

Positive mutation call

Functional impact is nonframeshift
insertion, or nonframeshift block
substitution

Insertion impacts codons 762-775 of
EGFR or variant is in EGFR exon 20
insertion confirmed list

ERBB2 exon 20
insertionl']

Gain-of-Function

ERBB2Exon20Insertion

Positive mutation call

Functional impact is nonframeshift
insertion, or nonframeshift block
substitution

Insertion impacts codons 770-783 of
ERBB2
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(continued)

Variant type

Oncomine™ Gene
class

Oncomine™ Variant class

Annotation criteria

JAK2 exon 12 indell]

Loss-of-Function

JAK2Exon12Iindel

Positive mutation call

Functional impact is nonframeshift
deletion, nonframeshift insertion, or
nonframeshift block substitution

Indel impacts codons 536-547 of JAK2

KIT exon 11 Gain-of-Function KITExon11Deletion Positive mutation call

deletion!'] Functional impact is nonframeshift
deletion, or nonframeshift block
substitution
Deletion impacts codons 550-580 of
KIT
Alternatively, mutation occurs in splice
site flanking the 5' end of exon 11

KIT exon 11 Gain-of-Function KITExon11Insertion Positive mutation call

insertionl] Functional impact is nonframeshift
insertion, or nonframeshift block
substitution
Insertion impacts codons 550-580 of
KIT

MET exon 14 Gain-of-Function METExon14Skipping Positive mutation call

skipping!'! Location is splice site in MET exon
14, is intronic >= 4bp deletion in 30
nucleotides preceding MET exon 14,
or variant is in MET Exon 14 Skipping
confirmed list

PDGFRA exon 18 Gain-of-Function | PDGFRAExon18Deletion Positive mutation call

deletionl] Functional impact is nonframeshift
deletion, or nonframeshift block
substitution
Deletion impacts codons 841-847 of
PDGFRA

FLT3 internal tandem | Gain-of-Function FLT3ITD Positive mutation call

duplication

Functional impact is a non-frameshift
insertion in exon 14/15 of FLT3 or
SVTYPE = "FLT3ITD"

' For more information, see “lon Torrent™ Class-Based Variants” on page 399.
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lon Torrent™ Class-Based Variants

lon Torrent™ Class-Based Variants are a set of logic-based rules that Genexus™ Software uses to
computationally identify and annotate novel mutations in important genomic variant classes. The
annotation logic is based on scientific literature evidence. Details about the logic follow.

EGFR exon 19 deletion

Background: Epidermal growth factor receptor (EGFR) is a transmembrane receptor protein made
up of 1210 amino acids and located on chromosome 7p11.2. EGFR has 31 exons— exons 2-4

and 8-12 encode the ligand binding domains, exons 5-7 and 13-16 encode the cysteine rich
domain, exons 18-24 encode the tyrosine kinase domain (TKD), and exons 25-28 encode the
autophosphorylation region [PMID: 17318210]. Mutations in EGFR often target the TKD which
make up the ATP-binding pocket of the enzyme [PMID: 17318210]. Exon 19 deletions are indels
that range between 15-18 bp in length and usually occur within codons 746-756 [PMID: 23768755,
PMID: 22190593, PMID: 26933124, PMID: 24163741]. In non-small cell lung cancer (NSCLC),
EGFR exon 19 deletions, located within codons 746-750, represent 45-50% of somatic mutations
[PMID: 26933124, PMID: 24163741]. Exon 19 deletions result in constitutive activation of the
receptor tyrosine kinase and hyperactivation of downstream signaling pathways [PMID: 29455648].

CBYV Criteria: The boundaries defined to capture EGFR exon 19 deletions as a class-based variant
start at codon 744 and end at codon 761, which encompass common and rare indels [PMID:
30473385].

EGFR exon 20 insertion

Background: Epidermal growth factor receptor (EGFR) is a transmembrane receptor protein made
up of 1210 amino acids located on chromosome 7p11.2. EGFR has 31 exons— exons 2-4 and 8-12
encode the ligand binding domains, exons 5-7 and 13-16 encode the cysteine rich domain, exons
18-24 encode the tyrosine kinase domain (TKD), and exons 25-28 encode the autophosphorylation
region [PMID: 17318210]. Mutations in EGFR often target the TKD which make up the ATP-binding
pocket of the enzyme [PMID: 17318210]. In-frame insertions within exon 20 of EGFR are the third
most common type of mutation found in NSCLC, representing 4-12% of all EGFR mutations in
NSCLC [PMID: 31208370]. EGFR exon 20 encompasses codons 762 to 823. Exon 20 insertions
commonly involve codons 762 to 774 wherein codons 762-766 make up the c-helix and codons
767-774 make up the activation loop [PMID: 31208370, PMID: 30854234]. EGFR exon 20 insertions
do not alter the receptor binding affinity; however, it is suggested that the location of exon 20
insertions stabilizes its active confirmation [PMID: 30854234, PMID: 27843613].

CBYV Criteria: The boundaries defined to capture EGFR exon 20 insertions as a class-

based variant start at codon 762 and end at codon 775. Additionally, known EGFR exon

20 insertions p.A763_Y764insFQEA and p.A763_Y764insLQEA, represented as ¢.2284-6_2284—
5insTCCAGGAAGCCT and ¢.2284-9_2284-8insCCCTCCAGGAAG due to left alignment into the
intronic region, are included in this rule.
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ERBB2 exon 20 insertion

Background: Erb-b2 receptor tyrosine kinase 2 (ERBB2) is a transmembrane glycoprotein located
on chromosome 17q12 [PMID: 25276427]. ERBB2 (also known as HER2) has 27 exons— exons
2-4 and 9-12 encode the extracellular receptor L domains, exons 5-8 encode the furin like domain,
exons 13-16 encode the growth factor receptor domain IV, exon 17 encodes the transmembrane
domain, and exons 18-24 encode the tyrosine kinase domain (TKD) [PMID: 22761469, PMID:
29420467]. In lung cancer, the most recurrent ERBB2 activating mutations include in-frame

exon 20 insertions [PMID: 30425522]. ERBB2 exon 20 involves codons 770 to 831 and majority

of exon 20 insertions occur between codons 775 and 781 within the kinase domain [PMID:
29686424, PMID:22761469]. Insertions at the C-terminal end of ERBB2 exon 20 induce a change
in conformation of the a-C helix leading to a constitutively active formation which affects the
drug-binding pocket [PMID: 29686424].

CBYV Criteria: The boundaries defined to capture ERBB2 exon 20 insertions as a class-based
variant start at codon 770 and end at codon 783.

JAK2 exon 12 indel

Background: Janus kinase 2 (JAK2) is a non-receptor membrane associated protein tyrosine
kinase (PTK) made up of 1132 amino acids and located on chromosome 9p24. JAK2 belongs to
the Janus kinase (JAK) family and has 25 exons—exons 3-7 encode the FERM domain, exons
9-11 encode the SH2-pseudokinase domain, exons 12-19 encode the kinase-like or pseudokinase
domain (JH2), and exons 19-25 encode the C-terminal tyrosine kinase domain (JH1) [PMID:
23592968; PMID: 17639043; PMID: 29379470]. In addition, codons 523-544 in exon 12 encode
the SH2-pseudokinase linker region and codons 817-839 in exon 19 encode the linker between
the JH1 and JH2 protein kinase regions [PMID: 23592968, PMID: 17639043]. Mutations in JAK2
often target exon 12 including the region adjacent to the start of the pseudo-kinase domain
[PMID: 21674578]. JAK2 exon 12 mutations (missense and in-frame deletions) are prevalent in
myeloproliferative neoplasms including polycythemia vera [PMID: 21674578].

CBYV Criteria: The boundaries defined to capture JAK2 exon 12 in-frame insertions and deletions
(indels) as a class-based variant start at codon 536 and end at codon 547. These boundaries
capture the most common JAK2 exon 12 indels, including N542_E543del, E543_D544del,
F537_K539delinsL and R541_E543delinsK mutations.
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KIT exon 11 insertion and KIT exon 11 deletion

* Background: KIT, also known as CD117, is a proto-oncogene receptor tyrosine kinase made up of
976 amino acids located on chromosome 4g12 [PMID: 16689459]. KIT is a member of the PDGFR
type lll receptor tyrosine kinase family [PMID: 26579483; PMID: 26309392]. KIT has 21 exons—
exons 1-9 encode the extracellular ligand-binding region containing five Ig-like domains, exon 10
encodes the transmembrane (TM) domain, and exon 11 encodes a cytoplasmic juxtamembrane
region. The intracellular region of KIT is encoded by exons 12-21, wherein, exons 12-14 encode
the tyrosine kinase domain 1, exons 15-16 encode the kinase insert (Kl) region, and exons 17—

19 encode the tyrosine kinase domain 2 [PMID: 24449920, PMID: 27536065, PMID: 31378162,
PMID: 15342366, PMID: 17555444]. Recurrent somatic KIT alterations are observed in both solid
and hematological cancers and include activating mutations such as single nucleotide variants
(SNVs), small duplications, and complex in-frame insertions or deletions (indels). Mutations in KIT
exons 8, 9, 11, and 17 disrupt the auto-inhibitory mechanisms and lead to constitutive activity
[PMID: 27536065]. While mutations in exons 8 and 17 are common in myeloid cancers, 60-70%
of somatic mutations (including SNVs and indels) in gastrointestinal stromal tumor (GIST) occur in
exon 11, which encodes the juxtamembrane domain [PMID: 27536065, PMID: 22588877, PMID:
23678293; NCCN-GIST].

® CBYV Criteria: The boundaries defined to capture KIT exon 11 insertions and deletions as a class-
based variant start at codon 550 and end at codon 580.

MET exon 14 skipping

¢ Background: The MET proto-oncogene is a receptor tyrosine kinase made up of 1390 amino acids
and is located on chromosome 7g31 [PMID: 15735036]. MET has 21 exons containing three main
structural domains—an extracellular Sema domain in exon 2, a juxtamembrane domain in exon
14, and a tyrosine kinase domain in exons 15-21 [PMID: 28376232, PMID: 9380410]. Splice site
mutations flanking exon 14 are observed in 4% of non-small cell lung cancer (NSCLC). These
mutations include canonical splice site mutations affecting exon 14 and deletions that extend into
the splicing motifs within intron 13 [PMID: 25971938, PMID: 27343443]. Such mutations disrupt
splicing leading to the formation of an alternative transcript that joins exon 13 directly to exon 15
and skips exon 14 entirely. The MET exon 14 skipping transcript lacks the juxtamembrane domain
that contains the recognition motif for ubiquitin-dependent proteolysis and thus leads to a marked
increase in steady-state level of the MET protein [PMID: 28164087].

® CBV Criteria: The boundaries defined to capture MET exon 14 skipping as a class-based variant
can be summarized into four individual rules: (a) has transcript = NM_001127500.3, exon = 14,
and location = splicesite_3 (at ¢.2942) or splicesite_5 (at ¢.3082), (b) is an intronic deletion = 4 bp
impacting 30 nucleotides preceding exon 14 (c) is a missense variant at ¢.3082 [PMID: 27343443,
PMID: 26729443, PMID: 25971938, PMID: 25898962, PMID: 25898965, PMID: 31472177], (d) is
one of the following variants with confirmed skipping defined as ¢.3082delG [PMID: 25971938,
PMID: 27343443], c.3066_3081delAGCTACTTTTCCAGAA, c.3075_3082del [PMID: 31472177], or
c.3080_3081delAA [PMID: 26729443].
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PDGFRA exon 18 deletion

* Background: Platelet derived growth factor receptor alpha (PDGFRA) is a cell surface tyrosine
kinase receptor made up of 1089 amino acids and located on chromosome 4q12. PDGFRA
contains 23 exons —exons 1-2 encode the signaling peptide, exons 3-10 encode the extracellular
domain, exon 11 encodes the transmembrane domain, exon 12 encodes the juxtamembrane
domain, and exons 13-23 encode the kinase domain [PMID: 33449152]. Mutations in PDGFRA
often target the activation loop located within exon 18 and, to a lesser extent, target the
juxtamembrane domain and the N-lobe of the kinase domain found within exons 12 and 14
[PMID: 30778083, PMID: 33449152, PMID: 15146165]. Activating PDGFRA exon 18 mutations
such as V561D, N659K, D842V, and in-frame deletions are observed in 30-40% of KIT-negative
gastrointestinal stromal tumors (GISTs) [PMID: 17193822, PMID: 15928335, PMID: 12522257,
PMID: 23970477]. Specifically, PDGFRA in-frame deletions in codons 841-847 make up 23% of
all exon 18 mutations [PMID: 15146165].

® CBYV Criteria: The boundaries defined to capture PDGFRA exon 18 deletions as a class-based
variant start at codon 841 and end at codon 847.
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Hotspots BED files

The BED file specification (http://genome.ucsc.edu/FAQ/FAQformat.html#formati.7) indicates that
the fourth column is the name of the BED line, and is used to label the variant region in the UCSC
genome browser or IGV. This label is also used to populate the ID field in the output VCF files as well as
the Variant ID columns in Genexus™ Software.

Oncomine™ panel hotspots files contain genomic representations that correspond to somatic variants
that have been frequently observed in cancer samples, and thus are likely to be relevant to

the cancer phenotype. These files also contain less frequently observed variants, implicated in

literature reports as functionally relevant, for example, activating/inactivating variants. When possible,
variants within the hotspots files are assigned an identifier consistent with a publicly accessible

data source, preferentially COSMIC (https://cancer.sanger.ac.uk/cosmic) but also including dbSNP
(https://www.ncbi.nlm.nih.gov/snp/) and ClinVar (https://www.ncbi.nlm.nih.gov/clinvar/). If a variant
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cannot be found in COSMIC, it may receive an arbitrarily assigned identifier to aid in variant calling
interpretation and troubleshooting; these identifiers (for example, BT144, OM3324, OMINDEL700,
MAN103) should be consistent across Oncomine™ panels. When hotspots files are updated, Thermo
Fisher Scientific reviews the COSMIC database to determine whether variants with such identifiers have
been assigned COSMIC IDs, and replace them with the more meaningful COSMIC IDs.

COSMIC ID changes due to database updates

The COSMIC database updates approximately four times a year, and these updates involve the
addition of newly curated variants, removal of a smaller number of variants, and changes in genomic
representations to a very small number of variants. There is, therefore, a chance that the variant
identifiers in the hotspots files might be out of sync with, or no longer be found on the COSMIC
website. Additionally, prior to COSMIC version 90, the same normalized genomic variant (see https://
pubmed.ncbi.nim.nih.gov/25701572/) might have had multiple redundant COSMIC variant identifiers
(COSM); since COSMIC version 90, these identifiers have been replaced with one consistent COSV
identifier, and multiple COSMIC variants may map to these identifiers.

Fusions files

A comprehensive, universally recognized database of oncogenic gene fusion breakpoints does not
exist. Therefore, gene fusion isoform identifiers are generated by concatenating the two gene symbols
with a hyphen, and then combining the first letter of the 5’ partner with the last retained 5’ exon along
with the first letter of the 3’ partner with the first retained 3’ exon. For example, EML4-ALK.E6A17
involves a fusion between the sixth exon of EML4 with the 17th exon of ALK. Fusion isoforms involving
junctions between incomplete exons, or involving intronic insertions may contain “ins” or “del” modifiers
followed by the number of nucleotides removed or added. Additionally, assay names may contain
additional identifiers such as COSMIC COSF ids or GenBank accession numbers.

System-installed annotation sets

Genexus™ Software includes system-installed annotation sets as presets to use in assays. System-
installed annotation sets are locked and cannot be changed.

System-installed annotation sets Description

All_hg19_516 A system-installed annotation set for use with hg19 assays.
All_GRCh38_516 A system-installed annotation set for use with GRCh38 assays.
Performance Qualification A system-installed annotation set for use with Performance
Annotations -1.9.0 Qualification assays.

This annotation set is available when the assay parameter set for it is
enabled in the system.

Integrated Purification A system-installed annotation set for use with Performance
Performance Qualification Qualification assays for the integrated Genexus™ Integrated Sequencer.

Annotations -1.9.2 This annotation set is available when the assay parameter set for it is

enabled in the system.
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System-installed barcode sets

The Genexus™ Software includes system-installed barcode sets as presets to use in assays. System-
installed barcode sets are locked and cannot be changed.

System-installed barcode set

Description

lon AmpliSeq™ HD Dual Barcode Kit 1-24

A set of 24 unique dual-barcode primers designed
and validated for optimal performance with lon
GeneStudio™ S5 Series sequencers.

For use with lon AmpliSeq™ HD assays.

lonCode™ Barcodes 1-32

A unique set of 32 barcode adapters designed for
optimal performance with lon GeneStudio™ S5, lon
PGM™, and lon Proton™ sequencers.

lonCode™ Barcodes 1-384

A unique set of 384 barcode adapters designed for
optimal performance with lon GeneStudio™ S5, lon
PGM™, and lon Proton™ sequencers.

lon Select BC Set-1

A unique set of 16 barcode adapters supplied with
the lon PGM™ Select Library Kit.

lon SingleSeq™ Barcodes

A unique set of 96 barcode adapters optimized for
use with lon ReproSeq™ libraries.

lon Torrent™ Dual Barcode Kit 1-96

A set of 96 unique dual-matched barcode adapters
designed to enable optimal performance of amplicon
libraries and lon semiconductor sequencers.

For use with lon AmpliSeq™ HD and Oncomine™
assays.

lon Torrent™ Genexus™ Barcodes 1-32 HD

A unique set of 32 barcode adapters designed and
validated for optimal performance with the Genexus™
Integrated Sequencer.

For use with lon AmpliSeq™ HD assays.

lon Torrent™ Genexus™ Barcodes 1-96 AS

A unique set of 96 barcode adapters designed and
validated for optimal performance with the Genexus™
Integrated Sequencer.

lon Xpress™ Barcodes

A unique set of 96 barcode adapters for use with lon
AmpliSeg™ libraries and lon Xpress™ Plus fragment
libraries.

404

Genexus™ Software 6.8 User Guide




Appendix B Reference information
System-installed filter chains

System-installed filter chains

Genexus™ Software includes system-installed filter chains as that are included as presets in assays to
filter in or out variants of interest in run results. The filter chains can also be used to dynamically change
the view of the variants as you view results. System-installed filter chains are locked and cannot be
changed. You cannot edit system-installed filter chains, but you can create custom filter chains to refine
the results in the software.

System-installed

Available

filter chain versionsl'] Description
Oncomine™ * 6.8 This filter chain includes all Oncomine™-annotated variants and
Extended e 516 variants that can be relevant to cancer due to their inclusion in one or
. 514 more of the following classes:
* Non-targeted fusions.
® CNV variants with FILTER value of GAIN or LOSS.
* Likely somatic mutations based on dbSNP, 5000Exomes,
ExAC, and UCSC Common SNPs annotation source databases.
The minor allele frequencies range lies between 0.0 and 1.0E-6.
Mutations must also be nonsynonymous and occur in exonic or
splice-site regions.
* Variants with ClinVar annotations of pathogenic or likely
pathogenic.
Oncomine™ * 6.8 This filter chain includes all Oncomine™-annotated variants.
Variants e 516
e 514
Variant Matrix * 638 Returns variant types in a visualization. Variant types returned are
Summary e 516 SNV/INDEL, CNV, fusions, and RNAExonVariants.
e 514
Oncomine™ * 6.8 Removes any variants in the sample ID amplicons that are not in the
BRCA e 516 BRCA1 and BRCA2 genes.
TMB (Non- * 6.8 This filter chain returns results for somatic variants based on dbSNP,
germline 5000Exomes, ExAC, and UCSC Common SNPs annotation source
Mutations) databases. The minor allele frequencies range is between 0.0 and

1.0E-6. This filter chain also filters out variants of homopolymer
lengths greater than 7.
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(continued)
System-installed Available Descriotion
filter chain versions!'] P
Oncomine™ * 638 A logical filter group that contains multiple filters that might include
Variants AND e 516 unannotated variants.
Nor!-Targeted Filters are applied in the following order.
Fusions
* Oncomine =In
* Variant Type in FUSION
* Filter in PASS
No Filter not applicable Select this option to remove a previously applied filter chain and view
all called variants.

' The version depends on the assay parameter set installed in the software.

Genexus™ Software includes system-installed filters that you can add to custom filter chains. A filter

chain is a set of filters that the software uses to narrow the list of variants that are included in results.
When you create a filter chain, you can dynamically change the view of variants in results, or you can
filter in or out variants from results by adding the filter chain to an assay that is used for a sequencing

run.

The system-installed filters are based on public and proprietary annotation sources and data types that
are included in the software.
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Filters for genes and variants

You can add system-installed filters to create filter chains that are based on information for genes and
variants. You can filter results based on the following types of information.
* specific genes * user-classifications that you create, such as

* specific variant types, such as SNV variant of uncertain significance

¢ effects of variants on the coding sequence,

* specific genomic regions
such as a frameshift deletion

* hotspot variants

. * variant subtypes, such as a big deletion
* homozygous or heterozygous variants

* known variants in the cystic fibrosis

* variants in specific locations, such as transmembrane regulator (CFTR) gene

upstream
* probability of variant calls (P-value)

Gene Symbol filter
This filter can be added to filter chains in the software to report on specific genes.

Filter conditions include the ability to select all (In), none (Not In), or specific gene symbols from the list,
and to include or exclude unannotated variants in filtered analysis results.

This filter returns the gene symbols of genes that are found in your samples.

Genomic Coordinates filter

This filter can be added to filter chains in the software to narrow analysis results to specific genomic
regions. The filter can also be used to identify regions that are targeted by an amplicon or amplicons in
a user-defined assay.

The filter value is one chromosome region, or multiple regions that are separated by OR operators or
commas.

The Genomic Coordinates filter returns variants in samples that are in the range for the genomic
coordinates that you set.

IMPORTANT! Do not use AND, OR, or NOT when adding values to the Genomic Coordinates filter.

Hotspot filter

The Hotspot filter can be added to filter chains in Genexus™ Software to show or exclude variants that
are hotspots.

Filter conditions include the ability to include (In) or exclude (Not In) hotspot position overlaps in results
when the filter chain is applied.

The filter returns variants that overlap hotspots that are defined in an uploaded hotspots file.
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Location filter

This filter can be added to filter chains in the software to detect variants in specific positions, such as
exonic.

Filter conditions include the ability to select all locations or specific locations in filtered analysis results.
Locations include:

® unknown * splicesite_3
® intergenic ® upstream

* intronic * downstream
® exonic ® exonic_nc

* utr 5 ® intronic_nc
e utr 3 * ncRNA

* splicesite_5 * nonCoding

The filter returns variants in samples that match the selected filter locations.

Named Variants filter

This filter can be added to filter chains in the software to detect known variants in the lon
AmpliSegq™ Community Panel for the cystic fibrosis transmembrane regulator (CFTR) gene, for example:
c.2054delA.

Filter conditions include the ability to select all named variants, to select specific named variants, and to
include or exclude unannotated variants in filtered analysis results.

The filter returns variants in samples that match the CFTR variants that are specified in the filter.

PValue filter

This filter can be added to filter chains in the software to narrow results based on the P-value of
variants. The P-value quantifies the statistical significance of variant calls.

Filter conditions include the ability to set a range from 0.0 to 1.0. The range boundaries are included.
The option to include or exclude unannotated variants in filtered results is also available.

The filter returns P-values for variants calls in the samples.

Variant Classification filter
This filter can be added to filter chains in the software to narrow results to the following user-set variant
classifications:

* Unclassified

* Unknown

* Benign

® Suspected Benign

* Likely Benign

® Suspected Deleterious

* Deleterious
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¢ Pathogenic

* Likely Pathogenic

e VUS

* Uncertain Significance
® Technical Artifact

Filter conditions include the ability to include all (Filter Option set to In), none (Filter Option set to Not
In), or to select specific classifications in filtered analysis results.

The filter returns variants that are classified by software users.

Variant Effect filter
This filter can be added to filter chains in the software to detect the effect of variants on coding
sequences. Specific values include:
¢ refAllele
* unknown
® synonymous
® missense
* nonframeshiftinsertion
* nonframeshiftDeletion
¢ nonframshiftBlockSubstitution
®* nonsense
* stoploss
* frameshiftinsertion
¢ frameshiftDeletion
¢ frameshiftBlockSubstitution

Filter conditions include the ability to select all (Filter Option set to In), none (Filter Option set to Not In),
or to select specific values, and to include or exclude unannotated variants in filtered analysis results.

The filter returns variants in samples that match the selected variant effects.

Variant Subtype filter

This filter can be added to filter chains in the software to detect variant subtypes, including:
¢ BigDel
¢ BigDup
* GeneCNV
* REF
e NOCALL

Filter conditions include the ability to select all or specific variant subtypes in filtered analysis results.

The filter returns variants that match the selected specific variant subtypes.
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Variant Type filter

This filter can be added to filter chains in the software to detect variants that match the following variant

types:
e SNV e ASSAYS_5P_3P
* [INDEL ¢ RNA_HOTSPOT
e MNV * GENE_EXPRESSION
* REF * RNAExonVariant
* NOCALL * ProcControl
e CNV e FLT3ITD
¢ LONGDEL
Note: The FLT3ITD variant type is detected
* FUSION only in Oncomine™ Myeloid Assay analysis
e EXPR_CONTROL workflows.

Filter conditions include the ability to select all variant types or specific variant types in filtered analysis
results.

The filter returns variants in analyses that match the selected specific variant types.

Zygosity filter

This filter can be added to filter chains in the software to detect variants that are homozygous or
heterozygous.

Filter conditions include the ability to search for both homozygous and heterozygous variants, or either
of them, in filtered analysis results.

The filter returns variants in analyses that are homozygous or heterozygous.

Filters for population frequencies

410

You can add system-installed filters to create filter chains for population frequencies. You can filter
results with information that is derived from the following databases.

* Exome Aggregation Consortium (ExAC) database
* 5000Exomes annotation database
¢ dbSNP database from the 1000 genomes project
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ExAC filters

These filters can be added to filter chains to detect rare gene variants for specific population groups.
The filters are derived from the Exome Aggregation Consortium (ExXAC) database. The specific filters

are.

* EXAC AAF(1) e ExAC GAF(1)
e EXAC EAAF(1) * ExAC LAF(1)
e EXAC EFAF(1) e EXAC OAF(1)
* EXAC ENFAF(1) e EXAC SAAF(1)

Filter conditions include the ability to set a range from 0.0 to 1.0. The range boundaries are included.
The option to include or exclude unannotated variants in filtered results is also available.

The filter detects rare gene variant results that align with the EXAC database, which can be included or
excluded from filtered results.

Minor Allele Frequency filter

This filter can be added to filter chains to detect variants with minor allele frequencies that match those
in the dbSNP database from the 1000 genomes project.

Filter conditions include the ability to set a range from 0.0 to 0.5 for minor allele frequencies. The range
boundaries are included. The option to include or exclude unannotated variants in filtered results is also
available.

The filter returns variants that match those in the dbSNP database from the 1000 genomes project.

5000Exomes filters

The 5000Exomes filters can be added to filter chains to detect minor allele frequencies (MAF) for
specific population groups. The filters are derived from the 5000Exomes annotation database. The
specific filters are:

¢ 5000Exomes AfricanAmerican MAF
* 5000Exomes AfricanAmerican MAF(20161108)
* 5000Exomes EuropeanAmerican MAF
* 5000Exomes EuropeanAmerican MAF(20161108)
* 5000Exomes Global MAF
* 5000Exomes Global MAF(20161108)
Filter conditions include the ability to set minor allele frequency ranges from 0.0 to 0.5. The range

boundaries are included. The option to include or exclude unannotated variants in filtered results is also
available.

The filter returns minor allele frequency results in samples that align with the 5000Exomes minor allele
frequency database.
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Filters for metrics

412

You can add system-installed filters to create filter chains that are based on data and metrics from
results. You can filter the results based on the following types of information.

* nonreference allele frequencies ¢ specific annotations, such as LOSS
* read counts ® coverage

¢ alternate allele counts e fusion read counts

* CNV confidence range * homopolymer length

* CNV confidence range for somatic samples

Allele Ratio filter
This filter can be added to filter chains to narrow results to nonreference allele frequencies.

Filter conditions include the ability to set allele ratio ranges from 0.0 to 1.0. The range boundaries are
included. The option to include or exclude unannotated variants in filtered results is also available.

The filter returns all variants that have at least one nonreference allele reported with a frequency in the
selected filter range.

Allele Read-Count filter
This filter can be added to filter chains to set the minimum count for genotype alleles.

Filter conditions include the ability to set allele read-count ranges from 0 to 100,000. The range
boundaries are included. The option to include or exclude unannotated variants in filtered results is
also available.

The filter removes variant candidates that do not have the required numbers of supporting reads.

Alternate Allele Count filter
This filter can be added to filter chains to set the minimum count for alternate alleles.

Filter conditions include the ability to set alternate allele read-count ranges from 0 to 100,000. The range
boundaries are included. The option to include or exclude unannotated variants in filtered results is also
available.

The filter removes variant candidates that do not have the required numbers of reads.

CNV Confidence Range filter

This filter can be added to filter chains to return copy number variants (CNV) with confidence levels
between 10 and 10,000,000 and other variants.

Filter conditions include the ability to set the CNV confidence range from 10 to 1.0E7. The range
boundaries are included. The option to include or exclude unannotated variants in filtered results is also
available.

The filter returns copy number variants with high confidence levels and other variants.
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CNV Somatic Confidence Range filter

This filter can be added to filter chains in the software to make ploidy estimates with lower and upper
confidence values on somatic samples. The filter detects extra copies over the expected normal ploidy
value (2 for autosomes, 2 for X chromosomes in females, and 1 for X chromosomes in males). The 5%
lower confidence bound value is the ploidy estimate where there is a 5% chance that the true ploidy is
below that value. The 95% upper confidence bound is the ploidy estimate where it is 95% certain that
the true ploidy is below that value. The lower bound is the most important for gains. The upper bound is
most important for losses.

By default, the filter is set to detect gains and losses using the confidence interval values of 5%
confidence interval for Minimum Ploidy Gain over the expected value and 95% confidence interval for
Minimum Ploidy Loss under the expected value. The default boundary values are set to 0.0.

This filter can be set to return the samples that do not meet both of the thresholds for Minimum Ploidy
Gain and Minimum Ploidy Loss. When there are multiple filters in a filter chain, the software setting of (A
or B), NOT (A or B) is calculated as (NOT A) and (NOT B). Because of this logic, the setting to return the
samples that do not meet both threshold settings is NOT with OR. For example, NOT Minimum Ploidy
Gain (5% CI) over expected OR Minimum Ploidy Loss (95% CI) under expected.

If you set the Minimum Ploidy Gain (5% CI) over expected to 2.0 (2+2=4) and the Minimum Ploidy
Loss (95% CI) under expected to 0.0, you can expect the following example CNV call Cl data:

Gene A—A gene with suspected gain of 5% Cl = 4.1 and 95% CI = 10.3 filtered in.

Gene B—A gene with suspected loss of 5% Cl = 0 and 95% CI = 1.0 filtered in.

Gene C—A gene with suspected gain of 5% Cl = 2.2 and 95% ClI = 3.6 filtered out (2.2 is less than 4).
Gene D—A gene with suspected gain of 5% Cl = 2.1 and 95% CI = 5.2 filtered out (2.1 is less than 4).
Gene E—A gene with 5% Cl = 0.8 and 95% CI = 2.1 filtered out (0.8 is less than 4 and 2.1 is greater

than 2).
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Expected Normal Ploidy Buffer filter

The Expected normal ploidy buffer filter can be added to filter chains in the software to detect mosaic
chromosomal aneuploidies in research samples and to set a buffer for normal ploidy values (2 for
autosomes, 2 for X chromosomes in females, and 1 for X and Y chromosomes in males) so as to
identify the most likely aneuploidy samples. Ploidy calls do not have to be integers because mosaicism
detection allows decimal-level Copy Number Gain or Loss calls.

By default, the filter is set to filter out all copy number variant segments of gain or loss within 0.2 ploidy
value of expected normal. Gains must be above ploidy 2.2 and below ploidy 1.8 to remain filtered in on
autosome and female X, and ploidy 1.2 and ploidy 0.8 on male Y. Filter conditions include the ability to
change the amount of buffer by adjusting the From and To values. This Expected Normal Ploidy Buffer

overrides any Confidence filtering that may be in effect within the buffer zone.

This filter can be set to return the samples that do not meet both of the thresholds for Expected Normal
Ploidy Buffer and Confidence. When there are multiple filters in a filter chain, the software setting of (A
or B), NOT (A or B) is calculated as (NOT A) and (NOT B). Because of this logic, the setting to return

the samples that do not meet both the Expected Normal Ploidy Buffer and the Confidence thresholds is
NOT with OR. For example, NOT Expected Normal Ploidy Buffer OR Confidence.

If default settings are applied, ploidy values of 1.8 to 2.2 are filtered out as normal for autosomes and X
chromosomes in females, and 0.8 to 1.2 are filtered out as normal for X and Y chromosomes in males.
Values outside this range are detected as chromosomal ploidy samples.

Filter filter
This filter can be added to filter chains in Genexus™ Software to show or exclude specific annotations.
* REF e FAIL
* PASS ¢ ABSENT_HOM_V
e NOCALL e ABSENT_HET_V
e LOSS e ABSENT_HET_RV
e GAIN ¢ . — indicates de novo variant

Filter conditions include the ability to include all (In), none (Not In), or specific annotations, and to
include or exclude unannotated variants in results when you apply the filter chain.

Filtered Coverage filter

This filter can be added to filter chains to review results that meet a specific coverage threshold. By
default, the filter reports all results with a coverage greater than or equal to 100. You can adjust the
minimum threshold. The minimum threshold value that is set is included.

The option to include or exclude unannotated variants in filtered results is also available.

Fusion Read Counts filter
This filter can be added to filter chains in the software to produce counts for fusion reads.

Filter conditions include the ability to set a minimum count of 0 or higher, to include the boundary value
for the count, and to include or exclude unannotated variants in filtered analysis results.

This filter returns results that meet the fusion read minimum count value.
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Homopolymer Length filter
This filter can be used in a filter chain to detect INDELs of specific homopolymer lengths.

Filter conditions include the ability to set a range from 0 to 1,000 for homopolymer length. The range
boundaries are included. The option to include or exclude unannotated variants in filtered results is also
available.

This filter returns INDEL variants that meet the specified homopolymer length.

Annotation source filters

You can create filter chains that identify variants based on the annotations associated with those
variants. The software uses annotation sources from public and proprietary genomic databases to
apply these annotations to variants during analysis.

Filters that are made from annotation sources are available in the software and you can use these filters
to build filter chains that narrow the list of variants that appear in the analysis results.

Clinvar filter

This filter can be added to filter chains to evaluate the impact of variants that match those in

the National Center for Biotechnology Information (NCBI) ClinVar database. In Genexus™ Software,
updated versions of the Clinvar database are available. For more information, see “Updated versions of
annotations” on page 254.

One or more of the impact values can be included in the filter chain. The complete list can be viewed
when the option of All is selected.

The option to include or exclude unannotated variants in filtered results is also available.

The filter returns all variants with the selected impact values that match those in the NCBI ClinVar
database.

COSMIC filter
This filter can be added to filter chains in the software to compare variants to the catalog of somatic
mutations in tumor tissue as compiled by the COSMIC database. The specific filters are:

¢ COSMIC(85)

¢ COSMIC(89)

e COSMIC(91)

e COSMIC(94)

Filter conditions include the ability to select all COSMIC values and to include or exclude unannotated
variants in filtered results.

In addition, one or more specific annotation values can be included in the filter chain. Examples include
ER-positive_carcinoma and basal_cell_carcinoma. A partial list can be viewed when the option of All is
selected.

The filter returns variants that match those in the COSMIC database.
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dbSNP filter
This filter can be added to filter chains in the software to compare single nucleotide polymorphism
variants in samples against the doSNP database. The specific filters are:

¢ dbSNP(151)

¢ dbSNP(153)

¢ dbSNP(154)

¢ dbSNP(155)
Filter conditions include the ability to select all dbSNP values (In), or to exclude all dbSNP values (Not
In).

The filter detects SNP variants that match those in the dbSNP database, which can be included in or
excluded from filtered results.

DGV filter
This filter can be added to filter chains in the software to detect human genomic structural variants that
match those in the Database of Genomic Variants (DGV). The specific filters are:

* DGV filter(20160515)

* DGV filter(20200225)

Filter conditions include the ability to include all DGV variants (In), or to exclude all DGV variants (NOT
In) in filtered results.

The filter detects human genomic structural variants as defined by DGV, which can be included in or
excluded from filtered results.

DrugBank filter
This filter can be added to filter chains in the software to detect variants that are correlated with drugs
and drug targets listed in the DrugBank database. The specific filters are:
* DrugBank (20180731)
* DrugBank (20190723)
¢ DrugBank (20200619)
¢ DrugBank (20210727)
Filter conditions include the ability to select specific values, to include all DrugBank values (In), or to

exclude all DrugBank values (NOT In). In addition, unannotated variants can be included or excluded in
filtered results.

This filter detects variants that are correlated with drugs and drug targets in DrugBank, which can be
included in or excluded from filtered results.
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OMIM filter
This filter can be added to filter chains in the software to detect variants that match those in the Online
Mendelian Inheritance in Man® (OMIM) database. The specific filters are:

e OMIM(20180823)

e OMIM(20191001)

e OMIM(20200508)

e OMIM(20210625)

Filter conditions include the ability to search for all (In) or none (NOT In) and to include or exclude
unannotated variants in filtered results.

In addition, one or more specific annotation values can be included in the filter chain. Examples include
5-hydroxytryptamine (serotonin) receptor-1A and A kinase (PRKA) anchor protein 17A. A partial list of
specific annotation values can be viewed when the option of All is selected.

The filter returns variants that match those in the OMIM database.

Oncomine™ filter

This filter is the default filter for most Oncomine™ assays. It presents Oncomine™ driver variants that are
based on their Oncomine™ Gene Class and Oncomine™ Variant Class annotations. It can be added to
filter chains in the software to detect Oncomine™-annotated variants in specific Oncomine™ panels.

Oncomine™ assays for lon AmpliSeq™ HD panels in Genexus™ Software include the Oncomine™ Variant
Annotator plugin. The plugin integrates into analysis results data from more than 24,000 exomes

across solid tumor and hematological cancer types, and annotates variants relevant to cancer with
Oncomine™ Gene class and Oncomine™ Variant class information. For more information and a full list of
annotation rules for each Oncomine™ assay, see “Annotation criteria for Oncomine™ Variant Annotator”
on page 385, or contact a Field Bioinformatics Specialist (FBS).

The Oncomine™ filter (Oncomine = In) returns variants that have Oncomine™ Gene class and
Oncomine™ Variant class annotation.

This filter can be used only if an Oncomine™ assay was used. You can apply filter chains that include
the Oncomine™ filter only if the assay that was used for the analysis includes the Oncomine™ Variant
Annotator plugin. Examples of filter chains that include this filter are the Oncomine™ Variants and
Oncomine™ Extended filter chains.

Pfam filter
This filter can be added to filter chains in the software to detect protein domain families in coded
proteins as defined by the Pfam database. The specific filters are:

e Pfam (31)

* Pfam (32)

* Pfam (33)

¢ Pfam (34)

Filter conditions include the ability to search for all (In) or none (NOT In) and to include or exclude
unannotated variants in filtered results.
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In addition, one or more specific annotation values can be included in the filter chain. Examples include
7 transmembrane receptor (Secretin family) and Activator of apoptosis harakiri. A partial list of specific
annotation values can be viewed when the option of All is selected.

The filter returns variants that match the variants in the Pfam database.

UCSC Common SNPs filter

This filter can be added to filter chains in the software to detect variants that match those in the UCSC
Genome Browser Common SNPs database.

Filter conditions include the ability to include (In) or exclude (Not In) variants that match the UCSC
Common SNPs in filtered results.

The filter returns variants in samples that match the UCSC Common SNPs database.

Filters for functional scores

418

You can add system-installed filters to create filter chains that include functional scores. You can
filter results based on Functional Analysis through Hidden Markov Models (FATHMM) scores or PyloP
scores.

FATHMM Scores filter

This filter can be added to filter chains to calculate Functional Analysis through Hidden Markov
Models (FATHMM) Scores for coding variants, nonsynonymous single-nucleotide variants (nsSNVs),
and noncoding variants. The specific filters are:

FATHMM Scores(85)
FATHMM Scores(89)
FATHMM Scores(91)
FATHMM Scores(94)

Filter conditions include the ability to set a range from 0.0 to 1.0 for the score. The range boundaries are
included. The option to include or exclude unannotated variants in filtered results is also available.

The filter calculates FATHMM scores for coding variants, nsSNVs, and noncoding variants.

PhyloP Scores filter

This filter can be added to filter chains in the software to measure the conservation of protein across a
wide range of organisms in 16S metagenomics analyses. The specific filters are:

PhyloP Scores(20160919)

Filter conditions include the ability to set a score range from —-20.0 to 30.0. The range boundaries are
included. The option to include or exclude unannotated variants in filtered results is also available.

This filter returns PyloP scores for 16S metagenomics samples.
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Other filters

In addition to the system-installed filters described in other sections, you can also filter results based on
the following types of information.

¢ allele frequencies ¢ functional scores based on SIFT, PolyPhen,

* CNV confidence range for CNVs only and Grantham scores

* CNV confidence range for CNV somatic * Phred QUAL scores
samples only * gene ontologies

e fusion variants, expression control markers, ® rare gene variants derived from the genome
and assay 5'/3' markers aggregation database (gnomAD) database

¢ fusion variants, expression control markers, ¢ alleles that have passed all variant calling
assay 5'/3' markers, and DNA variants filters used by the Torrent Variant Caller (TVC)

* Disease Research Area (DRA) annotation module but missed by genotype

source database

Allele Frequency filter

The Allele Frequency filter can be added to filter chains in the software to report the frequency of alleles
observed in raw data.

Filter conditions include the ability to set allele frequency ranges from 0.0 to 1.0. The option to include
or exclude unannotated variants in filtered results is also available.

The filter returns allele frequencies of alleles observed in raw data.

CNV Confidence Range—CNVs Only filter

This filter can be added to filter chains in the software to return copy number variants (CNV) with
confidence levels between 0 and 10,000,000.

Filter conditions include the ability to set the CNV confidence range from 10 to 1.0E7. The range
boundaries are included. The option to include or exclude unannotated variants in filtered results is also
available.

The filter returns only copy number variants with high confidence levels.

CNV Somatic Confidence—CNVs Only filter

This filter can be added to filter chains in the software to make ploidy estimates with lower and upper
confidence levels.

Filter conditions include the ability to enable and set the range for Minimum Ploidy Gain (5% CI) over
expected, to enable and set the Minimum Ploidy Loss (95% CI) under expected ploidy values. The
range boundaries are included. The option to include or exclude unannotated variants in filtered results
is also available.

The filter returns only somatic copy number variants within the lower and upper limits of the set
confidence ranges.

This filter can be set to return the samples that do not meet both of the thresholds for Minimum Ploidy
Gain and Minimum Ploidy Loss. When there are multiple filters in a filter chain, the software setting of (A
or B), NOT (A or B) is calculated as (NOT A) and (NOT B). Because of this logic, the setting to return the
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samples that do not meet both threshold settings is NOT with OR. For example, NOT Minimum Ploidy
Gain (5% CI) over expected OR Minimum Ploidy Loss (95% CIl) under expected.

Default DNA and Fusions View filter

This filter can be added to filter chains in the software to detect all of the fusion variants, expression
control markers, assay 5'/3' markers, and all DNA variants that the predefined Default DNA and Fusions
View filter chain detects.

Filter conditions include the ability to select specific annotations (Present or Absent), to include all
default DNA and Fusions view variants (In), or to exclude all Default DNA and Fusions view variants (Not
In) in filtered analysis results. In addition, unannotated variants can be included or excluded in filtered
analysis results.

The filter detects the fusion variants, expression control markers, assay 5'/3' markers, and all DNA
variants, which can be included or excluded in filtered analysis results.

Default Fusions View filter

This filter can be added to filter chains in the software to detect all of the fusion variants, expression
control markers, and assay 5'/3' markers that the predefined Default Fusions View filter chain detects.

Filter conditions include the ability to select specific annotations (Present or Absent), to include all
Default Fusions View variants (In), or to exclude all Default Fusions View variants (Not In) in filter analysis
results. In addition, unannotated variants can be included or excluded in filtered analysis results.

The filter detects fusion variants, expression control markers, and assays 5'/3' markers, which can be
included or excluded in filtered analysis results.

Disease Research Area (DRA) filter

This filter can be added to filter chains in the software to annotate disease research categories as
defined by the Disease Research Area (DRA) annotation source database. The specific filters are:
* Disease Research Area (DRA)(20170914)

Filter conditions include the ability to search for all (In) or none (NOT In) and to include or exclude
unannotated variants in filtered results.

In addition, one or more specific annotation values can be included in the filter chain. Examples include
acquired immunodeficiency syndrome and adenoma. A partial list of specific annotation values can be
viewed when the option of All is selected.

This filter annotates disease research areas that match the DRA database, and can be included or
excluded.
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Functional Scores filter

This filter can be added to filter chains to provide functional scores based on SIFT, PolyPhen, and
Grantham scores. SIFT and PolyPhen scores are predictions of the functional effect of a variant
on a protein. A Grantham score attempts to predict the distance between two amino acids, in an
evolutionary sense (lower is less distance, higher is greater distance).

Filter conditions include the ability to include or exclude SIFT, PolyPhen, and Gratham scores, and to
set ranges for those scores. The range boundaries are included. SIFT and PolyPhen ranges can be set
from 0.0 to 1.0, and Grantham can be set from 0.0 to 215.0.

The filter returns a functional score based on the three (or fewer) scores.

This filter can be set to return the variants that do not meet all three threshold scores set in the filter.
When there are multiple filters in a filter chain, the software setting of (A or B), NOT (A or B) is calculated
as (NOT A) and (NOT B). Because of this logic, the setting to return the samples that do not meet all
threshold settings is NOT with OR. For example, NOT SIFT, PolyPhen OR Grantham.

Gene Ontology (GO) filter

This filter can be added to filter chains in the software to detect various gene ontologies (functions of
specific genes). The specific filters are:

* go(20171101)

* go(20190930)

* go(20200511)

* go(20210830)

Filter conditions include the ability to search for all (In) or none (NOT In) and to include or exclude
unannotated variants in filtered results.

In addition, one or more specific annotation values can be included in the filter chain.

This filter returns gene ontologies of samples based on the selections made.
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gnomAD filters

These filters can be added to filter chains to detect rare gene variants for specific population groups in
the software. The filters are derived from the genome aggregation database (gnomAD) database. The
specific filters are:

* gnomAD AAF (African Population Allele * gnomAD GAF (Global Population Allele
Frequency) (2) Frequency) (2)

* gnomAD AJAF (Ashkenazi Jewish Population ® gnomAD LAF (Latino Population Allele
Allele Frequency) (2) Frequency) (2)

¢ gnomAD EAAF (East Asian Population Allele * gnomAD MAF (male Population Allele
Frequency (2) Frequency) (2)

* gnomAD EFAF (European Finnish Population ® gnomAD OAF (Other Population Allele
Allele Frequency) (2) Frequency) (2)

¢ gnomAD FEM (Female Population Allele * gnomAD SAAF (South Asian Population Allele
Frequency) (2) Frequency) (2)

* gnomAD FNFAF (European Non-Finnish
Population Allele Frequency) (2)

Filter conditions include the ability to set a range from 0.0 to 1.0. The range boundaries are included.
Unannotated variants can be included or excluded in filtered results.

The filter detects rare gene variant results that align with the gnomAD database.

Phred QUAL Score filter

This filter can be added to filter chains to filter by the Phred QUAL score. Phred QUAL scores are
defined as a property which is logarithmically related to the base-calling error probabilities.

The filter returns Phred Qual scores for variants calls. Scores are calculated in the following way.

* For variants, the score is computed by the posterior probability that the variant allele frequency is
greater than the minimum allele-frequency that is specified for the variant type.

* For reference calls, the score is computed by posterior probability that the variant allele frequency
is below this threshold.

Posterior probability is computed conditional on the reads observed and includes sampling variability.

Filter conditions include the ability to set a range from 0.0 to 1,000,000.0. The range boundaries are
included. In addition, unannotated variants can be included or excluded in filtered results.

Possible Polyploidy Alleles filter

The Possible Polyploidy Alleles filter can be added to filter chains to detect searches alleles which
have passed all variant calling filters used by the Torrent Variant Caller (TVC) module but missed by
genotype.

The Possible Polyploidy Alleles filter is useful for identification of variants beyond diploid genomes, that
is, cancer cells or polyploidy species.

Filter conditions include the ability to select YES to find alleles that have passed all filters, NO, to find
alleles that have not passed all filters in addition to genotype, or both YES and NO.
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System-installed plugins

Genexus™ Software includes system-installed plugins that expand the analysis capabilities of the
software. System-installed plugins are locked and cannot be changed.

System-installed plugin

Description

coverageAnalysis

This plugin provides statistics and graphs that describe the level of
sequence coverage that is produced for targeted genomic regions.

molecularCoverage Analysis

This plugin provides statics and graphs that describe the level of
sequence molecular coverage that is produced for targeted genomic
regions.

samplelD

This plugin produces a unique identification code (samplelD) for each
barcode in a sample.

lonReporterUploader

This plugin allows you to directly transfer sample results files that are
generated in Genexus™ Software to lon Reporter™ Software.

System-installed reference genome files

The Genexus™ Software includes system-installed reference genome files as presets to use in assays.
System-installed reference genome files are locked and cannot be changed.

System-installed reference genome file Description
hg19 Human reference genome.
GRCh38 Human reference genome.

Genexus™ Software 6.8 User Guide

423



Appendix B Reference information
System-installed report templates

System-installed report templates

Genexus™ Software includes system-installed report templates that can be used directly to generate
variant reports. System-installed report templates are locked and cannot be changed. However,
system-installed report templates can be used as a template when you create a custom variant report.

System-installed report template Description

Default

A system-installed report template for use with all
application categories.

After you create the first custom report template, you
can no longer use this template to generate a report or to
create another custom report template. Instead, use any
other available report template.

Default_Cancer_Germline A system-installed report template for use with samples

that are designated with the application category of
Cancer (Germline).

Default_Hematologic_Cancer A system-installed report template for use with samples

that are designated with the application category of
Hematologic Cancer.

Default_Solid_Tumor

A system-installed report template for use with samples
that are designated with the application category of Solid
Tumor.

System-installed sample attributes

The following table lists and describes system-installed sample attributes. System-installed sample
attributes cannot be edited.

Note: Custom sample attributes are not listed in this table.

Sample attribute

Description

Sample Namel']

A unique identifier representing the sample.

The sample name can contain only alphanumeric characters (0-9, Aa-Zz), periods (.),
underscores (_), or hyphens (-), cannot contain spaces, and is limited to a maximum of
20 characters.

IMPORTANT! To prevent erroneous sample selection during run planning, ensure that you
assign a unique and distinguishable sample name for each sample.

Note:
. Samples that have been used in a run cannot be deleted.

. To prevent duplication, the software checks all sample names and returns an error
message if a non-unique sample name is detected.

424

Genexus™ Software 6.8 User Guide



(continued)

Appendix B Reference information
System-installed sample attributes

Sample attribute

Description

Collection Datel'!

The date that the sample was collected.

Click = Calendar to select the date in the correct format.

Genderl'! The biological sex of the sample: Female, Male, or Unknown.
IMPORTANT! Male or Female must be selected for proper measurement of AR CNV.

Sample Typel'! A term that describes the sample, for example, RNA. You can also select Other, then enter a
custom sample type.

Application The sample application category, such as Cancer (Germline) or Solid Tumor.

(1]

Category Note: If you select an oncology application category in this list, the Cancer Stage, Cancer
Type, % Cellularity, and % Necrosis attributes listed below become available in the Add
New Sample dialog box.

Cancer Typel'l The type of cancer that is represented by the sample.

Select the type of solid or hematologic cancer. If cancer type is unknown, select Unknown

Primary Origin.

Cancer Stage!']

The stage of the cancer from which the sample was collected.

Select Stage 0-1V, or Primary, Unknown, or Other.

% Cellularity

The percentage of tumor cells over normal cells in the sample. This is a whole number
between 1 and 100. The % Cellularity attribute is applicable to FFPE samples only.

IMPORTANT!
. If not set, % Cellularity is assumed to be 100% in calculations that use this attribute.

. % Cellularity is a required attribute for CNV analyses. Do not leave the field blank.

. (FFPE samples only) If % Cellularity value is set to <100, then the magnitude of copy
number gain or loss can be decreased. For more information, see “CNVs table” on
page 117.

% Necrosis

The percentage of cellular necrosis in the sample. This is a whole number between
1 and 100.

Notes

An open-entry field for more sample information.

' Required attribute
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System-installed verification templates

Field Service Engineers use the system-installed verification templates during Genexus™ Integrated
Sequencer installation.

IMPORTANT! The Assays / Verification Templates screen lists the verification templates that are
used only by service engineers during Genexus™ Integrated Sequencer installation and performance
qualification testing. These templates should not be used or modified in any way.

Details about each verification template is available when you click the name of the template in the
software.

* Performance Qualification Assay
¢ System Install Qualification Assay
¢ Integrated Purification Performance Qualification Assay
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Download Instrument Diagnostics

You can download diagnostics files for troubleshooting purposes. Instrument diagnostics files include:
* Diagnostic archive file (ZIP format)
* Init.log file (TXT format)
* |Installation Acceptance Report (PDF format)

You must upload the instrument diagnostics files from the Genexus™ Integrated Sequencer before you
can download them in Genexus™ Software.

For more information, see the Genexus™ Integrated Sequencer User Guide (Pub. No. MAN0017910).

1. In the menu bar, click 3 (Settings) » Services.
2. Scroll to the bottom of the screen.

3. In the Download Instrument Diagnostics section, in the Select Instrument dropdown menu,
select the instrument.

4. Click Download.
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Customer Support Archive (CSA)

You can download an archive that a Technical Support representative can use to diagnose Genexus™
Software issues. The Customer Support Archive (CSA) contains log files and other technical data about
your Genexus™ Software and other files from sequencing runs on a Genexus™ Integrated Sequencer.

You can access customer support archive files from the Results / Sample Results and the
Results / Run Results screens.

Download a Customer Support Archive

When you download a Customer Support Archive (CSA) in Genexus™ Software, files are included for all
samples for a specific assay. If the run includes only one assay, files for all samples are included. If the
run includes more than one assay, you can specify the assay of interest when you download the CSA.

1. In the menu bar, click Results » Sample Results.

2. In Sample Results screen, place the pointer over the row of the sample result of interest, then
click CSA.

Alternatively, you can download CSA files three other ways.

¢ Click Results » Sample Results. Click the sample name of interest. Then, click
.-+ (More Options) » CSA.

¢ Click Results » Run Results. Click the run name of interest. Place the pointer over the run of
interest, then click CSA. In the Download CSA dialog box that appears, select the assay of
interest, then click Download.

* (Click Results » Run Results. Click the run name of interest. Then, click
.-+ (More Options) » CSA. In the Download CSA dialog box that appears, select the assay of
interest, then click Download.

An XZ compressed TAR archive (TXZ) file is downloaded to the folder that you specified to download
files from the browser. This location depends on the browser settings. You can attach the archive to an
email to send to Customer Support.

Troubleshoot Genexus™ Software

Observation Possible cause Recommended action
Cannot sign in to the You have either forgotten your | Contact the Genexus™ Software system
Genexus™ Software password or are signed out administrator.
due to several failed login
attempts.
Batch sample import fails One or more entries in Check each entry for correct formatting,

the sample-import spreadsheet | correct any errors, and repeat the import.
contains special characters,
lines breaks, unexpected
spaces, incorrect entry length,
incorrect date formatting, or
other formatting errors.
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Observation

Possible cause

Recommended action

Batch sample import fails
(continued)

Blank rows were copied into
the sample-import template file
from a different source.

Rows that appear empty can contain hidden
formatting that conflicts with the import
function. Start with a clean sample-import
template file, and be careful to copy only those
rows that contain actual data.

The sample import
spreadsheet contains a
nonunique sample name.

Every sample name in the software must be
unique. Ensure that the spreadsheet does not
contain any duplicate sample names, then
repeat the import. Note that the system check
is not case-sensitive, so a sample name of
ABC1 conflicts with abc1.

The headings in the sample
import spreadsheet do not
match the sample attributes in
the software.

The headings must match the sample
attributes in the software exactly. Check the
headings for spelling or other errors.

Map a sample attribute if needed.

Library batch import fails

One or more entries in

the library batch import
spreadsheet contains special
characters, lines breaks,
unexpected spaces, incorrect
entry length, incorrect date
formatting, or other formatting
errors.

Check each entry for correct formatting,
correct any errors, and repeat the import.

Blank rows were copied
into the library batch import
template file from a different
source.

Rows that appear empty can contain hidden
formatting that conflicts with the import
function. Start with a clean library batch
import template file, and be careful to copy
only those rows that contain actual data.

The library batch import
spreadsheet contains a
nonunique Library Batch ID.

Each Library Batch ID in the software must
be unique. Ensure that the spreadsheet does
not contain any duplicate IDs, then repeat
the import. The system check is not case-
sensitive. For example, a Library Batch ID of
ABC1 conflicts with abc1.

A sample name entered

in the library batch import
spreadsheet does not match
a sample name listed in the
Manage Samples screen.

Ensure that the sample names entered into the
spreadsheet are correct and match an existing
sample name added to the software.

The Barcode ID name format
does not exactly match the
format that is used in the
Prepare Library Batch dialog
box.

Use the name format following the

Barcode ID name format found

in the Barcode Set reference lists

(Settings » References » Barcode Set), for
example: lonDual_0101 through lonDual_0196,
or lonHDdual_0101 to lonHDdual_0132.
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Observation

Possible cause

Recommended action

Library batch import fails
(continued)

An invalid library, control, or
panel kit barcode has been
entered in the spreadsheet.

Ensure that you have correctly entered a valid
kit barcode in the appropriate cell of the
spreadsheet.

The spreadsheet template that
you used is from a previous
software version.

New fields in the template file can be added
with new software versions. Ensure that you
download the template file from the current

software version.

Cannot upload my panel or
hotspots

Issues with BED file format or
files do not end in .bed.

Ensure your file is in the correct BED format
and has a .bed extension.

Variants tab is missing hotspot
entries

Details: The remaining entries
are present.

Hotspot BED file contains
entries that are incorrectly
formatted.

Check that BED file entry is correctly
formatted. See the following examples:

SNP entry: chr1 2337276 2337277 SVA_322 0
+ REF=C;0BS=T;ANCHOR=G AMPL

Deletion entry: chr1 201341175 201341180
SVA_497 0 + REF=AGAAG;0OBS=;ANCHOR=C
AMPL

Insertion entry: chr1 236978992 236978992
SVA_621 0 + REF=;0BS=TCTG;ANCHOR=T
AMPL

Ensure that the REF values match the actual
reference coordinate of hg19.

No information for my loci of
interest in the results

The wrong hotspot or BED file
is associated with the assay.

1. Check the hotspot and BED files
associated with the assay. If either is
incorrect, create a new assay.

2. Plan a new run for the sample or sample
library with the correct assay.

3. Repeat sequencing of the sample or
sample library.

Cannot download run result
files

The run failed.

Create an assay with the correct configuration
for the samples, then reanalyze the samples.

430

Genexus™ Software 6.8 User Guide



Documentation and support

Related documentation ... ... .. e 431
Customer and technical SUPPOIt . ... ot e 431
Limited produCt warranty . . .......... i e 432

Related documentation

Document Publication number
Oncomine™ BRCA Assay GX User Guide MANO0018514
Genexus™ Integrated Sequencer User Guide MANO017910
Genexus™ Integrated Sequencer Quick Reference MANO0017912
Genexus™ Integrated Sequencer Site Preparation Guide MANO0017918
Genexus™ Purification System User Guide MANO0018475
Genexus™ Purification System Quick Reference Guide MANOO018476
Genexus™ Purification System Site Preparation Guide MANO0018477
lon Reporter™ Software 5.18 User Guide MANO0024776
Oncomine™ Precision Assay GX User Guide MANO0018508
Oncomine™ Comprehensive Assay v3 GX User Guide MANO0018512
Oncomine™ TCR Beta-LR Assay GX User Guide MANO0018513

Customer and technical support

Visit thermofisher.com/support for the latest service and support information.
* Worldwide contact telephone numbers

* Product support information
- Product FAQs

— Software, patches, and updates
— Training for many applications and instruments

® Order and web support
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* Product documentation
— User guides, manuals, and protocols

— Certificates of Analysis
— Safety Data Sheets (SDSs; also known as MSDSs)

Note: For SDSs for reagents and chemicals from other manufacturers, contact the
manufacturer.

Limited product warranty

Life Technologies Corporation and/or its affiliate(s) warrant their products as set forth in the

Life Technologies' General Terms and Conditions of Sale at www.thermofisher.com/us/en/home/
global/terms-and-conditions.html. If you have any questions, please contact Life Technologies at
www.thermofisher.com/support.
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Glossary

Genexus™ Software definitions

adapter dimer (ISPs)
ISPs that carry DNA insert length of less than 8 bp.

aligned read length

The aligned length of a read at a given accuracy threshold is defined as the greatest position in the read
at which the accuracy in the bases up to and including the position meets the accuracy threshold. For
example, the AQ17 length of a read is the greatest length at which the read error rate is 2% or less. The
"perfect” length is the longest perfectly aligned segment. For all of these calculations, the alignment is
constrained to start from position 1 in the read—that is, no 5’ clipping is allowed.

aligned reads

The number of bases covered by reads aligned to the reference sequence.

AQ score

An alignment quality (AQ) score defines read accuracy when compared to the reference sequence. The
discrepancy can be biological (real variant) or technical (sequencing error). For example, an AQ score of
17 represents 2% aligned read error rate, while an AQ score of 20 represents 1% aligned read error rate
when compared to the reference sequence.

archive

The process that occurs when runs on the lon Torrent™ Genexus™ Integrated Sequencer reach the
maximum time to be on the sequencer and the run is eligible for deletion from the sequencer.

average base coverage depth

The average number of reads of all targeted reference bases.

average base read depth

The average number of reads of all targeted reference bases that were read at least once.

backup

The process of data being copied to an external storage device or system from the lon Torrent™
Genexus™ Integrated Sequencer. Backups of data are done each night, based on backup settings, and
data that is backed up is not deleted from the sequencer. When data is backed up, the same data
remains on both the Genexus™ Integrated Sequencer and on the external storage system.
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BAM file

A BAM (binary alignment map) file (.bam) is the binary version of a SAM (sequence alignment map) file
(.sam). A SAM file is a tab-delimited text file that contains sequence alignment data. A BAM file contains
aligned reads sorted by reference location.

barcode

A barcode is a machine-readable code in the form of numbers and a pattern of parallel lines of varying
widths, printed on and identifying a product.

There are several applications for barcodes. Libraries can be molecularly barcoded with unique nucleic
acid sequence identifiers. Library barcodes are used during data analysis to sort the sequencing results
from sequencing reactions that contain combined libraries. Chips and sample tubes also contain unique
numeric barcodes that aid in the setup of the experimental analysis workflow.

base calling

Base calling is the process by which raw data from the sequencing instrument is converted to nucleo-
tide sequences. This is performed by base calling software that is usually run from the instrument itself.

basecalling input file

Signal processing input files are converted to a single condensed basecalling input file that represents
the processed signal. Basecalling input files are required files for basecalling.

bead loading

The percentage of chip wells that contain live ISPs. The percentage value considers only potentially
addressable wells. Bead loading is calculated as number of loaded ISPs divided by the number of
potentially addressable wells.

bp
Abbreviation for "base pair(s)".

cellularity (%)

The percentage of tumor cells in a given sample.

BED file

Browser Extensible Data file—BED file—defines chromosome positions or regions.

CNV

Copy number variation (CNV) is the variation in copy number of any given gene between two samples.
CNV is a phenomenon in which sections of the genome are repeated and the number of repeats in the
genome varies between individuals in the human population.

contig

A contig (from contiguous) is a set of overlapping DNA segments that together represent a consensus
region of DNA.
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control sequence

Control nucleic acid sequences can be added to DNA or RNA samples to facilitate post-sequencing
data analysis. Two types of control sequences can be used during sample preparation. ERCC RNA
Spike-In Mix is used with RNA samples to achieve a standard measure for data comparison across
gene expression experiments. lon AmpliSeq™ Sample ID Panel, comprised of nine specially designed
primers, can be added prior to template amplification to generate a unique ID for each sample during
post-sequencing analysis.

CSV file

A comma-separated values (CSV) file is a delimited text file in which each line represents a data record
with information fields separated by a comma. A CSV file stores tabular data (numbers and text) in plain
text. Each line of the file is a data record.

CSV files are easily opened using spreadsheet software, such as Microsoft™ Excel™ or Apache®
OpenOffice™ Calc, where each comma-separated field is listed in a separate column.

DAT file

A DAT file is a generic data file. It contains data that may be opened or referenced by a specific
application. While some DAT files can be opened directly, most contain program data that is referenced
the program when it is running. Therefore, most DAT files are not meant to be opened manually.

empty wells

Wells on a chip that do not contain an ISP.

enrichment (%)

Predicted number of live ISPs that have a key signal identical to the library key signal. The percent
enrichment value reported is the number of loaded ISPs that are library ISPs, after taking out the test
fragment ISPs.

FASTA file

A FASTA file is a text-based format for representing either nucleotide sequences or peptide sequences,
in which base pairs or amino acids are represented using single-letter codes. A sequence in FASTA
format begins with a single-line description, followed by lines of sequence data.

FASTQ file

A FASTQ file is a text-based format for storing both a biological sequence (usually nucleotide sequence)
and its corresponding quality scores. Both the sequence letter and quality score are each encoded with
a single ASCII character for brevity.

FD (flow disruptiveness)
A data filtering parameter that is used instead of INDEL, SNP, and MNP.
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final library reads

Number (and percentage) of reads, passing all filters that are recorded in the unmapped BAM file. This
value may be different from the total number of reads located in the Library Summary Section due to
specifications associated with read trimming beyond a minimal requirement resulting in total number of
reads being slightly less than Final Library Reads.

flow
A flow is the event of exposing a chip to one particular dNTP ( deoxyribonucleotide triphosphate),
followed by a washing step.

flow order

The order in which a chip is exposed to each particular dNTP. The default Samba flow order consists
of a 32-base sequence, repeated. This flow order resists phase errors by providing opportunities for
out-of-phase molecules to catch up and is designed to sample all dimer (nucleotide pair) sequences
efficiently. Samba is the default flow order because it improves sequencing accuracy for longer reads
by resisting phase errors.

flow transfer

Progress of the sequencing run expressed as humber of total flows completed. For example, a
sequencing run set to 500 flows shows 250/500 flows in the status column of the Runs in Progress
table when the sequencing run is half completed.

fusions

A target technique used for detection and annotation of gene fusions (or translocation of genetic
material) in samples.

homologous recombination repair

Homologous Recombination Repair (HRR) is a pathway to repair double-strand breaks which are
generated as by-products of cellular metabolism, DNA replication errors, or exogenous factors.

hotspots file

A BED or a VCF file that defines regions in the gene that typically contain variants. Specifying a
hotspots file to use in a run enables the Torrent Variant Caller (TVC) module module to identify if a
specific variant is present or absent. A hotspots file instructs the Torrent Variant Caller (TVC) module
module to include these positions in its output files, including evidence for a variant and the filtering
thresholds that disqualified a variant candidate. A hotspots file does not affect other parts of the
analysis pipeline.

If you don't specify a hotspots file, the software tells only the difference between your sequence and the
reference genome.

Isothermal application (IA) is a template preparation technique that uses nonemulsion isothermal
reaction to clonally amplify DNA onto an ISP surface.
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INDEL

INDEL is an abbreviation used to designate an insertion or deletion of bases in the genome of an
organism.

intermediate files

Intermediate files contain information used for debugging runs.

ISPs

lon Sphere™ Particles (ISPs) are particles that contain bound copies of a single (ideally) DNA fragment
amplified during template preparation.

key signal

Average 1-mer signal in the library key.

library ISPs

Live ISPs that have a key signal identical to the library key signal.

LIMS metadata

Laboratory Information Management System (LIMS) software is used for recording sequencing
metadata. Entered text is associated with the Planned Run and can be extracted using APIs for LIMS
consumption.

live ISP

An ISP with a signal of sufficient strength and composition to be associated with the library or test
fragment key.

low quality ISP

An ISP with a low or unrecognizable signal.

library key

A short known sequence of bases used to distinguish a library fragment from a test fragment (for
example, "TCAG").

MAPD

Acronym for median absolute pairwise difference. Assuming that adjacent amplicons in the genome
most likely have the same underlying copy number in a sample, the difference between the log2(read
count ratio) values against the reference baseline for all adjacent amplicons contains information for the
noise level of the data. The median of the absolute values of all such difference in log2(read count ratio)
is the measure for how informative the results fare for copy number estimates.

mapped reads

Sequencing reads that have been mapped to the reference sequence.
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mean raw accuracy

Average raw accuracy of 1-mers at a specific position in the read.

microsatellite instability

Microsatellite instability (MSI) is a form of genomic instability in the replication of repetitive DNA that
leads to the appearance of multiple alleles at microsatellite loci. MSI markers can be detected with
some DNA and DNA and Fusions assays.

missense SNV

A point mutation that changes the amino acid of the respective protein. SNV is an acronym for single
nucleotide variation, which means at one base there is a difference.

MNP

Multiple nucleotide polymorphism (MNP) is a genetic mutation in an allele that differs from the reference
allele of the same length by >1 nucleotide.

nonsense SNV

A point mutation that changes one of the 20 amino acids into a stop codon, hence a shorter or
unfinished protein product. SNV is an acronym for single nucleotide variation, which means at one base
there is a difference.

on target reads

Sequencing reads mapped to any target region of the reference. A read is considered to be on target if
at least one aligned base overlaps a target region. A read that overlaps a targeted region but where only
flanking sequence is aligned, for example, due to poor matching of 5’ bases of the read, is not counted.

primer dimer

A primer dimer (PD) is a potential by-product in PCR, a common biotechnological method. As its name
implies, a PD consists of primer molecules that have attached (hybridized) to each other because of
strings of complementary bases in the primers

primer dimer ISP

An ISP that carries an insert length of less than 8 base pairs.

Q score

Phred quality score (Q score) is used to measure the accuracy of the nucleotide sequence generated by
the sequencing instrument. The Q score represents the probability that a given base is called incorrectly
by the sequencer.

read length

The length of called reads measured in base pairs.

read

The sequence of a section of a unique fragment obtained after the end of the sequencing process.
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reference library

A consensus nucleotide sequence that represents the genome of a particular species. The results from
a sequencing run are compared to the reference library to identify sequence variants.

SAM file

A SAM (Sequence Alignment Map) file is a tab-delimited text file that contains sequence alignment
data. It stores biological sequences aligned to a reference sequence.

sample

Genetic material from one source (for example, DNA from one individual).

signal processing input files

Signal processing input files consist of the raw voltage measurement data collected during the
sequencing run. These files are required to reanalyze the run from signal processing.

SNP

Single nucleotide polymorphism (SNP) is a genetic mutation in an allele that differs from the reference
allele of the same length by one nucleotide.

SSH

SSH, also known as Secure Shell or Secure Socket Shell, is a network protocol that gives users,
particularly system administrators, a secure way to access a computer over an unsecured network.
SSH also refers to the suite of utilities that implement the SSH protocol.

structural variants

Genetic mutations that cause a change in the organism's chromosome structure, such as insertions,
deletions, copy number variations, duplications, inversions, and translocations.

target base coverage

Summary statistics for targeted base reads of the reference. A base covered by multiple target regions
is counted only once per sequencing read.

target regions file

A BED file that specifies all of the regions that a panel represents such as the amplified regions that are
used with target sequencing. The complete software analysis pipeline, including plugins, is restricted to
include only these specified regions instead of the entire reference library.

test fragment

A test fragment (TF) is a known nucleotide sequence that is used to monitor system characteristics.

test fragment ISPs

Live ISPs with a key signal that is identical to the test fragment key signal.
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test fragment key

A test fragment key (TF key) is the nucleotide sequence that is used to identify test fragment reads.

TF key peak counts
Signal strength of the first three bases of the TF key.

total reads

Total number of filtered and trimmed reads independent of length reported in the output BAM file.

TSV file

A tab-separated values (TSV) file is a tab-delimited file that is used with spreadsheet software. TSV files
are essentially text files, and the raw data can be viewed by text editors, though they are often used
when moving raw data between spreadsheets. See also VCF file

uBAM file

An unmapped BAM (uBAM) file is a variant form of the BAM file format in which the read data does
not contain mapping information. This is basically an "off-label" use of the BAM format (which was
specifically designed to contain mapping information) that is used for data management reasons. It
allows you to attach metadata to the reads from as early on in the analysis process as possible.

unaligned reads

Nucleotide bases covered by reads that are not aligned to the reference.

uniformity of base coverage

The percentage of bases in all targeted regions (or whole genome) covered by at least 0.2X the average
base coverage depth.

usable sequence / usable reads

Usable reads consist of library ISPs that pass the polyclonal, low quality, and primer dimer filter.

VCEF file

A variant call format (VCF) file specifies a variant of interest and its location. This file stores the
differences between the BAM file and the reference file.

wells with ISPs

Number of wells that were determined to be positive for the presence of an ISP within the well. Wells
containing ISPs have a delayed pH change due to the presence of an ISP slowing the detection of the
pH change from the solution.

XLS file

Files that use the .xIs extension. XLS files can be created by Microsoft™ Excel™ and other similar
spreadsheet programs.
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