
For Research Use Only.

Not for use in diagnostic procedures.

Affymetrix Confidential

700339 Rev. 3

Affymetrix
Laboratory 
Information
Management
System (LIMS)

LIMS Manager 
User’s Guide

Version 3.0

®

Manager.book  Page i  Wednesday, February 27, 2002  4:56 PM



Trademarks

Affymetrix®, GeneChip®, EASI™, ™, , ™, HuSNP™, 
GenFlex™, Jaguar™, MicroDB™, 417™, 418™, 427™, 428™, 
Pin-and-Ring™, Flying Objective™, NetAffx™ and CustomExpress™ are 
trademarks owned or used by Affymetrix, Inc.

Microsoft® is a registered trademark of Microsoft Corporation.

Oracle® is a registered trademark of Oracle Corporation. 

GeneArray® is a registered U.S. trademark of Agilent Technologies, Inc.

Limited License

PROBE ARRAYS, INSTRUMENTS, SOFTWARE AND REAGENTS ARE 
LICENSED FOR RESEARCH USE ONLY AND NOT FOR USE IN 
DIAGNOSTIC PROCEDURES. NO RIGHT TO MAKE, HAVE MADE, OFFER 
TO SELL, SELL, OR IMPORT OLIGONUCLEOTIDE PROBE ARRAYS OR 
ANY OTHER PRODUCT IN WHICH AFFYMETRIX HAS PATENT RIGHTS 
IS CONVEYED BY THE SALE OF PROBE ARRAYS, INSTRUMENTS, 
SOFTWARE OR REAGENTS HEREUNDER. THIS LIMITED LICENSE 
PERMITS ONLY THE USE OF THE PARTICULAR PRODUCT(S) THAT THE 
USER HAS PURCHASED FROM AFFYMETRIX.

Patents

Software products may be covered by one or more of the following patents: 
U.S. Patent Nos. 5,733,729; 5,795,716; 5,974,164; 6,066,454; 6,090,555; 
6,185,561 and 6,188,783; and other U.S. or foreign patents.

Copyright

©1999 - 2001 Affymetrix, Inc. All rights reserved.

Manager.book  Page ii  Wednesday, February 27, 2002  4:56 PM



Manager.book  Page i  Wednesday, February 27, 2002  4:56 PM
Contents

CHAPTER 1    Getting Started 3

System Requirements 3

Installing LIMS Manager 4

LIMS Manager Overview 11

Features in Version 3.0  11

Workflow-Based Tracking 12

Data Security  12

LIMS and Affymetrix® Software Applications 13

Summary 15

User Interface Orientation 16

Icons Used in LIMS  17

Tool/Toolbar Items 18

Glossary 18

File and Object Types Across All Tabs  18

Tab-Specific Terminology  19

Documentation 22

Conventions Used  22

Your Feedback is Welcome 24

Technical Support 24
i



CONTENTSii

Manager.book  Page ii  Wednesday, February 27, 2002  4:56 PM
CHAPTER 2    Process Tab 27

Process Tab Window 27

Process Tab Functions 29

Data Archive  30

Data Unarchive  31

Assume Ownership 32

Delete Process Data  32

Delete Probe Array Type 34

Export 35

Views in Process Tab Window  36

Print an Experiment 38

Register a LIMS Server 39

Unregister a LIMS Server  40

Server Events  40

Server Tasks  40

Task List Commands 42

Find Function  45

Sample Filter  47

CHAPTER 3    Publish Tab 53

Publish Tab Window 53

Publish Databases 55

Deleting 56

Probe Array Type  56

Publish Data  57

Creating Publish Databases 60

Database Size Considerations  60

Microsoft® SQL Server Publish Database  61

Oracle® Publish Database 63



Affymetrix®  LIMS Manager   User’s Guide iii

Manager.book  Page iii  Wednesday, February 27, 2002  4:56 PM
CHAPTER 4    Import Tab 67

Import Tab Window 67

Entering and Updating Data 69

Importing Data 70

Selecting an Import File Path  70

Identifying a Sample  71

Associating Files 73

Start Import  75

Edit Sample  75

Remove and Remove All 76

Sample Filter  76

CHAPTER 5    Userset Tab 81

Userset Tab Window 81

Userset Definition 83

Creating a Userset 84

Modifying a Userset 85

Define Parameter Values  85

Delete a Probe Array Type from a Userset 88

Delete a Userset  89

CHAPTER 6    Template Tab 93

Template Tab Window 93

Templates 95

Defining or Editing Attributes and Values 97

Deactivating and Activating 101

Renaming  103



CONTENTSiv

Manager.book  Page iv  Wednesday, February 27, 2002  4:56 PM
Working with Attributes 103

Multi selecting 104

Inserting  104

Deactivating  104

Activating  105

Copying  105

Cutting  106

Pasting  106

CHAPTER 7    Roles Tab 109

Roles Tab Window 109

Creating a Role 111

Defining Membership 115

Deleting Roles 116

APPENDIX A    Print Samples 119

Diagram Only 119

Diagram & Properties 120

APPENDIX B    FAQs 123

LIMS FAQs 123

Index 127



Manager.book  Page 1  Wednesday, February 27, 2002  4:56 PM
1



Manager.book  Page 2  Wednesday, February 27, 2002  4:56 PM
Chapter 1



Manager.book  Page 3  Wednesday, February 27, 2002  4:56 PM
Getting Started 1

Welcome to Affymetrix® Laboratory Information Management System 
(LIMS). LIMS Manager v 3.0 is a stand-alone database application 
designed to assist the system administrator in managing the data 
created by Affymetrix® Microarray Suite (formerly GeneChip® 
Analysis Suite). LIMS Manager imports and archives probe array 
data, provides security and allows the system administrator to assign 
users and set user privileges.

This chapter provides you with the information you need to get started 
with Affymetrix® LIMS Manager, including system requirements and 
installation procedures. Additionally, an overview of LIMS Manager 
and other Affymetrix® software applications is presented.

System Requirements

To use Affymetrix® LIMS Manager your system must meet the following 
hardware and software minimum requirements:

■ 500 MHz Processor

■ 128 MB RAM

■ Microsoft Windows NT® or Windows 2000 Workstation 

■ Available space on hard drive = 1 GB

■ Microsoft® Internet Explorer 5.5 with SP2

■ Microsoft® Data Access Components (MDAC) 2.5 SP1
3
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Installing LIMS Manager

During the installation of Affymetrix® LIMS Manager 3.0 previous 
version(s) are not removed. If installed in the same directory, the installation 
program overwrites the previous version’s files. 

After completing the installation of LIMS Manager 3.0, the program asks 
you to reboot the system. Restart the computer. Upon logging in, the system 
registers information into the registry and displays a message on screen 
informing you that the installation has finished.

1. Insert the Affymetrix® LIMS 3.0 Client CD-ROM.

If the autorun feature does not start the program:

a. Click Start → Run.

b. Type <cd drive letter>:\setup.exe.

c. Click OK.

⇒ A splash screen is displayed, followed by the Welcome window 
(Figure 1.1).

You must be logged in as administrator to install the LIMS Manager 3.0 
software.

LIMS Manager 3.0 is not required to run MAS 5.0 in LIMS mode.

The screen captures depicted in this manual may not exactly match the 
windows displayed on your screen.

If at any time during the installation a dialog box with a red ‘X’ appears, 
this indicates that you logged on with a username that does not have 
the local administrative privileges required to install the software. Log 
out and log back in under a user name with proper privileges.
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2. Click Next.

⇒ Several consecutive Software License Agreement windows appear.

Figure 1.1    

Welcome window

Figure 1.2    

Software License Agreement window
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3. Review the contents and click Yes in each window to accept the terms 
of the licensing agreement.

⇒ A Question window appears regarding the path location in 
reference to an upgrade (Figure 1.3).

4. If this is an upgrade you are asked if you want the latest version of 
LIMS Manager in the same location as the previous version. 

■ Click Yes to install in defined location.

⇒ The files from the previous version are overwritten.

■ Click No to install in new location. In the dialog box that appears, 
define the new path location desired.

⇒ The Choose Destination Location window appears (Figure 1.4).

Figure 1.3    

Question window

For upgrades, we recommended that you install LIMS Manager v 3.0 in 
the same location as the previous version and overwrite the existing 
files.
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5. Select the destination to install LIMS Manager 3.0. Click Next.

C:\GeneChip is the default location.

⇒ Files are copied.

6. Click Next.

⇒ The Select Components window appears (Figure 1.5).

Figure 1.4    

Choose Destination Location window

Figure 1.5    

Select Components window - configuration disk
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7. Select Yes if you have the LIMS configuration disk, No if you do not.

8. If Yes, go to step 9. If No, go to step 11.

9. Browse to the location of LIMS configuration disk. 

The file needed is called GeneChipDB.ini and resides on the LIMS 
server. The file is located at <server>\gclims\library. Browse to the file 
location.

10. Click OK. Go to step 14.

11. Enter the name of the LIMS server and click Next (Figure 1.7).

Figure 1.6    

Browse to File Location

Figure 1.7    

Enter Information window - enter LIMS server name
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12. Enter the name of the domain the server resides on with the global 
group name that contains the LIMS users. (Domain Name\Global 
Group) (Figure 1.8).

13. Click Next.

⇒ The Setup Not Complete window appears.

14. Select Yes, I want to restart my computer now to complete the 
installation.

Figure 1.8    

Enter Information window - enter global group name
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15. Log in as an administrator to complete the installation.

16. Click Finish in the Setup dialog box.

Figure 1.9    

Reboot to continue installation
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LIMS Manager Overview

Affymetrix® LIMS Manager v 3.0 is the software tool that provides you with 
a convenient way to manage your GeneChip® expression data. Improved 
performance in process database, improved access security throughout and 
improved query performance are just some of the features new in version 3.0 
designed to enhance the management capabilities of LIMS Manager.

Features in Version 3.0

■ Improved query performance for better database access

■ Improved database management and data security features

■ Improved access security throughout, including administrator defined 
user access level for added data security

■ Easily track experiment status

■ Ability to import historical data from a local hard drive or an external 
storage device (ZIP, JAZ, CD-ROM) and store on LIMS server

■ Supports experiment and sample attribution

■ Support for new data analysis algorithms

■ Expanded Oracle® database support to include Oracle 8.1.7 - both publish 
and process database

■ Expanded Microsoft® SQL database support to include SQL 2000 - both 
publish and process database

■ Support for Microsoft Windows NT® and Microsoft® Windows 2000
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Workflow-Based Tracking

Affymetrix® LIMS Manager software tracks experiments and processes. Its 
database provides storage and management for expression data.

You can access experimental data from any workstation on the network 
through the Affymetrix® LIMS server. Each user with access to the LIMS 
system can set up samples, experiments and publish data.

The LIMS Manager software processes experimental data through a 
workflow-based tracking system. The software tracks the stages of sample 
registration, experiment setup, hybridization, scan, grid alignment, analysis 
processes and publishing. This tracking allows you to follow the status of an 
experiment from sample preparation through analysis.

Data Security

The Affymetrix® LIMS software incorporates data security from the 
Windows 2000 computer. The logon name verifies that the user has access to 
the Affymetrix® LIMS database.

Users can access the Affymetrix® LIMS database only if they have been 
granted authorization. Access is provided to the LIMS server by requesting 
privileges from the system administrator who is responsible for assigning 
users’ rights and permissions.

LIMS protects users’ data from unauthorized changes. A user who creates, 
generates and analyzes an experiment is the original owner of the data. With 
security settings defined in the Roles tab, a user who is not the owner of the 
data will only have read access but is allowed to create new analyses without 
overwriting the original data. Security settings can also specify that only the 
owner of the data can overwrite the original data files.
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LIMS and Affymetrix® Software Applications

Affymetrix® LIMS Manager is the second of three software tools from 
Affymetrix for gene expression analysis (Figure 1.10).

Use Affymetrix® Microarray Suite to create, analyze and publish expression 
analysis data files. Next, import these files to a server database using LIMS 
Manager. Finally, access the publish database using Affymetrix® Data 
Mining Tool (DMT) to further analyze the data by filtering, pivoting and 
graphing. All three products are separate Windows applications available 
from Affymetrix.

Figure 1.10    

Affymetrix® software applications for expression analysis

Affymetrix® Microarray SuiteAffymetrix® LIMS Manager

Affymetrix® Data Mining Tool
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Figure 1.11     

GeneChip® Probe Array data flow



Affymetrix®  LIMS Manager   User’s Guide 15

Manager.book  Page 15  Wednesday, February 27, 2002  4:56 PM
Summary

The Affymetrix® LIMS and Data Mining Tool applications ensure that 
multiple users have simultaneous access to the database from any 
workstation. When used together, Affymetrix® Microarray Suite, 
Affymetrix® LIMS and Affymetrix® Data Mining Tool software applications 
generate experimental and research data for scientific analysis. Using these 
powerful tools in conjunction, users are able to review and analyze data in a 
robust and dynamic manner.
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User Interface Orientation

Figure 1.12     

LIMS Manager interface

Menu BarActive Server
Toolbar

Process Database
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Icons Used in LIMS

Table 1.1

LIMS Manager Icons

Sample Template Properties Information

Project Global Gray bullet indicates processes 
that have been completed.

Experiment Information / 
.exp file Server Green bullet indicates processes 

waiting to commence.

Image of Scanned Probe 
Array / .dat file

Process Database 
(yellow)

Red check mark on .exp, .dat, 
.cel or .chp icon(s) indicates that 
the file already exists in the 
Publish Database.

Averaged Intensities / 
.cel file

Publish Database 
(gray) Export Status

Analysis Output / .chp file Import to Database Import Status

Probe Array type Domain Delete Status

Chip User Group Archive Status

Vessel User Create Publish Database Status

Userset Role Filter
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Tool/Toolbar Items

Most toolbar or Tool menu items are available across all tabs. Detailed 
descriptions of these commands are presented in subsequent sections of this 
manual.

Glossary

The following terms are used frequently throughout this manual. For your 
convenience the terms are listed under the tabs where they are most 
frequently found.

Figure 1.13    

LIMS Toolbar

File and Object Types Across All Tabs

Automate Automate is a monitored task whose status, either on or off, is viewed in the 
Local Task pane. Automate On indicates LIMS is automatically tracking 
an experiment through data analysis after a scan of the probe array has 
successfully completed.

.cel The .cel averaged intensity file. Also known as “cell” file, this file is 
automatically created after grid alignment. The cell averaging analysis 
calculates the average intensities of each cell and assigns it an x and y 
coordinate, and can be used to re-analyze data with different algorithm 
patterns. The .cel file is one of two file types you can migrate to a publish 
database using Affymetrix® Microarray Suite.

.chp Also known as a “chip” file, this analysis file is the output generated by the 
analysis of a .dat and .cel file. The .chp is the second of two file types you 
can migrate to a publish database using Affymetrix® Microarray Suite.

Print

FindServer TasksRegister LIMS Server Help

File PathServer EventsActive Server list box Filter 
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Tab-Specific Terminology

.dat The .dat file is the image of the scanned probe array and is created by the 
analysis.

.exp The .exp file is created by the user and contains information defined by the 
experiment template used. The experiment name becomes the file name for 
subsequent files generated in the analysis. The Import function presents the 
concept of moving files and on this tab there is an experiment (.exp) file. The 
process database contains files and data, but does not contain experiment 
files; only experiment and sample data.

Sample A set of experiments.

Active Server Several LIMS servers may be registered. The active server refers to the 
LIMS server where the displayed process database resides.

Archive To move files from the process database and send to an external location.

Export To copy data from the process database and send to an external location.

Process Database Database residing on server containing experiment and sample data. Only 
one process database exists per server.

Project A set of experiments with a common bond and grouped together by their 
affiliation to a project. Creation of the project is accomplished during the 
sample registration process in Affymetrix® Microarray Suite.

Unarchive Restoring files to the process database.
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Affymetrix® 
Analysis Data 
Model

The Affymetrix® Analysis Data Model is the relational database schema 
Affymetrix uses to store experiment data so that results may be filtered 
and mined by analysis tools. Previously referred to as the GATC data 
model, the Affymetrix® Analysis Data Model includes additional tables to 
support mapping, spotted arrays and new expression results 1.

The Affymetrix® Analysis Data Model is publicly available to support 
open access to experiment information generated and managed by 
Affymetrix® software.

Intensities See .cel file on page 18.

Publish Database An Affymetrix® Analysis Data Model database residing on a server 
containing select process data that have been published. You may have 
several publish databases on a single server.

Publish Publishing is the act of migrating sample data to a Microsoft® SQL or 
Oracle® publish database and is a function of Microarray Suite v 4.0 or 
above.

Create Sample Creating a sample captures sample information and is used to identify the 
relationship of the .exp and analysis files being imported.

Import Importing copies data files created in Affymetrix® Microarray Suite and 
stored on a local hard drive and moves them into the process database.

1 Affymetrix® LIMS Manager 3.0 does not support mapping or spotted array data.
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Userset A userset is a predefined prarameter set used when running an expression 
analysis.

Independent 
Parameter

Defined in the userset, independent parameters are static settings not 
influenced by probe array selection.

Dependent 
Parameter

Defined in the userset, dependent parameters are settings that are specific 
to the particular probe array type selected.

Activate Activate is a command that restores an inactive (deactivated) template or 
attribute.

Template A template is a form created by the administrator in LIMS to define the 
attributes and values for both the experiment and sample registration 
process. The registration process is a function of Affymetrix® Microarray 
Suite.

Deactivate On the Template tab, the Deactivate command does not permanently 
remove an existing template or attribute. The deactivate action only 
renders the item inactive. The item does not appear in Affymetrix® 

Microarray Suite until the Activate command is used.

Privilege Privileges are the functions or permissions used for defining roles.

Role Definitions The name used to identify the first branch listed under the server where 
role names are identified.

Role A Role is a defined set of access privileges.

User Definitions The name used to identify the branch under the process database where 
role membership is defined.
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Documentation

This manual provides a detailed outline for all tasks associated with 
Affymetrix® LIMS Manager.

Additionally, the LIMS Manager installation CD includes an electronic 
version of this user’s guide. The on-line documentation is presented in 
Adobe Acrobat® format (a .pdf file) and is readable with the Adobe Acrobat® 
Reader software, available free from Adobe at http://www.adobe.com. The 
electronic user’s guide is printable, searchable and fully indexed.

Conventions Used

Various conventions are used throughout the manual to help illustrate the 
procedures described. Explanations of these conventions are provided 
below.

Steps

Instructions for procedures are written in a step format. Immediately 
following the step number is the action to be performed. On the line below 
the step there may be the following symbol: ⇒ . This symbol defines the 
system response or consequence as a result of user action; what you see and 
what has happened that you may not see.

Following the response, additional information pertaining to the step may be 
found and is presented in paragraph format. 
For example:

9. Click Yes to continue.

⇒ The Delete task proceeds. 
In the lower right pane the status is displayed. 

To view more information pertaining to the delete task, right-click 
Delete and select View Task Log from the shortcut menu.
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Font Styles

Bold fonts indicate names of commands, buttons or options within a dialog 
box. When asked to enter specific information, such input appears in italics 
within the procedure being outlined.
For example:

1. To select another server, enter the server name in the Oracle Alias box.

2. Enter DMT_2_Tutorial in the Publish Database box, then click 
Register.

⇒ The tutorial database is available to DMT.

Screen Captures

The steps outlining procedures are frequently supplemented with screen 
captures to further illustrate the instructions given.

Additional Comments

Throughout the manual, text and procedures are occasionally accompanied 
by special notes. These additional comment types and their meanings are 
described below.

The screen captures depicted in this manual may not exactly match the 
windows displayed on your screen.

Information presented as tips provide helpful advice or shortcuts for 
completing a task.

The Note format presents information pertaining to the text or 
procedure being outlined.

Caution notes advise you that the consequence(s) of an action may be 
irreversible and/or result in lost data.

Warnings alert you to situations where physical harm to person or 
damage to hardware is possible.
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Your Feedback is Welcome

Affymetrix Technical Publications is dedicated to continually improving the 
quality of our documentation and helping you get the information that you 
need. We welcome any comments or suggestions you may have regarding 
this manual. Please contact us at: 
technical_publications@affymetrix.com

Technical Support

Affymetrix provides technical support to all licensed users via phone or 
e-mail. To contact Affymetrix Technical Support:

Affymetrix Inc.

3380 Central Expressway
Santa Clara, CA 95051
USA

Tel: 1-888-362-2447 (1-888-DNA-CHIP)
Fax: 1-408-731-5441
E-mail: support@affymetrix.com

Affymetrix UK Ltd.,

Voyager, Mercury Park,
Wycombe Lane, Wooburn Green,
High Wycombe HP10 0HH
United Kingdom

Tel: +44 (0) 1628 552550
Fax: +44 (0) 1628 552585
E-mail: supporteurope@affymetrix.com

www.affymetrix.com
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Process Tab 2

The initial view presented upon opening Affymetrix® LIMS Manager 
is the Process tab. The Process tab shows you the data in the system, 
where it is found and allows you to view environmental property 
information regarding the data. 

This chapter orients you to the layout of the Process tab window and 
describes in detail the functions and tasks accomplished here.

Process Tab Window

The Process tab window is divided into three panes (Figure 2.1). The first pane 
on the left side displays a tree that identifies the active server, process 
database and data types (Samples, Projects and Probe Arrays). The data 
type subfolders contain the Sample Name , Project Name , or Probe 
Array Name  files for expression data. The tree stops at this level.

The second pane in the upper right corner takes the Sample Name or the 
Project Name, selected in the first pane, copies it as the top node and lists 
the associated experiment(s) underneath. The first time you click an 
experiment in this pane, the information is read and a ‘+’ is displayed next to 
the experiment name. Click the ‘+’ to display processes completed with 
inputs and outputs, or associated .dat files. Alternatively, double-click an 
experiment in this pane and the information is read and processes or 
associated files are displayed. Experiment information in this pane is 
displayed in either a Process view or a File view.

The third pane in the lower right corner displays either a Property 
Information or Local Task status view, depending on the item selected. 
Property Information lists environment details pertaining to the selected 
item. This information is defined by the template used during the Sample 
Registration process completed in Affymetrix® Microarray Suite.
27
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The Local Task status view displays the status of processes that may be 
occurring in the database, such as Export, Import, Delete, Archive and 
Create. This view allows you to monitor these jobs while concurrently 
working on additional tasks within the LIMS system.

 

Figure 2.1    

Process tab: Process View (2) of selected sample (1) with environmental property information displayed(3)

1
2

3
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Process Tab Functions

The primary functions of the Process tab include archiving, unarchiving, 
deleting, exporting, assuming ownership and printing data. These commands 
are found on the menu bar under Process.

The primary data types in the Process tab are sample, project, experiment 
and file. Each data type has associated functions whose commands are found 
under Process on the menu bar, or accessed by right-clicking the data type 
and selecting from the shortcut menu that appears (Figure 2.2).

Figure 2.2    

Shortcut menus for data types

Sample File

ExperimentProject
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Data Archive

Archiving data moves specified files and stores them in an external location. 
Although archived files no longer exist in the process database, their 
representative icon remains in the tree and appears gray to alert you that this 
data is available through the Unarchive process.

It is not possible in the current version of LIMS to archive experiments. You 
may only archive specific data files (.dat, .cel and .chp).

Archiving Data Files

1. On the menu bar select Process → File View, if necessary.

2. In the upper right pane, click to select the file to be archived.

Selecting a parent file also includes all related children files in the 
archive process.

3. On the menu bar select Process → Archive.

Alternatively, right-click the file to archive and select Archive from the 
shortcut menu that appears.

⇒ The Select Archive File Path window appears (Figure 2.3).

4. Select a Drive from the drop-down list and browse to find desired 
directory.

Figure 2.3    

Select Archive File Path window
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5. Click OK.

⇒ The Archive Local Task status is displayed in the lower right pane.

Double-click Archive at any time to view additional information 
pertaining to the archive status, or right-click Archive and select View 
Task Log from the shortcut menu that appears.

Data Unarchive

The icon(s) for data that have been archived lose their color and appear gray. 
The Unarchive command recalls the archived data and restores it to the 
process database.

Unarchiving Data Files

1. Click to select the file to unarchive.

Selecting a parent file also includes all related children files in the 
unarchive process.

If the archived file cannot be located a File Location dialog appears. 
Use this dialog box to define the location of the desired files.

2. On the menu bar select Process → Unarchive, or right-click the file and 
select Unarchive from the shortcut menu.

Use the Find function to generate a list of files associated with a 
specific project. Then SHIFT-select and archive these files in one quick 
step. This only works with .dat, .cel and .chp files in the process 
database.

The Process window does not automatically refresh upon completion of 
the Archive or Unarchive task. Therefore, if you unarchive a data file 
the icon remains gray even though the task was completed 
successfully. To refresh the view select View → Refresh from the 
menu bar.
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Assume Ownership

Change the User attribute of data to enable the reassignment of data when 
necessary for security or management purposes. Ownership of samples, 
experiments or analyses may be assumed when the Take Ownership 
Process Data option is defined for the user in the Roles tab.

Assuming Ownership

1. Click to select the appropriate sample, experiment or analyses.

2. From the menu bar select Process → Assume Ownership.

⇒ Your user name appears as User in the properties window in the 
lower right pane.

OR

1. Right-click the appropriate sample, experiment or analyses.

2. Select Assume Ownership from the shortcut menu.

⇒ Your user name appears as User in the properties window in the 
lower right pane.

Delete Process Data

You may delete samples, experiments, .cel, .chp analyses and usersets. 
Deleting samples deletes all associated experiments and analyses. Deleting 
experiments deletes all associated analyses.

Deleting Process Data

1. Click to select the item to delete.

2. From the menu bar select Process → Delete.

⇒ A warning / confirmation window appears (Figure 2.4).

The Delete option permanently removes data from the database. 
There is no restore function to recover deleted data.
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3. Click Yes to continue.

⇒ The Delete Local Task status is displayed in the lower right pane.

Double-click Delete at any time to view additional information 
pertaining to the delete status, or right-click Delete and select View 
Task Log from the shortcut menu that appears.

OR

1. Right-click an item to delete.

2. Select Delete from the shortcut menu that appears.

⇒ A warning / confirmation window appears (Figure 2.4).

3. Click Yes to continue.

⇒ The Delete Local Task status is displayed in the lower right pane. 

Double-click Delete at any time to view additional information 
pertaining to the delete status, or right-click Delete and select View 
Task Log from the shortcut menu that appears.

Figure 2.4    

Delete warning / confirmation window

Deleting process data is different from deleting publish data (see 
Publish Data, on page 57). Deleting published data removes only the 
data that has been published into a publish database. However, the data 
source in the process database remains available.
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Delete Probe Array Type

Remove an unused or unwanted probe array type from the process database 
from the left hand pane in the Process tab window.

Deleting a Probe Array Type from the Process Database

1. Under the Probe Array Type folder in the left hand pane, click to 
expand the Expression folder.

2. Click to select the probe array type of interest.

3. On the menu bar select Process → Delete, or right-click the probe array 
type of interest and select Delete from the shortcut menu that appears.

⇒ A warning / confirmation window appears (Figure 2.5).

4. Click Yes to delete the probe array type from the process database.

⇒ The probe array type is removed and no longer appears listed in the 
left hand pane.

Figure 2.5    

Delete warning / confirmation window

When a probe array type is deleted the associated usersets are also 
removed. Data created with these usersets remains, but is not 
accessible.
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Export

The Export command allows you to copy all data including sample, 
experiment, .dat, .cel and .chp files and send them to an external location for 
storage. 

Exporting Data

1. In the left pane, click to select the sample of interest.

2. On the menu bar select Process → File View, if necessary. 

You may use Process View if exporting the entire sample or experiment 
and related files.

3. In the upper right pane, click to select the data to export.

Selecting an object takes that object and all associated data with it. For 
example, selecting a sample takes the sample, experiment and any 
related .dat, .cel and .chp files.

4. On the menu bar, select Tools → File Path, or click the  button on 
the toolbar.

⇒ The Select Export File Path window appears (Figure 2.6).

The sample and experiment data are exported to an Affymetrix® 
Microarray Suite v4.x .exp file.

Figure 2.6    

Select Export File Path window
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5. Select a Drive from the drop-down list and browse to find desired 
export destination directory, then click OK.

6. On the menu bar select Process → Export, or right-click the file and 
select Export from the shortcut menu that appears.

7. Click OK.

⇒ The Export Local Task status is displayed in the lower right pane.

Double-click Export at any time to view additional information 
pertaining to the Export status, or right-click Export and select View 
Task Log from the shortcut menu that appears.

Views in Process Tab Window

The upper right pane of the Process tab window displays either a File View 
or a Process View of the selected sample or data file. The Process View 
identifies the stages completed by the experiment displayed as gray bullets, 
and stages that are pending are displayed as green bullets. The File View 
displays the experiment and all related files. For samples of both views, see 
Figure 2.7.

Changing Views

1. Click to select a sample in the left pane.

2. From the menu bar select Process → Process View (or File View, as 
appropriate).

OR

1. Right-click a sample in the pane on the left side of the window.

2. From the shortcut menu that appears, select Process View or File View 
as appropriate.
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Figure 2.7    

Process tab: Process View (left) and File View (right)
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Print an Experiment

The Print Experiment command allows you to obtain a printout of 
experimental information. Two print options are available (described 
below), and samples of each are provided in Appendix A on page 119.

Printing an Experiment

1. From the upper right pane in the Process tab window, click to select an 
experiment to print.

2. From the menu bar click Process.

3. Select Print Experiment → Diagram Only or Diagram & Properties.

■ Diagram Only option displays the experiment process and lists the 
inputs and outputs for each stage.

■ Diagram & Properties option displays the experiment processes, 
input and outputs and provides property information relevant to each 
stage.

⇒ The experiment information is printed on the default printer.

OR

1. From the upper right pane in the Process tab window, right-click the 
experiment to print.

2. Select Print from the shortcut menu.

3. Select Print Experiment → Diagram Only or Diagram & Properties.

■ Diagram Only option displays the experiment process and lists the 
inputs and outputs for each stage.

■ Diagram & Properties option displays the experiment processes, 
input and outputs and provides property information relevant to each 
stage.

⇒ The experiment information is printed on the default printer.
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Register a LIMS Server

Registering a LIMS Server means to add a server and make it available to 
LIMS Manager.

Registering a Server

1. From the menu bar select Tools → Register LIMS Server, or click the 
 button on the toolbar.

⇒ The Register LIMS Server window appears (Figure 2.8).

2. Search the tree and select the desired server to register.

3. Click OK.

⇒ The selected server is added to the drop-down list on the toolbar and 
appears listed in the left pane of the Process tab (Figure 2.1).

⇒ If the server selected is not LIMS aware, an error message is 
displayed (Figure 2.9).

Figure 2.8    

Register LIMS Server dialog box

The newly registered server becomes the active server.
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Unregister a LIMS Server

Right-click to select the server to remove and select Unregister LIMS 
Server from the shortcut menu that appears.

Server Events

The Server Events option displays a log allowing you to view events 
occurring on the active LIMS server.

To view the Server Events log: 
Select Tools → Server Events, or click the  button on the toolbar.

Server Tasks

Use the Server Tasks option to view a task window that displays the 
publishing queue. Review the task list at any time to monitor all publishing 
occurring on the active server (Figure 2.10).

To view Server Tasks: 
Select Tools → Server Tasks or click the  button on the toolbar.

Figure 2.9    

Register LIMS Server error message

An error message indicates that there is no LIMS system installed, or 
that there is an installation error. For further information, please refer to 
the ‘Affymetrix® LIMS Installation and Administration Guide.’
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Figure 2.10    

Server Tasks window

service status

Select a column to define the primary sort order. Click the column heading once to 
sort the task list in an ascending manner, click again to sort descending.

Click icon 
for menu.

Identifies a new item in the queue, pending processing.

Indicates a completed task.

Indicates that an error occurred and the task was not completed.
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Task List Commands

Further action may be taken on items in the Task List window. Access the 
command menu for the task list either by clicking the  icon in the upper 
left corner of the window (Figure 2.10), or by right-clicking a task (Figure 2.11).

Viewing Tasks

The Task List window displays the status of each task on the server when 
View Tasks is selected (Figure 2.11).

Figure 2.11    

Right-click task for shortcut menu
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Viewing Task Items

The Task List window displays all items for a specified task when View 
Task Items is selected (Figure 2.12).

Viewing All Items

All items for all tasks are displayed in the Task List window when View All 
Items is selected.

Saving the Task List

The Save As command allows you to save displayed items from the Task 
List window as a .txt file.

1. Click the  icon in the upper left corner of the Task List window and 
select Save As from the drop-down menu.
Alternatively, right-click a task in the list and select Save As from the 
shortcut menu that appears.

⇒ The Save As dialog box appears (Figure 2.13).

Figure 2.12     

View Task Items window
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2. From the Save in drop-down list, browse to the desired destination.

3. Name the file and click Save.

⇒ The task list is saved as a text file in the defined destination.

Deleting Task Items

The Delete Task Items command removes all listed task items.

1. Click to select a task.

2. Right-click the task and select Delete Task Items from the shortcut 
menu that appears.

⇒ A warning / confirmation window appears (Figure 2.14).

Figure 2.13    

Save As dialog box

Figure 2.14    

Task Delete warning / confirmation window
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3. Click Yes to delete all tasks on and before the date and time indicated.

⇒ Items are deleted and Task List window is empty.

Cancelling an Active Publish Task

Right-click a pending task and select Cancel from the shortcut menu to stop 
the publish process.

Restarting a Cancelled Publish Task

Right-click a task that has been cancelled or stopped due to error and select 
Restart to reactivate the publish process.

Find Function

Use the Find feature to query Samples, Experiments or analyses within the 
process database for Export, Archive, Assume Ownership or Delete 
functions. When preforming one of these functions after a Find command, 
only the selected objects are affected by the action and do not include any 
related children objects.

Finding a Sample, Experiment or File

1. From the menu bar select Tools → Find, or click the  button on the 
Toolbar.

⇒ The Find window appears (Figure 2.15).

The Find function only searches the process database.
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2. Click either the Select Object, Advanced Filter or Data Filter tab and 
make selections from the drop-down lists, or type in requested 
information.

Further refine your search by selecting additional tabs.

Figure 2.15    

Find window with Advanced Filter tab displayed

All three tabs work in union. For Example, if sample is selected as the 
Object Type in the Select Object tab, when you switch to the 
Advanced Filter tab, only those boxes that pertain to finding a sample 
will be active.

Multiple Find windows are allowed.

Select a column heading to define the 
primary sort order. Click once to sort the 
list in an ascending manner, click again to 
sort descending.
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3. Click Find Now.

⇒ Matching results are displayed at the bottom of the window.

4. Click to select the sample, experiment or file of interest.

The commands available for the selected object are found under Find 
on the menu bar, or right-click the object to access these commands 
from the shortcut menu (Figure 2.17).

To select multiple contiguous objects to act upon: click an object in the 
list, then SHIFT-click another item anywhere either above or below the 
first selected. All objects between the two selections are selected.

To select multiple non-contiguous objects to act upon: click an object in 
the list, then CTRL-click another item anywhere in the list. Repeat as 
necessary for additional items.

Follow the procedure(s) for the Export, Archive/Unarchive, Delete and 
Assume Ownership commands outlined earlier in this chapter. There are 
two differences when performing these procedures after a Find task;  the 
commands are found under Find on the menu bar, and  the Export, 
Assume Ownership and Archive/Unarchive procedures only affect the 
specific file selected and do not include any associated data.

Sample Filter

The Filter function is used to reduce the number of samples displayed in a 
tree of samples. The Filter icon becomes active in the Process tab and the 
Import tab when you click a node under a Samples folder and remains 
active from session to session until the parameters are changed.

Using the Sample Filter

1. Click the Samples folder.

⇒ The tree expands displaying samples and the Filter icon on the 
toolbar becomes active.

2. Click the Filter icon .

⇒ The Sample Filter dialog box appears (Figure 2.16).
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3. From the drop-down boxes, define filter parameters.

The Role and User filter options are mutually exclusive. You may select 
one or the other, but not both.

4. Click Apply.

⇒ The Samples are filtered and the sample list is adjusted accordingly.

Figure 2.16    

Sample Filter dialog box

The filter parameters remain active from session to session. You must 
reset the parameters when a different display is desired.
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Figure 2.17    

Right-click objects for shortcut menus after a Find procedure

Sample

Experiment

File
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Publish Tab 3

The Publish tab allows you to create new publish databases and 
delete published data from a database. All publish databases are 
password-protected and can only be accessed using the password 
defined during the creation of the database. 

This chapter orients you to the layout of the Publish tab and describes 
in detail the functions and tasks accomplished here.

Publish Tab Window

There are three panes in the Publish tab window (Figure 3.1). The first pane 
on the left side displays a tree showing the active LIMS server, all publish 
databases residing on the server, all supported probe array types and their 
contents. 

The second pane becomes active and is filled with a create database dialog 
when a Create Database command is initiated. 

The third pane in the lower right corner is the Local Task status view that 
displays the status of processes that may be occurring in the database, such 
as Export, Import, Delete, Archive and Create. This view allows you to 
monitor these jobs while concurrently working on additional tasks within the 
LIMS system.
53
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Figure 3.1     

The three panes of the Publish tab window

2

1

3
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Publish Databases

A new security feature in LIMS Manager v3.0 is password protection for 
publish databases. Passwords are defined during the creation of the database 
and can be changed on the server using the LIMS Sync utility. For more 
information see Affymetrix LIMS Installation and Administration Guide.

Accessing Publish Databases

1. From the Publish tab, click the database you want to access.

⇒ A Publish Database Login window appears.

2. Enter the database Password and click Login.

⇒ The publish database tree expands, displaying the Probe Array 
Type folder (Figure 3.2).

Passwords are case-sensitive.

Figure 3.2    

Publish Database Login window
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Deleting

The Delete function allows you to delete data or a probe array type from a 
publish database.

Probe Array Type

Probe array types that are no longer used may be removed from the publish 
database. When a probe array type is deleted all published data associated 
with it, from the parent down, are also deleted.

Deleting a Probe Array Type

1. Click the Probe Array Type folder under the publish database of 
interest.

2. Click to select the probe array type to delete.

3. From the menu bar select Publish → Delete

⇒ A warning window appears (Figure 3.3).

4. Click Yes to delete the selected probe array type.

⇒ The probe array type is removed from the publish database and all 
associated data is deleted.

OR

1. Right-click the probe array type to delete.

2. Select Delete from the shortcut menu that appears.

⇒ A warning / confirmation window appears (Figure 3.3).

Figure 3.3    

Probe array delete warning / confirmation window
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3. Click Yes to delete the selected probe array type.

⇒ The probe array type is removed from the publish database and all 
associated data is deleted.

Publish Data

Deleting publish data removes the specified experiments or analyses from 
the publish database. When deleting a published data file, all associated files 
below are also removed.

Deleting Published Data

1. From the drop-down list on the toolbar, select the server where the 
publish database resides.

2. In the first pane on the left side of the window, select the database of 
interest and expand the tree.

3. Click to select the data to delete.

You may either select a single analysis file or an experiment.

4. On the menu bar select Publish → Delete.

⇒ A warning / confirmation window appears (Figure 3.4).

Deleting publish data permanently removes data from the database. 
Deleted data can be restored by repeating the publish procedure in 
Affymetrix ® Microarray Suite only if the information still resides on a 
process database.

Figure 3.4    

Analysis delete warning / confirmation window
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5. Click Yes to continue.

⇒ The Delete task proceeds. 
An information window appears asking you to please wait while  
published file(s) are deleted. In the lower right pane the status is 
displayed. 

To view more information pertaining to the delete task, double-click 
Delete in the lower right pane, or right-click Delete in the lower right 
pane and select View Task Log from the shortcut menu (Figure 3.6).

OR

1. From the drop-down list on the toolbar, select the server where the 
publish database resides.

2. In first pane on the left side of the window, select the database of 
interest and expand the tree.

3. Right-click the data to delete and select Delete from the shortcut menu 
(Figure 3.5).

⇒ A warning window appears (Figure 3.4).

4. Click Yes to continue.

⇒ The Delete task proceeds. 
An information window appears asking you to please wait while  
published file(s) are deleted. In the lower right pane the status is 
displayed. 

To view more information pertaining to the delete task, double-click 
Delete in the lower right pane, or right-click Delete in the lower right 
pane and select View Task Log from the shortcut menu (Figure 3.6).

Figure 3.5    

Right-click for Delete shortcut
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Figure 3.6    

Active Delete publish data task
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Creating Publish Databases

Create new publish databases at any time from the Publish tab of 
Affymetrix® LIMS Manager. In addition to creating the new database, the 
system also creates the necessary ODBC DSNs for publishing data. Several 
key pieces of information are required to create a publish database. This 
information includes:

■ Server on which to create the database

■ Username and password with appropriate permissions for creating 
databases on the selected server

■ Size of database to create

■ Proper drive and path for the database files

The server name selected on the Create Publish Database pages is 
represented by an ODBC data source name description. This ODBC DSN 
specifies the location of an administration database that is used to create the 
actual publish database. This DSN is normally created during the installation 
process of the Affymetrix® LIMS system.

Database Size Considerations

When creating a Microsoft® SQL Server publish database, the initial size of 
the database can be between 128 MB and 1024 MB. This size corresponds to 
approximately the following storage capabilities (based on a probe array 
with 270 x 270 cells, 1800 probe sets per probe array):

■ 8 MB per experiment (includes experiment information, cell file and chip 
file)

■ 8 MB per library file 

■ 128 MB database = 4 library files and 12 experiments

■ 1024 MB database = 16 library files and 110 experiments

Creating an Oracle® publish database has only 2 size options, Small and 
Large. The small database takes approximately 6 GB of space and the large 
is almost 12 GB. These publish databases have enough room to publish 
approximately 500 and 1000 experiments respectively.

The size of a Microsoft® SQL Server database can easily be increased once 
the database is created. For information on increasing the size of a SQL 
Server publish database, see Affymetrix® LIMS Installation and 
Administration Guide.
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Microsoft® SQL Server Publish Database

Affymetrix® LIMS Manager 3.0 features increased security with a 
password-protected publish database. Publish databases can only be 
accessed with the password defined at the time the publish database was 
created. 

Creating a Microsoft® SQL Server Database

1. From the drop-down list on the toolbar, select the server where the 
publish database will reside.

2. Click to select the server icon in the left pane of the Publish tab.

3. On the menu bar select Publish → Create SQL Database, or right-
click the server icon in the left pane and select Create SQL Database.

⇒ The Create SQL Database dialog box appears in the upper right 
pane (Figure 3.7).

Figure 3.7    

Create SQL Database dialog box
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4. Enter the following information in the Database section:

■ Database name: <name for the new publish database>

■ Database password: <password of your choice>

■ Confirm database password: <re-enter password to confirm>

5. Enter the following information in the Data device, Index device and  
Log device sections:

■ Path: Use the complete drive description, including drive letter, colon 
and backslash (E:\Affymetrix DBDevices).

■ Size (MB): The size depends on the number of experiments that will 
be published to the database and the amount of available space on 
the drive selected. Microsoft® SQL Server databases are relatively 
easy to expand after creation; therefore, creating a smaller database 
and expanding it as necessary is recommended.

6. Click Install.

⇒ It takes several minutes to create the database and allocate the 
amount of drive space requested (2 -15 minutes or more, depending 
on the speed of the server and drive).

Once created, the database is available for publishing without further 
configuration. If the newly created database does not appear in the 
Select Publish Database(s) drop-down list, verify that the database and 
the ODBC DSN were created properly.

The publish database name is limited to 22 characters in length.

The drive letter specifies the drive on the actual publish database 
server. If the publish database is being created on a remote server, 
make sure the selected drive letter is available on that server.
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Oracle® Publish Database

Creating an Oracle® Publish Database

1. From the drop-down list on the toolbar, select the server where the 
publish database will reside.

2. Click to select the server icon in the left pane of the Publish tab.

3. On the menu bar select Publish → Create Oracle Database, or right-
click the server icon and select Create Oracle Database from the 
shortcut menu.

⇒ The Create Oracle Database dialog box appears in the upper right 
pane (Figure 3.8).

The Oracle® publish databases are much larger than the default 
Microsoft® SQL Server databases. Verify that there is adequate space on 
the server before creating an Oracle database. The Small Oracle 
publish database requires 6 GB and the Large database requires 12 GB. 
These sizes correspond to publishing approximately 500 and 1000 
experiments respectively.

Figure 3.8    

Create Oracle Database dialog box
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4. In the Database section enter the following information:

■ Database name: <name for the new publish database>

■ Database password: <password of your choice>

■ Confirm database password: <re-enter password to confirm>

5. In the Data Device section enter the following information:

■ Server Device Path: This is the complete path for the database files. 
Use the complete drive description for Windows 2000. 
For example: E:\Affymetrix DBdevices\
Be sure to include the trailing slash.

■ Database Size: from the drop-down list.
The Small database requires approximately 6 GB of drive space and 
the Large requires approximately 12 GB.

6. Click Install.

⇒ It takes several minutes to create the database and allocate the 
amount of drive space requested (15 - 30 minutes or more, 
depending on the speed of the server and drive).

Once created, the database is available for publishing without further 
configuration. If the newly created database does not appear in the 
Select Publish Database(s) drop-down list, verify that the database and 
the ODBC DSN were created properly.

The publish database name is limited to 22 characters in length.

The datafile path directory used specifies the file location on the actual 
publish database server. If the publish database is being created on a 
remote server, make sure the path specified is available on that server.
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Import Tab 4

Data created in Affymetrix® Microarray Suite and stored on a local 
hard drive is moved, or copied, to a process database on a LIMS 
server with LIMS Manager via the Import tab. The additional tasks of 
editing and updating data are also accomplished from the Import tab.

This chapter orients you to the layout of the Import tab and describes 
in detail the tasks accomplished here.

Import Tab Window

The window of the Import tab is divided into four panes (Figure 4.1). The first 
pane displays all registered servers and process databases and lists the 
samples associated with expression assays.

The second pane in the upper right corner is tabbed with a separate file type 
on each of the three tabs. The tabs display the corresponding files found at 
the defined import file path.

In the upper center of the Import tab window is the Data to Import pane, a 
staging area where you identify the sample and associate the files of interest 
with the sample.

The fourth pane found in the lower right corner displays either a Property 
Information or Local Task status view. Property Information lists 
environment details pertaining to the selected item. This information is 
primarily obtained from the Sample Registration process and includes 
information such as Sample Project, Sample Type, Initial Stage, 
Description, Comments, Date, User and Template.

The Local Task status view displays the status of processes that may be 
occurring in the database, such as Export, Import, Delete, Archive and 
Create. This view allows you to monitor these jobs while concurrently 
working on additional tasks within the LIMS system.
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.

Figure 4.1     

The four panes of the Import tab window

1 2
3
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Entering and Updating Data

Only the Import tab requires your input to enter or update data. The 
following rules apply for all user input data fields:

Table 4.1

Rules for Data Input

Data Input Rule

Character length ≤ 64 characters

Invalid Characters \ / : * ? “ < > | ‘ ~ ´, { } [ ]

Required Data fields Required fields are indicated by blue titles 
and may not be left blank

Data fields Names may not duplicate existing names

Table 4.2

Valid Field Lengths

Editing Samples Attributes Length

Sample Project 64

Sample Type 64

Description 64

Comments 64

Sample Name 64
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Importing Data

The Import function imports or copies data files created in Affymetrix® 
Microarray Suite stored on a local hard drive and moves them to a process 
database on a LIMS server. It is possible to import data to multiple LIMS 
Servers. Importing data is a three-step process consisting of selecting a file 
path, identifying a sample and associating files with the sample.

Selecting an Import File Path

1. On the menu bar select Tools → File Path, or click the  button on the 
toolbar.

2. Select a Drive from the drop-down list and browse to find the desired 
files.

3. Click OK.

⇒ The file path defined appears above the upper right pane, and the 
data files at that location are listed under the EXP, CEL and CHP 
tabs (Figure 4.2).

Figure 4.2    

File Path location and data type tabs

The default file path is the same path assigned to Affymetrix® 
Microarray Suite experimental data.
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Identifying a Sample

LIMS offers the ability of tracking both the sample and projects associated 
with an array (experiment). Affymetrix® Microarray Suite starts with the 
array but does not make project or sample associations. Thus, after selecting 
a file path, the next step requires you to rebuild this association. This is 
accomplished by providing a project and sample for each imported array. 
You do this by creating a new sample or importing data into an existing 
sample.

Creating a New Sample

The Create Sample option, found on the Import tab, captures sample 
information and is available for all assay types. Create Sample differs from 
the Register Sample option, available in Affymetrix® Microarray Suite that 
captures the sample information defined by the template used. 

1. In the left pane, click the Expression folder.

2. On the menu bar select Import → Create Sample, or right-click the 
folder and select Create Sample from the shortcut menu.

⇒ The Create Sample dialog box appears (Figure 4.3).

Figure 4.3    

Create Sample dialog box

required fields
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3. Enter the Sample name

4. Enter the Sample project and Sample type, or select from the drop-
down lists.

5. Enter Descriptions and Comments, if desired.

6. Click OK.

⇒ The sample created appears in the center, Data to Import pane.

Selecting an Existing Sample

The second method of identifying a sample is to select an existing sample 
from the process database tree.

1. In the first pane, expand the Expression folder and locate the sample of 
interest.

2. Click and drag the sample from the first pane and drop into the Data to 
Import pane.

⇒ The sample and all associated files appear in the staging area with 
red check marks indicating that these files already exist in the 
database (Figure 4.4).

Once a sample is created, all sample information may be edited except 
the Sample Name. You may only edit new samples and not existing 
ones. See “Edit Sample” on page 75.

Figure 4.4    

Selecting an existing sample for data import
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Associating Files

The third and final step of the import data task is to associate files with a 
sample. Drag and drop an .exp file, and the .cel and .chp files with the same 
prefix are automatically associated.

Additional files with different prefixes may also be added. This is done in a 
hierarchical manner. First match the .exp file(s) to the sample. Then match 
the .cel file(s) to the .exp, and finally the .chp to the .cel.

Associating .exp with Sample

The EXP tab displays all files located at the designated path that contain the 
.exp extension. The import process also migrates the .dat file associated with 
the .exp file via a common filename. Importing an .exp file that does not 
have an associated .dat file within the designated folder results in an error 
message. These .dat files without associated .exp files are not available for 
import.

1. Click and drag the .exp file from the upper right pane and drop on top of 
the sample you wish to associate it with in the Data to Import pane.

⇒ The .exp file appears on the branch below the sample name with 
.cel and .chp files containing the same prefix (Figure 4.5).

 

2. Repeat step 1 to associate additional .exp files with the sample. 

The filenames of imported files need to conform to the naming 
conventions within LIMS (see page 69). You may need to rename files to 
ensure that the filenames conform.

Figure 4.5    

Associating .exp file with a sample
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3. If other .cel or .chp files with different prefixes are to be included, 
continue with the following steps.

Associating .cel with .exp

1. Select the CEL tab.

2. Click and drag the .cel file from the upper right pane and drop on top of 
the .exp file you wish to associate it with in the Data to Import pane.

⇒ The .cel file appears in the branch below the .exp file in the Data to 
Import pane (Figure 4.6).

3. Repeat step 2 for additional .cel files.

You can only associate files from probe array types installed in the LIMS 
database. If a particular probe array type is not installed, an error 
message appears when you try to associate files from that probe array 
type.

Figure 4.6    

Associating a .cel file with an .exp

To avoid having to associate a .cel and .chp file with each .exp file 
imported into the process database, simply import only the .exp file. 
Then recreate the .cel and .chp files using Affymetrix® Microarray Suite 
in LIMS mode. This minimizes potential error from mistakenly dragging 
a .chp file onto the wrong .cel file. Contact Affymetrix Technical Support 
for help on batch analysis methods in Affymetrix® Microarray Suite, or 
refer to Affymetrix® Microarray Suite User’s Guide.
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Associating .chp with .cel

1. Select the CHP tab.

2. Click and drag the .chp file from the upper right pane and drop on top of 
the .cel file you wish to associate it with in the Data to Import pane.

⇒ The .chp file appears in the branch below the .cel file in the Data to 
Import pane.

3. Repeat step 2 for additional files to associate.

Start Import

From the menu bar select Import → Start Import, or right-click the 
sample and select Start Import from the shortcut menu.

⇒ The import task proceeds and the status is displayed in the lower 
right pane.

Double-click Import to view more information pertaining to the import 
task, or right-click Import in the lower right pane and select View Task 
Log from the shortcut menu.

Edit Sample

A sample can only be edited in LIMS Manager before it has been imported 
into a process database. After a sample has been imported, or created via 
Microarray Suite, it can no longer be edited.

1. Click to select a sample to edit in either the Data to Import pane that 
has not been imported.

2. On the menu bar select Import → Edit Sample, or right-click the 
sample and select Edit Sample from the shortcut menu.

3. Make changes as necessary. You may not alter the Sample Name.

4. Click OK.
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Remove and Remove All

To correct errors that occur as you build the sample to import, use the 
Remove or Remove All command.

1. In the Data to Import pane, click to select the file to remove.

Select a node without children and the Remove command is active.

Select a parent node and the Remove All command is active and erases 
the parent file and all associated children files from the Data to Import 
pane.

2. On the menu bar select Import → Remove or Remove All as 
appropriate, or right-click the file to remove and select from the shortcut 
menu.

⇒ The file(s) disappear from the Data to Import pane.

Sample Filter

The Filter function is used to reduce the number of samples displayed in a 
tree of samples. The Filter icon becomes active in the Process tab and the 
Import tab when you click a node under a Samples folder and remains 
active from session to session until the parameters are changed.

Using the Sample Filter

1. Click the Samples folder.

⇒ The tree expands displaying samples and the Filter icon on the 
toolbar becomes active.

2. Click the Filter icon .

⇒ The Sample Filter dialog box appears (Figure 4.7).
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3. From the drop-down boxes, define filter parameters.

The Role and User filter options are mutually exclusive. You may select 
one or the other, but not both.

4. Click Apply.

⇒ The Samples are filtered and the sample list is adjusted accordingly.

Figure 4.7    

Sample Filter dialog box

The filter parameters remain active from session to session. You must 
reset the parameters when a different display is desired.
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Userset Tab 5

The userset is a predefined set of parameters used when running an 
expression analysis in Affymetrix® Microarray Suite. Creating and 
modifying a userset is accomplished from this tab in Affymetrix® LIMS 
Manager.

This chapter orients you to the layout of the Userset tab window and 
describes in detail the functions and tasks accomplished here.

Userset Tab Window

The window of the Userset tab is divided into three panes (Figure 5.1). The 
first pane displays the active servers and process databases, and lists defined 
usersets and probe array types associated with the expression assay.

The second pane in the upper right corner is the userset definition area where 
existing usersets are reviewed or edited and where new usersets are created.

The third pane found in the lower right corner displays the Local Task status 
view that displays the status of processes that may be occurring in the 
database, such as Export, Import, Delete, Archive and Create. This view 
allows you to monitor these jobs while concurrently working on additional 
tasks within the LIMS system.

You only have access to this tab if the appropriate privileges are defined for 
you in the Roles tab.
81
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Figure 5.1     

The three panes of the Userset tab window
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Userset Definition

The algorithm involved in expression probe array analysis has 
approximately 18 user-defined parameters that are set before an analysis is 
run. Rather than requiring you to adjust these parameters for each analysis, a 
predefined userset, created by an administrator or other authorized user, 
frees you to simply select a userset and run the analysis. The function of the 
userset is to create defined parameters to be used when running an 
expression analysis.

Figure 5.2    

Userset definition pane
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modification
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Creating a Userset

The userset is created in Affymetrix® LIMS Manager and used by 
Microarray Suite when analyzing a probe array. The procedure outlined 
below creates the basic shell of a new userset, giving it a name and defining 
probe array types.

Creating a Userset

1. Type a unique userset name in the Create set name box.

2. From the Probe Array Types list box, select a probe array type and 
click >> to move to the Probe array types used list box (Figure 5.3).

Repeat this step to add as many probe array types as desired.

Figure 5.3     

Creating a new userset
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3. Click Create Set.

⇒ The name of the new userset appears in the Existing userset 
name(s) list box in the upper right corner and in the left hand pane.

4. Proceed to Modifying a Userset.

Modifying a Userset

The 18 user-defined parameter settings are used by the algorithm when 
running an expression analysis. An existing userset is modified by defining 
these parameter values.

A userset may also be modified by removing a probe array type. See page 88 
for more information.

Define Parameter Values

An independent parameter is a static setting that is not influenced by probe 
array selection. A dependent parameter is a setting that is specific to the 
particular probe array type selected. This section outlines how to modify 
these settings.

For a detailed explanation of parameters, refer to the Affymetrix® 
Microarray Suite User’s Guide.
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Defining Independent Parameters

1. From the independent parameters list box (Figure 5.4) click to select a 
parameter of interest.

⇒ The selected parameter name and current value are displayed in the 
box above.

2. Type a value in the box above to edit.

3. Click Modify.

New values do not take effect until Update Set or Create Set is clicked.

4. Repeat for additional values.

Click Defaults to reset independent and dependent parameter values.

5. Click Update Set.

Figure 5.4    

Selecting Independent Parameters



Affymetrix®  LIMS Manager   User’s Guide 87

Manager.book  Page 87  Wednesday, February 27, 2002  4:56 PM
Defining Dependent Parameter Values

1. From the Probe array types used list box, click to select a probe array 
type (Figure 5.5).

⇒ The selected probe array information appears in the dependent 
parameter box.

2. Select a method for how the data will be analyzed by clicking the 
appropriate tab; Scaling, Normalization, Probe Mask or Baseline.

3. Click Update Set.

4. If necessary, repeat for additional probe arrays listed.

Figure 5.5    

Defining parameter values
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Delete a Probe Array Type from a Userset

You may remove a probe array type from an existing userset in one of two 
ways.

Removing a Probe Array Type Via the Userset Definition Pane

1. Click to select the probe array type to delete in the Probe array type 
used list box in the userset definition pane. 

2. Click <<.

⇒ The probe array type is removed from the Probe array type used 
list box and no longer appears under the userset in the left hand 
pane.

Removing a Probe Array Type Via the Left Hand Pane

1. In the left hand pane click (+) to expand the userset of interest 
(Figure 5.6).

2. Click to select the probe array type to delete.

Figure 5.6    

Right-click for Delete short cut
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3. From the menu bar select Userset → Delete, or right-click the probe 
array type to delete and select Delete from the shortcut menu (Figure 5.6).

⇒ A warning / confirmation window appears.

4. Click Yes to delete.

⇒ The probe array type is removed from the userset.

Delete a Userset

Use the delete command to remove a userset that is no longer needed. 
Deleted usersets are removed in LIMS Manager and are unavailable to 
Microarray Suite users.

Deleting a Userset

1. In the left hand pane, click to select the userset to delete.

Figure 5.7     

Delete probe array warning / confirmation window

Figure 5.8    

Right-click for Delete shortcut menu
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2. From the menu bar select Userset → Delete, or right-click the userset to 
delete and select Delete from the shortcut menu (Figure 5.8).

⇒ A warning / confirmation window appears (Figure 5.9).

3. Click Yes to delete userset.

⇒ The userset is deleted and removed from both the userset list in the 
left hand pane and the Existing userset name(s) list box in the 
upper right corner.

Figure 5.9    

Delete warning / confirmation window
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Template Tab 6

A template is a form created by the administrator, or other authorized 
user in Affymetrix® LIMS Manager, and is used to define the attributes 
and values for both the experiment and sample registration process. 
The registration process is a function of Affymetrix® Microarray Suite.

This chapter orients you to the layout of the Template tab window and 
describes in detail the functions and tasks accomplished here.

Template Tab Window

The window of the Template tab is divided into three panes (Figure 6.1). The 
first pane displays the active server, the process database and the 
Experiment and Sample templates that reside there.

The second pane in the upper right corner is the template attributes area. 
This pane displays the attributes and values of the template selected in the 
first pane.

The third pane found in the lower right corner displays the Local Task status 
view that displays the status of processes that may be occurring in the 
database, such as Export, Import, Delete, Archive and Create. This view 
allows you to monitor these jobs while concurrently working on additional 
tasks within the LIMS system.
93
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Figure 6.1     

The three panes of the template tab window
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Templates

Creating a New Template

1. Click to select either the Experiment Templates or Sample Templates 
folder. 

2. From the menu bar select Templates → Create, or right-click the 
templates folder and select Create from the shortcut menu that appears 
(Figure 6.2).

⇒ The Create Template name dialog box appears (Figure 6.3).

Figure 6.2    

Right-click for short cut menu

Figure 6.3    

Create Template name dialog box
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3. Type a unique name for the template type in the box and click OK.

⇒ The new name appears under the appropriate template folder in the 
left hand pane, and the upper right hand pane displays the blank 
template (Figure 6.4).

4. Proceed to Defining or Editing Attributes and Values.

Figure 6.4    

New Template appears in List



Affymetrix®  LIMS Manager   User’s Guide 97

Manager.book  Page 97  Wednesday, February 27, 2002  4:56 PM
Defining or Editing Attributes and Values

The process of defining attributes for a new template, or editing an 
attribute(s) for an existing template is virtually identical. The procedure 
below is written as if working with a blank template, however it can also be 
used for the purpose of editing attributes.

Defining Attributes and Values

1. Click to select a template name in the first pane.

⇒ The template appears in the second pane.

2. Double-click a cell under the Name column.

⇒ The mouse pointer becomes an I-beam, and the other cells in the 
row are blocked (Figure 6.5).

3. Type an attribute name and press ENTER.

⇒ The attribute name is inserted, and a number appears in the left 
column.

4. Click the cell under the Type column, then click the button that 
appears.

5. Define the data type for the attribute by selecting from the drop-down 
list.

■ Integer: whole number

■ Float: floating point number

■ String: limited to 255 characters

■ Date: date

■ Time: time

■ Controlled: limits user response to options listed

Figure 6.5    

Creating an attribute: Naming
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⇒ The data type is defined and appears in the cell (Figure 6.6).

6. Click the cell under the Required column, then click the button that 
appears (Figure 6.7).

7. Select Yes if the information is required or No if it is not.

A Yes selection requires the Microarray Suite user to enter a value 
before the sample or experiment can be registered.

⇒ The response entered appears in the cell.

8. If the data type you selected was controlled, double-click the cell under 
the Values column, otherwise go to step 11.

⇒ A Controlled Values Edit List dialog box appears (Figure 6.8).

Figure 6.6    

Creating an attribute: defining data type

Figure 6.7    

Creating an attribute: defining if required
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9. Define a controlled value by typing the desired value options in the box. 
Press ENTER after each option (Figure 6.9).

10. Click OK when finished.

⇒ Values appear in drop-down list box under the Values column 
(Figure 6.10).

Figure 6.8    

Creating an attribute: double-click for Controlled Values Edit List dialog box

Figure 6.9    

Controlled Values Edit List dialog box
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11. Click Apply.

The defined attributes do not take effect until you click Apply.

⇒ A warning message appears if this is an update to an existing 
template (Figure 6.11).

12. Click OK to continue.

13. Repeat above steps to add additional attributes to the template.

14. Click Apply.

⇒ The attributes are applied to the template.

Figure 6.10    

Defined controlled values

Figure 6.11    

Update warning message

Save time creating and defining attributes in a new template by copying 
the desired attribute(s) from existing templates and pasting them into a 
new template. See page 105.
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Deactivating and Activating

Templates are used in Affymetrix® Microarray Suite during the 
experiment or sample registration process. Deactivating a template in 
Affymetrix® LIMS Manager removes it from use in Microarray Suite.

Deactivating a Template

1. Click to select the template to deactivate from the left hand pane.

2. From the menu bar, select Template → Deactivate, or right-click the 
template to deactivate and select Deactivate from the shortcut menu 
that appears.

⇒ A warning window appears (Figure 6.12).

3. Click OK to deactivate.

⇒ The template icon remains in the tree, but appears gray to indicate 
an inactive template (Figure 6.13).

Activating a Template

1. Click to select the template to activate from the left hand pane.

2. From the menu bar, select Template → Activate, or right-click the 
template to activate and select Activate from the shortcut menu that 
appears.

⇒ The template is activated and the icon is restored to full color 
(Figure 6.13).

Figure 6.12    

Deactivate warning window

Deactivated templates do not appear in Microarray Suite.
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Figure 6.13    

Deactivating and Activating Templates
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Renaming

Renaming a Template

1. Click to select the template to rename from the left hand pane.

2. From the menu bar, select Template → Rename, or right-click the 
template to rename and select Rename from the shortcut menu that 
appears.

3. Type a unique template name in the box, and press ENTER.

Working with Attributes

You may not duplicate an existing template name for a particular 
template type.

Figure 6.14     

Templates menus and commands
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Multi selecting

To select multiple contiguous attributes to act upon: click an attribute 
number in the left column, then SHIFT-click another number anywhere 
either above or below the first selected. All attributes between the two 
selections are selected.

To select multiple non-contiguous attributes to act upon: click an attribute 
number in the left column, then CTRL-click another number anywhere in 
the list. Repeat as necessary for additional attributes.

Inserting

Inserting an Attribute

1. Select the attribute below the insertion point and click the attribute 
number in the left column.

2. From the menu bar, select Template → Attribute → Insert, or click 
the attribute number to select the row then right-click and select Insert 
from the shortcut menu that appears.

⇒ A blank row is inserted in the template.

3. Define the attribute. 

For further information, refer to the section Defining or Editing 
Attributes and Values on page 97.

4. Click Apply.

Deactivating

Deactivating an Attribute

1. Click the attribute number in the left column.

2. From the menu bar, select Template → Attribute → Deactivate, or 
click the attribute number to select the row then right-click and select 
Deactivate from the shortcut menu that appears.

⇒ The attribute appears grayed-out, but remains in the attribute list.

3. Click Apply.

⇒ A warning message appears (Figure 6.15).
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4. Click OK to deactivate the attribute.

⇒ The attribute becomes inactive.

Activating

Activating an Attribute

1. Click the attribute number in the left column.

2. From the menu bar, select Templates → Attribute → Activate, or click 
the attribute number to select the row then right-click and select 
Activate from the shortcut menu that appears.

⇒ The attribute no longer appears gray.

3. Click Apply.

⇒ The attribute becomes active.

Copying

Copying an Attribute

1. Click the attribute number in the left column.

2. From the menu bar, select Template → Attribute → Copy, or click the 
attribute number to select the row then right-click and select Copy from 
the shortcut menu that appears.

⇒ The information is copied to the clipboard and is available for a 
paste action.

Figure 6.15    

Warning message

In Microarray Suite, deactivated attributes appear for the samples and 
experiments that have already been saved using the attribute, but 
cannot be modified. Deactivated attributes are not shown for new 
samples and experiments.
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Cutting

Cutting an Attribute

1. Click the attribute number in the left column.

2. From the menu bar, select Template → Attribute → Cut, or click the 
attribute number to select the row then right-click and select Cut from 
the shortcut menu that appears.

⇒ The information is removed from the template, copied to the 
clipboard and is available for a paste action.

Pasting

Pasting an Attribute

1. Click the attribute number in the left column.

2. From the menu bar, select Template → Attribute → Paste, or click the 
attribute number to select the row then right-click and select Paste from 
the shortcut menu that appears.

⇒ The information on the clipboard is pasted on the template as the 
last item in the list.

3. Click Apply.
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Roles Tab 7

A role is a defined set of access privileges created by the 
administrator to control access to data by users. Creating and 
defining roles provides the system administrator with a security 
feature that allows granting various levels of access to different users, 
or different groups of users.

This chapter orients you to the layout of the Roles tab window and 
describes in detail the functions and tasks accomplished here.

Roles Tab Window

The window of the Roles tab is divided into three panes (Figure 7.1). The first 
pane on the left side identifies the server(s) and all the roles that have been 
created on that server. The branch immediately under the server lists the role 
names, and is known as the Role Definitions branch (Figure 7.3). LIMS 
Administrator and the LIMS User are default roles and cannot be deleted. 
The LIMS Administrator has the ability to add additional roles. 

The process database name for the server is listed below the Role 
Definitions branch in the first pane. The branch below the process database 
name lists all role names that have been added to the process database. This 
is the User Definitions branch and is where users are added and membership 
to roles is made (Figure 7.3). Double-click a role name to expand the branch 
and view individual user names listed.

The default view for the second pane in the upper right corner lists the 
domains that reside on the network. Click a role name in the Role 
Definitions branch of the first pane and the corresponding template defining 
the rights and privileges of the role replaces the default view in this pane 
(Figure 7.2).
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The third pane in the lower right corner is the Local Task status view that 
displays the status of processes that may be occurring in the database, such 
as Export, Import, Delete, Archive and Create. This view allows you to 
monitor these jobs while concurrently working on additional tasks within the 
LIMS system.

Figure 7.1     

The three panes in the Roles tab window

1 2

3
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Creating a Role

A role provides a user with a set of access privileges. All LIMS users are 
assigned to a role. Click a role in the Role Definitions branch of the first 
pane (Figure 7.3) and see a template of information about that role appear in 
the second pane listing role functions. Every role has identical functions 
associated with it that are static. It is the privileges given to the user to access 
that function that are modified.

Creating a role is a three-fold process: naming the new role, defining the 
functions associated with the role, i.e., what the user can and cannot do, and 
defining role membership.

Figure 7.2    

Default View and Template View of the second pane of the Roles tab window



CHAPTER 7   Roles Tab112

Manager.book  Page 112  Wednesday, February 27, 2002  4:56 PM
Creating a New Role

1. Click an existing role in the Role Definitions branch in the first pane.

2. On the menu bar select Roles → Create Role, or right-click an existing 
role and select Create Role from the shortcut menu that appears.

⇒ The Create Role dialog box appears (Figure 7.4).

3. Type a role name in box and click OK.

⇒ The new role appears in the Role Definitions branch in the first 
pane.

Figure 7.3    

Branches identified in the Roles tab 

Figure 7.4    

The Create Role dialog box

Role Definitions

Member Definitions

Role Members 
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4. Click and drag a role name from the Role Definitions branch and drop it 
on top of the process database name in the User Definitions branch 
below.

⇒ The new role appears in the User Definitions branch.

Defining Privileges

1. Click the role name in the Role Definitions branch in the first pane.

⇒ The corresponding template defining the rights and privileges of the 
role appear in the second pane (Figure 7.5).

The first column of boxes refers to the rights a role member is given 
with regards to their own data. The second column is the Function or 
privilege. The third column refers to the rights the role member is given 
with regards to Other User Data Access. Table 7.1 defines the various 
privilege functions.

2. Click to select the functions users will have with their own data.

⇒ The selected functions appear with a check mark in the box.

3. In the third column, click to toggle Yes/No to define the functions a user 
will have with Other User Data Access.

A role name cannot be left blank or duplicate an existing name.

Figure 7.5    

Default privilege settings
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Other User Data Access is always Yes and cannot be toggled for the 
following functions: Take Ownership, Maintain Roles, Import 
Process Data and Delete Publish Data.

The LIMS Administrator role cannot be modified.

Table 7.1

Role Privileges

Function Description

Read Process Database Allows a user to browse sample, experiment and analyses in formation in the 
process database.

Update Process Database Allows a user to modify sample and experiment properties information in the 
process database.

Update Publish Database Allows a user to overwrite experiment and analyses information in the publish 
database.

Archive Process Data Allows a user to move and restore data files from and to the LIMS server.

Delete Process Data Allows a user to delete sample, experiment, analyses, userset and probe array 
type information from the process database.

Delete Publish Data Allows a user to delete experiment and analyses information from any publish 
database.

Import Process Data Allows a user to migrate Affymetrix® Microarray Suite datafiles into the 
process database.

Export Process Data Allows a user to copy sample, experiment, and analyses files from the LIMS 
server to a defined location.

Take Ownership of Process Data Allows a user to assume ownership of a sample, experiment and analyses 
information with the ability to overwrite a file with new contents (i.e., 
reanalyzing with different parameters).

Maintain Roles Allows a user to manage role, role membership and set privileges.

Delete Server Tasks Allows a user to delete publish tasks on or before a given date.

Maintain Templates Allows a user to manage templates and their attributes.

Maintain Usersets Allows a user to manage Expression Analysis parameter sets.

Create Publish Database Allows a user to create a publish database.
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Defining Membership

Adding a User

1. Click to expand the domain name tree in the upper right pane.

⇒ The tree expands displaying the user groups residing on the domain.

2. Traverse the tree to find the desired user name.

3. Click and drag the user name and drop it on top of the role in the User 
Definitions branch in the first pane.

⇒ The user is added to the role, and the role name expands to display 
membership (Figure 7.6).

Removing a User

1. Click to expand the role in the User Definitions branch of the first pane.

2. Click to select the user to delete.

3. On the menu bar select Roles → Remove User, or right-click the user 
name and select Remove User from the shortcut menu.

⇒ The user name is removed from role membership.

Figure 7.6    

Adding a Member

Click and drag the  icon to collectively add an entire user group to a 
role.
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Deleting Roles

Deleting a Role

1. Click to select the role to delete.

2. On the menu bar select Roles → Delete Role, or right-click the role to 
delete and select Delete Role from the shortcut menu.

⇒ A warning window appears (Figure 7.7).

3. Click Yes to delete.

⇒ The role is deleted and disappears from both the Role Definitions 
and the User Definitions branches in the left pane.

LIMS User and LIMS Administrator are default roles and cannot be 
deleted.

Figure 7.7    

LIMS warning window
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Print Samples A

The following are samples of two types of print output available in 
LIMS Manager.

Diagram Only

Figure A.1   

Print Diagram Only

ProcessView Report of Experiment:Wisc_Control (Diagram Only) 5/15/01 12:33:37

Sample Name   : UOF W Date       : Mar 30 2000 10:21AM Server     : DBSERVER04
Sample Project: Uof W Stage      : Hybridization Database   : LIMS3
Sample Type   : total RNA Template   : User       : lwang
Comments      : 
Description   : 

Wisc_Control <Experiment>
Sample Registration
(O) Uof W <sample>

Uof W:GE <vessel>
Experiment Setup
(I) Uof W <sample>
(O) Wisc_Control <experiment>
Hybridization
(I) Uof W:GE <vessel>

Wisc_Control <chip>
Scan
(I) Wisc_Control <chip>
(O) Wisc_Control.dat
Grid Alignment
(I) Wisc_Control.dat
Cell Intensity Analysis
(I) Wisc_Control.dat
(O) Wisc_Control.CEL
Probe Array Analysis
(I) Wisc_Control.CEL
(O) Wisc_Control.CHP
Publish
(O) Wisc_Control <experiment>

Wisc_Control.CEL
Wisc_Control.CHP
119
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Diagram & Properties

Figure A.2   

Print Diagram and Properties (page 1 of 4, only)

ProcessView Report of Experiment:Wisc_Control 5/15/01 12:33:56

Sample Name   : UOF W Date       : Mar 30 2000 10:21AM Server     : DBSERVER04
Sample Project: Uof W Stage      : Hybridization Database   : LIMS3
Sample Type   : total RNA Template   : User       : lwang
Comments      : 
Description   : 

Wisc_Control <Experiment>
Probe Array Type : Hu6800
Comment : (null)
User : lwang
Date : Mar 30 2000 10:21AM
Auto : OFF
Template :

Sample Registration
(O) Uof W <sample>

Uof W:GE <vessel>
Comment    :
Barcode    : NEW2
Type       : Tube

Experiment Setup
(I) Uof W <sample>
(O) Wisc_Control <experiment>
Hybridization
Operator : lwang
Hyb Date : Jan 25 2000 11:35  
Hyb Comments :
Hyb Description :
Hyb Station ID : 0
Hyb Station # : 1
Hyb Protocol : EukGE-WS2
Hyb Module : 1
Hyb Stages : Completed
Hyb Reagents :
Hyb LotNumber :

(I) Uof W:GE <vessel>
Wisc_Control <chip>
Probe Array Lot# : 97957
Barcode          : Wisc_Control
Probe Array Type : Hu6800

Scan
Operator : lwang
Scan Date : Jan 25 2000 10:44AM           
Scan Comments :
Scanner Type : HP
Scanner ID :
Scan Filter : 570
Scan Temperature : 0
Scan Pixel Size : 3.000000
Scan Line Length : 0.000000
Scan # of Lines : 0
Scan Horizontal Offset : 0.000000
Scan Vertical Offset : 0.000000
# of Scans : 2

(I) Wisc_Control <chip>
(O) Wisc_Control.dat

Path       : \\NTLIMS04\GCLims\Data\Wisc_Control.dat
Barcode    : Wisc_Control
Created By : lwang
Edited By  : lwang
C D J 25 2000 10 44AM
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FAQs B

This appendix lists frequently asked questions (FAQs) regarding 
Affymetrix® LIMS Manager. If after reviewing these questions you still 
need assistance, please contact Affymetrix Technical Support.

LIMS FAQs

Q: I want to view information about other expression samples. I try to select another 
sample by clicking its icon but the software refuses to switch to a different sample. 
What should I do?

A: Throughout the program, click the text representing the sample or experiment name 
rather than the icon.

Q: How can I change the “export to” or “import from” location?

A: On the menubar, click the icon that depicts a folder opening (see page 18). If you are 
in the Process, Publish, or Find tabs, this will select a target location for exported 
files. If you are in the Import tab, this will select a location to import files.

Q: How do I use the Find command to search the Publish database?

A: The Find command only works with the Process database.

Q: Using the Find command, I know some of my samples (projects or experiments) are 
in the process database. However, the results continually produce an empty set. Why 
does this happen?

A: In the Find window, the Select Object tab, the Advanced Filter tab, and the Data 
Filter tab are additive. Thus if you select experiments with the text string 
“xxxAssay” using the Select Object tab and then limit the search to Project X using 
123
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the Advanced Filter tab, then the Find command is looking for experiments with 
the text string “xxxx” that are members of Project X.

Q: I want to delete (assume ownership, export, or archive) multiple files (experiments 
or samples) at one time. However I cannot select multiple files at one time within 
the process database. How can I accomplish this?

A: You can SHIFT-select or control-select multiple files, samples, or experiments at one 
time within the Find window. The majority of the functions available within the 
Process tab are also available within the Find window.

Q: I want to archive a sample but the software won't let me choose that function. How 
do I archive a sample?

A: Currently, archiving can be performed on experiments and files, but not samples. A 
list of available functions within the Find window is listed below:

Files: archive, assume ownership, delete, and export

Experiments: assume ownership, delete, export and rename

Samples: assume ownership, delete, and rename

Q: How do I get out of the Find window and back to the process database?

A: Simply close Find window or go to the Windows menu and select “LIMS server 
manager.”

Q: Can I view property information about files in the publish database?

A: No, this information is not available. But you are able to view property information 
about files in the process database from either the Publish or the Process tabs.

Q: I can't find my .dat file under the LIMS Import tab. I have confirmed that the .dat 
file exists on the local drive and that I have the import location mapped correctly. 
Why doesn't LIMS let me import my .dat file?

A: LIMS will import .exp files and the associated .dat files with the same filename. 
Make certain that an .exp file that contains the exact same filename is contained 
within the same folder as your .dat file. As a last resort, open your .dat file in 
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Affymetrix® Microarray Suite. If an .exp file does not exist for that .dat, 
Affymetrix® Microarray Suite will automatically create one.

Q: When I try to open a Sample folder, only a few samples are displayed and I know 
that there should be more in the database. What happened to the samples?

A: The Sample filter remains active during successive sessions. Reset Sample Filter 
parameters. See Sample Filter, on page 47.
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