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INTRODUCTION 

Release Notes Avizo 7.1.0 

Release Date: October 2012 

This document describes the improvements and new features in version 7.1 of Avizo, the 3D visualization 
Software for Scientific and Industrial data. 
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OVERVIEW 

Avizo 7.1 includes some important new extensions and features, enhancements of the user interface, 

performance improvements and issues fixes. 

NEW PRODUCT IN AVIZO XLAB EXTENSIONS FAMILY 

XLab Diffusion (Molecular Diffusivity)  

XLab Diffusion, a new extension of Avizo Fire software, provides numerical simulation capabilities to calculate 
molecular diffusivity of a porous medium from a scanned sample (CT, FIB/SEM, MRI, etc.). 
XLab Diffusion directly computes material properties from the segmented 3D image. Fick's second equation is 
solved using a finite volume method, with no need to extract a 3D mesh. 
 
Two new modules are provided with this extension: 
 

• Molecular Diffusivity Tensor Calculation 
The diffusivity tensor is computed using a volume averaging method applied to Fick's second equation. The 
studied sample is considered representative of a larger scale material, thus allowing periodic boundary 
conditions to be imposed. The diffusivity tensor provides additional information about the intensity of 
diffusivity along any direction in space. It can reveal anisotropy of the porous media as the dependence of 
the diffusivity on the direction of the concentration gradient. 
 

• Molecular Diffusivity Experiment Simulation 
An experiment is simulated by adding reservoirs with imposed initial concentrations at the two opposed 
input and output faces of the given sample, and by hermetically closing it on the four other faces to guide 
the diffusion along a single direction. 
 

The calculation considers diffusion of a single species in a fluid phase filled with a solvent where there is no flow, 
with no diffusion in the solid phase.  

See Avizo XLab User's Guide for more information. XLab Diffusion is available on Windows XP/Vista/7 64-Bit. 

 
 

XLab Electro (Electrical Resistivity / Formation Factor)  

XLab Electro, a new extension of Avizo Fire software, provides numerical simulation capabilities to calculate 
electrical resistivity (formation factor) of a porous medium from a scanned sample (CT, FIB/SEM, MRI, etc.). 
XLab Electro directly computes material properties from the segmented 3D image. Ohm's equation is solved 
using a finite volume method, with no need to extract a 3D mesh. 
 
Two new modules are provided with this extension: 
 

• Formation Factor Tensor Calculation 
The electrical resistivity (formation factor) tensor is computed using a volume averaging method applied to 
Ohm's equation. The studied sample is considered representative of a larger scale material, thus allowing 
periodic boundary conditions to be imposed. The resistivity tensor provides additional information about the 
intensity of resistivity along any direction in space. It can reveal anisotropy of the porous medium as the 
dependence of the resistivity on the direction of the potential difference. 
 

• Formation Factor Experiment Simulation 
An experiment is simulated, by imposing a potential difference to two opposed input and output faces of the 
given sample and by insulating the sample from outside on the four other faces. 
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The calculation considers resistivity of a single fluid phase that is filled with a solution conducting electricity 
where there is no flow, within an insulating solid phase.   

See Avizo XLab User's Guide for more information. XLab Electro is available on Windows XP/Vista/7 64-Bit. 

 

  



 

4 
Avizo 7.1 release notes – VSG© 2012 

AVIZO ALL EDITIONS - ENHANCEMENTS AND NEW FEATURES 

See also below in this document improvements and new features for specific Avizo Editions. 

NEW FEATURES 

New Animation Producer 

The Animation Producer is a powerful replacement for the familiar Demo Maker module. It allows you to create 

and edit key frame animations and demos with an intuitive timeline panel. You can start the Animation Producer 

by pressing the clap button in the main toolbar, or by selecting Animation Producer in the Window main menu. 

With the default layout, the Animation Producer window appears docked below the viewer window. You will also 

notice stopwatch icons added next to components such as modules, ports, and viewers. You can compose an 

animation by moving the orange time cursor in the extensible timeline, then use stopwatch icons to add events in 

the key frame event tracks, and modify events in the event tracks once they have been added below the timeline. 

You can zoom and pan the timeline. The remote control buttons allow playing the animation, or setting the time 

cursor to the next or previous event. 

To create a movie, you will toggle the tape button in the Animation Producer panel, near the 'remote control' 

buttons, which shows the Movie Maker interface. 

You can create multiple new animations and select any as the current animation. 

 

For more details, see the updated tutorial in Avizo User's Guide, in chapter Animations, Movies and Presentations 

in Avizo. 

By default, when loading an existing project, the contained Demo Maker modules remain hidden in the project 

view and are automatically converted into Animation Producer content. This can be disabled in the Preferences 

General panel by checking the option Use Legacy Demo Maker. 

 

USER INTERFACE ENHANCEMENTS 

Extended Colormap port, superseding Data Window port (linear mapping type) 

The Data Window range slider port that was available in modules such as Ortho Slice, is now superseded by a 

Colormap port. Colormap port has been extended to support the same features as the former Data Window 

range slider port: histogram displayed in background (Avizo Fire edition only) and subrange buttons. Note that 

colormap port supports reversed ranges (left value bigger than right value). For instance, while dragging a 

subrange button, when crossing the other subrange button, the colormap appears reversed. 

When loading a project saved with Avizo 7.0.1 and earlier, a Data Window port (Tcl linearRange or range port of 

type HxPortRangeSlider) is automatically replaced by an equivalent Colormap port. The colormap port is set with 

grayscale colormap, local range mode, and auto-adjust mode, tracking the input data window. For instance, if an 

Ortho Slice is attached to a data set, whenever the data window is changed for this data set, the Ortho Slice 

colormap will be adjusted accordingly, independently from other Ortho Slices modules in the project. Changing 

the colormap range will not modify the other displayed objects unless the local range mode is disabled.  

If a display module doesn't show the expected intensity range, first check the colormap range and the input data 
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min-max range or the data window in the Properties Area. With Avizo Fire, the Range Calibration Editor can be 

used to adjust the data window of a data set.  

Colormap Editor - selected data and colormap 

Since Avizo 7, the display of the selected data object is updated when the colormap is modified in the Colormap 

Editor or when a new colormap is selected in the Colormap menu of the Colormap Editor. Now this also applies 

to LDA data. 

To edit the colormap of a given display module or data object, simply select it in the project view or using the 

viewer's pick tool; the corresponding Colormap and Data menu items are set in the Colormap Editor. 

If the data object shown in the Colormap Editor's Data menu has a shared colormap, all display modules attached 

to this data object are affected by the colormap change. Otherwise, the first display module that has been 

selected in the project view and is attached to the data object is affected by the colormap change. 

Surface Simplifier – new option and port for intersection test strategy  

A new option is available to choose the intersection test strategy. It supersedes the Tcl command 

setIntersectionTestStrategy.  

Generate Surface enhancements  

A new port Smoothing extent is available if the Smoothing port is set to Constrained Smoothing or Unconstrained 
Smoothing. This port allows you to control the amount of smoothing applied when generating the surface. It 
supersedes the Tcl variable SmoothKernelSize ("Generate Surface" setVar SmoothKernelSize <value>).  
 
 

FILE FORMATS ENHANCEMENTS 

New reader for .vgi and .xtekct files  

Two new readers have been added for volume description files such as created by GE Phoenix X-ray or Nikon 

Metrology CT scanners. All information items stored in header files are attached as data parameters (see Data 

Parameter Editor in Avizo User's Guide). Like other formats, when the input volume size exceeds a threshold that 

can be defined in Preferences (LDA tab), you can choose among three options: 

 Read the complete volume into memory 

 Read as external disk data, loading data on demand, for instance, for quick data preview with Ortho Slice 

display or sub-volume extraction 

 Convert to LDA (Large Data Access) optimized multi-resolution format, allowing, for instance, fast 

roaming and visualization with arbitrary slices or volume rendering, selection of region of interest and 

sub-volume extraction.  

 

OTHER ENHANCEMENTS 

Enhanced support for shadows 

Most display modules such as Ortho Slice, (Oblique) Slice, and Isosurface now support shadowing. 
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New Surface View display mode – colorfield mapping type 

Surfaces can now be textured by 3D volumes (uniform scalar fields). 

A new port Colorfield mapping type specifies how colors are mapped onto surfaces, when the optional colorfield 

data input port is used. With per-vertex mapping, the input colorfield is evaluated at the surface triangle vertices 

and colors will be interpolated in between. Colorfield mapping precision is therefore limited by the vertex density 

of the surface. With the new per-voxel mapping, textures are used to sample the input colorfield and map it 

accurately within surface triangles, potentially at the expense of higher memory consumption and lower 

performance. Note that surfaces can be simplified by using the Simplification Editor. 

Ortho Slice - new Alpha port  

This port allows specification of the minimum and maximum opacity values when Transparency is Alpha and 

Mapping Type is Histogram. 

Curve Editor enhancement: new auto-trace editing mode  

A new editing mode option auto-trace has been added to the Curve Editor. When auto-trace option is enabled, 

the Curve Editor adds a Module input port that can be attached to an Ortho Slice module. Then, the edited curve 

path is automatically fitted to the image edges of the attached Ortho Slice. Curves can be created, for instance, 

by main menu Create > Curve, or by 3D images menu Display > Curved Slice. 

Histogram module for point clusters  

It is now possible to compute and display histogram for data values attached to point clusters. 

Movie Maker new stereo recording modes  

Two new modes have been added for stereo movie generation: over/under (horizontal half screen) and stereo 

side by side half filled (vertical half-filled screen, stretching images instead of preserving aspect ratio). 

New module Copy Transformation 

This module copies the geometric transformation (i.e., translation, rotation, scale) of a reference data set to 

another data set. Setting the auto-refresh toggle causes the connected data transformation to be continuously 

updated as the reference transformation is changed. 

 

NEW AND UPDATED TUTORIALS 

New tutorial on Animation Producer 

 

In the User's Guide chapter Animations, Movies and Presentations in Avizo, the Demo Maker tutorial has been 

replaced by a new tutorial about the Animation Producer. The section Creating movie files has also been 

updated. 
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PERFORMANCE IMPROVEMENTS 

Surface rendering optimized 

Rendering performance of geometric surfaces has been dramatically improved. This impacts, in particular, the 

Surface View and Isosurface modules for shaded, outline, transparent, and shadowed rendering. 

 

The previous rendering mode can be enabled in the Preferences, Rendering panel, by checking the Legacy 

Surface Rendering option.  

The new surface rendering avoids memory consumption overhead and initial render delay tied to the previous 

Optimize graphics performance mode. At the same time, performance is higher, in particular, for large surfaces. 

Performance is even dramatically higher compared to the previous Reduce memory consumption default mode. 

 

TCL COMMANDS AND SCRIPTING - ENHANCEMENTS AND COMPATIBILITY CHANGES 

Custom script objects saved in pack&go project 

When saving a project as pack&go (project and data files), the project's script objects files are now copied along 

with data in the pack & go files directory. This makes it easier to interchange projects including custom script 

modules. However, note that additional files that are loaded or sourced from the script module are not copied to 

the pack&go files directory. Also the .rc resource file possibly associated with a script object is not part of the 

pack&go archive; hence, the saved pack & go project will not redefine object menus.  

New Tcl commands for Surface Editor  

New Tcl commands have been added for the Surface Editor: flipEdge, fixIntersection, fixDihedralAngle, 

fixTetraQuality, and prepareTetraGen. 

New Tcl commands setIconColor 

A new Tcl command setIconColor has been added for modules and data objects (HxObject). 

This command can be used at any time to change the color of the icon that represents an object instance in the 

project view and properties area. It can also be used in resource files to specify the color used for icons when 

creating objects of a given type. 

New Tcl command fileFormats  

The new Tcl command fileFormats returns the list of all file formats used by Avizo. 

Changes affecting scripts  compatibility  

Since the ports Data Window of modules such as Ortho Slices are superseded by colormap ports, existing script 

modules using such ports may cause Tcl errors. These scripts should be modified so that Data Window ports (Tcl 

linearRange or range, HxPortRangeSlider) are replaced by colormap ports. The affected modules are: 

HxBumpSlice, HxCurvedSlice, HxViewCursor, HxCylinderSlice, HxMultiSlice, HxFenceSlice, HxObliqueSlice, 
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HxOrthoSlice, HxDspThreshold, HxObliqueSliceLDM, HxOrthoSliceLDM, HxSeismicSlice, HxFreeSlice, HxInline, 

HxCrossline, and HxTimeSline. 

Note that, when loading .hx projects script files, the linearRange ports are automatically replaced by equivalent 

Colormap ports (set with grayscale colormap and local range mode). However, this cannot apply to script 

modules. 
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AVIZO FIRE EDITION -ENHANCEMENTS AND NEW FEATURES 

See also above in this document the improvements and new features common to all Avizo Editions. 

NEW FEATURES 

New module Ruled Surface  

This new module builds a surface from two input curves that are joined together by a set of triangles. The input 

curves can be either Line Set or B-Spline data. The resulting surface is a ruled surface. Ruled Surface is available in 

the menu Compute. Volume data can be mapped on surfaces (see the Surface new colorfield mapping type 

above) and a new Extract Image module is available to create flattened images of ruled surfaces with mapped 

colorfield. 

New module Curve Morphing 

This new module interpolates two input curves of type Line Set or B-Spline. Curve Morphing is available in menu 

Compute. This can be used, for instance, in combination with Curved Slice or Ruled Surface modules for 

animating a surface with a mapped colorfield.  

New module Extract Image for ruled surfaces  

This new module can attach to a Surface View module displaying a surface that has been generated by the 

module Ruled Surface, with per-voxel colorfield mapping. Extract Image can then create a flattened 2D image of 

the input surface with mapped colorfield.  

New module Filter Sandbox 

 
This new convenience module can be used to preview the effect of an image filter on a part of an image, and 
then apply it on the entire image. It is available in the image object's menu Image Filters. The filter can be: 
bilateral, box filter, Gaussian, median, recursive, delineate, anisotropic diffusion, non-local means, and unsharp-
masking. Filters can be applied in 2D or in 3D (anisotropic diffusion is 3D only, and non-local means may be 
preferred in 2D mode for performance). In 3D mode, for preview, the filter is applied to a slab on the region-of-
interest. The effect of a filter on the thresholding segmentation can be visualized. You can display means, 
standard deviations and histograms before and after applying the filter. 
See also the other filters available in Avizo Fire. 
Advanced users that are familiar with Tcl scripting can extend this module for more filters or a specific purpose.   

New Image Registration Wizard 

This convenience module can be used for registration of image data sets. It can set up Ortho Views display, 

subsample and extract subvolumes from input data (e.g., for partially overlapping images), and handle pre-

alignment and optimized registration. 

 

NEW TUTORIALS AND EXAMPLES 

New tutorials on registration, alignment , and data fusion 

file:///C:/hxsurface/HxSurface.html%23A1
file:///C:/hxlines/HxLineSet.html%23A1
file:///C:/hxlines/HxBSpline.html%23A1
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A new set of tutorials has been added to the Avizo Fire user's guide (see section Registration, Alignment, and 
Data Fusion). The following tutorials and examples provide the basics for typical registration tasks: 
 

 Getting started with spatial data registration using the Transform Editor 

 Data fusion, comparing and merging data 

 Registration with landmarks, warping surfaces and images 

 Registration of 3D image data sets 

 Registration of 2D image and 3D image data sets 

 Alignment and correction of 2D images stacks - FIB/SEM and other cross sections 

 Registration of 3D surfaces 

 Registration of 3D image and surface, nominal-actual analysis  

 

OTHER ENHANCEMENTS 

Improved FIB Stack Wizard 

The FIB Stack Wizard (in image object's menu Compute) has been improved to simplify going through steps and 

to support an optional input mask defining the region to be considered during automatic alignment. Note that 

the FIB Stack Wizard keeps intermediate copies of data hidden, to facilitate backtracking. For very large data and 

depending on available memory, you can show intermediate data (use menu Project > Show Object) and remove 

unneeded data. 

New getMeasure Tcl command for measure callouts 

 
This new Tcl command is now available for measure objects, to retrieve the current value of the measure as 
displayed in the callout beside the title. Use "Measurement" GUI getItemLabels to retrieve the list of measure 
objects. 
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AVIZO GREEN EDITION – ENHANCEMENTS AND NEW FEATURES   

See also above in this document the improvements and new features common to all Avizo Editions. 

 New module Embossed Surface  

This new module displays an embossed slice (bump mapping) on an unstructured surface mesh. 

 New module Bar Chart Surface  

This new module displays a bar chart on an unstructured surface mesh. 

 Earth module enhancements  

 
The Earth display module has been enhanced:  

 New port Texture Brightness 

 New port Orography 

 New port Orography Quality 
 
 

AVIZO XSCREEN - IMPROVEMENTS   

Avizo XScreen enhancements 

Several improvements have been made in Avizo XScreen: 

 Volume Rendering has been improved, in particular, for cluster configurations 

 Molecule View legend and color editor work with XScreen cluster configurations  

 Mouse cursor can now stay hidden on cluster slaves. 

 

AVIZO XPAND – ENHANCEMENTS AND COMPATIBILITY CHANGES 

Changed port constructors 

WARNING: The method signature for port constructors was changed for localization support.  

For instance, port initialization looked like this in previous versions: 

portRange(this,"range",2) // two float fields 

Now, you need to specify the port's label via Qt method as follows: 

portRange(this,"range",QApplication::translate("MyModule", "Range"),2)  

Simplified Visual Studio requirements - OpenMP disabled in debug mode 

The Avizo XPand debug libraries are no longer dependent on OpenMP, the reason that Avizo XPand previously 

required use of Visual Studio Professional Edition. You can now use Visual Studio 2008 Standard Edition or Visual 

Studio 2008 Express with Avizo XPand.  
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Announcement for next major release: End of support for Microsoft Visual Studio 2008  

After Avizo 7.1, the next major release of Avizo will no longer support Microsoft Visual Studio 2005/2008 (VC++ 
8/9).  
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LIST OF SOLVED ISSUES 

 

Issue# Title Release notes 

792 Custom script objects should be saved when 
saving projects as pack&go 

When saving a project as pack&go (project and data files), the 
project's script objects files are now copied along with data in 
the pack & go files directory. This makes it easier to interchange 
projects including custom script modules. Note however that 
additional files possibly loaded or sourced from the script 
module are not copied to the pack&go files directory. Also the 
.rc resource file possibly associated with a script object is not 
part of the pack&go archive, hence the saved pack & go project 
will not redefine object menus. 

795 Snapshot doesn't support multi-viewers 
display 

An issue has been fixed on Mac OS. 

1003 Segmentation Editor doesn't remember Data 
Window 

The segmentation editor allows changing the displayed 
grayscale range from the initial 'data window'. Such change was 
lost when closing the segmentation editor. The segmentation 
editor's grayscale range associated with a data set is now 
persistent during an Avizo session. However this is independent 
from the actual initial data window attached to the data set.  
For making a permanent change to the data window for reuse 
after restarting Avizo, you can use the Range Calibration Editor 
and save the data with modified range. 

1113 Shadowing not supported with display 
modules such as Ortho Slice, Oblique Slice, 
Isosurface 

A number of display modules were not rendered consistently 
when shadowing was enabled. Most display modules now 
support shadowing. 

1329 Incorrect lighting and color display when 
headlight and shadowing are enabled 

An issue occurring on Linux was fixed. 

2060 Avizo requirements for Visual Studio due to 
OpenMP support 

Avizo XPand packages are no longer dependent on OpenMP by 
default, which required using Visual Studio Professional Edition 
with Avizo XPand. You can now use Visual Studio 2008 Standard 
Edition or Visual Studio 2008 Express with Avizo XPand. 

2139 TIFF conversion to LDM problem In some cases on Linux, TIFF files could not be converted to 
LDM. This is now fixed. 

2199 OrthoSlice data window doesn't support left 
value bigger than right value 

The Data Window range slider port, that was available in 
modules such as Ortho Slice, is now superseded by a Colormap 
port. Colormap ports support reversed ranges (left value bigger 
than right value) and have been extended to support the same 
features as the former Data Window range slider port: 
histogram displayed in background (Avizo Fire edition) and 
subrange buttons. When dragging a subrange button, the 
colormap appears reversed once crossing the other subrange 
button. See "Extended Colormap port" in release notes for 
more details.  

2271 The desktop background can be seen 
through the segmentation editor viewers 
when enabling the composite option of the X 
server 

This issue occurring on Linux was fixed. 

2275 Tcl command addMolecule crashed in some 
cases 

This issue was fixed. 

2279 Transform Editor abnormally slow with 
surfaces 

Interactions with the Transform Editor of a surface data set are 
now faster. 

2288 Molecule View legend window displayed on 
cluster slaves could not be closed in VR 

Molecule View legend window is now only displayed on 
XScreen master node. 
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environment 

2289 The color editor of Molecule View doesn't 
update atoms colors on cluster slaves 
(XScreen) 

This issue was fixed. 

2311 Changing module colors with "module -
color" in .rc. files doesn't work 

Since "module -color" could not apply to script objects, a new 
Tcl command 'setIconColor' has been added for modules and 
data objects (HxObject). 
This command can be used at any time to change the color of 
the icon that represents an object instance in the project view 
and properties area. 
It can be used in resource files to define the icon color of 
specific object type, so once it is created it has the defined icon 
color. 

2312 Tcl script module port commands 
documentation 

Documentation has been completed (see Alphabetic index of 
Ports). 

2704 Surface menus changes for consistency The modules "Apply Deformation" and "Vertex Morph" moved 
from the "Surface Transforms" menu to the "Geometry 
Transforms" menu. 

2767 Cannot reload project loading files with [] in 
path 

File paths containing square brackets are now saved properly in 
project scripts (using \ to prevent unwanted Tcl evaluation). 

2989 Option "Show port interconnection in 
Project Graph View" (Preferences/Layout) is 
always checked 

Fixed. 

3057 Convert Image Type doesn't update 
resolution of output when resolution of 
input has changed 

Fixed. 

3124 Console completion issues Automatic completion when pressing TAB key in the console 
has been improved. 

3129 Changing the colormap in the Colormap 
Editor doesn't affect the representation 
from which the editor has been opened 

Since Avizo 7, visualization of selected data object is updated 
when modifying colormap in the Colormap Editor or selecting a 
new colormap in the Colormap menu of the Colormap Editor. 
This now also applies to LDA data sets. See release notes 
section "Colormap editor" for details. 

3190 The segmentation editor could crash in some 
cases when changing slice after selecting the 
Pick&Move tool 

Fixed 

3192 Menu Save or hotkey Ctrl+S on new data 
should trigger Save As 

Fixed. 

3240 Measurement module fails when user clicks 
on volume rendering 

Measure tools can now work with Volume Rendering and 
Isosurface Rendering display modules. 

3252 Arithmetic module is not safe if bad 
expression is entered and may crash in some 
cases 

Fixed handling of illegal expressions. Note that warnings about 
incorrect expressions are issued in Avizo console. 

3254 Watershed tool in segmentation editor 
doesn't work directly with unsigned 16-bit or 
32-bit image. 

This issue has been fixed. Gradient is computed from data 
converted to signed 16-bit. 

3294 Crash with reading DICOM file Some DICOM files using non-uniform slice location (irregular 
spacing) were not supported. They are now properly imported 
as scalar fields with stacked coordinates. 

3320 Projection update on unstructured mesh 
display does not work properly 

Fixed. Display is now correct when changing the projection type 
on an unstructured mesh. 

3409 Tcl command "dso unloadPackage" has no 
effect 

unloadPackage is now fixed.  
unloadPackage <package> unloads (if possible) the specified 
dynamic library. This allows replacing a dynamic library when 
developing a custom module without restarting Avizo. The 
command now also displays a diagnostic message when given 



 

15 
Avizo 7.1 release notes – VSG© 2012 

library was not loaded or if library cannot be unloaded because 
it is currently in use. 

3440 Calculus MATLAB cannot load MATLAB 
2010/2011 dlls on RHEL5 

In order to use the Calculus MATLAB module, that establishes a 
connection to MATLAB (The MathWorks, Inc.), some 
installation steps must be followed. The LD_LIBRARY_PATH 
environment variable should be set to 
MATLAB_INSTALLATION_PATH/bin/glnx86 on Linux 32-bit and 
MATLAB_INSTALLATION_PATH/bin/glnxa64 on Linux 64-bit. The 
PATH environment variable should be also set to 
MATLAB_INSTALLATION_PATH/bin. 
If after doing this you still encounter troubles starting Calculus 
MATLAB, it might be because the GNU Standard C++ Library 
(libstdc++) installed on your platform is older than the one 
required by MATLAB. You can check MATLAB's embedded 
libstdc++ version in 
MATLAB_INSTALLATION_PATH/sys/os/glnx86 on Linux 32-bit 
and MATLAB_INSTALLATION_PATH/sys/os/glnxa64 on Linux 64-
bit. If needed, add this path to LD_LIBRARY_PATH. . 

3480 Resample module wants to allocate a huge 
amount of memory 

An issue was fixed for abnormal memory consumption in 
Resample module. 

3511 Creating new lights has no effect on Volume 
Rendering 

This issue has been fixed. It is now possible to change the 
lighting direction for volume rendering by creating a light from 
the menu View > Lights. Make sure to disable the headlight in 
menu View > Light, or viewer's popup menu. Only the first 
active light object with directional light type is considered for 
volume rendering. 

3547 Crash when removing a MultiChannelField 
connected to "Volume Rendering" in the 
project 

This issue was fixed. 

3564 Crash when loading in memory or converting 
to LDA a 64-bits raw image 48000x48000 

An issue when reading large 2D slices has been fixed. Note 
however that, when reading an image file or an image stack, 
the current Avizo release still requires at least twice the 
memory occupied by a single slice. 

3566 The Tcl command getVoxelSize doesn't use 
the current display unit 

The returned voxel size is now converted from working to 
display coordinates unit if this is enabled in the Preferences 
(menu Edit > Preferences, Units tab). Please see User's Guide 
for more detail about Units in Avizo. 

3610 The directory port (Tcl newPortDirectory) 
doesn't return folder names when selecting 
several folders in the browser 

All selected folders are now available in the port (default label 
"Folder Selection"). 

3614 Crash when enabling the new Measurement 
tool in VirtualGL environment 

Solved. This bug was due to VirtualGL and has been fixed with 
the latest version of VirtualGL. 

3629 Avizo Green cannot load netCDF curvilinear 
dataset with coordinates in some cases 

Fixed. The netCDF reader was extended to support some 
Coordinate Attribute Convention. 

3644 Point Cluster View performance issue Rendering performance for Point Cluster View was dramatically 
improved, in particular for large number of points. 

3757 Avizo cannot import .im6 files using signed 
16-bit (short integer) 

.im6 signed 16-bit files are now supported, loaded as signed 16-
bit grayscale scalar fields. 

3774 Shading correction and FIB Stack Wizard 
script not working 

A regression in Avizo 7.01 has been fixed. In addition, the FIB 
Stack Wizard has been further improved and a tutorial is now 
available in the Avizo Fire User's Guide. 

3776 When closing Avizo with Align Slices in edit 
mode, viewer decoration are removed at 
next start 

In some cases, the viewer decorations could be disabled at 
Avizo restart. This is now fixed. 

3795 No pack&go option for the global command 
saveProjectAs 

The packAndGo option has been added to saveProjectAs Tcl 
command 
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3835 DICOM import failure on PC with 'Traditional 
Chinese (Taiwan)' in regional settings 

This regression has been fixed. 

3848 Crash in applying Arithmetic on two image An invalid expression caused the crash. Syntax such as {A}-{B} is 
now accepted, and non-existent variables no longer cause a 
crash. 

3856 Remesh Surface seems never ending Fixed. In some case Remesh Surface could take an abnormally 
long time to finish. 

3869 Menu Project > Show Object doesn't work in 
some cases 

Fixed. The Project > Show Object menu did not expand before 
using the pop-up menu once in Project View. 

3870 Precision with Measurement tool. In some cases measurement sampling was incorrect. This has 
been fixed. 

3888 Some CATIA V5 files could not be read with 
Avizo XReader option 

Solved. The files were saved from an incomplete CATIA session 
(still opened in Sketcher workbench). 

3891 Erroneous error message in the console 
when loading some .am file 

Fixed. An .am file with incomplete header was not properly 
interpreted and considered as Raw as External Data. 

3892 An Avizo 6.3 project or .am file cannot be 
correctly loaded in Avizo 7 

Fixed. An .am file with incomplete header was not properly 
interpreted. 

3893 Segmentation Editor - Remove Islands 
corrupts label field 

Since Avizo 7.0.1 the Remove Islands tool did not work correctly 
in 3D volume mode without the option that allows merging 
connected component. This regression has been fixed. 

3899 XLab Hydro should display dialog boxes at 
the beginning or end of the computation. 

When calculating multiple directions at once, warning dialog 
boxes are now displayed only once at beginning or end of the 
full run. 

3902 Missing time per iteration for XLab Hydro 
compute modules. 

Time per iteration is now displayed in the console, for each 
direction possibly calculated. 

3943 Surface View on large surface crashed The display driver was interrupted due to initial rendering 
exceeding the Windows Time-Out limit. This issue is solved 
since surface rendering with Surface View has been 
dramatically improved for performance. See "Surface rendering 
optimized" section in release notes. 

4017 The header size in the Raw Data Parameters 
dialog is limited to signed 32-bit int 

Fixed. 64-bit integers are now supported for header offset on 
64-bit machines. 

4048 Data Window port (linearRange/range) no 
longer available in Avizo 7.1 

The Data Window range slider ports, which were available in 
modules such as Ortho Slice, are now superseded by Colormap 
ports. See release notes section "Extended Colormap port" for 
more details. 
While .hx project files compatibility is preserved, the .scro script 
modules may need to be modified to replace the Data Window 
ports by colormap ports. See release notes section "Changes 
affecting scripts compatibility" for more details. 

4145 Landmark file extension incorrect Incorrect file naming for Landmark files has been fixed. 

4150 Anisotropic Diffusion filter crash on large 
data 

This has been fixed. 

4182 Abnormal Closing filter allocation failure This issue has been fixed. 

4227 Need for side by side stereo movies with 
stretched images instead of preserving 
aspect ratio. 

A new stereo mode was added to Movie Maker "stereo side by 
side half filled". 

4236 Mouse cursor appears on slave nodes when 
active stereo is enabled 

In some case, hidden cursor was unexpectedly restored when 
switching the stereo mode. This is now fixed. 

 


